Autodesk.Revit Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit
Visual Basic (Declaration)
Namespace Autodesk.Revit
Visual C++
namespace Autodesk.Revit

Classes

 | Class | Description
Public class | ACADExportOptions | Export options specific to AutoCAD file formats.
Public class | ACADImportOptions | Import options specific to AutoCAD file formats.
Public class | APIObject | Supports all objects in the Autodesk Revit API hierarchy.
Public class | Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class | CADExportOptions | Generic CAD Export options.
Public class | CADImportOptions | Generic CAD Import options.
Public class | Categories | The Categories object is a map that contains all the Category objects within the Document.
Public class | Category | Represents the category or sub category to which an element belongs.
Public class | CategoryFilter | Represents a filter to filter elements with specific category.
Public class | CategoryNameMap | A map that contains a mapping of category name to its category object.
Public class | CategoryNameMapIterator | An iterator to a category name map.
Public class | CategorySet | A set that can contains Category objects.
Public class | CategorySetIterator | An iterator to a category set.
Public class | Color | Represents a color in Autodesk Revit.
Public class | Construction | Construction definition for Project Information.
Public class | ControlledApplication | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class | Document | An object that represents an open Autodesk Revit project.
Public class | DocumentSet | A set that can contain any documents.
Public class | DocumentSetIterator | An iterator to a set of documents.
Public class | DWF2DExportOptions | DWF2D Export options.
Public class | DWF3DExportOptions | DWF3D Export options.
Public class | DWFX2DExportOptions | DWFX2D Export options.
Public class | DWFX3DExportOptions | DWFX3D Export options.
Public class | DWGExportOptions | DWG Export options.
Public class | DWGImportOptions | Import options specific to AutoCAD's DWG file formats.
Public class | Element | Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.
Public class | ElementArray | An array that contains element objects.
Public class | ElementArrayIterator | An iterator to an element array.
Public class | ElementIdSet | A set that can contain Element Ids.
Public class | ElementIdSetIterator | An iterator to a element id set.
Public class | ElementIterator | An iterator object that enable access to every element within the Autodesk Revit project.
Public class | ElementSet | A set that contains element objects.
Public class | ElementSetIterator | An iterator to an element set.
Public class | ExternalApplicationArray | An array that can contain any number of IExternalApplication objects.
Public class | ExternalApplicationArrayIterator | An iterator to an array of IExternalApplication objects..
Public class | ExternalCommandData | A class contains reference to Application and View which are needed by external command.
Public class | FamilyFilter | A filter object that used to filter family elements which satisfy specified criterion, filter elements via specifying family name.
Public class | FBXExportOptions | 3D-Studio Max (FBX) Export options.
Public class | FillPatternSet | A set that contains FillPatterns.
Public class | FillPatternSetIterator | An iterator to a FillPattern set.
Public class | Filter | Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.
Public class | FilterCriterion | An object that defines the criteria as the filter for retrieving certain needed elements.
Public class | FormatOptions | Contains the Unit information of current user selection of Unit within the project.
Public class | GBXMLExportOptions | Gren-Building XML Export options.
Public class | GenericImportOptions | Generic Import options.
Public class | ImageImportOptions | Import options specific image (bitmap) formats.
Public class | InstanceUsageFilter | Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.
Public class | Leader | An object that represents a Leader within the Autodesk Revit project.
Public class | LeaderArray | An array that can contain any number of leaders.
Public class | LeaderArrayIterator | An iterator to an array of leaders.
Public class | LinePatternSet | A set that can contain any number of line patterns.
Public class | LinePatternSetIterator | An iterator to a set.
Public class | Location | Provides location functionality for all elements.
Public class | LocationCurve | Provides location functionality for all elements that are based upon a curve.
Public class | LocationPoint | Provides location functionality for all elements that have a single insertion point.
Public class | LogicAndFilter | The LogicAndFilter is used to implement Logic-AND operation of Filters.
Public class | LogicNotFilter | The LogicNotFilter is used to implement Logic-NOT operation of Filters.
Public class | LogicOrFilter | The LogicOrFilter is used to implement Logic-OR operation of Filters.
Public class | MaterialFilter | Represents a filter to filter elements with the given material.
Public class | Materials | A set of materials that provides access to the materials in an Autodesk Revit project.
Public class | MaterialSet | An set that contains materials.
Public class | MaterialSetIterator | An iterator to a material set.
Public class | MenuItem | Basic unit to build custermized menus.
Public class | MEPSpaceConstruction | Construction definition for Space.
Public class | ObjectFactory | For Internal Use Only.
Public class | PaperSize | An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
Public class | PaperSizeSet | A set that can contain any number of paper size objects.
Public class | PaperSizeSetIterator | An iterator to a set of paper size objects.
Public class | PaperSource | An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
Public class | PaperSourceSet | A set that can contain any number of paper source objects.
Public class | PaperSourceSetIterator | An iterator to a set of paper source objects.
Public class | Parameter | The parameter object contains the value data assigned to that parameter.
Public class | ParameterFilter | To filter elements with specific parameter criterion.
Public class | ParameterMap | A map that can contain a mapping of a parameter name (a String) to a parameter.
Public class | ParameterMapIterator | An iterator to a map relating a parameter name (the key, a String) to a parameter.
Public class | ParameterSet | A set that contains parameters.
Public class | ParameterSetIterator | An iterator to a parameter set.
Public class | ParameterStorage | An object that contains details for the value of a parameter. This class is mainly used with the class FilterCriterion to retrieve Elements according to certain criteria.
Public class | PlanCircuit | An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Public class | PlanCircuitSet | A set that can contain any number of plan circuit objects.
Public class | PlanCircuitSetIterator | An iterator to a set of plan circuit objects.
Public class | PlanTopology | An object that represents a Plan Topology within the Autodesk Revit project.
Public class | PlanTopologySet | A set that can contain any number of plan topology objects.
Public class | PlanTopologySetIterator | An iterator to a set of plan topology objects.
Public class | PostedError | A class that holds information about a posted error.
Public class | PostedErrorArray | An array that can contain any number of posted errors.
Public class | PostedErrorArrayIterator | A class that holds an array of posted errors.
Public class | PrintManager | Represents the Print information in Print Dialog(File->Print) within Autodesk Revit.
Public class | PrintParameters | An object that contains settings used for printing the document.
Public class | PrintSetup | Represents the Print Setup (File->Print Setup...) within Autodesk Revit.
Public class | Selection | Contains the current user selection of elements within the project.
Public class | SelElementSet | This class contains the current user selection of elements within the project.
Public class | Settings | The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Public class | StructuralTypeFilter | A Filter object that represents StructuralType, used to retrieve family instances whose structural type is specified structural type.
Public class | SuspendUpdating | Temporarily delay Revit's automatic updating and consistency operations.
Public class | Symbol | Base class for all Symbols and Types within Autodesk Revit.
Public class | SymbolFilter | A filter object that used to filter symbol elements which satisfy specified criterion, filter elements by specifying symbol name.
Public class | Toolbar | The Toolbar object represents a tool bar, which should contains an array of ToolbarItems.
Public class | ToolbarArray | An array that can contain any number of toolbars.
Public class | ToolbarArrayIterator | An iterator to an array of toolbars.
Public class | ToolbarItem | The ToolbarItem object represents a tool bar item, which should contain the information for creating one tool bar item.
Public class | ToolbarItemArray | An array that can contain any number of toolbar items.
Public class | ToolbarItemArrayIterator | An iterator to an array of toolbar items.
Public class | TrussMemberInfo | Provides access to the information of a truss member in Autodesk Revit.
Public class | TypeFilter | Represents a filter to filter elements with the given type.
Public class | ViewSheetSetting | Represents the View/Sheet Set (File->Print) within Autodesk Revit.
Public class | VolumeCalculationOptions | This class provides access to options related to room volume and area computations.
Public class | VolumeCalculationSetting | This class provides access to settings related to room volume and area computations.
Public class | WallUsageFilter | A Filter object that represents Structural WallUsage, used to retrieve Wall elements whose structural WallUsage is specified WallUsage type.

Structures

 | Structure | Description
Public structure | ElementId | The ElementId object is used as a unique identification for an element within a single project.

Interfaces

 | Interface | Description
Public interface | IExtension | An interface that supports the additonal operation for Extension Status
Public interface | IExternalApplication | An interface that when support provides additional applications within Autodesk Revit implemented by external applications.
Public interface | IExternalCommand | An interface that when support provides additional commands within Autodesk Revit implemented by external applications.

Enumerations

 | Enumeration | Description
Public enumeration | BuiltInCategory | A list of all the built in categories within Revit.
Public enumeration | IExternalApplication..::Result | Informs Autodesk Revit of the status of your application after execution.
Public enumeration | IExternalCommand..::Result | Informs Autodesk Revit of the status of your command after execution.
Public enumeration | JoinType | The type of join at the end of an element. The join type affects only geometric treatment, i.e. cleaning of the end, and not join behavior.
Public enumeration | MenuItem..::MenuType | Type of menu to be created.
Public enumeration | ToolbarItem..::ToolbarItemType | An enumerate type listing all the toolbar item styles.

Send comments about this topic to Autodesk.


ACADExportOptions Class
See Also Members
CollapseAll image DropDown image

Export options specific to AutoCAD file formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7AE51DE2-276A-4a45-A751-D58A923B684D")]
public abstract class ACADExportOptions : CADExportOptions
Visual Basic (Declaration)
<GuidAttribute("7AE51DE2-276A-4a45-A751-D58A923B684D")> _
Public MustInherit Class ACADExportOptions _
    Inherits CADExportOptions
Visual C++
[GuidAttribute(L"7AE51DE2-276A-4a45-A751-D58A923B684D")]
public ref class ACADExportOptions abstract : public CADExportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::ACADExportOptions
Autodesk.Revit..::DWGExportOptions

See Also

ACADExportOptions Members
Autodesk.Revit Namespace


ACADExportOptions Members
See Also Methods Constructors Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class ACADExportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADExportOptions
Visual C++
public ref class ACADExportOptions abstract

The type exposes the following members.

Protected Constructors

 | Name | Description
Protected method | ACADExportOptionsACADExportOptionsNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportOfSolids | Mode of exporting solids in 3D views.
Public field | FileVersion | AutoCAD file version.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
Public field | LineScaling | LineType scaling mode.
Public field | PropOverrides | How to export overriden object styles.
Public field | SharedCoords | Whether to use shared coordinate system or a project's. internal origin.
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

ACADExportOptions
Autodesk.Revit Namespace


ACADExportOptions Constructor
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected ACADExportOptions()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ACADExportOptions ()

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ACADExportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class ACADExportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADExportOptions
Visual C++
public ref class ACADExportOptions abstract

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportOfSolids | Mode of exporting solids in 3D views.
Public field | FileVersion | AutoCAD file version.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
Public field | LineScaling | LineType scaling mode.
Public field | PropOverrides | How to export overriden object styles.
Public field | SharedCoords | Whether to use shared coordinate system or a project's. internal origin.
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

ACADExportOptions
Autodesk.Revit Namespace


ExportOfSolids Field

ACADExportOptions..::ExportOfSolids Field
CollapseAll image DropDown image

Mode of exporting solids in 3D views.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SolidGeometry ExportOfSolids
Visual Basic (Declaration)
Public ExportOfSolids As SolidGeometry
Visual C++
public:
SolidGeometry ExportOfSolids

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


FileVersion Field

ACADExportOptions..::FileVersion Field
CollapseAll image DropDown image

AutoCAD file version.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ACADVersion FileVersion
Visual Basic (Declaration)
Public FileVersion As ACADVersion
Visual C++
public:
ACADVersion FileVersion

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


LayerMapping Field

ACADExportOptions..::LayerMapping Field
CollapseAll image DropDown image

Name of a layer settings standard or filename (with custom layer settings).

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string LayerMapping
Visual Basic (Declaration)
Public LayerMapping As String
Visual C++
public:
String^ LayerMapping

Remarks

Valid standards are: AIA, CP83, BS1192, and ISO13567.

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


LineScaling Field

ACADExportOptions..::LineScaling Field
CollapseAll image DropDown image

LineType scaling mode.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineScaling LineScaling
Visual Basic (Declaration)
Public LineScaling As LineScaling
Visual C++
public:
LineScaling LineScaling

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


PropOverrides Field

ACADExportOptions..::PropOverrides Field
CollapseAll image DropDown image

How to export overriden object styles.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PropOverrideMode PropOverrides
Visual Basic (Declaration)
Public PropOverrides As PropOverrideMode
Visual C++
public:
PropOverrideMode PropOverrides

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


SharedCoords Field

ACADExportOptions..::SharedCoords Field
CollapseAll image DropDown image

Whether to use shared coordinate system or a project's. internal origin.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SharedCoords
Visual Basic (Declaration)
Public SharedCoords As Boolean
Visual C++
public:
bool SharedCoords

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ACADImportOptions Class
See Also Members
CollapseAll image DropDown image

Import options specific to AutoCAD file formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E3D79A48-48B6-40a0-B825-B5424D4E5897")]
public abstract class ACADImportOptions : CADImportOptions
Visual Basic (Declaration)
<GuidAttribute("E3D79A48-48B6-40a0-B825-B5424D4E5897")> _
Public MustInherit Class ACADImportOptions _
    Inherits CADImportOptions
Visual C++
[GuidAttribute(L"E3D79A48-48B6-40a0-B825-B5424D4E5897")]
public ref class ACADImportOptions abstract : public CADImportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::GenericImportOptions
Autodesk.Revit..::CADImportOptions
Autodesk.Revit..::ACADImportOptions
Autodesk.Revit..::DWGImportOptions

See Also

ACADImportOptions Members
Autodesk.Revit Namespace


ACADImportOptions Members
See Also Methods Constructors Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class ACADImportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADImportOptions
Visual C++
public ref class ACADImportOptions abstract

The type exposes the following members.

Protected Constructors

 | Name | Description
Protected method | ACADImportOptionsACADImportOptionsNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
Public field | CustomScale | Scaling the import. (Inherited from CADImportOptions.)
Public field | LayerSelection | The layers collection for import.
Public field | LineWeights | A Byte array of line weights for the DWG/DXF Color number.
Public field | OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Public field | Placement | Where to place the import. (Inherited from CADImportOptions.)
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Public field | Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
Public field | VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions
Autodesk.Revit Namespace


ACADImportOptions Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected ACADImportOptions()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ACADImportOptions ()

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


ACADImportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class ACADImportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADImportOptions
Visual C++
public ref class ACADImportOptions abstract

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
Public field | CustomScale | Scaling the import. (Inherited from CADImportOptions.)
Public field | LayerSelection | The layers collection for import.
Public field | LineWeights | A Byte array of line weights for the DWG/DXF Color number.
Public field | OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Public field | Placement | Where to place the import. (Inherited from CADImportOptions.)
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Public field | Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
Public field | VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions
Autodesk.Revit Namespace


LayerSelection Field

ACADImportOptions..::LayerSelection Field
CollapseAll image DropDown image

The layers collection for import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringCollection LayerSelection
Visual Basic (Declaration)
Public LayerSelection As StringCollection
Visual C++
public:
StringCollection^ LayerSelection

Remarks

Specify the names of layers and levels to import.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


LineWeights Field

ACADImportOptions..::LineWeights Field
CollapseAll image DropDown image

A Byte array of line weights for the DWG/DXF Color number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public byte[] LineWeights
Visual Basic (Declaration)
Public LineWeights As Byte()
Visual C++
public:
array<unsigned char>^ LineWeights

Remarks

Import pen numbers from a DWG or DXF file and map them to a line weight.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


VisibleLayersOnly Field

ACADImportOptions..::VisibleLayersOnly Field
CollapseAll image DropDown image

Only import the visible layers.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool VisibleLayersOnly
Visual Basic (Declaration)
Public VisibleLayersOnly As Boolean
Visual C++
public:
bool VisibleLayersOnly

Remarks

If this option is set to true, only visible layers are imported.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


APIObject Class
See Also Members
CollapseAll image DropDown image

Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("959E7C83-A739-42b1-BDAD-42EDC4619C62")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class APIObject : IDisposable
Visual Basic (Declaration)
<GuidAttribute("959E7C83-A739-42b1-BDAD-42EDC4619C62")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class APIObject _
    Implements IDisposable
Visual C++
[GuidAttribute(L"959E7C83-A739-42b1-BDAD-42EDC4619C62")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementSet
Autodesk.Revit..::ElementSetIterator
Autodesk.Revit..::Document
Autodesk.Revit..::Element
Autodesk.Revit..::ElementIdSet
Autodesk.Revit..::ElementIdSetIterator
Autodesk.Revit..::Color
Autodesk.Revit..::ToolbarArray
Autodesk.Revit..::ToolbarArrayIterator
Autodesk.Revit..::Application
Autodesk.Revit..::ExternalCommandData
Autodesk.Revit..::PostedError
Autodesk.Revit..::PostedErrorArray
Autodesk.Revit..::PostedErrorArrayIterator
Autodesk.Revit..::Selection
Autodesk.Revit..::Settings
Autodesk.Revit..::CategoryNameMap
Autodesk.Revit..::CategoryNameMapIterator
Autodesk.Revit..::Category
Autodesk.Revit..::PlanTopology
Autodesk.Revit..::PlanCircuit
Autodesk.Revit..::PrintParameters
Autodesk.Revit..::PrintSetup
Autodesk.Revit..::PrintManager
Autodesk.Revit..::DocumentSet
Autodesk.Revit..::DocumentSetIterator
Autodesk.Revit..::MenuItem
Autodesk.Revit..::ToolbarItem
Autodesk.Revit..::Toolbar
Autodesk.Revit..::ExternalApplicationArray
Autodesk.Revit..::ExternalApplicationArrayIterator
Autodesk.Revit..::CategorySet
Autodesk.Revit..::CategorySetIterator
Autodesk.Revit..::ElementArray
Autodesk.Revit..::ElementArrayIterator
Autodesk.Revit..::FillPatternSet
Autodesk.Revit..::FillPatternSetIterator
Autodesk.Revit..::MaterialSet
Autodesk.Revit..::MaterialSetIterator
Autodesk.Revit..::LinePatternSet
Autodesk.Revit..::LinePatternSetIterator
Autodesk.Revit..::Filter
Autodesk.Revit..::ElementIterator
Autodesk.Revit..::PlanTopologySet
Autodesk.Revit..::PlanTopologySetIterator
Autodesk.Revit..::FilterCriterion
Autodesk.Revit..::Location
Autodesk.Revit..::PlanCircuitSet
Autodesk.Revit..::PlanCircuitSetIterator
Autodesk.Revit..::SuspendUpdating
Autodesk.Revit..::FormatOptions
Autodesk.Revit..::Leader
Autodesk.Revit..::LeaderArray
Autodesk.Revit..::LeaderArrayIterator
Autodesk.Revit..::PaperSize
Autodesk.Revit..::PaperSizeSet
Autodesk.Revit..::PaperSizeSetIterator
Autodesk.Revit..::PaperSource
Autodesk.Revit..::PaperSourceSet
Autodesk.Revit..::PaperSourceSetIterator
Autodesk.Revit..::ViewSheetSetting
Autodesk.Revit..::ToolbarItemArray
Autodesk.Revit..::ToolbarItemArrayIterator
Autodesk.Revit..::Parameter
Autodesk.Revit..::ParameterMap
Autodesk.Revit..::ParameterMapIterator
Autodesk.Revit..::ParameterSet
Autodesk.Revit..::ParameterSetIterator
Autodesk.Revit..::ParameterStorage
Autodesk.Revit.Events..::DialogBoxData
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Reference
Autodesk.Revit.Geometry..::Plane
Autodesk.Revit.Geometry..::CurveArray
Autodesk.Revit.Geometry..::CurveArrayIterator
Autodesk.Revit.Geometry..::Options
Autodesk.Revit.Geometry..::XYZArray
Autodesk.Revit.Geometry..::XYZArrayIterator
Autodesk.Revit.Geometry..::DoubleArray
Autodesk.Revit.Geometry..::DoubleArrayIterator
Autodesk.Revit.Geometry..::BoundingBoxXYZ
Autodesk.Revit.Geometry..::ReferenceArray
Autodesk.Revit.Geometry..::ReferenceArrayIterator
Autodesk.Revit.Geometry..::FaceArray
Autodesk.Revit.Geometry..::FaceArrayIterator
Autodesk.Revit.Geometry..::IntersectionResultArray
Autodesk.Revit.Geometry..::IntersectionResultArrayIterator
Autodesk.Revit.Geometry..::Transform
Autodesk.Revit.Geometry..::IntersectionResult
Autodesk.Revit.Geometry..::CurveArrArray
Autodesk.Revit.Geometry..::CurveArrArrayIterator
Autodesk.Revit.Geometry..::UVArray
Autodesk.Revit.Geometry..::UVArrayIterator
Autodesk.Revit.Geometry..::EdgeArray
Autodesk.Revit.Geometry..::EdgeArrayIterator
Autodesk.Revit.Geometry..::EdgeArrayArray
Autodesk.Revit.Geometry..::EdgeArrayArrayIterator
Autodesk.Revit.Geometry..::GeometryObjectArray
Autodesk.Revit.Geometry..::GeometryObjectArrayIterator
Autodesk.Revit.Geometry..::MeshTriangle
Autodesk.Revit.Geometry..::InstanceArray
Autodesk.Revit.Geometry..::InstanceArrayIterator
Autodesk.Revit.Geometry..::MeshArray
Autodesk.Revit.Geometry..::MeshArrayIterator
Autodesk.Revit.Geometry..::SolidArray
Autodesk.Revit.Geometry..::SolidArrayIterator
Autodesk.Revit.Elements..::ViewSet
Autodesk.Revit.Elements..::ViewSetIterator
Autodesk.Revit.Elements..::RebarHostData
Autodesk.Revit.Elements..::LoadCaseSet
Autodesk.Revit.Elements..::LoadCaseSetIterator
Autodesk.Revit.Elements..::LoadCaseArray
Autodesk.Revit.Elements..::LoadCaseArrayIterator
Autodesk.Revit.Elements..::LoadUsageArray
Autodesk.Revit.Elements..::LoadUsageArrayIterator
Autodesk.Revit.Elements..::LoadCombinationArray
Autodesk.Revit.Elements..::LoadCombinationArrayIterator
Autodesk.Revit.Elements..::SpaceSet
Autodesk.Revit.Elements..::SpaceSetIterator
Autodesk.Revit.Elements..::PhaseArray
Autodesk.Revit.Elements..::PhaseArrayIterator
Autodesk.Revit.Elements..::ViewSheetSets
Autodesk.Revit.Elements..::ViewSheetSetsIterator
Autodesk.Revit.Elements..::ModelCurveArray
Autodesk.Revit.Elements..::ModelCurveArrayIterator
Autodesk.Revit.Elements..::DetailCurveArray
Autodesk.Revit.Elements..::DetailCurveArrayIterator
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::CurtainCell
Autodesk.Revit.Elements..::CurtainCellSet
Autodesk.Revit.Elements..::CurtainCellSetIterator
Autodesk.Revit.Elements..::CurtainGrid
Autodesk.Revit.Elements..::CurtainGridSet
Autodesk.Revit.Elements..::CurtainGridSetIterator
Autodesk.Revit.Elements..::GenericFormSet
Autodesk.Revit.Elements..::GenericFormSetIterator
Autodesk.Revit.Elements..::ModelCurveArrArray
Autodesk.Revit.Elements..::ModelCurveArrArrayIterator
Autodesk.Revit.Elements..::GroupSet
Autodesk.Revit.Elements..::GroupSetIterator
Autodesk.Revit.Elements..::SketchSet
Autodesk.Revit.Elements..::SketchSetIterator
Autodesk.Revit.Elements..::ElectricalSystemSet
Autodesk.Revit.Elements..::ElectricalSystemSetIterator
Autodesk.Revit.Elements..::ConduitTypeSet
Autodesk.Revit.Elements..::ConduitTypeSetIterator
Autodesk.Revit.Elements..::WireMaterialTypeSet
Autodesk.Revit.Elements..::WireMaterialTypeSetIterator
Autodesk.Revit.Elements..::TemperatureRatingTypeSet
Autodesk.Revit.Elements..::TemperatureRatingTypeSetIterator
Autodesk.Revit.Elements..::InsulationTypeSet
Autodesk.Revit.Elements..::InsulationTypeSetIterator
Autodesk.Revit.Elements..::WireSet
Autodesk.Revit.Elements..::WireSetIterator
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::DefinitionFile
Autodesk.Revit.Parameters..::DefinitionGroup
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::DefinitionsBaseIterator
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ParameterListItemArray
Autodesk.Revit.Parameters..::ParameterListItemArrayIterator
Autodesk.Revit.Parameters..::ParameterListItem
Autodesk.Revit.Parameters..::DefinitionGroupsBase
Autodesk.Revit.Parameters..::DefinitionGroupsBaseIterator
Autodesk.Revit.Collections..::StringStringMap
Autodesk.Revit.Collections..::StringStringMapIterator
Autodesk.Revit.Collections..::DefinitionBindingMap
Autodesk.Revit.Collections..::DefinitionBindingMapIterator
Autodesk.Revit.Collections..::Array
Autodesk.Revit.Collections..::ArrayIterator
Autodesk.Revit.Collections..::Map
Autodesk.Revit.Collections..::MapIterator
Autodesk.Revit.Collections..::Set
Autodesk.Revit.Collections..::SetIterator
Autodesk.Revit.Editor..::SlabShapeCreaseArray
Autodesk.Revit.Editor..::SlabShapeCreaseArrayIterator
Autodesk.Revit.Editor..::SlabShapeVertexArray
Autodesk.Revit.Editor..::SlabShapeVertexArrayIterator
Autodesk.Revit.Creation..::Filter
Autodesk.Revit.Creation..::Application
Autodesk.Revit.Creation..::Document
Autodesk.Revit.Options..::Application
Autodesk.Revit.Symbols..::RebarShapeDefinition
Autodesk.Revit.Symbols..::FamilySymbolSet
Autodesk.Revit.Symbols..::FamilySymbolSetIterator
Autodesk.Revit.Symbols..::WallTypeSet
Autodesk.Revit.Symbols..::WallTypeSetIterator
Autodesk.Revit.Symbols..::FloorTypeSet
Autodesk.Revit.Symbols..::FloorTypeSetIterator
Autodesk.Revit.Symbols..::ContFootingTypeSet
Autodesk.Revit.Symbols..::ContFootingTypeSetIterator
Autodesk.Revit.Symbols..::BeamSystemTypeSet
Autodesk.Revit.Symbols..::BeamSystemTypeSetIterator
Autodesk.Revit.Symbols..::DimensionTypeSet
Autodesk.Revit.Symbols..::DimensionTypeSetIterator
Autodesk.Revit.Symbols..::AnnotationSymbolTypeSet
Autodesk.Revit.Symbols..::AnnotationSymbolTypeSetIterator
Autodesk.Revit.Symbols..::SpotDimensionTypeSet
Autodesk.Revit.Symbols..::SpotDimensionTypeSetIterator
Autodesk.Revit.Symbols..::RebarBarTypeSet
Autodesk.Revit.Symbols..::RebarBarTypeSetIterator
Autodesk.Revit.Symbols..::RebarHookTypeSet
Autodesk.Revit.Symbols..::RebarHookTypeSetIterator
Autodesk.Revit.Symbols..::RebarCoverTypeSet
Autodesk.Revit.Symbols..::RebarCoverTypeSetIterator
Autodesk.Revit.Symbols..::RebarShapeSet
Autodesk.Revit.Symbols..::RebarShapeSetIterator
Autodesk.Revit.Symbols..::LevelTypeSet
Autodesk.Revit.Symbols..::LevelTypeSetIterator
Autodesk.Revit.Symbols..::TextNoteTypeSet
Autodesk.Revit.Symbols..::TextNoteTypeSetIterator
Autodesk.Revit.Symbols..::GridTypeSet
Autodesk.Revit.Symbols..::GridTypeSetIterator
Autodesk.Revit.Symbols..::RoomTagTypeSet
Autodesk.Revit.Symbols..::RoomTagTypeSetIterator
Autodesk.Revit.Symbols..::TrussTypeSet
Autodesk.Revit.Symbols..::TrussTypeSetIterator
Autodesk.Revit.Symbols..::RoofTypeSet
Autodesk.Revit.Symbols..::RoofTypeSetIterator
Autodesk.Revit.Symbols..::SpaceTagTypeSet
Autodesk.Revit.Symbols..::SpaceTagTypeSetIterator
Autodesk.Revit.Symbols..::MullionTypeSet
Autodesk.Revit.Symbols..::MullionTypeSetIterator
Autodesk.Revit.Symbols..::PanelTypeSet
Autodesk.Revit.Symbols..::PanelTypeSetIterator
Autodesk.Revit.Symbols..::CurtainSystemTypeSet
Autodesk.Revit.Symbols..::CurtainSystemTypeSetIterator
Autodesk.Revit.Symbols..::SlabEdgeTypeSet
Autodesk.Revit.Symbols..::SlabEdgeTypeSetIterator
Autodesk.Revit.Symbols..::GutterTypeSet
Autodesk.Revit.Symbols..::GutterTypeSetIterator
Autodesk.Revit.Symbols..::FasciaTypeSet
Autodesk.Revit.Symbols..::FasciaTypeSetIterator
Autodesk.Revit.Symbols..::AreaTagTypeSet
Autodesk.Revit.Symbols..::AreaTagTypeSetIterator
Autodesk.Revit.Symbols..::LoadTypeBaseSet
Autodesk.Revit.Symbols..::LoadTypeBaseSetIterator
Autodesk.Revit.Symbols..::PointLoadTypeSet
Autodesk.Revit.Symbols..::PointLoadTypeSetIterator
Autodesk.Revit.Symbols..::LineLoadTypeSet
Autodesk.Revit.Symbols..::LineLoadTypeSetIterator
Autodesk.Revit.Symbols..::AreaLoadTypeSet
Autodesk.Revit.Symbols..::AreaLoadTypeSetIterator
Autodesk.Revit.Symbols..::DistributionSysTypeSet
Autodesk.Revit.Symbols..::DistributionSysTypeSetIterator
Autodesk.Revit.Symbols..::VoltageTypeSet
Autodesk.Revit.Symbols..::VoltageTypeSetIterator
Autodesk.Revit.Symbols..::WireTypeSet
Autodesk.Revit.Symbols..::WireTypeSetIterator
Autodesk.Revit.Symbols..::MEPBuildingConstructionSet
Autodesk.Revit.Symbols..::MEPBuildingConstructionSetIterator
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::BarDescription
Autodesk.Revit.Structural..::CompoundStructure
Autodesk.Revit.Structural..::AnalyticalSupportData
Autodesk.Revit.Structural..::AnalyticalSupportInfo
Autodesk.Revit.Structural..::AnalyticalSupportInfoArray
Autodesk.Revit.Structural..::AnalyticalSupportInfoArrayIterator
Autodesk.Revit.Structural..::CompoundStructureLayer
Autodesk.Revit.Structural..::CompoundStructureLayerArray
Autodesk.Revit.Structural..::CompoundStructureLayerArrayIterator
Autodesk.Revit.Site..::City
Autodesk.Revit.Site..::CitySet
Autodesk.Revit.Site..::CitySetIterator
Autodesk.Revit.Site..::ProjectPosition
Autodesk.Revit.Site..::ProjectLocationSet
Autodesk.Revit.Site..::ProjectLocationSetIterator
Autodesk.Revit.MEP..::WireSize
Autodesk.Revit.MEP..::CorrectionFactor
Autodesk.Revit.MEP..::GroundConductorSize
Autodesk.Revit.MEP..::DemandFactorData
Autodesk.Revit.MEP..::Connector
Autodesk.Revit.MEP..::ElectricalSetting
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::ConnectorSet
Autodesk.Revit.MEP..::ConnectorSetIterator
Autodesk.Revit.MEP..::ConnectorManager
Autodesk.Revit.MEP..::DemandFactorDataSet
Autodesk.Revit.MEP..::DemandFactorDataSetIterator
Autodesk.Revit.MEP..::WireSizeSet
Autodesk.Revit.MEP..::WireSizeSetIterator
Autodesk.Revit.MEP..::GroundConductorSizeSet
Autodesk.Revit.MEP..::GroundConductorSizeSetIterator
Autodesk.Revit.MEP..::CorrectionFactorSet
Autodesk.Revit.MEP..::CorrectionFactorSetIterator
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetSet
Autodesk.Revit.Utility..::AssetSetIterator
Autodesk.Revit.Rooms..::BoundarySegment
Autodesk.Revit.Rooms..::BoundarySegmentArray
Autodesk.Revit.Rooms..::BoundarySegmentArrayIterator
Autodesk.Revit.Rooms..::BoundarySegmentArrayArray
Autodesk.Revit.Rooms..::BoundarySegmentArrayArrayIterator
Autodesk.Revit.Areas..::BoundarySegment
Autodesk.Revit.Areas..::BoundarySegmentArray
Autodesk.Revit.Areas..::BoundarySegmentArrayIterator
Autodesk.Revit.Areas..::BoundarySegmentArrayArray
Autodesk.Revit.Areas..::BoundarySegmentArrayArrayIterator
Autodesk.Revit.Spaces..::BoundarySegment
Autodesk.Revit.Spaces..::BoundarySegmentArray
Autodesk.Revit.Spaces..::BoundarySegmentArrayIterator
Autodesk.Revit.Spaces..::BoundarySegmentArrayArray
Autodesk.Revit.Spaces..::BoundarySegmentArrayArrayIterator

See Also

APIObject Members
Autodesk.Revit Namespace


APIObject Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class APIObject
Visual Basic (Declaration)
Public Class APIObject
Visual C++
public ref class APIObject

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | APIObjectAPIObjectNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Dispose | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.
Protected method | Finalize | (Overrides Object ..:: Finalize()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources |
Protected method | ReleaseUnmanagedResources |

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject
Autodesk.Revit Namespace


APIObject Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public APIObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
APIObject ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

APIObject Class
Autodesk.Revit Namespace


APIObject Methods
CollapseAll image DropDown image

Syntax

C#
public class APIObject
Visual Basic (Declaration)
Public Class APIObject
Visual C++
public ref class APIObject

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Dispose | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.
Protected method | Finalize | (Overrides Object ..:: Finalize()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources |
Protected method | ReleaseUnmanagedResources |

See Also

APIObject
Autodesk.Revit Namespace


Dispose Method

APIObject..::Dispose Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Dispose()() | Causes the object to release immediately any resources it may be utilizing.
Protected method | Dispose(Boolean) |

See Also

APIObject Class
APIObject Members
Autodesk.Revit Namespace


Dispose Method

APIObject..::Dispose Method
CollapseAll image DropDown image

Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose () sealed

Remarks

This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.

See Also

APIObject Class
Autodesk.Revit Namespace


Dispose Method (Boolean)

APIObject..::Dispose Method (Boolean)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected virtual void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
)

Parameters

Boolean

See Also

APIObject Class
Autodesk.Revit Namespace


Finalize Method

APIObject..::Finalize Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize () override

See Also

APIObject Class
Autodesk.Revit Namespace


ReleaseManagedResources Method

APIObject..::ReleaseManagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected virtual void ReleaseManagedResources()
Visual Basic (Declaration)
Protected Overridable Sub ReleaseManagedResources
Visual C++
protected:
virtual void ReleaseManagedResources ()

See Also

APIObject Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

APIObject..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected virtual void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overridable Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources ()

See Also

APIObject Class
Autodesk.Revit Namespace


APIObject Properties
CollapseAll image DropDown image

Syntax

C#
public class APIObject
Visual Basic (Declaration)
Public Class APIObject
Visual C++
public ref class APIObject

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject
Autodesk.Revit Namespace


IsReadOnly Property

APIObject..::IsReadOnly Property
CollapseAll image DropDown image

Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsReadOnly{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

See Also

APIObject Class
Autodesk.Revit Namespace


Application Class
See Also Members
CollapseAll image DropDown image

Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("66D283CE-9E65-4153-91DB-FC0AF80644B3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Application : APIObject
Visual Basic (Declaration)
<GuidAttribute("66D283CE-9E65-4153-91DB-FC0AF80644B3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Application _
    Inherits APIObject
Visual C++
[GuidAttribute(L"66D283CE-9E65-4153-91DB-FC0AF80644B3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Application : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Application

See Also

Application Members
Autodesk.Revit Namespace


Application Members
See Also Methods Properties Constructors Events
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ApplicationApplicationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile | Overloaded.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ActiveDocument | Provides access to an object that represents the currently active project.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | Documents | Returns a set of documents within Revit.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Autodesk Revit dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified after a document is closed.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified after a new document has been created.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified after a document has been opened.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified after a document is saved.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

See Also

Application
Autodesk.Revit Namespace


Application Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Application ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Application Class
Autodesk.Revit Namespace


Application Methods
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile | Overloaded.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Application
Autodesk.Revit Namespace


CreateToolbar Method

Application..::CreateToolbar Method
CollapseAll image DropDown image

Create a new ToolBar

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Toolbar CreateToolbar()
Visual Basic (Declaration)
Public Overridable Function CreateToolbar As Toolbar
Visual C++
public:
virtual Toolbar^ CreateToolbar ()

Remarks

This method will create an API ToolBar appending to the Revit standard ToolBars.

Exceptions

Exception | Condition
System..::InvalidOperationException | if more than 100 ToolBars were created.

See Also

Application Class
Autodesk.Revit Namespace


CreateTopMenu Method

Application..::CreateTopMenu Method
CollapseAll image DropDown image

Creates a top level menu which will be added to revit main menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MenuItem CreateTopMenu(
    string menuName
)
Visual Basic (Declaration)
Public Overridable Function CreateTopMenu ( _
    menuName As String _
) As MenuItem
Visual C++
public:
virtual MenuItem^ CreateTopMenu (
    String^ menuName
)

Parameters

menuName
String
The caption of the menu to be created.

Remarks

The user can use this function to add a new item to the main menu of Revit. The return value will be the created MenuItem.

See Also

Application Class
Autodesk.Revit Namespace


GetAllTopMenus Method

Application..::GetAllTopMenus Method
CollapseAll image DropDown image

Returns all of the top level menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void GetAllTopMenus(
    ref Array topMenus
)
Visual Basic (Declaration)
Public Overridable Sub GetAllTopMenus ( _
    ByRef topMenus As Array _
)
Visual C++
public:
virtual void GetAllTopMenus (
    Array^% topMenus
)

Parameters

topMenus
Array %
This is an output argument, which will include all the main menu items of Revit.

Remarks

All the items included in the main menu of Revit will be returned in the output arguments topMenus.

See Also

Application Class
Autodesk.Revit Namespace


GetToolbars Method

Application..::GetToolbars Method
CollapseAll image DropDown image

Get all the ToolBars created by API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ToolbarArray GetToolbars()
Visual Basic (Declaration)
Public Overridable Function GetToolbars As ToolbarArray
Visual C++
public:
virtual ToolbarArray^ GetToolbars ()

Remarks

All the ToolBars created by API, exclude the Revit standard ToolBars.

See Also

Application Class
Autodesk.Revit Namespace


NewFamilyDocument Method

Application..::NewFamilyDocument Method
CollapseAll image DropDown image

New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document NewFamilyDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewFamilyDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewFamilyDocument (
    String^ templateFileName
)

Parameters

templateFileName
String
The template file name.

Remarks

It is correspond to the File->New->Family.../TitleBlock.../Annotation Symbol....

Exceptions

Exception | Condition
System..::ArgumentException | if 'templateFileName' is a null object or a empty string.
System..::InvalidOperationException | if can not new a family document.

See Also

Application Class
Autodesk.Revit Namespace


NewProjectDocument Method

Application..::NewProjectDocument Method
CollapseAll image DropDown image

New project document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument (
    String^ templateFileName
)

Parameters

templateFileName
String
The template file name.

Remarks

It is correspond to the File->New->Project....

Exceptions

Exception | Condition
System..::ArgumentException | if 'templateFileName' is a null object or a empty string.
System..::InvalidOperationException | if can not new a project document.

See Also

Application Class
Autodesk.Revit Namespace


NewProjectTemplateDocument Method

Application..::NewProjectTemplateDocument Method
CollapseAll image DropDown image

New project template document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic (Declaration)
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument (
    String^ templateFilename
)

Parameters

templateFilename
String
The template file name.

Remarks

It is correspond to the File->New->Project....

Exceptions

Exception | Condition
System..::ArgumentException | if 'templateFileName' is a null object or a empty string.
System..::InvalidOperationException | if can not new a project template document.

See Also

Application Class
Autodesk.Revit Namespace


OpenDocumentFile Method

Application..::OpenDocumentFile Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | OpenDocumentFile(String) | Open document
Public method | OpenDocumentFile(String, PostedErrorArray) | Open document

See Also

Application Class
Application Members
Autodesk.Revit Namespace


OpenDocumentFile Method (String)

Application..::OpenDocumentFile Method (String)
See Also
CollapseAll image DropDown image

Open document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile (
    String^ fileName
)

Parameters

fileName
String
The file to be opened.

Remarks

It is correspond to the File->Open....

Exceptions

Exception | Condition
System..::ArgumentException | if 'fileName' is a null object or a empty string.
System..::InvalidOperationException | if can not open a file.

See Also

Application Class
Autodesk.Revit Namespace


OpenDocumentFile Method (String, PostedErrorArray)

Application..::OpenDocumentFile Method (String, PostedErrorArray)
See Also
CollapseAll image DropDown image

Open document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String, _
    postedErrors As PostedErrorArray _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile (
    String^ fileName,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
String
The file to be opened.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Remarks

This method corresponds to the File->Open... menu command.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

Exceptions

Exception | Condition
System..::ArgumentException | if 'fileName' is a null object or a empty string.
System..::InvalidOperationException | if can not open a file.

See Also

Application Class
Autodesk.Revit Namespace


OpenSharedParameterFile Method

Application..::OpenSharedParameterFile Method
CollapseAll image DropDown image

Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic (Declaration)
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile ()

Return Value

An object that represents a shared parameters file.

Remarks

This function is used to return an object that represents a Revit shared parameters file that exists on disk. Revit can use only one shared parameters file at any one time. The filename for the shared parameters file can be set in the Revit Application Options object. If the file does not exist and error will be created and an empty reference will be returned.

See Also

Application Class
Autodesk.Revit Namespace


Application Properties
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ActiveDocument | Provides access to an object that represents the currently active project.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | Documents | Returns a set of documents within Revit.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

Application
Autodesk.Revit Namespace


ActiveDocument Property

Application..::ActiveDocument Property
CollapseAll image DropDown image

Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document ActiveDocument{ get; set;}
Visual Basic (Declaration)
Public Overridable Property ActiveDocument As Document
Visual C++
public:
virtual property Document^ ActiveDocument {
    Document^ get ();
    void set (Document^ value);
}

Remarks

External API commands can access this property in read-oly mode only! The ability to modify the property is reserved for future implementations.

Exceptions

Exception | Condition
System..::NotSupportedException | Thrown when attempting to modify the property.

See Also

Application Class
Autodesk.Revit Namespace


Assets Property

Application..::Assets Property
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetSet Assets[
    AssetType
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Assets ( _
     As AssetType _
) As AssetSet
Visual C++
public:
property AssetSet^ Assets[AssetType ] {
    AssetSet^ get (AssetType );
}

Parameters

AssetType

See Also

Application Class
Autodesk.Revit Namespace


Cities Property

Application..::Cities Property
CollapseAll image DropDown image

Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CitySet Cities{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Cities As CitySet
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

See Also

Application Class
Autodesk.Revit Namespace


Create Property

Application..::Create Property
CollapseAll image DropDown image

Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application Create{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

Application Class
Autodesk.Revit Namespace


Documents Property

Application..::Documents Property
CollapseAll image DropDown image

Returns a set of documents within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DocumentSet Documents{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Documents As DocumentSet
Visual C++
public:
virtual property DocumentSet^ Documents {
    DocumentSet^ get ();
}

Remarks

This property can be used for the user to find all the document inside Revit.

See Also

Application Class
Autodesk.Revit Namespace


IsQuiescent Property

Application..::IsQuiescent Property
CollapseAll image DropDown image

Returns if the current application is quiescent.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsQuiescent{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsQuiescent As Boolean
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in of the current application is in editing mode or the In-place famliy is being edited, it returns false. Otherwise, true will be returned.

See Also

Application Class
Autodesk.Revit Namespace


LoadedApplications Property

Application..::LoadedApplications Property
CollapseAll image DropDown image

Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

Application Class
Autodesk.Revit Namespace


ObjectFactory Property

Application..::ObjectFactory Property
CollapseAll image DropDown image

Provides an object that can be used to create other instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ObjectFactory ObjectFactory{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ObjectFactory As ObjectFactory
Visual C++
public:
property ObjectFactory^ ObjectFactory {
    ObjectFactory^ get ();
}

Remarks

Returns an object factory object that can create other objects. This property is available for advanced use cases only. For general purpose creation of Autodesk Revit API objects use the Application.Create object.

See Also

Application Class
Autodesk.Revit Namespace


Options Property

Application..::Options Property
CollapseAll image DropDown image

Provides access to an object that represents the application wide settings available in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application Options{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Options As Application
Visual C++
public:
property Application^ Options {
    Application^ get ();
}

Remarks

This property return the Revit Options object which exposes some of the options available in the Revit Options dialog available from the Settings, Options – menu.

See Also

Application Class
Autodesk.Revit Namespace


RecordingJournalFilename Property

Application..::RecordingJournalFilename Property
CollapseAll image DropDown image

Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string RecordingJournalFilename{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RecordingJournalFilename As String
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file.These files are useful for providing information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

Application Class
Autodesk.Revit Namespace


VersionBuild Property

Application..::VersionBuild Property
CollapseAll image DropDown image

Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string VersionBuild{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VersionBuild As String
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correct against that version of Autodesk Revit.

See Also

Application Class
Autodesk.Revit Namespace


VersionName Property

Application..::VersionName Property
CollapseAll image DropDown image

Returns the name of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string VersionName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VersionName As String
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correct against that version of Revit.

See Also

Application Class
Autodesk.Revit Namespace


VersionNumber Property

Application..::VersionNumber Property
CollapseAll image DropDown image

Return the primary version of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string VersionNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correct against that version of Revit.

See Also

Application Class
Autodesk.Revit Namespace


Application Events
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following events.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Autodesk Revit dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified after a document is closed.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified after a new document has been created.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified after a document has been opened.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified after a document is saved.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

See Also

Application
Autodesk.Revit Namespace


OnDialogBox Event

Application..::OnDialogBox Event
CollapseAll image DropDown image

Subscribe to the OnDialogBox event to be notified when a Autodesk Revit dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometime a Autodesk Revit dialog box may be displayed during an API command. By subscribing to this event the application will be notified of such an event and can perform an action, such as dismissing the dialog automatically.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentClosed Event

Application..::OnDocumentClosed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentClosed event to be notified after a document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been closed during an API command. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentNewed Event

Application..::OnDocumentNewed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentNewed event to be notified after a new document has been created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a new document has been created. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentOpened Event

Application..::OnDocumentOpened Event
CollapseAll image DropDown image

Subscribe to the OnDocumentOpened event to be notified after a document has been opened.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been opened. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentSaved Event

Application..::OnDocumentSaved Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSaved event to be notified after a document is saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved. By subscribing to this event the application will be notified after such an event and can perform an action in reponse.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentSavedAs Event

Application..::OnDocumentSavedAs Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved to a file with another name. By subscribing to this event the application will be notified after such an event and can perform an action in reponse.

See Also

Application Class
Autodesk.Revit Namespace


BuiltInCategory Enumeration
CollapseAll image DropDown image

A list of all the built in categories within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3FE0CE42-FE3F-4eab-94BF-25532396D549")]
public enum BuiltInCategory
Visual Basic (Declaration)
<GuidAttribute("3FE0CE42-FE3F-4eab-94BF-25532396D549")> _
Public Enumeration BuiltInCategory
Visual C++
[GuidAttribute(L"3FE0CE42-FE3F-4eab-94BF-25532396D549")]
public enum class BuiltInCategory

Members

Member name | Description
OST_IOSNavWheelPivotBall |
OST_IOSRoomComputationHeight |
OST_IOSRoomUpperLowerLines |
OST_IOSDragBoxInverted |
OST_IOSDragBox |
OST_Phases |
OST_IOS_GeoSite |
OST_IOS_GeoLocations |
OST_EPS_Future |
OST_EPS_Temporary |
OST_EPS_New |
OST_EPS_Demolished |
OST_EPS_Existing |
OST_IOSMeasureLineScreenSize |
OST_IOSRebarSystemSpanSymbolCtrl |
OST_IOSRoomTagToRoomLines |
OST_IOSAttachedDetailGroups |
OST_IOSDetailGroups |
OST_IOSModelGroups |
OST_IOSSuspendedSketch |
OST_IOSWallCoreBoundary |
OST_IOSMeasureLine |
OST_IOSArrays |
OST_Curtain_Systems |
OST_IOSBBoxScreenSize |
OST_IOSSlabShapeEditorPointInterior |
OST_IOSSlabShapeEditorPointBoundary |
OST_IOSSlabShapeEditorBoundary |
OST_IOSSlabShapeEditorAutoCrease |
OST_IOSSlabShapeEditorExplitCrease |
OST_IOSNotSilhouette |
OST_IOSRoomPerimeterLines |
OST_IOSCuttingGeometry |
OST_IOSCrashGraphics |
OST_IOSGroups |
OST_IOSGhost |
OST_IOSThinPixel_DashDot |
OST_IOSThinPixel_Dash |
OST_IOSThinPixel_Dot |
OST_IOSThinPixel |
OST_IOSFlipControl |
OST_IOSSketchGrid |
OST_IOSSuspendedSketch_obsolete |
OST_IOSFreeSnapLine |
OST_IOSDatumPlane |
OST_IOSConstructionLine |
OST_IOSAlignmentGraphics |
OST_IOSAligningLine |
OST_IOSBackedUpElements |
OST_IOSRegeneratedElements |
OST_IOSRegenerationFailure |
OST_IOS |
OST_CutOutlines |
OST_StructuralTrussStickSymbols |
OST_StructuralTrussHiddenLines |
OST_TrussChord |
OST_TrussWeb |
OST_TrussBottomChordCurve |
OST_TrussTopChordCurve |
OST_TrussVertWebCurve |
OST_TrussDiagWebCurve |
OST_Truss |
OST_TrussDummy |
OST_MassHiddenLines |
OST_CurtaSystemHiddenLines |
OST_OBSOLETE_ElemArrayHiddenLines |
OST_EntourageHiddenLines |
OST_PlantingHiddenLines |
OST_SpecialityEquipmentHiddenLines |
OST_TopographyHiddenLines |
OST_StructuralFramingSystemHiddenLines |
OST_SiteHiddenLines |
OST_RoadsHiddenLines |
OST_ParkingHiddenLines |
OST_PlumbingFixturesHiddenLines |
OST_MechanicalEquipmentHiddenLines |
OST_LightingFixturesHiddenLines |
OST_FurnitureSystemsHiddenLines |
OST_ElectricalFixturesHiddenLines |
OST_ElectricalEquipmentHiddenLines |
OST_CaseworkHiddenLines |
OST_DetailComponentsHiddenLines |
OST_ShaftOpeningHiddenLines |
OST_GenericModelHiddenLines |
OST_CurtainWallMullionsHiddenLines |
OST_CurtainWallPanelsHiddenLines |
OST_RampsHiddenLines |
OST_StairsRailingHiddenLines |
OST_StairsHiddenLines |
OST_ColumnsHiddenLines |
OST_FurnitureHiddenLines |
OST_LinesHiddenLines |
OST_CeilingsHiddenLines |
OST_RoofsHiddenLines |
OST_DoorsHiddenLines |
OST_WindowsHiddenLines |
OST_StructConnectionTags |
OST_StructWeldLines |
OST_StructConnections |
OST_AreaReinTags |
OST_RebarTags |
OST_CoverType |
OST_RebarShape |
OST_PathReinBoundary |
OST_PathReinTags |
OST_PathReinSpanSymbol |
OST_PathRein |
OST_Cage |
OST_AreaReinXVisibility |
OST_AreaReinBoundary |
OST_AreaReinSpanSymbol |
OST_AreaReinSketchOverride |
OST_AreaRein |
OST_RebarLines |
OST_RebarSketchLines |
OST_Rebar |
OST_HVAC_Zones_Reference_Visibility |
OST_HVAC_Zones_InteriorFill_Visibility |
OST_HVAC_Zones_ColorFill |
OST_ZoneTags |
OST_LayoutPath_Bases |
OST_WireTemperatureRatings |
OST_WireInsulations |
OST_WireMaterials |
OST_HVAC_Zones_Reference |
OST_HVAC_Zones_InteriorFill |
OST_HVAC_Zones_Boundary |
OST_HVAC_Zones |
OST_Fluids |
OST_PipeSchedules |
OST_PipeMaterials |
OST_PipeConnections |
OST_EAConstructions |
OST_SwitchSystem |
OST_SprinklerTags |
OST_Sprinklers |
OST_RouteCurveBranch |
OST_RouteCurveMain |
OST_RouteCurve |
OST_GbXML_Opening |
OST_GbXML_SType_Underground |
OST_GbXML_SType_Shade |
OST_GbXML_SType_Exterior |
OST_GbXML_SType_Interior |
OST_GbXMLFaces |
OST_WireHomeRunArrows |
OST_LightingDeviceTags |
OST_LightingDevices |
OST_FireAlarmDeviceTags |
OST_FireAlarmDevices |
OST_DataDeviceTags |
OST_DataDevices |
OST_CommunicationDeviceTags |
OST_CommunicationDevices |
OST_SecurityDeviceTags |
OST_SecurityDevices |
OST_NurseCallDeviceTags |
OST_NurseCallDevices |
OST_TelephoneDeviceTags |
OST_TelephoneDevices |
OST_WireTickMarks |
OST_PipeFittingInsulation |
OST_PipeFittingCenterLine |
OST_FlexPipeCurvesInsulation |
OST_PipeCurvesInsulation |
OST_PipeCurvesDrop |
OST_DuctFittingLining |
OST_DuctFittingInsulation |
OST_DuctFittingCenterLine |
OST_FlexDuctCurvesInsulation |
OST_DuctCurvesLining |
OST_DuctCurvesInsulation |
OST_DuctCurvesDrop |
OST_DuctFittingTags |
OST_PipeFittingTags |
OST_PipeColorFills |
OST_PipeColorFillLegends |
OST_WireTags |
OST_PipeAccessoryTags |
OST_PipeAccessory |
OST_PipeCurvesRiseDrop |
OST_FlexPipeCurvesPattern |
OST_FlexPipeCurvesContour |
OST_FlexPipeCurvesCenterLine |
OST_FlexPipeCurves |
OST_PipeFitting |
OST_FlexPipeTags |
OST_PipeTags |
OST_PipeCurvesContour |
OST_PipeCurvesCenterLine |
OST_PipeCurves |
OST_PipingSystem |
OST_ElectricalDemandFactor |
OST_ElecDistributionSys |
OST_ElectricalVoltage |
OST_Wire |
OST_ElectricalCircuitTags |
OST_ElectricalCircuit |
OST_DuctCurvesRiseDrop |
OST_FlexDuctCurvesPattern |
OST_FlexDuctCurvesContour |
OST_FlexDuctCurvesCenterLine |
OST_FlexDuctCurves |
OST_DuctAccessoryTags |
OST_DuctAccessory |
OST_DuctSystem |
OST_DuctTerminalTags |
OST_DuctTerminal |
OST_DuctFitting |
OST_FlexDuctTags |
OST_DuctTags |
OST_DuctCurvesContour |
OST_DuctCurvesCenterLine |
OST_DuctCurves |
OST_DuctColorFills |
OST_DuctColorFillLegends |
OST_ConnectorElemZAxis |
OST_ConnectorElemYAxis |
OST_ConnectorElemXAxis |
OST_ConnectorElem |
OST_DesignOptions |
OST_DesignOptionSets |
OST_StructuralBracePlanReps |
OST_StructuralConnections |
OST_StructuralAnnotations |
OST_RevisionCloudTags |
OST_Revisions |
OST_RevisionClouds |
OST_EditCutProfile |
OST_GridHeads |
OST_LevelHeads |
OST_DecalType |
OST_DecalElement |
OST_VolumeOfInterest |
OST_BoundaryConditions |
OST_InternalAreaLoadTags |
OST_InternalLineLoadTags |
OST_InternalPointLoadTags |
OST_AreaLoadTags |
OST_LineLoadTags |
OST_PointLoadTags |
OST_LoadCasesSeismic |
OST_LoadCasesTemperature |
OST_LoadCasesAccidental |
OST_LoadCasesRoofLive |
OST_LoadCasesSnow |
OST_LoadCasesWind |
OST_LoadCasesLive |
OST_LoadCasesDead |
OST_LoadCases |
OST_InternalAreaLoads |
OST_InternalLineLoads |
OST_InternalPointLoads |
OST_InternalLoads |
OST_AreaLoads |
OST_LineLoads |
OST_PointLoads |
OST_Loads |
OST_BeamSystemTags |
OST_FootingSpanDirectionSymbol |
OST_SpanDirectionSymbol |
OST_SpotSlopesSymbols |
OST_SpotCoordinateSymbols |
OST_SpotElevSymbols |
OST_TrussTags |
OST_KeynoteTags |
OST_DetailComponentTags |
OST_MaterialTags |
OST_FloorTags |
OST_CurtaSystemTags |
OST_HostFinTags |
OST_StairTags |
OST_MultiCategoryTags |
OST_PlantingTags |
OST_AreaTags |
OST_StructuralFoundationTags |
OST_StructuralColumnTags |
OST_ParkingTags |
OST_SiteTags |
OST_StructuralFramingTags |
OST_SpecialityEquipmentTags |
OST_GenericModelTags |
OST_CurtainWallPanelTags |
OST_WallTags |
OST_PlumbingFixtureTags |
OST_MechanicalEquipmentTags |
OST_LightingFixtureTags |
OST_FurnitureSystemTags |
OST_FurnitureTags |
OST_ElectricalFixtureTags |
OST_ElectricalEquipmentTags |
OST_CeilingTags |
OST_CaseworkTags |
OST_Tags |
OST_LegendComponents |
OST_ScheduleGraphics |
OST_RasterImages |
OST_ColorFillSchema |
OST_RoomColorFill |
OST_ColorFillLegends |
OST_AnnotationCropSpecial |
OST_CropBoundarySpecial |
OST_AnnotationCrop |
OST_CalloutLeaderLine |
OST_CalloutBoundary |
OST_CalloutHeads |
OST_Callouts |
OST_CropBoundary |
OST_Elev |
OST_AxisZ |
OST_AxisY |
OST_AxisX |
OST_ReferenceLines |
OST_CLines |
OST_Lights |
OST_ViewportLabel |
OST_Viewports |
OST_Camera_Lines |
OST_Cameras |
OST_MEPSpaceTags |
OST_RoomTags |
OST_DoorTags |
OST_WindowTags |
OST_SectionHeadWideLines |
OST_SectionHeadMediumLines |
OST_SectionHeadThinLines |
OST_SectionHeads |
OST_ContourLabels |
OST_RenderRegions |
OST_SectionBox |
OST_TextNotes |
OST_Catalogs |
OST_DirectionEdgeLines |
OST_CenterLines |
OST_LinesBeyond |
OST_HiddenLines |
OST_DemolishedLines |
OST_OverheadLines |
OST_TitleBlockWideLines |
OST_TitleBlockMediumLines |
OST_TitleBlockThinLines |
OST_TitleBlocks |
OST_Views |
OST_Viewers |
OST_RoofTags |
OST_SpotSlopes |
OST_SpotCoordinates |
OST_SpotElevations |
OST_Constraints |
OST_WeakDims |
OST_Dimensions |
OST_DatumLevels |
OST_Levels |
OST_Grids |
OST_BrokenSectionLine |
OST_SectionLine |
OST_Sections |
OST_MEPSpaceColorFill |
OST_MEPSpaceReference |
OST_MEPSpaceInteriorFill |
OST_MEPSpaceReferenceVisibility |
OST_MEPSpaceInteriorFillVisibility |
OST_MEPSpaces |
OST_StackedWalls |
OST_StackedWalls_Obsolete_IdInWrongRange |
OST_MassAreaFaceTags |
OST_HostTemplate |
OST_MassFaceSplitter |
OST_MassCutter |
OST_ZoningEnvelope |
OST_MassTags |
OST_MassSurface |
OST_MassAreaFaces |
OST_Mass |
OST_MassTags_Obsolete_IdInWrongRange |
OST_MassSurface_Obsolete_IdInWrongRange |
OST_MassAreaFaces_Obsolete_IdInWrongRange |
OST_Mass_Obsolete_IdInWrongRange |
OST_ZoneSchemes |
OST_AreaSchemes |
OST_Areas |
OST_ProjectInformation |
OST_DrawingSheets |
OST_ProfileFamilies |
OST_DetailComponents |
OST_RoofSoffit |
OST_EdgeSlab |
OST_Gutter |
OST_Fascia |
OST_Entourage |
OST_Planting |
OST_StructuralStiffenerTags |
OST_StructuralStiffener |
OST_FootingAnalyticalGeometry |
OST_RvtLinks |
OST_Automatic |
OST_SpecialityEquipment |
OST_ColumnAnalyticalRigidLinks |
OST_SecondaryTopographyContours |
OST_TopographyContours |
OST_TopographySurface |
OST_Topography |
OST_StructuralTruss |
OST_StructuralColumnStickSymbols |
OST_HiddenStructuralColumnLines |
OST_AnalyticalRigidLinks |
OST_ColumnAnalyticalGeometry |
OST_FramingAnalyticalGeometry |
OST_StructuralColumns |
OST_HiddenStructuralFramingLines |
OST_KickerBracing |
OST_StructuralFramingSystem |
OST_VerticalBracing |
OST_HorizontalBracing |
OST_Purlin |
OST_Joist |
OST_Girder |
OST_StructuralFramingOther |
OST_StructuralFraming |
OST_HiddenStructuralFoundationLines |
OST_StructuralFoundation |
OST_SiteRegion |
OST_SitePropertyLineSegmentTags |
OST_SitePropertyLineSegment |
OST_SitePropertyTags |
OST_SitePointBoundary |
OST_SiteProperty |
OST_BuildingPad |
OST_SitePoint |
OST_SiteSurface |
OST_Site |
OST_HiddenBuildingUnitLines |
OST_BuildingUnits |
OST_Sewer |
OST_Roads |
OST_Property |
OST_Parking |
OST_PlumbingFixtures |
OST_MechanicalEquipment |
OST_LightingFixtureSource |
OST_LightingFixtures |
OST_FurnitureSystems |
OST_ElectricalFixtures |
OST_ElectricalEquipment |
OST_Casework |
OST_GenericModel |
OST_GenericAnnotation |
OST_Materials |
OST_AreaReport_Arc_Minus |
OST_AreaReport_Arc_Plus |
OST_AreaReport_Boundary |
OST_AreaReport_Triangle |
OST_CurtaSystemFaceManager |
OST_CurtaSystem |
OST_DetailArray |
OST_ModelArray |
OST_HostFinHF |
OST_HostFinWall |
OST_HostFinCeiling |
OST_HostFinRoof |
OST_HostFinFloor |
OST_HostFin |
OST_ReferenceViewer |
OST_ReferenceViewerSymbol |
OST_ImportObjectStyles |
OST_ModelText |
OST_MaskingRegion |
OST_Matchline |
OST_FaceSplitter |
OST_PlanRegion |
OST_FilledRegion |
OST_MassingProjectionOutlines |
OST_MassingCutOutlines |
OST_Massing |
OST_Reveals |
OST_Cornices |
OST_RampsDownArrow |
OST_RampsUpArrow |
OST_RampsDownText |
OST_RampsUpText |
OST_RampsStringerAboveCut |
OST_RampsStringer |
OST_RampsAboveCut |
OST_RampsIncomplete |
OST_Ramps |
OST_RailingBalusterRailCut |
OST_RailingBalusterRail |
OST_Railings |
OST_CurtainGridsCurtaSystem |
OST_CurtainGridsSystem |
OST_CurtainGridsWall |
OST_CurtainGridsRoof |
OST_CurtainGrids |
OST_CurtainWallMullionsCut |
OST_CurtainWallMullions |
OST_CurtainWallPanels |
OST_AreaReference |
OST_AreaInteriorFill |
OST_RoomReference |
OST_RoomInteriorFill |
OST_AreaColorFill |
OST_AreaReferenceVisibility |
OST_AreaInteriorFillVisibility |
OST_RoomReferenceVisibility |
OST_RoomInteriorFillVisibility |
OST_Rooms |
OST_Fixtures |
OST_StairsRailingTags |
OST_StairsRailingAboveCut |
OST_StairsRailingRail |
OST_StairsRailingBaluster |
OST_StairsRailing |
OST_StairsDownArrow |
OST_StairsUpArrow |
OST_StairsDownText |
OST_StairsUpText |
OST_StairsStringerAboveCut |
OST_StairsStringer |
OST_StairsAboveCut |
OST_StairsIncomplete |
OST_Stairs |
OST_Columns |
OST_Furniture |
OST_Extrusions |
OST_FillPatterns |
OST_MeshElem_HiddenLines |
OST_MeshElem_Facets |
OST_MeshElem_Edges |
OST_MeshElem_Points |
OST_MeshElem |
OST_MEPSpaceSeparationLines |
OST_AreaPolylines |
OST_RoomPolylines |
OST_InstanceDrivenLineStyle |
OST_StickSymbols_Obsolete_IdInWrongRange |
OST_RemovedGridSeg |
OST_RemovedGridSeg_Obsolete_IdInWrongRange |
OST_RepeatingDetailLines |
OST_AreaSchemeLines |
OST_GenericLines |
OST_InsulationLines |
OST_CloudLines |
OST_StairsLandingCenterLines |
OST_StairsRunLines |
OST_StairsRiserLines |
OST_StairsBoundaryLines |
OST_AreaSeparationLines |
OST_AxisOfRotation |
OST_InvisibleLines |
OST_SketchLines |
OST_CurvesWideLines |
OST_CurvesMediumLines |
OST_CurvesThinLines |
OST_Curves |
OST_Lines |
OST_CeilingsSurfacePattern |
OST_CeilingsProjection |
OST_CeilingsCut |
OST_Ceilings |
OST_RoofsSurfacePattern |
OST_RoofsProjection |
OST_RoofsCut |
OST_Roofs |
OST_FloorsAnalyticalGeometry |
OST_FloorsSurfacePattern |
OST_FloorsProjection |
OST_FloorsCut |
OST_Floors |
OST_DoorsGlassProjection |
OST_DoorsGlassCut |
OST_DoorsFrameMullionProjection |
OST_DoorsFrameMullionCut |
OST_DoorsOpeningProjection |
OST_DoorsOpeningCut |
OST_DoorsPanelProjection |
OST_DoorsPanelCut |
OST_Doors |
OST_WindowsOpeningProjection |
OST_WindowsOpeningCut |
OST_WindowsSillHeadProjection |
OST_WindowsSillHeadCut |
OST_WindowsFrameMullionProjection |
OST_WindowsFrameMullionCut |
OST_WindowsGlassProjection |
OST_WindowsGlassCut |
OST_Windows |
OST_ColumnOpening |
OST_StructuralFramingOpening |
OST_ShaftOpening |
OST_CeilingOpening |
OST_FloorOpening |
OST_DormerOpeningIncomplete |
OST_RoofOpening |
OST_SWallRectOpening |
OST_ArcWallRectOpening |
OST_WallRefPlanes |
OST_WallRefPlanes_Obsolete_IdInWrongRange |
OST_CeilingsCutPattern |
OST_CeilingsDefault |
OST_CeilingsFinish2 |
OST_CeilingsFinish1 |
OST_CeilingsSubstrate |
OST_CeilingsInsulation |
OST_CeilingsStructure |
OST_CeilingsMembrane |
OST_FloorsInteriorEdges |
OST_FloorsCutPattern |
OST_HiddenFloorLines |
OST_FloorsDefault |
OST_FloorsFinish2 |
OST_FloorsFinish1 |
OST_FloorsSubstrate |
OST_FloorsInsulation |
OST_FloorsStructure |
OST_FloorsMembrane |
OST_RoofsInteriorEdges |
OST_RoofsCutPattern |
OST_RoofsDefault |
OST_RoofsFinish2 |
OST_RoofsFinish1 |
OST_RoofsSubstrate |
OST_RoofsInsulation |
OST_RoofsStructure |
OST_RoofsMembrane |
OST_WallsCutPattern |
OST_HiddenWallLines |
OST_WallsDefault |
OST_WallsFinish2 |
OST_WallsFinish1 |
OST_WallsSubstrate |
OST_WallsInsulation |
OST_WallsStructure |
OST_WallsMembrane |
OST_WallsSurfacePattern |
OST_WallsAnalyticalGeometry |
OST_WallsProjectionOutlines |
OST_WallsCutOutlines |
OST_Walls |
OST_MatchSiteComponent |
OST_MatchProfile |
OST_MatchDetail |
OST_MatchAnnotation |
OST_MatchModel |
OST_MatchAll |
INVALID |

See Also

Autodesk.Revit Namespace


CADExportOptions Class
See Also Members
CollapseAll image DropDown image

Generic CAD Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CFB3A194-9B5F-449f-8032-B5FF366F01E4")]
public abstract class CADExportOptions
Visual Basic (Declaration)
<GuidAttribute("CFB3A194-9B5F-449f-8032-B5FF366F01E4")> _
Public MustInherit Class CADExportOptions
Visual C++
[GuidAttribute(L"CFB3A194-9B5F-449f-8032-B5FF366F01E4")]
public ref class CADExportOptions abstract

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::ACADExportOptions
Autodesk.Revit..::DWF3DExportOptions
Autodesk.Revit..::DWF2DExportOptions
Autodesk.Revit..::DWFX3DExportOptions
Autodesk.Revit..::DWFX2DExportOptions

See Also

CADExportOptions Members
Autodesk.Revit Namespace


CADExportOptions Members
See Also Methods Constructors Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class CADExportOptions
Visual Basic (Declaration)
Public MustInherit Class CADExportOptions
Visual C++
public ref class CADExportOptions abstract

The type exposes the following members.

Protected Constructors

 | Name | Description
Protected method | CADExportOptionsCADExportOptionsNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views.
Public field | TargetUnit | Type of units in the target CAD format.

See Also

CADExportOptions
Autodesk.Revit Namespace


CADExportOptions Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected CADExportOptions()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
CADExportOptions ()

See Also

CADExportOptions Class
Autodesk.Revit Namespace


CADExportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class CADExportOptions
Visual Basic (Declaration)
Public MustInherit Class CADExportOptions
Visual C++
public ref class CADExportOptions abstract

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views.
Public field | TargetUnit | Type of units in the target CAD format.

See Also

CADExportOptions
Autodesk.Revit Namespace


ExportingAreas Field

CADExportOptions..::ExportingAreas Field
CollapseAll image DropDown image

Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ExportingAreas
Visual Basic (Declaration)
Public ExportingAreas As Boolean
Visual C++
public:
bool ExportingAreas

See Also

CADExportOptions Class
Autodesk.Revit Namespace


ForcedHLR Field

CADExportOptions..::ForcedHLR Field
CollapseAll image DropDown image

Whether to enforce Hidden Lines Removal in 3D views.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ForcedHLR
Visual Basic (Declaration)
Public ForcedHLR As Boolean
Visual C++
public:
bool ForcedHLR

See Also

CADExportOptions Class
Autodesk.Revit Namespace


TargetUnit Field

CADExportOptions..::TargetUnit Field
CollapseAll image DropDown image

Type of units in the target CAD format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExportUnit TargetUnit
Visual Basic (Declaration)
Public TargetUnit As ExportUnit
Visual C++
public:
ExportUnit TargetUnit

See Also

CADExportOptions Class
Autodesk.Revit Namespace


CADImportOptions Class
See Also Members
CollapseAll image DropDown image

Generic CAD Import options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0F998739-2A81-49b4-BC89-30EDBF4C356A")]
public abstract class CADImportOptions : GenericImportOptions
Visual Basic (Declaration)
<GuidAttribute("0F998739-2A81-49b4-BC89-30EDBF4C356A")> _
Public MustInherit Class CADImportOptions _
    Inherits GenericImportOptions
Visual C++
[GuidAttribute(L"0F998739-2A81-49b4-BC89-30EDBF4C356A")]
public ref class CADImportOptions abstract : public GenericImportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::GenericImportOptions
Autodesk.Revit..::CADImportOptions
Autodesk.Revit..::ACADImportOptions

See Also

CADImportOptions Members
Autodesk.Revit Namespace


CADImportOptions Members
See Also Methods Constructors Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class CADImportOptions
Visual Basic (Declaration)
Public MustInherit Class CADImportOptions
Visual C++
public ref class CADImportOptions abstract

The type exposes the following members.

Protected Constructors

 | Name | Description
Protected method | CADImportOptionsCADImportOptionsNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import.
Public field | CustomScale | Scaling the import.
Public field | OrientToView | Place the import at the same orientation as the current view.
Public field | Placement | Where to place the import.
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Public field | Unit | The unit of measure for imported geometry.
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions
Autodesk.Revit Namespace


CADImportOptions Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected CADImportOptions()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
CADImportOptions ()

See Also

CADImportOptions Class
Autodesk.Revit Namespace


CADImportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class CADImportOptions
Visual Basic (Declaration)
Public MustInherit Class CADImportOptions
Visual C++
public ref class CADImportOptions abstract

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import.
Public field | CustomScale | Scaling the import.
Public field | OrientToView | Place the import at the same orientation as the current view.
Public field | Placement | Where to place the import.
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Public field | Unit | The unit of measure for imported geometry.
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions
Autodesk.Revit Namespace


ColorMode Field

CADImportOptions..::ColorMode Field
CollapseAll image DropDown image

Color mode for the import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ImportColorMode ColorMode
Visual Basic (Declaration)
Public ColorMode As ImportColorMode
Visual C++
public:
ImportColorMode ColorMode

Remarks

Three modes are supported. Black and White, Preserve Colors, and Invert Colors.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


CustomScale Field

CADImportOptions..::CustomScale Field
CollapseAll image DropDown image

Scaling the import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CustomScale
Visual Basic (Declaration)
Public CustomScale As Double
Visual C++
public:
double CustomScale

Remarks

If this is defined and a valid value (> 0.0), it takes preference over units.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


OrientToView Field

CADImportOptions..::OrientToView Field
CollapseAll image DropDown image

Place the import at the same orientation as the current view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool OrientToView
Visual Basic (Declaration)
Public OrientToView As Boolean
Visual C++
public:
bool OrientToView

Remarks

This option is available only for non-view-specific imports.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


Placement Field

CADImportOptions..::Placement Field
CollapseAll image DropDown image

Where to place the import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ImportPlacement Placement
Visual Basic (Declaration)
Public Placement As ImportPlacement
Visual C++
public:
ImportPlacement Placement

Remarks

Set this option to place the view at the origin or the center, or a shared coordinates.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


ThisViewOnly Field

CADImportOptions..::ThisViewOnly Field
CollapseAll image DropDown image

Imports dwg, dgn, and dxf drawings into the active view only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ThisViewOnly
Visual Basic (Declaration)
Public ThisViewOnly As Boolean
Visual C++
public:
bool ThisViewOnly

Remarks

This option is not available in 3D views.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


Unit Field

CADImportOptions..::Unit Field
CollapseAll image DropDown image

The unit of measure for imported geometry.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ImportUnit Unit
Visual Basic (Declaration)
Public Unit As ImportUnit
Visual C++
public:
ImportUnit Unit

Remarks

Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored.

Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, Revit will default to inches.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


Categories Class
See Also Members
CollapseAll image DropDown image

The Categories object is a map that contains all the Category objects within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5DA0C323-C8E7-40ff-A176-C9DBB6E479EC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Categories : CategoryNameMap
Visual Basic (Declaration)
<GuidAttribute("5DA0C323-C8E7-40ff-A176-C9DBB6E479EC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Categories _
    Inherits CategoryNameMap
Visual C++
[GuidAttribute(L"5DA0C323-C8E7-40ff-A176-C9DBB6E479EC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Categories : public CategoryNameMap

Remarks

A specific category object can be retrieved from the Categories map using the Item method, passing the name, as a string, to the method.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::CategoryNameMap
Autodesk.Revit..::Categories

See Also

Categories Members
Autodesk.Revit Namespace


Categories Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Categories
Visual Basic (Declaration)
Public Class Categories
Visual C++
public ref class Categories

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoriesCategoriesNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Public method | Contains | Tests for the existence of a category with that name within the map. (Inherited from CategoryNameMap.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map. (Inherited from CategoryNameMap.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides CategoryNameMap ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from CategoryNameMap.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from CategoryNameMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Size | Returns the number of categories that are in the map. (Inherited from CategoryNameMap.)

See Also

Categories
Autodesk.Revit Namespace


Categories Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Categories()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Categories ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Categories Class
Autodesk.Revit Namespace


Categories Methods
CollapseAll image DropDown image

Syntax

C#
public class Categories
Visual Basic (Declaration)
Public Class Categories
Visual C++
public ref class Categories

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Public method | Contains | Tests for the existence of a category with that name within the map. (Inherited from CategoryNameMap.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map. (Inherited from CategoryNameMap.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides CategoryNameMap ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from CategoryNameMap.)

See Also

Categories
Autodesk.Revit Namespace


Dispose Method

Categories..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Categories Class
Autodesk.Revit Namespace


Categories Properties
CollapseAll image DropDown image

Syntax

C#
public class Categories
Visual Basic (Declaration)
Public Class Categories
Visual C++
public ref class Categories

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from CategoryNameMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Size | Returns the number of categories that are in the map. (Inherited from CategoryNameMap.)

See Also

Categories
Autodesk.Revit Namespace


Item Property

Categories..::Item Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Item[([String])] | Gets or sets a category at a specified name within the map. (Inherited from CategoryNameMap.)
Public property | Item[([BuiltInCategory])] | Retrieve a category object using a built in category id.

See Also

Categories Class
Categories Members
Autodesk.Revit Namespace


Item Property (BuiltInCategory)

Categories..::Item Property (BuiltInCategory)
See Also
CollapseAll image DropDown image

Retrieve a category object using a built in category id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Category Item[
    BuiltInCategory categoryId
]{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Item ( _
    categoryId As BuiltInCategory _
) As Category
Visual C++
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}

Parameters

categoryId
BuiltInCategory

See Also

Categories Class
Autodesk.Revit Namespace


Category Class
See Also Members
CollapseAll image DropDown image

Represents the category or sub category to which an element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5D5097B8-00A6-4afc-A125-9DB1A484C869")]
public class Category : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5D5097B8-00A6-4afc-A125-9DB1A484C869")> _
Public Class Category _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5D5097B8-00A6-4afc-A125-9DB1A484C869")]
public ref class Category : public APIObject

Remarks

Categories are an import tool within Revit for identifying the inferred type of an element, such as anything in the Walls category should be considered as a wall. The API exposes access to the built in categories within Revit via the Document.Settings.Categories property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Category

See Also

Category Members
Autodesk.Revit Namespace


Category Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Category
Visual Basic (Declaration)
Public Class Category
Visual C++
public ref class Category

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoryCategoryNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object ..:: GetHashCode()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Id | Returns the category id associated with the category object.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Material | Retrieve or change the material of the category.
Public property | Name | Returns the user visible name of the category.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the sub categories of this category.
Public property | Visible | Retrieve or change the visible of the category in the active view.

See Also

Category
Autodesk.Revit Namespace


Category Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Category()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Category ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Category Class
Autodesk.Revit Namespace


Category Methods
CollapseAll image DropDown image

Syntax

C#
public class Category
Visual Basic (Declaration)
Public Class Category
Visual C++
public ref class Category

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object ..:: GetHashCode()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Category
Autodesk.Revit Namespace


GetHashCode Method

Category..::GetHashCode Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode () override

See Also

Category Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

Category..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Category Class
Autodesk.Revit Namespace


Category Properties
CollapseAll image DropDown image

Syntax

C#
public class Category
Visual Basic (Declaration)
Public Class Category
Visual C++
public ref class Category

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Id | Returns the category id associated with the category object.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Material | Retrieve or change the material of the category.
Public property | Name | Returns the user visible name of the category.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the sub categories of this category.
Public property | Visible | Retrieve or change the visible of the category in the active view.

See Also

Category
Autodesk.Revit Namespace


Id Property

Category..::Id Property
CollapseAll image DropDown image

Returns the category id associated with the category object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId Id{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId Id {
    ElementId get ();
}

See Also

Category Class
Autodesk.Revit Namespace


Material Property

Category..::Material Property
CollapseAll image DropDown image

Retrieve or change the material of the category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Material Material{ get; set;}
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Remarks

If this category doesn't have a material,then nullptr will be returned by the get method.

See Also

Category Class
Autodesk.Revit Namespace


Name Property

Category..::Name Property
CollapseAll image DropDown image

Returns the user visible name of the category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Category Class
Autodesk.Revit Namespace


Parent Property

Category..::Parent Property
CollapseAll image DropDown image

Returns the parent category of this category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Category Parent{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parent As Category
Visual C++
public:
property Category^ Parent {
    Category^ get ();
}

Remarks

If this category a not a sub category then Nothing will be returned.

See Also

Category Class
Autodesk.Revit Namespace


SubCategories Property

Category..::SubCategories Property
CollapseAll image DropDown image

Returns a map containing all of the sub categories of this category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryNameMap SubCategories{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SubCategories As CategoryNameMap
Visual C++
public:
property CategoryNameMap^ SubCategories {
    CategoryNameMap^ get ();
}

Remarks

If the category has no sub-categories then an empty map will be returned.

See Also

Category Class
Autodesk.Revit Namespace


Visible Property

Category..::Visible Property
CollapseAll image DropDown image

Retrieve or change the visible of the category in the active view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Visible[
    View view
]{ get; set;}
Visual Basic (Declaration)
Public Property Visible ( _
    view As View _
) As Boolean
Visual C++
public:
property bool Visible[View^ view] {
    bool get (View^ view);
    void set (View^ view, bool value);
}

Parameters

view
View
Check the category if it is visible in this view.

See Also

Category Class
Autodesk.Revit Namespace


CategoryFilter Class
See Also Members
CollapseAll image DropDown image

Represents a filter to filter elements with specific category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0A6EFA03-01F3-4e17-934F-41DE44D2A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CategoryFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("0A6EFA03-01F3-4e17-934F-41DE44D2A7B7")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CategoryFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"0A6EFA03-01F3-4e17-934F-41DE44D2A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CategoryFilter : public Filter

Remarks

The category filter object is used to filter all the elements in the document of which the category is the appointed one.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::CategoryFilter

See Also

CategoryFilter Members
Autodesk.Revit Namespace


CategoryFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CategoryFilter
Visual Basic (Declaration)
Public Class CategoryFilter
Visual C++
public ref class CategoryFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoryFilterCategoryFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategoryFilter
Autodesk.Revit Namespace


CategoryFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategoryFilter Class
Autodesk.Revit Namespace


CategoryFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class CategoryFilter
Visual Basic (Declaration)
Public Class CategoryFilter
Visual C++
public ref class CategoryFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

CategoryFilter
Autodesk.Revit Namespace


Dispose Method

CategoryFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CategoryFilter Class
Autodesk.Revit Namespace


CategoryNameMap Class
See Also Members
CollapseAll image DropDown image

A map that contains a mapping of category name to its category object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("293DE12E-7815-402b-A673-548CF922895E")]
public class CategoryNameMap : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("293DE12E-7815-402b-A673-548CF922895E")> _
Public Class CategoryNameMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"293DE12E-7815-402b-A673-548CF922895E")]
public ref class CategoryNameMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::CategoryNameMap
Autodesk.Revit..::Categories

See Also

CategoryNameMap Members
Autodesk.Revit Namespace


CategoryNameMap Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CategoryNameMap
Visual Basic (Declaration)
Public Class CategoryNameMap
Visual C++
public ref class CategoryNameMap

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoryNameMapCategoryNameMapNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap
Autodesk.Revit Namespace


CategoryNameMap Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryNameMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryNameMap ()

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


CategoryNameMap Methods
CollapseAll image DropDown image

Syntax

C#
public class CategoryNameMap
Visual Basic (Declaration)
Public Class CategoryNameMap
Visual C++
public ref class CategoryNameMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CategoryNameMap
Autodesk.Revit Namespace


Clear Method

CategoryNameMap..::Clear Method
CollapseAll image DropDown image

Removes every category from the map, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Contains Method

CategoryNameMap..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a category with that name within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains (
    String^ key
)

Parameters

key
String
The category name to be searched for.

Return Value

The Contains method returns True if the name is within the map, otherwise False.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Dispose Method

CategoryNameMap..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Erase Method

CategoryNameMap..::Erase Method
CollapseAll image DropDown image

Removes a category with the specified name from the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase (
    String^ key
)

Parameters

key
String
The name of the category to be erased.

Return Value

The number of categories that were erased from the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


ForwardIterator Method

CategoryNameMap..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CategoryNameMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


GetEnumerator Method

CategoryNameMap..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Insert Method

CategoryNameMap..::Insert Method
CollapseAll image DropDown image

Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    string key,
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert (
    String^ key,
    Category^ item
)

Parameters

key
String
The name to be used for inserting the category into the map.
item
Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

CategoryNameMap..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


ReverseIterator Method

CategoryNameMap..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CategoryNameMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


CategoryNameMap Properties
CollapseAll image DropDown image

Syntax

C#
public class CategoryNameMap
Visual Basic (Declaration)
Public Class CategoryNameMap
Visual C++
public ref class CategoryNameMap

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap
Autodesk.Revit Namespace


IsEmpty Property

CategoryNameMap..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the map is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Item Property

CategoryNameMap..::Item Property
CollapseAll image DropDown image

Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Category Item[
    string key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}

Parameters

key
String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Size Property

CategoryNameMap..::Size Property
CollapseAll image DropDown image

Returns the number of categories that are in the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


CategoryNameMapIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a category name map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2544F9D5-480C-4732-B604-DF035A6EB302")]
public abstract class CategoryNameMapIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2544F9D5-480C-4732-B604-DF035A6EB302")> _
Public MustInherit Class CategoryNameMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2544F9D5-480C-4732-B604-DF035A6EB302")]
public ref class CategoryNameMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::CategoryNameMapIterator

See Also

CategoryNameMapIterator Members
Autodesk.Revit Namespace


CategoryNameMapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CategoryNameMapIterator
Visual Basic (Declaration)
Public MustInherit Class CategoryNameMapIterator
Visual C++
public ref class CategoryNameMapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoryNameMapIteratorCategoryNameMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator
Autodesk.Revit Namespace


CategoryNameMapIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryNameMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryNameMapIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


CategoryNameMapIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CategoryNameMapIterator
Visual Basic (Declaration)
Public MustInherit Class CategoryNameMapIterator
Visual C++
public ref class CategoryNameMapIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CategoryNameMapIterator
Autodesk.Revit Namespace


Dispose Method

CategoryNameMapIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


MoveNext Method

CategoryNameMapIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

CategoryNameMapIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


Reset Method

CategoryNameMapIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


CategoryNameMapIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CategoryNameMapIterator
Visual Basic (Declaration)
Public MustInherit Class CategoryNameMapIterator
Visual C++
public ref class CategoryNameMapIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator
Autodesk.Revit Namespace


Current Property

CategoryNameMapIterator..::Current Property
CollapseAll image DropDown image

Retrieves the category that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


Key Property

CategoryNameMapIterator..::Key Property
CollapseAll image DropDown image

Retrieves the category name that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual string Key{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


CategorySet Class
See Also Members
CollapseAll image DropDown image

A set that can contains Category objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C70C66C8-F476-4901-AE6F-D98A99D6C46F")]
public class CategorySet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C70C66C8-F476-4901-AE6F-D98A99D6C46F")> _
Public Class CategorySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C70C66C8-F476-4901-AE6F-D98A99D6C46F")]
public ref class CategorySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::CategorySet

See Also

CategorySet Members
Autodesk.Revit Namespace


CategorySet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CategorySet
Visual Basic (Declaration)
Public Class CategorySet
Visual C++
public ref class CategorySet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategorySetCategorySetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of categories that are in the set.

See Also

CategorySet
Autodesk.Revit Namespace


CategorySet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategorySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategorySet ()

See Also

CategorySet Class
Autodesk.Revit Namespace


CategorySet Methods
CollapseAll image DropDown image

Syntax

C#
public class CategorySet
Visual Basic (Declaration)
Public Class CategorySet
Visual C++
public ref class CategorySet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CategorySet
Autodesk.Revit Namespace


Clear Method

CategorySet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CategorySet Class
Autodesk.Revit Namespace


Contains Method

CategorySet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a category within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Category^ item
)

Parameters

item
Category
The category to be searched for.

Return Value

The Contains method returns True if the category is within the set, otherwise False.

See Also

CategorySet Class
Autodesk.Revit Namespace


Dispose Method

CategorySet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CategorySet Class
Autodesk.Revit Namespace


Erase Method

CategorySet..::Erase Method
CollapseAll image DropDown image

Removes a specified category from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Category _
) As Integer
Visual C++
public:
virtual int Erase (
    Category^ item
)

Parameters

item
Category
The category to be erased.

Return Value

The number of items that were erased from the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


ForwardIterator Method

CategorySet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CategorySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


GetEnumerator Method

CategorySet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


Insert Method

CategorySet..::Insert Method
CollapseAll image DropDown image

Insert the specified category into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Category^ item
)

Parameters

item
Category
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

CategorySet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CategorySet Class
Autodesk.Revit Namespace


ReverseIterator Method

CategorySet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CategorySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


CategorySet Properties
CollapseAll image DropDown image

Syntax

C#
public class CategorySet
Visual Basic (Declaration)
Public Class CategorySet
Visual C++
public ref class CategorySet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of categories that are in the set.

See Also

CategorySet
Autodesk.Revit Namespace


IsEmpty Property

CategorySet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CategorySet Class
Autodesk.Revit Namespace


Size Property

CategorySet..::Size Property
CollapseAll image DropDown image

Returns the number of categories that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategorySet Class
Autodesk.Revit Namespace


CategorySetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a category set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2D8DB487-3186-435e-9F6C-31F09AEA90E6")]
public abstract class CategorySetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2D8DB487-3186-435e-9F6C-31F09AEA90E6")> _
Public MustInherit Class CategorySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2D8DB487-3186-435e-9F6C-31F09AEA90E6")]
public ref class CategorySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::CategorySetIterator

See Also

CategorySetIterator Members
Autodesk.Revit Namespace


CategorySetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CategorySetIterator
Visual Basic (Declaration)
Public MustInherit Class CategorySetIterator
Visual C++
public ref class CategorySetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategorySetIteratorCategorySetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator
Autodesk.Revit Namespace


CategorySetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategorySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategorySetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


CategorySetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CategorySetIterator
Visual Basic (Declaration)
Public MustInherit Class CategorySetIterator
Visual C++
public ref class CategorySetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CategorySetIterator
Autodesk.Revit Namespace


Dispose Method

CategorySetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


MoveNext Method

CategorySetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

CategorySetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


Reset Method

CategorySetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


CategorySetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CategorySetIterator
Visual Basic (Declaration)
Public MustInherit Class CategorySetIterator
Visual C++
public ref class CategorySetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator
Autodesk.Revit Namespace


Current Property

CategorySetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


Color Class
See Also Members
CollapseAll image DropDown image

Represents a color in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D66B262E-CFF3-4d26-9FE3-4A3DF3EDFEF3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Color : APIObject
Visual Basic (Declaration)
<GuidAttribute("D66B262E-CFF3-4d26-9FE3-4A3DF3EDFEF3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Color _
    Inherits APIObject
Visual C++
[GuidAttribute(L"D66B262E-CFF3-4d26-9FE3-4A3DF3EDFEF3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Color : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Color

See Also

Color Members
Autodesk.Revit Namespace


Color Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Color
Visual Basic (Declaration)
Public Class Color
Visual C++
public ref class Color

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ColorColorNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Blue | Get or set the blue channel of the color.
Public property | Green | Get or set the green channel of the color.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Red | Get or set the red channel of the color.

See Also

Color
Autodesk.Revit Namespace


Color Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ColorColorNew()() | For Internal Use Only.
Public method | ColorColorNew(Byte, Byte, Byte) | Constructor that takes the red, green and blue channels of the color.

See Also

Color Class
Color Members
Autodesk.Revit Namespace


Color Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Color ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Color Class
Autodesk.Revit Namespace


Color Constructor (Byte, Byte, Byte)
CollapseAll image DropDown image

Constructor that takes the red, green and blue channels of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color(
    byte red,
    byte green,
    byte blue
)
Visual Basic (Declaration)
Public Sub New ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
Visual C++
public:
Color (
    unsigned char red,
    unsigned char green,
    unsigned char blue
)

Parameters

red
Byte
The red channel of the color that ranges from 0 to 255.
green
Byte
The green channel of the color that ranges from 0 to 255.
blue
Byte
The blue channel of the color that ranges from 0 to 255.

See Also

Color Class
Autodesk.Revit Namespace


Color Properties
CollapseAll image DropDown image

Syntax

C#
public class Color
Visual Basic (Declaration)
Public Class Color
Visual C++
public ref class Color

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Blue | Get or set the blue channel of the color.
Public property | Green | Get or set the green channel of the color.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Red | Get or set the red channel of the color.

See Also

Color
Autodesk.Revit Namespace


Blue Property

Color..::Blue Property
CollapseAll image DropDown image

Get or set the blue channel of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public byte Blue{ get; set;}
Visual Basic (Declaration)
Public Property Blue As Byte
Visual C++
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the blue channel.

See Also

Color Class
Autodesk.Revit Namespace


Green Property

Color..::Green Property
CollapseAll image DropDown image

Get or set the green channel of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public byte Green{ get; set;}
Visual Basic (Declaration)
Public Property Green As Byte
Visual C++
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the green channel.

See Also

Color Class
Autodesk.Revit Namespace


Red Property

Color..::Red Property
CollapseAll image DropDown image

Get or set the red channel of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public byte Red{ get; set;}
Visual Basic (Declaration)
Public Property Red As Byte
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the red channel.

See Also

Color Class
Autodesk.Revit Namespace


Construction Class
See Also Members
CollapseAll image DropDown image

Construction definition for Project Information.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D9F64EDE-DC5B-44a4-8D26-98D015CB7B32")]
public class Construction
Visual Basic (Declaration)
<GuidAttribute("D9F64EDE-DC5B-44a4-8D26-98D015CB7B32")> _
Public Class Construction
Visual C++
[GuidAttribute(L"D9F64EDE-DC5B-44a4-8D26-98D015CB7B32")]
public ref class Construction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::Construction

See Also

Construction Members
Autodesk.Revit Namespace


Construction Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class Construction
Visual Basic (Declaration)
Public Class Construction
Visual C++
public ref class Construction

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConstructionConstructionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.

See Also

Construction
Autodesk.Revit Namespace


Construction Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Construction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Construction ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Construction Class
Autodesk.Revit Namespace


Construction Properties
CollapseAll image DropDown image

Syntax

C#
public class Construction
Visual Basic (Declaration)
Public Class Construction
Visual C++
public ref class Construction

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.

See Also

Construction
Autodesk.Revit Namespace


Id Property

Construction..::Id Property
CollapseAll image DropDown image

Get the id of the Construction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Id{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
}

Remarks

This property is used to get the id of the Construction.

See Also

Construction Class
Autodesk.Revit Namespace


Name Property

Construction..::Name Property
CollapseAll image DropDown image

Get the name of the Construction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

This property is used to get the name of the Construction.

See Also

Construction Class
Autodesk.Revit Namespace


ControlledApplication Class
See Also Members
CollapseAll image DropDown image

Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4C99D41F-ACA5-4d11-8E3A-58D526818220")]
public class ControlledApplication
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4C99D41F-ACA5-4d11-8E3A-58D526818220")> _
Public Class ControlledApplication
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4C99D41F-ACA5-4d11-8E3A-58D526818220")]
public ref class ControlledApplication

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::ControlledApplication

See Also

ControlledApplication Members
Autodesk.Revit Namespace


ControlledApplication Members
See Also Methods Constructors Properties Events
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ControlledApplicationControlledApplicationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | VersionBuild | Returns the internal build number of the Revit applciation.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

See Also

ControlledApplication
Autodesk.Revit Namespace


ControlledApplication Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ControlledApplication()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ControlledApplication ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ControlledApplication Methods
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

ControlledApplication
Autodesk.Revit Namespace


CreateToolbar Method

ControlledApplication..::CreateToolbar Method
CollapseAll image DropDown image

Create a new ToolBar

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Toolbar CreateToolbar()
Visual Basic (Declaration)
Public Function CreateToolbar As Toolbar
Visual C++
public:
Toolbar^ CreateToolbar ()

Remarks

This method will create an API ToolBar appending to the Revit standard ToolBars.

Exceptions

Exception | Condition
System..::InvalidOperationException | if more than 100 ToolBars were created.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


CreateTopMenu Method

ControlledApplication..::CreateTopMenu Method
CollapseAll image DropDown image

Creates a top level menu which will be added to revit main menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem CreateTopMenu(
    string menuName
)
Visual Basic (Declaration)
Public Function CreateTopMenu ( _
    menuName As String _
) As MenuItem
Visual C++
public:
MenuItem^ CreateTopMenu (
    String^ menuName
)

Parameters

menuName
String
The caption of the menu to be created.

Remarks

The user can use this function to add a new item to the main menu of Revit. The return value will be the created MenuItem.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


GetAllTopMenus Method

ControlledApplication..::GetAllTopMenus Method
CollapseAll image DropDown image

Returns all of the top level menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void GetAllTopMenus(
    ref Array topMenus
)
Visual Basic (Declaration)
Public Sub GetAllTopMenus ( _
    ByRef topMenus As Array _
)
Visual C++
public:
void GetAllTopMenus (
    Array^% topMenus
)

Parameters

topMenus
Array %
This is an output argument, which will include all the main menu items of Revit.

Remarks

All the items included in the main menu of Revit will be returned in the output arguments topMenus.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


GetToolbars Method

ControlledApplication..::GetToolbars Method
CollapseAll image DropDown image

Get all the ToolBars created by API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarArray GetToolbars()
Visual Basic (Declaration)
Public Function GetToolbars As ToolbarArray
Visual C++
public:
ToolbarArray^ GetToolbars ()

Remarks

All the ToolBars created by API, exclude the Revit standard ToolBars.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OpenSharedParameterFile Method

ControlledApplication..::OpenSharedParameterFile Method
CollapseAll image DropDown image

Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic (Declaration)
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile ()

Return Value

An object that represents a shared parameters file.

Remarks

This function is used to return an object that represents a Revit shared parameters file that exists on disk. Revit can use only one shared parameters file at any one time. The filename for the shared parameters file can be set in the Revit Application Options object. If the file does not exist and error will be created and an empty reference will be returned.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ControlledApplication Properties
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | VersionBuild | Returns the internal build number of the Revit applciation.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication
Autodesk.Revit Namespace


Cities Property

ControlledApplication..::Cities Property
CollapseAll image DropDown image

Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CitySet Cities{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Cities As CitySet
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Create Property

ControlledApplication..::Create Property
CollapseAll image DropDown image

Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application Create{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

ControlledApplication Class
Autodesk.Revit Namespace


IsQuiescent Property

ControlledApplication..::IsQuiescent Property
CollapseAll image DropDown image

Returns if the current application is quiescent.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsQuiescent{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsQuiescent As Boolean
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in of the current application is in editing mode or the In-place famliy is being edited, it returns false. Otherwise, true will be returned.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


LoadedApplications Property

ControlledApplication..::LoadedApplications Property
CollapseAll image DropDown image

Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExternalApplicationArray LoadedApplications{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Options Property

ControlledApplication..::Options Property
CollapseAll image DropDown image

Provides access to an object that represents the application wide settings available in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application Options{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Options As Application
Visual C++
public:
property Application^ Options {
    Application^ get ();
}

Remarks

This property return the Revit Options object which exposes some of the options available in the Revit Options dialog available from the Settings, Options – menu.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


VersionBuild Property

ControlledApplication..::VersionBuild Property
CollapseAll image DropDown image

Returns the internal build number of the Revit applciation.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string VersionBuild{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VersionBuild As String
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correct against that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


VersionName Property

ControlledApplication..::VersionName Property
CollapseAll image DropDown image

Returns the name of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string VersionName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VersionName As String
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correct against that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


VersionNumber Property

ControlledApplication..::VersionNumber Property
CollapseAll image DropDown image

Return the primary version of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string VersionNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correct against that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ControlledApplication Events
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following events.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

See Also

ControlledApplication
Autodesk.Revit Namespace


OnDialogBox Event

ControlledApplication..::OnDialogBox Event
CollapseAll image DropDown image

Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometime a Revit dialog box may be displayed during an API command. By subscribing to this event you application will be notified of such an event and perform an action, such as causing the dialog to be ok'd or cancelled etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentClosed Event

ControlledApplication..::OnDocumentClosed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometime a document will be closed during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentNewed Event

ControlledApplication..::OnDocumentNewed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometime a new document will be created during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as create some elements for this document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentOpened Event

ControlledApplication..::OnDocumentOpened Event
CollapseAll image DropDown image

Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometime a document will be opened during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as get some elements from the opened document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentSaved Event

ControlledApplication..::OnDocumentSaved Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometime a document will be saved during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentSavedAs Event

ControlledApplication..::OnDocumentSavedAs Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometime a document will be saved to a file with another name during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Document Class
See Also Members
CollapseAll image DropDown image

An object that represents an open Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("83412177-A17B-4a14-A51A-D4888EE6F4DD")]
public class Document : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("83412177-A17B-4a14-A51A-D4888EE6F4DD")> _
Public Class Document _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"83412177-A17B-4a14-A51A-D4888EE6F4DD")]
public ref class Document : public APIObject

Remarks

The Document object represents an Autodesk Revit project. Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the Application object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Document

See Also

Document Members
Autodesk.Revit Namespace


Document Members
See Also Methods Properties Constructors Events
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DocumentDocumentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AbortTransaction | Abort a transaction for specified document.
Public method | Array | Overloaded.
Public method | ArrayWithoutAssociate | Overloaded.
Public method | BeginTransaction | Overloaded.
Public method | Close | Overloaded.
Public method | Delete | Overloaded.
Public method | EndTransaction | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Overloaded.
Public method | LoadFamily | Overloaded.
Public method | LoadFamilySymbol | Overloaded.
Public method | Mirror | Overloaded.
Public method | Move | Overloaded.
Public method | Print | Overloaded.
Public method | Rotate | Overloaded.
Public method | Save | Overloaded.
Public method | SaveAs | Overloaded.
Public method | ShowElements | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Public property | BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
Public property | ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
Public property | DeckProfiles | Returns an object that contains all of the avaible deck profiles currently loaded to this project.
Public property | DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | ElectricalEquipmentTypes | Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.
Public property | Element | Overloaded.
Public property | Elements | Overloaded.
Public property | FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
Public property | FilterTypeSupported | Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.
Public property | FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
Public property | GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
Public property | GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
Public property | IsModified | Reports if the document has been modified since it was last saved.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
Public property | IsWorkshared | Identifies if worksets have been enabled in the document.
Public property | LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
Public property | LightingDeviceTypes | Returns an object that contains all of the avaible lighting device types currently loaded to this project.
Public property | LightingFixtureTypes | Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.
Public property | MechanicalEquipmentTypes | Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | Call this function to get the fully qualified path of the document's disk file.
Public property | Phases | Retrieves all the object that represent phases within the project.
Public property | PlanTopologies | Overloaded.
Public property | PlanTopology | Overloaded.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | PrintSettings | Retrieve all Print Settings of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ProjectUnit | Provides access to Project Unit Setting with in the document.
Public property | ReactionsAreUpToDate | Reports whether the reactionary loads have changed.
Public property | RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
Public property | RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
Public property | RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
Public property | RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
Public property | RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
Public property | RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | Selection | Retrieve the currently selected Elements in Autodesk Revit.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
Public property | SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
Public property | TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Public property | Title | Call this function to get the project's title, which is usually derived from the project's filename.
Public property | TitleBlocks | Titleblocks currently loaded into the document.
Public property | TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
Public property | TypeOfStorage | Get the storage type of the specified builtin parameter.
Public property | ViewSheetSets | The view sheet sets stored in the document.
Public property | WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
Public property | WorksharingCentralFilename | The name and path of the central file name for a workshared document.

Public Events

 | Name | Description
Public event | OnClose | Subscribe to the OnClose event to be notified before the current document is closed.
Public event | OnSave | Subscribe to the OnSave event to be notified before a document has been saved.
Public event | OnSaveAs | Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

See Also

Document
Autodesk.Revit Namespace


Document Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Document ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Document Class
Autodesk.Revit Namespace


Document Methods
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AbortTransaction | Abort a transaction for specified document.
Public method | Array | Overloaded.
Public method | ArrayWithoutAssociate | Overloaded.
Public method | BeginTransaction | Overloaded.
Public method | Close | Overloaded.
Public method | Delete | Overloaded.
Public method | EndTransaction | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Overloaded.
Public method | LoadFamily | Overloaded.
Public method | LoadFamilySymbol | Overloaded.
Public method | Mirror | Overloaded.
Public method | Move | Overloaded.
Public method | Print | Overloaded.
Public method | Rotate | Overloaded.
Public method | Save | Overloaded.
Public method | SaveAs | Overloaded.
Public method | ShowElements | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Document
Autodesk.Revit Namespace


AbortTransaction Method

Document..::AbortTransaction Method
CollapseAll image DropDown image

Abort a transaction for specified document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AbortTransaction()
Visual Basic (Declaration)
Public Sub AbortTransaction
Visual C++
public:
void AbortTransaction ()

Remarks

All the operations after last BeginTransaction will be abandoned if Abort is called.

See Also

Document Class
Autodesk.Revit Namespace


Array Method

Document..::Array Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Array(Element, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | Array(Element, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.
Public method | Array(ElementId%, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | Array(ElementId%, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.
Public method | Array(ElementIdSet, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | Array(ElementIdSet, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.
Public method | Array(ElementSet, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | Array(ElementSet, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Array Method (Element, Int32, Boolean, XYZ)

Document..::Array Method (Element, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinearArray Array(
    Element element,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array (
    Element^ element,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

element
Element
The element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


Array Method (Element, Int32, Boolean, Double)

Document..::Array Method (Element, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RadialArray Array(
    Element element,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array (
    Element^ element,
    int number,
    bool moveToLast,
    double angle
)

Parameters

element
Element
The element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


Array Method (ElementId, Int32, Boolean, XYZ)

Document..::Array Method (ElementId%, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinearArray Array(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array (
    ElementId% elementId,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementId
ElementId %
The id for an element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


Array Method (ElementId, Int32, Boolean, Double)

Document..::Array Method (ElementId%, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RadialArray Array(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array (
    ElementId% elementId,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementId
ElementId %
The id for an element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


Array Method (ElementIdSet, Int32, Boolean, XYZ)

Document..::Array Method (ElementIdSet, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinearArray Array(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array (
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementIds
ElementIdSet
A set of ids for elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


Array Method (ElementIdSet, Int32, Boolean, Double)

Document..::Array Method (ElementIdSet, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RadialArray Array(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array (
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementIds
ElementIdSet
A set of ids for elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


Array Method (ElementSet, Int32, Boolean, XYZ)

Document..::Array Method (ElementSet, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinearArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array (
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
ElementSet
A set of elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


Array Method (ElementSet, Int32, Boolean, Double)

Document..::Array Method (ElementSet, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RadialArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array (
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
ElementSet
A set of elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method

Document..::ArrayWithoutAssociate Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ArrayWithoutAssociate(Element, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | ArrayWithoutAssociate(Element, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.
Public method | ArrayWithoutAssociate(ElementId%, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | ArrayWithoutAssociate(ElementId%, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.
Public method | ArrayWithoutAssociate(ElementIdSet, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | ArrayWithoutAssociate(ElementIdSet, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.
Public method | ArrayWithoutAssociate(ElementSet, Int32, Boolean, XYZ) | Array one or several elements within the project by a specified number.
Public method | ArrayWithoutAssociate(ElementSet, Int32, Boolean, Double) | Array one or several elements within the project by a specified number of degree.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (Element, Int32, Boolean, XYZ)

Document..::ArrayWithoutAssociate Method (Element, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    Element^ element,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

element
Element
The element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (Element, Int32, Boolean, Double)

Document..::ArrayWithoutAssociate Method (Element, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    Element^ element,
    int number,
    bool moveToLast,
    double angle
)

Parameters

element
Element
The element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementId, Int32, Boolean, XYZ)

Document..::ArrayWithoutAssociate Method (ElementId%, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    ElementId% elementId,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementId
ElementId %
The id for an element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementId, Int32, Boolean, Double)

Document..::ArrayWithoutAssociate Method (ElementId%, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    ElementId% elementId,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementId
ElementId %
The id for an element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, XYZ)

Document..::ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementIds
ElementIdSet
A set of ids for elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, Double)

Document..::ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementIds
ElementIdSet
A set of ids for elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, XYZ)

Document..::ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
ElementSet
A set of elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, Double)

Document..::ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, Double)
See Also
CollapseAll image DropDown image

Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
ElementSet
A set of elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace


BeginTransaction Method

Document..::BeginTransaction Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | BeginTransaction()() | Begins a transaction for the following operations.
Public method | BeginTransaction(PostedErrorArray) | Begins a transaction for the following operations.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


BeginTransaction Method

Document..::BeginTransaction Method
CollapseAll image DropDown image

Begins a transaction for the following operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool BeginTransaction()
Visual Basic (Declaration)
Public Function BeginTransaction As Boolean
Visual C++
public:
bool BeginTransaction ()

Return Value

true is returned if the transaction is started successfully, otherwise false will be returned.

Remarks

To begin a new transaction before a series of operation can ensure all the following operations will be done in same transaction, which can avoid inconsistency.

See Also

Document Class
Autodesk.Revit Namespace


BeginTransaction Method (PostedErrorArray)

Document..::BeginTransaction Method (PostedErrorArray)
See Also
CollapseAll image DropDown image

Begins a transaction for the following operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool BeginTransaction(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function BeginTransaction ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool BeginTransaction (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

true is returned if the transaction is started successfully, otherwise false will be returned.

Remarks

To begin a new transaction before a series of operation can ensure all the following operations will be done in same transaction, which can avoid inconsistency.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


Close Method

Document..::Close Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Close()() | Close the document.
Public method | Close(Boolean) | Close the document.
Public method | Close(PostedErrorArray) | Close the document.
Public method | Close(Boolean, PostedErrorArray) | Close the document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Close Method

Document..::Close Method
CollapseAll image DropDown image

Close the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Close()
Visual Basic (Declaration)
Public Function Close As Boolean
Visual C++
public:
bool Close ()

Return Value

Returns false if Save operations fails. Otherwise, returns true.

Remarks

Before the document is closed, the changes will be saved firstly.

See Also

Document Class
Autodesk.Revit Namespace


Close Method (Boolean)

Document..::Close Method (Boolean)
See Also
CollapseAll image DropDown image

Close the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Close(
    bool saveModified
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean _
) As Boolean
Visual C++
public:
bool Close (
    bool saveModified
)

Parameters

saveModified
Boolean
Indicates if the current document should be saved before close operation.

Return Value

Returns false if bSaveBeforeClose is set to true, but Save returns false. Otherwise, returns true.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return false.

See Also

Document Class
Autodesk.Revit Namespace


Close Method (PostedErrorArray)

Document..::Close Method (PostedErrorArray)
See Also
CollapseAll image DropDown image

Close the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Close(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if Save operations fails. Otherwise, returns true.

Remarks

Before the document is closed, the changes will be saved firstly.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


Close Method (Boolean, PostedErrorArray)

Document..::Close Method (Boolean, PostedErrorArray)
See Also
CollapseAll image DropDown image

Close the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Close(
    bool saveModified,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close (
    bool saveModified,
    PostedErrorArray^ postedErrors
)

Parameters

saveModified
Boolean
Indicates if the current document should be saved before close operation.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if bSaveBeforeClose is set to true, but Save returns false. Otherwise, returns true.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return false.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


Delete Method

Document..::Delete Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Delete(Element) | Delete an element from the project.
Public method | Delete(ElementId%) | Delete an element from the project given the id of that element.
Public method | Delete(ElementIdSet) | Delete several elements from the project given their ids.
Public method | Delete(ElementSet) | Delete several elements from the project.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Delete Method (Element)

Document..::Delete Method (Element)
See Also
CollapseAll image DropDown image

Delete an element from the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    Element element
)
Visual Basic (Declaration)
Public Function Delete ( _
    element As Element _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    Element^ element
)

Parameters

element
Element
The element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace


Delete Method (ElementId)

Document..::Delete Method (ElementId%)
See Also
CollapseAll image DropDown image

Delete an element from the project given the id of that element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    ref ElementId id
)
Visual Basic (Declaration)
Public Function Delete ( _
    ByRef id As ElementId _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    ElementId% id
)

Parameters

id
ElementId %
The ElementId for the element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace


Delete Method (ElementIdSet)

Document..::Delete Method (ElementIdSet)
See Also
CollapseAll image DropDown image

Delete several elements from the project given their ids.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    ElementIdSet ids
)
Visual Basic (Declaration)
Public Function Delete ( _
    ids As ElementIdSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    ElementIdSet^ ids
)

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace


Delete Method (ElementSet)

Document..::Delete Method (ElementSet)
See Also
CollapseAll image DropDown image

Delete several elements from the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function Delete ( _
    elements As ElementSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    ElementSet^ elements
)

Parameters

elements
ElementSet
A set of elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace


EndTransaction Method

Document..::EndTransaction Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | EndTransaction()() | Ends a transaction for specified document.
Public method | EndTransaction(PostedErrorArray) | Ends a transaction for specified document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


EndTransaction Method

Document..::EndTransaction Method
CollapseAll image DropDown image

Ends a transaction for specified document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool EndTransaction()
Visual Basic (Declaration)
Public Function EndTransaction As Boolean
Visual C++
public:
bool EndTransaction ()

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

See Also

Document Class
Autodesk.Revit Namespace


EndTransaction Method (PostedErrorArray)

Document..::EndTransaction Method (PostedErrorArray)
See Also
CollapseAll image DropDown image

Ends a transaction for specified document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool EndTransaction(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function EndTransaction ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool EndTransaction (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


Export Method

Document..::Export Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Export(String, String, GBXMLExportOptions) | Exports the current model in Green-Building XML format.
Public method | Export(String, String, ViewSet, DWF2DExportOptions) | Exports the current view or a selection of views in DWF-2D format.
Public method | Export(String, String, ViewSet, DWF3DExportOptions) | Exports the current view or a selection of views in DWF-3D format.
Public method | Export(String, String, ViewSet, DWFX2DExportOptions) | Exports the current view or a selection of views in DWFX-2D format.
Public method | Export(String, String, ViewSet, DWFX3DExportOptions) | Exports the current view or a selection of views in DWFX-3D format.
Public method | Export(String, String, ViewSet, DWGExportOptions) | Exports the current view or a selection of views in DWG format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the current model in 3D-Studio Max (FBX) format.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Export Method (String, String, GBXMLExportOptions)

Document..::Export Method (String, String, GBXMLExportOptions)
See Also
CollapseAll image DropDown image

Exports the current model in Green-Building XML format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    options As GBXMLExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
options
GBXMLExportOptions
Options applicable to the dbXML format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be null).

See Also

Document Class
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWF2DExportOptions)

Document..::Export Method (String, String, ViewSet, DWF2DExportOptions)
See Also
CollapseAll image DropDown image

Exports the current view or a selection of views in DWF-2D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWF2DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWF2DExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWF2DExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
Selection of views to be exported. If nullptr or empty, only the active view will be exported.
options
DWF2DExportOptions
Various options applicable to the DWF format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWF3DExportOptions)

Document..::Export Method (String, String, ViewSet, DWF3DExportOptions)
See Also
CollapseAll image DropDown image

Exports the current view or a selection of views in DWF-3D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWF3DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWF3DExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWF3DExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
Selection of 3D views to be exported. If nullptr or empty, only the active 3D view will be exported.
options
DWF3DExportOptions
Various options applicable to the DWF format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be 3D views in order for the Export to succeed.

See Also

Document Class
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWFX2DExportOptions)

Document..::Export Method (String, String, ViewSet, DWFX2DExportOptions)
See Also
CollapseAll image DropDown image

Exports the current view or a selection of views in DWFX-2D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFX2DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFX2DExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFX2DExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
Selection of views to be exported. If nullptr or empty, only the active view will be exported.
options
DWFX2DExportOptions
Various options applicable to the DWFX format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWFX3DExportOptions)

Document..::Export Method (String, String, ViewSet, DWFX3DExportOptions)
See Also
CollapseAll image DropDown image

Exports the current view or a selection of views in DWFX-3D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFX3DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFX3DExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFX3DExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
Selection of 3D views to be exported. If nullptr or empty, only the active 3D view will be exported.
options
DWFX3DExportOptions
Various options applicable to the DWFX format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be 3D views in order for the Export to succeed.

See Also

Document Class
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWGExportOptions)

Document..::Export Method (String, String, ViewSet, DWGExportOptions)
See Also
CollapseAll image DropDown image

Exports the current view or a selection of views in DWG format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWGExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWGExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWGExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
Selection of views to be exported. If nullptr or empty, only the active view will be exported.
options
DWGExportOptions
Various options applicable to the DWG format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, FBXExportOptions)

Document..::Export Method (String, String, ViewSet, FBXExportOptions)
See Also
CollapseAll image DropDown image

Exports the current model in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As FBXExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
options
FBXExportOptions
Options applicable to the FBX format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be null).

See Also

Document Class
Autodesk.Revit Namespace


Import Method

Document..::Import Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Import(String, DWGImportOptions, Element%) | Imports a DWG file into Revit.
Public method | Import(String, ImageImportOptions, Element%) | Imports an image (a bitmap) into Revit.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Import Method (String, DWGImportOptions, Element)

Document..::Import Method (String, DWGImportOptions, Element%)
See Also
CollapseAll image DropDown image

Imports a DWG file into Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Import(
    string file,
    DWGImportOptions options,
    ref Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As DWGImportOptions, _
    ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import (
    String^ file,
    DWGImportOptions^ options,
    Element^% element
)

Parameters

file
String
Full path of the file to import. File must exist.
options
DWGImportOptions
Various options applicable to the DWG format. If nullptr, all options will be set to their respective default values.
element
Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

See Also

Document Class
Autodesk.Revit Namespace


Import Method (String, ImageImportOptions, Element)

Document..::Import Method (String, ImageImportOptions, Element%)
See Also
CollapseAll image DropDown image

Imports an image (a bitmap) into Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Import(
    string file,
    ImageImportOptions options,
    ref Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As ImageImportOptions, _
    ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import (
    String^ file,
    ImageImportOptions^ options,
    Element^% element
)

Parameters

file
String
Full path of the file to import. File must exist.
options
ImageImportOptions
Various options applicable to an image. If nullptr, all options will be set to their respective default values.
element
Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

See Also

Document Class
Autodesk.Revit Namespace


LoadFamily Method

Document..::LoadFamily Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the project.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the project and provides a reference to the loaded family.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


LoadFamily Method (String)

Document..::LoadFamily Method (String)
See Also
CollapseAll image DropDown image

Loads an entire family and all its types/symbols into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool LoadFamily(
    string filename
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String _
) As Boolean
Visual C++
public:
bool LoadFamily (
    String^ filename
)

Parameters

filename
String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

Returns True if the entire family was loaded successfully into the project, otherwise false.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

See Also

Document Class
Autodesk.Revit Namespace


LoadFamily Method (String, Family)

Document..::LoadFamily Method (String, Family%)
See Also
CollapseAll image DropDown image

Loads an entire family and all its types/symbols into the project and provides a reference to the loaded family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool LoadFamily(
    string filename,
    ref Family family
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String, _
    ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily (
    String^ filename,
    Family^% family
)

Parameters

filename
String
The fully qualified filename of the Family file, usually ending in .rfa.
family
Family %
A reference to the family that was loaded if successful, otherwise Nothing.

Return Value

Returns True if the entire family was loaded successfully into the project, otherwise false.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

See Also

Document Class
Autodesk.Revit Namespace


LoadFamilySymbol Method

Document..::LoadFamilySymbol Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | LoadFamilySymbol(String, String) | Loads only the specified family type/symbol from a family file into the project.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the project and provides a reference to the loaded family symbol.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


LoadFamilySymbol Method (String, String)

Document..::LoadFamilySymbol Method (String, String)
See Also
CollapseAll image DropDown image

Loads only the specified family type/symbol from a family file into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol (
    String^ filename,
    String^ name
)

Parameters

filename
String
The fully qualified filename of the Family file, usually ending in .rfa.
name
String
The name of the type/symbol to be loaded, such as "W11x14".

Return Value

Returns True if the family type/symbol was loaded successfully into the project, otherwise false.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

See Also

Document Class
Autodesk.Revit Namespace


LoadFamilySymbol Method (String, String, FamilySymbol)

Document..::LoadFamilySymbol Method (String, String, FamilySymbol%)
See Also
CollapseAll image DropDown image

Loads only the specified family type/symbol from a family file into the project and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    ref FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol (
    String^ filename,
    String^ name,
    FamilySymbol^% symbol
)

Parameters

filename
String
The fully qualified filename of the Family file, usually ending in .rfa.
name
String
The name of the type/symbol to be loaded, such as "W11x14".
symbol
FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

Returns True if the family type/symbol was loaded successfully into the project, otherwise false.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

See Also

Document Class
Autodesk.Revit Namespace


Mirror Method

Document..::Mirror Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Mirror(Element, Reference) | Mirror one or several elements by a reference.
Public method | Mirror(ElementId%, Reference) | Mirror one or several elements by a reference.
Public method | Mirror(ElementIdSet, Reference) | Mirror one or several elements by a reference.
Public method | Mirror(ElementSet, Line) | Mirror one or several elements by a line.
Public method | Mirror(ElementSet, Reference) | Mirror one or several elements by a reference.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Mirror Method (Element, Reference)

Document..::Mirror Method (Element, Reference)
See Also
CollapseAll image DropDown image

Mirror one or several elements by a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Mirror(
    Element element,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    element As Element, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror (
    Element^ element,
    Reference^ reference
)

Parameters

element
Element
A element that is to be mirrored.
reference
Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Autodesk.Revit Namespace


Mirror Method (ElementId, Reference)

Document..::Mirror Method (ElementId%, Reference)
See Also
CollapseAll image DropDown image

Mirror one or several elements by a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Mirror(
    ref ElementId id,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ByRef id As ElementId, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror (
    ElementId% id,
    Reference^ reference
)

Parameters

id
ElementId %
The ElementId for the element that is to be mirrored.
reference
Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Autodesk.Revit Namespace


Mirror Method (ElementIdSet, Reference)

Document..::Mirror Method (ElementIdSet, Reference)
See Also
CollapseAll image DropDown image

Mirror one or several elements by a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Mirror(
    ElementIdSet ids,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ids As ElementIdSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror (
    ElementIdSet^ ids,
    Reference^ reference
)

Parameters

ids
ElementIdSet
A set of elements that are to be mirrored.
reference
Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Autodesk.Revit Namespace


Mirror Method (ElementSet, Line)

Document..::Mirror Method (ElementSet, Line)
See Also
CollapseAll image DropDown image

Mirror one or several elements by a line.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Line line
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    line As Line _
) As Boolean
Visual C++
public:
bool Mirror (
    ElementSet^ elements,
    Line^ line
)

Parameters

elements
ElementSet
A set of elements that are to be mirrored.
line
Line
The line by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Autodesk.Revit Namespace


Mirror Method (ElementSet, Reference)

Document..::Mirror Method (ElementSet, Reference)
See Also
CollapseAll image DropDown image

Mirror one or several elements by a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror (
    ElementSet^ elements,
    Reference^ reference
)

Parameters

elements
ElementSet
A set of elements that are to be mirrored.
reference
Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Autodesk.Revit Namespace


Move Method

Document..::Move Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Move(Element, XYZ) | Move an element within the project by a specified vector.
Public method | Move(ElementId%, XYZ) | Move an element, specified by id, within the project by a specified vector.
Public method | Move(ElementIdSet, XYZ) | Move several elements, specified by a set of ids within the project by a specified vector.
Public method | Move(ElementSet, XYZ) | Move several elements within the project by a specified vector.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Move Method (Element, XYZ)

Document..::Move Method (Element, XYZ)
See Also
CollapseAll image DropDown image

Move an element within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    Element element,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    element As Element, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    Element^ element,
    XYZ^ translationVec
)

Parameters

element
Element
The element that is to be moved.
translationVec
XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is level, all the elements on that level will also be moved.

See Also

Document Class
Autodesk.Revit Namespace


Move Method (ElementId, XYZ)

Document..::Move Method (ElementId%, XYZ)
See Also
CollapseAll image DropDown image

Move an element, specified by id, within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    ref ElementId id,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ByRef id As ElementId, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    ElementId% id,
    XYZ^ translationVec
)

Parameters

id
ElementId %
The ElementId for the element that is to be moved.
translationVec
XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

See Also

Document Class
Autodesk.Revit Namespace


Move Method (ElementIdSet, XYZ)

Document..::Move Method (ElementIdSet, XYZ)
See Also
CollapseAll image DropDown image

Move several elements, specified by a set of ids within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    ElementIdSet ids,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ids As ElementIdSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    ElementIdSet^ ids,
    XYZ^ translationVec
)

Parameters

ids
ElementIdSet
A set of element ids specifying which elements are to be moved.
translationVec
XYZ
The vector by which the elements are to be moved.

Return Value

If the elements are moved successfully then the method returns True, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved, for example: if the elements are structural columns, all the beams joined to those columns will also be moved or resized.

See Also

Document Class
Autodesk.Revit Namespace


Move Method (ElementSet, XYZ)

Document..::Move Method (ElementSet, XYZ)
See Also
CollapseAll image DropDown image

Move several elements within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    ElementSet elements,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    elements As ElementSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    ElementSet^ elements,
    XYZ^ translationVec
)

Parameters

elements
ElementSet
A set of element which are to be moved.
translationVec
XYZ
The vector by which the elements are to be moved.

Return Value

If the elements are moved successfully then the method returns True, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved, for example: if the elements are floors, the openings within those floors will also be moved.

See Also

Document Class
Autodesk.Revit Namespace


Print Method

Document..::Print Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Print(ViewSet) | Print a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Print a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Print a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Print a set of views with a specified view template and default print settings.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Print Method (ViewSet)

Document..::Print Method (ViewSet)
See Also
CollapseAll image DropDown image

Print a set of views with default view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    ViewSet views
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet _
)
Visual C++
public:
void Print (
    ViewSet^ views
)

Parameters

views
ViewSet
The set of views which need to be printed.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown out.

See Also

Document Class
Autodesk.Revit Namespace


Print Method (ViewSet, View)

Document..::Print Method (ViewSet, View)
See Also
CollapseAll image DropDown image

Print a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View _
)
Visual C++
public:
void Print (
    ViewSet^ views,
    View^ viewTemplate
)

Parameters

views
ViewSet
The set of views which need to be printed.
viewTemplate
View
The view template which apply to the set of views.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown out.

See Also

Document Class
Autodesk.Revit Namespace


Print Method (ViewSet, Boolean)

Document..::Print Method (ViewSet, Boolean)
See Also
CollapseAll image DropDown image

Print a set of views with default view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    ViewSet views,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print (
    ViewSet^ views,
    bool useCurrentPrintSettings
)

Parameters

views
ViewSet
The set of views which need to be printed.
useCurrentPrintSettings
Boolean
If true, print the view with the current print setting ,otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown out.

See Also

Document Class
Autodesk.Revit Namespace


Print Method (ViewSet, View, Boolean)

Document..::Print Method (ViewSet, View, Boolean)
See Also
CollapseAll image DropDown image

Print a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print (
    ViewSet^ views,
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

views
ViewSet
The set of views which need to be printed.
viewTemplate
View
The view template which apply to the set of views.
useCurrentPrintSettings
Boolean
If true, print the view with the current print setting ,otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown out.

See Also

Document Class
Autodesk.Revit Namespace


Rotate Method

Document..::Rotate Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Rotate(Element, Line, Double) | Rotate an element within the project by a specified number of degrees around a given axis.
Public method | Rotate(ElementId%, Line, Double) | Rotate an element, specified by id, within the project by a specified number of degrees around a given axis.
Public method | Rotate(ElementIdSet, Line, Double) | Rotate several elements, specified by a set of ids, within the project by a specified number of degrees around a given axis.
Public method | Rotate(ElementSet, Line, Double) | Rotate several elements within the project by a specified number of degrees around a given axis.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Rotate Method (Element, Line, Double)

Document..::Rotate Method (Element, Line, Double)
See Also
CollapseAll image DropDown image

Rotate an element within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rotate(
    Element element,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    element As Element, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate (
    Element^ element,
    Line^ axis,
    double angle
)

Parameters

element
Element
The element that is to be rotated.
axis
Line
An unbounded line that represents the axis of rotation.
angle
Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Autodesk.Revit Namespace


Rotate Method (ElementId, Line, Double)

Document..::Rotate Method (ElementId%, Line, Double)
See Also
CollapseAll image DropDown image

Rotate an element, specified by id, within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rotate(
    ref ElementId id,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    ByRef id As ElementId, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate (
    ElementId% id,
    Line^ axis,
    double angle
)

Parameters

id
ElementId %
The ElementId for the element that is to be rotated.
axis
Line
An unbounded line that represents the axis of rotation.
angle
Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Autodesk.Revit Namespace


Rotate Method (ElementIdSet, Line, Double)

Document..::Rotate Method (ElementIdSet, Line, Double)
See Also
CollapseAll image DropDown image

Rotate several elements, specified by a set of ids, within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rotate(
    ElementIdSet ids,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    ids As ElementIdSet, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate (
    ElementIdSet^ ids,
    Line^ axis,
    double angle
)

Parameters

ids
ElementIdSet
The set of ids for the elements that are to be rotated.
axis
Line
An unbounded line that represents the axis of rotation.
angle
Double
The number of degrees, in radians, by which the elements are to be rotated around the specified axis.

Return Value

If the elements are rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Autodesk.Revit Namespace


Rotate Method (ElementSet, Line, Double)

Document..::Rotate Method (ElementSet, Line, Double)
See Also
CollapseAll image DropDown image

Rotate several elements within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rotate(
    ElementSet elements,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    elements As ElementSet, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate (
    ElementSet^ elements,
    Line^ axis,
    double angle
)

Parameters

elements
ElementSet
A set of elements that are to be rotated.
axis
Line
An unbounded line that represents the axis of rotation.
angle
Double
The number of degrees, in radians, by which the elements are to be rotated around the specified axis.

Return Value

If the elements are rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Autodesk.Revit Namespace


Save Method

Document..::Save Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Save()() | Save the changes for the document.
Public method | Save(PostedErrorArray) | Save the changes for the document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Save Method

Document..::Save Method
CollapseAll image DropDown image

Save the changes for the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save ()

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

See Also

Document Class
Autodesk.Revit Namespace


Save Method (PostedErrorArray)

Document..::Save Method (PostedErrorArray)
See Also
CollapseAll image DropDown image

Save the changes for the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Save(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Save ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Save (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


SaveAs Method

Document..::SaveAs Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | SaveAs()() | Save the document to another file with the specified name.
Public method | SaveAs(String) | Save the document to another file with the specified name.
Public method | SaveAs(PostedErrorArray) | Save the document to another file with the specified name.
Public method | SaveAs(String, PostedErrorArray) | Save the document to another file with the specified name.
Public method | SaveAs(String, Boolean) | Save the document to another file with the specified name.
Public method | SaveAs(String, Boolean, PostedErrorArray) | Save the document to another file with the specified name.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


SaveAs Method

Document..::SaveAs Method
CollapseAll image DropDown image

Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs()
Visual Basic (Declaration)
Public Function SaveAs As Boolean
Visual C++
public:
bool SaveAs ()

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

See Also

Document Class
Autodesk.Revit Namespace


SaveAs Method (String)

Document..::SaveAs Method (String)
See Also
CollapseAll image DropDown image

Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName
)

Parameters

fileName
String
File name to be saved as.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

None.

See Also

Document Class
Autodesk.Revit Namespace


SaveAs Method (PostedErrorArray)

Document..::SaveAs Method (PostedErrorArray)
See Also
CollapseAll image DropDown image

Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


SaveAs Method (String, PostedErrorArray)

Document..::SaveAs Method (String, PostedErrorArray)
See Also
CollapseAll image DropDown image

Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
String
File name to be saved as.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


SaveAs Method (String, Boolean)

Document..::SaveAs Method (String, Boolean)
See Also
CollapseAll image DropDown image

Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName,
    bool changeDocumentFilename
)

Parameters

fileName
String
File name to be saved as.
changeDocumentFilename
Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

None.

See Also

Document Class
Autodesk.Revit Namespace


SaveAs Method (String, Boolean, PostedErrorArray)

Document..::SaveAs Method (String, Boolean, PostedErrorArray)
See Also
CollapseAll image DropDown image

Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName,
    bool changeDocumentFilename,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
String
File name to be saved as.
changeDocumentFilename
Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace


ShowElements Method

Document..::ShowElements Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ShowElements(Element) | Shows the element by zoom to fit.
Public method | ShowElements(ElementId%) | Shows the element by zoom to fit.
Public method | ShowElements(ElementIdSet) | Shows the elements by zoom to fit.
Public method | ShowElements(ElementSet) | Shows the elements by zoom to fit.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


ShowElements Method (Element)

Document..::ShowElements Method (Element)
See Also
CollapseAll image DropDown image

Shows the element by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ShowElements(
    Element element
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    element As Element _
)
Visual C++
public:
void ShowElements (
    Element^ element
)

Parameters

element
Element
Element that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

Document Class
Autodesk.Revit Namespace


ShowElements Method (ElementId)

Document..::ShowElements Method (ElementId%)
See Also
CollapseAll image DropDown image

Shows the element by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ShowElements(
    ref ElementId elementId
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    ByRef elementId As ElementId _
)
Visual C++
public:
void ShowElements (
    ElementId% elementId
)

Parameters

elementId
ElementId %
Element id that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

Document Class
Autodesk.Revit Namespace


ShowElements Method (ElementIdSet)

Document..::ShowElements Method (ElementIdSet)
See Also
CollapseAll image DropDown image

Shows the elements by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ShowElements(
    ElementIdSet elementIds
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elementIds As ElementIdSet _
)
Visual C++
public:
void ShowElements (
    ElementIdSet^ elementIds
)

Parameters

elementIds
ElementIdSet
The set of element ids which will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

Document Class
Autodesk.Revit Namespace


ShowElements Method (ElementSet)

Document..::ShowElements Method (ElementSet)
See Also
CollapseAll image DropDown image

Shows the elements by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ShowElements(
    ElementSet elements
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elements As ElementSet _
)
Visual C++
public:
void ShowElements (
    ElementSet^ elements
)

Parameters

elements
ElementSet
The set of elements that will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

Document Class
Autodesk.Revit Namespace


Document Properties
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Public property | BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
Public property | ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
Public property | DeckProfiles | Returns an object that contains all of the avaible deck profiles currently loaded to this project.
Public property | DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | ElectricalEquipmentTypes | Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.
Public property | Element | Overloaded.
Public property | Elements | Overloaded.
Public property | FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
Public property | FilterTypeSupported | Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.
Public property | FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
Public property | GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
Public property | GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
Public property | IsModified | Reports if the document has been modified since it was last saved.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
Public property | IsWorkshared | Identifies if worksets have been enabled in the document.
Public property | LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
Public property | LightingDeviceTypes | Returns an object that contains all of the avaible lighting device types currently loaded to this project.
Public property | LightingFixtureTypes | Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.
Public property | MechanicalEquipmentTypes | Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | Call this function to get the fully qualified path of the document's disk file.
Public property | Phases | Retrieves all the object that represent phases within the project.
Public property | PlanTopologies | Overloaded.
Public property | PlanTopology | Overloaded.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | PrintSettings | Retrieve all Print Settings of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ProjectUnit | Provides access to Project Unit Setting with in the document.
Public property | ReactionsAreUpToDate | Reports whether the reactionary loads have changed.
Public property | RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
Public property | RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
Public property | RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
Public property | RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
Public property | RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
Public property | RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | Selection | Retrieve the currently selected Elements in Autodesk Revit.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
Public property | SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
Public property | TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Public property | Title | Call this function to get the project's title, which is usually derived from the project's filename.
Public property | TitleBlocks | Titleblocks currently loaded into the document.
Public property | TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
Public property | TypeOfStorage | Get the storage type of the specified builtin parameter.
Public property | ViewSheetSets | The view sheet sets stored in the document.
Public property | WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
Public property | WorksharingCentralFilename | The name and path of the central file name for a workshared document.

See Also

Document
Autodesk.Revit Namespace


ActiveProjectLocation Property

Document..::ActiveProjectLocation Property
CollapseAll image DropDown image

Retrieve the active project location.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocation ActiveProjectLocation{ get; set;}
Visual Basic (Declaration)
Public Property ActiveProjectLocation As ProjectLocation
Visual C++
public:
property ProjectLocation^ ActiveProjectLocation {
    ProjectLocation^ get ();
    void set (ProjectLocation^ value);
}

Remarks

Getting this property returns the currently active project location that the user is currently working with. Setting this property can be used to change the active project location.

See Also

Document Class
Autodesk.Revit Namespace


ActiveView Property

Document..::ActiveView Property
CollapseAll image DropDown image

The document's active view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View ActiveView{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActiveView As View
Visual C++
public:
property View^ ActiveView {
    View^ get ();
}

Field Value

The active view is the view that last had focus in the UI. null if no view is considered active.

See Also

Document Class
Autodesk.Revit Namespace


AnnotationSymbolTypes Property

Document..::AnnotationSymbolTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the annotation types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbolTypeSet AnnotationSymbolTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AnnotationSymbolTypes As AnnotationSymbolTypeSet
Visual C++
public:
property AnnotationSymbolTypeSet^ AnnotationSymbolTypes {
    AnnotationSymbolTypeSet^ get ();
}

Remarks

This property returns a set of AnnotationSymbol objects. These objects can be used change the type of a Annotation from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


BeamSystemTypes Property

Document..::BeamSystemTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of beam system types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystemTypeSet BeamSystemTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BeamSystemTypes As BeamSystemTypeSet
Visual C++
public:
property BeamSystemTypeSet^ BeamSystemTypes {
    BeamSystemTypeSet^ get ();
}

Remarks

This property returns a set of BeamSystemType objects. These objects can be used change the type of a BeamSystem from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


ContFootingTypes Property

Document..::ContFootingTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of continuous footing types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ContFootingTypeSet ContFootingTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ContFootingTypes As ContFootingTypeSet
Visual C++
public:
property ContFootingTypeSet^ ContFootingTypes {
    ContFootingTypeSet^ get ();
}

Remarks

This property returns a set of ContFootingType objects. These objects can be used change the type of a ContFooting from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Create Property

Document..::Create Property
CollapseAll image DropDown image

An object that can be used to create new instances of Autodesk Revit API elements within a project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document Create{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Create As Document
Visual C++
public:
property Document^ Create {
    Document^ get ();
}

Field Value

This object is used to create new instances of project elements within the Autodesk Revit API, such as FamilyInstances or groups.

See Also

Document Class
Autodesk.Revit Namespace


CurtainSystemTypes Property

Document..::CurtainSystemTypes Property
CollapseAll image DropDown image

This property is used to retrieve all the CurtainSystem types in current system.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystemTypeSet CurtainSystemTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurtainSystemTypes As CurtainSystemTypeSet
Visual C++
public:
property CurtainSystemTypeSet^ CurtainSystemTypes {
    CurtainSystemTypeSet^ get ();
}

Remarks

This property returns a set of CurtainSystemType objects. These objects can be used change the type of a CurtainSystem from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


DeckProfiles Property

Document..::DeckProfiles Property
CollapseAll image DropDown image

Returns an object that contains all of the avaible deck profiles currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet DeckProfiles{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DeckProfiles As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ DeckProfiles {
    FamilySymbolSet^ get ();
}

Remarks

The DeckProfiles property returns an object that contains the deck profiles which can be used to change the profile of a layer within a compound structure object.

See Also

Document Class
Autodesk.Revit Namespace


DimensionTypes Property

Document..::DimensionTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of dimension types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DimensionTypeSet DimensionTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DimensionTypes As DimensionTypeSet
Visual C++
public:
property DimensionTypeSet^ DimensionTypes {
    DimensionTypeSet^ get ();
}

Remarks

This property returns a set of DimensionType objects. These objects can be used change the type of a Dimension from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


DisplayUnitSystem Property

Document..::DisplayUnitSystem Property
CollapseAll image DropDown image

Provides access to display unit type with in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DisplayUnit DisplayUnitSystem{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitSystem As DisplayUnit
Visual C++
public:
property DisplayUnit DisplayUnitSystem {
    DisplayUnit get ();
}

Remarks

Return the display unit type, metric or imperial.

See Also

Document Class
Autodesk.Revit Namespace


ElectricalEquipmentTypes Property

Document..::ElectricalEquipmentTypes Property
CollapseAll image DropDown image

Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet ElectricalEquipmentTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ElectricalEquipmentTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ ElectricalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The ElectricalEquipmentTypes property returns an object that contains the electrical equipment types which can be used to change the type of a electrical equipment from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Element Property

Document..::Element Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Element[([String])] | Retrieves the specified element from the Document.
Public property | Element[([ElementId%])] | Retrieves the specified element from the Document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Element Property (String)

Document..::Element Property (String)
See Also
CollapseAll image DropDown image

Retrieves the specified element from the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element[
    string
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
     As String _
) As Element
Visual C++
public:
property Element^ Element[String^ ] {
    Element^ get (String^ );
}

Parameters

String

Remarks

Returns the element corresponding to the unique id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the uniqueId does not exist then an empty reference will be returned.

See Also

Document Class
Autodesk.Revit Namespace


Element Property (ElementId)

Document..::Element Property (ElementId%)
See Also
CollapseAll image DropDown image

Retrieves the specified element from the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element[
    ref ElementId id
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
    ByRef id As ElementId _
) As Element
Visual C++
public:
property Element^ Element[ElementId% id] {
    Element^ get (ElementId% id);
}

Parameters

id
ElementId %
The ElementId of the element to be retrieved from the Document.

Remarks

Returns the element corresponding to the id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the ElementId does not exist then an empty reference will be returned.

See Also

Document Class
Autodesk.Revit Namespace


Elements Property

Document..::Elements Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Elements | Provides access to all elements within the Document.
Public property | Elements[([Type])] | Provides access to all elements of specified type within the Document.
Public property | Elements[([Filter])] | Provides access to all elements which satisfy specified filter within the Document.
Public property | Elements[([Type, ICollection<(Of <Element>)>])] |
Public property | Elements[([Filter, ICollection<(Of <Element>)>])] |

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Elements Property

Document..::Elements Property
CollapseAll image DropDown image

Provides access to all elements within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIterator Elements{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementIterator
Visual C++
public:
property ElementIterator^ Elements {
    ElementIterator^ get ();
}

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

See Also

Document Class
Autodesk.Revit Namespace


Elements Property (Type)

Document..::Elements Property (Type)
See Also
CollapseAll image DropDown image

Provides access to all elements of specified type within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIterator Elements[
    Type
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
     As Type _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Type^ ] {
    ElementIterator^ get (Type^ );
}

Parameters

Type

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements of specified type. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

See Also

Document Class
Autodesk.Revit Namespace


Elements Property (Filter)

Document..::Elements Property (Filter)
See Also
CollapseAll image DropDown image

Provides access to all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIterator Elements[
    Filter filter
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Filter^ filter] {
    ElementIterator^ get (Filter^ filter);
}

Parameters

filter
Filter
Filter specified by user.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter of Filter is null.

See Also

Document Class
Autodesk.Revit Namespace


Elements Property (Type, ICollection)

Document..::Elements Property (Type, ICollection<(Of <Element>)>)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Elements[
    Type type,
    ICollection<Element> collection
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    type As Type, _
    collection As ICollection(Of Element) _
) As Integer
Visual C++
public:
property int Elements[Type^ type, ICollection<Element^>^ collection] {
    int get (Type^ type, ICollection<Element^>^ collection);
}

Parameters

type
Type
collection
ICollection <(Of < Element >)>

See Also

Document Class
Autodesk.Revit Namespace


Elements Property (Filter, ICollection)

Document..::Elements Property (Filter, ICollection<(Of <Element>)>)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Elements[
    Filter filter,
    ICollection<Element> collection
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter, _
    collection As ICollection(Of Element) _
) As Integer
Visual C++
public:
property int Elements[Filter^ filter, ICollection<Element^>^ collection] {
    int get (Filter^ filter, ICollection<Element^>^ collection);
}

Parameters

filter
Filter
collection
ICollection <(Of < Element >)>

See Also

Document Class
Autodesk.Revit Namespace


FasciaTypes Property

Document..::FasciaTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the Fascia types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FasciaTypeSet FasciaTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FasciaTypes As FasciaTypeSet
Visual C++
public:
property FasciaTypeSet^ FasciaTypes {
    FasciaTypeSet^ get ();
}

Remarks

This property returns a set of FasciaType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


FilterTypeSupported Property

Document..::FilterTypeSupported Property
CollapseAll image DropDown image

Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool FilterTypeSupported[
    BuiltInParameter ,
    CriteriaFilterType
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FilterTypeSupported ( _
     As BuiltInParameter, _
     As CriteriaFilterType _
) As Boolean
Visual C++
public:
property bool FilterTypeSupported[BuiltInParameter , CriteriaFilterType ] {
    bool get (BuiltInParameter , CriteriaFilterType );
}

Parameters

BuiltInParameter
CriteriaFilterType

Remarks

This property is useful in element retrieval. It can be used to provide correct options of filter types for the FilterCriterion object.

See Also

Document Class
Autodesk.Revit Namespace


FloorTypes Property

Document..::FloorTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the floor types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FloorTypeSet FloorTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FloorTypes As FloorTypeSet
Visual C++
public:
property FloorTypeSet^ FloorTypes {
    FloorTypeSet^ get ();
}

Remarks

This property returns a set of FloorType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


GridTypes Property

Document..::GridTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of Grid types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GridTypeSet GridTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GridTypes As GridTypeSet
Visual C++
public:
property GridTypeSet^ GridTypes {
    GridTypeSet^ get ();
}

Remarks

This property returns a set of Grid objects. These objects can be used change the type of a Grid from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


GutterTypes Property

Document..::GutterTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the Gutter types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GutterTypeSet GutterTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GutterTypes As GutterTypeSet
Visual C++
public:
property GutterTypeSet^ GutterTypes {
    GutterTypeSet^ get ();
}

Remarks

This property returns a set of GutterType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


IsModified Property

Document..::IsModified Property
CollapseAll image DropDown image

Reports if the document has been modified since it was last saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsModified{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsModified As Boolean
Visual C++
public:
property bool IsModified {
    bool get ();
}

See Also

Document Class
Autodesk.Revit Namespace


IsReadOnlyFile Property

Document..::IsReadOnlyFile Property
CollapseAll image DropDown image

Signals whether the document was opened in read-only mode or not.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsReadOnlyFile{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnlyFile As Boolean
Visual C++
public:
property bool IsReadOnlyFile {
    bool get ();
}

Remarks

A document would be opened in read-only mode when, for example, at the time of opening it was already being used by another Revit user.

Although it is still possible to modify documents opened in read-only mode, any attempt to save them would naturally fail. Therefore any changes to the document would have to be saved using the SaveAs method.

See Also

Document Class
Autodesk.Revit Namespace


IsWorkshared Property

Document..::IsWorkshared Property
CollapseAll image DropDown image

Identifies if worksets have been enabled in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsWorkshared{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsWorkshared As Boolean
Visual C++
public:
property bool IsWorkshared {
    bool get ();
}

Field Value

True if the document is using worksets, false if it is working with a local file.

See Also

Document Class
Autodesk.Revit Namespace


LevelTypes Property

Document..::LevelTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the level types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LevelTypeSet LevelTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LevelTypes As LevelTypeSet
Visual C++
public:
property LevelTypeSet^ LevelTypes {
    LevelTypeSet^ get ();
}

Remarks

This property returns a set of level objects. These objects can be used change the type of a level from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


LightingDeviceTypes Property

Document..::LightingDeviceTypes Property
CollapseAll image DropDown image

Returns an object that contains all of the avaible lighting device types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet LightingDeviceTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LightingDeviceTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ LightingDeviceTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingDeviceTypes property returns an object that contains the lighting device types which can be used to change the type of a lighting device from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


LightingFixtureTypes Property

Document..::LightingFixtureTypes Property
CollapseAll image DropDown image

Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet LightingFixtureTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LightingFixtureTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ LightingFixtureTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingFixtureTypes property returns an object that contains the lighting fixture types which can be used to change the type of a lighting fixture from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


MechanicalEquipmentTypes Property

Document..::MechanicalEquipmentTypes Property
CollapseAll image DropDown image

Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet MechanicalEquipmentTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MechanicalEquipmentTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ MechanicalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The MechanicalEquipmentTypes property returns an object that contains the mechanical equipment types which can be used to change the type of a mechanical equipment from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


MullionTypes Property

Document..::MullionTypes Property
CollapseAll image DropDown image

This property is used to retrieve all the mullion types in current system.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MullionTypeSet MullionTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MullionTypes As MullionTypeSet
Visual C++
public:
property MullionTypeSet^ MullionTypes {
    MullionTypeSet^ get ();
}

Remarks

This property returns a set of MullionType objects. These objects can be used change the type of a mullion from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


PanelTypes Property

Document..::PanelTypes Property
CollapseAll image DropDown image

Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PanelTypeSet PanelTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PanelTypes As PanelTypeSet
Visual C++
public:
property PanelTypeSet^ PanelTypes {
    PanelTypeSet^ get ();
}

Remarks

This property returns a set of panelType objects. These objects can be used change the type of a panel from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


ParameterBindings Property

Document..::ParameterBindings Property
CollapseAll image DropDown image

Retrieves an object from which mappings between parameter definitions and categories can be found.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BindingMap ParameterBindings{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ParameterBindings As BindingMap
Visual C++
public:
property BindingMap^ ParameterBindings {
    BindingMap^ get ();
}

Remarks

Returns a mapping between parameter definitions and parameter bindings. New bindings can be added to the Revit Document by using this object.

See Also

Document Class
Autodesk.Revit Namespace


PathName Property

Document..::PathName Property
CollapseAll image DropDown image

Call this function to get the fully qualified path of the document's disk file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string PathName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

The project's fully qualified path. This string is empty if the project has not been saved or does not have a disk file associated with it.

See Also

Document Class
Autodesk.Revit Namespace


Phases Property

Document..::Phases Property
CollapseAll image DropDown image

Retrieves all the object that represent phases within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PhaseArray Phases{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Phases As PhaseArray
Visual C++
public:
property PhaseArray^ Phases {
    PhaseArray^ get ();
}

Remarks

The phases returned are in order of earliest phase first, through to latest phase last.

See Also

Document Class
Autodesk.Revit Namespace


PlanTopologies Property

Document..::PlanTopologies Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | PlanTopologies | Get the PlanTopologies of the current project.
Public property | PlanTopologies[([Phase])] | Get the PlanTopologies of the current project.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


PlanTopologies Property

Document..::PlanTopologies Property
CollapseAll image DropDown image

Get the PlanTopologies of the current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanTopologySet PlanTopologies{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies {
    PlanTopologySet^ get ();
}

Remarks

The Plan Topologies you get here is the last phase.

See Also

Document Class
Autodesk.Revit Namespace


PlanTopologies Property (Phase)

Document..::PlanTopologies Property (Phase)
See Also
CollapseAll image DropDown image

Get the PlanTopologies of the current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanTopologySet PlanTopologies[
    Phase phase
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies ( _
    phase As Phase _
) As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}

Parameters

phase
Phase
The phase of the Plan Topology.

Remarks

The Plan Topologies you get here is in the phase you assigned.

See Also

Document Class
Autodesk.Revit Namespace


PlanTopology Property

Document..::PlanTopology Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | PlanTopology[([Level])] | Get the PlanTopology of the certain Level.
Public property | PlanTopology[([Level, Phase])] | Get the PlanTopology of the certain Level.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


PlanTopology Property (Level)

Document..::PlanTopology Property (Level)
See Also
CollapseAll image DropDown image

Get the PlanTopology of the certain Level.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanTopology PlanTopology[
    Level level
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PlanTopology ( _
    level As Level _
) As PlanTopology
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level] {
    PlanTopology^ get (Level^ level);
}

Parameters

level
Level
The level of the Plan Topology.

Remarks

The Plan Topology you get here is the last phase.

See Also

Document Class
Autodesk.Revit Namespace


PlanTopology Property (Level, Phase)

Document..::PlanTopology Property (Level, Phase)
See Also
CollapseAll image DropDown image

Get the PlanTopology of the certain Level.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanTopology PlanTopology[
    Level level,
    Phase phase
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PlanTopology ( _
    level As Level, _
    phase As Phase _
) As PlanTopology
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
    PlanTopology^ get (Level^ level, Phase^ phase);
}

Parameters

level
Level
The level of the Plan Topology.
phase
Phase
The phase of the Plan Topology.

Remarks

The Plan Topology you get here is in the phase you assigned.

See Also

Document Class
Autodesk.Revit Namespace


PrintManager Property

Document..::PrintManager Property
CollapseAll image DropDown image

Retrieve the PrintManager of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintManager PrintManager{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PrintManager As PrintManager
Visual C++
public:
property PrintManager^ PrintManager {
    PrintManager^ get ();
}

See Also

Document Class
Autodesk.Revit Namespace


PrintSettings Property

Document..::PrintSettings Property
CollapseAll image DropDown image

Retrieve all Print Settings of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet PrintSettings{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PrintSettings As ElementSet
Visual C++
public:
property ElementSet^ PrintSettings {
    ElementSet^ get ();
}

See Also

Document Class
Autodesk.Revit Namespace


ProjectInformation Property

Document..::ProjectInformation Property
CollapseAll image DropDown image

Return the Project Information of the current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectInfo ProjectInformation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ProjectInformation As ProjectInfo
Visual C++
public:
property ProjectInfo^ ProjectInformation {
    ProjectInfo^ get ();
}

Return Value

Revit::Elements::ProjectInfo

See Also

Document Class
Autodesk.Revit Namespace


ProjectLocations Property

Document..::ProjectLocations Property
CollapseAll image DropDown image

Retrieve all the project locations associated with this project

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocationSet ProjectLocations{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ProjectLocations As ProjectLocationSet
Visual C++
public:
property ProjectLocationSet^ ProjectLocations {
    ProjectLocationSet^ get ();
}

Remarks

This property returns all the locations of the project. A project can have one site location but many project locations within that site. Each project location object is an offset and rotation from the site location.

See Also

Document Class
Autodesk.Revit Namespace


ProjectUnit Property

Document..::ProjectUnit Property
CollapseAll image DropDown image

Provides access to Project Unit Setting with in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectUnit ProjectUnit{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ProjectUnit As ProjectUnit
Visual C++
public:
property ProjectUnit^ ProjectUnit {
    ProjectUnit^ get ();
}

Remarks

Return the Project Unit Setting items.

See Also

Document Class
Autodesk.Revit Namespace


ReactionsAreUpToDate Property

Document..::ReactionsAreUpToDate Property
CollapseAll image DropDown image

Reports whether the reactionary loads have changed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ReactionsAreUpToDate{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ReactionsAreUpToDate As Boolean
Visual C++
public:
property bool ReactionsAreUpToDate {
    bool get ();
}

Remarks

This property can be used to check to see if loads have changing in a significant manner and hence structural analysis may need to be performed again.

See Also

Document Class
Autodesk.Revit Namespace


RebarBarTypes Property

Document..::RebarBarTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the rebar bar types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarBarTypeSet RebarBarTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RebarBarTypes As RebarBarTypeSet
Visual C++
public:
property RebarBarTypeSet^ RebarBarTypes {
    RebarBarTypeSet^ get ();
}

Remarks

This property returns a set of rebarbartype objects. These objects can be used change the type of a rebar from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


RebarCoverTypes Property

Document..::RebarCoverTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the rebar cover types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarCoverTypeSet RebarCoverTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RebarCoverTypes As RebarCoverTypeSet
Visual C++
public:
property RebarCoverTypeSet^ RebarCoverTypes {
    RebarCoverTypeSet^ get ();
}

Remarks

This property returns a set of RebarCoverType objects.

See Also

Document Class
Autodesk.Revit Namespace


RebarHookTypes Property

Document..::RebarHookTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the rebar hook types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookTypeSet RebarHookTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RebarHookTypes As RebarHookTypeSet
Visual C++
public:
property RebarHookTypeSet^ RebarHookTypes {
    RebarHookTypeSet^ get ();
}

Remarks

This property returns a set of rebarhooktype objects.

See Also

Document Class
Autodesk.Revit Namespace


RebarShapes Property

Document..::RebarShapes Property
CollapseAll image DropDown image

Retrieves an object that contains all the rebar shape types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeSet RebarShapes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RebarShapes As RebarShapeSet
Visual C++
public:
property RebarShapeSet^ RebarShapes {
    RebarShapeSet^ get ();
}

Remarks

This property returns a set of RebarShape objects.

See Also

Document Class
Autodesk.Revit Namespace


RoofTypes Property

Document..::RoofTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the roof types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoofTypeSet RoofTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RoofTypes As RoofTypeSet
Visual C++
public:
property RoofTypeSet^ RoofTypes {
    RoofTypeSet^ get ();
}

Remarks

This property returns a set of RoofType objects.

See Also

Document Class
Autodesk.Revit Namespace


RoomTagTypes Property

Document..::RoomTagTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTagTypeSet RoomTagTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RoomTagTypes As RoomTagTypeSet
Visual C++
public:
property RoomTagTypeSet^ RoomTagTypes {
    RoomTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Selection Property

Document..::Selection Property
CollapseAll image DropDown image

Retrieve the currently selected Elements in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Selection Selection{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

Remarks

Returns an object that represents the active selection. The Selection property returns an object that represents the active selection when the command was started.

See Also

Document Class
Autodesk.Revit Namespace


Settings Property

Document..::Settings Property
CollapseAll image DropDown image

Provides access to general application settings, such as Categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Settings Settings{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Settings As Settings
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

Remarks

Returns an object that provides access to various settings within Autodesk Revit. The Settings property returns an object that provides access to the categories within the Autodesk Revit project.

See Also

Document Class
Autodesk.Revit Namespace


SiteLocation Property

Document..::SiteLocation Property
CollapseAll image DropDown image

Returns the site location information.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SiteLocation SiteLocation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SiteLocation As SiteLocation
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The SiteLocation property returns an object that contains the site location for the entire project.

See Also

Document Class
Autodesk.Revit Namespace


SlabEdgeTypes Property

Document..::SlabEdgeTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdgeTypeSet SlabEdgeTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SlabEdgeTypes As SlabEdgeTypeSet
Visual C++
public:
property SlabEdgeTypeSet^ SlabEdgeTypes {
    SlabEdgeTypeSet^ get ();
}

Remarks

This property returns a set of SlabEdgeType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


SpaceTagTypes Property

Document..::SpaceTagTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceTagTypeSet SpaceTagTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SpaceTagTypes As SpaceTagTypeSet
Visual C++
public:
property SpaceTagTypeSet^ SpaceTagTypes {
    SpaceTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


SpotDimensionTypes Property

Document..::SpotDimensionTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimensionTypeSet SpotDimensionTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SpotDimensionTypes As SpotDimensionTypeSet
Visual C++
public:
property SpotDimensionTypeSet^ SpotDimensionTypes {
    SpotDimensionTypeSet^ get ();
}

Remarks

This property returns a set of SpotDimensionType objects. These objects can be used change the type of a SpotDimension from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


TextNoteTypes Property

Document..::TextNoteTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all of TextNote types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteTypeSet TextNoteTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TextNoteTypes As TextNoteTypeSet
Visual C++
public:
property TextNoteTypeSet^ TextNoteTypes {
    TextNoteTypeSet^ get ();
}

Remarks

This property returns a set of TextNote objects. These objects can be used change the type of a TextNote from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Title Property

Document..::Title Property
CollapseAll image DropDown image

Call this function to get the project's title, which is usually derived from the project's filename.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Title{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

Remarks

Returns the document's title.

See Also

Document Class
Autodesk.Revit Namespace


TitleBlocks Property

Document..::TitleBlocks Property
CollapseAll image DropDown image

Titleblocks currently loaded into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet TitleBlocks{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TitleBlocks As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ TitleBlocks {
    FamilySymbolSet^ get ();
}

Remarks

A titleblock is a symbol that defines the layout of a drafting sheet.

See Also

Document Class
Autodesk.Revit Namespace


TrussTypes Property

Document..::TrussTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the truss types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussTypeSet TrussTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrussTypes As TrussTypeSet
Visual C++
public:
property TrussTypeSet^ TrussTypes {
    TrussTypeSet^ get ();
}

Remarks

This property returns a set of TrussType objects.

See Also

Document Class
Autodesk.Revit Namespace


TypeOfStorage Property

Document..::TypeOfStorage Property
CollapseAll image DropDown image

Get the storage type of the specified builtin parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StorageType TypeOfStorage[
    BuiltInParameter
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TypeOfStorage ( _
     As BuiltInParameter _
) As StorageType
Visual C++
public:
property StorageType TypeOfStorage[BuiltInParameter ] {
    StorageType get (BuiltInParameter );
}

Parameters

BuiltInParameter

Remarks

This property is useful in element retrieval. It can be used to create a ParameterStorage object with a correct storage type for the FilterCriterion object.

See Also

Document Class
Autodesk.Revit Namespace


ViewSheetSets Property

Document..::ViewSheetSets Property
CollapseAll image DropDown image

The view sheet sets stored in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheetSets ViewSheetSets{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ViewSheetSets As ViewSheetSets
Visual C++
public:
property ViewSheetSets^ ViewSheetSets {
    ViewSheetSets^ get ();
}

Field Value

A group of the available view sheet sets.

See Also

Document Class
Autodesk.Revit Namespace


WallTypes Property

Document..::WallTypes Property
CollapseAll image DropDown image

Retrieves an object that contains all the wall types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallTypeSet WallTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property WallTypes As WallTypeSet
Visual C++
public:
property WallTypeSet^ WallTypes {
    WallTypeSet^ get ();
}

Remarks

This property returns a set of WallType objects. These objects can be used change the type of a wall from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


WorksharingCentralFilename Property

Document..::WorksharingCentralFilename Property
CollapseAll image DropDown image

The name and path of the central file name for a workshared document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string WorksharingCentralFilename{ get;}
Visual Basic (Declaration)
Public ReadOnly Property WorksharingCentralFilename As String
Visual C++
public:
property String^ WorksharingCentralFilename {
    String^ get ();
}

Field Value

The name and path of the central file, or "" if the file is not workshared.

See Also

Document Class
Autodesk.Revit Namespace


Document Events
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following events.

Public Events

 | Name | Description
Public event | OnClose | Subscribe to the OnClose event to be notified before the current document is closed.
Public event | OnSave | Subscribe to the OnSave event to be notified before a document has been saved.
Public event | OnSaveAs | Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

See Also

Document
Autodesk.Revit Namespace


OnClose Event

Document..::OnClose Event
CollapseAll image DropDown image

Subscribe to the OnClose event to be notified before the current document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentCloseEventHandler OnClose
Visual Basic (Declaration)
Public Event OnClose As DocumentCloseEventHandler
Visual C++
public:
 event DocumentCloseEventHandler^ OnClose {
    void add (DocumentCloseEventHandler^ value);
    void remove (DocumentCloseEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be closed. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace


OnSave Event

Document..::OnSave Event
CollapseAll image DropDown image

Subscribe to the OnSave event to be notified before a document has been saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSaveEventHandler OnSave
Visual Basic (Declaration)
Public Event OnSave As DocumentSaveEventHandler
Visual C++
public:
 event DocumentSaveEventHandler^ OnSave {
    void add (DocumentSaveEventHandler^ value);
    void remove (DocumentSaveEventHandler^ value);
}

Remarks

Sometimes an application needs to know when the document will be saved. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace


OnSaveAs Event

Document..::OnSaveAs Event
CollapseAll image DropDown image

Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSaveAsEventHandler OnSaveAs
Visual Basic (Declaration)
Public Event OnSaveAs As DocumentSaveAsEventHandler
Visual C++
public:
 event DocumentSaveAsEventHandler^ OnSaveAs {
    void add (DocumentSaveAsEventHandler^ value);
    void remove (DocumentSaveAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be saved as a file with another name. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace


DocumentSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any documents.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("68055836-5A99-4c27-95BA-FC4183CEE28E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DocumentSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("68055836-5A99-4c27-95BA-FC4183CEE28E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DocumentSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"68055836-5A99-4c27-95BA-FC4183CEE28E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DocumentSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::DocumentSet

See Also

DocumentSet Members
Autodesk.Revit Namespace


DocumentSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DocumentSet
Visual Basic (Declaration)
Public Class DocumentSet
Visual C++
public ref class DocumentSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DocumentSetDocumentSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

DocumentSet
Autodesk.Revit Namespace


DocumentSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DocumentSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSet ()

See Also

DocumentSet Class
Autodesk.Revit Namespace


DocumentSet Methods
CollapseAll image DropDown image

Syntax

C#
public class DocumentSet
Visual Basic (Declaration)
Public Class DocumentSet
Visual C++
public ref class DocumentSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DocumentSet
Autodesk.Revit Namespace


Clear Method

DocumentSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DocumentSet Class
Autodesk.Revit Namespace


Contains Method

DocumentSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Document^ item
)

Parameters

item
Document
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

DocumentSet Class
Autodesk.Revit Namespace


Dispose Method

DocumentSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DocumentSet Class
Autodesk.Revit Namespace


Erase Method

DocumentSet..::Erase Method
CollapseAll image DropDown image

Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Document _
) As Integer
Visual C++
public:
virtual int Erase (
    Document^ item
)

Parameters

item
Document
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


ForwardIterator Method

DocumentSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DocumentSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


GetEnumerator Method

DocumentSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


Insert Method

DocumentSet..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Document^ item
)

Parameters

item
Document
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

DocumentSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DocumentSet Class
Autodesk.Revit Namespace


ReverseIterator Method

DocumentSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DocumentSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


DocumentSet Properties
CollapseAll image DropDown image

Syntax

C#
public class DocumentSet
Visual Basic (Declaration)
Public Class DocumentSet
Visual C++
public ref class DocumentSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

DocumentSet
Autodesk.Revit Namespace


IsEmpty Property

DocumentSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DocumentSet Class
Autodesk.Revit Namespace


Size Property

DocumentSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DocumentSet Class
Autodesk.Revit Namespace


DocumentSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set of documents.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F95ECAD1-CFAF-463c-900A-EFA88EFF5F25")]
public abstract class DocumentSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F95ECAD1-CFAF-463c-900A-EFA88EFF5F25")> _
Public MustInherit Class DocumentSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F95ECAD1-CFAF-463c-900A-EFA88EFF5F25")]
public ref class DocumentSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::DocumentSetIterator

See Also

DocumentSetIterator Members
Autodesk.Revit Namespace


DocumentSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DocumentSetIterator
Visual Basic (Declaration)
Public MustInherit Class DocumentSetIterator
Visual C++
public ref class DocumentSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DocumentSetIteratorDocumentSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator
Autodesk.Revit Namespace


DocumentSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DocumentSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


DocumentSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DocumentSetIterator
Visual Basic (Declaration)
Public MustInherit Class DocumentSetIterator
Visual C++
public ref class DocumentSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DocumentSetIterator
Autodesk.Revit Namespace


Dispose Method

DocumentSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

DocumentSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

DocumentSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


Reset Method

DocumentSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


DocumentSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DocumentSetIterator
Visual Basic (Declaration)
Public MustInherit Class DocumentSetIterator
Visual C++
public ref class DocumentSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator
Autodesk.Revit Namespace


Current Property

DocumentSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


DWF2DExportOptions Class
See Also Members
CollapseAll image DropDown image

DWF2D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("684185F5-9B3A-4fc0-ABF4-634B36157AF9")]
public class DWF2DExportOptions : CADExportOptions
Visual Basic (Declaration)
<GuidAttribute("684185F5-9B3A-4fc0-ABF4-634B36157AF9")> _
Public Class DWF2DExportOptions _
    Inherits CADExportOptions
Visual C++
[GuidAttribute(L"684185F5-9B3A-4fc0-ABF4-634B36157AF9")]
public ref class DWF2DExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::DWF2DExportOptions

See Also

DWF2DExportOptions Members
Autodesk.Revit Namespace


DWF2DExportOptions Members
See Also Fields Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class DWF2DExportOptions
Visual Basic (Declaration)
Public Class DWF2DExportOptions
Visual C++
public ref class DWF2DExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWF2DExportOptionsDWF2DExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportObjectData | Whether to include properties associated with elements.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | MergedViews | Whether to merge all views in one file.
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWF2DExportOptions
Autodesk.Revit Namespace


DWF2DExportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWF2DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWF2DExportOptions ()

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


DWF2DExportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public class DWF2DExportOptions
Visual Basic (Declaration)
Public Class DWF2DExportOptions
Visual C++
public ref class DWF2DExportOptions

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportObjectData | Whether to include properties associated with elements.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | MergedViews | Whether to merge all views in one file.
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWF2DExportOptions
Autodesk.Revit Namespace


ExportObjectData Field

DWF2DExportOptions..::ExportObjectData Field
CollapseAll image DropDown image

Whether to include properties associated with elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ExportObjectData
Visual Basic (Declaration)
Public ExportObjectData As Boolean
Visual C++
public:
bool ExportObjectData

Remarks

ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


MergedViews Field

DWF2DExportOptions..::MergedViews Field
CollapseAll image DropDown image

Whether to merge all views in one file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool MergedViews
Visual Basic (Declaration)
Public MergedViews As Boolean
Visual C++
public:
bool MergedViews

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


DWF3DExportOptions Class
See Also Members
CollapseAll image DropDown image

DWF3D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1AF67217-FF6B-4a91-A0E4-8CAC1D5D8D6A")]
public class DWF3DExportOptions : CADExportOptions
Visual Basic (Declaration)
<GuidAttribute("1AF67217-FF6B-4a91-A0E4-8CAC1D5D8D6A")> _
Public Class DWF3DExportOptions _
    Inherits CADExportOptions
Visual C++
[GuidAttribute(L"1AF67217-FF6B-4a91-A0E4-8CAC1D5D8D6A")]
public ref class DWF3DExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::DWF3DExportOptions

See Also

DWF3DExportOptions Members
Autodesk.Revit Namespace


DWF3DExportOptions Members
See Also Fields Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class DWF3DExportOptions
Visual Basic (Declaration)
Public Class DWF3DExportOptions
Visual C++
public ref class DWF3DExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWF3DExportOptionsDWF3DExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWF3DExportOptions
Autodesk.Revit Namespace


DWF3DExportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWF3DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWF3DExportOptions ()

See Also

DWF3DExportOptions Class
Autodesk.Revit Namespace


DWFX2DExportOptions Class
See Also Members
CollapseAll image DropDown image

DWFX2D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("53B6AF1B-0354-4bf3-82CE-4D24C0710CCC")]
public class DWFX2DExportOptions : CADExportOptions
Visual Basic (Declaration)
<GuidAttribute("53B6AF1B-0354-4bf3-82CE-4D24C0710CCC")> _
Public Class DWFX2DExportOptions _
    Inherits CADExportOptions
Visual C++
[GuidAttribute(L"53B6AF1B-0354-4bf3-82CE-4D24C0710CCC")]
public ref class DWFX2DExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::DWFX2DExportOptions

See Also

DWFX2DExportOptions Members
Autodesk.Revit Namespace


DWFX2DExportOptions Members
See Also Fields Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class DWFX2DExportOptions
Visual Basic (Declaration)
Public Class DWFX2DExportOptions
Visual C++
public ref class DWFX2DExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWFX2DExportOptionsDWFX2DExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportObjectData | Whether to include properties associated with elements.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | MergedViews | Whether to merge all views in one file.
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWFX2DExportOptions
Autodesk.Revit Namespace


DWFX2DExportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWFX2DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWFX2DExportOptions ()

See Also

DWFX2DExportOptions Class
Autodesk.Revit Namespace


DWFX2DExportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public class DWFX2DExportOptions
Visual Basic (Declaration)
Public Class DWFX2DExportOptions
Visual C++
public ref class DWFX2DExportOptions

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportObjectData | Whether to include properties associated with elements.
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | MergedViews | Whether to merge all views in one file.
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWFX2DExportOptions
Autodesk.Revit Namespace


ExportObjectData Field

DWFX2DExportOptions..::ExportObjectData Field
CollapseAll image DropDown image

Whether to include properties associated with elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ExportObjectData
Visual Basic (Declaration)
Public ExportObjectData As Boolean
Visual C++
public:
bool ExportObjectData

Remarks

ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.

See Also

DWFX2DExportOptions Class
Autodesk.Revit Namespace


MergedViews Field

DWFX2DExportOptions..::MergedViews Field
CollapseAll image DropDown image

Whether to merge all views in one file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool MergedViews
Visual Basic (Declaration)
Public MergedViews As Boolean
Visual C++
public:
bool MergedViews

See Also

DWFX2DExportOptions Class
Autodesk.Revit Namespace


DWFX3DExportOptions Class
See Also Members
CollapseAll image DropDown image

DWFX3D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("20751B2C-6BC9-4096-97B3-B7E00288808E")]
public class DWFX3DExportOptions : CADExportOptions
Visual Basic (Declaration)
<GuidAttribute("20751B2C-6BC9-4096-97B3-B7E00288808E")> _
Public Class DWFX3DExportOptions _
    Inherits CADExportOptions
Visual C++
[GuidAttribute(L"20751B2C-6BC9-4096-97B3-B7E00288808E")]
public ref class DWFX3DExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::DWFX3DExportOptions

See Also

DWFX3DExportOptions Members
Autodesk.Revit Namespace


DWFX3DExportOptions Members
See Also Fields Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class DWFX3DExportOptions
Visual Basic (Declaration)
Public Class DWFX3DExportOptions
Visual C++
public ref class DWFX3DExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWFX3DExportOptionsDWFX3DExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWFX3DExportOptions
Autodesk.Revit Namespace


DWFX3DExportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWFX3DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWFX3DExportOptions ()

See Also

DWFX3DExportOptions Class
Autodesk.Revit Namespace


DWGExportOptions Class
See Also Members
CollapseAll image DropDown image

DWG Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("979BD680-123B-410c-A365-B0697C43A784")]
public class DWGExportOptions : ACADExportOptions
Visual Basic (Declaration)
<GuidAttribute("979BD680-123B-410c-A365-B0697C43A784")> _
Public Class DWGExportOptions _
    Inherits ACADExportOptions
Visual C++
[GuidAttribute(L"979BD680-123B-410c-A365-B0697C43A784")]
public ref class DWGExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::ACADExportOptions
Autodesk.Revit..::DWGExportOptions

See Also

DWGExportOptions Members
Autodesk.Revit Namespace


DWGExportOptions Members
See Also Fields Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class DWGExportOptions
Visual Basic (Declaration)
Public Class DWGExportOptions
Visual C++
public ref class DWGExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWGExportOptionsDWGExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
Public field | FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
Public field | LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
Public field | MergedViews | Whether to merge all views in one file (via XRefs).
Public field | PropOverrides | How to export overriden object styles. (Inherited from ACADExportOptions.)
Public field | SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWGExportOptions
Autodesk.Revit Namespace


DWGExportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWGExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWGExportOptions ()

See Also

DWGExportOptions Class
Autodesk.Revit Namespace


DWGExportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public class DWGExportOptions
Visual Basic (Declaration)
Public Class DWGExportOptions
Visual C++
public ref class DWGExportOptions

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
Public field | FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
Public field | LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
Public field | MergedViews | Whether to merge all views in one file (via XRefs).
Public field | PropOverrides | How to export overriden object styles. (Inherited from ACADExportOptions.)
Public field | SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWGExportOptions
Autodesk.Revit Namespace


MergedViews Field

DWGExportOptions..::MergedViews Field
CollapseAll image DropDown image

Whether to merge all views in one file (via XRefs).

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool MergedViews
Visual Basic (Declaration)
Public MergedViews As Boolean
Visual C++
public:
bool MergedViews

See Also

DWGExportOptions Class
Autodesk.Revit Namespace


DWGImportOptions Class
See Also Members
CollapseAll image DropDown image

Import options specific to AutoCAD's DWG file formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B9740BB9-FCE8-4c10-A5C3-1D062E64D8FE")]
public class DWGImportOptions : ACADImportOptions
Visual Basic (Declaration)
<GuidAttribute("B9740BB9-FCE8-4c10-A5C3-1D062E64D8FE")> _
Public Class DWGImportOptions _
    Inherits ACADImportOptions
Visual C++
[GuidAttribute(L"B9740BB9-FCE8-4c10-A5C3-1D062E64D8FE")]
public ref class DWGImportOptions : public ACADImportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::GenericImportOptions
Autodesk.Revit..::CADImportOptions
Autodesk.Revit..::ACADImportOptions
Autodesk.Revit..::DWGImportOptions

See Also

DWGImportOptions Members
Autodesk.Revit Namespace


DWGImportOptions Members
See Also Fields Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class DWGImportOptions
Visual Basic (Declaration)
Public Class DWGImportOptions
Visual C++
public ref class DWGImportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWGImportOptionsDWGImportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
Public field | CustomScale | Scaling the import. (Inherited from CADImportOptions.)
Public field | LayerSelection | The layers collection for import. (Inherited from ACADImportOptions.)
Public field | LineWeights | A Byte array of line weights for the DWG/DXF Color number. (Inherited from ACADImportOptions.)
Public field | OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Public field | Placement | Where to place the import. (Inherited from CADImportOptions.)
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Public field | Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
Public field | VisibleLayersOnly | Only import the visible layers. (Inherited from ACADImportOptions.)

See Also

DWGImportOptions
Autodesk.Revit Namespace


DWGImportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWGImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWGImportOptions ()

See Also

DWGImportOptions Class
Autodesk.Revit Namespace


Element Class
See Also Members
CollapseAll image DropDown image

Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("11CA8950-8E66-4295-9A90-702202BD7704")]
public class Element : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("11CA8950-8E66-4295-9A90-702202BD7704")> _
Public Class Element _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"11CA8950-8E66-4295-9A90-702202BD7704")]
public ref class Element : public APIObject

Remarks

The Element object is base class for all elements that can persist inside the Autodesk Revit project database. Element objects can be retrieved from the Document.Element or Document.Elements properties.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Elements..::BaseArray
Autodesk.Revit.Elements..::BoundaryConditions
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::LoadNature
Autodesk.Revit.Elements..::FamilyBase
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::Level
Autodesk.Revit.Elements..::Grid
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::LoadCombination
Autodesk.Revit.Elements..::LoadCase
Autodesk.Revit.Elements..::LoadUsage
Autodesk.Revit.Elements..::Room
Autodesk.Revit.Elements..::Group
Autodesk.Revit.Elements..::Rebar
Autodesk.Revit.Elements..::AreaReinforcementCurve
Autodesk.Revit.Elements..::AreaReinforcement
Autodesk.Revit.Elements..::DesignOption
Autodesk.Revit.Elements..::Phase
Autodesk.Revit.Elements..::Dimension
Autodesk.Revit.Elements..::RoomTag
Autodesk.Revit.Elements..::ProjectInfo
Autodesk.Revit.Elements..::gbXMLParamElem
Autodesk.Revit.Elements..::ProjectUnit
Autodesk.Revit.Elements..::FillPattern
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::SketchPlane
Autodesk.Revit.Elements..::ReferencePlane
Autodesk.Revit.Elements..::Opening
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::BeamSystem
Autodesk.Revit.Elements..::IndependentTag
Autodesk.Revit.Elements..::TextElement
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::PathReinforcement
Autodesk.Revit.Elements..::AnnotationSymbol
Autodesk.Revit.Elements..::LinePattern
Autodesk.Revit.Elements..::ViewSheetSet
Autodesk.Revit.Elements..::PrintSetting
Autodesk.Revit.Elements..::Area
Autodesk.Revit.Elements..::AreaTag
Autodesk.Revit.Elements..::ElectricalSystem
Autodesk.Revit.Elements..::InsulationType
Autodesk.Revit.Elements..::TemperatureRatingType
Autodesk.Revit.Elements..::WireMaterialType
Autodesk.Revit.Elements..::ConduitType
Autodesk.Revit.Elements..::Truss
Autodesk.Revit.Elements..::Space
Autodesk.Revit.Elements..::SpaceTag
Autodesk.Revit.Elements..::Zone
Autodesk.Revit.Elements..::Mullion
Autodesk.Revit.Elements..::Panel

See Also

Element Members
Autodesk.Revit Namespace


Element Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Element
Visual Basic (Declaration)
Public Class Element
Visual C++
public ref class Element

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementElementNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned.
Public property | Location | This property is used to find the physical location of an element within project.
Public property | Name | Returns a human readable name for the Element.
Public property | ObjectType | Returns the instance type of this object.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | PhaseCreated | An object representing the phase when the element is created.
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished.
Public property | Pinned | Informs the developer if an element has been pinned by a user.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance.
Public property | UniqueId | A stable unique identifier for an element within the document.

See Also

Element
Autodesk.Revit Namespace


Element Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Element ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Element Class
Autodesk.Revit Namespace


Element Methods
CollapseAll image DropDown image

Syntax

C#
public class Element
Visual Basic (Declaration)
Public Class Element
Visual C++
public ref class Element

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Element
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

Element..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Element Class
Autodesk.Revit Namespace


Element Properties
CollapseAll image DropDown image

Syntax

C#
public class Element
Visual Basic (Declaration)
Public Class Element
Visual C++
public ref class Element

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned.
Public property | Location | This property is used to find the physical location of an element within project.
Public property | Name | Returns a human readable name for the Element.
Public property | ObjectType | Returns the instance type of this object.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | PhaseCreated | An object representing the phase when the element is created.
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished.
Public property | Pinned | Informs the developer if an element has been pinned by a user.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance.
Public property | UniqueId | A stable unique identifier for an element within the document.

See Also

Element
Autodesk.Revit Namespace


BoundingBox Property

Element..::BoundingBox Property
CollapseAll image DropDown image

Retrieves a box that circumscribes all geometry of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxXYZ BoundingBox[
    View
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BoundingBox ( _
     As View _
) As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ BoundingBox[View^ ] {
    BoundingBoxXYZ^ get (View^ );
}

Parameters

View

Remarks

Pass in a view to query view-specific (e.g., cut) geometry or null for model geometry. If view box is not known, will return model box; if model box is not known, will return null.

See Also

Element Class
Autodesk.Revit Namespace


Category Property

Element..::Category Property
CollapseAll image DropDown image

Retrieves a Category object that represents the category or sub category in which the element resides.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Category Category{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Category As Category
Visual C++
public:
property Category^ Category {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

Element Class
Autodesk.Revit Namespace


DesignOption Property

Element..::DesignOption Property
CollapseAll image DropDown image

Returns the design option to which the element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DesignOption DesignOption{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DesignOption As DesignOption
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return Nothing.

See Also

Element Class
Autodesk.Revit Namespace


Document Property

Element..::Document Property
CollapseAll image DropDown image

Returns the Document in which the Element resides.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document Document{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.

See Also

Element Class
Autodesk.Revit Namespace


Geometry Property

Element..::Geometry Property
CollapseAll image DropDown image

Retrieves the geometric representation of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Geometry[
    Options options
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Geometry ( _
    options As Options _
) As Element
Visual C++
public:
property Element^ Geometry[Options^ options] {
    Element^ get (Options^ options);
}

Parameters

options
Options
User preferences for parsing of geometry.

Remarks

This call will retrieve 3d representation of the element. Nothing will be returned for symbols, annotations or details. This involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical.

See Also

Element Class
Autodesk.Revit Namespace


Group Property

Element..::Group Property
CollapseAll image DropDown image

Return to group to which an element belongs. If it is not in a group then this will return Nothing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Group Group{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Group As Group
Visual C++
public:
property Group^ Group {
    Group^ get ();
}

See Also

Element Class
Autodesk.Revit Namespace


Id Property

Element..::Id Property
CollapseAll image DropDown image

Provides a way of uniquely identifying an Element within an Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId Id{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId Id {
    ElementId get ();
}

Remarks

Returns an ElementId object containing the project wide unique identifier for this Element. The identifier with the ElementId is only unique for the project, it is not unique across separate Autodesk Revit projects.

See Also

Element Class
Autodesk.Revit Namespace


Level Property

Element..::Level Property
CollapseAll image DropDown image

If the element is level based then level to which the element is assigned it returned.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level Level{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

Remarks

A number of elements use a level as a base reference, such as a column.

See Also

Element Class
Autodesk.Revit Namespace


Location Property

Element..::Location Property
CollapseAll image DropDown image

This property is used to find the physical location of an element within project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Location Location{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get ();
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.

See Also

Element Class
Autodesk.Revit Namespace


Name Property

Element..::Name Property
CollapseAll image DropDown image

Returns a human readable name for the Element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual string Name{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Element Class
Autodesk.Revit Namespace


ObjectType Property

Element..::ObjectType Property
CollapseAll image DropDown image

Returns the instance type of this object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Symbol ObjectType{ get; set;}
Visual Basic (Declaration)
Public Property ObjectType As Symbol
Visual C++
public:
property Symbol^ ObjectType {
    Symbol^ get ();
    void set (Symbol^ value);
}

Remarks

The type of the object returned by this method depends upon the type of this instance, for example - if this object is a wall then a wall type object will be returned. Not all objects have an instance type in which case Nothing is returned.

See Also

Element Class
Autodesk.Revit Namespace


Parameter Property

Element..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter.
Public property | Parameter[([String])] | Retrieve parameter object from parameter name.
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id.
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition.

See Also

Element Class
Element Members
Autodesk.Revit Namespace


Parameter Property (Guid)

Element..::Parameter Property (Guid)
See Also
CollapseAll image DropDown image

Retrieves a parameter from an element given a GUID for a shared parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter Parameter[
    Guid guid
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[Guid guid] {
    Parameter^ get (Guid guid);
}

Parameters

guid
Guid
The unique id associated with the shared parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method is used to retrieve a parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

Element Class
Autodesk.Revit Namespace


Parameter Property (String)

Element..::Parameter Property (String)
See Also
CollapseAll image DropDown image

Retrieve parameter object from parameter name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter Parameter[
    string paramName
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    paramName As String _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[String^ paramName] {
    Parameter^ get (String^ paramName);
}

Parameters

paramName
String
The name of the parameter to be retrieved.

See Also

Element Class
Autodesk.Revit Namespace


Parameter Property (BuiltInParameter)

Element..::Parameter Property (BuiltInParameter)
See Also
CollapseAll image DropDown image

Retrieves a parameter from an element given a parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter Parameter[
    BuiltInParameter parameterId
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
    Parameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.

See Also

Element Class
Autodesk.Revit Namespace


Parameter Property (Definition)

Element..::Parameter Property (Definition)
See Also
CollapseAll image DropDown image

Retrieve a parameter from an element based on its definition.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter Parameter[
    Definition definition
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[Definition^ definition] {
    Parameter^ get (Definition^ definition);
}

Parameters

definition
Definition
The internal or external definition of the parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.

See Also

Element Class
Autodesk.Revit Namespace


Parameters Property

Element..::Parameters Property
CollapseAll image DropDown image

Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterSet Parameters{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterSet
Visual C++
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}

Remarks

The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.

See Also

Element Class
Autodesk.Revit Namespace


ParametersMap Property

Element..::ParametersMap Property
CollapseAll image DropDown image

Retrieves a map containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterMap ParametersMap{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ParametersMap As ParameterMap
Visual C++
public:
property ParameterMap^ ParametersMap {
    ParameterMap^ get ();
}

Remarks

The Parameters can be rapidly accessed by parameter name as a key. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this map.

See Also

Element Class
Autodesk.Revit Namespace


PhaseCreated Property

Element..::PhaseCreated Property
CollapseAll image DropDown image

An object representing the phase when the element is created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Phase PhaseCreated{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PhaseCreated As Phase
Visual C++
public:
property Phase^ PhaseCreated {
    Phase^ get ();
}

Remarks

Elements always have a phase for when they are created.

See Also

Element Class
Autodesk.Revit Namespace


PhaseDemolished Property

Element..::PhaseDemolished Property
CollapseAll image DropDown image

An object representing the phase for when the element is to be demolished.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Phase PhaseDemolished{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PhaseDemolished As Phase
Visual C++
public:
property Phase^ PhaseDemolished {
    Phase^ get ();
}

Remarks

The element may not have a demolishion phase. If it does not then this property will return nothing.

See Also

Element Class
Autodesk.Revit Namespace


Pinned Property

Element..::Pinned Property
CollapseAll image DropDown image

Informs the developer if an element has been pinned by a user.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Pinned{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Pinned As Boolean
Visual C++
public:
property bool Pinned {
    bool get ();
}

Remarks

If a user pins an element then they are signifying that the element should not be changed.

See Also

Element Class
Autodesk.Revit Namespace


SimilarObjectTypes Property

Element..::SimilarObjectTypes Property
CollapseAll image DropDown image

Returns the types being similar to the current instance.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementSet SimilarObjectTypes{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property SimilarObjectTypes As ElementSet
Visual C++
public:
virtual property ElementSet^ SimilarObjectTypes {
    ElementSet^ get ();
}

Remarks

The returned types include all the similar types to current instance, which means the type of the current instance can be swapped to the type included in the returned set.

See Also

Element Class
Autodesk.Revit Namespace


UniqueId Property

Element..::UniqueId Property
CollapseAll image DropDown image

A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string UniqueId{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UniqueId As String
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

Remarks

The UniqueId can be used to store an identifier in and external database and then be used to retrieve the exact same element in the future if it still exists. This id can be passed the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as save to central whereas the ElementId property may change.

See Also

Element Class
Autodesk.Revit Namespace


ElementArray Class
See Also Members
CollapseAll image DropDown image

An array that contains element objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B3AE5AA1-CF1E-4624-BB1A-EB3E600E23EA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElementArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("B3AE5AA1-CF1E-4624-BB1A-EB3E600E23EA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"B3AE5AA1-CF1E-4624-BB1A-EB3E600E23EA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementArray

See Also

ElementArray Members
Autodesk.Revit Namespace


ElementArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElementArray
Visual Basic (Declaration)
Public Class ElementArray
Visual C++
public ref class ElementArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementArrayElementArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.

See Also

ElementArray
Autodesk.Revit Namespace


ElementArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementArray ()

See Also

ElementArray Class
Autodesk.Revit Namespace


ElementArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ElementArray
Visual Basic (Declaration)
Public Class ElementArray
Visual C++
public ref class ElementArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElementArray
Autodesk.Revit Namespace


Append Method

ElementArray..::Append Method
CollapseAll image DropDown image

Add the element to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Element item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Element _
)
Visual C++
public:
virtual void Append (
    Element^ item
)

Parameters

item
Element
The element to be added.

See Also

ElementArray Class
Autodesk.Revit Namespace


Clear Method

ElementArray..::Clear Method
CollapseAll image DropDown image

Removes every element from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ElementArray Class
Autodesk.Revit Namespace


Dispose Method

ElementArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElementArray Class
Autodesk.Revit Namespace


ForwardIterator Method

ElementArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


GetEnumerator Method

ElementArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


Insert Method

ElementArray..::Insert Method
CollapseAll image DropDown image

Insert the specified element into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Element item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Element, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Element^ item,
    int index
)

Parameters

item
Element
The element to be inserted into the array.
index
Int32
The element will be inserted before this index.

Return Value

Returns whether the element was inserted into the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ElementArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElementArray Class
Autodesk.Revit Namespace


ReverseIterator Method

ElementArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


ElementArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ElementArray
Visual Basic (Declaration)
Public Class ElementArray
Visual C++
public ref class ElementArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.

See Also

ElementArray
Autodesk.Revit Namespace


IsEmpty Property

ElementArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ElementArray Class
Autodesk.Revit Namespace


Item Property

ElementArray..::Item Property
CollapseAll image DropDown image

Gets or sets an element at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Element Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Element
Visual C++
public:
virtual property Element^ Item[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}

Parameters

index
Int32
The index of the element to be set or retrieved.

Return Value

Returns the element at the specified index.

See Also

ElementArray Class
Autodesk.Revit Namespace


Size Property

ElementArray..::Size Property
CollapseAll image DropDown image

Returns the number of elements that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementArray Class
Autodesk.Revit Namespace


ElementArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an element array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EA263E94-36C6-4a99-B6F5-7D62A3CEEDB2")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ElementArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("EA263E94-36C6-4a99-B6F5-7D62A3CEEDB2")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"EA263E94-36C6-4a99-B6F5-7D62A3CEEDB2")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementArrayIterator

See Also

ElementArrayIterator Members
Autodesk.Revit Namespace


ElementArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ElementArrayIterator
Visual C++
public ref class ElementArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementArrayIteratorElementArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator
Autodesk.Revit Namespace


ElementArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ElementArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ElementArrayIterator
Visual C++
public ref class ElementArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElementArrayIterator
Autodesk.Revit Namespace


Dispose Method

ElementArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

ElementArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ElementArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


Reset Method

ElementArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ElementArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ElementArrayIterator
Visual C++
public ref class ElementArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator
Autodesk.Revit Namespace


Current Property

ElementArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ElementId Structure
See Also Members
CollapseAll image DropDown image

The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EEF7A1DF-FC31-4bcb-95FB-06B718D37307")]
public struct ElementId
Visual Basic (Declaration)
<GuidAttribute("EEF7A1DF-FC31-4bcb-95FB-06B718D37307")> _
Public Structure ElementId
Visual C++
[GuidAttribute(L"EEF7A1DF-FC31-4bcb-95FB-06B718D37307")]
public value class ElementId

Remarks

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.

See Also

ElementId Members
Autodesk.Revit Namespace


ElementId Members
See Also Methods Fields
CollapseAll image DropDown image

Syntax

C#
public struct ElementId
Visual Basic (Declaration)
Public Structure ElementId
Visual C++
public value class ElementId

The type exposes the following members.

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | Value | Provides the value of the element id as an integer.

See Also

ElementId
Autodesk.Revit Namespace


ElementId Fields
CollapseAll image DropDown image

Syntax

C#
public struct ElementId
Visual Basic (Declaration)
Public Structure ElementId
Visual C++
public value class ElementId

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | Value | Provides the value of the element id as an integer.

See Also

ElementId
Autodesk.Revit Namespace


Value Field

ElementId..::Value Field
CollapseAll image DropDown image

Provides the value of the element id as an integer.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Value
Visual Basic (Declaration)
Public Value As Integer
Visual C++
public:
int Value

See Also

ElementId Structure
Autodesk.Revit Namespace


ElementIdSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain Element Ids.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1005EF4B-4C5F-4dae-BA2E-5F2D67E682FF")]
public class ElementIdSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1005EF4B-4C5F-4dae-BA2E-5F2D67E682FF")> _
Public Class ElementIdSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1005EF4B-4C5F-4dae-BA2E-5F2D67E682FF")]
public ref class ElementIdSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementIdSet

See Also

ElementIdSet Members
Autodesk.Revit Namespace


ElementIdSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElementIdSet
Visual Basic (Declaration)
Public Class ElementIdSet
Visual C++
public ref class ElementIdSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementIdSetElementIdSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every element id from the set, rendering it empty.
Public method | Contains | Tests for the existence of an element id within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified element id from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element id into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of element ids that are in the set.

See Also

ElementIdSet
Autodesk.Revit Namespace


ElementIdSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIdSet ()

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ElementIdSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ElementIdSet
Visual Basic (Declaration)
Public Class ElementIdSet
Visual C++
public ref class ElementIdSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every element id from the set, rendering it empty.
Public method | Contains | Tests for the existence of an element id within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified element id from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element id into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElementIdSet
Autodesk.Revit Namespace


Clear Method

ElementIdSet..::Clear Method
CollapseAll image DropDown image

Removes every element id from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Contains Method

ElementIdSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an element id within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    ref ElementId item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    ByRef item As ElementId _
) As Boolean
Visual C++
public:
virtual bool Contains (
    ElementId% item
)

Parameters

item
ElementId %
The item to be searched for.

Return Value

The Contains method returns True if the element id is within the set, otherwise False.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Dispose Method

ElementIdSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Erase Method

ElementIdSet..::Erase Method
CollapseAll image DropDown image

Removes a specified element id from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    ref ElementId item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    ByRef item As ElementId _
) As Integer
Visual C++
public:
virtual int Erase (
    ElementId% item
)

Parameters

item
ElementId %
The element id to be erased.

Return Value

The number of element ids that were erased from the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ForwardIterator Method

ElementIdSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementIdSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementIdSetIterator
Visual C++
public:
virtual ElementIdSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


GetEnumerator Method

ElementIdSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Insert Method

ElementIdSet..::Insert Method
CollapseAll image DropDown image

Insert the specified element id into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    ref ElementId item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    ByRef item As ElementId _
) As Boolean
Visual C++
public:
virtual bool Insert (
    ElementId% item
)

Parameters

item
ElementId %
The element id to be inserted into the set.

Return Value

Returns whether the element id was inserted into the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ElementIdSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ReverseIterator Method

ElementIdSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementIdSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementIdSetIterator
Visual C++
public:
virtual ElementIdSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ElementIdSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ElementIdSet
Visual Basic (Declaration)
Public Class ElementIdSet
Visual C++
public ref class ElementIdSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of element ids that are in the set.

See Also

ElementIdSet
Autodesk.Revit Namespace


IsEmpty Property

ElementIdSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Size Property

ElementIdSet..::Size Property
CollapseAll image DropDown image

Returns the number of element ids that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ElementIdSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a element id set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("004F47EF-E994-4fc0-82D3-56248B2923A8")]
public abstract class ElementIdSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("004F47EF-E994-4fc0-82D3-56248B2923A8")> _
Public MustInherit Class ElementIdSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"004F47EF-E994-4fc0-82D3-56248B2923A8")]
public ref class ElementIdSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementIdSetIterator

See Also

ElementIdSetIterator Members
Autodesk.Revit Namespace


ElementIdSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementIdSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElementIdSetIterator
Visual C++
public ref class ElementIdSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementIdSetIteratorElementIdSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIdSetIterator
Autodesk.Revit Namespace


ElementIdSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIdSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ElementIdSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementIdSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElementIdSetIterator
Visual C++
public ref class ElementIdSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElementIdSetIterator
Autodesk.Revit Namespace


Dispose Method

ElementIdSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

ElementIdSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ElementIdSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


Reset Method

ElementIdSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ElementIdSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementIdSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElementIdSetIterator
Visual C++
public ref class ElementIdSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIdSetIterator
Autodesk.Revit Namespace


Current Property

ElementIdSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ElementIterator Class
See Also Members
CollapseAll image DropDown image

An iterator object that enable access to every element within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8329CDF1-D3B5-4829-AB8A-6071F7D7A2B8")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElementIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("8329CDF1-D3B5-4829-AB8A-6071F7D7A2B8")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElementIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"8329CDF1-D3B5-4829-AB8A-6071F7D7A2B8")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementIterator : public APIObject,
    IEnumerator

Remarks

The Autodesk Revit may contain a very large number of elements so iteration can be very time consuming. The elements that are accessible by this iterator are not only the visible elements within the project, but also those that cannot be seen, such as family types, wall types, group types etc. This is a forward seeking iterator.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementIterator

See Also

ElementIterator Members
Autodesk.Revit Namespace


ElementIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElementIterator
Visual Basic (Declaration)
Public Class ElementIterator
Visual C++
public ref class ElementIterator

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementIteratorElementIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one element forward.
Public method | Reset | Bring the iterator back to the start of the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | canSkipElement |
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | getADoc | Get document to which current iterator belongs.
Protected method | getElemIter | Get current element iterator.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Current | The object that represents the current element in the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIterator
Autodesk.Revit Namespace


ElementIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementIterator Class
Autodesk.Revit Namespace


ElementIterator Methods
CollapseAll image DropDown image

Syntax

C#
public class ElementIterator
Visual Basic (Declaration)
Public Class ElementIterator
Visual C++
public ref class ElementIterator

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one element forward.
Public method | Reset | Bring the iterator back to the start of the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | canSkipElement |
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | getADoc | Get document to which current iterator belongs.
Protected method | getElemIter | Get current element iterator.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

ElementIterator
Autodesk.Revit Namespace


canSkipElement Method

ElementIterator..::canSkipElement Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected bool canSkipElement(
    ElemRecAccess** pERA
)
Visual Basic (Declaration)
Protected Function canSkipElement ( _
    pERA As ElemRecAccess** _
) As Boolean
Visual C++
protected:
bool canSkipElement (
    ElemRecAccess** pERA
)

Parameters

pERA
ElemRecAccess IsConst IsConst*IsImplicitlyDereferenced*

See Also

ElementIterator Class
Autodesk.Revit Namespace


Dispose Method

ElementIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElementIterator Class
Autodesk.Revit Namespace


getADoc Method

ElementIterator..::getADoc Method
CollapseAll image DropDown image

Get document to which current iterator belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected ADocument* getADoc()
Visual Basic (Declaration)
Protected Function getADoc As ADocument*
Visual C++
protected:
ADocument* getADoc ()

Return Value

Current document.

See Also

ElementIterator Class
Autodesk.Revit Namespace


getElemIter Method

ElementIterator..::getElemIter Method
CollapseAll image DropDown image

Get current element iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected ElemIter* getElemIter()
Visual Basic (Declaration)
Protected Function getElemIter As ElemIter*
Visual C++
protected:
ElemIter* getElemIter ()

Return Value

Current iterator points to element.

See Also

ElementIterator Class
Autodesk.Revit Namespace


MoveNext Method

ElementIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one element forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one element and the Current property will return a valid Element. False will be returned it the iterator has reached the end of the project database.

See Also

ElementIterator Class
Autodesk.Revit Namespace


Reset Method

ElementIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the database.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the Autodesk Revit project database in line with the definition of IEnumerator. Note that you must call MoveNext before the first element can be accessed via the Current property.

See Also

ElementIterator Class
Autodesk.Revit Namespace


ElementIterator Properties
CollapseAll image DropDown image

Syntax

C#
public class ElementIterator
Visual Basic (Declaration)
Public Class ElementIterator
Visual C++
public ref class ElementIterator

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | The object that represents the current element in the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIterator
Autodesk.Revit Namespace


Current Property

ElementIterator..::Current Property
CollapseAll image DropDown image

The object that represents the current element in the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Object Current{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Field Value

This object will be derived from Autodesk.Revit.Element.

Remarks

In order for this property to return a valid element after the iterator is first obtained or reset, the iterator must have MoveNext called upon it once.

See Also

ElementIterator Class
Autodesk.Revit Namespace


ElementSet Class
See Also Members
CollapseAll image DropDown image

A set that contains element objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7C79A689-EDA2-45b8-A0BA-9A4054641481")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElementSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("7C79A689-EDA2-45b8-A0BA-9A4054641481")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"7C79A689-EDA2-45b8-A0BA-9A4054641481")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementSet
Autodesk.Revit..::SelElementSet

See Also

ElementSet Members
Autodesk.Revit Namespace


ElementSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElementSet
Visual Basic (Declaration)
Public Class ElementSet
Visual C++
public ref class ElementSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementSetElementSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set.

See Also

ElementSet
Autodesk.Revit Namespace


ElementSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementSet ()

See Also

ElementSet Class
Autodesk.Revit Namespace


ElementSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ElementSet
Visual Basic (Declaration)
Public Class ElementSet
Visual C++
public ref class ElementSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElementSet
Autodesk.Revit Namespace


Clear Method

ElementSet..::Clear Method
CollapseAll image DropDown image

Removes every item element the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ElementSet Class
Autodesk.Revit Namespace


Contains Method

ElementSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an element within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Element^ item
)

Parameters

item
Element
The element to be searched for.

Return Value

The Contains method returns True if the element is within the set, otherwise False.

See Also

ElementSet Class
Autodesk.Revit Namespace


Dispose Method

ElementSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElementSet Class
Autodesk.Revit Namespace


Erase Method

ElementSet..::Erase Method
CollapseAll image DropDown image

Removes a specified element from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Element _
) As Integer
Visual C++
public:
virtual int Erase (
    Element^ item
)

Parameters

item
Element
The element to be erased.

Return Value

The number of elements that were erased from the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


ForwardIterator Method

ElementSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


GetEnumerator Method

ElementSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


Insert Method

ElementSet..::Insert Method
CollapseAll image DropDown image

Insert the specified element into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Element^ item
)

Parameters

item
Element
The element to be inserted into the set.

Return Value

Returns whether the element was inserted into the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ElementSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElementSet Class
Autodesk.Revit Namespace


ReverseIterator Method

ElementSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


ElementSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ElementSet
Visual Basic (Declaration)
Public Class ElementSet
Visual C++
public ref class ElementSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set.

See Also

ElementSet
Autodesk.Revit Namespace


IsEmpty Property

ElementSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElementSet Class
Autodesk.Revit Namespace


Size Property

ElementSet..::Size Property
CollapseAll image DropDown image

Returns the number of elements that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementSet Class
Autodesk.Revit Namespace


ElementSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6E99AF64-EBCD-4f27-9119-BCE17C1FACF9")]
public abstract class ElementSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6E99AF64-EBCD-4f27-9119-BCE17C1FACF9")> _
Public MustInherit Class ElementSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6E99AF64-EBCD-4f27-9119-BCE17C1FACF9")]
public ref class ElementSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementSetIterator

See Also

ElementSetIterator Members
Autodesk.Revit Namespace


ElementSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElementSetIterator
Visual C++
public ref class ElementSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementSetIteratorElementSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator
Autodesk.Revit Namespace


ElementSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ElementSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElementSetIterator
Visual C++
public ref class ElementSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElementSetIterator
Autodesk.Revit Namespace


Dispose Method

ElementSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

ElementSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ElementSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


Reset Method

ElementSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ElementSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElementSetIterator
Visual C++
public ref class ElementSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator
Autodesk.Revit Namespace


Current Property

ElementSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ExternalApplicationArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any number of IExternalApplication objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("480A6B7C-2990-4565-8D47-1D5CC11A8A58")]
public class ExternalApplicationArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("480A6B7C-2990-4565-8D47-1D5CC11A8A58")> _
Public Class ExternalApplicationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"480A6B7C-2990-4565-8D47-1D5CC11A8A58")]
public ref class ExternalApplicationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ExternalApplicationArray

See Also

ExternalApplicationArray Members
Autodesk.Revit Namespace


ExternalApplicationArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ExternalApplicationArray
Visual Basic (Declaration)
Public Class ExternalApplicationArray
Visual C++
public ref class ExternalApplicationArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExternalApplicationArrayExternalApplicationArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray
Autodesk.Revit Namespace


ExternalApplicationArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExternalApplicationArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalApplicationArray ()

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ExternalApplicationArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ExternalApplicationArray
Visual Basic (Declaration)
Public Class ExternalApplicationArray
Visual C++
public ref class ExternalApplicationArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ExternalApplicationArray
Autodesk.Revit Namespace


Append Method

ExternalApplicationArray..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    IExternalApplication item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As IExternalApplication _
)
Visual C++
public:
virtual void Append (
    IExternalApplication^ item
)

Parameters

item
IExternalApplication
The item to be added.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Clear Method

ExternalApplicationArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Dispose Method

ExternalApplicationArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ForwardIterator Method

ExternalApplicationArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ExternalApplicationArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


GetEnumerator Method

ExternalApplicationArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Insert Method

ExternalApplicationArray..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    IExternalApplication item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As IExternalApplication, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    IExternalApplication^ item,
    int index
)

Parameters

item
IExternalApplication
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ExternalApplicationArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ReverseIterator Method

ExternalApplicationArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ExternalApplicationArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ExternalApplicationArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ExternalApplicationArray
Visual Basic (Declaration)
Public Class ExternalApplicationArray
Visual C++
public ref class ExternalApplicationArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray
Autodesk.Revit Namespace


IsEmpty Property

ExternalApplicationArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Item Property

ExternalApplicationArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IExternalApplication Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As IExternalApplication
Visual C++
public:
virtual property IExternalApplication^ Item[int index] {
    IExternalApplication^ get (int index);
    void set (int index, IExternalApplication^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Size Property

ExternalApplicationArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of IExternalApplication objects..

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C76817C4-CD27-46bf-A85E-93AB11FFF4CE")]
public abstract class ExternalApplicationArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C76817C4-CD27-46bf-A85E-93AB11FFF4CE")> _
Public MustInherit Class ExternalApplicationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C76817C4-CD27-46bf-A85E-93AB11FFF4CE")]
public ref class ExternalApplicationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ExternalApplicationArrayIterator

See Also

ExternalApplicationArrayIterator Members
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ExternalApplicationArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ExternalApplicationArrayIterator
Visual C++
public ref class ExternalApplicationArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExternalApplicationArrayIteratorExternalApplicationArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExternalApplicationArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalApplicationArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ExternalApplicationArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ExternalApplicationArrayIterator
Visual C++
public ref class ExternalApplicationArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ExternalApplicationArrayIterator
Autodesk.Revit Namespace


Dispose Method

ExternalApplicationArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

ExternalApplicationArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ExternalApplicationArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


Reset Method

ExternalApplicationArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ExternalApplicationArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ExternalApplicationArrayIterator
Visual C++
public ref class ExternalApplicationArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator
Autodesk.Revit Namespace


Current Property

ExternalApplicationArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ExternalCommandData Class
See Also Members
CollapseAll image DropDown image

A class contains reference to Application and View which are needed by external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("68060C9A-ED4E-4b55-9849-AB6C1FF7EF94")]
public class ExternalCommandData : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("68060C9A-ED4E-4b55-9849-AB6C1FF7EF94")> _
Public Class ExternalCommandData _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"68060C9A-ED4E-4b55-9849-AB6C1FF7EF94")]
public ref class ExternalCommandData : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ExternalCommandData

See Also

ExternalCommandData Members
Autodesk.Revit Namespace


ExternalCommandData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ExternalCommandData
Visual Basic (Declaration)
Public Class ExternalCommandData
Visual C++
public ref class ExternalCommandData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExternalCommandDataExternalCommandDataNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Application | Retrieves an object that represents the current Application for external command.
Public property | Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData
Autodesk.Revit Namespace


ExternalCommandData Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExternalCommandData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalCommandData ()

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


ExternalCommandData Properties
CollapseAll image DropDown image

Syntax

C#
public class ExternalCommandData
Visual Basic (Declaration)
Public Class ExternalCommandData
Visual C++
public ref class ExternalCommandData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Application | Retrieves an object that represents the current Application for external command.
Public property | Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData
Autodesk.Revit Namespace


Application Property

ExternalCommandData..::Application Property
CollapseAll image DropDown image

Retrieves an object that represents the current Application for external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application Application{ get; set;}
Visual Basic (Declaration)
Public Property Application As Application
Visual C++
public:
property Application^ Application {
    Application^ get ();
    void set (Application^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


Data Property

ExternalCommandData..::Data Property
CollapseAll image DropDown image

A data map that can be used to read and write data to the Autodesk Revit journal file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringStringMap Data{ get; set;}
Visual Basic (Declaration)
Public Property Data As StringStringMap
Visual C++
public:
property StringStringMap^ Data {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

The data map is a string to string map that can be used to store data in the Revit journal file at the end of execution of the external command. If the command is then executed from the journal file during playback this data is then passed to the external command in this Data property so the external command can execute with this passed data in a UI-less mode, hence providing non interactive journal playback for automated testing purposes. For more information on Revit's journaling features contact the Autodesk Developer Network.

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


View Property

ExternalCommandData..::View Property
CollapseAll image DropDown image

Retrieves an object that represents the View external command work on.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View View{ get; set;}
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


FamilyFilter Class
See Also Members
CollapseAll image DropDown image

A filter object that used to filter family elements which satisfy specified criterion, filter elements via specifying family name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6BBD9055-0D7F-4148-93E4-A935B6408F86")]
public class FamilyFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6BBD9055-0D7F-4148-93E4-A935B6408F86")> _
Public Class FamilyFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6BBD9055-0D7F-4148-93E4-A935B6408F86")]
public ref class FamilyFilter : public Filter

Remarks

The filtered elements include: Family type elements, Symbol type elements, FamilyInstance type elements and other types instances(such as Door, Wall, etc) whose family is specified family. These elements should belong to main model, active design option or primary design option.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::FamilyFilter

See Also

FamilyFilter Members
Autodesk.Revit Namespace


FamilyFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FamilyFilter
Visual Basic (Declaration)
Public Class FamilyFilter
Visual C++
public ref class FamilyFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyFilterFamilyFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyFilter
Autodesk.Revit Namespace


FamilyFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyFilter Class
Autodesk.Revit Namespace


FamilyFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class FamilyFilter
Visual Basic (Declaration)
Public Class FamilyFilter
Visual C++
public ref class FamilyFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

FamilyFilter
Autodesk.Revit Namespace


Dispose Method

FamilyFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FamilyFilter Class
Autodesk.Revit Namespace


FBXExportOptions Class
See Also Members
CollapseAll image DropDown image

3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5CEE4533-A1E3-4c9b-B7D8-B53637B6219C")]
public class FBXExportOptions
Visual Basic (Declaration)
<GuidAttribute("5CEE4533-A1E3-4c9b-B7D8-B53637B6219C")> _
Public Class FBXExportOptions
Visual C++
[GuidAttribute(L"5CEE4533-A1E3-4c9b-B7D8-B53637B6219C")]
public ref class FBXExportOptions

Remarks

Not used currently. Reserved for future use

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::FBXExportOptions

See Also

FBXExportOptions Members
Autodesk.Revit Namespace


FBXExportOptions Members
See Also Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class FBXExportOptions
Visual Basic (Declaration)
Public Class FBXExportOptions
Visual C++
public ref class FBXExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FBXExportOptionsFBXExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

FBXExportOptions
Autodesk.Revit Namespace


FBXExportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FBXExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FBXExportOptions ()

See Also

FBXExportOptions Class
Autodesk.Revit Namespace


FillPatternSet Class
See Also Members
CollapseAll image DropDown image

A set that contains FillPatterns.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B5662AC9-5869-4942-B86E-291E6FB58BBB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FillPatternSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("B5662AC9-5869-4942-B86E-291E6FB58BBB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FillPatternSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"B5662AC9-5869-4942-B86E-291E6FB58BBB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FillPatternSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::FillPatternSet

See Also

FillPatternSet Members
Autodesk.Revit Namespace


FillPatternSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FillPatternSet
Visual Basic (Declaration)
Public Class FillPatternSet
Visual C++
public ref class FillPatternSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FillPatternSetFillPatternSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every fill pattern from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fill pattern within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified fill pattern from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified fill pattern into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet
Autodesk.Revit Namespace


FillPatternSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPatternSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPatternSet ()

See Also

FillPatternSet Class
Autodesk.Revit Namespace


FillPatternSet Methods
CollapseAll image DropDown image

Syntax

C#
public class FillPatternSet
Visual Basic (Declaration)
Public Class FillPatternSet
Visual C++
public ref class FillPatternSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every fill pattern from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fill pattern within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified fill pattern from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified fill pattern into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FillPatternSet
Autodesk.Revit Namespace


Clear Method

FillPatternSet..::Clear Method
CollapseAll image DropDown image

Removes every fill pattern from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Contains Method

FillPatternSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a fill pattern within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FillPattern _
) As Boolean
Visual C++
public:
virtual bool Contains (
    FillPattern^ item
)

Parameters

item
FillPattern
The fill pattern to be searched for.

Return Value

The Contains method returns True if the fill pattern is within the set, otherwise False.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Dispose Method

FillPatternSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Erase Method

FillPatternSet..::Erase Method
CollapseAll image DropDown image

Removes a specified fill pattern from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FillPattern _
) As Integer
Visual C++
public:
virtual int Erase (
    FillPattern^ item
)

Parameters

item
FillPattern
The fill pattern to be erased.

Return Value

The number of fill patterns that were erased from the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


ForwardIterator Method

FillPatternSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FillPatternSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FillPatternSetIterator
Visual C++
public:
virtual FillPatternSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


GetEnumerator Method

FillPatternSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Insert Method

FillPatternSet..::Insert Method
CollapseAll image DropDown image

Insert the specified fill pattern into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FillPattern _
) As Boolean
Visual C++
public:
virtual bool Insert (
    FillPattern^ item
)

Parameters

item
FillPattern
The fill pattern to be inserted into the set.

Return Value

Returns whether the fill pattern was inserted into the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

FillPatternSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FillPatternSet Class
Autodesk.Revit Namespace


ReverseIterator Method

FillPatternSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FillPatternSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FillPatternSetIterator
Visual C++
public:
virtual FillPatternSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


FillPatternSet Properties
CollapseAll image DropDown image

Syntax

C#
public class FillPatternSet
Visual Basic (Declaration)
Public Class FillPatternSet
Visual C++
public ref class FillPatternSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet
Autodesk.Revit Namespace


IsEmpty Property

FillPatternSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Size Property

FillPatternSet..::Size Property
CollapseAll image DropDown image

Returns the number of fill patterns that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FillPatternSet Class
Autodesk.Revit Namespace


FillPatternSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a FillPattern set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("501BCC8A-B709-40f9-91F5-7BDC0D02D80C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class FillPatternSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("501BCC8A-B709-40f9-91F5-7BDC0D02D80C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class FillPatternSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"501BCC8A-B709-40f9-91F5-7BDC0D02D80C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FillPatternSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::FillPatternSetIterator

See Also

FillPatternSetIterator Members
Autodesk.Revit Namespace


FillPatternSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class FillPatternSetIterator
Visual Basic (Declaration)
Public MustInherit Class FillPatternSetIterator
Visual C++
public ref class FillPatternSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FillPatternSetIteratorFillPatternSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FillPatternSetIterator
Autodesk.Revit Namespace


FillPatternSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPatternSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPatternSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


FillPatternSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class FillPatternSetIterator
Visual Basic (Declaration)
Public MustInherit Class FillPatternSetIterator
Visual C++
public ref class FillPatternSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FillPatternSetIterator
Autodesk.Revit Namespace


Dispose Method

FillPatternSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

FillPatternSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

FillPatternSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


Reset Method

FillPatternSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


FillPatternSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class FillPatternSetIterator
Visual Basic (Declaration)
Public MustInherit Class FillPatternSetIterator
Visual C++
public ref class FillPatternSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FillPatternSetIterator
Autodesk.Revit Namespace


Current Property

FillPatternSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


Filter Class
See Also Members
CollapseAll image DropDown image

Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("24E91405-DEB5-448b-B07F-325F66AA654A")]
public abstract class Filter : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("24E91405-DEB5-448b-B07F-325F66AA654A")> _
Public MustInherit Class Filter _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"24E91405-DEB5-448b-B07F-325F66AA654A")]
public ref class Filter abstract : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::CategoryFilter
Autodesk.Revit..::FamilyFilter
Autodesk.Revit..::InstanceUsageFilter
Autodesk.Revit..::MaterialFilter
Autodesk.Revit..::ParameterFilter
Autodesk.Revit..::StructuralTypeFilter
Autodesk.Revit..::SymbolFilter
Autodesk.Revit..::TypeFilter
Autodesk.Revit..::WallUsageFilter
Autodesk.Revit..::LogicAndFilter
Autodesk.Revit..::LogicOrFilter
Autodesk.Revit..::LogicNotFilter

See Also

Filter Members
Autodesk.Revit Namespace


Filter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class Filter
Visual Basic (Declaration)
Public MustInherit Class Filter
Visual C++
public ref class Filter abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LogicalAnd | Overload operator && for new Logic-AND filter.
 | LogicalNot | Overload operator ! for new Logic-Not filter.
 | LogicalOr | Overload operator || for new Logic-OR filter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter
Autodesk.Revit Namespace


Filter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Filter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Filter Class
Autodesk.Revit Namespace


Filter Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class Filter
Visual Basic (Declaration)
Public MustInherit Class Filter
Visual C++
public ref class Filter abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LogicalAnd | Overload operator && for new Logic-AND filter.
 | LogicalNot | Overload operator ! for new Logic-Not filter.
 | LogicalOr | Overload operator || for new Logic-OR filter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Filter
Autodesk.Revit Namespace


Dispose Method

Filter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Filter Class
Autodesk.Revit Namespace


LogicalAnd Operator

Filter..::LogicalAnd Operator
CollapseAll image DropDown image

Overload operator && for new Logic-AND filter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
C# does not support this operator.
Visual Basic (Declaration)
Visual Basic does not support this operator.
Visual C++
Visual C++ does not support this operator.

Parameters

leftFilter
Filter
leftFilter which is left operand of Logic-AND operator.
rightFilter
Filter
rightFilter which is right operand of Logic-AND operator.

Return Value

Returns a new LogicAndFilter object.

See Also

Filter Class
Autodesk.Revit Namespace


LogicalNot Operator

Filter..::LogicalNot Operator
CollapseAll image DropDown image

Overload operator ! for new Logic-Not filter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static LogicNotFilter operator !(
    Filter subFilter
)
Visual Basic (Declaration)
Public Shared Operator Not ( _
    subFilter As Filter _
) As LogicNotFilter
Visual C++
public:
static LogicNotFilter^ operator ! (
    Filter^ subFilter
)

Parameters

subFilter
Filter
subFilter which is an operand of Logic-NOT operator.

Return Value

Returns a new LogicNotFilter object.

See Also

Filter Class
Autodesk.Revit Namespace


LogicalOr Operator

Filter..::LogicalOr Operator
CollapseAll image DropDown image

Overload operator || for new Logic-OR filter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
C# does not support this operator.
Visual Basic (Declaration)
Visual Basic does not support this operator.
Visual C++
Visual C++ does not support this operator.

Parameters

leftFilter
Filter
leftFilter which is left operand of Logic-OR operator.
rightFilter
Filter
rightFilter which is right operand of Logic-OR operator.

Return Value

Returns a new LogicOrFilter object.

See Also

Filter Class
Autodesk.Revit Namespace


FilterCriterion Class
See Also Members
CollapseAll image DropDown image

An object that defines the criteria as the filter for retrieving certain needed elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3E651097-7CC6-4ce6-BF8F-5BF97009F270")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FilterCriterion : APIObject
Visual Basic (Declaration)
<GuidAttribute("3E651097-7CC6-4ce6-BF8F-5BF97009F270")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FilterCriterion _
    Inherits APIObject
Visual C++
[GuidAttribute(L"3E651097-7CC6-4ce6-BF8F-5BF97009F270")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FilterCriterion : public APIObject

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::FilterCriterion

See Also

FilterCriterion Members
Autodesk.Revit Namespace


FilterCriterion Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FilterCriterion
Visual Basic (Declaration)
Public Class FilterCriterion
Visual C++
public ref class FilterCriterion

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterCriterionFilterCriterionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | FilterType | Gets or sets the filter type of this criterion.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | Gets or sets the parameter of this criterion by builtin parameter.
Public property | ParameterID | Gets or sets the parameter of this criterion by parameter id.
Public property | ParameterValue | Gets or sets the parameter value of this criterion.

See Also

FilterCriterion
Autodesk.Revit Namespace


FilterCriterion Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FilterCriterion()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterCriterion ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FilterCriterion Methods
CollapseAll image DropDown image

Syntax

C#
public class FilterCriterion
Visual Basic (Declaration)
Public Class FilterCriterion
Visual C++
public ref class FilterCriterion

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FilterCriterion
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

FilterCriterion..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FilterCriterion Properties
CollapseAll image DropDown image

Syntax

C#
public class FilterCriterion
Visual Basic (Declaration)
Public Class FilterCriterion
Visual C++
public ref class FilterCriterion

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | FilterType | Gets or sets the filter type of this criterion.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | Gets or sets the parameter of this criterion by builtin parameter.
Public property | ParameterID | Gets or sets the parameter of this criterion by parameter id.
Public property | ParameterValue | Gets or sets the parameter value of this criterion.

See Also

FilterCriterion
Autodesk.Revit Namespace


FilterType Property

FilterCriterion..::FilterType Property
CollapseAll image DropDown image

Gets or sets the filter type of this criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CriteriaFilterType FilterType{ get; set;}
Visual Basic (Declaration)
Public Property FilterType As CriteriaFilterType
Visual C++
public:
property CriteriaFilterType FilterType {
    CriteriaFilterType get ();
    void set (CriteriaFilterType value);
}

Remarks

The filter type defines the relationship between the parameter of certain element and the parameter value which is specified by the property of ParameterValue.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


Parameter Property

FilterCriterion..::Parameter Property
CollapseAll image DropDown image

Gets or sets the parameter of this criterion by builtin parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BuiltInParameter Parameter{ get; set;}
Visual Basic (Declaration)
Public Property Parameter As BuiltInParameter
Visual C++
public:
property BuiltInParameter Parameter {
    BuiltInParameter get ();
    void set (BuiltInParameter value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


ParameterID Property

FilterCriterion..::ParameterID Property
CollapseAll image DropDown image

Gets or sets the parameter of this criterion by parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId ParameterID{ get; set;}
Visual Basic (Declaration)
Public Property ParameterID As ElementId
Visual C++
public:
property ElementId ParameterID {
    ElementId get ();
    void set (ElementId value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


ParameterValue Property

FilterCriterion..::ParameterValue Property
CollapseAll image DropDown image

Gets or sets the parameter value of this criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterStorage ParameterValue{ get; set;}
Visual Basic (Declaration)
Public Property ParameterValue As ParameterStorage
Visual C++
public:
property ParameterStorage^ ParameterValue {
    ParameterStorage^ get ();
    void set (ParameterStorage^ value);
}

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter of ParameterStorage is null.
System..::InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FormatOptions Class
See Also Members
CollapseAll image DropDown image

Contains the Unit information of current user selection of Unit within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A07FEB06-BCDF-416d-8B46-23AF07A1E1D5")]
public class FormatOptions : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A07FEB06-BCDF-416d-8B46-23AF07A1E1D5")> _
Public Class FormatOptions _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A07FEB06-BCDF-416d-8B46-23AF07A1E1D5")]
public ref class FormatOptions : public APIObject

Remarks

The FormatOptions contains 5 item. Rounding and UnitSymbol properties depend on the Units propery.All these three properties provided set function, but it is more rigid on input.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::FormatOptions

See Also

FormatOptions Members
Autodesk.Revit Namespace


FormatOptions Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FormatOptions
Visual Basic (Declaration)
Public Class FormatOptions
Visual C++
public ref class FormatOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FormatOptionsFormatOptionsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Group | Retrieves the Group of Units Type that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieves the Name of Units Type that are currently selected.
Public property | Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Public property | Units | Retrieves the Units Type that are currently selected.
Public property | Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions
Autodesk.Revit Namespace


FormatOptions Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FormatOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FormatOptions ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FormatOptions Class
Autodesk.Revit Namespace


FormatOptions Properties
CollapseAll image DropDown image

Syntax

C#
public class FormatOptions
Visual Basic (Declaration)
Public Class FormatOptions
Visual C++
public ref class FormatOptions

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Group | Retrieves the Group of Units Type that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieves the Name of Units Type that are currently selected.
Public property | Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Public property | Units | Retrieves the Units Type that are currently selected.
Public property | Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions
Autodesk.Revit Namespace


Group Property

FormatOptions..::Group Property
CollapseAll image DropDown image

Retrieves the Group of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UnitGroup Group{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Group As UnitGroup
Visual C++
public:
property UnitGroup Group {
    UnitGroup get ();
}

Remarks

Commond or Structural, etc.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Name Property

FormatOptions..::Name Property
CollapseAll image DropDown image

Retrieves the Name of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Get the Name of Units Type that are currently selected.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Rounding Property

FormatOptions..::Rounding Property
CollapseAll image DropDown image

Retrieves the Rounding/Accuracy of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Rounding{ get; set;}
Visual Basic (Declaration)
Public Property Rounding As Double
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Remarks

You can set a non-negative double value to Rounding property, if there is no this type in UI Combox, it will show us Custom value. and if you input a negative value, it will correct to 1.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Units Property

FormatOptions..::Units Property
CollapseAll image DropDown image

Retrieves the Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DisplayUnitType Units{ get; set;}
Visual Basic (Declaration)
Public Property Units As DisplayUnitType
Visual C++
public:
property DisplayUnitType Units {
    DisplayUnitType get ();
    void set (DisplayUnitType value);
}

Remarks

The Units property returns the Units Type that were selected at the Format Options Dialog.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Unitsymbol Property

FormatOptions..::Unitsymbol Property
CollapseAll image DropDown image

Retrieves the Unit Symbol of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UnitSymbolType Unitsymbol{ get; set;}
Visual Basic (Declaration)
Public Property Unitsymbol As UnitSymbolType
Visual C++
public:
property UnitSymbolType Unitsymbol {
    UnitSymbolType get ();
    void set (UnitSymbolType value);
}

Remarks

You can set or get Unit Symbol of Units Type that are currently selected. If current DisplayUnitType do NOT support Unit Symbol and you have inputed as well, it will throw an InvalidOperationException. If current DisplayUnitType support, and you set a unfit enum value, it will throw an ArgumentOutOfRangeException.

See Also

FormatOptions Class
Autodesk.Revit Namespace


GBXMLExportOptions Class
See Also Members
CollapseAll image DropDown image

Gren-Building XML Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C2068451-781B-4c86-B123-49E6D1AACDC1")]
public class GBXMLExportOptions
Visual Basic (Declaration)
<GuidAttribute("C2068451-781B-4c86-B123-49E6D1AACDC1")> _
Public Class GBXMLExportOptions
Visual C++
[GuidAttribute(L"C2068451-781B-4c86-B123-49E6D1AACDC1")]
public ref class GBXMLExportOptions

Remarks

Not used currently. Reserved for future use

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::GBXMLExportOptions

See Also

GBXMLExportOptions Members
Autodesk.Revit Namespace


GBXMLExportOptions Members
See Also Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class GBXMLExportOptions
Visual Basic (Declaration)
Public Class GBXMLExportOptions
Visual C++
public ref class GBXMLExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GBXMLExportOptionsGBXMLExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

GBXMLExportOptions
Autodesk.Revit Namespace


GBXMLExportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GBXMLExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GBXMLExportOptions ()

See Also

GBXMLExportOptions Class
Autodesk.Revit Namespace


GenericImportOptions Class
See Also Members
CollapseAll image DropDown image

Generic Import options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C196E36D-504F-4b4e-9B17-B55B7DF6EBC8")]
public abstract class GenericImportOptions
Visual Basic (Declaration)
<GuidAttribute("C196E36D-504F-4b4e-9B17-B55B7DF6EBC8")> _
Public MustInherit Class GenericImportOptions
Visual C++
[GuidAttribute(L"C196E36D-504F-4b4e-9B17-B55B7DF6EBC8")]
public ref class GenericImportOptions abstract

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::GenericImportOptions
Autodesk.Revit..::CADImportOptions
Autodesk.Revit..::ImageImportOptions

See Also

GenericImportOptions Members
Autodesk.Revit Namespace


GenericImportOptions Members
See Also Methods Constructors Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class GenericImportOptions
Visual Basic (Declaration)
Public MustInherit Class GenericImportOptions
Visual C++
public ref class GenericImportOptions abstract

The type exposes the following members.

Protected Constructors

 | Name | Description
Protected method | GenericImportOptionsGenericImportOptionsNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted.
Public field | View | A view into which the image is going to be imported.

See Also

GenericImportOptions
Autodesk.Revit Namespace


GenericImportOptions Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected GenericImportOptions()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
GenericImportOptions ()

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


GenericImportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public abstract class GenericImportOptions
Visual Basic (Declaration)
Public MustInherit Class GenericImportOptions
Visual C++
public ref class GenericImportOptions abstract

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted.
Public field | View | A view into which the image is going to be imported.

See Also

GenericImportOptions
Autodesk.Revit Namespace


RefPoint Field

GenericImportOptions..::RefPoint Field
CollapseAll image DropDown image

Reference point (in Revit) to which the image is going to be inserted.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ RefPoint
Visual Basic (Declaration)
Public RefPoint As XYZ
Visual C++
public:
XYZ^ RefPoint

Remarks

If null, the image will be inserted to the Revit's origin.

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


View Field

GenericImportOptions..::View Field
CollapseAll image DropDown image

A view into which the image is going to be imported.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View View
Visual Basic (Declaration)
Public View As View
Visual C++
public:
View^ View

Remarks

If null, the document's active view will be used.

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


IExtension Interface
See Also Members
CollapseAll image DropDown image

An interface that supports the additonal operation for Extension Status

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("490BADC2-0080-43d7-BBF2-8450D2178D15")]
public interface IExtension
Visual Basic (Declaration)
<GuidAttribute("490BADC2-0080-43d7-BBF2-8450D2178D15")> _
Public Interface IExtension
Visual C++
[GuidAttribute(L"490BADC2-0080-43d7-BBF2-8450D2178D15")]
public interface class IExtension

Remarks

See Also

IExtension Members
Autodesk.Revit Namespace


IExtension Members
See Also Properties
CollapseAll image DropDown image

Syntax

C#
public interface IExtension
Visual Basic (Declaration)
Public Interface IExtension
Visual C++
public interface class IExtension

The type exposes the following members.

Public Properties

 | Name | Description
Public property | Extended | Retrieves or set the extension status at the end
Public property | HasMiter | Retrieves the miter status at the end
Public property | IsMiterLocked | Retrieves or set the miter locked status at the end.
Public property | SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension
Autodesk.Revit Namespace


IExtension Properties
CollapseAll image DropDown image

Syntax

C#
public interface IExtension
Visual Basic (Declaration)
Public Interface IExtension
Visual C++
public interface class IExtension

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Extended | Retrieves or set the extension status at the end
Public property | HasMiter | Retrieves the miter status at the end
Public property | IsMiterLocked | Retrieves or set the miter locked status at the end.
Public property | SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension
Autodesk.Revit Namespace


Extended Property

IExtension..::Extended Property
CollapseAll image DropDown image

Retrieves or set the extension status at the end

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
bool Extended[
    int index
]{ get; set;}
Visual Basic (Declaration)
Property Extended ( _
    index As Integer _
) As Boolean
Visual C++
property bool Extended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, if the beam extension status is changed, other status such as the symbolic extension status, miter status, miter locked status, and other beams extension status will be changed automatically at the same time. This change can protect that a join can have up to two extended beams, if there are two extended beams at the join, they shall be mitered.

See Also

IExtension Interface
Autodesk.Revit Namespace


HasMiter Property

IExtension..::HasMiter Property
CollapseAll image DropDown image

Retrieves the miter status at the end

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
bool HasMiter[
    int index
]{ get;}
Visual Basic (Declaration)
ReadOnly Property HasMiter ( _
    index As Integer _
) As Boolean
Visual C++
property bool HasMiter[int index] {
    bool get (int index);
}

Parameters

index
Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, this can check whether the beam is mitered with other beams at the end

See Also

IExtension Interface
Autodesk.Revit Namespace


IsMiterLocked Property

IExtension..::IsMiterLocked Property
CollapseAll image DropDown image

Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
bool IsMiterLocked[
    int index
]{ get; set;}
Visual Basic (Declaration)
Property IsMiterLocked ( _
    index As Integer _
) As Boolean
Visual C++
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid

See Also

IExtension Interface
Autodesk.Revit Namespace


SymbolicExtended Property

IExtension..::SymbolicExtended Property
CollapseAll image DropDown image

Retrieves or set the symbolic extension status at the end

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
bool SymbolicExtended[
    int index
]{ get; set;}
Visual Basic (Declaration)
Property SymbolicExtended ( _
    index As Integer _
) As Boolean
Visual C++
property bool SymbolicExtended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked at the end. Otherwise the setting is invalid

See Also

IExtension Interface
Autodesk.Revit Namespace


IExternalApplication Interface
See Also Members
CollapseAll image DropDown image

An interface that when support provides additional applications within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B2C17B9E-54E6-4147-A320-77450D57265A")]
public interface IExternalApplication
Visual Basic (Declaration)
<GuidAttribute("B2C17B9E-54E6-4147-A320-77450D57265A")> _
Public Interface IExternalApplication
Visual C++
[GuidAttribute(L"B2C17B9E-54E6-4147-A320-77450D57265A")]
public interface class IExternalApplication

Remarks

To add an external application to Autodesk Revit the developer should implement an object that supports the IExternalApplication interface.

See Also

IExternalApplication Members
Autodesk.Revit Namespace


IExternalApplication Members
See Also Methods
CollapseAll image DropDown image

Syntax

C#
public interface IExternalApplication
Visual Basic (Declaration)
Public Interface IExternalApplication
Visual C++
public interface class IExternalApplication

The type exposes the following members.

Public Methods

 | Name | Description
Public method | OnShutdown | Provide an interface for the user to do some extra work when Revit closes.
Public method | OnStartup | Provide an interface for the user to do some extra work when Revit starts.

See Also

IExternalApplication
Autodesk.Revit Namespace


IExternalApplication Methods
CollapseAll image DropDown image

Syntax

C#
public interface IExternalApplication
Visual Basic (Declaration)
Public Interface IExternalApplication
Visual C++
public interface class IExternalApplication

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | OnShutdown | Provide an interface for the user to do some extra work when Revit closes.
Public method | OnStartup | Provide an interface for the user to do some extra work when Revit starts.

See Also

IExternalApplication
Autodesk.Revit Namespace


OnShutdown Method

IExternalApplication..::OnShutdown Method
CollapseAll image DropDown image

Provide an interface for the user to do some extra work when Revit closes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
IExternalApplication.IExternalApplication..::Result OnShutdown(
    ControlledApplication application
)
Visual Basic (Declaration)
Function OnShutdown ( _
    application As ControlledApplication _
) As IExternalApplication..::Result
Visual C++
IExternalApplication..::Result OnShutdown (
    ControlledApplication^ application
)

Parameters

application
ControlledApplication
The application is being shut down.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an exteranl application, the task within OnShutdown will be executed when Revit closes.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace


OnStartup Method

IExternalApplication..::OnStartup Method
CollapseAll image DropDown image

Provide an interface for the user to do some extra work when Revit starts.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
IExternalApplication.IExternalApplication..::Result OnStartup(
    ControlledApplication application
)
Visual Basic (Declaration)
Function OnStartup ( _
    application As ControlledApplication _
) As IExternalApplication..::Result
Visual C++
IExternalApplication..::Result OnStartup (
    ControlledApplication^ application
)

Parameters

application
ControlledApplication
The application is being started.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an exteranl application, the task within OnStartup will be executed when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace


IExternalApplication..::Result Enumeration
CollapseAll image DropDown image

Informs Autodesk Revit of the status of your application after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CC16E821-AE76-4437-9F41-DEC39752DA34")]
public enum Result
Visual Basic (Declaration)
<GuidAttribute("CC16E821-AE76-4437-9F41-DEC39752DA34")> _
Public Enumeration Result
Visual C++
[GuidAttribute(L"CC16E821-AE76-4437-9F41-DEC39752DA34")]
public enum class Result

Members

Member name | Description
Cancelled | Signifies that the external application is cancelled.
Succeeded | The external application completed successfully. Autodesk Revit will keep this object during the entire Revit session.
Failed | The external application was unable to complete its task.

See Also

Autodesk.Revit Namespace


IExternalCommand Interface
See Also Members
CollapseAll image DropDown image

An interface that when support provides additional commands within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1D2E879E-22AA-420f-9607-AFC45D9733F6")]
public interface IExternalCommand
Visual Basic (Declaration)
<GuidAttribute("1D2E879E-22AA-420f-9607-AFC45D9733F6")> _
Public Interface IExternalCommand
Visual C++
[GuidAttribute(L"1D2E879E-22AA-420f-9607-AFC45D9733F6")]
public interface class IExternalCommand

Remarks

To add an external command to Autodesk Revit the developer should implement an object that supports the IExternalCommand interface.

See Also

IExternalCommand Members
Autodesk.Revit Namespace


IExternalCommand Members
See Also Methods
CollapseAll image DropDown image

Syntax

C#
public interface IExternalCommand
Visual Basic (Declaration)
Public Interface IExternalCommand
Visual C++
public interface class IExternalCommand

The type exposes the following members.

Public Methods

 | Name | Description
Public method | Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand
Autodesk.Revit Namespace


IExternalCommand Methods
CollapseAll image DropDown image

Syntax

C#
public interface IExternalCommand
Visual Basic (Declaration)
Public Interface IExternalCommand
Visual C++
public interface class IExternalCommand

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand
Autodesk.Revit Namespace


Execute Method

IExternalCommand..::Execute Method
CollapseAll image DropDown image

Overload this method to implement and external command within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
IExternalCommand.IExternalCommand..::Result Execute(
    ExternalCommandData commandData,
    out string message,
    ElementSet elements
)
Visual Basic (Declaration)
Function Execute ( _
    commandData As ExternalCommandData, _
    <OutAttribute> ByRef message As String, _
    <OutAttribute> elements As ElementSet _
) As IExternalCommand..::Result
Visual C++
IExternalCommand..::Result Execute (
    ExternalCommandData^ commandData,
    [InAttribute] [OutAttribute] String^% message,
    [InAttribute] [OutAttribute] ElementSet^ elements
)

Parameters

commandData
ExternalCommandData
A ExternalCommandData object which contains reference to Application and View needed by external command.
message
String %
Error message can be returned by external command.
elements
ElementSet
Element set could be used for transferring elements between external command and Autodesk Revit.

Return Value

Result tells whether the excution fail,succeed or was canceled by user. If not succeed, Autodesk Revit should undo any changes made by the external command.

See Also

IExternalCommand Interface
Autodesk.Revit Namespace


IExternalCommand..::Result Enumeration
CollapseAll image DropDown image

Informs Autodesk Revit of the status of your command after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("93E200E9-2024-4e04-9E3A-C4EDCCD67B8B")]
public enum Result
Visual Basic (Declaration)
<GuidAttribute("93E200E9-2024-4e04-9E3A-C4EDCCD67B8B")> _
Public Enumeration Result
Visual C++
[GuidAttribute(L"93E200E9-2024-4e04-9E3A-C4EDCCD67B8B")]
public enum class Result

Members

Member name | Description
Cancelled | Signifies that the user cancelled the external command. Autodesk Revit should undo any changes made by the external command but not signal a failure.
Succeeded | The external command completed successfully. Autodesk Revit will keep any changes made by the external command.
Failed | The external command was unable to complete its task. Autodesk Revit should undo any operations that the external command performed and signal a failure.

See Also

Autodesk.Revit Namespace


ImageImportOptions Class
See Also Members
CollapseAll image DropDown image

Import options specific image (bitmap) formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("70AD7890-A80E-4c5a-864D-D946F034D130")]
public class ImageImportOptions : GenericImportOptions
Visual Basic (Declaration)
<GuidAttribute("70AD7890-A80E-4c5a-864D-D946F034D130")> _
Public Class ImageImportOptions _
    Inherits GenericImportOptions
Visual C++
[GuidAttribute(L"70AD7890-A80E-4c5a-864D-D946F034D130")]
public ref class ImageImportOptions : public GenericImportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::GenericImportOptions
Autodesk.Revit..::ImageImportOptions

See Also

ImageImportOptions Members
Autodesk.Revit Namespace


ImageImportOptions Members
See Also Fields Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class ImageImportOptions
Visual Basic (Declaration)
Public Class ImageImportOptions
Visual C++
public ref class ImageImportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ImageImportOptionsImageImportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | Placement | Placement mode defines by which point is the image goind to be inserted.
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | Resolution | Resolution [ppi] of the image to be imported.
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

ImageImportOptions
Autodesk.Revit Namespace


ImageImportOptions Constructor
CollapseAll image DropDown image

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ImageImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageImportOptions ()

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


ImageImportOptions Fields
CollapseAll image DropDown image

Syntax

C#
public class ImageImportOptions
Visual Basic (Declaration)
Public Class ImageImportOptions
Visual C++
public ref class ImageImportOptions

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | Placement | Placement mode defines by which point is the image goind to be inserted.
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | Resolution | Resolution [ppi] of the image to be imported.
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

ImageImportOptions
Autodesk.Revit Namespace


Placement Field

ImageImportOptions..::Placement Field
CollapseAll image DropDown image

Placement mode defines by which point is the image goind to be inserted.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoxPlacement Placement
Visual Basic (Declaration)
Public Placement As BoxPlacement
Visual C++
public:
BoxPlacement Placement

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


Resolution Field

ImageImportOptions..::Resolution Field
CollapseAll image DropDown image

Resolution [ppi] of the image to be imported.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ushort Resolution
Visual Basic (Declaration)
Public Resolution As UShort
Visual C++
public:
unsigned short Resolution

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


InstanceUsageFilter Class
See Also Members
CollapseAll image DropDown image

Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("86A213E1-C5E0-49d7-AB5D-81322340AC2A")]
public class InstanceUsageFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("86A213E1-C5E0-49d7-AB5D-81322340AC2A")> _
Public Class InstanceUsageFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"86A213E1-C5E0-49d7-AB5D-81322340AC2A")]
public ref class InstanceUsageFilter : public Filter

Remarks

The InstanceUsageFilter object is to filter all the elements with the given InstanceUsage/StructuralUsage in the active document. FamilyInstance (only brace and beam) has the property StructuralUsage.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::InstanceUsageFilter

See Also

InstanceUsageFilter Members
Autodesk.Revit Namespace


InstanceUsageFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InstanceUsageFilter
Visual Basic (Declaration)
Public Class InstanceUsageFilter
Visual C++
public ref class InstanceUsageFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceUsageFilterInstanceUsageFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceUsageFilter
Autodesk.Revit Namespace


InstanceUsageFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceUsageFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceUsageFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InstanceUsageFilter Class
Autodesk.Revit Namespace


InstanceUsageFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class InstanceUsageFilter
Visual Basic (Declaration)
Public Class InstanceUsageFilter
Visual C++
public ref class InstanceUsageFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

InstanceUsageFilter
Autodesk.Revit Namespace


Dispose Method

InstanceUsageFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InstanceUsageFilter Class
Autodesk.Revit Namespace


JoinType Enumeration
CollapseAll image DropDown image

The type of join at the end of an element. The join type affects only geometric treatment, i.e. cleaning of the end, and not join behavior.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E36E9F08-7163-44cd-9E08-1535E169B491")]
public enum JoinType
Visual Basic (Declaration)
<GuidAttribute("E36E9F08-7163-44cd-9E08-1535E169B491")> _
Public Enumeration JoinType
Visual C++
[GuidAttribute(L"E36E9F08-7163-44cd-9E08-1535E169B491")]
public enum class JoinType

Members

Member name | Description
None | No join type
Extension | Extension Join
SquareOff | Square-off Join
Miter | Miter Join
Abut | Abut Join

See Also

Autodesk.Revit Namespace


Leader Class
See Also Members
CollapseAll image DropDown image

An object that represents a Leader within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F8C25806-26EB-450f-AE4F-B6F2E8C7489D")]
public class Leader : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F8C25806-26EB-450f-AE4F-B6F2E8C7489D")> _
Public Class Leader _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F8C25806-26EB-450f-AE4F-B6F2E8C7489D")]
public ref class Leader : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Leader.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Leader

See Also

Leader Members
Autodesk.Revit Namespace


Leader Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Leader
Visual Basic (Declaration)
Public Class Leader
Visual C++
public ref class Leader

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LeaderLeaderNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Elbow | Retrieves and sets the Elbow point of the Leader.
Public property | End | Retrieves and sets the End point of the Leader.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader
Autodesk.Revit Namespace


Leader Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Leader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Leader ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Leader Class
Autodesk.Revit Namespace


Leader Properties
CollapseAll image DropDown image

Syntax

C#
public class Leader
Visual Basic (Declaration)
Public Class Leader
Visual C++
public ref class Leader

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Elbow | Retrieves and sets the Elbow point of the Leader.
Public property | End | Retrieves and sets the End point of the Leader.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader
Autodesk.Revit Namespace


Elbow Property

Leader..::Elbow Property
CollapseAll image DropDown image

Retrieves and sets the Elbow point of the Leader.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Elbow{ get; set;}
Visual Basic (Declaration)
Public Property Elbow As XYZ
Visual C++
public:
property XYZ^ Elbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Elbow point of the specified Leader object can be taken and set with this Elbow property.

See Also

Leader Class
Autodesk.Revit Namespace


End Property

Leader..::End Property
CollapseAll image DropDown image

Retrieves and sets the End point of the Leader.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ End{ get; set;}
Visual Basic (Declaration)
Public Property End As XYZ
Visual C++
public:
property XYZ^ End {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The End point of the specified Leader object can be taken and set with this End property.

See Also

Leader Class
Autodesk.Revit Namespace


LeaderArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any number of leaders.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("05810507-5AC3-4458-BED3-21F2D188359E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LeaderArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("05810507-5AC3-4458-BED3-21F2D188359E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LeaderArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"05810507-5AC3-4458-BED3-21F2D188359E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LeaderArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::LeaderArray

See Also

LeaderArray Members
Autodesk.Revit Namespace


LeaderArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LeaderArray
Visual Basic (Declaration)
Public Class LeaderArray
Visual C++
public ref class LeaderArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LeaderArrayLeaderArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LeaderArray
Autodesk.Revit Namespace


LeaderArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LeaderArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeaderArray ()

See Also

LeaderArray Class
Autodesk.Revit Namespace


LeaderArray Methods
CollapseAll image DropDown image

Syntax

C#
public class LeaderArray
Visual Basic (Declaration)
Public Class LeaderArray
Visual C++
public ref class LeaderArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LeaderArray
Autodesk.Revit Namespace


Append Method

LeaderArray..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Leader item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Leader _
)
Visual C++
public:
virtual void Append (
    Leader^ item
)

Parameters

item
Leader
The item to be added.

See Also

LeaderArray Class
Autodesk.Revit Namespace


Clear Method

LeaderArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LeaderArray Class
Autodesk.Revit Namespace


Dispose Method

LeaderArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LeaderArray Class
Autodesk.Revit Namespace


ForwardIterator Method

LeaderArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LeaderArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


GetEnumerator Method

LeaderArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


Insert Method

LeaderArray..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Leader item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Leader, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Leader^ item,
    int index
)

Parameters

item
Leader
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

LeaderArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LeaderArray Class
Autodesk.Revit Namespace


ReverseIterator Method

LeaderArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LeaderArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


LeaderArray Properties
CollapseAll image DropDown image

Syntax

C#
public class LeaderArray
Visual Basic (Declaration)
Public Class LeaderArray
Visual C++
public ref class LeaderArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LeaderArray
Autodesk.Revit Namespace


IsEmpty Property

LeaderArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LeaderArray Class
Autodesk.Revit Namespace


Item Property

LeaderArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Leader Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Leader
Visual C++
public:
virtual property Leader^ Item[int index] {
    Leader^ get (int index);
    void set (int index, Leader^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LeaderArray Class
Autodesk.Revit Namespace


Size Property

LeaderArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LeaderArray Class
Autodesk.Revit Namespace


LeaderArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of leaders.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7528D556-2E50-4743-B196-281288A85EF7")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class LeaderArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("7528D556-2E50-4743-B196-281288A85EF7")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class LeaderArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"7528D556-2E50-4743-B196-281288A85EF7")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LeaderArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::LeaderArrayIterator

See Also

LeaderArrayIterator Members
Autodesk.Revit Namespace


LeaderArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LeaderArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LeaderArrayIterator
Visual C++
public ref class LeaderArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LeaderArrayIteratorLeaderArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator
Autodesk.Revit Namespace


LeaderArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LeaderArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeaderArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


LeaderArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LeaderArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LeaderArrayIterator
Visual C++
public ref class LeaderArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LeaderArrayIterator
Autodesk.Revit Namespace


Dispose Method

LeaderArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

LeaderArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

LeaderArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


Reset Method

LeaderArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


LeaderArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LeaderArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LeaderArrayIterator
Visual C++
public ref class LeaderArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator
Autodesk.Revit Namespace


Current Property

LeaderArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


LinePatternSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any number of line patterns.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9B70677C-F949-4f8e-8B02-07F204B5F914")]
public class LinePatternSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9B70677C-F949-4f8e-8B02-07F204B5F914")> _
Public Class LinePatternSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9B70677C-F949-4f8e-8B02-07F204B5F914")]
public ref class LinePatternSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::LinePatternSet

See Also

LinePatternSet Members
Autodesk.Revit Namespace


LinePatternSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LinePatternSet
Visual Basic (Declaration)
Public Class LinePatternSet
Visual C++
public ref class LinePatternSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LinePatternSetLinePatternSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

LinePatternSet
Autodesk.Revit Namespace


LinePatternSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinePatternSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePatternSet ()

See Also

LinePatternSet Class
Autodesk.Revit Namespace


LinePatternSet Methods
CollapseAll image DropDown image

Syntax

C#
public class LinePatternSet
Visual Basic (Declaration)
Public Class LinePatternSet
Visual C++
public ref class LinePatternSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LinePatternSet
Autodesk.Revit Namespace


Clear Method

LinePatternSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Contains Method

LinePatternSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LinePattern _
) As Boolean
Visual C++
public:
virtual bool Contains (
    LinePattern^ item
)

Parameters

item
LinePattern
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Dispose Method

LinePatternSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Erase Method

LinePatternSet..::Erase Method
CollapseAll image DropDown image

Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LinePattern _
) As Integer
Visual C++
public:
virtual int Erase (
    LinePattern^ item
)

Parameters

item
LinePattern
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


ForwardIterator Method

LinePatternSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LinePatternSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LinePatternSetIterator
Visual C++
public:
virtual LinePatternSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


GetEnumerator Method

LinePatternSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Insert Method

LinePatternSet..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LinePattern _
) As Boolean
Visual C++
public:
virtual bool Insert (
    LinePattern^ item
)

Parameters

item
LinePattern
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

LinePatternSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LinePatternSet Class
Autodesk.Revit Namespace


ReverseIterator Method

LinePatternSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LinePatternSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LinePatternSetIterator
Visual C++
public:
virtual LinePatternSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


LinePatternSet Properties
CollapseAll image DropDown image

Syntax

C#
public class LinePatternSet
Visual Basic (Declaration)
Public Class LinePatternSet
Visual C++
public ref class LinePatternSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

LinePatternSet
Autodesk.Revit Namespace


IsEmpty Property

LinePatternSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Size Property

LinePatternSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LinePatternSet Class
Autodesk.Revit Namespace


LinePatternSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("50C16CBA-F8A1-492d-852E-4B1211915010")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class LinePatternSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("50C16CBA-F8A1-492d-852E-4B1211915010")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class LinePatternSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"50C16CBA-F8A1-492d-852E-4B1211915010")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LinePatternSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::LinePatternSetIterator

See Also

LinePatternSetIterator Members
Autodesk.Revit Namespace


LinePatternSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LinePatternSetIterator
Visual Basic (Declaration)
Public MustInherit Class LinePatternSetIterator
Visual C++
public ref class LinePatternSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LinePatternSetIteratorLinePatternSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LinePatternSetIterator
Autodesk.Revit Namespace


LinePatternSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinePatternSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePatternSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


LinePatternSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LinePatternSetIterator
Visual Basic (Declaration)
Public MustInherit Class LinePatternSetIterator
Visual C++
public ref class LinePatternSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LinePatternSetIterator
Autodesk.Revit Namespace


Dispose Method

LinePatternSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

LinePatternSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

LinePatternSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


Reset Method

LinePatternSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


LinePatternSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LinePatternSetIterator
Visual Basic (Declaration)
Public MustInherit Class LinePatternSetIterator
Visual C++
public ref class LinePatternSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LinePatternSetIterator
Autodesk.Revit Namespace


Current Property

LinePatternSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


Location Class
See Also Members
CollapseAll image DropDown image

Provides location functionality for all elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("62945E43-FB00-42e5-8A21-EA6F4DD9960C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Location : APIObject
Visual Basic (Declaration)
<GuidAttribute("62945E43-FB00-42e5-8A21-EA6F4DD9960C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Location _
    Inherits APIObject
Visual C++
[GuidAttribute(L"62945E43-FB00-42e5-8A21-EA6F4DD9960C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Location : public APIObject

Remarks

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Location
Autodesk.Revit..::LocationPoint
Autodesk.Revit..::LocationCurve

See Also

Location Members
Autodesk.Revit Namespace


Location Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Location
Visual Basic (Declaration)
Public Class Location
Visual C++
public ref class Location

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LocationLocationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector.
Public method | Rotate | Rotate the element within the project by a specified number of degrees around a given axis.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location
Autodesk.Revit Namespace


Location Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Location()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Location ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Location Class
Autodesk.Revit Namespace


Location Methods
CollapseAll image DropDown image

Syntax

C#
public class Location
Visual Basic (Declaration)
Public Class Location
Visual C++
public ref class Location

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector.
Public method | Rotate | Rotate the element within the project by a specified number of degrees around a given axis.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Location
Autodesk.Revit Namespace


Move Method

Location..::Move Method
CollapseAll image DropDown image

Move the element within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    XYZ translation
)
Visual Basic (Declaration)
Public Function Move ( _
    translation As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    XYZ^ translation
)

Parameters

translation
XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

See Also

Location Class
Autodesk.Revit Namespace


Rotate Method

Location..::Rotate Method
CollapseAll image DropDown image

Rotate the element within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rotate(
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate (
    Line^ axis,
    double angle
)

Parameters

axis
Line
An unbounded line that represents the axis of rotation.
angle
Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

See Also

Location Class
Autodesk.Revit Namespace


LocationCurve Class
See Also Members
CollapseAll image DropDown image

Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67C26FFA-E670-4b32-9B86-21CA5A6B1C00")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LocationCurve : Location
Visual Basic (Declaration)
<GuidAttribute("67C26FFA-E670-4b32-9B86-21CA5A6B1C00")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LocationCurve _
    Inherits Location
Visual C++
[GuidAttribute(L"67C26FFA-E670-4b32-9B86-21CA5A6B1C00")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Location
Autodesk.Revit..::LocationCurve

See Also

LocationCurve Members
Autodesk.Revit Namespace


LocationCurve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LocationCurve
Visual Basic (Declaration)
Public Class LocationCurve
Visual C++
public ref class LocationCurve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LocationCurveLocationCurveNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve
Autodesk.Revit Namespace


LocationCurve Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LocationCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LocationCurve ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LocationCurve Class
Autodesk.Revit Namespace


LocationCurve Properties
CollapseAll image DropDown image

Syntax

C#
public class LocationCurve
Visual Basic (Declaration)
Public Class LocationCurve
Visual C++
public ref class LocationCurve

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve
Autodesk.Revit Namespace


Curve Property

LocationCurve..::Curve Property
CollapseAll image DropDown image

Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get; set;}
Visual Basic (Declaration)
Public Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

See Also

LocationCurve Class
Autodesk.Revit Namespace


ElementsAtJoin Property

LocationCurve..::ElementsAtJoin Property
CollapseAll image DropDown image

Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public List<Element> ElementsAtJoin[
    int end
]{ get; set;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Property ElementsAtJoin ( _
    end As Integer _
) As List(Of Element)
Visual C++
[ComVisibleAttribute(false)]
public:
property List<Element^>^ ElementsAtJoin[int end] {
    List<Element^>^ get (int end);
    void set (int end, List<Element^>^ value);
}

Parameters

end
Int32
The end at which the join is to be obtained or we want to change the order of join participants.

Remarks

The list of elements is expected to be a permutation of the elements already in the join at the end. It is expected that no new elements will be introduced, and existing ones will not be removed.

See Also

LocationCurve Class
Autodesk.Revit Namespace


JoinType Property

LocationCurve..::JoinType Property
CollapseAll image DropDown image

Get/change the type of the join at the specified end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public JoinType JoinType[
    int end
]{ get; set;}
Visual Basic (Declaration)
Public Property JoinType ( _
    end As Integer _
) As JoinType
Visual C++
public:
property JoinType JoinType[int end] {
    JoinType get (int end);
    void set (int end, JoinType value);
}

Parameters

end
Int32
The end of the location curve driver under question.

Remarks

This property allows to get join type of wall and concrete beam and to set wall's join type. The new join type is expected to be different from the current one for this end.

Exceptions

Exception | Condition
System..::NotSupportedException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property.
System..::InvalidOperationException | A failure occurred while attempting to set the new type.

See Also

LocationCurve Class
Autodesk.Revit Namespace


LocationPoint Class
See Also Members
CollapseAll image DropDown image

Provides location functionality for all elements that have a single insertion point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("AD815920-6B6A-4122-A8CE-021F1560399B")]
public class LocationPoint : Location
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("AD815920-6B6A-4122-A8CE-021F1560399B")> _
Public Class LocationPoint _
    Inherits Location
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"AD815920-6B6A-4122-A8CE-021F1560399B")]
public ref class LocationPoint : public Location

Remarks

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Location
Autodesk.Revit..::LocationPoint

See Also

LocationPoint Members
Autodesk.Revit Namespace


LocationPoint Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LocationPoint
Visual Basic (Declaration)
Public Class LocationPoint
Visual C++
public ref class LocationPoint

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LocationPointLocationPointNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Get and set the physical location of the element.
Public property | Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint
Autodesk.Revit Namespace


LocationPoint Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LocationPoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LocationPoint ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LocationPoint Class
Autodesk.Revit Namespace


LocationPoint Properties
CollapseAll image DropDown image

Syntax

C#
public class LocationPoint
Visual Basic (Declaration)
Public Class LocationPoint
Visual C++
public ref class LocationPoint

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Get and set the physical location of the element.
Public property | Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint
Autodesk.Revit Namespace


Point Property

LocationPoint..::Point Property
CollapseAll image DropDown image

Get and set the physical location of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Point{ get; set;}
Visual Basic (Declaration)
Public Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

See Also

LocationPoint Class
Autodesk.Revit Namespace


Rotation Property

LocationPoint..::Rotation Property
CollapseAll image DropDown image

Retrieve the angle of rotation around the insertion point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Rotation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Rotation As Double
Visual C++
public:
property double Rotation {
    double get ();
}

See Also

LocationPoint Class
Autodesk.Revit Namespace


LogicAndFilter Class
See Also Members
CollapseAll image DropDown image

The LogicAndFilter is used to implement Logic-AND operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("96D40172-8F32-418f-8A74-E0D5458F11E0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LogicAndFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("96D40172-8F32-418f-8A74-E0D5458F11E0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LogicAndFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"96D40172-8F32-418f-8A74-E0D5458F11E0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LogicAndFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-AND relationship, use it to filter elements which satisfy both sub-filters.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::LogicAndFilter

See Also

LogicAndFilter Members
Autodesk.Revit Namespace


LogicAndFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LogicAndFilter
Visual Basic (Declaration)
Public Class LogicAndFilter
Visual C++
public ref class LogicAndFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LogicAndFilterLogicAndFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from Filter.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LeftFilter | Get Filter which is left operand of Logic-AND operation
Public property | RightFilter | Get Filter which is right operand of Logic-AND operation

See Also

LogicAndFilter
Autodesk.Revit Namespace


LogicAndFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicAndFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogicAndFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


LogicAndFilter Properties
CollapseAll image DropDown image

Syntax

C#
public class LogicAndFilter
Visual Basic (Declaration)
Public Class LogicAndFilter
Visual C++
public ref class LogicAndFilter

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LeftFilter | Get Filter which is left operand of Logic-AND operation
Public property | RightFilter | Get Filter which is right operand of Logic-AND operation

See Also

LogicAndFilter
Autodesk.Revit Namespace


LeftFilter Property

LogicAndFilter..::LeftFilter Property
CollapseAll image DropDown image

Get Filter which is left operand of Logic-AND operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter LeftFilter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LeftFilter As Filter
Visual C++
public:
property Filter^ LeftFilter {
    Filter^ get ();
}

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


RightFilter Property

LogicAndFilter..::RightFilter Property
CollapseAll image DropDown image

Get Filter which is right operand of Logic-AND operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter RightFilter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RightFilter As Filter
Visual C++
public:
property Filter^ RightFilter {
    Filter^ get ();
}

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


LogicNotFilter Class
See Also Members
CollapseAll image DropDown image

The LogicNotFilter is used to implement Logic-NOT operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("BB6BF006-D08F-4d22-9480-51836EB30E00")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LogicNotFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("BB6BF006-D08F-4d22-9480-51836EB30E00")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LogicNotFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"BB6BF006-D08F-4d22-9480-51836EB30E00")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LogicNotFilter : public Filter

Remarks

This filter represents a combined filter consists of one sub-filter by Logic-NOT relationship, use it to filter elements which don't satisfy the sub-filter.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::LogicNotFilter

See Also

LogicNotFilter Members
Autodesk.Revit Namespace


LogicNotFilter Members
See Also Methods Properties Constructors Fields
CollapseAll image DropDown image

Syntax

C#
public class LogicNotFilter
Visual Basic (Declaration)
Public Class LogicNotFilter
Visual C++
public ref class LogicNotFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LogicNotFilterLogicNotFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from Filter.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Protected Fields

 | Name | Description
Protected field | m_subFilter | Filter which is operand of Logic-NOT operation

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SubFilter | Get Filter which is operand of Logic-NOT operation

See Also

LogicNotFilter
Autodesk.Revit Namespace


LogicNotFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicNotFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogicNotFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


LogicNotFilter Fields
CollapseAll image DropDown image

Syntax

C#
public class LogicNotFilter
Visual Basic (Declaration)
Public Class LogicNotFilter
Visual C++
public ref class LogicNotFilter

The type exposes the following fields.

Protected Fields

 | Name | Description
Protected field | m_subFilter | Filter which is operand of Logic-NOT operation

See Also

LogicNotFilter
Autodesk.Revit Namespace


m_subFilter Field

LogicNotFilter..::m_subFilter Field
CollapseAll image DropDown image

Filter which is operand of Logic-NOT operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected Filter m_subFilter
Visual Basic (Declaration)
Protected m_subFilter As Filter
Visual C++
protected:
Filter^ m_subFilter

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


LogicNotFilter Properties
CollapseAll image DropDown image

Syntax

C#
public class LogicNotFilter
Visual Basic (Declaration)
Public Class LogicNotFilter
Visual C++
public ref class LogicNotFilter

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SubFilter | Get Filter which is operand of Logic-NOT operation

See Also

LogicNotFilter
Autodesk.Revit Namespace


SubFilter Property

LogicNotFilter..::SubFilter Property
CollapseAll image DropDown image

Get Filter which is operand of Logic-NOT operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter SubFilter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SubFilter As Filter
Visual C++
public:
property Filter^ SubFilter {
    Filter^ get ();
}

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


LogicOrFilter Class
See Also Members
CollapseAll image DropDown image

The LogicOrFilter is used to implement Logic-OR operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B5EB6F89-3B92-4e51-95BF-43CCE41DA8AD")]
public class LogicOrFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B5EB6F89-3B92-4e51-95BF-43CCE41DA8AD")> _
Public Class LogicOrFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B5EB6F89-3B92-4e51-95BF-43CCE41DA8AD")]
public ref class LogicOrFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-OR relationship, use it to filter elements which satisfy one of two sub-filters.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::LogicOrFilter

See Also

LogicOrFilter Members
Autodesk.Revit Namespace


LogicOrFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LogicOrFilter
Visual Basic (Declaration)
Public Class LogicOrFilter
Visual C++
public ref class LogicOrFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LogicOrFilterLogicOrFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from Filter.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LeftFilter | Get Filter which is left operand of Logic-OR operation.
Public property | RightFilter | Get Filter which is right operand of Logic-OR operation

See Also

LogicOrFilter
Autodesk.Revit Namespace


LogicOrFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicOrFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogicOrFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


LogicOrFilter Properties
CollapseAll image DropDown image

Syntax

C#
public class LogicOrFilter
Visual Basic (Declaration)
Public Class LogicOrFilter
Visual C++
public ref class LogicOrFilter

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LeftFilter | Get Filter which is left operand of Logic-OR operation.
Public property | RightFilter | Get Filter which is right operand of Logic-OR operation

See Also

LogicOrFilter
Autodesk.Revit Namespace


LeftFilter Property

LogicOrFilter..::LeftFilter Property
CollapseAll image DropDown image

Get Filter which is left operand of Logic-OR operation.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter LeftFilter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LeftFilter As Filter
Visual C++
public:
property Filter^ LeftFilter {
    Filter^ get ();
}

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


RightFilter Property

LogicOrFilter..::RightFilter Property
CollapseAll image DropDown image

Get Filter which is right operand of Logic-OR operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter RightFilter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RightFilter As Filter
Visual C++
public:
property Filter^ RightFilter {
    Filter^ get ();
}

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


MaterialFilter Class
See Also Members
CollapseAll image DropDown image

Represents a filter to filter elements with the given material.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0BBDBAEF-6895-49dd-8662-24D42B33689B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("0BBDBAEF-6895-49dd-8662-24D42B33689B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"0BBDBAEF-6895-49dd-8662-24D42B33689B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialFilter : public Filter

Remarks

The MaterialFilter object is to filter all the elements with the given material in the active document. Both FamilyInstance and FamilySymbol with the material property will be searched through.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::MaterialFilter

See Also

MaterialFilter Members
Autodesk.Revit Namespace


MaterialFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialFilter
Visual Basic (Declaration)
Public Class MaterialFilter
Visual C++
public ref class MaterialFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialFilterMaterialFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialFilter
Autodesk.Revit Namespace


MaterialFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialFilter Class
Autodesk.Revit Namespace


MaterialFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class MaterialFilter
Visual Basic (Declaration)
Public Class MaterialFilter
Visual C++
public ref class MaterialFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

MaterialFilter
Autodesk.Revit Namespace


Dispose Method

MaterialFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialFilter Class
Autodesk.Revit Namespace


Materials Class
See Also Members
CollapseAll image DropDown image

A set of materials that provides access to the materials in an Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("359D23D8-D459-4d7d-B6B7-25E9396425F1")]
public class Materials : MaterialSet
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("359D23D8-D459-4d7d-B6B7-25E9396425F1")> _
Public Class Materials _
    Inherits MaterialSet
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"359D23D8-D459-4d7d-B6B7-25E9396425F1")]
public ref class Materials : public MaterialSet

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::MaterialSet
Autodesk.Revit..::Materials

See Also

Materials Members
Autodesk.Revit Namespace


Materials Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Materials
Visual Basic (Declaration)
Public Class Materials
Visual C++
public ref class Materials

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialsMaterialsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddConcrete | Add a concrete material with the given name .
Public method | AddGeneric | Add a generic material with the given name .
Public method | AddOther | Add an other material with the given name .
Public method | AddSteel | Add a steel material with the given name .
Public method | AddWood | Add a wood material with the given name .
Public method | Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Public method | Contains | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified material from the set. (Inherited from MaterialSet.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified material into the set. (Inherited from MaterialSet.)
Public method | Remove | Remove the material with the speicified name .
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides MaterialSet ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from MaterialSet.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials
Autodesk.Revit Namespace


Materials Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Materials()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Materials ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Materials Class
Autodesk.Revit Namespace


Materials Methods
CollapseAll image DropDown image

Syntax

C#
public class Materials
Visual Basic (Declaration)
Public Class Materials
Visual C++
public ref class Materials

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddConcrete | Add a concrete material with the given name .
Public method | AddGeneric | Add a generic material with the given name .
Public method | AddOther | Add an other material with the given name .
Public method | AddSteel | Add a steel material with the given name .
Public method | AddWood | Add a wood material with the given name .
Public method | Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Public method | Contains | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified material from the set. (Inherited from MaterialSet.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified material into the set. (Inherited from MaterialSet.)
Public method | Remove | Remove the material with the speicified name .
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides MaterialSet ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from MaterialSet.)

See Also

Materials
Autodesk.Revit Namespace


AddConcrete Method

Materials..::AddConcrete Method
CollapseAll image DropDown image

Add a concrete material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialConcrete AddConcrete(
    string name
)
Visual Basic (Declaration)
Public Function AddConcrete ( _
    name As String _
) As MaterialConcrete
Visual C++
public:
MaterialConcrete^ AddConcrete (
    String^ name
)

Parameters

name
String
The name of the concrete material to be added.

Return Value

The pointer to the added concrete material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace


AddGeneric Method

Materials..::AddGeneric Method
CollapseAll image DropDown image

Add a generic material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialGeneric AddGeneric(
    string name
)
Visual Basic (Declaration)
Public Function AddGeneric ( _
    name As String _
) As MaterialGeneric
Visual C++
public:
MaterialGeneric^ AddGeneric (
    String^ name
)

Parameters

name
String
The name of the generic material to be added.

Return Value

The pointer to the added generic material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace


AddOther Method

Materials..::AddOther Method
CollapseAll image DropDown image

Add an other material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialOther AddOther(
    string name
)
Visual Basic (Declaration)
Public Function AddOther ( _
    name As String _
) As MaterialOther
Visual C++
public:
MaterialOther^ AddOther (
    String^ name
)

Parameters

name
String
The name of the other material to be added.

Return Value

The pointer to the added other material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace


AddSteel Method

Materials..::AddSteel Method
CollapseAll image DropDown image

Add a steel material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialSteel AddSteel(
    string name
)
Visual Basic (Declaration)
Public Function AddSteel ( _
    name As String _
) As MaterialSteel
Visual C++
public:
MaterialSteel^ AddSteel (
    String^ name
)

Parameters

name
String
The name of the steel material to be added.

Return Value

The pointer to the added steel material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace


AddWood Method

Materials..::AddWood Method
CollapseAll image DropDown image

Add a wood material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialWood AddWood(
    string name
)
Visual Basic (Declaration)
Public Function AddWood ( _
    name As String _
) As MaterialWood
Visual C++
public:
MaterialWood^ AddWood (
    String^ name
)

Parameters

name
String
The name of the wood material to be added.

Return Value

The pointer to the added wood material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace


Contains Method

Materials..::Contains Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Contains(String) | Check if the material set contains the material with the specified name .
Public method | Contains(ElementId) | Check if the material set contains the material with the specified ID.
Public method | Contains(Material) | Tests for the existence of a material within the set. (Inherited from MaterialSet.)

See Also

Materials Class
Materials Members
Autodesk.Revit Namespace


Contains Method (String)

Materials..::Contains Method (String)
See Also
CollapseAll image DropDown image

Check if the material set contains the material with the specified name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
bool Contains (
    String^ name
)

Parameters

name
String
The name of the material to found.

Return Value

Returns true if the material set contains the material with the specified name, and returns false if not.

See Also

Materials Class
Autodesk.Revit Namespace


Contains Method (ElementId)

Materials..::Contains Method (ElementId)
See Also
CollapseAll image DropDown image

Check if the material set contains the material with the specified ID.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Contains(
    ElementId itemId
)
Visual Basic (Declaration)
Public Function Contains ( _
    itemId As ElementId _
) As Boolean
Visual C++
public:
bool Contains (
    ElementId itemId
)

Parameters

itemId
ElementId
The ID of the material to be found.

Return Value

Returns true if the material set contains the material with the specified ID, and false if not.

See Also

Materials Class
Autodesk.Revit Namespace


Dispose Method

Materials..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Materials Class
Autodesk.Revit Namespace


Remove Method

Materials..::Remove Method
CollapseAll image DropDown image

Remove the material with the speicified name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Remove(
    string matName
)
Visual Basic (Declaration)
Public Sub Remove ( _
    matName As String _
)
Visual C++
public:
void Remove (
    String^ matName
)

Parameters

matName
String
The name of the material to be removed.

See Also

Materials Class
Autodesk.Revit Namespace


Materials Properties
CollapseAll image DropDown image

Syntax

C#
public class Materials
Visual Basic (Declaration)
Public Class Materials
Visual C++
public ref class Materials

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials
Autodesk.Revit Namespace


Item Property

Materials..::Item Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Item[([String])] | Get the material with the specified name .
Public property | Item[([ElementId])] | Get the material with the specified ID.

See Also

Materials Class
Materials Members
Autodesk.Revit Namespace


Item Property (String)

Materials..::Item Property (String)
See Also
CollapseAll image DropDown image

Get the material with the specified name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Material Item[
    string name
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    name As String _
) As Material
Visual C++
public:
property Material^ Item[String^ name] {
    Material^ get (String^ name);
}

Parameters

name
String
The name of the material to be found.

Remarks

If the material with the specified name does not exist, null pointer will be returned.

See Also

Materials Class
Autodesk.Revit Namespace


Item Property (ElementId)

Materials..::Item Property (ElementId)
See Also
CollapseAll image DropDown image

Get the material with the specified ID.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Material Item[
    ElementId itemId
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    itemId As ElementId _
) As Material
Visual C++
public:
property Material^ Item[ElementId itemId] {
    Material^ get (ElementId itemId);
}

Parameters

itemId
ElementId
The ID of the material to be found.

Remarks

If the material with the specified ID does not exist, null pointer will be returned.

See Also

Materials Class
Autodesk.Revit Namespace


MaterialSet Class
See Also Members
CollapseAll image DropDown image

An set that contains materials.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BEA2B6C7-76C1-46d7-8B40-A31E82132BCA")]
public class MaterialSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BEA2B6C7-76C1-46d7-8B40-A31E82132BCA")> _
Public Class MaterialSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BEA2B6C7-76C1-46d7-8B40-A31E82132BCA")]
public ref class MaterialSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::MaterialSet
Autodesk.Revit..::Materials

See Also

MaterialSet Members
Autodesk.Revit Namespace


MaterialSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialSet
Visual Basic (Declaration)
Public Class MaterialSet
Visual C++
public ref class MaterialSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialSetMaterialSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every material from the set, rendering it empty.
Public method | Contains | Tests for the existence of a material within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified material from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified material into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of materials that are in the set.

See Also

MaterialSet
Autodesk.Revit Namespace


MaterialSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSet ()

See Also

MaterialSet Class
Autodesk.Revit Namespace


MaterialSet Methods
CollapseAll image DropDown image

Syntax

C#
public class MaterialSet
Visual Basic (Declaration)
Public Class MaterialSet
Visual C++
public ref class MaterialSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every material from the set, rendering it empty.
Public method | Contains | Tests for the existence of a material within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified material from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified material into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MaterialSet
Autodesk.Revit Namespace


Clear Method

MaterialSet..::Clear Method
CollapseAll image DropDown image

Removes every material from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

MaterialSet Class
Autodesk.Revit Namespace


Contains Method

MaterialSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a material within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Material^ item
)

Parameters

item
Material
The material to be searched for.

Return Value

The Contains method returns True if the material is within the set, otherwise False.

See Also

MaterialSet Class
Autodesk.Revit Namespace


Dispose Method

MaterialSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialSet Class
Autodesk.Revit Namespace


Erase Method

MaterialSet..::Erase Method
CollapseAll image DropDown image

Removes a specified material from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Material _
) As Integer
Visual C++
public:
virtual int Erase (
    Material^ item
)

Parameters

item
Material
The material to be erased.

Return Value

The number of materials that were erased from the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


ForwardIterator Method

MaterialSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MaterialSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


GetEnumerator Method

MaterialSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


Insert Method

MaterialSet..::Insert Method
CollapseAll image DropDown image

Insert the specified material into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Material^ item
)

Parameters

item
Material
The material to be inserted into the set.

Return Value

Returns whether the material was inserted into the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

MaterialSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MaterialSet Class
Autodesk.Revit Namespace


ReverseIterator Method

MaterialSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MaterialSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


MaterialSet Properties
CollapseAll image DropDown image

Syntax

C#
public class MaterialSet
Visual Basic (Declaration)
Public Class MaterialSet
Visual C++
public ref class MaterialSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of materials that are in the set.

See Also

MaterialSet
Autodesk.Revit Namespace


IsEmpty Property

MaterialSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MaterialSet Class
Autodesk.Revit Namespace


Size Property

MaterialSet..::Size Property
CollapseAll image DropDown image

Returns the number of materials that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MaterialSet Class
Autodesk.Revit Namespace


MaterialSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a material set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2B70B169-B934-4865-AD8E-690ED74309F9")]
public abstract class MaterialSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2B70B169-B934-4865-AD8E-690ED74309F9")> _
Public MustInherit Class MaterialSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2B70B169-B934-4865-AD8E-690ED74309F9")]
public ref class MaterialSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::MaterialSetIterator

See Also

MaterialSetIterator Members
Autodesk.Revit Namespace


MaterialSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class MaterialSetIterator
Visual Basic (Declaration)
Public MustInherit Class MaterialSetIterator
Visual C++
public ref class MaterialSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialSetIteratorMaterialSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator
Autodesk.Revit Namespace


MaterialSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MaterialSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class MaterialSetIterator
Visual Basic (Declaration)
Public MustInherit Class MaterialSetIterator
Visual C++
public ref class MaterialSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MaterialSetIterator
Autodesk.Revit Namespace


Dispose Method

MaterialSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

MaterialSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

MaterialSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


Reset Method

MaterialSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MaterialSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class MaterialSetIterator
Visual Basic (Declaration)
Public MustInherit Class MaterialSetIterator
Visual C++
public ref class MaterialSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator
Autodesk.Revit Namespace


Current Property

MaterialSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MenuItem Class
See Also Members
CollapseAll image DropDown image

Basic unit to build custermized menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("17767ABF-BF32-4488-900D-C905439E65DA")]
public class MenuItem : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("17767ABF-BF32-4488-900D-C905439E65DA")> _
Public Class MenuItem _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"17767ABF-BF32-4488-900D-C905439E65DA")]
public ref class MenuItem : public APIObject

Remarks

The MenuItem object is a basic unit to build custermized menus when revit is at statup .

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::MenuItem

See Also

MenuItem Members
Autodesk.Revit Namespace


MenuItem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MenuItemMenuItemNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddToExternalTools | Add top level menu to "external tools" menu.
Public method | Append | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMenuItemCount | Get number of sub menus, if current menu is not popup menu, zero will be returned.
Public method | GetSubMenu | Get a sub menu, if current menu is not popup menu, null will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | AssemblyName | Get or set name of the assembly which external command lives in.
Public property | Checked | Set check or uncheck the menu through API.
Public property | ClassName | Get or set name of the class which implements external command.
Public property | Enabled | Disable and Enable the Custom menu through API.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MenuItemType | Get type of the menu through API.
Public property | Name | Get name of the menu through API.
Public property | StatusbarTip | Get or set tips.

See Also

MenuItem
Autodesk.Revit Namespace


MenuItem Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MenuItem ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MenuItem Class
Autodesk.Revit Namespace


MenuItem Methods
CollapseAll image DropDown image

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddToExternalTools | Add top level menu to "external tools" menu.
Public method | Append | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMenuItemCount | Get number of sub menus, if current menu is not popup menu, zero will be returned.
Public method | GetSubMenu | Get a sub menu, if current menu is not popup menu, null will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

MenuItem
Autodesk.Revit Namespace


AddToExternalTools Method

MenuItem..::AddToExternalTools Method
CollapseAll image DropDown image

Add top level menu to "external tools" menu.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AddToExternalTools()
Visual Basic (Declaration)
Public Function AddToExternalTools As Boolean
Visual C++
public:
bool AddToExternalTools ()

Return Value

When trying to add a non-top level menu into "external tools" menu, it gets false.

Remarks

All of the sub-menus will be added into external tools menu.

See Also

MenuItem Class
Autodesk.Revit Namespace


Append Method

MenuItem..::Append Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Append(MenuItem..::MenuType) | Append a new menu after the last sub menu of current menu.
Public method | Append(MenuItem..::MenuType, String) | Append a new menu after the last sub menu of current menu.
Public method | Append(MenuItem..::MenuType, String, String, String) | Append a new menu after the last sub menu of current menu, basic menu, popup menu and separator menu are allowed here.

See Also

MenuItem Class
MenuItem Members
Autodesk.Revit Namespace


Append Method (MenuItem.MenuType)

MenuItem..::Append Method (MenuItem..::MenuType)
See Also
CollapseAll image DropDown image

Append a new menu after the last sub menu of current menu.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Append(
    MenuItem.MenuItem..::MenuType menuType
)
Visual Basic (Declaration)
Public Function Append ( _
    menuType As MenuItem..::MenuType _
) As MenuItem
Visual C++
public:
MenuItem^ Append (
    MenuItem..::MenuType menuType
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.

Return Value

That new appended menu item will be returned if success, else null.

Remarks

Menu will be added as the last menu of current pop up menu. A default menu name will be given. And if it is a basic menu, then assembly and class should be assigned later via corresponding properties.

See Also

MenuItem Class
Autodesk.Revit Namespace


Append Method (MenuItem.MenuType, String)

MenuItem..::Append Method (MenuItem..::MenuType, String)
See Also
CollapseAll image DropDown image

Append a new menu after the last sub menu of current menu.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Append(
    MenuItem.MenuItem..::MenuType menuType,
    string menuName
)
Visual Basic (Declaration)
Public Function Append ( _
    menuType As MenuItem..::MenuType, _
    menuName As String _
) As MenuItem
Visual C++
public:
MenuItem^ Append (
    MenuItem..::MenuType menuType,
    String^ menuName
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.
menuName
String
Text which will be displayed on the created menu.

Return Value

That new appended menu item will be returned if success, else null.

Remarks

Menu will be added as the last menu of current pop up menu. If menuName is null, a default name will be given. And if it is a basic menu, then assembly and class should be assigned later via corresponding properties.

See Also

MenuItem Class
Autodesk.Revit Namespace


Append Method (MenuItem.MenuType, String, String, String)

MenuItem..::Append Method (MenuItem..::MenuType, String, String, String)
See Also
CollapseAll image DropDown image

Append a new menu after the last sub menu of current menu, basic menu, popup menu and separator menu are allowed here.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Append(
    MenuItem.MenuItem..::MenuType menuType,
    string menuName,
    string assemblyName,
    string className
)
Visual Basic (Declaration)
Public Function Append ( _
    menuType As MenuItem..::MenuType, _
    menuName As String, _
    assemblyName As String, _
    className As String _
) As MenuItem
Visual C++
public:
MenuItem^ Append (
    MenuItem..::MenuType menuType,
    String^ menuName,
    String^ assemblyName,
    String^ className
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.
menuName
String
Text which will be displayed on the created menu.
assemblyName
String
Assembly in which the corresponding command lives.
className
String
Class which implements corresponding command.

Return Value

That new appended menu item will be returned if success, else null.

Remarks

Menu will be added as the last menu of current pop up menu. If menuName is null, a default name will be given. And if assembly name and class name are null and it is a basic menu, then they should be assigned later via corresponding properties.

See Also

MenuItem Class
Autodesk.Revit Namespace


GetMenuItemCount Method

MenuItem..::GetMenuItemCount Method
CollapseAll image DropDown image

Get number of sub menus, if current menu is not popup menu, zero will be returned.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int GetMenuItemCount()
Visual Basic (Declaration)
Public Function GetMenuItemCount As Integer
Visual C++
public:
int GetMenuItemCount ()

Return Value

Number of the submenus of current menu.

Remarks

If current menu is not a popup menu, 0 will be returned.

See Also

MenuItem Class
Autodesk.Revit Namespace


GetSubMenu Method

MenuItem..::GetSubMenu Method
CollapseAll image DropDown image

Get a sub menu, if current menu is not popup menu, null will be returned.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem GetSubMenu(
    int pos
)
Visual Basic (Declaration)
Public Function GetSubMenu ( _
    pos As Integer _
) As MenuItem
Visual C++
public:
MenuItem^ GetSubMenu (
    int pos
)

Parameters

pos
Int32
Index of the sub menu to be returned, starting from 0.

Return Value

Sub menu item will be returned if successful.

Remarks

Before get sub menu, it's better to call GetMenuItemCount.

See Also

MenuItem Class
Autodesk.Revit Namespace


Insert Method

MenuItem..::Insert Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Insert(MenuItem..::MenuType, Int32) | Insert a new menu before the specified menu.
Public method | Insert(MenuItem..::MenuType, String, Int32) | Insert a new menu before the specified menu.
Public method | Insert(MenuItem..::MenuType, String, String, String, Int32) | Insert a new menu before the specified menu,basic menu, popup menu and separator menu are allowed here.

See Also

MenuItem Class
MenuItem Members
Autodesk.Revit Namespace


Insert Method (MenuItem.MenuType, Int32)

MenuItem..::Insert Method (MenuItem..::MenuType, Int32)
See Also
CollapseAll image DropDown image

Insert a new menu before the specified menu.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Insert(
    MenuItem.MenuItem..::MenuType menuType,
    int pos
)
Visual Basic (Declaration)
Public Function Insert ( _
    menuType As MenuItem..::MenuType, _
    pos As Integer _
) As MenuItem
Visual C++
public:
MenuItem^ Insert (
    MenuItem..::MenuType menuType,
    int pos
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.
pos
Int32
Position before which new menu item will be inserted.

Return Value

That new inserted menu item will be returned if success, else null.

Remarks

If pos is -1, menu will be appended. And the other arguments are the same with method Append.

See Also

MenuItem Class
Autodesk.Revit Namespace


Insert Method (MenuItem.MenuType, String, Int32)

MenuItem..::Insert Method (MenuItem..::MenuType, String, Int32)
See Also
CollapseAll image DropDown image

Insert a new menu before the specified menu.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Insert(
    MenuItem.MenuItem..::MenuType menuType,
    string menuName,
    int pos
)
Visual Basic (Declaration)
Public Function Insert ( _
    menuType As MenuItem..::MenuType, _
    menuName As String, _
    pos As Integer _
) As MenuItem
Visual C++
public:
MenuItem^ Insert (
    MenuItem..::MenuType menuType,
    String^ menuName,
    int pos
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.
menuName
String
Text which will be displayed on the created menu.
pos
Int32
Position before which new menu item will be inserted.

Return Value

That new inserted menu item will be returned if success, else null.

Remarks

If pos is -1, menu will be appended. And the other arguments are the same with method Append.

See Also

MenuItem Class
Autodesk.Revit Namespace


Insert Method (MenuItem.MenuType, String, String, String, Int32)

MenuItem..::Insert Method (MenuItem..::MenuType, String, String, String, Int32)
See Also
CollapseAll image DropDown image

Insert a new menu before the specified menu,basic menu, popup menu and separator menu are allowed here.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Insert(
    MenuItem.MenuItem..::MenuType menuType,
    string menuName,
    string assemblyName,
    string className,
    int pos
)
Visual Basic (Declaration)
Public Function Insert ( _
    menuType As MenuItem..::MenuType, _
    menuName As String, _
    assemblyName As String, _
    className As String, _
    pos As Integer _
) As MenuItem
Visual C++
public:
MenuItem^ Insert (
    MenuItem..::MenuType menuType,
    String^ menuName,
    String^ assemblyName,
    String^ className,
    int pos
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.
menuName
String
Text which will be displayed on the created menu.
assemblyName
String
Assembly in which the corresponding command lives.
className
String
Class which implements corresponding command.
pos
Int32
Position before which new menu item will be inserted.

Return Value

That new inserted menu item will be returned if success, else null.

Remarks

If pos is -1, menu will be appended. And the other arguments are the same with method Append.

See Also

MenuItem Class
Autodesk.Revit Namespace


MenuItem Properties
CollapseAll image DropDown image

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AssemblyName | Get or set name of the assembly which external command lives in.
Public property | Checked | Set check or uncheck the menu through API.
Public property | ClassName | Get or set name of the class which implements external command.
Public property | Enabled | Disable and Enable the Custom menu through API.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MenuItemType | Get type of the menu through API.
Public property | Name | Get name of the menu through API.
Public property | StatusbarTip | Get or set tips.

See Also

MenuItem
Autodesk.Revit Namespace


AssemblyName Property

MenuItem..::AssemblyName Property
CollapseAll image DropDown image

Get or set name of the assembly which external command lives in.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string AssemblyName{ get; set;}
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

Assembly name which external command lives in

See Also

MenuItem Class
Autodesk.Revit Namespace


Checked Property

MenuItem..::Checked Property
CollapseAll image DropDown image

Set check or uncheck the menu through API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Checked{ get; set;}
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

Remarks

Place the default check mark next to the item or not.

See Also

MenuItem Class
Autodesk.Revit Namespace


ClassName Property

MenuItem..::ClassName Property
CollapseAll image DropDown image

Get or set name of the class which implements external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string ClassName{ get; set;}
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

Name of the class which implements external command.

See Also

MenuItem Class
Autodesk.Revit Namespace


Enabled Property

MenuItem..::Enabled Property
CollapseAll image DropDown image

Disable and Enable the Custom menu through API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Enabled{ get; set;}
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

After disabled, there’s no response whatever menu it clicked.

See Also

MenuItem Class
Autodesk.Revit Namespace


MenuItemType Property

MenuItem..::MenuItemType Property
CollapseAll image DropDown image

Get type of the menu through API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem.MenuItem..::MenuType MenuItemType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MenuItemType As MenuItem..::MenuType
Visual C++
public:
property MenuItem..::MenuType MenuItemType {
    MenuItem..::MenuType get ();
}

Remarks

Type of menu will be returned, i.e. basic menu, pop up menu or separator menu.

See Also

MenuItem Class
Autodesk.Revit Namespace


Name Property

MenuItem..::Name Property
CollapseAll image DropDown image

Get name of the menu through API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Name of the menu.

See Also

MenuItem Class
Autodesk.Revit Namespace


StatusbarTip Property

MenuItem..::StatusbarTip Property
CollapseAll image DropDown image

Get or set tips.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string StatusbarTip{ get; set;}
Visual Basic (Declaration)
Public Property StatusbarTip As String
Visual C++
public:
property String^ StatusbarTip {
    String^ get ();
    void set (String^ value);
}

Remarks

Tip of corresponding command shown in status bar.

See Also

MenuItem Class
Autodesk.Revit Namespace


MenuItem..::MenuType Enumeration
CollapseAll image DropDown image

Type of menu to be created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("ED952F57-3F78-4399-B4CD-30E8A380CD6B")]
public enum MenuType
Visual Basic (Declaration)
<GuidAttribute("ED952F57-3F78-4399-B4CD-30E8A380CD6B")> _
Public Enumeration MenuType
Visual C++
[GuidAttribute(L"ED952F57-3F78-4399-B4CD-30E8A380CD6B")]
public enum class MenuType

Members

Member name | Description
SeparatorMenu | Menu used to separate other menus
PopupMenu | Pop up menu which can have sub menus.
BasicMenu | Standard menu associated with a command.

Remarks

There are three types of menu which can be created when Revit is at startup.

See Also

Autodesk.Revit Namespace


MEPSpaceConstruction Class
See Also Members
CollapseAll image DropDown image

Construction definition for Space.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("04E41931-E91E-4c1a-AFDC-C0803B493D28")]
public class MEPSpaceConstruction
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("04E41931-E91E-4c1a-AFDC-C0803B493D28")> _
Public Class MEPSpaceConstruction
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"04E41931-E91E-4c1a-AFDC-C0803B493D28")]
public ref class MEPSpaceConstruction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::MEPSpaceConstruction

See Also

MEPSpaceConstruction Members
Autodesk.Revit Namespace


MEPSpaceConstruction Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class MEPSpaceConstruction
Visual Basic (Declaration)
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MEPSpaceConstructionMEPSpaceConstructionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | DeleteConstruction | Remove a existent construction from Space constructions.
Public method | DuplicateConstruction | Create a new construction for Space constructions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewConstruction | Create a new construction for Space constructions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
Public property | SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction
Autodesk.Revit Namespace


MEPSpaceConstruction Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPSpaceConstruction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPSpaceConstruction ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


MEPSpaceConstruction Methods
CollapseAll image DropDown image

Syntax

C#
public class MEPSpaceConstruction
Visual Basic (Declaration)
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | DeleteConstruction | Remove a existent construction from Space constructions.
Public method | DuplicateConstruction | Create a new construction for Space constructions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewConstruction | Create a new construction for Space constructions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

MEPSpaceConstruction
Autodesk.Revit Namespace


DeleteConstruction Method

MEPSpaceConstruction..::DeleteConstruction Method
CollapseAll image DropDown image

Remove a existent construction from Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void DeleteConstruction(
    MEPBuildingConstruction pCurrentConstruction
)
Visual Basic (Declaration)
Public Sub DeleteConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction _
)
Visual C++
public:
void DeleteConstruction (
    MEPBuildingConstruction^ pCurrentConstruction
)

Parameters

pCurrentConstruction
MEPBuildingConstruction
The Construction will be deleted.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


DuplicateConstruction Method

MEPSpaceConstruction..::DuplicateConstruction Method
CollapseAll image DropDown image

Create a new construction for Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstruction DuplicateConstruction(
    MEPBuildingConstruction pCurrentConstruction,
    string pName
)
Visual Basic (Declaration)
Public Function DuplicateConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction, _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ DuplicateConstruction (
    MEPBuildingConstruction^ pCurrentConstruction,
    String^ pName
)

Parameters

pCurrentConstruction
MEPBuildingConstruction
The existent Construction want to be cloned.
pName
String
The name of the new Construction.

Remarks

If the name is same with the existen one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


NewConstruction Method

MEPSpaceConstruction..::NewConstruction Method
CollapseAll image DropDown image

Create a new construction for Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstruction NewConstruction(
    string pName
)
Visual Basic (Declaration)
Public Function NewConstruction ( _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ NewConstruction (
    String^ pName
)

Parameters

pName
String
The name of the new Construction.

Remarks

If the name is same with the existen one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


MEPSpaceConstruction Properties
CollapseAll image DropDown image

Syntax

C#
public class MEPSpaceConstruction
Visual Basic (Declaration)
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
Public property | SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction
Autodesk.Revit Namespace


CurrentConstruction Property

MEPSpaceConstruction..::CurrentConstruction Property
CollapseAll image DropDown image

Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstruction CurrentConstruction{ get; set;}
Visual Basic (Declaration)
Public Property CurrentConstruction As MEPBuildingConstruction
Visual C++
public:
property MEPBuildingConstruction^ CurrentConstruction {
    MEPBuildingConstruction^ get ();
    void set (MEPBuildingConstruction^ value);
}

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


SpaceConstructions Property

MEPSpaceConstruction..::SpaceConstructions Property
CollapseAll image DropDown image

Return all the Space constructions of current space.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstructionSet SpaceConstructions{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SpaceConstructions As MEPBuildingConstructionSet
Visual C++
public:
property MEPBuildingConstructionSet^ SpaceConstructions {
    MEPBuildingConstructionSet^ get ();
}

Remarks

If the name is same with the existen one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


ObjectFactory Class
See Also Members
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("63457915-E68A-4f30-B34B-5C5A4FDFAF11")]
public class ObjectFactory : IDisposable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("63457915-E68A-4f30-B34B-5C5A4FDFAF11")> _
Public Class ObjectFactory _
    Implements IDisposable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"63457915-E68A-4f30-B34B-5C5A4FDFAF11")]
public ref class ObjectFactory : IDisposable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::ObjectFactory

See Also

ObjectFactory Members
Autodesk.Revit Namespace


ObjectFactory Members
See Also Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class ObjectFactory
Visual Basic (Declaration)
Public Class ObjectFactory
Visual C++
public ref class ObjectFactory

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ObjectFactoryObjectFactoryNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | CreateInstance | For Internal Use Only.
Public method | Dispose | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInstance | For Internal Use Only.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveInstance | For Internal Use Only.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

ObjectFactory
Autodesk.Revit Namespace


ObjectFactory Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ObjectFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ObjectFactory ()

Return Value

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ObjectFactory Class
Autodesk.Revit Namespace


ObjectFactory Methods
CollapseAll image DropDown image

Syntax

C#
public class ObjectFactory
Visual Basic (Declaration)
Public Class ObjectFactory
Visual C++
public ref class ObjectFactory

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | CreateInstance | For Internal Use Only.
Public method | Dispose | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInstance | For Internal Use Only.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveInstance | For Internal Use Only.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

ObjectFactory
Autodesk.Revit Namespace


CreateInstance Method

ObjectFactory..::CreateInstance Method
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public APIObject CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function CreateInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As APIObject
Visual C++
public:
APIObject^ CreateInstance (
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
IntPtr
pData
IntPtr
tag
IntPtr

Return Value

See Also

ObjectFactory Class
Autodesk.Revit Namespace


Dispose Method

ObjectFactory..::Dispose Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Dispose()() | For Internal Use Only.
Protected method | Dispose(Boolean) |

See Also

ObjectFactory Class
ObjectFactory Members
Autodesk.Revit Namespace


Dispose Method

ObjectFactory..::Dispose Method
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose () sealed

See Also

ObjectFactory Class
Autodesk.Revit Namespace


Dispose Method (Boolean)

ObjectFactory..::Dispose Method (Boolean)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected virtual void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
)

Parameters

Boolean

See Also

ObjectFactory Class
Autodesk.Revit Namespace


GetInstance Method

ObjectFactory..::GetInstance Method
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public APIObject GetInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function GetInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As APIObject
Visual C++
public:
APIObject^ GetInstance (
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
IntPtr
pData
IntPtr
tag
IntPtr

Return Value

See Also

ObjectFactory Class
Autodesk.Revit Namespace


RemoveInstance Method

ObjectFactory..::RemoveInstance Method
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveInstance(
    IntPtr tag
)
Visual Basic (Declaration)
Public Sub RemoveInstance ( _
    tag As IntPtr _
)
Visual C++
public:
void RemoveInstance (
    IntPtr tag
)

Parameters

tag
IntPtr

See Also

ObjectFactory Class
Autodesk.Revit Namespace


PaperSize Class
See Also Members
CollapseAll image DropDown image

An object that represents a Paper Size of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67885075-FDEA-4a03-87F5-5972778995FB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PaperSize : APIObject
Visual Basic (Declaration)
<GuidAttribute("67885075-FDEA-4a03-87F5-5972778995FB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PaperSize _
    Inherits APIObject
Visual C++
[GuidAttribute(L"67885075-FDEA-4a03-87F5-5972778995FB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PaperSize : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PaperSize

See Also

PaperSize Members
Autodesk.Revit Namespace


PaperSize Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PaperSize
Visual Basic (Declaration)
Public Class PaperSize
Visual C++
public ref class PaperSize

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PaperSizePaperSizeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper size name of current project.

See Also

PaperSize
Autodesk.Revit Namespace


PaperSize Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSize ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSize Class
Autodesk.Revit Namespace


PaperSize Properties
CollapseAll image DropDown image

Syntax

C#
public class PaperSize
Visual Basic (Declaration)
Public Class PaperSize
Visual C++
public ref class PaperSize

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper size name of current project.

See Also

PaperSize
Autodesk.Revit Namespace


Name Property

PaperSize..::Name Property
CollapseAll image DropDown image

Retrieve the paper size name of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSize Class
Autodesk.Revit Namespace


PaperSizeSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any number of paper size objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CA0DE555-F462-47f8-B9EB-03887692AD01")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PaperSizeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("CA0DE555-F462-47f8-B9EB-03887692AD01")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PaperSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"CA0DE555-F462-47f8-B9EB-03887692AD01")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PaperSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PaperSizeSet

See Also

PaperSizeSet Members
Autodesk.Revit Namespace


PaperSizeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PaperSizeSet
Visual Basic (Declaration)
Public Class PaperSizeSet
Visual C++
public ref class PaperSizeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PaperSizeSetPaperSizeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet
Autodesk.Revit Namespace


PaperSizeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSizeSet ()

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


PaperSizeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class PaperSizeSet
Visual Basic (Declaration)
Public Class PaperSizeSet
Visual C++
public ref class PaperSizeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PaperSizeSet
Autodesk.Revit Namespace


Clear Method

PaperSizeSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Contains Method

PaperSizeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Contains (
    PaperSize^ item
)

Parameters

item
PaperSize
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Dispose Method

PaperSizeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Erase Method

PaperSizeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PaperSize _
) As Integer
Visual C++
public:
virtual int Erase (
    PaperSize^ item
)

Parameters

item
PaperSize
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


ForwardIterator Method

PaperSizeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PaperSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


GetEnumerator Method

PaperSizeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Insert Method

PaperSizeSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Insert (
    PaperSize^ item
)

Parameters

item
PaperSize

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PaperSizeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


ReverseIterator Method

PaperSizeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PaperSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


PaperSizeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class PaperSizeSet
Visual Basic (Declaration)
Public Class PaperSizeSet
Visual C++
public ref class PaperSizeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet
Autodesk.Revit Namespace


IsEmpty Property

PaperSizeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Size Property

PaperSizeSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


PaperSizeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set of paper size objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1921C459-C448-48fd-9A86-165A9366BF81")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class PaperSizeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("1921C459-C448-48fd-9A86-165A9366BF81")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class PaperSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"1921C459-C448-48fd-9A86-165A9366BF81")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PaperSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PaperSizeSetIterator

See Also

PaperSizeSetIterator Members
Autodesk.Revit Namespace


PaperSizeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PaperSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PaperSizeSetIterator
Visual C++
public ref class PaperSizeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PaperSizeSetIteratorPaperSizeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator
Autodesk.Revit Namespace


PaperSizeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSizeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


PaperSizeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PaperSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PaperSizeSetIterator
Visual C++
public ref class PaperSizeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PaperSizeSetIterator
Autodesk.Revit Namespace


Dispose Method

PaperSizeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

PaperSizeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PaperSizeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


Reset Method

PaperSizeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


PaperSizeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PaperSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PaperSizeSetIterator
Visual C++
public ref class PaperSizeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator
Autodesk.Revit Namespace


Current Property

PaperSizeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


PaperSource Class
See Also Members
CollapseAll image DropDown image

An object that represents a Paper Source of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F62B4C84-C8BA-4faa-B0E9-72A55459B318")]
public class PaperSource : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F62B4C84-C8BA-4faa-B0E9-72A55459B318")> _
Public Class PaperSource _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F62B4C84-C8BA-4faa-B0E9-72A55459B318")]
public ref class PaperSource : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PaperSource

See Also

PaperSource Members
Autodesk.Revit Namespace


PaperSource Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PaperSource
Visual Basic (Declaration)
Public Class PaperSource
Visual C++
public ref class PaperSource

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PaperSourcePaperSourceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper source name of current project.

See Also

PaperSource
Autodesk.Revit Namespace


PaperSource Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSource ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSource Class
Autodesk.Revit Namespace


PaperSource Properties
CollapseAll image DropDown image

Syntax

C#
public class PaperSource
Visual Basic (Declaration)
Public Class PaperSource
Visual C++
public ref class PaperSource

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper source name of current project.

See Also

PaperSource
Autodesk.Revit Namespace


Name Property

PaperSource..::Name Property
CollapseAll image DropDown image

Retrieve the paper source name of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSource Class
Autodesk.Revit Namespace


PaperSourceSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any number of paper source objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("157B2650-8935-4097-B997-30BB5DCDB620")]
public class PaperSourceSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("157B2650-8935-4097-B997-30BB5DCDB620")> _
Public Class PaperSourceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"157B2650-8935-4097-B997-30BB5DCDB620")]
public ref class PaperSourceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PaperSourceSet

See Also

PaperSourceSet Members
Autodesk.Revit Namespace


PaperSourceSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PaperSourceSet
Visual Basic (Declaration)
Public Class PaperSourceSet
Visual C++
public ref class PaperSourceSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PaperSourceSetPaperSourceSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet
Autodesk.Revit Namespace


PaperSourceSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSourceSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSourceSet ()

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


PaperSourceSet Methods
CollapseAll image DropDown image

Syntax

C#
public class PaperSourceSet
Visual Basic (Declaration)
Public Class PaperSourceSet
Visual C++
public ref class PaperSourceSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PaperSourceSet
Autodesk.Revit Namespace


Clear Method

PaperSourceSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Contains Method

PaperSourceSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Contains (
    PaperSource^ item
)

Parameters

item
PaperSource
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Dispose Method

PaperSourceSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Erase Method

PaperSourceSet..::Erase Method
CollapseAll image DropDown image

Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PaperSource _
) As Integer
Visual C++
public:
virtual int Erase (
    PaperSource^ item
)

Parameters

item
PaperSource
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


ForwardIterator Method

PaperSourceSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PaperSourceSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


GetEnumerator Method

PaperSourceSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Insert Method

PaperSourceSet..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Insert (
    PaperSource^ item
)

Parameters

item
PaperSource
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PaperSourceSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


ReverseIterator Method

PaperSourceSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PaperSourceSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


PaperSourceSet Properties
CollapseAll image DropDown image

Syntax

C#
public class PaperSourceSet
Visual Basic (Declaration)
Public Class PaperSourceSet
Visual C++
public ref class PaperSourceSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet
Autodesk.Revit Namespace


IsEmpty Property

PaperSourceSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Size Property

PaperSourceSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


PaperSourceSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set of paper source objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F9A95919-7583-4b78-B5C3-55C70891FE6F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class PaperSourceSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("F9A95919-7583-4b78-B5C3-55C70891FE6F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class PaperSourceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"F9A95919-7583-4b78-B5C3-55C70891FE6F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PaperSourceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PaperSourceSetIterator

See Also

PaperSourceSetIterator Members
Autodesk.Revit Namespace


PaperSourceSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PaperSourceSetIterator
Visual Basic (Declaration)
Public MustInherit Class PaperSourceSetIterator
Visual C++
public ref class PaperSourceSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PaperSourceSetIteratorPaperSourceSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator
Autodesk.Revit Namespace


PaperSourceSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSourceSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSourceSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


PaperSourceSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PaperSourceSetIterator
Visual Basic (Declaration)
Public MustInherit Class PaperSourceSetIterator
Visual C++
public ref class PaperSourceSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PaperSourceSetIterator
Autodesk.Revit Namespace


Dispose Method

PaperSourceSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

PaperSourceSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PaperSourceSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


Reset Method

PaperSourceSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


PaperSourceSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PaperSourceSetIterator
Visual Basic (Declaration)
Public MustInherit Class PaperSourceSetIterator
Visual C++
public ref class PaperSourceSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator
Autodesk.Revit Namespace


Current Property

PaperSourceSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


Parameter Class
See Also Members
CollapseAll image DropDown image

The parameter object contains the value data assigned to that parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6652F4AD-BAC4-4040-83CD-F24E350C96C0")]
public class Parameter : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6652F4AD-BAC4-4040-83CD-F24E350C96C0")> _
Public Class Parameter _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6652F4AD-BAC4-4040-83CD-F24E350C96C0")]
public ref class Parameter : public APIObject

Remarks

The piece of data contained within the parameter can be either a Double, Integer, String or ElementId. The parameter object can be retrieved from any Element object using either a built in id, definition object or shared parameter guid. All Elements within Autodesk Revit contain Parameters. These are options that can be accessed in a generic fashion. Revit contains many built in parameter types but users and now developers, via the API, can add their own parameters in the form of shared parameters. The developer should become familiar with the Revit user interface for added and managing parameters and shared parameters before using this API. The user interface components can be found in the following locations: Element Properties dialog, Shared Parameters dialog (available from the File menu), Project Parameters dialog (available from the Settings menu), Family Types dialog (available from the Settings menu when editing a family). There are several relationships between the objects that make up the APIs exposure of parameters. The parameter object contains the data value. Parameter objects can be retrieved from Elements if you know its built-in id, its definition or its shared parameter guid. Each parameter has a definition. New parameters can be added to Elements by adding a ParameterBinding object to the Document object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Parameter

See Also

Parameter Members
Autodesk.Revit Namespace


Parameter Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterParameterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set | Overloaded.
Public method | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Get the display unit type of the parameter object.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject ..:: IsReadOnly.)
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter
Autodesk.Revit Namespace


Parameter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Parameter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Parameter Class
Autodesk.Revit Namespace


Parameter Methods
CollapseAll image DropDown image

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set | Overloaded.
Public method | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Parameter
Autodesk.Revit Namespace


AsDouble Method

Parameter..::AsDouble Method
CollapseAll image DropDown image

Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double AsDouble()
Visual Basic (Declaration)
Public Function AsDouble As Double
Visual C++
public:
double AsDouble ()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

See Also

Parameter Class
Autodesk.Revit Namespace


AsElementId Method

Parameter..::AsElementId Method
CollapseAll image DropDown image

Provides access to the ElementId stored within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId AsElementId()
Visual Basic (Declaration)
Public Function AsElementId As ElementId
Visual C++
public:
ElementId AsElementId ()

Return Value

The ElementId contained in the parameter.

Remarks

The AsElementId method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

See Also

Parameter Class
Autodesk.Revit Namespace


AsInteger Method

Parameter..::AsInteger Method
CollapseAll image DropDown image

Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int AsInteger()
Visual Basic (Declaration)
Public Function AsInteger As Integer
Visual C++
public:
int AsInteger ()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

See Also

Parameter Class
Autodesk.Revit Namespace


AsString Method

Parameter..::AsString Method
CollapseAll image DropDown image

Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string AsString()
Visual Basic (Declaration)
Public Function AsString As String
Visual C++
public:
String^ AsString ()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

See Also

Parameter Class
Autodesk.Revit Namespace


AsValueString Method

Parameter..::AsValueString Method
CollapseAll image DropDown image

Get the parameter value as a string with unit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string AsValueString()
Visual Basic (Declaration)
Public Function AsValueString As String
Visual C++
public:
String^ AsValueString ()

Return Value

The string that represents the parameter value.

Remarks

The method only applies to parameters of value types. If the parameter is not a value, the method returns a null pointer.

See Also

Parameter Class
Autodesk.Revit Namespace


Set Method

Parameter..::Set Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Set(Double) | Set the parameter to a new real number value.
Public method | Set(Int32) | Set the parameter to a new integer value.
Public method | Set(String) | Set the parameter to a new string of text.
Public method | Set(ElementId%) | Set the parameter to a new element id.

See Also

Parameter Class
Parameter Members
Autodesk.Revit Namespace


Set Method (Double)

Parameter..::Set Method (Double)
See Also
CollapseAll image DropDown image

Set the parameter to a new real number value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Set(
    double value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
bool Set (
    double value
)

Parameters

value
Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

See Also

Parameter Class
Autodesk.Revit Namespace


Set Method (Int32)

Parameter..::Set Method (Int32)
See Also
CollapseAll image DropDown image

Set the parameter to a new integer value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Set(
    int value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As Integer _
) As Boolean
Visual C++
public:
bool Set (
    int value
)

Parameters

value
Int32
The new integer value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a integer.

See Also

Parameter Class
Autodesk.Revit Namespace


Set Method (String)

Parameter..::Set Method (String)
See Also
CollapseAll image DropDown image

Set the parameter to a new string of text.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Set(
    string value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
bool Set (
    String^ value
)

Parameters

value
String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

See Also

Parameter Class
Autodesk.Revit Namespace


Set Method (ElementId)

Parameter..::Set Method (ElementId%)
See Also
CollapseAll image DropDown image

Set the parameter to a new element id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Set(
    ref ElementId value
)
Visual Basic (Declaration)
Public Function Set ( _
    ByRef value As ElementId _
) As Boolean
Visual C++
public:
bool Set (
    ElementId% value
)

Parameters

value
ElementId %
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

Parameter Class
Autodesk.Revit Namespace


SetValueString Method

Parameter..::SetValueString Method
CollapseAll image DropDown image

Set the parameter value according to the input string.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SetValueString(
    string valueString
)
Visual Basic (Declaration)
Public Function SetValueString ( _
    valueString As String _
) As Boolean
Visual C++
public:
bool SetValueString (
    String^ valueString
)

Parameters

valueString
String
The string that represents the parameter value.

Return Value

Indicates whether the parameter value is successfully set.

Remarks

The method only applies to parameters of value types.

See Also

Parameter Class
Autodesk.Revit Namespace


Parameter Properties
CollapseAll image DropDown image

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Get the display unit type of the parameter object.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject ..:: IsReadOnly.)
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter
Autodesk.Revit Namespace


Definition Property

Parameter..::Definition Property
CollapseAll image DropDown image

Returns the Definition object that describes the data type, name and other details of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definition Definition{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Definition As Definition
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

See Also

Parameter Class
Autodesk.Revit Namespace


DisplayUnitType Property

Parameter..::DisplayUnitType Property
CollapseAll image DropDown image

Get the display unit type of the parameter object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DisplayUnitType DisplayUnitType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

Return Value

The display unit type of the parameter.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::Parameters::DisplayUnitType::Invalid.

See Also

Parameter Class
Autodesk.Revit Namespace


IsReadOnly Property

Parameter..::IsReadOnly Property
CollapseAll image DropDown image

Get the readonly property of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override bool IsReadOnly{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

Remarks

This function can be used to check if the parameter is read-only.

See Also

Parameter Class
Autodesk.Revit Namespace


StorageType Property

Parameter..::StorageType Property
CollapseAll image DropDown image

Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StorageType StorageType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

Parameter Class
Autodesk.Revit Namespace


ParameterFilter Class
See Also Members
CollapseAll image DropDown image

To filter elements with specific parameter criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("AD469815-0BA9-4bca-9BCD-2C8A9556731F")]
public class ParameterFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("AD469815-0BA9-4bca-9BCD-2C8A9556731F")> _
Public Class ParameterFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"AD469815-0BA9-4bca-9BCD-2C8A9556731F")]
public ref class ParameterFilter : public Filter

Remarks

The parameter filter object is used to filter all the elements in the document which meet the given parameter criterion.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::ParameterFilter

See Also

ParameterFilter Members
Autodesk.Revit Namespace


ParameterFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ParameterFilter
Visual Basic (Declaration)
Public Class ParameterFilter
Visual C++
public ref class ParameterFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterFilterParameterFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterFilter
Autodesk.Revit Namespace


ParameterFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterFilter Class
Autodesk.Revit Namespace


ParameterFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class ParameterFilter
Visual Basic (Declaration)
Public Class ParameterFilter
Visual C++
public ref class ParameterFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterFilter
Autodesk.Revit Namespace


Dispose Method

ParameterFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ParameterFilter Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ParameterFilter..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterFilter Class
Autodesk.Revit Namespace


ParameterMap Class
See Also Members
CollapseAll image DropDown image

A map that can contain a mapping of a parameter name (a String) to a parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C5EA27F0-3D6D-4767-8407-38C0D428679F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ParameterMap : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("C5EA27F0-3D6D-4767-8407-38C0D428679F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ParameterMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"C5EA27F0-3D6D-4767-8407-38C0D428679F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ParameterMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterMap

See Also

ParameterMap Members
Autodesk.Revit Namespace


ParameterMap Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ParameterMap
Visual Basic (Declaration)
Public Class ParameterMap
Visual C++
public ref class ParameterMap

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterMapParameterMapNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

ParameterMap
Autodesk.Revit Namespace


ParameterMap Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterMap ()

See Also

ParameterMap Class
Autodesk.Revit Namespace


ParameterMap Methods
CollapseAll image DropDown image

Syntax

C#
public class ParameterMap
Visual Basic (Declaration)
Public Class ParameterMap
Visual C++
public ref class ParameterMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterMap
Autodesk.Revit Namespace


Clear Method

ParameterMap..::Clear Method
CollapseAll image DropDown image

Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ParameterMap Class
Autodesk.Revit Namespace


Contains Method

ParameterMap..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a key within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains (
    String^ key
)

Parameters

key
String
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

ParameterMap Class
Autodesk.Revit Namespace


Dispose Method

ParameterMap..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ParameterMap Class
Autodesk.Revit Namespace


Erase Method

ParameterMap..::Erase Method
CollapseAll image DropDown image

Removes a object with the specified key from the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase (
    String^ key
)

Parameters

key
String
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


ForwardIterator Method

ParameterMap..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ParameterMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


GetEnumerator Method

ParameterMap..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


Insert Method

ParameterMap..::Insert Method
CollapseAll image DropDown image

Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    string key,
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert (
    String^ key,
    Parameter^ item
)

Parameters

key
String
The key to be used for inserting the item into the map.
item
Parameter
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ParameterMap..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterMap Class
Autodesk.Revit Namespace


ReverseIterator Method

ParameterMap..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ParameterMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


ParameterMap Properties
CollapseAll image DropDown image

Syntax

C#
public class ParameterMap
Visual Basic (Declaration)
Public Class ParameterMap
Visual C++
public ref class ParameterMap

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

ParameterMap
Autodesk.Revit Namespace


IsEmpty Property

ParameterMap..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the map is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

ParameterMap Class
Autodesk.Revit Namespace


Item Property

ParameterMap..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Parameter Item[
    string key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Parameter
Visual C++
public:
virtual property Parameter^ Item[String^ key] {
    Parameter^ get (String^ key);
    void set (String^ key, Parameter^ value);
}

Parameters

key
String
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

ParameterMap Class
Autodesk.Revit Namespace


Size Property

ParameterMap..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterMap Class
Autodesk.Revit Namespace


ParameterMapIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a map relating a parameter name (the key, a String) to a parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("EFBB82F9-0E36-4b8f-B50D-05E3B2CD9A28")]
public abstract class ParameterMapIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("EFBB82F9-0E36-4b8f-B50D-05E3B2CD9A28")> _
Public MustInherit Class ParameterMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"EFBB82F9-0E36-4b8f-B50D-05E3B2CD9A28")]
public ref class ParameterMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterMapIterator

See Also

ParameterMapIterator Members
Autodesk.Revit Namespace


ParameterMapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterMapIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterMapIterator
Visual C++
public ref class ParameterMapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterMapIteratorParameterMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator
Autodesk.Revit Namespace


ParameterMapIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterMapIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ParameterMapIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterMapIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterMapIterator
Visual C++
public ref class ParameterMapIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterMapIterator
Autodesk.Revit Namespace


Dispose Method

ParameterMapIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


MoveNext Method

ParameterMapIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ParameterMapIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


Reset Method

ParameterMapIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ParameterMapIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterMapIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterMapIterator
Visual C++
public ref class ParameterMapIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator
Autodesk.Revit Namespace


Current Property

ParameterMapIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


Key Property

ParameterMapIterator..::Key Property
CollapseAll image DropDown image

Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual string Key{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ParameterSet Class
See Also Members
CollapseAll image DropDown image

A set that contains parameters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("58A9C837-25BB-4c6d-9216-88D0D8B86DCE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ParameterSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("58A9C837-25BB-4c6d-9216-88D0D8B86DCE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"58A9C837-25BB-4c6d-9216-88D0D8B86DCE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterSet

See Also

ParameterSet Members
Autodesk.Revit Namespace


ParameterSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ParameterSet
Visual Basic (Declaration)
Public Class ParameterSet
Visual C++
public ref class ParameterSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterSetParameterSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of parameters that are in the set.

See Also

ParameterSet
Autodesk.Revit Namespace


ParameterSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterSet ()

See Also

ParameterSet Class
Autodesk.Revit Namespace


ParameterSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ParameterSet
Visual Basic (Declaration)
Public Class ParameterSet
Visual C++
public ref class ParameterSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterSet
Autodesk.Revit Namespace


Clear Method

ParameterSet..::Clear Method
CollapseAll image DropDown image

Removes every parameter from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ParameterSet Class
Autodesk.Revit Namespace


Contains Method

ParameterSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a parameter within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Parameter^ item
)

Parameters

item
Parameter
The parameter to be searched for.

Return Value

The Contains method returns True if the parameter is within the set, otherwise False.

See Also

ParameterSet Class
Autodesk.Revit Namespace


Dispose Method

ParameterSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ParameterSet Class
Autodesk.Revit Namespace


Erase Method

ParameterSet..::Erase Method
CollapseAll image DropDown image

Removes a specified parameter from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Parameter _
) As Integer
Visual C++
public:
virtual int Erase (
    Parameter^ item
)

Parameters

item
Parameter
The parameter to be erased.

Return Value

The number of parameters that were erased from the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


ForwardIterator Method

ParameterSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ParameterSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


GetEnumerator Method

ParameterSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


Insert Method

ParameterSet..::Insert Method
CollapseAll image DropDown image

Insert the specified parameter into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Parameter^ item
)

Parameters

item
Parameter
The parameter to be inserted into the set.

Return Value

Returns whether the parameter was inserted into the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ParameterSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterSet Class
Autodesk.Revit Namespace


ReverseIterator Method

ParameterSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ParameterSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


ParameterSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ParameterSet
Visual Basic (Declaration)
Public Class ParameterSet
Visual C++
public ref class ParameterSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of parameters that are in the set.

See Also

ParameterSet
Autodesk.Revit Namespace


IsEmpty Property

ParameterSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ParameterSet Class
Autodesk.Revit Namespace


Size Property

ParameterSet..::Size Property
CollapseAll image DropDown image

Returns the number of parameters that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterSet Class
Autodesk.Revit Namespace


ParameterSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a parameter set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4CFF8FEE-DB25-4ca5-A84B-167DD146D3CC")]
public abstract class ParameterSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4CFF8FEE-DB25-4ca5-A84B-167DD146D3CC")> _
Public MustInherit Class ParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4CFF8FEE-DB25-4ca5-A84B-167DD146D3CC")]
public ref class ParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterSetIterator

See Also

ParameterSetIterator Members
Autodesk.Revit Namespace


ParameterSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterSetIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterSetIterator
Visual C++
public ref class ParameterSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterSetIteratorParameterSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator
Autodesk.Revit Namespace


ParameterSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ParameterSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterSetIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterSetIterator
Visual C++
public ref class ParameterSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterSetIterator
Autodesk.Revit Namespace


Dispose Method

ParameterSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

ParameterSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ParameterSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


Reset Method

ParameterSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ParameterSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterSetIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterSetIterator
Visual C++
public ref class ParameterSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator
Autodesk.Revit Namespace


Current Property

ParameterSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ParameterStorage Class
See Also Members
CollapseAll image DropDown image

An object that contains details for the value of a parameter. This class is mainly used with the class FilterCriterion to retrieve Elements according to certain criteria.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("ECCB2394-583D-4b40-8D90-953AFB6AF9FF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ParameterStorage : APIObject
Visual Basic (Declaration)
<GuidAttribute("ECCB2394-583D-4b40-8D90-953AFB6AF9FF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ParameterStorage _
    Inherits APIObject
Visual C++
[GuidAttribute(L"ECCB2394-583D-4b40-8D90-953AFB6AF9FF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ParameterStorage : public APIObject

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterStorage

See Also

ParameterStorage Members
Autodesk.Revit Namespace


ParameterStorage Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class ParameterStorage
Visual Basic (Declaration)
Public Class ParameterStorage
Visual C++
public ref class ParameterStorage

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterStorageParameterStorageNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsReadOnly | (Overrides APIObject ..:: IsReadOnly.)
Public property | StorageType | Describes the type that contains parameter's value.

See Also

ParameterStorage
Autodesk.Revit Namespace


ParameterStorage Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterStorage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterStorage ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


ParameterStorage Methods
CollapseAll image DropDown image

Syntax

C#
public class ParameterStorage
Visual Basic (Declaration)
Public Class ParameterStorage
Visual C++
public ref class ParameterStorage

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterStorage
Autodesk.Revit Namespace


AsDouble Method

ParameterStorage..::AsDouble Method
CollapseAll image DropDown image

Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual double AsDouble()
Visual Basic (Declaration)
Public Overridable Function AsDouble As Double
Visual C++
public:
virtual double AsDouble ()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

Exceptions

Exception | Condition
InvalidOperationException..::InvalidOperationExceptionInvalidOperationExceptionNew()() | Thrown when the StorageType is not Double

See Also

ParameterStorage Class
Autodesk.Revit Namespace


AsElementId Method

ParameterStorage..::AsElementId Method
CollapseAll image DropDown image

Provides access to the ElementId stored within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElementId AsElementId()
Visual Basic (Declaration)
Public Overridable Function AsElementId As ElementId
Visual C++
public:
virtual ElementId AsElementId ()

Return Value

The ElementId contained in the parameter.

Remarks

The AsElementId method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

Exceptions

Exception | Condition
InvalidOperationException..::InvalidOperationExceptionInvalidOperationExceptionNew()() | Thrown when the StorageType is not ElementId

See Also

ParameterStorage Class
Autodesk.Revit Namespace


AsInteger Method

ParameterStorage..::AsInteger Method
CollapseAll image DropDown image

Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int AsInteger()
Visual Basic (Declaration)
Public Overridable Function AsInteger As Integer
Visual C++
public:
virtual int AsInteger ()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

Exceptions

Exception | Condition
InvalidOperationException..::InvalidOperationExceptionInvalidOperationExceptionNew()() | Thrown when the StorageType is not Integer

See Also

ParameterStorage Class
Autodesk.Revit Namespace


AsString Method

ParameterStorage..::AsString Method
CollapseAll image DropDown image

Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual string AsString()
Visual Basic (Declaration)
Public Overridable Function AsString As String
Visual C++
public:
virtual String^ AsString ()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

Exceptions

Exception | Condition
InvalidOperationException..::InvalidOperationExceptionInvalidOperationExceptionNew()() | Thrown when the StorageType is not String

See Also

ParameterStorage Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ParameterStorage..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterStorage Class
Autodesk.Revit Namespace


Set Method

ParameterStorage..::Set Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Set(Double) | Set the parameter to a new real number value.
Public method | Set(Int32) | Set the parameter to a new integer value.
Public method | Set(String) | Set the parameter to a new string of text.
Public method | Set(ElementId%) | Set the parameter to a new element id.

See Also

ParameterStorage Class
ParameterStorage Members
Autodesk.Revit Namespace


Set Method (Double)

ParameterStorage..::Set Method (Double)
See Also
CollapseAll image DropDown image

Set the parameter to a new real number value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Set(
    double value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
virtual bool Set (
    double value
)

Parameters

value
Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown System::ArgumentNullException when the value is infinite.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


Set Method (Int32)

ParameterStorage..::Set Method (Int32)
See Also
CollapseAll image DropDown image

Set the parameter to a new integer value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Set(
    int value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As Integer _
) As Boolean
Visual C++
public:
virtual bool Set (
    int value
)

Parameters

value
Int32
The new integer value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a integer.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


Set Method (String)

ParameterStorage..::Set Method (String)
See Also
CollapseAll image DropDown image

Set the parameter to a new string of text.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Set(
    string value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool Set (
    String^ value
)

Parameters

value
String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown System::ArgumentNullException when the value is null.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


Set Method (ElementId)

ParameterStorage..::Set Method (ElementId%)
See Also
CollapseAll image DropDown image

Set the parameter to a new element id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Set(
    ref ElementId value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    ByRef value As ElementId _
) As Boolean
Visual C++
public:
virtual bool Set (
    ElementId% value
)

Parameters

value
ElementId %
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


ParameterStorage Properties
CollapseAll image DropDown image

Syntax

C#
public class ParameterStorage
Visual Basic (Declaration)
Public Class ParameterStorage
Visual C++
public ref class ParameterStorage

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | (Overrides APIObject ..:: IsReadOnly.)
Public property | StorageType | Describes the type that contains parameter's value.

See Also

ParameterStorage
Autodesk.Revit Namespace


IsReadOnly Property

ParameterStorage..::IsReadOnly Property
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override bool IsReadOnly{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

See Also

ParameterStorage Class
Autodesk.Revit Namespace


StorageType Property

ParameterStorage..::StorageType Property
CollapseAll image DropDown image

Describes the type that contains parameter's value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StorageType StorageType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The parameter's value stored here is not associated to the contents of a particular Element while the value stored in the class Parameter is; The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


PlanCircuit Class
See Also Members
CollapseAll image DropDown image

An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6B098CEE-319E-429c-B7CB-99637A65FA60")]
public class PlanCircuit : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6B098CEE-319E-429c-B7CB-99637A65FA60")> _
Public Class PlanCircuit _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6B098CEE-319E-429c-B7CB-99637A65FA60")]
public ref class PlanCircuit : public APIObject

Remarks

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of romms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanCircuit

See Also

PlanCircuit Members
Autodesk.Revit Namespace


PlanCircuit Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PlanCircuit
Visual Basic (Declaration)
Public Class PlanCircuit
Visual C++
public ref class PlanCircuit

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanCircuitPlanCircuitNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Area | The enclosed area of the circuit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.

See Also

PlanCircuit
Autodesk.Revit Namespace


PlanCircuit Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanCircuit()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuit ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanCircuit Class
Autodesk.Revit Namespace


PlanCircuit Methods
CollapseAll image DropDown image

Syntax

C#
public class PlanCircuit
Visual Basic (Declaration)
Public Class PlanCircuit
Visual C++
public ref class PlanCircuit

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PlanCircuit
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PlanCircuit..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PlanCircuit Class
Autodesk.Revit Namespace


PlanCircuit Properties
CollapseAll image DropDown image

Syntax

C#
public class PlanCircuit
Visual Basic (Declaration)
Public Class PlanCircuit
Visual C++
public ref class PlanCircuit

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The enclosed area of the circuit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.

See Also

PlanCircuit
Autodesk.Revit Namespace


Area Property

PlanCircuit..::Area Property
CollapseAll image DropDown image

The enclosed area of the circuit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Area{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

See Also

PlanCircuit Class
Autodesk.Revit Namespace


IsRoomLocated Property

PlanCircuit..::IsRoomLocated Property
CollapseAll image DropDown image

Reports whether there is a room located in this circuit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsRoomLocated{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsRoomLocated As Boolean
Visual C++
public:
property bool IsRoomLocated {
    bool get ();
}

Field Value

True if there is a room located in this circuit on the circuit's level, false if there is no room located in this circuit on the circuit's level.

See Also

PlanCircuit Class
Autodesk.Revit Namespace


SideNum Property

PlanCircuit..::SideNum Property
CollapseAll image DropDown image

The number of sides in the circuit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int SideNum{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SideNum As Integer
Visual C++
public:
property int SideNum {
    int get ();
}

See Also

PlanCircuit Class
Autodesk.Revit Namespace


PlanCircuitSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any number of plan circuit objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("EBD38310-5D81-4fc3-A531-71C2B8D7F284")]
public class PlanCircuitSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("EBD38310-5D81-4fc3-A531-71C2B8D7F284")> _
Public Class PlanCircuitSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"EBD38310-5D81-4fc3-A531-71C2B8D7F284")]
public ref class PlanCircuitSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanCircuitSet

See Also

PlanCircuitSet Members
Autodesk.Revit Namespace


PlanCircuitSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PlanCircuitSet
Visual Basic (Declaration)
Public Class PlanCircuitSet
Visual C++
public ref class PlanCircuitSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanCircuitSetPlanCircuitSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet
Autodesk.Revit Namespace


PlanCircuitSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanCircuitSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuitSet ()

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


PlanCircuitSet Methods
CollapseAll image DropDown image

Syntax

C#
public class PlanCircuitSet
Visual Basic (Declaration)
Public Class PlanCircuitSet
Visual C++
public ref class PlanCircuitSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PlanCircuitSet
Autodesk.Revit Namespace


Clear Method

PlanCircuitSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Contains Method

PlanCircuitSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Contains (
    PlanCircuit^ item
)

Parameters

item
PlanCircuit
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Dispose Method

PlanCircuitSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Erase Method

PlanCircuitSet..::Erase Method
CollapseAll image DropDown image

Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PlanCircuit _
) As Integer
Visual C++
public:
virtual int Erase (
    PlanCircuit^ item
)

Parameters

item
PlanCircuit
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


ForwardIterator Method

PlanCircuitSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PlanCircuitSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


GetEnumerator Method

PlanCircuitSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Insert Method

PlanCircuitSet..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Insert (
    PlanCircuit^ item
)

Parameters

item
PlanCircuit
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PlanCircuitSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


ReverseIterator Method

PlanCircuitSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PlanCircuitSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


PlanCircuitSet Properties
CollapseAll image DropDown image

Syntax

C#
public class PlanCircuitSet
Visual Basic (Declaration)
Public Class PlanCircuitSet
Visual C++
public ref class PlanCircuitSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet
Autodesk.Revit Namespace


IsEmpty Property

PlanCircuitSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Size Property

PlanCircuitSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


PlanCircuitSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set of plan circuit objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FDE6058F-2411-4b50-935F-1D52596618A5")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class PlanCircuitSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("FDE6058F-2411-4b50-935F-1D52596618A5")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class PlanCircuitSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"FDE6058F-2411-4b50-935F-1D52596618A5")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PlanCircuitSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanCircuitSetIterator

See Also

PlanCircuitSetIterator Members
Autodesk.Revit Namespace


PlanCircuitSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PlanCircuitSetIterator
Visual Basic (Declaration)
Public MustInherit Class PlanCircuitSetIterator
Visual C++
public ref class PlanCircuitSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanCircuitSetIteratorPlanCircuitSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator
Autodesk.Revit Namespace


PlanCircuitSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanCircuitSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuitSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


PlanCircuitSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PlanCircuitSetIterator
Visual Basic (Declaration)
Public MustInherit Class PlanCircuitSetIterator
Visual C++
public ref class PlanCircuitSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PlanCircuitSetIterator
Autodesk.Revit Namespace


Dispose Method

PlanCircuitSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

PlanCircuitSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PlanCircuitSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


Reset Method

PlanCircuitSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


PlanCircuitSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PlanCircuitSetIterator
Visual Basic (Declaration)
Public MustInherit Class PlanCircuitSetIterator
Visual C++
public ref class PlanCircuitSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator
Autodesk.Revit Namespace


Current Property

PlanCircuitSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


PlanTopology Class
See Also Members
CollapseAll image DropDown image

An object that represents a Plan Topology within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("511384BD-1B3B-45ac-966E-A228F8AA94D3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PlanTopology : APIObject
Visual Basic (Declaration)
<GuidAttribute("511384BD-1B3B-45ac-966E-A228F8AA94D3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PlanTopology _
    Inherits APIObject
Visual C++
[GuidAttribute(L"511384BD-1B3B-45ac-966E-A228F8AA94D3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PlanTopology : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanTopology

See Also

PlanTopology Members
Autodesk.Revit Namespace


PlanTopology Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PlanTopology
Visual Basic (Declaration)
Public Class PlanTopology
Visual C++
public ref class PlanTopology

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanTopologyPlanTopologyNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Circuits | Retrieves Circuits of the PlanTopology.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | Retrieves Level of the PlanTopology.
Public property | Phase | Retrieves the phase of the PlanTopology.
Public property | Rooms | Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology
Autodesk.Revit Namespace


PlanTopology Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanTopology()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopology ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanTopology Class
Autodesk.Revit Namespace


PlanTopology Methods
CollapseAll image DropDown image

Syntax

C#
public class PlanTopology
Visual Basic (Declaration)
Public Class PlanTopology
Visual C++
public ref class PlanTopology

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PlanTopology
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PlanTopology..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PlanTopology Class
Autodesk.Revit Namespace


PlanTopology Properties
CollapseAll image DropDown image

Syntax

C#
public class PlanTopology
Visual Basic (Declaration)
Public Class PlanTopology
Visual C++
public ref class PlanTopology

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Circuits | Retrieves Circuits of the PlanTopology.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | Retrieves Level of the PlanTopology.
Public property | Phase | Retrieves the phase of the PlanTopology.
Public property | Rooms | Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology
Autodesk.Revit Namespace


Circuits Property

PlanTopology..::Circuits Property
CollapseAll image DropDown image

Retrieves Circuits of the PlanTopology.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanCircuitSet Circuits{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Circuits As PlanCircuitSet
Visual C++
public:
property PlanCircuitSet^ Circuits {
    PlanCircuitSet^ get ();
}

See Also

PlanTopology Class
Autodesk.Revit Namespace


Level Property

PlanTopology..::Level Property
CollapseAll image DropDown image

Retrieves Level of the PlanTopology.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level Level{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

See Also

PlanTopology Class
Autodesk.Revit Namespace


Phase Property

PlanTopology..::Phase Property
CollapseAll image DropDown image

Retrieves the phase of the PlanTopology.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Phase Phase{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Phase As Phase
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

See Also

PlanTopology Class
Autodesk.Revit Namespace


Rooms Property

PlanTopology..::Rooms Property
CollapseAll image DropDown image

Retrieves rooms of the PlanTopology in the last phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet Rooms{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Rooms As ElementSet
Visual C++
public:
property ElementSet^ Rooms {
    ElementSet^ get ();
}

Remarks

The Rooms you get here is in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class
Autodesk.Revit Namespace


PlanTopologySet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any number of plan topology objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("551D027D-572B-4f2b-9567-19B9266AABC5")]
public class PlanTopologySet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("551D027D-572B-4f2b-9567-19B9266AABC5")> _
Public Class PlanTopologySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"551D027D-572B-4f2b-9567-19B9266AABC5")]
public ref class PlanTopologySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanTopologySet

See Also

PlanTopologySet Members
Autodesk.Revit Namespace


PlanTopologySet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PlanTopologySet
Visual Basic (Declaration)
Public Class PlanTopologySet
Visual C++
public ref class PlanTopologySet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanTopologySetPlanTopologySetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet
Autodesk.Revit Namespace


PlanTopologySet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanTopologySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopologySet ()

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


PlanTopologySet Methods
CollapseAll image DropDown image

Syntax

C#
public class PlanTopologySet
Visual Basic (Declaration)
Public Class PlanTopologySet
Visual C++
public ref class PlanTopologySet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PlanTopologySet
Autodesk.Revit Namespace


Clear Method

PlanTopologySet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Contains Method

PlanTopologySet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Contains (
    PlanTopology^ item
)

Parameters

item
PlanTopology
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Dispose Method

PlanTopologySet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Erase Method

PlanTopologySet..::Erase Method
CollapseAll image DropDown image

Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PlanTopology _
) As Integer
Visual C++
public:
virtual int Erase (
    PlanTopology^ item
)

Parameters

item
PlanTopology
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


ForwardIterator Method

PlanTopologySet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PlanTopologySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


GetEnumerator Method

PlanTopologySet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Insert Method

PlanTopologySet..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Insert (
    PlanTopology^ item
)

Parameters

item
PlanTopology
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PlanTopologySet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


ReverseIterator Method

PlanTopologySet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PlanTopologySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


PlanTopologySet Properties
CollapseAll image DropDown image

Syntax

C#
public class PlanTopologySet
Visual Basic (Declaration)
Public Class PlanTopologySet
Visual C++
public ref class PlanTopologySet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet
Autodesk.Revit Namespace


IsEmpty Property

PlanTopologySet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Size Property

PlanTopologySet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


PlanTopologySetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set of plan topology objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CE820195-2832-498b-8DCB-0D7962DCEF51")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class PlanTopologySetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("CE820195-2832-498b-8DCB-0D7962DCEF51")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class PlanTopologySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"CE820195-2832-498b-8DCB-0D7962DCEF51")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PlanTopologySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanTopologySetIterator

See Also

PlanTopologySetIterator Members
Autodesk.Revit Namespace


PlanTopologySetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PlanTopologySetIterator
Visual Basic (Declaration)
Public MustInherit Class PlanTopologySetIterator
Visual C++
public ref class PlanTopologySetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanTopologySetIteratorPlanTopologySetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator
Autodesk.Revit Namespace


PlanTopologySetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanTopologySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopologySetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


PlanTopologySetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PlanTopologySetIterator
Visual Basic (Declaration)
Public MustInherit Class PlanTopologySetIterator
Visual C++
public ref class PlanTopologySetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PlanTopologySetIterator
Autodesk.Revit Namespace


Dispose Method

PlanTopologySetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


MoveNext Method

PlanTopologySetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PlanTopologySetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


Reset Method

PlanTopologySetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


PlanTopologySetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PlanTopologySetIterator
Visual Basic (Declaration)
Public MustInherit Class PlanTopologySetIterator
Visual C++
public ref class PlanTopologySetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator
Autodesk.Revit Namespace


Current Property

PlanTopologySetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


PostedError Class
See Also Members
CollapseAll image DropDown image

A class that holds information about a posted error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F6DD6FB0-563C-4daf-8B39-C19833372710")]
public class PostedError : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F6DD6FB0-563C-4daf-8B39-C19833372710")> _
Public Class PostedError _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F6DD6FB0-563C-4daf-8B39-C19833372710")]
public ref class PostedError : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PostedError

See Also

PostedError Members
Autodesk.Revit Namespace


PostedError Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PostedError
Visual Basic (Declaration)
Public Class PostedError
Visual C++
public ref class PostedError

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PostedErrorPostedErrorNew | Copy constructor

Public Methods

 | Name | Description
 | Equality | Equality operator - static method
 | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides Object ..:: ToString()().)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Descriptor | Internal string identifier for the error.
Public property | ErrorType | Type of the error.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | Message associated with the error.
Public property | RawID | Internal identifier of the error.

See Also

PostedError
Autodesk.Revit Namespace


PostedError Constructor
CollapseAll image DropDown image

Copy constructor

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PostedError(
    PostedError pe
)
Visual Basic (Declaration)
Public Sub New ( _
    pe As PostedError _
)
Visual C++
public:
PostedError (
    PostedError^ pe
)

Parameters

pe
PostedError

See Also

PostedError Class
Autodesk.Revit Namespace


PostedError Methods
CollapseAll image DropDown image

Syntax

C#
public class PostedError
Visual Basic (Declaration)
Public Class PostedError
Visual C++
public ref class PostedError

The type exposes the following methods.

Public Methods

 | Name | Description
 | Equality | Equality operator - static method
 | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides Object ..:: ToString()().)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

PostedError
Autodesk.Revit Namespace


Equality Operator

PostedError..::Equality Operator
CollapseAll image DropDown image

Equality operator - static method

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static bool operator ==(
    PostedError lhs,
    PostedError rhs
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    lhs As PostedError, _
    rhs As PostedError _
) As Boolean
Visual C++
public:
static bool operator == (
    PostedError^ lhs,
    PostedError^ rhs
)

Parameters

lhs
PostedError
rhs
PostedError

See Also

PostedError Class
Autodesk.Revit Namespace


Equals Method

PostedError..::Equals Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(PostedError) | Tests equality
 | Equals(PostedError, PostedError) | Tests equality - static method

See Also

PostedError Class
PostedError Members
Autodesk.Revit Namespace


Equals Method (PostedError)

PostedError..::Equals Method (PostedError)
See Also
CollapseAll image DropDown image

Tests equality

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Equals(
    PostedError pe
)
Visual Basic (Declaration)
Public Function Equals ( _
    pe As PostedError _
) As Boolean
Visual C++
public:
bool Equals (
    PostedError^ pe
)

Parameters

pe
PostedError

See Also

PostedError Class
Autodesk.Revit Namespace


Equals Method (PostedError, PostedError)

PostedError..::Equals Method (PostedError, PostedError)
See Also
CollapseAll image DropDown image

Tests equality - static method

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static bool Equals(
    PostedError lhs,
    PostedError rhs
)
Visual Basic (Declaration)
Public Shared Function Equals ( _
    lhs As PostedError, _
    rhs As PostedError _
) As Boolean
Visual C++
public:
static bool Equals (
    PostedError^ lhs,
    PostedError^ rhs
)

Parameters

lhs
PostedError
rhs
PostedError

See Also

PostedError Class
Autodesk.Revit Namespace


ToString Method

PostedError..::ToString Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString () override

See Also

PostedError Class
Autodesk.Revit Namespace


PostedError Properties
CollapseAll image DropDown image

Syntax

C#
public class PostedError
Visual Basic (Declaration)
Public Class PostedError
Visual C++
public ref class PostedError

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Descriptor | Internal string identifier for the error.
Public property | ErrorType | Type of the error.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | Message associated with the error.
Public property | RawID | Internal identifier of the error.

See Also

PostedError
Autodesk.Revit Namespace


Descriptor Property

PostedError..::Descriptor Property
CollapseAll image DropDown image

Internal string identifier for the error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Descriptor{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Descriptor As String
Visual C++
public:
property String^ Descriptor {
    String^ get ();
}

Remarks

This string is never localized. Though a descriptor may differ between two major versions of Revit, thus it is not unique, it is a more reliable identifier then the integer ID.

See Also

PostedError Class
Autodesk.Revit Namespace


ErrorType Property

PostedError..::ErrorType Property
CollapseAll image DropDown image

Type of the error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PostedErrorType ErrorType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ErrorType As PostedErrorType
Visual C++
public:
property PostedErrorType ErrorType {
    PostedErrorType get ();
}

Remarks

The type indentifies the severity of a posted error. The lowest level is a 'Warning', which can be safely ignored in most cases, to 'Fatal Error', which should probably never be ignored

See Also

PostedError Class
Autodesk.Revit Namespace


Message Property

PostedError..::Message Property
CollapseAll image DropDown image

Message associated with the error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Message{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

Remarks

This message may localized for the target language version.

See Also

PostedError Class
Autodesk.Revit Namespace


RawID Property

PostedError..::RawID Property
CollapseAll image DropDown image

Internal identifier of the error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int RawID{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RawID As Integer
Visual C++
public:
property int RawID {
    int get ();
}

Remarks

This ID is not unique and should not be depended upon. It can change between two versions of Revit and there could also be one ID associated with more then one error.

See Also

PostedError Class
Autodesk.Revit Namespace


PostedErrorArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any number of posted errors.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7A143393-925A-48b2-A6E7-B6EF4B83B3BE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PostedErrorArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("7A143393-925A-48b2-A6E7-B6EF4B83B3BE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PostedErrorArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"7A143393-925A-48b2-A6E7-B6EF4B83B3BE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PostedErrorArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PostedErrorArray

See Also

PostedErrorArray Members
Autodesk.Revit Namespace


PostedErrorArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PostedErrorArray
Visual Basic (Declaration)
Public Class PostedErrorArray
Visual C++
public ref class PostedErrorArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PostedErrorArrayPostedErrorArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

PostedErrorArray
Autodesk.Revit Namespace


PostedErrorArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PostedErrorArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PostedErrorArray ()

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


PostedErrorArray Methods
CollapseAll image DropDown image

Syntax

C#
public class PostedErrorArray
Visual Basic (Declaration)
Public Class PostedErrorArray
Visual C++
public ref class PostedErrorArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PostedErrorArray
Autodesk.Revit Namespace


Append Method

PostedErrorArray..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    PostedError item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As PostedError _
)
Visual C++
public:
virtual void Append (
    PostedError^ item
)

Parameters

item
PostedError
The item to be added.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Clear Method

PostedErrorArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Dispose Method

PostedErrorArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


ForwardIterator Method

PostedErrorArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PostedErrorArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PostedErrorArrayIterator
Visual C++
public:
virtual PostedErrorArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


GetEnumerator Method

PostedErrorArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Insert Method

PostedErrorArray..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    PostedError item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As PostedError, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    PostedError^ item,
    int index
)

Parameters

item
PostedError
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PostedErrorArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


ReverseIterator Method

PostedErrorArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PostedErrorArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PostedErrorArrayIterator
Visual C++
public:
virtual PostedErrorArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


PostedErrorArray Properties
CollapseAll image DropDown image

Syntax

C#
public class PostedErrorArray
Visual Basic (Declaration)
Public Class PostedErrorArray
Visual C++
public ref class PostedErrorArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

PostedErrorArray
Autodesk.Revit Namespace


IsEmpty Property

PostedErrorArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Item Property

PostedErrorArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PostedError Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As PostedError
Visual C++
public:
virtual property PostedError^ Item[int index] {
    PostedError^ get (int index);
    void set (int index, PostedError^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Size Property

PostedErrorArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


PostedErrorArrayIterator Class
See Also Members
CollapseAll image DropDown image

A class that holds an array of posted errors.
An iterator to an array of posted errors.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D4518FB0-5592-4ff3-BF77-77722F207A45")]
public abstract class PostedErrorArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D4518FB0-5592-4ff3-BF77-77722F207A45")> _
Public MustInherit Class PostedErrorArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D4518FB0-5592-4ff3-BF77-77722F207A45")]
public ref class PostedErrorArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PostedErrorArrayIterator

See Also

PostedErrorArrayIterator Members
Autodesk.Revit Namespace


PostedErrorArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PostedErrorArrayIterator
Visual Basic (Declaration)
Public MustInherit Class PostedErrorArrayIterator
Visual C++
public ref class PostedErrorArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PostedErrorArrayIteratorPostedErrorArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PostedErrorArrayIterator
Autodesk.Revit Namespace


PostedErrorArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PostedErrorArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PostedErrorArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


PostedErrorArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PostedErrorArrayIterator
Visual Basic (Declaration)
Public MustInherit Class PostedErrorArrayIterator
Visual C++
public ref class PostedErrorArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PostedErrorArrayIterator
Autodesk.Revit Namespace


Dispose Method

PostedErrorArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

PostedErrorArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PostedErrorArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


Reset Method

PostedErrorArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


PostedErrorArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PostedErrorArrayIterator
Visual Basic (Declaration)
Public MustInherit Class PostedErrorArrayIterator
Visual C++
public ref class PostedErrorArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PostedErrorArrayIterator
Autodesk.Revit Namespace


Current Property

PostedErrorArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


PrintManager Class
See Also Members
CollapseAll image DropDown image

Represents the Print information in Print Dialog(File->Print) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("55A9D557-4BF5-4331-B8AF-58AFA16EE196")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PrintManager : APIObject
Visual Basic (Declaration)
<GuidAttribute("55A9D557-4BF5-4331-B8AF-58AFA16EE196")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PrintManager _
    Inherits APIObject
Visual C++
[GuidAttribute(L"55A9D557-4BF5-4331-B8AF-58AFA16EE196")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PrintManager : public APIObject

Remarks

This class is a new interface class in Revit API for print function.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PrintManager

See Also

PrintManager Members
Autodesk.Revit Namespace


PrintManager Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PrintManager
Visual Basic (Declaration)
Public Class PrintManager
Visual C++
public ref class PrintManager

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintManagerPrintManagerNew | Overloaded.

Protected Constructors

 | Name | Description
Protected method | PrintManagerPrintManagerNew | Overloaded.

Public Methods

 | Name | Description
Public method | Close | Close the Print, just like close the Print Dialog in Revit.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNewPrintDriver | User can select new Printer with new printer name and its port name.
Public method | SubmitPrint | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Collate | Retrieve the information about whether to Collate or not of the current print.
Public property | CombinedFile | Retrieve the file name if user choose print to file.
Public property | CopyNumber | Retrieve the Number of copies of current print.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsVirtual | Retrieve the information about whether the current printer is virtual or not in Revit.
Public property | PrinterName | Retrieve the printer name of current project.
Public property | PrintOrderReverse | Retrieve the information about whether to Reverse the print order or not of the current print.
Public property | PrintRange | Retrieve the Print Range of current print.
Public property | PrintSetup | Retrieve the Print Setup information of current project, and you can change the default Print Setting for Current Project.
Public property | PrintToFile | Retrieve the information about whether to Print to File or not of current project.
Public property | PrintToFileName | Retrieve the file name if user choose print to file.
Public property | ViewSheetSetting | Retrieve the View/Sheet Set information of current project, and you can change the default View/Sheet Set for Current Project.

See Also

PrintManager
Autodesk.Revit Namespace


PrintManager Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | PrintManagerPrintManagerNew()() | For Internal Use Only.
Protected method | PrintManagerPrintManagerNew(ADocument*) |

See Also

PrintManager Class
PrintManager Members
Autodesk.Revit Namespace


PrintManager Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintManager ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintManager Constructor (*)
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected PrintManager(
    ADocument* pADoc
)
Visual Basic (Declaration)
Visual Basic does not support APIs that consume or return unsafe types.
Visual C++
protected:
PrintManager (
    ADocument* pADoc
)

Parameters

pADoc
ADocument*

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintManager Methods
CollapseAll image DropDown image

Syntax

C#
public class PrintManager
Visual Basic (Declaration)
Public Class PrintManager
Visual C++
public ref class PrintManager

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Close | Close the Print, just like close the Print Dialog in Revit.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNewPrintDriver | User can select new Printer with new printer name and its port name.
Public method | SubmitPrint | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PrintManager
Autodesk.Revit Namespace


Close Method

PrintManager..::Close Method
CollapseAll image DropDown image

Close the Print, just like close the Print Dialog in Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close ()

Remarks

If you do not close the Print, you will always get the same Print object.

See Also

PrintManager Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

PrintManager..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PrintManager Class
Autodesk.Revit Namespace


SelectNewPrintDriver Method

PrintManager..::SelectNewPrintDriver Method
CollapseAll image DropDown image

User can select new Printer with new printer name and its port name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SelectNewPrintDriver(
    string strPrinterName
)
Visual Basic (Declaration)
Public Sub SelectNewPrintDriver ( _
    strPrinterName As String _
)
Visual C++
public:
void SelectNewPrintDriver (
    String^ strPrinterName
)

Parameters

strPrinterName
String
The name string of new printer.

Remarks

This property is the common property for all project. It means change one project's printer, all the project will change too.

See Also

PrintManager Class
Autodesk.Revit Namespace


SubmitPrint Method

PrintManager..::SubmitPrint Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | SubmitPrint()() | Print with the current Settings.
Public method | SubmitPrint(View) | Print User-assigned view with the current Settings.

See Also

PrintManager Class
PrintManager Members
Autodesk.Revit Namespace


SubmitPrint Method

PrintManager..::SubmitPrint Method
CollapseAll image DropDown image

Print with the current Settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SubmitPrint()
Visual Basic (Declaration)
Public Function SubmitPrint As Boolean
Visual C++
public:
bool SubmitPrint ()

Remarks

PrintManager will print the view/views/sheets which user defined with the current settings.

See Also

PrintManager Class
Autodesk.Revit Namespace


SubmitPrint Method (View)

PrintManager..::SubmitPrint Method (View)
See Also
CollapseAll image DropDown image

Print User-assigned view with the current Settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SubmitPrint(
    View view
)
Visual Basic (Declaration)
Public Function SubmitPrint ( _
    view As View _
) As Boolean
Visual C++
public:
bool SubmitPrint (
    View^ view
)

Parameters

view
View
The User-assigned view.

Remarks

PrintManager will print the user-assigned view with the current settings. When the print range is visible and the view is not the active view, the print result is whole view. It means the visible option will be meaningless in this context.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintManager Properties
CollapseAll image DropDown image

Syntax

C#
public class PrintManager
Visual Basic (Declaration)
Public Class PrintManager
Visual C++
public ref class PrintManager

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Collate | Retrieve the information about whether to Collate or not of the current print.
Public property | CombinedFile | Retrieve the file name if user choose print to file.
Public property | CopyNumber | Retrieve the Number of copies of current print.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsVirtual | Retrieve the information about whether the current printer is virtual or not in Revit.
Public property | PrinterName | Retrieve the printer name of current project.
Public property | PrintOrderReverse | Retrieve the information about whether to Reverse the print order or not of the current print.
Public property | PrintRange | Retrieve the Print Range of current print.
Public property | PrintSetup | Retrieve the Print Setup information of current project, and you can change the default Print Setting for Current Project.
Public property | PrintToFile | Retrieve the information about whether to Print to File or not of current project.
Public property | PrintToFileName | Retrieve the file name if user choose print to file.
Public property | ViewSheetSetting | Retrieve the View/Sheet Set information of current project, and you can change the default View/Sheet Set for Current Project.

See Also

PrintManager
Autodesk.Revit Namespace


Collate Property

PrintManager..::Collate Property
CollapseAll image DropDown image

Retrieve the information about whether to Collate or not of the current print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Collate{ get; set;}
Visual Basic (Declaration)
Public Property Collate As Boolean
Visual C++
public:
property bool Collate {
    bool get ();
    void set (bool value);
}

Remarks

This property is the common property for all project. It means change one project's PrintOrderReverse setting, all the other projects will change too.

See Also

PrintManager Class
Autodesk.Revit Namespace


CombinedFile Property

PrintManager..::CombinedFile Property
CollapseAll image DropDown image

Retrieve the file name if user choose print to file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CombinedFile{ get; set;}
Visual Basic (Declaration)
Public Property CombinedFile As Boolean
Visual C++
public:
property bool CombinedFile {
    bool get ();
    void set (bool value);
}

Remarks

This property is only available when user choose print to file.

See Also

PrintManager Class
Autodesk.Revit Namespace


CopyNumber Property

PrintManager..::CopyNumber Property
CollapseAll image DropDown image

Retrieve the Number of copies of current print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int CopyNumber{ get; set;}
Visual Basic (Declaration)
Public Property CopyNumber As Integer
Visual C++
public:
property int CopyNumber {
    int get ();
    void set (int value);
}

Remarks

This property is only available when user do NOT choose print to file.

See Also

PrintManager Class
Autodesk.Revit Namespace


IsVirtual Property

PrintManager..::IsVirtual Property
CollapseAll image DropDown image

Retrieve the information about whether the current printer is virtual or not in Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VirtualPrinterType IsVirtual{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsVirtual As VirtualPrinterType
Visual C++
public:
property VirtualPrinterType IsVirtual {
    VirtualPrinterType get ();
}

Remarks

This property reports the information in Revit way.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrinterName Property

PrintManager..::PrinterName Property
CollapseAll image DropDown image

Retrieve the printer name of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string PrinterName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PrinterName As String
Visual C++
public:
property String^ PrinterName {
    String^ get ();
}

Remarks

This property is the common property for all project.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintOrderReverse Property

PrintManager..::PrintOrderReverse Property
CollapseAll image DropDown image

Retrieve the information about whether to Reverse the print order or not of the current print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool PrintOrderReverse{ get; set;}
Visual Basic (Declaration)
Public Property PrintOrderReverse As Boolean
Visual C++
public:
property bool PrintOrderReverse {
    bool get ();
    void set (bool value);
}

Remarks

This property is the common property for all project. It means change one project's PrintOrderReverse setting, all the project will change too.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintRange Property

PrintManager..::PrintRange Property
CollapseAll image DropDown image

Retrieve the Print Range of current print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintRange PrintRange{ get; set;}
Visual Basic (Declaration)
Public Property PrintRange As PrintRange
Visual C++
public:
property PrintRange PrintRange {
    PrintRange get ();
    void set (PrintRange value);
}

Remarks

This property is the common property for all project. It means change one project's PrintToFile setting, all the project will change too.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintSetup Property

PrintManager..::PrintSetup Property
CollapseAll image DropDown image

Retrieve the Print Setup information of current project, and you can change the default Print Setting for Current Project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintSetup PrintSetup{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PrintSetup As PrintSetup
Visual C++
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}

Remarks

PrintSetup is a interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintToFile Property

PrintManager..::PrintToFile Property
CollapseAll image DropDown image

Retrieve the information about whether to Print to File or not of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool PrintToFile{ get; set;}
Visual Basic (Declaration)
Public Property PrintToFile As Boolean
Visual C++
public:
property bool PrintToFile {
    bool get ();
    void set (bool value);
}

Remarks

This property is the common property for all project. It means change one project's PrintToFile setting, all the project will change too.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintToFileName Property

PrintManager..::PrintToFileName Property
CollapseAll image DropDown image

Retrieve the file name if user choose print to file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string PrintToFileName{ get; set;}
Visual Basic (Declaration)
Public Property PrintToFileName As String
Visual C++
public:
property String^ PrintToFileName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is only available when user choose print to file or in DWF/PDF virtual printer mode.

See Also

PrintManager Class
Autodesk.Revit Namespace


ViewSheetSetting Property

PrintManager..::ViewSheetSetting Property
CollapseAll image DropDown image

Retrieve the View/Sheet Set information of current project, and you can change the default View/Sheet Set for Current Project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheetSetting ViewSheetSetting{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ViewSheetSetting As ViewSheetSetting
Visual C++
public:
property ViewSheetSetting^ ViewSheetSetting {
    ViewSheetSetting^ get ();
}

Remarks

This property can only get when the Print Range is Selected views/sheets.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintParameters Class
See Also Members
CollapseAll image DropDown image

An object that contains settings used for printing the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2A860F19-BDCF-4321-A6D3-AECFF7EC83A2")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PrintParameters : APIObject
Visual Basic (Declaration)
<GuidAttribute("2A860F19-BDCF-4321-A6D3-AECFF7EC83A2")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PrintParameters _
    Inherits APIObject
Visual C++
[GuidAttribute(L"2A860F19-BDCF-4321-A6D3-AECFF7EC83A2")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PrintParameters : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PrintParameters

See Also

PrintParameters Members
Autodesk.Revit Namespace


PrintParameters Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PrintParameters
Visual Basic (Declaration)
Public Class PrintParameters
Visual C++
public ref class PrintParameters

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintParametersPrintParametersNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ColorDepth | Retrieve the Color Depth Type of current print setting.
Public property | HiddenLineViews | Retrieve the Hidden Line Views of current print setting.
Public property | HideCropBoundaries | Returns if the Options of current print parameter is Hide Crop Boundaries.
Public property | HideReforWorkPlanes | Returns if the Options of current print parameter is View Links in Blue.
Public property | HideScopeBoxes | Returns if the Options of current print parameter is Hide Scope Boxes.
Public property | HideUnreferencedViewTages | Returns if the Options of current print parameter is Hide Unreferenced View Tages.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MarginType | Retrieve the Print Margin Type of current print setting.
Public property | PageOrientation | Retrieves the Page Orientation of the Print Setting.
Public property | PaperPlacement | Retrieve the Paper Placement Type of current print setting.
Public property | PaperSize | Retrieves the Page size of the Print Setting.
Public property | PaperSource | Retrieves the Page source of the Print Setting.
Public property | RasterQuality | Retrieve the Raster Quality Type of current print setting.
Public property | UserDefinedMarginX | Retrieve the User defined x value of offset from corner of current print setting.
Public property | UserDefinedMarginY | Retrieve the User defined y value of offset from corner of current print setting.
Public property | ViewLinksinBlue | Returns if the current print parameter is View Links in Blue.
Public property | Zoom | Retrieve the Zoom value of current print setting.
Public property | ZoomType | Retrieve the Zoom Type of current print setting.

See Also

PrintParameters
Autodesk.Revit Namespace


PrintParameters Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintParameters()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintParameters ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PrintParameters Properties
CollapseAll image DropDown image

Syntax

C#
public class PrintParameters
Visual Basic (Declaration)
Public Class PrintParameters
Visual C++
public ref class PrintParameters

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ColorDepth | Retrieve the Color Depth Type of current print setting.
Public property | HiddenLineViews | Retrieve the Hidden Line Views of current print setting.
Public property | HideCropBoundaries | Returns if the Options of current print parameter is Hide Crop Boundaries.
Public property | HideReforWorkPlanes | Returns if the Options of current print parameter is View Links in Blue.
Public property | HideScopeBoxes | Returns if the Options of current print parameter is Hide Scope Boxes.
Public property | HideUnreferencedViewTages | Returns if the Options of current print parameter is Hide Unreferenced View Tages.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MarginType | Retrieve the Print Margin Type of current print setting.
Public property | PageOrientation | Retrieves the Page Orientation of the Print Setting.
Public property | PaperPlacement | Retrieve the Paper Placement Type of current print setting.
Public property | PaperSize | Retrieves the Page size of the Print Setting.
Public property | PaperSource | Retrieves the Page source of the Print Setting.
Public property | RasterQuality | Retrieve the Raster Quality Type of current print setting.
Public property | UserDefinedMarginX | Retrieve the User defined x value of offset from corner of current print setting.
Public property | UserDefinedMarginY | Retrieve the User defined y value of offset from corner of current print setting.
Public property | ViewLinksinBlue | Returns if the current print parameter is View Links in Blue.
Public property | Zoom | Retrieve the Zoom value of current print setting.
Public property | ZoomType | Retrieve the Zoom Type of current print setting.

See Also

PrintParameters
Autodesk.Revit Namespace


ColorDepth Property

PrintParameters..::ColorDepth Property
CollapseAll image DropDown image

Retrieve the Color Depth Type of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ColorDepthType ColorDepth{ get; set;}
Visual Basic (Declaration)
Public Property ColorDepth As ColorDepthType
Visual C++
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HiddenLineViews Property

PrintParameters..::HiddenLineViews Property
CollapseAll image DropDown image

Retrieve the Hidden Line Views of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public HiddenLineViewsType HiddenLineViews{ get; set;}
Visual Basic (Declaration)
Public Property HiddenLineViews As HiddenLineViewsType
Visual C++
public:
property HiddenLineViewsType HiddenLineViews {
    HiddenLineViewsType get ();
    void set (HiddenLineViewsType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideCropBoundaries Property

PrintParameters..::HideCropBoundaries Property
CollapseAll image DropDown image

Returns if the Options of current print parameter is Hide Crop Boundaries.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HideCropBoundaries{ get; set;}
Visual Basic (Declaration)
Public Property HideCropBoundaries As Boolean
Visual C++
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideReforWorkPlanes Property

PrintParameters..::HideReforWorkPlanes Property
CollapseAll image DropDown image

Returns if the Options of current print parameter is View Links in Blue.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HideReforWorkPlanes{ get; set;}
Visual Basic (Declaration)
Public Property HideReforWorkPlanes As Boolean
Visual C++
public:
property bool HideReforWorkPlanes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideScopeBoxes Property

PrintParameters..::HideScopeBoxes Property
CollapseAll image DropDown image

Returns if the Options of current print parameter is Hide Scope Boxes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HideScopeBoxes{ get; set;}
Visual Basic (Declaration)
Public Property HideScopeBoxes As Boolean
Visual C++
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideUnreferencedViewTages Property

PrintParameters..::HideUnreferencedViewTages Property
CollapseAll image DropDown image

Returns if the Options of current print parameter is Hide Unreferenced View Tages.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HideUnreferencedViewTages{ get; set;}
Visual Basic (Declaration)
Public Property HideUnreferencedViewTages As Boolean
Visual C++
public:
property bool HideUnreferencedViewTages {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


MarginType Property

PrintParameters..::MarginType Property
CollapseAll image DropDown image

Retrieve the Print Margin Type of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MarginType MarginType{ get; set;}
Visual Basic (Declaration)
Public Property MarginType As MarginType
Visual C++
public:
property MarginType MarginType {
    MarginType get ();
    void set (MarginType value);
}

Remarks

This property is only available when Offset from corner is checked.

Exceptions

Exception | Condition
System..::InvalidOperationException | if Offset from corner is unchecked.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PageOrientation Property

PrintParameters..::PageOrientation Property
CollapseAll image DropDown image

Retrieves the Page Orientation of the Print Setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PageOrientationType PageOrientation{ get; set;}
Visual Basic (Declaration)
Public Property PageOrientation As PageOrientationType
Visual C++
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Remarks

User can set or get the Page Orientation of the Print Setting.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PaperPlacement Property

PrintParameters..::PaperPlacement Property
CollapseAll image DropDown image

Retrieve the Paper Placement Type of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperPlacementType PaperPlacement{ get; set;}
Visual Basic (Declaration)
Public Property PaperPlacement As PaperPlacementType
Visual C++
public:
property PaperPlacementType PaperPlacement {
    PaperPlacementType get ();
    void set (PaperPlacementType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


PaperSize Property

PrintParameters..::PaperSize Property
CollapseAll image DropDown image

Retrieves the Page size of the Print Setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSize PaperSize{ get; set;}
Visual Basic (Declaration)
Public Property PaperSize As PaperSize
Visual C++
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}

Remarks

User can select the candidate via PrintSetup::PaperSizes and then set the Page source of the Print Setting.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PaperSource Property

PrintParameters..::PaperSource Property
CollapseAll image DropDown image

Retrieves the Page source of the Print Setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSource PaperSource{ get; set;}
Visual Basic (Declaration)
Public Property PaperSource As PaperSource
Visual C++
public:
property PaperSource^ PaperSource {
    PaperSource^ get ();
    void set (PaperSource^ value);
}

Remarks

User can select the candidate via PrintSetup::PaperSources and then set the Page source of the Print Setting.

See Also

PrintParameters Class
Autodesk.Revit Namespace


RasterQuality Property

PrintParameters..::RasterQuality Property
CollapseAll image DropDown image

Retrieve the Raster Quality Type of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RasterQualityType RasterQuality{ get; set;}
Visual Basic (Declaration)
Public Property RasterQuality As RasterQualityType
Visual C++
public:
property RasterQualityType RasterQuality {
    RasterQualityType get ();
    void set (RasterQualityType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


UserDefinedMarginX Property

PrintParameters..::UserDefinedMarginX Property
CollapseAll image DropDown image

Retrieve the User defined x value of offset from corner of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UserDefinedMarginX{ get; set;}
Visual Basic (Declaration)
Public Property UserDefinedMarginX As Double
Visual C++
public:
property double UserDefinedMarginX {
    double get ();
    void set (double value);
}

Remarks

This property is only available when PaperPlacement is Margins and MarginType is User defined.

Exceptions

Exception | Condition
System..::InvalidOperationException | if PaperPlacement is NOT Margins and MarginType is NOT User defined.

See Also

PrintParameters Class
Autodesk.Revit Namespace


UserDefinedMarginY Property

PrintParameters..::UserDefinedMarginY Property
CollapseAll image DropDown image

Retrieve the User defined y value of offset from corner of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UserDefinedMarginY{ get; set;}
Visual Basic (Declaration)
Public Property UserDefinedMarginY As Double
Visual C++
public:
property double UserDefinedMarginY {
    double get ();
    void set (double value);
}

Remarks

This property is only available when PaperPlacement is Margins and MarginType is User defined.

Exceptions

Exception | Condition
System..::InvalidOperationException | if PaperPlacement is NOT Margins and MarginType is NOT User defined.

See Also

PrintParameters Class
Autodesk.Revit Namespace


ViewLinksinBlue Property

PrintParameters..::ViewLinksinBlue Property
CollapseAll image DropDown image

Returns if the current print parameter is View Links in Blue.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ViewLinksinBlue{ get; set;}
Visual Basic (Declaration)
Public Property ViewLinksinBlue As Boolean
Visual C++
public:
property bool ViewLinksinBlue {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


Zoom Property

PrintParameters..::Zoom Property
CollapseAll image DropDown image

Retrieve the Zoom value of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Zoom{ get; set;}
Visual Basic (Declaration)
Public Property Zoom As Integer
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Remarks

This property will control the Paper placement method. It means if user choose Fit to page and then Paper placement property will change to Center.

Exceptions

Exception | Condition
System..::InvalidOperationException | if Current Zoom Type is NOT Zoom.
System..::ArgumentOutOfRangeException | if Zoom value can not less than 1.

See Also

PrintParameters Class
Autodesk.Revit Namespace


ZoomType Property

PrintParameters..::ZoomType Property
CollapseAll image DropDown image

Retrieve the Zoom Type of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ZoomType ZoomType{ get; set;}
Visual Basic (Declaration)
Public Property ZoomType As ZoomType
Visual C++
public:
property ZoomType ZoomType {
    ZoomType get ();
    void set (ZoomType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


PrintSetup Class
See Also Members
CollapseAll image DropDown image

Represents the Print Setup (File->Print Setup...) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0A0F0C54-4225-409d-98DB-4EB1853B43E3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PrintSetup : APIObject
Visual Basic (Declaration)
<GuidAttribute("0A0F0C54-4225-409d-98DB-4EB1853B43E3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PrintSetup _
    Inherits APIObject
Visual C++
[GuidAttribute(L"0A0F0C54-4225-409d-98DB-4EB1853B43E3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PrintSetup : public APIObject

Remarks

The Print Setup object can only get from PrintManager object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PrintSetup

See Also

PrintSetup Members
Autodesk.Revit Namespace


PrintSetup Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PrintSetup
Visual Basic (Declaration)
Public Class PrintSetup
Visual C++
public ref class PrintSetup

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintSetupPrintSetupNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Delete | Delete the current print setting.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current print setting to another print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | CurrentPrintSetting | Get or Set the current Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PaperSizes | Get all Print sizes of current Print.
Public property | PaperSources | Get all Print sources of current Print.

See Also

PrintSetup
Autodesk.Revit Namespace


PrintSetup Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintSetup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintSetup ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintSetup Class
Autodesk.Revit Namespace


PrintSetup Methods
CollapseAll image DropDown image

Syntax

C#
public class PrintSetup
Visual Basic (Declaration)
Public Class PrintSetup
Visual C++
public ref class PrintSetup

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Delete | Delete the current print setting.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current print setting to another print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

PrintSetup
Autodesk.Revit Namespace


Delete Method

PrintSetup..::Delete Method
CollapseAll image DropDown image

Delete the current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Delete()
Visual Basic (Declaration)
Public Function Delete As Boolean
Visual C++
public:
bool Delete ()

Return Value

Returns false if Delete operation fails, otherwise, returns true.

Remarks

If the current print setting is In-Session, a InvalidOperationException will be thrown.

See Also

PrintSetup Class
Autodesk.Revit Namespace


Rename Method

PrintSetup..::Rename Method
CollapseAll image DropDown image

Rename the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename (
    String^ newName
)

Parameters

newName
String
print setting name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current print setting list, a InvalidOperationException will be thrown.

See Also

PrintSetup Class
Autodesk.Revit Namespace


Revert Method

PrintSetup..::Revert Method
CollapseAll image DropDown image

Revert the current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Revert()
Visual Basic (Declaration)
Public Sub Revert
Visual C++
public:
void Revert ()

Remarks

If the current print setting is In-Session, a InvalidOperationException will be thrown.

See Also

PrintSetup Class
Autodesk.Revit Namespace


Save Method

PrintSetup..::Save Method
CollapseAll image DropDown image

Save the changes for the current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save ()

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

"In-Session" print setting can NOT save, if current print setting is In-Session or the current print setting does not changed, a InvalidOperationException will be thrown.

See Also

PrintSetup Class
Autodesk.Revit Namespace


SaveAs Method

PrintSetup..::SaveAs Method
CollapseAll image DropDown image

Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ newName
)

Parameters

newName
String
print setting name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current print setting list, a InvalidOperationException will be thrown.

See Also

PrintSetup Class
Autodesk.Revit Namespace


PrintSetup Properties
CollapseAll image DropDown image

Syntax

C#
public class PrintSetup
Visual Basic (Declaration)
Public Class PrintSetup
Visual C++
public ref class PrintSetup

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | CurrentPrintSetting | Get or Set the current Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PaperSizes | Get all Print sizes of current Print.
Public property | PaperSources | Get all Print sources of current Print.

See Also

PrintSetup
Autodesk.Revit Namespace


CurrentPrintSetting Property

PrintSetup..::CurrentPrintSetting Property
CollapseAll image DropDown image

Get or Set the current Print Setting of Print Setup.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintSetting CurrentPrintSetting{ get; set;}
Visual Basic (Declaration)
Public Property CurrentPrintSetting As PrintSetting
Visual C++
public:
property PrintSetting^ CurrentPrintSetting {
    PrintSetting^ get ();
    void set (PrintSetting^ value);
}

Remarks

The Current Print Setting, user can only edit/Save/SaveAs/Revit/Delete this Print Setting.

See Also

PrintSetup Class
Autodesk.Revit Namespace


PaperSizes Property

PrintSetup..::PaperSizes Property
CollapseAll image DropDown image

Get all Print sizes of current Print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSizeSet PaperSizes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PaperSizes As PaperSizeSet
Visual C++
public:
property PaperSizeSet^ PaperSizes {
    PaperSizeSet^ get ();
}

Remarks

User can select the paper size from here to set the papersize of print.

See Also

PrintSetup Class
Autodesk.Revit Namespace


PaperSources Property

PrintSetup..::PaperSources Property
CollapseAll image DropDown image

Get all Print sources of current Print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PaperSourceSet PaperSources{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PaperSources As PaperSourceSet
Visual C++
public:
property PaperSourceSet^ PaperSources {
    PaperSourceSet^ get ();
}

Remarks

User can select the paper source from here to set the papersource of print.

See Also

PrintSetup Class
Autodesk.Revit Namespace


Selection Class
See Also Members
CollapseAll image DropDown image

Contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("50E07DF9-F172-4bd6-9983-C0711EB36A31")]
public class Selection : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("50E07DF9-F172-4bd6-9983-C0711EB36A31")> _
Public Class Selection _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"50E07DF9-F172-4bd6-9983-C0711EB36A31")]
public ref class Selection : public APIObject

Remarks

The Selection object is used to retrieve the current user selected elements when an external API command is executed.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Selection

See Also

Selection Members
Autodesk.Revit Namespace


Selection Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Selection
Visual Basic (Declaration)
Public Class Selection
Visual C++
public ref class Selection

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SelectionSelectionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickOne | Allows the user to select one element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WindowSelect | Allows the user to select elements by a rectangle.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Elements | The elements that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | StatusbarTip | The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection
Autodesk.Revit Namespace


Selection Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Selection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Selection ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Selection Class
Autodesk.Revit Namespace


Selection Methods
CollapseAll image DropDown image

Syntax

C#
public class Selection
Visual Basic (Declaration)
Public Class Selection
Visual C++
public ref class Selection

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickOne | Allows the user to select one element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WindowSelect | Allows the user to select elements by a rectangle.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Selection
Autodesk.Revit Namespace


PickOne Method

Selection..::PickOne Method
CollapseAll image DropDown image

Allows the user to select one element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool PickOne()
Visual Basic (Declaration)
Public Function PickOne As Boolean
Visual C++
public:
bool PickOne ()

Return Value

True if the user selected an element, false if the user selected elsewhere in the UI

Remarks

One more element will be added to the active set of selected elements if user selects an element that is not in the active set of selected elements.

See Also

Selection Class
Autodesk.Revit Namespace


WindowSelect Method

Selection..::WindowSelect Method
CollapseAll image DropDown image

Allows the user to select elements by a rectangle.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool WindowSelect()
Visual Basic (Declaration)
Public Function WindowSelect As Boolean
Visual C++
public:
bool WindowSelect ()

Return Value

True if the user selected one or more elements, false if the user selected elsewhere in the UI

Remarks

Newly selected elements will be added to the active set of selected elements.

See Also

Selection Class
Autodesk.Revit Namespace


Selection Properties
CollapseAll image DropDown image

Syntax

C#
public class Selection
Visual Basic (Declaration)
Public Class Selection
Visual C++
public ref class Selection

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Elements | The elements that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | StatusbarTip | The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection
Autodesk.Revit Namespace


Elements Property

Selection..::Elements Property
CollapseAll image DropDown image

The elements that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SelElementSet Elements{ get; set;}
Visual Basic (Declaration)
Public Property Elements As SelElementSet
Visual C++
public:
property SelElementSet^ Elements {
    SelElementSet^ get ();
    void set (SelElementSet^ value);
}

Field Value

The set of elements that are actively selected.

Remarks

This set will contain the results after the user makes selections due to a PickOne or WindowSelect call.

See Also

Selection Class
Autodesk.Revit Namespace


StatusbarTip Property

Selection..::StatusbarTip Property
CollapseAll image DropDown image

The message displayed in the status bar tip when prompting the user to make a selection.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string StatusbarTip{ get; set;}
Visual Basic (Declaration)
Public Property StatusbarTip As String
Visual C++
public:
property String^ StatusbarTip {
    String^ get ();
    void set (String^ value);
}

Field Value

The message is displayed in the status bar at the bottom of the Autodesk Revit UI.

See Also

Selection Class
Autodesk.Revit Namespace


SelElementSet Class
See Also Members
CollapseAll image DropDown image

This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F38EF9B4-1324-4700-9BBE-B570933596D9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SelElementSet : ElementSet
Visual Basic (Declaration)
<GuidAttribute("F38EF9B4-1324-4700-9BBE-B570933596D9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SelElementSet _
    Inherits ElementSet
Visual C++
[GuidAttribute(L"F38EF9B4-1324-4700-9BBE-B570933596D9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SelElementSet : public ElementSet

Remarks

Because the ModScope is transfered into the constructor, the SelElementSet can be used to Add or Remove element from the selected element set directly.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementSet
Autodesk.Revit..::SelElementSet

See Also

SelElementSet Members
Autodesk.Revit Namespace


SelElementSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SelElementSet
Visual Basic (Declaration)
Public Class SelElementSet
Visual C++
public ref class SelElementSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SelElementSetSelElementSetNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Add | Add an element into the selected element set.
Public method | Clear | Clear the selected element set. (Overrides ElementSet ..:: Clear()().)
Public method | Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Remove an element from the selected element set. (Overrides ElementSet ..:: Erase(Element).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Public method | Remove | Remove an element from the selected element set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides ElementSet ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from ElementSet.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from ElementSet.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set. (Inherited from ElementSet.)

See Also

SelElementSet
Autodesk.Revit Namespace


SelElementSet Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SelElementSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelElementSet ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SelElementSet Class
Autodesk.Revit Namespace


SelElementSet Methods
CollapseAll image DropDown image

Syntax

C#
public class SelElementSet
Visual Basic (Declaration)
Public Class SelElementSet
Visual C++
public ref class SelElementSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Add | Add an element into the selected element set.
Public method | Clear | Clear the selected element set. (Overrides ElementSet ..:: Clear()().)
Public method | Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Remove an element from the selected element set. (Overrides ElementSet ..:: Erase(Element).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Public method | Remove | Remove an element from the selected element set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides ElementSet ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from ElementSet.)

See Also

SelElementSet
Autodesk.Revit Namespace


Add Method

SelElementSet..::Add Method
CollapseAll image DropDown image

Add an element into the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Add(
    Element element
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    element As Element _
)
Visual C++
public:
virtual void Add (
    Element^ element
)

Parameters

element
Element
The element to be added.

Remarks

This function will add the specified element to the selected element set, just like the element is picked from the UI.

See Also

SelElementSet Class
Autodesk.Revit Namespace


Clear Method

SelElementSet..::Clear Method
CollapseAll image DropDown image

Clear the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear () override

Remarks

All the elements in the selected element set will be removed and no element will be highlighted after the operation.

See Also

SelElementSet Class
Autodesk.Revit Namespace


Dispose Method

SelElementSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SelElementSet Class
Autodesk.Revit Namespace


Erase Method

SelElementSet..::Erase Method
CollapseAll image DropDown image

Remove an element from the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override int Erase(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function Erase ( _
    element As Element _
) As Integer
Visual C++
public:
virtual int Erase (
    Element^ element
) override

Parameters

element
Element
The element to be removed.

Return Value

Returns count of the elements to be erased from the selected element set.

Remarks

This function will do same task as Remove.

See Also

SelElementSet Class
Autodesk.Revit Namespace


Remove Method

SelElementSet..::Remove Method
CollapseAll image DropDown image

Remove an element from the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Remove(
    Element element
)
Visual Basic (Declaration)
Public Overridable Sub Remove ( _
    element As Element _
)
Visual C++
public:
virtual void Remove (
    Element^ element
)

Parameters

element
Element
The element to be removed.

Remarks

This function will remove the specified from the selected element set, just like de-select it from the UI.

See Also

SelElementSet Class
Autodesk.Revit Namespace


Settings Class
See Also Members
CollapseAll image DropDown image

The settings object provides access to general components of the Autodesk Revit application, such as Categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("20F6047C-6690-49ff-B27F-D5371EDC180A")]
public class Settings : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("20F6047C-6690-49ff-B27F-D5371EDC180A")> _
Public Class Settings _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"20F6047C-6690-49ff-B27F-D5371EDC180A")]
public ref class Settings : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Settings

See Also

Settings Members
Autodesk.Revit Namespace


Settings Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Settings
Visual Basic (Declaration)
Public Class Settings
Visual C++
public ref class Settings

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SettingsSettingsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Public property | Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
Public property | VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings
Autodesk.Revit Namespace


Settings Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Settings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Settings ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Settings Class
Autodesk.Revit Namespace


Settings Properties
CollapseAll image DropDown image

Syntax

C#
public class Settings
Visual Basic (Declaration)
Public Class Settings
Visual C++
public ref class Settings

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Public property | Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
Public property | VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings
Autodesk.Revit Namespace


Categories Property

Settings..::Categories Property
CollapseAll image DropDown image

Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Categories Categories{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Categories As Categories
Visual C++
public:
property Categories^ Categories {
    Categories^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


ElectricalSetting Property

Settings..::ElectricalSetting Property
CollapseAll image DropDown image

Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSetting ElectricalSetting{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSetting As ElectricalSetting
Visual C++
public:
property ElectricalSetting^ ElectricalSetting {
    ElectricalSetting^ get ();
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available.

See Also

Settings Class
Autodesk.Revit Namespace


FillPatterns Property

Settings..::FillPatterns Property
CollapseAll image DropDown image

Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPatternSet FillPatterns{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FillPatterns As FillPatternSet
Visual C++
public:
property FillPatternSet^ FillPatterns {
    FillPatternSet^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


LinePatterns Property

Settings..::LinePatterns Property
CollapseAll image DropDown image

Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinePatternSet LinePatterns{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LinePatterns As LinePatternSet
Visual C++
public:
property LinePatternSet^ LinePatterns {
    LinePatternSet^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


Materials Property

Settings..::Materials Property
CollapseAll image DropDown image

Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Materials Materials{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Materials As Materials
Visual C++
public:
property Materials^ Materials {
    Materials^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


VolumeCalculationSetting Property

Settings..::VolumeCalculationSetting Property
CollapseAll image DropDown image

Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VolumeCalculationSetting VolumeCalculationSetting{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VolumeCalculationSetting As VolumeCalculationSetting
Visual C++
public:
property VolumeCalculationSetting^ VolumeCalculationSetting {
    VolumeCalculationSetting^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


StructuralTypeFilter Class
See Also Members
CollapseAll image DropDown image

A Filter object that represents StructuralType, used to retrieve family instances whose structural type is specified structural type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0AC36005-04E8-4560-9659-49A26B5BE24F")]
public class StructuralTypeFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0AC36005-04E8-4560-9659-49A26B5BE24F")> _
Public Class StructuralTypeFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0AC36005-04E8-4560-9659-49A26B5BE24F")]
public ref class StructuralTypeFilter : public Filter

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::StructuralTypeFilter

See Also

StructuralTypeFilter Members
Autodesk.Revit Namespace


StructuralTypeFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class StructuralTypeFilter
Visual Basic (Declaration)
Public Class StructuralTypeFilter
Visual C++
public ref class StructuralTypeFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | StructuralTypeFilterStructuralTypeFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

StructuralTypeFilter
Autodesk.Revit Namespace


StructuralTypeFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StructuralTypeFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StructuralTypeFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

StructuralTypeFilter Class
Autodesk.Revit Namespace


StructuralTypeFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class StructuralTypeFilter
Visual Basic (Declaration)
Public Class StructuralTypeFilter
Visual C++
public ref class StructuralTypeFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

StructuralTypeFilter
Autodesk.Revit Namespace


Dispose Method

StructuralTypeFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

StructuralTypeFilter Class
Autodesk.Revit Namespace


SuspendUpdating Class
See Also Members
CollapseAll image DropDown image

Temporarily delay Revit's automatic updating and consistency operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public class SuspendUpdating : APIObject
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Class SuspendUpdating _
    Inherits APIObject
Visual C++
[ComVisibleAttribute(false)]
public ref class SuspendUpdating : public APIObject

Remarks

Creating an intance of this object will cause Autodesk Revit to suspend certain updating and consistency operation thereby enabling increased performance of large scale changes via the API. When the object is disposed updating will take place if required. The object should be disposed explicitly using the Dispose method to ensure known points of consistency within your application. Note that while this object is active the Revit model data may be inconsistent hence values retrieve from object cannot necessarily be trusted. The object may be nested and the Nested property will return if such an object is already nested. During nesting the final updating will only happen when all SuspendUpdating objects are disposed. Currently suspend updating functionality works primarily with object transformation operations such as move and rotate. Note: This functionality is not available through the Revit COM API. Following methods(properties) support SuspendUpdating: Autodesk.Revit.Document.Move, Autodesk.Revit.Document.Rotate, Autodesk.Revit.Document.Mirror, Autodesk.Revit.Location.Move, Autodesk.Revit.Location.Rotate, Autodesk.Revit.Creation.Document.NewAnnotationSymbol, Autodesk.Revit.Elements.FamilyInstance.flipHand, Autodesk.Revit.Elements.FamilyInstance.flipFacing, Autodesk.Revit.Elements.FamilyInstance.rotate, Autodesk.Revit.Elements.FamilyInstance.FlipFromToRoom, Autodesk.Revit.Elements.CurtainGridLine.Move, property Autodesk.Revit.LocationPoint.Point.set, property Autodesk.Revit.Elements.FamilyInstance.Symbol.set, property Autodesk.Revit.Elements.FamilyInstance.StructuralUsage.set, property Autodesk.Revit.Elements.Wall.WallType.set, property Autodesk.Revit.Elements.TextNote.Coord.set, property Autodesk.Revit.Elements.TextNote.Width.set, property Autodesk.Revit.Elements.IndependentTag.TagHeadPosition.set, property Autodesk.Revit.Elements.IndependentTag.LeaderElbow.set, property Autodesk.Revit.Elements.IndependentTag.LeaderEnd.set, property Autodesk.Revit.Leader.End.set, property Autodesk.Revit.Leader.Elbow.set

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::SuspendUpdating

See Also

SuspendUpdating Members
Autodesk.Revit Namespace


SuspendUpdating Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SuspendUpdating
Visual Basic (Declaration)
Public Class SuspendUpdating
Visual C++
public ref class SuspendUpdating

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SuspendUpdatingSuspendUpdatingNew | Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Overrides APIObject ..:: ReleaseManagedResources()().)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Nested | A property that reports if updating has already been suspended before

See Also

SuspendUpdating
Autodesk.Revit Namespace


SuspendUpdating Constructor
CollapseAll image DropDown image

Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SuspendUpdating (
    Document^ document
)

Parameters

document
Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating object has been disposed Revit will make the document consistent again.

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


SuspendUpdating Methods
CollapseAll image DropDown image

Syntax

C#
public class SuspendUpdating
Visual Basic (Declaration)
Public Class SuspendUpdating
Visual C++
public ref class SuspendUpdating

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Overrides APIObject ..:: ReleaseManagedResources()().)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SuspendUpdating
Autodesk.Revit Namespace


ReleaseManagedResources Method

SuspendUpdating..::ReleaseManagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseManagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseManagedResources
Visual C++
protected:
virtual void ReleaseManagedResources () override

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

SuspendUpdating..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


SuspendUpdating Properties
CollapseAll image DropDown image

Syntax

C#
public class SuspendUpdating
Visual Basic (Declaration)
Public Class SuspendUpdating
Visual C++
public ref class SuspendUpdating

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Nested | A property that reports if updating has already been suspended before

See Also

SuspendUpdating
Autodesk.Revit Namespace


Nested Property

SuspendUpdating..::Nested Property
CollapseAll image DropDown image

A property that reports if updating has already been suspended before

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Nested{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Nested As Boolean
Visual C++
public:
property bool Nested {
    bool get ();
}

Remarks

This property can be used to detect that the SuspendUpdating object has been created during the lifetime of another SuspendUpdating object and hence the document will not be made consistent which this object is disposed.

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


Symbol Class
See Also Members
CollapseAll image DropDown image

Base class for all Symbols and Types within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FEE5FE57-9B1E-4fa7-B616-D610DEE18434")]
public class Symbol : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FEE5FE57-9B1E-4fa7-B616-D610DEE18434")> _
Public Class Symbol _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FEE5FE57-9B1E-4fa7-B616-D610DEE18434")]
public ref class Symbol : public Element

Remarks

Symbols are usually non user visible elements that define instances. For example a wall type is a symbol that is not visible until an instance of the wall is created.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::LoadTypeBase
Autodesk.Revit.Symbols..::GroupType
Autodesk.Revit.Symbols..::RebarBarType
Autodesk.Revit.Symbols..::RebarHookType
Autodesk.Revit.Symbols..::RebarShape
Autodesk.Revit.Symbols..::RebarCoverType
Autodesk.Revit.Symbols..::AreaReinforcementType
Autodesk.Revit.Symbols..::DimensionType
Autodesk.Revit.Symbols..::LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::PathReinforcementType
Autodesk.Revit.Symbols..::BeamSystemType
Autodesk.Revit.Symbols..::LevelType
Autodesk.Revit.Symbols..::RoomTagType
Autodesk.Revit.Symbols..::AreaTagType
Autodesk.Revit.Symbols..::VoltageType
Autodesk.Revit.Symbols..::DistributionSysType
Autodesk.Revit.Symbols..::WireType
Autodesk.Revit.Symbols..::DemandFactor
Autodesk.Revit.Symbols..::TrussType
Autodesk.Revit.Symbols..::SpaceTagType
Autodesk.Revit.Symbols..::MEPBuildingConstruction
Autodesk.Revit.Site..::SiteLocation

See Also

Symbol Members
Autodesk.Revit Namespace


Symbol Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Symbol
Visual Basic (Declaration)
Public Class Symbol
Visual C++
public ref class Symbol

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SymbolSymbolNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Symbol
Autodesk.Revit Namespace


Symbol Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Symbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Symbol ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Symbol Class
Autodesk.Revit Namespace


Symbol Methods
CollapseAll image DropDown image

Syntax

C#
public class Symbol
Visual Basic (Declaration)
Public Class Symbol
Visual C++
public ref class Symbol

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Symbol
Autodesk.Revit Namespace


Duplicate Method

Symbol..::Duplicate Method
CollapseAll image DropDown image

Duplicate this object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Symbol Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As Symbol
Visual C++
public:
Symbol^ Duplicate (
    String^ name
)

Parameters

name
String
The new name that will be assigned to the duplicated object.

Return Value

If successful the duplicated object is returned, otherwise Nothing.

Remarks

This method attempts to duplicate the object and assign it the specified name. In some cases the name must be unique, i.e. not already exist in the project. If the name is required to be unique and the name is not a System.ArgumentException will be thrown. If for some reason the object cannot be duplicated a System.NullReferenceException will be thrown.

See Also

Symbol Class
Autodesk.Revit Namespace


Symbol Properties
CollapseAll image DropDown image

Syntax

C#
public class Symbol
Visual Basic (Declaration)
Public Class Symbol
Visual C++
public ref class Symbol

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Symbol
Autodesk.Revit Namespace


Name Property

Symbol..::Name Property
CollapseAll image DropDown image

set name for a symbol

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

this method will assign the symbol a new name, and then notify object brower to fresh name

See Also

Symbol Class
Autodesk.Revit Namespace


Parameter Property

Symbol..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Symbol Class
Symbol Members
Autodesk.Revit Namespace


SymbolFilter Class
See Also Members
CollapseAll image DropDown image

A filter object that used to filter symbol elements which satisfy specified criterion, filter elements by specifying symbol name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A9361346-3867-484f-9EF3-FB8FB7E41EE2")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SymbolFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("A9361346-3867-484f-9EF3-FB8FB7E41EE2")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SymbolFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"A9361346-3867-484f-9EF3-FB8FB7E41EE2")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SymbolFilter : public Filter

Remarks

The filtered elements include: Symbol type elements, FamilyInstance type elements and other types instances(such as Door, Wall, etc) whose symbol is specified symbol. These elements should belong to main model, active design option or primary design option.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::SymbolFilter

See Also

SymbolFilter Members
Autodesk.Revit Namespace


SymbolFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SymbolFilter
Visual Basic (Declaration)
Public Class SymbolFilter
Visual C++
public ref class SymbolFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SymbolFilterSymbolFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolFilter
Autodesk.Revit Namespace


SymbolFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SymbolFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SymbolFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SymbolFilter Class
Autodesk.Revit Namespace


SymbolFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class SymbolFilter
Visual Basic (Declaration)
Public Class SymbolFilter
Visual C++
public ref class SymbolFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

SymbolFilter
Autodesk.Revit Namespace


Dispose Method

SymbolFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SymbolFilter Class
Autodesk.Revit Namespace


Toolbar Class
See Also Members
CollapseAll image DropDown image

The Toolbar object represents a tool bar, which should contains an array of ToolbarItems.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("045FCF04-CBB7-4192-AAF0-D0BE3ACEFC12")]
public class Toolbar : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("045FCF04-CBB7-4192-AAF0-D0BE3ACEFC12")> _
Public Class Toolbar _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"045FCF04-CBB7-4192-AAF0-D0BE3ACEFC12")]
public ref class Toolbar : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Toolbar

See Also

Toolbar Members
Autodesk.Revit Namespace


Toolbar Members
See Also Methods Properties
CollapseAll image DropDown image

Syntax

C#
public class Toolbar
Visual Basic (Declaration)
Public Class Toolbar
Visual C++
public ref class Toolbar

The type exposes the following members.

Public Methods

 | Name | Description
Public method | AddItem | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the toolbar can respond to user interaction.
Public property | Image | Gets or sets the collection of images available to the toolbar button controls.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Gets or sets the name of the toolbar.
Public property | ToolbarItems | Gets the collection of ToolBarItem controls assigned to the toolbar control.
Public property | Visible | Gets or sets a value indicating whether the toolbar is displayed.

See Also

Toolbar
Autodesk.Revit Namespace


Toolbar Methods
CollapseAll image DropDown image

Syntax

C#
public class Toolbar
Visual Basic (Declaration)
Public Class Toolbar
Visual C++
public ref class Toolbar

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddItem | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Toolbar
Autodesk.Revit Namespace


AddItem Method

Toolbar..::AddItem Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | AddItem(MenuItem) | Add a new ToolbarItem to the Toolbar.
Public method | AddItem(String, String) | Add a new ToolbarItem to the Toolbar.

See Also

Toolbar Class
Toolbar Members
Autodesk.Revit Namespace


AddItem Method (MenuItem)

Toolbar..::AddItem Method (MenuItem)
See Also
CollapseAll image DropDown image

Add a new ToolbarItem to the Toolbar.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItem AddItem(
    MenuItem pMenuItem
)
Visual Basic (Declaration)
Public Function AddItem ( _
    pMenuItem As MenuItem _
) As ToolbarItem
Visual C++
public:
ToolbarItem^ AddItem (
    MenuItem^ pMenuItem
)

Parameters

pMenuItem
MenuItem
The corresponding MenuItem, can be null. If pMenuItem is not null, the new Item will have the same execution command with the menu. If pMenuItem is null, it will create a separator bar.

Remarks

This method will add a new API ToolBarItem to the Toolbar.

Exceptions

Exception | Condition
System..::ArgumentException | if 'pMenuItem' is a pop up menu.

See Also

Toolbar Class
Autodesk.Revit Namespace


AddItem Method (String, String)

Toolbar..::AddItem Method (String, String)
See Also
CollapseAll image DropDown image

Add a new ToolbarItem to the Toolbar.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItem AddItem(
    string pAssemblyName,
    string pClassName
)
Visual Basic (Declaration)
Public Function AddItem ( _
    pAssemblyName As String, _
    pClassName As String _
) As ToolbarItem
Visual C++
public:
ToolbarItem^ AddItem (
    String^ pAssemblyName,
    String^ pClassName
)

Parameters

pAssemblyName
String
The execution command corresponding Assembly name.
pClassName
String
The execution command corresponding Class name.

Remarks

This method will add a new API ToolBarItem to the Toolbar.

Exceptions

Exception | Condition
System..::ArgumentException | If 'pAssemblyName' or 'pClassName' is a null object or an empty string.

See Also

Toolbar Class
Autodesk.Revit Namespace


Toolbar Properties
CollapseAll image DropDown image

Syntax

C#
public class Toolbar
Visual Basic (Declaration)
Public Class Toolbar
Visual C++
public ref class Toolbar

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the toolbar can respond to user interaction.
Public property | Image | Gets or sets the collection of images available to the toolbar button controls.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Gets or sets the name of the toolbar.
Public property | ToolbarItems | Gets the collection of ToolBarItem controls assigned to the toolbar control.
Public property | Visible | Gets or sets a value indicating whether the toolbar is displayed.

See Also

Toolbar
Autodesk.Revit Namespace


Enabled Property

Toolbar..::Enabled Property
CollapseAll image DropDown image

Gets or sets a value indicating whether the toolbar can respond to user interaction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Enabled{ get; set;}
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

With the Enabled property, you can enable or disable controls at run time.

See Also

Toolbar Class
Autodesk.Revit Namespace


Image Property

Toolbar..::Image Property
CollapseAll image DropDown image

Gets or sets the collection of images available to the toolbar button controls.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Image{ get; set;}
Visual Basic (Declaration)
Public Property Image As String
Visual C++
public:
property String^ Image {
    String^ get ();
    void set (String^ value);
}

Remarks

If you assign an imagelist to the Image property, you can assign an image from the collection to the ToolBarItem controls by assigning the image's index value to the ImageIndex property of the toolbar button.

See Also

Toolbar Class
Autodesk.Revit Namespace


Name Property

Toolbar..::Name Property
CollapseAll image DropDown image

Gets or sets the name of the toolbar.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get; set;}
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The name is displayed on the context menu of hide/show toolbars.

See Also

Toolbar Class
Autodesk.Revit Namespace


ToolbarItems Property

Toolbar..::ToolbarItems Property
CollapseAll image DropDown image

Gets the collection of ToolBarItem controls assigned to the toolbar control.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItemArray ToolbarItems{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ToolbarItems As ToolbarItemArray
Visual C++
public:
property ToolbarItemArray^ ToolbarItems {
    ToolbarItemArray^ get ();
}

Remarks

The ToolbarItems property is a zero-based indexed collection used to hold all the ToolBarItem controls assigned to the toolbar. Because the property is read-only, it can not be assigned a collection of toolbar items directly. Toolbar items can be added by using the methods AddItem. Use the Add method to add individual button.

See Also

Toolbar Class
Autodesk.Revit Namespace


Visible Property

Toolbar..::Visible Property
CollapseAll image DropDown image

Gets or sets a value indicating whether the toolbar is displayed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Visible{ get; set;}
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Remarks

true if the toolbar is displayed; otherwise, false. The default is true.

See Also

Toolbar Class
Autodesk.Revit Namespace


ToolbarArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any number of toolbars.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("04CCF2E3-5394-4818-9097-5B4AD57E438F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ToolbarArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("04CCF2E3-5394-4818-9097-5B4AD57E438F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ToolbarArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"04CCF2E3-5394-4818-9097-5B4AD57E438F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ToolbarArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ToolbarArray

See Also

ToolbarArray Members
Autodesk.Revit Namespace


ToolbarArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ToolbarArray
Visual Basic (Declaration)
Public Class ToolbarArray
Visual C++
public ref class ToolbarArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ToolbarArrayToolbarArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ToolbarArray
Autodesk.Revit Namespace


ToolbarArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolbarArray ()

See Also

ToolbarArray Class
Autodesk.Revit Namespace


ToolbarArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ToolbarArray
Visual Basic (Declaration)
Public Class ToolbarArray
Visual C++
public ref class ToolbarArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ToolbarArray
Autodesk.Revit Namespace


Append Method

ToolbarArray..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Toolbar item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Toolbar _
)
Visual C++
public:
virtual void Append (
    Toolbar^ item
)

Parameters

item
Toolbar
The item to be added.

See Also

ToolbarArray Class
Autodesk.Revit Namespace


Clear Method

ToolbarArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ToolbarArray Class
Autodesk.Revit Namespace


Dispose Method

ToolbarArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ToolbarArray Class
Autodesk.Revit Namespace


ForwardIterator Method

ToolbarArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ToolbarArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ToolbarArrayIterator
Visual C++
public:
virtual ToolbarArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ToolbarArray Class
Autodesk.Revit Namespace


GetEnumerator Method

ToolbarArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ToolbarArray Class
Autodesk.Revit Namespace


Insert Method

ToolbarArray..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Toolbar item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Toolbar, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Toolbar^ item,
    int index
)

Parameters

item
Toolbar
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

ToolbarArray Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ToolbarArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ToolbarArray Class
Autodesk.Revit Namespace


ReverseIterator Method

ToolbarArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ToolbarArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ToolbarArrayIterator
Visual C++
public:
virtual ToolbarArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ToolbarArray Class
Autodesk.Revit Namespace


ToolbarArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ToolbarArray
Visual Basic (Declaration)
Public Class ToolbarArray
Visual C++
public ref class ToolbarArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ToolbarArray
Autodesk.Revit Namespace


IsEmpty Property

ToolbarArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ToolbarArray Class
Autodesk.Revit Namespace


Item Property

ToolbarArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Toolbar Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Toolbar
Visual C++
public:
virtual property Toolbar^ Item[int index] {
    Toolbar^ get (int index);
    void set (int index, Toolbar^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ToolbarArray Class
Autodesk.Revit Namespace


Size Property

ToolbarArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ToolbarArray Class
Autodesk.Revit Namespace


ToolbarArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of toolbars.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B6C32EC7-7F0A-4872-A9FD-502C927D6238")]
public abstract class ToolbarArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B6C32EC7-7F0A-4872-A9FD-502C927D6238")> _
Public MustInherit Class ToolbarArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B6C32EC7-7F0A-4872-A9FD-502C927D6238")]
public ref class ToolbarArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ToolbarArrayIterator

See Also

ToolbarArrayIterator Members
Autodesk.Revit Namespace


ToolbarArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ToolbarArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ToolbarArrayIterator
Visual C++
public ref class ToolbarArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ToolbarArrayIteratorToolbarArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ToolbarArrayIterator
Autodesk.Revit Namespace


ToolbarArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolbarArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ToolbarArrayIterator Class
Autodesk.Revit Namespace


ToolbarArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ToolbarArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ToolbarArrayIterator
Visual C++
public ref class ToolbarArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ToolbarArrayIterator
Autodesk.Revit Namespace


Dispose Method

ToolbarArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ToolbarArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

ToolbarArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ToolbarArrayIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ToolbarArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ToolbarArrayIterator Class
Autodesk.Revit Namespace


Reset Method

ToolbarArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ToolbarArrayIterator Class
Autodesk.Revit Namespace


ToolbarArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ToolbarArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ToolbarArrayIterator
Visual C++
public ref class ToolbarArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ToolbarArrayIterator
Autodesk.Revit Namespace


Current Property

ToolbarArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ToolbarArrayIterator Class
Autodesk.Revit Namespace


ToolbarItem Class
See Also Members
CollapseAll image DropDown image

The ToolbarItem object represents a tool bar item, which should contain the information for creating one tool bar item.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2DA1562F-FC8A-4554-AB28-A9BF344C3325")]
public class ToolbarItem : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2DA1562F-FC8A-4554-AB28-A9BF344C3325")> _
Public Class ToolbarItem _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2DA1562F-FC8A-4554-AB28-A9BF344C3325")]
public ref class ToolbarItem : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ToolbarItem

See Also

ToolbarItem Members
Autodesk.Revit Namespace


ToolbarItem Members
See Also Methods Properties
CollapseAll image DropDown image

Syntax

C#
public class ToolbarItem
Visual Basic (Declaration)
Public Class ToolbarItem
Visual C++
public ref class ToolbarItem

The type exposes the following members.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | AssemblyName | Gets or sets the assembly path.
Public property | Checked | Gets or sets a value indicating whether a toggle-style toolbar button is currently in the checked state.
Public property | ClassName | Gets or sets the class name.
Public property | Enabled | Gets or sets a value indicating whether the button is enabled.
Public property | ImageIndex | Gets or sets the index value of the image assigned to the button.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | ItemText | Gets or sets the text displayed on the toolbar button.
Public property | ItemType | Gets or sets the item type.
Public property | StatusbarTip | Gets or sets the text that appears on the Status bar for the button.
Public property | ToolTip | Gets or sets the text that appears as a ToolTip for the button.

See Also

ToolbarItem
Autodesk.Revit Namespace


ToolbarItem Properties
CollapseAll image DropDown image

Syntax

C#
public class ToolbarItem
Visual Basic (Declaration)
Public Class ToolbarItem
Visual C++
public ref class ToolbarItem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AssemblyName | Gets or sets the assembly path.
Public property | Checked | Gets or sets a value indicating whether a toggle-style toolbar button is currently in the checked state.
Public property | ClassName | Gets or sets the class name.
Public property | Enabled | Gets or sets a value indicating whether the button is enabled.
Public property | ImageIndex | Gets or sets the index value of the image assigned to the button.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | ItemText | Gets or sets the text displayed on the toolbar button.
Public property | ItemType | Gets or sets the item type.
Public property | StatusbarTip | Gets or sets the text that appears on the Status bar for the button.
Public property | ToolTip | Gets or sets the text that appears as a ToolTip for the button.

See Also

ToolbarItem
Autodesk.Revit Namespace


AssemblyName Property

ToolbarItem..::AssemblyName Property
CollapseAll image DropDown image

Gets or sets the assembly path.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string AssemblyName{ get; set;}
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

See Also

ToolbarItem Class
Autodesk.Revit Namespace


Checked Property

ToolbarItem..::Checked Property
CollapseAll image DropDown image

Gets or sets a value indicating whether a toggle-style toolbar button is currently in the checked state.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Checked{ get; set;}
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

Remarks

When Checked is set to true, the toolbar button appears sunken.

See Also

ToolbarItem Class
Autodesk.Revit Namespace


ClassName Property

ToolbarItem..::ClassName Property
CollapseAll image DropDown image

Gets or sets the class name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string ClassName{ get; set;}
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

See Also

ToolbarItem Class
Autodesk.Revit Namespace


Enabled Property

ToolbarItem..::Enabled Property
CollapseAll image DropDown image

Gets or sets a value indicating whether the button is enabled.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Enabled{ get; set;}
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

When the Enabled property is set to false, the toolbar item cannot be clicked, and the item's appearance changes. The Image and Text assigned to the button appear grayed out.

See Also

ToolbarItem Class
Autodesk.Revit Namespace


ImageIndex Property

ToolbarItem..::ImageIndex Property
CollapseAll image DropDown image

Gets or sets the index value of the image assigned to the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public uint ImageIndex{ get; set;}
Visual Basic (Declaration)
Public Property ImageIndex As UInteger
Visual C++
public:
property unsigned int ImageIndex {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The ImageIndex value references the indexed value of the images in an ImageList assigned to the parent ToolBar control.

See Also

ToolbarItem Class
Autodesk.Revit Namespace


ItemText Property

ToolbarItem..::ItemText Property
CollapseAll image DropDown image

Gets or sets the text displayed on the toolbar button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string ItemText{ get; set;}
Visual Basic (Declaration)
Public Property ItemText As String
Visual C++
public:
property String^ ItemText {
    String^ get ();
    void set (String^ value);
}

Remarks

The text will be displayed if this control type is BtnRText.

See Also

ToolbarItem Class
Autodesk.Revit Namespace


ItemType Property

ToolbarItem..::ItemType Property
CollapseAll image DropDown image

Gets or sets the item type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItem.ToolbarItem..::ToolbarItemType ItemType{ get; set;}
Visual Basic (Declaration)
Public Property ItemType As ToolbarItem..::ToolbarItemType
Visual C++
public:
property ToolbarItem..::ToolbarItemType ItemType {
    ToolbarItem..::ToolbarItemType get ();
    void set (ToolbarItem..::ToolbarItemType value);
}

Remarks

If the item is set to BtnRText, the ItemText will be displayed on the right side of the button. If it's set to BtnSeparator, it'll appear as a button separate. If it's set to BtnStd, it acts as a standard button.

See Also

ToolbarItem Class
Autodesk.Revit Namespace


StatusbarTip Property

ToolbarItem..::StatusbarTip Property
CollapseAll image DropDown image

Gets or sets the text that appears on the Status bar for the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string StatusbarTip{ get; set;}
Visual Basic (Declaration)
Public Property StatusbarTip As String
Visual C++
public:
property String^ StatusbarTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the mouse pointer moves over the toolbar button. The default is an empty string ("").

See Also

ToolbarItem Class
Autodesk.Revit Namespace


ToolTip Property

ToolbarItem..::ToolTip Property
CollapseAll image DropDown image

Gets or sets the text that appears as a ToolTip for the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string ToolTip{ get; set;}
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the mouse pointer moves over the toolbar button. The default is an empty string ("").

See Also

ToolbarItem Class
Autodesk.Revit Namespace


ToolbarItem..::ToolbarItemType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the toolbar item styles.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D8A6BFF5-9519-4733-89D5-9FD215EFE571")]
public enum ToolbarItemType
Visual Basic (Declaration)
<GuidAttribute("D8A6BFF5-9519-4733-89D5-9FD215EFE571")> _
Public Enumeration ToolbarItemType
Visual C++
[GuidAttribute(L"D8A6BFF5-9519-4733-89D5-9FD215EFE571")]
public enum class ToolbarItemType

Members

Member name | Description
BtnRText | A button with text on its right side.
BtnStd | A standard, three-dimensional button.
BtnSeparator | A line between toolbar buttons.

See Also

Autodesk.Revit Namespace


ToolbarItemArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any number of toolbar items.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1BE698FE-96DF-4050-959F-09D2AC0D6565")]
public class ToolbarItemArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1BE698FE-96DF-4050-959F-09D2AC0D6565")> _
Public Class ToolbarItemArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1BE698FE-96DF-4050-959F-09D2AC0D6565")]
public ref class ToolbarItemArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ToolbarItemArray

See Also

ToolbarItemArray Members
Autodesk.Revit Namespace


ToolbarItemArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ToolbarItemArray
Visual Basic (Declaration)
Public Class ToolbarItemArray
Visual C++
public ref class ToolbarItemArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ToolbarItemArrayToolbarItemArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ToolbarItemArray
Autodesk.Revit Namespace


ToolbarItemArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItemArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolbarItemArray ()

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


ToolbarItemArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ToolbarItemArray
Visual Basic (Declaration)
Public Class ToolbarItemArray
Visual C++
public ref class ToolbarItemArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ToolbarItemArray
Autodesk.Revit Namespace


Append Method

ToolbarItemArray..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    ToolbarItem item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ToolbarItem _
)
Visual C++
public:
virtual void Append (
    ToolbarItem^ item
)

Parameters

item
ToolbarItem
The item to be added.

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


Clear Method

ToolbarItemArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


Dispose Method

ToolbarItemArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


ForwardIterator Method

ToolbarItemArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ToolbarItemArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ToolbarItemArrayIterator
Visual C++
public:
virtual ToolbarItemArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


GetEnumerator Method

ToolbarItemArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


Insert Method

ToolbarItemArray..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    ToolbarItem item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ToolbarItem, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    ToolbarItem^ item,
    int index
)

Parameters

item
ToolbarItem
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ToolbarItemArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


ReverseIterator Method

ToolbarItemArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ToolbarItemArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ToolbarItemArrayIterator
Visual C++
public:
virtual ToolbarItemArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


ToolbarItemArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ToolbarItemArray
Visual Basic (Declaration)
Public Class ToolbarItemArray
Visual C++
public ref class ToolbarItemArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ToolbarItemArray
Autodesk.Revit Namespace


IsEmpty Property

ToolbarItemArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


Item Property

ToolbarItemArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ToolbarItem Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ToolbarItem
Visual C++
public:
virtual property ToolbarItem^ Item[int index] {
    ToolbarItem^ get (int index);
    void set (int index, ToolbarItem^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


Size Property

ToolbarItemArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ToolbarItemArray Class
Autodesk.Revit Namespace


ToolbarItemArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of toolbar items.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("BC8A5EAC-AFBD-4dfe-8C1F-DF37E28DF48B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ToolbarItemArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("BC8A5EAC-AFBD-4dfe-8C1F-DF37E28DF48B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ToolbarItemArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"BC8A5EAC-AFBD-4dfe-8C1F-DF37E28DF48B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ToolbarItemArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ToolbarItemArrayIterator

See Also

ToolbarItemArrayIterator Members
Autodesk.Revit Namespace


ToolbarItemArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ToolbarItemArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ToolbarItemArrayIterator
Visual C++
public ref class ToolbarItemArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ToolbarItemArrayIteratorToolbarItemArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ToolbarItemArrayIterator
Autodesk.Revit Namespace


ToolbarItemArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItemArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolbarItemArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ToolbarItemArrayIterator Class
Autodesk.Revit Namespace


ToolbarItemArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ToolbarItemArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ToolbarItemArrayIterator
Visual C++
public ref class ToolbarItemArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ToolbarItemArrayIterator
Autodesk.Revit Namespace


Dispose Method

ToolbarItemArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ToolbarItemArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

ToolbarItemArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ToolbarItemArrayIterator Class
Autodesk.Revit Namespace


ReleaseUnmanagedResources Method

ToolbarItemArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ToolbarItemArrayIterator Class
Autodesk.Revit Namespace


Reset Method

ToolbarItemArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ToolbarItemArrayIterator Class
Autodesk.Revit Namespace


ToolbarItemArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ToolbarItemArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ToolbarItemArrayIterator
Visual C++
public ref class ToolbarItemArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ToolbarItemArrayIterator
Autodesk.Revit Namespace


Current Property

ToolbarItemArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ToolbarItemArrayIterator Class
Autodesk.Revit Namespace


TrussMemberInfo Class
See Also Members
CollapseAll image DropDown image

Provides access to the information of a truss member in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5F53D824-0327-4a95-BF55-3817D4EF4983")]
public class TrussMemberInfo
Visual Basic (Declaration)
<GuidAttribute("5F53D824-0327-4a95-BF55-3817D4EF4983")> _
Public Class TrussMemberInfo
Visual C++
[GuidAttribute(L"5F53D824-0327-4a95-BF55-3817D4EF4983")]
public ref class TrussMemberInfo

Remarks

A struct TrussMemberInfo that contains an element's host truss,whether lock to the truss,usage type,etc.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::TrussMemberInfo

See Also

TrussMemberInfo Members
Autodesk.Revit Namespace


TrussMemberInfo Members
See Also Methods Constructors Fields
CollapseAll image DropDown image

Syntax

C#
public class TrussMemberInfo
Visual Basic (Declaration)
Public Class TrussMemberInfo
Visual C++
public ref class TrussMemberInfo

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TrussMemberInfoTrussMemberInfoNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | hostTrussId | The host truss' ElementId of the member.
Public field | lockedToTruss | Whether the member locked to the host truss.
Public field | memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo
Autodesk.Revit Namespace


TrussMemberInfo Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussMemberInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussMemberInfo ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


TrussMemberInfo Fields
CollapseAll image DropDown image

Syntax

C#
public class TrussMemberInfo
Visual Basic (Declaration)
Public Class TrussMemberInfo
Visual C++
public ref class TrussMemberInfo

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | hostTrussId | The host truss' ElementId of the member.
Public field | lockedToTruss | Whether the member locked to the host truss.
Public field | memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo
Autodesk.Revit Namespace


hostTrussId Field

TrussMemberInfo..::hostTrussId Field
CollapseAll image DropDown image

The host truss' ElementId of the member.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId hostTrussId
Visual Basic (Declaration)
Public hostTrussId As ElementId
Visual C++
public:
ElementId hostTrussId

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


lockedToTruss Field

TrussMemberInfo..::lockedToTruss Field
CollapseAll image DropDown image

Whether the member locked to the host truss.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool lockedToTruss
Visual Basic (Declaration)
Public lockedToTruss As Boolean
Visual C++
public:
bool lockedToTruss

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


memberTypeKey Field

TrussMemberInfo..::memberTypeKey Field
CollapseAll image DropDown image

Kind of the member in the truss.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussMemberType memberTypeKey
Visual Basic (Declaration)
Public memberTypeKey As TrussMemberType
Visual C++
public:
TrussMemberType memberTypeKey

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


TypeFilter Class
See Also Members
CollapseAll image DropDown image

Represents a filter to filter elements with the given type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CD9E823B-F629-432a-AA50-C60266B732CE")]
public class TypeFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CD9E823B-F629-432a-AA50-C60266B732CE")> _
Public Class TypeFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CD9E823B-F629-432a-AA50-C60266B732CE")]
public ref class TypeFilter : public Filter

Remarks

The TypeFilter object is to filter all the elements with the given type in the active document. You can specify whether its derived classes will be filtered out or not. By default, this filter will not retrieve derived classes objects.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::TypeFilter

See Also

TypeFilter Members
Autodesk.Revit Namespace


TypeFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TypeFilter
Visual Basic (Declaration)
Public Class TypeFilter
Visual C++
public ref class TypeFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TypeFilterTypeFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeFilter
Autodesk.Revit Namespace


TypeFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TypeFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TypeFilter Class
Autodesk.Revit Namespace


TypeFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class TypeFilter
Visual Basic (Declaration)
Public Class TypeFilter
Visual C++
public ref class TypeFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

TypeFilter
Autodesk.Revit Namespace


Dispose Method

TypeFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

TypeFilter Class
Autodesk.Revit Namespace


ViewSheetSetting Class
See Also Members
CollapseAll image DropDown image

Represents the View/Sheet Set (File->Print) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2845E150-DC15-4a01-8069-50F0DA9BBD6B")]
public class ViewSheetSetting : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2845E150-DC15-4a01-8069-50F0DA9BBD6B")> _
Public Class ViewSheetSetting _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2845E150-DC15-4a01-8069-50F0DA9BBD6B")]
public ref class ViewSheetSetting : public APIObject

Remarks

The View/Sheet Setting object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ViewSheetSetting

See Also

ViewSheetSetting Members
Autodesk.Revit Namespace


ViewSheetSetting Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSetting
Visual Basic (Declaration)
Public Class ViewSheetSetting
Visual C++
public ref class ViewSheetSetting

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSheetSettingViewSheetSettingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current view sheet set to another view sheet set with the specified name.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | AvailableViews | Get all available views (including sheets) in current project.
Public property | CurrentViewSheetSet | Get or Set the current Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting
Autodesk.Revit Namespace


ViewSheetSetting Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheetSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSetting ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


ViewSheetSetting Methods
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSetting
Visual Basic (Declaration)
Public Class ViewSheetSetting
Visual C++
public ref class ViewSheetSetting

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current view sheet set to another view sheet set with the specified name.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

ViewSheetSetting
Autodesk.Revit Namespace


Delete Method

ViewSheetSetting..::Delete Method
CollapseAll image DropDown image

Delete the current view sheet set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Delete()
Visual Basic (Declaration)
Public Function Delete As Boolean
Visual C++
public:
bool Delete ()

Return Value

Returns false if Delete operation fails, otherwise, returns true.

Remarks

If the current viewsheetset is In-Session, an InvalidOperationException will be thrown.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


Rename Method

ViewSheetSetting..::Rename Method
CollapseAll image DropDown image

Rename the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename (
    String^ newName
)

Parameters

newName
String
view sheet set name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current viewsheetset list, an InvalidOperationException will be thrown.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


Revert Method

ViewSheetSetting..::Revert Method
CollapseAll image DropDown image

Revert the current view sheet set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Revert()
Visual Basic (Declaration)
Public Sub Revert
Visual C++
public:
void Revert ()

Remarks

If the current viewsheetset is In-Session, an InvalidOperationException will be thrown.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


Save Method

ViewSheetSetting..::Save Method
CollapseAll image DropDown image

Save the changes for the current view sheet set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save ()

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

"In-Session" View Sheet Set can NOT save, if current viewsheetset is In-Session or the current viewsheetset does not changed, an InvalidOperationException will be thrown.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


SaveAs Method

ViewSheetSetting..::SaveAs Method
CollapseAll image DropDown image

Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ newName
)

Parameters

newName
String
view sheet set name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current viewsheetset list, an InvalidOperationException will be thrown.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


ViewSheetSetting Properties
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSetting
Visual Basic (Declaration)
Public Class ViewSheetSetting
Visual C++
public ref class ViewSheetSetting

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AvailableViews | Get all available views (including sheets) in current project.
Public property | CurrentViewSheetSet | Get or Set the current Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting
Autodesk.Revit Namespace


AvailableViews Property

ViewSheetSetting..::AvailableViews Property
CollapseAll image DropDown image

Get all available views (including sheets) in current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSet AvailableViews{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AvailableViews As ViewSet
Visual C++
public:
property ViewSet^ AvailableViews {
    ViewSet^ get ();
}

Remarks

User can select the view/sheet from this view set to printing.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


CurrentViewSheetSet Property

ViewSheetSetting..::CurrentViewSheetSet Property
CollapseAll image DropDown image

Get or Set the current Print Setting of Print Setup.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheetSet CurrentViewSheetSet{ get; set;}
Visual Basic (Declaration)
Public Property CurrentViewSheetSet As ViewSheetSet
Visual C++
public:
property ViewSheetSet^ CurrentViewSheetSet {
    ViewSheetSet^ get ();
    void set (ViewSheetSet^ value);
}

Remarks

The Current View Sheet Set, user can only edit/Save/SaveAs/Revit/Delete this ViewSheetSet.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


VolumeCalculationOptions Class
See Also Members
CollapseAll image DropDown image

This class provides access to options related to room volume and area computations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("55241FFB-BFBF-474b-A7B1-E161CABCCA87")]
public class VolumeCalculationOptions
Visual Basic (Declaration)
<GuidAttribute("55241FFB-BFBF-474b-A7B1-E161CABCCA87")> _
Public Class VolumeCalculationOptions
Visual C++
[GuidAttribute(L"55241FFB-BFBF-474b-A7B1-E161CABCCA87")]
public ref class VolumeCalculationOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::VolumeCalculationOptions

See Also

VolumeCalculationOptions Members
Autodesk.Revit Namespace


VolumeCalculationOptions Members
See Also Methods Constructors Fields Properties
CollapseAll image DropDown image

Syntax

C#
public class VolumeCalculationOptions
Visual Basic (Declaration)
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | VolumeCalculationOptionsVolumeCalculationOptionsNew | Creates a new instance of the volume calculation options.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
Public field | VolumeComputationEnbale | Deprecated; this field will be removed in future release of the Revit API. Use VolumeComputationEnable instead.

Public Properties

 | Name | Description
Public property | VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions
Autodesk.Revit Namespace


VolumeCalculationOptions Constructor
CollapseAll image DropDown image

Creates a new instance of the volume calculation options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VolumeCalculationOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VolumeCalculationOptions ()

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeCalculationOptions Fields
CollapseAll image DropDown image

Syntax

C#
public class VolumeCalculationOptions
Visual Basic (Declaration)
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
Public field | VolumeComputationEnbale | Deprecated; this field will be removed in future release of the Revit API. Use VolumeComputationEnable instead.

See Also

VolumeCalculationOptions
Autodesk.Revit Namespace


RoomAreaBoundaryLocation Field

VolumeCalculationOptions..::RoomAreaBoundaryLocation Field
CollapseAll image DropDown image

The location used to calculate area and volume from room boundaries.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryLocationType RoomAreaBoundaryLocation
Visual Basic (Declaration)
Public RoomAreaBoundaryLocation As BoundaryLocationType
Visual C++
public:
BoundaryLocationType RoomAreaBoundaryLocation

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeComputationEnbale Field

VolumeCalculationOptions..::VolumeComputationEnbale Field
CollapseAll image DropDown image

Deprecated; this field will be removed in future release of the Revit API. Use VolumeComputationEnable instead.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool VolumeComputationEnbale
Visual Basic (Declaration)
Public VolumeComputationEnbale As Boolean
Visual C++
public:
bool VolumeComputationEnbale

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeCalculationOptions Properties
CollapseAll image DropDown image

Syntax

C#
public class VolumeCalculationOptions
Visual Basic (Declaration)
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions
Autodesk.Revit Namespace


VolumeComputationEnable Property

VolumeCalculationOptions..::VolumeComputationEnable Property
CollapseAll image DropDown image

True to enable volume computation in Revit. False to disable it.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool VolumeComputationEnable{ get; set;}
Visual Basic (Declaration)
Public Property VolumeComputationEnable As Boolean
Visual C++
public:
property bool VolumeComputationEnable {
    bool get ();
    void set (bool value);
}

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeCalculationSetting Class
See Also Members
CollapseAll image DropDown image

This class provides access to settings related to room volume and area computations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("574BB195-E319-43df-83FA-DE6EB364F021")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class VolumeCalculationSetting
Visual Basic (Declaration)
<GuidAttribute("574BB195-E319-43df-83FA-DE6EB364F021")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class VolumeCalculationSetting
Visual C++
[GuidAttribute(L"574BB195-E319-43df-83FA-DE6EB364F021")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class VolumeCalculationSetting

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::VolumeCalculationSetting

See Also

VolumeCalculationSetting Members
Autodesk.Revit Namespace


VolumeCalculationSetting Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class VolumeCalculationSetting
Visual Basic (Declaration)
Public Class VolumeCalculationSetting
Visual C++
public ref class VolumeCalculationSetting

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | VolumeCalculationSettingVolumeCalculationSettingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | VolumeCalculationOptions | Retrieve or change the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting
Autodesk.Revit Namespace


VolumeCalculationSetting Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VolumeCalculationSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VolumeCalculationSetting ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VolumeCalculationSetting Class
Autodesk.Revit Namespace


VolumeCalculationSetting Properties
CollapseAll image DropDown image

Syntax

C#
public class VolumeCalculationSetting
Visual Basic (Declaration)
Public Class VolumeCalculationSetting
Visual C++
public ref class VolumeCalculationSetting

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | VolumeCalculationOptions | Retrieve or change the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting
Autodesk.Revit Namespace


VolumeCalculationOptions Property

VolumeCalculationSetting..::VolumeCalculationOptions Property
See Also
CollapseAll image DropDown image

Retrieve or change the application settings related to automatic calculation of room volumes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VolumeCalculationOptions VolumeCalculationOptions{ get; set;}
Visual Basic (Declaration)
Public Property VolumeCalculationOptions As VolumeCalculationOptions
Visual C++
public:
property VolumeCalculationOptions^ VolumeCalculationOptions {
    VolumeCalculationOptions^ get ();
    void set (VolumeCalculationOptions^ value);
}

See Also

VolumeCalculationSetting Class
Autodesk.Revit Namespace


WallUsageFilter Class
See Also Members
CollapseAll image DropDown image

A Filter object that represents Structural WallUsage, used to retrieve Wall elements whose structural WallUsage is specified WallUsage type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1DB666E5-A207-449d-AD08-D5FF1B346418")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WallUsageFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("1DB666E5-A207-449d-AD08-D5FF1B346418")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WallUsageFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"1DB666E5-A207-449d-AD08-D5FF1B346418")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WallUsageFilter : public Filter

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::WallUsageFilter

See Also

WallUsageFilter Members
Autodesk.Revit Namespace


WallUsageFilter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WallUsageFilter
Visual Basic (Declaration)
Public Class WallUsageFilter
Visual C++
public ref class WallUsageFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WallUsageFilterWallUsageFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallUsageFilter
Autodesk.Revit Namespace


WallUsageFilter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallUsageFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallUsageFilter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallUsageFilter Class
Autodesk.Revit Namespace


WallUsageFilter Methods
CollapseAll image DropDown image

Syntax

C#
public class WallUsageFilter
Visual Basic (Declaration)
Public Class WallUsageFilter
Visual C++
public ref class WallUsageFilter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Filter ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

WallUsageFilter
Autodesk.Revit Namespace


Dispose Method

WallUsageFilter..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WallUsageFilter Class
Autodesk.Revit Namespace


Autodesk.Revit.Areas Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Areas
Visual Basic (Declaration)
Namespace Autodesk.Revit.Areas
Visual C++
namespace Autodesk.Revit.Areas

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of a area boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.


BoundarySegment Class
See Also Members
CollapseAll image DropDown image

An object that represents a segment of a area boundary.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("30D74E65-6F1F-4C18-BFB3-3F1832FFD64A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegment : APIObject
Visual Basic (Declaration)
<GuidAttribute("30D74E65-6F1F-4C18-BFB3-3F1832FFD64A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
[GuidAttribute(L"30D74E65-6F1F-4C18-BFB3-3F1832FFD64A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Areas Namespace


BoundarySegment Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentBoundarySegmentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this area.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment
Autodesk.Revit.Areas Namespace


BoundarySegment Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegment ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


BoundarySegment Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegment
Autodesk.Revit.Areas Namespace


ReleaseUnmanagedResources Method

BoundarySegment..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


BoundarySegment Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this area.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment
Autodesk.Revit.Areas Namespace


Curve Property

BoundarySegment..::Curve Property
CollapseAll image DropDown image

Get the curve that is formed by the element that defines the edge of this area.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


Document Property

BoundarySegment..::Document Property
CollapseAll image DropDown image

Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document Document{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


Element Property

BoundarySegment..::Element Property
CollapseAll image DropDown image

Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific area.

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segments.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5930C8C8-69A1-4729-A621-6F41851657FB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegmentArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("5930C8C8-69A1-4729-A621-6F41851657FB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"5930C8C8-69A1-4729-A621-6F41851657FB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayBoundarySegmentArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray ()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArray
Autodesk.Revit.Areas Namespace


Append Method

BoundarySegmentArray..::Append Method
CollapseAll image DropDown image

Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append (
    BoundarySegment^ item
)

Parameters

item
BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Clear Method

BoundarySegmentArray..::Clear Method
CollapseAll image DropDown image

Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Dispose Method

BoundarySegmentArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


ForwardIterator Method

BoundarySegmentArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


GetEnumerator Method

BoundarySegmentArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Insert Method

BoundarySegmentArray..::Insert Method
CollapseAll image DropDown image

Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    BoundarySegment^ item,
    int index
)

Parameters

item
BoundarySegment
The boundary segment to be inserted into the array.
index
Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


ReverseIterator Method

BoundarySegmentArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray
Autodesk.Revit.Areas Namespace


IsEmpty Property

BoundarySegmentArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Item Property

BoundarySegmentArray..::Item Property
CollapseAll image DropDown image

Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegment Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Size Property

BoundarySegmentArray..::Size Property
CollapseAll image DropDown image

Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D999CDF9-F038-45C3-8C82-4130D32EAAF3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegmentArrayArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("D999CDF9-F038-45C3-8C82-4130D32EAAF3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"D999CDF9-F038-45C3-8C82-4130D32EAAF3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayBoundarySegmentArrayArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray ()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Areas Namespace


Append Method

BoundarySegmentArrayArray..::Append Method
CollapseAll image DropDown image

Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append (
    BoundarySegmentArray^ item
)

Parameters

item
BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Clear Method

BoundarySegmentArrayArray..::Clear Method
CollapseAll image DropDown image

Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Dispose Method

BoundarySegmentArrayArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


ForwardIterator Method

BoundarySegmentArrayArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


GetEnumerator Method

BoundarySegmentArrayArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Insert Method

BoundarySegmentArrayArray..::Insert Method
CollapseAll image DropDown image

Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayArray..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


ReverseIterator Method

BoundarySegmentArrayArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Areas Namespace


IsEmpty Property

BoundarySegmentArrayArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Item Property

BoundarySegmentArrayArray..::Item Property
CollapseAll image DropDown image

Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Size Property

BoundarySegmentArrayArray..::Size Property
CollapseAll image DropDown image

Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FD85F1FE-F504-437F-96A9-E6564CC82879")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BoundarySegmentArrayArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("FD85F1FE-F504-437F-96A9-E6564CC82879")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"FD85F1FE-F504-437F-96A9-E6564CC82879")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayIteratorBoundarySegmentArrayArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Areas Namespace


Dispose Method

BoundarySegmentArrayArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


MoveNext Method

BoundarySegmentArrayArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


Reset Method

BoundarySegmentArrayArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Areas Namespace


Current Property

BoundarySegmentArrayArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EEFD665B-3238-4925-84E3-ED8EB723B20F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BoundarySegmentArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("EEFD665B-3238-4925-84E3-ED8EB723B20F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"EEFD665B-3238-4925-84E3-ED8EB723B20F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayIteratorBoundarySegmentArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Areas Namespace


Dispose Method

BoundarySegmentArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


MoveNext Method

BoundarySegmentArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


Reset Method

BoundarySegmentArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Areas Namespace


Current Property

BoundarySegmentArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


Autodesk.Revit.Collections Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Collections
Visual Basic (Declaration)
Namespace Autodesk.Revit.Collections
Visual C++
namespace Autodesk.Revit.Collections

Classes

 | Class | Description
Public class | Array | An array that can contain any type of object.
Public class | ArrayIterator | An iterator to a array.
Public class | DefinitionBindingMap | A map that contains mappings of parameter definitions to parameter bindings.
Public class | DefinitionBindingMapIterator | An iterator to a parameter definition to parameter bindings map.
Public class | Map | A map that can contain a mapping of any type of object to any other type of object.
Public class | MapIterator | An iterator to a map.
Public class | Set | A set that can contain any type of object.
Public class | SetIterator | An iterator to a set.
Public class | StringStringMap | A map that can contain a mapping of a string to another string.
Public class | StringStringMapIterator | An iterator to a string to string map.


Array Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A807ABA2-D7E9-4a97-974A-8A17F360DCC8")]
public class Array : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A807ABA2-D7E9-4a97-974A-8A17F360DCC8")> _
Public Class Array _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A807ABA2-D7E9-4a97-974A-8A17F360DCC8")]
public ref class Array : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::Array

See Also

Array Members
Autodesk.Revit.Collections Namespace


Array Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Array
Visual Basic (Declaration)
Public Class Array
Visual C++
public ref class Array

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ArrayArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

Array
Autodesk.Revit.Collections Namespace


Array Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Array()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Array ()

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Methods
CollapseAll image DropDown image

Syntax

C#
public class Array
Visual Basic (Declaration)
Public Class Array
Visual C++
public ref class Array

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Array
Autodesk.Revit.Collections Namespace


Append Method

Array..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Object item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Object _
)
Visual C++
public:
virtual void Append (
    Object^ item
)

Parameters

item
Object
The item to be added.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Clear Method

Array..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

Array Class
Autodesk.Revit.Collections Namespace


Dispose Method

Array..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Array Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

Array..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ArrayIterator
Visual C++
public:
virtual ArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

Array..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Insert Method

Array..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Object item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Object, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Object^ item,
    int index
)

Parameters

item
Object
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

Array..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Array Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

Array..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ArrayIterator
Visual C++
public:
virtual ArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Properties
CollapseAll image DropDown image

Syntax

C#
public class Array
Visual Basic (Declaration)
Public Class Array
Visual C++
public ref class Array

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

Array
Autodesk.Revit.Collections Namespace


IsEmpty Property

Array..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Item Property

Array..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Object Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
virtual property Object^ Item[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Size Property

Array..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Array Class
Autodesk.Revit.Collections Namespace


ArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0C5E799B-240D-4b6a-9BCA-39AC0D878DE1")]
public abstract class ArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0C5E799B-240D-4b6a-9BCA-39AC0D878DE1")> _
Public MustInherit Class ArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0C5E799B-240D-4b6a-9BCA-39AC0D878DE1")]
public ref class ArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::ArrayIterator

See Also

ArrayIterator Members
Autodesk.Revit.Collections Namespace


ArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ArrayIterator
Visual C++
public ref class ArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ArrayIteratorArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ArrayIterator
Autodesk.Revit.Collections Namespace


ArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ArrayIterator
Visual C++
public ref class ArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ArrayIterator
Autodesk.Revit.Collections Namespace


Dispose Method

ArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

ArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

ArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

ArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ArrayIterator
Visual C++
public ref class ArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ArrayIterator
Autodesk.Revit.Collections Namespace


Current Property

ArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Class
See Also Members
CollapseAll image DropDown image

A map that contains mappings of parameter definitions to parameter bindings.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("42407C5E-5D3C-4540-8C96-E659AFF836D7")]
public class DefinitionBindingMap : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("42407C5E-5D3C-4540-8C96-E659AFF836D7")> _
Public Class DefinitionBindingMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"42407C5E-5D3C-4540-8C96-E659AFF836D7")]
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::DefinitionBindingMap
Autodesk.Revit.Parameters..::BindingMap

See Also

DefinitionBindingMap Members
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionBindingMap
Visual Basic (Declaration)
Public Class DefinitionBindingMap
Visual C++
public ref class DefinitionBindingMap

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionBindingMapDefinitionBindingMapNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains | Tests for the existence of a definition within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a binding with the specified definition from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified binding with the specified definition into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a parameter binding for a specified parameter definition within the map.
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionBindingMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionBindingMap ()

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Methods
CollapseAll image DropDown image

Syntax

C#
public class DefinitionBindingMap
Visual Basic (Declaration)
Public Class DefinitionBindingMap
Visual C++
public ref class DefinitionBindingMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains | Tests for the existence of a definition within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a binding with the specified definition from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified binding with the specified definition into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionBindingMap
Autodesk.Revit.Collections Namespace


Clear Method

DefinitionBindingMap..::Clear Method
CollapseAll image DropDown image

Removes every binding from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Contains Method

DefinitionBindingMap..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a definition within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Definition^ key
)

Parameters

key
Definition
The definition to be searched for.

Return Value

The Contains method returns True if the definition is within the map, otherwise False.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Dispose Method

DefinitionBindingMap..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Erase Method

DefinitionBindingMap..::Erase Method
CollapseAll image DropDown image

Removes a binding with the specified definition from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase (
    Definition^ key
)

Parameters

key
Definition
The definition of the binding to be erased.

Return Value

The number of bindings that were erased from the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

DefinitionBindingMap..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DefinitionBindingMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

DefinitionBindingMap..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Insert Method

DefinitionBindingMap..::Insert Method
CollapseAll image DropDown image

Insert the specified binding with the specified definition into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Definition^ key,
    Binding^ item
)

Parameters

key
Definition
The definition to be used for inserting the binding into the map.
item
Binding
The binding to be inserted into the map.

Return Value

Returns whether the binding was inserted into the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

DefinitionBindingMap..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

DefinitionBindingMap..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DefinitionBindingMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Properties
CollapseAll image DropDown image

Syntax

C#
public class DefinitionBindingMap
Visual Basic (Declaration)
Public Class DefinitionBindingMap
Visual C++
public ref class DefinitionBindingMap

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a parameter binding for a specified parameter definition within the map.
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap
Autodesk.Revit.Collections Namespace


IsEmpty Property

DefinitionBindingMap..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Item Property

DefinitionBindingMap..::Item Property
CollapseAll image DropDown image

Gets or sets a parameter binding for a specified parameter definition within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Binding Item[
    Definition key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key);
    void set (Definition^ key, Binding^ value);
}

Parameters

key
Definition
The parameter definition of the binding to be set or retrieved.

Return Value

Returns the binding for the specified definition.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Size Property

DefinitionBindingMap..::Size Property
CollapseAll image DropDown image

Returns the number of bindings that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a parameter definition to parameter bindings map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("79B1A17C-2AB6-45e9-92C7-12A5B6B43CBA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class DefinitionBindingMapIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("79B1A17C-2AB6-45e9-92C7-12A5B6B43CBA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class DefinitionBindingMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"79B1A17C-2AB6-45e9-92C7-12A5B6B43CBA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DefinitionBindingMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::DefinitionBindingMapIterator

See Also

DefinitionBindingMapIterator Members
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionBindingMapIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionBindingMapIterator
Visual C++
public ref class DefinitionBindingMapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionBindingMapIteratorDefinitionBindingMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionBindingMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionBindingMapIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionBindingMapIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionBindingMapIterator
Visual C++
public ref class DefinitionBindingMapIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionBindingMapIterator
Autodesk.Revit.Collections Namespace


Dispose Method

DefinitionBindingMapIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

DefinitionBindingMapIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

DefinitionBindingMapIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

DefinitionBindingMapIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionBindingMapIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionBindingMapIterator
Visual C++
public ref class DefinitionBindingMapIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator
Autodesk.Revit.Collections Namespace


Current Property

DefinitionBindingMapIterator..::Current Property
CollapseAll image DropDown image

Retrieves the binding that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

DefinitionBindingMapIterator..::Key Property
CollapseAll image DropDown image

Retrieves the definition that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Definition Key{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As Definition
Visual C++
public:
virtual property Definition^ Key {
    Definition^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


Map Class
See Also Members
CollapseAll image DropDown image

A map that can contain a mapping of any type of object to any other type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A2D913DD-93B3-4db1-AB40-D5B6F792AD29")]
public class Map : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A2D913DD-93B3-4db1-AB40-D5B6F792AD29")> _
Public Class Map _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A2D913DD-93B3-4db1-AB40-D5B6F792AD29")]
public ref class Map : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::Map

See Also

Map Members
Autodesk.Revit.Collections Namespace


Map Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Map
Visual Basic (Declaration)
Public Class Map
Visual C++
public ref class Map

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MapMapNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

Map
Autodesk.Revit.Collections Namespace


Map Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Map()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Map ()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Methods
CollapseAll image DropDown image

Syntax

C#
public class Map
Visual Basic (Declaration)
Public Class Map
Visual C++
public ref class Map

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Map
Autodesk.Revit.Collections Namespace


Clear Method

Map..::Clear Method
CollapseAll image DropDown image

Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Contains Method

Map..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Object^ key
)

Parameters

key
Object
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Dispose Method

Map..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Map Class
Autodesk.Revit.Collections Namespace


Erase Method

Map..::Erase Method
CollapseAll image DropDown image

Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Object _
) As Integer
Visual C++
public:
virtual int Erase (
    Object^ key
)

Parameters

key
Object
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

Map..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MapIterator
Visual C++
public:
virtual MapIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

Map..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Insert Method

Map..::Insert Method
CollapseAll image DropDown image

Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Object key,
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Object, _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Object^ key,
    Object^ item
)

Parameters

key
Object
The key to be used for inserting the item into the map.
item
Object
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

Map..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Map Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

Map..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MapIterator
Visual C++
public:
virtual MapIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Properties
CollapseAll image DropDown image

Syntax

C#
public class Map
Visual Basic (Declaration)
Public Class Map
Visual C++
public ref class Map

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

Map
Autodesk.Revit.Collections Namespace


IsEmpty Property

Map..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Item Property

Map..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Object Item[
    Object key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Object _
) As Object
Visual C++
public:
virtual property Object^ Item[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Object
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Size Property

Map..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Map Class
Autodesk.Revit.Collections Namespace


MapIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("79C1ABA9-849D-4a53-8B31-268C85D05056")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class MapIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("79C1ABA9-849D-4a53-8B31-268C85D05056")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class MapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"79C1ABA9-849D-4a53-8B31-268C85D05056")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::MapIterator

See Also

MapIterator Members
Autodesk.Revit.Collections Namespace


MapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class MapIterator
Visual Basic (Declaration)
Public MustInherit Class MapIterator
Visual C++
public ref class MapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MapIteratorMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

MapIterator
Autodesk.Revit.Collections Namespace


MapIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MapIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class MapIterator
Visual Basic (Declaration)
Public MustInherit Class MapIterator
Visual C++
public ref class MapIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MapIterator
Autodesk.Revit.Collections Namespace


Dispose Method

MapIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

MapIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

MapIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

MapIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class MapIterator
Visual Basic (Declaration)
Public MustInherit Class MapIterator
Visual C++
public ref class MapIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

MapIterator
Autodesk.Revit.Collections Namespace


Current Property

MapIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

MapIterator..::Key Property
CollapseAll image DropDown image

Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Object Key{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As Object
Visual C++
public:
virtual property Object^ Key {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Set Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6CA7525A-7C8A-4d18-AD0A-981663E9A0CC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Set : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("6CA7525A-7C8A-4d18-AD0A-981663E9A0CC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Set _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"6CA7525A-7C8A-4d18-AD0A-981663E9A0CC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Set : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::Set

See Also

Set Members
Autodesk.Revit.Collections Namespace


Set Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Set
Visual Basic (Declaration)
Public Class Set
Visual C++
public ref class Set

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SetSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

Set
Autodesk.Revit.Collections Namespace


Set Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Set()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Set ()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Methods
CollapseAll image DropDown image

Syntax

C#
public class Set
Visual Basic (Declaration)
Public Class Set
Visual C++
public ref class Set

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Set
Autodesk.Revit.Collections Namespace


Clear Method

Set..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Contains Method

Set..::Contains Method
CollapseAll image DropDown image

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Object^ item
)

Parameters

item
Object
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Dispose Method

Set..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Set Class
Autodesk.Revit.Collections Namespace


Erase Method

Set..::Erase Method
CollapseAll image DropDown image

Removes a specified object from the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Erase (
    Object^ item
)

Parameters

item
Object
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

Set..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SetIterator
Visual C++
public:
virtual SetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

Set..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Insert Method

Set..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Object^ item
)

Parameters

item
Object
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

Set..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Set Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

Set..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SetIterator
Visual C++
public:
virtual SetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Properties
CollapseAll image DropDown image

Syntax

C#
public class Set
Visual Basic (Declaration)
Public Class Set
Visual C++
public ref class Set

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

Set
Autodesk.Revit.Collections Namespace


IsEmpty Property

Set..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Size Property

Set..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Set Class
Autodesk.Revit.Collections Namespace


SetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7B52D1BA-F161-43cd-9BAB-1642029460BB")]
public abstract class SetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7B52D1BA-F161-43cd-9BAB-1642029460BB")> _
Public MustInherit Class SetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7B52D1BA-F161-43cd-9BAB-1642029460BB")]
public ref class SetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::SetIterator

See Also

SetIterator Members
Autodesk.Revit.Collections Namespace


SetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SetIterator
Visual Basic (Declaration)
Public MustInherit Class SetIterator
Visual C++
public ref class SetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SetIteratorSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SetIterator
Autodesk.Revit.Collections Namespace


SetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SetIterator
Visual Basic (Declaration)
Public MustInherit Class SetIterator
Visual C++
public ref class SetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SetIterator
Autodesk.Revit.Collections Namespace


Dispose Method

SetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

SetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

SetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

SetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SetIterator
Visual Basic (Declaration)
Public MustInherit Class SetIterator
Visual C++
public ref class SetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SetIterator
Autodesk.Revit.Collections Namespace


Current Property

SetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


StringStringMap Class
See Also Members
CollapseAll image DropDown image

A map that can contain a mapping of a string to another string.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4C89D833-0173-4a5a-B0A1-CB80252E7B39")]
public class StringStringMap : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4C89D833-0173-4a5a-B0A1-CB80252E7B39")> _
Public Class StringStringMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4C89D833-0173-4a5a-B0A1-CB80252E7B39")]
public ref class StringStringMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::StringStringMap

See Also

StringStringMap Members
Autodesk.Revit.Collections Namespace


StringStringMap Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class StringStringMap
Visual Basic (Declaration)
Public Class StringStringMap
Visual C++
public ref class StringStringMap

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | StringStringMapStringStringMapNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every string from the map, rendering it empty.
Public method | Contains | Tests for the existence of a string key within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes an item with the specified string key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a string item at a specified string key within the map.
Public property | Size | Returns the number of strings that are in the map.

See Also

StringStringMap
Autodesk.Revit.Collections Namespace


StringStringMap Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringStringMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringStringMap ()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Methods
CollapseAll image DropDown image

Syntax

C#
public class StringStringMap
Visual Basic (Declaration)
Public Class StringStringMap
Visual C++
public ref class StringStringMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every string from the map, rendering it empty.
Public method | Contains | Tests for the existence of a string key within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes an item with the specified string key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

StringStringMap
Autodesk.Revit.Collections Namespace


Clear Method

StringStringMap..::Clear Method
CollapseAll image DropDown image

Removes every string from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Contains Method

StringStringMap..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains (
    String^ key
)

Parameters

key
String
The key to be searched for.

Return Value

The Contains method returns True if the string key is within the map, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Dispose Method

StringStringMap..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Erase Method

StringStringMap..::Erase Method
CollapseAll image DropDown image

Removes an item with the specified string key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase (
    String^ key
)

Parameters

key
String
The string key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

StringStringMap..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual StringStringMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

StringStringMap..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Insert Method

StringStringMap..::Insert Method
CollapseAll image DropDown image

Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    string key,
    string item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As String _
) As Boolean
Visual C++
public:
virtual bool Insert (
    String^ key,
    String^ item
)

Parameters

key
String
The key to be used for inserting the item into the map.
item
String
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

StringStringMap..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

StringStringMap..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual StringStringMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Properties
CollapseAll image DropDown image

Syntax

C#
public class StringStringMap
Visual Basic (Declaration)
Public Class StringStringMap
Visual C++
public ref class StringStringMap

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a string item at a specified string key within the map.
Public property | Size | Returns the number of strings that are in the map.

See Also

StringStringMap
Autodesk.Revit.Collections Namespace


IsEmpty Property

StringStringMap..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Item Property

StringStringMap..::Item Property
CollapseAll image DropDown image

Gets or sets a string item at a specified string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual string Item[
    string key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As String
Visual C++
public:
virtual property String^ Item[String^ key] {
    String^ get (String^ key);
    void set (String^ key, String^ value);
}

Parameters

key
String
The string key of the string item to be set or retrieved.

Return Value

Returns the string item at the specified string key.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Size Property

StringStringMap..::Size Property
CollapseAll image DropDown image

Returns the number of strings that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a string to string map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1F3794B6-5598-4e4c-8568-9C7297320D80")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class StringStringMapIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("1F3794B6-5598-4e4c-8568-9C7297320D80")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class StringStringMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"1F3794B6-5598-4e4c-8568-9C7297320D80")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class StringStringMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::StringStringMapIterator

See Also

StringStringMapIterator Members
Autodesk.Revit.Collections Namespace


StringStringMapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class StringStringMapIterator
Visual Basic (Declaration)
Public MustInherit Class StringStringMapIterator
Visual C++
public ref class StringStringMapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | StringStringMapIteratorStringStringMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the string item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator
Autodesk.Revit.Collections Namespace


StringStringMapIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringStringMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringStringMapIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class StringStringMapIterator
Visual Basic (Declaration)
Public MustInherit Class StringStringMapIterator
Visual C++
public ref class StringStringMapIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

StringStringMapIterator
Autodesk.Revit.Collections Namespace


Dispose Method

StringStringMapIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

StringStringMapIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


ReleaseUnmanagedResources Method

StringStringMapIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

StringStringMapIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class StringStringMapIterator
Visual Basic (Declaration)
Public MustInherit Class StringStringMapIterator
Visual C++
public ref class StringStringMapIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the string item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator
Autodesk.Revit.Collections Namespace


Current Property

StringStringMapIterator..::Current Property
CollapseAll image DropDown image

Retrieves the string item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

StringStringMapIterator..::Key Property
CollapseAll image DropDown image

Retrieves the string key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual string Key{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Autodesk.Revit.Creation Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Creation
Visual Basic (Declaration)
Namespace Autodesk.Revit.Creation
Visual C++
namespace Autodesk.Revit.Creation

Classes

 | Class | Description
Public class | Application | The Application Creation object is used to create new instances of utility objects.
Public class | AreaCreationData | A class which wraps the arguments of Area for batch creation
Public class | Document | The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Public class | FamilyInstanceCreationData | A class which wraps the arguments of FamilyInstance for batch creation.
Public class | Filter | The Filter creation object is used to create new instances of element filter utility objects.
Public class | ProfiledWallCreationData | A class which wraps the arguments of Wall for batch creation
Public class | RectangularWallCreationData | A class which wraps the arguments of Wall for batch creation
Public class | RoomCreationData | A class which wraps the arguments of Room for batch creation.
Public class | TextNoteCreationData | A class which wraps the arguments of TextNote for batch creation

Enumerations

 | Enumeration | Description
Public enumeration | Document..::eRefFace | Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.


Application Class
See Also Members
CollapseAll image DropDown image

The Application Creation object is used to create new instances of utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("711849C2-4FD7-4617-BB97-B212DA042C8E")]
public class Application : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("711849C2-4FD7-4617-BB97-B212DA042C8E")> _
Public Class Application _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"711849C2-4FD7-4617-BB97-B212DA042C8E")]
public ref class Application : public APIObject

Remarks

General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Creation..::Application

See Also

Application Members
Autodesk.Revit.Creation Namespace


Application Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ApplicationApplicationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewArc | Overloaded.
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewArray | Creates a new instance of a generic Array.
Public method | NewBoundingBoxUV | Overloaded.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
Public method | NewColor | Returns a new color object.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWF2DExportOptions | Creates DWF2D Export options.
Public method | NewDWF3DExportOptions | Creates DWF3D Export options.
Public method | NewDWFX2DExportOptions | Creates DWFX2D Export options.
Public method | NewDWFX3DExportOptions | Creates DWFX3D Export options.
Public method | NewDWGExportOptions | Creates DWG Export options.
Public method | NewElementArray | Returns an array that can hold element objects.
Public method | NewElementId | Creates a new ElementId object.
Public method | NewElementIdSet | Creates a new instance of a set specifically for holding element ids.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewEllipse | Creates a new geometric ellipse object.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData | Overloaded.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewFillPatternSet | Returns a set that can hold fill pattern objects.
Public method | NewGBXMLExportOptions | Creates Gren-Building XML Export options.
Public method | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewInstanceBinding | Overloaded.
Public method | NewIntersectionResultArray | Creates a new instance of a IntersectionResult array.
Public method | NewLine | Creates a new bound or unbounded geometric line object.
Public method | NewLineBound | Creates a new bounded geometric line object.
Public method | NewLinePatternSet | Returns a set that can hold line pattern objects.
Public method | NewLineUnbound | Creates a new unbounded geometric line object.
Public method | NewLoadCaseArray | Creates a new instance of a LoadCase array.
Public method | NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
Public method | NewLoadUsageArray | Creates a new instance of a LoadUsage array.
Public method | NewMap | Creates a new instance of a generic Map.
Public method | NewMaterialSet | Create a new instance of MaterialSet.
Public method | NewNurbSpline | Creates a new geometric nurbSpline object.
Public method | NewParameterListItemArray | Returns an array that can hold list items of external list parameter.
Public method | NewPlane | Overloaded.
Public method | NewPostedErrorArray | Creates a array to store instances of PostedError.
Public method | NewProfiledWallCreationData | Overloaded.
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewRectangularWallCreationData | Overloaded.
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewRoomCreationData | Creates an object which wraps the arguments of Room for batch creation.
Public method | NewSelElementSet | Creates a new instance of a set specifically for holding selected elements.
Public method | NewSet | Creates a new instance of a generic Set.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewStringStringMap | Creates a new map that maps one string to another string.
Public method | NewTextNoteCreationData | Overloaded.
Public method | NewTypeBinding | Overloaded.
Public method | NewUV | Overloaded.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewXYZ | Overloaded.
Public method | NewXYZArray | Generate an empty array that can hold XYZ point objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Filter | Gives access to an object for creating different types of filters.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application
Autodesk.Revit.Creation Namespace


Application Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Application ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Application Class
Autodesk.Revit.Creation Namespace


Application Methods
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewArc | Overloaded.
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewArray | Creates a new instance of a generic Array.
Public method | NewBoundingBoxUV | Overloaded.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
Public method | NewColor | Returns a new color object.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWF2DExportOptions | Creates DWF2D Export options.
Public method | NewDWF3DExportOptions | Creates DWF3D Export options.
Public method | NewDWFX2DExportOptions | Creates DWFX2D Export options.
Public method | NewDWFX3DExportOptions | Creates DWFX3D Export options.
Public method | NewDWGExportOptions | Creates DWG Export options.
Public method | NewElementArray | Returns an array that can hold element objects.
Public method | NewElementId | Creates a new ElementId object.
Public method | NewElementIdSet | Creates a new instance of a set specifically for holding element ids.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewEllipse | Creates a new geometric ellipse object.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData | Overloaded.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewFillPatternSet | Returns a set that can hold fill pattern objects.
Public method | NewGBXMLExportOptions | Creates Gren-Building XML Export options.
Public method | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewInstanceBinding | Overloaded.
Public method | NewIntersectionResultArray | Creates a new instance of a IntersectionResult array.
Public method | NewLine | Creates a new bound or unbounded geometric line object.
Public method | NewLineBound | Creates a new bounded geometric line object.
Public method | NewLinePatternSet | Returns a set that can hold line pattern objects.
Public method | NewLineUnbound | Creates a new unbounded geometric line object.
Public method | NewLoadCaseArray | Creates a new instance of a LoadCase array.
Public method | NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
Public method | NewLoadUsageArray | Creates a new instance of a LoadUsage array.
Public method | NewMap | Creates a new instance of a generic Map.
Public method | NewMaterialSet | Create a new instance of MaterialSet.
Public method | NewNurbSpline | Creates a new geometric nurbSpline object.
Public method | NewParameterListItemArray | Returns an array that can hold list items of external list parameter.
Public method | NewPlane | Overloaded.
Public method | NewPostedErrorArray | Creates a array to store instances of PostedError.
Public method | NewProfiledWallCreationData | Overloaded.
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewRectangularWallCreationData | Overloaded.
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewRoomCreationData | Creates an object which wraps the arguments of Room for batch creation.
Public method | NewSelElementSet | Creates a new instance of a set specifically for holding selected elements.
Public method | NewSet | Creates a new instance of a generic Set.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewStringStringMap | Creates a new map that maps one string to another string.
Public method | NewTextNoteCreationData | Overloaded.
Public method | NewTypeBinding | Overloaded.
Public method | NewUV | Overloaded.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewXYZ | Overloaded.
Public method | NewXYZArray | Generate an empty array that can hold XYZ point objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Application
Autodesk.Revit.Creation Namespace


NewArc Method

Application..::NewArc Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewArc(XYZ, XYZ, XYZ) | Creates a new geometric arc object.
Public method | NewArc(Plane, Double, Double, Double) | Creates a new geometric arc object.
Public method | NewArc(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, XYZ, XYZ)

Application..::NewArc Method (XYZ, XYZ, XYZ)
See Also
CollapseAll image DropDown image

Creates a new geometric arc object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Arc NewArc(
    XYZ end0,
    XYZ end1,
    XYZ pointOnCurve
)
Visual Basic (Declaration)
Public Function NewArc ( _
    end0 As XYZ, _
    end1 As XYZ, _
    pointOnCurve As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc (
    XYZ^ end0,
    XYZ^ end1,
    XYZ^ pointOnCurve
)

Parameters

end0
XYZ
The start point of the arc.
end1
XYZ
The end point of the arc.
pointOnCurve
XYZ
A point on the arc.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArc Method (Plane, Double, Double, Double)

Application..::NewArc Method (Plane, Double, Double, Double)
See Also
CollapseAll image DropDown image

Creates a new geometric arc object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Arc NewArc(
    Plane plane,
    double radius,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewArc ( _
    plane As Plane, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
) As Arc
Visual C++
public:
Arc^ NewArc (
    Plane^ plane,
    double radius,
    double startAngle,
    double endAngle
)

Parameters

plane
Plane
The plane which the arc resides in. The plane's origin is the center of the arc.
radius
Double
startAngle
Double
The start angle of the arc.
endAngle
Double
The end angle of the arc.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)

Application..::NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)
See Also
CollapseAll image DropDown image

Creates a new geometric arc object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Arc NewArc(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Visual Basic (Declaration)
Public Function NewArc ( _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    xAxis As XYZ, _
    yAxis As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc (
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)

Parameters

center
XYZ
The center of the arc.
radius
Double
The radius of the arc.
startAngle
Double
The start angle of the arc.
endAngle
Double
The end angle of the arc.
xAxis
XYZ
The x axis to define the arc plane. Must be normalized.
yAxis
XYZ
The y axis to define the arc plane. Must be normalized.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewAreaCreationData Method

Application..::NewAreaCreationData Method
CollapseAll image DropDown image

Creates an object which wraps the arguments of Area for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaCreationData NewAreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewAreaCreationData ( _
    areaView As ViewPlan, _
    point As UV _
) As AreaCreationData
Visual C++
public:
AreaCreationData^ NewAreaCreationData (
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
ViewPlan
The view of area element.
point
UV
A point which lies in an enclosed region of area boundary where the new area will reside.

Return Value

The object containing the data needed for area creation.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArray Method

Application..::NewArray Method
CollapseAll image DropDown image

Creates a new instance of a generic Array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Array NewArray()
Visual Basic (Declaration)
Public Function NewArray As Array
Visual C++
public:
Array^ NewArray ()

Return Value

Returns a new instance of a generic Array.

Remarks

Generic arrays can hold any type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

Application..::NewBoundingBoxUV Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewBoundingBoxUV()() | Creates a two-dimensional rectangle, parallel to the coordinate axes.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

Application..::NewBoundingBoxUV Method
CollapseAll image DropDown image

Creates a two-dimensional rectangle, parallel to the coordinate axes.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV()
Visual Basic (Declaration)
Public Function NewBoundingBoxUV As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method (Double, Double, Double, Double)

Application..::NewBoundingBoxUV Method (Double, Double, Double, Double)
See Also
CollapseAll image DropDown image

Creates a two-dimensional rectangle with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic (Declaration)
Public Function NewBoundingBoxUV ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV (
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Double
The first coordinate of min.
min_v
Double
The second coordinate of min.
max_u
Double
The first coordinate of max.
max_v
Double
The second coordinate of max.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBoundingBoxXYZ Method

Application..::NewBoundingBoxXYZ Method
CollapseAll image DropDown image

Creates a three-dimensional rectangular box.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxXYZ NewBoundingBoxXYZ()
Visual Basic (Declaration)
Public Function NewBoundingBoxXYZ As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ NewBoundingBoxXYZ ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCategorySet Method

Application..::NewCategorySet Method
CollapseAll image DropDown image

Creates a new instance of a set specifically for holding category objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategorySet NewCategorySet()
Visual Basic (Declaration)
Public Function NewCategorySet As CategorySet
Visual C++
public:
CategorySet^ NewCategorySet ()

Return Value

Returns a new instance of a Category Set.

Remarks

This type of set is used during the creation of instance and type bindings.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewColor Method

Application..::NewColor Method
CollapseAll image DropDown image

Returns a new color object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color NewColor()
Visual Basic (Declaration)
Public Function NewColor As Color
Visual C++
public:
Color^ NewColor ()

Return Value

The new color oject.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveArray Method

Application..::NewCurveArray Method
CollapseAll image DropDown image

Creates an empty array that can store geometric curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray NewCurveArray()
Visual Basic (Declaration)
Public Function NewCurveArray As CurveArray
Visual C++
public:
CurveArray^ NewCurveArray ()

Return Value

Returns an empty array that can hold geometric curves.

Remarks

This method can be used to create an array that can hold any curve type object. This array can be then passed to methods, such as NewAreaLoad, to represent the geometry for the boundary of the load.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDoubleArray Method

Application..::NewDoubleArray Method
CollapseAll image DropDown image

Creates a new instance of a double array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray NewDoubleArray()
Visual Basic (Declaration)
Public Function NewDoubleArray As DoubleArray
Visual C++
public:
DoubleArray^ NewDoubleArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWF2DExportOptions Method

Application..::NewDWF2DExportOptions Method
CollapseAll image DropDown image

Creates DWF2D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWF2DExportOptions NewDWF2DExportOptions()
Visual Basic (Declaration)
Public Function NewDWF2DExportOptions As DWF2DExportOptions
Visual C++
public:
DWF2DExportOptions^ NewDWF2DExportOptions ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWF3DExportOptions Method

Application..::NewDWF3DExportOptions Method
CollapseAll image DropDown image

Creates DWF3D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWF3DExportOptions NewDWF3DExportOptions()
Visual Basic (Declaration)
Public Function NewDWF3DExportOptions As DWF3DExportOptions
Visual C++
public:
DWF3DExportOptions^ NewDWF3DExportOptions ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFX2DExportOptions Method

Application..::NewDWFX2DExportOptions Method
CollapseAll image DropDown image

Creates DWFX2D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWFX2DExportOptions NewDWFX2DExportOptions()
Visual Basic (Declaration)
Public Function NewDWFX2DExportOptions As DWFX2DExportOptions
Visual C++
public:
DWFX2DExportOptions^ NewDWFX2DExportOptions ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFX3DExportOptions Method

Application..::NewDWFX3DExportOptions Method
CollapseAll image DropDown image

Creates DWFX3D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWFX3DExportOptions NewDWFX3DExportOptions()
Visual Basic (Declaration)
Public Function NewDWFX3DExportOptions As DWFX3DExportOptions
Visual C++
public:
DWFX3DExportOptions^ NewDWFX3DExportOptions ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWGExportOptions Method

Application..::NewDWGExportOptions Method
CollapseAll image DropDown image

Creates DWG Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DWGExportOptions NewDWGExportOptions()
Visual Basic (Declaration)
Public Function NewDWGExportOptions As DWGExportOptions
Visual C++
public:
DWGExportOptions^ NewDWGExportOptions ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementArray Method

Application..::NewElementArray Method
CollapseAll image DropDown image

Returns an array that can hold element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray NewElementArray()
Visual Basic (Declaration)
Public Function NewElementArray As ElementArray
Visual C++
public:
ElementArray^ NewElementArray ()

Return Value

An empty array that can contain any Autodesk Revit element derived objects.

Remarks

The array returned by this method can be used as a general purpose tool for holding ordered lists of any type of element.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementId Method

Application..::NewElementId Method
CollapseAll image DropDown image

Creates a new ElementId object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId NewElementId()
Visual Basic (Declaration)
Public Function NewElementId As ElementId
Visual C++
public:
ElementId NewElementId ()

Return Value

The new ElementId object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementIdSet Method

Application..::NewElementIdSet Method
CollapseAll image DropDown image

Creates a new instance of a set specifically for holding element ids.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet NewElementIdSet()
Visual Basic (Declaration)
Public Function NewElementIdSet As ElementIdSet
Visual C++
public:
ElementIdSet^ NewElementIdSet ()

Return Value

Returns a new Element Id Set.

Remarks

This is a general purpose set for passing element ids to and from methods.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementSet Method

Application..::NewElementSet Method
CollapseAll image DropDown image

Creates a new instance of a set specifically for holding elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewElementSet()
Visual Basic (Declaration)
Public Function NewElementSet As ElementSet
Visual C++
public:
ElementSet^ NewElementSet ()

Return Value

Returns a new Element Set.

Remarks

This is a general purpose set for passing elements to and from methods.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewEllipse Method

Application..::NewEllipse Method
CollapseAll image DropDown image

Creates a new geometric ellipse object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Ellipse NewEllipse(
    XYZ center,
    double radX,
    double radY,
    XYZ xVec,
    XYZ yVec,
    double param0,
    double param1
)
Visual Basic (Declaration)
Public Function NewEllipse ( _
    center As XYZ, _
    radX As Double, _
    radY As Double, _
    xVec As XYZ, _
    yVec As XYZ, _
    param0 As Double, _
    param1 As Double _
) As Ellipse
Visual C++
public:
Ellipse^ NewEllipse (
    XYZ^ center,
    double radX,
    double radY,
    XYZ^ xVec,
    XYZ^ yVec,
    double param0,
    double param1
)

Parameters

center
XYZ
The center of the ellipse.
radX
Double
The x vector radius of the ellipse.Shoud be >0.
radY
Double
The y vector radius of the ellipse.Shoud be >0.
xVec
XYZ
The x axis to define the ellipse plane.
yVec
XYZ
The y axis to define the ellipse plane.xVec must be orthogonal with yVec.
param0
Double
The start angle of the ellipse. Must less than Param1,and greater than -2*PI.
param1
Double
The end angle of the ellipse. Must greater than Param0,and less than 2*PI.

Remarks

The PI represents the value used in Revit internal code, it's accuracy is not the same as MSDN, it's value is 3.14159265358979.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFaceArray Method

Application..::NewFaceArray Method
CollapseAll image DropDown image

Creates a new instance of a face array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FaceArray NewFaceArray()
Visual Basic (Declaration)
Public Function NewFaceArray As FaceArray
Visual C++
public:
FaceArray^ NewFaceArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method

Application..::NewFamilyInstanceCreationData Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of FamilyInstance for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of FamilyInstance for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of FamilyInstance for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of FamilyInstance for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of FamilyInstance for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of FamilyInstance for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of FamilyInstance for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of FamilyInstance for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)

Application..::NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
position
Line
A line on the face defining where the symbol is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)

Application..::NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
StructuralType
Specify if the family instance is structural.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)

Application..::NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Curve
The curve where the instance is based.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)

Application..::NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
location
XYZ
Point on the face where the instance is to be placed.
referenceDirection
XYZ
A vector that defines the direction of the family instance.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)

Application..::NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)

Application..::NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)

Application..::NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

Application..::NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
XYZ
A vector that dictates the direction of certain family instances.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFBXExportOptions Method

Application..::NewFBXExportOptions Method
CollapseAll image DropDown image

Creates 3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FBXExportOptions NewFBXExportOptions()
Visual Basic (Declaration)
Public Function NewFBXExportOptions As FBXExportOptions
Visual C++
public:
FBXExportOptions^ NewFBXExportOptions ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFillPatternSet Method

Application..::NewFillPatternSet Method
CollapseAll image DropDown image

Returns a set that can hold fill pattern objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPatternSet NewFillPatternSet()
Visual Basic (Declaration)
Public Function NewFillPatternSet As FillPatternSet
Visual C++
public:
FillPatternSet^ NewFillPatternSet ()

Return Value

An empty set that can contain fill pattern objects.

Remarks

The set returned by this method can be used as a container for holding fill patterns.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLExportOptions Method

Application..::NewGBXMLExportOptions Method
CollapseAll image DropDown image

Creates Gren-Building XML Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GBXMLExportOptions NewGBXMLExportOptions()
Visual Basic (Declaration)
Public Function NewGBXMLExportOptions As GBXMLExportOptions
Visual C++
public:
GBXMLExportOptions^ NewGBXMLExportOptions ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGeometryOptions Method

Application..::NewGeometryOptions Method
CollapseAll image DropDown image

Creates an object to specify user preferences in parsing of geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Options NewGeometryOptions()
Visual Basic (Declaration)
Public Function NewGeometryOptions As Options
Visual C++
public:
Options^ NewGeometryOptions ()

Return Value

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

Application..::NewInstanceBinding Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewInstanceBinding()() | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

Application..::NewInstanceBinding Method
CollapseAll image DropDown image

Creates a new empty instance binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceBinding NewInstanceBinding()
Visual Basic (Declaration)
Public Function NewInstanceBinding As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding ()

Return Value

Returns a new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method (CategorySet)

Application..::NewInstanceBinding Method (CategorySet)
See Also
CollapseAll image DropDown image

Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceBinding NewInstanceBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewInstanceBinding ( _
    categorySet As CategorySet _
) As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding (
    CategorySet^ categorySet
)

Parameters

categorySet
CategorySet
A set of categories that will be added to the binding.

Return Value

Returns a new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewIntersectionResultArray Method

Application..::NewIntersectionResultArray Method
CollapseAll image DropDown image

Creates a new instance of a IntersectionResult array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IntersectionResultArray NewIntersectionResultArray()
Visual Basic (Declaration)
Public Function NewIntersectionResultArray As IntersectionResultArray
Visual C++
public:
IntersectionResultArray^ NewIntersectionResultArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLine Method

Application..::NewLine Method
CollapseAll image DropDown image

Creates a new bound or unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line NewLine(
    XYZ point,
    XYZ endOrDirection,
    bool bound
)
Visual Basic (Declaration)
Public Function NewLine ( _
    point As XYZ, _
    endOrDirection As XYZ, _
    bound As Boolean _
) As Line
Visual C++
public:
Line^ NewLine (
    XYZ^ point,
    XYZ^ endOrDirection,
    bool bound
)

Parameters

point
XYZ
A start point or a point through which the line will pass.
endOrDirection
XYZ
An end point of a vector for the direction of the line.
bound
Boolean
Set to True if you wish the line to be bound or False is the line is to be infinite.

Return Value

Returns a new bounded or unbounded line object.

Remarks

If the bound parameter is False then the point parameter is considered to be a point on the line and the endOrDirection parameter is considered to be a directional vector. If the bound parameter is True then the point parameter is considered to be the start of the line and the endOrDirection parameter is considered to be the end of the line.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineBound Method

Application..::NewLineBound Method
CollapseAll image DropDown image

Creates a new bounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line NewLineBound(
    XYZ start,
    XYZ end
)
Visual Basic (Declaration)
Public Function NewLineBound ( _
    start As XYZ, _
    end As XYZ _
) As Line
Visual C++
public:
Line^ NewLineBound (
    XYZ^ start,
    XYZ^ end
)

Parameters

start
XYZ
A start point for the line.
end
XYZ
An end point for the line.

Return Value

Returns a new bounded line object.

Remarks

The new line is bounded and has the start parameter as the start point and the end parameter as the end point.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLinePatternSet Method

Application..::NewLinePatternSet Method
CollapseAll image DropDown image

Returns a set that can hold line pattern objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinePatternSet NewLinePatternSet()
Visual Basic (Declaration)
Public Function NewLinePatternSet As LinePatternSet
Visual C++
public:
LinePatternSet^ NewLinePatternSet ()

Return Value

An empty set that can contain line pattern objects.

Remarks

The set returned by this method can be used as a container for holding line patterns.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineUnbound Method

Application..::NewLineUnbound Method
CollapseAll image DropDown image

Creates a new unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line NewLineUnbound(
    XYZ point,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewLineUnbound ( _
    point As XYZ, _
    direction As XYZ _
) As Line
Visual C++
public:
Line^ NewLineUnbound (
    XYZ^ point,
    XYZ^ direction
)

Parameters

point
XYZ
A point through which the line will pass.
direction
XYZ
A vector for the direction of the line.

Return Value

Returns a new unbounded line object.

Remarks

The line returned will be infinite in length and pass through the point provided in the specified direction. This method is useful for generating an axis around which an element can be rotated.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCaseArray Method

Application..::NewLoadCaseArray Method
CollapseAll image DropDown image

Creates a new instance of a LoadCase array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCaseArray NewLoadCaseArray()
Visual Basic (Declaration)
Public Function NewLoadCaseArray As LoadCaseArray
Visual C++
public:
LoadCaseArray^ NewLoadCaseArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCombinationArray Method

Application..::NewLoadCombinationArray Method
CollapseAll image DropDown image

Creates a new instance of a LoadCombination array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCombinationArray NewLoadCombinationArray()
Visual Basic (Declaration)
Public Function NewLoadCombinationArray As LoadCombinationArray
Visual C++
public:
LoadCombinationArray^ NewLoadCombinationArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadUsageArray Method

Application..::NewLoadUsageArray Method
CollapseAll image DropDown image

Creates a new instance of a LoadUsage array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadUsageArray NewLoadUsageArray()
Visual Basic (Declaration)
Public Function NewLoadUsageArray As LoadUsageArray
Visual C++
public:
LoadUsageArray^ NewLoadUsageArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewMap Method

Application..::NewMap Method
CollapseAll image DropDown image

Creates a new instance of a generic Map.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Map NewMap()
Visual Basic (Declaration)
Public Function NewMap As Map
Visual C++
public:
Map^ NewMap ()

Return Value

Returns a new instance of a generic Map.

Remarks

Generic maps can link any type of object to any other type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewMaterialSet Method

Application..::NewMaterialSet Method
CollapseAll image DropDown image

Create a new instance of MaterialSet.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialSet NewMaterialSet()
Visual Basic (Declaration)
Public Function NewMaterialSet As MaterialSet
Visual C++
public:
MaterialSet^ NewMaterialSet ()

Return Value

The newly created MaterialSet instance.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewNurbSpline Method

Application..::NewNurbSpline Method
CollapseAll image DropDown image

Creates a new geometric nurbSpline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public NurbSpline NewNurbSpline(
    XYZArray ctrlPoints,
    DoubleArray weights,
    DoubleArray knots,
    int nDegree,
    bool bClosed,
    bool bRational
)
Visual Basic (Declaration)
Public Function NewNurbSpline ( _
    ctrlPoints As XYZArray, _
    weights As DoubleArray, _
    knots As DoubleArray, _
    nDegree As Integer, _
    bClosed As Boolean, _
    bRational As Boolean _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline (
    XYZArray^ ctrlPoints,
    DoubleArray^ weights,
    DoubleArray^ knots,
    int nDegree,
    bool bClosed,
    bool bRational
)

Parameters

ctrlPoints
XYZArray
The control points of the nurbSpline.
weights
DoubleArray
The weights of the nurbSpline.
knots
DoubleArray
The knots of the nurbSpline.
nDegree
Int32
The degree of the nurbSpline.
bClosed
Boolean
The nurbSpline is closed or not.
bRational
Boolean
The nurbSpline is rational or no rational.

Remarks

If bRational is true,the size of ctrlPoints must equal to weights's,otherwise throw ArgumentException. There is a rule like that the size of knots equals to the sum of nDegree, ctrlPoints.size and 1, and the first nDegree+1 elements in the knots always are zero.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewParameterListItemArray Method

Application..::NewParameterListItemArray Method
CollapseAll image DropDown image

Returns an array that can hold list items of external list parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItemArray NewParameterListItemArray()
Visual Basic (Declaration)
Public Function NewParameterListItemArray As ParameterListItemArray
Visual C++
public:
ParameterListItemArray^ NewParameterListItemArray ()

Return Value

An empty array that contain list items whose type is Revit::Parameters::ParameterListItem.

Remarks

The array returned by this method can be used as a general purpose tool for holding ordered list items.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPlane Method

Application..::NewPlane Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewPlane(XYZ, XYZ) | Creates a new geometric plane object.
Public method | NewPlane(XYZ, XYZ, XYZ) | Creates a new geometric plane object.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ)

Application..::NewPlane Method (XYZ, XYZ)
See Also
CollapseAll image DropDown image

Creates a new geometric plane object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane NewPlane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    norm As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane (
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
XYZ
X vector of the plane coordinate system.
origin
XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

Remarks

The new plane is created with a normal vectors and an origin.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ, XYZ)

Application..::NewPlane Method (XYZ, XYZ, XYZ)
See Also
CollapseAll image DropDown image

Creates a new geometric plane object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane NewPlane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane (
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
XYZ
X vector of the plane coordinate system.
yVec
XYZ
Y vector of the plane coordinate system.
origin
XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

Remarks

The new plane is created with two coordinate vectors and an origin.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPostedErrorArray Method

Application..::NewPostedErrorArray Method
CollapseAll image DropDown image

Creates a array to store instances of PostedError.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PostedErrorArray NewPostedErrorArray()
Visual Basic (Declaration)
Public Function NewPostedErrorArray As PostedErrorArray
Visual C++
public:
PostedErrorArray^ NewPostedErrorArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method

Application..::NewProfiledWallCreationData Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewProfiledWallCreationData(CurveArray, Boolean) | Creates an object which wraps the arguments of Wall for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Creates an object which wraps the arguments of Wall for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Creates an object which wraps the arguments of Wall for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, Boolean)

Application..::NewProfiledWallCreationData Method (CurveArray, Boolean)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)

Application..::NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)

Application..::NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.
normal
XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProjectPosition Method

Application..::NewProjectPosition Method
CollapseAll image DropDown image

Creates a new project position object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectPosition NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Function NewProjectPosition ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
) As ProjectPosition
Visual C++
public:
ProjectPosition^ NewProjectPosition (
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Double
East to West offset in feet.
ns
Double
North to South offset in feet.
elevation
Double
Elevation above sea level in feet.
angle
Double
Rotation angle away from true north in the range of -PI to +PI.

Remarks

This object contains offset information and is used by the project location object for setting the project location relative to the site location. Measurements are in feet and radians.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method

Application..::NewRectangularWallCreationData Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewRectangularWallCreationData(Curve, Level, Boolean) | Creates an object which wraps the arguments of Wall for batch creation
Public method | NewRectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates an object which wraps the arguments of Wall for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, Level, Boolean)

Application..::NewRectangularWallCreationData Method (Curve, Level, Boolean)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData (
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

Application..::NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData (
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
height
Double
The height of the wall.
offset
Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewReferenceArray Method

Application..::NewReferenceArray Method
CollapseAll image DropDown image

Creates a new instance of a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferenceArray NewReferenceArray()
Visual Basic (Declaration)
Public Function NewReferenceArray As ReferenceArray
Visual C++
public:
ReferenceArray^ NewReferenceArray ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRoomCreationData Method

Application..::NewRoomCreationData Method
CollapseAll image DropDown image

Creates an object which wraps the arguments of Room for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomCreationData NewRoomCreationData(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoomCreationData ( _
    level As Level, _
    point As UV _
) As RoomCreationData
Visual C++
public:
RoomCreationData^ NewRoomCreationData (
    Level^ level,
    UV^ point
)

Parameters

level
Level
- The level on which the room is to exist.
point
UV
A 2D point the dictates the location on that specified level.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSelElementSet Method

Application..::NewSelElementSet Method
CollapseAll image DropDown image

Creates a new instance of a set specifically for holding selected elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SelElementSet NewSelElementSet()
Visual Basic (Declaration)
Public Function NewSelElementSet As SelElementSet
Visual C++
public:
SelElementSet^ NewSelElementSet ()

Return Value

Returns a new Element Set.

Remarks

If the user wants to change the selected Element with the API, the instance SelElementSet must be created to do the operation of Add and Remove.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSet Method

Application..::NewSet Method
CollapseAll image DropDown image

Creates a new instance of a generic Set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Set NewSet()
Visual Basic (Declaration)
Public Function NewSet As Set
Visual C++
public:
Set^ NewSet ()

Return Value

Returns a new instance of a generic Set.

Remarks

Generic sets can hold any type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSpaceSet Method

Application..::NewSpaceSet Method
CollapseAll image DropDown image

Creates a new instance of a space set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceSet NewSpaceSet()
Visual Basic (Declaration)
Public Function NewSpaceSet As SpaceSet
Visual C++
public:
SpaceSet^ NewSpaceSet ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewStringStringMap Method

Application..::NewStringStringMap Method
CollapseAll image DropDown image

Creates a new map that maps one string to another string.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringStringMap NewStringStringMap()
Visual Basic (Declaration)
Public Function NewStringStringMap As StringStringMap
Visual C++
public:
StringStringMap^ NewStringStringMap ()

Return Value

A map that maps one string to another.

Remarks

This is a general purpose string to string mapping which can be used for generating Autodesk Revit library paths.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method

Application..::NewTextNoteCreationData Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates an object which wraps the arguments of TextNote for batch creation
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates an object which wraps the arguments of TextNote for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

Application..::NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of TextNote for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData (
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
View
The View for TextNote.
origin
XYZ
Origin of the TextNote.
baseVec
XYZ
BaseVec parameter of the TextNote.
upVec
XYZ
UpVec parameter of the TextNote.
lineWidth
Double
Line width of the out rectangle.
textAlign
TextAlignFlags
Align style.
leaderType
TextNoteLeaderTypes
Leader type as straight or arc.
leaderStyle
TextNoteLeaderStyles
Leader style.
leaderEnd
XYZ
End point of the leader.
leaderElbow
XYZ
Elbow point of the leader.
strText
String
Text.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

Application..::NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
See Also
CollapseAll image DropDown image

Creates an object which wraps the arguments of TextNote for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData (
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
View
The View for TextNote.
origin
XYZ
Origin of the TextNote.
baseVec
XYZ
BaseVec parameter of the TextNote.
upVec
XYZ
UpVec parameter of the TextNote.
lineWidth
Double
Line width of the out rectangle.
textAlign
TextAlignFlags
Align style.
strText
String
Text.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

Application..::NewTypeBinding Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewTypeBinding()() | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

Application..::NewTypeBinding Method
CollapseAll image DropDown image

Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeBinding NewTypeBinding()
Visual Basic (Declaration)
Public Function NewTypeBinding As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding ()

Return Value

Returns a new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTypeBinding Method (CategorySet)

Application..::NewTypeBinding Method (CategorySet)
See Also
CollapseAll image DropDown image

Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewTypeBinding ( _
    categorySet As CategorySet _
) As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding (
    CategorySet^ categorySet
)

Parameters

categorySet
CategorySet
A set of categories that will be added to the binding.

Return Value

Returns a new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewUV Method

Application..::NewUV Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewUV()() | Creates a UV object representing coordinates in 2-space.
Public method | NewUV(UV) | Creates a UV object representing coordinates in 2-space with supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewUV Method

Application..::NewUV Method
CollapseAll image DropDown image

Creates a UV object representing coordinates in 2-space.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV NewUV()
Visual Basic (Declaration)
Public Function NewUV As UV
Visual C++
public:
UV^ NewUV ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewUV Method (UV)

Application..::NewUV Method (UV)
See Also
CollapseAll image DropDown image

Creates a UV object representing coordinates in 2-space with supplied UV object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV NewUV(
    UV uv
)
Visual Basic (Declaration)
Public Function NewUV ( _
    uv As UV _
) As UV
Visual C++
public:
UV^ NewUV (
    UV^ uv
)

Parameters

uv
UV
The supplied UV object

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewUV Method (Double, Double)

Application..::NewUV Method (Double, Double)
See Also
CollapseAll image DropDown image

Creates a UV object representing coordinates in 2-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV NewUV(
    double u,
    double v
)
Visual Basic (Declaration)
Public Function NewUV ( _
    u As Double, _
    v As Double _
) As UV
Visual C++
public:
UV^ NewUV (
    double u,
    double v
)

Parameters

u
Double
The first coordinate.
v
Double
The second coordinate.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the U or V property.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewViewSet Method

Application..::NewViewSet Method
CollapseAll image DropDown image

Creates a new instance of a View set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSet NewViewSet()
Visual Basic (Declaration)
Public Function NewViewSet As ViewSet
Visual C++
public:
ViewSet^ NewViewSet ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZ Method

Application..::NewXYZ Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewXYZ()() | Creates a XYZ object representing coordinates in 3-space.
Public method | NewXYZ(XYZ) | Creates a XYZ object with supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewXYZ Method

Application..::NewXYZ Method
CollapseAll image DropDown image

Creates a XYZ object representing coordinates in 3-space.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ NewXYZ()
Visual Basic (Declaration)
Public Function NewXYZ As XYZ
Visual C++
public:
XYZ^ NewXYZ ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZ Method (XYZ)

Application..::NewXYZ Method (XYZ)
See Also
CollapseAll image DropDown image

Creates a XYZ object with supplied XYZ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ NewXYZ(
    XYZ xyz
)
Visual Basic (Declaration)
Public Function NewXYZ ( _
    xyz As XYZ _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ (
    XYZ^ xyz
)

Parameters

xyz
XYZ
The supplied XYZ object

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZ Method (Double, Double, Double)

Application..::NewXYZ Method (Double, Double, Double)
See Also
CollapseAll image DropDown image

Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ NewXYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Function NewXYZ ( _
    x As Double, _
    y As Double, _
    z As Double _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ (
    double x,
    double y,
    double z
)

Parameters

x
Double
The first coordinate.
y
Double
The second coordinate.
z
Double
The third coordinate.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZArray Method

Application..::NewXYZArray Method
CollapseAll image DropDown image

Generate an empty array that can hold XYZ point objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray NewXYZArray()
Visual Basic (Declaration)
Public Function NewXYZArray As XYZArray
Visual C++
public:
XYZArray^ NewXYZArray ()

Return Value

An empty array capable of holding XYZ points or vectors.

Remarks

This method can be used to create an array that can be used for representing ordered points, such as those for the outline of a piece of geometry..

See Also

Application Class
Autodesk.Revit.Creation Namespace


Application Properties
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Filter | Gives access to an object for creating different types of filters.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application
Autodesk.Revit.Creation Namespace


Filter Property

Application..::Filter Property
CollapseAll image DropDown image

Gives access to an object for creating different types of filters.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter Filter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Filter As Filter
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
}

Field Value

The object to use for creating new filters.

See Also

Application Class
Autodesk.Revit.Creation Namespace


AreaCreationData Class
See Also Members
CollapseAll image DropDown image

A class which wraps the arguments of Area for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("97E88AB6-2DFB-4699-A83E-02B3ACB53FE9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AreaCreationData
Visual Basic (Declaration)
<GuidAttribute("97E88AB6-2DFB-4699-A83E-02B3ACB53FE9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AreaCreationData
Visual C++
[GuidAttribute(L"97E88AB6-2DFB-4699-A83E-02B3ACB53FE9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaCreationData

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Creation..::AreaCreationData

See Also

AreaCreationData Members
Autodesk.Revit.Creation Namespace


AreaCreationData Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaCreationData
Visual Basic (Declaration)
Public Class AreaCreationData
Visual C++
public ref class AreaCreationData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaCreationDataAreaCreationDataNew | The data needed to create a new area

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | TagPoint | Specify the location of the area tag.

See Also

AreaCreationData
Autodesk.Revit.Creation Namespace


AreaCreationData Constructor
CollapseAll image DropDown image

The data needed to create a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Sub New ( _
    areaView As ViewPlan, _
    point As UV _
)
Visual C++
public:
AreaCreationData (
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
ViewPlan
The view of area element.
point
UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaCreationData
Visual Basic (Declaration)
Public Class AreaCreationData
Visual C++
public ref class AreaCreationData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | TagPoint | Specify the location of the area tag.

See Also

AreaCreationData
Autodesk.Revit.Creation Namespace


TagPoint Property

AreaCreationData..::TagPoint Property
CollapseAll image DropDown image

Specify the location of the area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV TagPoint{ get; set;}
Visual Basic (Declaration)
Public Property TagPoint As UV
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


Document Class
See Also Members
CollapseAll image DropDown image

The Document Creation object is used to create new instances of elements within the Autodesk Revit project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DB1636EA-F122-4354-B984-9BDBB4D0218A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Document : APIObject
Visual Basic (Declaration)
<GuidAttribute("DB1636EA-F122-4354-B984-9BDBB4D0218A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Document _
    Inherits APIObject
Visual C++
[GuidAttribute(L"DB1636EA-F122-4354-B984-9BDBB4D0218A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Document : public APIObject

Remarks

The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly. The object can create a limited number of types, which is expected to increase as the API matures.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Creation..::Document

See Also

Document Members
Autodesk.Revit.Creation Namespace


Document Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DocumentDocumentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAnnotationSymbol | Add a new instance of a Annotation Symbol into the Autodesk Revit project, using a location and a symbol.
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions | Overloaded.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreaLoad | Overloaded.
Public method | NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
Public method | NewAreas |
Public method | NewAreaTag | Creates a new area tag.
Public method | NewAreaViewPlan | Creates a new view for the new area.
Public method | NewBeamSystem | Overloaded.
Public method | NewCurtainSystem | Overloaded.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension | Overloaded.
Public method | NewElectricalSystem | Overloaded.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance | Overloaded.
Public method | NewFamilyInstances |
Public method | NewFascia | Overloaded.
Public method | NewFloor | Overloaded.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFoundationWall | Creates a new continuous footing object.
Public method | NewGrid | Overloaded.
Public method | NewGrids | Creates new grid lines.
Public method | NewGroup | Creates a new type of group.
Public method | NewGutter | Overloaded.
Public method | NewLevel | Creates a new level.
Public method | NewLineBoundaryConditions | Overloaded.
Public method | NewLineLoad | Overloaded.
Public method | NewLoadCase | Creates a new instance of a LoadCase element within the project.
Public method | NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
Public method | NewLoadNature | Creates a new instance of a LoadNature element within the project.
Public method | NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewOpening | Overloaded.
Public method | NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewPointLoad | Overloaded.
Public method | NewRebar | Overloaded.
Public method | NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | NewRoom | Overloaded.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms | Overloaded.
Public method | NewRoomTag | Creates a new RoomTag.
Public method | NewSketchPlane | Creates a new sketch plane.
Public method | NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
Public method | NewSlabEdge | Overloaded.
Public method | NewSpace | Overloaded.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces | Overloaded.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTag | Creates a new IndependentTag Element.
Public method | NewTextNote | Overloaded.
Public method | NewTextNotes |
Public method | NewTruss | Creates a New Truss.
Public method | NewView3D | Creates a new 3D view.
Public method | NewViewDrafting | Creates a new drafting view.
Public method | NewViewPlan | Creates a plan view based on the specified level.
Public method | NewViewSection | Creates a new section view.
Public method | NewViewSheet | Creates a new sheet view.
Public method | NewWall | Overloaded.
Public method | NewWalls | Overloaded.
Public method | NewWire | Creates a new wire element.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit project, using a location and a group type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document
Autodesk.Revit.Creation Namespace


Document Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Document ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Methods
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAnnotationSymbol | Add a new instance of a Annotation Symbol into the Autodesk Revit project, using a location and a symbol.
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions | Overloaded.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreaLoad | Overloaded.
Public method | NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
Public method | NewAreas |
Public method | NewAreaTag | Creates a new area tag.
Public method | NewAreaViewPlan | Creates a new view for the new area.
Public method | NewBeamSystem | Overloaded.
Public method | NewCurtainSystem | Overloaded.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension | Overloaded.
Public method | NewElectricalSystem | Overloaded.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance | Overloaded.
Public method | NewFamilyInstances |
Public method | NewFascia | Overloaded.
Public method | NewFloor | Overloaded.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFoundationWall | Creates a new continuous footing object.
Public method | NewGrid | Overloaded.
Public method | NewGrids | Creates new grid lines.
Public method | NewGroup | Creates a new type of group.
Public method | NewGutter | Overloaded.
Public method | NewLevel | Creates a new level.
Public method | NewLineBoundaryConditions | Overloaded.
Public method | NewLineLoad | Overloaded.
Public method | NewLoadCase | Creates a new instance of a LoadCase element within the project.
Public method | NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
Public method | NewLoadNature | Creates a new instance of a LoadNature element within the project.
Public method | NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewOpening | Overloaded.
Public method | NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewPointLoad | Overloaded.
Public method | NewRebar | Overloaded.
Public method | NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | NewRoom | Overloaded.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms | Overloaded.
Public method | NewRoomTag | Creates a new RoomTag.
Public method | NewSketchPlane | Creates a new sketch plane.
Public method | NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
Public method | NewSlabEdge | Overloaded.
Public method | NewSpace | Overloaded.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces | Overloaded.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTag | Creates a new IndependentTag Element.
Public method | NewTextNote | Overloaded.
Public method | NewTextNotes |
Public method | NewTruss | Creates a New Truss.
Public method | NewView3D | Creates a new 3D view.
Public method | NewViewDrafting | Creates a new drafting view.
Public method | NewViewPlan | Creates a plan view based on the specified level.
Public method | NewViewSection | Creates a new section view.
Public method | NewViewSheet | Creates a new sheet view.
Public method | NewWall | Overloaded.
Public method | NewWalls | Overloaded.
Public method | NewWire | Creates a new wire element.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit project, using a location and a group type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Document
Autodesk.Revit.Creation Namespace


NewAnnotationSymbol Method

Document..::NewAnnotationSymbol Method
CollapseAll image DropDown image

Add a new instance of a Annotation Symbol into the Autodesk Revit project, using a location and a symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbol NewAnnotationSymbol(
    XYZ location,
    AnnotationSymbolType annotationSymbolType,
    View specView
)
Visual Basic (Declaration)
Public Function NewAnnotationSymbol ( _
    location As XYZ, _
    annotationSymbolType As AnnotationSymbolType, _
    specView As View _
) As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ NewAnnotationSymbol (
    XYZ^ location,
    AnnotationSymbolType^ annotationSymbolType,
    View^ specView
)

Parameters

location
XYZ
The physical location where the annotation symbol is to be placed.
annotationSymbolType
AnnotationSymbolType
A annotation symbol type object that represents the type of the instance that is to be inserted.
specView
View
a 2D view which display the annotation symbol.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewArea Method

Document..::NewArea Method
CollapseAll image DropDown image

Creates a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Area NewArea(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewArea ( _
    areaView As ViewPlan, _
    point As UV _
) As Area
Visual C++
public:
Area^ NewArea (
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
ViewPlan
The view of area element.
point
UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method

Document..::NewAreaBoundaryConditions Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions Element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions Element.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

Document..::NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
See Also
CollapseAll image DropDown image

Creates a new Area BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions (
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

hostElement
Element
The Geometry reference to Wall, Slab or Slab Foundation.
X_Translation
TranslationRotationValue
Translation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_TranslationSpringModulus
Double
Translation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Translation
TranslationRotationValue
Translation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_TranslationSpringModulus
Double
Translation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Translation
TranslationRotationValue
Translation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_TranslationSpringModulus
Double
Translation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

Document..::NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
See Also
CollapseAll image DropDown image

Creates a new Area BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions (
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

reference
Reference
The Geometry reference to Walls, Slabs or Slab Foundations.
X_Translation
TranslationRotationValue
Translation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_TranslationSpringModulus
Double
Translation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Translation
TranslationRotationValue
Translation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_TranslationSpringModulus
Double
Translation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Translation
TranslationRotationValue
Translation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_TranslationSpringModulus
Double
Translation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaBoundaryLine Method

Document..::NewAreaBoundaryLine Method
CollapseAll image DropDown image

Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
    SketchPlane plan,
    Curve geometryCurve,
    ViewPlan areaView
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryLine ( _
    plan As SketchPlane, _
    geometryCurve As Curve, _
    areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine (
    SketchPlane^ plan,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)

Parameters

plan
SketchPlane
The sketch plan
geometryCurve
Curve
The geometry curve on which the boundary line are
areaView
ViewPlan
The View for the new Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaLoad Method

Document..::NewAreaLoad Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewAreaLoad(Element, XYZ, Boolean, AreaLoadType) | Creates a new instance of a AreaLoad element within the project.
Public method | NewAreaLoad(XYZArray, XYZ, Boolean, AreaLoadType) | Creates a new instance of a AreaLoad element with polygonal shape within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[](), array<Int32>[](), XYZArray, Boolean, AreaLoadType) | Creates a new instance of a AreaLoad element within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[](), array<Int32>[](), XYZ, XYZ, XYZ, Boolean, AreaLoadType) | Creates a new instance of a AreaLoad element within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)

Document..::NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)
See Also
CollapseAll image DropDown image

Creates a new instance of a AreaLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad NewAreaLoad(
    Element host,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    host As Element, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad (
    Element^ host,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

host
Element
The host element (Floor or Wall) of the AreaLoad application.
force
XYZ
The 3d area force applied to the first reference point.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
AreaLoadType

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (XYZArray, XYZ, Boolean, AreaLoadType)

Document..::NewAreaLoad Method (XYZArray, XYZ, Boolean, AreaLoadType)
See Also
CollapseAll image DropDown image

Creates a new instance of a AreaLoad element with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad NewAreaLoad(
    XYZArray points,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    points As XYZArray, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad (
    XYZArray^ points,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

points
XYZArray
Vertexes of AreaLoad shape polygon.
force
XYZ
The applied 3d area force.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
AreaLoadType

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], XYZArray, Boolean, AreaLoadType)

Document..::NewAreaLoad Method (CurveArray, array<Int32>[](), array<Int32>[](), XYZArray, Boolean, AreaLoadType)
See Also
CollapseAll image DropDown image

Creates a new instance of a AreaLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    XYZArray forces,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    forces As XYZArray, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad (
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    XYZArray^ forces,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
CurveArray
An array of curves that define the shape of the area load curves.
refPntIdxs
array< Int32 >[]()
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
array< Int32 >[]()
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
forces
XYZArray
The 3d area forces applied to each of the reference points in the refPntIdxs array.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
AreaLoadType

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application. The size of the refPntIdxs, ends, and forces arrays must be the same, and a maximum of 3 values is permitted.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], XYZ, XYZ, XYZ, Boolean, AreaLoadType)

Document..::NewAreaLoad Method (CurveArray, array<Int32>[](), array<Int32>[](), XYZ, XYZ, XYZ, Boolean, AreaLoadType)
See Also
CollapseAll image DropDown image

Creates a new instance of a AreaLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    XYZ force0,
    XYZ force1,
    XYZ force2,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    force0 As XYZ, _
    force1 As XYZ, _
    force2 As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad (
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    XYZ^ force0,
    XYZ^ force1,
    XYZ^ force2,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
CurveArray
An array of curves that define the shape of the area load.
refPntIdxs
array< Int32 >[]()
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
array< Int32 >[]()
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
force0
XYZ
The 3d area force applied to the first reference point.
force1
XYZ
The 3d area force applied to the second reference point. Ignored if only one or two reference points are supplied.
force2
XYZ
The 3d area force applied to the third reference point. Ignored if only one or two reference points are supplied.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
AreaLoadType

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application. The size of the refPntIdxs and ends arrays must be the same, and a maximum of 3 values is permitted.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaReinforcement Method

Document..::NewAreaReinforcement Method
CollapseAll image DropDown image

Creates a new instance of an Area Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaReinforcement NewAreaReinforcement(
    Element host,
    CurveArray curves,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewAreaReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    direction As XYZ _
) As AreaReinforcement
Visual C++
public:
AreaReinforcement^ NewAreaReinforcement (
    Element^ host,
    CurveArray^ curves,
    XYZ^ direction
)

Parameters

host
Element
The element to which the Area Reinforcement belongs. The element must be a structural floor or wall.
curves
CurveArray
An array of curves that define the boundary of the area. They must belong to the top face of the floor or the exterior face of the wall.
direction
XYZ

Return Value

If successful, NewAreaReinforcement returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreas Method

Document..::NewAreas Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public ElementSet NewAreas(
    List<AreaCreationData> dataList
)
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Function NewAreas ( _
    dataList As List(Of AreaCreationData) _
) As ElementSet
Visual C++
[ComVisibleAttribute(false)]
public:
ElementSet^ NewAreas (
    List<AreaCreationData^>^ dataList
)

Parameters

dataList
List <(Of < AreaCreationData >)>

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaTag Method

Document..::NewAreaTag Method
CollapseAll image DropDown image

Creates a new area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaTag NewAreaTag(
    ViewPlan areaView,
    Area room,
    UV point
)
Visual Basic (Declaration)
Public Function NewAreaTag ( _
    areaView As ViewPlan, _
    room As Area, _
    point As UV _
) As AreaTag
Visual C++
public:
AreaTag^ NewAreaTag (
    ViewPlan^ areaView,
    Area^ room,
    UV^ point
)

Parameters

areaView
ViewPlan
The area view
room
Area
point
UV
The position of the area tag

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaViewPlan Method

Document..::NewAreaViewPlan Method
CollapseAll image DropDown image

Creates a new view for the new area.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewPlan NewAreaViewPlan(
    string pViewName,
    Level pLevel,
    AreaElemType areaElemType
)
Visual Basic (Declaration)
Public Function NewAreaViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    areaElemType As AreaElemType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewAreaViewPlan (
    String^ pViewName,
    Level^ pLevel,
    AreaElemType areaElemType
)

Parameters

pViewName
String
The name of new created view
pLevel
Level
areaElemType
AreaElemType
The type of area element

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewBeamSystem Method

Document..::NewBeamSystem Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewBeamSystem(CurveArray) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, XYZ) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray)

Document..::NewBeamSystem Method (CurveArray)
See Also
CollapseAll image DropDown image

Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem (
    CurveArray^ profile
)

Parameters

profile
CurveArray
The profile is the profile of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, XYZ)

Document..::NewBeamSystem Method (CurveArray, XYZ)
See Also
CollapseAll image DropDown image

Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    direction As XYZ _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem (
    CurveArray^ profile,
    XYZ^ direction
)

Parameters

profile
CurveArray
The profile is the profile of the BeamSystem.
direction
XYZ
The direction is the direction of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)

Document..::NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)
See Also
CollapseAll image DropDown image

Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem (
    CurveArray^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
CurveArray
The profile of the BeamSystem.
sketchPlane
SketchPlane
The work plane of the BeamSystem.
direction
XYZ
The direction is the direction of the BeamSystem.
is3d
Boolean
If the BeamSystem is 3D, the inputted sketchPlane must be a level, or an exception will be thrown out.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method

Document..::NewCurtainSystem Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewCurtainSystem(FaceArray, CurtainSystemType) | Creates a new CurtainSystem element.
Public method | NewCurtainSystem(ReferenceArray, CurtainSystemType) | Creates a new CurtainSystem element.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (FaceArray, CurtainSystemType)

Document..::NewCurtainSystem Method (FaceArray, CurtainSystemType)
See Also
CollapseAll image DropDown image

Creates a new CurtainSystem element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As FaceArray, _
    curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem (
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is null. The size of faces is zero.
System..::InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (ReferenceArray, CurtainSystemType)

Document..::NewCurtainSystem Method (ReferenceArray, CurtainSystemType)
See Also
CollapseAll image DropDown image

Creates a new CurtainSystem element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewCurtainSystem(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As ReferenceArray, _
    curtainSystemType As CurtainSystemType _
) As ElementSet
Visual C++
public:
ElementSet^ NewCurtainSystem (
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is null. The size of faces is zero.
System..::InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewDetailCurve Method

Document..::NewDetailCurve Method
CollapseAll image DropDown image

Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewDetailCurve ( _
    view As View, _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As DetailCurve
Visual C++
public:
DetailCurve^ NewDetailCurve (
    View^ view,
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

view
View
The view in which the detail curve is to be visible.
geometryCurve
Curve
The internal geometry curve for detail curve. It should be a bound curve.
sketchPlane
SketchPlane
The sketch plane this new detail curve resides in.

Return Value

If successful a new detail curve element. Otherwise null pointer.

Remarks

Different type of detail curve element will be returned according to the type of geometry curve.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewDetailCurveArray Method

Document..::NewDetailCurveArray Method
CollapseAll image DropDown image

Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailCurveArray NewDetailCurveArray(
    View view,
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewDetailCurveArray ( _
    view As View, _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ NewDetailCurveArray (
    View^ view,
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

view
View
The view in which the detail curves are to be visible.
geometryCurveArray
CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.
sketchPlane
SketchPlane
The sketch plane this new detail curves resides in.

Return Value

If successful an array of new detail curve elements. Otherwise null pointer.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewDimension Method

Document..::NewDimension Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewDimension(View, Line, ReferenceArray) | Generate a new linear dimension object within the project using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Generate a new linear dimension object within the project using the specified dimension style.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray)

Document..::NewDimension Method (View, Line, ReferenceArray)
See Also
CollapseAll image DropDown image

Generate a new linear dimension object within the project using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewDimension (
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
View
The view in which the dimension is to be visible.
line
Line
The line drawn for the dimension.
references
ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

If successful a new dimension object, otherwise Nothing.

Remarks

The currently user set default style is used for the created dimension.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray, DimensionType)

Document..::NewDimension Method (View, Line, ReferenceArray, DimensionType)
See Also
CollapseAll image DropDown image

Generate a new linear dimension object within the project using the specified dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewDimension (
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
View
The view in which the dimension is to be visible.
line
Line
The line drawn for the dimension.
references
ReferenceArray
An array of geometric references to which the dimension is to be bound.
dimensionType
DimensionType
The dimension style to be used for the dimension.

Return Value

If successful a new dimension object, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method

Document..::NewElectricalSystem Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewElectricalSystem(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.
Public method | NewElectricalSystem(ElementSet, ElectricalSystemType) | Creates a new MEP Electrical System element.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (Connector, ElectricalSystemType)

Document..::NewElectricalSystem Method (Connector, ElectricalSystemType)
See Also
CollapseAll image DropDown image

Creates a new MEP Electrical System element from an unused Connector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    Connector connector,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    connector As Connector, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem (
    Connector^ connector,
    ElectricalSystemType elecSysType
)

Parameters

connector
Connector
The Connector to create this Electrical System.
elecSysType
ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
System..::InvalidOperationException | Thrown when the electrical system cannot be created by these input connector.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (ElementSet, ElectricalSystemType)

Document..::NewElectricalSystem Method (ElementSet, ElectricalSystemType)
See Also
CollapseAll image DropDown image

Creates a new MEP Electrical System element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    ElementSet electComponents,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    electComponents As ElementSet, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem (
    ElementSet^ electComponents,
    ElectricalSystemType elecSysType
)

Parameters

electComponents
ElementSet
The electrical components in this system.
elecSysType
ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
System..::InvalidOperationException | Thrown when the electrical system cannot be created by these input electrical components.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewExtrusionRoof Method

Document..::NewExtrusionRoof Method
CollapseAll image DropDown image

Creates a new Extrusion Roof.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExtrusionRoof NewExtrusionRoof(
    CurveArray profile,
    ReferencePlane refPlane,
    Level level,
    RoofType roofType,
    double extrusionStart,
    double extrusionEnd
)
Visual Basic (Declaration)
Public Function NewExtrusionRoof ( _
    profile As CurveArray, _
    refPlane As ReferencePlane, _
    level As Level, _
    roofType As RoofType, _
    extrusionStart As Double, _
    extrusionEnd As Double _
) As ExtrusionRoof
Visual C++
public:
ExtrusionRoof^ NewExtrusionRoof (
    CurveArray^ profile,
    ReferencePlane^ refPlane,
    Level^ level,
    RoofType^ roofType,
    double extrusionStart,
    double extrusionEnd
)

Parameters

profile
CurveArray
The profile of the extrusion roof.
refPlane
ReferencePlane
The work plane for the extrusion roof.
level
Level
The level of the extrusion roof.
roofType
RoofType
Type of the extrusion roof.
extrusionStart
Double
Start the extrusion.
extrusionEnd
Double
End the extrusion.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

Document..::NewFamilyInstance Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Insert a new instance of a Family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Add a new instance of a Family into the Autodesk Revit project, using a location and a type/symbol.
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Add a new instance of a Family into the Autodesk Revit project, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Insert a new instance of a Family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Add a new instance of a level based Family into the Autodesk Revit project, using a location, type/symbol and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, the host element and a reference direction.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, Line, FamilySymbol)

Document..::NewFamilyInstance Method (Face, Line, FamilySymbol)
See Also
CollapseAll image DropDown image

Insert a new instance of a Family onto a face of an existing element, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
position
Line
A line on the face defining where the symbol is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise Nothing(null).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)

Document..::NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)
See Also
CollapseAll image DropDown image

Add a new instance of a Family into the Autodesk Revit project, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

Use this method to insert a family instance that does not require a host element or level.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)

Document..::NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)
See Also
CollapseAll image DropDown image

Add a new instance of a Family into the Autodesk Revit project, using a curve, type/symbol and reference level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Curve
The curve where the instance is based.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to insert one family instance into another element along the geometry of a curve. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail. All levels within the project can be found by iterating over the entire project and searching for objects of type Autodesk.Revit.Elements.Level.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)

Document..::NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)
See Also
CollapseAll image DropDown image

Insert a new instance of a Family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
location
XYZ
Point on the face where the instance is to be placed.
referenceDirection
XYZ
A vector that defines the direction of the family instance.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise Nothing(null).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)

Document..::NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)
See Also
CollapseAll image DropDown image

Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, and the host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to insert one family instance into another element, such as inserting a window into a wall. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)

Document..::NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)
See Also
CollapseAll image DropDown image

Add a new instance of a level based Family into the Autodesk Revit project, using a location, type/symbol and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to add a family instance that doesn't require a host element, but that can be associated to a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the project can be found by iterating over the entire project and searching for objects of type Autodesk.Revit.Elements.Level.

Some families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

Document..::NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)
See Also
CollapseAll image DropDown image

Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed on the specified level.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Element
A host object into which the instance will be embedded
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the project can be found by iterating over the entire project and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

Document..::NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
See Also
CollapseAll image DropDown image

Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, the host element and a reference direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
XYZ
A vector that dictates the direction of certains family instances.
host
Element
A host object into which the instance will be embedded
structuralType
StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method allows you to create FamilyInstance objects that require both a location and direction. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstances Method

Document..::NewFamilyInstances Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public ElementSet NewFamilyInstances(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Function NewFamilyInstances ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ElementSet
Visual C++
[ComVisibleAttribute(false)]
public:
ElementSet^ NewFamilyInstances (
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
List <(Of < FamilyInstanceCreationData >)>

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFascia Method

Document..::NewFascia Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along the reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along the reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, Reference)

Document..::NewFascia Method (FasciaType, Reference)
See Also
CollapseAll image DropDown image

Creates a fascia along the reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    reference As Reference _
) As Fascia
Visual C++
public:
Fascia^ NewFascia (
    FasciaType^ FasciaType,
    Reference^ reference
)

Parameters

FasciaType
FasciaType
The type of the fascia to create
reference
Reference
A planar line or arc that represent the place where you want to place fascia.

Return Value

If successful a new fascia object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, ReferenceArray)

Document..::NewFascia Method (FasciaType, ReferenceArray)
See Also
CollapseAll image DropDown image

Creates a fascia along the reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia (
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
FasciaType
The type of the fascia to create
references
ReferenceArray
An array of planar lines and arcs that represent the place where you want to place fascia.

Return Value

If successful a new fascia object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFloor Method

Document..::NewFloor Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, Boolean)

Document..::NewFloor Method (CurveArray, Boolean)
See Also
CollapseAll image DropDown image

Creates a floor within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the floor.
structural
Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean)

Document..::NewFloor Method (CurveArray, FloorType, Level, Boolean)
See Also
CollapseAll image DropDown image

Creates a floor within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor (
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
FloorType
A floor type to be used by the new floor instead of the default type.
level
Level
The level on which the floor is to be placed.
structural
Boolean
If set, specifies that the floor is structural in nature.

Return Value

if successful, a new floor object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise a exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)

Document..::NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Creates a floor within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFloor (
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
FloorType
A floor type to be used by the new floor instead of the default type.
level
Level
The level on which the floor is to be placed.
structural
Boolean
If set, specifies that the floor is structural in nature.
normal
XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new floor object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise a exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFootPrintRoof Method

Document..::NewFootPrintRoof Method
CollapseAll image DropDown image

Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    ElementIdSet footPrintToModelCurvesMapping
)
Visual Basic (Declaration)
Public Function NewFootPrintRoof ( _
    footPrint As CurveArray, _
    level As Level, _
    roofType As RoofType, _
    footPrintToModelCurvesMapping As ElementIdSet _
) As FootPrintRoof
Visual C++
public:
FootPrintRoof^ NewFootPrintRoof (
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    ElementIdSet^ footPrintToModelCurvesMapping
)

Parameters

footPrint
CurveArray
The footprint of the FootPrintRoof.
level
Level
The level of the FootPrintRoof.
roofType
RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping
ElementIdSet
Map footprint to Model Curves.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationSlab Method

Document..::NewFoundationSlab Method
CollapseAll image DropDown image

Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewFoundationSlab(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewFoundationSlab ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFoundationSlab (
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
FloorType
A floor type to be used by the new floor instead of the default type.
level
Level
The level on which the floor is to be placed.
structural
Boolean
If set, specifies that the floor is structural in nature.
normal
XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new foundation slab object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise a exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationWall Method

Document..::NewFoundationWall Method
CollapseAll image DropDown image

Creates a new continuous footing object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ContFooting NewFoundationWall(
    ContFootingType contFootingType,
    Wall wall
)
Visual Basic (Declaration)
Public Function NewFoundationWall ( _
    contFootingType As ContFootingType, _
    wall As Wall _
) As ContFooting
Visual C++
public:
ContFooting^ NewFoundationWall (
    ContFootingType^ contFootingType,
    Wall^ wall
)

Parameters

contFootingType
ContFootingType
The ContFooting type.
wall
Wall
The Wall to append a ContFooting.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGrid Method

Document..::NewGrid Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewGrid(Arc) | Creates a new grid line.
Public method | NewGrid(Line) | Creates a new grid line.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGrid Method (Arc)

Document..::NewGrid Method (Arc)
See Also
CollapseAll image DropDown image

Creates a new grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Grid NewGrid(
    Arc arc
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    arc As Arc _
) As Grid
Visual C++
public:
Grid^ NewGrid (
    Arc^ arc
)

Parameters

arc
Arc
A arc object that represents the location of the new grid line.

Return Value

The newly created grid line.

Remarks

The arc should be on a horizontal plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGrid Method (Line)

Document..::NewGrid Method (Line)
See Also
CollapseAll image DropDown image

Creates a new grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Grid NewGrid(
    Line line
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    line As Line _
) As Grid
Visual C++
public:
Grid^ NewGrid (
    Line^ line
)

Parameters

line
Line
A line object which represents the location of the grid line.

Return Value

The newly created grid line.

Remarks

The line should be on a horizontal plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGrids Method

Document..::NewGrids Method
CollapseAll image DropDown image

Creates new grid lines.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewGrids(
    CurveArray curves
)
Visual Basic (Declaration)
Public Function NewGrids ( _
    curves As CurveArray _
) As ElementSet
Visual C++
public:
ElementSet^ NewGrids (
    CurveArray^ curves
)

Parameters

curves
CurveArray
The curves which represent the new grid lines. These curves must be lines or bounded arcs.

Return Value

An Element set that contains the Grids.

Remarks

All input curves should lie on horizontal planes.

Exceptions

Exception | Condition
System..::ArgumentException | If the curve is an unbounded arc (a circle).
System..::ArgumentNullException | If any curve supplied in the input is null.
System..::InvalidOperationException | If any grid line is not created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGroup Method

Document..::NewGroup Method
CollapseAll image DropDown image

Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Group NewGroup(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function NewGroup ( _
    elements As ElementSet _
) As Group
Visual C++
public:
Group^ NewGroup (
    ElementSet^ elements
)

Parameters

elements
ElementSet
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGutter Method

Document..::NewGutter Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewGutter(GutterType, Reference) | Creates a gutter along the reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along the reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, Reference)

Document..::NewGutter Method (GutterType, Reference)
See Also
CollapseAll image DropDown image

Creates a gutter along the reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    reference As Reference _
) As Gutter
Visual C++
public:
Gutter^ NewGutter (
    GutterType^ GutterType,
    Reference^ reference
)

Parameters

GutterType
GutterType
The type of the gutter to create
reference
Reference
A planar line or arc that represent the place where you want to place gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, ReferenceArray)

Document..::NewGutter Method (GutterType, ReferenceArray)
See Also
CollapseAll image DropDown image

Creates a gutter along the reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter (
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
GutterType
The type of the gutter to create
references
ReferenceArray
An array of planar lines and arcs that represent the place where you want to place gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLevel Method

Document..::NewLevel Method
CollapseAll image DropDown image

Creates a new level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level NewLevel(
    double elevation
)
Visual Basic (Declaration)
Public Function NewLevel ( _
    elevation As Double _
) As Level
Visual C++
public:
Level^ NewLevel (
    double elevation
)

Parameters

elevation
Double
The elevation to apply to the new level.

Return Value

The newly created level.

Remarks

Default level attributes retrieved from ADocument will apply to the new level.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method

Document..::NewLineBoundaryConditions Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions Element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions Element.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

Document..::NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
See Also
CollapseAll image DropDown image

Creates a new Line BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions (
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

hostElement
Element
The Geometry reference to Beam.
X_Translation
TranslationRotationValue
Translation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_TranslationSpringModulus
Double
Translation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Translation
TranslationRotationValue
Translation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_TranslationSpringModulus
Double
Translation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Translation
TranslationRotationValue
Translation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_TranslationSpringModulus
Double
Translation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"
X_Rotation
TranslationRotationValue
Rotation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_RotationSpringModulus
Double
Rotation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

Document..::NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
See Also
CollapseAll image DropDown image

Creates a new Line BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions (
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

reference
Reference
The Geometry reference to Beam's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical lines.
X_Translation
TranslationRotationValue
Translation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_TranslationSpringModulus
Double
Translation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Translation
TranslationRotationValue
Translation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_TranslationSpringModulus
Double
Translation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Translation
TranslationRotationValue
Translation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_TranslationSpringModulus
Double
Translation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"
X_Rotation
TranslationRotationValue
Rotation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_RotationSpringModulus
Double
Rotation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLineLoad Method

Document..::NewLineLoad Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewLineLoad(XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new instance of a LineLoad element within the project.
Public method | NewLineLoad(Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new instance of a LineLoad element within the project using the host Element.
Public method | NewLineLoad(Reference, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new instance of a LineLoad element within the project using the host Element.
Public method | NewLineLoad(XYZArray, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new instance of a LineLoad element within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

Document..::NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
See Also
CollapseAll image DropDown image

Creates a new instance of a LineLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoad NewLineLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    XYZ point1,
    XYZ force1,
    XYZ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    point1 As XYZ, _
    force1 As XYZ, _
    moment1 As XYZ, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad (
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    XYZ^ point1,
    XYZ^ force1,
    XYZ^ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
XYZ
The first point of the LineLoad application.
force
XYZ
The applied 3d linear force in the first point.
moment
XYZ
The applied 3d linear moment in the first point.
point1
XYZ
The second point of the LineLoad application.
force1
XYZ
The applied 3d linear force in the second point.
moment1
XYZ
The applied 3d linear moment in the second point.
uniform
Boolean
Set to True if you wish to create the uniform load.
projected
Boolean
Set to True if you wish to create the projected load.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
LineLoadType
plane
SketchPlane

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

Document..::NewLineLoad Method (Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
See Also
CollapseAll image DropDown image

Creates a new instance of a LineLoad element within the project using the host Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoad NewLineLoad(
    Element host,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    host As Element, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad (
    Element^ host,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

host
Element
The host element (Beam, Brace or Column) of the LineLoad application.
forces
XYZArray
The applied 3d linear forces in the end points.
moments
XYZArray
The applied 3d linear moments in the end points.
uniform
Boolean
Set to True if you wish to create the uniform load.
projected
Boolean
Set to True if you wish to create the projected load.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
LineLoadType
plane
SketchPlane

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Reference, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

Document..::NewLineLoad Method (Reference, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
See Also
CollapseAll image DropDown image

Creates a new instance of a LineLoad element within the project using the host Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoad NewLineLoad(
    Reference reference,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    reference As Reference, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad (
    Reference^ reference,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Reference
The Geometry reference to Beam's, Brace's, Column's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical lines.
forces
XYZArray
The applied 3d linear forces in the end points.
moments
XYZArray
The applied 3d linear moments in the end points.
uniform
Boolean
Set to True if you wish to create the uniform load.
projected
Boolean
Set to True if you wish to create the projected load.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
LineLoadType
plane
SketchPlane

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLineLoad Method (XYZArray, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

Document..::NewLineLoad Method (XYZArray, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
See Also
CollapseAll image DropDown image

Creates a new instance of a LineLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoad NewLineLoad(
    XYZArray points,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    points As XYZArray, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad (
    XYZArray^ points,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

points
XYZArray
The end points of the LineLoad application.
forces
XYZArray
The applied 3d linear forces in the end points.
moments
XYZArray
The applied 3d linear moments in the end points.
uniform
Boolean
Set to True if you wish to create the uniform load.
projected
Boolean
Set to True if you wish to create the projected load.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
LineLoadType
plane
SketchPlane

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadCase Method

Document..::NewLoadCase Method
CollapseAll image DropDown image

Creates a new instance of a LoadCase element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCase NewLoadCase(
    string name,
    LoadNature nature,
    Category category
)
Visual Basic (Declaration)
Public Function NewLoadCase ( _
    name As String, _
    nature As LoadNature, _
    category As Category _
) As LoadCase
Visual C++
public:
LoadCase^ NewLoadCase (
    String^ name,
    LoadNature^ nature,
    Category^ category
)

Parameters

name
String
The not empty name for the Load Case Element to create.
nature
LoadNature
The Load Case nature.
category
Category
The Load Case category.

Return Value

If successful, NewLoadCase and there isn’t the Load Case Element with the same name returns an object for the newly created LoadCase. If such element exist and match desired one (has the same nature and number), returns existing element. Otherwise nothing is returned.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadCombination Method

Document..::NewLoadCombination Method
CollapseAll image DropDown image

Creates a new instance of a LoadCombination element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCombination NewLoadCombination(
    string name,
    int typeInd,
    int stateInd,
    double[] factors,
    LoadCaseArray cases,
    LoadCombinationArray combinations,
    LoadUsageArray usages
)
Visual Basic (Declaration)
Public Function NewLoadCombination ( _
    name As String, _
    typeInd As Integer, _
    stateInd As Integer, _
    factors As Double(), _
    cases As LoadCaseArray, _
    combinations As LoadCombinationArray, _
    usages As LoadUsageArray _
) As LoadCombination
Visual C++
public:
LoadCombination^ NewLoadCombination (
    String^ name,
    int typeInd,
    int stateInd,
    array<double>^ factors,
    LoadCaseArray^ cases,
    LoadCombinationArray^ combinations,
    LoadUsageArray^ usages
)

Parameters

name
String
The not empty name for the Load Combination Element to create.
typeInd
Int32
LoadCombination Type Index: 0-Combination, 1-Envelope.
stateInd
Int32
LoadCombination State Index: 0-Servicebility, 1-Ultimate.
factors
array< Double >[]()
Factors array for Load Combination formula.
cases
LoadCaseArray
Load Cases array for Load Combination formula.
combinations
LoadCombinationArray
Load Combinations array for Load Combination formula.
usages
LoadUsageArray
Load Usages array.

Return Value

If successful, NewLoadCombination and there isn’t the Load Combination Element with the same name returns an object for the newly created LoadCombination. If such element exist and match desired one (has the same formula and the same usages set), returns existing element. Otherwise nothing is returned.

Remarks

Factors and Load Combinations arrays have the same dimension (n). The Load Combination formula is equal to: factors[0]*cases[0]*factors[1]*cases[1]*. . . factors[n]*cases[n]. This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadNature Method

Document..::NewLoadNature Method
CollapseAll image DropDown image

Creates a new instance of a LoadNature element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadNature NewLoadNature(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadNature ( _
    name As String _
) As LoadNature
Visual C++
public:
LoadNature^ NewLoadNature (
    String^ name
)

Parameters

name
String
The name for the Load Nature Element to create.

Return Value

If successful and there isn’t the Load Nature Element with the same name NewLoadNature returns an object for the newly created LoadNature. If such element exist it returns existing element. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadUsage Method

Document..::NewLoadUsage Method
CollapseAll image DropDown image

Creates a new instance of a LoadUsage element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadUsage NewLoadUsage(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadUsage ( _
    name As String _
) As LoadUsage
Visual C++
public:
LoadUsage^ NewLoadUsage (
    String^ name
)

Parameters

name
String
The not empty name for the Load Usage Element to create.

Return Value

If successful and there isn’t the Load Usage Element with the same name NewLoadUsage returns an object for the newly created LoadUsage. If such element exist it returns existing element. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewModelCurve Method

Document..::NewModelCurve Method
CollapseAll image DropDown image

Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewModelCurve (
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Curve
The internal geometry curve for model line.
sketchPlane
SketchPlane
The sketch plane this new model line resides in.

Return Value

If successful a new model line element. Otherwise null pointer.

Remarks

Different type of model curve element will be returned according to the type of geometry curve.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewModelCurveArray Method

Document..::NewModelCurveArray Method
CollapseAll image DropDown image

Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurveArray ( _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewModelCurveArray (
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurveArray
CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane
SketchPlane

Return Value

If successful an array of new model line elements. Otherwise null pointer.

Remarks

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewOpening Method

Document..::NewOpening Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewOpening(Element, CurveArray, Document..::eRefFace) | Creates a new Opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new Opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new Opening Element.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a opening in a swall or arcwall.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, Document.eRefFace)

Document..::NewOpening Method (Element, CurveArray, Document..::eRefFace)
See Also
CollapseAll image DropDown image

Creates a new Opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    Document.Document..::eRefFace iFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    famInstElement As Element, _
    profile As CurveArray, _
    iFace As Document..::eRefFace _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Element^ famInstElement,
    CurveArray^ profile,
    Document..::eRefFace iFace
)

Parameters

famInstElement
Element
host element of the opening, can be a beam, brace and column.
profile
CurveArray
profile of the opening.
iFace
Document..::eRefFace
face on which opening is based on.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on a beam, brace and column.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, Boolean)

Document..::NewOpening Method (Element, CurveArray, Boolean)
See Also
CollapseAll image DropDown image

Creates a new Opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    hostElement As Element, _
    profile As CurveArray, _
    bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)

Parameters

hostElement
Element
host element of the opening, can be a roof,floor and ceiling.
profile
CurveArray
profile of the opening.
bPerpendicularFace
Boolean
whether it is to cut perpendicular to the face or cut vertically.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on the floor, ceiling and roof

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewOpening Method (Level, Level, CurveArray)

Document..::NewOpening Method (Level, Level, CurveArray)
See Also
CollapseAll image DropDown image

Creates a new Opening Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    bottomLevel As Level, _
    topLevel As Level, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)

Parameters

bottomLevel
Level
bottom level
topLevel
Level
top level
profile
CurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewOpening Method (Wall, XYZ, XYZ)

Document..::NewOpening Method (Wall, XYZ, XYZ)
See Also
CollapseAll image DropDown image

Creates a opening in a swall or arcwall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    wall As Wall, _
    pntStart As XYZ, _
    pntEnd As XYZ _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)

Parameters

wall
Wall
host element of the opening.
pntStart
XYZ
first point of the rect.
pntEnd
XYZ
second point of the rect.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on the arc wall or swall.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPathReinforcement Method

Document..::NewPathReinforcement Method
CollapseAll image DropDown image

Creates a new instance of a Path Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PathReinforcement NewPathReinforcement(
    Element host,
    CurveArray curves,
    bool flip
)
Visual Basic (Declaration)
Public Function NewPathReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    flip As Boolean _
) As PathReinforcement
Visual C++
public:
PathReinforcement^ NewPathReinforcement (
    Element^ host,
    CurveArray^ curves,
    bool flip
)

Parameters

host
Element
The element to which the Path Reinforcement belongs. The element must be a structural floor or wall.
curves
CurveArray
An array of curves forming a chain. Bars will be placed orthogonal to the chain with their hook ends near the chain, offset by the side cover setting. The curves must belong to the top face of the floor or the exterior face of the wall.
flip
Boolean
A flag controlling the bars relative to the curves. If the curves are given in order and with consistent orientation, the bars will lie to the right of the chain if flip=false, to the left if flip=true, when viewed from above the floor or outside the wall.

Return Value

If successful, NewPathReinforcement returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointBoundaryConditions Method

Document..::NewPointBoundaryConditions Method
CollapseAll image DropDown image

Creates a new Point BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions NewPointBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewPointBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double, _
    Y_Rotation As TranslationRotationValue, _
    Y_RotationSpringModulus As Double, _
    Z_Rotation As TranslationRotationValue, _
    Z_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewPointBoundaryConditions (
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)

Parameters

reference
Reference
The Geometry reference to Beam's, Brace's or Column's analytical line end.
X_Translation
TranslationRotationValue
Translation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_TranslationSpringModulus
Double
Translation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Translation
TranslationRotationValue
Translation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_TranslationSpringModulus
Double
Translation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Translation
TranslationRotationValue
Translation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_TranslationSpringModulus
Double
Translation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"
X_Rotation
TranslationRotationValue
Rotation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_RotationSpringModulus
Double
Rotation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Rotation
TranslationRotationValue
Rotation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_RotationSpringModulus
Double
Rotation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Rotation
TranslationRotationValue
Rotation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_RotationSpringModulus
Double
Rotation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"

Return Value

If successful, NewPointBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 0 - "Point". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointLoad Method

Document..::NewPointLoad Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewPointLoad(Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new instance of a PointLoad element within the project.
Public method | NewPointLoad(XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new instance of a PointLoad element within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

Document..::NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
See Also
CollapseAll image DropDown image

Creates a new instance of a PointLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PointLoad NewPointLoad(
    Reference reference,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    reference As Reference, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad (
    Reference^ reference,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Reference
The Geometry reference to Beam's, Brace's, Column's, analytical line's end.
force
XYZ
The 3d force.
moment
XYZ
The 3d moment.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
PointLoadType
plane
SketchPlane

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

Document..::NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
See Also
CollapseAll image DropDown image

Creates a new instance of a PointLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PointLoad NewPointLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad (
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
XYZ
The point of the PointLoad application.
force
XYZ
The 3d force.
moment
XYZ
The 3d moment.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
PointLoadType
plane
SketchPlane

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRebar Method

Document..::NewRebar Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewRebar(RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, Int32, Int32, Boolean, Boolean) | Creates a new instance of a Rebar element within the project
Public method | NewRebar(RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ) | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRebar Method (RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, Int32, Int32, Boolean, Boolean)

Document..::NewRebar Method (RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, Int32, Int32, Boolean, Boolean)
See Also
CollapseAll image DropDown image

Creates a new instance of a Rebar element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Rebar NewRebar(
    RebarStyle style,
    RebarBarType rebarType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    CurveArray curves,
    int startHookOrient,
    int endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    style As RebarStyle, _
    rebarType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As CurveArray, _
    startHookOrient As Integer, _
    endHookOrient As Integer, _
    useExistingShapeIfPossible As Boolean, _
    createNewShape As Boolean _
) As Rebar
Visual C++
public:
Rebar^ NewRebar (
    RebarStyle style,
    RebarBarType^ rebarType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    CurveArray^ curves,
    int startHookOrient,
    int endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)

Parameters

style
RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
rebarType
RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
startHook
RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted before the first curve of the rebar. If this parameter is null, it means to create a rebar with NONE hook type.
endHook
RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted after the last curve segment of the rebar. If this parameter is null, it means to create a rebar with NONE hook type.
host
Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
norm
XYZ
The normal to the plane that the rebar curves lie on.
curves
CurveArray
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Int32
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = 1: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = 3: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Int32
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = 1: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = 3: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
useExistingShapeIfPossible
Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns null or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true".
createNewShape
Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.

Return Value

If successful, NewRebar returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRebar Method (RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ)

Document..::NewRebar Method (RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ)
See Also
CollapseAll image DropDown image

Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Rebar NewRebar(
    RebarShape rebarShape,
    RebarBarType rebarType,
    Element host,
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    rebarShape As RebarShape, _
    rebarType As RebarBarType, _
    host As Element, _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
) As Rebar
Visual C++
public:
Rebar^ NewRebar (
    RebarShape^ rebarShape,
    RebarBarType^ rebarType,
    Element^ host,
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

rebarShape
RebarShape
The shape type of the Rebar.
rebarType
RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
host
Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
origin
XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVec
XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVec
XYZ
The y-axis in the shape definition will be mapped to this direction in the project.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRebarShape Method

Document..::NewRebarShape Method
CollapseAll image DropDown image

Creates a new instance of a Rebar Shape, which defines the shape of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShape NewRebarShape()
Visual Basic (Declaration)
Public Function NewRebarShape As RebarShape
Visual C++
public:
RebarShape^ NewRebarShape ()

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewReferencePlane Method

Document..::NewReferencePlane Method
CollapseAll image DropDown image

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    cutVec As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane (
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)

Parameters

bubbleEnd
XYZ
The bubble end applied to reference plane.
freeEnd
XYZ
The free end applied to reference plane.
cutVec
XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView
View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewReferencePlane2 Method

Document..::NewReferencePlane2 Method
CollapseAll image DropDown image

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane2 ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    thirdPnt As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane2 (
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)

Parameters

bubbleEnd
XYZ
The bubble end applied to reference plane.
freeEnd
XYZ
The free end applied to reference plane.
thirdPnt
XYZ
A third point needed to define the reference plane.
pView
View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoom Method

Document..::NewRoom Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewRoom(Phase) | Creates a new room and insert to a exist schedule with the phase you assigned.
Public method | NewRoom(Level, UV) | Creates a new Room.
Public method | NewRoom(Room, PlanCircuit) | Creates a number of new Rooms.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRoom Method (Phase)

Document..::NewRoom Method (Phase)
See Also
CollapseAll image DropDown image

Creates a new room and insert to a exist schedule with the phase you assigned.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room NewRoom(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom (
    Phase^ phase
)

Parameters

phase
Phase
The phase on which the room is to exist.

Return Value

If successful a room with NO Location should be returned, otherwise Nothing. If your action is in the certain Design Option, the room will in the certain Option.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoom Method (Level, UV)

Document..::NewRoom Method (Level, UV)
See Also
CollapseAll image DropDown image

Creates a new Room.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room NewRoom(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    level As Level, _
    point As UV _
) As Room
Visual C++
public:
Room^ NewRoom (
    Level^ level,
    UV^ point
)

Parameters

level
Level
The level on which the room is to exist.
point
UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Room object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoom Method (Room, PlanCircuit)

Document..::NewRoom Method (Room, PlanCircuit)
See Also
CollapseAll image DropDown image

Creates a number of new Rooms.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room NewRoom(
    Room room,
    PlanCircuit circuit
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    room As Room, _
    circuit As PlanCircuit _
) As Room
Visual C++
public:
Room^ NewRoom (
    Room^ room,
    PlanCircuit^ circuit
)

Parameters

room
Room
The room which you want to locate in the circuit.
circuit
PlanCircuit
The circuit which you want to locate a room.

Return Value

If successful room should be returned, otherwise Nothing.

Remarks

If the circuit is not closed or there is a room already exist in the circuit, will throw a exception.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoomBoundaryLines Method

Document..::NewRoomBoundaryLines Method
CollapseAll image DropDown image

Creates a new boundary line as an Room border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArray NewRoomBoundaryLines(
    SketchPlane plan,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomBoundaryLines ( _
    plan As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewRoomBoundaryLines (
    SketchPlane^ plan,
    CurveArray^ curves,
    View^ view
)

Parameters

plan
SketchPlane
The sketch plan
curves
CurveArray
The geometry curves on which the boundary lines are
view
View
The View for the new Room

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRooms Method

Document..::NewRooms Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewRooms(List<(Of <RoomCreationData>)>) |
Public method | NewRooms(Level) | Creates new Rooms in the Last Phase.
Public method | NewRooms(Level, Phase) | Creates new Rooms.
Public method | NewRooms(Phase, Int32) | Creates new Rooms.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRooms Method (List)

Document..::NewRooms Method (List<(Of <RoomCreationData>)>)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public ElementSet NewRooms(
    List<RoomCreationData> dataList
)
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Function NewRooms ( _
    dataList As List(Of RoomCreationData) _
) As ElementSet
Visual C++
[ComVisibleAttribute(false)]
public:
ElementSet^ NewRooms (
    List<RoomCreationData^>^ dataList
)

Parameters

dataList
List <(Of < RoomCreationData >)>

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRooms Method (Level)

Document..::NewRooms Method (Level)
See Also
CollapseAll image DropDown image

Creates new Rooms in the Last Phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewRooms(
    Level level
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms (
    Level^ level
)

Parameters

level
Level
- The level on which the room is to exist.

Return Value

If successful a Element set which contain the rooms should be returned, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRooms Method (Level, Phase)

Document..::NewRooms Method (Level, Phase)
See Also
CollapseAll image DropDown image

Creates new Rooms.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewRooms(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level, _
    phase As Phase _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms (
    Level^ level,
    Phase^ phase
)

Parameters

level
Level
The level on which the room is to exist.
phase
Phase
The phase on which the room is to exist.

Return Value

If successful a Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::ArgumentNullException | If either of RoomCreationData's level or point is null object.
System..::ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRooms Method (Phase, Int32)

Document..::NewRooms Method (Phase, Int32)
See Also
CollapseAll image DropDown image

Creates new Rooms.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewRooms(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms (
    Phase^ phase,
    int count
)

Parameters

phase
Phase
The phase on which the room is to exist.
count
Int32
The number of the rooms to be created.

Return Value

If successful a Element set which contain the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoomTag Method

Document..::NewRoomTag Method
CollapseAll image DropDown image

Creates a new RoomTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTag NewRoomTag(
    Room room,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomTag ( _
    room As Room, _
    point As UV, _
    view As View _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag (
    Room^ room,
    UV^ point,
    View^ view
)

Parameters

room
Room
The Room which the tag refers.
point
UV
A 2D point that dictates the location on the level of the room.
view
View
The view where the tag will lie.

Return Value

If successful a RoomTag object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

Document..::NewSketchPlane Method
CollapseAll image DropDown image

Creates a new sketch plane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchPlane NewSketchPlane(
    Plane geometryPlane
)
Visual Basic (Declaration)
Public Function NewSketchPlane ( _
    geometryPlane As Plane _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane (
    Plane^ geometryPlane
)

Parameters

geometryPlane
Plane
The geometry plane to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise null pointer.

Remarks

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSlab Method

Document..::NewSlab Method
CollapseAll image DropDown image

Creates a slab within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewSlab(
    CurveArray profile,
    Level level,
    Line slopedArrow,
    double slope,
    bool isStructural
)
Visual Basic (Declaration)
Public Function NewSlab ( _
    profile As CurveArray, _
    level As Level, _
    slopedArrow As Line, _
    slope As Double, _
    isStructural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewSlab (
    CurveArray^ profile,
    Level^ level,
    Line^ slopedArrow,
    double slope,
    bool isStructural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the slab.
level
Level
The level on which the slab is to be placed.
slopedArrow
Line
A line use to control the sloped angle of the slab. It should be in the same face with profile.
slope
Double
The slope.
isStructural
Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSlabEdge Method

Document..::NewSlabEdge Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along the reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along the reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, Reference)

Document..::NewSlabEdge Method (SlabEdgeType, Reference)
See Also
CollapseAll image DropDown image

Creates a slab edge along the reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    reference As Reference _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge (
    SlabEdgeType^ SlabEdgeType,
    Reference^ reference
)

Parameters

SlabEdgeType
SlabEdgeType
The type of the slab edge to create
reference
Reference
A planar line or arc that represent the place where you want to place slab edge.

Return Value

If successful a new slab edge object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, ReferenceArray)

Document..::NewSlabEdge Method (SlabEdgeType, ReferenceArray)
See Also
CollapseAll image DropDown image

Creates a slab edge along the reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    references As ReferenceArray _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge (
    SlabEdgeType^ SlabEdgeType,
    ReferenceArray^ references
)

Parameters

SlabEdgeType
SlabEdgeType
The type of the slab edge to create
references
ReferenceArray
An array of planar lines and arcs that represent the place where you want to place slab edge.

Return Value

If successful a new slab edge object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpace Method

Document..::NewSpace Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewSpace(Phase) | Creates a new space and insert to a existent schedule with the phase you assigned.
Public method | NewSpace(Level, UV) | Creates a new Space element.
Public method | NewSpace(Level, Phase, UV) | Creates a new Space element.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpace Method (Phase)

Document..::NewSpace Method (Phase)
See Also
CollapseAll image DropDown image

Creates a new space and insert to a existent schedule with the phase you assigned.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Space NewSpace(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    phase As Phase _
) As Space
Visual C++
public:
Space^ NewSpace (
    Phase^ phase
)

Parameters

phase
Phase
The phase on which the space is to exist.

Return Value

If successful a space with NO Location should be returned, otherwise Nothing. If your action is in the certain Design Option, the space will in the certain Option.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, UV)

Document..::NewSpace Method (Level, UV)
See Also
CollapseAll image DropDown image

Creates a new Space element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Space NewSpace(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace (
    Level^ level,
    UV^ point
)

Parameters

level
Level
The level on which the space is to exist.
point
UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Space element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::InvalidOperationException | Thrown when the space cannot be created with input level and phase.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, Phase, UV)

Document..::NewSpace Method (Level, Phase, UV)
See Also
CollapseAll image DropDown image

Creates a new Space element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Space NewSpace(
    Level level,
    Phase phase,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    phase As Phase, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace (
    Level^ level,
    Phase^ phase,
    UV^ point
)

Parameters

level
Level
The level on which the room is to exist.
phase
Phase
The phase on which the room is to exist.
point
UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Space element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::InvalidOperationException | Thrown when the space cannot be created with input level and phase.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpaceBoundaryLines Method

Document..::NewSpaceBoundaryLines Method
CollapseAll image DropDown image

Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArray NewSpaceBoundaryLines(
    SketchPlane plan,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceBoundaryLines ( _
    plan As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewSpaceBoundaryLines (
    SketchPlane^ plan,
    CurveArray^ curves,
    View^ view
)

Parameters

plan
SketchPlane
The sketch plan
curves
CurveArray
The geometry curves on which the boundary lines are
view
View
The View for the new Space

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpaces Method

Document..::NewSpaces Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewSpaces(Phase, Int32) | Creates a set of new spaces and insert to a existent schedule with the phase you assigned.
Public method | NewSpaces(Level, Phase, View) | Creates new Spaces.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpaces Method (Phase, Int32)

Document..::NewSpaces Method (Phase, Int32)
See Also
CollapseAll image DropDown image

Creates a set of new spaces and insert to a existent schedule with the phase you assigned.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewSpaces(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces (
    Phase^ phase,
    int count
)

Parameters

phase
Phase
The phase on which the space is to exist.
count
Int32

Return Value

If successful spaces with NO Location should be returned, otherwise Nothing. If your action is in the certain Design Option, the spaces will in the certain Option.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpaces Method (Level, Phase, View)

Document..::NewSpaces Method (Level, Phase, View)
See Also
CollapseAll image DropDown image

Creates new Spaces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewSpaces(
    Level level,
    Phase phase,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces (
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Level
The level on which the spaces is to exist.
phase
Phase
The phase on which the spaces is to exist.
view
View
The view on which the tags of spaces is to exist.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpaceTag Method

Document..::NewSpaceTag Method
CollapseAll image DropDown image

Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceTag NewSpaceTag(
    Space space,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceTag ( _
    space As Space, _
    point As UV, _
    view As View _
) As SpaceTag
Visual C++
public:
SpaceTag^ NewSpaceTag (
    Space^ space,
    UV^ point,
    View^ view
)

Parameters

space
Space
The Space which the tag refers.
point
UV
A 2D point that dictates the location on the level of the space.
view
View
The view where the tag will lie.

Return Value

If successful a SpaceTag object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotCoordinate Method

Document..::NewSpotCoordinate Method
CollapseAll image DropDown image

Generate a new spot coordinate object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimension NewSpotCoordinate(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotCoordinate ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotCoordinate (
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
View
The view in which the spot coordinate is to be visible.
reference
Reference
The reference to which the spot coordinate is to be bound.
origin
XYZ
The point which the spot coordinate evaluate.
bend
XYZ
The bend point for the spot coordinate.
end
XYZ
The end point for the spot coordinate.
refPt
XYZ
The actual point on the reference which the spot coordinate evaluate.
hasLeader
Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise Nothing.

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotElevation Method

Document..::NewSpotElevation Method
CollapseAll image DropDown image

Generate a new spot elevation object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimension NewSpotElevation(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotElevation ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotElevation (
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
View
The view in which the spot elevation is to be visible.
reference
Reference
The reference to which the spot elevation is to be bound.
origin
XYZ
The point which the spot elevation evaluate.
bend
XYZ
The bend point for the spot elevation.
end
XYZ
The end point for the spot elevation.
refPt
XYZ
The actual point on the reference which the spot elevation evaluate.
hasLeader
Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise Nothing.

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTag Method

Document..::NewTag Method
CollapseAll image DropDown image

Creates a new IndependentTag Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IndependentTag NewTag(
    View dbview,
    Element objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ pnt
)
Visual Basic (Declaration)
Public Function NewTag ( _
    dbview As View, _
    objelem As Element, _
    leader As Boolean, _
    tagmode As TagMode, _
    tagorn As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
IndependentTag^ NewTag (
    View^ dbview,
    Element^ objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ^ pnt
)

Parameters

dbview
View
The view in which the dimension is to be visible.
objelem
Element
The host object of tag
leader
Boolean
whether have leader
tagmode
TagMode
the mode of tag. Add by Category, add by Multi-Category and add by material
tagorn
TagOrientation
The Orientation of the Tag
pnt
XYZ
The position of the Tag

Return Value

If successful, an IndependentTag object is returned.

Remarks

This method forms an Tag tie to the host object.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTextNote Method

Document..::NewTextNote Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new TextNote object.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

Document..::NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
See Also
CollapseAll image DropDown image

Creates a new TextNote object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote (
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

pView
View
Current DBView
origin
XYZ
origin of the TextNote
baseVec
XYZ
baseVec parameter of the TextNote.
upVec
XYZ
upVec parameter of the TextNote.
lineWidth
Double
line width of the out rectangle.
textAlign
TextAlignFlags
align style.
leaderType
TextNoteLeaderTypes
leader type as straight or arc.
leaderStyle
TextNoteLeaderStyles
leaderEnd
XYZ
end point of the leader.
leaderElbow
XYZ
elbow point of the leader.
strText
String
text.

Return Value

If successful, a TextNote object is returned.

Remarks

This method forms a TextNote object.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

Document..::NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
See Also
CollapseAll image DropDown image

Creates a new TextNote object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote (
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

pView
View
Current DBView
origin
XYZ
origin of the TextNote
baseVec
XYZ
baseVec parameter of the TextNote.
upVec
XYZ
upVec parameter of the TextNote.
lineWidth
Double
line width of the out rectangle.
textAlign
TextAlignFlags
align style.
strText
String
text.

Return Value

If successful, a TextNote object is returned.

Remarks

This method forms a TextNote object.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTextNotes Method

Document..::NewTextNotes Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public ElementSet NewTextNotes(
    List<TextNoteCreationData> dataList
)
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Function NewTextNotes ( _
    dataList As List(Of TextNoteCreationData) _
) As ElementSet
Visual C++
[ComVisibleAttribute(false)]
public:
ElementSet^ NewTextNotes (
    List<TextNoteCreationData^>^ dataList
)

Parameters

dataList
List <(Of < TextNoteCreationData >)>

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTruss Method

Document..::NewTruss Method
CollapseAll image DropDown image

Creates a New Truss.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Truss NewTruss(
    TrussType trussType,
    SketchPlane sketchPlane,
    Curve baseCurve,
    View dbView
)
Visual Basic (Declaration)
Public Function NewTruss ( _
    trussType As TrussType, _
    sketchPlane As SketchPlane, _
    baseCurve As Curve, _
    dbView As View _
) As Truss
Visual C++
public:
Truss^ NewTruss (
    TrussType^ trussType,
    SketchPlane^ sketchPlane,
    Curve^ baseCurve,
    View^ dbView
)

Parameters

trussType
TrussType
The type for truss.
sketchPlane
SketchPlane
The sketch plane the truss is going to be reside in.It could be nullptr.
baseCurve
Curve
The curve that represents truss's base curve. It must be a line, must not be a vertical line, must be within the sketch plane if sketchPlane is valid.
dbView
View
The DBView where truss's tag going to be placed. A valid dbViewId must be a Plan view or RPlan view, or an elevation view paralleling to the truss base curve.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewView3D Method

Document..::NewView3D Method
CollapseAll image DropDown image

Creates a new 3D view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View3D NewView3D(
    XYZ viewDirection
)
Visual Basic (Declaration)
Public Function NewView3D ( _
    viewDirection As XYZ _
) As View3D
Visual C++
public:
View3D^ NewView3D (
    XYZ^ viewDirection
)

Parameters

viewDirection
XYZ
The view direction - the vector pointing towards the eye.

Return Value

The newly created 3D view.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewDrafting Method

Document..::NewViewDrafting Method
CollapseAll image DropDown image

Creates a new drafting view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewDrafting NewViewDrafting()
Visual Basic (Declaration)
Public Function NewViewDrafting As ViewDrafting
Visual C++
public:
ViewDrafting^ NewViewDrafting ()

Return Value

The newly created drafting view.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewPlan Method

Document..::NewViewPlan Method
CollapseAll image DropDown image

Creates a plan view based on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewPlan NewViewPlan(
    string pViewName,
    Level pLevel,
    ViewType viewType
)
Visual Basic (Declaration)
Public Function NewViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    viewType As ViewType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewViewPlan (
    String^ pViewName,
    Level^ pLevel,
    ViewType viewType
)

Parameters

pViewName
String
The name for the new plan view, must be unique or null pointer.
pLevel
Level
The level on which the plan view is to be associated.
viewType
ViewType
The type of plan view to be created, must be Floor Plan or Ceiling Plan (Structural Plan in Structure).

Return Value

if successful, a new plan view object within the project, otherwise Nothing.

Remarks

if pViewName is null, the pLevel's name will be use as new plan view's name. if the name is not unique, an Exception will be thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewSection Method

Document..::NewViewSection Method
CollapseAll image DropDown image

Creates a new section view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSection NewViewSection(
    BoundingBoxXYZ box
)
Visual Basic (Declaration)
Public Function NewViewSection ( _
    box As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
ViewSection^ NewViewSection (
    BoundingBoxXYZ^ box
)

Parameters

box
BoundingBoxXYZ
The orientation and bounds of the view. The X direction of the box is right on screen; Y, up; Z, towards the user.

Return Value

The newly created section view.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewSheet Method

Document..::NewViewSheet Method
CollapseAll image DropDown image

Creates a new sheet view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheet NewViewSheet(
    FamilySymbol titleBlock
)
Visual Basic (Declaration)
Public Function NewViewSheet ( _
    titleBlock As FamilySymbol _
) As ViewSheet
Visual C++
public:
ViewSheet^ NewViewSheet (
    FamilySymbol^ titleBlock
)

Parameters

titleBlock
FamilySymbol
The titleblock family symbol to apply to this sheet.

Return Value

The newly created sheet view.

Remarks

Use the TitleBlocks property of Document to choose a titleblock.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method

Document..::NewWall Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewWall(CurveArray, Boolean) | Creates a non rectangular profile wall within the project using the default wall style.
Public method | NewWall(Curve, Level, Boolean) | Creates a new rectangular profile wall within the project on the specified level using the default wall style.
Public method | NewWall(CurveArray, WallType, Level, Boolean) | Creates a non rectangular profile wall within the project.
Public method | NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Creates a non rectangular profile wall within the project with a specific normal.
Public method | NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, Boolean)

Document..::NewWall Method (CurveArray, Boolean)
See Also
CollapseAll image DropDown image

Creates a non rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, Level, Boolean)

Document..::NewWall Method (Curve, Level, Boolean)
See Also
CollapseAll image DropDown image

Creates a new rectangular profile wall within the project on the specified level using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall (
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean)

Document..::NewWall Method (CurveArray, WallType, Level, Boolean)
See Also
CollapseAll image DropDown image

Creates a non rectangular profile wall within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)

Document..::NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)
See Also
CollapseAll image DropDown image

Creates a non rectangular profile wall within the project with a specific normal.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Wall
Visual C++
public:
Wall^ NewWall (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.
normal
XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

Document..::NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
See Also
CollapseAll image DropDown image

Creates a new rectangular profile wall within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall (
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
height
Double
The height of the wall other than the default height.
offset
Double
An offset distance, in feet from the baseline specified. The wall will be placed that distance from the baseline.
flip
Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWalls Method

Document..::NewWalls Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewWalls(List<(Of <ProfiledWallCreationData>)>) |
Public method | NewWalls(List<(Of <RectangularWallCreationData>)>) |

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWalls Method (List)

Document..::NewWalls Method (List<(Of <ProfiledWallCreationData>)>)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public ElementSet NewWalls(
    List<ProfiledWallCreationData> dataList
)
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Function NewWalls ( _
    dataList As List(Of ProfiledWallCreationData) _
) As ElementSet
Visual C++
[ComVisibleAttribute(false)]
public:
ElementSet^ NewWalls (
    List<ProfiledWallCreationData^>^ dataList
)

Parameters

dataList
List <(Of < ProfiledWallCreationData >)>

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWalls Method (List)

Document..::NewWalls Method (List<(Of <RectangularWallCreationData>)>)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public ElementSet NewWalls(
    List<RectangularWallCreationData> dataList
)
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Function NewWalls ( _
    dataList As List(Of RectangularWallCreationData) _
) As ElementSet
Visual C++
[ComVisibleAttribute(false)]
public:
ElementSet^ NewWalls (
    List<RectangularWallCreationData^>^ dataList
)

Parameters

dataList
List <(Of < RectangularWallCreationData >)>

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWire Method

Document..::NewWire Method
CollapseAll image DropDown image

Creates a new wire element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wire NewWire(
    Curve curve,
    View view,
    Connector startConnector,
    Connector endConnector,
    WireType wireType,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWire ( _
    curve As Curve, _
    view As View, _
    startConnector As Connector, _
    endConnector As Connector, _
    wireType As WireType, _
    wiringType As WiringType _
) As Wire
Visual C++
public:
Wire^ NewWire (
    Curve^ curve,
    View^ view,
    Connector^ startConnector,
    Connector^ endConnector,
    WireType^ wireType,
    WiringType wiringType
)

Parameters

curve
Curve
The base line of the wire.
view
View
The view in which the wire is to be visible.
startConnector
Connector
The connector which connects with the start point connector of wire, if it is null, the start point connects with nothing.
endConnector
Connector
The connector which connects with the end point connector of wire, if it is null, the end point connects with nothing.
wireType
WireType
Specify wire type of new created wire.
wiringType
WiringType
Specify wiring type(Arc or chamfer) of new created wire.

Return Value

If successful a new wire element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::InvalidOperationException | An InvalidOperationException will to be thrown when Revit MEP product is unavailable.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewZone Method

Document..::NewZone Method
CollapseAll image DropDown image

Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Zone NewZone(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewZone ( _
    level As Level, _
    phase As Phase _
) As Zone
Visual C++
public:
Zone^ NewZone (
    Level^ level,
    Phase^ phase
)

Parameters

level
Level
The level on which the Zone is to exist.
phase
Phase
The associative phase on which the Zone is to exist.

Return Value

If successful a new Zone element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::InvalidOperationException | Thrown when the electrical system cannot be created by these input phase and level.

See Also

Document Class
Autodesk.Revit.Creation Namespace


PlaceGroup Method

Document..::PlaceGroup Method
CollapseAll image DropDown image

Place an instance of a Model Group into the Autodesk Revit project, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Visual Basic (Declaration)
Public Function PlaceGroup ( _
    location As XYZ, _
    groupType As GroupType _
) As Group
Visual C++
public:
Group^ PlaceGroup (
    XYZ^ location,
    GroupType^ groupType
)

Parameters

location
XYZ
The physical location where the group is to be placed.
groupType
GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

If creation was successful then an instance to the new group is returned, otherwise Nothing.

Remarks

This method is used to place a new instance of an existing group type within the project. The group's origin will placed at the point specified by the location. All group types within the project can be found by iterating over the document and looking for elements of type Autodesk.Revit.Symbols.GroupType.

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document..::eRefFace Enumeration
CollapseAll image DropDown image

Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public enum eRefFace
Visual Basic (Declaration)
Public Enumeration eRefFace
Visual C++
public enum class eRefFace

Members

Member name | Description
CenterZ | The reference face is at the middle of the element in the direction of z-axis and its normal is parallel to z-axis.
CenterY | The reference face is at the middle of the element in the direction of y-axis and its normal is parallel to y-axis.
CenterX | The reference face is at the middle of the element in the direction of x-axis and its normal is parallel to x-axis.

Remarks

Direction of the opening.

See Also

Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Class
See Also Members
CollapseAll image DropDown image

A class which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8A872B78-8DF4-4f91-AFD3-64EFEE1064E1")]
public class FamilyInstanceCreationData
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8A872B78-8DF4-4f91-AFD3-64EFEE1064E1")> _
Public Class FamilyInstanceCreationData
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8A872B78-8DF4-4f91-AFD3-64EFEE1064E1")]
public ref class FamilyInstanceCreationData

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Creation..::FamilyInstanceCreationData

See Also

FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstanceCreationData
Visual Basic (Declaration)
Public Class FamilyInstanceCreationData
Visual C++
public ref class FamilyInstanceCreationData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(Face, Line, FamilySymbol) |
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(XYZ, FamilySymbol, StructuralType) |
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(Curve, FamilySymbol, Level, StructuralType) |
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(Face, XYZ, XYZ, FamilySymbol) |
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(XYZ, FamilySymbol, Element, StructuralType) |
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(XYZ, FamilySymbol, Level, StructuralType) |
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(XYZ, FamilySymbol, Element, Level, StructuralType) |
Public method | FamilyInstanceCreationDataFamilyInstanceCreationDataNew(XYZ, FamilySymbol, XYZ, Element, StructuralType) |

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData (
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
position
Line
A line on the face defining where the symbol is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
StructuralType
Specify if the family instance is structural.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Curve
The curve where the instance is based.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData (
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
location
XYZ
Point on the face where the instance is to be placed.
referenceDirection
XYZ
A vector that defines the direction of the family instance.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
XYZ
A vector that dictates the direction of certain family instances.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Properties
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstanceCreationData
Visual Basic (Declaration)
Public Class FamilyInstanceCreationData
Visual C++
public ref class FamilyInstanceCreationData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData
Autodesk.Revit.Creation Namespace


Axis Property

FamilyInstanceCreationData..::Axis Property
CollapseAll image DropDown image

Get or set the axis of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line Axis{ get; set;}
Visual Basic (Declaration)
Public Property Axis As Line
Visual C++
public:
property Line^ Axis {
    Line^ get ();
    void set (Line^ value);
}

Remarks

The element property will be the axis while performing the rotation.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


RotateAngle Property

FamilyInstanceCreationData..::RotateAngle Property
CollapseAll image DropDown image

Get or set the rotate angle of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double RotateAngle{ get; set;}
Visual Basic (Declaration)
Public Property RotateAngle As Double
Visual C++
public:
property double RotateAngle {
    double get ();
    void set (double value);
}

Remarks

The FamilyInstance will rotate this angle when the instance is created.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


Filter Class
See Also Members
CollapseAll image DropDown image

The Filter creation object is used to create new instances of element filter utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1D9FA602-01D7-483e-A243-1564DF05E469")]
public class Filter : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1D9FA602-01D7-483e-A243-1564DF05E469")> _
Public Class Filter _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1D9FA602-01D7-483e-A243-1564DF05E469")]
public ref class Filter : public APIObject

Remarks

Elements filter related objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Creation..::Filter

See Also

Filter Members
Autodesk.Revit.Creation Namespace


Filter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Filter
Visual Basic (Declaration)
Public Class Filter
Visual C++
public ref class Filter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewCategoryFilter | Overloaded.
Public method | NewFamilyFilter | Creates a FamilyFilter object.
Public method | NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
Public method | NewLogicAndFilter | Creates a new LogicAndFilter object.
Public method | NewLogicNotFilter | Creates a new LogicNotFilter object.
Public method | NewLogicOrFilter | Creates a new LogicOrFilter object.
Public method | NewMaterialFilter | Creates a MaterialFilter object.
Public method | NewParameterFilter | Overloaded.
Public method | NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
Public method | NewSymbolFilter | Creates a SymbolFilter object.
Public method | NewTypeFilter | Overloaded.
Public method | NewWallUsageFilter | Creates a new WallUsageFilter object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter
Autodesk.Revit.Creation Namespace


Filter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Filter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Filter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


Filter Methods
CollapseAll image DropDown image

Syntax

C#
public class Filter
Visual Basic (Declaration)
Public Class Filter
Visual C++
public ref class Filter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewCategoryFilter | Overloaded.
Public method | NewFamilyFilter | Creates a FamilyFilter object.
Public method | NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
Public method | NewLogicAndFilter | Creates a new LogicAndFilter object.
Public method | NewLogicNotFilter | Creates a new LogicNotFilter object.
Public method | NewLogicOrFilter | Creates a new LogicOrFilter object.
Public method | NewMaterialFilter | Creates a MaterialFilter object.
Public method | NewParameterFilter | Overloaded.
Public method | NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
Public method | NewSymbolFilter | Creates a SymbolFilter object.
Public method | NewTypeFilter | Overloaded.
Public method | NewWallUsageFilter | Creates a new WallUsageFilter object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Filter
Autodesk.Revit.Creation Namespace


NewCategoryFilter Method

Filter..::NewCategoryFilter Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewCategoryFilter(BuiltInCategory) | Creates a new category filter object.
Public method | NewCategoryFilter(Category) | Creates a new category filter object.

See Also

Filter Class
Filter Members
Autodesk.Revit.Creation Namespace


NewCategoryFilter Method (BuiltInCategory)

Filter..::NewCategoryFilter Method (BuiltInCategory)
See Also
CollapseAll image DropDown image

Creates a new category filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryFilter NewCategoryFilter(
    BuiltInCategory builtInCat
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    builtInCat As BuiltInCategory _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter (
    BuiltInCategory builtInCat
)

Parameters

builtInCat
BuiltInCategory
Filter elements by the built-in category.

Return Value

Returns a new category filter object with given built-in category.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewCategoryFilter Method (Category)

Filter..::NewCategoryFilter Method (Category)
See Also
CollapseAll image DropDown image

Creates a new category filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryFilter NewCategoryFilter(
    Category category
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    category As Category _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter (
    Category^ category
)

Parameters

category
Category
Filter elements by the category.

Return Value

Returns a new category filter object with given category.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewFamilyFilter Method

Filter..::NewFamilyFilter Method
CollapseAll image DropDown image

Creates a FamilyFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyFilter NewFamilyFilter(
    string familyName
)
Visual Basic (Declaration)
Public Function NewFamilyFilter ( _
    familyName As String _
) As FamilyFilter
Visual C++
public:
FamilyFilter^ NewFamilyFilter (
    String^ familyName
)

Parameters

familyName
String
Filter elements by the family name.

Return Value

Returns a new family filter object with given family.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the familyName is nullptr or empty.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewInstanceUsageFilter Method

Filter..::NewInstanceUsageFilter Method
CollapseAll image DropDown image

Creates an InstanceUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceUsageFilter NewInstanceUsageFilter(
    InstanceUsage instanceUsage
)
Visual Basic (Declaration)
Public Function NewInstanceUsageFilter ( _
    instanceUsage As InstanceUsage _
) As InstanceUsageFilter
Visual C++
public:
InstanceUsageFilter^ NewInstanceUsageFilter (
    InstanceUsage instanceUsage
)

Parameters

instanceUsage
InstanceUsage
Filter elements by the instance usage.

Return Value

Returns a new instance usage filter object with given instance usage.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewLogicAndFilter Method

Filter..::NewLogicAndFilter Method
CollapseAll image DropDown image

Creates a new LogicAndFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicAndFilter NewLogicAndFilter(
    Filter leftFilter,
    Filter rightFilter
)
Visual Basic (Declaration)
Public Function NewLogicAndFilter ( _
    leftFilter As Filter, _
    rightFilter As Filter _
) As LogicAndFilter
Visual C++
public:
LogicAndFilter^ NewLogicAndFilter (
    Filter^ leftFilter,
    Filter^ rightFilter
)

Parameters

leftFilter
Filter
leftFilter is left operand of logic-and operator
rightFilter
Filter
rightFilter is right operand of logic-and operator

Return Value

Returns a new LogicAndFilter object.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewLogicNotFilter Method

Filter..::NewLogicNotFilter Method
CollapseAll image DropDown image

Creates a new LogicNotFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicNotFilter NewLogicNotFilter(
    Filter subFilter
)
Visual Basic (Declaration)
Public Function NewLogicNotFilter ( _
    subFilter As Filter _
) As LogicNotFilter
Visual C++
public:
LogicNotFilter^ NewLogicNotFilter (
    Filter^ subFilter
)

Parameters

subFilter
Filter
subFilter is an operand of logic-not operator

Return Value

Returns a new LogicNotFilter object.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewLogicOrFilter Method

Filter..::NewLogicOrFilter Method
CollapseAll image DropDown image

Creates a new LogicOrFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicOrFilter NewLogicOrFilter(
    Filter leftFilter,
    Filter rightFilter
)
Visual Basic (Declaration)
Public Function NewLogicOrFilter ( _
    leftFilter As Filter, _
    rightFilter As Filter _
) As LogicOrFilter
Visual C++
public:
LogicOrFilter^ NewLogicOrFilter (
    Filter^ leftFilter,
    Filter^ rightFilter
)

Parameters

leftFilter
Filter
leftFilter is left operand of logic-or operator.
rightFilter
Filter
rightFilter is right operand of logic-or operator.

Return Value

Returns a new LogicOrFilter object.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewMaterialFilter Method

Filter..::NewMaterialFilter Method
CollapseAll image DropDown image

Creates a MaterialFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialFilter NewMaterialFilter(
    Material material
)
Visual Basic (Declaration)
Public Function NewMaterialFilter ( _
    material As Material _
) As MaterialFilter
Visual C++
public:
MaterialFilter^ NewMaterialFilter (
    Material material
)

Parameters

material
Material
Filter elements by the material.

Return Value

Returns a new material filter object with given material.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method

Filter..::NewParameterFilter Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewParameterFilter(String, CriteriaFilterType, ElementId) | Creates a parameter filter object.
Public method | NewParameterFilter(String, CriteriaFilterType, Double) | Creates a parameter filter object.
Public method | NewParameterFilter(String, CriteriaFilterType, Int32) | Creates a parameter filter object.
Public method | NewParameterFilter(String, CriteriaFilterType, String) | Creates a parameter filter object.
Public method | NewParameterFilter(BuiltInParameter, CriteriaFilterType, ElementId) | Creates a parameter filter object.
Public method | NewParameterFilter(BuiltInParameter, CriteriaFilterType, Double) | Creates a parameter filter object.
Public method | NewParameterFilter(BuiltInParameter, CriteriaFilterType, Int32) | Creates a parameter filter object.
Public method | NewParameterFilter(BuiltInParameter, CriteriaFilterType, String) | Creates a parameter filter object.

See Also

Filter Class
Filter Members
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, ElementId)

Filter..::NewParameterFilter Method (String, CriteriaFilterType, ElementId)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    ElementId parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As ElementId _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    String^ paramDefName,
    CriteriaFilterType filterType,
    ElementId parameterValue
)

Parameters

paramDefName
String
The user visible name of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
ElementId
The parameter value that is stored as ElementId.

Return Value

Returns a new parameter filter object with given element id.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::ArgumentNullException | Thrown when the paramDefName is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, Double)

Filter..::NewParameterFilter Method (String, CriteriaFilterType, Double)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    double parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As Double _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    String^ paramDefName,
    CriteriaFilterType filterType,
    double parameterValue
)

Parameters

paramDefName
String
The user visible name of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Double
The parameter value that is stored as Double.

Return Value

Returns a new parameter filter object with given Double value.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::ArgumentNullException | Thrown when the paramDefName is nullptr.
System..::NotFiniteNumberException | Thrown when the parameterValue is infinite values, such as double.NegativeInfinite.
System..::ArgumentException | Thrown when the parameterValue is not number, such as double.Nan.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, Int32)

Filter..::NewParameterFilter Method (String, CriteriaFilterType, Int32)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    int parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As Integer _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    String^ paramDefName,
    CriteriaFilterType filterType,
    int parameterValue
)

Parameters

paramDefName
String
The user visible name of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Int32
The parameter value that is stored as Integer.

Return Value

Returns a new parameter filter object with given Integer value.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::ArgumentNullException | Thrown when the paramDefName is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, String)

Filter..::NewParameterFilter Method (String, CriteriaFilterType, String)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    string parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As String _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    String^ paramDefName,
    CriteriaFilterType filterType,
    String^ parameterValue
)

Parameters

paramDefName
String
The user visible name of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
String
The parameter value that is stored as String.

Return Value

Returns a new parameter filter object with given string.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::ArgumentNullException | Thrown when the paramDefName or parameterValue is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, ElementId)

Filter..::NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, ElementId)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    ElementId parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As ElementId _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    ElementId parameterValue
)

Parameters

builtinParameter
BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
ElementId
The parameter value that is stored as ElementId.

Return Value

Returns a new parameter filter object with given element id.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Double)

Filter..::NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Double)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    double parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As Double _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    double parameterValue
)

Parameters

builtinParameter
BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Double
The parameter value that is stored as Double.

Return Value

Returns a new parameter filter object with given Double value.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::NotFiniteNumberException | Thrown when the parameterValue is infinite values, such as double.NegativeInfinite.
System..::ArgumentException | Thrown when the parameterValue is not number, such as double.Nan.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Int32)

Filter..::NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Int32)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    int parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As Integer _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    int parameterValue
)

Parameters

builtinParameter
BuiltInParameter
The built-in parameter id of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Int32
The parameter value that is stored as Integer.

Return Value

Returns a new parameter filter object with given Integer value.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, String)

Filter..::NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, String)
See Also
CollapseAll image DropDown image

Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    string parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As String _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    String^ parameterValue
)

Parameters

builtinParameter
BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
String
The parameter value that is stored as String.

Return Value

Returns a new parameter filter object with given string.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::ArgumentNullException | Thrown when the parameterValue is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewStructuralTypeFilter Method

Filter..::NewStructuralTypeFilter Method
CollapseAll image DropDown image

Creates a StructuralTypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StructuralTypeFilter NewStructuralTypeFilter(
    StructuralType structType
)
Visual Basic (Declaration)
Public Function NewStructuralTypeFilter ( _
    structType As StructuralType _
) As StructuralTypeFilter
Visual C++
public:
StructuralTypeFilter^ NewStructuralTypeFilter (
    StructuralType structType
)

Parameters

structType
StructuralType
Filter elements by the structural type.

Return Value

Returns a new structural type filter object with given structural type.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewSymbolFilter Method

Filter..::NewSymbolFilter Method
CollapseAll image DropDown image

Creates a SymbolFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SymbolFilter NewSymbolFilter(
    string symbolName
)
Visual Basic (Declaration)
Public Function NewSymbolFilter ( _
    symbolName As String _
) As SymbolFilter
Visual C++
public:
SymbolFilter^ NewSymbolFilter (
    String^ symbolName
)

Parameters

symbolName
String
Filter elements by the symbol name.

Return Value

Returns a new symbol filter object with given symbol.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the symbolName is nullptr or empty.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewTypeFilter Method

Filter..::NewTypeFilter Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewTypeFilter(Type) | Creates a new TypeFilter object.
Public method | NewTypeFilter(Type, Boolean) | Creates a new TypeFilter object.

See Also

Filter Class
Filter Members
Autodesk.Revit.Creation Namespace


NewTypeFilter Method (Type)

Filter..::NewTypeFilter Method (Type)
See Also
CollapseAll image DropDown image

Creates a new TypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter (
    Type^ givenType
)

Parameters

givenType
Type
Filter elements by the given type.

Return Value

Returns a new type filter object within given type.

Remarks

It will not find out the elements which is given type's derived classes.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewTypeFilter Method (Type, Boolean)

Filter..::NewTypeFilter Method (Type, Boolean)
See Also
CollapseAll image DropDown image

Creates a new TypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType,
    bool includeDerivedTypes
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type, _
    includeDerivedTypes As Boolean _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter (
    Type^ givenType,
    bool includeDerivedTypes
)

Parameters

givenType
Type
Filter elements by the given type.
includeDerivedTypes
Boolean
Indicates if find out the elements which are given type's derived classes or not. If includeDerivedTypes is true, will filter derived class elements; false, don't filter derived class elements.

Return Value

Returns a new type filter object within given type.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewWallUsageFilter Method

Filter..::NewWallUsageFilter Method
CollapseAll image DropDown image

Creates a new WallUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallUsageFilter NewWallUsageFilter(
    WallUsage wallUsage
)
Visual Basic (Declaration)
Public Function NewWallUsageFilter ( _
    wallUsage As WallUsage _
) As WallUsageFilter
Visual C++
public:
WallUsageFilter^ NewWallUsageFilter (
    WallUsage wallUsage
)

Parameters

wallUsage
WallUsage
Filter elements by the wall usage.

Return Value

Returns a new wall usage filter object with given wall usage.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Class
See Also Members
CollapseAll image DropDown image

A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E95CCAE9-2D77-4006-93BB-8E5E04BE4263")]
public class ProfiledWallCreationData
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E95CCAE9-2D77-4006-93BB-8E5E04BE4263")> _
Public Class ProfiledWallCreationData
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E95CCAE9-2D77-4006-93BB-8E5E04BE4263")]
public ref class ProfiledWallCreationData

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Creation..::ProfiledWallCreationData

See Also

ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Members
See Also Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProfiledWallCreationData
Visual Basic (Declaration)
Public Class ProfiledWallCreationData
Visual C++
public ref class ProfiledWallCreationData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProfiledWallCreationDataProfiledWallCreationDataNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

ProfiledWallCreationData
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ProfiledWallCreationDataProfiledWallCreationDataNew(CurveArray, Boolean) |
Public method | ProfiledWallCreationDataProfiledWallCreationDataNew(CurveArray, WallType, Level, Boolean) |
Public method | ProfiledWallCreationDataProfiledWallCreationDataNew(CurveArray, WallType, Level, Boolean, XYZ) |

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, Boolean)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
)
Visual C++
public:
ProfiledWallCreationData (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.
normal
XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Class
See Also Members
CollapseAll image DropDown image

A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("40C14A23-A8DD-46d1-8D67-D4CA7919715B")]
public class RectangularWallCreationData
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("40C14A23-A8DD-46d1-8D67-D4CA7919715B")> _
Public Class RectangularWallCreationData
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"40C14A23-A8DD-46d1-8D67-D4CA7919715B")]
public ref class RectangularWallCreationData

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Creation..::RectangularWallCreationData

See Also

RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Members
See Also Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class RectangularWallCreationData
Visual Basic (Declaration)
Public Class RectangularWallCreationData
Visual C++
public ref class RectangularWallCreationData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RectangularWallCreationDataRectangularWallCreationDataNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

RectangularWallCreationData
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | RectangularWallCreationDataRectangularWallCreationDataNew(Curve, Level, Boolean) |
Public method | RectangularWallCreationDataRectangularWallCreationDataNew(Curve, WallType, Level, Double, Double, Boolean, Boolean) |

See Also

RectangularWallCreationData Class
RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, Level, Boolean)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData (
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData (
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
height
Double
The height of the wall.
offset
Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Class
See Also Members
CollapseAll image DropDown image

A class which wraps the arguments of Room for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B0592179-B808-4ad2-9672-1A6790484811")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RoomCreationData
Visual Basic (Declaration)
<GuidAttribute("B0592179-B808-4ad2-9672-1A6790484811")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RoomCreationData
Visual C++
[GuidAttribute(L"B0592179-B808-4ad2-9672-1A6790484811")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RoomCreationData

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Creation..::RoomCreationData

See Also

RoomCreationData Members
Autodesk.Revit.Creation Namespace


RoomCreationData Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class RoomCreationData
Visual Basic (Declaration)
Public Class RoomCreationData
Visual C++
public ref class RoomCreationData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoomCreationDataRoomCreationDataNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | TagPoint | Get or set the location of room tag.

See Also

RoomCreationData
Autodesk.Revit.Creation Namespace


RoomCreationData Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomCreationData(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Sub New ( _
    level As Level, _
    point As UV _
)
Visual C++
public:
RoomCreationData (
    Level^ level,
    UV^ point
)

Parameters

level
Level
- The level on which the room is to exist.
point
UV
A 2D point the dictates the location on that specified level.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Properties
CollapseAll image DropDown image

Syntax

C#
public class RoomCreationData
Visual Basic (Declaration)
Public Class RoomCreationData
Visual C++
public ref class RoomCreationData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | TagPoint | Get or set the location of room tag.

See Also

RoomCreationData
Autodesk.Revit.Creation Namespace


TagPoint Property

RoomCreationData..::TagPoint Property
CollapseAll image DropDown image

Get or set the location of room tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV TagPoint{ get; set;}
Visual Basic (Declaration)
Public Property TagPoint As UV
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Class
See Also Members
CollapseAll image DropDown image

A class which wraps the arguments of TextNote for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("96242625-1B2E-4ab4-8341-DC50A1463175")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class TextNoteCreationData
Visual Basic (Declaration)
<GuidAttribute("96242625-1B2E-4ab4-8341-DC50A1463175")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class TextNoteCreationData
Visual C++
[GuidAttribute(L"96242625-1B2E-4ab4-8341-DC50A1463175")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TextNoteCreationData

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Creation..::TextNoteCreationData

See Also

TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Members
See Also Methods Constructors
CollapseAll image DropDown image

Syntax

C#
public class TextNoteCreationData
Visual Basic (Declaration)
Public Class TextNoteCreationData
Visual C++
public ref class TextNoteCreationData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TextNoteCreationDataTextNoteCreationDataNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

TextNoteCreationData
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | TextNoteCreationDataTextNoteCreationDataNew(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) |
Public method | TextNoteCreationDataTextNoteCreationDataNew(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) |

See Also

TextNoteCreationData Class
TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData (
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
View
The View for TextNote.
origin
XYZ
Origin of the TextNote.
baseVec
XYZ
BaseVec parameter of the TextNote.
upVec
XYZ
UpVec parameter of the TextNote.
lineWidth
Double
Line width of the out rectangle.
textAlign
TextAlignFlags
Align style.
leaderType
TextNoteLeaderTypes
Leader type as straight or arc.
leaderStyle
TextNoteLeaderStyles
Leader style.
leaderEnd
XYZ
End point of the leader.
leaderElbow
XYZ
Elbow point of the leader.
strText
String
Text.

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData (
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
View
The View for TextNote.
origin
XYZ
Origin of the TextNote.
baseVec
XYZ
BaseVec parameter of the TextNote.
upVec
XYZ
UpVec parameter of the TextNote.
lineWidth
Double
Line width of the out rectangle.
textAlign
TextAlignFlags
Align style.
strText
String
Text.

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


Autodesk.Revit.Editor Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Editor
Visual Basic (Declaration)
Namespace Autodesk.Revit.Editor
Visual C++
namespace Autodesk.Revit.Editor

Classes

 | Class | Description
Public class | SlabShapeCrease | A crease used in Slab Shape Editing.
Public class | SlabShapeCreaseArray | An array that can contain any number of creases used in Slab Shape Editing.
Public class | SlabShapeCreaseArrayIterator | An iterator to an array of creases used for Slab Shape Editing.
Public class | SlabShapeEditor | An object used for Slab Shape Editing.
Public class | SlabShapeVertex | A vertex used in Slab Shape Editing.
Public class | SlabShapeVertexArray | An array that can contain any number of vertices used in Slab Shape Editing.
Public class | SlabShapeVertexArrayIterator | An iterator to an array of vertices used for Slab Shape Editing.


SlabShapeCrease Class
See Also Members
CollapseAll image DropDown image

A crease used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A7DBD5D2-AF15-4c6f-BC5B-F3D3B7381AD6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SlabShapeCrease
Visual Basic (Declaration)
<GuidAttribute("A7DBD5D2-AF15-4c6f-BC5B-F3D3B7381AD6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SlabShapeCrease
Visual C++
[GuidAttribute(L"A7DBD5D2-AF15-4c6f-BC5B-F3D3B7381AD6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SlabShapeCrease

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Editor..::SlabShapeCrease

See Also

SlabShapeCrease Members
Autodesk.Revit.Editor Namespace


SlabShapeCrease Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeCrease
Visual Basic (Declaration)
Public Class SlabShapeCrease
Visual C++
public ref class SlabShapeCrease

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabShapeCreaseSlabShapeCreaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.

See Also

SlabShapeCrease
Autodesk.Revit.Editor Namespace


SlabShapeCrease Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeCrease()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCrease ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


SlabShapeCrease Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeCrease
Visual Basic (Declaration)
Public Class SlabShapeCrease
Visual C++
public ref class SlabShapeCrease

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.

See Also

SlabShapeCrease
Autodesk.Revit.Editor Namespace


CreaseType Property

SlabShapeCrease..::CreaseType Property
CollapseAll image DropDown image

The type of the crease.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeCreaseType CreaseType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CreaseType As SlabShapeCreaseType
Visual C++
public:
property SlabShapeCreaseType CreaseType {
    SlabShapeCreaseType get ();
}

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


Curve Property

SlabShapeCrease..::Curve Property
CollapseAll image DropDown image

The geometry of the crease.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


EndPoints Property

SlabShapeCrease..::EndPoints Property
CollapseAll image DropDown image

The vertices of the crease.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertexArray EndPoints{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndPoints As SlabShapeVertexArray
Visual C++
public:
property SlabShapeVertexArray^ EndPoints {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any number of creases used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D3547783-3473-43ac-B678-410B723C3C20")]
public class SlabShapeCreaseArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D3547783-3473-43ac-B678-410B723C3C20")> _
Public Class SlabShapeCreaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D3547783-3473-43ac-B678-410B723C3C20")]
public ref class SlabShapeCreaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Editor..::SlabShapeCreaseArray

See Also

SlabShapeCreaseArray Members
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeCreaseArray
Visual Basic (Declaration)
Public Class SlabShapeCreaseArray
Visual C++
public ref class SlabShapeCreaseArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabShapeCreaseArraySlabShapeCreaseArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeCreaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCreaseArray ()

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Methods
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeCreaseArray
Visual Basic (Declaration)
Public Class SlabShapeCreaseArray
Visual C++
public ref class SlabShapeCreaseArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SlabShapeCreaseArray
Autodesk.Revit.Editor Namespace


Append Method

SlabShapeCreaseArray..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    SlabShapeCrease item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As SlabShapeCrease _
)
Visual C++
public:
virtual void Append (
    SlabShapeCrease^ item
)

Parameters

item
SlabShapeCrease
The item to be added.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Clear Method

SlabShapeCreaseArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Dispose Method

SlabShapeCreaseArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


ForwardIterator Method

SlabShapeCreaseArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


GetEnumerator Method

SlabShapeCreaseArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Insert Method

SlabShapeCreaseArray..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    SlabShapeCrease item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SlabShapeCrease, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    SlabShapeCrease^ item,
    int index
)

Parameters

item
SlabShapeCrease
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


ReleaseUnmanagedResources Method

SlabShapeCreaseArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


ReverseIterator Method

SlabShapeCreaseArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeCreaseArray
Visual Basic (Declaration)
Public Class SlabShapeCreaseArray
Visual C++
public ref class SlabShapeCreaseArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray
Autodesk.Revit.Editor Namespace


IsEmpty Property

SlabShapeCreaseArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Item Property

SlabShapeCreaseArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabShapeCrease Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeCrease
Visual C++
public:
virtual property SlabShapeCrease^ Item[int index] {
    SlabShapeCrease^ get (int index);
    void set (int index, SlabShapeCrease^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Size Property

SlabShapeCreaseArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of creases used for Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0E27BFBB-C710-4a08-9916-D30BC100FBDD")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class SlabShapeCreaseArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("0E27BFBB-C710-4a08-9916-D30BC100FBDD")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class SlabShapeCreaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"0E27BFBB-C710-4a08-9916-D30BC100FBDD")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SlabShapeCreaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Editor..::SlabShapeCreaseArrayIterator

See Also

SlabShapeCreaseArrayIterator Members
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabShapeCreaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeCreaseArrayIterator
Visual C++
public ref class SlabShapeCreaseArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabShapeCreaseArrayIteratorSlabShapeCreaseArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeCreaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCreaseArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabShapeCreaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeCreaseArrayIterator
Visual C++
public ref class SlabShapeCreaseArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SlabShapeCreaseArrayIterator
Autodesk.Revit.Editor Namespace


Dispose Method

SlabShapeCreaseArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


MoveNext Method

SlabShapeCreaseArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


ReleaseUnmanagedResources Method

SlabShapeCreaseArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


Reset Method

SlabShapeCreaseArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabShapeCreaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeCreaseArrayIterator
Visual C++
public ref class SlabShapeCreaseArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator
Autodesk.Revit.Editor Namespace


Current Property

SlabShapeCreaseArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeEditor Class
See Also Members
CollapseAll image DropDown image

An object used for Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3E37F213-D13B-4aeb-B592-325733671DF9")]
public class SlabShapeEditor
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3E37F213-D13B-4aeb-B592-325733671DF9")> _
Public Class SlabShapeEditor
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3E37F213-D13B-4aeb-B592-325733671DF9")]
public ref class SlabShapeEditor

Remarks

The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Editor..::SlabShapeEditor

See Also

SlabShapeEditor Members
Autodesk.Revit.Editor Namespace


SlabShapeEditor Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeEditor
Visual Basic (Declaration)
Public Class SlabShapeEditor
Visual C++
public ref class SlabShapeEditor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabShapeEditorSlabShapeEditorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifySubElement | Overloaded.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | IsEnabled | Identifies if the slab shape editing functionality is enabled.
Public property | SlabShapeCreases | All of the creases that can be edited.
Public property | SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor
Autodesk.Revit.Editor Namespace


SlabShapeEditor Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeEditor ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeEditor Methods
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeEditor
Visual Basic (Declaration)
Public Class SlabShapeEditor
Visual C++
public ref class SlabShapeEditor

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifySubElement | Overloaded.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

SlabShapeEditor
Autodesk.Revit.Editor Namespace


DrawPoint Method

SlabShapeEditor..::DrawPoint Method
CollapseAll image DropDown image

Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic (Declaration)
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint (
    XYZ^ location
)

Parameters

location
XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return null. Drawing a point on boundary crease may increase the number of creases.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


DrawSplitLine Method

SlabShapeEditor..::DrawSplitLine Method
CollapseAll image DropDown image

Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeCreaseArray DrawSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
Visual Basic (Declaration)
Public Function DrawSplitLine ( _
    startVertex As SlabShapeVertex, _
    endVertex As SlabShapeVertex _
) As SlabShapeCreaseArray
Visual C++
public:
SlabShapeCreaseArray^ DrawSplitLine (
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)

Parameters

startVertex
SlabShapeVertex
The vertex to start the split line.
endVertex
SlabShapeVertex
The vertex to end the split line.

Return Value

The newly created creases.

Remarks

Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


Enable Method

SlabShapeEditor..::Enable Method
CollapseAll image DropDown image

Enables the slab shape editing functionality.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable ()

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


ModifySubElement Method

SlabShapeEditor..::ModifySubElement Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.

See Also

SlabShapeEditor Class
SlabShapeEditor Members
Autodesk.Revit.Editor Namespace


ModifySubElement Method (SlabShapeCrease, Double)

SlabShapeEditor..::ModifySubElement Method (SlabShapeCrease, Double)
See Also
CollapseAll image DropDown image

Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ModifySubElement(
    SlabShapeCrease pCrease,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    pCrease As SlabShapeCrease, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement (
    SlabShapeCrease^ pCrease,
    double offset
)

Parameters

pCrease
SlabShapeCrease
The crease.
offset
Double
The new value of the crease offset, which is the average of offsets of its ends.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


ModifySubElement Method (SlabShapeVertex, Double)

SlabShapeEditor..::ModifySubElement Method (SlabShapeVertex, Double)
See Also
CollapseAll image DropDown image

Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ModifySubElement(
    SlabShapeVertex pVertex,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    pVertex As SlabShapeVertex, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement (
    SlabShapeVertex^ pVertex,
    double offset
)

Parameters

pVertex
SlabShapeVertex
The vertex.
offset
Double
The new value of the vertex offset.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


PickSupport Method

SlabShapeEditor..::PickSupport Method
CollapseAll image DropDown image

Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void PickSupport(
    Line gLine
)
Visual Basic (Declaration)
Public Sub PickSupport ( _
    gLine As Line _
)
Visual C++
public:
void PickSupport (
    Line^ gLine
)

Parameters

gLine
Line
A line from a support element such as a beam.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


ResetSlabShape Method

SlabShapeEditor..::ResetSlabShape Method
CollapseAll image DropDown image

Removes the modifications made during editing and resets the element geometry back to the un-modified state.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ResetSlabShape()
Visual Basic (Declaration)
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape ()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeEditor Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeEditor
Visual Basic (Declaration)
Public Class SlabShapeEditor
Visual C++
public ref class SlabShapeEditor

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEnabled | Identifies if the slab shape editing functionality is enabled.
Public property | SlabShapeCreases | All of the creases that can be edited.
Public property | SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor
Autodesk.Revit.Editor Namespace


IsEnabled Property

SlabShapeEditor..::IsEnabled Property
CollapseAll image DropDown image

Identifies if the slab shape editing functionality is enabled.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsEnabled{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsEnabled As Boolean
Visual C++
public:
property bool IsEnabled {
    bool get ();
}

Remarks

If true, the creases and vertices are accessible and modifiable. If false, no creases and vertices are accessible.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeCreases Property

SlabShapeEditor..::SlabShapeCreases Property
CollapseAll image DropDown image

All of the creases that can be edited.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeCreaseArray SlabShapeCreases{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeCreases As SlabShapeCreaseArray
Visual C++
public:
property SlabShapeCreaseArray^ SlabShapeCreases {
    SlabShapeCreaseArray^ get ();
}

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeVertices Property

SlabShapeEditor..::SlabShapeVertices Property
CollapseAll image DropDown image

All of the vertices that can be edited.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertexArray SlabShapeVertices{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeVertices As SlabShapeVertexArray
Visual C++
public:
property SlabShapeVertexArray^ SlabShapeVertices {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeVertex Class
See Also Members
CollapseAll image DropDown image

A vertex used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("ECC709FE-5939-4db6-A4B0-2CC8578EDC6B")]
public class SlabShapeVertex
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("ECC709FE-5939-4db6-A4B0-2CC8578EDC6B")> _
Public Class SlabShapeVertex
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"ECC709FE-5939-4db6-A4B0-2CC8578EDC6B")]
public ref class SlabShapeVertex

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Editor..::SlabShapeVertex

See Also

SlabShapeVertex Members
Autodesk.Revit.Editor Namespace


SlabShapeVertex Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeVertex
Visual Basic (Declaration)
Public Class SlabShapeVertex
Visual C++
public ref class SlabShapeVertex

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabShapeVertexSlabShapeVertexNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | Position | The positon of the vertex.
Public property | VertexType | The type of the vertex.

See Also

SlabShapeVertex
Autodesk.Revit.Editor Namespace


SlabShapeVertex Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertex()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertex ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


SlabShapeVertex Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeVertex
Visual Basic (Declaration)
Public Class SlabShapeVertex
Visual C++
public ref class SlabShapeVertex

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Position | The positon of the vertex.
Public property | VertexType | The type of the vertex.

See Also

SlabShapeVertex
Autodesk.Revit.Editor Namespace


Position Property

SlabShapeVertex..::Position Property
CollapseAll image DropDown image

The positon of the vertex.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Position{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Position As XYZ
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


VertexType Property

SlabShapeVertex..::VertexType Property
CollapseAll image DropDown image

The type of the vertex.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertexType VertexType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VertexType As SlabShapeVertexType
Visual C++
public:
property SlabShapeVertexType VertexType {
    SlabShapeVertexType get ();
}

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any number of vertices used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("09374485-EAF4-46b5-9F69-D3D2A90E4588")]
public class SlabShapeVertexArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("09374485-EAF4-46b5-9F69-D3D2A90E4588")> _
Public Class SlabShapeVertexArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"09374485-EAF4-46b5-9F69-D3D2A90E4588")]
public ref class SlabShapeVertexArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Editor..::SlabShapeVertexArray

See Also

SlabShapeVertexArray Members
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeVertexArray
Visual Basic (Declaration)
Public Class SlabShapeVertexArray
Visual C++
public ref class SlabShapeVertexArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabShapeVertexArraySlabShapeVertexArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertexArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertexArray ()

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Methods
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeVertexArray
Visual Basic (Declaration)
Public Class SlabShapeVertexArray
Visual C++
public ref class SlabShapeVertexArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SlabShapeVertexArray
Autodesk.Revit.Editor Namespace


Append Method

SlabShapeVertexArray..::Append Method
CollapseAll image DropDown image

Add the item to the end of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    SlabShapeVertex item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As SlabShapeVertex _
)
Visual C++
public:
virtual void Append (
    SlabShapeVertex^ item
)

Parameters

item
SlabShapeVertex
The item to be added.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Clear Method

SlabShapeVertexArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Dispose Method

SlabShapeVertexArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


ForwardIterator Method

SlabShapeVertexArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabShapeVertexArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


GetEnumerator Method

SlabShapeVertexArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Insert Method

SlabShapeVertexArray..::Insert Method
CollapseAll image DropDown image

Insert the specified item into the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    SlabShapeVertex item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SlabShapeVertex, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    SlabShapeVertex^ item,
    int index
)

Parameters

item
SlabShapeVertex
The item to be inserted into the array.
index
Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


ReleaseUnmanagedResources Method

SlabShapeVertexArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


ReverseIterator Method

SlabShapeVertexArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabShapeVertexArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeVertexArray
Visual Basic (Declaration)
Public Class SlabShapeVertexArray
Visual C++
public ref class SlabShapeVertexArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray
Autodesk.Revit.Editor Namespace


IsEmpty Property

SlabShapeVertexArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Item Property

SlabShapeVertexArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabShapeVertex Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeVertex
Visual C++
public:
virtual property SlabShapeVertex^ Item[int index] {
    SlabShapeVertex^ get (int index);
    void set (int index, SlabShapeVertex^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Size Property

SlabShapeVertexArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of vertices used for Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E1A79C40-559F-4601-826D-DAB0DBEF4F60")]
public abstract class SlabShapeVertexArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E1A79C40-559F-4601-826D-DAB0DBEF4F60")> _
Public MustInherit Class SlabShapeVertexArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E1A79C40-559F-4601-826D-DAB0DBEF4F60")]
public ref class SlabShapeVertexArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Editor..::SlabShapeVertexArrayIterator

See Also

SlabShapeVertexArrayIterator Members
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabShapeVertexArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeVertexArrayIterator
Visual C++
public ref class SlabShapeVertexArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabShapeVertexArrayIteratorSlabShapeVertexArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertexArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertexArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabShapeVertexArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeVertexArrayIterator
Visual C++
public ref class SlabShapeVertexArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SlabShapeVertexArrayIterator
Autodesk.Revit.Editor Namespace


Dispose Method

SlabShapeVertexArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


MoveNext Method

SlabShapeVertexArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


ReleaseUnmanagedResources Method

SlabShapeVertexArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


Reset Method

SlabShapeVertexArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabShapeVertexArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeVertexArrayIterator
Visual C++
public ref class SlabShapeVertexArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator
Autodesk.Revit.Editor Namespace


Current Property

SlabShapeVertexArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


Autodesk.Revit.Elements Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Elements
Visual Basic (Declaration)
Namespace Autodesk.Revit.Elements
Visual C++
namespace Autodesk.Revit.Elements

Classes

 | Class | Description
Public class | AnnotationSymbol | This object represents a symbol of the Generic Annotation.
Public class | Area | Provides access to the area topology in Autodesk Revit.
Public class | AreaLoad | An object that represents a force applied across an area.
Public class | AreaReinforcement | An object that represents an Area Reinforcement within the Autodesk Revit project.
Public class | AreaReinforcementCurve | An object that specifies the type of a floor in Autodesk Revit.
Public class | AreaTag | Provides access to the area topology in Autodesk Revit.
Public class | BaseArray | An abstract base class that represents an array within the Revit project.
Public class | BeamSystem | An object that represents a BeamSystem within the Autodesk Revit project.
Public class | Blend | Provides access to the Blend model in Autodesk Revit.
Public class | BoundaryConditions | An object that represents a force applied across an area.
Public class | CeilingAndFloor | A base class that provides support for all ceiling and floor objects.
Public class | ConduitType | Represents a specific conduit type of wire type.
Public class | ConduitTypeSet | A set that contains conduit types.
Public class | ConduitTypeSetIterator | An iterator to a conduit type set.
Public class | ContFooting | An object that represents a Continuous Footing within Autodesk Revit.
Public class | CurtainCell | Represents a CurtainCell within Autodesk Revit.
Public class | CurtainCellSet | A set that can contain any type of object.
Public class | CurtainCellSetIterator | An iterator to a set.
Public class | CurtainGrid | Represents a CurtainGrid within Autodesk Revit. It is not an independent element.It represents a CurtainGrid from a curtain wall,curtain system or curtain roof. Curtain wall has only one CurtainGrid,curtain system or curtain roof may have several CurtainGrids.
Public class | CurtainGridLine | Represents a CurtainGridLine within Autodesk Revit.
Public class | CurtainGridSet | A set that can contain any type of object.
Public class | CurtainGridSetIterator | An iterator to a set.
Public class | CurtainSystem | Provides access to the CurtainSystem object in Autodesk Revit.
Public class | CurtainSystemBase | Provides access to the CurtainSystemBase object in Autodesk Revit.
Public class | DesignOption | An element that represents a design alternative.
Public class | DetailArc | Represents a DetailArc within Autodesk Revit.
Public class | DetailCurve | Represents a DetailCurve within Autodesk Revit.
Public class | DetailCurveArray | An array that can contain any type of object.
Public class | DetailCurveArrayIterator | An iterator to a array.
Public class | DetailEllipse | Represents a DetailEllipse within Autodesk Revit.
Public class | DetailLine | Represents a DetailLine within Autodesk Revit.
Public class | DetailNurbSpline | Represents a DetailNurbSpline within Autodesk Revit.
Public class | Dimension | An object that represents a dimension within the Revit project.
Public class | ElectricalSystem | Provides access to the Electrical System in Autodesk Revit MEP.
Public class | ElectricalSystemSet | A set that can contain any type of object.
Public class | ElectricalSystemSetIterator | An iterator to a set.
Public class | Extrusion | Provides access to the Extrusion model in Autodesk Revit.
Public class | ExtrusionRoof | Represents some kinds of Extrusion Roofs.
Public class | Family | The Family object is a Symbol that defines an entire family.
Public class | FamilyBase | A base class for all Family objects.
Public class | FamilyInstance | This object represents a single instance of a family type, such as a single I beam.
Public class | Fascia | An object that represents a fascia within the Autodesk Revit project.
Public class | FillPattern | Represents a fill pattern element within an Autodesk Revit project.
Public class | Floor | An object that represents a Floor within the Autodesk Revit project.
Public class | FootPrintRoof | Represents kinds of FootPrintRoofs.
Public class | gbXMLParamElem | An object that represents the gbXML Parameters within the Autodesk Revit project.
Public class | GenericForm | Provides access to the Generic Form model in Autodesk Revit.
Public class | GenericFormSet | A set that can contain any type of object.
Public class | GenericFormSetIterator | An iterator to a set.
Public class | Grid | Represents a single grid line within Autodesk Revit.
Public class | Group | This object represents a group of elements within the project.
Public class | GroupSet | An set that contains groups.
Public class | GroupSetIterator | An iterator to a group set.
Public class | Gutter | An object that represents a gutter within the Autodesk Revit project.
Public class | HostedSweep | An object that represents a roof within the Autodesk Revit project.
Public class | HostObject | A base class that provides support for all objects that can host other objects, such as a wall.
Public class | IndependentTag | Represents a IndependentTag within Autodesk Revit.
Public class | InsertableInstance | A base class that provides support insertable instances.
Public class | Instance | A base class for all instance objects.
Public class | InsulationType | Represents electrical insulation type definition information.
Public class | InsulationTypeSet | A set that contains insulation types.
Public class | InsulationTypeSetIterator | An iterator to a insulation type set.
Public class | LayoutRule | The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Public class | LayoutRuleClearSpacing | This class indicate the layout rule of a Beam System is Clear-Spacing.
Public class | LayoutRuleFixedDistance | This class indicate the layout rule of a Beam System is Fixed-Distance.
Public class | LayoutRuleFixedNumber | This class indicate the layout rule of a Beam System is Fixed-Number.
Public class | LayoutRuleMaximumSpacing | This class indicate the layout rule of a Beam System is Max-Spacing.
Public class | Level | Represents a Level line within Autodesk Revit.
Public class | LinearArray | An object that represents an Array created linearly within the Revit project.
Public class | LineLoad | An object that represents a force/moment applied in a linear manner.
Public class | LinePattern | Represents a line pattern element within an Autodesk Revit project.
Public class | LoadBase | The LoadBase object is the base class for all load objects within the Autodesk Revit API.
Public class | LoadCase | This object represents a load case within the project.
Public class | LoadCaseArray | An array that contains load case objects.
Public class | LoadCaseArrayIterator | An iterator to an load case array.
Public class | LoadCaseSet | A set that contains load cases.
Public class | LoadCaseSetIterator | An iterator to a load case set.
Public class | LoadCombination | An object that represents a load combination.
Public class | LoadCombinationArray | An array that can contain any type of object.
Public class | LoadCombinationArrayIterator | An iterator to a array.
Public class | LoadNature | A structural Load nature object.
Public class | LoadUsage | This object represents a load case within the project.
Public class | LoadUsageArray | An array that contains load usage objects.
Public class | LoadUsageArrayIterator | An iterator to an load usage array.
Public class | Material | Represents a material element within an Autodesk Revit project.
Public class | MaterialConcrete | Represents a concrete material element in an Autodesk Revit project.
Public class | MaterialGeneric | Represents a generic material element in an Autodesk Revit project.
Public class | MaterialOther | Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.
Public class | MaterialSteel | Represents a steel material element in an Autodesk Revit project.
Public class | MaterialWood | Represents a wood material element in an Autodesk Revit project.
Public class | ModelArc | Represents a ModelArc within Autodesk Revit.
Public class | ModelCurve | Represents a ModelCurve within Autodesk Revit.
Public class | ModelCurveArrArray | An array that can contain any type of object.
Public class | ModelCurveArrArrayIterator | An iterator to a array.
Public class | ModelCurveArray | An array that contains model curves.
Public class | ModelCurveArrayIterator | An iterator to a model curve array.
Public class | ModelEllipse | Represents a ModelEllipse within Autodesk Revit.
Public class | ModelHermiteSpline | Represents a ModelHermiteSpline within Autodesk Revit.
Public class | ModelLine | Represents a ModelLine within Autodesk Revit.
Public class | ModelNurbSpline | Represents a ModelNurbSpline within Autodesk Revit.
Public class | Mullion | Represents a CurtainGrid within Autodesk Revit.
Public class | Opening | An object that represents a Opening within the Autodesk Revit project.
Public class | Panel | This object represents a curtain panel.
Public class | Path3d | Provides access to the Generic 3D path object in Autodesk Revit.
Public class | PathReinforcement | An object that represents an Path Reinforcement within the Autodesk Revit project.
Public class | Phase | Represents a phase in the life of a building.
Public class | PhaseArray | An array that contains phase objects.
Public class | PhaseArrayIterator | An iterator to a phase array.
Public class | PointLoad | An object that represents a force/moment applied to a single point.
Public class | PrintSetting | Represents the Print Setup (File->Print Setup...) within Autodesk Revit.
Public class | ProjectInfo | An object that represents a Project Information within the Autodesk Revit project.
Public class | ProjectUnit | Provides access to the Project Unit... in Autodesk Revit.
Public class | RadialArray | An object that represents an Array created radially within the Revit project.
Public class | Rebar | An object that represents Rebar.
Public class | RebarHostData | Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.
Public class | ReferencePlane | Represents a reference plane of Autodesk Revit.
Public class | Revolution | Provides access to the Revolution Form model in Autodesk Revit.
Public class | RoofBase | Represents all kinds of Roofs.
Public class | Room | Provides access to the room topology in Autodesk Revit.
Public class | RoomTag | Provides access to the room tag in Autodesk Revit.
Public class | Sketch | Provides access to the Sketch in Autodesk Revit.
Public class | SketchBase | Provides access to the SketchBase in Autodesk Revit.
Public class | SketchPlane | Represents a SketchPlane within Autodesk Revit.
Public class | SketchSet | A set that can contain any type of object.
Public class | SketchSetIterator | An iterator to a set.
Public class | SlabEdge | An object that represents a slab edge within the Autodesk Revit project.
Public class | Space | Provides access to the space topology in Autodesk Revit.
Public class | SpaceSet | A set that can contain any type of object.
Public class | SpaceSetIterator | An iterator to a set.
Public class | SpaceTag | Provides access to the space tag in Autodesk Revit.
Public class | SpotDimension | An object that represents a spot dimension within the Revit project.
Public class | Sweep | Provides access to the Sweep model in Autodesk Revit.
Public class | TemperatureRatingType | Represents temperature rating type definition information.
Public class | TemperatureRatingTypeSet | A set that contains TemperatureRating types.
Public class | TemperatureRatingTypeSetIterator | An iterator to a TemperatureRating type set.
Public class | TextElement | Represents the TextElment.
Public class | TextNote | Provides access to the TextNote object in Autodesk Revit.
Public class | Truss | Represents all kinds of Trusses.
Public class | View | Base class for Revit Views.
Public class | View3D | A freely-oriented orthographic or perspective view of the model.
Public class | ViewDrafting | A drafting view allows the user to draw graphics without including them in the model.
Public class | ViewPlan | A plan represents for floor plan or ceiling plan.
Public class | ViewSection | A section view cuts through the model to expose its interior structure.
Public class | ViewSet | A set that contains views.
Public class | ViewSetIterator | An iterator to a view set.
Public class | ViewSheet | A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.
Public class | ViewSheetSet | Represents all kinds of ViewSheetSets.
Public class | ViewSheetSets | A set that can contain any type of object.
Public class | ViewSheetSetsIterator | An iterator to a set.
Public class | Wall | Represents all of the different kinds of walls Autodesk Revit.
Public class | Wire | An object to represent electrical wire in Revit MEP product.
Public class | WireMaterialType | Represents electrical wire material type definition information of wire type.
Public class | WireMaterialTypeSet | A set that contains wire material types.
Public class | WireMaterialTypeSetIterator | An iterator to a wire material type set.
Public class | WireSet | A set that can contain any type of object.
Public class | WireSetIterator | An iterator to a set.
Public class | Zone | Provides access to the Zone Element in Autodesk Revit.


AnnotationSymbol Class
See Also Members
CollapseAll image DropDown image

This object represents a symbol of the Generic Annotation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F09BD497-A1D9-493d-82CF-95978B03059A")]
public class AnnotationSymbol : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F09BD497-A1D9-493d-82CF-95978B03059A")> _
Public Class AnnotationSymbol _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F09BD497-A1D9-493d-82CF-95978B03059A")]
public ref class AnnotationSymbol : public Element

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::AnnotationSymbol

See Also

AnnotationSymbol Members
Autodesk.Revit.Elements Namespace


AnnotationSymbol Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbol
Visual Basic (Declaration)
Public Class AnnotationSymbol
Visual C++
public ref class AnnotationSymbol

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnnotationSymbolAnnotationSymbolNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | addLeader | add a leader to this annotation symbol.
Public method | duplicate | Duplicate this annotation symbol.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | removeLeader | remove a leader of this annotation symbol.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leaders | Get all the leaders of this annotation symbol.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AnnotationSymbol
Autodesk.Revit.Elements Namespace


AnnotationSymbol Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbol ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AnnotationSymbol Methods
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbol
Visual Basic (Declaration)
Public Class AnnotationSymbol
Visual C++
public ref class AnnotationSymbol

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | addLeader | add a leader to this annotation symbol.
Public method | duplicate | Duplicate this annotation symbol.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | removeLeader | remove a leader of this annotation symbol.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

AnnotationSymbol
Autodesk.Revit.Elements Namespace


addLeader Method

AnnotationSymbol..::addLeader Method
CollapseAll image DropDown image

add a leader to this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void addLeader()
Visual Basic (Declaration)
Public Sub addLeader
Visual C++
public:
void addLeader ()

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


duplicate Method

AnnotationSymbol..::duplicate Method
CollapseAll image DropDown image

Duplicate this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbol duplicate()
Visual Basic (Declaration)
Public Function duplicate As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ duplicate ()

Return Value

Pointer to the new annotation symbol.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


removeLeader Method

AnnotationSymbol..::removeLeader Method
CollapseAll image DropDown image

remove a leader of this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void removeLeader()
Visual Basic (Declaration)
Public Sub removeLeader
Visual C++
public:
void removeLeader ()

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AnnotationSymbol Properties
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbol
Visual Basic (Declaration)
Public Class AnnotationSymbol
Visual C++
public ref class AnnotationSymbol

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leaders | Get all the leaders of this annotation symbol.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AnnotationSymbol
Autodesk.Revit.Elements Namespace


AnnotationSymbolType Property

AnnotationSymbol..::AnnotationSymbolType Property
CollapseAll image DropDown image

The AnnotationSymbol style of this AnnotationSymbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbolType AnnotationSymbolType{ get; set;}
Visual Basic (Declaration)
Public Property AnnotationSymbolType As AnnotationSymbolType
Visual C++
public:
property AnnotationSymbolType^ AnnotationSymbolType {
    AnnotationSymbolType^ get ();
    void set (AnnotationSymbolType^ value);
}

Remarks

The AnnotationSymbolType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a annotation by setting it to a different type. All the annotation symbol types in the project can be found using the Document.AnnotationSymbolTypes property.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AsFamilyInstance Property

AnnotationSymbol..::AsFamilyInstance Property
CollapseAll image DropDown image

This property is used to get family instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance AsFamilyInstance{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

The AsFamilyInstance property returns an family instance that can be used to stand for this annotation within the project.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


Leaders Property

AnnotationSymbol..::Leaders Property
CollapseAll image DropDown image

Get all the leaders of this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LeaderArray Leaders{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Leaders As LeaderArray
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Return Value

The Leaders property returns a leader array that contains all the leaders of this annotation symbol.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


Location Property

AnnotationSymbol..::Location Property
CollapseAll image DropDown image

This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an instance within the project.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


Parameter Property

AnnotationSymbol..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members
Autodesk.Revit.Elements Namespace


Area Class
See Also Members
CollapseAll image DropDown image

Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("576F8B9E-55DE-4E08-B520-C0B922FBEA0E")]
public class Area : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("576F8B9E-55DE-4E08-B520-C0B922FBEA0E")> _
Public Class Area _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"576F8B9E-55DE-4E08-B520-C0B922FBEA0E")]
public ref class Area : public Element

Remarks

The area object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Area

See Also

Area Members
Autodesk.Revit.Elements Namespace


Area Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Area
Visual Basic (Declaration)
Public Class Area
Visual C++
public ref class Area

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaAreaNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Boundary | Returns the boundary of the area.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the area. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Name of the Number.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Area
Autodesk.Revit.Elements Namespace


Area Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Area()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Area ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Area Properties
CollapseAll image DropDown image

Syntax

C#
public class Area
Visual Basic (Declaration)
Public Class Area
Visual C++
public ref class Area

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Boundary | Returns the boundary of the area.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the area. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Name of the Number.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Area
Autodesk.Revit.Elements Namespace


Boundary Property

Area..::Boundary Property
CollapseAll image DropDown image

Returns the boundary of the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArray Boundary{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the area. Each area may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Area.BoundarySegment object for more details about the segments that make up the area topology.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Location Property

Area..::Location Property
CollapseAll image DropDown image

get a location point object. The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

Area Class
Autodesk.Revit.Elements Namespace


Name Property

Area..::Name Property
CollapseAll image DropDown image

Get or Set the Name of the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the area.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Number Property

Area..::Number Property
CollapseAll image DropDown image

Get or Set the Name of the Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Number{ get; set;}
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Number of the area.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Parameter Property

Area..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Area Class
Area Members
Autodesk.Revit.Elements Namespace


AreaLoad Class
See Also Members
CollapseAll image DropDown image

An object that represents a force applied across an area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A44986F9-5DCC-4c3d-9FA2-4C23886AADD1")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AreaLoad : LoadBase
Visual Basic (Declaration)
<GuidAttribute("A44986F9-5DCC-4c3d-9FA2-4C23886AADD1")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AreaLoad _
    Inherits LoadBase
Visual C++
[GuidAttribute(L"A44986F9-5DCC-4c3d-9FA2-4C23886AADD1")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaLoad : public LoadBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::AreaLoad

See Also

AreaLoad Members
Autodesk.Revit.Elements Namespace


AreaLoad Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaLoad
Visual Basic (Declaration)
Public Class AreaLoad
Visual C++
public ref class AreaLoad

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaLoadAreaLoadNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Public property | Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Public property | Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves within a geometric loop that defines the area.
Public property | NumLoops | Returns the number of geometric curve loops that define the area.
Public property | NumRefPoints | Returns the total number of reference points for the area load.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RefPoint | Retrieve the physical location of the reference point.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoad
Autodesk.Revit.Elements Namespace


AreaLoad Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoad ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


AreaLoad Methods
CollapseAll image DropDown image

Syntax

C#
public class AreaLoad
Visual Basic (Declaration)
Public Class AreaLoad
Visual C++
public ref class AreaLoad

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

AreaLoad
Autodesk.Revit.Elements Namespace


Dispose Method

AreaLoad..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


AreaLoad Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaLoad
Visual Basic (Declaration)
Public Class AreaLoad
Visual C++
public ref class AreaLoad

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Public property | Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Public property | Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves within a geometric loop that defines the area.
Public property | NumLoops | Returns the number of geometric curve loops that define the area.
Public property | NumRefPoints | Returns the total number of reference points for the area load.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RefPoint | Retrieve the physical location of the reference point.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoad
Autodesk.Revit.Elements Namespace


Curve Property

AreaLoad..::Curve Property
CollapseAll image DropDown image

Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve[
    int loopIndex,
    int curveIndex
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    loopIndex As Integer, _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int loopIndex, int curveIndex] {
    Curve^ get (int loopIndex, int curveIndex);
}

Parameters

loopIndex
Int32
The index of the geometric loop.
curveIndex
Int32
The index curve within the loop.

Remarks

The loop index should be between 0 and less than NumLoops. The curve index should be between 0 and less than NumCurves(loopIndex).

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force Property

AreaLoad..::Force Property
CollapseAll image DropDown image

Returns the three dimensional force applied to one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints. The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force1 Property

AreaLoad..::Force1 Property
CollapseAll image DropDown image

Returns the three dimensional force applied to the point 1 of the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force1{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force1 As XYZ
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force2 Property

AreaLoad..::Force2 Property
CollapseAll image DropDown image

Returns the three dimensional force applied to the point 2 of the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force2{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force2 As XYZ
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force3 Property

AreaLoad..::Force3 Property
CollapseAll image DropDown image

Returns the three dimensional force applied to the point 3 of the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force3{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force3 As XYZ
Visual C++
public:
property XYZ^ Force3 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


NumCurves Property

AreaLoad..::NumCurves Property
CollapseAll image DropDown image

Returns the number of curves within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumCurves[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumCurves ( _
    index As Integer _
) As Integer
Visual C++
public:
property int NumCurves[int index] {
    int get (int index);
}

Parameters

index
Int32
The index of the geometric loop.

Remarks

The index should be between 0 and less than NumLoops.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


NumLoops Property

AreaLoad..::NumLoops Property
CollapseAll image DropDown image

Returns the number of geometric curve loops that define the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumLoops{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumLoops As Integer
Visual C++
public:
property int NumLoops {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


NumRefPoints Property

AreaLoad..::NumRefPoints Property
CollapseAll image DropDown image

Returns the total number of reference points for the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumRefPoints{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumRefPoints As Integer
Visual C++
public:
property int NumRefPoints {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Parameter Property

AreaLoad..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AreaLoad Class
AreaLoad Members
Autodesk.Revit.Elements Namespace


RefPoint Property

AreaLoad..::RefPoint Property
CollapseAll image DropDown image

Retrieve the physical location of the reference point.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ RefPoint[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RefPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ RefPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


AreaReinforcement Class
See Also Members
CollapseAll image DropDown image

An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67B97E86-7979-48c0-A81C-A189CE899019")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AreaReinforcement : Element
Visual Basic (Declaration)
<GuidAttribute("67B97E86-7979-48c0-A81C-A189CE899019")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AreaReinforcement _
    Inherits Element
Visual C++
[GuidAttribute(L"67B97E86-7979-48c0-A81C-A189CE899019")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::AreaReinforcement

See Also

AreaReinforcement Members
Autodesk.Revit.Elements Namespace


AreaReinforcement Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcement
Visual Basic (Declaration)
Public Class AreaReinforcement
Visual C++
public ref class AreaReinforcement

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaReinforcementAreaReinforcementNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AreaReinforcementType | Retrieves the type of the Area Reinforcement.
Public property | BarDescription | Retrieves the Bar Table property of an Area Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | Retrieves the array of curves forming the boundary of the Area Reinforcement.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcement
Autodesk.Revit.Elements Namespace


AreaReinforcement Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaReinforcement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaReinforcement ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


AreaReinforcement Methods
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcement
Visual Basic (Declaration)
Public Class AreaReinforcement
Visual C++
public ref class AreaReinforcement

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

AreaReinforcement
Autodesk.Revit.Elements Namespace


Dispose Method

AreaReinforcement..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


AreaReinforcement Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcement
Visual Basic (Declaration)
Public Class AreaReinforcement
Visual C++
public ref class AreaReinforcement

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AreaReinforcementType | Retrieves the type of the Area Reinforcement.
Public property | BarDescription | Retrieves the Bar Table property of an Area Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | Retrieves the array of curves forming the boundary of the Area Reinforcement.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcement
Autodesk.Revit.Elements Namespace


AreaReinforcementType Property

AreaReinforcement..::AreaReinforcementType Property
CollapseAll image DropDown image

Retrieves the type of the Area Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaReinforcementType AreaReinforcementType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AreaReinforcementType As AreaReinforcementType
Visual C++
public:
property AreaReinforcementType^ AreaReinforcementType {
    AreaReinforcementType^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


BarDescription Property

AreaReinforcement..::BarDescription Property
CollapseAll image DropDown image

Retrieves the Bar Table property of an Area Reinforcement element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BarDescription BarDescription[
    int idx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
Visual C++
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Int32
Index of a Bar Description.

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


Curves Property

AreaReinforcement..::Curves Property
CollapseAll image DropDown image

Retrieves the array of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


Direction Property

AreaReinforcement..::Direction Property
CollapseAll image DropDown image

Retrieve or change the Major Direction of the Area Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Direction{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


NumBarDescriptions Property

AreaReinforcement..::NumBarDescriptions Property
CollapseAll image DropDown image

Retrieves the number of distinct bar shapes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumBarDescriptions{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumBarDescriptions As Integer
Visual C++
public:
property int NumBarDescriptions {
    int get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


Parameter Property

AreaReinforcement..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AreaReinforcement Class
AreaReinforcement Members
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9D1585BB-A0CC-43aa-A6F4-E744168999A5")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AreaReinforcementCurve : Element
Visual Basic (Declaration)
<GuidAttribute("9D1585BB-A0CC-43aa-A6F4-E744168999A5")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AreaReinforcementCurve _
    Inherits Element
Visual C++
[GuidAttribute(L"9D1585BB-A0CC-43aa-A6F4-E744168999A5")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaReinforcementCurve : public Element

Remarks

The structural layers of the floor can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::AreaReinforcementCurve

See Also

AreaReinforcementCurve Members
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcementCurve
Visual Basic (Declaration)
Public Class AreaReinforcementCurve
Visual C++
public ref class AreaReinforcementCurve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaReinforcementCurveAreaReinforcementCurveNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcementCurve
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaReinforcementCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaReinforcementCurve ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Methods
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcementCurve
Visual Basic (Declaration)
Public Class AreaReinforcementCurve
Visual C++
public ref class AreaReinforcementCurve

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

AreaReinforcementCurve
Autodesk.Revit.Elements Namespace


Dispose Method

AreaReinforcementCurve..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcementCurve
Visual Basic (Declaration)
Public Class AreaReinforcementCurve
Visual C++
public ref class AreaReinforcementCurve

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcementCurve
Autodesk.Revit.Elements Namespace


Curve Property

AreaReinforcementCurve..::Curve Property
CollapseAll image DropDown image

Returns the 3D curve forming part of the boundary of an Area Reinforcement element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


Parameter Property

AreaReinforcementCurve..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
AreaReinforcementCurve Members
Autodesk.Revit.Elements Namespace


AreaTag Class
See Also Members
CollapseAll image DropDown image

Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F86DFBD1-746D-431F-91EB-9EA240357660")]
public class AreaTag : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F86DFBD1-746D-431F-91EB-9EA240357660")> _
Public Class AreaTag _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F86DFBD1-746D-431F-91EB-9EA240357660")]
public ref class AreaTag : public Element

Remarks

The areaTag object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::AreaTag

See Also

AreaTag Members
Autodesk.Revit.Elements Namespace


AreaTag Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaTag
Visual Basic (Declaration)
Public Class AreaTag
Visual C++
public ref class AreaTag

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaTagAreaTagNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Area | Returns the area that the tag is associated with.
Public property | AreaTagType | get/set the type.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | get/set the display attribute of Leader.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. (Overrides Element ..:: Location.)
Public property | Name | Retrieve or Change the name associated with the AreaTag. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Returns the view in which the tag was place.

See Also

AreaTag
Autodesk.Revit.Elements Namespace


AreaTag Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTag ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


AreaTag Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaTag
Visual Basic (Declaration)
Public Class AreaTag
Visual C++
public ref class AreaTag

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | Returns the area that the tag is associated with.
Public property | AreaTagType | get/set the type.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | get/set the display attribute of Leader.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. (Overrides Element ..:: Location.)
Public property | Name | Retrieve or Change the name associated with the AreaTag. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Returns the view in which the tag was place.

See Also

AreaTag
Autodesk.Revit.Elements Namespace


Area Property

AreaTag..::Area Property
CollapseAll image DropDown image

Returns the area that the tag is associated with.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Area Area{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Area As Area
Visual C++
public:
property Area^ Area {
    Area^ get ();
}

Remarks

get the area that the tag is associated with

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


AreaTagType Property

AreaTag..::AreaTagType Property
CollapseAll image DropDown image

get/set the type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaTagType AreaTagType{ get; set;}
Visual Basic (Declaration)
Public Property AreaTagType As AreaTagType
Visual C++
public:
property AreaTagType^ AreaTagType {
    AreaTagType^ get ();
    void set (AreaTagType^ value);
}

Remarks

get/set the type for the current AreaTag.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Leader Property

AreaTag..::Leader Property
CollapseAll image DropDown image

get/set the display attribute of Leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Leader{ get; set;}
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Remarks

get/set, will be true if the leader is displayed otherwise false.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Location Property

AreaTag..::Location Property
CollapseAll image DropDown image

get a location point object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Name Property

AreaTag..::Name Property
CollapseAll image DropDown image

Retrieve or Change the name associated with the AreaTag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

AreaTag..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AreaTag Class
AreaTag Members
Autodesk.Revit.Elements Namespace


View Property

AreaTag..::View Property
CollapseAll image DropDown image

Returns the view in which the tag was place.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View View{ get;}
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

Remarks

get the view in which the tag was placed.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


BaseArray Class
See Also Members
CollapseAll image DropDown image

An abstract base class that represents an array within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0335452A-782C-4f86-BD9C-C950FDC1A72D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BaseArray : Element
Visual Basic (Declaration)
<GuidAttribute("0335452A-782C-4f86-BD9C-C950FDC1A72D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BaseArray _
    Inherits Element
Visual C++
[GuidAttribute(L"0335452A-782C-4f86-BD9C-C950FDC1A72D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BaseArray abstract : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BaseArray
Autodesk.Revit.Elements..::LinearArray
Autodesk.Revit.Elements..::RadialArray

See Also

BaseArray Members
Autodesk.Revit.Elements Namespace


BaseArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BaseArray
Visual Basic (Declaration)
Public MustInherit Class BaseArray
Visual C++
public ref class BaseArray abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BaseArrayBaseArrayNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Retrieve the copied members of the Array.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | NumMembers | Retrieve or Change the number of the arrayed members.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OrigMembers | Retrieve the original members of the Array.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BaseArray
Autodesk.Revit.Elements Namespace


BaseArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BaseArray ()

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


BaseArray Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BaseArray
Visual Basic (Declaration)
Public MustInherit Class BaseArray
Visual C++
public ref class BaseArray abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Retrieve the copied members of the Array.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | NumMembers | Retrieve or Change the number of the arrayed members.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OrigMembers | Retrieve the original members of the Array.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BaseArray
Autodesk.Revit.Elements Namespace


CopyMembers Property

BaseArray..::CopyMembers Property
CollapseAll image DropDown image

Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract ElementArray CopyMembers{ get;}
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


Name Property

BaseArray..::Name Property
CollapseAll image DropDown image

Get and Set the Name property

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for BaseArray object, an InvalidOperationException will be thrown.

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


NumMembers Property

BaseArray..::NumMembers Property
CollapseAll image DropDown image

Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract int NumMembers{ get; set;}
Visual Basic (Declaration)
Public MustOverride Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () abstract;
    void set (int value) abstract;
}

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


OrigMembers Property

BaseArray..::OrigMembers Property
CollapseAll image DropDown image

Retrieve the original members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract ElementArray OrigMembers{ get;}
Visual Basic (Declaration)
Public MustOverride ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


Parameter Property

BaseArray..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

BaseArray Class
BaseArray Members
Autodesk.Revit.Elements Namespace


BeamSystem Class
See Also Members
CollapseAll image DropDown image

An object that represents a BeamSystem within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("72166770-C7A0-478e-B5A3-6EE6AC560673")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BeamSystem : Element
Visual Basic (Declaration)
<GuidAttribute("72166770-C7A0-478e-B5A3-6EE6AC560673")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BeamSystem _
    Inherits Element
Visual C++
[GuidAttribute(L"72166770-C7A0-478e-B5A3-6EE6AC560673")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BeamSystem : public Element

Remarks

This object derived from the Element base object. It can be used access the properties of a BeamSystem, such as elevation, level etc. All the beams belongs to a BeamSystem can be got and there is a static method to find out the BeamSystem to which the beam belongs.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BeamSystem

See Also

BeamSystem Members
Autodesk.Revit.Elements Namespace


BeamSystem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BeamSystem
Visual Basic (Declaration)
Public Class BeamSystem
Visual C++
public ref class BeamSystem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BeamSystemBeamSystemNew | For Internal Use Only.

Public Methods

 | Name | Description
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllBeams | Get all the beams of the BeamSystem.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BeamSystemType | Retrieve or change the type of the BeamSystem.
Public property | BeamType | Retrieve or change the Beam Type of the BeamSystem.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve or change the Direction of the BeamSystem.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieve or change the Elevation of the BeamSystem.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Profile | Retrieve or set the profile of the BeamSystem.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BeamSystem
Autodesk.Revit.Elements Namespace


BeamSystem Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystem ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamSystem Methods
CollapseAll image DropDown image

Syntax

C#
public class BeamSystem
Visual Basic (Declaration)
Public Class BeamSystem
Visual C++
public ref class BeamSystem

The type exposes the following methods.

Public Methods

 | Name | Description
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllBeams | Get all the beams of the BeamSystem.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

BeamSystem
Autodesk.Revit.Elements Namespace


BeamBelongsTo Method

BeamSystem..::BeamBelongsTo Method
CollapseAll image DropDown image

Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Visual Basic (Declaration)
Public Shared Function BeamBelongsTo ( _
    beam As FamilyInstance _
) As BeamSystem
Visual C++
public:
static BeamSystem^ BeamBelongsTo (
    FamilyInstance^ beam
)

Parameters

beam
FamilyInstance
The beam want to ask.

Return Value

The BeamSystem.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


GetAllBeams Method

BeamSystem..::GetAllBeams Method
CollapseAll image DropDown image

Get all the beams of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet GetAllBeams()
Visual Basic (Declaration)
Public Function GetAllBeams As ElementSet
Visual C++
public:
ElementSet^ GetAllBeams ()

Return Value

The beams.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamSystem Properties
CollapseAll image DropDown image

Syntax

C#
public class BeamSystem
Visual Basic (Declaration)
Public Class BeamSystem
Visual C++
public ref class BeamSystem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BeamSystemType | Retrieve or change the type of the BeamSystem.
Public property | BeamType | Retrieve or change the Beam Type of the BeamSystem.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve or change the Direction of the BeamSystem.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieve or change the Elevation of the BeamSystem.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Profile | Retrieve or set the profile of the BeamSystem.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BeamSystem
Autodesk.Revit.Elements Namespace


BeamSystemType Property

BeamSystem..::BeamSystemType Property
CollapseAll image DropDown image

Retrieve or change the type of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystemType BeamSystemType{ get; set;}
Visual Basic (Declaration)
Public Property BeamSystemType As BeamSystemType
Visual C++
public:
property BeamSystemType^ BeamSystemType {
    BeamSystemType^ get ();
    void set (BeamSystemType^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamType Property

BeamSystem..::BeamType Property
CollapseAll image DropDown image

Retrieve or change the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbol BeamType{ get; set;}
Visual Basic (Declaration)
Public Property BeamType As FamilySymbol
Visual C++
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Direction Property

BeamSystem..::Direction Property
CollapseAll image DropDown image

Retrieve or change the Direction of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Direction{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Elevation Property

BeamSystem..::Elevation Property
CollapseAll image DropDown image

Retrieve or change the Elevation of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Elevation{ get; set;}
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


LayoutRule Property

BeamSystem..::LayoutRule Property
CollapseAll image DropDown image

Retrieve or change the LayoutRule of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRule LayoutRule{ get; set;}
Visual Basic (Declaration)
Public Property LayoutRule As LayoutRule
Visual C++
public:
property LayoutRule^ LayoutRule {
    LayoutRule^ get ();
    void set (LayoutRule^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Level Property

BeamSystem..::Level Property
CollapseAll image DropDown image

Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level Level{ get; set;}
Visual Basic (Declaration)
Public Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Parameter Property

BeamSystem..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

BeamSystem Class
BeamSystem Members
Autodesk.Revit.Elements Namespace


Profile Property

BeamSystem..::Profile Property
CollapseAll image DropDown image

Retrieve or set the profile of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Profile{ get; set;}
Visual Basic (Declaration)
Public Property Profile As CurveArray
Visual C++
public:
property CurveArray^ Profile {
    CurveArray^ get ();
    void set (CurveArray^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Blend Class
See Also Members
CollapseAll image DropDown image

Provides access to the Blend model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7F9E59E7-1B48-41bc-930A-1A6971064B3B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Blend : GenericForm
Visual Basic (Declaration)
<GuidAttribute("7F9E59E7-1B48-41bc-930A-1A6971064B3B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Blend _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"7F9E59E7-1B48-41bc-930A-1A6971064B3B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Blend : public GenericForm

Remarks

The Blend object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Blend

See Also

Blend Members
Autodesk.Revit.Elements Namespace


Blend Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Blend
Visual Basic (Declaration)
Public Class Blend
Visual C++
public ref class Blend

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BlendBlendNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FirstEnd | Returns the First End of the Blend.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SecondEnd | Returns the Second End of the Blend.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TopSketch | Returns the Top Sketch of the Blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Blend
Autodesk.Revit.Elements Namespace


Blend Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Blend()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Blend ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


Blend Properties
CollapseAll image DropDown image

Syntax

C#
public class Blend
Visual Basic (Declaration)
Public Class Blend
Visual C++
public ref class Blend

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FirstEnd | Returns the First End of the Blend.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SecondEnd | Returns the Second End of the Blend.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TopSketch | Returns the Top Sketch of the Blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Blend
Autodesk.Revit.Elements Namespace


BottomSketch Property

Blend..::BottomSketch Property
CollapseAll image DropDown image

Returns the Bottom Sketch of the Blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sketch BottomSketch{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BottomSketch As Sketch
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Bottom Sketch of the Blend.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


FirstEnd Property

Blend..::FirstEnd Property
CollapseAll image DropDown image

Returns the First End of the Blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double FirstEnd{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FirstEnd As Double
Visual C++
public:
property double FirstEnd {
    double get ();
}

Remarks

This property is used to retrieve the First End of the Blend.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


Parameter Property

Blend..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Blend Class
Blend Members
Autodesk.Revit.Elements Namespace


SecondEnd Property

Blend..::SecondEnd Property
CollapseAll image DropDown image

Returns the Second End of the Blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double SecondEnd{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SecondEnd As Double
Visual C++
public:
property double SecondEnd {
    double get ();
}

Remarks

This property is used to retrieve the Second End of the Blend.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


TopSketch Property

Blend..::TopSketch Property
CollapseAll image DropDown image

Returns the Top Sketch of the Blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sketch TopSketch{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TopSketch As Sketch
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Top Sketch of the Blend.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


BoundaryConditions Class
See Also Members
CollapseAll image DropDown image

An object that represents a force applied across an area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("299FEBB3-B25A-4297-B0D0-A90821B353FF")]
public class BoundaryConditions : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("299FEBB3-B25A-4297-B0D0-A90821B353FF")> _
Public Class BoundaryConditions _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"299FEBB3-B25A-4297-B0D0-A90821B353FF")]
public ref class BoundaryConditions : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BoundaryConditions

See Also

BoundaryConditions Members
Autodesk.Revit.Elements Namespace


BoundaryConditions Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundaryConditions
Visual Basic (Declaration)
Public Class BoundaryConditions
Visual C++
public ref class BoundaryConditions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundaryConditionsBoundaryConditionsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | associateWithLoad | Sets the ElementId of Load to associate.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AssociatedLoad | Retrieve the AssociatedLoad.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | Retrieve the HostElementId.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves represent the Boundary Conditions Element.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Point | If successful, returns the point represetns Boundary Conditions.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BoundaryConditions
Autodesk.Revit.Elements Namespace


BoundaryConditions Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundaryConditions ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


BoundaryConditions Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundaryConditions
Visual Basic (Declaration)
Public Class BoundaryConditions
Visual C++
public ref class BoundaryConditions

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | associateWithLoad | Sets the ElementId of Load to associate.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

BoundaryConditions
Autodesk.Revit.Elements Namespace


associateWithLoad Method

BoundaryConditions..::associateWithLoad Method
CollapseAll image DropDown image

Sets the ElementId of Load to associate.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool associateWithLoad(
    ref ElementId elementToAssociateId
)
Visual Basic (Declaration)
Public Function associateWithLoad ( _
    ByRef elementToAssociateId As ElementId _
) As Boolean
Visual C++
public:
bool associateWithLoad (
    ElementId% elementToAssociateId
)

Parameters

elementToAssociateId
ElementId %
The the ElementId of Load to associate.

Return Value

If the ElementId was set returns true. Otherwise returns false.

Remarks

ElementId may be set if the internal Load with the elementToAssociateId exist and it's type fit the BoundaryConditions type only.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


Dispose Method

BoundaryConditions..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


BoundaryConditions Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundaryConditions
Visual Basic (Declaration)
Public Class BoundaryConditions
Visual C++
public ref class BoundaryConditions

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AssociatedLoad | Retrieve the AssociatedLoad.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | Retrieve the HostElementId.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves represent the Boundary Conditions Element.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Point | If successful, returns the point represetns Boundary Conditions.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BoundaryConditions
Autodesk.Revit.Elements Namespace


AssociatedLoad Property

BoundaryConditions..::AssociatedLoad Property
CollapseAll image DropDown image

Retrieve the AssociatedLoad.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element AssociatedLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AssociatedLoad As Element
Visual C++
public:
property Element^ AssociatedLoad {
    Element^ get ();
}

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


Curve Property

BoundaryConditions..::Curve Property
CollapseAll image DropDown image

Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve[
    int curveIndex
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int curveIndex] {
    Curve^ get (int curveIndex);
}

Parameters

curveIndex
Int32
The index curve in the BoundaryConditions.

Return Value

If successful, returns the curve pointer. Otherwise returns nullptr.

Remarks

The curve index should be between 0 and NumCurves-1.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


HostElement Property

BoundaryConditions..::HostElement Property
CollapseAll image DropDown image

Retrieve the HostElementId.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element HostElement{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HostElement As Element
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


NumCurves Property

BoundaryConditions..::NumCurves Property
CollapseAll image DropDown image

Returns the number of curves represent the Boundary Conditions Element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumCurves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumCurves As Integer
Visual C++
public:
property int NumCurves {
    int get ();
}

Remarks

For Point Boundary Conditions returns 0, for Line Boundary Conditions returns 1, for Area Boundary Conditions returns value > 0.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


Parameter Property

BoundaryConditions..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

BoundaryConditions Class
BoundaryConditions Members
Autodesk.Revit.Elements Namespace


Point Property

BoundaryConditions..::Point Property
CollapseAll image DropDown image

If successful, returns the point represetns Boundary Conditions.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Point{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

Returns the point if the BoundaryConditionsType == 0 - point. Otherwise returns default XYZ().

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


CeilingAndFloor Class
See Also Members
CollapseAll image DropDown image

A base class that provides support for all ceiling and floor objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E3567FD7-0E1B-4de8-B999-FBED7D6161D6")]
public class CeilingAndFloor : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E3567FD7-0E1B-4de8-B999-FBED7D6161D6")> _
Public Class CeilingAndFloor _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E3567FD7-0E1B-4de8-B999-FBED7D6161D6")]
public ref class CeilingAndFloor : public HostObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CeilingAndFloor

See Also

CeilingAndFloor Members
Autodesk.Revit.Elements Namespace


CeilingAndFloor Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CeilingAndFloor
Visual Basic (Declaration)
Public Class CeilingAndFloor
Visual C++
public ref class CeilingAndFloor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CeilingAndFloorCeilingAndFloorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides HostObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CeilingAndFloor
Autodesk.Revit.Elements Namespace


CeilingAndFloor Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CeilingAndFloor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CeilingAndFloor ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CeilingAndFloor Class
Autodesk.Revit.Elements Namespace


CeilingAndFloor Methods
CollapseAll image DropDown image

Syntax

C#
public class CeilingAndFloor
Visual Basic (Declaration)
Public Class CeilingAndFloor
Visual C++
public ref class CeilingAndFloor

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides HostObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

CeilingAndFloor
Autodesk.Revit.Elements Namespace


Dispose Method

CeilingAndFloor..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CeilingAndFloor Class
Autodesk.Revit.Elements Namespace


ConduitType Class
See Also Members
CollapseAll image DropDown image

Represents a specific conduit type of wire type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A05F87DD-4E7F-485c-BD29-96DD8E780965")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ConduitType : Element
Visual Basic (Declaration)
<GuidAttribute("A05F87DD-4E7F-485c-BD29-96DD8E780965")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ConduitType _
    Inherits Element
Visual C++
[GuidAttribute(L"A05F87DD-4E7F-485c-BD29-96DD8E780965")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ConduitType : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ConduitType

See Also

ConduitType Members
Autodesk.Revit.Elements Namespace


ConduitType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ConduitType
Visual Basic (Declaration)
Public Class ConduitType
Visual C++
public ref class ConduitType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConduitTypeConduitTypeNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get name of conduit type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ConduitType
Autodesk.Revit.Elements Namespace


ConduitType Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConduitType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConduitType ()

See Also

ConduitType Class
Autodesk.Revit.Elements Namespace


ConduitType Properties
CollapseAll image DropDown image

Syntax

C#
public class ConduitType
Visual Basic (Declaration)
Public Class ConduitType
Visual C++
public ref class ConduitType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get name of conduit type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ConduitType
Autodesk.Revit.Elements Namespace


Name Property

ConduitType..::Name Property
CollapseAll image DropDown image

Get name of conduit type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::NotSupportedException | Set name can't be supported.

See Also

ConduitType Class
Autodesk.Revit.Elements Namespace


Parameter Property

ConduitType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ConduitType Class
ConduitType Members
Autodesk.Revit.Elements Namespace


ConduitTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains conduit types.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("95B24BDF-F647-41c8-874A-47EE09971EFB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ConduitTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("95B24BDF-F647-41c8-874A-47EE09971EFB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ConduitTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"95B24BDF-F647-41c8-874A-47EE09971EFB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ConduitTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ConduitTypeSet

See Also

ConduitTypeSet Members
Autodesk.Revit.Elements Namespace


ConduitTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ConduitTypeSet
Visual Basic (Declaration)
Public Class ConduitTypeSet
Visual C++
public ref class ConduitTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConduitTypeSetConduitTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every conduit type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a conduit type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified conduit type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified conduit type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of conduit types that are in the set.

See Also

ConduitTypeSet
Autodesk.Revit.Elements Namespace


ConduitTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConduitTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConduitTypeSet ()

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


ConduitTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ConduitTypeSet
Visual Basic (Declaration)
Public Class ConduitTypeSet
Visual C++
public ref class ConduitTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every conduit type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a conduit type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified conduit type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified conduit type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ConduitTypeSet
Autodesk.Revit.Elements Namespace


Clear Method

ConduitTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every conduit type from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


Contains Method

ConduitTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a conduit type within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    ConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ConduitType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    ConduitType^ item
)

Parameters

item
ConduitType
The conduit type to be searched for.

Return Value

The Contains method returns True if the conduit type is within the set, otherwise False.

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

ConduitTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


Erase Method

ConduitTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified conduit type from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    ConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ConduitType _
) As Integer
Visual C++
public:
virtual int Erase (
    ConduitType^ item
)

Parameters

item
ConduitType
The conduit type to be erased.

Return Value

The number of conduit types that were erased from the set.

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

ConduitTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ConduitTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ConduitTypeSetIterator
Visual C++
public:
virtual ConduitTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

ConduitTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


Insert Method

ConduitTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified conduit type into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    ConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ConduitType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    ConduitType^ item
)

Parameters

item
ConduitType
The conduit type to be inserted into the set.

Return Value

Returns whether the conduit type was inserted into the set.

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ConduitTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

ConduitTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ConduitTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ConduitTypeSetIterator
Visual C++
public:
virtual ConduitTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


ConduitTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ConduitTypeSet
Visual Basic (Declaration)
Public Class ConduitTypeSet
Visual C++
public ref class ConduitTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of conduit types that are in the set.

See Also

ConduitTypeSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

ConduitTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


Size Property

ConduitTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of conduit types that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ConduitTypeSet Class
Autodesk.Revit.Elements Namespace


ConduitTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a conduit type set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FB47B29F-1A65-457b-8FDF-0CCBACE21EE2")]
public abstract class ConduitTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FB47B29F-1A65-457b-8FDF-0CCBACE21EE2")> _
Public MustInherit Class ConduitTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FB47B29F-1A65-457b-8FDF-0CCBACE21EE2")]
public ref class ConduitTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ConduitTypeSetIterator

See Also

ConduitTypeSetIterator Members
Autodesk.Revit.Elements Namespace


ConduitTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ConduitTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class ConduitTypeSetIterator
Visual C++
public ref class ConduitTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConduitTypeSetIteratorConduitTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConduitTypeSetIterator
Autodesk.Revit.Elements Namespace


ConduitTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConduitTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConduitTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.Elements Namespace


ConduitTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ConduitTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class ConduitTypeSetIterator
Visual C++
public ref class ConduitTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ConduitTypeSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

ConduitTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

ConduitTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ConduitTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

ConduitTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.Elements Namespace


ConduitTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ConduitTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class ConduitTypeSetIterator
Visual C++
public ref class ConduitTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConduitTypeSetIterator
Autodesk.Revit.Elements Namespace


Current Property

ConduitTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.Elements Namespace


ContFooting Class
See Also Members
CollapseAll image DropDown image

An object that represents a Continuous Footing within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("09EB9FED-E8AE-4fa7-A484-5126545206FA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ContFooting : HostObject
Visual Basic (Declaration)
<GuidAttribute("09EB9FED-E8AE-4fa7-A484-5126545206FA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ContFooting _
    Inherits HostObject
Visual C++
[GuidAttribute(L"09EB9FED-E8AE-4fa7-A484-5126545206FA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ContFooting : public HostObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::ContFooting

See Also

ContFooting Members
Autodesk.Revit.Elements Namespace


ContFooting Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ContFooting
Visual Basic (Declaration)
Public Class ContFooting
Visual C++
public ref class ContFooting

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ContFootingContFootingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for this footing.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FootingType | Retrieves an object that represents the type of the footing.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ContFooting
Autodesk.Revit.Elements Namespace


ContFooting Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ContFooting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFooting ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


ContFooting Properties
CollapseAll image DropDown image

Syntax

C#
public class ContFooting
Visual Basic (Declaration)
Public Class ContFooting
Visual C++
public ref class ContFooting

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for this footing.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FootingType | Retrieves an object that represents the type of the footing.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ContFooting
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

ContFooting..::AnalyticalModel Property
CollapseAll image DropDown image

Retrieves the structural analytical model for this footing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModel AnalyticalModel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the footing has a structural analytical model it is returned by this method, otherwise Nothing is returned. For this kind of footing, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModel3D to be able to access details about the footing. This property will only function with the Autodesk Revit Structure product.

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


FootingType Property

ContFooting..::FootingType Property
CollapseAll image DropDown image

Retrieves an object that represents the type of the footing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ContFootingType FootingType{ get; set;}
Visual Basic (Declaration)
Public Property FootingType As ContFootingType
Visual C++
public:
property ContFootingType^ FootingType {
    ContFootingType^ get ();
    void set (ContFootingType^ value);
}

Remarks

The footing type can be used to access the multi layered structure of a footing.

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


Parameter Property

ContFooting..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ContFooting Class
ContFooting Members
Autodesk.Revit.Elements Namespace


CurtainCell Class
See Also Members
CollapseAll image DropDown image

Represents a CurtainCell within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8672793B-E1DA-40a0-B1B6-380F59167EB1")]
public class CurtainCell : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8672793B-E1DA-40a0-B1B6-380F59167EB1")> _
Public Class CurtainCell _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8672793B-E1DA-40a0-B1B6-380F59167EB1")]
public ref class CurtainCell : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::CurtainCell

See Also

CurtainCell Members
Autodesk.Revit.Elements Namespace


CurtainCell Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainCell
Visual Basic (Declaration)
Public Class CurtainCell
Visual C++
public ref class CurtainCell

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainCellCurtainCellNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell
Autodesk.Revit.Elements Namespace


CurtainCell Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCell ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurtainCell Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainCell
Visual Basic (Declaration)
Public Class CurtainCell
Visual C++
public ref class CurtainCell

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainCell
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

CurtainCell..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurtainCell Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainCell
Visual Basic (Declaration)
Public Class CurtainCell
Visual C++
public ref class CurtainCell

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell
Autodesk.Revit.Elements Namespace


CurveLoops Property

CurtainCell..::CurveLoops Property
CollapseAll image DropDown image

The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArrArray CurveLoops{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ CurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


PlanarizedCurveLoops Property

CurtainCell..::PlanarizedCurveLoops Property
CollapseAll image DropDown image

The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArrArray PlanarizedCurveLoops{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PlanarizedCurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ PlanarizedCurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurtainCellSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2B893289-BDD6-49a4-BBBE-764C49FE86E1")]
public class CurtainCellSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2B893289-BDD6-49a4-BBBE-764C49FE86E1")> _
Public Class CurtainCellSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2B893289-BDD6-49a4-BBBE-764C49FE86E1")]
public ref class CurtainCellSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::CurtainCellSet

See Also

CurtainCellSet Members
Autodesk.Revit.Elements Namespace


CurtainCellSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainCellSet
Visual Basic (Declaration)
Public Class CurtainCellSet
Visual C++
public ref class CurtainCellSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainCellSetCurtainCellSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

CurtainCellSet
Autodesk.Revit.Elements Namespace


CurtainCellSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainCellSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCellSet ()

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


CurtainCellSet Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainCellSet
Visual Basic (Declaration)
Public Class CurtainCellSet
Visual C++
public ref class CurtainCellSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainCellSet
Autodesk.Revit.Elements Namespace


Clear Method

CurtainCellSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Contains Method

CurtainCellSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Contains (
    CurtainCell^ item
)

Parameters

item
CurtainCell

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

CurtainCellSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Erase Method

CurtainCellSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainCell _
) As Integer
Visual C++
public:
virtual int Erase (
    CurtainCell^ item
)

Parameters

item
CurtainCell

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

CurtainCellSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurtainCellSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

CurtainCellSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Insert Method

CurtainCellSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Insert (
    CurtainCell^ item
)

Parameters

item
CurtainCell

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

CurtainCellSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

CurtainCellSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurtainCellSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


CurtainCellSet Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainCellSet
Visual Basic (Declaration)
Public Class CurtainCellSet
Visual C++
public ref class CurtainCellSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

CurtainCellSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

CurtainCellSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Size Property

CurtainCellSet..::Size Property
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("68F9349C-53E8-48e1-99E6-F783D26DEE83")]
public abstract class CurtainCellSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("68F9349C-53E8-48e1-99E6-F783D26DEE83")> _
Public MustInherit Class CurtainCellSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"68F9349C-53E8-48e1-99E6-F783D26DEE83")]
public ref class CurtainCellSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::CurtainCellSetIterator

See Also

CurtainCellSetIterator Members
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainCellSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainCellSetIterator
Visual C++
public ref class CurtainCellSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainCellSetIteratorCurtainCellSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainCellSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCellSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainCellSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainCellSetIterator
Visual C++
public ref class CurtainCellSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainCellSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

CurtainCellSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

CurtainCellSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

CurtainCellSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

CurtainCellSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainCellSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainCellSetIterator
Visual C++
public ref class CurtainCellSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator
Autodesk.Revit.Elements Namespace


Current Property

CurtainCellSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainGrid Class
See Also Members
CollapseAll image DropDown image

Represents a CurtainGrid within Autodesk Revit. It is not an independent element.It represents a CurtainGrid from a curtain wall,curtain system or curtain roof. Curtain wall has only one CurtainGrid,curtain system or curtain roof may have several CurtainGrids.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0C4F6489-CAAE-4920-94CF-3E83C1DD8130")]
public class CurtainGrid : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0C4F6489-CAAE-4920-94CF-3E83C1DD8130")> _
Public Class CurtainGrid _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0C4F6489-CAAE-4920-94CF-3E83C1DD8130")]
public ref class CurtainGrid : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::CurtainGrid

See Also

CurtainGrid Members
Autodesk.Revit.Elements Namespace


CurtainGrid Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainGrid
Visual Basic (Declaration)
Public Class CurtainGrid
Visual C++
public ref class CurtainGrid

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainGridCurtainGridNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddGridLine | Add a GridLine to the CurtainGrid.
Public method | ChangePanelType | Change type of a curtain panel.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCell | Get the specified cell located by the intersection of the grid lin
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Cells | Get all the cells owned by this curtain grid.
Public property | Grid1Angle | Get/Set the angle for grid1 pattern of the curtain grid.
Public property | Grid1Justification | Get/Set the Justification for grid1 pattern of the curtain grid.
Public property | Grid1Offset | Get/Set the offset for grid1 pattern of the curtain grid.
Public property | Grid2Angle | Get/Set the angle for grid2 pattern of the curtain grid.
Public property | Grid2Justification | Get/Set the Justification for grid2 pattern of the curtain grid.
Public property | Grid2Offset | Get/Set the offset for grid2 pattern of the curtain grid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Mullions | Get all the mullions of the curtain grid. The element in this set is an instance of Autodesk::Revit::Elements::Mullion.
Public property | NumPanels | Retrieve the number of panels.
Public property | NumULines | Get the U direction grid line number.
Public property | NumVLines | Get the V direction grid line number.
Public property | Panels | Get all the panels of the curtain grid.
Public property | UGridLines | Return all grid lines of U direction.
Public property | UnlockedMullions | Get all the unlocked mullions of of the curtain grid.
Public property | UnlockedPanels | Get all the unlocked panels of the curtain grid.
Public property | VGridLines | Return all grid lines of V direction.

See Also

CurtainGrid
Autodesk.Revit.Elements Namespace


CurtainGrid Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGrid ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


CurtainGrid Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainGrid
Visual Basic (Declaration)
Public Class CurtainGrid
Visual C++
public ref class CurtainGrid

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddGridLine | Add a GridLine to the CurtainGrid.
Public method | ChangePanelType | Change type of a curtain panel.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCell | Get the specified cell located by the intersection of the grid lin
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainGrid
Autodesk.Revit.Elements Namespace


AddGridLine Method

CurtainGrid..::AddGridLine Method
CollapseAll image DropDown image

Add a GridLine to the CurtainGrid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddGridLine ( _
    isUGridLine As Boolean, _
    position As XYZ, _
    oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine (
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)

Parameters

isUGridLine
Boolean
Specify the direction of the grid line. If it is true, a U-direction grid line will be added. Otherwise, V-direction grid line will be added.
position
XYZ
specify the position of the grid line. If the param to locate the Gridline (which is calculated by the input position)-is out of range, throw invalid argument exception.
oneSegmentOnly
Boolean
If it is true, only one segment is added. Otherwise, all segments will be added

Return Value

The created CurtainGridLine is returned if the operation is successful. Otherwise, nullptr is returned.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


ChangePanelType Method

CurtainGrid..::ChangePanelType Method
CollapseAll image DropDown image

Change type of a curtain panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element ChangePanelType(
    Element panel,
    Symbol newSymbol
)
Visual Basic (Declaration)
Public Function ChangePanelType ( _
    panel As Element, _
    newSymbol As Symbol _
) As Element
Visual C++
public:
Element^ ChangePanelType (
    Element^ panel,
    Symbol^ newSymbol
)

Parameters

panel
Element
The panel to be changed, it can be a type of Panel or a Wall.
newSymbol
Symbol
The new symbol, it may be PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the resulted element of Autodesk.Revit.Elements.Panel or Autodesk.Revit.Elements.Wall is returned.

Exceptions

Exception | Condition
System..::ArgumentException | If the input newSymbol is a WallType but the panel is hosted in a CurtainSystem, ArgumentException will be thrown.
System..::InvalidOperationException | Internal fails to change the type or regeneration fails.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


GetCell Method

CurtainGrid..::GetCell Method
CollapseAll image DropDown image

Get the specified cell located by the intersection of the grid lin

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainCell GetCell(
    ref ElementId uGridLine,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetCell ( _
    ByRef uGridLine As ElementId, _
    ByRef vGridLineId As ElementId _
) As CurtainCell
Visual C++
public:
CurtainCell^ GetCell (
    ElementId% uGridLine,
    ElementId% vGridLineId
)

Parameters

uGridLine
ElementId %
Specify a UGridLine id to locate the cell.
vGridLineId
ElementId %
Specify a VGridLine id to locate the cell.

Return Value

The result cell.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


GetPanel Method

CurtainGrid..::GetPanel Method
CollapseAll image DropDown image

Get the specified panel located by the intersection of the grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Panel GetPanel(
    ref ElementId uGridLine,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetPanel ( _
    ByRef uGridLine As ElementId, _
    ByRef vGridLineId As ElementId _
) As Panel
Visual C++
public:
Panel^ GetPanel (
    ElementId% uGridLine,
    ElementId% vGridLineId
)

Parameters

uGridLine
ElementId %
Specify a UGridLine id to locate the panel.
vGridLineId
ElementId %
Specify a VGridLine id to locate the panel.

Return Value

The result panel.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

CurtainGrid..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


CurtainGrid Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainGrid
Visual Basic (Declaration)
Public Class CurtainGrid
Visual C++
public ref class CurtainGrid

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Cells | Get all the cells owned by this curtain grid.
Public property | Grid1Angle | Get/Set the angle for grid1 pattern of the curtain grid.
Public property | Grid1Justification | Get/Set the Justification for grid1 pattern of the curtain grid.
Public property | Grid1Offset | Get/Set the offset for grid1 pattern of the curtain grid.
Public property | Grid2Angle | Get/Set the angle for grid2 pattern of the curtain grid.
Public property | Grid2Justification | Get/Set the Justification for grid2 pattern of the curtain grid.
Public property | Grid2Offset | Get/Set the offset for grid2 pattern of the curtain grid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Mullions | Get all the mullions of the curtain grid. The element in this set is an instance of Autodesk::Revit::Elements::Mullion.
Public property | NumPanels | Retrieve the number of panels.
Public property | NumULines | Get the U direction grid line number.
Public property | NumVLines | Get the V direction grid line number.
Public property | Panels | Get all the panels of the curtain grid.
Public property | UGridLines | Return all grid lines of U direction.
Public property | UnlockedMullions | Get all the unlocked mullions of of the curtain grid.
Public property | UnlockedPanels | Get all the unlocked panels of the curtain grid.
Public property | VGridLines | Return all grid lines of V direction.

See Also

CurtainGrid
Autodesk.Revit.Elements Namespace


Cells Property

CurtainGrid..::Cells Property
CollapseAll image DropDown image

Get all the cells owned by this curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainCellSet Cells{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Cells As CurtainCellSet
Visual C++
public:
property CurtainCellSet^ Cells {
    CurtainCellSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid1Angle Property

CurtainGrid..::Grid1Angle Property
CollapseAll image DropDown image

Get/Set the angle for grid1 pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Grid1Angle{ get; set;}
Visual Basic (Declaration)
Public Property Grid1Angle As Double
Visual C++
public:
property double Grid1Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid1Justification Property

CurtainGrid..::Grid1Justification Property
CollapseAll image DropDown image

Get/Set the Justification for grid1 pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridAlignType Grid1Justification{ get; set;}
Visual Basic (Declaration)
Public Property Grid1Justification As CurtainGridAlignType
Visual C++
public:
property CurtainGridAlignType Grid1Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid1Offset Property

CurtainGrid..::Grid1Offset Property
CollapseAll image DropDown image

Get/Set the offset for grid1 pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Grid1Offset{ get; set;}
Visual Basic (Declaration)
Public Property Grid1Offset As Double
Visual C++
public:
property double Grid1Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid2Angle Property

CurtainGrid..::Grid2Angle Property
CollapseAll image DropDown image

Get/Set the angle for grid2 pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Grid2Angle{ get; set;}
Visual Basic (Declaration)
Public Property Grid2Angle As Double
Visual C++
public:
property double Grid2Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid2Justification Property

CurtainGrid..::Grid2Justification Property
CollapseAll image DropDown image

Get/Set the Justification for grid2 pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridAlignType Grid2Justification{ get; set;}
Visual Basic (Declaration)
Public Property Grid2Justification As CurtainGridAlignType
Visual C++
public:
property CurtainGridAlignType Grid2Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid2Offset Property

CurtainGrid..::Grid2Offset Property
CollapseAll image DropDown image

Get/Set the offset for grid2 pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Grid2Offset{ get; set;}
Visual Basic (Declaration)
Public Property Grid2Offset As Double
Visual C++
public:
property double Grid2Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Mullions Property

CurtainGrid..::Mullions Property
CollapseAll image DropDown image

Get all the mullions of the curtain grid. The element in this set is an instance of Autodesk::Revit::Elements::Mullion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet Mullions{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Mullions As ElementSet
Visual C++
public:
property ElementSet^ Mullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


NumPanels Property

CurtainGrid..::NumPanels Property
CollapseAll image DropDown image

Retrieve the number of panels.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumPanels{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumPanels As Integer
Visual C++
public:
property int NumPanels {
    int get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


NumULines Property

CurtainGrid..::NumULines Property
CollapseAll image DropDown image

Get the U direction grid line number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumULines{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumULines As Integer
Visual C++
public:
property int NumULines {
    int get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


NumVLines Property

CurtainGrid..::NumVLines Property
CollapseAll image DropDown image

Get the V direction grid line number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumVLines{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumVLines As Integer
Visual C++
public:
property int NumVLines {
    int get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Panels Property

CurtainGrid..::Panels Property
CollapseAll image DropDown image

Get all the panels of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet Panels{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Panels As ElementSet
Visual C++
public:
property ElementSet^ Panels {
    ElementSet^ get ();
}

Remarks

For curtain wall, the element in this set is either an instance of Autodesk::Revit::Elements::Panel or Autodesk::Revit::Elements::Wall. For curtain system, the set contains only one type of object Autodesk.Revit.Elements.Panel.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


UGridLines Property

CurtainGrid..::UGridLines Property
CollapseAll image DropDown image

Return all grid lines of U direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet UGridLines{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UGridLines As ElementSet
Visual C++
public:
property ElementSet^ UGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


UnlockedMullions Property

CurtainGrid..::UnlockedMullions Property
CollapseAll image DropDown image

Get all the unlocked mullions of of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet UnlockedMullions{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UnlockedMullions As ElementSet
Visual C++
public:
property ElementSet^ UnlockedMullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


UnlockedPanels Property

CurtainGrid..::UnlockedPanels Property
CollapseAll image DropDown image

Get all the unlocked panels of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet UnlockedPanels{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UnlockedPanels As ElementSet
Visual C++
public:
property ElementSet^ UnlockedPanels {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


VGridLines Property

CurtainGrid..::VGridLines Property
CollapseAll image DropDown image

Return all grid lines of V direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet VGridLines{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VGridLines As ElementSet
Visual C++
public:
property ElementSet^ VGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


CurtainGridLine Class
See Also Members
CollapseAll image DropDown image

Represents a CurtainGridLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("24AC7427-647E-4132-9D10-7756B7565686")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurtainGridLine : HostObject
Visual Basic (Declaration)
<GuidAttribute("24AC7427-647E-4132-9D10-7756B7565686")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurtainGridLine _
    Inherits HostObject
Visual C++
[GuidAttribute(L"24AC7427-647E-4132-9D10-7756B7565686")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainGridLine : public HostObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CurtainGridLine

See Also

CurtainGridLine Members
Autodesk.Revit.Elements Namespace


CurtainGridLine Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridLine
Visual Basic (Declaration)
Public Class CurtainGridLine
Visual C++
public ref class CurtainGridLine

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainGridLineCurtainGridLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Lock | Retrieve or change the lock state of the curtain grid line.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainGridLine
Autodesk.Revit.Elements Namespace


CurtainGridLine Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridLine ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


CurtainGridLine Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridLine
Visual Basic (Declaration)
Public Class CurtainGridLine
Visual C++
public ref class CurtainGridLine

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

CurtainGridLine
Autodesk.Revit.Elements Namespace


AddAllSegments Method

CurtainGridLine..::AddAllSegments Method
CollapseAll image DropDown image

All the segments on this grid line will be added.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddAllSegments()
Visual Basic (Declaration)
Public Sub AddAllSegments
Visual C++
public:
void AddAllSegments ()

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


AddMullions Method

CurtainGridLine..::AddMullions Method
CollapseAll image DropDown image

Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet AddMullions(
    Curve segment,
    MullionType mullionType,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddMullions ( _
    segment As Curve, _
    mullionType As MullionType, _
    oneSegmentOnly As Boolean _
) As ElementSet
Visual C++
public:
ElementSet^ AddMullions (
    Curve^ segment,
    MullionType^ mullionType,
    bool oneSegmentOnly
)

Parameters

segment
Curve
Curve of the segment.
mullionType
MullionType
The type of the mullion.
oneSegmentOnly
Boolean
If it is true, we only add one mullion to the specified segment, otherwise we add mullions to all the segments of the grid line.

Return Value

If operation succeeds, the created mullion will be returned.

Exceptions

Exception | Condition
System..::ArgumentException | If one of the segments are not the tagged edge of the host element, this exception will be thrown.
System..::InvalidOperationException | The operation fails to create one or several mullions as required or regeneration fails.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


AddSegment Method

CurtainGridLine..::AddSegment Method
CollapseAll image DropDown image

Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    curve As Curve _
)
Visual C++
public:
void AddSegment (
    Curve^ curve
)

Parameters

curve
Curve
The curve used to locate the segment to be removed.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


Move Method

CurtainGridLine..::Move Method
CollapseAll image DropDown image

It is used to move unlocked type-driven grid lines or user defined grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Move ( _
    moveVec As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    XYZ^ moveVec
)

Parameters

moveVec
XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return true, otherwise false.

Remarks

Grid line can only move within its surface and U line can only be moved along V direction. So the move distance on grid surface will be caculated from moveVec.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


RemoveSegment Method

CurtainGridLine..::RemoveSegment Method
CollapseAll image DropDown image

Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    curve As Curve _
)
Visual C++
public:
void RemoveSegment (
    Curve^ curve
)

Parameters

curve
Curve
The curve used to locate the segment to be removed.

Remarks

When a segment is removed, the neighboring two panels will be merged into one panel.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


CurtainGridLine Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridLine
Visual Basic (Declaration)
Public Class CurtainGridLine
Visual C++
public ref class CurtainGridLine

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Lock | Retrieve or change the lock state of the curtain grid line.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainGridLine
Autodesk.Revit.Elements Namespace


AllSegmentCurves Property

CurtainGridLine..::AllSegmentCurves Property
CollapseAll image DropDown image

Retrieve the curves of all segments.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray AllSegmentCurves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AllSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ AllSegmentCurves {
    CurveArray^ get ();
}

Remarks

Curves contained in this array may be added or removed to the curtain grid by AddSegment() or RemoveSegment().

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


ExistingSegmentCurves Property

CurtainGridLine..::ExistingSegmentCurves Property
CollapseAll image DropDown image

Retrieve all the existing segment curves of the grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray ExistingSegmentCurves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ExistingSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ ExistingSegmentCurves {
    CurveArray^ get ();
}

Remarks

Curves contained in this array may be removed from the curtain grid using RemoveSegment(). Mullions may be applied to these segments using AddMulllions().

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


FullCurve Property

CurtainGridLine..::FullCurve Property
CollapseAll image DropDown image

Retrieve the geometry curve of the curtain grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve FullCurve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FullCurve As Curve
Visual C++
public:
property Curve^ FullCurve {
    Curve^ get ();
}

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


IsUGridLine Property

CurtainGridLine..::IsUGridLine Property
CollapseAll image DropDown image

Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsUGridLine{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsUGridLine As Boolean
Visual C++
public:
property bool IsUGridLine {
    bool get ();
}

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


Lock Property

CurtainGridLine..::Lock Property
CollapseAll image DropDown image

Retrieve or change the lock state of the curtain grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Lock{ get; set;}
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


Parameter Property

CurtainGridLine..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

CurtainGridLine Class
CurtainGridLine Members
Autodesk.Revit.Elements Namespace


SkippedSegmentCurves Property

CurtainGridLine..::SkippedSegmentCurves Property
CollapseAll image DropDown image

Retrieve all the removed segment curves of the grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray SkippedSegmentCurves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SkippedSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ SkippedSegmentCurves {
    CurveArray^ get ();
}

Remarks

Curves contained in this array may be added to the curtain grid using AddSegment().

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


CurtainGridSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6A68FB6C-8D75-4af2-8D82-8BEDBD2BD095")]
public class CurtainGridSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6A68FB6C-8D75-4af2-8D82-8BEDBD2BD095")> _
Public Class CurtainGridSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6A68FB6C-8D75-4af2-8D82-8BEDBD2BD095")]
public ref class CurtainGridSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::CurtainGridSet

See Also

CurtainGridSet Members
Autodesk.Revit.Elements Namespace


CurtainGridSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridSet
Visual Basic (Declaration)
Public Class CurtainGridSet
Visual C++
public ref class CurtainGridSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainGridSetCurtainGridSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet
Autodesk.Revit.Elements Namespace


CurtainGridSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridSet ()

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


CurtainGridSet Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridSet
Visual Basic (Declaration)
Public Class CurtainGridSet
Visual C++
public ref class CurtainGridSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainGridSet
Autodesk.Revit.Elements Namespace


Clear Method

CurtainGridSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Contains Method

CurtainGridSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Contains (
    CurtainGrid^ item
)

Parameters

item
CurtainGrid

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

CurtainGridSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Erase Method

CurtainGridSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainGrid _
) As Integer
Visual C++
public:
virtual int Erase (
    CurtainGrid^ item
)

Parameters

item
CurtainGrid

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

CurtainGridSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurtainGridSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

CurtainGridSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Insert Method

CurtainGridSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Insert (
    CurtainGrid^ item
)

Parameters

item
CurtainGrid

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

CurtainGridSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

CurtainGridSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurtainGridSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


CurtainGridSet Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridSet
Visual Basic (Declaration)
Public Class CurtainGridSet
Visual C++
public ref class CurtainGridSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

CurtainGridSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Size Property

CurtainGridSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EE291E69-93DE-4800-8BD6-B59168B9C6E1")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class CurtainGridSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("EE291E69-93DE-4800-8BD6-B59168B9C6E1")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class CurtainGridSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"EE291E69-93DE-4800-8BD6-B59168B9C6E1")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainGridSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::CurtainGridSetIterator

See Also

CurtainGridSetIterator Members
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainGridSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainGridSetIterator
Visual C++
public ref class CurtainGridSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainGridSetIteratorCurtainGridSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainGridSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainGridSetIterator
Visual C++
public ref class CurtainGridSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainGridSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

CurtainGridSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

CurtainGridSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

CurtainGridSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

CurtainGridSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainGridSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainGridSetIterator
Visual C++
public ref class CurtainGridSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator
Autodesk.Revit.Elements Namespace


Current Property

CurtainGridSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainSystem Class
See Also Members
CollapseAll image DropDown image

Provides access to the CurtainSystem object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("14018A71-D0DB-46e9-BB31-6C732896BCEF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurtainSystem : CurtainSystemBase
Visual Basic (Declaration)
<GuidAttribute("14018A71-D0DB-46e9-BB31-6C732896BCEF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurtainSystem _
    Inherits CurtainSystemBase
Visual C++
[GuidAttribute(L"14018A71-D0DB-46e9-BB31-6C732896BCEF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainSystem : public CurtainSystemBase

Remarks

The user can create CurtainSystem object and change the internal properties.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CurtainSystemBase
Autodesk.Revit.Elements..::CurtainSystem

See Also

CurtainSystem Members
Autodesk.Revit.Elements Namespace


CurtainSystem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystem
Visual Basic (Declaration)
Public Class CurtainSystem
Visual C++
public ref class CurtainSystem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainSystemCurtainSystemNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystem
Autodesk.Revit.Elements Namespace


CurtainSystem Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystem ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainSystem Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystem
Visual Basic (Declaration)
Public Class CurtainSystem
Visual C++
public ref class CurtainSystem

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

CurtainSystem
Autodesk.Revit.Elements Namespace


AddCurtainGrid Method

CurtainSystem..::AddCurtainGrid Method
CollapseAll image DropDown image

Add CurtainGrid on the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub AddCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void AddCurtainGrid (
    Reference^ face
)

Parameters

face
Reference
The face new CurtainGrid will be created on.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the input argument face is nullptr.
System..::InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


RemoveCurtainGrid Method

CurtainSystem..::RemoveCurtainGrid Method
CollapseAll image DropDown image

Remove CurtainGrid from the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub RemoveCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void RemoveCurtainGrid (
    Reference^ face
)

Parameters

face
Reference
The face CurtainGrid will be removed from.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the input parameter face is nullptr.
System..::InvalidOperationException | Thrown when the CurtainGrid cannot be removed from the specified face or regenerate fails.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainSystem Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystem
Visual Basic (Declaration)
Public Class CurtainSystem
Visual C++
public ref class CurtainSystem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystem
Autodesk.Revit.Elements Namespace


CurtainGrids Property

CurtainSystem..::CurtainGrids Property
CollapseAll image DropDown image

Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridSet CurtainGrids{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Return Value

A CurtainGrid set will be returned if the operation succeeds. nullptr will be returned if the CurtainSystem doesn't include any CurtainGrid.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainSystemType Property

CurtainSystem..::CurtainSystemType Property
CollapseAll image DropDown image

get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystemType CurtainSystemType{ get; set;}
Visual Basic (Declaration)
Public Property CurtainSystemType As CurtainSystemType
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter curtainSystemType is null.
System..::InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


Parameter Property

CurtainSystem..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

CurtainSystem Class
CurtainSystem Members
Autodesk.Revit.Elements Namespace


CurtainSystemBase Class
See Also Members
CollapseAll image DropDown image

Provides access to the CurtainSystemBase object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3D5D69E1-878F-4006-8BFC-340F0159C3DC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurtainSystemBase : HostObject
Visual Basic (Declaration)
<GuidAttribute("3D5D69E1-878F-4006-8BFC-340F0159C3DC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurtainSystemBase _
    Inherits HostObject
Visual C++
[GuidAttribute(L"3D5D69E1-878F-4006-8BFC-340F0159C3DC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainSystemBase : public HostObject

Remarks

This is the base class of CurtainSystem.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CurtainSystemBase
Autodesk.Revit.Elements..::CurtainSystem

See Also

CurtainSystemBase Members
Autodesk.Revit.Elements Namespace


CurtainSystemBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystemBase
Visual Basic (Declaration)
Public Class CurtainSystemBase
Visual C++
public ref class CurtainSystemBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainSystemBaseCurtainSystemBaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystemBase
Autodesk.Revit.Elements Namespace


CurtainSystemBase Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystemBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemBase ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemBase Class
Autodesk.Revit.Elements Namespace


DesignOption Class
See Also Members
CollapseAll image DropDown image

An element that represents a design alternative.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0A5ED1CF-9543-4573-B5DE-280922549327")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DesignOption : Element
Visual Basic (Declaration)
<GuidAttribute("0A5ED1CF-9543-4573-B5DE-280922549327")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DesignOption _
    Inherits Element
Visual C++
[GuidAttribute(L"0A5ED1CF-9543-4573-B5DE-280922549327")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DesignOption : public Element

Remarks

Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DesignOption

See Also

DesignOption Members
Autodesk.Revit.Elements Namespace


DesignOption Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DesignOption
Visual Basic (Declaration)
Public Class DesignOption
Visual C++
public ref class DesignOption

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DesignOptionDesignOptionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DesignOption
Autodesk.Revit.Elements Namespace


DesignOption Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DesignOption()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignOption ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DesignOption Class
Autodesk.Revit.Elements Namespace


DetailArc Class
See Also Members
CollapseAll image DropDown image

Represents a DetailArc within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8138EF2C-5288-4250-8A61-5E20F0AFB8B1")]
public class DetailArc : DetailCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8138EF2C-5288-4250-8A61-5E20F0AFB8B1")> _
Public Class DetailArc _
    Inherits DetailCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8138EF2C-5288-4250-8A61-5E20F0AFB8B1")]
public ref class DetailArc : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailArc

See Also

DetailArc Members
Autodesk.Revit.Elements Namespace


DetailArc Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DetailArc
Visual Basic (Declaration)
Public Class DetailArc
Visual C++
public ref class DetailArc

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DetailArcDetailArcNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from DetailCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from DetailCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from DetailCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the detail line. (Inherited from DetailCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from DetailCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the detail line resides in. (Inherited from DetailCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailArc
Autodesk.Revit.Elements Namespace


DetailArc Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailArc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailArc ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailArc Class
Autodesk.Revit.Elements Namespace


DetailCurve Class
See Also Members
CollapseAll image DropDown image

Represents a DetailCurve within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BC135687-9262-4725-990A-467D3610CBB5")]
public class DetailCurve : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BC135687-9262-4725-990A-467D3610CBB5")> _
Public Class DetailCurve _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BC135687-9262-4725-990A-467D3610CBB5")]
public ref class DetailCurve : public Element

Remarks

This is the parent class for detail lines. Currently, the supported detail lines are line, arc, Ellipse, NurbSpline.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailArc
Autodesk.Revit.Elements..::DetailEllipse
Autodesk.Revit.Elements..::DetailLine
Autodesk.Revit.Elements..::DetailNurbSpline

See Also

DetailCurve Members
Autodesk.Revit.Elements Namespace


DetailCurve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DetailCurve
Visual Basic (Declaration)
Public Class DetailCurve
Visual C++
public ref class DetailCurve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DetailCurveDetailCurveNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve.
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the detail line.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the detail line resides in.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailCurve
Autodesk.Revit.Elements Namespace


DetailCurve Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurve ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


DetailCurve Methods
CollapseAll image DropDown image

Syntax

C#
public class DetailCurve
Visual Basic (Declaration)
Public Class DetailCurve
Visual C++
public ref class DetailCurve

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve.
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

DetailCurve
Autodesk.Revit.Elements Namespace


getLineStyle Method

DetailCurve..::getLineStyle Method
CollapseAll image DropDown image

Get the line style of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId getLineStyle()
Visual Basic (Declaration)
Public Function getLineStyle As ElementId
Visual C++
public:
ElementId getLineStyle ()

Remarks

Get the current line style of the curve.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


setLineStyle Method

DetailCurve..::setLineStyle Method
CollapseAll image DropDown image

Set the line style for the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void setLineStyle(
    ElementId lineStyle
)
Visual Basic (Declaration)
Public Sub setLineStyle ( _
    lineStyle As ElementId _
)
Visual C++
public:
void setLineStyle (
    ElementId lineStyle
)

Parameters

lineStyle
ElementId
The line style element id,you get the them from LineStyles property.

Remarks

Set a new line style for the curve.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


SetPlaneAndCurve Method

DetailCurve..::SetPlaneAndCurve Method
CollapseAll image DropDown image

Set sketch plane and geometry curve properties simultaneously.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetPlaneAndCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Sub SetPlaneAndCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
)
Visual C++
public:
void SetPlaneAndCurve (
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Curve
The new geometry curve property.
sketchPlane
SketchPlane
The new sketch plane property.

Remarks

Set the sketch plane and geometry curve properties for the curve.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


DetailCurve Properties
CollapseAll image DropDown image

Syntax

C#
public class DetailCurve
Visual Basic (Declaration)
Public Class DetailCurve
Visual C++
public ref class DetailCurve

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the detail line.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the detail line resides in.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailCurve
Autodesk.Revit.Elements Namespace


GeometryCurve Property

DetailCurve..::GeometryCurve Property
CollapseAll image DropDown image

Get or set the geometry curve of the detail line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve GeometryCurve{ get; set;}
Visual Basic (Declaration)
Public Property GeometryCurve As Curve
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

Because there are no corresponding geometry curve type for HermiteSpline, for this type only general Geometry::Curve object will be returned.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


LineStyles Property

DetailCurve..::LineStyles Property
CollapseAll image DropDown image

Returns all line style of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray LineStyles{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LineStyles As ElementArray
Visual C++
public:
property ElementArray^ LineStyles {
    ElementArray^ get ();
}

Remarks

Returns all line styles that the curve supports.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


Parameter Property

DetailCurve..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DetailCurve Class
DetailCurve Members
Autodesk.Revit.Elements Namespace


SketchPlane Property

DetailCurve..::SketchPlane Property
CollapseAll image DropDown image

Get or set the sketch the detail line resides in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchPlane SketchPlane{ get; set;}
Visual Basic (Declaration)
Public Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Remarks

A SketchPlane is a plane where you want to draw lines.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


DetailCurveArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C85FE6F8-27E6-48e4-95B3-2B6DD7C6D03C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DetailCurveArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("C85FE6F8-27E6-48e4-95B3-2B6DD7C6D03C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DetailCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"C85FE6F8-27E6-48e4-95B3-2B6DD7C6D03C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DetailCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::DetailCurveArray

See Also

DetailCurveArray Members
Autodesk.Revit.Elements Namespace


DetailCurveArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DetailCurveArray
Visual Basic (Declaration)
Public Class DetailCurveArray
Visual C++
public ref class DetailCurveArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DetailCurveArrayDetailCurveArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray
Autodesk.Revit.Elements Namespace


DetailCurveArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailCurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurveArray ()

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


DetailCurveArray Methods
CollapseAll image DropDown image

Syntax

C#
public class DetailCurveArray
Visual Basic (Declaration)
Public Class DetailCurveArray
Visual C++
public ref class DetailCurveArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DetailCurveArray
Autodesk.Revit.Elements Namespace


Append Method

DetailCurveArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    DetailCurve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As DetailCurve _
)
Visual C++
public:
virtual void Append (
    DetailCurve^ item
)

Parameters

item
DetailCurve

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Clear Method

DetailCurveArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Dispose Method

DetailCurveArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

DetailCurveArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DetailCurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

DetailCurveArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Insert Method

DetailCurveArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    DetailCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As DetailCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    DetailCurve^ item,
    int index
)

Parameters

item
DetailCurve
index
Int32

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

DetailCurveArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

DetailCurveArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DetailCurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


DetailCurveArray Properties
CollapseAll image DropDown image

Syntax

C#
public class DetailCurveArray
Visual Basic (Declaration)
Public Class DetailCurveArray
Visual C++
public ref class DetailCurveArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray
Autodesk.Revit.Elements Namespace


IsEmpty Property

DetailCurveArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Item Property

DetailCurveArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DetailCurve Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As DetailCurve
Visual C++
public:
virtual property DetailCurve^ Item[int index] {
    DetailCurve^ get (int index);
    void set (int index, DetailCurve^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Size Property

DetailCurveArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("188F4B18-7794-44ee-89DF-97AF637F27EF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class DetailCurveArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("188F4B18-7794-44ee-89DF-97AF637F27EF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class DetailCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"188F4B18-7794-44ee-89DF-97AF637F27EF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DetailCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::DetailCurveArrayIterator

See Also

DetailCurveArrayIterator Members
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DetailCurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class DetailCurveArrayIterator
Visual C++
public ref class DetailCurveArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DetailCurveArrayIteratorDetailCurveArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailCurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurveArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DetailCurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class DetailCurveArrayIterator
Visual C++
public ref class DetailCurveArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DetailCurveArrayIterator
Autodesk.Revit.Elements Namespace


Dispose Method

DetailCurveArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

DetailCurveArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

DetailCurveArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

DetailCurveArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DetailCurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class DetailCurveArrayIterator
Visual C++
public ref class DetailCurveArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator
Autodesk.Revit.Elements Namespace


Current Property

DetailCurveArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


DetailEllipse Class
See Also Members
CollapseAll image DropDown image

Represents a DetailEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("89B5AF3A-2E2F-4094-9686-25970F4528C2")]
public class DetailEllipse : DetailCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("89B5AF3A-2E2F-4094-9686-25970F4528C2")> _
Public Class DetailEllipse _
    Inherits DetailCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"89B5AF3A-2E2F-4094-9686-25970F4528C2")]
public ref class DetailEllipse : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailEllipse

See Also

DetailEllipse Members
Autodesk.Revit.Elements Namespace


DetailEllipse Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DetailEllipse
Visual Basic (Declaration)
Public Class DetailEllipse
Visual C++
public ref class DetailEllipse

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DetailEllipseDetailEllipseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from DetailCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from DetailCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from DetailCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the detail line. (Inherited from DetailCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from DetailCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the detail line resides in. (Inherited from DetailCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailEllipse
Autodesk.Revit.Elements Namespace


DetailEllipse Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailEllipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailEllipse ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailEllipse Class
Autodesk.Revit.Elements Namespace


DetailLine Class
See Also Members
CollapseAll image DropDown image

Represents a DetailLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("70013D2F-3846-4e0b-87BC-D7271C71244C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DetailLine : DetailCurve
Visual Basic (Declaration)
<GuidAttribute("70013D2F-3846-4e0b-87BC-D7271C71244C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DetailLine _
    Inherits DetailCurve
Visual C++
[GuidAttribute(L"70013D2F-3846-4e0b-87BC-D7271C71244C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DetailLine : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailLine

See Also

DetailLine Members
Autodesk.Revit.Elements Namespace


DetailLine Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DetailLine
Visual Basic (Declaration)
Public Class DetailLine
Visual C++
public ref class DetailLine

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DetailLineDetailLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from DetailCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from DetailCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from DetailCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the detail line. (Inherited from DetailCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from DetailCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the detail line resides in. (Inherited from DetailCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailLine
Autodesk.Revit.Elements Namespace


DetailLine Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailLine ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailLine Class
Autodesk.Revit.Elements Namespace


DetailNurbSpline Class
See Also Members
CollapseAll image DropDown image

Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("619BBA93-34CE-4a2c-A4DC-840B877E2847")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DetailNurbSpline : DetailCurve
Visual Basic (Declaration)
<GuidAttribute("619BBA93-34CE-4a2c-A4DC-840B877E2847")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
[GuidAttribute(L"619BBA93-34CE-4a2c-A4DC-840B877E2847")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailNurbSpline

See Also

DetailNurbSpline Members
Autodesk.Revit.Elements Namespace


DetailNurbSpline Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DetailNurbSpline
Visual Basic (Declaration)
Public Class DetailNurbSpline
Visual C++
public ref class DetailNurbSpline

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DetailNurbSplineDetailNurbSplineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from DetailCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from DetailCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from DetailCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the detail line. (Inherited from DetailCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from DetailCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the detail line resides in. (Inherited from DetailCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailNurbSpline
Autodesk.Revit.Elements Namespace


DetailNurbSpline Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailNurbSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailNurbSpline ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailNurbSpline Class
Autodesk.Revit.Elements Namespace


Dimension Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("904E6686-E3C8-4664-A27D-BA17F223329D")]
public class Dimension : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("904E6686-E3C8-4664-A27D-BA17F223329D")> _
Public Class Dimension _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"904E6686-E3C8-4664-A27D-BA17F223329D")]
public ref class Dimension : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Dimension
Autodesk.Revit.Elements..::SpotDimension

See Also

Dimension Members
Autodesk.Revit.Elements Namespace


Dimension Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Dimension
Visual Basic (Declaration)
Public Class Dimension
Visual C++
public ref class Dimension

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DimensionDimensionNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionType | The dimension style of this dimension.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Retrieve or Change the name associated with the Dimension.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension
Autodesk.Revit.Elements Namespace


Dimension Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Dimension()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Dimension ()

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Dimension Properties
CollapseAll image DropDown image

Syntax

C#
public class Dimension
Visual Basic (Declaration)
Public Class Dimension
Visual C++
public ref class Dimension

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionType | The dimension style of this dimension.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Retrieve or Change the name associated with the Dimension.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension
Autodesk.Revit.Elements Namespace


Curve Property

Dimension..::Curve Property
CollapseAll image DropDown image

A curve that represents the dimension line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


DimensionType Property

Dimension..::DimensionType Property
CollapseAll image DropDown image

The dimension style of this dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DimensionType DimensionType{ get; set;}
Visual Basic (Declaration)
Public Property DimensionType As DimensionType
Visual C++
public:
property DimensionType^ DimensionType {
    DimensionType^ get ();
    void set (DimensionType^ value);
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Name Property

Dimension..::Name Property
CollapseAll image DropDown image

Retrieve or Change the name associated with the Dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get; set;}
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Parameter Property

Dimension..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Dimension Class
Dimension Members
Autodesk.Revit.Elements Namespace


References Property

Dimension..::References Property
CollapseAll image DropDown image

Returns an array of geometric references to which the dimension is attached.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferenceArray References{ get;}
Visual Basic (Declaration)
Public ReadOnly Property References As ReferenceArray
Visual C++
public:
property ReferenceArray^ References {
    ReferenceArray^ get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


View Property

Dimension..::View Property
CollapseAll image DropDown image

Supplies the view that contains the dimension if the dimension is view specific.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View View{ get;}
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


ElectricalSystem Class
See Also Members
CollapseAll image DropDown image

Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5F9BCF72-B234-40e4-ACDA-84A82CEAE77D")]
public class ElectricalSystem : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5F9BCF72-B234-40e4-ACDA-84A82CEAE77D")> _
Public Class ElectricalSystem _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5F9BCF72-B234-40e4-ACDA-84A82CEAE77D")]
public ref class ElectricalSystem : public Element

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ElectricalSystem

See Also

ElectricalSystem Members
Autodesk.Revit.Elements Namespace


ElectricalSystem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSystem
Visual Basic (Declaration)
Public Class ElectricalSystem
Visual C++
public ref class ElectricalSystem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElectricalSystemElectricalSystemNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddToCircuit | Add a set of exist components to the Electrical System.
Public method | DisconnectPanel | Disconnect the panel for the Electrical System.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewWires | Create a bunch of wires for the electrical system.
Public method | RemoveFromCircuit | remove a set of exist components from the Electrical System.
Public method | SelectPanel | Set the panel for the Electrical System.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
Public property | ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
Public property | ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
Public property | ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
Public property | ApparentLoad | Returns the ApparentLoad value of the Electrical System.
Public property | ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
Public property | ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
Public property | ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
Public property | BalancedLoad | Reports whether the BalancedLoad is on or off.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CircuitNumber | Returns the CircuitNumber of the Electrical System.
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Returns the Length value of the Electrical System.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadClassification | Returns the LoadClassification Type of the Electrical System.
Public property | LoadName | Get/Set the LoadName of the Electrical System.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns the Name of the Electrical System. (Overrides Element ..:: Name.)
Public property | NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | PanelName | Returns the Panel name of the Electrical System.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PolesNumber | Returns the Poles Number of the Electrical System.
Public property | PowerFactor | Returns the PowerFactor value of the Electrical System.
Public property | PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Public property | Rating | Get/Set the Rating value of the Electrical System.
Public property | RunsNumber | Returns the Runs Number of the Electrical System.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SystemType | Returns the Electrical System Type of the Electrical System.
Public property | TrueCurrent | Returns the TrueCurrent value of the Electrical System.
Public property | TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
Public property | TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
Public property | TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
Public property | TrueLoad | Returns the TrueLoad value of the Electrical System.
Public property | TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
Public property | TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
Public property | TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Voltage | Returns the Voltage value of the Electrical System.
Public property | VoltageDrop | Returns the VoltageDrop value of the Electrical System.
Public property | WireSizeString | Returns the WireSize as a String of the Electrical System.
Public property | WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem
Autodesk.Revit.Elements Namespace


ElectricalSystem Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystem ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ElectricalSystem Methods
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSystem
Visual Basic (Declaration)
Public Class ElectricalSystem
Visual C++
public ref class ElectricalSystem

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddToCircuit | Add a set of exist components to the Electrical System.
Public method | DisconnectPanel | Disconnect the panel for the Electrical System.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewWires | Create a bunch of wires for the electrical system.
Public method | RemoveFromCircuit | remove a set of exist components from the Electrical System.
Public method | SelectPanel | Set the panel for the Electrical System.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ElectricalSystem
Autodesk.Revit.Elements Namespace


AddToCircuit Method

ElectricalSystem..::AddToCircuit Method
CollapseAll image DropDown image

Add a set of exist components to the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AddToCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Function AddToCircuit ( _
    components As ElementSet _
) As Boolean
Visual C++
public:
bool AddToCircuit (
    ElementSet^ components
)

Parameters

components
ElementSet
The components added to the electrical system.

Return Value

If successful, all the components will add to the system. Otherwise nothing is returned.

Remarks

This method will only function with the Autodesk Revit MEP application.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


DisconnectPanel Method

ElectricalSystem..::DisconnectPanel Method
CollapseAll image DropDown image

Disconnect the panel for the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void DisconnectPanel()
Visual Basic (Declaration)
Public Sub DisconnectPanel
Visual C++
public:
void DisconnectPanel ()

Remarks

If successful, the system will disconnect this panel. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the panel parameter Value is null.
System..::InvalidOperationException | Thrown when the panel cannot be disconnected for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


NewWires Method

ElectricalSystem..::NewWires Method
CollapseAll image DropDown image

Create a bunch of wires for the electrical system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSet NewWires(
    View view,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWires ( _
    view As View, _
    wiringType As WiringType _
) As WireSet
Visual C++
public:
WireSet^ NewWires (
    View^ view,
    WiringType wiringType
)

Parameters

view
View
The view in which the wire is to be visible.
wiringType
WiringType
Specify the wiring type(Arc or Chamfer) that is to be applied to all new created wires.

Return Value

New created wires

Exceptions

Exception | Condition
System..::ArgumentException | This method can just only be used to created a bunch of wires according to specific pairs of elements, so if there exists null element in any pair of familyInstancePairs, the exception will be thrown.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


RemoveFromCircuit Method

ElectricalSystem..::RemoveFromCircuit Method
CollapseAll image DropDown image

remove a set of exist components from the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveFromCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Sub RemoveFromCircuit ( _
    components As ElementSet _
)
Visual C++
public:
void RemoveFromCircuit (
    ElementSet^ components
)

Parameters

components
ElementSet
The components removed from the electrical system.

Remarks

If successful, all the components will remove from the system. Otherwise nothing is removed. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the components parameter Value is null.
System..::InvalidOperationException | Thrown when the components cannot be removed from the system.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


SelectPanel Method

ElectricalSystem..::SelectPanel Method
CollapseAll image DropDown image

Set the panel for the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SelectPanel(
    FamilyInstance panel
)
Visual Basic (Declaration)
Public Sub SelectPanel ( _
    panel As FamilyInstance _
)
Visual C++
public:
void SelectPanel (
    FamilyInstance^ panel
)

Parameters

panel
FamilyInstance
The panel of the electrical system.

Remarks

If successful, the panel will be set for the system. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the panel parameter Value is null.
System..::InvalidOperationException | Thrown when the panel cannot be set for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ElectricalSystem Properties
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSystem
Visual Basic (Declaration)
Public Class ElectricalSystem
Visual C++
public ref class ElectricalSystem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
Public property | ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
Public property | ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
Public property | ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
Public property | ApparentLoad | Returns the ApparentLoad value of the Electrical System.
Public property | ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
Public property | ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
Public property | ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
Public property | BalancedLoad | Reports whether the BalancedLoad is on or off.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CircuitNumber | Returns the CircuitNumber of the Electrical System.
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Returns the Length value of the Electrical System.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadClassification | Returns the LoadClassification Type of the Electrical System.
Public property | LoadName | Get/Set the LoadName of the Electrical System.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns the Name of the Electrical System. (Overrides Element ..:: Name.)
Public property | NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | PanelName | Returns the Panel name of the Electrical System.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PolesNumber | Returns the Poles Number of the Electrical System.
Public property | PowerFactor | Returns the PowerFactor value of the Electrical System.
Public property | PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Public property | Rating | Get/Set the Rating value of the Electrical System.
Public property | RunsNumber | Returns the Runs Number of the Electrical System.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SystemType | Returns the Electrical System Type of the Electrical System.
Public property | TrueCurrent | Returns the TrueCurrent value of the Electrical System.
Public property | TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
Public property | TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
Public property | TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
Public property | TrueLoad | Returns the TrueLoad value of the Electrical System.
Public property | TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
Public property | TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
Public property | TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Voltage | Returns the Voltage value of the Electrical System.
Public property | VoltageDrop | Returns the VoltageDrop value of the Electrical System.
Public property | WireSizeString | Returns the WireSize as a String of the Electrical System.
Public property | WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem
Autodesk.Revit.Elements Namespace


ApparentCurrent Property

ElectricalSystem..::ApparentCurrent Property
CollapseAll image DropDown image

Returns the ApparentCurrent value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentCurrent{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrent As Double
Visual C++
public:
property double ApparentCurrent {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ApparentCurrentPhaseA Property

ElectricalSystem..::ApparentCurrentPhaseA Property
CollapseAll image DropDown image

Returns the ApparentCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentCurrentPhaseA{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseA As Double
Visual C++
public:
property double ApparentCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ApparentCurrentPhaseB Property

ElectricalSystem..::ApparentCurrentPhaseB Property
CollapseAll image DropDown image

Returns the ApparentCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentCurrentPhaseB{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseB As Double
Visual C++
public:
property double ApparentCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ApparentCurrentPhaseC Property

ElectricalSystem..::ApparentCurrentPhaseC Property
CollapseAll image DropDown image

Returns the ApparentCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentCurrentPhaseC{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseC As Double
Visual C++
public:
property double ApparentCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ApparentLoad Property

ElectricalSystem..::ApparentLoad Property
CollapseAll image DropDown image

Returns the ApparentLoad value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoad As Double
Visual C++
public:
property double ApparentLoad {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ApparentLoadPhaseA Property

ElectricalSystem..::ApparentLoadPhaseA Property
CollapseAll image DropDown image

Returns the ApparentLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentLoadPhaseA{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseA As Double
Visual C++
public:
property double ApparentLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ApparentLoadPhaseB Property

ElectricalSystem..::ApparentLoadPhaseB Property
CollapseAll image DropDown image

Returns the ApparentLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentLoadPhaseB{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseB As Double
Visual C++
public:
property double ApparentLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ApparentLoadPhaseC Property

ElectricalSystem..::ApparentLoadPhaseC Property
CollapseAll image DropDown image

Returns the ApparentLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApparentLoadPhaseC{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseC As Double
Visual C++
public:
property double ApparentLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


BalancedLoad Property

ElectricalSystem..::BalancedLoad Property
CollapseAll image DropDown image

Reports whether the BalancedLoad is on or off.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool BalancedLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BalancedLoad As Boolean
Visual C++
public:
property bool BalancedLoad {
    bool get ();
}

Remarks

This property is used to retrieve the BalancedLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


CircuitNumber Property

ElectricalSystem..::CircuitNumber Property
CollapseAll image DropDown image

Returns the CircuitNumber of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string CircuitNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CircuitNumber As String
Visual C++
public:
property String^ CircuitNumber {
    String^ get ();
}

Remarks

This property is used to retrieve the CircuitNumber of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ConnectorManager Property

ElectricalSystem..::ConnectorManager Property
CollapseAll image DropDown image

Retrieves the Connector Manager from this MEPModel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorManager ConnectorManager{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

This property returns Connector Manager from this MEPModel.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


GroundConductorsNumber Property

ElectricalSystem..::GroundConductorsNumber Property
CollapseAll image DropDown image

Returns the GroundConductors Number of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int GroundConductorsNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GroundConductorsNumber As Integer
Visual C++
public:
property int GroundConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the GroundConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


HotConductorsNumber Property

ElectricalSystem..::HotConductorsNumber Property
CollapseAll image DropDown image

Returns the HotConductors Number of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int HotConductorsNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HotConductorsNumber As Integer
Visual C++
public:
property int HotConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the HotConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


Length Property

ElectricalSystem..::Length Property
CollapseAll image DropDown image

Returns the Length value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Length{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

This property is used to retrieve the Length value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


LoadClassification Property

ElectricalSystem..::LoadClassification Property
CollapseAll image DropDown image

Returns the LoadClassification Type of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadClassificationType LoadClassification{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LoadClassification As LoadClassificationType
Visual C++
public:
property LoadClassificationType LoadClassification {
    LoadClassificationType get ();
}

Remarks

This property is used to retrieve the LoadClassification Type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


LoadName Property

ElectricalSystem..::LoadName Property
CollapseAll image DropDown image

Get/Set the LoadName of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string LoadName{ get; set;}
Visual Basic (Declaration)
Public Property LoadName As String
Visual C++
public:
property String^ LoadName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to retrieve the LoadName of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


Name Property

ElectricalSystem..::Name Property
CollapseAll image DropDown image

Returns the Name of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Remarks

This property is used to get or set the Name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


NeutralConductorsNumber Property

ElectricalSystem..::NeutralConductorsNumber Property
CollapseAll image DropDown image

Returns the NeutralConductors Number of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NeutralConductorsNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NeutralConductorsNumber As Integer
Visual C++
public:
property int NeutralConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the NeutralConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


PanelName Property

ElectricalSystem..::PanelName Property
CollapseAll image DropDown image

Returns the Panel name of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string PanelName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PanelName As String
Visual C++
public:
property String^ PanelName {
    String^ get ();
}

Remarks

This property is used to retrieve the Panel name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


Parameter Property

ElectricalSystem..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ElectricalSystem Class
ElectricalSystem Members
Autodesk.Revit.Elements Namespace


PolesNumber Property

ElectricalSystem..::PolesNumber Property
CollapseAll image DropDown image

Returns the Poles Number of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int PolesNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PolesNumber As Integer
Visual C++
public:
property int PolesNumber {
    int get ();
}

Remarks

This property is used to retrieve the Poles Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


PowerFactor Property

ElectricalSystem..::PowerFactor Property
CollapseAll image DropDown image

Returns the PowerFactor value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PowerFactor{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PowerFactor As Double
Visual C++
public:
property double PowerFactor {
    double get ();
}

Remarks

This property is used to retrieve the PowerFactor value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


PowerFactorState Property

ElectricalSystem..::PowerFactorState Property
CollapseAll image DropDown image

Returns the PowerFactorState type of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PowerFactorStateType PowerFactorState{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PowerFactorState As PowerFactorStateType
Visual C++
public:
property PowerFactorStateType PowerFactorState {
    PowerFactorStateType get ();
}

Remarks

This property is used to retrieve the PowerFactorState type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


Rating Property

ElectricalSystem..::Rating Property
CollapseAll image DropDown image

Get/Set the Rating value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Rating{ get; set;}
Visual Basic (Declaration)
Public Property Rating As Double
Visual C++
public:
property double Rating {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve the Rating value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


RunsNumber Property

ElectricalSystem..::RunsNumber Property
CollapseAll image DropDown image

Returns the Runs Number of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int RunsNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RunsNumber As Integer
Visual C++
public:
property int RunsNumber {
    int get ();
}

Remarks

This property is used to retrieve the Runs Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


SystemType Property

ElectricalSystem..::SystemType Property
CollapseAll image DropDown image

Returns the Electrical System Type of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystemType SystemType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
}

Remarks

This property is used to retrieve the Electrical System Type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueCurrent Property

ElectricalSystem..::TrueCurrent Property
CollapseAll image DropDown image

Returns the TrueCurrent value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueCurrent{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrent As Double
Visual C++
public:
property double TrueCurrent {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueCurrentPhaseA Property

ElectricalSystem..::TrueCurrentPhaseA Property
CollapseAll image DropDown image

Returns the TrueCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueCurrentPhaseA{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseA As Double
Visual C++
public:
property double TrueCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueCurrentPhaseB Property

ElectricalSystem..::TrueCurrentPhaseB Property
CollapseAll image DropDown image

Returns the TrueCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueCurrentPhaseB{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseB As Double
Visual C++
public:
property double TrueCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueCurrentPhaseC Property

ElectricalSystem..::TrueCurrentPhaseC Property
CollapseAll image DropDown image

Returns the TrueCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueCurrentPhaseC{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseC As Double
Visual C++
public:
property double TrueCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueLoad Property

ElectricalSystem..::TrueLoad Property
CollapseAll image DropDown image

Returns the TrueLoad value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueLoad As Double
Visual C++
public:
property double TrueLoad {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueLoadPhaseA Property

ElectricalSystem..::TrueLoadPhaseA Property
CollapseAll image DropDown image

Returns the TrueLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueLoadPhaseA{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseA As Double
Visual C++
public:
property double TrueLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueLoadPhaseB Property

ElectricalSystem..::TrueLoadPhaseB Property
CollapseAll image DropDown image

Returns the TrueLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueLoadPhaseB{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseB As Double
Visual C++
public:
property double TrueLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


TrueLoadPhaseC Property

ElectricalSystem..::TrueLoadPhaseC Property
CollapseAll image DropDown image

Returns the TrueLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TrueLoadPhaseC{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseC As Double
Visual C++
public:
property double TrueLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


Voltage Property

ElectricalSystem..::Voltage Property
CollapseAll image DropDown image

Returns the Voltage value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Voltage{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Voltage As Double
Visual C++
public:
property double Voltage {
    double get ();
}

Remarks

This property is used to retrieve the Voltage value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


VoltageDrop Property

ElectricalSystem..::VoltageDrop Property
CollapseAll image DropDown image

Returns the VoltageDrop value of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double VoltageDrop{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VoltageDrop As Double
Visual C++
public:
property double VoltageDrop {
    double get ();
}

Remarks

This property is used to retrieve the VoltageDrop value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


WireSizeString Property

ElectricalSystem..::WireSizeString Property
CollapseAll image DropDown image

Returns the WireSize as a String of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string WireSizeString{ get;}
Visual Basic (Declaration)
Public ReadOnly Property WireSizeString As String
Visual C++
public:
property String^ WireSizeString {
    String^ get ();
}

Remarks

This property is used to retrieve the WireSize String of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


WireType Property

ElectricalSystem..::WireType Property
CollapseAll image DropDown image

Get/Set the wire type of the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireType WireType{ get; set;}
Visual Basic (Declaration)
Public Property WireType As WireType
Visual C++
public:
property WireType^ WireType {
    WireType^ get ();
    void set (WireType^ value);
}

Remarks

This property is used to retrieve the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace


ElectricalSystemSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7B318661-CDEA-4505-A8CB-6D0228DE92A8")]
public class ElectricalSystemSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7B318661-CDEA-4505-A8CB-6D0228DE92A8")> _
Public Class ElectricalSystemSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7B318661-CDEA-4505-A8CB-6D0228DE92A8")]
public ref class ElectricalSystemSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ElectricalSystemSet

See Also

ElectricalSystemSet Members
Autodesk.Revit.Elements Namespace


ElectricalSystemSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSystemSet
Visual Basic (Declaration)
Public Class ElectricalSystemSet
Visual C++
public ref class ElectricalSystemSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElectricalSystemSetElectricalSystemSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ElectricalSystemSet
Autodesk.Revit.Elements Namespace


ElectricalSystemSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystemSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystemSet ()

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


ElectricalSystemSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSystemSet
Visual Basic (Declaration)
Public Class ElectricalSystemSet
Visual C++
public ref class ElectricalSystemSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElectricalSystemSet
Autodesk.Revit.Elements Namespace


Clear Method

ElectricalSystemSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


Contains Method

ElectricalSystemSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Contains (
    ElectricalSystem^ item
)

Parameters

item
ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

ElectricalSystemSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


Erase Method

ElectricalSystemSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ElectricalSystem _
) As Integer
Visual C++
public:
virtual int Erase (
    ElectricalSystem^ item
)

Parameters

item
ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

ElectricalSystemSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElectricalSystemSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

ElectricalSystemSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


Insert Method

ElectricalSystemSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Insert (
    ElectricalSystem^ item
)

Parameters

item
ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ElectricalSystemSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

ElectricalSystemSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ElectricalSystemSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


ElectricalSystemSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSystemSet
Visual Basic (Declaration)
Public Class ElectricalSystemSet
Visual C++
public ref class ElectricalSystemSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ElectricalSystemSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

ElectricalSystemSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


Size Property

ElectricalSystemSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElectricalSystemSet Class
Autodesk.Revit.Elements Namespace


ElectricalSystemSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CAD0DC6D-8128-4b91-85BF-367719A95091")]
public abstract class ElectricalSystemSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CAD0DC6D-8128-4b91-85BF-367719A95091")> _
Public MustInherit Class ElectricalSystemSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CAD0DC6D-8128-4b91-85BF-367719A95091")]
public ref class ElectricalSystemSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ElectricalSystemSetIterator

See Also

ElectricalSystemSetIterator Members
Autodesk.Revit.Elements Namespace


ElectricalSystemSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ElectricalSystemSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElectricalSystemSetIterator
Visual C++
public ref class ElectricalSystemSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElectricalSystemSetIteratorElectricalSystemSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator
Autodesk.Revit.Elements Namespace


ElectricalSystemSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystemSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystemSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.Elements Namespace


ElectricalSystemSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ElectricalSystemSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElectricalSystemSetIterator
Visual C++
public ref class ElectricalSystemSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElectricalSystemSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

ElectricalSystemSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

ElectricalSystemSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ElectricalSystemSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

ElectricalSystemSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.Elements Namespace


ElectricalSystemSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ElectricalSystemSetIterator
Visual Basic (Declaration)
Public MustInherit Class ElectricalSystemSetIterator
Visual C++
public ref class ElectricalSystemSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator
Autodesk.Revit.Elements Namespace


Current Property

ElectricalSystemSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.Elements Namespace


Extrusion Class
See Also Members
CollapseAll image DropDown image

Provides access to the Extrusion model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A9DDCB39-4F1A-4ec3-AF2C-2CCB3521C415")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Extrusion : GenericForm
Visual Basic (Declaration)
<GuidAttribute("A9DDCB39-4F1A-4ec3-AF2C-2CCB3521C415")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Extrusion _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"A9DDCB39-4F1A-4ec3-AF2C-2CCB3521C415")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Extrusion : public GenericForm

Remarks

The Extrusion object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Extrusion

See Also

Extrusion Members
Autodesk.Revit.Elements Namespace


Extrusion Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Extrusion
Visual Basic (Declaration)
Public Class Extrusion
Visual C++
public ref class Extrusion

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExtrusionExtrusionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtrusionEnd | Returns the Extrusion End of the Extrusion.
Public property | ExtrusionStart | Returns the Extrusion Start of the Extrusion.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Extrusion
Autodesk.Revit.Elements Namespace


Extrusion Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Extrusion()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Extrusion ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


Extrusion Properties
CollapseAll image DropDown image

Syntax

C#
public class Extrusion
Visual Basic (Declaration)
Public Class Extrusion
Visual C++
public ref class Extrusion

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtrusionEnd | Returns the Extrusion End of the Extrusion.
Public property | ExtrusionStart | Returns the Extrusion Start of the Extrusion.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Extrusion
Autodesk.Revit.Elements Namespace


ExtrusionEnd Property

Extrusion..::ExtrusionEnd Property
CollapseAll image DropDown image

Returns the Extrusion End of the Extrusion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ExtrusionEnd{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ExtrusionEnd As Double
Visual C++
public:
property double ExtrusionEnd {
    double get ();
}

Remarks

This property is used to retrieve the Extrusion End of the Extrusion.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


ExtrusionStart Property

Extrusion..::ExtrusionStart Property
CollapseAll image DropDown image

Returns the Extrusion Start of the Extrusion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ExtrusionStart{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ExtrusionStart As Double
Visual C++
public:
property double ExtrusionStart {
    double get ();
}

Remarks

This property is used to retrieve the Extrusion Start of the Extrusion.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


Parameter Property

Extrusion..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Extrusion Class
Extrusion Members
Autodesk.Revit.Elements Namespace


Sketch Property

Extrusion..::Sketch Property
CollapseAll image DropDown image

Returns the Sketch of the Extrusion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sketch Sketch{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Sketch As Sketch
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketchs of the Extrusion.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


ExtrusionRoof Class
See Also Members
CollapseAll image DropDown image

Represents some kinds of Extrusion Roofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6D770476-FC0D-4f57-84E7-B091DB25DD5E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ExtrusionRoof : RoofBase
Visual Basic (Declaration)
<GuidAttribute("6D770476-FC0D-4f57-84E7-B091DB25DD5E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ExtrusionRoof _
    Inherits RoofBase
Visual C++
[GuidAttribute(L"6D770476-FC0D-4f57-84E7-B091DB25DD5E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ExtrusionRoof : public RoofBase

Remarks

The ExtrusionRoof object represents some kinds of extrusion roof in Revit. The extrusion roof object is derived from the RoofBase object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::RoofBase
Autodesk.Revit.Elements..::ExtrusionRoof

See Also

ExtrusionRoof Members
Autodesk.Revit.Elements Namespace


ExtrusionRoof Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ExtrusionRoof
Visual Basic (Declaration)
Public Class ExtrusionRoof
Visual C++
public ref class ExtrusionRoof

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExtrusionRoofExtrusionRoofNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ExtrusionRoof
Autodesk.Revit.Elements Namespace


ExtrusionRoof Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExtrusionRoof()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtrusionRoof ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


ExtrusionRoof Methods
CollapseAll image DropDown image

Syntax

C#
public class ExtrusionRoof
Visual Basic (Declaration)
Public Class ExtrusionRoof
Visual C++
public ref class ExtrusionRoof

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ExtrusionRoof
Autodesk.Revit.Elements Namespace


GetProfile Method

ExtrusionRoof..::GetProfile Method
CollapseAll image DropDown image

Retrieve the Profile of ExtrusionRoof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArray GetProfile()
Visual Basic (Declaration)
Public Function GetProfile As ModelCurveArray
Visual C++
public:
ModelCurveArray^ GetProfile ()

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


ExtrusionRoof Properties
CollapseAll image DropDown image

Syntax

C#
public class ExtrusionRoof
Visual Basic (Declaration)
Public Class ExtrusionRoof
Visual C++
public ref class ExtrusionRoof

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ExtrusionRoof
Autodesk.Revit.Elements Namespace


CurtainGrids Property

ExtrusionRoof..::CurtainGrids Property
CollapseAll image DropDown image

Retrieve all the CurtainGrid objects of a curtain Roof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridSet CurtainGrids{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a CurtainRoof, this property makes sense.

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


Parameter Property

ExtrusionRoof..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ExtrusionRoof Class
ExtrusionRoof Members
Autodesk.Revit.Elements Namespace


Family Class
See Also Members
CollapseAll image DropDown image

The Family object is a Symbol that defines an entire family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CB06E669-3606-4f97-A59F-120FFE430153")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Family : FamilyBase
Visual Basic (Declaration)
<GuidAttribute("CB06E669-3606-4f97-A59F-120FFE430153")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Family _
    Inherits FamilyBase
Visual C++
[GuidAttribute(L"CB06E669-3606-4f97-A59F-120FFE430153")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Family : public FamilyBase

Remarks

This object is used mostly to get all the family symbols that belong to the family so that instances can be swapped from one symbol to another. The Family object is derived from the Symbol object and the Element object and as such inherits all the properties and methods of that object. Families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of Families. The Family object represents the entire family such as an 'I Beam'. You can think of that object as representing the entire family file on disk. The Family object contains a number of FamilySymbols. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that Type (FamilySymbol) within the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project. Therefore: Each FamilyInstance has one FamilySymbol, e.g. an instance of a W14x32. Each FamilySymbol belongs to one Family, e.g. the W14x32 symbol belongs to an 'I Beam' family. Each Family will contain one or more FamilySymbols, e.g. the 'I Beam' family contains a W14x32 symbol, a W12x32 symbol etc.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::FamilyBase
Autodesk.Revit.Elements..::Family

See Also

Family Members
Autodesk.Revit.Elements Namespace


Family Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Family
Visual Basic (Declaration)
Public Class Family
Visual C++
public ref class Family

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyFamilyNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Components | A set of all components that belong to a Family.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadedSymbols | A set of all family symbols loaded in a Family.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Others | A set of all other components that belong to a Family.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SolidForms | A set of all solid forms that belong to a Family.
Public property | Symbols | A set of all symbols (types) that belong to a Family.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VoidForms | A set of all void forms that belong to a Family.

See Also

Family
Autodesk.Revit.Elements Namespace


Family Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Family()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Family ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Family Class
Autodesk.Revit.Elements Namespace


Family Properties
CollapseAll image DropDown image

Syntax

C#
public class Family
Visual Basic (Declaration)
Public Class Family
Visual C++
public ref class Family

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Components | A set of all components that belong to a Family.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadedSymbols | A set of all family symbols loaded in a Family.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Others | A set of all other components that belong to a Family.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SolidForms | A set of all solid forms that belong to a Family.
Public property | Symbols | A set of all symbols (types) that belong to a Family.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VoidForms | A set of all void forms that belong to a Family.

See Also

Family
Autodesk.Revit.Elements Namespace


Components Property

Family..::Components Property
CollapseAll image DropDown image

A set of all components that belong to a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet Components{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Components As ElementSet
Visual C++
public:
property ElementSet^ Components {
    ElementSet^ get ();
}

Remarks

Returns a read only set of all components that belong to a particular family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


LoadedSymbols Property

Family..::LoadedSymbols Property
CollapseAll image DropDown image

A set of all family symbols loaded in a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet LoadedSymbols{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LoadedSymbols As ElementSet
Visual C++
public:
property ElementSet^ LoadedSymbols {
    ElementSet^ get ();
}

Remarks

Returns a read-only set of all family symbols loaded in a particular family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


Others Property

Family..::Others Property
CollapseAll image DropDown image

A set of all other components that belong to a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet Others{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Others As ElementSet
Visual C++
public:
property ElementSet^ Others {
    ElementSet^ get ();
}

Remarks

Returns a read only set of all other components that belong to a particular family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


Parameter Property

Family..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Family Class
Family Members
Autodesk.Revit.Elements Namespace


SolidForms Property

Family..::SolidForms Property
CollapseAll image DropDown image

A set of all solid forms that belong to a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GenericFormSet SolidForms{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SolidForms As GenericFormSet
Visual C++
public:
property GenericFormSet^ SolidForms {
    GenericFormSet^ get ();
}

Remarks

Returns a read only set of all the solid forms that belong to a particular family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


Symbols Property

Family..::Symbols Property
CollapseAll image DropDown image

A set of all symbols (types) that belong to a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet Symbols{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Symbols As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ Symbols {
    FamilySymbolSet^ get ();
}

Remarks

Returns a read only set of all the symbols that belong to a particular family. The family symbol objects within this set can be used to swap an instance from one type to another.

See Also

Family Class
Autodesk.Revit.Elements Namespace


VoidForms Property

Family..::VoidForms Property
CollapseAll image DropDown image

A set of all void forms that belong to a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GenericFormSet VoidForms{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VoidForms As GenericFormSet
Visual C++
public:
property GenericFormSet^ VoidForms {
    GenericFormSet^ get ();
}

Remarks

Returns a read only set of all the void forms that belong to a particular family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


FamilyBase Class
See Also Members
CollapseAll image DropDown image

A base class for all Family objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("80C91481-6FCF-4d5e-A324-F750699035C7")]
public class FamilyBase : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("80C91481-6FCF-4d5e-A324-F750699035C7")> _
Public Class FamilyBase _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"80C91481-6FCF-4d5e-A324-F750699035C7")]
public ref class FamilyBase : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::FamilyBase
Autodesk.Revit.Elements..::Family

See Also

FamilyBase Members
Autodesk.Revit.Elements Namespace


FamilyBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FamilyBase
Visual Basic (Declaration)
Public Class FamilyBase
Visual C++
public ref class FamilyBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyBaseFamilyBaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyBase
Autodesk.Revit.Elements Namespace


FamilyBase Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyBase ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace


FamilyBase Properties
CollapseAll image DropDown image

Syntax

C#
public class FamilyBase
Visual Basic (Declaration)
Public Class FamilyBase
Visual C++
public ref class FamilyBase

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyBase
Autodesk.Revit.Elements Namespace


FamilyCategory Property

FamilyBase..::FamilyCategory Property
CollapseAll image DropDown image

Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Category FamilyCategory{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FamilyCategory As Category
Visual C++
public:
property Category^ FamilyCategory {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

FamilyBase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

FamilyBase Class
FamilyBase Members
Autodesk.Revit.Elements Namespace


FamilyInstance Class
See Also Members
CollapseAll image DropDown image

This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C691F591-61A6-460e-AF90-90118509366C")]
public class FamilyInstance : InsertableInstance
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C691F591-61A6-460e-AF90-90118509366C")> _
Public Class FamilyInstance _
    Inherits InsertableInstance
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C691F591-61A6-460e-AF90-90118509366C")]
public ref class FamilyInstance : public InsertableInstance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::InsertableInstance
Autodesk.Revit.Elements..::FamilyInstance

See Also

FamilyInstance Members
Autodesk.Revit.Elements Namespace


FamilyInstance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstance
Visual Basic (Declaration)
Public Class FamilyInstance
Visual C++
public ref class FamilyInstance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyInstanceFamilyInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Change the room to which the door or window is opened.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopings | Lists the elements currently used as coping cutters for this element.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
Public method | SetCopings | Specify the set of coping cutters on this element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from InsertableInstance.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the family instance.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | Overloaded.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Material | This property returns the physical material from which the instance is made.
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Room | Overloaded.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Property to get the sub componets of current family instance.
Public property | SuperComponent | Property to get the super componet of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | Overloaded.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyInstance
Autodesk.Revit.Elements Namespace


FamilyInstance Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyInstance ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FamilyInstance Methods
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstance
Visual Basic (Declaration)
Public Class FamilyInstance
Visual C++
public ref class FamilyInstance

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Change the room to which the door or window is opened.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopings | Lists the elements currently used as coping cutters for this element.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
Public method | SetCopings | Specify the set of coping cutters on this element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from InsertableInstance.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

FamilyInstance
Autodesk.Revit.Elements Namespace


AddCoping Method

FamilyInstance..::AddCoping Method
CollapseAll image DropDown image

Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AddCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function AddCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool AddCoping (
    FamilyInstance^ cutter
)

Parameters

cutter
FamilyInstance
A steel beam or column. May not be null or itself.

Remarks

This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when 'cutter' is null.
System..::ArgumentException | Thrown when 'cutter' refers to this instance.
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


flipFacing Method

FamilyInstance..::flipFacing Method
CollapseAll image DropDown image

The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool flipFacing()
Visual Basic (Declaration)
Public Function flipFacing As Boolean
Visual C++
public:
bool flipFacing ()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FlipFromToRoom Method

FamilyInstance..::FlipFromToRoom Method
CollapseAll image DropDown image

Change the room to which the door or window is opened.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void FlipFromToRoom()
Visual Basic (Declaration)
Public Sub FlipFromToRoom
Visual C++
public:
void FlipFromToRoom ()

Remarks

The FromRoom and ToRoom properties of current family instance's swap after calling this method.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when current family instance is neither door nor window.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


flipHand Method

FamilyInstance..::flipHand Method
CollapseAll image DropDown image

The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool flipHand()
Visual Basic (Declaration)
Public Function flipHand As Boolean
Visual C++
public:
bool flipHand ()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


GetCopings Method

FamilyInstance..::GetCopings Method
CollapseAll image DropDown image

Lists the elements currently used as coping cutters for this element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet GetCopings()
Visual Basic (Declaration)
Public Function GetCopings As ElementSet
Visual C++
public:
ElementSet^ GetCopings ()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


RemoveCoping Method

FamilyInstance..::RemoveCoping Method
CollapseAll image DropDown image

Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool RemoveCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function RemoveCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool RemoveCoping (
    FamilyInstance^ cutter
)

Parameters

cutter
FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be null or itself.

Remarks

This function corresponds to Tools -> Remove coping in Revit Structure.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when 'cutter' is null.
System..::ArgumentException | Thrown when 'cutter' refers to this instance.
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


rotate Method

FamilyInstance..::rotate Method
CollapseAll image DropDown image

The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool rotate()
Visual Basic (Declaration)
Public Function rotate As Boolean
Visual C++
public:
bool rotate ()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


SetCopings Method

FamilyInstance..::SetCopings Method
CollapseAll image DropDown image

Specify the set of coping cutters on this element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SetCopings(
    ElementSet cutters
)
Visual Basic (Declaration)
Public Function SetCopings ( _
    cutters As ElementSet _
) As Boolean
Visual C++
public:
bool SetCopings (
    ElementSet^ cutters
)

Parameters

cutters
ElementSet
A set of coping cutters (steel beams and steel columns).

Remarks

The set must contain elements of FamilyInstance type only. The set may be null or empty, but may not contain the element being coped.

Exceptions

Exception | Condition
System..::ArgumentException | Thrown when 'cutters' contains this instance.
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FamilyInstance Properties
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstance
Visual Basic (Declaration)
Public Class FamilyInstance
Visual C++
public ref class FamilyInstance

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the family instance.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | Overloaded.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Material | This property returns the physical material from which the instance is made.
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Room | Overloaded.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Property to get the sub componets of current family instance.
Public property | SuperComponent | Property to get the super componet of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | Overloaded.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyInstance
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

FamilyInstance..::AnalyticalModel Property
CollapseAll image DropDown image

Retrieves the structural analytical model for the family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModel AnalyticalModel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the family instance has a structural analytical model it is returned by this method, otherwise Nothing is returned. Different types of analytical model will be returned based on the type of the instance, for example - if the instance is a beam then a frame analytical model will be returned. If the instance is a footing then a location analytical model will be returned. This property will only function with the Autodesk Revit Structure product.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


CanFlipFacing Property

FamilyInstance..::CanFlipFacing Property
CollapseAll image DropDown image

Property to test whether the orientation of family instance facing can be flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CanFlipFacing{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CanFlipFacing As Boolean
Visual C++
public:
property bool CanFlipFacing {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


CanFlipHand Property

FamilyInstance..::CanFlipHand Property
CollapseAll image DropDown image

Property to test whether the orientation of family instance hand can be flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CanFlipHand{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CanFlipHand As Boolean
Visual C++
public:
property bool CanFlipHand {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


CanRotate Property

FamilyInstance..::CanRotate Property
CollapseAll image DropDown image

Property to test whether the family instance can be rotated by 180 degree.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CanRotate{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CanRotate As Boolean
Visual C++
public:
property bool CanRotate {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


ExtensionUtility Property

FamilyInstance..::ExtensionUtility Property
CollapseAll image DropDown image

Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IExtension ExtensionUtility{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ExtensionUtility As IExtension
Visual C++
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}

Remarks

If the family instance can not support extension operation, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FacingFlipped Property

FamilyInstance..::FacingFlipped Property
CollapseAll image DropDown image

Property to test whether the orientation of family instance facing is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool FacingFlipped{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FacingFlipped As Boolean
Visual C++
public:
property bool FacingFlipped {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FacingOrientation Property

FamilyInstance..::FacingOrientation Property
CollapseAll image DropDown image

Property to get the orientation of family instance facing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ FacingOrientation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FacingOrientation As XYZ
Visual C++
public:
property XYZ^ FacingOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FromRoom Property

FamilyInstance..::FromRoom Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | FromRoom | Property to get the room from which the door is opened at the last phase of the project.
Public property | FromRoom[([Phase])] |

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


FromRoom Property

FamilyInstance..::FromRoom Property
CollapseAll image DropDown image

Property to get the room from which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room FromRoom{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FromRoom As Room
Visual C++
public:
property Room^ FromRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return null.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FromRoom Property (Phase)

FamilyInstance..::FromRoom Property (Phase)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room FromRoom[
    Phase phase
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FromRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ FromRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Phase

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


HandFlipped Property

FamilyInstance..::HandFlipped Property
CollapseAll image DropDown image

Property to test whether the orientation of family instance hand is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HandFlipped{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HandFlipped As Boolean
Visual C++
public:
property bool HandFlipped {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


HandOrientation Property

FamilyInstance..::HandOrientation Property
CollapseAll image DropDown image

Property to get the orientation of family instance hand.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ HandOrientation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HandOrientation As XYZ
Visual C++
public:
property XYZ^ HandOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Host Property

FamilyInstance..::Host Property
CollapseAll image DropDown image

If the instance is contained within another element, this property returns the containing element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Host{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Location Property

FamilyInstance..::Location Property
CollapseAll image DropDown image

This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an instance within the project. An instance may have a point location, such as a footing or may have a line location. A beam is an example of an instance that has a line location.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Material Property

FamilyInstance..::Material Property
CollapseAll image DropDown image

This property returns the physical material from which the instance is made.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Material Material{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Material As Material
Visual C++
public:
property Material Material {
    Material get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material. Different from Revit materials that geometry really consists of, this property is a family parameter defining family behavior and can not be set per instance. Its value is the same with the type of the instance's family. For example, the instances of different kind of column families(Steel, Concrete or Wood) have different material values and can't be changed int the UI or RevitAPI.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


MEPModel Property

FamilyInstance..::MEPModel Property
CollapseAll image DropDown image

Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPModel MEPModel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MEPModel As MEPModel
Visual C++
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}

Remarks

If the family instance has a MEP model it is returned by this method, otherwise Nothing is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Mirrored Property

FamilyInstance..::Mirrored Property
CollapseAll image DropDown image

Property to test whether the family instance is mirrored. (only one axis is flipped)

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Mirrored{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Mirrored As Boolean
Visual C++
public:
property bool Mirrored {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Parameter Property

FamilyInstance..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


Room Property

FamilyInstance..::Room Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Room | Returns the Room in which an instance is located at the last phase of the project.
Public property | Room[([Phase])] |

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


Room Property

FamilyInstance..::Room Property
CollapseAll image DropDown image

Returns the Room in which an instance is located at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room Room{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

This property can be used for facilities management type applications. The Room object can also provide its boundary for containment testing.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Room Property (Phase)

FamilyInstance..::Room Property (Phase)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room Room[
    Phase phase
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Room ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ Room[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Phase

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


StructuralType Property

FamilyInstance..::StructuralType Property
CollapseAll image DropDown image

Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StructuralType StructuralType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StructuralType As StructuralType
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


StructuralUsage Property

FamilyInstance..::StructuralUsage Property
CollapseAll image DropDown image

Provides the primary structural usage of the instance, such as brace, girder etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceUsage StructuralUsage{ get; set;}
Visual Basic (Declaration)
Public Property StructuralUsage As InstanceUsage
Visual C++
public:
property InstanceUsage StructuralUsage {
    InstanceUsage get ();
    void set (InstanceUsage value);
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


SubComponents Property

FamilyInstance..::SubComponents Property
CollapseAll image DropDown image

Property to get the sub componets of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet SubComponents{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SubComponents As ElementSet
Visual C++
public:
property ElementSet^ SubComponents {
    ElementSet^ get ();
}

Remarks

When current familyinstance has no sub component, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


SuperComponent Property

FamilyInstance..::SuperComponent Property
CollapseAll image DropDown image

Property to get the super componet of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element SuperComponent{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SuperComponent As Element
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When current familyinstance has no super component, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Symbol Property

FamilyInstance..::Symbol Property
CollapseAll image DropDown image

Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbol Symbol{ get; set;}
Visual Basic (Declaration)
Public Property Symbol As FamilySymbol
Visual C++
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


ToRoom Property

FamilyInstance..::ToRoom Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | ToRoom | Property to get the room to which the door is opened at the last phase of the project.
Public property | ToRoom[([Phase])] |

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


ToRoom Property

FamilyInstance..::ToRoom Property
CollapseAll image DropDown image

Property to get the room to which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room ToRoom{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ToRoom As Room
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return null.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


ToRoom Property (Phase)

FamilyInstance..::ToRoom Property (Phase)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room ToRoom[
    Phase phase
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ToRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ ToRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Phase

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Fascia Class
See Also Members
CollapseAll image DropDown image

An object that represents a fascia within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A4CD9A82-8303-4d63-A00C-2B02C5248200")]
public class Fascia : HostedSweep
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A4CD9A82-8303-4d63-A00C-2B02C5248200")> _
Public Class Fascia _
    Inherits HostedSweep
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A4CD9A82-8303-4d63-A00C-2B02C5248200")]
public ref class Fascia : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::Fascia

See Also

Fascia Members
Autodesk.Revit.Elements Namespace


Fascia Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Fascia
Visual Basic (Declaration)
Public Class Fascia
Visual C++
public ref class Fascia

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FasciaFasciaNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddSegment | Add segments to the fascia.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FasciaType | Retrieves/set an object that represents the type of the Fascia.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Fascia
Autodesk.Revit.Elements Namespace


Fascia Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Fascia()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Fascia ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


Fascia Methods
CollapseAll image DropDown image

Syntax

C#
public class Fascia
Visual Basic (Declaration)
Public Class Fascia
Visual C++
public ref class Fascia

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddSegment | Add segments to the fascia.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Fascia
Autodesk.Revit.Elements Namespace


AddSegment Method

Fascia..::AddSegment Method
CollapseAll image DropDown image

Add segments to the fascia.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void AddSegment (
    Reference^ targetRef
)

Parameters

targetRef
Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::ArgumentNullException | This exception will be thrown in following cases: - Input targetRef is null.
System..::InvalidOperationException | This exception will be thrown in following cases: 1.Internal code fails to create the segment object. 2.Regeneration fails.
System..::ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a fascia as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 3. Other fascia's horizontal edges

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


Fascia Properties
CollapseAll image DropDown image

Syntax

C#
public class Fascia
Visual Basic (Declaration)
Public Class Fascia
Visual C++
public ref class Fascia

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FasciaType | Retrieves/set an object that represents the type of the Fascia.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Fascia
Autodesk.Revit.Elements Namespace


FasciaType Property

Fascia..::FasciaType Property
CollapseAll image DropDown image

Retrieves/set an object that represents the type of the Fascia.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FasciaType FasciaType{ get; set;}
Visual Basic (Declaration)
Public Property FasciaType As FasciaType
Visual C++
public:
property FasciaType^ FasciaType {
    FasciaType^ get ();
    void set (FasciaType^ value);
}

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


Parameter Property

Fascia..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Fascia Class
Fascia Members
Autodesk.Revit.Elements Namespace


FillPattern Class
See Also Members
CollapseAll image DropDown image

Represents a fill pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C927D76A-60DD-4543-984B-543976DB4367")]
public class FillPattern : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C927D76A-60DD-4543-984B-543976DB4367")> _
Public Class FillPattern _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C927D76A-60DD-4543-984B-543976DB4367")]
public ref class FillPattern : public Element

Remarks

Currently the details of the fill patterns are not exposed but all the fill patterns can be found on the Document object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::FillPattern

See Also

FillPattern Members
Autodesk.Revit.Elements Namespace


FillPattern Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FillPattern
Visual Basic (Declaration)
Public Class FillPattern
Visual C++
public ref class FillPattern

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FillPatternFillPatternNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FillPattern
Autodesk.Revit.Elements Namespace


FillPattern Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPattern()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPattern ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FillPattern Class
Autodesk.Revit.Elements Namespace


FillPattern Methods
CollapseAll image DropDown image

Syntax

C#
public class FillPattern
Visual Basic (Declaration)
Public Class FillPattern
Visual C++
public ref class FillPattern

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

FillPattern
Autodesk.Revit.Elements Namespace


Dispose Method

FillPattern..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FillPattern Class
Autodesk.Revit.Elements Namespace


Floor Class
See Also Members
CollapseAll image DropDown image

An object that represents a Floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7CDB996A-A00C-4b7f-AF5F-CEEFA02CE136")]
public class Floor : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7CDB996A-A00C-4b7f-AF5F-CEEFA02CE136")> _
Public Class Floor _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7CDB996A-A00C-4b7f-AF5F-CEEFA02CE136")]
public ref class Floor : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::Floor

See Also

Floor Members
Autodesk.Revit.Elements Namespace


Floor Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Floor
Visual Basic (Declaration)
Public Class Floor
Visual C++
public ref class Floor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FloorFloorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the floor object.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorType | Retrieves/set an object that represents the type of the floor.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor
Public property | SpanDirectionSymbols | An array of span direction symbols associated with this floor.
Public property | StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Floor
Autodesk.Revit.Elements Namespace


Floor Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Floor ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


Floor Properties
CollapseAll image DropDown image

Syntax

C#
public class Floor
Visual Basic (Declaration)
Public Class Floor
Visual C++
public ref class Floor

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the floor object.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorType | Retrieves/set an object that represents the type of the floor.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor
Public property | SpanDirectionSymbols | An array of span direction symbols associated with this floor.
Public property | StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Floor
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

Floor..::AnalyticalModel Property
CollapseAll image DropDown image

Retrieves the structural analytical model for the floor object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModel AnalyticalModel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the floor has a structural analytical model it is returned by this method, otherwise Nothing is returned. For floors, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModelFloor to be able to access details about the floor. This property will only function with the Autodesk Revit Structure product.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


FloorType Property

Floor..::FloorType Property
CollapseAll image DropDown image

Retrieves/set an object that represents the type of the floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FloorType FloorType{ get; set;}
Visual Basic (Declaration)
Public Property FloorType As FloorType
Visual C++
public:
property FloorType^ FloorType {
    FloorType^ get ();
    void set (FloorType^ value);
}

Remarks

The floor type can be used to access the multi layered structure of a floor.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


Parameter Property

Floor..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Floor Class
Floor Members
Autodesk.Revit.Elements Namespace


SlabShapeEditor Property

Floor..::SlabShapeEditor Property
CollapseAll image DropDown image

Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeEditor SlabShapeEditor{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Only flat and horizontal floor is valid for slab shape edit.Otherwise,ShapeEditor will be nullptr.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


SpanDirectionAngle Property

Floor..::SpanDirectionAngle Property
CollapseAll image DropDown image

Retrieve the span direction angle of the floor

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double SpanDirectionAngle{ get; set;}
Visual Basic (Declaration)
Public Property SpanDirectionAngle As Double
Visual C++
public:
property double SpanDirectionAngle {
    double get ();
    void set (double value);
}

Remarks

The angle returned is in radians. An exception will be thrown if the floor is non structural.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


SpanDirectionSymbols Property

Floor..::SpanDirectionSymbols Property
CollapseAll image DropDown image

An array of span direction symbols associated with this floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray SpanDirectionSymbols{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SpanDirectionSymbols As ElementArray
Visual C++
public:
property ElementArray^ SpanDirectionSymbols {
    ElementArray^ get ();
}

Remarks

By using the ObjecType property on these span direction symbols it is possible to read if the floor has one way or two way span direction graphics.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


StructuralUsage Property

Floor..::StructuralUsage Property
CollapseAll image DropDown image

The floors designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabFoundationType StructuralUsage{ get; set;}
Visual Basic (Declaration)
Public Property StructuralUsage As SlabFoundationType
Visual C++
public:
property SlabFoundationType StructuralUsage {
    SlabFoundationType get ();
    void set (SlabFoundationType value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


FootPrintRoof Class
See Also Members
CollapseAll image DropDown image

Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DF9F82E6-198E-4c2e-A363-A3A045161547")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FootPrintRoof : RoofBase
Visual Basic (Declaration)
<GuidAttribute("DF9F82E6-198E-4c2e-A363-A3A045161547")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FootPrintRoof _
    Inherits RoofBase
Visual C++
[GuidAttribute(L"DF9F82E6-198E-4c2e-A363-A3A045161547")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof. The FootPrintRoof object is derived from the HostObject object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::RoofBase
Autodesk.Revit.Elements..::FootPrintRoof

See Also

FootPrintRoof Members
Autodesk.Revit.Elements Namespace


FootPrintRoof Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FootPrintRoof
Visual Basic (Declaration)
Public Class FootPrintRoof
Visual C++
public ref class FootPrintRoof

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FootPrintRoofFootPrintRoofNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FootPrintRoof
Autodesk.Revit.Elements Namespace


FootPrintRoof Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FootPrintRoof()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FootPrintRoof ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


FootPrintRoof Methods
CollapseAll image DropDown image

Syntax

C#
public class FootPrintRoof
Visual Basic (Declaration)
Public Class FootPrintRoof
Visual C++
public ref class FootPrintRoof

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

FootPrintRoof
Autodesk.Revit.Elements Namespace


GetProfiles Method

FootPrintRoof..::GetProfiles Method
CollapseAll image DropDown image

Retrieve all the curveLoops of FootPrintRoof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArrArray GetProfiles()
Visual Basic (Declaration)
Public Function GetProfiles As ModelCurveArrArray
Visual C++
public:
ModelCurveArrArray^ GetProfiles ()

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


FootPrintRoof Properties
CollapseAll image DropDown image

Syntax

C#
public class FootPrintRoof
Visual Basic (Declaration)
Public Class FootPrintRoof
Visual C++
public ref class FootPrintRoof

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FootPrintRoof
Autodesk.Revit.Elements Namespace


CurtainGrids Property

FootPrintRoof..::CurtainGrids Property
CollapseAll image DropDown image

Retrieve all the CurtainGrid objects of a FootPrintRoof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridSet CurtainGrids{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a Curtain FootPrintRoof, this property makes sense.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


DefinesSlope Property

FootPrintRoof..::DefinesSlope Property
CollapseAll image DropDown image

Retrieve or set the DefinesSlope of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool DefinesSlope[
    ModelCurve pCurve
]{ get; set;}
Visual Basic (Declaration)
Public Property DefinesSlope ( _
    pCurve As ModelCurve _
) As Boolean
Visual C++
public:
property bool DefinesSlope[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
ModelCurve

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


ExtendIntoWall Property

FootPrintRoof..::ExtendIntoWall Property
CollapseAll image DropDown image

Retrieve or set whether extend into wall the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ExtendIntoWall[
    ModelCurve pCurve
]{ get; set;}
Visual Basic (Declaration)
Public Property ExtendIntoWall ( _
    pCurve As ModelCurve _
) As Boolean
Visual C++
public:
property bool ExtendIntoWall[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


Offset Property

FootPrintRoof..::Offset Property
CollapseAll image DropDown image

Retrieve or set the Offset of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Offset[
    ModelCurve pCurve
]{ get; set;}
Visual Basic (Declaration)
Public Property Offset ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Offset[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
ModelCurve

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


Overhang Property

FootPrintRoof..::Overhang Property
CollapseAll image DropDown image

Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Overhang[
    ModelCurve pCurve
]{ get; set;}
Visual Basic (Declaration)
Public Property Overhang ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


Parameter Property

FootPrintRoof..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

FootPrintRoof Class
FootPrintRoof Members
Autodesk.Revit.Elements Namespace


SlopeAngle Property

FootPrintRoof..::SlopeAngle Property
CollapseAll image DropDown image

Retrieve or set the SlopeAngle of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double SlopeAngle[
    ModelCurve pCurve
]{ get; set;}
Visual Basic (Declaration)
Public Property SlopeAngle ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double SlopeAngle[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
ModelCurve

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


gbXMLParamElem Class
See Also Members
CollapseAll image DropDown image

An object that represents the gbXML Parameters within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("422DADB3-7AD6-443f-8F0F-7AFFB13FEA9E")]
public class gbXMLParamElem : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("422DADB3-7AD6-443f-8F0F-7AFFB13FEA9E")> _
Public Class gbXMLParamElem _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"422DADB3-7AD6-443f-8F0F-7AFFB13FEA9E")]
public ref class gbXMLParamElem : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::gbXMLParamElem

See Also

gbXMLParamElem Members
Autodesk.Revit.Elements Namespace


gbXMLParamElem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class gbXMLParamElem
Visual Basic (Declaration)
Public Class gbXMLParamElem
Visual C++
public ref class gbXMLParamElem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | gbXMLParamElemgbXMLParamElemNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BuildingConstruction | Get the Building Construction of the Project Information.
Public property | BuildingService | Get or Set the Building Service of the Project Information.
Public property | BuildingType | Get or Set the Building Type of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundPlane | Get the Ground Plane of the Project Information.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PostalCode | Get or Set the Postal Code of the Project Information.
Public property | ProjectLocation | Get the Location of the Project Information.
Public property | ProjectPhase | Get the Project Phase of the Project Information.
Public property | ShadingSurfaces | Get the Shading Surfaces of the Project Information.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

gbXMLParamElem
Autodesk.Revit.Elements Namespace


gbXMLParamElem Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public gbXMLParamElem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
gbXMLParamElem ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


gbXMLParamElem Properties
CollapseAll image DropDown image

Syntax

C#
public class gbXMLParamElem
Visual Basic (Declaration)
Public Class gbXMLParamElem
Visual C++
public ref class gbXMLParamElem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BuildingConstruction | Get the Building Construction of the Project Information.
Public property | BuildingService | Get or Set the Building Service of the Project Information.
Public property | BuildingType | Get or Set the Building Type of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundPlane | Get the Ground Plane of the Project Information.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PostalCode | Get or Set the Postal Code of the Project Information.
Public property | ProjectLocation | Get the Location of the Project Information.
Public property | ProjectPhase | Get the Project Phase of the Project Information.
Public property | ShadingSurfaces | Get the Shading Surfaces of the Project Information.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

gbXMLParamElem
Autodesk.Revit.Elements Namespace


BuildingConstruction Property

gbXMLParamElem..::BuildingConstruction Property
CollapseAll image DropDown image

Get the Building Construction of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstruction BuildingConstruction{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BuildingConstruction As MEPBuildingConstruction
Visual C++
public:
property MEPBuildingConstruction^ BuildingConstruction {
    MEPBuildingConstruction^ get ();
}

Remarks

This property is used to get or set the Building Construction of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


BuildingService Property

gbXMLParamElem..::BuildingService Property
CollapseAll image DropDown image

Get or Set the Building Service of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ServiceType BuildingService{ get; set;}
Visual Basic (Declaration)
Public Property BuildingService As ServiceType
Visual C++
public:
property ServiceType BuildingService {
    ServiceType get ();
    void set (ServiceType value);
}

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


BuildingType Property

gbXMLParamElem..::BuildingType Property
CollapseAll image DropDown image

Get or Set the Building Type of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BuildingType BuildingType{ get; set;}
Visual Basic (Declaration)
Public Property BuildingType As BuildingType
Visual C++
public:
property BuildingType BuildingType {
    BuildingType get ();
    void set (BuildingType value);
}

Remarks

This property is used to get or set the Building Type of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


GroundPlane Property

gbXMLParamElem..::GroundPlane Property
CollapseAll image DropDown image

Get the Ground Plane of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level GroundPlane{ get; set;}
Visual Basic (Declaration)
Public Property GroundPlane As Level
Visual C++
public:
property Level^ GroundPlane {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get the Ground Plane of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


Parameter Property

gbXMLParamElem..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

gbXMLParamElem Class
gbXMLParamElem Members
Autodesk.Revit.Elements Namespace


PostalCode Property

gbXMLParamElem..::PostalCode Property
CollapseAll image DropDown image

Get or Set the Postal Code of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string PostalCode{ get; set;}
Visual Basic (Declaration)
Public Property PostalCode As String
Visual C++
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the ZIP Code of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


ProjectLocation Property

gbXMLParamElem..::ProjectLocation Property
CollapseAll image DropDown image

Get the Location of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocation ProjectLocation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ProjectLocation As ProjectLocation
Visual C++
public:
property ProjectLocation^ ProjectLocation {
    ProjectLocation^ get ();
}

Remarks

This property is used to get the location of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


ProjectPhase Property

gbXMLParamElem..::ProjectPhase Property
CollapseAll image DropDown image

Get the Project Phase of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Phase ProjectPhase{ get; set;}
Visual Basic (Declaration)
Public Property ProjectPhase As Phase
Visual C++
public:
property Phase^ ProjectPhase {
    Phase^ get ();
    void set (Phase^ value);
}

Remarks

This property is used to get the Project Phase of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


ShadingSurfaces Property

gbXMLParamElem..::ShadingSurfaces Property
CollapseAll image DropDown image

Get the Shading Surfaces of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ShadingSurfaces{ get; set;}
Visual Basic (Declaration)
Public Property ShadingSurfaces As Boolean
Visual C++
public:
property bool ShadingSurfaces {
    bool get ();
    void set (bool value);
}

Remarks

This property is used to get the Shading Surfaces of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


GenericForm Class
See Also Members
CollapseAll image DropDown image

Provides access to the Generic Form model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4F46029D-6FE1-4aaa-B836-EDEA9395A41D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GenericForm : Element
Visual Basic (Declaration)
<GuidAttribute("4F46029D-6FE1-4aaa-B836-EDEA9395A41D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GenericForm _
    Inherits Element
Visual C++
[GuidAttribute(L"4F46029D-6FE1-4aaa-B836-EDEA9395A41D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GenericForm : public Element

Remarks

The Generic Form object can be queried for a generic form for use in family modeling and massing.it is the base class of Sweep, Blend, Extrusion, Revolution.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Extrusion
Autodesk.Revit.Elements..::Sweep
Autodesk.Revit.Elements..::Blend
Autodesk.Revit.Elements..::Revolution

See Also

GenericForm Members
Autodesk.Revit.Elements Namespace


GenericForm Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GenericForm
Visual Basic (Declaration)
Public Class GenericForm
Visual C++
public ref class GenericForm

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GenericFormGenericFormNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm.

See Also

GenericForm
Autodesk.Revit.Elements Namespace


GenericForm Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GenericForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericForm ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


GenericForm Properties
CollapseAll image DropDown image

Syntax

C#
public class GenericForm
Visual Basic (Declaration)
Public Class GenericForm
Visual C++
public ref class GenericForm

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm.

See Also

GenericForm
Autodesk.Revit.Elements Namespace


IsSolid Property

GenericForm..::IsSolid Property
CollapseAll image DropDown image

Identifies if the GenericForm is a solid or a void element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsSolid{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsSolid As Boolean
Visual C++
public:
property bool IsSolid {
    bool get ();
}

Field Value

True if the form is a solid, false if the solid is a void element.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


Name Property

GenericForm..::Name Property
CollapseAll image DropDown image

Get and Set the Name property

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


Parameter Property

GenericForm..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

GenericForm Class
GenericForm Members
Autodesk.Revit.Elements Namespace


Visible Property

GenericForm..::Visible Property
CollapseAll image DropDown image

The visibility of the GenericForm.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Visible{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

Field Value

True if the form is visible, false if it is hidden.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


GenericFormSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("65D0CA32-DFBE-4a17-9513-39C9904AECDB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GenericFormSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("65D0CA32-DFBE-4a17-9513-39C9904AECDB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GenericFormSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"65D0CA32-DFBE-4a17-9513-39C9904AECDB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GenericFormSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::GenericFormSet

See Also

GenericFormSet Members
Autodesk.Revit.Elements Namespace


GenericFormSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GenericFormSet
Visual Basic (Declaration)
Public Class GenericFormSet
Visual C++
public ref class GenericFormSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GenericFormSetGenericFormSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

GenericFormSet
Autodesk.Revit.Elements Namespace


GenericFormSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GenericFormSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericFormSet ()

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GenericFormSet Methods
CollapseAll image DropDown image

Syntax

C#
public class GenericFormSet
Visual Basic (Declaration)
Public Class GenericFormSet
Visual C++
public ref class GenericFormSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GenericFormSet
Autodesk.Revit.Elements Namespace


Clear Method

GenericFormSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Contains Method

GenericFormSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Contains (
    GenericForm^ item
)

Parameters

item
GenericForm

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

GenericFormSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Erase Method

GenericFormSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GenericForm _
) As Integer
Visual C++
public:
virtual int Erase (
    GenericForm^ item
)

Parameters

item
GenericForm

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

GenericFormSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GenericFormSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

GenericFormSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Insert Method

GenericFormSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Insert (
    GenericForm^ item
)

Parameters

item
GenericForm

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

GenericFormSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

GenericFormSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GenericFormSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GenericFormSet Properties
CollapseAll image DropDown image

Syntax

C#
public class GenericFormSet
Visual Basic (Declaration)
Public Class GenericFormSet
Visual C++
public ref class GenericFormSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

GenericFormSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

GenericFormSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Size Property

GenericFormSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5AE322A5-4A22-4892-B292-903E495E9EA4")]
public abstract class GenericFormSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5AE322A5-4A22-4892-B292-903E495E9EA4")> _
Public MustInherit Class GenericFormSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5AE322A5-4A22-4892-B292-903E495E9EA4")]
public ref class GenericFormSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::GenericFormSetIterator

See Also

GenericFormSetIterator Members
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class GenericFormSetIterator
Visual Basic (Declaration)
Public MustInherit Class GenericFormSetIterator
Visual C++
public ref class GenericFormSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GenericFormSetIteratorGenericFormSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GenericFormSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericFormSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class GenericFormSetIterator
Visual Basic (Declaration)
Public MustInherit Class GenericFormSetIterator
Visual C++
public ref class GenericFormSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GenericFormSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

GenericFormSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

GenericFormSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

GenericFormSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

GenericFormSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class GenericFormSetIterator
Visual Basic (Declaration)
Public MustInherit Class GenericFormSetIterator
Visual C++
public ref class GenericFormSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator
Autodesk.Revit.Elements Namespace


Current Property

GenericFormSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


Grid Class
See Also Members
CollapseAll image DropDown image

Represents a single grid line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("584AEACB-B042-48ef-9FC4-5A654083370A")]
public class Grid : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("584AEACB-B042-48ef-9FC4-5A654083370A")> _
Public Class Grid _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"584AEACB-B042-48ef-9FC4-5A654083370A")]
public ref class Grid : public Element

Remarks

Grid lines can either be curved or straight. The Grid object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the contents of the grid lines bubble.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Grid

See Also

Grid Members
Autodesk.Revit.Elements Namespace


Grid Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Grid
Visual Basic (Declaration)
Public Class Grid
Visual C++
public ref class Grid

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GridGridNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides Element ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GridType | Get and Set the type of the grid object.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsCurved | Test to see if the grid line is curved or straight.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Grid
Autodesk.Revit.Elements Namespace


Grid Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Grid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Grid ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Grid Methods
CollapseAll image DropDown image

Syntax

C#
public class Grid
Visual Basic (Declaration)
Public Class Grid
Visual C++
public ref class Grid

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides Element ..:: ReleaseUnmanagedResources()().)

See Also

Grid
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

Grid..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Grid Properties
CollapseAll image DropDown image

Syntax

C#
public class Grid
Visual Basic (Declaration)
Public Class Grid
Visual C++
public ref class Grid

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GridType | Get and Set the type of the grid object.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsCurved | Test to see if the grid line is curved or straight.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Grid
Autodesk.Revit.Elements Namespace


Curve Property

Grid..::Curve Property
CollapseAll image DropDown image

Retrieves an object that represents the geometry of the grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Remarks

The geometry can either be an arc of a curve. The IsCurved property can be used to test which.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


GridType Property

Grid..::GridType Property
CollapseAll image DropDown image

Get and Set the type of the grid object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GridType GridType{ get; set;}
Visual Basic (Declaration)
Public Property GridType As GridType
Visual C++
public:
property GridType^ GridType {
    GridType^ get ();
    void set (GridType^ value);
}

Remarks

When a nullptr is input for the method set, ArgumentNullException will be thrown.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


IsCurved Property

Grid..::IsCurved Property
CollapseAll image DropDown image

Test to see if the grid line is curved or straight.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsCurved{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsCurved As Boolean
Visual C++
public:
property bool IsCurved {
    bool get ();
}

Remarks

A value of True is returned if the grid line is an arc or False if the grid line is straight. Use the Curve property to retrieve an object that represents the geometry of the grid line.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Parameter Property

Grid..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Grid Class
Grid Members
Autodesk.Revit.Elements Namespace


Group Class
See Also Members
CollapseAll image DropDown image

This object represents a group of elements within the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9AC7A3FC-467E-4d91-8B94-F13A224DFBAB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Group : Element
Visual Basic (Declaration)
<GuidAttribute("9AC7A3FC-467E-4d91-8B94-F13A224DFBAB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Group _
    Inherits Element
Visual C++
[GuidAttribute(L"9AC7A3FC-467E-4d91-8B94-F13A224DFBAB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Group : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Group

See Also

Group Members
Autodesk.Revit.Elements Namespace


Group Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Group
Visual Basic (Declaration)
Public Class Group
Visual C++
public ref class Group

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GroupGroupNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Ungroup | Ungroup the group.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | GroupType | Get or set the type of the group.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides Element ..:: Location.)
Public property | Members | Returns all the members of the group.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Group
Autodesk.Revit.Elements Namespace


Group Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Group()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Group ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Group Methods
CollapseAll image DropDown image

Syntax

C#
public class Group
Visual Basic (Declaration)
Public Class Group
Visual C++
public ref class Group

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Ungroup | Ungroup the group.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Group
Autodesk.Revit.Elements Namespace


Ungroup Method

Group..::Ungroup Method
CollapseAll image DropDown image

Ungroup the group.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet Ungroup()
Visual Basic (Declaration)
Public Function Ungroup As ElementSet
Visual C++
public:
ElementSet^ Ungroup ()

Return Value

If successful the removed group elements are returned in this set.

Remarks

Ungroup removed all the members from the group and then causes the group itself to be deleted. Note that the reference to this group object will become invalid once this method is called. If the group cannot be ungrouped a System.InvalidOperationException will be thrown.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Group Properties
CollapseAll image DropDown image

Syntax

C#
public class Group
Visual Basic (Declaration)
Public Class Group
Visual C++
public ref class Group

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | GroupType | Get or set the type of the group.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides Element ..:: Location.)
Public property | Members | Returns all the members of the group.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Group
Autodesk.Revit.Elements Namespace


GroupType Property

Group..::GroupType Property
CollapseAll image DropDown image

Get or set the type of the group.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GroupType GroupType{ get; set;}
Visual Basic (Declaration)
Public Overridable Property GroupType As GroupType
Visual C++
public:
virtual property GroupType^ GroupType {
    GroupType^ get ();
    void set (GroupType^ value);
}

Remarks

By setting this property the group can be swapped to a different kind of group.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Location Property

Group..::Location Property
CollapseAll image DropDown image

This property is used to find the physical location of a group within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. Groups return a point location object.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Members Property

Group..::Members Property
CollapseAll image DropDown image

Returns all the members of the group.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray Members{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Members As ElementArray
Visual C++
public:
property ElementArray^ Members {
    ElementArray^ get ();
}

Remarks

This property returns an ordered array of the members within the group. The order of this array can be used to match members between other instances of the group.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Parameter Property

Group..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Group Class
Group Members
Autodesk.Revit.Elements Namespace


GroupSet Class
See Also Members
CollapseAll image DropDown image

An set that contains groups.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("480DF18C-120F-4c03-AE7E-B6B15D885591")]
public class GroupSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("480DF18C-120F-4c03-AE7E-B6B15D885591")> _
Public Class GroupSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"480DF18C-120F-4c03-AE7E-B6B15D885591")]
public ref class GroupSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::GroupSet

See Also

GroupSet Members
Autodesk.Revit.Elements Namespace


GroupSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GroupSet
Visual Basic (Declaration)
Public Class GroupSet
Visual C++
public ref class GroupSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GroupSetGroupSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of groups that are in the set.

See Also

GroupSet
Autodesk.Revit.Elements Namespace


GroupSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroupSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupSet ()

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GroupSet Methods
CollapseAll image DropDown image

Syntax

C#
public class GroupSet
Visual Basic (Declaration)
Public Class GroupSet
Visual C++
public ref class GroupSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GroupSet
Autodesk.Revit.Elements Namespace


Clear Method

GroupSet..::Clear Method
CollapseAll image DropDown image

Removes every group from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Contains Method

GroupSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a group within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Group^ item
)

Parameters

item
Group
The group to be searched for.

Return Value

The Contains method returns True if the group is within the set, otherwise False.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

GroupSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Erase Method

GroupSet..::Erase Method
CollapseAll image DropDown image

Removes a specified group from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Group _
) As Integer
Visual C++
public:
virtual int Erase (
    Group^ item
)

Parameters

item
Group
The group to be erased.

Return Value

The number of groups that were erased from the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

GroupSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GroupSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

GroupSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Insert Method

GroupSet..::Insert Method
CollapseAll image DropDown image

Insert the specified group into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Group^ item
)

Parameters

item
Group
The group to be inserted into the set.

Return Value

Returns whether the group was inserted into the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

GroupSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

GroupSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GroupSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GroupSet Properties
CollapseAll image DropDown image

Syntax

C#
public class GroupSet
Visual Basic (Declaration)
Public Class GroupSet
Visual C++
public ref class GroupSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of groups that are in the set.

See Also

GroupSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

GroupSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Size Property

GroupSet..::Size Property
CollapseAll image DropDown image

Returns the number of groups that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GroupSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a group set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("87B9CCA2-2A56-4f96-B315-7087128B1C0F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class GroupSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("87B9CCA2-2A56-4f96-B315-7087128B1C0F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class GroupSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"87B9CCA2-2A56-4f96-B315-7087128B1C0F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GroupSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::GroupSetIterator

See Also

GroupSetIterator Members
Autodesk.Revit.Elements Namespace


GroupSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class GroupSetIterator
Visual Basic (Declaration)
Public MustInherit Class GroupSetIterator
Visual C++
public ref class GroupSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GroupSetIteratorGroupSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator
Autodesk.Revit.Elements Namespace


GroupSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroupSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


GroupSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class GroupSetIterator
Visual Basic (Declaration)
Public MustInherit Class GroupSetIterator
Visual C++
public ref class GroupSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GroupSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

GroupSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

GroupSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

GroupSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

GroupSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


GroupSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class GroupSetIterator
Visual Basic (Declaration)
Public MustInherit Class GroupSetIterator
Visual C++
public ref class GroupSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator
Autodesk.Revit.Elements Namespace


Current Property

GroupSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


Gutter Class
See Also Members
CollapseAll image DropDown image

An object that represents a gutter within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5EE23152-06FA-493a-8C35-89E979950D12")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Gutter : HostedSweep
Visual Basic (Declaration)
<GuidAttribute("5EE23152-06FA-493a-8C35-89E979950D12")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Gutter _
    Inherits HostedSweep
Visual C++
[GuidAttribute(L"5EE23152-06FA-493a-8C35-89E979950D12")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Gutter : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::Gutter

See Also

Gutter Members
Autodesk.Revit.Elements Namespace


Gutter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Gutter
Visual Basic (Declaration)
Public Class Gutter
Visual C++
public ref class Gutter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GutterGutterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddSegment | Add segments to the gutter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | GutterType | Retrieves/set an object that represents the type of the Gutter.
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Gutter
Autodesk.Revit.Elements Namespace


Gutter Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Gutter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Gutter ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


Gutter Methods
CollapseAll image DropDown image

Syntax

C#
public class Gutter
Visual Basic (Declaration)
Public Class Gutter
Visual C++
public ref class Gutter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddSegment | Add segments to the gutter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Gutter
Autodesk.Revit.Elements Namespace


AddSegment Method

Gutter..::AddSegment Method
CollapseAll image DropDown image

Add segments to the gutter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void AddSegment (
    Reference^ targetRef
)

Parameters

targetRef
Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::ArgumentNullException | This exception will be thrown in following cases: - Input targetRef is null.
System..::InvalidOperationException | This exception will be thrown in following cases: 1.Internal code fails to create the segment object. 2.Regeneration fails.
System..::ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


Gutter Properties
CollapseAll image DropDown image

Syntax

C#
public class Gutter
Visual Basic (Declaration)
Public Class Gutter
Visual C++
public ref class Gutter

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | GutterType | Retrieves/set an object that represents the type of the Gutter.
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Gutter
Autodesk.Revit.Elements Namespace


GutterType Property

Gutter..::GutterType Property
CollapseAll image DropDown image

Retrieves/set an object that represents the type of the Gutter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GutterType GutterType{ get; set;}
Visual Basic (Declaration)
Public Property GutterType As GutterType
Visual C++
public:
property GutterType^ GutterType {
    GutterType^ get ();
    void set (GutterType^ value);
}

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


Parameter Property

Gutter..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Gutter Class
Gutter Members
Autodesk.Revit.Elements Namespace


HostedSweep Class
See Also Members
CollapseAll image DropDown image

An object that represents a roof within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("864776A8-6312-4049-95AF-F24F33E9D58F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class HostedSweep : HostObject
Visual Basic (Declaration)
<GuidAttribute("864776A8-6312-4049-95AF-F24F33E9D58F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class HostedSweep _
    Inherits HostObject
Visual C++
[GuidAttribute(L"864776A8-6312-4049-95AF-F24F33E9D58F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class HostedSweep : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::SlabEdge
Autodesk.Revit.Elements..::Gutter
Autodesk.Revit.Elements..::Fascia

See Also

HostedSweep Members
Autodesk.Revit.Elements Namespace


HostedSweep Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class HostedSweep
Visual Basic (Declaration)
Public Class HostedSweep
Visual C++
public ref class HostedSweep

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | HostedSweepHostedSweepNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep
Autodesk.Revit.Elements Namespace


HostedSweep Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public HostedSweep()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostedSweep ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HostedSweep Methods
CollapseAll image DropDown image

Syntax

C#
public class HostedSweep
Visual Basic (Declaration)
Public Class HostedSweep
Visual C++
public ref class HostedSweep

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

HostedSweep
Autodesk.Revit.Elements Namespace


GetEndPointParameter Method

HostedSweep..::GetEndPointParameter Method
CollapseAll image DropDown image

Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Visual Basic (Declaration)
Public Function GetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer _
) As Double
Visual C++
public:
double GetEndPointParameter (
    Reference^ targetRef,
    int endIdx
)

Parameters

targetRef
Reference
Segment's reference whose parameter want to be get.
endIdx
Int32
Start point (=0) or end point (=1).

Return Value

Start point or end point parameter.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HorizontalFlip Method

HostedSweep..::HorizontalFlip Method
CollapseAll image DropDown image

Flip the hosted sweep object along horizontal line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void HorizontalFlip()
Visual Basic (Declaration)
Public Sub HorizontalFlip
Visual C++
public:
void HorizontalFlip ()

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


RemoveSegment Method

HostedSweep..::RemoveSegment Method
CollapseAll image DropDown image

Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment (
    Reference^ targetRef
)

Parameters

targetRef
Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


SetEndPointParameter Method

HostedSweep..::SetEndPointParameter Method
CollapseAll image DropDown image

Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Visual Basic (Declaration)
Public Function SetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer, _
    param As Double _
) As Boolean
Visual C++
public:
bool SetEndPointParameter (
    Reference^ targetRef,
    int endIdx,
    double param
)

Parameters

targetRef
Reference
Segment's reference whose parameter want to be set.
endIdx
Int32
Start point (=0) or end point (=1).
param
Double
Value of parameter.

Return Value

true if operation success.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


VerticalFlip Method

HostedSweep..::VerticalFlip Method
CollapseAll image DropDown image

Flip the hosted sweep object along vertical line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void VerticalFlip()
Visual Basic (Declaration)
Public Sub VerticalFlip
Visual C++
public:
void VerticalFlip ()

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HostedSweep Properties
CollapseAll image DropDown image

Syntax

C#
public class HostedSweep
Visual Basic (Declaration)
Public Class HostedSweep
Visual C++
public ref class HostedSweep

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep
Autodesk.Revit.Elements Namespace


Angle Property

HostedSweep..::Angle Property
CollapseAll image DropDown image

Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Angle{ get; set;}
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HorizontalFlipped Property

HostedSweep..::HorizontalFlipped Property
CollapseAll image DropDown image

Retrieve the horizontal flip status of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HorizontalFlipped{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HorizontalFlipped As Boolean
Visual C++
public:
property bool HorizontalFlipped {
    bool get ();
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HorizontalOffset Property

HostedSweep..::HorizontalOffset Property
CollapseAll image DropDown image

Retrieve/set the horizontal offset of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HorizontalOffset{ get; set;}
Visual Basic (Declaration)
Public Property HorizontalOffset As Double
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


Length Property

HostedSweep..::Length Property
CollapseAll image DropDown image

Retrieve the length of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Length{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


Parameter Property

HostedSweep..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

HostedSweep Class
HostedSweep Members
Autodesk.Revit.Elements Namespace


ReferenceCurve Property

HostedSweep..::ReferenceCurve Property
CollapseAll image DropDown image

Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve ReferenceCurve[
    Reference targetRef
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ReferenceCurve ( _
    targetRef As Reference _
) As Curve
Visual C++
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}

Parameters

targetRef
Reference
Segment's reference whose curve want to be retrieved.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


VerticalFlipped Property

HostedSweep..::VerticalFlipped Property
CollapseAll image DropDown image

Retrieve the vertical flip status of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool VerticalFlipped{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VerticalFlipped As Boolean
Visual C++
public:
property bool VerticalFlipped {
    bool get ();
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


VerticalOffset Property

HostedSweep..::VerticalOffset Property
CollapseAll image DropDown image

Retrieve/set the vertical offset of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double VerticalOffset{ get; set;}
Visual Basic (Declaration)
Public Property VerticalOffset As Double
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HostObject Class
See Also Members
CollapseAll image DropDown image

A base class that provides support for all objects that can host other objects, such as a wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B9A60FA9-F07B-4ebe-A7E9-59E4704DE5D6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class HostObject : Element
Visual Basic (Declaration)
<GuidAttribute("B9A60FA9-F07B-4ebe-A7E9-59E4704DE5D6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class HostObject _
    Inherits Element
Visual C++
[GuidAttribute(L"B9A60FA9-F07B-4ebe-A7E9-59E4704DE5D6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class HostObject : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CeilingAndFloor
Autodesk.Revit.Elements..::Wall
Autodesk.Revit.Elements..::Floor
Autodesk.Revit.Elements..::ContFooting
Autodesk.Revit.Elements..::RoofBase
Autodesk.Revit.Elements..::Wire
Autodesk.Revit.Elements..::CurtainGridLine
Autodesk.Revit.Elements..::CurtainSystemBase
Autodesk.Revit.Elements..::HostedSweep

See Also

HostObject Members
Autodesk.Revit.Elements Namespace


HostObject Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class HostObject
Visual Basic (Declaration)
Public Class HostObject
Visual C++
public ref class HostObject

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | HostObjectHostObjectNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostObject
Autodesk.Revit.Elements Namespace


HostObject Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public HostObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostObject ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostObject Class
Autodesk.Revit.Elements Namespace


HostObject Methods
CollapseAll image DropDown image

Syntax

C#
public class HostObject
Visual Basic (Declaration)
Public Class HostObject
Visual C++
public ref class HostObject

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

HostObject
Autodesk.Revit.Elements Namespace


Dispose Method

HostObject..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

HostObject Class
Autodesk.Revit.Elements Namespace


IndependentTag Class
See Also Members
CollapseAll image DropDown image

Represents a IndependentTag within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5627D384-3285-4475-8DD3-DA19E8384DED")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class IndependentTag : Element
Visual Basic (Declaration)
<GuidAttribute("5627D384-3285-4475-8DD3-DA19E8384DED")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class IndependentTag _
    Inherits Element
Visual C++
[GuidAttribute(L"5627D384-3285-4475-8DD3-DA19E8384DED")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class IndependentTag : public Element

Remarks

The IndependentTag object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::IndependentTag

See Also

IndependentTag Members
Autodesk.Revit.Elements Namespace


IndependentTag Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class IndependentTag
Visual Basic (Declaration)
Public Class IndependentTag
Visual C++
public ref class IndependentTag

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | IndependentTagIndependentTagNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | Returns whether the tag have Leader, and can add a leader to tag via set function.
Public property | LeaderElbow | Returns the position of the elbow of leader.
Public property | LeaderEnd | Returns the position of the end of leader.
Public property | LeaderMode | Returns whether the Leader End Condition of tag.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TagHeadPosition | Returns the position of the head of tag.
Public property | TagMode | Returns whether the Tag Mode of tag.
Public property | TagOrientation | Returns whether the tag Orientation of tag.
Public property | TagText | Returns the text of the Tag.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

IndependentTag
Autodesk.Revit.Elements Namespace


IndependentTag Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IndependentTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IndependentTag ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


IndependentTag Properties
CollapseAll image DropDown image

Syntax

C#
public class IndependentTag
Visual Basic (Declaration)
Public Class IndependentTag
Visual C++
public ref class IndependentTag

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | Returns whether the tag have Leader, and can add a leader to tag via set function.
Public property | LeaderElbow | Returns the position of the elbow of leader.
Public property | LeaderEnd | Returns the position of the end of leader.
Public property | LeaderMode | Returns whether the Leader End Condition of tag.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TagHeadPosition | Returns the position of the head of tag.
Public property | TagMode | Returns whether the Tag Mode of tag.
Public property | TagOrientation | Returns whether the tag Orientation of tag.
Public property | TagText | Returns the text of the Tag.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

IndependentTag
Autodesk.Revit.Elements Namespace


Leader Property

IndependentTag..::Leader Property
CollapseAll image DropDown image

Returns whether the tag have Leader, and can add a leader to tag via set function.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Leader{ get; set;}
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Return Value

If the tag hold a Leader, return true; if not, return false.

Remarks

This property retrieves the Leader of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


LeaderElbow Property

IndependentTag..::LeaderElbow Property
CollapseAll image DropDown image

Returns the position of the elbow of leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ LeaderElbow{ get; set;}
Visual Basic (Declaration)
Public Property LeaderElbow As XYZ
Visual C++
public:
property XYZ^ LeaderElbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Elbow of the Tag Leader.

Remarks

This property retrieves the elbow position of Tag Leader.

Exceptions

Exception | Condition
System..::InvalidOperationException | If there is no leader for this tag or the leader is straight, the InvalidOperationException will be thrown.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


LeaderEnd Property

IndependentTag..::LeaderEnd Property
CollapseAll image DropDown image

Returns the position of the end of leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ LeaderEnd{ get; set;}
Visual Basic (Declaration)
Public Property LeaderEnd As XYZ
Visual C++
public:
property XYZ^ LeaderEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the end of the Tag Leader.

Remarks

This property retrieves the end position of Tag Leader, which tie to the Host obj. And ONLY Material Tag support Set operation!

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


LeaderMode Property

IndependentTag..::LeaderMode Property
CollapseAll image DropDown image

Returns whether the Leader End Condition of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LeaderEndCondition LeaderMode{ get; set;}
Visual Basic (Declaration)
Public Property LeaderMode As LeaderEndCondition
Visual C++
public:
property LeaderEndCondition LeaderMode {
    LeaderEndCondition get ();
    void set (LeaderEndCondition value);
}

Return Value

Return the End Condition of the Tag Leader.

Remarks

This property retrieves the Leader Mode of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

IndependentTag..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

IndependentTag Class
IndependentTag Members
Autodesk.Revit.Elements Namespace


TagHeadPosition Property

IndependentTag..::TagHeadPosition Property
CollapseAll image DropDown image

Returns the position of the head of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ TagHeadPosition{ get; set;}
Visual Basic (Declaration)
Public Property TagHeadPosition As XYZ
Visual C++
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Head Position of the Tag.

Remarks

This property retrieves the head position of tag head.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


TagMode Property

IndependentTag..::TagMode Property
CollapseAll image DropDown image

Returns whether the Tag Mode of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TagMode TagMode{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TagMode As TagMode
Visual C++
public:
property TagMode TagMode {
    TagMode get ();
}

Return Value

Return the Tag Mode of the Tag.

Remarks

This read only property retrieves the Mode of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


TagOrientation Property

IndependentTag..::TagOrientation Property
CollapseAll image DropDown image

Returns whether the tag Orientation of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TagOrientation TagOrientation{ get; set;}
Visual Basic (Declaration)
Public Property TagOrientation As TagOrientation
Visual C++
public:
property TagOrientation TagOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}

Return Value

Return the Orientation of the Tag.

Remarks

This property retrieves the tag Orientation of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


TagText Property

IndependentTag..::TagText Property
CollapseAll image DropDown image

Returns the text of the Tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string TagText{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TagText As String
Visual C++
public:
property String^ TagText {
    String^ get ();
}

Return Value

Return the text of the Tag.

Remarks

This property retrieves the text of the Tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


InsertableInstance Class
See Also Members
CollapseAll image DropDown image

A base class that provides support insertable instances.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A3C274C2-A754-4ccb-9202-18FF73696730")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class InsertableInstance : Instance
Visual Basic (Declaration)
<GuidAttribute("A3C274C2-A754-4ccb-9202-18FF73696730")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class InsertableInstance _
    Inherits Instance
Visual C++
[GuidAttribute(L"A3C274C2-A754-4ccb-9202-18FF73696730")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class InsertableInstance : public Instance

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::InsertableInstance
Autodesk.Revit.Elements..::FamilyInstance

See Also

InsertableInstance Members
Autodesk.Revit.Elements Namespace


InsertableInstance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InsertableInstance
Visual Basic (Declaration)
Public Class InsertableInstance
Visual C++
public ref class InsertableInstance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InsertableInstanceInsertableInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsertableInstance
Autodesk.Revit.Elements Namespace


InsertableInstance Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsertableInstance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsertableInstance ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InsertableInstance Class
Autodesk.Revit.Elements Namespace


InsertableInstance Methods
CollapseAll image DropDown image

Syntax

C#
public class InsertableInstance
Visual Basic (Declaration)
Public Class InsertableInstance
Visual C++
public ref class InsertableInstance

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

InsertableInstance
Autodesk.Revit.Elements Namespace


Dispose Method

InsertableInstance..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InsertableInstance Class
Autodesk.Revit.Elements Namespace


Instance Class
See Also Members
CollapseAll image DropDown image

A base class for all instance objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E1AB420F-77F1-452c-B53F-E97A60AB16DA")]
public class Instance : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E1AB420F-77F1-452c-B53F-E97A60AB16DA")> _
Public Class Instance _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E1AB420F-77F1-452c-B53F-E97A60AB16DA")]
public ref class Instance : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::InsertableInstance
Autodesk.Revit.Site..::ProjectLocation

See Also

Instance Members
Autodesk.Revit.Elements Namespace


Instance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Instance
Visual Basic (Declaration)
Public Class Instance
Visual C++
public ref class Instance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Instance
Autodesk.Revit.Elements Namespace


Instance Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Instance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Instance ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Instance Class
Autodesk.Revit.Elements Namespace


InsulationType Class
See Also Members
CollapseAll image DropDown image

Represents electrical insulation type definition information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DD811A5A-38D2-4aa7-A20A-1C2656027C69")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class InsulationType : Element
Visual Basic (Declaration)
<GuidAttribute("DD811A5A-38D2-4aa7-A20A-1C2656027C69")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class InsulationType _
    Inherits Element
Visual C++
[GuidAttribute(L"DD811A5A-38D2-4aa7-A20A-1C2656027C69")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class InsulationType : public Element

Remarks

Insulation type is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::InsulationType

See Also

InsulationType Members
Autodesk.Revit.Elements Namespace


InsulationType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InsulationType
Visual Basic (Declaration)
Public Class InsulationType
Visual C++
public ref class InsulationType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InsulationTypeInsulationTypeNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the insulation type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get name of Insulation type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsulationType
Autodesk.Revit.Elements Namespace


InsulationType Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsulationType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationType ()

See Also

InsulationType Class
Autodesk.Revit.Elements Namespace


InsulationType Properties
CollapseAll image DropDown image

Syntax

C#
public class InsulationType
Visual Basic (Declaration)
Public Class InsulationType
Visual C++
public ref class InsulationType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the insulation type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get name of Insulation type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsulationType
Autodesk.Revit.Elements Namespace


IsInUse Property

InsulationType..::IsInUse Property
CollapseAll image DropDown image

Indicate whether the insulation type is in use.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInUse{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

InsulationType Class
Autodesk.Revit.Elements Namespace


Name Property

InsulationType..::Name Property
CollapseAll image DropDown image

Get name of Insulation type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::NotSupportedException | Set name can't be supported.

See Also

InsulationType Class
Autodesk.Revit.Elements Namespace


Parameter Property

InsulationType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

InsulationType Class
InsulationType Members
Autodesk.Revit.Elements Namespace


InsulationTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains insulation types.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("26FCA5CE-A555-4854-818C-A11D2D9615DA")]
public class InsulationTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("26FCA5CE-A555-4854-818C-A11D2D9615DA")> _
Public Class InsulationTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"26FCA5CE-A555-4854-818C-A11D2D9615DA")]
public ref class InsulationTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::InsulationTypeSet

See Also

InsulationTypeSet Members
Autodesk.Revit.Elements Namespace


InsulationTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InsulationTypeSet
Visual Basic (Declaration)
Public Class InsulationTypeSet
Visual C++
public ref class InsulationTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InsulationTypeSetInsulationTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every insulation type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a insulation type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified insulation type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified insulation type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of insulation types that are in the set.

See Also

InsulationTypeSet
Autodesk.Revit.Elements Namespace


InsulationTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsulationTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationTypeSet ()

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


InsulationTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class InsulationTypeSet
Visual Basic (Declaration)
Public Class InsulationTypeSet
Visual C++
public ref class InsulationTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every insulation type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a insulation type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified insulation type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified insulation type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

InsulationTypeSet
Autodesk.Revit.Elements Namespace


Clear Method

InsulationTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every insulation type from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


Contains Method

InsulationTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a insulation type within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    InsulationType^ item
)

Parameters

item
InsulationType
The insulation type to be searched for.

Return Value

The Contains method returns True if the insulation type is within the set, otherwise False.

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

InsulationTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


Erase Method

InsulationTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified insulation type from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As InsulationType _
) As Integer
Visual C++
public:
virtual int Erase (
    InsulationType^ item
)

Parameters

item
InsulationType
The insulation type to be erased.

Return Value

The number of insulation types that were erased from the set.

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

InsulationTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual InsulationTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

InsulationTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


Insert Method

InsulationTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified insulation type into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    InsulationType^ item
)

Parameters

item
InsulationType
The insulation type to be inserted into the set.

Return Value

Returns whether the insulation type was inserted into the set.

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

InsulationTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

InsulationTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual InsulationTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


InsulationTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class InsulationTypeSet
Visual Basic (Declaration)
Public Class InsulationTypeSet
Visual C++
public ref class InsulationTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of insulation types that are in the set.

See Also

InsulationTypeSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

InsulationTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


Size Property

InsulationTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of insulation types that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InsulationTypeSet Class
Autodesk.Revit.Elements Namespace


InsulationTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a insulation type set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("026D7C5E-6ECF-4789-9D41-D510FEB70CAE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class InsulationTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("026D7C5E-6ECF-4789-9D41-D510FEB70CAE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class InsulationTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"026D7C5E-6ECF-4789-9D41-D510FEB70CAE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class InsulationTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::InsulationTypeSetIterator

See Also

InsulationTypeSetIterator Members
Autodesk.Revit.Elements Namespace


InsulationTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class InsulationTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class InsulationTypeSetIterator
Visual C++
public ref class InsulationTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InsulationTypeSetIteratorInsulationTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator
Autodesk.Revit.Elements Namespace


InsulationTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsulationTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.Elements Namespace


InsulationTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class InsulationTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class InsulationTypeSetIterator
Visual C++
public ref class InsulationTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

InsulationTypeSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

InsulationTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

InsulationTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

InsulationTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

InsulationTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.Elements Namespace


InsulationTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class InsulationTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class InsulationTypeSetIterator
Visual C++
public ref class InsulationTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator
Autodesk.Revit.Elements Namespace


Current Property

InsulationTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.Elements Namespace


LayoutRule Class
See Also Members
CollapseAll image DropDown image

The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CBF44E93-2DA5-4df0-AC5F-577F327E1A47")]
public abstract class LayoutRule : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CBF44E93-2DA5-4df0-AC5F-577F327E1A47")> _
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CBF44E93-2DA5-4df0-AC5F-577F327E1A47")]
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleFixedDistance
Autodesk.Revit.Elements..::LayoutRuleFixedNumber
Autodesk.Revit.Elements..::LayoutRuleMaximumSpacing
Autodesk.Revit.Elements..::LayoutRuleClearSpacing

See Also

LayoutRule Members
Autodesk.Revit.Elements Namespace


LayoutRule Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LayoutRule
Visual Basic (Declaration)
Public MustInherit Class LayoutRule
Visual C++
public ref class LayoutRule abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LayoutRuleLayoutRuleNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule
Autodesk.Revit.Elements Namespace


LayoutRule Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRule()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRule ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRule Class
Autodesk.Revit.Elements Namespace


LayoutRule Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LayoutRule
Visual Basic (Declaration)
Public MustInherit Class LayoutRule
Visual C++
public ref class LayoutRule abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

LayoutRule
Autodesk.Revit.Elements Namespace


Dispose Method

LayoutRule..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LayoutRule Class
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Clear-Spacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7D15F3B9-F54E-49fe-9594-0313C64D72AF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LayoutRuleClearSpacing : LayoutRule
Visual Basic (Declaration)
<GuidAttribute("7D15F3B9-F54E-49fe-9594-0313C64D72AF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LayoutRuleClearSpacing _
    Inherits LayoutRule
Visual C++
[GuidAttribute(L"7D15F3B9-F54E-49fe-9594-0313C64D72AF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LayoutRuleClearSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleClearSpacing

See Also

LayoutRuleClearSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleClearSpacing
Visual Basic (Declaration)
Public Class LayoutRuleClearSpacing
Visual C++
public ref class LayoutRuleClearSpacing

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LayoutRuleClearSpacingLayoutRuleClearSpacingNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | LayoutRuleClearSpacingLayoutRuleClearSpacingNew()() | For Internal Use Only.
Public method | LayoutRuleClearSpacingLayoutRuleClearSpacingNew(Double, BeamSystemJustifyType) | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

See Also

LayoutRuleClearSpacing Class
LayoutRuleClearSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleClearSpacing()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleClearSpacing ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Constructor (Double, BeamSystemJustifyType)
CollapseAll image DropDown image

Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleClearSpacing (
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Double
The value of spacing must be in [0, 30000).
justifyType
BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Methods
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleClearSpacing
Visual Basic (Declaration)
Public Class LayoutRuleClearSpacing
Visual C++
public ref class LayoutRuleClearSpacing

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

LayoutRuleClearSpacing
Autodesk.Revit.Elements Namespace


Dispose Method

LayoutRuleClearSpacing..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Properties
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleClearSpacing
Visual Basic (Declaration)
Public Class LayoutRuleClearSpacing
Visual C++
public ref class LayoutRuleClearSpacing

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing
Autodesk.Revit.Elements Namespace


JustifyType Property

LayoutRuleClearSpacing..::JustifyType Property
CollapseAll image DropDown image

Get or set the type of justification.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystemJustifyType JustifyType{ get; set;}
Visual Basic (Declaration)
Public Property JustifyType As BeamSystemJustifyType
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


Spacing Property

LayoutRuleClearSpacing..::Spacing Property
CollapseAll image DropDown image

Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Spacing{ get; set;}
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Fixed-Distance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("17DB8BE0-D34F-4f16-BD65-E4E0059C740C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LayoutRuleFixedDistance : LayoutRule
Visual Basic (Declaration)
<GuidAttribute("17DB8BE0-D34F-4f16-BD65-E4E0059C740C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LayoutRuleFixedDistance _
    Inherits LayoutRule
Visual C++
[GuidAttribute(L"17DB8BE0-D34F-4f16-BD65-E4E0059C740C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LayoutRuleFixedDistance : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleFixedDistance

See Also

LayoutRuleFixedDistance Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleFixedDistance
Visual Basic (Declaration)
Public Class LayoutRuleFixedDistance
Visual C++
public ref class LayoutRuleFixedDistance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LayoutRuleFixedDistanceLayoutRuleFixedDistanceNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | LayoutRuleFixedDistanceLayoutRuleFixedDistanceNew()() | For Internal Use Only.
Public method | LayoutRuleFixedDistanceLayoutRuleFixedDistanceNew(Double, BeamSystemJustifyType) | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

See Also

LayoutRuleFixedDistance Class
LayoutRuleFixedDistance Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleFixedDistance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleFixedDistance ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Constructor (Double, BeamSystemJustifyType)
CollapseAll image DropDown image

Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleFixedDistance (
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Double
The value of spacing must be in (0, 30000).
justifyType
BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Methods
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleFixedDistance
Visual Basic (Declaration)
Public Class LayoutRuleFixedDistance
Visual C++
public ref class LayoutRuleFixedDistance

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

LayoutRuleFixedDistance
Autodesk.Revit.Elements Namespace


Dispose Method

LayoutRuleFixedDistance..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Properties
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleFixedDistance
Visual Basic (Declaration)
Public Class LayoutRuleFixedDistance
Visual C++
public ref class LayoutRuleFixedDistance

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance
Autodesk.Revit.Elements Namespace


JustifyType Property

LayoutRuleFixedDistance..::JustifyType Property
CollapseAll image DropDown image

Get or set the type of justification.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystemJustifyType JustifyType{ get; set;}
Visual Basic (Declaration)
Public Property JustifyType As BeamSystemJustifyType
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


Spacing Property

LayoutRuleFixedDistance..::Spacing Property
CollapseAll image DropDown image

Get or set spacing of the Beam System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Spacing{ get; set;}
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Fixed-Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D518A610-7616-4c53-AE97-681A7453EA69")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LayoutRuleFixedNumber : LayoutRule
Visual Basic (Declaration)
<GuidAttribute("D518A610-7616-4c53-AE97-681A7453EA69")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LayoutRuleFixedNumber _
    Inherits LayoutRule
Visual C++
[GuidAttribute(L"D518A610-7616-4c53-AE97-681A7453EA69")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LayoutRuleFixedNumber : public LayoutRule

Remarks

To use this type of LayoutRule, only the number of the beams must be set.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleFixedNumber

See Also

LayoutRuleFixedNumber Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleFixedNumber
Visual Basic (Declaration)
Public Class LayoutRuleFixedNumber
Visual C++
public ref class LayoutRuleFixedNumber

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LayoutRuleFixedNumberLayoutRuleFixedNumberNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | LayoutRuleFixedNumberLayoutRuleFixedNumberNew()() | For Internal Use Only.
Public method | LayoutRuleFixedNumberLayoutRuleFixedNumberNew(Int32) | Constructor of LayoutRuleFixedNumber.

See Also

LayoutRuleFixedNumber Class
LayoutRuleFixedNumber Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleFixedNumber()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleFixedNumber ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Constructor (Int32)
CollapseAll image DropDown image

Constructor of LayoutRuleFixedNumber.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleFixedNumber(
    int numberOfLines
)
Visual Basic (Declaration)
Public Sub New ( _
    numberOfLines As Integer _
)
Visual C++
public:
LayoutRuleFixedNumber (
    int numberOfLines
)

Parameters

numberOfLines
Int32
The value of numberOfLines must be positive.

Remarks

Create a LayoutRuleFixedNumber object with the number of the beams and this number must be positive.

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Methods
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleFixedNumber
Visual Basic (Declaration)
Public Class LayoutRuleFixedNumber
Visual C++
public ref class LayoutRuleFixedNumber

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

LayoutRuleFixedNumber
Autodesk.Revit.Elements Namespace


Dispose Method

LayoutRuleFixedNumber..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Properties
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleFixedNumber
Visual Basic (Declaration)
Public Class LayoutRuleFixedNumber
Visual C++
public ref class LayoutRuleFixedNumber

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber
Autodesk.Revit.Elements Namespace


NumberOfLines Property

LayoutRuleFixedNumber..::NumberOfLines Property
CollapseAll image DropDown image

Get or set the number of the beams in a beam system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumberOfLines{ get; set;}
Visual Basic (Declaration)
Public Property NumberOfLines As Integer
Visual C++
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}

Remarks

The number must be positive.

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Max-Spacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DA1A1817-CCC4-4a5b-9ABF-BA37778F0264")]
public class LayoutRuleMaximumSpacing : LayoutRule
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DA1A1817-CCC4-4a5b-9ABF-BA37778F0264")> _
Public Class LayoutRuleMaximumSpacing _
    Inherits LayoutRule
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DA1A1817-CCC4-4a5b-9ABF-BA37778F0264")]
public ref class LayoutRuleMaximumSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleMaximumSpacing

See Also

LayoutRuleMaximumSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleMaximumSpacing
Visual Basic (Declaration)
Public Class LayoutRuleMaximumSpacing
Visual C++
public ref class LayoutRuleMaximumSpacing

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LayoutRuleMaximumSpacingLayoutRuleMaximumSpacingNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | LayoutRuleMaximumSpacingLayoutRuleMaximumSpacingNew()() | For Internal Use Only.
Public method | LayoutRuleMaximumSpacingLayoutRuleMaximumSpacingNew(Double) | Constructor of LayoutRuleMaximumSpacing.

See Also

LayoutRuleMaximumSpacing Class
LayoutRuleMaximumSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleMaximumSpacing()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleMaximumSpacing ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Constructor (Double)
CollapseAll image DropDown image

Constructor of LayoutRuleMaximumSpacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleMaximumSpacing(
    double spacing
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double _
)
Visual C++
public:
LayoutRuleMaximumSpacing (
    double spacing
)

Parameters

spacing
Double
The value of spacing must be in (0, 30000).

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Methods
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleMaximumSpacing
Visual Basic (Declaration)
Public Class LayoutRuleMaximumSpacing
Visual C++
public ref class LayoutRuleMaximumSpacing

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides LayoutRule ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

LayoutRuleMaximumSpacing
Autodesk.Revit.Elements Namespace


Dispose Method

LayoutRuleMaximumSpacing..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Properties
CollapseAll image DropDown image

Syntax

C#
public class LayoutRuleMaximumSpacing
Visual Basic (Declaration)
Public Class LayoutRuleMaximumSpacing
Visual C++
public ref class LayoutRuleMaximumSpacing

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing
Autodesk.Revit.Elements Namespace


Spacing Property

LayoutRuleMaximumSpacing..::Spacing Property
CollapseAll image DropDown image

Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Spacing{ get; set;}
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


Level Class
See Also Members
CollapseAll image DropDown image

Represents a Level line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("98333DD3-C7C2-4e26-B54B-2876D00D98D5")]
public class Level : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("98333DD3-C7C2-4e26-B54B-2876D00D98D5")> _
Public Class Level _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"98333DD3-C7C2-4e26-B54B-2876D00D98D5")]
public ref class Level : public Element

Remarks

The Level object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the user visible name of the level that appears in the level bubble. To retrieve all the levels within a project use the Document.Elements iterator and look for objects of type Autodesk.Revit.Elements.Level.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Level

See Also

Level Members
Autodesk.Revit.Elements Namespace


Level Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Level
Visual Basic (Declaration)
Public Class Level
Visual C++
public ref class Level

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LevelLevelNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieve or change the elevation above or below the ground level.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LevelType | The level style of this level.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Level
Autodesk.Revit.Elements Namespace


Level Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Level ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Level Class
Autodesk.Revit.Elements Namespace


Level Properties
CollapseAll image DropDown image

Syntax

C#
public class Level
Visual Basic (Declaration)
Public Class Level
Visual C++
public ref class Level

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieve or change the elevation above or below the ground level.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LevelType | The level style of this level.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Level
Autodesk.Revit.Elements Namespace


Elevation Property

Level..::Elevation Property
CollapseAll image DropDown image

Retrieve or change the elevation above or below the ground level.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Elevation{ get; set;}
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

This property Retrieve or change the elevation above or below the ground level of the project. If the Elevation Base parameter is set to Project, the elevation is relative to project origin. If the Elevation Base parameter is set to Shared, the elevation is relative to shared origin which can be changed by relocate operation. The value is given in decimal feet.

See Also

Level Class
Autodesk.Revit.Elements Namespace


LevelType Property

Level..::LevelType Property
CollapseAll image DropDown image

The level style of this level.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LevelType LevelType{ get; set;}
Visual Basic (Declaration)
Public Property LevelType As LevelType
Visual C++
public:
property LevelType^ LevelType {
    LevelType^ get ();
    void set (LevelType^ value);
}

See Also

Level Class
Autodesk.Revit.Elements Namespace


Parameter Property

Level..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Level Class
Level Members
Autodesk.Revit.Elements Namespace


ProjectElevation Property

Level..::ProjectElevation Property
CollapseAll image DropDown image

Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ProjectElevation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ProjectElevation As Double
Visual C++
public:
property double ProjectElevation {
    double get ();
}

Remarks

This read only property returns the elevation relative to project origin.

See Also

Level Class
Autodesk.Revit.Elements Namespace


LinearArray Class
See Also Members
CollapseAll image DropDown image

An object that represents an Array created linearly within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("55655614-3DED-44a2-AC44-B2614AA75259")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LinearArray : BaseArray
Visual Basic (Declaration)
<GuidAttribute("55655614-3DED-44a2-AC44-B2614AA75259")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LinearArray _
    Inherits BaseArray
Visual C++
[GuidAttribute(L"55655614-3DED-44a2-AC44-B2614AA75259")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LinearArray : public BaseArray

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BaseArray
Autodesk.Revit.Elements..::LinearArray

See Also

LinearArray Members
Autodesk.Revit.Elements Namespace


LinearArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LinearArray
Visual Basic (Declaration)
Public Class LinearArray
Visual C++
public ref class LinearArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LinearArrayLinearArrayNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray ..:: CopyMembers.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from BaseArray.)
Public property | NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray ..:: NumMembers.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray ..:: OrigMembers.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LinearArray
Autodesk.Revit.Elements Namespace


LinearArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinearArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearArray ()

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


LinearArray Properties
CollapseAll image DropDown image

Syntax

C#
public class LinearArray
Visual Basic (Declaration)
Public Class LinearArray
Visual C++
public ref class LinearArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray ..:: CopyMembers.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from BaseArray.)
Public property | NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray ..:: NumMembers.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray ..:: OrigMembers.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LinearArray
Autodesk.Revit.Elements Namespace


CopyMembers Property

LinearArray..::CopyMembers Property
CollapseAll image DropDown image

Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override ElementArray CopyMembers{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


NumMembers Property

LinearArray..::NumMembers Property
CollapseAll image DropDown image

Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override int NumMembers{ get; set;}
Visual Basic (Declaration)
Public Overrides Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


OrigMembers Property

LinearArray..::OrigMembers Property
CollapseAll image DropDown image

Retrieve the original members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override ElementArray OrigMembers{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


Parameter Property

LinearArray..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LinearArray Class
LinearArray Members
Autodesk.Revit.Elements Namespace


LineLoad Class
See Also Members
CollapseAll image DropDown image

An object that represents a force/moment applied in a linear manner.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B60742B1-4D95-4e65-A404-C24EC450DAA4")]
public class LineLoad : LoadBase
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B60742B1-4D95-4e65-A404-C24EC450DAA4")> _
Public Class LineLoad _
    Inherits LoadBase
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B60742B1-4D95-4e65-A404-C24EC450DAA4")]
public ref class LineLoad : public LoadBase

Remarks

The load/moment may be uniform or it may vary between the two ends of the line.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::LineLoad

See Also

LineLoad Members
Autodesk.Revit.Elements Namespace


LineLoad Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LineLoad
Visual Basic (Declaration)
Public Class LineLoad
Visual C++
public ref class LineLoad

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineLoadLineLoadNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndPoint | Returns the three dimensional location of the end point for the line load.
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the start point of the line load.
Public property | Force2 | Returns the three dimensional force applied to the end point of the line load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment applied to one of the points for the line load.
Public property | Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Public property | Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Point | Returns the three dimensional location of one of the points for the line load.
Public property | ProjectedLoad | Returns whether the load is projected or not.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StartPoint | Returns the three dimensional location of the start point for the line load.
Public property | UniformLoad | Report if the load is uniform.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoad
Autodesk.Revit.Elements Namespace


LineLoad Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoad ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


LineLoad Methods
CollapseAll image DropDown image

Syntax

C#
public class LineLoad
Visual Basic (Declaration)
Public Class LineLoad
Visual C++
public ref class LineLoad

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

LineLoad
Autodesk.Revit.Elements Namespace


Dispose Method

LineLoad..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


LineLoad Properties
CollapseAll image DropDown image

Syntax

C#
public class LineLoad
Visual Basic (Declaration)
Public Class LineLoad
Visual C++
public ref class LineLoad

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndPoint | Returns the three dimensional location of the end point for the line load.
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the start point of the line load.
Public property | Force2 | Returns the three dimensional force applied to the end point of the line load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment applied to one of the points for the line load.
Public property | Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Public property | Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Point | Returns the three dimensional location of one of the points for the line load.
Public property | ProjectedLoad | Returns whether the load is projected or not.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StartPoint | Returns the three dimensional location of the start point for the line load.
Public property | UniformLoad | Report if the load is uniform.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoad
Autodesk.Revit.Elements Namespace


EndPoint Property

LineLoad..::EndPoint Property
CollapseAll image DropDown image

Returns the three dimensional location of the end point for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ EndPoint{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As XYZ
Visual C++
public:
property XYZ^ EndPoint {
    XYZ^ get ();
}

Remarks

The location of the end point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Force Property

LineLoad..::Force Property
CollapseAll image DropDown image

Returns the three dimensional force applied to one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Force1 Property

LineLoad..::Force1 Property
CollapseAll image DropDown image

Returns the three dimensional force applied to the start point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force1{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force1 As XYZ
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Force2 Property

LineLoad..::Force2 Property
CollapseAll image DropDown image

Returns the three dimensional force applied to the end point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force2{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force2 As XYZ
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Moment Property

LineLoad..::Moment Property
CollapseAll image DropDown image

Returns the three dimensional moment applied to one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Moment[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Moment ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Moment[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Moment1 Property

LineLoad..::Moment1 Property
CollapseAll image DropDown image

Returns the three dimensional moment applied to the start point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Moment1{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Moment1 As XYZ
Visual C++
public:
property XYZ^ Moment1 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Moment2 Property

LineLoad..::Moment2 Property
CollapseAll image DropDown image

Returns the three dimensional moment applied to the end point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Moment2{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Moment2 As XYZ
Visual C++
public:
property XYZ^ Moment2 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Parameter Property

LineLoad..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LineLoad Class
LineLoad Members
Autodesk.Revit.Elements Namespace


Point Property

LineLoad..::Point Property
CollapseAll image DropDown image

Returns the three dimensional location of one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Point[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The location of the point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


ProjectedLoad Property

LineLoad..::ProjectedLoad Property
CollapseAll image DropDown image

Returns whether the load is projected or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ProjectedLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ProjectedLoad As Boolean
Visual C++
public:
property bool ProjectedLoad {
    bool get ();
}

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


StartPoint Property

LineLoad..::StartPoint Property
CollapseAll image DropDown image

Returns the three dimensional location of the start point for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ StartPoint{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As XYZ
Visual C++
public:
property XYZ^ StartPoint {
    XYZ^ get ();
}

Remarks

The location of the start point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


UniformLoad Property

LineLoad..::UniformLoad Property
CollapseAll image DropDown image

Report if the load is uniform.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int UniformLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UniformLoad As Integer
Visual C++
public:
property int UniformLoad {
    int get ();
}

Remarks

This property will return True is the line load is uniform, i.e. the load is that same across the entire line.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


LinePattern Class
See Also Members
CollapseAll image DropDown image

Represents a line pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D11DCFD0-B773-43c4-963E-957D30B9DFB1")]
public class LinePattern : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D11DCFD0-B773-43c4-963E-957D30B9DFB1")> _
Public Class LinePattern _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D11DCFD0-B773-43c4-963E-957D30B9DFB1")]
public ref class LinePattern : public Element

Remarks

Currently the details of the line patterns are not exposed but all the line patterns can be found on the Document object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LinePattern

See Also

LinePattern Members
Autodesk.Revit.Elements Namespace


LinePattern Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LinePattern
Visual Basic (Declaration)
Public Class LinePattern
Visual C++
public ref class LinePattern

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LinePatternLinePatternNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LinePattern
Autodesk.Revit.Elements Namespace


LinePattern Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinePattern()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePattern ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LinePattern Class
Autodesk.Revit.Elements Namespace


LinePattern Methods
CollapseAll image DropDown image

Syntax

C#
public class LinePattern
Visual Basic (Declaration)
Public Class LinePattern
Visual C++
public ref class LinePattern

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

LinePattern
Autodesk.Revit.Elements Namespace


Dispose Method

LinePattern..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LinePattern Class
Autodesk.Revit.Elements Namespace


LoadBase Class
See Also Members
CollapseAll image DropDown image

The LoadBase object is the base class for all load objects within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8AF35A53-05B0-4c95-91EA-FE873C94A3D1")]
public class LoadBase : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8AF35A53-05B0-4c95-91EA-FE873C94A3D1")> _
Public Class LoadBase _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8AF35A53-05B0-4c95-91EA-FE873C94A3D1")]
public ref class LoadBase : public Element

Remarks

Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::PointLoad
Autodesk.Revit.Elements..::LineLoad
Autodesk.Revit.Elements..::AreaLoad

See Also

LoadBase Members
Autodesk.Revit.Elements Namespace


LoadBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadBase
Visual Basic (Declaration)
Public Class LoadBase
Visual C++
public ref class LoadBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadBaseLoadBaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs.
Public property | LoadCategoryName | The name of the category to which this load belongs.
Public property | LoadNatureName | A string representing the nature of the load.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadBase
Autodesk.Revit.Elements Namespace


LoadBase Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadBase ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadBase Properties
CollapseAll image DropDown image

Syntax

C#
public class LoadBase
Visual Basic (Declaration)
Public Class LoadBase
Visual C++
public ref class LoadBase

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs.
Public property | LoadCategoryName | The name of the category to which this load belongs.
Public property | LoadNatureName | A string representing the nature of the load.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadBase
Autodesk.Revit.Elements Namespace


HostElement Property

LoadBase..::HostElement Property
CollapseAll image DropDown image

The host element for the load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element HostElement{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HostElement As Element
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

Field Value

If the load is host-based this is the host element. Otherwise this property is null.

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadCaseName Property

LoadBase..::LoadCaseName Property
CollapseAll image DropDown image

The name of the load case to which this load belongs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string LoadCaseName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LoadCaseName As String
Visual C++
public:
property String^ LoadCaseName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadCategoryName Property

LoadBase..::LoadCategoryName Property
CollapseAll image DropDown image

The name of the category to which this load belongs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string LoadCategoryName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LoadCategoryName As String
Visual C++
public:
property String^ LoadCategoryName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadNatureName Property

LoadBase..::LoadNatureName Property
CollapseAll image DropDown image

A string representing the nature of the load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string LoadNatureName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LoadNatureName As String
Visual C++
public:
property String^ LoadNatureName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

LoadBase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LoadBase Class
LoadBase Members
Autodesk.Revit.Elements Namespace


LoadCase Class
See Also Members
CollapseAll image DropDown image

This object represents a load case within the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CC5C1D25-A8C5-4c46-8C41-966EF2036AC9")]
public class LoadCase : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CC5C1D25-A8C5-4c46-8C41-966EF2036AC9")> _
Public Class LoadCase _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CC5C1D25-A8C5-4c46-8C41-966EF2036AC9")]
public ref class LoadCase : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadCase

See Also

LoadCase Members
Autodesk.Revit.Elements Namespace


LoadCase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadCase
Visual Basic (Declaration)
Public Class LoadCase
Visual C++
public ref class LoadCase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCaseLoadCaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadCase
Autodesk.Revit.Elements Namespace


LoadCase Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCase ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCase Class
Autodesk.Revit.Elements Namespace


LoadCaseArray Class
See Also Members
CollapseAll image DropDown image

An array that contains load case objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("48AFB4FA-46DA-4566-B5A1-A02AEA881BB9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LoadCaseArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("48AFB4FA-46DA-4566-B5A1-A02AEA881BB9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LoadCaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"48AFB4FA-46DA-4566-B5A1-A02AEA881BB9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadCaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadCaseArray

See Also

LoadCaseArray Members
Autodesk.Revit.Elements Namespace


LoadCaseArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseArray
Visual Basic (Declaration)
Public Class LoadCaseArray
Visual C++
public ref class LoadCaseArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCaseArrayLoadCaseArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the load case to the end of the array.
Public method | Clear | Removes every load case from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load case at a specified index within the array.
Public property | Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray
Autodesk.Revit.Elements Namespace


LoadCaseArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseArray ()

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


LoadCaseArray Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseArray
Visual Basic (Declaration)
Public Class LoadCaseArray
Visual C++
public ref class LoadCaseArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the load case to the end of the array.
Public method | Clear | Removes every load case from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadCaseArray
Autodesk.Revit.Elements Namespace


Append Method

LoadCaseArray..::Append Method
CollapseAll image DropDown image

Add the load case to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadCase _
)
Visual C++
public:
virtual void Append (
    LoadCase^ item
)

Parameters

item
LoadCase
The load case to be added.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Clear Method

LoadCaseArray..::Clear Method
CollapseAll image DropDown image

Removes every load case from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Dispose Method

LoadCaseArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

LoadCaseArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

LoadCaseArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Insert Method

LoadCaseArray..::Insert Method
CollapseAll image DropDown image

Insert the specified load case into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    LoadCase item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadCase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    LoadCase^ item,
    int index
)

Parameters

item
LoadCase
The load case to be inserted into the array.
index
Int32
The load case will be inserted before this index.

Return Value

Returns whether the load case was inserted into the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadCaseArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

LoadCaseArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


LoadCaseArray Properties
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseArray
Visual Basic (Declaration)
Public Class LoadCaseArray
Visual C++
public ref class LoadCaseArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load case at a specified index within the array.
Public property | Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray
Autodesk.Revit.Elements Namespace


IsEmpty Property

LoadCaseArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Item Property

LoadCaseArray..::Item Property
CollapseAll image DropDown image

Gets or sets an load case at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCase Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadCase
Visual C++
public:
virtual property LoadCase^ Item[int index] {
    LoadCase^ get (int index);
    void set (int index, LoadCase^ value);
}

Parameters

index
Int32
The index of the load case to be set or retrieved.

Return Value

Returns the load case at the specified index.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Size Property

LoadCaseArray..::Size Property
CollapseAll image DropDown image

Returns the number of load cases that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an load case array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("89700F3E-9360-4e72-BA8F-57A53940CD05")]
public abstract class LoadCaseArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("89700F3E-9360-4e72-BA8F-57A53940CD05")> _
Public MustInherit Class LoadCaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"89700F3E-9360-4e72-BA8F-57A53940CD05")]
public ref class LoadCaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadCaseArrayIterator

See Also

LoadCaseArrayIterator Members
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseArrayIterator
Visual C++
public ref class LoadCaseArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCaseArrayIteratorLoadCaseArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseArrayIterator
Visual C++
public ref class LoadCaseArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadCaseArrayIterator
Autodesk.Revit.Elements Namespace


Dispose Method

LoadCaseArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

LoadCaseArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadCaseArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

LoadCaseArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseArrayIterator
Visual C++
public ref class LoadCaseArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator
Autodesk.Revit.Elements Namespace


Current Property

LoadCaseArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseSet Class
See Also Members
CollapseAll image DropDown image

A set that contains load cases.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6147449F-BB59-44f1-A149-58C80DE77AAC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LoadCaseSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("6147449F-BB59-44f1-A149-58C80DE77AAC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LoadCaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"6147449F-BB59-44f1-A149-58C80DE77AAC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadCaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadCaseSet

See Also

LoadCaseSet Members
Autodesk.Revit.Elements Namespace


LoadCaseSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseSet
Visual Basic (Declaration)
Public Class LoadCaseSet
Visual C++
public ref class LoadCaseSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCaseSetLoadCaseSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every load case from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load case within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load case from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet
Autodesk.Revit.Elements Namespace


LoadCaseSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCaseSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseSet ()

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


LoadCaseSet Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseSet
Visual Basic (Declaration)
Public Class LoadCaseSet
Visual C++
public ref class LoadCaseSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every load case from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load case within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load case from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadCaseSet
Autodesk.Revit.Elements Namespace


Clear Method

LoadCaseSet..::Clear Method
CollapseAll image DropDown image

Removes every load case from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Contains Method

LoadCaseSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a load case within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Contains (
    LoadCase^ item
)

Parameters

item
LoadCase
The load case to be searched for.

Return Value

The Contains method returns True if the load case is within the set, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

LoadCaseSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Erase Method

LoadCaseSet..::Erase Method
CollapseAll image DropDown image

Removes a specified load case from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LoadCase _
) As Integer
Visual C++
public:
virtual int Erase (
    LoadCase^ item
)

Parameters

item
LoadCase
The load case to be erased.

Return Value

The number of load cases that were erased from the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

LoadCaseSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCaseSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

LoadCaseSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Insert Method

LoadCaseSet..::Insert Method
CollapseAll image DropDown image

Insert the specified load case into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Insert (
    LoadCase^ item
)

Parameters

item
LoadCase
The load case to be inserted into the set.

Return Value

Returns whether the load case was inserted into the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadCaseSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

LoadCaseSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCaseSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


LoadCaseSet Properties
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseSet
Visual Basic (Declaration)
Public Class LoadCaseSet
Visual C++
public ref class LoadCaseSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

LoadCaseSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Size Property

LoadCaseSet..::Size Property
CollapseAll image DropDown image

Returns the number of load cases that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a load case set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D1434927-9C9D-4d8c-8903-87D225FC2944")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class LoadCaseSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("D1434927-9C9D-4d8c-8903-87D225FC2944")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class LoadCaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"D1434927-9C9D-4d8c-8903-87D225FC2944")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadCaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadCaseSetIterator

See Also

LoadCaseSetIterator Members
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCaseSetIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseSetIterator
Visual C++
public ref class LoadCaseSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCaseSetIteratorLoadCaseSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCaseSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCaseSetIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseSetIterator
Visual C++
public ref class LoadCaseSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadCaseSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

LoadCaseSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

LoadCaseSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadCaseSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

LoadCaseSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCaseSetIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseSetIterator
Visual C++
public ref class LoadCaseSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator
Autodesk.Revit.Elements Namespace


Current Property

LoadCaseSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


LoadCombination Class
See Also Members
CollapseAll image DropDown image

An object that represents a load combination.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E30F7786-EC77-4a78-B018-26FBC3AE63B3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LoadCombination : Element
Visual Basic (Declaration)
<GuidAttribute("E30F7786-EC77-4a78-B018-26FBC3AE63B3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LoadCombination _
    Inherits Element
Visual C++
[GuidAttribute(L"E30F7786-EC77-4a78-B018-26FBC3AE63B3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadCombination : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadCombination

See Also

LoadCombination Members
Autodesk.Revit.Elements Namespace


LoadCombination Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadCombination
Visual Basic (Declaration)
Public Class LoadCombination
Visual C++
public ref class LoadCombination

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCombinationLoadCombinationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CombinationCaseName | Returns load combination case name.
Public property | CombinationNatureName | Returns load combination nature name of load case element.
Public property | CombinationState | Returns load combination state.
Public property | CombinationStateIndex | Returns the index in predefined load combination state array {}.
Public property | CombinationType | Returns load combination type.
Public property | CombinationTypeIndex | Returns the index in predefined load combination type array.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Factor | Returns factor value.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns load combination name.
Public property | NumberOfComponents | Returns number of factors.
Public property | NumberOfUsages | Returns number of usages.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsageName | Returns usage value.

See Also

LoadCombination
Autodesk.Revit.Elements Namespace


LoadCombination Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCombination()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombination ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


LoadCombination Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadCombination
Visual Basic (Declaration)
Public Class LoadCombination
Visual C++
public ref class LoadCombination

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

LoadCombination
Autodesk.Revit.Elements Namespace


Dispose Method

LoadCombination..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


LoadCombination Properties
CollapseAll image DropDown image

Syntax

C#
public class LoadCombination
Visual Basic (Declaration)
Public Class LoadCombination
Visual C++
public ref class LoadCombination

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CombinationCaseName | Returns load combination case name.
Public property | CombinationNatureName | Returns load combination nature name of load case element.
Public property | CombinationState | Returns load combination state.
Public property | CombinationStateIndex | Returns the index in predefined load combination state array {}.
Public property | CombinationType | Returns load combination type.
Public property | CombinationTypeIndex | Returns the index in predefined load combination type array.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Factor | Returns factor value.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns load combination name.
Public property | NumberOfComponents | Returns number of factors.
Public property | NumberOfUsages | Returns number of usages.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsageName | Returns usage value.

See Also

LoadCombination
Autodesk.Revit.Elements Namespace


CombinationCaseName Property

LoadCombination..::CombinationCaseName Property
CollapseAll image DropDown image

Returns load combination case name.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string CombinationCaseName[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CombinationCaseName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ CombinationCaseName[int index] {
    String^ get (int index);
}

Parameters

index
Int32
The index of load case.

Remarks

The index should be not less then 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationNatureName Property

LoadCombination..::CombinationNatureName Property
CollapseAll image DropDown image

Returns load combination nature name of load case element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string CombinationNatureName[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CombinationNatureName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ CombinationNatureName[int index] {
    String^ get (int index);
}

Parameters

index
Int32
The index of load case.

Remarks

The index should be not less 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationState Property

LoadCombination..::CombinationState Property
CollapseAll image DropDown image

Returns load combination state.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string CombinationState{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CombinationState As String
Visual C++
public:
property String^ CombinationState {
    String^ get ();
}

Remarks

The state should be "Serviceability" or "Ultimate".

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationStateIndex Property

LoadCombination..::CombinationStateIndex Property
CollapseAll image DropDown image

Returns the index in predefined load combination state array {}.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int CombinationStateIndex{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CombinationStateIndex As Integer
Visual C++
public:
property int CombinationStateIndex {
    int get ();
}

Remarks

The index should be 0 ("Serviceability") or 1 ("Ultimate").

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationType Property

LoadCombination..::CombinationType Property
CollapseAll image DropDown image

Returns load combination type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string CombinationType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CombinationType As String
Visual C++
public:
property String^ CombinationType {
    String^ get ();
}

Remarks

The type should be "Combination" or "Envelope".

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationTypeIndex Property

LoadCombination..::CombinationTypeIndex Property
CollapseAll image DropDown image

Returns the index in predefined load combination type array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int CombinationTypeIndex{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CombinationTypeIndex As Integer
Visual C++
public:
property int CombinationTypeIndex {
    int get ();
}

Remarks

The index should be 0 ("Combination") or 1 ("Envelope").

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


Factor Property

LoadCombination..::Factor Property
CollapseAll image DropDown image

Returns factor value.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Factor[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Factor ( _
    index As Integer _
) As Double
Visual C++
public:
property double Factor[int index] {
    double get (int index);
}

Parameters

index
Int32
The index of factor in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


Name Property

LoadCombination..::Name Property
CollapseAll image DropDown image

Returns load combination name.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get; set;}
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


NumberOfComponents Property

LoadCombination..::NumberOfComponents Property
CollapseAll image DropDown image

Returns number of factors.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumberOfComponents{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumberOfComponents As Integer
Visual C++
public:
property int NumberOfComponents {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


NumberOfUsages Property

LoadCombination..::NumberOfUsages Property
CollapseAll image DropDown image

Returns number of usages.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumberOfUsages{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumberOfUsages As Integer
Visual C++
public:
property int NumberOfUsages {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


Parameter Property

LoadCombination..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LoadCombination Class
LoadCombination Members
Autodesk.Revit.Elements Namespace


UsageName Property

LoadCombination..::UsageName Property
CollapseAll image DropDown image

Returns usage value.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string UsageName[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UsageName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ UsageName[int index] {
    String^ get (int index);
}

Parameters

index
Int32
The index of usage in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


LoadCombinationArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D730AC56-3A66-4811-AA42-9D8A3CD3221C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LoadCombinationArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("D730AC56-3A66-4811-AA42-9D8A3CD3221C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LoadCombinationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"D730AC56-3A66-4811-AA42-9D8A3CD3221C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadCombinationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadCombinationArray

See Also

LoadCombinationArray Members
Autodesk.Revit.Elements Namespace


LoadCombinationArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadCombinationArray
Visual Basic (Declaration)
Public Class LoadCombinationArray
Visual C++
public ref class LoadCombinationArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCombinationArrayLoadCombinationArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray
Autodesk.Revit.Elements Namespace


LoadCombinationArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCombinationArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombinationArray ()

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


LoadCombinationArray Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadCombinationArray
Visual Basic (Declaration)
Public Class LoadCombinationArray
Visual C++
public ref class LoadCombinationArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadCombinationArray
Autodesk.Revit.Elements Namespace


Append Method

LoadCombinationArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    LoadCombination item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadCombination _
)
Visual C++
public:
virtual void Append (
    LoadCombination^ item
)

Parameters

item
LoadCombination

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Clear Method

LoadCombinationArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Dispose Method

LoadCombinationArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

LoadCombinationArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCombinationArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

LoadCombinationArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Insert Method

LoadCombinationArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    LoadCombination item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadCombination, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    LoadCombination^ item,
    int index
)

Parameters

item
LoadCombination
index
Int32

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadCombinationArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

LoadCombinationArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCombinationArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


LoadCombinationArray Properties
CollapseAll image DropDown image

Syntax

C#
public class LoadCombinationArray
Visual Basic (Declaration)
Public Class LoadCombinationArray
Visual C++
public ref class LoadCombinationArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray
Autodesk.Revit.Elements Namespace


IsEmpty Property

LoadCombinationArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Item Property

LoadCombinationArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadCombination Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadCombination
Visual C++
public:
virtual property LoadCombination^ Item[int index] {
    LoadCombination^ get (int index);
    void set (int index, LoadCombination^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Size Property

LoadCombinationArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("216003B4-B2BA-4706-8A9B-E68A666398D5")]
public abstract class LoadCombinationArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("216003B4-B2BA-4706-8A9B-E68A666398D5")> _
Public MustInherit Class LoadCombinationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"216003B4-B2BA-4706-8A9B-E68A666398D5")]
public ref class LoadCombinationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadCombinationArrayIterator

See Also

LoadCombinationArrayIterator Members
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCombinationArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCombinationArrayIterator
Visual C++
public ref class LoadCombinationArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCombinationArrayIteratorLoadCombinationArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCombinationArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombinationArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCombinationArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCombinationArrayIterator
Visual C++
public ref class LoadCombinationArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadCombinationArrayIterator
Autodesk.Revit.Elements Namespace


Dispose Method

LoadCombinationArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

LoadCombinationArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadCombinationArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

LoadCombinationArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadCombinationArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadCombinationArrayIterator
Visual C++
public ref class LoadCombinationArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator
Autodesk.Revit.Elements Namespace


Current Property

LoadCombinationArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadNature Class
See Also Members
CollapseAll image DropDown image

A structural Load nature object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F052800A-0DEB-4485-BD91-424177EDFEF4")]
public class LoadNature : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F052800A-0DEB-4485-BD91-424177EDFEF4")> _
Public Class LoadNature _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F052800A-0DEB-4485-BD91-424177EDFEF4")]
public ref class LoadNature : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadNature

See Also

LoadNature Members
Autodesk.Revit.Elements Namespace


LoadNature Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadNature
Visual Basic (Declaration)
Public Class LoadNature
Visual C++
public ref class LoadNature

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadNatureLoadNatureNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadNature
Autodesk.Revit.Elements Namespace


LoadNature Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadNature()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadNature ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadNature Class
Autodesk.Revit.Elements Namespace


LoadNature Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadNature
Visual Basic (Declaration)
Public Class LoadNature
Visual C++
public ref class LoadNature

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

LoadNature
Autodesk.Revit.Elements Namespace


Dispose Method

LoadNature..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadNature Class
Autodesk.Revit.Elements Namespace


LoadUsage Class
See Also Members
CollapseAll image DropDown image

This object represents a load case within the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("151C8ACE-43FB-4ed7-B86C-465387BBB039")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LoadUsage : Element
Visual Basic (Declaration)
<GuidAttribute("151C8ACE-43FB-4ed7-B86C-465387BBB039")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LoadUsage _
    Inherits Element
Visual C++
[GuidAttribute(L"151C8ACE-43FB-4ed7-B86C-465387BBB039")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadUsage : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadUsage

See Also

LoadUsage Members
Autodesk.Revit.Elements Namespace


LoadUsage Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadUsage
Visual Basic (Declaration)
Public Class LoadUsage
Visual C++
public ref class LoadUsage

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadUsageLoadUsageNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadUsage
Autodesk.Revit.Elements Namespace


LoadUsage Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadUsage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsage ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadUsage Class
Autodesk.Revit.Elements Namespace


LoadUsage Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadUsage
Visual Basic (Declaration)
Public Class LoadUsage
Visual C++
public ref class LoadUsage

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

LoadUsage
Autodesk.Revit.Elements Namespace


Dispose Method

LoadUsage..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadUsage Class
Autodesk.Revit.Elements Namespace


LoadUsageArray Class
See Also Members
CollapseAll image DropDown image

An array that contains load usage objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DB846A5B-09CD-4278-BBE9-827E0A4CD83A")]
public class LoadUsageArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DB846A5B-09CD-4278-BBE9-827E0A4CD83A")> _
Public Class LoadUsageArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DB846A5B-09CD-4278-BBE9-827E0A4CD83A")]
public ref class LoadUsageArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadUsageArray

See Also

LoadUsageArray Members
Autodesk.Revit.Elements Namespace


LoadUsageArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadUsageArray
Visual Basic (Declaration)
Public Class LoadUsageArray
Visual C++
public ref class LoadUsageArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadUsageArrayLoadUsageArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the load usage to the end of the array.
Public method | Clear | Removes every load usage from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load usage into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load usage at a specified index within the array.
Public property | Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray
Autodesk.Revit.Elements Namespace


LoadUsageArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadUsageArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsageArray ()

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


LoadUsageArray Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadUsageArray
Visual Basic (Declaration)
Public Class LoadUsageArray
Visual C++
public ref class LoadUsageArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the load usage to the end of the array.
Public method | Clear | Removes every load usage from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load usage into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadUsageArray
Autodesk.Revit.Elements Namespace


Append Method

LoadUsageArray..::Append Method
CollapseAll image DropDown image

Add the load usage to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    LoadUsage item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadUsage _
)
Visual C++
public:
virtual void Append (
    LoadUsage^ item
)

Parameters

item
LoadUsage
The load usage to be added.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Clear Method

LoadUsageArray..::Clear Method
CollapseAll image DropDown image

Removes every load usage from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Dispose Method

LoadUsageArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

LoadUsageArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadUsageArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

LoadUsageArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Insert Method

LoadUsageArray..::Insert Method
CollapseAll image DropDown image

Insert the specified load usage into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    LoadUsage item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadUsage, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    LoadUsage^ item,
    int index
)

Parameters

item
LoadUsage
The load usage to be inserted into the array.
index
Int32
The load usage will be inserted before this index.

Return Value

Returns whether the load usage was inserted into the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadUsageArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

LoadUsageArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadUsageArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


LoadUsageArray Properties
CollapseAll image DropDown image

Syntax

C#
public class LoadUsageArray
Visual Basic (Declaration)
Public Class LoadUsageArray
Visual C++
public ref class LoadUsageArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load usage at a specified index within the array.
Public property | Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray
Autodesk.Revit.Elements Namespace


IsEmpty Property

LoadUsageArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Item Property

LoadUsageArray..::Item Property
CollapseAll image DropDown image

Gets or sets an load usage at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadUsage Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadUsage
Visual C++
public:
virtual property LoadUsage^ Item[int index] {
    LoadUsage^ get (int index);
    void set (int index, LoadUsage^ value);
}

Parameters

index
Int32
The index of the load usage to be set or retrieved.

Return Value

Returns the load usage at the specified index.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Size Property

LoadUsageArray..::Size Property
CollapseAll image DropDown image

Returns the number of load usages that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an load usage array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("02FED51B-3426-41ce-90AD-5C79BA220399")]
public abstract class LoadUsageArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("02FED51B-3426-41ce-90AD-5C79BA220399")> _
Public MustInherit Class LoadUsageArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"02FED51B-3426-41ce-90AD-5C79BA220399")]
public ref class LoadUsageArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LoadUsageArrayIterator

See Also

LoadUsageArrayIterator Members
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadUsageArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadUsageArrayIterator
Visual C++
public ref class LoadUsageArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadUsageArrayIteratorLoadUsageArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadUsageArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsageArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadUsageArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadUsageArrayIterator
Visual C++
public ref class LoadUsageArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadUsageArrayIterator
Autodesk.Revit.Elements Namespace


Dispose Method

LoadUsageArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

LoadUsageArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

LoadUsageArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

LoadUsageArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadUsageArrayIterator
Visual Basic (Declaration)
Public MustInherit Class LoadUsageArrayIterator
Visual C++
public ref class LoadUsageArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator
Autodesk.Revit.Elements Namespace


Current Property

LoadUsageArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


Material Class
See Also Members
CollapseAll image DropDown image

Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("80C8B148-52E1-43bd-95E5-B04612D36000")]
public abstract class Material : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("80C8B148-52E1-43bd-95E5-B04612D36000")> _
Public MustInherit Class Material _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"80C8B148-52E1-43bd-95E5-B04612D36000")]
public ref class Material abstract : public Element

Remarks

This is the abstract parent class for concrete material subclasses. Currently, the supported materials are wood, steel, generic, concrete and other.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialConcrete
Autodesk.Revit.Elements..::MaterialGeneric
Autodesk.Revit.Elements..::MaterialOther
Autodesk.Revit.Elements..::MaterialSteel
Autodesk.Revit.Elements..::MaterialWood

See Also

Material Members
Autodesk.Revit.Elements Namespace


Material Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class Material
Visual Basic (Declaration)
Public MustInherit Class Material
Visual C++
public ref class Material abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialMaterialNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicates the material.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material.
Public property | CutPattern | The cut pattern of the material.
Public property | CutPatternColor | The cut pattern color of the material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RenderAppearance | The rendering appearance property of the material.
Public property | Shininess | The shininess of the material.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material.
Public property | SurfacePattern | The surface pattern of the material.
Public property | SurfacePatternColor | The surface pattern color of the material.
Public property | Transparency | The transparency of the material.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Material
Autodesk.Revit.Elements Namespace


Material Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Material()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Material ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Material Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class Material
Visual Basic (Declaration)
Public MustInherit Class Material
Visual C++
public ref class Material abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicates the material.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Material
Autodesk.Revit.Elements Namespace


Dispose Method

Material..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Material Class
Autodesk.Revit.Elements Namespace


Duplicate Method

Material..::Duplicate Method
CollapseAll image DropDown image

Duplicates the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public MustOverride Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate (
    String^ name
) abstract

Parameters

name
String
Name of the new material.

Return Value

The new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, a null pointer will be returned.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Material Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class Material
Visual Basic (Declaration)
Public MustInherit Class Material
Visual C++
public ref class Material abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material.
Public property | CutPattern | The cut pattern of the material.
Public property | CutPatternColor | The cut pattern color of the material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RenderAppearance | The rendering appearance property of the material.
Public property | Shininess | The shininess of the material.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material.
Public property | SurfacePattern | The surface pattern of the material.
Public property | SurfacePatternColor | The surface pattern color of the material.
Public property | Transparency | The transparency of the material.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Material
Autodesk.Revit.Elements Namespace


Color Property

Material..::Color Property
CollapseAll image DropDown image

The color of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color Color{ get; set;}
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

See Also

Material Class
Autodesk.Revit.Elements Namespace


CutPattern Property

Material..::CutPattern Property
CollapseAll image DropDown image

The cut pattern of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPattern CutPattern{ get; set;}
Visual Basic (Declaration)
Public Property CutPattern As FillPattern
Visual C++
public:
property FillPattern^ CutPattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The cut pattern element, or null, if the material does not have an associated cut pattern.

See Also

Material Class
Autodesk.Revit.Elements Namespace


CutPatternColor Property

Material..::CutPatternColor Property
CollapseAll image DropDown image

The cut pattern color of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color CutPatternColor{ get; set;}
Visual Basic (Declaration)
Public Property CutPatternColor As Color
Visual C++
public:
property Color^ CutPatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the cut pattern color for this material.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Glow Property

Material..::Glow Property
CollapseAll image DropDown image

Whether the material can glow.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Glow{ get; set;}
Visual Basic (Declaration)
Public Property Glow As Boolean
Visual C++
public:
property bool Glow {
    bool get ();
    void set (bool value);
}

Field Value

True if the material can glow, false if it cannot.

Remarks

This value is obsolete in Autodesk Revit 2009 due to a similar change in the UI.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Parameter Property

Material..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Material Class
Material Members
Autodesk.Revit.Elements Namespace


RenderAppearance Property

Material..::RenderAppearance Property
CollapseAll image DropDown image

The rendering appearance property of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Asset RenderAppearance{ get; set;}
Visual Basic (Declaration)
Public Property RenderAppearance As Asset
Visual C++
public:
property Asset^ RenderAppearance {
    Asset^ get ();
    void set (Asset^ value);
}

Field Value

The rendering appearance property, or null, if the render library isn't available.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Shininess Property

Material..::Shininess Property
CollapseAll image DropDown image

The shininess of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Shininess{ get; set;}
Visual Basic (Declaration)
Public Property Shininess As Integer
Visual C++
public:
property int Shininess {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 128. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Smoothness Property

Material..::Smoothness Property
CollapseAll image DropDown image

The smoothness of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Smoothness{ get; set;}
Visual Basic (Declaration)
Public Property Smoothness As Integer
Visual C++
public:
property int Smoothness {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace


SurfacePattern Property

Material..::SurfacePattern Property
CollapseAll image DropDown image

The surface pattern of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPattern SurfacePattern{ get; set;}
Visual Basic (Declaration)
Public Property SurfacePattern As FillPattern
Visual C++
public:
property FillPattern^ SurfacePattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The surface pattern element, or null, if the material does not have an associated surface pattern.

See Also

Material Class
Autodesk.Revit.Elements Namespace


SurfacePatternColor Property

Material..::SurfacePatternColor Property
CollapseAll image DropDown image

The surface pattern color of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color SurfacePatternColor{ get; set;}
Visual Basic (Declaration)
Public Property SurfacePatternColor As Color
Visual C++
public:
property Color^ SurfacePatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the surface pattern color for this material

See Also

Material Class
Autodesk.Revit.Elements Namespace


Transparency Property

Material..::Transparency Property
CollapseAll image DropDown image

The transparency of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Transparency{ get; set;}
Visual Basic (Declaration)
Public Property Transparency As Integer
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace


MaterialConcrete Class
See Also Members
CollapseAll image DropDown image

Represents a concrete material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D571124B-EB8F-4bc8-B27C-FC2773A3188B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialConcrete : Material
Visual Basic (Declaration)
<GuidAttribute("D571124B-EB8F-4bc8-B27C-FC2773A3188B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialConcrete _
    Inherits Material
Visual C++
[GuidAttribute(L"D571124B-EB8F-4bc8-B27C-FC2773A3188B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialConcrete : public Material

Remarks

MaterialConcrete is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialConcrete

See Also

MaterialConcrete Members
Autodesk.Revit.Elements Namespace


MaterialConcrete Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialConcrete
Visual Basic (Declaration)
Public Class MaterialConcrete
Visual C++
public ref class MaterialConcrete

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialConcreteMaterialConcreteNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this concrete material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the concrete material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | ConcreteCompression | Get or set the concrete compression of the concrete material.
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DampingRatio | Get or set the damping ratio of the concrete material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LightWeight | Get or set whether the concrete material is lightweight.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
Public property | ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the concrete material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete
Autodesk.Revit.Elements Namespace


MaterialConcrete Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialConcrete()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialConcrete ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


MaterialConcrete Methods
CollapseAll image DropDown image

Syntax

C#
public class MaterialConcrete
Visual Basic (Declaration)
Public Class MaterialConcrete
Visual C++
public ref class MaterialConcrete

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this concrete material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

MaterialConcrete
Autodesk.Revit.Elements Namespace


Dispose Method

MaterialConcrete..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


Duplicate Method

MaterialConcrete..::Duplicate Method
CollapseAll image DropDown image

Duplicate this concrete material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate (
    String^ name
) override

Parameters

name
String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


MaterialConcrete Properties
CollapseAll image DropDown image

Syntax

C#
public class MaterialConcrete
Visual Basic (Declaration)
Public Class MaterialConcrete
Visual C++
public ref class MaterialConcrete

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the concrete material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | ConcreteCompression | Get or set the concrete compression of the concrete material.
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DampingRatio | Get or set the damping ratio of the concrete material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LightWeight | Get or set whether the concrete material is lightweight.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
Public property | ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the concrete material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete
Autodesk.Revit.Elements Namespace


Behavior Property

MaterialConcrete..::Behavior Property
CollapseAll image DropDown image

Get or set the material behavior type of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialBehaviourType Behavior{ get; set;}
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ConcreteCompression Property

MaterialConcrete..::ConcreteCompression Property
CollapseAll image DropDown image

Get or set the concrete compression of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ConcreteCompression{ get; set;}
Visual Basic (Declaration)
Public Property ConcreteCompression As Double
Visual C++
public:
property double ConcreteCompression {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the concrete compression to an invalid value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


DampingRatio Property

MaterialConcrete..::DampingRatio Property
CollapseAll image DropDown image

Get or set the damping ratio of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DampingRatio{ get; set;}
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


LightWeight Property

MaterialConcrete..::LightWeight Property
CollapseAll image DropDown image

Get or set whether the concrete material is lightweight.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool LightWeight{ get; set;}
Visual Basic (Declaration)
Public Property LightWeight As Boolean
Visual C++
public:
property bool LightWeight {
    bool get ();
    void set (bool value);
}

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


Parameter Property

MaterialConcrete..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

MaterialConcrete Class
MaterialConcrete Members
Autodesk.Revit.Elements Namespace


PoissonModulusX Property

MaterialConcrete..::PoissonModulusX Property
CollapseAll image DropDown image

Get or set the x component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusX{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


PoissonModulusY Property

MaterialConcrete..::PoissonModulusY Property
CollapseAll image DropDown image

Get or set the y component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusY{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


PoissonModulusZ Property

MaterialConcrete..::PoissonModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearModulusX Property

MaterialConcrete..::ShearModulusX Property
CollapseAll image DropDown image

Get or set the x component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusX{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearModulusY Property

MaterialConcrete..::ShearModulusY Property
CollapseAll image DropDown image

Get or set the y component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusY{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearModulusZ Property

MaterialConcrete..::ShearModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearStrengthReduction Property

MaterialConcrete..::ShearStrengthReduction Property
CollapseAll image DropDown image

Get or set the shear strength reduction of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearStrengthReduction{ get; set;}
Visual Basic (Declaration)
Public Property ShearStrengthReduction As Double
Visual C++
public:
property double ShearStrengthReduction {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the shear strength reduction to an invalid value. InvalidOperationException will be thrown if lightweight is false

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientX Property

MaterialConcrete..::ThermalExpansionCoefficientX Property
CollapseAll image DropDown image

Get or set the x component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientX{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientY Property

MaterialConcrete..::ThermalExpansionCoefficientY Property
CollapseAll image DropDown image

Get or set the y component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientY{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientZ Property

MaterialConcrete..::ThermalExpansionCoefficientZ Property
CollapseAll image DropDown image

Get or set the z component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientZ{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

MaterialConcrete..::UnitWeight Property
CollapseAll image DropDown image

Get or set the unit weight of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UnitWeight{ get; set;}
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


YoungModulusX Property

MaterialConcrete..::YoungModulusX Property
CollapseAll image DropDown image

Get or set the x component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusX{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


YoungModulusY Property

MaterialConcrete..::YoungModulusY Property
CollapseAll image DropDown image

Get or set the y component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusY{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


YoungModulusZ Property

MaterialConcrete..::YoungModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


MaterialGeneric Class
See Also Members
CollapseAll image DropDown image

Represents a generic material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7E29A64E-223D-4182-A2E1-5A1E17DBFBBF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialGeneric : Material
Visual Basic (Declaration)
<GuidAttribute("7E29A64E-223D-4182-A2E1-5A1E17DBFBBF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialGeneric _
    Inherits Material
Visual C++
[GuidAttribute(L"7E29A64E-223D-4182-A2E1-5A1E17DBFBBF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialGeneric : public Material

Remarks

MaterialGeneric is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialGeneric

See Also

MaterialGeneric Members
Autodesk.Revit.Elements Namespace


MaterialGeneric Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialGeneric
Visual Basic (Declaration)
Public Class MaterialGeneric
Visual C++
public ref class MaterialGeneric

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialGenericMaterialGenericNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this generic material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the generic material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DampingRatio | Get or set the damping ratio of the generic material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
Public property | ReductionFactor | Get or set the reduction factor for shear of the generic material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulusX | Get or set the x component of the shear modulus of the generic material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the generic material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the generic material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the generic material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the generic material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric
Autodesk.Revit.Elements Namespace


MaterialGeneric Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialGeneric()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialGeneric ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MaterialGeneric Methods
CollapseAll image DropDown image

Syntax

C#
public class MaterialGeneric
Visual Basic (Declaration)
Public Class MaterialGeneric
Visual C++
public ref class MaterialGeneric

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this generic material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

MaterialGeneric
Autodesk.Revit.Elements Namespace


Dispose Method

MaterialGeneric..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


Duplicate Method

MaterialGeneric..::Duplicate Method
CollapseAll image DropDown image

Duplicate this generic material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate (
    String^ name
) override

Parameters

name
String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MaterialGeneric Properties
CollapseAll image DropDown image

Syntax

C#
public class MaterialGeneric
Visual Basic (Declaration)
Public Class MaterialGeneric
Visual C++
public ref class MaterialGeneric

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the generic material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DampingRatio | Get or set the damping ratio of the generic material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
Public property | ReductionFactor | Get or set the reduction factor for shear of the generic material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulusX | Get or set the x component of the shear modulus of the generic material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the generic material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the generic material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the generic material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the generic material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric
Autodesk.Revit.Elements Namespace


Behavior Property

MaterialGeneric..::Behavior Property
CollapseAll image DropDown image

Get or set the material behavior type of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialBehaviourType Behavior{ get; set;}
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


DampingRatio Property

MaterialGeneric..::DampingRatio Property
CollapseAll image DropDown image

Get or set the damping ratio of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DampingRatio{ get; set;}
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MinimumYieldStress Property

MaterialGeneric..::MinimumYieldStress Property
CollapseAll image DropDown image

Get or set the minimum yield stress of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double MinimumYieldStress{ get; set;}
Visual Basic (Declaration)
Public Property MinimumYieldStress As Double
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the minimum yield stress to an invalid vlaue.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


Parameter Property

MaterialGeneric..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

MaterialGeneric Class
MaterialGeneric Members
Autodesk.Revit.Elements Namespace


PoissonModulusX Property

MaterialGeneric..::PoissonModulusX Property
CollapseAll image DropDown image

Get or set the x component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusX{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


PoissonModulusY Property

MaterialGeneric..::PoissonModulusY Property
CollapseAll image DropDown image

Get or set the y component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusY{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


PoissonModulusZ Property

MaterialGeneric..::PoissonModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ReductionFactor Property

MaterialGeneric..::ReductionFactor Property
CollapseAll image DropDown image

Get or set the reduction factor for shear of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ReductionFactor{ get; set;}
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid vlaue.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ShearModulusX Property

MaterialGeneric..::ShearModulusX Property
CollapseAll image DropDown image

Get or set the x component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusX{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ShearModulusY Property

MaterialGeneric..::ShearModulusY Property
CollapseAll image DropDown image

Get or set the y component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusY{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ShearModulusZ Property

MaterialGeneric..::ShearModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientX Property

MaterialGeneric..::ThermalExpansionCoefficientX Property
CollapseAll image DropDown image

Get or set the x component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientX{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientY Property

MaterialGeneric..::ThermalExpansionCoefficientY Property
CollapseAll image DropDown image

Get or set the y component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientY{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientZ Property

MaterialGeneric..::ThermalExpansionCoefficientZ Property
CollapseAll image DropDown image

Get or set the z component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientZ{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

MaterialGeneric..::UnitWeight Property
CollapseAll image DropDown image

Get or set the unit weight of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UnitWeight{ get; set;}
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


YoungModulusX Property

MaterialGeneric..::YoungModulusX Property
CollapseAll image DropDown image

Get or set the x component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusX{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


YoungModulusY Property

MaterialGeneric..::YoungModulusY Property
CollapseAll image DropDown image

Get or set the y component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusY{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


YoungModulusZ Property

MaterialGeneric..::YoungModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MaterialOther Class
See Also Members
CollapseAll image DropDown image

Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F86E76AD-B1A6-4b9a-83EE-B55A9909B771")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialOther : Material
Visual Basic (Declaration)
<GuidAttribute("F86E76AD-B1A6-4b9a-83EE-B55A9909B771")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialOther _
    Inherits Material
Visual C++
[GuidAttribute(L"F86E76AD-B1A6-4b9a-83EE-B55A9909B771")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialOther : public Material

Remarks

MaterialOther is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialOther

See Also

MaterialOther Members
Autodesk.Revit.Elements Namespace


MaterialOther Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialOther
Visual Basic (Declaration)
Public Class MaterialOther
Visual C++
public ref class MaterialOther

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialOtherMaterialOtherNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this other material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MaterialOther
Autodesk.Revit.Elements Namespace


MaterialOther Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialOther()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialOther ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


MaterialOther Methods
CollapseAll image DropDown image

Syntax

C#
public class MaterialOther
Visual Basic (Declaration)
Public Class MaterialOther
Visual C++
public ref class MaterialOther

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this other material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

MaterialOther
Autodesk.Revit.Elements Namespace


Dispose Method

MaterialOther..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


Duplicate Method

MaterialOther..::Duplicate Method
CollapseAll image DropDown image

Duplicate this other material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate (
    String^ name
) override

Parameters

name
String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


MaterialSteel Class
See Also Members
CollapseAll image DropDown image

Represents a steel material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2C4F4CEA-05B4-46b6-800C-2A39344F8F66")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialSteel : Material
Visual Basic (Declaration)
<GuidAttribute("2C4F4CEA-05B4-46b6-800C-2A39344F8F66")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialSteel _
    Inherits Material
Visual C++
[GuidAttribute(L"2C4F4CEA-05B4-46b6-800C-2A39344F8F66")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialSteel : public Material

Remarks

MaterialSteel is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialSteel

See Also

MaterialSteel Members
Autodesk.Revit.Elements Namespace


MaterialSteel Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialSteel
Visual Basic (Declaration)
Public Class MaterialSteel
Visual C++
public ref class MaterialSteel

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialSteelMaterialSteelNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this steel material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the steel material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DampingRatio | Get or set the damping ratio of the steel material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
Public property | MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
Public property | ReductionFactor | Get or set the reduction factor for shear of the steel material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulusX | Get or set the x component of the shear modulus of the steel material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the steel material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the steel material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the steel material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the steel material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel
Autodesk.Revit.Elements Namespace


MaterialSteel Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialSteel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSteel ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MaterialSteel Methods
CollapseAll image DropDown image

Syntax

C#
public class MaterialSteel
Visual Basic (Declaration)
Public Class MaterialSteel
Visual C++
public ref class MaterialSteel

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this steel material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

MaterialSteel
Autodesk.Revit.Elements Namespace


Dispose Method

MaterialSteel..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


Duplicate Method

MaterialSteel..::Duplicate Method
CollapseAll image DropDown image

Duplicate this steel material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate (
    String^ name
) override

Parameters

name
String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MaterialSteel Properties
CollapseAll image DropDown image

Syntax

C#
public class MaterialSteel
Visual Basic (Declaration)
Public Class MaterialSteel
Visual C++
public ref class MaterialSteel

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the steel material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DampingRatio | Get or set the damping ratio of the steel material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
Public property | MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
Public property | ReductionFactor | Get or set the reduction factor for shear of the steel material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulusX | Get or set the x component of the shear modulus of the steel material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the steel material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the steel material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the steel material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the steel material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel
Autodesk.Revit.Elements Namespace


Behavior Property

MaterialSteel..::Behavior Property
CollapseAll image DropDown image

Get or set the material behavior type of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialBehaviourType Behavior{ get; set;}
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


DampingRatio Property

MaterialSteel..::DampingRatio Property
CollapseAll image DropDown image

Get or set the damping ratio of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DampingRatio{ get; set;}
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MinimumTensileStrength Property

MaterialSteel..::MinimumTensileStrength Property
CollapseAll image DropDown image

Get or set the minimum tensile strength of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double MinimumTensileStrength{ get; set;}
Visual Basic (Declaration)
Public Property MinimumTensileStrength As Double
Visual C++
public:
property double MinimumTensileStrength {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the minimum tensile strength to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MinimumYieldStress Property

MaterialSteel..::MinimumYieldStress Property
CollapseAll image DropDown image

Get or set the minimum yield stress of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double MinimumYieldStress{ get; set;}
Visual Basic (Declaration)
Public Property MinimumYieldStress As Double
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


Parameter Property

MaterialSteel..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

MaterialSteel Class
MaterialSteel Members
Autodesk.Revit.Elements Namespace


PoissonModulusX Property

MaterialSteel..::PoissonModulusX Property
CollapseAll image DropDown image

Get or set the x component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusX{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


PoissonModulusY Property

MaterialSteel..::PoissonModulusY Property
CollapseAll image DropDown image

Get or set the y component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusY{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


PoissonModulusZ Property

MaterialSteel..::PoissonModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ReductionFactor Property

MaterialSteel..::ReductionFactor Property
CollapseAll image DropDown image

Get or set the reduction factor for shear of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ReductionFactor{ get; set;}
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ShearModulusX Property

MaterialSteel..::ShearModulusX Property
CollapseAll image DropDown image

Get or set the x component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusX{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ShearModulusY Property

MaterialSteel..::ShearModulusY Property
CollapseAll image DropDown image

Get or set the y component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusY{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ShearModulusZ Property

MaterialSteel..::ShearModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientX Property

MaterialSteel..::ThermalExpansionCoefficientX Property
CollapseAll image DropDown image

Get or set the x component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientX{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientY Property

MaterialSteel..::ThermalExpansionCoefficientY Property
CollapseAll image DropDown image

Get or set the y component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientY{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientZ Property

MaterialSteel..::ThermalExpansionCoefficientZ Property
CollapseAll image DropDown image

Get or set the z component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficientZ{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

MaterialSteel..::UnitWeight Property
CollapseAll image DropDown image

Get or set the unit weight of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UnitWeight{ get; set;}
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


YoungModulusX Property

MaterialSteel..::YoungModulusX Property
CollapseAll image DropDown image

Get or set the x component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusX{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


YoungModulusY Property

MaterialSteel..::YoungModulusY Property
CollapseAll image DropDown image

Get or set the y component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusY{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


YoungModulusZ Property

MaterialSteel..::YoungModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MaterialWood Class
See Also Members
CollapseAll image DropDown image

Represents a wood material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3967F6E1-8FFB-4377-9FDE-FCF0A291D593")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialWood : Material
Visual Basic (Declaration)
<GuidAttribute("3967F6E1-8FFB-4377-9FDE-FCF0A291D593")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialWood _
    Inherits Material
Visual C++
[GuidAttribute(L"3967F6E1-8FFB-4377-9FDE-FCF0A291D593")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialWood : public Material

Remarks

MaterialWood is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialWood

See Also

MaterialWood Members
Autodesk.Revit.Elements Namespace


MaterialWood Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialWood
Visual Basic (Declaration)
Public Class MaterialWood
Visual C++
public ref class MaterialWood

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialWoodMaterialWoodNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this wood material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Bending | Get or set the bending of the wood material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CompressionParallel | Get or set the compression parallel to grain of the wood material.
Public property | CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Grade | Get or set the grade of the wood material.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulus | Get or set the Poisson modulus of the wood material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulus | Get or set the shear modulus of the wood material.
Public property | ShearParallel | Get or set the shear parallel to grain of the wood material.
Public property | ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | Species | Get or set the species of the wood material.
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the wood material.
Public property | YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood
Autodesk.Revit.Elements Namespace


MaterialWood Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialWood()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialWood ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


MaterialWood Methods
CollapseAll image DropDown image

Syntax

C#
public class MaterialWood
Visual Basic (Declaration)
Public Class MaterialWood
Visual C++
public ref class MaterialWood

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this wood material element. (Overrides Material ..:: Duplicate(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

MaterialWood
Autodesk.Revit.Elements Namespace


Dispose Method

MaterialWood..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Duplicate Method

MaterialWood..::Duplicate Method
CollapseAll image DropDown image

Duplicate this wood material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate (
    String^ name
) override

Parameters

name
String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


MaterialWood Properties
CollapseAll image DropDown image

Syntax

C#
public class MaterialWood
Visual Basic (Declaration)
Public Class MaterialWood
Visual C++
public ref class MaterialWood

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Bending | Get or set the bending of the wood material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CompressionParallel | Get or set the compression parallel to grain of the wood material.
Public property | CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Grade | Get or set the grade of the wood material.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulus | Get or set the Poisson modulus of the wood material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulus | Get or set the shear modulus of the wood material.
Public property | ShearParallel | Get or set the shear parallel to grain of the wood material.
Public property | ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | Species | Get or set the species of the wood material.
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the wood material.
Public property | YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood
Autodesk.Revit.Elements Namespace


Bending Property

MaterialWood..::Bending Property
CollapseAll image DropDown image

Get or set the bending of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Bending{ get; set;}
Visual Basic (Declaration)
Public Property Bending As Double
Visual C++
public:
property double Bending {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the bending to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


CompressionParallel Property

MaterialWood..::CompressionParallel Property
CollapseAll image DropDown image

Get or set the compression parallel to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CompressionParallel{ get; set;}
Visual Basic (Declaration)
Public Property CompressionParallel As Double
Visual C++
public:
property double CompressionParallel {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the compression parallel to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


CompressionPerpendicular Property

MaterialWood..::CompressionPerpendicular Property
CollapseAll image DropDown image

Get or set the compression perpendicular to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CompressionPerpendicular{ get; set;}
Visual Basic (Declaration)
Public Property CompressionPerpendicular As Double
Visual C++
public:
property double CompressionPerpendicular {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the compression perpendicular to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Grade Property

MaterialWood..::Grade Property
CollapseAll image DropDown image

Get or set the grade of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Grade{ get; set;}
Visual Basic (Declaration)
Public Property Grade As String
Visual C++
public:
property String^ Grade {
    String^ get ();
    void set (String^ value);
}

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Parameter Property

MaterialWood..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

MaterialWood Class
MaterialWood Members
Autodesk.Revit.Elements Namespace


PoissonModulus Property

MaterialWood..::PoissonModulus Property
CollapseAll image DropDown image

Get or set the Poisson modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulus{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulus As Double
Visual C++
public:
property double PoissonModulus {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the Poisson modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ShearModulus Property

MaterialWood..::ShearModulus Property
CollapseAll image DropDown image

Get or set the shear modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulus{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulus As Double
Visual C++
public:
property double ShearModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ShearParallel Property

MaterialWood..::ShearParallel Property
CollapseAll image DropDown image

Get or set the shear parallel to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearParallel{ get; set;}
Visual Basic (Declaration)
Public Property ShearParallel As Double
Visual C++
public:
property double ShearParallel {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear parallel to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ShearPerpendicular Property

MaterialWood..::ShearPerpendicular Property
CollapseAll image DropDown image

Get or set the tension perpendicular to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearPerpendicular{ get; set;}
Visual Basic (Declaration)
Public Property ShearPerpendicular As Double
Visual C++
public:
property double ShearPerpendicular {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the tension perpendicular to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Species Property

MaterialWood..::Species Property
CollapseAll image DropDown image

Get or set the species of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Species{ get; set;}
Visual Basic (Declaration)
Public Property Species As String
Visual C++
public:
property String^ Species {
    String^ get ();
    void set (String^ value);
}

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficient Property

MaterialWood..::ThermalExpansionCoefficient Property
CollapseAll image DropDown image

Get or set the thermal expansion coefficient of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ThermalExpansionCoefficient{ get; set;}
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficient As Double
Visual C++
public:
property double ThermalExpansionCoefficient {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the thermal expansion coefficient to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

MaterialWood..::UnitWeight Property
CollapseAll image DropDown image

Get or set the unit weight of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UnitWeight{ get; set;}
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


YoungModulus Property

MaterialWood..::YoungModulus Property
CollapseAll image DropDown image

Get or set the Young modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulus{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulus As Double
Visual C++
public:
property double YoungModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the Young modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ModelArc Class
See Also Members
CollapseAll image DropDown image

Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("26E3630F-1061-4306-9259-9CB243B3BD3D")]
public class ModelArc : ModelCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("26E3630F-1061-4306-9259-9CB243B3BD3D")> _
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"26E3630F-1061-4306-9259-9CB243B3BD3D")]
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelArc

See Also

ModelArc Members
Autodesk.Revit.Elements Namespace


ModelArc Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelArc
Visual Basic (Declaration)
Public Class ModelArc
Visual C++
public ref class ModelArc

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelArcModelArcNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from ModelCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from ModelCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the model line. (Inherited from ModelCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from ModelCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the model line resides in. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelArc
Autodesk.Revit.Elements Namespace


ModelArc Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelArc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelArc ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelArc Class
Autodesk.Revit.Elements Namespace


ModelCurve Class
See Also Members
CollapseAll image DropDown image

Represents a ModelCurve within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("117FA724-284E-4d9f-8B5C-CBC27C4E78D3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ModelCurve : Element
Visual Basic (Declaration)
<GuidAttribute("117FA724-284E-4d9f-8B5C-CBC27C4E78D3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ModelCurve _
    Inherits Element
Visual C++
[GuidAttribute(L"117FA724-284E-4d9f-8B5C-CBC27C4E78D3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelCurve : public Element

Remarks

This is the parent class for model lines. Currently, the supported model lines are line, arc, Ellipse, NurbSpline and HermiteSpline.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelArc
Autodesk.Revit.Elements..::ModelEllipse
Autodesk.Revit.Elements..::ModelLine
Autodesk.Revit.Elements..::ModelHermiteSpline
Autodesk.Revit.Elements..::ModelNurbSpline

See Also

ModelCurve Members
Autodesk.Revit.Elements Namespace


ModelCurve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelCurve
Visual Basic (Declaration)
Public Class ModelCurve
Visual C++
public ref class ModelCurve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelCurveModelCurveNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve.
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the model line.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the model line resides in.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelCurve
Autodesk.Revit.Elements Namespace


ModelCurve Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurve ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ModelCurve Methods
CollapseAll image DropDown image

Syntax

C#
public class ModelCurve
Visual Basic (Declaration)
Public Class ModelCurve
Visual C++
public ref class ModelCurve

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve.
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ModelCurve
Autodesk.Revit.Elements Namespace


getLineStyle Method

ModelCurve..::getLineStyle Method
CollapseAll image DropDown image

Get the line style of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId getLineStyle()
Visual Basic (Declaration)
Public Function getLineStyle As ElementId
Visual C++
public:
ElementId getLineStyle ()

Remarks

Get the current line style of the curve.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


setLineStyle Method

ModelCurve..::setLineStyle Method
CollapseAll image DropDown image

Set the line style for the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void setLineStyle(
    ElementId lineStyle
)
Visual Basic (Declaration)
Public Sub setLineStyle ( _
    lineStyle As ElementId _
)
Visual C++
public:
void setLineStyle (
    ElementId lineStyle
)

Parameters

lineStyle
ElementId
The line style element id,you get the them from LineStyles property.

Remarks

Set a new line style for the curve.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


SetPlaneAndCurve Method

ModelCurve..::SetPlaneAndCurve Method
CollapseAll image DropDown image

Set sketch plane and geometry curve properties simultaneously.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetPlaneAndCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Sub SetPlaneAndCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
)
Visual C++
public:
void SetPlaneAndCurve (
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Curve
The new geometry curve property.
sketchPlane
SketchPlane
The new sketch plane property.

Remarks

Set the sketch plane and geometry curve properties for the curve.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ModelCurve Properties
CollapseAll image DropDown image

Syntax

C#
public class ModelCurve
Visual Basic (Declaration)
Public Class ModelCurve
Visual C++
public ref class ModelCurve

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the model line.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the model line resides in.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelCurve
Autodesk.Revit.Elements Namespace


GeometryCurve Property

ModelCurve..::GeometryCurve Property
CollapseAll image DropDown image

Get or set the geometry curve of the model line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve GeometryCurve{ get; set;}
Visual Basic (Declaration)
Public Property GeometryCurve As Curve
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

Because there are no corresponding geometry curve type for HermiteSpline, for this type only general Geometry::Curve object will be returned.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


LineStyles Property

ModelCurve..::LineStyles Property
CollapseAll image DropDown image

Returns all line style of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray LineStyles{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LineStyles As ElementArray
Visual C++
public:
property ElementArray^ LineStyles {
    ElementArray^ get ();
}

Remarks

Returns all line styles that the curve supports.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


Parameter Property

ModelCurve..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ModelCurve Class
ModelCurve Members
Autodesk.Revit.Elements Namespace


SketchPlane Property

ModelCurve..::SketchPlane Property
CollapseAll image DropDown image

Get or set the sketch the model line resides in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchPlane SketchPlane{ get; set;}
Visual Basic (Declaration)
Public Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Remarks

A SketchPlane is a plane where you want to draw lines.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("48905367-706A-4f02-9A00-19F17E8901BE")]
public class ModelCurveArrArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("48905367-706A-4f02-9A00-19F17E8901BE")> _
Public Class ModelCurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"48905367-706A-4f02-9A00-19F17E8901BE")]
public ref class ModelCurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ModelCurveArrArray

See Also

ModelCurveArrArray Members
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelCurveArrArray
Visual Basic (Declaration)
Public Class ModelCurveArrArray
Visual C++
public ref class ModelCurveArrArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelCurveArrArrayModelCurveArrArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArrArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrArray ()

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ModelCurveArrArray
Visual Basic (Declaration)
Public Class ModelCurveArrArray
Visual C++
public ref class ModelCurveArrArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ModelCurveArrArray
Autodesk.Revit.Elements Namespace


Append Method

ModelCurveArrArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    ModelCurveArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ModelCurveArray _
)
Visual C++
public:
virtual void Append (
    ModelCurveArray^ item
)

Parameters

item
ModelCurveArray

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Clear Method

ModelCurveArrArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Dispose Method

ModelCurveArrArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

ModelCurveArrArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ModelCurveArrArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

ModelCurveArrArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Insert Method

ModelCurveArrArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    ModelCurveArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ModelCurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    ModelCurveArray^ item,
    int index
)

Parameters

item
ModelCurveArray
index
Int32

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ModelCurveArrArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

ModelCurveArrArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ModelCurveArrArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ModelCurveArrArray
Visual Basic (Declaration)
Public Class ModelCurveArrArray
Visual C++
public ref class ModelCurveArrArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray
Autodesk.Revit.Elements Namespace


IsEmpty Property

ModelCurveArrArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Item Property

ModelCurveArrArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ModelCurveArray Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurveArray
Visual C++
public:
virtual property ModelCurveArray^ Item[int index] {
    ModelCurveArray^ get (int index);
    void set (int index, ModelCurveArray^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Size Property

ModelCurveArrArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("21A92653-DC59-4c87-8DB8-AD83E97F7BB8")]
public abstract class ModelCurveArrArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("21A92653-DC59-4c87-8DB8-AD83E97F7BB8")> _
Public MustInherit Class ModelCurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"21A92653-DC59-4c87-8DB8-AD83E97F7BB8")]
public ref class ModelCurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ModelCurveArrArrayIterator

See Also

ModelCurveArrArrayIterator Members
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ModelCurveArrArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrArrayIterator
Visual C++
public ref class ModelCurveArrArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelCurveArrArrayIteratorModelCurveArrArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArrArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ModelCurveArrArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrArrayIterator
Visual C++
public ref class ModelCurveArrArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ModelCurveArrArrayIterator
Autodesk.Revit.Elements Namespace


Dispose Method

ModelCurveArrArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

ModelCurveArrArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ModelCurveArrArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

ModelCurveArrArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ModelCurveArrArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrArrayIterator
Visual C++
public ref class ModelCurveArrArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator
Autodesk.Revit.Elements Namespace


Current Property

ModelCurveArrArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArray Class
See Also Members
CollapseAll image DropDown image

An array that contains model curves.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("17467790-6E27-46ef-AF0B-3127AB22480D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ModelCurveArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("17467790-6E27-46ef-AF0B-3127AB22480D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ModelCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"17467790-6E27-46ef-AF0B-3127AB22480D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ModelCurveArray

See Also

ModelCurveArray Members
Autodesk.Revit.Elements Namespace


ModelCurveArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelCurveArray
Visual Basic (Declaration)
Public Class ModelCurveArray
Visual C++
public ref class ModelCurveArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelCurveArrayModelCurveArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray
Autodesk.Revit.Elements Namespace


ModelCurveArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArray ()

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ModelCurveArray
Visual Basic (Declaration)
Public Class ModelCurveArray
Visual C++
public ref class ModelCurveArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ModelCurveArray
Autodesk.Revit.Elements Namespace


Append Method

ModelCurveArray..::Append Method
CollapseAll image DropDown image

Add the model curve to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    ModelCurve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ModelCurve _
)
Visual C++
public:
virtual void Append (
    ModelCurve^ item
)

Parameters

item
ModelCurve
The model curve to be added.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Clear Method

ModelCurveArray..::Clear Method
CollapseAll image DropDown image

Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Dispose Method

ModelCurveArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

ModelCurveArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ModelCurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

ModelCurveArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Insert Method

ModelCurveArray..::Insert Method
CollapseAll image DropDown image

Insert the specified model curve into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    ModelCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ModelCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    ModelCurve^ item,
    int index
)

Parameters

item
ModelCurve
The model curve to be inserted into the array.
index
Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ModelCurveArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

ModelCurveArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ModelCurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ModelCurveArray
Visual Basic (Declaration)
Public Class ModelCurveArray
Visual C++
public ref class ModelCurveArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray
Autodesk.Revit.Elements Namespace


IsEmpty Property

ModelCurveArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Item Property

ModelCurveArray..::Item Property
CollapseAll image DropDown image

Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ModelCurve Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurve
Visual C++
public:
virtual property ModelCurve^ Item[int index] {
    ModelCurve^ get (int index);
    void set (int index, ModelCurve^ value);
}

Parameters

index
Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Size Property

ModelCurveArray..::Size Property
CollapseAll image DropDown image

Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a model curve array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C740DB23-F551-4dea-897B-AA1BE47E770E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ModelCurveArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("C740DB23-F551-4dea-897B-AA1BE47E770E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ModelCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"C740DB23-F551-4dea-897B-AA1BE47E770E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ModelCurveArrayIterator

See Also

ModelCurveArrayIterator Members
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ModelCurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrayIterator
Visual C++
public ref class ModelCurveArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelCurveArrayIteratorModelCurveArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ModelCurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrayIterator
Visual C++
public ref class ModelCurveArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ModelCurveArrayIterator
Autodesk.Revit.Elements Namespace


Dispose Method

ModelCurveArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

ModelCurveArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ModelCurveArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

ModelCurveArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ModelCurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrayIterator
Visual C++
public ref class ModelCurveArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator
Autodesk.Revit.Elements Namespace


Current Property

ModelCurveArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelEllipse Class
See Also Members
CollapseAll image DropDown image

Represents a ModelEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8CCD9846-23DF-4382-8048-02D143A02D86")]
public class ModelEllipse : ModelCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8CCD9846-23DF-4382-8048-02D143A02D86")> _
Public Class ModelEllipse _
    Inherits ModelCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8CCD9846-23DF-4382-8048-02D143A02D86")]
public ref class ModelEllipse : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelEllipse

See Also

ModelEllipse Members
Autodesk.Revit.Elements Namespace


ModelEllipse Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelEllipse
Visual Basic (Declaration)
Public Class ModelEllipse
Visual C++
public ref class ModelEllipse

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelEllipseModelEllipseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from ModelCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from ModelCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the model line. (Inherited from ModelCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from ModelCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the model line resides in. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelEllipse
Autodesk.Revit.Elements Namespace


ModelEllipse Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelEllipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelEllipse ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelEllipse Class
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Class
See Also Members
CollapseAll image DropDown image

Represents a ModelHermiteSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EFA7BF12-F113-491d-AA62-6E83098D336B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ModelHermiteSpline : ModelCurve
Visual Basic (Declaration)
<GuidAttribute("EFA7BF12-F113-491d-AA62-6E83098D336B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ModelHermiteSpline _
    Inherits ModelCurve
Visual C++
[GuidAttribute(L"EFA7BF12-F113-491d-AA62-6E83098D336B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelHermiteSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelHermiteSpline

See Also

ModelHermiteSpline Members
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelHermiteSpline
Visual Basic (Declaration)
Public Class ModelHermiteSpline
Visual C++
public ref class ModelHermiteSpline

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelHermiteSplineModelHermiteSplineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from ModelCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from ModelCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the model line. (Inherited from ModelCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from ModelCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the model line resides in. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelHermiteSpline
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelHermiteSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelHermiteSpline ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelHermiteSpline Class
Autodesk.Revit.Elements Namespace


ModelLine Class
See Also Members
CollapseAll image DropDown image

Represents a ModelLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("04A14242-C701-4425-A529-D89408CEFFC2")]
public class ModelLine : ModelCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("04A14242-C701-4425-A529-D89408CEFFC2")> _
Public Class ModelLine _
    Inherits ModelCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"04A14242-C701-4425-A529-D89408CEFFC2")]
public ref class ModelLine : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelLine

See Also

ModelLine Members
Autodesk.Revit.Elements Namespace


ModelLine Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelLine
Visual Basic (Declaration)
Public Class ModelLine
Visual C++
public ref class ModelLine

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelLineModelLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from ModelCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from ModelCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the model line. (Inherited from ModelCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from ModelCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the model line resides in. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelLine
Autodesk.Revit.Elements Namespace


ModelLine Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelLine ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelLine Class
Autodesk.Revit.Elements Namespace


ModelNurbSpline Class
See Also Members
CollapseAll image DropDown image

Represents a ModelNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C0A8C877-514A-473b-8C43-D927C8BC6B99")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ModelNurbSpline : ModelCurve
Visual Basic (Declaration)
<GuidAttribute("C0A8C877-514A-473b-8C43-D927C8BC6B99")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ModelNurbSpline _
    Inherits ModelCurve
Visual C++
[GuidAttribute(L"C0A8C877-514A-473b-8C43-D927C8BC6B99")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelNurbSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelNurbSpline

See Also

ModelNurbSpline Members
Autodesk.Revit.Elements Namespace


ModelNurbSpline Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelNurbSpline
Visual Basic (Declaration)
Public Class ModelNurbSpline
Visual C++
public ref class ModelNurbSpline

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelNurbSplineModelNurbSplineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve. (Inherited from ModelCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve. (Inherited from ModelCurve.)
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Get or set the geometry curve of the model line. (Inherited from ModelCurve.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LineStyles | Returns all line style of the curve. (Inherited from ModelCurve.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Get or set the sketch the model line resides in. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelNurbSpline
Autodesk.Revit.Elements Namespace


ModelNurbSpline Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelNurbSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelNurbSpline ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelNurbSpline Class
Autodesk.Revit.Elements Namespace


Mullion Class
See Also Members
CollapseAll image DropDown image

Represents a CurtainGrid within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("570024C5-6BDF-4628-8D20-185EE096E44A")]
public class Mullion : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("570024C5-6BDF-4628-8D20-185EE096E44A")> _
Public Class Mullion _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"570024C5-6BDF-4628-8D20-185EE096E44A")]
public ref class Mullion : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Mullion

See Also

Mullion Members
Autodesk.Revit.Elements Namespace


Mullion Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Mullion
Visual Basic (Declaration)
Public Class Mullion
Visual C++
public ref class Mullion

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MullionMullionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | LocationCurve | The curve profile of the mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Mullion
Autodesk.Revit.Elements Namespace


Mullion Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Mullion()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Mullion ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Mullion Methods
CollapseAll image DropDown image

Syntax

C#
public class Mullion
Visual Basic (Declaration)
Public Class Mullion
Visual C++
public ref class Mullion

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Mullion
Autodesk.Revit.Elements Namespace


BreakMullion Method

Mullion..::BreakMullion Method
CollapseAll image DropDown image

This method is used to break the current Mullion at ends with its neighboring mullions.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void BreakMullion()
Visual Basic (Declaration)
Public Sub BreakMullion
Visual C++
public:
void BreakMullion ()

Remarks

The mullions being perpendicular to it will be joined accordingly.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


JoinMullion Method

Mullion..::JoinMullion Method
CollapseAll image DropDown image

This method is used to control the join condition the current Mullion with its neighboring mullions.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void JoinMullion()
Visual Basic (Declaration)
Public Sub JoinMullion
Visual C++
public:
void JoinMullion ()

Remarks

The mullions being perpendicular to it will be broken accordingly.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Mullion Properties
CollapseAll image DropDown image

Syntax

C#
public class Mullion
Visual Basic (Declaration)
Public Class Mullion
Visual C++
public ref class Mullion

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | LocationCurve | The curve profile of the mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Mullion
Autodesk.Revit.Elements Namespace


AsFamilyInstance Property

Mullion..::AsFamilyInstance Property
CollapseAll image DropDown image

This property is used to get family instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance AsFamilyInstance{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

The AsFamilyInstance property returns an family instance that can be used to stand for this Mullion within the project.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


LocationCurve Property

Mullion..::LocationCurve Property
CollapseAll image DropDown image

The curve profile of the mullion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve LocationCurve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LocationCurve As Curve
Visual C++
public:
property Curve^ LocationCurve {
    Curve^ get ();
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Lock Property

Mullion..::Lock Property
CollapseAll image DropDown image

Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Lock{ get; set;}
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Lockable Property

Mullion..::Lockable Property
CollapseAll image DropDown image

Get - to get whether the Mullion can be lock or unlock.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Lockable{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Lockable As Boolean
Visual C++
public:
property bool Lockable {
    bool get ();
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


MullionType Property

Mullion..::MullionType Property
CollapseAll image DropDown image

The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MullionType MullionType{ get; set;}
Visual Basic (Declaration)
Public Property MullionType As MullionType
Visual C++
public:
property MullionType^ MullionType {
    MullionType^ get ();
    void set (MullionType^ value);
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Parameter Property

Mullion..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Mullion Class
Mullion Members
Autodesk.Revit.Elements Namespace


Opening Class
See Also Members
CollapseAll image DropDown image

An object that represents a Opening within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9AAA7DD6-FA3A-4cb9-ADCA-DC8B063B09AB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Opening : Element
Visual Basic (Declaration)
<GuidAttribute("9AAA7DD6-FA3A-4cb9-ADCA-DC8B063B09AB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Opening _
    Inherits Element
Visual C++
[GuidAttribute(L"9AAA7DD6-FA3A-4cb9-ADCA-DC8B063B09AB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Opening : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Opening

See Also

Opening Members
Autodesk.Revit.Elements Namespace


Opening Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Opening
Visual Basic (Declaration)
Public Class Opening
Visual C++
public ref class Opening

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | OpeningOpeningNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundaryCurves | Retrieves the geometry information if the opening boundary is not a rect.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Host | Retrieves the host element of this opening.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rect boundary.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Opening
Autodesk.Revit.Elements Namespace


Opening Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Opening ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Opening Properties
CollapseAll image DropDown image

Syntax

C#
public class Opening
Visual Basic (Declaration)
Public Class Opening
Visual C++
public ref class Opening

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundaryCurves | Retrieves the geometry information if the opening boundary is not a rect.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Host | Retrieves the host element of this opening.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rect boundary.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Opening
Autodesk.Revit.Elements Namespace


BoundaryCurves Property

Opening..::BoundaryCurves Property
CollapseAll image DropDown image

Retrieves the geometry information if the opening boundary is not a rect.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray BoundaryCurves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BoundaryCurves As CurveArray
Visual C++
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}

Remarks

See Also

Opening Class
Autodesk.Revit.Elements Namespace


BoundaryRect Property

Opening..::BoundaryRect Property
CollapseAll image DropDown image

Retrieves the geometry information if the opening boundary is a rect.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray BoundaryRect{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BoundaryRect As XYZArray
Visual C++
public:
property XYZArray^ BoundaryRect {
    XYZArray^ get ();
}

Remarks

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Host Property

Opening..::Host Property
CollapseAll image DropDown image

Retrieves the host element of this opening.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Host{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

"Host Element" means the element that this opening cuts out.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


IsRectBoundary Property

Opening..::IsRectBoundary Property
CollapseAll image DropDown image

Retrieves the information whether the opening has a rect boundary.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsRectBoundary{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsRectBoundary As Boolean
Visual C++
public:
property bool IsRectBoundary {
    bool get ();
}

Remarks

If the opening has a rect boundary, we can get the geometry information from BoundaryRect property. Otherwise we should get the geometry information from BoundaryCurves property.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Parameter Property

Opening..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Opening Class
Opening Members
Autodesk.Revit.Elements Namespace


Panel Class
See Also Members
CollapseAll image DropDown image

This object represents a curtain panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DCDCF539-A640-4c9f-B12C-C6092F2BC621")]
public class Panel : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DCDCF539-A640-4c9f-B12C-C6092F2BC621")> _
Public Class Panel _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DCDCF539-A640-4c9f-B12C-C6092F2BC621")]
public ref class Panel : public Element

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Panel

See Also

Panel Members
Autodesk.Revit.Elements Namespace


Panel Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Panel
Visual Basic (Declaration)
Public Class Panel
Visual C++
public ref class Panel

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PanelPanelNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | PanelType | The Panel style of this Panel.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Panel
Autodesk.Revit.Elements Namespace


Panel Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Panel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Panel ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Panel Methods
CollapseAll image DropDown image

Syntax

C#
public class Panel
Visual Basic (Declaration)
Public Class Panel
Visual C++
public ref class Panel

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Panel
Autodesk.Revit.Elements Namespace


GetRefGridLines Method

Panel..::GetRefGridLines Method
CollapseAll image DropDown image

This method is used to get the reference gridlines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void GetRefGridLines(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Sub GetRefGridLines ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
)
Visual C++
public:
void GetRefGridLines (
    ElementId% uGridLineId,
    ElementId% vGridLineId
)

Parameters

uGridLineId
ElementId %
vGridLineId
ElementId %

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Panel Properties
CollapseAll image DropDown image

Syntax

C#
public class Panel
Visual Basic (Declaration)
Public Class Panel
Visual C++
public ref class Panel

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | PanelType | The Panel style of this Panel.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Panel
Autodesk.Revit.Elements Namespace


AsFamilyInstance Property

Panel..::AsFamilyInstance Property
CollapseAll image DropDown image

This property is used to get family instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance AsFamilyInstance{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

The AsFamilyInstance property returns an family instance that can be used to stand for this panel within the project.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Lock Property

Panel..::Lock Property
CollapseAll image DropDown image

This property is used to know whether a panel is locked and lock or unlock a panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Lock{ get; set;}
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

Remarks

If the panel is locked, get() returns true, else false.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this panel can't be locked.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Lockable Property

Panel..::Lockable Property
CollapseAll image DropDown image

This property is used to know whether a panel can be locked.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Lockable{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Lockable As Boolean
Visual C++
public:
property bool Lockable {
    bool get ();
}

Remarks

If the panel can be locked, return true, else false.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


PanelType Property

Panel..::PanelType Property
CollapseAll image DropDown image

The Panel style of this Panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PanelType PanelType{ get; set;}
Visual Basic (Declaration)
Public Property PanelType As PanelType
Visual C++
public:
property PanelType^ PanelType {
    PanelType^ get ();
    void set (PanelType^ value);
}

Remarks

The Symbol property can be used to retrieve the kind of the panel. This property can also be used to change the type of a panel by setting it to a different type. All the panel types in the project can be found using the Document.CutainPanelTypes property.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Parameter Property

Panel..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Panel Class
Panel Members
Autodesk.Revit.Elements Namespace


Transform Property

Panel..::Transform Property
CollapseAll image DropDown image

This property is used to find the transform of a curtain panel within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform Transform{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Remarks

The Transform property returns a Geometry::Transform object that can be used to find the transfer matrix of a curtain panel within the project.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Path3d Class
See Also Members
CollapseAll image DropDown image

Provides access to the Generic 3D path object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E1238821-CD4B-4500-82F5-DDA027A3A0E6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Path3d : SketchBase
Visual Basic (Declaration)
<GuidAttribute("E1238821-CD4B-4500-82F5-DDA027A3A0E6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Path3d _
    Inherits SketchBase
Visual C++
[GuidAttribute(L"E1238821-CD4B-4500-82F5-DDA027A3A0E6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Path3d : public SketchBase

Remarks

This object represents a 3D path sketch of Sweep.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::Path3d

See Also

Path3d Members
Autodesk.Revit.Elements Namespace


Path3d Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Path3d
Visual Basic (Declaration)
Public Class Path3d
Visual C++
public ref class Path3d

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | Path3dPath3dNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AllCurveLoops | Get all the Curve Loops of Path3d.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurveLoop | Get the Curve Loop of Path3d via index.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumCurveLoops | Get the Number of Curve Loops of Path3d.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Path3d
Autodesk.Revit.Elements Namespace


Path3d Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Path3d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Path3d ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


Path3d Properties
CollapseAll image DropDown image

Syntax

C#
public class Path3d
Visual Basic (Declaration)
Public Class Path3d
Visual C++
public ref class Path3d

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AllCurveLoops | Get all the Curve Loops of Path3d.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurveLoop | Get the Curve Loop of Path3d via index.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumCurveLoops | Get the Number of Curve Loops of Path3d.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Path3d
Autodesk.Revit.Elements Namespace


AllCurveLoops Property

Path3d..::AllCurveLoops Property
CollapseAll image DropDown image

Get all the Curve Loops of Path3d.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray AllCurveLoops{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AllCurveLoops As CurveArray
Visual C++
public:
property CurveArray^ AllCurveLoops {
    CurveArray^ get ();
}

Remarks

Returns all the Curve Loops of Path3d.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


CurveLoop Property

Path3d..::CurveLoop Property
CollapseAll image DropDown image

Get the Curve Loop of Path3d via index.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray CurveLoop[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurveLoop ( _
    index As Integer _
) As CurveArray
Visual C++
public:
property CurveArray^ CurveLoop[int index] {
    CurveArray^ get (int index);
}

Parameters

index
Int32

Remarks

Returns the index order Curve Loop of Path3d.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


NumCurveLoops Property

Path3d..::NumCurveLoops Property
CollapseAll image DropDown image

Get the Number of Curve Loops of Path3d.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumCurveLoops{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumCurveLoops As Integer
Visual C++
public:
property int NumCurveLoops {
    int get ();
}

Remarks

Returns the Number of Curve Loops of Path3d.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


Parameter Property

Path3d..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Path3d Class
Path3d Members
Autodesk.Revit.Elements Namespace


PathReinforcement Class
See Also Members
CollapseAll image DropDown image

An object that represents an Path Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C10B5ECE-E37F-4d78-B28C-E8A50F0862CF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PathReinforcement : Element
Visual Basic (Declaration)
<GuidAttribute("C10B5ECE-E37F-4d78-B28C-E8A50F0862CF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PathReinforcement _
    Inherits Element
Visual C++
[GuidAttribute(L"C10B5ECE-E37F-4d78-B28C-E8A50F0862CF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PathReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Path Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::PathReinforcement

See Also

PathReinforcement Members
Autodesk.Revit.Elements Namespace


PathReinforcement Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PathReinforcement
Visual Basic (Declaration)
Public Class PathReinforcement
Visual C++
public ref class PathReinforcement

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PathReinforcementPathReinforcementNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BarDescription | Retrieves the Bar Table property of an Path Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | Retrieves the array of curves forming the boundary of the Path Reinforcement.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathReinforcementType | Retrieves the type of the Path Reinforcement.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PathReinforcement
Autodesk.Revit.Elements Namespace


PathReinforcement Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PathReinforcement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PathReinforcement ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


PathReinforcement Methods
CollapseAll image DropDown image

Syntax

C#
public class PathReinforcement
Visual Basic (Declaration)
Public Class PathReinforcement
Visual C++
public ref class PathReinforcement

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

PathReinforcement
Autodesk.Revit.Elements Namespace


Dispose Method

PathReinforcement..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


PathReinforcement Properties
CollapseAll image DropDown image

Syntax

C#
public class PathReinforcement
Visual Basic (Declaration)
Public Class PathReinforcement
Visual C++
public ref class PathReinforcement

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BarDescription | Retrieves the Bar Table property of an Path Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | Retrieves the array of curves forming the boundary of the Path Reinforcement.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathReinforcementType | Retrieves the type of the Path Reinforcement.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PathReinforcement
Autodesk.Revit.Elements Namespace


BarDescription Property

PathReinforcement..::BarDescription Property
CollapseAll image DropDown image

Retrieves the Bar Table property of an Path Reinforcement element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BarDescription BarDescription[
    int idx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
Visual C++
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Int32
Index of a Bar Description.

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


Curves Property

PathReinforcement..::Curves Property
CollapseAll image DropDown image

Retrieves the array of curves forming the boundary of the Path Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type ModelCurve.

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


NumBarDescriptions Property

PathReinforcement..::NumBarDescriptions Property
CollapseAll image DropDown image

Retrieves the number of distinct bar shapes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumBarDescriptions{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumBarDescriptions As Integer
Visual C++
public:
property int NumBarDescriptions {
    int get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


Parameter Property

PathReinforcement..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

PathReinforcement Class
PathReinforcement Members
Autodesk.Revit.Elements Namespace


PathReinforcementType Property

PathReinforcement..::PathReinforcementType Property
CollapseAll image DropDown image

Retrieves the type of the Path Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PathReinforcementType PathReinforcementType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PathReinforcementType As PathReinforcementType
Visual C++
public:
property PathReinforcementType^ PathReinforcementType {
    PathReinforcementType^ get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


Phase Class
See Also Members
CollapseAll image DropDown image

Represents a phase in the life of a building.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("55A3998B-8A8D-472b-B0AE-83BD93ADE3BB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Phase : Element
Visual Basic (Declaration)
<GuidAttribute("55A3998B-8A8D-472b-B0AE-83BD93ADE3BB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Phase _
    Inherits Element
Visual C++
[GuidAttribute(L"55A3998B-8A8D-472b-B0AE-83BD93ADE3BB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Phase

See Also

Phase Members
Autodesk.Revit.Elements Namespace


Phase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Phase
Visual Basic (Declaration)
Public Class Phase
Visual C++
public ref class Phase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PhasePhaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Phase
Autodesk.Revit.Elements Namespace


Phase Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Phase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Phase ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Phase Class
Autodesk.Revit.Elements Namespace


PhaseArray Class
See Also Members
CollapseAll image DropDown image

An array that contains phase objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("86A3E389-113B-4f7c-BC53-8095E63D6535")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PhaseArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("86A3E389-113B-4f7c-BC53-8095E63D6535")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PhaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"86A3E389-113B-4f7c-BC53-8095E63D6535")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PhaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::PhaseArray

See Also

PhaseArray Members
Autodesk.Revit.Elements Namespace


PhaseArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PhaseArray
Visual Basic (Declaration)
Public Class PhaseArray
Visual C++
public ref class PhaseArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PhaseArrayPhaseArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.

See Also

PhaseArray
Autodesk.Revit.Elements Namespace


PhaseArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PhaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PhaseArray ()

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


PhaseArray Methods
CollapseAll image DropDown image

Syntax

C#
public class PhaseArray
Visual Basic (Declaration)
Public Class PhaseArray
Visual C++
public ref class PhaseArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PhaseArray
Autodesk.Revit.Elements Namespace


Append Method

PhaseArray..::Append Method
CollapseAll image DropDown image

Add the phase to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Phase item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Phase _
)
Visual C++
public:
virtual void Append (
    Phase^ item
)

Parameters

item
Phase
The phase to be added.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Clear Method

PhaseArray..::Clear Method
CollapseAll image DropDown image

Removes every phase from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Dispose Method

PhaseArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

PhaseArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PhaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

PhaseArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Insert Method

PhaseArray..::Insert Method
CollapseAll image DropDown image

Insert the specified phase into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Phase item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Phase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Phase^ item,
    int index
)

Parameters

item
Phase
The phase to be inserted into the array.
index
Int32
The phase will be inserted before this index.

Return Value

Returns whether the phase was inserted into the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

PhaseArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

PhaseArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PhaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


PhaseArray Properties
CollapseAll image DropDown image

Syntax

C#
public class PhaseArray
Visual Basic (Declaration)
Public Class PhaseArray
Visual C++
public ref class PhaseArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.

See Also

PhaseArray
Autodesk.Revit.Elements Namespace


IsEmpty Property

PhaseArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Item Property

PhaseArray..::Item Property
CollapseAll image DropDown image

Gets or sets a phase at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Phase Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Phase
Visual C++
public:
virtual property Phase^ Item[int index] {
    Phase^ get (int index);
    void set (int index, Phase^ value);
}

Parameters

index
Int32
The index of the phase to be set or retrieved.

Return Value

Returns the phase at the specified index.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Size Property

PhaseArray..::Size Property
CollapseAll image DropDown image

Returns the number of phases that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a phase array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("676AB018-D158-46ed-8AD3-2A1D786F126E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class PhaseArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("676AB018-D158-46ed-8AD3-2A1D786F126E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class PhaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"676AB018-D158-46ed-8AD3-2A1D786F126E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PhaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::PhaseArrayIterator

See Also

PhaseArrayIterator Members
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PhaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class PhaseArrayIterator
Visual C++
public ref class PhaseArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PhaseArrayIteratorPhaseArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PhaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PhaseArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PhaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class PhaseArrayIterator
Visual C++
public ref class PhaseArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PhaseArrayIterator
Autodesk.Revit.Elements Namespace


Dispose Method

PhaseArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

PhaseArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

PhaseArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

PhaseArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PhaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class PhaseArrayIterator
Visual C++
public ref class PhaseArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator
Autodesk.Revit.Elements Namespace


Current Property

PhaseArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


PointLoad Class
See Also Members
CollapseAll image DropDown image

An object that represents a force/moment applied to a single point.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F89B6E0A-5E61-44f4-933F-060C630B1B4B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PointLoad : LoadBase
Visual Basic (Declaration)
<GuidAttribute("F89B6E0A-5E61-44f4-933F-060C630B1B4B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PointLoad _
    Inherits LoadBase
Visual C++
[GuidAttribute(L"F89B6E0A-5E61-44f4-933F-060C630B1B4B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PointLoad : public LoadBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::PointLoad

See Also

PointLoad Members
Autodesk.Revit.Elements Namespace


PointLoad Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PointLoad
Visual Basic (Declaration)
Public Class PointLoad
Visual C++
public ref class PointLoad

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PointLoadPointLoadNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to the point load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment application to the point load.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Point | Returns the three dimensional coordinates of point load.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PointLoad
Autodesk.Revit.Elements Namespace


PointLoad Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PointLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoad ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


PointLoad Methods
CollapseAll image DropDown image

Syntax

C#
public class PointLoad
Visual Basic (Declaration)
Public Class PointLoad
Visual C++
public ref class PointLoad

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

PointLoad
Autodesk.Revit.Elements Namespace


Dispose Method

PointLoad..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


PointLoad Properties
CollapseAll image DropDown image

Syntax

C#
public class PointLoad
Visual Basic (Declaration)
Public Class PointLoad
Visual C++
public ref class PointLoad

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to the point load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment application to the point load.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Point | Returns the three dimensional coordinates of point load.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PointLoad
Autodesk.Revit.Elements Namespace


Force Property

PointLoad..::Force Property
CollapseAll image DropDown image

Returns the three dimensional force applied to the point load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Force{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Force As XYZ
Visual C++
public:
property XYZ^ Force {
    XYZ^ get ();
}

Remarks

The force is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


Moment Property

PointLoad..::Moment Property
CollapseAll image DropDown image

Returns the three dimensional moment application to the point load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Moment{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Moment As XYZ
Visual C++
public:
property XYZ^ Moment {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


Parameter Property

PointLoad..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

PointLoad Class
PointLoad Members
Autodesk.Revit.Elements Namespace


Point Property

PointLoad..::Point Property
CollapseAll image DropDown image

Returns the three dimensional coordinates of point load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Point{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

The location is measured in decimal feet.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


PrintSetting Class
See Also Members
CollapseAll image DropDown image

Represents the Print Setup (File->Print Setup...) within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5D6B1B6B-73E6-4592-93D2-E98FBAFC6FD4")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PrintSetting : Element
Visual Basic (Declaration)
<GuidAttribute("5D6B1B6B-73E6-4592-93D2-E98FBAFC6FD4")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PrintSetting _
    Inherits Element
Visual C++
[GuidAttribute(L"5D6B1B6B-73E6-4592-93D2-E98FBAFC6FD4")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PrintSetting : public Element

Remarks

The Print Setup object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::PrintSetting

See Also

PrintSetting Members
Autodesk.Revit.Elements Namespace


PrintSetting Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PrintSetting
Visual Basic (Declaration)
Public Class PrintSetting
Visual C++
public ref class PrintSetting

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintSettingPrintSettingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns the Name of Print Setup. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PrinterName | Get the Printer Name of the Print Setting.
Public property | PrintParameters | Returns the Parameters of Print Setup.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PrintSetting
Autodesk.Revit.Elements Namespace


PrintSetting Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintSetting ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


PrintSetting Properties
CollapseAll image DropDown image

Syntax

C#
public class PrintSetting
Visual Basic (Declaration)
Public Class PrintSetting
Visual C++
public ref class PrintSetting

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns the Name of Print Setup. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PrinterName | Get the Printer Name of the Print Setting.
Public property | PrintParameters | Returns the Parameters of Print Setup.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PrintSetting
Autodesk.Revit.Elements Namespace


Name Property

PrintSetting..::Name Property
CollapseAll image DropDown image

Returns the Name of Print Setup.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ get; set;}
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

Retrieve/set the name of Print Setup.

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


Parameter Property

PrintSetting..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

PrintSetting Class
PrintSetting Members
Autodesk.Revit.Elements Namespace


PrinterName Property

PrintSetting..::PrinterName Property
CollapseAll image DropDown image

Get the Printer Name of the Print Setting.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string PrinterName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PrinterName As String
Visual C++
public:
property String^ PrinterName {
    String^ get ();
}

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


PrintParameters Property

PrintSetting..::PrintParameters Property
CollapseAll image DropDown image

Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PrintParameters PrintParameters{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PrintParameters As PrintParameters
Visual C++
public:
property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Remarks

The Parameters of Print Setup, you can reference the Print Setup dialog in Revit.

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


ProjectInfo Class
See Also Members
CollapseAll image DropDown image

An object that represents a Project Information within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CC6BAA47-01CD-40a2-8660-CCE3262C24D6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ProjectInfo : Element
Visual Basic (Declaration)
<GuidAttribute("CC6BAA47-01CD-40a2-8660-CCE3262C24D6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ProjectInfo _
    Inherits Element
Visual C++
[GuidAttribute(L"CC6BAA47-01CD-40a2-8660-CCE3262C24D6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ProjectInfo : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ProjectInfo

See Also

ProjectInfo Members
Autodesk.Revit.Elements Namespace


ProjectInfo Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectInfo
Visual Basic (Declaration)
Public Class ProjectInfo
Visual C++
public ref class ProjectInfo

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectInfoProjectInfoNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Address | Get or Set the Project Address of the Project Information.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClientName | Get or Set the Client Name of the Project Information.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | gbXMLSettings | Get the gbXML Settings of the Project Information.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IssueDate | Get or Set the Project Issue Date of the Project Information.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get or Set the Project Name of the Project Information.
Public property | Number | Get or Set the Project Number of the Project Information.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Status | Get or Set the Project Status of the Project Information.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectInfo
Autodesk.Revit.Elements Namespace


ProjectInfo Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectInfo ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ProjectInfo Properties
CollapseAll image DropDown image

Syntax

C#
public class ProjectInfo
Visual Basic (Declaration)
Public Class ProjectInfo
Visual C++
public ref class ProjectInfo

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Address | Get or Set the Project Address of the Project Information.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClientName | Get or Set the Client Name of the Project Information.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | gbXMLSettings | Get the gbXML Settings of the Project Information.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IssueDate | Get or Set the Project Issue Date of the Project Information.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get or Set the Project Name of the Project Information.
Public property | Number | Get or Set the Project Number of the Project Information.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Status | Get or Set the Project Status of the Project Information.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectInfo
Autodesk.Revit.Elements Namespace


Address Property

ProjectInfo..::Address Property
CollapseAll image DropDown image

Get or Set the Project Address of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Address{ get; set;}
Visual Basic (Declaration)
Public Property Address As String
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Address of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ClientName Property

ProjectInfo..::ClientName Property
CollapseAll image DropDown image

Get or Set the Client Name of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string ClientName{ get; set;}
Visual Basic (Declaration)
Public Property ClientName As String
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Client Name of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


gbXMLSettings Property

ProjectInfo..::gbXMLSettings Property
CollapseAll image DropDown image

Get the gbXML Settings of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public gbXMLParamElem gbXMLSettings{ get;}
Visual Basic (Declaration)
Public ReadOnly Property gbXMLSettings As gbXMLParamElem
Visual C++
public:
property gbXMLParamElem^ gbXMLSettings {
    gbXMLParamElem^ get ();
}

Remarks

This property is used to get or set the Project gbXML Settings of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


IssueDate Property

ProjectInfo..::IssueDate Property
CollapseAll image DropDown image

Get or Set the Project Issue Date of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string IssueDate{ get; set;}
Visual Basic (Declaration)
Public Property IssueDate As String
Visual C++
public:
property String^ IssueDate {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Issue Date of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


Name Property

ProjectInfo..::Name Property
CollapseAll image DropDown image

Get or Set the Project Name of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get; set;}
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Name of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


Number Property

ProjectInfo..::Number Property
CollapseAll image DropDown image

Get or Set the Project Number of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Number{ get; set;}
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


Parameter Property

ProjectInfo..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ProjectInfo Class
ProjectInfo Members
Autodesk.Revit.Elements Namespace


Status Property

ProjectInfo..::Status Property
CollapseAll image DropDown image

Get or Set the Project Status of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Status{ get; set;}
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Status of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ProjectUnit Class
See Also Members
CollapseAll image DropDown image

Provides access to the Project Unit... in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("19F91877-F209-4481-9C5F-4916FA86B1AA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ProjectUnit : Element
Visual Basic (Declaration)
<GuidAttribute("19F91877-F209-4481-9C5F-4916FA86B1AA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ProjectUnit _
    Inherits Element
Visual C++
[GuidAttribute(L"19F91877-F209-4481-9C5F-4916FA86B1AA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ProjectUnit : public Element

Remarks

The ProjectUnit object can be queried for its D in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ProjectUnit

See Also

ProjectUnit Members
Autodesk.Revit.Elements Namespace


ProjectUnit Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectUnit
Visual Basic (Declaration)
Public Class ProjectUnit
Visual C++
public ref class ProjectUnit

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectUnitProjectUnitNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setDigitGroupingType | Set the Digit Grouping Amount, using the three types
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
Public property | DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FormatOptions | Get the Format Options of the Project Unit Settings.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectUnit
Autodesk.Revit.Elements Namespace


ProjectUnit Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectUnit()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectUnit ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


ProjectUnit Methods
CollapseAll image DropDown image

Syntax

C#
public class ProjectUnit
Visual Basic (Declaration)
Public Class ProjectUnit
Visual C++
public ref class ProjectUnit

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setDigitGroupingType | Set the Digit Grouping Amount, using the three types
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ProjectUnit
Autodesk.Revit.Elements Namespace


setDigitGroupingType Method

ProjectUnit..::setDigitGroupingType Method
CollapseAll image DropDown image

Set the Digit Grouping Amount, using the three types

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void setDigitGroupingType(
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)
Visual Basic (Declaration)
Public Sub setDigitGroupingType ( _
    dst As DecimalSymbolType, _
    dgst As DigitGroupingSymbolType, _
    dga As DigitGroupingAmount _
)
Visual C++
public:
void setDigitGroupingType (
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)

Parameters

dst
DecimalSymbolType
dgst
DigitGroupingSymbolType
dga
DigitGroupingAmount

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


ProjectUnit Properties
CollapseAll image DropDown image

Syntax

C#
public class ProjectUnit
Visual Basic (Declaration)
Public Class ProjectUnit
Visual C++
public ref class ProjectUnit

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
Public property | DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FormatOptions | Get the Format Options of the Project Unit Settings.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectUnit
Autodesk.Revit.Elements Namespace


DecimalSymbolType Property

ProjectUnit..::DecimalSymbolType Property
CollapseAll image DropDown image

Get the Decimal Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DecimalSymbolType DecimalSymbolType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DecimalSymbolType As DecimalSymbolType
Visual C++
public:
property DecimalSymbolType DecimalSymbolType {
    DecimalSymbolType get ();
}

Return Value

The type of the Decimal Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::Enums::DecimalSymbolType::DST_DOT.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


DigitGroupingAmount Property

ProjectUnit..::DigitGroupingAmount Property
CollapseAll image DropDown image

Get the Digit Grouping Amount of Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DigitGroupingAmount DigitGroupingAmount{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DigitGroupingAmount As DigitGroupingAmount
Visual C++
public:
property DigitGroupingAmount DigitGroupingAmount {
    DigitGroupingAmount get ();
}

Return Value

The type of the Digit Grouping Amount.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::Enums::DigitGroupingAmount::DGA_THREE.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


DigitGroupingSymbolType Property

ProjectUnit..::DigitGroupingSymbolType Property
CollapseAll image DropDown image

Get the Digit Grouping Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DigitGroupingSymbolType DigitGroupingSymbolType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DigitGroupingSymbolType As DigitGroupingSymbolType
Visual C++
public:
property DigitGroupingSymbolType DigitGroupingSymbolType {
    DigitGroupingSymbolType get ();
}

Return Value

The type of the Digit Grouping Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::Enums::DigitGroupingSymbolType::DGST_COMMA.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


FormatOptions Property

ProjectUnit..::FormatOptions Property
CollapseAll image DropDown image

Get the Format Options of the Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FormatOptions FormatOptions[
    UnitType ut
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FormatOptions ( _
    ut As UnitType _
) As FormatOptions
Visual C++
public:
property FormatOptions^ FormatOptions[UnitType ut] {
    FormatOptions^ get (UnitType ut);
}

Parameters

ut
UnitType

Remarks

.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


Name Property

ProjectUnit..::Name Property
CollapseAll image DropDown image

Get and Set the Name property

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for ProjectUnit object, an InvalidOperationException will be thrown.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


Parameter Property

ProjectUnit..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ProjectUnit Class
ProjectUnit Members
Autodesk.Revit.Elements Namespace


RadialArray Class
See Also Members
CollapseAll image DropDown image

An object that represents an Array created radially within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A6CBD9BB-00D5-40ee-9059-249F2D917623")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RadialArray : BaseArray
Visual Basic (Declaration)
<GuidAttribute("A6CBD9BB-00D5-40ee-9059-249F2D917623")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RadialArray _
    Inherits BaseArray
Visual C++
[GuidAttribute(L"A6CBD9BB-00D5-40ee-9059-249F2D917623")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RadialArray : public BaseArray

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BaseArray
Autodesk.Revit.Elements..::RadialArray

See Also

RadialArray Members
Autodesk.Revit.Elements Namespace


RadialArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RadialArray
Visual Basic (Declaration)
Public Class RadialArray
Visual C++
public ref class RadialArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RadialArrayRadialArrayNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray ..:: CopyMembers.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from BaseArray.)
Public property | NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray ..:: NumMembers.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray ..:: OrigMembers.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RadialArray
Autodesk.Revit.Elements Namespace


RadialArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RadialArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadialArray ()

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


RadialArray Properties
CollapseAll image DropDown image

Syntax

C#
public class RadialArray
Visual Basic (Declaration)
Public Class RadialArray
Visual C++
public ref class RadialArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray ..:: CopyMembers.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from BaseArray.)
Public property | NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray ..:: NumMembers.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray ..:: OrigMembers.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RadialArray
Autodesk.Revit.Elements Namespace


CopyMembers Property

RadialArray..::CopyMembers Property
CollapseAll image DropDown image

Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override ElementArray CopyMembers{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


NumMembers Property

RadialArray..::NumMembers Property
CollapseAll image DropDown image

Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override int NumMembers{ get; set;}
Visual Basic (Declaration)
Public Overrides Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


OrigMembers Property

RadialArray..::OrigMembers Property
CollapseAll image DropDown image

Retrieve the original members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override ElementArray OrigMembers{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


Parameter Property

RadialArray..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RadialArray Class
RadialArray Members
Autodesk.Revit.Elements Namespace


Rebar Class
See Also Members
CollapseAll image DropDown image

An object that represents Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("30CF831F-5A7E-4671-B48E-9BCE0E0F8720")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Rebar : Element
Visual Basic (Declaration)
<GuidAttribute("30CF831F-5A7E-4671-B48E-9BCE0E0F8720")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Rebar _
    Inherits Element
Visual C++
[GuidAttribute(L"30CF831F-5A7E-4671-B48E-9BCE0E0F8720")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Rebar : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Rebar

See Also

Rebar Members
Autodesk.Revit.Elements Namespace


Rebar Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Rebar
Visual Basic (Declaration)
Public Class Rebar
Visual C++
public ref class Rebar

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarRebarNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ScaleToBox | Move and resize the bar to fit within a specified box.
Public method | SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | ArrayLength | For Rebar with an array layout, return the length of the distribution path.
Public property | BarType | Return the type of the rebar.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | The centerline of the Rebar.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Host | The element that contains the rebar.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RebarShape | Get/Set the RebarShape associated with the Rebar.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Rebar
Autodesk.Revit.Elements Namespace


Rebar Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Rebar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Rebar ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Rebar Methods
CollapseAll image DropDown image

Syntax

C#
public class Rebar
Visual Basic (Declaration)
Public Class Rebar
Visual C++
public ref class Rebar

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ScaleToBox | Move and resize the bar to fit within a specified box.
Public method | SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Rebar
Autodesk.Revit.Elements Namespace


ScaleToBox Method

Rebar..::ScaleToBox Method
CollapseAll image DropDown image

Move and resize the bar to fit within a specified box.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ScaleToBox(
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Sub ScaleToBox ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
)
Visual C++
public:
void ScaleToBox (
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

origin
XYZ
xVec
XYZ
yVec
XYZ

Remarks

The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


SetLayoutRuleWithoutExaminingHost Method

Rebar..::SetLayoutRuleWithoutExaminingHost Method
CollapseAll image DropDown image

Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetLayoutRuleWithoutExaminingHost(
    int layoutRule
)
Visual Basic (Declaration)
Public Sub SetLayoutRuleWithoutExaminingHost ( _
    layoutRule As Integer _
)
Visual C++
public:
void SetLayoutRuleWithoutExaminingHost (
    int layoutRule
)

Parameters

layoutRule
Int32
0 for "None" or "Single", 1 for "Fixed Number", 2 for "Maximum Spacing", 3 for "Number with Spacing", 4 for "Minimum Clear Spacing".

Remarks

Changing the parameter REBAR_ELEM_LAYOUT_RULE attempts to extend the rebar set towards the center of the host, but depending on geometrical conditions, it can make the wrong decision. This function changes the layout rule while suppressing the geometric test for the direction of the set. The difference in behavior only occurs when changing the layout rule from None (0) to one of the other settings.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Rebar Properties
CollapseAll image DropDown image

Syntax

C#
public class Rebar
Visual Basic (Declaration)
Public Class Rebar
Visual C++
public ref class Rebar

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ArrayLength | For Rebar with an array layout, return the length of the distribution path.
Public property | BarType | Return the type of the rebar.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | The centerline of the Rebar.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Host | The element that contains the rebar.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RebarShape | Get/Set the RebarShape associated with the Rebar.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Rebar
Autodesk.Revit.Elements Namespace


ArrayLength Property

Rebar..::ArrayLength Property
CollapseAll image DropDown image

For Rebar with an array layout, return the length of the distribution path.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ArrayLength{ get; set;}
Visual Basic (Declaration)
Public Property ArrayLength As Double
Visual C++
public:
property double ArrayLength {
    double get ();
    void set (double value);
}

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


BarType Property

Rebar..::BarType Property
CollapseAll image DropDown image

Return the type of the rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarBarType BarType{ get; set;}
Visual Basic (Declaration)
Public Property BarType As RebarBarType
Visual C++
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
    void set (RebarBarType^ value);
}

Remarks

Returns a RebarBarType element that defines bar diameter and bend radius for the rebar.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Curves Property

Rebar..::Curves Property
CollapseAll image DropDown image

The centerline of the Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Remarks

These curves represent the centerline of the rebar, including the hooks and bends. They are the curves shown in Revit views at the coarse detail level.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


DistributionPath Property

Rebar..::DistributionPath Property
CollapseAll image DropDown image

For Rebar with an array layout, return the distribution path (a line).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve DistributionPath{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DistributionPath As Curve
Visual C++
public:
property Curve^ DistributionPath {
    Curve^ get ();
}

Remarks

This creates a new curve.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Host Property

Rebar..::Host Property
CollapseAll image DropDown image

The element that contains the rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Host{ get; set;}
Visual Basic (Declaration)
Public Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
    void set (Element^ value);
}

Remarks

Returns the Autodesk Revit element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


IsShownInFrontOfGeometryInView Property

Rebar..::IsShownInFrontOfGeometryInView Property
CollapseAll image DropDown image

Control placement of the rebar graphics in the viewing planes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsShownInFrontOfGeometryInView[
    View dbView
]{ get; set;}
Visual Basic (Declaration)
Public Property IsShownInFrontOfGeometryInView ( _
    dbView As View _
) As Boolean
Visual C++
public:
property bool IsShownInFrontOfGeometryInView[View^ dbView] {
    bool get (View^ dbView);
    void set (View^ dbView, bool value);
}

Parameters

dbView
View

Remarks

Control whether the graphics are shown in front of the geometry in a view.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Parameter Property

Rebar..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Rebar Class
Rebar Members
Autodesk.Revit.Elements Namespace


RebarShape Property

Rebar..::RebarShape Property
CollapseAll image DropDown image

Get/Set the RebarShape associated with the Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShape RebarShape{ get; set;}
Visual Basic (Declaration)
Public Property RebarShape As RebarShape
Visual C++
public:
property RebarShape^ RebarShape {
    RebarShape^ get ();
    void set (RebarShape^ value);
}

Remarks

When set, the instance will choose values for its shape parameters to try to preserve its previous shape.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


RebarHostData Class
See Also Members
CollapseAll image DropDown image

Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("740FFDF7-8F1F-4bb1-BFEE-B39AE35257C9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RebarHostData : APIObject
Visual Basic (Declaration)
<GuidAttribute("740FFDF7-8F1F-4bb1-BFEE-B39AE35257C9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RebarHostData _
    Inherits APIObject
Visual C++
[GuidAttribute(L"740FFDF7-8F1F-4bb1-BFEE-B39AE35257C9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarHostData : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::RebarHostData

See Also

RebarHostData Members
Autodesk.Revit.Elements Namespace


RebarHostData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarHostData
Visual Basic (Declaration)
Public Class RebarHostData
Visual C++
public ref class RebarHostData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarHostDataRebarHostDataNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCoverTypeForReference | Checks whether the reference has an associated cover.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | CoverType | Gets the RebarCoverType associated with a face of the element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData
Autodesk.Revit.Elements Namespace


RebarHostData Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHostData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHostData ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


RebarHostData Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarHostData
Visual Basic (Declaration)
Public Class RebarHostData
Visual C++
public ref class RebarHostData

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCoverTypeForReference | Checks whether the reference has an associated cover.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

RebarHostData
Autodesk.Revit.Elements Namespace


Dispose Method

RebarHostData..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


getRebarHostData Method

RebarHostData..::getRebarHostData Method
CollapseAll image DropDown image

Gets a RebarHostData object referring to the specified rebar host element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static RebarHostData getRebarHostData(
    Element host
)
Visual Basic (Declaration)
Public Shared Function getRebarHostData ( _
    host As Element _
) As RebarHostData
Visual C++
public:
static RebarHostData^ getRebarHostData (
    Element^ host
)

Parameters

host
Element

Remarks

Returns null for elements that cannot ever be rebar hosts, such as levels.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


HasCoverTypeForReference Method

RebarHostData..::HasCoverTypeForReference Method
CollapseAll image DropDown image

Checks whether the reference has an associated cover.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HasCoverTypeForReference(
    Reference
)
Visual Basic (Declaration)
Public Function HasCoverTypeForReference ( _
     As Reference _
) As Boolean
Visual C++
public:
bool HasCoverTypeForReference (
    Reference^
)

Parameters

Reference

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


RebarHostData Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarHostData
Visual Basic (Declaration)
Public Class RebarHostData
Visual C++
public ref class RebarHostData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | CoverType | Gets the RebarCoverType associated with a face of the element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData
Autodesk.Revit.Elements Namespace


CoverType Property

RebarHostData..::CoverType Property
CollapseAll image DropDown image

Gets the RebarCoverType associated with a face of the element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarCoverType CoverType[
    Reference
]{ get; set;}
Visual Basic (Declaration)
Public Property CoverType ( _
     As Reference _
) As RebarCoverType
Visual C++
public:
property RebarCoverType^ CoverType[Reference^ ] {
    RebarCoverType^ get (Reference^ );
    void set (Reference^ , RebarCoverType^ value);
}

Parameters

Reference

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


Valid Property

RebarHostData..::Valid Property
CollapseAll image DropDown image

Returns whether the element is a valid rebar host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Valid{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Valid As Boolean
Visual C++
public:
property bool Valid {
    bool get ();
}

Remarks

If getRebarHostData() returns an invalid RebarHostData, this means that the element can be made a valid rebar host, generally by setting a property like FLOOR_PARAM_IS_STRUCTURAL or by changing the element's physical material to concrete. On the other hand, if getRebarHostData() returns null, the element cannot be made into a rebar host.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


ReferencePlane Class
See Also Members
CollapseAll image DropDown image

Represents a reference plane of Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("11F1777D-1062-42de-B6A5-1DAA64AF620C")]
public class ReferencePlane : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("11F1777D-1062-42de-B6A5-1DAA64AF620C")> _
Public Class ReferencePlane _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"11F1777D-1062-42de-B6A5-1DAA64AF620C")]
public ref class ReferencePlane : public Element

Remarks

This object is derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also has many methods to set the specific properties of the reference plane

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ReferencePlane

See Also

ReferencePlane Members
Autodesk.Revit.Elements Namespace


ReferencePlane Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ReferencePlane
Visual Basic (Declaration)
Public Class ReferencePlane
Visual C++
public ref class ReferencePlane

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ReferencePlaneReferencePlaneNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | The direction of the reference plane.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FreeEnd | The free end of the reference plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Plane | The geometry plane to which the reference plane is assigned.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ReferencePlane
Autodesk.Revit.Elements Namespace


ReferencePlane Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferencePlane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferencePlane ()

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


ReferencePlane Methods
CollapseAll image DropDown image

Syntax

C#
public class ReferencePlane
Visual Basic (Declaration)
Public Class ReferencePlane
Visual C++
public ref class ReferencePlane

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ReferencePlane
Autodesk.Revit.Elements Namespace


Dispose Method

ReferencePlane..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Flip Method

ReferencePlane..::Flip Method
CollapseAll image DropDown image

Flips the orientation of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Flip()
Visual Basic (Declaration)
Public Sub Flip
Visual C++
public:
void Flip ()

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


ReferencePlane Properties
CollapseAll image DropDown image

Syntax

C#
public class ReferencePlane
Visual Basic (Declaration)
Public Class ReferencePlane
Visual C++
public ref class ReferencePlane

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | The direction of the reference plane.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FreeEnd | The free end of the reference plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Plane | The geometry plane to which the reference plane is assigned.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ReferencePlane
Autodesk.Revit.Elements Namespace


BubbleEnd Property

ReferencePlane..::BubbleEnd Property
CollapseAll image DropDown image

The bubble end of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ BubbleEnd{ get; set;}
Visual Basic (Declaration)
Public Property BubbleEnd As XYZ
Visual C++
public:
property XYZ^ BubbleEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the bubble end is set to almost the same point as free end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Direction Property

ReferencePlane..::Direction Property
CollapseAll image DropDown image

The direction of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Direction{ get; set;}
Visual Basic (Declaration)
Public Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is almost zero or if it is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


FreeEnd Property

ReferencePlane..::FreeEnd Property
CollapseAll image DropDown image

The free end of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ FreeEnd{ get; set;}
Visual Basic (Declaration)
Public Property FreeEnd As XYZ
Visual C++
public:
property XYZ^ FreeEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the free end is set to almost the same point as bubble end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Name Property

ReferencePlane..::Name Property
CollapseAll image DropDown image

The name property of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get; set;}
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property overrides Element's default implementation.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Normal Property

ReferencePlane..::Normal Property
CollapseAll image DropDown image

The normal vector of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Normal{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Parameter Property

ReferencePlane..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ReferencePlane Class
ReferencePlane Members
Autodesk.Revit.Elements Namespace


Plane Property

ReferencePlane..::Plane Property
CollapseAll image DropDown image

The geometry plane to which the reference plane is assigned.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane Plane{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Plane As Plane
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Revolution Class
See Also Members
CollapseAll image DropDown image

Provides access to the Revolution Form model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0FD3C0B1-2A8F-4431-8318-8CBF59B5A83D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Revolution : GenericForm
Visual Basic (Declaration)
<GuidAttribute("0FD3C0B1-2A8F-4431-8318-8CBF59B5A83D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Revolution _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"0FD3C0B1-2A8F-4431-8318-8CBF59B5A83D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Revolution : public GenericForm

Remarks

The Revolution Form object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Revolution

See Also

Revolution Members
Autodesk.Revit.Elements Namespace


Revolution Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Revolution
Visual Basic (Declaration)
Public Class Revolution
Visual C++
public ref class Revolution

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RevolutionRevolutionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Axis | Returns the Axis of the Revolution.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndAngle | Returns the Start Angle of the Revolution.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | Returns the Start Angle of the Revolution.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Revolution
Autodesk.Revit.Elements Namespace


Revolution Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Revolution()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Revolution ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


Revolution Properties
CollapseAll image DropDown image

Syntax

C#
public class Revolution
Visual Basic (Declaration)
Public Class Revolution
Visual C++
public ref class Revolution

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Axis | Returns the Axis of the Revolution.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndAngle | Returns the Start Angle of the Revolution.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | Returns the Start Angle of the Revolution.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Revolution
Autodesk.Revit.Elements Namespace


Axis Property

Revolution..::Axis Property
CollapseAll image DropDown image

Returns the Axis of the Revolution.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelLine Axis{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Axis As ModelLine
Visual C++
public:
property ModelLine^ Axis {
    ModelLine^ get ();
}

Remarks

This property is used to retrieve the Axis of the Revolution.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


EndAngle Property

Revolution..::EndAngle Property
CollapseAll image DropDown image

Returns the Start Angle of the Revolution.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double EndAngle{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndAngle As Double
Visual C++
public:
property double EndAngle {
    double get ();
}

Remarks

This property is used to retrieve the Start Angle of the Revolution.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


Parameter Property

Revolution..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Revolution Class
Revolution Members
Autodesk.Revit.Elements Namespace


Sketch Property

Revolution..::Sketch Property
CollapseAll image DropDown image

Returns the Sketch of the Revolution.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sketch Sketch{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Sketch As Sketch
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketch of the Revolution.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


StartAngle Property

Revolution..::StartAngle Property
CollapseAll image DropDown image

Returns the Start Angle of the Revolution.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double StartAngle{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
}

Remarks

This property is used to retrieve the Start Angle of the Revolution.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


RoofBase Class
See Also Members
CollapseAll image DropDown image

Represents all kinds of Roofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("32BA40EA-20B6-4961-AF29-96FAF8EFBE47")]
public class RoofBase : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("32BA40EA-20B6-4961-AF29-96FAF8EFBE47")> _
Public Class RoofBase _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"32BA40EA-20B6-4961-AF29-96FAF8EFBE47")]
public ref class RoofBase : public HostObject

Remarks

The RoofBase object represents all kinds of roof in Revit.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::RoofBase
Autodesk.Revit.Elements..::FootPrintRoof
Autodesk.Revit.Elements..::ExtrusionRoof

See Also

RoofBase Members
Autodesk.Revit.Elements Namespace


RoofBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RoofBase
Visual Basic (Declaration)
Public Class RoofBase
Visual C++
public ref class RoofBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoofBaseRoofBaseNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoofBase
Autodesk.Revit.Elements Namespace


RoofBase Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoofBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofBase ()

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


RoofBase Properties
CollapseAll image DropDown image

Syntax

C#
public class RoofBase
Visual Basic (Declaration)
Public Class RoofBase
Visual C++
public ref class RoofBase

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoofBase
Autodesk.Revit.Elements Namespace


EaveCuts Property

RoofBase..::EaveCuts Property
CollapseAll image DropDown image

Retrieve or set the EaveCutterType.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public EaveCutterType EaveCuts{ get; set;}
Visual Basic (Declaration)
Public Property EaveCuts As EaveCutterType
Visual C++
public:
property EaveCutterType EaveCuts {
    EaveCutterType get ();
    void set (EaveCutterType value);
}

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


FasciaDepth Property

RoofBase..::FasciaDepth Property
CollapseAll image DropDown image

Retrieve or set the FasciaDepth.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double FasciaDepth{ get; set;}
Visual Basic (Declaration)
Public Property FasciaDepth As Double
Visual C++
public:
property double FasciaDepth {
    double get ();
    void set (double value);
}

Remarks

If the EaveCutterType is PlumbCut, this property doesn't make sense.

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

RoofBase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RoofBase Class
RoofBase Members
Autodesk.Revit.Elements Namespace


RoofType Property

RoofBase..::RoofType Property
CollapseAll image DropDown image

Retrieve or set the Type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoofType RoofType{ get; set;}
Visual Basic (Declaration)
Public Property RoofType As RoofType
Visual C++
public:
property RoofType^ RoofType {
    RoofType^ get ();
    void set (RoofType^ value);
}

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


SlabShapeEditor Property

RoofBase..::SlabShapeEditor Property
CollapseAll image DropDown image

Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeEditor SlabShapeEditor{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Roofs cannot be attached to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, the ShapeEditor will be nullptr.

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


Room Class
See Also Members
CollapseAll image DropDown image

Provides access to the room topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("54548F23-4FB5-43fd-968D-47EBD37A6D79")]
public class Room : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("54548F23-4FB5-43fd-968D-47EBD37A6D79")> _
Public Class Room _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"54548F23-4FB5-43fd-968D-47EBD37A6D79")]
public ref class Room : public Element

Remarks

The room object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Room

See Also

Room Members
Autodesk.Revit.Elements Namespace


Room Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Room
Visual Basic (Declaration)
Public Class Room
Visual C++
public ref class Room

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoomRoomNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Area | Get the Area of the Room.
Public property | BaseOffset | Get or Set the Base Offset of the Room.
Public property | Boundary | Returns the boundary of the room.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClosedShell | Return the closedShell of the Room.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LimitOffset | Get or Set the Limit Offset of the Room.
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the room. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Number of the Room.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Room.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UnboundedHeight | Get the Unbounded Height of the Room.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Room.
Public property | Volume | Get the Volume of the Room.

See Also

Room
Autodesk.Revit.Elements Namespace


Room Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Room ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Room Methods
CollapseAll image DropDown image

Syntax

C#
public class Room
Visual Basic (Declaration)
Public Class Room
Visual C++
public ref class Room

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Room
Autodesk.Revit.Elements Namespace


Unplace Method

Room..::Unplace Method
CollapseAll image DropDown image

Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Unplace()
Visual Basic (Declaration)
Public Sub Unplace
Visual C++
public:
void Unplace ()

Remarks

Note that current room is changed to unplaced and all corresponding rooms which in other group instance are deleted when in group edit mode.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Room Properties
CollapseAll image DropDown image

Syntax

C#
public class Room
Visual Basic (Declaration)
Public Class Room
Visual C++
public ref class Room

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | Get the Area of the Room.
Public property | BaseOffset | Get or Set the Base Offset of the Room.
Public property | Boundary | Returns the boundary of the room.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClosedShell | Return the closedShell of the Room.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LimitOffset | Get or Set the Limit Offset of the Room.
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the room. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Number of the Room.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Room.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UnboundedHeight | Get the Unbounded Height of the Room.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Room.
Public property | Volume | Get the Volume of the Room.

See Also

Room
Autodesk.Revit.Elements Namespace


Area Property

Room..::Area Property
CollapseAll image DropDown image

Get the Area of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Area{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


BaseOffset Property

Room..::BaseOffset Property
CollapseAll image DropDown image

Get or Set the Base Offset of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double BaseOffset{ get; set;}
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Boundary Property

Room..::Boundary Property
CollapseAll image DropDown image

Returns the boundary of the room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArray Boundary{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the room. Each room may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Room.BoundarySegment object for more details about the segments that make up the room topology.

See Also

Room Class
Autodesk.Revit.Elements Namespace


ClosedShell Property

Room..::ClosedShell Property
CollapseAll image DropDown image

Return the closedShell of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element ClosedShell{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ClosedShell As Element
Visual C++
public:
property Element^ ClosedShell {
    Element^ get ();
}

See Also

Room Class
Autodesk.Revit.Elements Namespace


LimitOffset Property

Room..::LimitOffset Property
CollapseAll image DropDown image

Get or Set the Limit Offset of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double LimitOffset{ get; set;}
Visual Basic (Declaration)
Public Property LimitOffset As Double
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Location Property

Room..::Location Property
CollapseAll image DropDown image

get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

Room Class
Autodesk.Revit.Elements Namespace


Name Property

Room..::Name Property
CollapseAll image DropDown image

Get or Set the Name of the room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Number Property

Room..::Number Property
CollapseAll image DropDown image

Get or Set the Number of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Number{ get; set;}
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Number of the room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Parameter Property

Room..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Room Class
Room Members
Autodesk.Revit.Elements Namespace


Perimeter Property

Room..::Perimeter Property
CollapseAll image DropDown image

Get the Perimeter of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Perimeter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


UnboundedHeight Property

Room..::UnboundedHeight Property
CollapseAll image DropDown image

Get the Unbounded Height of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UnboundedHeight{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UnboundedHeight As Double
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


UpperLimit Property

Room..::UpperLimit Property
CollapseAll image DropDown image

Get or Set the Upper Limit of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level UpperLimit{ get; set;}
Visual Basic (Declaration)
Public Property UpperLimit As Level
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Volume Property

Room..::Volume Property
CollapseAll image DropDown image

Get the Volume of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Volume{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


RoomTag Class
See Also Members
CollapseAll image DropDown image

Provides access to the room tag in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("46175D5A-7A1F-43c1-97F0-242EA2D61AB4")]
public class RoomTag : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("46175D5A-7A1F-43c1-97F0-242EA2D61AB4")> _
Public Class RoomTag _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"46175D5A-7A1F-43c1-97F0-242EA2D61AB4")]
public ref class RoomTag : public Element

Remarks

The roomTag object can be queried for room information.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::RoomTag

See Also

RoomTag Members
Autodesk.Revit.Elements Namespace


RoomTag Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RoomTag
Visual Basic (Declaration)
Public Class RoomTag
Visual C++
public ref class RoomTag

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoomTagRoomTagNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | get/set the display attribute of Leader.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. (Overrides Element ..:: Location.)
Public property | Name | The name associated with the room tag. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Room | Returns the room that the tag is associated with.
Public property | RoomTagType | get/set the type.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Returns the view in which the tag was place.

See Also

RoomTag
Autodesk.Revit.Elements Namespace


RoomTag Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTag ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


RoomTag Properties
CollapseAll image DropDown image

Syntax

C#
public class RoomTag
Visual Basic (Declaration)
Public Class RoomTag
Visual C++
public ref class RoomTag

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | get/set the display attribute of Leader.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. (Overrides Element ..:: Location.)
Public property | Name | The name associated with the room tag. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Room | Returns the room that the tag is associated with.
Public property | RoomTagType | get/set the type.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Returns the view in which the tag was place.

See Also

RoomTag
Autodesk.Revit.Elements Namespace


Leader Property

RoomTag..::Leader Property
CollapseAll image DropDown image

get/set the display attribute of Leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Leader{ get; set;}
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Remarks

get/set, will be true if the leader is displayed otherwise false.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Location Property

RoomTag..::Location Property
CollapseAll image DropDown image

get a location point object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Name Property

RoomTag..::Name Property
CollapseAll image DropDown image

The name associated with the room tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This overrides Element.Name to allow the API to prevent modifications to the room tag's name (because this is not permitted to be modified in the Autodesk Revit UI. Calling this method will result in a System.InvalidOperationException.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

RoomTag..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RoomTag Class
RoomTag Members
Autodesk.Revit.Elements Namespace


Room Property

RoomTag..::Room Property
CollapseAll image DropDown image

Returns the room that the tag is associated with.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room Room{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

get the room that the tag is associated with

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


RoomTagType Property

RoomTag..::RoomTagType Property
CollapseAll image DropDown image

get/set the type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTagType RoomTagType{ get; set;}
Visual Basic (Declaration)
Public Property RoomTagType As RoomTagType
Visual C++
public:
property RoomTagType^ RoomTagType {
    RoomTagType^ get ();
    void set (RoomTagType^ value);
}

Remarks

get/set the type for the current RoomTag.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


View Property

RoomTag..::View Property
CollapseAll image DropDown image

Returns the view in which the tag was place.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View View{ get;}
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

Remarks

get the view in which the tag was placed.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Sketch Class
See Also Members
CollapseAll image DropDown image

Provides access to the Sketch in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("84278CA0-4E34-4205-9646-648F79126EA2")]
public class Sketch : SketchBase
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("84278CA0-4E34-4205-9646-648F79126EA2")> _
Public Class Sketch _
    Inherits SketchBase
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"84278CA0-4E34-4205-9646-648F79126EA2")]
public ref class Sketch : public SketchBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::Sketch

See Also

Sketch Members
Autodesk.Revit.Elements Namespace


Sketch Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Sketch
Visual Basic (Declaration)
Public Class Sketch
Visual C++
public ref class Sketch

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SketchSketchNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurveLoop | Returns the CurveLoop of the Sketch.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Sketch
Autodesk.Revit.Elements Namespace


Sketch Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sketch()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sketch ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


Sketch Properties
CollapseAll image DropDown image

Syntax

C#
public class Sketch
Visual Basic (Declaration)
Public Class Sketch
Visual C++
public ref class Sketch

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurveLoop | Returns the CurveLoop of the Sketch.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Sketch
Autodesk.Revit.Elements Namespace


CurveLoop Property

Sketch..::CurveLoop Property
CollapseAll image DropDown image

Returns the CurveLoop of the Sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray CurveLoop{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurveLoop As CurveArray
Visual C++
public:
property CurveArray^ CurveLoop {
    CurveArray^ get ();
}

Remarks

This property is used to retrieve the CurveLoop of Sketch.

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


Parameter Property

Sketch..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Sketch Class
Sketch Members
Autodesk.Revit.Elements Namespace


SketchPlane Property

Sketch..::SketchPlane Property
CollapseAll image DropDown image

Returns the Sketch Plane of the Sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchPlane SketchPlane{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
}

Remarks

This property is used to retrieve the Sketch Plane of Sketch.

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


SketchBase Class
See Also Members
CollapseAll image DropDown image

Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A8CFE7ED-FEFB-48c4-B13D-99AEAE577F82")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SketchBase : Element
Visual Basic (Declaration)
<GuidAttribute("A8CFE7ED-FEFB-48c4-B13D-99AEAE577F82")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SketchBase _
    Inherits Element
Visual C++
[GuidAttribute(L"A8CFE7ED-FEFB-48c4-B13D-99AEAE577F82")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::Sketch
Autodesk.Revit.Elements..::Path3d

See Also

SketchBase Members
Autodesk.Revit.Elements Namespace


SketchBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SketchBase
Visual Basic (Declaration)
Public Class SketchBase
Visual C++
public ref class SketchBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SketchBaseSketchBaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SketchBase
Autodesk.Revit.Elements Namespace


SketchBase Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchBase ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SketchBase Class
Autodesk.Revit.Elements Namespace


SketchPlane Class
See Also Members
CollapseAll image DropDown image

Represents a SketchPlane within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("53C5D986-BF53-4189-8C6F-CF7162EE5707")]
public class SketchPlane : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("53C5D986-BF53-4189-8C6F-CF7162EE5707")> _
Public Class SketchPlane _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"53C5D986-BF53-4189-8C6F-CF7162EE5707")]
public ref class SketchPlane : public Element

Remarks

The SketchPlane object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the user visible name of the level that appears in the level bubble. To retrieve all the levels within a project use the Document.Elements iterator and look for objects of type Autodesk.Revit.Elements.SketchPlane.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchPlane

See Also

SketchPlane Members
Autodesk.Revit.Elements Namespace


SketchPlane Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SketchPlane
Visual Basic (Declaration)
Public Class SketchPlane
Visual C++
public ref class SketchPlane

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SketchPlaneSketchPlaneNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Plane | Returns the corresponding Plane.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SketchPlane
Autodesk.Revit.Elements Namespace


SketchPlane Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchPlane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchPlane ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


SketchPlane Properties
CollapseAll image DropDown image

Syntax

C#
public class SketchPlane
Visual Basic (Declaration)
Public Class SketchPlane
Visual C++
public ref class SketchPlane

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Plane | Returns the corresponding Plane.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SketchPlane
Autodesk.Revit.Elements Namespace


Parameter Property

SketchPlane..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SketchPlane Class
SketchPlane Members
Autodesk.Revit.Elements Namespace


Plane Property

SketchPlane..::Plane Property
CollapseAll image DropDown image

Returns the corresponding Plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane Plane{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Plane As Plane
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

Remarks

This property returns the Plane which can be used to get some infomations of the SketchPlane.

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


SketchSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("58E3B95F-04C4-48a7-BAD9-AE28DCA431E3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SketchSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("58E3B95F-04C4-48a7-BAD9-AE28DCA431E3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SketchSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"58E3B95F-04C4-48a7-BAD9-AE28DCA431E3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SketchSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::SketchSet

See Also

SketchSet Members
Autodesk.Revit.Elements Namespace


SketchSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SketchSet
Visual Basic (Declaration)
Public Class SketchSet
Visual C++
public ref class SketchSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SketchSetSketchSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

SketchSet
Autodesk.Revit.Elements Namespace


SketchSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchSet ()

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


SketchSet Methods
CollapseAll image DropDown image

Syntax

C#
public class SketchSet
Visual Basic (Declaration)
Public Class SketchSet
Visual C++
public ref class SketchSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SketchSet
Autodesk.Revit.Elements Namespace


Clear Method

SketchSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Contains Method

SketchSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Sketch item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Sketch _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Sketch^ item
)

Parameters

item
Sketch

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

SketchSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Erase Method

SketchSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Sketch item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Sketch _
) As Integer
Visual C++
public:
virtual int Erase (
    Sketch^ item
)

Parameters

item
Sketch

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

SketchSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SketchSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SketchSetIterator
Visual C++
public:
virtual SketchSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

SketchSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Insert Method

SketchSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Sketch item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Sketch _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Sketch^ item
)

Parameters

item
Sketch

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

SketchSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

SketchSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SketchSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SketchSetIterator
Visual C++
public:
virtual SketchSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


SketchSet Properties
CollapseAll image DropDown image

Syntax

C#
public class SketchSet
Visual Basic (Declaration)
Public Class SketchSet
Visual C++
public ref class SketchSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

SketchSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

SketchSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Size Property

SketchSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


SketchSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DC882184-B35C-4c92-9CD2-824E182ACEA0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class SketchSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("DC882184-B35C-4c92-9CD2-824E182ACEA0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class SketchSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"DC882184-B35C-4c92-9CD2-824E182ACEA0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SketchSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::SketchSetIterator

See Also

SketchSetIterator Members
Autodesk.Revit.Elements Namespace


SketchSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SketchSetIterator
Visual Basic (Declaration)
Public MustInherit Class SketchSetIterator
Visual C++
public ref class SketchSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SketchSetIteratorSketchSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SketchSetIterator
Autodesk.Revit.Elements Namespace


SketchSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


SketchSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SketchSetIterator
Visual Basic (Declaration)
Public MustInherit Class SketchSetIterator
Visual C++
public ref class SketchSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SketchSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

SketchSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

SketchSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

SketchSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

SketchSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


SketchSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SketchSetIterator
Visual Basic (Declaration)
Public MustInherit Class SketchSetIterator
Visual C++
public ref class SketchSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SketchSetIterator
Autodesk.Revit.Elements Namespace


Current Property

SketchSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


SlabEdge Class
See Also Members
CollapseAll image DropDown image

An object that represents a slab edge within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("AD002C65-8673-4bdb-B954-793E70266B66")]
public class SlabEdge : HostedSweep
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("AD002C65-8673-4bdb-B954-793E70266B66")> _
Public Class SlabEdge _
    Inherits HostedSweep
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"AD002C65-8673-4bdb-B954-793E70266B66")]
public ref class SlabEdge : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::SlabEdge

See Also

SlabEdge Members
Autodesk.Revit.Elements Namespace


SlabEdge Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SlabEdge
Visual Basic (Declaration)
Public Class SlabEdge
Visual C++
public ref class SlabEdge

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabEdgeSlabEdgeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddSegment | Add segments to the slab edge.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

SlabEdge
Autodesk.Revit.Elements Namespace


SlabEdge Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdge()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdge ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


SlabEdge Methods
CollapseAll image DropDown image

Syntax

C#
public class SlabEdge
Visual Basic (Declaration)
Public Class SlabEdge
Visual C++
public ref class SlabEdge

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddSegment | Add segments to the slab edge.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

SlabEdge
Autodesk.Revit.Elements Namespace


AddSegment Method

SlabEdge..::AddSegment Method
CollapseAll image DropDown image

Add segments to the slab edge.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void AddSegment (
    Reference^ targetRef
)

Parameters

targetRef
Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::ArgumentNullException | This exception will be thrown in following cases: - Input targetRef is null.
System..::InvalidOperationException | This exception will be thrown in following cases: 1.Internal code fails to create the segment object. 2.Regeneration fails.
System..::ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


SlabEdge Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabEdge
Visual Basic (Declaration)
Public Class SlabEdge
Visual C++
public ref class SlabEdge

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

SlabEdge
Autodesk.Revit.Elements Namespace


Parameter Property

SlabEdge..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SlabEdge Class
SlabEdge Members
Autodesk.Revit.Elements Namespace


SlabEdgeType Property

SlabEdge..::SlabEdgeType Property
CollapseAll image DropDown image

Retrieves/set an object that represents the type of the SlabEdge.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdgeType SlabEdgeType{ get; set;}
Visual Basic (Declaration)
Public Property SlabEdgeType As SlabEdgeType
Visual C++
public:
property SlabEdgeType^ SlabEdgeType {
    SlabEdgeType^ get ();
    void set (SlabEdgeType^ value);
}

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


Space Class
See Also Members
CollapseAll image DropDown image

Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9B4B226D-1077-4a92-8DA1-354C90AE121B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Space : Element
Visual Basic (Declaration)
<GuidAttribute("9B4B226D-1077-4a92-8DA1-354C90AE121B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Space _
    Inherits Element
Visual C++
[GuidAttribute(L"9B4B226D-1077-4a92-8DA1-354C90AE121B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Space : public Element

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Space

See Also

Space Members
Autodesk.Revit.Elements Namespace


Space Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Space
Visual Basic (Declaration)
Public Class Space
Visual C++
public ref class Space

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpaceSpaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
Public property | ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
Public property | ActualLightingLoad | Get the Actual Lighting Load of the Space.
Public property | ActualOtherLoad | Get or set the Actual Other Load of the Space.
Public property | ActualPowerLoad | Get the Actual Power Load of the Space.
Public property | ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
Public property | ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Public property | Area | Get the Area of the Space.
Public property | AreaperPerson | Get the Area per Person of the Space.
Public property | AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
Public property | BaseOffset | Get or Set the Base Offset of the Space.
Public property | Boundary | Returns the boundary of the Space.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
Public property | CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
Public property | ClosedShell | Return the closedShell of the space.
Public property | ConditionType | Get or set the Condition type of the Space.
Public property | DesignCoolingLoad | Get the Design Cooling Load of the Space.
Public property | DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
Public property | DesignHeatingLoad | Get the Design Heating Load of the Space.
Public property | DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
Public property | DesignLightingLoad | Get or set the Design Lighting Load of the Space.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
Public property | DesignPowerLoad | Get or set the Design Power Load of the Space.
Public property | DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
Public property | DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorReflectance | Get or set the Floor Reflectance of the Space.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
Public property | LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
Public property | LimitOffset | Get or Set the Limit Offset of the Space.
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the Space. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Name of the Number.
Public property | NumberofPeople | Get the Number of People of the Space.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OccupancyUnit | Get the Occupancy Unit of the Space.
Public property | Occupiable | Reports whether this zone is Occupiable or not.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Space.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Plenum | Reports whether this zone is Plenum or not.
Public property | PowerLoadUnit | Get or Set the Power Load Unit of the Space.
Public property | ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Public property | Room | Return the Room of the space.
Public property | SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
Public property | SpaceConstruction | Get the Space Construction of the Space.
Public property | SpaceType | Get or set the Space type of the Space.
Public property | UnboundedHeight | Get the Unbounded Height of the Space.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Space.
Public property | Volume | Get the Volume of the Space.
Public property | WallReflectance | Get or set the Wall Reflectance of the Space.
Public property | Zone | Reports this space belong to which Zone.

See Also

Space
Autodesk.Revit.Elements Namespace


Space Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Space()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Space ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Space Properties
CollapseAll image DropDown image

Syntax

C#
public class Space
Visual Basic (Declaration)
Public Class Space
Visual C++
public ref class Space

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
Public property | ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
Public property | ActualLightingLoad | Get the Actual Lighting Load of the Space.
Public property | ActualOtherLoad | Get or set the Actual Other Load of the Space.
Public property | ActualPowerLoad | Get the Actual Power Load of the Space.
Public property | ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
Public property | ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Public property | Area | Get the Area of the Space.
Public property | AreaperPerson | Get the Area per Person of the Space.
Public property | AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
Public property | BaseOffset | Get or Set the Base Offset of the Space.
Public property | Boundary | Returns the boundary of the Space.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
Public property | CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
Public property | ClosedShell | Return the closedShell of the space.
Public property | ConditionType | Get or set the Condition type of the Space.
Public property | DesignCoolingLoad | Get the Design Cooling Load of the Space.
Public property | DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
Public property | DesignHeatingLoad | Get the Design Heating Load of the Space.
Public property | DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
Public property | DesignLightingLoad | Get or set the Design Lighting Load of the Space.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
Public property | DesignPowerLoad | Get or set the Design Power Load of the Space.
Public property | DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
Public property | DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorReflectance | Get or set the Floor Reflectance of the Space.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
Public property | LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
Public property | LimitOffset | Get or Set the Limit Offset of the Space.
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the Space. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Name of the Number.
Public property | NumberofPeople | Get the Number of People of the Space.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OccupancyUnit | Get the Occupancy Unit of the Space.
Public property | Occupiable | Reports whether this zone is Occupiable or not.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Space.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Plenum | Reports whether this zone is Plenum or not.
Public property | PowerLoadUnit | Get or Set the Power Load Unit of the Space.
Public property | ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Public property | Room | Return the Room of the space.
Public property | SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
Public property | SpaceConstruction | Get the Space Construction of the Space.
Public property | SpaceType | Get or set the Space type of the Space.
Public property | UnboundedHeight | Get the Unbounded Height of the Space.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Space.
Public property | Volume | Get the Volume of the Space.
Public property | WallReflectance | Get or set the Wall Reflectance of the Space.
Public property | Zone | Reports this space belong to which Zone.

See Also

Space
Autodesk.Revit.Elements Namespace


ActualExhaustAirflow Property

Space..::ActualExhaustAirflow Property
CollapseAll image DropDown image

Get the Actual Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualExhaustAirflow{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualExhaustAirflow As Double
Visual C++
public:
property double ActualExhaustAirflow {
    double get ();
}

Remarks

This property is used to get the Actual Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualHVACLoad Property

Space..::ActualHVACLoad Property
CollapseAll image DropDown image

Get or set the Actual HVAC Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualHVACLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualHVACLoad As Double
Visual C++
public:
property double ActualHVACLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual HVAC Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualLightingLoad Property

Space..::ActualLightingLoad Property
CollapseAll image DropDown image

Get the Actual Lighting Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualLightingLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualLightingLoad As Double
Visual C++
public:
property double ActualLightingLoad {
    double get ();
}

Remarks

This property is used to get the Actual Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualOtherLoad Property

Space..::ActualOtherLoad Property
CollapseAll image DropDown image

Get or set the Actual Other Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualOtherLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualOtherLoad As Double
Visual C++
public:
property double ActualOtherLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual Other Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualPowerLoad Property

Space..::ActualPowerLoad Property
CollapseAll image DropDown image

Get the Actual Power Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualPowerLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualPowerLoad As Double
Visual C++
public:
property double ActualPowerLoad {
    double get ();
}

Remarks

This property is used to get the Actual Power Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualReturnAirflow Property

Space..::ActualReturnAirflow Property
CollapseAll image DropDown image

Get or set the Actual Return Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualReturnAirflow{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualReturnAirflow As Double
Visual C++
public:
property double ActualReturnAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualSupplyAirflow Property

Space..::ActualSupplyAirflow Property
CollapseAll image DropDown image

Get or set the Actual Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualSupplyAirflow{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualSupplyAirflow As Double
Visual C++
public:
property double ActualSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Area Property

Space..::Area Property
CollapseAll image DropDown image

Get the Area of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Area{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


AreaperPerson Property

Space..::AreaperPerson Property
CollapseAll image DropDown image

Get the Area per Person of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double AreaperPerson{ get; set;}
Visual Basic (Declaration)
Public Property AreaperPerson As Double
Visual C++
public:
property double AreaperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Area per Person of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


AverageEstimatedIllumination Property

Space..::AverageEstimatedIllumination Property
CollapseAll image DropDown image

Get the Average Estimated Illumination of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double AverageEstimatedIllumination{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AverageEstimatedIllumination As Double
Visual C++
public:
property double AverageEstimatedIllumination {
    double get ();
}

Remarks

This property is used to get the Average Estimated Illumination of the Space. (Unit: fc)

See Also

Space Class
Autodesk.Revit.Elements Namespace


BaseOffset Property

Space..::BaseOffset Property
CollapseAll image DropDown image

Get or Set the Base Offset of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double BaseOffset{ get; set;}
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Boundary Property

Space..::Boundary Property
CollapseAll image DropDown image

Returns the boundary of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArray Boundary{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Space. Each Space may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Space.BoundarySegment object for more details about the segments that make up the Space topology.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CalculatedCoolingLoad Property

Space..::CalculatedCoolingLoad Property
CollapseAll image DropDown image

Get the Calculated Cooling Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CalculatedCoolingLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CalculatedCoolingLoad As Double
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CalculatedHeatingLoad Property

Space..::CalculatedHeatingLoad Property
CollapseAll image DropDown image

Get the Calculated Heating Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CalculatedHeatingLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CalculatedHeatingLoad As Double
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CalculatedSupplyAirflow Property

Space..::CalculatedSupplyAirflow Property
CollapseAll image DropDown image

Get or set the Calculated Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CalculatedSupplyAirflow{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CalculatedSupplyAirflow As Double
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Calculated Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CeilingReflectance Property

Space..::CeilingReflectance Property
CollapseAll image DropDown image

Get or set the Ceiling Reflectance of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CeilingReflectance{ get; set;}
Visual Basic (Declaration)
Public Property CeilingReflectance As Double
Visual C++
public:
property double CeilingReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Ceiling Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ClosedShell Property

Space..::ClosedShell Property
CollapseAll image DropDown image

Return the closedShell of the space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element ClosedShell{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ClosedShell As Element
Visual C++
public:
property Element^ ClosedShell {
    Element^ get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


ConditionType Property

Space..::ConditionType Property
CollapseAll image DropDown image

Get or set the Condition type of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConditionType ConditionType{ get; set;}
Visual Basic (Declaration)
Public Property ConditionType As ConditionType
Visual C++
public:
property ConditionType ConditionType {
    ConditionType get ();
    void set (ConditionType value);
}

Remarks

This property is used to get or set the Condition type of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignCoolingLoad Property

Space..::DesignCoolingLoad Property
CollapseAll image DropDown image

Get the Design Cooling Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignCoolingLoad{ get; set;}
Visual Basic (Declaration)
Public Property DesignCoolingLoad As Double
Visual C++
public:
property double DesignCoolingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignExhaustAirflow Property

Space..::DesignExhaustAirflow Property
CollapseAll image DropDown image

Get or set the Specified Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignExhaustAirflow{ get; set;}
Visual Basic (Declaration)
Public Property DesignExhaustAirflow As Double
Visual C++
public:
property double DesignExhaustAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignHeatingLoad Property

Space..::DesignHeatingLoad Property
CollapseAll image DropDown image

Get the Design Heating Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignHeatingLoad{ get; set;}
Visual Basic (Declaration)
Public Property DesignHeatingLoad As Double
Visual C++
public:
property double DesignHeatingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignHVACLoadperArea Property

Space..::DesignHVACLoadperArea Property
CollapseAll image DropDown image

Get or set the Design HVAC Load per Area of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignHVACLoadperArea{ get; set;}
Visual Basic (Declaration)
Public Property DesignHVACLoadperArea As Double
Visual C++
public:
property double DesignHVACLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design HVAC Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignLightingLoad Property

Space..::DesignLightingLoad Property
CollapseAll image DropDown image

Get or set the Design Lighting Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignLightingLoad{ get; set;}
Visual Basic (Declaration)
Public Property DesignLightingLoad As Double
Visual C++
public:
property double DesignLightingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignOtherLoadperArea Property

Space..::DesignOtherLoadperArea Property
CollapseAll image DropDown image

Get or set the Design Other Load per Area of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignOtherLoadperArea{ get; set;}
Visual Basic (Declaration)
Public Property DesignOtherLoadperArea As Double
Visual C++
public:
property double DesignOtherLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Other Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignPowerLoad Property

Space..::DesignPowerLoad Property
CollapseAll image DropDown image

Get or set the Design Power Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignPowerLoad{ get; set;}
Visual Basic (Declaration)
Public Property DesignPowerLoad As Double
Visual C++
public:
property double DesignPowerLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Power Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignReturnAirflow Property

Space..::DesignReturnAirflow Property
CollapseAll image DropDown image

Get or set the Specified Return Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignReturnAirflow{ get; set;}
Visual Basic (Declaration)
Public Property DesignReturnAirflow As Double
Visual C++
public:
property double DesignReturnAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignSupplyAirflow Property

Space..::DesignSupplyAirflow Property
CollapseAll image DropDown image

Get or set the Specified Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DesignSupplyAirflow{ get; set;}
Visual Basic (Declaration)
Public Property DesignSupplyAirflow As Double
Visual C++
public:
property double DesignSupplyAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


FloorReflectance Property

Space..::FloorReflectance Property
CollapseAll image DropDown image

Get or set the Floor Reflectance of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double FloorReflectance{ get; set;}
Visual Basic (Declaration)
Public Property FloorReflectance As Double
Visual C++
public:
property double FloorReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Floor Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LatentHeatGainperPerson Property

Space..::LatentHeatGainperPerson Property
CollapseAll image DropDown image

Get or set the Latent Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double LatentHeatGainperPerson{ get; set;}
Visual Basic (Declaration)
Public Property LatentHeatGainperPerson As Double
Visual C++
public:
property double LatentHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Latent Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LightingCalculationWorkplane Property

Space..::LightingCalculationWorkplane Property
CollapseAll image DropDown image

Get the Lighting Calculation Workplane of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double LightingCalculationWorkplane{ get; set;}
Visual Basic (Declaration)
Public Property LightingCalculationWorkplane As Double
Visual C++
public:
property double LightingCalculationWorkplane {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Lighting Calculation Workplane (Unit: feet) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LightingLoadUnit Property

Space..::LightingLoadUnit Property
CollapseAll image DropDown image

Get or Set the Lighting Load Unit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BaseLoadOn LightingLoadUnit{ get; set;}
Visual Basic (Declaration)
Public Property LightingLoadUnit As BaseLoadOn
Visual C++
public:
property BaseLoadOn LightingLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Lighting Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LimitOffset Property

Space..::LimitOffset Property
CollapseAll image DropDown image

Get or Set the Limit Offset of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double LimitOffset{ get; set;}
Visual Basic (Declaration)
Public Property LimitOffset As Double
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Location Property

Space..::Location Property
CollapseAll image DropDown image

get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


Name Property

Space..::Name Property
CollapseAll image DropDown image

Get or Set the Name of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Space of the room.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Number Property

Space..::Number Property
CollapseAll image DropDown image

Get or Set the Name of the Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Number{ get; set;}
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Number of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


NumberofPeople Property

Space..::NumberofPeople Property
CollapseAll image DropDown image

Get the Number of People of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double NumberofPeople{ get; set;}
Visual Basic (Declaration)
Public Property NumberofPeople As Double
Visual C++
public:
property double NumberofPeople {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Number of People of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


OccupancyUnit Property

Space..::OccupancyUnit Property
CollapseAll image DropDown image

Get the Occupancy Unit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public OccupancyUnit OccupancyUnit{ get; set;}
Visual Basic (Declaration)
Public Property OccupancyUnit As OccupancyUnit
Visual C++
public:
property OccupancyUnit OccupancyUnit {
    OccupancyUnit get ();
    void set (OccupancyUnit value);
}

Remarks

This property is used to get the Occupancy Unit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Occupiable Property

Space..::Occupiable Property
CollapseAll image DropDown image

Reports whether this zone is Occupiable or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Occupiable{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Occupiable As Boolean
Visual C++
public:
property bool Occupiable {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


Parameter Property

Space..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Space Class
Space Members
Autodesk.Revit.Elements Namespace


Perimeter Property

Space..::Perimeter Property
CollapseAll image DropDown image

Get the Perimeter of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Perimeter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Plenum Property

Space..::Plenum Property
CollapseAll image DropDown image

Reports whether this zone is Plenum or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Plenum{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Plenum As Boolean
Visual C++
public:
property bool Plenum {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


PowerLoadUnit Property

Space..::PowerLoadUnit Property
CollapseAll image DropDown image

Get or Set the Power Load Unit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BaseLoadOn PowerLoadUnit{ get; set;}
Visual Basic (Declaration)
Public Property PowerLoadUnit As BaseLoadOn
Visual C++
public:
property BaseLoadOn PowerLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Power Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ReturnAirflow Property

Space..::ReturnAirflow Property
CollapseAll image DropDown image

Get or set the Return type of Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReturnAirflowType ReturnAirflow{ get; set;}
Visual Basic (Declaration)
Public Property ReturnAirflow As ReturnAirflowType
Visual C++
public:
property ReturnAirflowType ReturnAirflow {
    ReturnAirflowType get ();
    void set (ReturnAirflowType value);
}

Remarks

This property is used to get or set the Return type of Supply Airflow of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Room Property

Space..::Room Property
CollapseAll image DropDown image

Return the Room of the space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room Room{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


SensibleHeatGainperPerson Property

Space..::SensibleHeatGainperPerson Property
CollapseAll image DropDown image

Get the Sensible Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double SensibleHeatGainperPerson{ get; set;}
Visual Basic (Declaration)
Public Property SensibleHeatGainperPerson As Double
Visual C++
public:
property double SensibleHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Sensible Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceCavityRatio Property

Space..::SpaceCavityRatio Property
CollapseAll image DropDown image

Get the Space Cavity Ratio of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double SpaceCavityRatio{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SpaceCavityRatio As Double
Visual C++
public:
property double SpaceCavityRatio {
    double get ();
}

Remarks

This property is used to get the Space Cavity Ratio of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceConstruction Property

Space..::SpaceConstruction Property
CollapseAll image DropDown image

Get the Space Construction of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPSpaceConstruction SpaceConstruction{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SpaceConstruction As MEPSpaceConstruction
Visual C++
public:
property MEPSpaceConstruction^ SpaceConstruction {
    MEPSpaceConstruction^ get ();
}

Remarks

This property is used to get the Space Construction of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceType Property

Space..::SpaceType Property
CollapseAll image DropDown image

Get or set the Space type of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceType SpaceType{ get; set;}
Visual Basic (Declaration)
Public Property SpaceType As SpaceType
Visual C++
public:
property SpaceType SpaceType {
    SpaceType get ();
    void set (SpaceType value);
}

Remarks

This property is used to get or set the Space type of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


UnboundedHeight Property

Space..::UnboundedHeight Property
CollapseAll image DropDown image

Get the Unbounded Height of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UnboundedHeight{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UnboundedHeight As Double
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


UpperLimit Property

Space..::UpperLimit Property
CollapseAll image DropDown image

Get or Set the Upper Limit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level UpperLimit{ get; set;}
Visual Basic (Declaration)
Public Property UpperLimit As Level
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Volume Property

Space..::Volume Property
CollapseAll image DropDown image

Get the Volume of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Volume{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


WallReflectance Property

Space..::WallReflectance Property
CollapseAll image DropDown image

Get or set the Wall Reflectance of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double WallReflectance{ get; set;}
Visual Basic (Declaration)
Public Property WallReflectance As Double
Visual C++
public:
property double WallReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Wall Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Zone Property

Space..::Zone Property
CollapseAll image DropDown image

Reports this space belong to which Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Zone Zone{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Zone As Zone
Visual C++
public:
property Zone^ Zone {
    Zone^ get ();
}

Remarks

This property is used to retrieve the host zone of this space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2DCAA399-6C1D-4354-9BD3-D6F5D0092893")]
public class SpaceSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2DCAA399-6C1D-4354-9BD3-D6F5D0092893")> _
Public Class SpaceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2DCAA399-6C1D-4354-9BD3-D6F5D0092893")]
public ref class SpaceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::SpaceSet

See Also

SpaceSet Members
Autodesk.Revit.Elements Namespace


SpaceSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpaceSet
Visual Basic (Declaration)
Public Class SpaceSet
Visual C++
public ref class SpaceSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpaceSetSpaceSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

SpaceSet
Autodesk.Revit.Elements Namespace


SpaceSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceSet ()

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


SpaceSet Methods
CollapseAll image DropDown image

Syntax

C#
public class SpaceSet
Visual Basic (Declaration)
Public Class SpaceSet
Visual C++
public ref class SpaceSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SpaceSet
Autodesk.Revit.Elements Namespace


Clear Method

SpaceSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Contains Method

SpaceSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Space^ item
)

Parameters

item
Space

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

SpaceSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Erase Method

SpaceSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Space _
) As Integer
Visual C++
public:
virtual int Erase (
    Space^ item
)

Parameters

item
Space

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

SpaceSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SpaceSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

SpaceSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Insert Method

SpaceSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Space^ item
)

Parameters

item
Space

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

SpaceSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

SpaceSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SpaceSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


SpaceSet Properties
CollapseAll image DropDown image

Syntax

C#
public class SpaceSet
Visual Basic (Declaration)
Public Class SpaceSet
Visual C++
public ref class SpaceSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

SpaceSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

SpaceSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Size Property

SpaceSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


SpaceSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FBB66A24-9346-4765-BE9A-1E7DC236B6D1")]
public abstract class SpaceSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FBB66A24-9346-4765-BE9A-1E7DC236B6D1")> _
Public MustInherit Class SpaceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FBB66A24-9346-4765-BE9A-1E7DC236B6D1")]
public ref class SpaceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::SpaceSetIterator

See Also

SpaceSetIterator Members
Autodesk.Revit.Elements Namespace


SpaceSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SpaceSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpaceSetIterator
Visual C++
public ref class SpaceSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpaceSetIteratorSpaceSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator
Autodesk.Revit.Elements Namespace


SpaceSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


SpaceSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SpaceSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpaceSetIterator
Visual C++
public ref class SpaceSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SpaceSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

SpaceSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

SpaceSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

SpaceSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

SpaceSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


SpaceSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SpaceSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpaceSetIterator
Visual C++
public ref class SpaceSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator
Autodesk.Revit.Elements Namespace


Current Property

SpaceSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


SpaceTag Class
See Also Members
CollapseAll image DropDown image

Provides access to the space tag in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("206EBCBC-0CFA-4779-8204-F3750183166E")]
public class SpaceTag : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("206EBCBC-0CFA-4779-8204-F3750183166E")> _
Public Class SpaceTag _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"206EBCBC-0CFA-4779-8204-F3750183166E")]
public ref class SpaceTag : public Element

Remarks

The space Tag object can be queried for space information.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SpaceTag

See Also

SpaceTag Members
Autodesk.Revit.Elements Namespace


SpaceTag Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpaceTag
Visual Basic (Declaration)
Public Class SpaceTag
Visual C++
public ref class SpaceTag

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpaceTagSpaceTagNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | get/set the display attribute of Leader.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. (Overrides Element ..:: Location.)
Public property | Name | Retrieve or Change the name associated with the SpaceTag. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Space | Returns the aream that the tag is associated with.
Public property | SpaceTagType | get/set the type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Returns the view in which the tag was place.

See Also

SpaceTag
Autodesk.Revit.Elements Namespace


SpaceTag Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTag ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpaceTag Properties
CollapseAll image DropDown image

Syntax

C#
public class SpaceTag
Visual Basic (Declaration)
Public Class SpaceTag
Visual C++
public ref class SpaceTag

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leader | get/set the display attribute of Leader.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | get a location point object. (Overrides Element ..:: Location.)
Public property | Name | Retrieve or Change the name associated with the SpaceTag. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Space | Returns the aream that the tag is associated with.
Public property | SpaceTagType | get/set the type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Returns the view in which the tag was place.

See Also

SpaceTag
Autodesk.Revit.Elements Namespace


Leader Property

SpaceTag..::Leader Property
CollapseAll image DropDown image

get/set the display attribute of Leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Leader{ get; set;}
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Remarks

get/set, will be true if the leader is displayed otherwise false.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


Location Property

SpaceTag..::Location Property
CollapseAll image DropDown image

get a location point object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The point within the location object should be get/set. This is the location of the space within the level. The Z location should be the elevation of the level and not changeable.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


Name Property

SpaceTag..::Name Property
CollapseAll image DropDown image

Retrieve or Change the name associated with the SpaceTag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

SpaceTag..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SpaceTag Class
SpaceTag Members
Autodesk.Revit.Elements Namespace


Space Property

SpaceTag..::Space Property
CollapseAll image DropDown image

Returns the aream that the tag is associated with.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Space Space{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Space As Space
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

get the aream that the tag is associated with

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpaceTagType Property

SpaceTag..::SpaceTagType Property
CollapseAll image DropDown image

get/set the type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceTagType SpaceTagType{ get; set;}
Visual Basic (Declaration)
Public Property SpaceTagType As SpaceTagType
Visual C++
public:
property SpaceTagType^ SpaceTagType {
    SpaceTagType^ get ();
    void set (SpaceTagType^ value);
}

Remarks

get/set the type for the current AreaTag.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


View Property

SpaceTag..::View Property
CollapseAll image DropDown image

Returns the view in which the tag was place.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View View{ get;}
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

Remarks

get the view in which the tag was placed.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpotDimension Class
See Also Members
CollapseAll image DropDown image

An object that represents a spot dimension within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4AFF8AD2-51B1-42c3-98E6-43DEA671F23D")]
public class SpotDimension : Dimension
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4AFF8AD2-51B1-42c3-98E6-43DEA671F23D")> _
Public Class SpotDimension _
    Inherits Dimension
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4AFF8AD2-51B1-42c3-98E6-43DEA671F23D")]
public ref class SpotDimension : public Dimension

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Dimension
Autodesk.Revit.Elements..::SpotDimension

See Also

SpotDimension Members
Autodesk.Revit.Elements Namespace


SpotDimension Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpotDimension
Visual Basic (Declaration)
Public Class SpotDimension
Visual C++
public ref class SpotDimension

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpotDimensionSpotDimensionNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | Get a location point object. This is the location of the spot dimension. (Overrides Element ..:: Location.)
Public property | Name | Retrieve or Change the name associated with the Dimension. (Inherited from Dimension.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)

See Also

SpotDimension
Autodesk.Revit.Elements Namespace


SpotDimension Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimension()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimension ()

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


SpotDimension Properties
CollapseAll image DropDown image

Syntax

C#
public class SpotDimension
Visual Basic (Declaration)
Public Class SpotDimension
Visual C++
public ref class SpotDimension

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | Get a location point object. This is the location of the spot dimension. (Overrides Element ..:: Location.)
Public property | Name | Retrieve or Change the name associated with the Dimension. (Inherited from Dimension.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)

See Also

SpotDimension
Autodesk.Revit.Elements Namespace


Location Property

SpotDimension..::Location Property
CollapseAll image DropDown image

Get a location point object. This is the location of the spot dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Location Location{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


Parameter Property

SpotDimension..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SpotDimension Class
SpotDimension Members
Autodesk.Revit.Elements Namespace


SpotDimensionType Property

SpotDimension..::SpotDimensionType Property
CollapseAll image DropDown image

The dimension style of this dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimensionType SpotDimensionType{ get; set;}
Visual Basic (Declaration)
Public Property SpotDimensionType As SpotDimensionType
Visual C++
public:
property SpotDimensionType^ SpotDimensionType {
    SpotDimensionType^ get ();
    void set (SpotDimensionType^ value);
}

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


Sweep Class
See Also Members
CollapseAll image DropDown image

Provides access to the Sweep model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("48510B8A-21BA-4675-A297-CEB88F1EC7FC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Sweep : GenericForm
Visual Basic (Declaration)
<GuidAttribute("48510B8A-21BA-4675-A297-CEB88F1EC7FC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Sweep _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"48510B8A-21BA-4675-A297-CEB88F1EC7FC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Sweep : public GenericForm

Remarks

The Sweep object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Sweep

See Also

Sweep Members
Autodesk.Revit.Elements Namespace


Sweep Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Sweep
Visual Basic (Declaration)
Public Class Sweep
Visual C++
public ref class Sweep

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SweepSweepNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EnableTrajSegmentation | Returns the Trajectory Segmentation state of the Sweep.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaxSegmentAngle | Returns the Maximum Segment Angle of the Sweep.
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Path3d | Returns the 3D Path Sketch of the Sweep.
Public property | PathSketch | Returns the Plan Path Sketch of the Sweep.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProfileSketch | Returns the profile Sketch of the Sweep.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Sweep
Autodesk.Revit.Elements Namespace


Sweep Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sweep()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sweep ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


Sweep Properties
CollapseAll image DropDown image

Syntax

C#
public class Sweep
Visual Basic (Declaration)
Public Class Sweep
Visual C++
public ref class Sweep

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EnableTrajSegmentation | Returns the Trajectory Segmentation state of the Sweep.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaxSegmentAngle | Returns the Maximum Segment Angle of the Sweep.
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Path3d | Returns the 3D Path Sketch of the Sweep.
Public property | PathSketch | Returns the Plan Path Sketch of the Sweep.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProfileSketch | Returns the profile Sketch of the Sweep.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Sweep
Autodesk.Revit.Elements Namespace


EnableTrajSegmentation Property

Sweep..::EnableTrajSegmentation Property
CollapseAll image DropDown image

Returns the Trajectory Segmentation state of the Sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool EnableTrajSegmentation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EnableTrajSegmentation As Boolean
Visual C++
public:
property bool EnableTrajSegmentation {
    bool get ();
}

Remarks

This property is used to retrieve the Trajectory Segmentation state of the Sweep. if return is true, means user can control the MaxSegmentAngle, otherwise is disable.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


MaxSegmentAngle Property

Sweep..::MaxSegmentAngle Property
CollapseAll image DropDown image

Returns the Maximum Segment Angle of the Sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double MaxSegmentAngle{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MaxSegmentAngle As Double
Visual C++
public:
property double MaxSegmentAngle {
    double get ();
}

Remarks

This property is used to retrieve the Maximum Segment Angle of the Sweep.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


Parameter Property

Sweep..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Sweep Class
Sweep Members
Autodesk.Revit.Elements Namespace


Path3d Property

Sweep..::Path3d Property
CollapseAll image DropDown image

Returns the 3D Path Sketch of the Sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Path3d Path3d{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Path3d As Path3d
Visual C++
public:
property Path3d^ Path3d {
    Path3d^ get ();
}

Remarks

This property is used to retrieve the 3D Path Sketch of the Sweep.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


PathSketch Property

Sweep..::PathSketch Property
CollapseAll image DropDown image

Returns the Plan Path Sketch of the Sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sketch PathSketch{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PathSketch As Sketch
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Plan Path Sketch of the Sweep.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


ProfileSketch Property

Sweep..::ProfileSketch Property
CollapseAll image DropDown image

Returns the profile Sketch of the Sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Sketch ProfileSketch{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ProfileSketch As Sketch
Visual C++
public:
property Sketch^ ProfileSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the profile Sketch of the Sweep.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


TemperatureRatingType Class
See Also Members
CollapseAll image DropDown image

Represents temperature rating type definition information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1FC97013-70F5-4f2e-98AA-48444E82249A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class TemperatureRatingType : Element
Visual Basic (Declaration)
<GuidAttribute("1FC97013-70F5-4f2e-98AA-48444E82249A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class TemperatureRatingType _
    Inherits Element
Visual C++
[GuidAttribute(L"1FC97013-70F5-4f2e-98AA-48444E82249A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TemperatureRatingType : public Element

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type informations such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::TemperatureRatingType

See Also

TemperatureRatingType Members
Autodesk.Revit.Elements Namespace


TemperatureRatingType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingType
Visual Basic (Declaration)
Public Class TemperatureRatingType
Visual C++
public ref class TemperatureRatingType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TemperatureRatingTypeTemperatureRatingTypeNew |

Public Methods

 | Name | Description
Public method | AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
Public method | AddInsulationType | Add a new kind of insulation type into this temperature rating type.
Public method | AddWireSize | Add a new kind of wire size type into this temperature rating type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
Public method | RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
Public method | RemoveWireSize | Remove an existing wire size type from this temperature rating type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
Public property | IsInUse | Indicate whether the temperature rating type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaterialType | Get the material type information which this temperature rating type belongs to.
Public property | Name | Get name of temperature rating type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType
Autodesk.Revit.Elements Namespace


TemperatureRatingType Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TemperatureRatingType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingType ()

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


TemperatureRatingType Methods
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingType
Visual Basic (Declaration)
Public Class TemperatureRatingType
Visual C++
public ref class TemperatureRatingType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
Public method | AddInsulationType | Add a new kind of insulation type into this temperature rating type.
Public method | AddWireSize | Add a new kind of wire size type into this temperature rating type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
Public method | RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
Public method | RemoveWireSize | Remove an existing wire size type from this temperature rating type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

TemperatureRatingType
Autodesk.Revit.Elements Namespace


AddCorrectionFactor Method

TemperatureRatingType..::AddCorrectionFactor Method
CollapseAll image DropDown image

Add a new electrical correction factor type to this temperature rating type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CorrectionFactor AddCorrectionFactor(
    long temperature,
    double factor
)
Visual Basic (Declaration)
Public Function AddCorrectionFactor ( _
    temperature As Long, _
    factor As Double _
) As CorrectionFactor
Visual C++
public:
CorrectionFactor^ AddCorrectionFactor (
    long long temperature,
    double factor
)

Parameters

temperature
Int64
Temperature of correction factor to be added.
factor
Double
Factor of correction factor to be added.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


AddInsulationType Method

TemperatureRatingType..::AddInsulationType Method
CollapseAll image DropDown image

Add a new kind of insulation type into this temperature rating type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsulationType AddInsulationType(
    string name
)
Visual Basic (Declaration)
Public Function AddInsulationType ( _
    name As String _
) As InsulationType
Visual C++
public:
InsulationType^ AddInsulationType (
    String^ name
)

Parameters

name
String
Name of insulation type symbol to be constructed and added.

Return Value

Constructed insulation type instance.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


AddWireSize Method

TemperatureRatingType..::AddWireSize Method
CollapseAll image DropDown image

Add a new kind of wire size type into this temperature rating type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSize AddWireSize(
    string size,
    long ampacity,
    double diameter
)
Visual Basic (Declaration)
Public Function AddWireSize ( _
    size As String, _
    ampacity As Long, _
    diameter As Double _
) As WireSize
Visual C++
public:
WireSize^ AddWireSize (
    String^ size,
    long long ampacity,
    double diameter
)

Parameters

size
String
Size of wire size.
ampacity
Int64
Ampacity of wire size to be added.
diameter
Double
Diameter of wire size to be added.

Return Value

Constructed wire size type.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


RemoveCorrectionFactor Method

TemperatureRatingType..::RemoveCorrectionFactor Method
CollapseAll image DropDown image

Remove an existing correction factor from this temperature rating type in Revit MEP project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveCorrectionFactor(
    CorrectionFactor correctionFactor
)
Visual Basic (Declaration)
Public Sub RemoveCorrectionFactor ( _
    correctionFactor As CorrectionFactor _
)
Visual C++
public:
void RemoveCorrectionFactor (
    CorrectionFactor^ correctionFactor
)

Parameters

correctionFactor
CorrectionFactor
The correction factor to be removed.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


RemoveInsulationType Method

TemperatureRatingType..::RemoveInsulationType Method
CollapseAll image DropDown image

Remove an existing insulation type from this temperature rating type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveInsulationType(
    InsulationType insulationType
)
Visual Basic (Declaration)
Public Sub RemoveInsulationType ( _
    insulationType As InsulationType _
)
Visual C++
public:
void RemoveInsulationType (
    InsulationType^ insulationType
)

Parameters

insulationType
InsulationType
Insulation type to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | The last one insulation type of project and any one which is in use by a wire type can't be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


RemoveWireSize Method

TemperatureRatingType..::RemoveWireSize Method
CollapseAll image DropDown image

Remove an existing wire size type from this temperature rating type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveWireSize(
    WireSize wireSize
)
Visual Basic (Declaration)
Public Sub RemoveWireSize ( _
    wireSize As WireSize _
)
Visual C++
public:
void RemoveWireSize (
    WireSize^ wireSize
)

Parameters

wireSize
WireSize
The wire size type to be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


TemperatureRatingType Properties
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingType
Visual Basic (Declaration)
Public Class TemperatureRatingType
Visual C++
public ref class TemperatureRatingType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
Public property | IsInUse | Indicate whether the temperature rating type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaterialType | Get the material type information which this temperature rating type belongs to.
Public property | Name | Get name of temperature rating type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType
Autodesk.Revit.Elements Namespace


CorrectionFactors Property

TemperatureRatingType..::CorrectionFactors Property
CollapseAll image DropDown image

Get all correction factors defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CorrectionFactorSet CorrectionFactors{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CorrectionFactors As CorrectionFactorSet
Visual C++
public:
property CorrectionFactorSet^ CorrectionFactors {
    CorrectionFactorSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


InsulationTypes Property

TemperatureRatingType..::InsulationTypes Property
CollapseAll image DropDown image

Get all insulation types defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsulationTypeSet InsulationTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property InsulationTypes As InsulationTypeSet
Visual C++
public:
property InsulationTypeSet^ InsulationTypes {
    InsulationTypeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


IsInUse Property

TemperatureRatingType..::IsInUse Property
CollapseAll image DropDown image

Indicate whether the temperature rating type is in use.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInUse{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


MaterialType Property

TemperatureRatingType..::MaterialType Property
CollapseAll image DropDown image

Get the material type information which this temperature rating type belongs to.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialType MaterialType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MaterialType As WireMaterialType
Visual C++
public:
property WireMaterialType^ MaterialType {
    WireMaterialType^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


Name Property

TemperatureRatingType..::Name Property
CollapseAll image DropDown image

Get name of temperature rating type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::NotSupportedException | Set name can't be supported.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


Parameter Property

TemperatureRatingType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

TemperatureRatingType Class
TemperatureRatingType Members
Autodesk.Revit.Elements Namespace


WireSizes Property

TemperatureRatingType..::WireSizes Property
CollapseAll image DropDown image

Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSizeSet WireSizes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property WireSizes As WireSizeSet
Visual C++
public:
property WireSizeSet^ WireSizes {
    WireSizeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains TemperatureRating types.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B3161730-E08B-4dc8-9C1A-A9B6EF5A4B92")]
public class TemperatureRatingTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B3161730-E08B-4dc8-9C1A-A9B6EF5A4B92")> _
Public Class TemperatureRatingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B3161730-E08B-4dc8-9C1A-A9B6EF5A4B92")]
public ref class TemperatureRatingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::TemperatureRatingTypeSet

See Also

TemperatureRatingTypeSet Members
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingTypeSet
Visual Basic (Declaration)
Public Class TemperatureRatingTypeSet
Visual C++
public ref class TemperatureRatingTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TemperatureRatingTypeSetTemperatureRatingTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every TemperatureRating type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a TemperatureRating type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified TemperatureRating type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified TemperatureRating type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of TemperatureRating types that are in the set.

See Also

TemperatureRatingTypeSet
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TemperatureRatingTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingTypeSet ()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingTypeSet
Visual Basic (Declaration)
Public Class TemperatureRatingTypeSet
Visual C++
public ref class TemperatureRatingTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every TemperatureRating type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a TemperatureRating type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified TemperatureRating type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified TemperatureRating type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

TemperatureRatingTypeSet
Autodesk.Revit.Elements Namespace


Clear Method

TemperatureRatingTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every TemperatureRating type from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


Contains Method

TemperatureRatingTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a TemperatureRating type within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    TemperatureRatingType^ item
)

Parameters

item
TemperatureRatingType
The TemperatureRating type to be searched for.

Return Value

The Contains method returns True if the TemperatureRating type is within the set, otherwise False.

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

TemperatureRatingTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


Erase Method

TemperatureRatingTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified TemperatureRating type from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TemperatureRatingType _
) As Integer
Visual C++
public:
virtual int Erase (
    TemperatureRatingType^ item
)

Parameters

item
TemperatureRatingType
The TemperatureRating type to be erased.

Return Value

The number of TemperatureRating types that were erased from the set.

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

TemperatureRatingTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

TemperatureRatingTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


Insert Method

TemperatureRatingTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified TemperatureRating type into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    TemperatureRatingType^ item
)

Parameters

item
TemperatureRatingType
The TemperatureRating type to be inserted into the set.

Return Value

Returns whether the TemperatureRating type was inserted into the set.

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

TemperatureRatingTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

TemperatureRatingTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingTypeSet
Visual Basic (Declaration)
Public Class TemperatureRatingTypeSet
Visual C++
public ref class TemperatureRatingTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of TemperatureRating types that are in the set.

See Also

TemperatureRatingTypeSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

TemperatureRatingTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


Size Property

TemperatureRatingTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of TemperatureRating types that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a TemperatureRating type set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1C299F6C-6B36-4ee3-BD96-A4F8DA13364E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class TemperatureRatingTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("1C299F6C-6B36-4ee3-BD96-A4F8DA13364E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class TemperatureRatingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"1C299F6C-6B36-4ee3-BD96-A4F8DA13364E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TemperatureRatingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::TemperatureRatingTypeSetIterator

See Also

TemperatureRatingTypeSetIterator Members
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class TemperatureRatingTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TemperatureRatingTypeSetIterator
Visual C++
public ref class TemperatureRatingTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TemperatureRatingTypeSetIteratorTemperatureRatingTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TemperatureRatingTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class TemperatureRatingTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TemperatureRatingTypeSetIterator
Visual C++
public ref class TemperatureRatingTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

TemperatureRatingTypeSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

TemperatureRatingTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

TemperatureRatingTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

TemperatureRatingTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

TemperatureRatingTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.Elements Namespace


TemperatureRatingTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class TemperatureRatingTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TemperatureRatingTypeSetIterator
Visual C++
public ref class TemperatureRatingTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator
Autodesk.Revit.Elements Namespace


Current Property

TemperatureRatingTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.Elements Namespace


TextElement Class
See Also Members
CollapseAll image DropDown image

Represents the TextElment.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5AB5EA87-1218-429c-AF65-D6B88E275A41")]
public class TextElement : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5AB5EA87-1218-429c-AF65-D6B88E275A41")> _
Public Class TextElement _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5AB5EA87-1218-429c-AF65-D6B88E275A41")]
public ref class TextElement : public Element

Remarks

This class can be parent class of TextNote and other Text related classes.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::TextElement
Autodesk.Revit.Elements..::TextNote

See Also

TextElement Members
Autodesk.Revit.Elements Namespace


TextElement Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TextElement
Visual Basic (Declaration)
Public Class TextElement
Visual C++
public ref class TextElement

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TextElementTextElementNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | Get and set the content of the TextElement object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextElement
Autodesk.Revit.Elements Namespace


TextElement Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextElement ()

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


TextElement Properties
CollapseAll image DropDown image

Syntax

C#
public class TextElement
Visual Basic (Declaration)
Public Class TextElement
Visual C++
public ref class TextElement

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | Get and set the content of the TextElement object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextElement
Autodesk.Revit.Elements Namespace


Parameter Property

TextElement..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

TextElement Class
TextElement Members
Autodesk.Revit.Elements Namespace


Symbol Property

TextElement..::Symbol Property
CollapseAll image DropDown image

Get the type of the TextElement object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextElementType Symbol{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Symbol As TextElementType
Visual C++
public:
property TextElementType^ Symbol {
    TextElementType^ get ();
}

Remarks

The user can call this property to get the related type.

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


Text Property

TextElement..::Text Property
CollapseAll image DropDown image

Get and set the content of the TextElement object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Text{ get; set;}
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

The content of TextElement object can also be accessed through the Built-In parameter TEXT_TEXT.

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


TextNote Class
See Also Members
CollapseAll image DropDown image

Provides access to the TextNote object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9C1F90C9-4654-42e9-AEB3-575FF9A97F6B")]
public class TextNote : TextElement
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9C1F90C9-4654-42e9-AEB3-575FF9A97F6B")> _
Public Class TextNote _
    Inherits TextElement
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9C1F90C9-4654-42e9-AEB3-575FF9A97F6B")]
public ref class TextNote : public TextElement

Remarks

The user can create TextNote object and change the internal property as Leaders and so on.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::TextElement
Autodesk.Revit.Elements..::TextNote

See Also

TextNote Members
Autodesk.Revit.Elements Namespace


TextNote Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TextNote
Visual Basic (Declaration)
Public Class TextNote
Visual C++
public ref class TextNote

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TextNoteTextNoteNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddLeader | Add a leader for the current TextNote object and return the new leader.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveLeaders | Romove all the leaders for the current TextNote object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Coord | Access the position of the TextNote object.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leaders | Retrieves all the leaders belongs to the current TextNote object.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Public property | Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
Public property | TextNoteType | Access the type of the TextNote object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Width | Access the width of the TextNote object.

See Also

TextNote
Autodesk.Revit.Elements Namespace


TextNote Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNote ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


TextNote Methods
CollapseAll image DropDown image

Syntax

C#
public class TextNote
Visual Basic (Declaration)
Public Class TextNote
Visual C++
public ref class TextNote

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddLeader | Add a leader for the current TextNote object and return the new leader.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveLeaders | Romove all the leaders for the current TextNote object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

TextNote
Autodesk.Revit.Elements Namespace


AddLeader Method

TextNote..::AddLeader Method
CollapseAll image DropDown image

Add a leader for the current TextNote object and return the new leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Leader AddLeader(
    TextNoteLeaderTypes
)
Visual Basic (Declaration)
Public Function AddLeader ( _
     As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader (
    TextNoteLeaderTypes
)

Parameters

TextNoteLeaderTypes

Remarks

If the current leader type is not same with the input type, System::InvalidOperationException will be thrown.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


RemoveLeaders Method

TextNote..::RemoveLeaders Method
CollapseAll image DropDown image

Romove all the leaders for the current TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveLeaders()
Visual Basic (Declaration)
Public Sub RemoveLeaders
Visual C++
public:
void RemoveLeaders ()

Remarks

It is different to the method AddLeader, in which one Leader is added. Calling this method will remove all the leaders.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


TextNote Properties
CollapseAll image DropDown image

Syntax

C#
public class TextNote
Visual Basic (Declaration)
Public Class TextNote
Visual C++
public ref class TextNote

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Coord | Access the position of the TextNote object.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Leaders | Retrieves all the leaders belongs to the current TextNote object.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Public property | Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
Public property | TextNoteType | Access the type of the TextNote object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Width | Access the width of the TextNote object.

See Also

TextNote
Autodesk.Revit.Elements Namespace


Coord Property

TextNote..::Coord Property
CollapseAll image DropDown image

Access the position of the TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Coord{ get; set;}
Visual Basic (Declaration)
Public Property Coord As XYZ
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

With this method, the position of the TextNote object can be retrieved and changed.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Leaders Property

TextNote..::Leaders Property
CollapseAll image DropDown image

Retrieves all the leaders belongs to the current TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LeaderArray Leaders{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Leaders As LeaderArray
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Remarks

This property is ReadOnly.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Parameter Property

TextNote..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

TextNote Class
TextNote Members
Autodesk.Revit.Elements Namespace


TextNoteType Property

TextNote..::TextNoteType Property
CollapseAll image DropDown image

Access the type of the TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteType TextNoteType{ get; set;}
Visual Basic (Declaration)
Public Property TextNoteType As TextNoteType
Visual C++
public:
property TextNoteType^ TextNoteType {
    TextNoteType^ get ();
    void set (TextNoteType^ value);
}

Remarks

The type of the TextNote object can be retrieved or changed.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Width Property

TextNote..::Width Property
CollapseAll image DropDown image

Access the width of the TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Width{ get; set;}
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

With this method, the width of the TextNote object can be retrieved and changed. The set method will calculate the real width of the TextNote. If the requested width is less than the real width, the real width will be set instead of the requested width.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Truss Class
See Also Members
CollapseAll image DropDown image

Represents all kinds of Trusses.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5816BD1F-51E9-4f8e-BB9B-7139A6119AAF")]
public class Truss : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5816BD1F-51E9-4f8e-BB9B-7139A6119AAF")> _
Public Class Truss _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5816BD1F-51E9-4f8e-BB9B-7139A6119AAF")]
public ref class Truss : public Element

Remarks

The Truss object represents all the kinds of Trusses in Revit. The TrussType property is used to distinguish the type of the Truss. The Truss object is derived from the Element object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Truss

See Also

Truss Members
Autodesk.Revit.Elements Namespace


Truss Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Truss
Visual Basic (Declaration)
Public Class Truss
Visual C++
public ref class Truss

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TrussTrussNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
Public method | DetachTopChord | Detach the truss's top from a specified element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | Get all the truss curves.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Members | Get all the members of truss.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TrussType | Retrieve/set an object that represents the type of the truss.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Truss
Autodesk.Revit.Elements Namespace


Truss Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Truss()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Truss ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Truss Methods
CollapseAll image DropDown image

Syntax

C#
public class Truss
Visual Basic (Declaration)
Public Class Truss
Visual C++
public ref class Truss

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
Public method | DetachTopChord | Detach the truss's top from a specified element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Truss
Autodesk.Revit.Elements Namespace


AttachTopChord Method

Truss..::AttachTopChord Method
CollapseAll image DropDown image

Attach truss's top to a specified element,the element should be a roof or floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AttachTopChord(
    Element attachToElement,
    bool forceRemoveSketch
)
Visual Basic (Declaration)
Public Sub AttachTopChord ( _
    attachToElement As Element, _
    forceRemoveSketch As Boolean _
)
Visual C++
public:
void AttachTopChord (
    Element^ attachToElement,
    bool forceRemoveSketch
)

Parameters

attachToElement
Element
The element that the truss's top is going to attach.
forceRemoveSketch
Boolean
Whether detach the original sketch if there is one.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


DetachTopChord Method

Truss..::DetachTopChord Method
CollapseAll image DropDown image

Detach the truss's top from a specified element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void DetachTopChord()
Visual Basic (Declaration)
Public Sub DetachTopChord
Visual C++
public:
void DetachTopChord ()

See Also

Truss Class
Autodesk.Revit.Elements Namespace


GetTrussMemberInfo Method

Truss..::GetTrussMemberInfo Method
CollapseAll image DropDown image

Query if a given element is a member of a truss,its lock status and its usage,etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussMemberInfo GetTrussMemberInfo(
    ref ElementId elemId
)
Visual Basic (Declaration)
Public Function GetTrussMemberInfo ( _
    ByRef elemId As ElementId _
) As TrussMemberInfo
Visual C++
public:
TrussMemberInfo^ GetTrussMemberInfo (
    ElementId% elemId
)

Parameters

elemId
ElementId %
The querying element.

Return Value

A struct TrussMemberInfo that contains the quering element's host truss,whether lock to the truss,usage type,etc.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


RemoveProfile Method

Truss..::RemoveProfile Method
CollapseAll image DropDown image

Remove the profile of a truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveProfile()
Visual Basic (Declaration)
Public Sub RemoveProfile
Visual C++
public:
void RemoveProfile ()

See Also

Truss Class
Autodesk.Revit.Elements Namespace


SetProfile Method

Truss..::SetProfile Method
CollapseAll image DropDown image

Add or modify the profile of a truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetProfile(
    CurveArray topChords,
    CurveArray bottomChords
)
Visual Basic (Declaration)
Public Sub SetProfile ( _
    topChords As CurveArray, _
    bottomChords As CurveArray _
)
Visual C++
public:
void SetProfile (
    CurveArray^ topChords,
    CurveArray^ bottomChords
)

Parameters

topChords
CurveArray
The curves serving as top chords of the truss.
bottomChords
CurveArray
The curves serving as bottom chords of the truss.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


TogglePinMember Method

Truss..::TogglePinMember Method
CollapseAll image DropDown image

Pin/Unpin a truss member.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void TogglePinMember(
    ref ElementId elemId
)
Visual Basic (Declaration)
Public Sub TogglePinMember ( _
    ByRef elemId As ElementId _
)
Visual C++
public:
void TogglePinMember (
    ElementId% elemId
)

Parameters

elemId
ElementId %
The member element is going to pin/unpin.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Truss Properties
CollapseAll image DropDown image

Syntax

C#
public class Truss
Visual Basic (Declaration)
Public Class Truss
Visual C++
public ref class Truss

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | Get all the truss curves.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Members | Get all the members of truss.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TrussType | Retrieve/set an object that represents the type of the truss.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Truss
Autodesk.Revit.Elements Namespace


Curves Property

Truss..::Curves Property
CollapseAll image DropDown image

Get all the truss curves.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

The Curves property returns a CurveArray that contains all the truss curves.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Members Property

Truss..::Members Property
CollapseAll image DropDown image

Get all the members of truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Members{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Members As ElementIdSet
Visual C++
public:
property ElementIdSet^ Members {
    ElementIdSet^ get ();
}

Return Value

The Members property returns an ElementIdSet that contains all the member Ids of truss.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Parameter Property

Truss..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Truss Class
Truss Members
Autodesk.Revit.Elements Namespace


TrussType Property

Truss..::TrussType Property
CollapseAll image DropDown image

Retrieve/set an object that represents the type of the truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussType TrussType{ get; set;}
Visual Basic (Declaration)
Public Property TrussType As TrussType
Visual C++
public:
property TrussType^ TrussType {
    TrussType^ get ();
    void set (TrussType^ value);
}

See Also

Truss Class
Autodesk.Revit.Elements Namespace


View Class
See Also Members
CollapseAll image DropDown image

Base class for Revit Views.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1C66A293-1D20-452a-A366-D4DEE6824345")]
public class View : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1C66A293-1D20-452a-A366-D4DEE6824345")> _
Public Class View _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1C66A293-1D20-452a-A366-D4DEE6824345")]
public ref class View : public Element

Remarks

A View is an image produced from a Revit model. Views can be graphical (plans etc.) or textual (schedules etc.) Views keep track of Elements that can be seen in them.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::View3D
Autodesk.Revit.Elements..::ViewDrafting
Autodesk.Revit.Elements..::ViewSheet
Autodesk.Revit.Elements..::ViewSection
Autodesk.Revit.Elements..::ViewPlan

See Also

View Members
Autodesk.Revit.Elements Namespace


View Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class View
Visual Basic (Declaration)
Public Class View
Visual C++
public ref class View

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewViewNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view.
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view.
Public property | CropBoxActive | Active of the Crop Box/Region.
Public property | CropBoxVisible | Visibility of the Crop Box/Region.
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view.
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view.
Public property | GenLevel | The level which generate this View.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in inches).
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewName | The name of the view.
Public property | ViewType | The type of the view.

See Also

View
Autodesk.Revit.Elements Namespace


View Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
View ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

View Class
Autodesk.Revit.Elements Namespace


View Methods
CollapseAll image DropDown image

Syntax

C#
public class View
Visual Basic (Declaration)
Public Class View
Visual C++
public ref class View

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view.
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

View
Autodesk.Revit.Elements Namespace


ApplyTemplate Method

View..::ApplyTemplate Method
CollapseAll image DropDown image

Applies the template to this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ApplyTemplate(
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub ApplyTemplate ( _
    viewTemplate As View _
)
Visual C++
public:
void ApplyTemplate (
    View^ viewTemplate
)

Parameters

viewTemplate
View
View to be used as the template.

See Also

View Class
Autodesk.Revit.Elements Namespace


getVisibility Method

View..::getVisibility Method
CollapseAll image DropDown image

get category visible of this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool getVisibility(
    Category category
)
Visual Basic (Declaration)
Public Function getVisibility ( _
    category As Category _
) As Boolean
Visual C++
public:
bool getVisibility (
    Category^ category
)

Parameters

category
Category
Category to be check its visible in this view.

See Also

View Class
Autodesk.Revit.Elements Namespace


Print Method

View..::Print Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Print()() | Print this view with default print setting and default view template.
Public method | Print(Boolean) | Print this view with default print setting and default view template.
Public method | Print(View) | Print this view with default print setting and specialized view template.
Public method | Print(View, Boolean) | Print this view with default print setting and specialized view template.

See Also

View Class
View Members
Autodesk.Revit.Elements Namespace


Print Method

View..::Print Method
CollapseAll image DropDown image

Print this view with default print setting and default view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print()
Visual Basic (Declaration)
Public Sub Print
Visual C++
public:
void Print ()

Remarks

If the view can not be printed successfully then an exception will be thrown out. print this view with the current print settings.

See Also

View Class
Autodesk.Revit.Elements Namespace


Print Method (Boolean)

View..::Print Method (Boolean)
See Also
CollapseAll image DropDown image

Print this view with default print setting and default view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print (
    bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings
Boolean
If true, print the view with the current print setting ,otherwise with the print setting of the document.

Remarks

If the view can not be printed successfully then an exception will be thrown out.

See Also

View Class
Autodesk.Revit.Elements Namespace


Print Method (View)

View..::Print Method (View)
See Also
CollapseAll image DropDown image

Print this view with default print setting and specialized view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View _
)
Visual C++
public:
void Print (
    View^ viewTemplate
)

Parameters

viewTemplate
View
The view template which apply to the view.

Remarks

If the view can not be printed successfully then an exception will be thrown out. print this view with the current print settings.

See Also

View Class
Autodesk.Revit.Elements Namespace


Print Method (View, Boolean)

View..::Print Method (View, Boolean)
See Also
CollapseAll image DropDown image

Print this view with default print setting and specialized view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print (
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

viewTemplate
View
The view template which apply to the view.
useCurrentPrintSettings
Boolean
If true, print the view with the current print setting ,otherwise with the print setting of the document.

Remarks

If the view can not be printed successfully then an exception will be thrown out.

See Also

View Class
Autodesk.Revit.Elements Namespace


setVisibility Method

View..::setVisibility Method
CollapseAll image DropDown image

set category visible of this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void setVisibility(
    Category category,
    bool visible
)
Visual Basic (Declaration)
Public Sub setVisibility ( _
    category As Category, _
    visible As Boolean _
)
Visual C++
public:
void setVisibility (
    Category^ category,
    bool visible
)

Parameters

category
Category
Category to be set its visible in this view.
visible
Boolean
Set the Category to be visible or not in this view.

See Also

View Class
Autodesk.Revit.Elements Namespace


View Properties
CollapseAll image DropDown image

Syntax

C#
public class View
Visual Basic (Declaration)
Public Class View
Visual C++
public ref class View

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view.
Public property | CropBoxActive | Active of the Crop Box/Region.
Public property | CropBoxVisible | Visibility of the Crop Box/Region.
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view.
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view.
Public property | GenLevel | The level which generate this View.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in inches).
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewName | The name of the view.
Public property | ViewType | The type of the view.

See Also

View
Autodesk.Revit.Elements Namespace


CanBePrinted Property

View..::CanBePrinted Property
CollapseAll image DropDown image

Test whether the view can be printed.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CanBePrinted{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CanBePrinted As Boolean
Visual C++
public:
property bool CanBePrinted {
    bool get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


CropBox Property

View..::CropBox Property
CollapseAll image DropDown image

The crop box sets display bounds of the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxXYZ CropBox{ get; set;}
Visual Basic (Declaration)
Public Property CropBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ CropBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

The X direction of the box is right on screen; Y, up; Z, towards the user.

See Also

View Class
Autodesk.Revit.Elements Namespace


CropBoxActive Property

View..::CropBoxActive Property
CollapseAll image DropDown image

Active of the Crop Box/Region.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CropBoxActive{ get; set;}
Visual Basic (Declaration)
Public Property CropBoxActive As Boolean
Visual C++
public:
property bool CropBoxActive {
    bool get ();
    void set (bool value);
}

Remarks

This property set whether the crop region is usd to actually modify graphical appearance of elements in the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


CropBoxVisible Property

View..::CropBoxVisible Property
CollapseAll image DropDown image

Visibility of the Crop Box/Region.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CropBoxVisible{ get; set;}
Visual Basic (Declaration)
Public Property CropBoxVisible As Boolean
Visual C++
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}

Remarks

This property set whether the crop box is visible in the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


CutColorOverrideByElement Property

View..::CutColorOverrideByElement Property
CollapseAll image DropDown image

Override the cut lines' color by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color CutColorOverrideByElement[
    ElementIdSet ids
]{ get; set;}
Visual Basic (Declaration)
Public Property CutColorOverrideByElement ( _
    ids As ElementIdSet _
) As Color
Visual C++
public:
property Color^ CutColorOverrideByElement[ElementIdSet^ ids] {
    Color^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, Color^ value);
}

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be override.

Remarks

This property set the color of the element to override the graphics in the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


CutLinePatternOverrideByElement Property

View..::CutLinePatternOverrideByElement Property
CollapseAll image DropDown image

Override the cut lines' pattern by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinePattern CutLinePatternOverrideByElement[
    ElementIdSet ids
]{ get; set;}
Visual Basic (Declaration)
Public Property CutLinePatternOverrideByElement ( _
    ids As ElementIdSet _
) As LinePattern
Visual C++
public:
property LinePattern^ CutLinePatternOverrideByElement[ElementIdSet^ ids] {
    LinePattern^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, LinePattern^ value);
}

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be override.

Remarks

This property set the line pattern of the element to override the graphics in the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


CutLineWeightOverrideByElement Property

View..::CutLineWeightOverrideByElement Property
CollapseAll image DropDown image

Override the cut lines' weight by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int CutLineWeightOverrideByElement[
    ElementIdSet ids
]{ get; set;}
Visual Basic (Declaration)
Public Property CutLineWeightOverrideByElement ( _
    ids As ElementIdSet _
) As Integer
Visual C++
public:
property int CutLineWeightOverrideByElement[ElementIdSet^ ids] {
    int get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, int value);
}

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be override.

Remarks

This property set the line weight of the element to override the graphics in the view. The line weigh number should be less or equal 16 and greater or equal 1 or equal -1.

See Also

View Class
Autodesk.Revit.Elements Namespace


Elements Property

View..::Elements Property
CollapseAll image DropDown image

Set of all elements that will be drawn in the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet Elements{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementSet
Visual C++
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}

Remarks

Elements that belong to this set have graphics that may be visible in this view. Some elements may still be hidden, e.g., obscured by other elements.

See Also

View Class
Autodesk.Revit.Elements Namespace


GenLevel Property

View..::GenLevel Property
CollapseAll image DropDown image

The level which generate this View.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level GenLevel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GenLevel As Level
Visual C++
public:
property Level^ GenLevel {
    Level^ get ();
}

Remarks

This property retrieve the level which generate this View, such as Plan Views is generated by Level1 or Level2, etc. if this View is not generated by a level, here will return a null.

See Also

View Class
Autodesk.Revit.Elements Namespace


Origin Property

View..::Origin Property
CollapseAll image DropDown image

Returns the origin of the screen.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Origin{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


Outline Property

View..::Outline Property
CollapseAll image DropDown image

The bounds of the view in paper space (in inches).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxUV Outline{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Outline As BoundingBoxUV
Visual C++
public:
property BoundingBoxUV^ Outline {
    BoundingBoxUV^ get ();
}

Remarks

Returns all zeros for empty views.

See Also

View Class
Autodesk.Revit.Elements Namespace


Parameter Property

View..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

View Class
View Members
Autodesk.Revit.Elements Namespace


ProjColorOverrideByElement Property

View..::ProjColorOverrideByElement Property
CollapseAll image DropDown image

Override the projection lines' color by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Color ProjColorOverrideByElement[
    ElementIdSet ids
]{ get; set;}
Visual Basic (Declaration)
Public Property ProjColorOverrideByElement ( _
    ids As ElementIdSet _
) As Color
Visual C++
public:
property Color^ ProjColorOverrideByElement[ElementIdSet^ ids] {
    Color^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, Color^ value);
}

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be override.

Remarks

This property set the color of the element to override the graphics in the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


ProjLinePatternOverrideByElement Property

View..::ProjLinePatternOverrideByElement Property
CollapseAll image DropDown image

Override the projection lines' pattern by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinePattern ProjLinePatternOverrideByElement[
    ElementIdSet ids
]{ get; set;}
Visual Basic (Declaration)
Public Property ProjLinePatternOverrideByElement ( _
    ids As ElementIdSet _
) As LinePattern
Visual C++
public:
property LinePattern^ ProjLinePatternOverrideByElement[ElementIdSet^ ids] {
    LinePattern^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, LinePattern^ value);
}

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be override.

Remarks

This property set the line pattern of the element to override the graphics in the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


ProjLineWeightOverrideByElement Property

View..::ProjLineWeightOverrideByElement Property
CollapseAll image DropDown image

Override the projection lines' weight by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int ProjLineWeightOverrideByElement[
    ElementIdSet ids
]{ get; set;}
Visual Basic (Declaration)
Public Property ProjLineWeightOverrideByElement ( _
    ids As ElementIdSet _
) As Integer
Visual C++
public:
property int ProjLineWeightOverrideByElement[ElementIdSet^ ids] {
    int get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, int value);
}

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be override.

Remarks

This property set the line weight of the element to override the graphics in the view. The line weigh number should be less or equal 16 and greater or equal 1 or equal -1.

See Also

View Class
Autodesk.Revit.Elements Namespace


RightDirection Property

View..::RightDirection Property
CollapseAll image DropDown image

The direction towards the right side of the screen.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ RightDirection{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RightDirection As XYZ
Visual C++
public:
property XYZ^ RightDirection {
    XYZ^ get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


Scale Property

View..::Scale Property
CollapseAll image DropDown image

The scale of the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Scale{ get; set;}
Visual Basic (Declaration)
Public Property Scale As Integer
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

The scale is the ratio of true model size to paper size. This property is meaningless for perspective views.

See Also

View Class
Autodesk.Revit.Elements Namespace


UpDirection Property

View..::UpDirection Property
CollapseAll image DropDown image

The direction towards the top of the screen.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ UpDirection{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UpDirection As XYZ
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


ViewDirection Property

View..::ViewDirection Property
CollapseAll image DropDown image

The direction towards the viewer.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ ViewDirection{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ViewDirection As XYZ
Visual C++
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}

Remarks

In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.

See Also

View Class
Autodesk.Revit.Elements Namespace


ViewName Property

View..::ViewName Property
CollapseAll image DropDown image

The name of the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string ViewName{ get; set;}
Visual Basic (Declaration)
Public Property ViewName As String
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Remarks

If the view requires a unique name and the name passed to this property already exists, or if an empty string is passed, ArgumentException is thrown.

See Also

View Class
Autodesk.Revit.Elements Namespace


ViewType Property

View..::ViewType Property
CollapseAll image DropDown image

The type of the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewType ViewType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ViewType As ViewType
Visual C++
public:
property ViewType ViewType {
    ViewType get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


View3D Class
See Also Members
CollapseAll image DropDown image

A freely-oriented orthographic or perspective view of the model.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("333F83F4-8765-4967-BC29-865F9FA9E25F")]
public class View3D : View
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("333F83F4-8765-4967-BC29-865F9FA9E25F")> _
Public Class View3D _
    Inherits View
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"333F83F4-8765-4967-BC29-865F9FA9E25F")]
public ref class View3D : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::View3D

See Also

View3D Members
Autodesk.Revit.Elements Namespace


View3D Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class View3D
Visual Basic (Declaration)
Public Class View3D
Visual C++
public ref class View3D

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | View3DView3DNew |

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view. (Inherited from View.)
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | EyePosition | The position of the camera.
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPerspective | Identifies whether this is a perspective view.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SectionBox | The section box of the 3D view cuts the model by its bounds.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

View3D
Autodesk.Revit.Elements Namespace


View3D Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View3D()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
View3D ()

See Also

View3D Class
Autodesk.Revit.Elements Namespace


View3D Properties
CollapseAll image DropDown image

Syntax

C#
public class View3D
Visual Basic (Declaration)
Public Class View3D
Visual C++
public ref class View3D

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | EyePosition | The position of the camera.
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPerspective | Identifies whether this is a perspective view.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SectionBox | The section box of the 3D view cuts the model by its bounds.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

View3D
Autodesk.Revit.Elements Namespace


EyePosition Property

View3D..::EyePosition Property
CollapseAll image DropDown image

The position of the camera.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ EyePosition{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EyePosition As XYZ
Visual C++
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

See Also

View3D Class
Autodesk.Revit.Elements Namespace


IsPerspective Property

View3D..::IsPerspective Property
CollapseAll image DropDown image

Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsPerspective{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsPerspective As Boolean
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

Remarks

If this is false, the view is orthographic - the view direction is constant. In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The view direction property becomes less meaningful - it only describes the general orientation of the camera.

See Also

View3D Class
Autodesk.Revit.Elements Namespace


Parameter Property

View3D..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

View3D Class
View3D Members
Autodesk.Revit.Elements Namespace


SectionBox Property

View3D..::SectionBox Property
CollapseAll image DropDown image

The section box of the 3D view cuts the model by its bounds.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxXYZ SectionBox{ get; set;}
Visual Basic (Declaration)
Public Property SectionBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ SectionBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

To turn off section box, pass in null or a disabled box. Individual bound enabled flags are currently ignored.

See Also

View3D Class
Autodesk.Revit.Elements Namespace


ViewDrafting Class
See Also Members
CollapseAll image DropDown image

A drafting view allows the user to draw graphics without including them in the model.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("17A64F43-31FB-497f-A4FA-96FD08637344")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ViewDrafting : View
Visual Basic (Declaration)
<GuidAttribute("17A64F43-31FB-497f-A4FA-96FD08637344")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ViewDrafting _
    Inherits View
Visual C++
[GuidAttribute(L"17A64F43-31FB-497f-A4FA-96FD08637344")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ViewDrafting : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::ViewDrafting

See Also

ViewDrafting Members
Autodesk.Revit.Elements Namespace


ViewDrafting Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewDrafting
Visual Basic (Declaration)
Public Class ViewDrafting
Visual C++
public ref class ViewDrafting

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewDraftingViewDraftingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view. (Inherited from View.)
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

ViewDrafting
Autodesk.Revit.Elements Namespace


ViewDrafting Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewDrafting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewDrafting ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewDrafting Class
Autodesk.Revit.Elements Namespace


ViewPlan Class
See Also Members
CollapseAll image DropDown image

A plan represents for floor plan or ceiling plan.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A488E5D2-DB09-4e4e-B5DD-6BAD060781EA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ViewPlan : View
Visual Basic (Declaration)
<GuidAttribute("A488E5D2-DB09-4e4e-B5DD-6BAD060781EA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ViewPlan _
    Inherits View
Visual C++
[GuidAttribute(L"A488E5D2-DB09-4e4e-B5DD-6BAD060781EA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ViewPlan : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::ViewPlan

See Also

ViewPlan Members
Autodesk.Revit.Elements Namespace


ViewPlan Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewPlan
Visual Basic (Declaration)
Public Class ViewPlan
Visual C++
public ref class ViewPlan

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewPlanViewPlanNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view. (Inherited from View.)
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

ViewPlan
Autodesk.Revit.Elements Namespace


ViewPlan Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewPlan()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewPlan ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewPlan Class
Autodesk.Revit.Elements Namespace


ViewSection Class
See Also Members
CollapseAll image DropDown image

A section view cuts through the model to expose its interior structure.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A32F0033-46FB-43b2-B23C-0DDA606E8F60")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ViewSection : View
Visual Basic (Declaration)
<GuidAttribute("A32F0033-46FB-43b2-B23C-0DDA606E8F60")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ViewSection _
    Inherits View
Visual C++
[GuidAttribute(L"A32F0033-46FB-43b2-B23C-0DDA606E8F60")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ViewSection : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::ViewSection

See Also

ViewSection Members
Autodesk.Revit.Elements Namespace


ViewSection Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewSection
Visual Basic (Declaration)
Public Class ViewSection
Visual C++
public ref class ViewSection

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSectionViewSectionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view. (Inherited from View.)
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

ViewSection
Autodesk.Revit.Elements Namespace


ViewSection Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSection ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSection Class
Autodesk.Revit.Elements Namespace


ViewSet Class
See Also Members
CollapseAll image DropDown image

A set that contains views.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C29EFF06-92AD-462c-831A-158C74860861")]
public class ViewSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C29EFF06-92AD-462c-831A-158C74860861")> _
Public Class ViewSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C29EFF06-92AD-462c-831A-158C74860861")]
public ref class ViewSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ViewSet

See Also

ViewSet Members
Autodesk.Revit.Elements Namespace


ViewSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewSet
Visual Basic (Declaration)
Public Class ViewSet
Visual C++
public ref class ViewSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSetViewSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet
Autodesk.Revit.Elements Namespace


ViewSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSet ()

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ViewSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ViewSet
Visual Basic (Declaration)
Public Class ViewSet
Visual C++
public ref class ViewSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ViewSet
Autodesk.Revit.Elements Namespace


Clear Method

ViewSet..::Clear Method
CollapseAll image DropDown image

Removes every view from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Contains Method

ViewSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a view within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Contains (
    View^ item
)

Parameters

item
View
The view to be searched for.

Return Value

The Contains method returns True if the view is within the set, otherwise False.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

ViewSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Erase Method

ViewSet..::Erase Method
CollapseAll image DropDown image

Removes a specified view from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As View _
) As Integer
Visual C++
public:
virtual int Erase (
    View^ item
)

Parameters

item
View
The view to be erased.

Return Value

The number of views that were erased from the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

ViewSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ViewSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

ViewSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Insert Method

ViewSet..::Insert Method
CollapseAll image DropDown image

Insert the specified view into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Insert (
    View^ item
)

Parameters

item
View
The view to be inserted into the set.

Return Value

Returns whether the view was inserted into the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ViewSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

ViewSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ViewSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ViewSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ViewSet
Visual Basic (Declaration)
Public Class ViewSet
Visual C++
public ref class ViewSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

ViewSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Size Property

ViewSet..::Size Property
CollapseAll image DropDown image

Returns the number of views that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ViewSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a view set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("77B910A9-BF8D-47a1-9D3C-69F87B064959")]
public abstract class ViewSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("77B910A9-BF8D-47a1-9D3C-69F87B064959")> _
Public MustInherit Class ViewSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"77B910A9-BF8D-47a1-9D3C-69F87B064959")]
public ref class ViewSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ViewSetIterator

See Also

ViewSetIterator Members
Autodesk.Revit.Elements Namespace


ViewSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ViewSetIterator
Visual Basic (Declaration)
Public MustInherit Class ViewSetIterator
Visual C++
public ref class ViewSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSetIteratorViewSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator
Autodesk.Revit.Elements Namespace


ViewSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ViewSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ViewSetIterator
Visual Basic (Declaration)
Public MustInherit Class ViewSetIterator
Visual C++
public ref class ViewSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ViewSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

ViewSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

ViewSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ViewSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

ViewSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ViewSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ViewSetIterator
Visual Basic (Declaration)
Public MustInherit Class ViewSetIterator
Visual C++
public ref class ViewSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator
Autodesk.Revit.Elements Namespace


Current Property

ViewSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ViewSheet Class
See Also Members
CollapseAll image DropDown image

A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7F87AAA0-C777-4c55-894B-C19184F0C914")]
public class ViewSheet : View
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7F87AAA0-C777-4c55-894B-C19184F0C914")> _
Public Class ViewSheet _
    Inherits View
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7F87AAA0-C777-4c55-894B-C19184F0C914")]
public ref class ViewSheet : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::ViewSheet

See Also

ViewSheet Members
Autodesk.Revit.Elements Namespace


ViewSheet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewSheet
Visual Basic (Declaration)
Public Class ViewSheet
Visual C++
public ref class ViewSheet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSheetViewSheetNew |

Public Methods

 | Name | Description
Public method | AddView | Places view on the sheet at the given location.
Public method | ApplyTemplate | Applies the template to this view. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view. (Inherited from View.)
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SheetNumber | Sheet number is unique in the document.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | Views | Returns the set of all views on the sheet.
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

ViewSheet
Autodesk.Revit.Elements Namespace


ViewSheet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheet ()

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


ViewSheet Methods
CollapseAll image DropDown image

Syntax

C#
public class ViewSheet
Visual Basic (Declaration)
Public Class ViewSheet
Visual C++
public ref class ViewSheet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddView | Places view on the sheet at the given location.
Public method | ApplyTemplate | Applies the template to this view. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view. (Inherited from View.)
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ViewSheet
Autodesk.Revit.Elements Namespace


AddView Method

ViewSheet..::AddView Method
CollapseAll image DropDown image

Places view on the sheet at the given location.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddView(
    View newView,
    UV location
)
Visual Basic (Declaration)
Public Sub AddView ( _
    newView As View, _
    location As UV _
)
Visual C++
public:
void AddView (
    View^ newView,
    UV^ location
)

Parameters

newView
View
The view to be placed.
location
UV
Sheet coordinates (in inches) of the center of the view.

Remarks

Argument exception occurs if the view is of unappropriate type (e.g. ViewSheet) or the view is already placed on another sheet. The lower left corner of the sheet has coordinates [0,0]. Empty views are not placed on the sheet but no exception occurs.

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


Print Method

ViewSheet..::Print Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Print(Boolean) | Print this view with default print setting and default view template. (Inherited from View.)
Public method | Print(View) | Print this view with default print setting and specialized view template. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with default print setting and specialized view template. (Inherited from View.)

See Also

ViewSheet Class
ViewSheet Members
Autodesk.Revit.Elements Namespace


ViewSheet Properties
CollapseAll image DropDown image

Syntax

C#
public class ViewSheet
Visual Basic (Declaration)
Public Class ViewSheet
Visual C++
public ref class ViewSheet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SheetNumber | Sheet number is unique in the document.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | Views | Returns the set of all views on the sheet.
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

ViewSheet
Autodesk.Revit.Elements Namespace


Parameter Property

ViewSheet..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ViewSheet Class
ViewSheet Members
Autodesk.Revit.Elements Namespace


SheetNumber Property

ViewSheet..::SheetNumber Property
CollapseAll image DropDown image

Sheet number is unique in the document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string SheetNumber{ get; set;}
Visual Basic (Declaration)
Public Property SheetNumber As String
Visual C++
public:
property String^ SheetNumber {
    String^ get ();
    void set (String^ value);
}

Remarks

Exception occurs when trying to set the value that is not unique.

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


Views Property

ViewSheet..::Views Property
CollapseAll image DropDown image

Returns the set of all views on the sheet.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSet Views{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Views As ViewSet
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
}

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


ViewSheetSet Class
See Also Members
CollapseAll image DropDown image

Represents all kinds of ViewSheetSets.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FF113E87-C122-4d3b-81D0-848B459C030B")]
public class ViewSheetSet : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FF113E87-C122-4d3b-81D0-848B459C030B")> _
Public Class ViewSheetSet _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FF113E87-C122-4d3b-81D0-848B459C030B")]
public ref class ViewSheetSet : public Element

Remarks

The ViewSheetSet object is derived from the Element object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ViewSheetSet

See Also

ViewSheetSet Members
Autodesk.Revit.Elements Namespace


ViewSheetSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSet
Visual Basic (Declaration)
Public Class ViewSheetSet
Visual C++
public ref class ViewSheetSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSheetSetViewSheetSetNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns the Name of View Sheet set. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Views | Returns View Sheet set.

See Also

ViewSheetSet
Autodesk.Revit.Elements Namespace


ViewSheetSet Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheetSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSet ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


ViewSheetSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSet
Visual Basic (Declaration)
Public Class ViewSheetSet
Visual C++
public ref class ViewSheetSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns the Name of View Sheet set. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Views | Returns View Sheet set.

See Also

ViewSheetSet
Autodesk.Revit.Elements Namespace


Name Property

ViewSheetSet..::Name Property
CollapseAll image DropDown image

Returns the Name of View Sheet set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ get; set;}
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

Retrieve/set the Name of View Sheet set.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


Parameter Property

ViewSheetSet..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ViewSheetSet Class
ViewSheetSet Members
Autodesk.Revit.Elements Namespace


Views Property

ViewSheetSet..::Views Property
CollapseAll image DropDown image

Returns View Sheet set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSet Views{ get; set;}
Visual Basic (Declaration)
Public Property Views As ViewSet
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Remarks

Get or Set the Views of current ViewSheetSet.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


ViewSheetSets Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("63BC4B63-F9FA-4527-A0B7-510BE08F77C3")]
public class ViewSheetSets : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("63BC4B63-F9FA-4527-A0B7-510BE08F77C3")> _
Public Class ViewSheetSets _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"63BC4B63-F9FA-4527-A0B7-510BE08F77C3")]
public ref class ViewSheetSets : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ViewSheetSets

See Also

ViewSheetSets Members
Autodesk.Revit.Elements Namespace


ViewSheetSets Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSets
Visual Basic (Declaration)
Public Class ViewSheetSets
Visual C++
public ref class ViewSheetSets

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSheetSetsViewSheetSetsNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets
Autodesk.Revit.Elements Namespace


ViewSheetSets Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheetSets()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSets ()

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ViewSheetSets Methods
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSets
Visual Basic (Declaration)
Public Class ViewSheetSets
Visual C++
public ref class ViewSheetSets

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ViewSheetSets
Autodesk.Revit.Elements Namespace


Clear Method

ViewSheetSets..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Contains Method

ViewSheetSets..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Contains (
    ViewSheetSet^ item
)

Parameters

item
ViewSheetSet

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Dispose Method

ViewSheetSets..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Erase Method

ViewSheetSets..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ViewSheetSet _
) As Integer
Visual C++
public:
virtual int Erase (
    ViewSheetSet^ item
)

Parameters

item
ViewSheetSet

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

ViewSheetSets..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ViewSheetSetsIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

ViewSheetSets..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Insert Method

ViewSheetSets..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Insert (
    ViewSheetSet^ item
)

Parameters

item
ViewSheetSet

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ViewSheetSets..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

ViewSheetSets..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ViewSheetSetsIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ViewSheetSets Properties
CollapseAll image DropDown image

Syntax

C#
public class ViewSheetSets
Visual Basic (Declaration)
Public Class ViewSheetSets
Visual C++
public ref class ViewSheetSets

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets
Autodesk.Revit.Elements Namespace


IsEmpty Property

ViewSheetSets..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Size Property

ViewSheetSets..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6802D5F5-A382-483a-B484-BDF9685072D6")]
public abstract class ViewSheetSetsIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6802D5F5-A382-483a-B484-BDF9685072D6")> _
Public MustInherit Class ViewSheetSetsIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6802D5F5-A382-483a-B484-BDF9685072D6")]
public ref class ViewSheetSetsIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ViewSheetSetsIterator

See Also

ViewSheetSetsIterator Members
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ViewSheetSetsIterator
Visual Basic (Declaration)
Public MustInherit Class ViewSheetSetsIterator
Visual C++
public ref class ViewSheetSetsIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSheetSetsIteratorViewSheetSetsIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheetSetsIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSetsIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ViewSheetSetsIterator
Visual Basic (Declaration)
Public MustInherit Class ViewSheetSetsIterator
Visual C++
public ref class ViewSheetSetsIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ViewSheetSetsIterator
Autodesk.Revit.Elements Namespace


Dispose Method

ViewSheetSetsIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

ViewSheetSetsIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

ViewSheetSetsIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

ViewSheetSetsIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ViewSheetSetsIterator
Visual Basic (Declaration)
Public MustInherit Class ViewSheetSetsIterator
Visual C++
public ref class ViewSheetSetsIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator
Autodesk.Revit.Elements Namespace


Current Property

ViewSheetSetsIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


Wall Class
See Also Members
CollapseAll image DropDown image

Represents all of the different kinds of walls Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("52FF70F5-4985-43ed-B21D-584FC5584F6D")]
public class Wall : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("52FF70F5-4985-43ed-B21D-584FC5584F6D")> _
Public Class Wall _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"52FF70F5-4985-43ed-B21D-584FC5584F6D")]
public ref class Wall : public HostObject

Remarks

The wall object represents all the different kinds of wall in Revit. The WallType property is used to distinguish the type of the wall. The wall object is derived from the Element object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::Wall

See Also

Wall Members
Autodesk.Revit.Elements Namespace


Wall Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Wall
Visual Basic (Declaration)
Public Class Wall
Visual C++
public ref class Wall

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WallWallNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flip | The wall orientation will be flipped.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for this Wall.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Orientation | Provides access to the wall's external face's orientation.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WallType | Retrieve or change the type of the wall.
Public property | Width | Returns the overall thickness of the wall.

See Also

Wall
Autodesk.Revit.Elements Namespace


Wall Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Wall ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Wall Methods
CollapseAll image DropDown image

Syntax

C#
public class Wall
Visual Basic (Declaration)
Public Class Wall
Visual C++
public ref class Wall

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flip | The wall orientation will be flipped.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Wall
Autodesk.Revit.Elements Namespace


flip Method

Wall..::flip Method
CollapseAll image DropDown image

The wall orientation will be flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void flip()
Visual Basic (Declaration)
Public Sub flip
Visual C++
public:
void flip ()

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Wall Properties
CollapseAll image DropDown image

Syntax

C#
public class Wall
Visual Basic (Declaration)
Public Class Wall
Visual C++
public ref class Wall

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for this Wall.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Orientation | Provides access to the wall's external face's orientation.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WallType | Retrieve or change the type of the wall.
Public property | Width | Returns the overall thickness of the wall.

See Also

Wall
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

Wall..::AnalyticalModel Property
CollapseAll image DropDown image

Retrieves the structural analytical model for this Wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModel AnalyticalModel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the wall has a structural analytical model it is returned by this method, otherwise Nothing is returned. For Walls, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModelWall to be able to access details about the wall. This property will only function with the Autodesk Revit Structure product.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


CurtainGrid Property

Wall..::CurtainGrid Property
CollapseAll image DropDown image

Get the grid object of a curtain wall

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGrid CurtainGrid{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrid As CurtainGrid
Visual C++
public:
property CurtainGrid^ CurtainGrid {
    CurtainGrid^ get ();
}

Remarks

This property is readonly.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Flipped Property

Wall..::Flipped Property
CollapseAll image DropDown image

Property to test whether the wall orientation is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Flipped{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Flipped As Boolean
Visual C++
public:
property bool Flipped {
    bool get ();
}

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Orientation Property

Wall..::Orientation Property
CollapseAll image DropDown image

Provides access to the wall's external face's orientation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Orientation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Orientation As XYZ
Visual C++
public:
property XYZ^ Orientation {
    XYZ^ get ();
}

Remarks

First get the start point of the wall's CurveDriver, then project it to the external face side,and return the normal on this point as orientation.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Parameter Property

Wall..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Wall Class
Wall Members
Autodesk.Revit.Elements Namespace


StructuralUsage Property

Wall..::StructuralUsage Property
CollapseAll image DropDown image

The walls designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallUsage StructuralUsage{ get; set;}
Visual Basic (Declaration)
Public Property StructuralUsage As WallUsage
Visual C++
public:
property WallUsage StructuralUsage {
    WallUsage get ();
    void set (WallUsage value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


WallType Property

Wall..::WallType Property
CollapseAll image DropDown image

Retrieve or change the type of the wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallType WallType{ get; set;}
Visual Basic (Declaration)
Public Property WallType As WallType
Visual C++
public:
property WallType^ WallType {
    WallType^ get ();
    void set (WallType^ value);
}

Remarks

The WallType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a wall by setting it to a different wall type. All the wall types in the project can be found using the Document.WallTypes property.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Width Property

Wall..::Width Property
CollapseAll image DropDown image

Returns the overall thickness of the wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Width{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Wire Class
See Also Members
CollapseAll image DropDown image

An object to represent electrical wire in Revit MEP product.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6BF91B15-A25D-4a24-9ED8-EBED11DE8DA5")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Wire : HostObject
Visual Basic (Declaration)
<GuidAttribute("6BF91B15-A25D-4a24-9ED8-EBED11DE8DA5")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Wire _
    Inherits HostObject
Visual C++
[GuidAttribute(L"6BF91B15-A25D-4a24-9ED8-EBED11DE8DA5")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Wire : public HostObject

Remarks

Adding wiring to a project is optional. you can create circuits and maintain the information associated with them without adding wiring to the project.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::Wire

See Also

Wire Members
Autodesk.Revit.Elements Namespace


Wire Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Wire
Visual Basic (Declaration)
Public Class Wire
Visual C++
public ref class Wire

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireWireNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Get connector manager of the wire.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorNum | Get of set ground conductor number. Its default value is zero after created.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NeutralConductorNum | Get of set neutral conductor number. Its default value is zero after created.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire
Autodesk.Revit.Elements Namespace


Wire Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wire()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Wire ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Wire Class
Autodesk.Revit.Elements Namespace


Wire Properties
CollapseAll image DropDown image

Syntax

C#
public class Wire
Visual Basic (Declaration)
Public Class Wire
Visual C++
public ref class Wire

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Get connector manager of the wire.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorNum | Get of set ground conductor number. Its default value is zero after created.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | NeutralConductorNum | Get of set neutral conductor number. Its default value is zero after created.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire
Autodesk.Revit.Elements Namespace


ConnectorManager Property

Wire..::ConnectorManager Property
CollapseAll image DropDown image

Get connector manager of the wire.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorManager ConnectorManager{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

Wire Class
Autodesk.Revit.Elements Namespace


GroundConductorNum Property

Wire..::GroundConductorNum Property
CollapseAll image DropDown image

Get of set ground conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int GroundConductorNum{ get; set;}
Visual Basic (Declaration)
Public Property GroundConductorNum As Integer
Visual C++
public:
property int GroundConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.Elements Namespace


HotConductorNum Property

Wire..::HotConductorNum Property
CollapseAll image DropDown image

Get or set hot conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int HotConductorNum{ get; set;}
Visual Basic (Declaration)
Public Property HotConductorNum As Integer
Visual C++
public:
property int HotConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.Elements Namespace


NeutralConductorNum Property

Wire..::NeutralConductorNum Property
CollapseAll image DropDown image

Get of set neutral conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NeutralConductorNum{ get; set;}
Visual Basic (Declaration)
Public Property NeutralConductorNum As Integer
Visual C++
public:
property int NeutralConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.Elements Namespace


Parameter Property

Wire..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Wire Class
Wire Members
Autodesk.Revit.Elements Namespace


WiringType Property

Wire..::WiringType Property
CollapseAll image DropDown image

Get or set wiring type(Arc or chamfer) for the wire.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WiringType WiringType{ get; set;}
Visual Basic (Declaration)
Public Property WiringType As WiringType
Visual C++
public:
property WiringType WiringType {
    WiringType get ();
    void set (WiringType value);
}

See Also

Wire Class
Autodesk.Revit.Elements Namespace


WireMaterialType Class
See Also Members
CollapseAll image DropDown image

Represents electrical wire material type definition information of wire type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B21F609A-5889-4184-A288-1204706FE8C0")]
public class WireMaterialType : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B21F609A-5889-4184-A288-1204706FE8C0")> _
Public Class WireMaterialType _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B21F609A-5889-4184-A288-1204706FE8C0")]
public ref class WireMaterialType : public Element

Remarks

All the other properties of wire type are based on wire material type. Only the wire material types which are retrieved from ElectricalSetting can work well, so don't retrieve it from Revit project directly.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::WireMaterialType

See Also

WireMaterialType Members
Autodesk.Revit.Elements Namespace


WireMaterialType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireMaterialType
Visual Basic (Declaration)
Public Class WireMaterialType
Visual C++
public ref class WireMaterialType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireMaterialTypeWireMaterialTypeNew |

Public Methods

 | Name | Description
Public method | AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
Public method | AddTemperatureRatingType | Add a new temperature rating type into material type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
Public method | RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the wire material type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get name of wire material type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

WireMaterialType
Autodesk.Revit.Elements Namespace


WireMaterialType Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialType ()

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


WireMaterialType Methods
CollapseAll image DropDown image

Syntax

C#
public class WireMaterialType
Visual Basic (Declaration)
Public Class WireMaterialType
Visual C++
public ref class WireMaterialType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
Public method | AddTemperatureRatingType | Add a new temperature rating type into material type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
Public method | RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

WireMaterialType
Autodesk.Revit.Elements Namespace


AddGroundConductorSize Method

WireMaterialType..::AddGroundConductorSize Method
CollapseAll image DropDown image

Add new electrical ground conductor size type into this material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroundConductorSize AddGroundConductorSize(
    long ampacity,
    string size
)
Visual Basic (Declaration)
Public Function AddGroundConductorSize ( _
    ampacity As Long, _
    size As String _
) As GroundConductorSize
Visual C++
public:
GroundConductorSize^ AddGroundConductorSize (
    long long ampacity,
    String^ size
)

Parameters

ampacity
Int64
Ampacity of ground conductor size to be added.
size
String
Size of ground conductor size to be added.

Return Value

New added ground conductor size.

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


AddTemperatureRatingType Method

WireMaterialType..::AddTemperatureRatingType Method
CollapseAll image DropDown image

Add a new temperature rating type into material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TemperatureRatingType AddTemperatureRatingType(
    string name,
    TemperatureRatingType baseOn
)
Visual Basic (Declaration)
Public Function AddTemperatureRatingType ( _
    name As String, _
    baseOn As TemperatureRatingType _
) As TemperatureRatingType
Visual C++
public:
TemperatureRatingType^ AddTemperatureRatingType (
    String^ name,
    TemperatureRatingType^ baseOn
)

Parameters

name
String
Name of temperature type to be added.
baseOn
TemperatureRatingType
The new temperature rating will be created base on this existing temperature rating type.

Return Value

New constructed temperature rating type.

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


RemoveGroundConductorSize Method

WireMaterialType..::RemoveGroundConductorSize Method
CollapseAll image DropDown image

Remove an existing ground conductor size from this material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveGroundConductorSize(
    GroundConductorSize grdConductorSize
)
Visual Basic (Declaration)
Public Sub RemoveGroundConductorSize ( _
    grdConductorSize As GroundConductorSize _
)
Visual C++
public:
void RemoveGroundConductorSize (
    GroundConductorSize^ grdConductorSize
)

Parameters

grdConductorSize
GroundConductorSize
The ground size type to be removed.

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


RemoveTemperatureRatingType Method

WireMaterialType..::RemoveTemperatureRatingType Method
CollapseAll image DropDown image

Remove an existing temperature rating type from this material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveTemperatureRatingType(
    TemperatureRatingType temperatureRating
)
Visual Basic (Declaration)
Public Sub RemoveTemperatureRatingType ( _
    temperatureRating As TemperatureRatingType _
)
Visual C++
public:
void RemoveTemperatureRatingType (
    TemperatureRatingType^ temperatureRating
)

Parameters

temperatureRating
TemperatureRatingType
The temperature rating type to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | The last temperature rating type of project and any one used by a wire type can't be removed.

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


WireMaterialType Properties
CollapseAll image DropDown image

Syntax

C#
public class WireMaterialType
Visual Basic (Declaration)
Public Class WireMaterialType
Visual C++
public ref class WireMaterialType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the wire material type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get name of wire material type. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

WireMaterialType
Autodesk.Revit.Elements Namespace


GroundConductorSizes Property

WireMaterialType..::GroundConductorSizes Property
CollapseAll image DropDown image

Get all ground conductor size types defined in this wire material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroundConductorSizeSet GroundConductorSizes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GroundConductorSizes As GroundConductorSizeSet
Visual C++
public:
property GroundConductorSizeSet^ GroundConductorSizes {
    GroundConductorSizeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


IsInUse Property

WireMaterialType..::IsInUse Property
CollapseAll image DropDown image

Indicate whether the wire material type is in use.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInUse{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


Name Property

WireMaterialType..::Name Property
CollapseAll image DropDown image

Get name of wire material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::NotSupportedException | Set name can't be supported.

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


Parameter Property

WireMaterialType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

WireMaterialType Class
WireMaterialType Members
Autodesk.Revit.Elements Namespace


TemperatureRatings Property

WireMaterialType..::TemperatureRatings Property
CollapseAll image DropDown image

Get all temperature rating type definitions defined in this wire material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TemperatureRatingTypeSet TemperatureRatings{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TemperatureRatings As TemperatureRatingTypeSet
Visual C++
public:
property TemperatureRatingTypeSet^ TemperatureRatings {
    TemperatureRatingTypeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace


WireMaterialTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains wire material types.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D02920B3-6D68-48e9-B344-64077823D2AA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WireMaterialTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("D02920B3-6D68-48e9-B344-64077823D2AA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WireMaterialTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"D02920B3-6D68-48e9-B344-64077823D2AA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WireMaterialTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::WireMaterialTypeSet

See Also

WireMaterialTypeSet Members
Autodesk.Revit.Elements Namespace


WireMaterialTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireMaterialTypeSet
Visual Basic (Declaration)
Public Class WireMaterialTypeSet
Visual C++
public ref class WireMaterialTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireMaterialTypeSetWireMaterialTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every wire material type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire material type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire material type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire material type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire material types that are in the set.

See Also

WireMaterialTypeSet
Autodesk.Revit.Elements Namespace


WireMaterialTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialTypeSet ()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


WireMaterialTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class WireMaterialTypeSet
Visual Basic (Declaration)
Public Class WireMaterialTypeSet
Visual C++
public ref class WireMaterialTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every wire material type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire material type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire material type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire material type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireMaterialTypeSet
Autodesk.Revit.Elements Namespace


Clear Method

WireMaterialTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every wire material type from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


Contains Method

WireMaterialTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a wire material type within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    WireMaterialType^ item
)

Parameters

item
WireMaterialType
The wire material type to be searched for.

Return Value

The Contains method returns True if the wire material type is within the set, otherwise False.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

WireMaterialTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


Erase Method

WireMaterialTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified wire material type from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireMaterialType _
) As Integer
Visual C++
public:
virtual int Erase (
    WireMaterialType^ item
)

Parameters

item
WireMaterialType
The wire material type to be erased.

Return Value

The number of wire material types that were erased from the set.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

WireMaterialTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireMaterialTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

WireMaterialTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


Insert Method

WireMaterialTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified wire material type into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    WireMaterialType^ item
)

Parameters

item
WireMaterialType
The wire material type to be inserted into the set.

Return Value

Returns whether the wire material type was inserted into the set.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

WireMaterialTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

WireMaterialTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireMaterialTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


WireMaterialTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class WireMaterialTypeSet
Visual Basic (Declaration)
Public Class WireMaterialTypeSet
Visual C++
public ref class WireMaterialTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire material types that are in the set.

See Also

WireMaterialTypeSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

WireMaterialTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


Size Property

WireMaterialTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of wire material types that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireMaterialTypeSet Class
Autodesk.Revit.Elements Namespace


WireMaterialTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a wire material type set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2C956DE0-3559-4487-B2F9-438C27899B55")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class WireMaterialTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("2C956DE0-3559-4487-B2F9-438C27899B55")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class WireMaterialTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"2C956DE0-3559-4487-B2F9-438C27899B55")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WireMaterialTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::WireMaterialTypeSetIterator

See Also

WireMaterialTypeSetIterator Members
Autodesk.Revit.Elements Namespace


WireMaterialTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class WireMaterialTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireMaterialTypeSetIterator
Visual C++
public ref class WireMaterialTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireMaterialTypeSetIteratorWireMaterialTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator
Autodesk.Revit.Elements Namespace


WireMaterialTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.Elements Namespace


WireMaterialTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class WireMaterialTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireMaterialTypeSetIterator
Visual C++
public ref class WireMaterialTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireMaterialTypeSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

WireMaterialTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

WireMaterialTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

WireMaterialTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

WireMaterialTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.Elements Namespace


WireMaterialTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class WireMaterialTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireMaterialTypeSetIterator
Visual C++
public ref class WireMaterialTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator
Autodesk.Revit.Elements Namespace


Current Property

WireMaterialTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.Elements Namespace


WireSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B0AE8C91-97C5-4e58-B91D-2EEF842007ED")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WireSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("B0AE8C91-97C5-4e58-B91D-2EEF842007ED")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WireSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"B0AE8C91-97C5-4e58-B91D-2EEF842007ED")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WireSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::WireSet

See Also

WireSet Members
Autodesk.Revit.Elements Namespace


WireSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireSet
Visual Basic (Declaration)
Public Class WireSet
Visual C++
public ref class WireSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireSetWireSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

WireSet
Autodesk.Revit.Elements Namespace


WireSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSet ()

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


WireSet Methods
CollapseAll image DropDown image

Syntax

C#
public class WireSet
Visual Basic (Declaration)
Public Class WireSet
Visual C++
public ref class WireSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireSet
Autodesk.Revit.Elements Namespace


Clear Method

WireSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


Contains Method

WireSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Wire^ item
)

Parameters

item
Wire

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


Dispose Method

WireSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


Erase Method

WireSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Wire _
) As Integer
Visual C++
public:
virtual int Erase (
    Wire^ item
)

Parameters

item
Wire

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

WireSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

WireSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


Insert Method

WireSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Wire^ item
)

Parameters

item
Wire

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

WireSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

WireSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


WireSet Properties
CollapseAll image DropDown image

Syntax

C#
public class WireSet
Visual Basic (Declaration)
Public Class WireSet
Visual C++
public ref class WireSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

WireSet
Autodesk.Revit.Elements Namespace


IsEmpty Property

WireSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


Size Property

WireSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSet Class
Autodesk.Revit.Elements Namespace


WireSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DE659A00-B6F4-4aa3-8C9D-B5E348819F60")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class WireSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("DE659A00-B6F4-4aa3-8C9D-B5E348819F60")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class WireSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"DE659A00-B6F4-4aa3-8C9D-B5E348819F60")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WireSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::WireSetIterator

See Also

WireSetIterator Members
Autodesk.Revit.Elements Namespace


WireSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class WireSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireSetIterator
Visual C++
public ref class WireSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireSetIteratorWireSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator
Autodesk.Revit.Elements Namespace


WireSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireSetIterator Class
Autodesk.Revit.Elements Namespace


WireSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class WireSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireSetIterator
Visual C++
public ref class WireSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireSetIterator
Autodesk.Revit.Elements Namespace


Dispose Method

WireSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

WireSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSetIterator Class
Autodesk.Revit.Elements Namespace


ReleaseUnmanagedResources Method

WireSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

WireSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireSetIterator Class
Autodesk.Revit.Elements Namespace


WireSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class WireSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireSetIterator
Visual C++
public ref class WireSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator
Autodesk.Revit.Elements Namespace


Current Property

WireSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireSetIterator Class
Autodesk.Revit.Elements Namespace


Zone Class
See Also Members
CollapseAll image DropDown image

Provides access to the Zone Element in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("25CA3569-508C-46b7-ABF5-44F61209A3F3")]
public class Zone : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("25CA3569-508C-46b7-ABF5-44F61209A3F3")> _
Public Class Zone _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"25CA3569-508C-46b7-ABF5-44F61209A3F3")]
public ref class Zone : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object is only available in Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Zone

See Also

Zone Members
Autodesk.Revit.Elements Namespace


Zone Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Zone
Visual Basic (Declaration)
Public Class Zone
Visual C++
public ref class Zone

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ZoneZoneNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddSpaces | Add a set of existing spaces to Zone element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveSpaces | Remove a set of existing spaces to the current Zone element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Area | Get the Area of the Zone.
Public property | Boundary | Returns the boundary of the Zone.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
Public property | CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
Public property | CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
Public property | DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GrossArea | Get the Gross Area of the Zone.
Public property | GrossVolume | Get the Gross Volume of the Zone.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
Public property | HeatingSetPoint | Get or set the Heating Set Point of the Zone.
Public property | HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultZone | Reports whether this zone is default or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Zone. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
Public property | OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
Public property | OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Zone.
Public property | Phase | Get the Phase of the Zone.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ServiceType | Get or set the Service Type of the Zone.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Spaces | Get the Spaces of the Zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Volume | Get the Volume of the Zone.

See Also

Zone
Autodesk.Revit.Elements Namespace


Zone Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Zone()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Zone ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Zone Methods
CollapseAll image DropDown image

Syntax

C#
public class Zone
Visual Basic (Declaration)
Public Class Zone
Visual C++
public ref class Zone

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddSpaces | Add a set of existing spaces to Zone element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveSpaces | Remove a set of existing spaces to the current Zone element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Zone
Autodesk.Revit.Elements Namespace


AddSpaces Method

Zone..::AddSpaces Method
CollapseAll image DropDown image

Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AddSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function AddSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool AddSpaces (
    SpaceSet^ spaces
)

Parameters

spaces
SpaceSet
The spaces which want to add to zone element.

Return Value

If successful the current zone element will add a set of input spaces, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::InvalidOperationException | Thrown when the input spaces cannot be added to current zone element.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


RemoveSpaces Method

Zone..::RemoveSpaces Method
CollapseAll image DropDown image

Remove a set of existing spaces to the current Zone element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool RemoveSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function RemoveSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool RemoveSpaces (
    SpaceSet^ spaces
)

Parameters

spaces
SpaceSet
The spaces which want to delete from the current zone element.

Return Value

If successful the current zone element will remove a set of input spaces, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::InvalidOperationException | Thrown when the input spaces cannot be deleted from current zone element.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Zone Properties
CollapseAll image DropDown image

Syntax

C#
public class Zone
Visual Basic (Declaration)
Public Class Zone
Visual C++
public ref class Zone

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | Get the Area of the Zone.
Public property | Boundary | Returns the boundary of the Zone.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
Public property | CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
Public property | CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
Public property | DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GrossArea | Get the Gross Area of the Zone.
Public property | GrossVolume | Get the Gross Volume of the Zone.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
Public property | HeatingSetPoint | Get or set the Heating Set Point of the Zone.
Public property | HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultZone | Reports whether this zone is default or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Zone. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
Public property | OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
Public property | OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Zone.
Public property | Phase | Get the Phase of the Zone.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ServiceType | Get or set the Service Type of the Zone.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Spaces | Get the Spaces of the Zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Volume | Get the Volume of the Zone.

See Also

Zone
Autodesk.Revit.Elements Namespace


Area Property

Zone..::Area Property
CollapseAll image DropDown image

Get the Area of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Area{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Boundary Property

Zone..::Boundary Property
CollapseAll image DropDown image

Returns the boundary of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Boundary{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Boundary As CurveArray
Visual C++
public:
property CurveArray^ Boundary {
    CurveArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Zone. Each Zone may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Zone.BoundarySegment object for more details about the segments that make up the Zone topology.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CalculatedCoolingLoad Property

Zone..::CalculatedCoolingLoad Property
CollapseAll image DropDown image

Get the Calculated Cooling Load of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CalculatedCoolingLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CalculatedCoolingLoad As Double
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CalculatedHeatingLoad Property

Zone..::CalculatedHeatingLoad Property
CollapseAll image DropDown image

Get the Calculated Heating Load of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CalculatedHeatingLoad{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CalculatedHeatingLoad As Double
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CalculatedSupplyAirflow Property

Zone..::CalculatedSupplyAirflow Property
CollapseAll image DropDown image

Get the Calculated Supply Airflow of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CalculatedSupplyAirflow{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CalculatedSupplyAirflow As Double
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get the Calculated Supply Airflow (Unit: Airflow ) of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CoolingAirTemperature Property

Zone..::CoolingAirTemperature Property
CollapseAll image DropDown image

Get or set the Cooling Air Temperature of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CoolingAirTemperature{ get; set;}
Visual Basic (Declaration)
Public Property CoolingAirTemperature As Double
Visual C++
public:
property double CoolingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CoolingSetPoint Property

Zone..::CoolingSetPoint Property
CollapseAll image DropDown image

Get or set the Cooling Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CoolingSetPoint{ get; set;}
Visual Basic (Declaration)
Public Property CoolingSetPoint As Double
Visual C++
public:
property double CoolingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


DehumidificationSetPoint Property

Zone..::DehumidificationSetPoint Property
CollapseAll image DropDown image

Get or set the DeHumidification Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double DehumidificationSetPoint{ get; set;}
Visual Basic (Declaration)
Public Property DehumidificationSetPoint As Double
Visual C++
public:
property double DehumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the DeHumidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


GrossArea Property

Zone..::GrossArea Property
CollapseAll image DropDown image

Get the Gross Area of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double GrossArea{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GrossArea As Double
Visual C++
public:
property double GrossArea {
    double get ();
}

Remarks

This property is used to get the Gross Area of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


GrossVolume Property

Zone..::GrossVolume Property
CollapseAll image DropDown image

Get the Gross Volume of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double GrossVolume{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GrossVolume As Double
Visual C++
public:
property double GrossVolume {
    double get ();
}

Remarks

This property is used to get the Gross Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


HeatingAirTemperature Property

Zone..::HeatingAirTemperature Property
CollapseAll image DropDown image

Get or set the Heating Air Temperature of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HeatingAirTemperature{ get; set;}
Visual Basic (Declaration)
Public Property HeatingAirTemperature As Double
Visual C++
public:
property double HeatingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


HeatingSetPoint Property

Zone..::HeatingSetPoint Property
CollapseAll image DropDown image

Get or set the Heating Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HeatingSetPoint{ get; set;}
Visual Basic (Declaration)
Public Property HeatingSetPoint As Double
Visual C++
public:
property double HeatingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


HumidificationSetPoint Property

Zone..::HumidificationSetPoint Property
CollapseAll image DropDown image

Get or set the Humidification Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HumidificationSetPoint{ get; set;}
Visual Basic (Declaration)
Public Property HumidificationSetPoint As Double
Visual C++
public:
property double HumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Humidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


IsDefaultZone Property

Zone..::IsDefaultZone Property
CollapseAll image DropDown image

Reports whether this zone is default or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsDefaultZone{ get; set;}
Visual Basic (Declaration)
Public Property IsDefaultZone As Boolean
Visual C++
public:
property bool IsDefaultZone {
    bool get ();
    void set (bool value);
}

Remarks

This property can be used to set the current zone as the default zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Name Property

Zone..::Name Property
CollapseAll image DropDown image

Get or Set the Name of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


OutDoorAirPerArea Property

Zone..::OutDoorAirPerArea Property
CollapseAll image DropDown image

Get or set the OutDoor Air Per Area of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double OutDoorAirPerArea{ get; set;}
Visual Basic (Declaration)
Public Property OutDoorAirPerArea As Double
Visual C++
public:
property double OutDoorAirPerArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Out DoorAir Per Area of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


OutDoorAirPerPerson Property

Zone..::OutDoorAirPerPerson Property
CollapseAll image DropDown image

Get or set the OutDoor Air Per Person of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double OutDoorAirPerPerson{ get; set;}
Visual Basic (Declaration)
Public Property OutDoorAirPerPerson As Double
Visual C++
public:
property double OutDoorAirPerPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Out DoorAir Per Person of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


OutdoorAirRatePerAirChangesPerHour Property

Zone..::OutdoorAirRatePerAirChangesPerHour Property
CollapseAll image DropDown image

Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double OutdoorAirRatePerAirChangesPerHour{ get; set;}
Visual Basic (Declaration)
Public Property OutdoorAirRatePerAirChangesPerHour As Double
Visual C++
public:
property double OutdoorAirRatePerAirChangesPerHour {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Parameter Property

Zone..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Zone Class
Zone Members
Autodesk.Revit.Elements Namespace


Perimeter Property

Zone..::Perimeter Property
CollapseAll image DropDown image

Get the Perimeter of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Perimeter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Phase Property

Zone..::Phase Property
CollapseAll image DropDown image

Get the Phase of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Phase Phase{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Phase As Phase
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

Remarks

This property is used to get the Phase of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


ServiceType Property

Zone..::ServiceType Property
CollapseAll image DropDown image

Get or set the Service Type of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ServiceType ServiceType{ get; set;}
Visual Basic (Declaration)
Public Property ServiceType As ServiceType
Visual C++
public:
property ServiceType ServiceType {
    ServiceType get ();
    void set (ServiceType value);
}

Remarks

This property is used to get or set the Service Type of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Spaces Property

Zone..::Spaces Property
CollapseAll image DropDown image

Get the Spaces of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceSet Spaces{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Spaces As SpaceSet
Visual C++
public:
property SpaceSet^ Spaces {
    SpaceSet^ get ();
}

Remarks

This property is used to get the Spaces of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Volume Property

Zone..::Volume Property
CollapseAll image DropDown image

Get the Volume of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Volume{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Autodesk.Revit.Enums Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Enums
Visual Basic (Declaration)
Namespace Autodesk.Revit.Enums
Visual C++
namespace Autodesk.Revit.Enums

Enumerations

 | Enumeration | Description
Public enumeration | ACADVersion | An enumerate type listing available AutoCAD versions, into which a file may be exported.
Public enumeration | AreaElemType | An enumerate type to store type of AreaElement.
Public enumeration | AssetPropertyType | An enumerate to list AssetProperty Types in Revit.
Public enumeration | AssetType | An enumerate to list Asset Types in Revit.
Public enumeration | BeamSystemJustifyType | Describes the justify method of beamsystem.
Public enumeration | BoxPlacement | An enumerate type listing possible placement of a box (an object of rectangular shape.)
Public enumeration | ColorDepthType | An enumerate type listing all Color Depth types of Print Setting.
Public enumeration | CriteriaFilterType | An enumerate type listing all relationships between element's parameter value and the specified value. It is used in defining a criterion in element retrieval by criteria filter.
Public enumeration | CurtainGridAlignType | An enumerate to list CurtainGrid patterns.
Public enumeration | DecimalSymbolType | An enumerate type listing two types of the Decimal Symbol types that Autodesk Revit supports.
Public enumeration | DigitGroupingAmount | An enumerate type listing the types of the Digit Grouping Amount that Autodesk Revit supports.
Public enumeration | DigitGroupingSymbolType | An enumerate type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.
Public enumeration | DisplayUnit | Describes the type of Revit display unit, metric or imperial.
Public enumeration | DisplayUnitType | An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.
Public enumeration | EaveCutterType | An enumerate type to store type of EaveCutter.
Public enumeration | ExportUnit | An enumerate type listing possible target units for CAD Export.
Public enumeration | HiddenLineViewsType | An enumerate type listing all Hidden Line Views types of Print Setting.
Public enumeration | ImportColorMode | An enumerate type listing how colors are handled in an import process.
Public enumeration | ImportPlacement | An enumerate type listing possible placement modes for imported drawings.
Public enumeration | ImportUnit | An enumerate type listing possible target units for CAD Export.
Public enumeration | LeaderEndCondition | An enumerate type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.
Public enumeration | LineScaling | An enumerate type listing possible LineType scaling modes.
Public enumeration | MarginType | An enumerate type listing all Margin types of Print Setting.
Public enumeration | MaterialBehaviourType | An enumerate type listing all the material behavior type.
Public enumeration | PageOrientationType | An enumerate type listing all Page Orientation types of Print Setting.
Public enumeration | PaperPlacementType | An enumerate type listing all Paper Placement types of Print Setting.
Public enumeration | PostedErrorType | Describes the type of a posted error.
Public enumeration | PrintRange | An enumerate type listing all Print Range types of Print.
Public enumeration | PropOverrideMode | An enumerate type listing ways how overridden object styles get exported.
Public enumeration | RasterQualityType | An enumerate type listing all Raster Quality types of Print Setting.
Public enumeration | SetComparisonResult | An enumerate type listing all the relationship types between two sets of arbitrary nature.
Public enumeration | SlabShapeCreaseType | An enumerate type listing all Crease types of Slab Shape Edit.
Public enumeration | SlabShapeVertexType | An enumerate type listing all Vertex types of Slab Shape Edit.
Public enumeration | SolidGeometry | An enumerate type listing possible ways of exporting solids in 3D views.
Public enumeration | TagMode | An enumerate type listing Tag Mode when user adding tag that Autodesk Revit supports.
Public enumeration | TagOrientation | An enumerate type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.
Public enumeration | TextAlignFlags | An enumerate type listing all the Text align flags.
Public enumeration | TextAlignMask | An enumerate type listing all the Text align mask.
Public enumeration | TextElementBackground | An enumerate type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
Public enumeration | TextNoteLeaderStyles | An enumerate type listing all the Leader styles.
Public enumeration | TextNoteLeaderTypes | An enumerate type listing all the Leader types.
Public enumeration | TrussMemberType | Indicates the "kind" of a truss member.
Public enumeration | UnitGroup | An enumerate type listing Discipline of the Unit types that Autodesk Revit supports.
Public enumeration | UnitSymbolType | An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.
Public enumeration | UnitType | An enumerate type listing all the Unit types that Autodesk Revit supports.
Public enumeration | ViewType | An enumerate type listing available view types.)
Public enumeration | VirtualPrinterType | An enumerate to list Virtual Printer Types in Revit.
Public enumeration | ZoomType | An enumerate type listing all Zoom types of Print Setting.


ACADVersion Enumeration
CollapseAll image DropDown image

An enumerate type listing available AutoCAD versions, into which a file may be exported.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EA7663B8-3A5B-495d-97C8-4E82C71BB739")]
public enum ACADVersion
Visual Basic (Declaration)
<GuidAttribute("EA7663B8-3A5B-495d-97C8-4E82C71BB739")> _
Public Enumeration ACADVersion
Visual C++
[GuidAttribute(L"EA7663B8-3A5B-495d-97C8-4E82C71BB739")]
public enum class ACADVersion

Members

Member name | Description
Default | Revit Building application's default export format.
R2007 | AutoCAD 2007 file format.
R2004 | AutoCAD 2004 file format.
R2000 | AutoCAD 2000 file format.

See Also

Autodesk.Revit.Enums Namespace


AreaElemType Enumeration
CollapseAll image DropDown image

An enumerate type to store type of AreaElement.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DCECC415-7605-4C4A-9B1F-CB7AC320618E")]
public enum AreaElemType
Visual Basic (Declaration)
<GuidAttribute("DCECC415-7605-4C4A-9B1F-CB7AC320618E")> _
Public Enumeration AreaElemType
Visual C++
[GuidAttribute(L"DCECC415-7605-4C4A-9B1F-CB7AC320618E")]
public enum class AreaElemType

Members

Member name | Description
BOMAArea | Office Area Scheme - uses BOMA rules for space classification.
GrossArea | Gross Area Scheme - only 2 types of spaces (internal and external).

See Also

Autodesk.Revit.Enums Namespace


AssetPropertyType Enumeration
CollapseAll image DropDown image

An enumerate to list AssetProperty Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("83D31B2F-81AA-4572-A4CB-705D5573184D")]
public enum AssetPropertyType
Visual Basic (Declaration)
<GuidAttribute("83D31B2F-81AA-4572-A4CB-705D5573184D")> _
Public Enumeration AssetPropertyType
Visual C++
[GuidAttribute(L"83D31B2F-81AA-4572-A4CB-705D5573184D")]
public enum class AssetPropertyType

Members

Member name | Description
APT_Last |
APT_Reference |
APT_Asset |
APT_Distance |
APT_Time |
APT_String |
APT_Double44 | AssetPropertyDoubleMatrix44.
APT_DoubleArray4d | AssetPropertyDoubleArray4d.
APT_DoubleArray3d | AssetPropertyDoubleArray3d.
APT_DoubleArray2d | AssetPropertyDoubleArray2d.
APT_Double | AssetPropertyDouble.
APT_Float |
APT_Integer |
APT_Enum |
APT_Boolean |
APT_Properties |
APT_Unknown |

See Also

Autodesk.Revit.Enums Namespace


AssetType Enumeration
CollapseAll image DropDown image

An enumerate to list Asset Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8A067799-605F-4d00-8BD4-66A2EA10D7F9")]
public enum AssetType
Visual Basic (Declaration)
<GuidAttribute("8A067799-605F-4d00-8BD4-66A2EA10D7F9")> _
Public Enumeration AssetType
Visual C++
[GuidAttribute(L"8A067799-605F-4d00-8BD4-66A2EA10D7F9")]
public enum class AssetType

Members

Member name | Description
Appearance |

See Also

Autodesk.Revit.Enums Namespace


BeamSystemJustifyType Enumeration
CollapseAll image DropDown image

Describes the justify method of beamsystem.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CADB2D89-A262-4a19-AA1A-07DF7A9D021C")]
public enum BeamSystemJustifyType
Visual Basic (Declaration)
<GuidAttribute("CADB2D89-A262-4a19-AA1A-07DF7A9D021C")> _
Public Enumeration BeamSystemJustifyType
Visual C++
[GuidAttribute(L"CADB2D89-A262-4a19-AA1A-07DF7A9D021C")]
public enum class BeamSystemJustifyType

Members

Member name | Description
Beginning | Beginning.
Center | Center.
End | End.

See Also

Autodesk.Revit.Enums Namespace


BoxPlacement Enumeration
CollapseAll image DropDown image

An enumerate type listing possible placement of a box (an object of rectangular shape.)

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7B58277A-FD3F-47bf-A48F-47FADA20B9F8")]
public enum BoxPlacement
Visual Basic (Declaration)
<GuidAttribute("7B58277A-FD3F-47bf-A48F-47FADA20B9F8")> _
Public Enumeration BoxPlacement
Visual C++
[GuidAttribute(L"7B58277A-FD3F-47bf-A48F-47FADA20B9F8")]
public enum class BoxPlacement

Members

Member name | Description
BottomRight | Placement of a box by its bottom right corner.
TopLeft | Placement of a box by its top left corner.
Center | Placement of a box by its center point.
BottomLeft | Placement of a box by its bottom left corner.
TopRight | Placement of a box by its top right corner.

See Also

Autodesk.Revit.Enums Namespace


ColorDepthType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Color Depth types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("88A786FE-B87D-41f9-9509-0C91629F5190")]
public enum ColorDepthType
Visual Basic (Declaration)
<GuidAttribute("88A786FE-B87D-41f9-9509-0C91629F5190")> _
Public Enumeration ColorDepthType
Visual C++
[GuidAttribute(L"88A786FE-B87D-41f9-9509-0C91629F5190")]
public enum class ColorDepthType

Members

Member name | Description
Color | The type of Color Depth is Color.
GrayScale | The type of Color Depth is Gray Scale.
BlackLine | The type of Color Depth is Black Line.

See Also

Autodesk.Revit.Enums Namespace


CriteriaFilterType Enumeration
CollapseAll image DropDown image

An enumerate type listing all relationships between element's parameter value and the specified value. It is used in defining a criterion in element retrieval by criteria filter.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("BAD4BC1C-0B8D-4456-9B51-5E27418EA5ED")]
public enum CriteriaFilterType
Visual Basic (Declaration)
<GuidAttribute("BAD4BC1C-0B8D-4456-9B51-5E27418EA5ED")> _
Public Enumeration CriteriaFilterType
Visual C++
[GuidAttribute(L"BAD4BC1C-0B8D-4456-9B51-5E27418EA5ED")]
public enum class CriteriaFilterType

Members

Member name | Description
Contains | The element's parameter value contains the specified value.
DoesNotEndWith | The element's parameter value doesn't end with specified value.
EndsWith | The element's parameter value ends with the specified value.
DoesNotBeginWith | The element's parameter value doesn't begin with specified value.
BeginsWith | The element's parameter value begins with the specified value.
DoesNotContain | The element's parameter value doesn't contain the specified value.
LessThanOrEqual | The element's parameter value is less than or equal to the specified value.
LessThan | The element's parameter value is less than the specified value.
GreaterThanOrEqual | The element's parameter value is greater than or equal to the specified value.
GreaterThan | The element's parameter value is greater than the specified value.
NotEqual | The element's parameter value is not equal to the specified value.
Equal | The element's parameter value is equal to the specified value.
HasParam | The element has parameter.
Invalid | Invalid filter type.

See Also

Autodesk.Revit.Enums Namespace


CurtainGridAlignType Enumeration
CollapseAll image DropDown image

An enumerate to list CurtainGrid patterns.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("696B2EBC-38A7-4053-922D-F2C618097529")]
public enum CurtainGridAlignType
Visual Basic (Declaration)
<GuidAttribute("696B2EBC-38A7-4053-922D-F2C618097529")> _
Public Enumeration CurtainGridAlignType
Visual C++
[GuidAttribute(L"696B2EBC-38A7-4053-922D-F2C618097529")]
public enum class CurtainGridAlignType

Members

Member name | Description
Center | Center pattern of CurtainGrid.
Beginning | Beginning pattern of CurtainGrid.
End | End pattern of CurtainGrid.
NoJustify | NoJustify.

See Also

Autodesk.Revit.Enums Namespace


DecimalSymbolType Enumeration
CollapseAll image DropDown image

An enumerate type listing two types of the Decimal Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("57492B7B-E387-4381-B36B-734C5326B487")]
public enum DecimalSymbolType
Visual Basic (Declaration)
<GuidAttribute("57492B7B-E387-4381-B36B-734C5326B487")> _
Public Enumeration DecimalSymbolType
Visual C++
[GuidAttribute(L"57492B7B-E387-4381-B36B-734C5326B487")]
public enum class DecimalSymbolType

Members

Member name | Description
DST_COMMA |
DST_DOT |

See Also

Autodesk.Revit.Enums Namespace


DigitGroupingAmount Enumeration
CollapseAll image DropDown image

An enumerate type listing the types of the Digit Grouping Amount that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("02947C05-FE56-4a11-979A-8ED74B60E478")]
public enum DigitGroupingAmount
Visual Basic (Declaration)
<GuidAttribute("02947C05-FE56-4a11-979A-8ED74B60E478")> _
Public Enumeration DigitGroupingAmount
Visual C++
[GuidAttribute(L"02947C05-FE56-4a11-979A-8ED74B60E478")]
public enum class DigitGroupingAmount

Members

Member name | Description
DGA_THREE |
DGA_TWO |

See Also

Autodesk.Revit.Enums Namespace


DigitGroupingSymbolType Enumeration
CollapseAll image DropDown image

An enumerate type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("85F626F6-A66E-4617-9BFE-3A6CA09243D9")]
public enum DigitGroupingSymbolType
Visual Basic (Declaration)
<GuidAttribute("85F626F6-A66E-4617-9BFE-3A6CA09243D9")> _
Public Enumeration DigitGroupingSymbolType
Visual C++
[GuidAttribute(L"85F626F6-A66E-4617-9BFE-3A6CA09243D9")]
public enum class DigitGroupingSymbolType

Members

Member name | Description
DGST_TICK |
DGST_SPACE |
DGST_COMMA |
DGST_DOT |

See Also

Autodesk.Revit.Enums Namespace


DisplayUnit Enumeration
CollapseAll image DropDown image

Describes the type of Revit display unit, metric or imperial.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1C405C89-D711-4c2a-AF53-18CF09CCE6BE")]
public enum DisplayUnit
Visual Basic (Declaration)
<GuidAttribute("1C405C89-D711-4c2a-AF53-18CF09CCE6BE")> _
Public Enumeration DisplayUnit
Visual C++
[GuidAttribute(L"1C405C89-D711-4c2a-AF53-18CF09CCE6BE")]
public enum class DisplayUnit

Members

Member name | Description
IMPERIAL |
METRIC |

See Also

Autodesk.Revit.Enums Namespace


DisplayUnitType Enumeration
CollapseAll image DropDown image

An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("47FD6BE5-8CF8-4ec3-8E51-821150148FC7")]
public enum DisplayUnitType
Visual Basic (Declaration)
<GuidAttribute("47FD6BE5-8CF8-4ec3-8E51-821150148FC7")> _
Public Enumeration DisplayUnitType
Visual C++
[GuidAttribute(L"47FD6BE5-8CF8-4ec3-8E51-821150148FC7")]
public enum class DisplayUnitType

Members

Member name | Description
DUT_SQUARE_FEET_PER_THOUSAND_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_LUMENS_PER_WATT |
DUT_CURRENCY |
DUT_SQUARE_METERS_PER_KILOWATTS |
DUT_SQUARE_FEET_PER_TON_OF_REFRIGERATION |
DUT_LITERS_PER_SECOND_KILOWATTS |
DUT_CUBIC_FEET_PER_MINUTE_TON_OF_REFRIGERATION |
DUT_LITERS_PER_SECOND_CUBIC_METER |
DUT_CUBIC_FEET_PER_MINUTE_CUBIC_FOOT |
DUT_TON_OF_REFRIGERATION |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_CUBIC_FOOT |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT |
DUT_WATTS_PER_CUBIC_METER |
DUT_WATTS_PER_CUBIC_FOOT |
DUT_RISE_OVER_MMS |
DUT_RISE_OVER_FOOT |
DUT_RISE_OVER_INCHES |
DUT_SLOPE_DEGREES |
DUT_RATIO_12 |
DUT_RATIO_10 |
DUT_LITERS_PER_SECOND_SQUARE_METER |
DUT_CUBIC_FEET_PER_MINUTE_SQUARE_FOOT |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT_FAHRENHEIT |
DUT_WATTS_PER_SQUARE_METER_KELVIN |
DUT_KILONEWTON_METERS_PER_DEGREE_PER_METER |
DUT_KIP_FEET_PER_DEGREE_PER_FOOT |
DUT_KILONEWTON_METERS_PER_DEGREE |
DUT_KIP_FEET_PER_DEGREE |
DUT_KIPS_PER_CUBIC_FOOT |
DUT_KIPS_PER_INCH |
DUT_POUNDS_MASS_PER_FOOT_HOUR |
DUT_POUND_FORCE_FEET_PER_FOOT |
DUT_TONNE_FORCE_METERS_PER_METER |
DUT_KILOGRAM_FORCE_METERS_PER_METER |
DUT_KIP_FEET_PER_FOOT |
DUT_MEGANEWTON_METERS_PER_METER |
DUT_KILONEWTON_METERS_PER_METER |
DUT_DECANEWTON_METERS_PER_METER |
DUT_NEWTON_METERS_PER_METER |
DUT_INV_CELSIUS |
DUT_INV_FAHRENHEIT |
DUT_KIPS_PER_CUBIC_INCH |
DUT_POUNDS_FORCE_PER_CUBIC_FOOT |
DUT_KILONEWTONS_PER_CUBIC_METER |
DUT_KIPS_PER_SQUARE_INCH |
DUT_FEET_PER_SECOND |
DUT_CENTIPOISES |
DUT_POUNDS_MASS_PER_FOOT_SECOND |
DUT_PASCAL_SECONDS |
DUT_FEET_OF_WATER |
DUT_FEET_OF_WATER_PER_100FT |
DUT_INV_KIPS |
DUT_INV_KILONEWTONS |
DUT_CUBIC_FEET_PER_KIP |
DUT_CUBIC_METERS_PER_KILONEWTON |
DUT_SQUARE_FEET_PER_KIP |
DUT_SQUARE_METERS_PER_KILONEWTON |
DUT_FEET_PER_KIP |
DUT_METERS_PER_KILONEWTON |
DUT_POUND_FORCE_FEET |
DUT_TONNE_FORCE_METERS |
DUT_KILOGRAM_FORCE_METERS |
DUT_KIP_FEET |
DUT_MEGANEWTON_METERS |
DUT_KILONEWTON_METERS |
DUT_DECANEWTON_METERS |
DUT_NEWTON_METERS |
DUT_POUNDS_FORCE_PER_SQUARE_FOOT |
DUT_TONNES_FORCE_PER_SQUARE_METER |
DUT_KILOGRAMS_FORCE_PER_SQUARE_METER |
DUT_KIPS_PER_SQUARE_FOOT |
DUT_MEGANEWTONS_PER_SQUARE_METER |
DUT_KILONEWTONS_PER_SQUARE_METER |
DUT_DECANEWTONS_PER_SQUARE_METER |
DUT_NEWTONS_PER_SQUARE_METER |
DUT_POUNDS_FORCE_PER_FOOT |
DUT_TONNES_FORCE_PER_METER |
DUT_KILOGRAMS_FORCE_PER_METER |
DUT_KIPS_PER_FOOT |
DUT_MEGANEWTONS_PER_METER |
DUT_KILONEWTONS_PER_METER |
DUT_DECANEWTONS_PER_METER |
DUT_NEWTONS_PER_METER |
DUT_POUNDS_FORCE |
DUT_TONNES_FORCE |
DUT_KILOGRAMS_FORCE |
DUT_KIPS |
DUT_MEGANEWTONS |
DUT_KILONEWTONS |
DUT_DECANEWTONS |
DUT_NEWTONS |
DUT_HORSEPOWER |
DUT_KILOVOLT_AMPERES |
DUT_VOLT_AMPERES |
DUT_LUMENS |
DUT_CANDLEPOWER |
DUT_CANDELAS |
DUT_CANDELAS_PER_SQUARE_METER |
DUT_FOOTLAMBERTS |
DUT_FOOTCANDLES |
DUT_LUX |
DUT_CYCLES_PER_SECOND |
DUT_HERTZ |
DUT_MILLIVOLTS |
DUT_KILOVOLTS |
DUT_VOLTS |
DUT_MILLIAMPERES |
DUT_KILOAMPERES |
DUT_AMPERES |
DUT_GALLONS_US_PER_HOUR |
DUT_GALLONS_US_PER_MINUTE |
DUT_CUBIC_METERS_PER_HOUR |
DUT_CUBIC_METERS_PER_SECOND |
DUT_LITERS_PER_SECOND |
DUT_CUBIC_FEET_PER_MINUTE |
DUT_CENTIMETERS_PER_MINUTE |
DUT_METERS_PER_SECOND |
DUT_FEET_PER_MINUTE |
DUT_RANKINE |
DUT_KELVIN |
DUT_CELSIUS |
DUT_FAHRENHEIT |
DUT_BARS |
DUT_ATMOSPHERES |
DUT_MILLIMETERS_OF_MERCURY |
DUT_INCHES_OF_MERCURY |
DUT_POUNDS_FORCE_PER_SQUARE_INCH |
DUT_MEGAPASCALS |
DUT_KILOPASCALS |
DUT_PASCALS |
DUT_INCHES_OF_WATER |
DUT_WATTS_PER_SQUARE_METER |
DUT_WATTS_PER_SQUARE_FOOT |
DUT_KILOCALORIES_PER_SECOND |
DUT_CALORIES_PER_SECOND |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_BRITISH_THERMAL_UNITS_PER_SECOND |
DUT_KILOWATTS |
DUT_WATTS |
DUT_PASCALS_PER_METER |
DUT_INCHES_OF_WATER_PER_100FT |
DUT_THERMS |
DUT_KILOWATT_HOURS |
DUT_JOULES |
DUT_KILOCALORIES |
DUT_CALORIES |
DUT_BRITISH_THERMAL_UNITS |
DUT_POUNDS_MASS_PER_CUBIC_INCH |
DUT_POUNDS_MASS_PER_CUBIC_FOOT |
DUT_KILOGRAMS_PER_CUBIC_METER |
DUT_PERCENTAGE |
DUT_FIXED |
DUT_GENERAL |
DUT_DEGREES_AND_MINUTES |
DUT_DECIMAL_DEGREES |
DUT_GALLONS_US |
DUT_LITERS |
DUT_CUBIC_MILLIMETERS |
DUT_CUBIC_CENTIMETERS |
DUT_CUBIC_METERS |
DUT_CUBIC_INCHES |
DUT_CUBIC_FEET |
DUT_CUBIC_YARDS |
DUT_HECTARES |
DUT_ACRES |
DUT_SQUARE_MILLIMETERS |
DUT_SQUARE_CENTIMETERS |
DUT_SQUARE_METERS |
DUT_SQUARE_INCHES |
DUT_SQUARE_FEET |
DUT_METERS_CENTIMETERS |
DUT_DECIMAL_INCHES |
DUT_FRACTIONAL_INCHES |
DUT_FEET_FRACTIONAL_INCHES |
DUT_DECIMAL_FEET |
DUT_MILLIMETERS |
DUT_CENTIMETERS |
DUT_METERS |

See Also

Autodesk.Revit.Enums Namespace


EaveCutterType Enumeration
CollapseAll image DropDown image

An enumerate type to store type of EaveCutter.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6C5CB7F2-873D-4ba5-8C8B-B6A6384B6B06")]
public enum EaveCutterType
Visual Basic (Declaration)
<GuidAttribute("6C5CB7F2-873D-4ba5-8C8B-B6A6384B6B06")> _
Public Enumeration EaveCutterType
Visual C++
[GuidAttribute(L"6C5CB7F2-873D-4ba5-8C8B-B6A6384B6B06")]
public enum class EaveCutterType

Members

Member name | Description
TwoCutSquare | Two Cut Square type of Eave.
TwoCutPlumb | Two Cut Plumb type of Eave.
PlumbCut | Plumb Cut type of Eave.

See Also

Autodesk.Revit.Enums Namespace


ExportUnit Enumeration
CollapseAll image DropDown image

An enumerate type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B282C4EE-5552-4bb4-89CB-B8EFC68668C8")]
public enum ExportUnit
Visual Basic (Declaration)
<GuidAttribute("B282C4EE-5552-4bb4-89CB-B8EFC68668C8")> _
Public Enumeration ExportUnit
Visual C++
[GuidAttribute(L"B282C4EE-5552-4bb4-89CB-B8EFC68668C8")]
public enum class ExportUnit

Members

Member name | Description
Default | Default export unit. Depends on Revit's current units.
Meter | Meters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.

See Also

Autodesk.Revit.Enums Namespace


HiddenLineViewsType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Hidden Line Views types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("548EBA65-0644-4c58-B4E2-4F39ACB869B2")]
public enum HiddenLineViewsType
Visual Basic (Declaration)
<GuidAttribute("548EBA65-0644-4c58-B4E2-4F39ACB869B2")> _
Public Enumeration HiddenLineViewsType
Visual C++
[GuidAttribute(L"548EBA65-0644-4c58-B4E2-4F39ACB869B2")]
public enum class HiddenLineViewsType

Members

Member name | Description
RasterProcessing | The type of Hidden Line Views is Raster Processing.
VectorProcessing | The type of Hidden Line Views is Vector Processing (fast).

See Also

Autodesk.Revit.Enums Namespace


ImportColorMode Enumeration
CollapseAll image DropDown image

An enumerate type listing how colors are handled in an import process.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F2B76C24-84BD-4c7d-8F6E-F943C66A3998")]
public enum ImportColorMode
Visual Basic (Declaration)
<GuidAttribute("F2B76C24-84BD-4c7d-8F6E-F943C66A3998")> _
Public Enumeration ImportColorMode
Visual C++
[GuidAttribute(L"F2B76C24-84BD-4c7d-8F6E-F943C66A3998")]
public enum class ImportColorMode

Members

Member name | Description
BlackAndWhite | Colors in the imported drawing are converted to Black and White.
Inverted | Colors in the imported drawing are inverted.
Preserved | Colors in the imported drawing are preserved.

See Also

Autodesk.Revit.Enums Namespace


ImportPlacement Enumeration
CollapseAll image DropDown image

An enumerate type listing possible placement modes for imported drawings.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7EB27CA8-E0CF-49e9-AEF2-6B914BC6F9D0")]
public enum ImportPlacement
Visual Basic (Declaration)
<GuidAttribute("7EB27CA8-E0CF-49e9-AEF2-6B914BC6F9D0")> _
Public Enumeration ImportPlacement
Visual C++
[GuidAttribute(L"7EB27CA8-E0CF-49e9-AEF2-6B914BC6F9D0")]
public enum class ImportPlacement

Members

Member name | Description
Shared | Placement with respect to the shared coordinates.
Centered | Placement at the Center.
Origin | Placement at the Origin.

See Also

Autodesk.Revit.Enums Namespace


ImportUnit Enumeration
CollapseAll image DropDown image

An enumerate type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7BC6080E-27B7-43db-B04C-9F7C76D4AE47")]
public enum ImportUnit
Visual Basic (Declaration)
<GuidAttribute("7BC6080E-27B7-43db-B04C-9F7C76D4AE47")> _
Public Enumeration ImportUnit
Visual C++
[GuidAttribute(L"7BC6080E-27B7-43db-B04C-9F7C76D4AE47")]
public enum class ImportUnit

Members

Member name | Description
Default | Unit (if available) from the document that is getting imported.
Meter | Meters as decimal values.
Decimeter | Centimeters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.

See Also

Autodesk.Revit.Enums Namespace


LeaderEndCondition Enumeration
CollapseAll image DropDown image

An enumerate type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2ED7F07E-5BA3-4792-A9CD-02E7A5B05B7E")]
public enum LeaderEndCondition
Visual Basic (Declaration)
<GuidAttribute("2ED7F07E-5BA3-4792-A9CD-02E7A5B05B7E")> _
Public Enumeration LeaderEndCondition
Visual C++
[GuidAttribute(L"2ED7F07E-5BA3-4792-A9CD-02E7A5B05B7E")]
public enum class LeaderEndCondition

Members

Member name | Description
LEC_FREE | The Leader of the tag is free.
LEC_ATTACHED | The Leader of the tag is attached.

See Also

Autodesk.Revit.Enums Namespace


LineScaling Enumeration
CollapseAll image DropDown image

An enumerate type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B8CEDC92-BD91-47a2-9A22-491CA04DC1C4")]
public enum LineScaling
Visual Basic (Declaration)
<GuidAttribute("B8CEDC92-BD91-47a2-9A22-491CA04DC1C4")> _
Public Enumeration LineScaling
Visual C++
[GuidAttribute(L"B8CEDC92-BD91-47a2-9A22-491CA04DC1C4")]
public enum class LineScaling

Members

Member name | Description
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.

Remarks

Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash.

Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.

See Also

Autodesk.Revit.Enums Namespace


MarginType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Margin types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8C0C90EE-9255-42c7-B0BE-4784D9B04135")]
public enum MarginType
Visual Basic (Declaration)
<GuidAttribute("8C0C90EE-9255-42c7-B0BE-4784D9B04135")> _
Public Enumeration MarginType
Visual C++
[GuidAttribute(L"8C0C90EE-9255-42c7-B0BE-4784D9B04135")]
public enum class MarginType

Members

Member name | Description
UserDefined | The type of Margin is User Defined .
PrinterLimit | The type of Margin is Printer Limit.
NoMargin | The type of Margin is No Margin.

See Also

Autodesk.Revit.Enums Namespace


MaterialBehaviourType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the material behavior type.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("93C31207-9774-4f72-8808-B6C6F7BC5494")]
public enum MaterialBehaviourType
Visual Basic (Declaration)
<GuidAttribute("93C31207-9774-4f72-8808-B6C6F7BC5494")> _
Public Enumeration MaterialBehaviourType
Visual C++
[GuidAttribute(L"93C31207-9774-4f72-8808-B6C6F7BC5494")]
public enum class MaterialBehaviourType

Members

Member name | Description
Undefined | Undefined material
Orthotropic | Orthotropic material
Isotropic | Isotropic material

See Also

Autodesk.Revit.Enums Namespace


PageOrientationType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Page Orientation types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("893955AA-61A7-4add-BDDF-4E31CB561E7E")]
public enum PageOrientationType
Visual Basic (Declaration)
<GuidAttribute("893955AA-61A7-4add-BDDF-4E31CB561E7E")> _
Public Enumeration PageOrientationType
Visual C++
[GuidAttribute(L"893955AA-61A7-4add-BDDF-4E31CB561E7E")]
public enum class PageOrientationType

Members

Member name | Description
Landscape | The type of Page Orientation is Landscape.
Portrait | The type of Page Orientation is Portrait.

See Also

Autodesk.Revit.Enums Namespace


PaperPlacementType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Paper Placement types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DAD53C0A-42D7-4f79-B8C5-AD24890C16FB")]
public enum PaperPlacementType
Visual Basic (Declaration)
<GuidAttribute("DAD53C0A-42D7-4f79-B8C5-AD24890C16FB")> _
Public Enumeration PaperPlacementType
Visual C++
[GuidAttribute(L"DAD53C0A-42D7-4f79-B8C5-AD24890C16FB")]
public enum class PaperPlacementType

Members

Member name | Description
Center | The type of Paper Placement is Center.
Margins | The type of Paper Placement is Margins.

See Also

Autodesk.Revit.Enums Namespace


PostedErrorType Enumeration
CollapseAll image DropDown image

Describes the type of a posted error.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("507A371B-9E50-4671-B413-7B11F242DD59")]
public enum PostedErrorType
Visual Basic (Declaration)
<GuidAttribute("507A371B-9E50-4671-B413-7B11F242DD59")> _
Public Enumeration PostedErrorType
Visual C++
[GuidAttribute(L"507A371B-9E50-4671-B413-7B11F242DD59")]
public enum class PostedErrorType

Members

Member name | Description
Error |
Fatal |
Warning |
Unknown |

See Also

Autodesk.Revit.Enums Namespace


PrintRange Enumeration
CollapseAll image DropDown image

An enumerate type listing all Print Range types of Print.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4469D3CF-9564-4d4f-9CAE-68AFD31CF553")]
public enum PrintRange
Visual Basic (Declaration)
<GuidAttribute("4469D3CF-9564-4d4f-9CAE-68AFD31CF553")> _
Public Enumeration PrintRange
Visual C++
[GuidAttribute(L"4469D3CF-9564-4d4f-9CAE-68AFD31CF553")]
public enum class PrintRange

Members

Member name | Description
Select | The type of Print Range is Select.
Current | The type of Print Range is Current.
Visible | The type of Print Range is Visible.

See Also

Autodesk.Revit.Enums Namespace


PropOverrideMode Enumeration
CollapseAll image DropDown image

An enumerate type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D1B98627-ADE8-4600-9837-CD7AF47AD6DC")]
public enum PropOverrideMode
Visual Basic (Declaration)
<GuidAttribute("D1B98627-ADE8-4600-9837-CD7AF47AD6DC")> _
Public Enumeration PropOverrideMode
Visual C++
[GuidAttribute(L"D1B98627-ADE8-4600-9837-CD7AF47AD6DC")]
public enum class PropOverrideMode

Members

Member name | Description
NewLayer | All properties BYLAYER, New Layers for overrides.
ByLayer | All properties BYLAYER, no overrides.
ByEntity | Category properties BYLAYER, overrides BYENTITY.

See Also

Autodesk.Revit.Enums Namespace


RasterQualityType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Raster Quality types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("18C0EC81-9668-4470-AFAC-FCBF5A7A2E06")]
public enum RasterQualityType
Visual Basic (Declaration)
<GuidAttribute("18C0EC81-9668-4470-AFAC-FCBF5A7A2E06")> _
Public Enumeration RasterQualityType
Visual C++
[GuidAttribute(L"18C0EC81-9668-4470-AFAC-FCBF5A7A2E06")]
public enum class RasterQualityType

Members

Member name | Description
Presentation | The type of Raster Quality is Presentation.
High | The type of Raster Quality is High.
Medium | The type of Raster Quality is Medium.
Low | The type of Raster Quality is Low.

See Also

Autodesk.Revit.Enums Namespace


SetComparisonResult Enumeration
CollapseAll image DropDown image

An enumerate type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6D1E3706-5BF7-4178-B2BF-065D62E0563B")]
public enum SetComparisonResult
Visual Basic (Declaration)
<GuidAttribute("6D1E3706-5BF7-4178-B2BF-065D62E0563B")> _
Public Enumeration SetComparisonResult
Visual C++
[GuidAttribute(L"6D1E3706-5BF7-4178-B2BF-065D62E0563B")]
public enum class SetComparisonResult

Members

Member name | Description
BothEmpty | Both sets are empty.
RightEmpty | The right set is empty and the left set is not.
LeftEmpty | The left set is empty and the right set is not.
Equal | Two nonempty sets are equal.
Superset | Both sets are not empty and the left set is strict superset of the right.
Subset | Both sets are not empty and the left set is strict subset of the right.
Overlap | The overlap of two sets is not empty and strict subset of both.
Disjoint | Both sets are not empty and don't overlap.

See Also

Autodesk.Revit.Enums Namespace


SlabShapeCreaseType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Crease types of Slab Shape Edit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8CFEAC45-7282-4e7e-AEEF-A3E10707F278")]
public enum SlabShapeCreaseType
Visual Basic (Declaration)
<GuidAttribute("8CFEAC45-7282-4e7e-AEEF-A3E10707F278")> _
Public Enumeration SlabShapeCreaseType
Visual C++
[GuidAttribute(L"8CFEAC45-7282-4e7e-AEEF-A3E10707F278")]
public enum class SlabShapeCreaseType

Members

Member name | Description
Auto | The type of Crease is Auto.
UserDrawn | The type of Crease is UserDrawn.
Boundary | The type of Crease is Boundary.
Invalid | The type of Crease is Invalid.

See Also

Autodesk.Revit.Enums Namespace


SlabShapeVertexType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Vertex types of Slab Shape Edit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("879C7E42-2CDD-4180-AB44-63F179CC4365")]
public enum SlabShapeVertexType
Visual Basic (Declaration)
<GuidAttribute("879C7E42-2CDD-4180-AB44-63F179CC4365")> _
Public Enumeration SlabShapeVertexType
Visual C++
[GuidAttribute(L"879C7E42-2CDD-4180-AB44-63F179CC4365")]
public enum class SlabShapeVertexType

Members

Member name | Description
Edge | The type of Vertex is Edge.
Interior | The type of Vertex is Interior.
Corner | The type of Vertex is Corner.
Invalid | The type of Vertex is Invalid.

See Also

Autodesk.Revit.Enums Namespace


SolidGeometry Enumeration
CollapseAll image DropDown image

An enumerate type listing possible ways of exporting solids in 3D views.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5BA62B01-1E40-4813-A03F-D708FBFC8AB8")]
public enum SolidGeometry
Visual Basic (Declaration)
<GuidAttribute("5BA62B01-1E40-4813-A03F-D708FBFC8AB8")> _
Public Enumeration SolidGeometry
Visual C++
[GuidAttribute(L"5BA62B01-1E40-4813-A03F-D708FBFC8AB8")]
public enum class SolidGeometry

Members

Member name | Description
ACIS | All visible Revit Building geometry is exported as ACIS 3D solids (except for any elements that are already a polymesh.)
Polymesh | All visible solids are exported as polymesh.

See Also

Autodesk.Revit.Enums Namespace


TagMode Enumeration
CollapseAll image DropDown image

An enumerate type listing Tag Mode when user adding tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("841D615A-E5C7-4d78-83A9-EC4102C76EEA")]
public enum TagMode
Visual Basic (Declaration)
<GuidAttribute("841D615A-E5C7-4d78-83A9-EC4102C76EEA")> _
Public Enumeration TagMode
Visual C++
[GuidAttribute(L"841D615A-E5C7-4d78-83A9-EC4102C76EEA")]
public enum class TagMode

Members

Member name | Description
TM_ADDBY_MATERIAL | The Tag you add by Material.
TM_ADDBY_MULTICATEGORY | The Tag you add by Multi-Category.
TM_ADDBY_CATEGORY | The Tag you add by Category.

See Also

Autodesk.Revit.Enums Namespace


TagOrientation Enumeration
CollapseAll image DropDown image

An enumerate type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("ED69E725-AD50-4644-ADCD-87428D81235E")]
public enum TagOrientation
Visual Basic (Declaration)
<GuidAttribute("ED69E725-AD50-4644-ADCD-87428D81235E")> _
Public Enumeration TagOrientation
Visual C++
[GuidAttribute(L"ED69E725-AD50-4644-ADCD-87428D81235E")]
public enum class TagOrientation

Members

Member name | Description
TAG_VERTICAL | The Orientation of tag is Vertical.
TAG_HORIZONTAL | The Orientation of tag is Horizontal.

See Also

Autodesk.Revit.Enums Namespace


TextAlignFlags Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Text align flags.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DD4A7361-0586-4aca-BFD0-1FA631159747")]
public enum TextAlignFlags
Visual Basic (Declaration)
<GuidAttribute("DD4A7361-0586-4aca-BFD0-1FA631159747")> _
Public Enumeration TextAlignFlags
Visual C++
[GuidAttribute(L"DD4A7361-0586-4aca-BFD0-1FA631159747")]
public enum class TextAlignFlags

Members

Member name | Description
TEF_ALIGN_BOTTOM | Align text bottom
TEF_ALIGN_MIDDLE | Align text middle
TEF_ALIGN_TOP | Align text top
TEF_ALIGN_RIGHT | Align text right
TEF_ALIGN_CENTER | Align text cener
TEF_ALIGN_LEFT | Align text left

See Also

Autodesk.Revit.Enums Namespace


TextAlignMask Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Text align mask.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CFA06E36-BCC2-461f-923B-EAA504F623FE")]
public enum TextAlignMask
Visual Basic (Declaration)
<GuidAttribute("CFA06E36-BCC2-461f-923B-EAA504F623FE")> _
Public Enumeration TextAlignMask
Visual C++
[GuidAttribute(L"CFA06E36-BCC2-461f-923B-EAA504F623FE")]
public enum class TextAlignMask

Members

Member name | Description
vertAlignMask | The mask of the Text object being aligned in the vertical direction.
horzAlignMask | The mask of the Text object being aligned in the horizontal direction.

See Also

Autodesk.Revit.Enums Namespace


TextElementBackground Enumeration
CollapseAll image DropDown image

An enumerate type listing all the background mode for the built-in parameter TEXT_BACKGROUND.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4D122BED-CFB1-433f-9A54-933558AA8B88")]
public enum TextElementBackground
Visual Basic (Declaration)
<GuidAttribute("4D122BED-CFB1-433f-9A54-933558AA8B88")> _
Public Enumeration TextElementBackground
Visual C++
[GuidAttribute(L"4D122BED-CFB1-433f-9A54-933558AA8B88")]
public enum class TextElementBackground

Members

Member name | Description
TBGR_TRANSPARENT | The TextElement object is transparent.
TBGR_OPAQUE | The TextElement object is opaque.

See Also

Autodesk.Revit.Enums Namespace


TextNoteLeaderStyles Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Leader styles.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("833F6457-88E4-48c5-B740-0186CE7E295C")]
public enum TextNoteLeaderStyles
Visual Basic (Declaration)
<GuidAttribute("833F6457-88E4-48c5-B740-0186CE7E295C")> _
Public Enumeration TextNoteLeaderStyles
Visual C++
[GuidAttribute(L"833F6457-88E4-48c5-B740-0186CE7E295C")]
public enum class TextNoteLeaderStyles

Members

Member name | Description
LCS_TWO_SEG_LINE | The leader include two line segments.
LCS_ONE_SEG_ARC | The leader is an arc.
LCS_ONE_SEG_LINE | The leader only includes one line segment.
LCS_NONE | No leader.

See Also

Autodesk.Revit.Enums Namespace


TextNoteLeaderTypes Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Leader types.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3E78C10B-64A5-4443-8613-B8873BF74A21")]
public enum TextNoteLeaderTypes
Visual Basic (Declaration)
<GuidAttribute("3E78C10B-64A5-4443-8613-B8873BF74A21")> _
Public Enumeration TextNoteLeaderTypes
Visual C++
[GuidAttribute(L"3E78C10B-64A5-4443-8613-B8873BF74A21")]
public enum class TextNoteLeaderTypes

Members

Member name | Description
TNLT_ARC_R | The leader is put at the right of the Text object and in the arc style.
TNLT_ARC_L | The leader is put at the left of the Text object and in the arc style.
TNLT_STRAIGHT_R | The leader is put at the right of the Text object and in the straight style.
TNLT_STRAIGHT_L | The leader is put at the left of the Text object and in the straight style.

See Also

Autodesk.Revit.Enums Namespace


TrussMemberType Enumeration
CollapseAll image DropDown image

Indicates the "kind" of a truss member.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67567F4C-44A3-40ec-A515-070A34BAE392")]
public enum TrussMemberType
Visual Basic (Declaration)
<GuidAttribute("67567F4C-44A3-40ec-A515-070A34BAE392")> _
Public Enumeration TrussMemberType
Visual C++
[GuidAttribute(L"67567F4C-44A3-40ec-A515-070A34BAE392")]
public enum class TrussMemberType

Members

Member name | Description
ETK_TrussDiagWeb | Truss DiagWeb.
ETK_TrussVertWeb | Truss VertWeb.
ETK_TrussBottomChord | Truss bottom chord.
ETK_TrussTopChord | Truss top chord.
ETK_Unknown | Unknown element type.

See Also

Autodesk.Revit.Enums Namespace


UnitGroup Enumeration
CollapseAll image DropDown image

An enumerate type listing Discipline of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("236C08D7-ACDE-4329-AA0F-B4A49FC6A24C")]
public enum UnitGroup
Visual Basic (Declaration)
<GuidAttribute("236C08D7-ACDE-4329-AA0F-B4A49FC6A24C")> _
Public Enumeration UnitGroup
Visual C++
[GuidAttribute(L"236C08D7-ACDE-4329-AA0F-B4A49FC6A24C")]
public enum class UnitGroup

Members

Member name | Description
UG_Piping |
UG_Electrical |
UG_HVAC |
UG_Structural |
UG_Common |

See Also

Autodesk.Revit.Enums Namespace


UnitSymbolType Enumeration
CollapseAll image DropDown image

An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2E36F13A-E0FA-4d5d-A208-4351D2735A62")]
public enum UnitSymbolType
Visual Basic (Declaration)
<GuidAttribute("2E36F13A-E0FA-4d5d-A208-4351D2735A62")> _
Public Enumeration UnitSymbolType
Visual C++
[GuidAttribute(L"2E36F13A-E0FA-4d5d-A208-4351D2735A62")]
public enum class UnitSymbolType

Members

Member name | Description
UST_SQ_FT_PER_KBTU_PER_H |
UST_SQ_FT_PER_MBH |
UST_SF_PER_KBTU_PER_H |
UST_SF_PER_MBH |
UST_LM_PER_W |
UST_KRONER |
UST_BAHT |
UST_DONG |
UST_SHEQEL |
UST_WON |
UST_CHINESE_HONG_KONG_SAR |
UST_YEN |
UST_POUND |
UST_EURO_PREFIX |
UST_EURO_SUFFIX |
UST_DOLLAR |
UST_SQ_M_PER_KW |
UST_SF_PER_TON |
UST_SQ_FT_PER_TON |
UST_L_PER_S_KW |
UST_CFM_PER_TON |
UST_L_PER_S_CU_M |
UST_CFM_PER_CF |
UST_CFM_PER_CU_FT |
UST_BTU_PER_H_CU_FT |
UST_WATT_PER_CU_M |
UST_WATT_PER_CU_FT |
UST_BTU_PER_H_SQ_FT |
UST_TON |
UST_SLOPE_DEGREE_SYMBOL |
UST_COLON_12 |
UST_COLON_10 |
UST_L_PER_S_SQ_M |
UST_LPS_PER_SQ_M |
UST_CFM_PER_SF |
UST_CFM_PER_SQ_FT |
UST_BTU_PER_H_SQ_FT_DEGREE_F |
UST_WATT_PER_SQ_M_K |
UST_K_N_M_PER_DEGREE_PER_M |
UST_K_N_M_PER_DEGREE |
UST_KIP_FT_PER_DEGREE_PER_FT |
UST_KIP_FT_PER_DEGREE |
UST_KIPS_PER_CU_FT |
UST_KIPS_PER_IN |
UST_INV_DEGREE_C |
UST_INV_DEGREE_F |
UST_KIP_PER_IN_SUP_3 |
UST_LBF_PER_CU_FT |
UST_LB_FORCE_PER_CU_FT |
UST_KN_PER_M_SUP_3 |
UST_KIP_PER_SQ_IN |
UST_KSI |
UST_LBM_PER_FT_H |
UST_LB_PER_FT_H |
UST_CP |
UST_LBM_PER_FT_S |
UST_LB_PER_FT_S |
UST_PA_S |
UST_FPS |
UST_FT_PER_S |
UST_FEET_OF_WATER |
UST_FT_OF_WATER |
UST_FTH2O |
UST_FEET_OF_WATER_PER_100FT |
UST_FT_OF_WATER_PER_100FT |
UST_FTH2O_PER_100FT |
UST_INV_KIP |
UST_INV_K_N |
UST_FT_SUP_3_PER_KIP |
UST_M_SUP_3_PER_K_N |
UST_FT_SUP_2_PER_KIP |
UST_M_SUP_2_PER_K_N |
UST_FT_PER_KIP |
UST_M_PER_K_N |
UST_LBF_DASH_FT_PER_FT |
UST_LB_DASH_FT_PER_FT |
UST_TF_DASH_M_PER_M |
UST_KGF_DASH_M_PER_M |
UST_KIP_DASH_FT_PER_FT |
UST_M_N_DASH_M_PER_M |
UST_K_N_DASH_M_PER_M |
UST_DA_N_DASH_M_PER_M |
UST_N_DASH_M_PER_M |
UST_LBF_DASH_FT |
UST_LB_DASH_FT |
UST_TF_DASH_M |
UST_KGF_DASH_M |
UST_KIP_DASH_FT |
UST_M_N_DASH_M |
UST_K_N_DASH_M |
UST_DA_N_DASH_M |
UST_N_DASH_M |
UST_LBF_PER_SQ_FT |
UST_LB_PER_SQ_FT |
UST_PSF |
UST_TF_PER_M_SUP_2 |
UST_KGF_PER_M_SUP_2 |
UST_KIP_PER_SQ_FT |
UST_KSF |
UST_M_N_PER_M_SUP_2 |
UST_K_N_PER_M_SUP_2 |
UST_DA_N_PER_M_SUP_2 |
UST_N_PER_M_SUP_2 |
UST_LBF_PER_FT |
UST_LB_PER_FT |
UST_TF_PER_M |
UST_KGF_PER_M |
UST_KIP_PER_FT |
UST_M_N_PER_M |
UST_K_N_PER_M |
UST_DA_N_PER_M |
UST_N_PER_M |
UST_LBF |
UST_LB |
UST_TF |
UST_KGF |
UST_KIP |
UST_M_N |
UST_K_N |
UST_DA_N |
UST_N |
UST_HP |
UST_KILOVOLTAMPERE |
UST_VOLTAMPERE |
UST_LM |
UST_CD |
UST_CD_PER_SQ_M |
UST_FTL |
UST_FL_LOWERCASE |
UST_FL |
UST_FTC |
UST_FC |
UST_LX |
UST_CPS |
UST_HZ |
UST_MILLIVOLT |
UST_KILOVOLT |
UST_VOLT |
UST_MILLIAMPERE |
UST_KILOAMPERE |
UST_AMPERE |
UST_USGPH |
UST_GPH |
UST_GAL_PER_H |
UST_USGPM |
UST_GPM |
UST_GAL_PER_MIN |
UST_CMH |
UST_CU_M_PER_H |
UST_CMS |
UST_CU_M_PER_S |
UST_LPS |
UST_L_PER_S |
UST_CFM |
UST_CU_FT_PER_MIN |
UST_CM_PER_MIN |
UST_M_PER_S |
UST_FPM |
UST_FT_PER_MIN |
UST_DEGREE_R |
UST_KELVIN |
UST_DEGREE_C |
UST_DEGREE_F |
UST_BAR |
UST_ATM |
UST_MM_HG |
UST_IN_HG |
UST_LBF_PER_SQ_IN |
UST_PSIA |
UST_PSIG |
UST_LB_PER_SQ_IN |
UST_PSI |
UST_MEGAPASCAL |
UST_KILOPASCAL |
UST_PASCAL |
UST_IN_WG |
UST_WATT_PER_SQ_M |
UST_WATT_PER_SQ_FT |
UST_KCAL_PER_S |
UST_CAL_PER_S |
UST_BTU_PER_H |
UST_BTU_PER_S |
UST_KILOWATT |
UST_WATT |
UST_PASCAL_PER_M |
UST_IN_WG_PER_100FT |
UST_THERM |
UST_KWH |
UST_JOULE |
UST_KCAL |
UST_CAL |
UST_BTU |
UST_LBM_PER_CU_IN |
UST_LB_PER_CU_IN |
UST_LBM_PER_CU_FT |
UST_LB_MASS_PER_CU_FT |
UST_KG_PER_CU_M |
UST_PERCENT_SIGN |
UST_DEGREE_SYMBOL |
UST_GAL |
UST_L |
UST_CY |
UST_MM_CARET_3 |
UST_MM_SUP_3 |
UST_CM_CARET_3 |
UST_CM_SUP_3 |
UST_M_CARET_3 |
UST_M_SUP_3 |
UST_IN_CARET_3 |
UST_IN_SUP_3 |
UST_FT_CARET_3 |
UST_FT_SUP_3 |
UST_CF |
UST_HECTARES |
UST_ACRES |
UST_MM_CARET_2 |
UST_MM_SUP_2 |
UST_CM_CARET_2 |
UST_CM_SUP_2 |
UST_M_CARET_2 |
UST_M_SUP_2 |
UST_IN_CARET_2 |
UST_IN_SUP_2 |
UST_FT_CARET_2 |
UST_FT_SUP_2 |
UST_SF |
UST_MM |
UST_CM |
UST_M |
UST_INCH_DOUBLE_QUOTE |
UST_FOOT_SINGLE_QUOTE |
UST_LF |
UST_NONE |

See Also

Autodesk.Revit.Enums Namespace


UnitType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7D7B62BF-F1A9-4eac-AB4B-EA348AE330FE")]
public enum UnitType
Visual Basic (Declaration)
<GuidAttribute("7D7B62BF-F1A9-4eac-AB4B-EA348AE330FE")> _
Public Enumeration UnitType
Visual C++
[GuidAttribute(L"7D7B62BF-F1A9-4eac-AB4B-EA348AE330FE")]
public enum class UnitType

Members

Member name | Description
UT_HVAC_Area_Divided_By_Heating_Load |
UT_Electrical_Luminance |
UT_Electrical_Luminous_Intensity |
UT_DecSheetLength |
UT_Color_Temperature |
UT_Electrical_Wattage |
UT_Electrical_Efficacy |
UT_Currency |
UT_Piping_Slope |
UT_HVAC_Slope |
UT_WireSize |
UT_HVAC_Area_Divided_By_Cooling_Load |
UT_HVAC_Airflow_Divided_By_Cooling_Load |
UT_HVAC_Airflow_Divided_By_Volume |
UT_HVAC_Heating_Load_Divided_By_Volume |
UT_HVAC_Heating_Load_Divided_By_Area |
UT_HVAC_Heating_Load |
UT_HVAC_Cooling_Load_Divided_By_Volume |
UT_HVAC_Cooling_Load_Divided_By_Area |
UT_HVAC_Cooling_Load |
UT_Slope |
UT_HVAC_Airflow_Density |
UT_HVAC_CoefficientOfHeatTransfer |
UT_HVAC_Viscosity |
UT_Piping_Volume |
UT_AreaForcePerLength |
UT_LinearForceLengthPerAngle |
UT_LinearForcePerLength |
UT_ForceLengthPerAngle |
UT_ForcePerLength |
UT_LinearMomentScale |
UT_LinearMoment |
UT_TemperalExp |
UT_UnitWeight |
UT_Stress |
UT_Piping_Roughness |
UT_PipeSize |
UT_Piping_Viscosity |
UT_Piping_Velocity |
UT_Piping_Temperature |
UT_Piping_Pressure |
UT_Piping_Friction |
UT_Piping_Flow |
UT_Piping_Density |
UT_Electrical_Power_Density |
UT_Electrical_Apparent_Power |
UT_MomentScale |
UT_AreaForceScale |
UT_LinearForceScale |
UT_ForceScale |
UT_Moment |
UT_AreaForce |
UT_LinearForce |
UT_Force |
UT_HVAC_Roughness |
UT_Electrical_Power |
UT_Electrical_Luminous_Flux |
UT_Electrical_Illuminance |
UT_Electrical_Frequency |
UT_Electrical_Potential |
UT_Electrical_Current |
UT_HVAC_HeatGain |
UT_HVAC_CrossSection |
UT_HVAC_DuctSize |
UT_HVAC_Airflow |
UT_HVAC_Velocity |
UT_HVAC_Temperature |
UT_HVAC_Pressure |
UT_HVAC_Power_Density |
UT_HVAC_Power |
UT_HVAC_Friction |
UT_HVAC_Energy |
UT_HVAC_Density |
UT_SiteAngle |
UT_SheetLength |
UT_Number |
UT_Angle |
UT_Volume |
UT_Area |
UT_Length |

See Also

Autodesk.Revit.Enums Namespace


ViewType Enumeration
CollapseAll image DropDown image

An enumerate type listing available view types.)

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A87F6F42-6C6C-48d3-AB82-9EBFE6BB72E2")]
public enum ViewType
Visual Basic (Declaration)
<GuidAttribute("A87F6F42-6C6C-48d3-AB82-9EBFE6BB72E2")> _
Public Enumeration ViewType
Visual C++
[GuidAttribute(L"A87F6F42-6C6C-48d3-AB82-9EBFE6BB72E2")]
public enum class ViewType

Members

Member name | Description
Section | Cross section type of view.
Internal | Revit's internal type of view
Rendering | Rendering type of view.
Walkthrough | Walk-Through type of 3D view.
ColumnSchedule | Column Schedule type of view.
PanelSchedule | Panel Schedule Report view.
PresureLossReport | Presure Loss Report view.
LoadsReport | Loads Report view.
CostReport | Cost Report view.
Report | Report type of view.
Legend | Legend type of view.
DrawingSheet | Drawing sheet type of view.
DraftingView | Drafting type of view.
Schedule | Schedule type of view.
ThreeD | 3-D type of view.
Detail | Detail type of view.
Elevation | Elevation type of view.
CeilingPlan | Reflected ceiling plan type of view.
AreaPlan | Area plan type of view.
EngineeringPlan | Engineering Floor Plan type of view.
FloorPlan | Floor plan type of view.
Undefined | Undefined/unspecified type of view.

See Also

Autodesk.Revit.Enums Namespace


VirtualPrinterType Enumeration
CollapseAll image DropDown image

An enumerate to list Virtual Printer Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0EFE46C0-951D-45d8-B219-0ACD376D0B37")]
public enum VirtualPrinterType
Visual Basic (Declaration)
<GuidAttribute("0EFE46C0-951D-45d8-B219-0ACD376D0B37")> _
Public Enumeration VirtualPrinterType
Visual C++
[GuidAttribute(L"0EFE46C0-951D-45d8-B219-0ACD376D0B37")]
public enum class VirtualPrinterType

Members

Member name | Description
None | None.
DWFWriter | DWFWriter.
AdobePDF | AdobePDF.

See Also

Autodesk.Revit.Enums Namespace


ZoomType Enumeration
CollapseAll image DropDown image

An enumerate type listing all Zoom types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("29F30AEE-1614-4689-8CB3-4068449AF78B")]
public enum ZoomType
Visual Basic (Declaration)
<GuidAttribute("29F30AEE-1614-4689-8CB3-4068449AF78B")> _
Public Enumeration ZoomType
Visual C++
[GuidAttribute(L"29F30AEE-1614-4689-8CB3-4068449AF78B")]
public enum class ZoomType

Members

Member name | Description
Zoom | The type of Zoom is user defined.
FitToPage | The type of Zoom is Fit To Page.

See Also

Autodesk.Revit.Enums Namespace


Autodesk.Revit.Events Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Events
Visual Basic (Declaration)
Namespace Autodesk.Revit.Events
Visual C++
namespace Autodesk.Revit.Events

Classes

 | Class | Description
Public class | DialogBoxData | An object that is passed to your application when a dialog is displayed in Revit.
Public class | MessageBoxData | An object that represents a simple message box that has been displayed prompting the user for some action.

Interfaces

 | Interface | Description
Public interface | ApplicationEvents | An interface that supports the events from the Revit Application object.
Public interface | DocumentEvents | An interface that supports the events from the Autodesk Revit Document object.

Delegates

 | Delegate | Description
Public delegate | DialogBoxEventHandler | A handler for the event that is fired when a Revit dialog box is displayed during an external API command.
Public delegate | DocumentClosedEventHandler | A handler for the event that is fired after a document is closed.
Public delegate | DocumentCloseEventHandler | A handler for the event that is fired before the current document is closed.
Public delegate | DocumentNewedEventHandler | A handler for the event that is fired after a new document is created.
Public delegate | DocumentOpenedEventHandler | A handler for the event that is fired after a document is opened.
Public delegate | DocumentSaveAsEventHandler | A handler for the event that is fired before the current document is saved as a file with different file name.
Public delegate | DocumentSavedAsEventHandler | A handler for the event that is fired after a document is saved as a file with different file name.
Public delegate | DocumentSavedEventHandler | A handler for the event that is fired after a document is saved.
Public delegate | DocumentSaveEventHandler | A handler for the event that is fired before the current document is saved.


ApplicationEvents Interface
See Also Members
CollapseAll image DropDown image

An interface that supports the events from the Revit Application object.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)]
[GuidAttribute("4DD847AE-D94C-4f5a-B4FC-CDCEF896DC4A")]
public interface ApplicationEvents
Visual Basic (Declaration)
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)> _
<GuidAttribute("4DD847AE-D94C-4f5a-B4FC-CDCEF896DC4A")> _
Public Interface ApplicationEvents
Visual C++
[InterfaceTypeAttribute(ComInterfaceType::InterfaceIsIDispatch)]
[GuidAttribute(L"4DD847AE-D94C-4f5a-B4FC-CDCEF896DC4A")]
public interface class ApplicationEvents

See Also

ApplicationEvents Members
Autodesk.Revit.Events Namespace


ApplicationEvents Members
See Also Methods
CollapseAll image DropDown image

Syntax

C#
public interface ApplicationEvents
Visual Basic (Declaration)
Public Interface ApplicationEvents
Visual C++
public interface class ApplicationEvents

The type exposes the following members.

Public Methods

 | Name | Description
Public method | OnDialogBox | This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.
Public method | OnDocumentClosed | This event is fired after a document is closed.
Public method | OnDocumentNewed | This event is fired after a new document is created.
Public method | OnDocumentOpened | This event is fired after a document is opened.
Public method | OnDocumentSaved | This event is fired after a document is saved.
Public method | OnDocumentSavedAs | This event is fired after a document is saved as another file name.

See Also

ApplicationEvents
Autodesk.Revit.Events Namespace


ApplicationEvents Methods
CollapseAll image DropDown image

Syntax

C#
public interface ApplicationEvents
Visual Basic (Declaration)
Public Interface ApplicationEvents
Visual C++
public interface class ApplicationEvents

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | OnDialogBox | This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.
Public method | OnDocumentClosed | This event is fired after a document is closed.
Public method | OnDocumentNewed | This event is fired after a new document is created.
Public method | OnDocumentOpened | This event is fired after a document is opened.
Public method | OnDocumentSaved | This event is fired after a document is saved.
Public method | OnDocumentSavedAs | This event is fired after a document is saved as another file name.

See Also

ApplicationEvents
Autodesk.Revit.Events Namespace


OnDialogBox Method

ApplicationEvents..::OnDialogBox Method
CollapseAll image DropDown image

This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnDialogBox(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Sub OnDialogBox ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
void OnDialogBox (
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
DialogBoxData
An object that describes the dialog box.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentClosed Method

ApplicationEvents..::OnDocumentClosed Method
CollapseAll image DropDown image

This event is fired after a document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnDocumentClosed(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentClosed ( _
    document As Document _
)
Visual C++
void OnDocumentClosed (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentNewed Method

ApplicationEvents..::OnDocumentNewed Method
CollapseAll image DropDown image

This event is fired after a new document is created.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnDocumentNewed(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentNewed ( _
    document As Document _
)
Visual C++
void OnDocumentNewed (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentOpened Method

ApplicationEvents..::OnDocumentOpened Method
CollapseAll image DropDown image

This event is fired after a document is opened.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnDocumentOpened(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentOpened ( _
    document As Document _
)
Visual C++
void OnDocumentOpened (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentSaved Method

ApplicationEvents..::OnDocumentSaved Method
CollapseAll image DropDown image

This event is fired after a document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnDocumentSaved(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentSaved ( _
    document As Document _
)
Visual C++
void OnDocumentSaved (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentSavedAs Method

ApplicationEvents..::OnDocumentSavedAs Method
CollapseAll image DropDown image

This event is fired after a document is saved as another file name.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnDocumentSavedAs(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentSavedAs ( _
    document As Document _
)
Visual C++
void OnDocumentSavedAs (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


DialogBoxData Class
See Also Members
CollapseAll image DropDown image

An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EDE91043-9BB6-4659-8163-753619C30DB8")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DialogBoxData : APIObject
Visual Basic (Declaration)
<GuidAttribute("EDE91043-9BB6-4659-8163-753619C30DB8")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DialogBoxData _
    Inherits APIObject
Visual C++
[GuidAttribute(L"EDE91043-9BB6-4659-8163-753619C30DB8")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Events..::DialogBoxData
Autodesk.Revit.Events..::MessageBoxData

See Also

DialogBoxData Members
Autodesk.Revit.Events Namespace


DialogBoxData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DialogBoxData
Visual Basic (Declaration)
Public Class DialogBoxData
Visual C++
public ref class DialogBoxData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DialogBoxDataDialogBoxDataNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | HelpId | An ID that represents the dialog that has been displayed.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData
Autodesk.Revit.Events Namespace


DialogBoxData Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DialogBoxData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DialogBoxData ()

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


DialogBoxData Methods
CollapseAll image DropDown image

Syntax

C#
public class DialogBoxData
Visual Basic (Declaration)
Public Class DialogBoxData
Visual C++
public ref class DialogBoxData

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

DialogBoxData
Autodesk.Revit.Events Namespace


OverrideResult Method

DialogBoxData..::OverrideResult Method
CollapseAll image DropDown image

Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic (Declaration)
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult (
    int result
)

Parameters

result
Int32
The result code you wish the Revit dialog to return.

Return Value

Returns true if the result code was accepted.

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


DialogBoxData Properties
CollapseAll image DropDown image

Syntax

C#
public class DialogBoxData
Visual Basic (Declaration)
Public Class DialogBoxData
Visual C++
public ref class DialogBoxData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | HelpId | An ID that represents the dialog that has been displayed.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData
Autodesk.Revit.Events Namespace


HelpId Property

DialogBoxData..::HelpId Property
CollapseAll image DropDown image

An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int HelpId{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HelpId As Integer
Visual C++
public:
property int HelpId {
    int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


DialogBoxEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired when a Revit dialog box is displayed during an external API command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DialogBoxEventHandler(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Public Delegate Sub DialogBoxEventHandler ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
public delegate void DialogBoxEventHandler (
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
DialogBoxData
An object that describes the dialog box

See Also

Autodesk.Revit.Events Namespace


DocumentClosedEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired after a document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentClosedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentClosedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentClosedEventHandler (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentCloseEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired before the current document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentCloseEventHandler()
Visual Basic (Declaration)
Public Delegate Sub DocumentCloseEventHandler
Visual C++
public delegate void DocumentCloseEventHandler ()

See Also

Autodesk.Revit.Events Namespace


DocumentEvents Interface
See Also Members
CollapseAll image DropDown image

An interface that supports the events from the Autodesk Revit Document object.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("07082A69-607B-41d2-9559-AF1674DA4AB9")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)]
public interface DocumentEvents
Visual Basic (Declaration)
<GuidAttribute("07082A69-607B-41d2-9559-AF1674DA4AB9")> _
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)> _
Public Interface DocumentEvents
Visual C++
[GuidAttribute(L"07082A69-607B-41d2-9559-AF1674DA4AB9")]
[InterfaceTypeAttribute(ComInterfaceType::InterfaceIsIDispatch)]
public interface class DocumentEvents

See Also

DocumentEvents Members
Autodesk.Revit.Events Namespace


DocumentEvents Members
See Also Methods
CollapseAll image DropDown image

Syntax

C#
public interface DocumentEvents
Visual Basic (Declaration)
Public Interface DocumentEvents
Visual C++
public interface class DocumentEvents

The type exposes the following members.

Public Methods

 | Name | Description
Public method | OnClose | This event is fired before the current document is closed.
Public method | OnSave | This event is fired before the current document is saved.
Public method | OnSaveAs | This event is fired before the current document is saved as another file.

See Also

DocumentEvents
Autodesk.Revit.Events Namespace


DocumentEvents Methods
CollapseAll image DropDown image

Syntax

C#
public interface DocumentEvents
Visual Basic (Declaration)
Public Interface DocumentEvents
Visual C++
public interface class DocumentEvents

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | OnClose | This event is fired before the current document is closed.
Public method | OnSave | This event is fired before the current document is saved.
Public method | OnSaveAs | This event is fired before the current document is saved as another file.

See Also

DocumentEvents
Autodesk.Revit.Events Namespace


OnClose Method

DocumentEvents..::OnClose Method
CollapseAll image DropDown image

This event is fired before the current document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnClose()
Visual Basic (Declaration)
Sub OnClose
Visual C++
void OnClose ()

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


OnSave Method

DocumentEvents..::OnSave Method
CollapseAll image DropDown image

This event is fired before the current document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnSave()
Visual Basic (Declaration)
Sub OnSave
Visual C++
void OnSave ()

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


OnSaveAs Method

DocumentEvents..::OnSaveAs Method
CollapseAll image DropDown image

This event is fired before the current document is saved as another file.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnSaveAs()
Visual Basic (Declaration)
Sub OnSaveAs
Visual C++
void OnSaveAs ()

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


DocumentNewedEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired after a new document is created.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentNewedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentNewedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentNewedEventHandler (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentOpenedEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired after a document is opened.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentOpenedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentOpenedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentOpenedEventHandler (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentSaveAsEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired before the current document is saved as a file with different file name.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentSaveAsEventHandler()
Visual Basic (Declaration)
Public Delegate Sub DocumentSaveAsEventHandler
Visual C++
public delegate void DocumentSaveAsEventHandler ()

See Also

Autodesk.Revit.Events Namespace


DocumentSavedAsEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired after a document is saved as a file with different file name.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentSavedAsEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentSavedAsEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentSavedAsEventHandler (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentSavedEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired after a document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentSavedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentSavedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentSavedEventHandler (
    Document^ document
)

Parameters

document
Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentSaveEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired before the current document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DocumentSaveEventHandler()
Visual Basic (Declaration)
Public Delegate Sub DocumentSaveEventHandler
Visual C++
public delegate void DocumentSaveEventHandler ()

See Also

Autodesk.Revit.Events Namespace


MessageBoxData Class
See Also Members
CollapseAll image DropDown image

An object that represents a simple message box that has been displayed prompting the user for some action.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3423CED5-9F90-417d-B3FE-0CD05F03E47A")]
public class MessageBoxData : DialogBoxData
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3423CED5-9F90-417d-B3FE-0CD05F03E47A")> _
Public Class MessageBoxData _
    Inherits DialogBoxData
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3423CED5-9F90-417d-B3FE-0CD05F03E47A")]
public ref class MessageBoxData : public DialogBoxData

Remarks

When the application receives this object, a simple message box has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Events..::DialogBoxData
Autodesk.Revit.Events..::MessageBoxData

See Also

MessageBoxData Members
Autodesk.Revit.Events Namespace


MessageBoxData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MessageBoxData
Visual Basic (Declaration)
Public Class MessageBoxData
Visual C++
public ref class MessageBoxData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MessageBoxDataMessageBoxDataNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | DialogType | An integer that describes the standard windows type of the dialog box.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData
Autodesk.Revit.Events Namespace


MessageBoxData Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MessageBoxData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MessageBoxData ()

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


MessageBoxData Methods
CollapseAll image DropDown image

Syntax

C#
public class MessageBoxData
Visual Basic (Declaration)
Public Class MessageBoxData
Visual C++
public ref class MessageBoxData

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

MessageBoxData
Autodesk.Revit.Events Namespace


Dispose Method

MessageBoxData..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


MessageBoxData Properties
CollapseAll image DropDown image

Syntax

C#
public class MessageBoxData
Visual Basic (Declaration)
Public Class MessageBoxData
Visual C++
public ref class MessageBoxData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | DialogType | An integer that describes the standard windows type of the dialog box.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData
Autodesk.Revit.Events Namespace


DialogType Property

MessageBoxData..::DialogType Property
CollapseAll image DropDown image

An integer that describes the standard windows type of the dialog box.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int DialogType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DialogType As Integer
Visual C++
public:
property int DialogType {
    int get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


Message Property

MessageBoxData..::Message Property
CollapseAll image DropDown image

The message that has been displayed in the dialog box.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Message{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


Autodesk.Revit.Geometry Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Geometry
Visual Basic (Declaration)
Namespace Autodesk.Revit.Geometry
Visual C++
namespace Autodesk.Revit.Geometry

Classes

 | Class | Description
Public class | Arc | A circular arc.
Public class | BoundingBoxUV | A two-dimensional rectangle, parallel to the coordinate axes.
Public class | BoundingBoxXYZ | A three-dimensional rectangular box.
Public class | ConicalFace | A cone face of a 3d solid.
Public class | Curve | A parametric curve.
Public class | CurveArrArray | An array that can contain any type of object.
Public class | CurveArrArrayIterator | An iterator to a array.
Public class | CurveArray | An array that can contain curves.
Public class | CurveArrayIterator | An iterator to a curve array.
Public class | CylindricalFace | A cylinder face of a 3d solid.
Public class | DoubleArray | An array that contains doubles.
Public class | DoubleArrayIterator | An iterator to an array of doubles.
Public class | Edge | An edge of a 3d solid.
Public class | EdgeArray | An array that contains edges.
Public class | EdgeArrayArray | An array of edge arrays.
Public class | EdgeArrayArrayIterator | An iterator to an array or edge arrays.
Public class | EdgeArrayIterator | An iterator to an edge array.
Public class | Element | Geometric representation of an element.
Public class | Ellipse | A whole or partial ellipse.
Public class | Face | A face of a 3d solid.
Public class | FaceArray | An array that contains faces.
Public class | FaceArrayIterator | An iterator to a face array.
Public class | GeometryObject | The common base class for all geometric primitives.
Public class | GeometryObjectArray | An array that contains geometry objects.
Public class | GeometryObjectArrayIterator | An iterator to a geometry object array.
Public class | HermiteFace | A cubic hermite spline face of a 3d solid.
Public class | Instance | An instance of another element (symbol), specially positioned by this element.
Public class | InstanceArray | An array that contains instances.
Public class | InstanceArrayIterator | An iterator to an instance array.
Public class | IntersectionResult | This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Public class | IntersectionResultArray | An array that can contain any type of object.
Public class | IntersectionResultArrayIterator | An iterator to a array.
Public class | Line | A line in space.
Public class | Mesh | A triangular mesh.
Public class | MeshArray | An array that contains meshes.
Public class | MeshArrayIterator | An iterator to a mesh array.
Public class | MeshTriangle | One triangle of a mesh.
Public class | NurbSpline | A nurb spline.
Public class | Options | User preferences for parsing of geometry.
Public class | PlanarFace | A planar face of a 3d solid.
Public class | Plane | Provides access to the geometry plane object.
Public class | Profile | A geometric profile consisting of a loop of curves.
Public class | Reference | A stable reference to a geometric object in a Revit model.
Public class | ReferenceArray |
Public class | ReferenceArrayIterator | An iterator to a reference array.
Public class | RevolvedFace | A revolved face of a 3d solid.
Public class | RuledFace | A ruled face of a 3d solid.
Public class | Solid | A 3d solid.
Public class | SolidArray | An array that contains solids.
Public class | SolidArrayIterator | An iterator to a solids array.
Public class | Transform | A transformation of the affine 3-space.
Public class | UV | Object representing coordinates in 2-space.
Public class | UVArray | An array that contains UV coordinates.
Public class | UVArrayIterator | An iterator to an array of UV coordinates.
Public class | XYZ | Object representing coordinates in 3-space.
Public class | XYZArray | An array that contains XYZ coordinates.
Public class | XYZArrayIterator | An iterator to an array of XYZ coordinates.

Enumerations

 | Enumeration | Description
Public enumeration | Options..::DetailLevels | Chooses the detail level of an element's representation.


Arc Class
See Also Members
CollapseAll image DropDown image

A circular arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6456ED41-1F0B-4418-94D2-1E09642A3FB0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Arc : Curve
Visual Basic (Declaration)
<GuidAttribute("6456ED41-1F0B-4418-94D2-1E09642A3FB0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Arc _
    Inherits Curve
Visual C++
[GuidAttribute(L"6456ED41-1F0B-4418-94D2-1E09642A3FB0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Arc : public Curve

Remarks

The arc lies in the plane defined by center and normal.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Arc

See Also

Arc Members
Autodesk.Revit.Geometry Namespace


Arc Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Arc
Visual Basic (Declaration)
Public Class Arc
Visual C++
public ref class Arc

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ArcArcNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the arc.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)

See Also

Arc
Autodesk.Revit.Geometry Namespace


Arc Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Arc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Arc ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Arc Properties
CollapseAll image DropDown image

Syntax

C#
public class Arc
Visual Basic (Declaration)
Public Class Arc
Visual C++
public ref class Arc

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the arc.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)

See Also

Arc
Autodesk.Revit.Geometry Namespace


Center Property

Arc..::Center Property
CollapseAll image DropDown image

Returns the center of the arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Center{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Center As XYZ
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Normal Property

Arc..::Normal Property
CollapseAll image DropDown image

Returns the normal to the plane in which the arc is defined.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Normal{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Radius Property

Arc..::Radius Property
CollapseAll image DropDown image

Returns the radius of the arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Radius{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
}

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Class
See Also Members
CollapseAll image DropDown image

A two-dimensional rectangle, parallel to the coordinate axes.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F7729D31-A7EF-475e-8722-764A12AB7669")]
public class BoundingBoxUV
Visual Basic (Declaration)
<GuidAttribute("F7729D31-A7EF-475e-8722-764A12AB7669")> _
Public Class BoundingBoxUV
Visual C++
[GuidAttribute(L"F7729D31-A7EF-475e-8722-764A12AB7669")]
public ref class BoundingBoxUV

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Geometry..::BoundingBoxUV

See Also

BoundingBoxUV Members
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundingBoxUV
Visual Basic (Declaration)
Public Class BoundingBoxUV
Visual C++
public ref class BoundingBoxUV

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundingBoxUVBoundingBoxUVNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | BoundingBoxUVBoundingBoxUVNew()() | default constructor
Public method | BoundingBoxUVBoundingBoxUVNew(Double, Double, Double, Double) | Creates object with supplied values.

See Also

BoundingBoxUV Class
BoundingBoxUV Members
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Constructor
CollapseAll image DropDown image

default constructor

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxUV()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBoxUV ()

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Constructor (Double, Double, Double, Double)
CollapseAll image DropDown image

Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic (Declaration)
Public Sub New ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
)
Visual C++
public:
BoundingBoxUV (
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Double
The first coordinate of min.
min_v
Double
The second coordinate of min.
max_u
Double
The first coordinate of max.
max_v
Double
The second coordinate of max.

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundingBoxUV
Visual Basic (Declaration)
Public Class BoundingBoxUV
Visual C++
public ref class BoundingBoxUV

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV
Autodesk.Revit.Geometry Namespace


Bounds Property

BoundingBoxUV..::Bounds Property
CollapseAll image DropDown image

Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Bounds[
    int idx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Bounds ( _
    idx As Integer _
) As UV
Visual C++
public:
property UV^ Bounds[int idx] {
    UV^ get (int idx);
}

Parameters

idx
Int32

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


Max Property

BoundingBoxUV..::Max Property
CollapseAll image DropDown image

Maximum coordinates (upper-right corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Max{ get; set;}
Visual Basic (Declaration)
Public Property Max As UV
Visual C++
public:
property UV^ Max {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


Min Property

BoundingBoxUV..::Min Property
CollapseAll image DropDown image

Minimum coordinates (lower-left corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Min{ get; set;}
Visual Basic (Declaration)
Public Property Min As UV
Visual C++
public:
property UV^ Min {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Class
See Also Members
CollapseAll image DropDown image

A three-dimensional rectangular box.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8813BA5C-9BBD-4fb1-B0DF-C03C2DA0CAAE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundingBoxXYZ : APIObject
Visual Basic (Declaration)
<GuidAttribute("8813BA5C-9BBD-4fb1-B0DF-C03C2DA0CAAE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundingBoxXYZ _
    Inherits APIObject
Visual C++
[GuidAttribute(L"8813BA5C-9BBD-4fb1-B0DF-C03C2DA0CAAE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundingBoxXYZ : public APIObject

Remarks

The box is defined as follows. A Transform specifies the coordinate system in which the box is defined. The minimum and maximum values for each coordinate in that system are specified. An alternative way to construct the box is: for each basis vector of the transform, there are two planes that are orthogonal to the vector and have their origins given by Transform.Origin + BasisVector * Bound. The entire box and each face may be turned on or off.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::BoundingBoxXYZ

See Also

BoundingBoxXYZ Members
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundingBoxXYZ
Visual Basic (Declaration)
Public Class BoundingBoxXYZ
Visual C++
public ref class BoundingBoxXYZ

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundingBoxXYZBoundingBoxXYZNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether bounding box is turned on.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
Public property | Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxXYZ()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBoxXYZ ()

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundingBoxXYZ
Visual Basic (Declaration)
Public Class BoundingBoxXYZ
Visual C++
public ref class BoundingBoxXYZ

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundingBoxXYZ
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

BoundingBoxXYZ..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundingBoxXYZ
Visual Basic (Declaration)
Public Class BoundingBoxXYZ
Visual C++
public ref class BoundingBoxXYZ

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether bounding box is turned on.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
Public property | Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ
Autodesk.Revit.Geometry Namespace


BoundEnabled Property

BoundingBoxXYZ..::BoundEnabled Property
CollapseAll image DropDown image

Indexed access for loops.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool BoundEnabled[
    int bound,
    int dim
]{ get; set;}
Visual Basic (Declaration)
Public Property BoundEnabled ( _
    bound As Integer, _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool BoundEnabled[int bound, int dim] {
    bool get (int bound, int dim);
    void set (int bound, int dim, bool value);
}

Parameters

bound
Int32
dim
Int32

Remarks

For bound, use 0 for Min and 1 for Max. For dimension, use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Bounds Property

BoundingBoxXYZ..::Bounds Property
CollapseAll image DropDown image

Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Bounds[
    int bound
]{ get; set;}
Visual Basic (Declaration)
Public Property Bounds ( _
    bound As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Bounds[int bound] {
    XYZ^ get (int bound);
    void set (int bound, XYZ^ value);
}

Parameters

bound
Int32

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Enabled Property

BoundingBoxXYZ..::Enabled Property
CollapseAll image DropDown image

Defines whether bounding box is turned on.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Enabled{ get; set;}
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Max Property

BoundingBoxXYZ..::Max Property
CollapseAll image DropDown image

Maximum coordinates (upper-right-front corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Max{ get; set;}
Visual Basic (Declaration)
Public Property Max As XYZ
Visual C++
public:
property XYZ^ Max {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


MaxEnabled Property

BoundingBoxXYZ..::MaxEnabled Property
CollapseAll image DropDown image

Defines whether the maximum bound is active for given dimension.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool MaxEnabled[
    int dim
]{ get; set;}
Visual Basic (Declaration)
Public Property MaxEnabled ( _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool MaxEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Min Property

BoundingBoxXYZ..::Min Property
CollapseAll image DropDown image

Minimum coordinates (lower-left-rear corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Min{ get; set;}
Visual Basic (Declaration)
Public Property Min As XYZ
Visual C++
public:
property XYZ^ Min {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


MinEnabled Property

BoundingBoxXYZ..::MinEnabled Property
CollapseAll image DropDown image

Defines whether the minimum bound is active for given dimension.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool MinEnabled[
    int dim
]{ get; set;}
Visual Basic (Declaration)
Public Property MinEnabled ( _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool MinEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Transform Property

BoundingBoxXYZ..::Transform Property
CollapseAll image DropDown image

The transform FROM the coordinate space of the box TO the model space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform Transform{ get; set;}
Visual Basic (Declaration)
Public Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

The transform must always be right-handed and orthonormal.

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


ConicalFace Class
See Also Members
CollapseAll image DropDown image

A cone face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D1870B7F-BD63-4046-8E09-3DE05846FCBA")]
public class ConicalFace : Face
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D1870B7F-BD63-4046-8E09-3DE05846FCBA")> _
Public Class ConicalFace _
    Inherits Face
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D1870B7F-BD63-4046-8E09-3DE05846FCBA")]
public ref class ConicalFace : public Face

Remarks

Cone faces are defined by cone surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + v*[sin(HalfAngle)*(cos(u)*Radius[0] + sin(u)*Radius[1]) + cos(HalfAngle)*Axis]

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::ConicalFace

See Also

ConicalFace Members
Autodesk.Revit.Geometry Namespace


ConicalFace Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ConicalFace
Visual Basic (Declaration)
Public Class ConicalFace
Visual C++
public ref class ConicalFace

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConicalFaceConicalFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | HalfAngle | Half angle of the surface.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

ConicalFace
Autodesk.Revit.Geometry Namespace


ConicalFace Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConicalFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConicalFace ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


ConicalFace Properties
CollapseAll image DropDown image

Syntax

C#
public class ConicalFace
Visual Basic (Declaration)
Public Class ConicalFace
Visual C++
public ref class ConicalFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | HalfAngle | Half angle of the surface.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

ConicalFace
Autodesk.Revit.Geometry Namespace


Axis Property

ConicalFace..::Axis Property
CollapseAll image DropDown image

Axis of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Axis{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


HalfAngle Property

ConicalFace..::HalfAngle Property
CollapseAll image DropDown image

Half angle of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HalfAngle{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HalfAngle As Double
Visual C++
public:
property double HalfAngle {
    double get ();
}

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

ConicalFace..::Origin Property
CollapseAll image DropDown image

Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Origin{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Radius Property

ConicalFace..::Radius Property
CollapseAll image DropDown image

Radii of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Radius[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Curve Class
See Also Members
CollapseAll image DropDown image

A parametric curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C1F2AF7E-4873-42b3-A517-1817DC59D6D1")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Curve : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("C1F2AF7E-4873-42b3-A517-1817DC59D6D1")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Curve _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"C1F2AF7E-4873-42b3-A517-1817DC59D6D1")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parametrization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Line
Autodesk.Revit.Geometry..::Arc
Autodesk.Revit.Geometry..::Ellipse
Autodesk.Revit.Geometry..::NurbSpline

See Also

Curve Members
Autodesk.Revit.Geometry Namespace


Curve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Curve
Visual Basic (Declaration)
Public Class Curve
Visual C++
public ref class Curve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurveCurveNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | EndParameter | The parameter of the start or the end point of the curve.
Public property | EndPoint | The start or the end point of this curve.
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Transformed | Applies the specified transformation to this curve and returns the result.

See Also

Curve
Autodesk.Revit.Geometry Namespace


Curve Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Curve ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Curve Methods
CollapseAll image DropDown image

Syntax

C#
public class Curve
Visual Basic (Declaration)
Public Class Curve
Visual C++
public ref class Curve

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

See Also

Curve
Autodesk.Revit.Geometry Namespace


Clone Method

Curve..::Clone Method
CollapseAll image DropDown image

Returns a copy of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Clone()
Visual Basic (Declaration)
Public Function Clone As Curve
Visual C++
public:
Curve^ Clone ()

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


ComputeDerivatives Method

Curve..::ComputeDerivatives Method
CollapseAll image DropDown image

Returns the moving frame around the curve at the specified parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ComputeDerivatives(
    double parameter,
    bool normalized
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double, _
    normalized As Boolean _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives (
    double parameter,
    bool normalized
)

Parameters

parameter
Double
The parameter to be evaluated.
normalized
Boolean
Indicates that the specified parameter is normalized.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the curve (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the bi-normal vector (tangent x normal). Normal and bi-normal are zero if the curve is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified parameter is infinite.
System..::ArgumentOutOfRangeException | Thrown when normalized is true and this curve is unbound or the parameter is not within [0, 1] interval.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


ComputeNormalizedParameter Method

Curve..::ComputeNormalizedParameter Method
CollapseAll image DropDown image

Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ComputeNormalizedParameter(
    double rawParameter
)
Visual Basic (Declaration)
Public Function ComputeNormalizedParameter ( _
    rawParameter As Double _
) As Double
Visual C++
public:
double ComputeNormalizedParameter (
    double rawParameter
)

Parameters

rawParameter
Double
The raw parameter.

Return Value

The real number equal to the normalized curve parameter.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when rawParameter is infinite.
System..::InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


ComputeRawParameter Method

Curve..::ComputeRawParameter Method
CollapseAll image DropDown image

Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ComputeRawParameter(
    double normalizedParameter
)
Visual Basic (Declaration)
Public Function ComputeRawParameter ( _
    normalizedParameter As Double _
) As Double
Visual C++
public:
double ComputeRawParameter (
    double normalizedParameter
)

Parameters

normalizedParameter
Double
The normalized parameter.

Return Value

The real number equal to the raw curve parameter.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when normalizedParameter is infinite.
System..::InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Distance Method

Curve..::Distance Method
CollapseAll image DropDown image

Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Distance(
    XYZ point
)
Visual Basic (Declaration)
Public Function Distance ( _
    point As XYZ _
) As Double
Visual C++
public:
double Distance (
    XYZ^ point
)

Parameters

point
XYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Evaluate Method

Curve..::Evaluate Method
CollapseAll image DropDown image

Evaluates a parameter on the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Evaluate(
    double param,
    bool normalized
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double, _
    normalized As Boolean _
) As XYZ
Visual C++
public:
XYZ^ Evaluate (
    double param,
    bool normalized
)

Parameters

param
Double
The parameter to be evaluated.
normalized
Boolean
If false, param is interpreted as natural parametrization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Intersect Method

Curve..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.

See Also

Curve Class
Curve Members
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve)

Curve..::Intersect Method (Curve)
See Also
CollapseAll image DropDown image

Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve
)

Parameters

curve
Curve
The specified curve to intersect with this curve.

Return Value

The value of SetComparisonResult enumeration that contains the intersection results.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified curve is null.
System..::InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve, IntersectionResultArray)

Curve..::Intersect Method (Curve, IntersectionResultArray%)
See Also
CollapseAll image DropDown image

Calculates the intersection of this curve with the specified curve and returns the intersection results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    ref IntersectionResultArray resultArray
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    ByRef resultArray As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve,
    IntersectionResultArray^% resultArray
)

Parameters

curve
Curve
The specified curve to intersect with this curve.
resultArray
IntersectionResultArray %
Provides more information about the intersection.

Return Value

The value of SetComparisonResult enumeration that contains the intersection results.

Remarks

The array of the intersection results contains one entry for each point where curves intersect. The following is the meaning of IntersectionResult members: XYZPoint is the evaluated intersection point; UVPoint.U is the raw parameter on this curve, UVPoint.V is the raw parameter on the specified curve.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified curve is null.
System..::InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


IsInside Method

Curve..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and returns end index.

See Also

Curve Class
Curve Members
Autodesk.Revit.Geometry Namespace


IsInside Method (Double)

Curve..::IsInside Method (Double)
See Also
CollapseAll image DropDown image

Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInside(
    double parameter
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double _
) As Boolean
Visual C++
public:
bool IsInside (
    double parameter
)

Parameters

parameter
Double
The raw curve parameter to be evaluated.

Return Value

True if the parameter is within the bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified parameter is infinite.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


IsInside Method (Double, Int32)

Curve..::IsInside Method (Double, Int32%)
See Also
CollapseAll image DropDown image

Indicates whether the specified parameter value is within this curve's bounds and returns end index.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInside(
    double parameter,
    ref int end
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double, _
    ByRef end As Integer _
) As Boolean
Visual C++
public:
bool IsInside (
    double parameter,
    int% end
)

Parameters

parameter
Double
The raw curve parameter to be evaluated.
end
Int32 %
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

True if the parameter is within the curve's bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


MakeBound Method

Curve..::MakeBound Method
CollapseAll image DropDown image

Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void MakeBound(
    double startParameter,
    double endParameter
)
Visual Basic (Declaration)
Public Sub MakeBound ( _
    startParameter As Double, _
    endParameter As Double _
)
Visual C++
public:
void MakeBound (
    double startParameter,
    double endParameter
)

Parameters

startParameter
Double
The new parameter of the start point.
endParameter
Double
The new parameter of the end point.

Remarks

This method changes this curve to bound.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified values are infinite.
System..::InvalidOperationException | Thrown when endParameter is smaller than startParameter, or the object is internally marked as read-only.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


MakeUnbound Method

Curve..::MakeUnbound Method
CollapseAll image DropDown image

Makes this curve unbound.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void MakeUnbound()
Visual Basic (Declaration)
Public Sub MakeUnbound
Visual C++
public:
void MakeUnbound ()

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the object is internally marked as read-only.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Project Method

Curve..::Project Method
CollapseAll image DropDown image

Projects the specified point on this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project (
    XYZ^ point
)

Parameters

point
XYZ
The point to be projected.

Return Value

Geometric information if projection is successful.

Remarks

The following is the meaning of every IntersectionResult's members: XYZPoint is the nearest point on the curve; Parameter is the parameter on the curve; Distance is the distance from the point to the curve (equivalent to Distance).

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Tessellate Method

Curve..::Tessellate Method
CollapseAll image DropDown image

Valid only if the curve is bound. Returns a polyline approximation to the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray Tessellate()
Visual Basic (Declaration)
Public Function Tessellate As XYZArray
Visual C++
public:
XYZArray^ Tessellate ()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Curve Properties
CollapseAll image DropDown image

Syntax

C#
public class Curve
Visual Basic (Declaration)
Public Class Curve
Visual C++
public ref class Curve

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | EndParameter | The parameter of the start or the end point of the curve.
Public property | EndPoint | The start or the end point of this curve.
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Transformed | Applies the specified transformation to this curve and returns the result.

See Also

Curve
Autodesk.Revit.Geometry Namespace


ApproximateLength Property

Curve..::ApproximateLength Property
CollapseAll image DropDown image

The approximate length of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApproximateLength{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApproximateLength As Double
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Quickly estimates the length of the curve, may deviate by a factor of 2 in some cases. The computation is exact for lines and arcs.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


EndParameter Property

Curve..::EndParameter Property
CollapseAll image DropDown image

The parameter of the start or the end point of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double EndParameter[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Property EndParameter ( _
    index As Integer _
) As Double
Visual C++
public:
property double EndParameter[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when the specified index is not 0 or 1 both in the getter and setter.
System..::InvalidOperationException | Thrown when the specified parameter is not within curve bounds in the setter, or the object is internally marked as read-only in the setter, or the curve is unbound both in the getter and setter.
System..::NotFiniteNumberException | Thrown when the value of parameter is infinite in the setter.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


EndPoint Property

Curve..::EndPoint Property
CollapseAll image DropDown image

The start or the end point of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ EndPoint[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ EndPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this curve is unbound.
System..::IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


EndPointReference Property

Curve..::EndPointReference Property
CollapseAll image DropDown image

Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Reference EndPointReference[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullptr if reference cannot be obtained.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.
System..::InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


IsBound Property

Curve..::IsBound Property
CollapseAll image DropDown image

Describes whether the parameter of the curve is restricted to a particular interval.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsBound{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsBound As Boolean
Visual C++
public:
property bool IsBound {
    bool get ();
}

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


IsCyclic Property

Curve..::IsCyclic Property
CollapseAll image DropDown image

The boolean value that indicates whether this curve is cyclic.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsCyclic{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic As Boolean
Visual C++
public:
property bool IsCyclic {
    bool get ();
}

Return Value

True if this curve is cyclic; otherwise, false.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Length Property

Curve..::Length Property
CollapseAll image DropDown image

The exact length of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Length{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Period Property

Curve..::Period Property
CollapseAll image DropDown image

The period of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Period{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Period As Double
Visual C++
public:
property double Period {
    double get ();
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the curve is not cyclic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Reference Property

Curve..::Reference Property
CollapseAll image DropDown image

Returns a stable reference to the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Reference Reference{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Transformed Property

Curve..::Transformed Property
CollapseAll image DropDown image

Applies the specified transformation to this curve and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Transformed[
    Transform transform
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Curve
Visual C++
public:
property Curve^ Transformed[Transform^ transform] {
    Curve^ get (Transform^ transform);
}

Parameters

transform
Transform
The transformation to be applied.

Return Value

The transformed curve.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified transformation is null.
System..::InvalidOperationException | Thrown when the transformation is not valid or the transformation application fails.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


CurveArrArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CFDE3105-DD71-4135-B7C3-1DC1B3A9C5E3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurveArrArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("CFDE3105-DD71-4135-B7C3-1DC1B3A9C5E3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"CFDE3105-DD71-4135-B7C3-1DC1B3A9C5E3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::CurveArrArray

See Also

CurveArrArray Members
Autodesk.Revit.Geometry Namespace


CurveArrArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurveArrArray
Visual Basic (Declaration)
Public Class CurveArrArray
Visual C++
public ref class CurveArrArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurveArrArrayCurveArrArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

CurveArrArray
Autodesk.Revit.Geometry Namespace


CurveArrArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArrArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrArray ()

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


CurveArrArray Methods
CollapseAll image DropDown image

Syntax

C#
public class CurveArrArray
Visual Basic (Declaration)
Public Class CurveArrArray
Visual C++
public ref class CurveArrArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurveArrArray
Autodesk.Revit.Geometry Namespace


Append Method

CurveArrArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    CurveArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CurveArray _
)
Visual C++
public:
virtual void Append (
    CurveArray^ item
)

Parameters

item
CurveArray

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

CurveArrArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

CurveArrArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

CurveArrArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurveArrArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

CurveArrArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

CurveArrArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    CurveArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    CurveArray^ item,
    int index
)

Parameters

item
CurveArray
index
Int32

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

CurveArrArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

CurveArrArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurveArrArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


CurveArrArray Properties
CollapseAll image DropDown image

Syntax

C#
public class CurveArrArray
Visual Basic (Declaration)
Public Class CurveArrArray
Visual C++
public ref class CurveArrArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

CurveArrArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

CurveArrArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Item Property

CurveArrArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurveArray Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CurveArray
Visual C++
public:
virtual property CurveArray^ Item[int index] {
    CurveArray^ get (int index);
    void set (int index, CurveArray^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Size Property

CurveArrArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("552D98B4-2921-40d5-BDF6-DEE08BA96789")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class CurveArrArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("552D98B4-2921-40d5-BDF6-DEE08BA96789")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class CurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"552D98B4-2921-40d5-BDF6-DEE08BA96789")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::CurveArrArrayIterator

See Also

CurveArrArrayIterator Members
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CurveArrArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CurveArrArrayIterator
Visual C++
public ref class CurveArrArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurveArrArrayIteratorCurveArrArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArrArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CurveArrArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CurveArrArrayIterator
Visual C++
public ref class CurveArrArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurveArrArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

CurveArrArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

CurveArrArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

CurveArrArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

CurveArrArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CurveArrArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CurveArrArrayIterator
Visual C++
public ref class CurveArrArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

CurveArrArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain curves.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("390919CF-F65D-481d-91DD-DB539B87C904")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurveArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("390919CF-F65D-481d-91DD-DB539B87C904")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"390919CF-F65D-481d-91DD-DB539B87C904")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::CurveArray

See Also

CurveArray Members
Autodesk.Revit.Geometry Namespace


CurveArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurveArray
Visual Basic (Declaration)
Public Class CurveArray
Visual C++
public ref class CurveArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurveArrayCurveArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveArray
Autodesk.Revit.Geometry Namespace


CurveArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArray ()

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


CurveArray Methods
CollapseAll image DropDown image

Syntax

C#
public class CurveArray
Visual Basic (Declaration)
Public Class CurveArray
Visual C++
public ref class CurveArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurveArray
Autodesk.Revit.Geometry Namespace


Append Method

CurveArray..::Append Method
CollapseAll image DropDown image

Add the curve to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Curve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Curve _
)
Visual C++
public:
virtual void Append (
    Curve^ item
)

Parameters

item
Curve
The curve to be added.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

CurveArray..::Clear Method
CollapseAll image DropDown image

Removes every curve from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

CurveArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

CurveArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

CurveArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

CurveArray..::Insert Method
CollapseAll image DropDown image

Insert the specified curve into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Curve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Curve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Curve^ item,
    int index
)

Parameters

item
Curve
The curve to be inserted into the array.
index
Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

CurveArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

CurveArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


CurveArray Properties
CollapseAll image DropDown image

Syntax

C#
public class CurveArray
Visual Basic (Declaration)
Public Class CurveArray
Visual C++
public ref class CurveArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

CurveArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Item Property

CurveArray..::Item Property
CollapseAll image DropDown image

Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Curve Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Curve
Visual C++
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}

Parameters

index
Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Size Property

CurveArray..::Size Property
CollapseAll image DropDown image

Returns the number of curves that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a curve array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2AA28DDC-B988-40d6-93AD-69E770EAF920")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class CurveArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("2AA28DDC-B988-40d6-93AD-69E770EAF920")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class CurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"2AA28DDC-B988-40d6-93AD-69E770EAF920")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::CurveArrayIterator

See Also

CurveArrayIterator Members
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CurveArrayIterator
Visual C++
public ref class CurveArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurveArrayIteratorCurveArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CurveArrayIterator
Visual C++
public ref class CurveArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurveArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

CurveArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

CurveArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

CurveArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

CurveArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CurveArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CurveArrayIterator
Visual C++
public ref class CurveArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

CurveArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


CylindricalFace Class
See Also Members
CollapseAll image DropDown image

A cylinder face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AD4F8A59-1D25-41B1-A755-8CC9AB1216A0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CylindricalFace : Face
Visual Basic (Declaration)
<GuidAttribute("AD4F8A59-1D25-41B1-A755-8CC9AB1216A0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CylindricalFace _
    Inherits Face
Visual C++
[GuidAttribute(L"AD4F8A59-1D25-41B1-A755-8CC9AB1216A0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CylindricalFace : public Face

Remarks

Cylinder faces are defined by cylinder surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + cos(u)*Radius[0] + sin(u)*Radius[1] + v*Axis

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::CylindricalFace

See Also

CylindricalFace Members
Autodesk.Revit.Geometry Namespace


CylindricalFace Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CylindricalFace
Visual Basic (Declaration)
Public Class CylindricalFace
Visual C++
public ref class CylindricalFace

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CylindricalFaceCylindricalFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

CylindricalFace
Autodesk.Revit.Geometry Namespace


CylindricalFace Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CylindricalFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CylindricalFace ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


CylindricalFace Properties
CollapseAll image DropDown image

Syntax

C#
public class CylindricalFace
Visual Basic (Declaration)
Public Class CylindricalFace
Visual C++
public ref class CylindricalFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

CylindricalFace
Autodesk.Revit.Geometry Namespace


Axis Property

CylindricalFace..::Axis Property
CollapseAll image DropDown image

Axis of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Axis{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

CylindricalFace..::Origin Property
CollapseAll image DropDown image

Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Origin{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


Radius Property

CylindricalFace..::Radius Property
CollapseAll image DropDown image

Radii of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Radius[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


DoubleArray Class
See Also Members
CollapseAll image DropDown image

An array that contains doubles.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("43855903-847F-4A33-9B49-818ECB1A2F6D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DoubleArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("43855903-847F-4A33-9B49-818ECB1A2F6D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DoubleArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"43855903-847F-4A33-9B49-818ECB1A2F6D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DoubleArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::DoubleArray

See Also

DoubleArray Members
Autodesk.Revit.Geometry Namespace


DoubleArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DoubleArray
Visual Basic (Declaration)
Public Class DoubleArray
Visual C++
public ref class DoubleArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DoubleArrayDoubleArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray
Autodesk.Revit.Geometry Namespace


DoubleArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DoubleArray ()

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


DoubleArray Methods
CollapseAll image DropDown image

Syntax

C#
public class DoubleArray
Visual Basic (Declaration)
Public Class DoubleArray
Visual C++
public ref class DoubleArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DoubleArray
Autodesk.Revit.Geometry Namespace


Append Method

DoubleArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    ref double item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    ByRef item As Double _
)
Visual C++
public:
virtual void Append (
    double% item
)

Parameters

item
Double %

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

DoubleArray..::Clear Method
CollapseAll image DropDown image

Removes every double from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

DoubleArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

DoubleArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DoubleArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

DoubleArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

DoubleArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    ref double item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    ByRef item As Double, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    double% item,
    int index
)

Parameters

item
Double %
index
Int32

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

DoubleArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

DoubleArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DoubleArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


DoubleArray Properties
CollapseAll image DropDown image

Syntax

C#
public class DoubleArray
Visual Basic (Declaration)
Public Class DoubleArray
Visual C++
public ref class DoubleArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

DoubleArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Item Property

DoubleArray..::Item Property
CollapseAll image DropDown image

Gets or sets a double at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual double Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Double
Visual C++
public:
virtual property double Item[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Int32
The index of the double to be set or retrieved.

Return Value

Returns the double at the specified index.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Size Property

DoubleArray..::Size Property
CollapseAll image DropDown image

Returns the number of doubles that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of doubles.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0645F027-D6D7-4DB5-8C3C-C45A90A858E3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class DoubleArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("0645F027-D6D7-4DB5-8C3C-C45A90A858E3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class DoubleArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"0645F027-D6D7-4DB5-8C3C-C45A90A858E3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DoubleArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::DoubleArrayIterator

See Also

DoubleArrayIterator Members
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DoubleArrayIterator
Visual Basic (Declaration)
Public MustInherit Class DoubleArrayIterator
Visual C++
public ref class DoubleArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DoubleArrayIteratorDoubleArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DoubleArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DoubleArrayIterator
Visual Basic (Declaration)
Public MustInherit Class DoubleArrayIterator
Visual C++
public ref class DoubleArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DoubleArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

DoubleArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

DoubleArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

DoubleArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

DoubleArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DoubleArrayIterator
Visual Basic (Declaration)
Public MustInherit Class DoubleArrayIterator
Visual C++
public ref class DoubleArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

DoubleArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


Edge Class
See Also Members
CollapseAll image DropDown image

An edge of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("247AEC56-4ACB-475f-8980-99F689765B43")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Edge : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("247AEC56-4ACB-475f-8980-99F689765B43")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Edge _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"247AEC56-4ACB-475f-8980-99F689765B43")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parametrization that is normalized to [0,1].

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Edge

See Also

Edge Members
Autodesk.Revit.Geometry Namespace


Edge Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Edge
Visual Basic (Declaration)
Public Class Edge
Visual C++
public ref class Edge

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EdgeEdgeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the edge.

See Also

Edge
Autodesk.Revit.Geometry Namespace


Edge Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Edge()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Edge ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Edge Methods
CollapseAll image DropDown image

Syntax

C#
public class Edge
Visual Basic (Declaration)
Public Class Edge
Visual C++
public ref class Edge

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

See Also

Edge
Autodesk.Revit.Geometry Namespace


ComputeDerivatives Method

Edge..::ComputeDerivatives Method
CollapseAll image DropDown image

Returns the moving frame around the edge at the parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ComputeDerivatives(
    double parameter
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives (
    double parameter
)

Parameters

parameter
Double
The parameter is the natural (or "raw") edge parameter.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation memebers: Origin is the point on the edge (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the binormal vector (tangent x normal). Normal and binormal are zero if the edge is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when parameter is an infinite number.
System..::InvalidOperationException | Thrown when failed to compute derivatives.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Evaluate Method

Edge..::Evaluate Method
CollapseAll image DropDown image

Evaluates a parameter on the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Evaluate(
    double param
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double _
) As XYZ
Visual C++
public:
XYZ^ Evaluate (
    double param
)

Parameters

param
Double
The parameter to be evaluated, in [0,1].

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


EvaluateOnFace Method

Edge..::EvaluateOnFace Method
CollapseAll image DropDown image

Evaluates a parameter on the edge to produce UV coordinates on the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV EvaluateOnFace(
    double param,
    Face face
)
Visual Basic (Declaration)
Public Function EvaluateOnFace ( _
    param As Double, _
    face As Face _
) As UV
Visual C++
public:
UV^ EvaluateOnFace (
    double param,
    Face^ face
)

Parameters

param
Double
The parameter to be evaluated, in [0,1].
face
Face
The face on which to perform the evaluation. Must belong to the edge.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Tessellate Method

Edge..::Tessellate Method
CollapseAll image DropDown image

Returns a polyline approximation to the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray Tessellate()
Visual Basic (Declaration)
Public Function Tessellate As XYZArray
Visual C++
public:
XYZArray^ Tessellate ()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


TessellateOnFace Method

Edge..::TessellateOnFace Method
CollapseAll image DropDown image

Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UVArray TessellateOnFace(
    Face face
)
Visual Basic (Declaration)
Public Function TessellateOnFace ( _
    face As Face _
) As UVArray
Visual C++
public:
UVArray^ TessellateOnFace (
    Face^ face
)

Parameters

face
Face
The face on which to perform the tessellation. Must belong to the edge.

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Edge Properties
CollapseAll image DropDown image

Syntax

C#
public class Edge
Visual Basic (Declaration)
Public Class Edge
Visual C++
public ref class Edge

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the edge.

See Also

Edge
Autodesk.Revit.Geometry Namespace


ApproximateLength Property

Edge..::ApproximateLength Property
CollapseAll image DropDown image

Returns the approximate length of the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ApproximateLength{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ApproximateLength As Double
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Estimates the length of the edge by adding together tesselated segments, Will underestimate when the surface is curved.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


EndPointReference Property

Edge..::EndPointReference Property
CollapseAll image DropDown image

Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Reference EndPointReference[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullptr if reference cannot be obtained.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.
System..::InvalidOperationException | Thrown when the object is internally marked as read-only in the setter.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Face Property

Edge..::Face Property
CollapseAll image DropDown image

Returns one of the two faces that meet at the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Face Face[
    int idx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Face ( _
    idx As Integer _
) As Face
Visual C++
public:
property Face^ Face[int idx] {
    Face^ get (int idx);
}

Parameters

idx
Int32
The index of the face (0 or 1).

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Reference Property

Edge..::Reference Property
CollapseAll image DropDown image

Returns a stable reference to the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Reference Reference{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


EdgeArray Class
See Also Members
CollapseAll image DropDown image

An array that contains edges.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4109D24E-3885-4017-B95C-D9D269CE5C85")]
public class EdgeArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4109D24E-3885-4017-B95C-D9D269CE5C85")> _
Public Class EdgeArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4109D24E-3885-4017-B95C-D9D269CE5C85")]
public ref class EdgeArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::EdgeArray

See Also

EdgeArray Members
Autodesk.Revit.Geometry Namespace


EdgeArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class EdgeArray
Visual Basic (Declaration)
Public Class EdgeArray
Visual C++
public ref class EdgeArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EdgeArrayEdgeArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.

See Also

EdgeArray
Autodesk.Revit.Geometry Namespace


EdgeArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public EdgeArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArray ()

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


EdgeArray Methods
CollapseAll image DropDown image

Syntax

C#
public class EdgeArray
Visual Basic (Declaration)
Public Class EdgeArray
Visual C++
public ref class EdgeArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

EdgeArray
Autodesk.Revit.Geometry Namespace


Append Method

EdgeArray..::Append Method
CollapseAll image DropDown image

Add the edge to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Edge item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Edge _
)
Visual C++
public:
virtual void Append (
    Edge^ item
)

Parameters

item
Edge
The edge to be added.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

EdgeArray..::Clear Method
CollapseAll image DropDown image

Removes every edge from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

EdgeArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

EdgeArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual EdgeArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

EdgeArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

EdgeArray..::Insert Method
CollapseAll image DropDown image

Insert the specified edge into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Edge item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Edge, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Edge^ item,
    int index
)

Parameters

item
Edge
The edge to be inserted into the array.
index
Int32
The edge will be inserted before this index.

Return Value

Returns whether the edge was inserted into the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

EdgeArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

EdgeArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual EdgeArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


EdgeArray Properties
CollapseAll image DropDown image

Syntax

C#
public class EdgeArray
Visual Basic (Declaration)
Public Class EdgeArray
Visual C++
public ref class EdgeArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.

See Also

EdgeArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

EdgeArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Item Property

EdgeArray..::Item Property
CollapseAll image DropDown image

Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Edge Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Edge
Visual C++
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}

Parameters

index
Int32
The index of the edge to be set or retrieved.

Return Value

Returns the edge at the specified index.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Size Property

EdgeArray..::Size Property
CollapseAll image DropDown image

Returns the number of edges that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Class
See Also Members
CollapseAll image DropDown image

An array of edge arrays.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("971D8EBA-99EC-4ba6-A41B-F1C6A869D718")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class EdgeArrayArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("971D8EBA-99EC-4ba6-A41B-F1C6A869D718")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class EdgeArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"971D8EBA-99EC-4ba6-A41B-F1C6A869D718")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class EdgeArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::EdgeArrayArray

See Also

EdgeArrayArray Members
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class EdgeArrayArray
Visual Basic (Declaration)
Public Class EdgeArrayArray
Visual C++
public ref class EdgeArrayArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EdgeArrayArrayEdgeArrayArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public EdgeArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayArray ()

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Methods
CollapseAll image DropDown image

Syntax

C#
public class EdgeArrayArray
Visual Basic (Declaration)
Public Class EdgeArrayArray
Visual C++
public ref class EdgeArrayArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

EdgeArrayArray
Autodesk.Revit.Geometry Namespace


Append Method

EdgeArrayArray..::Append Method
CollapseAll image DropDown image

Add the edge array to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    EdgeArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As EdgeArray _
)
Visual C++
public:
virtual void Append (
    EdgeArray^ item
)

Parameters

item
EdgeArray
The edge array to be added.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

EdgeArrayArray..::Clear Method
CollapseAll image DropDown image

Removes every edge array from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

EdgeArrayArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

EdgeArrayArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual EdgeArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

EdgeArrayArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

EdgeArrayArray..::Insert Method
CollapseAll image DropDown image

Insert the specified edge array into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    EdgeArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As EdgeArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    EdgeArray^ item,
    int index
)

Parameters

item
EdgeArray
The edge array to be inserted into the array.
index
Int32
The edge array will be inserted before this index.

Return Value

Returns whether the edge array was inserted into the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

EdgeArrayArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

EdgeArrayArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual EdgeArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Properties
CollapseAll image DropDown image

Syntax

C#
public class EdgeArrayArray
Visual Basic (Declaration)
Public Class EdgeArrayArray
Visual C++
public ref class EdgeArrayArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

EdgeArrayArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Item Property

EdgeArrayArray..::Item Property
CollapseAll image DropDown image

Gets or sets an edge array at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual EdgeArray Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As EdgeArray
Visual C++
public:
virtual property EdgeArray^ Item[int index] {
    EdgeArray^ get (int index);
    void set (int index, EdgeArray^ value);
}

Parameters

index
Int32
The index of the edge array to be set or retrieved.

Return Value

Returns the edge array at the specified index.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Size Property

EdgeArrayArray..::Size Property
CollapseAll image DropDown image

Returns the number of edge arrays that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array or edge arrays.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67455AF0-78B2-490c-AD83-0329956D84B9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class EdgeArrayArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("67455AF0-78B2-490c-AD83-0329956D84B9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class EdgeArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"67455AF0-78B2-490c-AD83-0329956D84B9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class EdgeArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::EdgeArrayArrayIterator

See Also

EdgeArrayArrayIterator Members
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class EdgeArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayArrayIterator
Visual C++
public ref class EdgeArrayArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EdgeArrayArrayIteratorEdgeArrayArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public EdgeArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class EdgeArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayArrayIterator
Visual C++
public ref class EdgeArrayArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

EdgeArrayArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

EdgeArrayArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

EdgeArrayArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

EdgeArrayArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

EdgeArrayArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class EdgeArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayArrayIterator
Visual C++
public ref class EdgeArrayArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

EdgeArrayArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an edge array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B5554A68-263D-44cf-84A1-7CD364F780B2")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class EdgeArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("B5554A68-263D-44cf-84A1-7CD364F780B2")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class EdgeArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"B5554A68-263D-44cf-84A1-7CD364F780B2")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class EdgeArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::EdgeArrayIterator

See Also

EdgeArrayIterator Members
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class EdgeArrayIterator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayIterator
Visual C++
public ref class EdgeArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EdgeArrayIteratorEdgeArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public EdgeArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class EdgeArrayIterator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayIterator
Visual C++
public ref class EdgeArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

EdgeArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

EdgeArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

EdgeArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

EdgeArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

EdgeArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class EdgeArrayIterator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayIterator
Visual C++
public ref class EdgeArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

EdgeArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


Element Class
See Also Members
CollapseAll image DropDown image

Geometric representation of an element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("92F7301A-D945-450c-9C17-764909E6486D")]
public class Element : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("92F7301A-D945-450c-9C17-764909E6486D")> _
Public Class Element _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"92F7301A-D945-450c-9C17-764909E6486D")]
public ref class Element : public GeometryObject

Remarks

This class contains geometric primitives that are generated from the parametric description of the element.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Element

See Also

Element Members
Autodesk.Revit.Geometry Namespace


Element Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Element
Visual Basic (Declaration)
Public Class Element
Visual C++
public ref class Element

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementElementNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed. (Overrides GeometryObject ..::MaterialElement()().)
Public property | Objects | All geometric primitives contained in the element.

See Also

Element
Autodesk.Revit.Geometry Namespace


Element Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Element ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Element Properties
CollapseAll image DropDown image

Syntax

C#
public class Element
Visual Basic (Declaration)
Public Class Element
Visual C++
public ref class Element

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed. (Overrides GeometryObject ..::MaterialElement()().)
Public property | Objects | All geometric primitives contained in the element.

See Also

Element
Autodesk.Revit.Geometry Namespace


MaterialElement Property

Element..::MaterialElement Property
CollapseAll image DropDown image

Element describing the material from which this element is composed.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Material MaterialElement{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property MaterialElement As Material
Visual C++
public:
virtual property Material^ MaterialElement {
    Material^ get () override;
}

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Objects Property

Element..::Objects Property
CollapseAll image DropDown image

All geometric primitives contained in the element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GeometryObjectArray Objects{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Objects As GeometryObjectArray
Visual C++
public:
property GeometryObjectArray^ Objects {
    GeometryObjectArray^ get ();
}

Remarks

Branching on dynamic type of the objects is advised. Faces and edges are contained in solids and never directly in an element.

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Ellipse Class
See Also Members
CollapseAll image DropDown image

A whole or partial ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("99427A0B-C429-44ac-8510-3F798396D14F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Ellipse : Curve
Visual Basic (Declaration)
<GuidAttribute("99427A0B-C429-44ac-8510-3F798396D14F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Ellipse _
    Inherits Curve
Visual C++
[GuidAttribute(L"99427A0B-C429-44ac-8510-3F798396D14F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Ellipse : public Curve

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Ellipse

See Also

Ellipse Members
Autodesk.Revit.Geometry Namespace


Ellipse Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Ellipse
Visual Basic (Declaration)
Public Class Ellipse
Visual C++
public ref class Ellipse

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EllipseEllipseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the ellipse.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)

See Also

Ellipse
Autodesk.Revit.Geometry Namespace


Ellipse Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Ellipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Ellipse ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Ellipse Properties
CollapseAll image DropDown image

Syntax

C#
public class Ellipse
Visual Basic (Declaration)
Public Class Ellipse
Visual C++
public ref class Ellipse

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the ellipse.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)

See Also

Ellipse
Autodesk.Revit.Geometry Namespace


Center Property

Ellipse..::Center Property
CollapseAll image DropDown image

Returns the center of the ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Center{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Center As XYZ
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Normal Property

Ellipse..::Normal Property
CollapseAll image DropDown image

Returns the normal to the plane in which the ellipse is defined.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Normal{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


RadiusX Property

Ellipse..::RadiusX Property
CollapseAll image DropDown image

Returns the X vector radius of the ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double RadiusX{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RadiusX As Double
Visual C++
public:
property double RadiusX {
    double get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


RadiusY Property

Ellipse..::RadiusY Property
CollapseAll image DropDown image

Returns the Y vector radius of the ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double RadiusY{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RadiusY As Double
Visual C++
public:
property double RadiusY {
    double get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Face Class
See Also Members
CollapseAll image DropDown image

A face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D0ADC7CF-97FB-4903-BEC1-5D0CA2FA047D")]
public class Face : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D0ADC7CF-97FB-4903-BEC1-5D0CA2FA047D")> _
Public Class Face _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D0ADC7CF-97FB-4903-BEC1-5D0CA2FA047D")]
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::ConicalFace
Autodesk.Revit.Geometry..::CylindricalFace
Autodesk.Revit.Geometry..::HermiteFace
Autodesk.Revit.Geometry..::PlanarFace
Autodesk.Revit.Geometry..::RevolvedFace
Autodesk.Revit.Geometry..::RuledFace

See Also

Face Members
Autodesk.Revit.Geometry Namespace


Face Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Face
Visual Basic (Declaration)
Public Class Face
Visual C++
public ref class Face

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FaceFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElement | Element describing the material from which this face is composed. (Overrides GeometryObject ..::MaterialElement()().)
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.

See Also

Face
Autodesk.Revit.Geometry Namespace


Face Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Face()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Face ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Face Methods
CollapseAll image DropDown image

Syntax

C#
public class Face
Visual Basic (Declaration)
Public Class Face
Visual C++
public ref class Face

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

See Also

Face
Autodesk.Revit.Geometry Namespace


ComputeDerivatives Method

Face..::ComputeDerivatives Method
CollapseAll image DropDown image

Returns the moving frame around the face at the specified parameters.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ComputeDerivatives(
    UV point
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    point As UV _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives (
    UV^ point
)

Parameters

point
UV
The parameters to be evaluated, in natural parametrization of the face.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the face; (equivalent to Evaluate); BasisX is the tangent vector along the U coordinate; (partial derivative with respect to U); BasisY is the tangent vector along the V coordinate; (partial derivative with respect to V); BasisZ is the normal vector. None of the vectors are normalized.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Evaluate Method

Face..::Evaluate Method
CollapseAll image DropDown image

Evaluates parameters on the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Evaluate(
    UV params
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    params As UV _
) As XYZ
Visual C++
public:
XYZ^ Evaluate (
    UV^ params
)

Parameters

params
UV
The parameters to be evaluated, in natural parametrization of the face.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Intersect Method

Face..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.

See Also

Face Class
Face Members
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve)

Face..::Intersect Method (Curve)
See Also
CollapseAll image DropDown image

Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve
)

Parameters

curve
Curve
The specified curve to intersect with this face.

Return Value

The type of the intersection.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the argument curve is null.
System..::InvalidOperationException | Thrown when the intersection calculation fails.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve, IntersectionResultArray)

Face..::Intersect Method (Curve, IntersectionResultArray%)
See Also
CollapseAll image DropDown image

Calculates the intersection of the specified curve with this face and returns the intersection results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    ref IntersectionResultArray results
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    ByRef results As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve,
    IntersectionResultArray^% results
)

Parameters

curve
Curve
The specified curve to intersect with this face.
results
IntersectionResultArray %
Provides more information about the intersection.

Return Value

The type of the intersection.

Remarks

The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members: XYZPoint is the evaluated intersection point; UVPoint is the intersection parameters on the face; Parameter is the raw intersection parameter on the curve; EdgeObject is the edge if the intersection happens to be near an edge of face; EdgeParameter is the parameter of the nearest point on the edge.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the curve is null.
System..::InvalidOperationException | Thrown when the intersection calculation fails.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


IsInside Method

Face..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and returns additional results.

See Also

Face Class
Face Members
Autodesk.Revit.Geometry Namespace


IsInside Method (UV)

Face..::IsInside Method (UV)
See Also
CollapseAll image DropDown image

Indicates whether the specified point is within this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInside(
    UV point
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV _
) As Boolean
Visual C++
public:
bool IsInside (
    UV^ point
)

Parameters

point
UV
The parameters to be evaluated, in natural parametrization of the face.

Return Value

True if point is within this face, otherwise false.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


IsInside Method (UV, IntersectionResult)

Face..::IsInside Method (UV, IntersectionResult%)
See Also
CollapseAll image DropDown image

Indicates whether the specified point is within this face and returns additional results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInside(
    UV point,
    ref IntersectionResult result
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV, _
    ByRef result As IntersectionResult _
) As Boolean
Visual C++
public:
bool IsInside (
    UV^ point,
    IntersectionResult^% result
)

Parameters

point
UV
The parameters to be evaluated, in natural parametrization of the face.
result
IntersectionResult %
Provides more information when the point is on the edge; otherwise, nullptr.

Return Value

Returns true is within this face, otherwise false.

Remarks

The following is the meaning of the IntersectionResult members when the point is on the edge: EdgeObject is the edge that the point lies on; EdgeParameter is the parameter of the point on the edge nearest to the UV point; UV is the specified point.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Project Method

Face..::Project Method
CollapseAll image DropDown image

Projects the specified point on this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project (
    XYZ^ point
)

Parameters

point
XYZ
The point to be projected.

Return Value

Geometric information if projection is successful; if projection fails or the nearest point is outside of this face, returns null.

Remarks

The following is the meaning of IntersectionResult's members:
XYZPoint is the nearest point to the projected point on the face;
UVPoint is the UV coordinates of the nearest point on the face;
Distance is the distance from the point to the face;
EdgeObject is the edge if projected point is near an edge;
EdgeParameter is the parameter of the nearest point on the edge.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Triangulate Method

Face..::Triangulate Method
CollapseAll image DropDown image

Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Mesh Triangulate()
Visual Basic (Declaration)
Public Function Triangulate As Mesh
Visual C++
public:
Mesh^ Triangulate ()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Face Properties
CollapseAll image DropDown image

Syntax

C#
public class Face
Visual Basic (Declaration)
Public Class Face
Visual C++
public ref class Face

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElement | Element describing the material from which this face is composed. (Overrides GeometryObject ..::MaterialElement()().)
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.

See Also

Face
Autodesk.Revit.Geometry Namespace


Area Property

Face..::Area Property
CollapseAll image DropDown image

The area of this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Area{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

Returns zero if fails to compute the area. Estimates the area of this face by integrating tessellated edges. Will slightly underestimate when the edges are curved.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


EdgeLoops Property

Face..::EdgeLoops Property
CollapseAll image DropDown image

Each edge loop is a closed boundary of the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public EdgeArrayArray EdgeLoops{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EdgeLoops As EdgeArrayArray
Visual C++
public:
property EdgeArrayArray^ EdgeLoops {
    EdgeArrayArray^ get ();
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


IsCyclic Property

Face..::IsCyclic Property
CollapseAll image DropDown image

The boolean value that indicates whether this face is periodic in the specified parametric direction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsCyclic[
    int paramIdx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic ( _
    paramIdx As Integer _
) As Boolean
Visual C++
public:
property bool IsCyclic[int paramIdx] {
    bool get (int paramIdx);
}

Parameters

paramIdx
Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

True if this face is cyclic; otherwise, false.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


IsTwoSided Property

Face..::IsTwoSided Property
CollapseAll image DropDown image

Determines if a face is two-sided (degenerate)

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsTwoSided{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTwoSided As Boolean
Visual C++
public:
virtual property bool IsTwoSided {
    bool get ();
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


MaterialElement Property

Face..::MaterialElement Property
CollapseAll image DropDown image

Element describing the material from which this face is composed.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Material MaterialElement{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property MaterialElement As Material
Visual C++
public:
virtual property Material^ MaterialElement {
    Material^ get () override;
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Period Property

Face..::Period Property
CollapseAll image DropDown image

The period of this face in the specified parametric direction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Period[
    int paramIdx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Period ( _
    paramIdx As Integer _
) As Double
Visual C++
public:
property double Period[int paramIdx] {
    double get (int paramIdx);
}

Parameters

paramIdx
Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

The real number equal to the period of this face.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.
System..::InvalidOperationException | Thrown when this face is not cyclic in the specified direction.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Reference Property

Face..::Reference Property
CollapseAll image DropDown image

Returns a stable reference to the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Reference Reference{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


FaceArray Class
See Also Members
CollapseAll image DropDown image

An array that contains faces.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6B81C639-5F31-4c5f-97D5-B9FCD43732D6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FaceArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("6B81C639-5F31-4c5f-97D5-B9FCD43732D6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FaceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"6B81C639-5F31-4c5f-97D5-B9FCD43732D6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FaceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::FaceArray

See Also

FaceArray Members
Autodesk.Revit.Geometry Namespace


FaceArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FaceArray
Visual Basic (Declaration)
Public Class FaceArray
Visual C++
public ref class FaceArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FaceArrayFaceArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.

See Also

FaceArray
Autodesk.Revit.Geometry Namespace


FaceArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FaceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FaceArray ()

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


FaceArray Methods
CollapseAll image DropDown image

Syntax

C#
public class FaceArray
Visual Basic (Declaration)
Public Class FaceArray
Visual C++
public ref class FaceArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FaceArray
Autodesk.Revit.Geometry Namespace


Append Method

FaceArray..::Append Method
CollapseAll image DropDown image

Add the face to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Face item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Face _
)
Visual C++
public:
virtual void Append (
    Face^ item
)

Parameters

item
Face
The face to be added.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

FaceArray..::Clear Method
CollapseAll image DropDown image

Removes every face from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

FaceArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

FaceArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FaceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

FaceArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

FaceArray..::Insert Method
CollapseAll image DropDown image

Insert the specified face into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Face item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Face, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Face^ item,
    int index
)

Parameters

item
Face
The face to be inserted into the array.
index
Int32
The face will be inserted before this index.

Return Value

Returns whether the face was inserted into the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

FaceArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

FaceArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FaceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


FaceArray Properties
CollapseAll image DropDown image

Syntax

C#
public class FaceArray
Visual Basic (Declaration)
Public Class FaceArray
Visual C++
public ref class FaceArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.

See Also

FaceArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

FaceArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Item Property

FaceArray..::Item Property
CollapseAll image DropDown image

Gets or sets a face at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Face Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Face
Visual C++
public:
virtual property Face^ Item[int index] {
    Face^ get (int index);
    void set (int index, Face^ value);
}

Parameters

index
Int32
The index of the face to be set or retrieved.

Return Value

Returns the face at the specified index.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Size Property

FaceArray..::Size Property
CollapseAll image DropDown image

Returns the number of faces that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a face array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A6F04AF3-0F69-45bd-A53C-D12431A20D46")]
public abstract class FaceArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A6F04AF3-0F69-45bd-A53C-D12431A20D46")> _
Public MustInherit Class FaceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A6F04AF3-0F69-45bd-A53C-D12431A20D46")]
public ref class FaceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::FaceArrayIterator

See Also

FaceArrayIterator Members
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class FaceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class FaceArrayIterator
Visual C++
public ref class FaceArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FaceArrayIteratorFaceArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FaceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FaceArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class FaceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class FaceArrayIterator
Visual C++
public ref class FaceArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FaceArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

FaceArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

FaceArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

FaceArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

FaceArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class FaceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class FaceArrayIterator
Visual C++
public ref class FaceArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

FaceArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


GeometryObject Class
See Also Members
CollapseAll image DropDown image

The common base class for all geometric primitives.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1E32AE6C-FD44-4e70-8A8F-B10899AF59CE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GeometryObject : APIObject
Visual Basic (Declaration)
<GuidAttribute("1E32AE6C-FD44-4e70-8A8F-B10899AF59CE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GeometryObject _
    Inherits APIObject
Visual C++
[GuidAttribute(L"1E32AE6C-FD44-4e70-8A8F-B10899AF59CE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GeometryObject : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Profile
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::Edge
Autodesk.Revit.Geometry..::Element
Autodesk.Revit.Geometry..::Mesh
Autodesk.Revit.Geometry..::Instance
Autodesk.Revit.Geometry..::Solid

See Also

GeometryObject Members
Autodesk.Revit.Geometry Namespace


GeometryObject Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GeometryObject
Visual Basic (Declaration)
Public Class GeometryObject
Visual C++
public ref class GeometryObject

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GeometryObjectGeometryObjectNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObject
Autodesk.Revit.Geometry Namespace


GeometryObject Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GeometryObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObject ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeometryObject Class
Autodesk.Revit.Geometry Namespace


GeometryObject Methods
CollapseAll image DropDown image

Syntax

C#
public class GeometryObject
Visual Basic (Declaration)
Public Class GeometryObject
Visual C++
public ref class GeometryObject

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GeometryObject
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

GeometryObject..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GeometryObject Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Class
See Also Members
CollapseAll image DropDown image

An array that contains geometry objects.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("90A26AEE-4454-4ace-93D0-34C070D64DEB")]
public class GeometryObjectArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("90A26AEE-4454-4ace-93D0-34C070D64DEB")> _
Public Class GeometryObjectArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"90A26AEE-4454-4ace-93D0-34C070D64DEB")]
public ref class GeometryObjectArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObjectArray

See Also

GeometryObjectArray Members
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GeometryObjectArray
Visual Basic (Declaration)
Public Class GeometryObjectArray
Visual C++
public ref class GeometryObjectArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GeometryObjectArrayGeometryObjectArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the geometry object to the end of the array.
Public method | Clear | Removes every geometry object from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified geometry object into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a geometry object at a specified index within the array.
Public property | Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GeometryObjectArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObjectArray ()

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Methods
CollapseAll image DropDown image

Syntax

C#
public class GeometryObjectArray
Visual Basic (Declaration)
Public Class GeometryObjectArray
Visual C++
public ref class GeometryObjectArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the geometry object to the end of the array.
Public method | Clear | Removes every geometry object from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified geometry object into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GeometryObjectArray
Autodesk.Revit.Geometry Namespace


Append Method

GeometryObjectArray..::Append Method
CollapseAll image DropDown image

Add the geometry object to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    GeometryObject item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As GeometryObject _
)
Visual C++
public:
virtual void Append (
    GeometryObject^ item
)

Parameters

item
GeometryObject
The geometry object to be added.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

GeometryObjectArray..::Clear Method
CollapseAll image DropDown image

Removes every geometry object from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

GeometryObjectArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

GeometryObjectArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GeometryObjectArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

GeometryObjectArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

GeometryObjectArray..::Insert Method
CollapseAll image DropDown image

Insert the specified geometry object into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    GeometryObject item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As GeometryObject, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    GeometryObject^ item,
    int index
)

Parameters

item
GeometryObject
The geometry object to be inserted into the array.
index
Int32
The geometry object will be inserted before this index.

Return Value

Returns whether the geometry object was inserted into the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

GeometryObjectArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

GeometryObjectArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GeometryObjectArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Properties
CollapseAll image DropDown image

Syntax

C#
public class GeometryObjectArray
Visual Basic (Declaration)
Public Class GeometryObjectArray
Visual C++
public ref class GeometryObjectArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a geometry object at a specified index within the array.
Public property | Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

GeometryObjectArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Item Property

GeometryObjectArray..::Item Property
CollapseAll image DropDown image

Gets or sets a geometry object at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GeometryObject Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As GeometryObject
Visual C++
public:
virtual property GeometryObject^ Item[int index] {
    GeometryObject^ get (int index);
    void set (int index, GeometryObject^ value);
}

Parameters

index
Int32
The index of the geometry object to be set or retrieved.

Return Value

Returns the geometry object at the specified index.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Size Property

GeometryObjectArray..::Size Property
CollapseAll image DropDown image

Returns the number of geometry objects that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a geometry object array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F8BAD43C-CE1B-4bd0-8B29-AD0F396E19E0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class GeometryObjectArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("F8BAD43C-CE1B-4bd0-8B29-AD0F396E19E0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class GeometryObjectArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"F8BAD43C-CE1B-4bd0-8B29-AD0F396E19E0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GeometryObjectArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObjectArrayIterator

See Also

GeometryObjectArrayIterator Members
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class GeometryObjectArrayIterator
Visual Basic (Declaration)
Public MustInherit Class GeometryObjectArrayIterator
Visual C++
public ref class GeometryObjectArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GeometryObjectArrayIteratorGeometryObjectArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GeometryObjectArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObjectArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class GeometryObjectArrayIterator
Visual Basic (Declaration)
Public MustInherit Class GeometryObjectArrayIterator
Visual C++
public ref class GeometryObjectArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GeometryObjectArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

GeometryObjectArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

GeometryObjectArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

GeometryObjectArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

GeometryObjectArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class GeometryObjectArrayIterator
Visual Basic (Declaration)
Public MustInherit Class GeometryObjectArrayIterator
Visual C++
public ref class GeometryObjectArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

GeometryObjectArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


HermiteFace Class
See Also Members
CollapseAll image DropDown image

A cubic hermite spline face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CC0AF75F-6778-4C89-995E-96906F6B6929")]
public class HermiteFace : Face
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CC0AF75F-6778-4C89-995E-96906F6B6929")> _
Public Class HermiteFace _
    Inherits Face
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CC0AF75F-6778-4C89-995E-96906F6B6929")]
public ref class HermiteFace : public Face

Remarks

Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::HermiteFace

See Also

HermiteFace Members
Autodesk.Revit.Geometry Namespace


HermiteFace Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class HermiteFace
Visual Basic (Declaration)
Public Class HermiteFace
Visual C++
public ref class HermiteFace

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | HermiteFaceHermiteFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | Params | Parameters of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Tangents | Tangents of the surface.

See Also

HermiteFace
Autodesk.Revit.Geometry Namespace


HermiteFace Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public HermiteFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HermiteFace ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


HermiteFace Properties
CollapseAll image DropDown image

Syntax

C#
public class HermiteFace
Visual Basic (Declaration)
Public Class HermiteFace
Visual C++
public ref class HermiteFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | Params | Parameters of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Tangents | Tangents of the surface.

See Also

HermiteFace
Autodesk.Revit.Geometry Namespace


MixedDerivs Property

HermiteFace..::MixedDerivs Property
CollapseAll image DropDown image

Mixed derivatives of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray MixedDerivs{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MixedDerivs As XYZArray
Visual C++
public:
property XYZArray^ MixedDerivs {
    XYZArray^ get ();
}

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Params Property

HermiteFace..::Params Property
CollapseAll image DropDown image

Parameters of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray Params[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Params ( _
    index As Integer _
) As DoubleArray
Visual C++
public:
property DoubleArray^ Params[int index] {
    DoubleArray^ get (int index);
}

Parameters

index
Int32

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Points Property

HermiteFace..::Points Property
CollapseAll image DropDown image

Interpolation points of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray Points{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Points As XYZArray
Visual C++
public:
property XYZArray^ Points {
    XYZArray^ get ();
}

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Tangents Property

HermiteFace..::Tangents Property
CollapseAll image DropDown image

Tangents of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray Tangents[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Tangents ( _
    index As Integer _
) As XYZArray
Visual C++
public:
property XYZArray^ Tangents[int index] {
    XYZArray^ get (int index);
}

Parameters

index
Int32

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Instance Class
See Also Members
CollapseAll image DropDown image

An instance of another element (symbol), specially positioned by this element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7EEA590E-DD5F-430b-BF42-18D457CBE5C0")]
public class Instance : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7EEA590E-DD5F-430b-BF42-18D457CBE5C0")> _
Public Class Instance _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7EEA590E-DD5F-430b-BF42-18D457CBE5C0")]
public ref class Instance : public GeometryObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Instance

See Also

Instance Members
Autodesk.Revit.Geometry Namespace


Instance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Instance
Visual Basic (Declaration)
Public Class Instance
Visual C++
public ref class Instance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Transformed | Transforms this instance and returns the result.

See Also

Instance
Autodesk.Revit.Geometry Namespace


Instance Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Instance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Instance ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


Instance Properties
CollapseAll image DropDown image

Syntax

C#
public class Instance
Visual Basic (Declaration)
Public Class Instance
Visual C++
public ref class Instance

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Transformed | Transforms this instance and returns the result.

See Also

Instance
Autodesk.Revit.Geometry Namespace


Symbol Property

Instance..::Symbol Property
CollapseAll image DropDown image

The symbol element that this object is referring to.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Symbol{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Symbol As Element
Visual C++
public:
property Element^ Symbol {
    Element^ get ();
}

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


SymbolGeometry Property

Instance..::SymbolGeometry Property
CollapseAll image DropDown image

The geometric representation of the symbol.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element SymbolGeometry{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SymbolGeometry As Element
Visual C++
public:
property Element^ SymbolGeometry {
    Element^ get ();
}

Remarks

This method is here because Autodesk.Revit.Element.Geometry will not return anything if the element is a symbol. Note that the symbol geometry will not be transformed by this call. It will still be defined in the local coordinate system of the symbol. However, the context of the Instance object (such as effective material) will be applied to the symbol. Ordinarily, this should not matter because the symbol is supposed to define its own context. Also, note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Symbol geometry will be parsed with the same options as those used when this object was retrieved.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


Transform Property

Instance..::Transform Property
CollapseAll image DropDown image

The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform Transform{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


Transformed Property

Instance..::Transformed Property
CollapseAll image DropDown image

Transforms this instance and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Instance Transformed[
    Transform transform
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Instance
Visual C++
public:
property Instance^ Transformed[Transform^ transform] {
    Instance^ get (Transform^ transform);
}

Parameters

transform
Transform
The transformation used to transform the instance.

Return Value

The transformed instance.

Remarks

Concatenates the specified transformation so that it is applied after the transformation of this instance.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


InstanceArray Class
See Also Members
CollapseAll image DropDown image

An array that contains instances.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FAA6E9DD-F19F-4de8-B574-CF061031BB63")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class InstanceArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("FAA6E9DD-F19F-4de8-B574-CF061031BB63")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class InstanceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"FAA6E9DD-F19F-4de8-B574-CF061031BB63")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class InstanceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::InstanceArray

See Also

InstanceArray Members
Autodesk.Revit.Geometry Namespace


InstanceArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InstanceArray
Visual Basic (Declaration)
Public Class InstanceArray
Visual C++
public ref class InstanceArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceArrayInstanceArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the instance to the end of the array.
Public method | Clear | Removes every instance from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified instance into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an instance at a specified index within the array.
Public property | Size | Returns the number of instances that are in the array.

See Also

InstanceArray
Autodesk.Revit.Geometry Namespace


InstanceArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceArray ()

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


InstanceArray Methods
CollapseAll image DropDown image

Syntax

C#
public class InstanceArray
Visual Basic (Declaration)
Public Class InstanceArray
Visual C++
public ref class InstanceArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the instance to the end of the array.
Public method | Clear | Removes every instance from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified instance into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

InstanceArray
Autodesk.Revit.Geometry Namespace


Append Method

InstanceArray..::Append Method
CollapseAll image DropDown image

Add the instance to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Instance item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Instance _
)
Visual C++
public:
virtual void Append (
    Instance^ item
)

Parameters

item
Instance
The instance to be added.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

InstanceArray..::Clear Method
CollapseAll image DropDown image

Removes every instance from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

InstanceArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

InstanceArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual InstanceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

InstanceArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

InstanceArray..::Insert Method
CollapseAll image DropDown image

Insert the specified instance into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Instance item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Instance, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Instance^ item,
    int index
)

Parameters

item
Instance
The instance to be inserted into the array.
index
Int32
The instance will be inserted before this index.

Return Value

Returns whether the instance was inserted into the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

InstanceArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

InstanceArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual InstanceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


InstanceArray Properties
CollapseAll image DropDown image

Syntax

C#
public class InstanceArray
Visual Basic (Declaration)
Public Class InstanceArray
Visual C++
public ref class InstanceArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an instance at a specified index within the array.
Public property | Size | Returns the number of instances that are in the array.

See Also

InstanceArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

InstanceArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Item Property

InstanceArray..::Item Property
CollapseAll image DropDown image

Gets or sets an instance at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Instance Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Instance
Visual C++
public:
virtual property Instance^ Item[int index] {
    Instance^ get (int index);
    void set (int index, Instance^ value);
}

Parameters

index
Int32
The index of the instance to be set or retrieved.

Return Value

Returns the instance at the specified index.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Size Property

InstanceArray..::Size Property
CollapseAll image DropDown image

Returns the number of instances that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an instance array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9DA1D933-A299-4039-A213-CFB8FB1D0A75")]
public abstract class InstanceArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9DA1D933-A299-4039-A213-CFB8FB1D0A75")> _
Public MustInherit Class InstanceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9DA1D933-A299-4039-A213-CFB8FB1D0A75")]
public ref class InstanceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::InstanceArrayIterator

See Also

InstanceArrayIterator Members
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class InstanceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class InstanceArrayIterator
Visual C++
public ref class InstanceArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceArrayIteratorInstanceArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class InstanceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class InstanceArrayIterator
Visual C++
public ref class InstanceArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

InstanceArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

InstanceArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

InstanceArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

InstanceArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

InstanceArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class InstanceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class InstanceArrayIterator
Visual C++
public ref class InstanceArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

InstanceArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


IntersectionResult Class
See Also Members
CollapseAll image DropDown image

This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8C8658C4-68AD-4b18-B304-1E22A91C063B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class IntersectionResult : APIObject
Visual Basic (Declaration)
<GuidAttribute("8C8658C4-68AD-4b18-B304-1E22A91C063B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class IntersectionResult _
    Inherits APIObject
Visual C++
[GuidAttribute(L"8C8658C4-68AD-4b18-B304-1E22A91C063B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class IntersectionResult : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::IntersectionResult

See Also

IntersectionResult Members
Autodesk.Revit.Geometry Namespace


IntersectionResult Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class IntersectionResult
Visual Basic (Declaration)
Public Class IntersectionResult
Visual C++
public ref class IntersectionResult

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | IntersectionResultIntersectionResultNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult
Autodesk.Revit.Geometry Namespace


IntersectionResult Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IntersectionResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResult ()

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


IntersectionResult Properties
CollapseAll image DropDown image

Syntax

C#
public class IntersectionResult
Visual Basic (Declaration)
Public Class IntersectionResult
Visual C++
public ref class IntersectionResult

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult
Autodesk.Revit.Geometry Namespace


Distance Property

IntersectionResult..::Distance Property
CollapseAll image DropDown image

Distance from the original object to located point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Distance{ get; internal set;}
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


EdgeObject Property

IntersectionResult..::EdgeObject Property
CollapseAll image DropDown image

Edge of the face close to the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Edge EdgeObject{ get; internal set;}
Visual Basic (Declaration)
Public Property EdgeObject As Edge
Visual C++
public:
property Edge^ EdgeObject {
    Edge^ get ();
    void set (Edge^ value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


EdgeParameter Property

IntersectionResult..::EdgeParameter Property
CollapseAll image DropDown image

Parameter of a point on the edge closest to the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double EdgeParameter{ get; internal set;}
Visual Basic (Declaration)
Public Property EdgeParameter As Double
Visual C++
public:
property double EdgeParameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


Parameter Property

IntersectionResult..::Parameter Property
CollapseAll image DropDown image

1d parameter of the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Parameter{ get; internal set;}
Visual Basic (Declaration)
Public Property Parameter As Double
Visual C++
public:
property double Parameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


UVPoint Property

IntersectionResult..::UVPoint Property
CollapseAll image DropDown image

2d (or two 1d) parameters of the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV UVPoint{ get; internal set;}
Visual Basic (Declaration)
Public Property UVPoint As UV
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


XYZPoint Property

IntersectionResult..::XYZPoint Property
CollapseAll image DropDown image

Point of intersection in local 3d coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ XYZPoint{ get; internal set;}
Visual Basic (Declaration)
Public Property XYZPoint As XYZ
Visual C++
public:
property XYZ^ XYZPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1EB5B58F-D9FA-4874-8211-4B26DE119EBE")]
public class IntersectionResultArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1EB5B58F-D9FA-4874-8211-4B26DE119EBE")> _
Public Class IntersectionResultArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1EB5B58F-D9FA-4874-8211-4B26DE119EBE")]
public ref class IntersectionResultArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::IntersectionResultArray

See Also

IntersectionResultArray Members
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class IntersectionResultArray
Visual Basic (Declaration)
Public Class IntersectionResultArray
Visual C++
public ref class IntersectionResultArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | IntersectionResultArrayIntersectionResultArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IntersectionResultArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResultArray ()

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Methods
CollapseAll image DropDown image

Syntax

C#
public class IntersectionResultArray
Visual Basic (Declaration)
Public Class IntersectionResultArray
Visual C++
public ref class IntersectionResultArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

IntersectionResultArray
Autodesk.Revit.Geometry Namespace


Append Method

IntersectionResultArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    IntersectionResult item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As IntersectionResult _
)
Visual C++
public:
virtual void Append (
    IntersectionResult^ item
)

Parameters

item
IntersectionResult

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

IntersectionResultArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

IntersectionResultArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

IntersectionResultArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IntersectionResultArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

IntersectionResultArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

IntersectionResultArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    IntersectionResult item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As IntersectionResult, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    IntersectionResult^ item,
    int index
)

Parameters

item
IntersectionResult
index
Int32

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

IntersectionResultArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

IntersectionResultArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IntersectionResultArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Properties
CollapseAll image DropDown image

Syntax

C#
public class IntersectionResultArray
Visual Basic (Declaration)
Public Class IntersectionResultArray
Visual C++
public ref class IntersectionResultArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

IntersectionResultArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Item Property

IntersectionResultArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IntersectionResult Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As IntersectionResult
Visual C++
public:
virtual property IntersectionResult^ Item[int index] {
    IntersectionResult^ get (int index);
    void set (int index, IntersectionResult^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Size Property

IntersectionResultArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("858476B4-8D84-404b-B8AB-5AC70D7334C9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class IntersectionResultArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("858476B4-8D84-404b-B8AB-5AC70D7334C9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class IntersectionResultArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"858476B4-8D84-404b-B8AB-5AC70D7334C9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class IntersectionResultArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::IntersectionResultArrayIterator

See Also

IntersectionResultArrayIterator Members
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class IntersectionResultArrayIterator
Visual Basic (Declaration)
Public MustInherit Class IntersectionResultArrayIterator
Visual C++
public ref class IntersectionResultArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | IntersectionResultArrayIteratorIntersectionResultArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IntersectionResultArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResultArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class IntersectionResultArrayIterator
Visual Basic (Declaration)
Public MustInherit Class IntersectionResultArrayIterator
Visual C++
public ref class IntersectionResultArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

IntersectionResultArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

IntersectionResultArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

IntersectionResultArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

IntersectionResultArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

IntersectionResultArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class IntersectionResultArrayIterator
Visual Basic (Declaration)
Public MustInherit Class IntersectionResultArrayIterator
Visual C++
public ref class IntersectionResultArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

IntersectionResultArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


Line Class
See Also Members
CollapseAll image DropDown image

A line in space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("35969067-89A2-4576-8017-E17D0B1B4370")]
public class Line : Curve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("35969067-89A2-4576-8017-E17D0B1B4370")> _
Public Class Line _
    Inherits Curve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"35969067-89A2-4576-8017-E17D0B1B4370")]
public ref class Line : public Curve

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Line

See Also

Line Members
Autodesk.Revit.Geometry Namespace


Line Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Line
Visual Basic (Declaration)
Public Class Line
Visual C++
public ref class Line

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
 | Bound | Returns the bounded line between the specified points.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
 | Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.

See Also

Line
Autodesk.Revit.Geometry Namespace


Line Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Line ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Line Properties
CollapseAll image DropDown image

Syntax

C#
public class Line
Visual Basic (Declaration)
Public Class Line
Visual C++
public ref class Line

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
 | Bound | Returns the bounded line between the specified points.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
 | Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.

See Also

Line
Autodesk.Revit.Geometry Namespace


Bound Property

Line..::Bound Property
CollapseAll image DropDown image

Returns the bounded line between the specified points.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Line Bound[
    XYZ startPoint,
    XYZ endPoint
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Bound ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Line
Visual C++
public:
static property Line^ Bound[XYZ^ startPoint, XYZ^ endPoint] {
    Line^ get (XYZ^ startPoint, XYZ^ endPoint);
}

Parameters

startPoint
XYZ
The start point of the line.
endPoint
XYZ
The end point of the line.

Exceptions

Exception | Condition
System..::ArgumentException | Thrown when the specified points are almost equal.

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Unbound Property

Line..::Unbound Property
CollapseAll image DropDown image

Returns the unbounded line that passes through the specified point in the direction of the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Line Unbound[
    XYZ origin,
    XYZ vector
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Unbound ( _
    origin As XYZ, _
    vector As XYZ _
) As Line
Visual C++
public:
static property Line^ Unbound[XYZ^ origin, XYZ^ vector] {
    Line^ get (XYZ^ origin, XYZ^ vector);
}

Parameters

origin
XYZ
The start point of the line.
vector
XYZ
The direction vector.

Exceptions

Exception | Condition
System..::ArgumentException | Thrown when the specified vector is almost zero and cannot be normalized.

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Mesh Class
See Also Members
CollapseAll image DropDown image

A triangular mesh.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8B7FFA0D-AA82-4eeb-AFF6-70D2D7FF3845")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Mesh : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("8B7FFA0D-AA82-4eeb-AFF6-70D2D7FF3845")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Mesh _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"8B7FFA0D-AA82-4eeb-AFF6-70D2D7FF3845")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Mesh : public GeometryObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Mesh

See Also

Mesh Members
Autodesk.Revit.Geometry Namespace


Mesh Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Mesh
Visual Basic (Declaration)
Public Class Mesh
Visual C++
public ref class Mesh

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MeshMeshNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.

See Also

Mesh
Autodesk.Revit.Geometry Namespace


Mesh Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Mesh()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Mesh ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Mesh Methods
CollapseAll image DropDown image

Syntax

C#
public class Mesh
Visual Basic (Declaration)
Public Class Mesh
Visual C++
public ref class Mesh

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

See Also

Mesh
Autodesk.Revit.Geometry Namespace


Dispose Method

Mesh..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Mesh Properties
CollapseAll image DropDown image

Syntax

C#
public class Mesh
Visual Basic (Declaration)
Public Class Mesh
Visual C++
public ref class Mesh

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.

See Also

Mesh
Autodesk.Revit.Geometry Namespace


NumTriangles Property

Mesh..::NumTriangles Property
CollapseAll image DropDown image

The number of triangles that the mesh contains.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumTriangles{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumTriangles As Integer
Visual C++
public:
property int NumTriangles {
    int get ();
}

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Transformed Property

Mesh..::Transformed Property
CollapseAll image DropDown image

Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Mesh Transformed[
    Transform transform
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Mesh
Visual C++
public:
property Mesh^ Transformed[Transform^ transform] {
    Mesh^ get (Transform^ transform);
}

Parameters

transform
Transform
The transformation used to transform the profile.

Return Value

The transformed mesh.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Triangle Property

Mesh..::Triangle Property
CollapseAll image DropDown image

Retrieves a specific triangle.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MeshTriangle Triangle[
    int idx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Triangle ( _
    idx As Integer _
) As MeshTriangle
Visual C++
public:
property MeshTriangle^ Triangle[int idx] {
    MeshTriangle^ get (int idx);
}

Parameters

idx
Int32
Index of the triangle, must be in [0, NumTriangles).

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Vertices Property

Mesh..::Vertices Property
CollapseAll image DropDown image

Retrieves all vertices used to define this mesh. Intended for indexed access.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray Vertices{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Vertices As XYZArray
Visual C++
public:
property XYZArray^ Vertices {
    XYZArray^ get ();
}

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


MeshArray Class
See Also Members
CollapseAll image DropDown image

An array that contains meshes.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8D6ACA93-ACC7-4c6f-B2E6-213DBAAF40B6")]
public class MeshArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8D6ACA93-ACC7-4c6f-B2E6-213DBAAF40B6")> _
Public Class MeshArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8D6ACA93-ACC7-4c6f-B2E6-213DBAAF40B6")]
public ref class MeshArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::MeshArray

See Also

MeshArray Members
Autodesk.Revit.Geometry Namespace


MeshArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MeshArray
Visual Basic (Declaration)
Public Class MeshArray
Visual C++
public ref class MeshArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MeshArrayMeshArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the mesh to the end of the array.
Public method | Clear | Removes every mesh from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mesh into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a mesh at a specified index within the array.
Public property | Size | Returns the number of meshes that are in the array.

See Also

MeshArray
Autodesk.Revit.Geometry Namespace


MeshArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MeshArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshArray ()

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


MeshArray Methods
CollapseAll image DropDown image

Syntax

C#
public class MeshArray
Visual Basic (Declaration)
Public Class MeshArray
Visual C++
public ref class MeshArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the mesh to the end of the array.
Public method | Clear | Removes every mesh from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mesh into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MeshArray
Autodesk.Revit.Geometry Namespace


Append Method

MeshArray..::Append Method
CollapseAll image DropDown image

Add the mesh to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Mesh item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Mesh _
)
Visual C++
public:
virtual void Append (
    Mesh^ item
)

Parameters

item
Mesh
The mesh to be added.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

MeshArray..::Clear Method
CollapseAll image DropDown image

Removes every mesh from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

MeshArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

MeshArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MeshArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

MeshArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

MeshArray..::Insert Method
CollapseAll image DropDown image

Insert the specified mesh into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Mesh item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Mesh, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Mesh^ item,
    int index
)

Parameters

item
Mesh
The mesh to be inserted into the array.
index
Int32
The mesh will be inserted before this index.

Return Value

Returns whether the mesh was inserted into the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

MeshArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

MeshArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MeshArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


MeshArray Properties
CollapseAll image DropDown image

Syntax

C#
public class MeshArray
Visual Basic (Declaration)
Public Class MeshArray
Visual C++
public ref class MeshArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a mesh at a specified index within the array.
Public property | Size | Returns the number of meshes that are in the array.

See Also

MeshArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

MeshArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Item Property

MeshArray..::Item Property
CollapseAll image DropDown image

Gets or sets a mesh at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Mesh Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Mesh
Visual C++
public:
virtual property Mesh^ Item[int index] {
    Mesh^ get (int index);
    void set (int index, Mesh^ value);
}

Parameters

index
Int32
The index of the mesh to be set or retrieved.

Return Value

Returns the mesh at the specified index.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Size Property

MeshArray..::Size Property
CollapseAll image DropDown image

Returns the number of meshes that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a mesh array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("906DF439-B27D-4362-B7D2-57DE9A1E0939")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class MeshArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("906DF439-B27D-4362-B7D2-57DE9A1E0939")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class MeshArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"906DF439-B27D-4362-B7D2-57DE9A1E0939")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MeshArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::MeshArrayIterator

See Also

MeshArrayIterator Members
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class MeshArrayIterator
Visual Basic (Declaration)
Public MustInherit Class MeshArrayIterator
Visual C++
public ref class MeshArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MeshArrayIteratorMeshArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MeshArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class MeshArrayIterator
Visual Basic (Declaration)
Public MustInherit Class MeshArrayIterator
Visual C++
public ref class MeshArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MeshArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

MeshArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

MeshArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

MeshArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

MeshArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class MeshArrayIterator
Visual Basic (Declaration)
Public MustInherit Class MeshArrayIterator
Visual C++
public ref class MeshArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

MeshArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MeshTriangle Class
See Also Members
CollapseAll image DropDown image

One triangle of a mesh.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C9DB57F4-DB84-48c1-90A9-E9F161923DE4")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MeshTriangle : APIObject
Visual Basic (Declaration)
<GuidAttribute("C9DB57F4-DB84-48c1-90A9-E9F161923DE4")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MeshTriangle _
    Inherits APIObject
Visual C++
[GuidAttribute(L"C9DB57F4-DB84-48c1-90A9-E9F161923DE4")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MeshTriangle : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::MeshTriangle

See Also

MeshTriangle Members
Autodesk.Revit.Geometry Namespace


MeshTriangle Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MeshTriangle
Visual Basic (Declaration)
Public Class MeshTriangle
Visual C++
public ref class MeshTriangle

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MeshTriangleMeshTriangleNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Vertex | A vertex of the triangle.

See Also

MeshTriangle
Autodesk.Revit.Geometry Namespace


MeshTriangle Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MeshTriangle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshTriangle ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


MeshTriangle Properties
CollapseAll image DropDown image

Syntax

C#
public class MeshTriangle
Visual Basic (Declaration)
Public Class MeshTriangle
Visual C++
public ref class MeshTriangle

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Vertex | A vertex of the triangle.

See Also

MeshTriangle
Autodesk.Revit.Geometry Namespace


Index Property

MeshTriangle..::Index Property
CollapseAll image DropDown image

The index of the vertex in the Vertices array of the mesh, for indexed access.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public uint Index[
    int idx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Index ( _
    idx As Integer _
) As UInteger
Visual C++
public:
property unsigned int Index[int idx] {
    unsigned int get (int idx);
}

Parameters

idx
Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


Vertex Property

MeshTriangle..::Vertex Property
CollapseAll image DropDown image

A vertex of the triangle.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Vertex[
    int idx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Vertex ( _
    idx As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Vertex[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


NurbSpline Class
See Also Members
CollapseAll image DropDown image

A nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("70E084BC-81A8-4a32-8E86-ADDB8B8D8DDB")]
public class NurbSpline : Curve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("70E084BC-81A8-4a32-8E86-ADDB8B8D8DDB")> _
Public Class NurbSpline _
    Inherits Curve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"70E084BC-81A8-4a32-8E86-ADDB8B8D8DDB")]
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::NurbSpline

See Also

NurbSpline Members
Autodesk.Revit.Geometry Namespace


NurbSpline Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class NurbSpline
Visual Basic (Declaration)
Public Class NurbSpline
Visual C++
public ref class NurbSpline

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | NurbSplineNurbSplineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | isClosed | Return/set the nurb spline's isClosed property.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline
Autodesk.Revit.Geometry Namespace


NurbSpline Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public NurbSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NurbSpline ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


NurbSpline Methods
CollapseAll image DropDown image

Syntax

C#
public class NurbSpline
Visual Basic (Declaration)
Public Class NurbSpline
Visual C++
public ref class NurbSpline

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

See Also

NurbSpline
Autodesk.Revit.Geometry Namespace


Intersect Method

NurbSpline..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members
Autodesk.Revit.Geometry Namespace


IsInside Method

NurbSpline..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and returns end index. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members
Autodesk.Revit.Geometry Namespace


SetControlPointsAndWeights Method

NurbSpline..::SetControlPointsAndWeights Method
CollapseAll image DropDown image

Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetControlPointsAndWeights(
    XYZArray ctrlPoints,
    DoubleArray weights
)
Visual Basic (Declaration)
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As XYZArray, _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights (
    XYZArray^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
XYZArray
weights
DoubleArray

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


NurbSpline Properties
CollapseAll image DropDown image

Syntax

C#
public class NurbSpline
Visual Basic (Declaration)
Public Class NurbSpline
Visual C++
public ref class NurbSpline

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | isClosed | Return/set the nurb spline's isClosed property.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline
Autodesk.Revit.Geometry Namespace


CtrlPoints Property

NurbSpline..::CtrlPoints Property
CollapseAll image DropDown image

Returns the control points of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray CtrlPoints{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CtrlPoints As XYZArray
Visual C++
public:
property XYZArray^ CtrlPoints {
    XYZArray^ get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Degree Property

NurbSpline..::Degree Property
CollapseAll image DropDown image

Returns the degree of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Degree{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Degree As Integer
Visual C++
public:
property int Degree {
    int get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


isClosed Property

NurbSpline..::isClosed Property
CollapseAll image DropDown image

Return/set the nurb spline's isClosed property.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool isClosed{ get; set;}
Visual Basic (Declaration)
Public Property isClosed As Boolean
Visual C++
public:
property bool isClosed {
    bool get ();
    void set (bool value);
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


isRational Property

NurbSpline..::isRational Property
CollapseAll image DropDown image

Returns whether the nurb spline is rational or not.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool isRational{ get;}
Visual Basic (Declaration)
Public ReadOnly Property isRational As Boolean
Visual C++
public:
property bool isRational {
    bool get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Knots Property

NurbSpline..::Knots Property
CollapseAll image DropDown image

Return/set the knots of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray Knots{ get; set;}
Visual Basic (Declaration)
Public Property Knots As DoubleArray
Visual C++
public:
property DoubleArray^ Knots {
    DoubleArray^ get ();
    void set (DoubleArray^ value);
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Weights Property

NurbSpline..::Weights Property
CollapseAll image DropDown image

Returns the weights of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray Weights{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Weights As DoubleArray
Visual C++
public:
property DoubleArray^ Weights {
    DoubleArray^ get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Options Class
See Also Members
CollapseAll image DropDown image

User preferences for parsing of geometry.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2E680113-3D6E-4f42-9158-4DDA76ED7F25")]
public class Options : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2E680113-3D6E-4f42-9158-4DDA76ED7F25")> _
Public Class Options _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2E680113-3D6E-4f42-9158-4DDA76ED7F25")]
public ref class Options : public APIObject

Remarks

Get an instance of this class from Application.Create, set your preferences and pass it to Element.Geometry or Instance.Geometry.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Options

See Also

Options Members
Autodesk.Revit.Geometry Namespace


Options Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Options
Visual Basic (Declaration)
Public Class Options
Visual C++
public ref class Options

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | OptionsOptionsNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | ComputeReferences | Checks whether references to geometric objects are computed.
Public property | DetailLevel | Returns the preferred detail level.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | Retrieves the view that was set for this object.

See Also

Options
Autodesk.Revit.Geometry Namespace


Options Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | OptionsOptionsNew()() | Creates a default Options object.
Public method | OptionsOptionsNew(Options) | Copy constructor.

See Also

Options Class
Options Members
Autodesk.Revit.Geometry Namespace


Options Constructor
CollapseAll image DropDown image

Creates a default Options object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Options()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Options ()

Remarks

Defaults to medium detail, no references and no view.

See Also

Options Class
Autodesk.Revit.Geometry Namespace


Options Constructor (Options)
CollapseAll image DropDown image

Copy constructor.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Options(
    Options pOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    pOptions As Options _
)
Visual C++
public:
Options (
    Options^ pOptions
)

Parameters

pOptions
Options

See Also

Options Class
Autodesk.Revit.Geometry Namespace


Options Methods
CollapseAll image DropDown image

Syntax

C#
public class Options
Visual Basic (Declaration)
Public Class Options
Visual C++
public ref class Options

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Options
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

Options..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Options Class
Autodesk.Revit.Geometry Namespace


Options Properties
CollapseAll image DropDown image

Syntax

C#
public class Options
Visual Basic (Declaration)
Public Class Options
Visual C++
public ref class Options

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ComputeReferences | Checks whether references to geometric objects are computed.
Public property | DetailLevel | Returns the preferred detail level.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | Retrieves the view that was set for this object.

See Also

Options
Autodesk.Revit.Geometry Namespace


ComputeReferences Property

Options..::ComputeReferences Property
CollapseAll image DropDown image

Checks whether references to geometric objects are computed.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool ComputeReferences{ get; set;}
Visual Basic (Declaration)
Public Property ComputeReferences As Boolean
Visual C++
public:
property bool ComputeReferences {
    bool get ();
    void set (bool value);
}

See Also

Options Class
Autodesk.Revit.Geometry Namespace


DetailLevel Property

Options..::DetailLevel Property
CollapseAll image DropDown image

Returns the preferred detail level.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Options.Options..::DetailLevels DetailLevel{ get; set;}
Visual Basic (Declaration)
Public Property DetailLevel As Options..::DetailLevels
Visual C++
public:
property Options..::DetailLevels DetailLevel {
    Options..::DetailLevels get ();
    void set (Options..::DetailLevels value);
}

Remarks

Calling this method after setting a view will result in an exception. Reset view to NULL first.

See Also

Options Class
Autodesk.Revit.Geometry Namespace


View Property

Options..::View Property
CollapseAll image DropDown image

Retrieves the view that was set for this object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public View View{ get; set;}
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

Remarks

If view-specific version of the element exists, it will be used in the retrieval. Also, detail level will be set to match the view.

See Also

Options Class
Autodesk.Revit.Geometry Namespace


Options..::DetailLevels Enumeration
CollapseAll image DropDown image

Chooses the detail level of an element's representation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D86E60F7-978E-4be7-B2BD-9A314D4A4796")]
public enum DetailLevels
Visual Basic (Declaration)
<GuidAttribute("D86E60F7-978E-4be7-B2BD-9A314D4A4796")> _
Public Enumeration DetailLevels
Visual C++
[GuidAttribute(L"D86E60F7-978E-4be7-B2BD-9A314D4A4796")]
public enum class DetailLevels

Members

Member name | Description
Fine | Corresponds to the fine view detail setting.
Medium | Corresponds to the medium view detail setting.
Coarse | Corresponds to the coarse view detail setting.
MAX | The value is used to check whether the enum is the same size as the internal one.
Undefined | May produce all or none of the available representations.

Remarks

This corresponds to detail levels in Revit's views and families.

See Also

Autodesk.Revit.Geometry Namespace


PlanarFace Class
See Also Members
CollapseAll image DropDown image

A planar face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("EF7AB8DF-4CBB-4933-BEC6-4747EB33EED8")]
public class PlanarFace : Face
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("EF7AB8DF-4CBB-4933-BEC6-4747EB33EED8")> _
Public Class PlanarFace _
    Inherits Face
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"EF7AB8DF-4CBB-4933-BEC6-4747EB33EED8")]
public ref class PlanarFace : public Face

Remarks

Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parametrization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::PlanarFace

See Also

PlanarFace Members
Autodesk.Revit.Geometry Namespace


PlanarFace Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PlanarFace
Visual Basic (Declaration)
Public Class PlanarFace
Visual C++
public ref class PlanarFace

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanarFacePlanarFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Normal | Normal of the surface.
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Vector | Defining vectors of the surface.

See Also

PlanarFace
Autodesk.Revit.Geometry Namespace


PlanarFace Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PlanarFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanarFace ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


PlanarFace Properties
CollapseAll image DropDown image

Syntax

C#
public class PlanarFace
Visual Basic (Declaration)
Public Class PlanarFace
Visual C++
public ref class PlanarFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Normal | Normal of the surface.
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Vector | Defining vectors of the surface.

See Also

PlanarFace
Autodesk.Revit.Geometry Namespace


Normal Property

PlanarFace..::Normal Property
CollapseAll image DropDown image

Normal of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Normal{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

PlanarFace..::Origin Property
CollapseAll image DropDown image

Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Origin{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Vector Property

PlanarFace..::Vector Property
CollapseAll image DropDown image

Defining vectors of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Vector[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Vector ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Vector[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Plane Class
See Also Members
CollapseAll image DropDown image

Provides access to the geometry plane object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B94F4B81-C12B-47fa-863B-024C54CE4C42")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Plane : APIObject
Visual Basic (Declaration)
<GuidAttribute("B94F4B81-C12B-47fa-863B-024C54CE4C42")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Plane _
    Inherits APIObject
Visual C++
[GuidAttribute(L"B94F4B81-C12B-47fa-863B-024C54CE4C42")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Plane : public APIObject

Remarks

The user can construct a plane object, get or set the vectors and origin through this class.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Plane

See Also

Plane Members
Autodesk.Revit.Geometry Namespace


Plane Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Plane
Visual Basic (Declaration)
Public Class Plane
Visual C++
public ref class Plane

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanePlaneNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Normal | Get the Normal of the plane.
Public property | Origin | Get the Origin of the plane.
Public property | XVec | Get the XVec of the plane.
Public property | YVec | Get the YVec of the plane.

See Also

Plane
Autodesk.Revit.Geometry Namespace


Plane Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | PlanePlaneNew()() | For Internal Use Only.
Public method | PlanePlaneNew(XYZ, XYZ) | Constructor for geometry plane.
Public method | PlanePlaneNew(XYZ, XYZ, XYZ) | Constructor for geometry plane.

See Also

Plane Class
Plane Members
Autodesk.Revit.Geometry Namespace


Plane Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Plane ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Plane Constructor (XYZ, XYZ)
CollapseAll image DropDown image

Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    norm As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane (
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
XYZ
The normal vector of the plane.
origin
XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Plane Constructor (XYZ, XYZ, XYZ)
CollapseAll image DropDown image

Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane (
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
XYZ
The vector for x-axis.
yVec
XYZ
The vector for y-axis.
origin
XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Plane Properties
CollapseAll image DropDown image

Syntax

C#
public class Plane
Visual Basic (Declaration)
Public Class Plane
Visual C++
public ref class Plane

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Normal | Get the Normal of the plane.
Public property | Origin | Get the Origin of the plane.
Public property | XVec | Get the XVec of the plane.
Public property | YVec | Get the YVec of the plane.

See Also

Plane
Autodesk.Revit.Geometry Namespace


Normal Property

Plane..::Normal Property
CollapseAll image DropDown image

Get the Normal of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Normal{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

Remarks

This property is used to get the Normal of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Origin Property

Plane..::Origin Property
CollapseAll image DropDown image

Get the Origin of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Origin{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to get the Origin of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


XVec Property

Plane..::XVec Property
CollapseAll image DropDown image

Get the XVec of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ XVec{ get;}
Visual Basic (Declaration)
Public ReadOnly Property XVec As XYZ
Visual C++
public:
property XYZ^ XVec {
    XYZ^ get ();
}

Remarks

This property is used to get the XVec of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


YVec Property

Plane..::YVec Property
CollapseAll image DropDown image

Get the YVec of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ YVec{ get;}
Visual Basic (Declaration)
Public ReadOnly Property YVec As XYZ
Visual C++
public:
property XYZ^ YVec {
    XYZ^ get ();
}

Remarks

This property is used to get the YVec of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Profile Class
See Also Members
CollapseAll image DropDown image

A geometric profile consisting of a loop of curves.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D09109A0-1049-43d1-9273-6514A0A245B2")]
public class Profile : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D09109A0-1049-43d1-9273-6514A0A245B2")> _
Public Class Profile _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D09109A0-1049-43d1-9273-6514A0A245B2")]
public ref class Profile : public GeometryObject

Remarks

The profile may be filled.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Profile

See Also

Profile Members
Autodesk.Revit.Geometry Namespace


Profile Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Profile
Visual Basic (Declaration)
Public Class Profile
Visual C++
public ref class Profile

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProfileProfileNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Transformed | Transforms this profile and returns the result.

See Also

Profile
Autodesk.Revit.Geometry Namespace


Profile Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Profile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Profile ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Profile Methods
CollapseAll image DropDown image

Syntax

C#
public class Profile
Visual Basic (Declaration)
Public Class Profile
Visual C++
public ref class Profile

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

See Also

Profile
Autodesk.Revit.Geometry Namespace


Clone Method

Profile..::Clone Method
CollapseAll image DropDown image

Returns a copy of this profile.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Profile Clone()
Visual Basic (Declaration)
Public Function Clone As Profile
Visual C++
public:
Profile^ Clone ()

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Profile Properties
CollapseAll image DropDown image

Syntax

C#
public class Profile
Visual Basic (Declaration)
Public Class Profile
Visual C++
public ref class Profile

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Transformed | Transforms this profile and returns the result.

See Also

Profile
Autodesk.Revit.Geometry Namespace


Curves Property

Profile..::Curves Property
CollapseAll image DropDown image

Retrieve the curves that make up the boundary of the profile.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Filled Property

Profile..::Filled Property
CollapseAll image DropDown image

Get or set whether the profile is filled.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Filled{ get; set;}
Visual Basic (Declaration)
Public Property Filled As Boolean
Visual C++
public:
property bool Filled {
    bool get ();
    void set (bool value);
}

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Transformed Property

Profile..::Transformed Property
CollapseAll image DropDown image

Transforms this profile and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Profile Transformed[
    Transform transform
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Profile
Visual C++
public:
property Profile^ Transformed[Transform^ transform] {
    Profile^ get (Transform^ transform);
}

Parameters

transform
Transform
The transformation used to transform the profile.

Return Value

The transformed profile.

Remarks

Transforms all the curves that define the boundary of this profile.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the specified transformation is null.
System..::InvalidOperationException | Thrown when failed to transform a curve in the profile.

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Reference Class
See Also Members
CollapseAll image DropDown image

A stable reference to a geometric object in a Revit model.
An array that contains reference objects.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DD414170-A856-44d8-829B-BCC137E6FF41")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Reference : APIObject
Visual Basic (Declaration)
<GuidAttribute("DD414170-A856-44d8-829B-BCC137E6FF41")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Reference _
    Inherits APIObject
Visual C++
[GuidAttribute(L"DD414170-A856-44d8-829B-BCC137E6FF41")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Reference : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Reference

See Also

Reference Members
Autodesk.Revit.Geometry Namespace


Reference Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Reference
Visual Basic (Declaration)
Public Class Reference
Visual C++
public ref class Reference

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ReferenceReferenceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Reference
Autodesk.Revit.Geometry Namespace


Reference Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Reference()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Reference ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


Reference Methods
CollapseAll image DropDown image

Syntax

C#
public class Reference
Visual Basic (Declaration)
Public Class Reference
Visual C++
public ref class Reference

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Reference
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

Reference..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


ReferenceArray Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FD2191AC-6114-4998-87E5-26963183BF58")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ReferenceArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("FD2191AC-6114-4998-87E5-26963183BF58")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ReferenceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"FD2191AC-6114-4998-87E5-26963183BF58")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ReferenceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::ReferenceArray

See Also

ReferenceArray Members
Autodesk.Revit.Geometry Namespace


ReferenceArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ReferenceArray
Visual Basic (Declaration)
Public Class ReferenceArray
Visual C++
public ref class ReferenceArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ReferenceArrayReferenceArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.

See Also

ReferenceArray
Autodesk.Revit.Geometry Namespace


ReferenceArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferenceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArray ()

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ReferenceArray
Visual Basic (Declaration)
Public Class ReferenceArray
Visual C++
public ref class ReferenceArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ReferenceArray
Autodesk.Revit.Geometry Namespace


Append Method

ReferenceArray..::Append Method
CollapseAll image DropDown image

Add the reference to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Reference item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Reference _
)
Visual C++
public:
virtual void Append (
    Reference^ item
)

Parameters

item
Reference
The reference to be added.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

ReferenceArray..::Clear Method
CollapseAll image DropDown image

Removes every reference from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

ReferenceArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

ReferenceArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ReferenceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

ReferenceArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

ReferenceArray..::Insert Method
CollapseAll image DropDown image

Insert the specified reference into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Reference item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Reference, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Reference^ item,
    int index
)

Parameters

item
Reference
The reference to be inserted into the array.
index
Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

ReferenceArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

ReferenceArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ReferenceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ReferenceArray
Visual Basic (Declaration)
Public Class ReferenceArray
Visual C++
public ref class ReferenceArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.

See Also

ReferenceArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

ReferenceArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Item Property

ReferenceArray..::Item Property
CollapseAll image DropDown image

Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Reference Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Reference
Visual C++
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}

Parameters

index
Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Size Property

ReferenceArray..::Size Property
CollapseAll image DropDown image

Returns the number of references that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a reference array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FDD8860C-3764-4ef7-81D5-599E154BA70B")]
public abstract class ReferenceArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FDD8860C-3764-4ef7-81D5-599E154BA70B")> _
Public MustInherit Class ReferenceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FDD8860C-3764-4ef7-81D5-599E154BA70B")]
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::ReferenceArrayIterator

See Also

ReferenceArrayIterator Members
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ReferenceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ReferenceArrayIterator
Visual C++
public ref class ReferenceArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ReferenceArrayIteratorReferenceArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferenceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ReferenceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ReferenceArrayIterator
Visual C++
public ref class ReferenceArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ReferenceArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

ReferenceArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

ReferenceArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

ReferenceArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

ReferenceArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ReferenceArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ReferenceArrayIterator
Visual C++
public ref class ReferenceArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

ReferenceArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


RevolvedFace Class
See Also Members
CollapseAll image DropDown image

A revolved face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1C4B1626-85A2-4258-9D7F-AFA441A7EA13")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RevolvedFace : Face
Visual Basic (Declaration)
<GuidAttribute("1C4B1626-85A2-4258-9D7F-AFA441A7EA13")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RevolvedFace _
    Inherits Face
Visual C++
[GuidAttribute(L"1C4B1626-85A2-4258-9D7F-AFA441A7EA13")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RevolvedFace : public Face

Remarks

Revoved faces are defined by revolved surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + Curve0(v)*cos(u)*Radius[0] + Curve0(v)*sin(u)*Radius[1] + Curve1(v)*Axis, where the profile curve has the parametric equation (Curve0(t), Curve1(t)).

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::RevolvedFace

See Also

RevolvedFace Members
Autodesk.Revit.Geometry Namespace


RevolvedFace Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RevolvedFace
Visual Basic (Declaration)
Public Class RevolvedFace
Visual C++
public ref class RevolvedFace

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RevolvedFaceRevolvedFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

RevolvedFace
Autodesk.Revit.Geometry Namespace


RevolvedFace Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RevolvedFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RevolvedFace ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


RevolvedFace Properties
CollapseAll image DropDown image

Syntax

C#
public class RevolvedFace
Visual Basic (Declaration)
Public Class RevolvedFace
Visual C++
public ref class RevolvedFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

RevolvedFace
Autodesk.Revit.Geometry Namespace


Axis Property

RevolvedFace..::Axis Property
CollapseAll image DropDown image

Axis of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Axis{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Curve Property

RevolvedFace..::Curve Property
CollapseAll image DropDown image

Profile curve of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

RevolvedFace..::Origin Property
CollapseAll image DropDown image

Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Origin{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Radius Property

RevolvedFace..::Radius Property
CollapseAll image DropDown image

Radius of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Radius[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


RuledFace Class
See Also Members
CollapseAll image DropDown image

A ruled face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("35418C2A-5FD9-4CB7-B5C6-B3C2E564653B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RuledFace : Face
Visual Basic (Declaration)
<GuidAttribute("35418C2A-5FD9-4CB7-B5C6-B3C2E564653B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RuledFace _
    Inherits Face
Visual C++
[GuidAttribute(L"35418C2A-5FD9-4CB7-B5C6-B3C2E564653B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RuledFace : public Face

Remarks

Ruled faces are defined by ruled surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::RuledFace

See Also

RuledFace Members
Autodesk.Revit.Geometry Namespace


RuledFace Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RuledFace
Visual Basic (Declaration)
Public Class RuledFace
Visual C++
public ref class RuledFace

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RuledFaceRuledFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

RuledFace
Autodesk.Revit.Geometry Namespace


RuledFace Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RuledFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RuledFace ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


RuledFace Properties
CollapseAll image DropDown image

Syntax

C#
public class RuledFace
Visual Basic (Declaration)
Public Class RuledFace
Visual C++
public ref class RuledFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

RuledFace
Autodesk.Revit.Geometry Namespace


Curve Property

RuledFace..::Curve Property
CollapseAll image DropDown image

Profile curves of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    index As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int index] {
    Curve^ get (int index);
}

Parameters

index
Int32

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


Point Property

RuledFace..::Point Property
CollapseAll image DropDown image

Profile points of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Point[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


Solid Class
See Also Members
CollapseAll image DropDown image

A 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A3A05FE6-7546-4020-B610-A5219CE08687")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Solid : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("A3A05FE6-7546-4020-B610-A5219CE08687")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Solid _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"A3A05FE6-7546-4020-B610-A5219CE08687")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Solid

See Also

Solid Members
Autodesk.Revit.Geometry Namespace


Solid Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Solid
Visual Basic (Declaration)
Public Class Solid
Visual C++
public ref class Solid

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SolidSolidNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid
Autodesk.Revit.Geometry Namespace


Solid Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Solid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Solid ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Solid Properties
CollapseAll image DropDown image

Syntax

C#
public class Solid
Visual Basic (Declaration)
Public Class Solid
Visual C++
public ref class Solid

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid
Autodesk.Revit.Geometry Namespace


Edges Property

Solid..::Edges Property
CollapseAll image DropDown image

The edges that belong to the solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public EdgeArray Edges{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Edges As EdgeArray
Visual C++
public:
property EdgeArray^ Edges {
    EdgeArray^ get ();
}

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Faces Property

Solid..::Faces Property
CollapseAll image DropDown image

The faces that belong to the solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FaceArray Faces{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Faces As FaceArray
Visual C++
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}

Remarks

A face may be degenerate. This can be determined with the Face property IsTwoSided.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


SurfaceArea Property

Solid..::SurfaceArea Property
CollapseAll image DropDown image

Returns the total surface area of this solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double SurfaceArea{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SurfaceArea As Double
Visual C++
public:
property double SurfaceArea {
    double get ();
}

Return Value

The real number equal to the total area of this solid.

Remarks

Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this solid is not a valid Geometry object.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Volume Property

Solid..::Volume Property
CollapseAll image DropDown image

Returns the signed volume of this solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Volume{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Return Value

The real number equal to the signed volume of this solid.

Remarks

Calculates the solid volume by integrating tessellated representations of faces and edges. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


SolidArray Class
See Also Members
CollapseAll image DropDown image

An array that contains solids.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B5287BA6-30F2-451f-885C-E951706CD9EE")]
public class SolidArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B5287BA6-30F2-451f-885C-E951706CD9EE")> _
Public Class SolidArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B5287BA6-30F2-451f-885C-E951706CD9EE")]
public ref class SolidArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::SolidArray

See Also

SolidArray Members
Autodesk.Revit.Geometry Namespace


SolidArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SolidArray
Visual Basic (Declaration)
Public Class SolidArray
Visual C++
public ref class SolidArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SolidArraySolidArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the solid to the end of the array.
Public method | Clear | Removes every solid from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified solid into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a solid at a specified index within the array.
Public property | Size | Returns the number of solids that are in the array.

See Also

SolidArray
Autodesk.Revit.Geometry Namespace


SolidArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SolidArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidArray ()

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


SolidArray Methods
CollapseAll image DropDown image

Syntax

C#
public class SolidArray
Visual Basic (Declaration)
Public Class SolidArray
Visual C++
public ref class SolidArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the solid to the end of the array.
Public method | Clear | Removes every solid from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified solid into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SolidArray
Autodesk.Revit.Geometry Namespace


Append Method

SolidArray..::Append Method
CollapseAll image DropDown image

Add the solid to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    Solid item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Solid _
)
Visual C++
public:
virtual void Append (
    Solid^ item
)

Parameters

item
Solid
The solid to be added.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

SolidArray..::Clear Method
CollapseAll image DropDown image

Removes every solid from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

SolidArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

SolidArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SolidArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

SolidArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

SolidArray..::Insert Method
CollapseAll image DropDown image

Insert the specified solid into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Solid item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Solid, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Solid^ item,
    int index
)

Parameters

item
Solid
The solid to be inserted into the array.
index
Int32
The solid will be inserted before this index.

Return Value

Returns whether the solid was inserted into the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

SolidArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

SolidArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SolidArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


SolidArray Properties
CollapseAll image DropDown image

Syntax

C#
public class SolidArray
Visual Basic (Declaration)
Public Class SolidArray
Visual C++
public ref class SolidArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a solid at a specified index within the array.
Public property | Size | Returns the number of solids that are in the array.

See Also

SolidArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

SolidArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Item Property

SolidArray..::Item Property
CollapseAll image DropDown image

Gets or sets a solid at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Solid Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Solid
Visual C++
public:
virtual property Solid^ Item[int index] {
    Solid^ get (int index);
    void set (int index, Solid^ value);
}

Parameters

index
Int32
The index of the solid to be set or retrieved.

Return Value

Returns the solid at the specified index.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Size Property

SolidArray..::Size Property
CollapseAll image DropDown image

Returns the number of solids that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a solids array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("612A8839-5045-4d1b-BF44-8C24F4281CFB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class SolidArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("612A8839-5045-4d1b-BF44-8C24F4281CFB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class SolidArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"612A8839-5045-4d1b-BF44-8C24F4281CFB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SolidArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::SolidArrayIterator

See Also

SolidArrayIterator Members
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SolidArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SolidArrayIterator
Visual C++
public ref class SolidArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SolidArrayIteratorSolidArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SolidArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SolidArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SolidArrayIterator
Visual C++
public ref class SolidArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SolidArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

SolidArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

SolidArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

SolidArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

SolidArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SolidArrayIterator
Visual Basic (Declaration)
Public MustInherit Class SolidArrayIterator
Visual C++
public ref class SolidArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

SolidArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


Transform Class
See Also Members
CollapseAll image DropDown image

A transformation of the affine 3-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4CE66A0D-2A39-4307-89B2-40ACE3EE4792")]
public class Transform : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4CE66A0D-2A39-4307-89B2-40ACE3EE4792")> _
Public Class Transform _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4CE66A0D-2A39-4307-89B2-40ACE3EE4792")]
public ref class Transform : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Transform

See Also

Transform Members
Autodesk.Revit.Geometry Namespace


Transform Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Transform
Visual Basic (Declaration)
Public Class Transform
Visual C++
public ref class Transform

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TransformTransformNew | The copy constructor.

Public Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
 | Multiply | Multiplies the two specified transforms.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
 | Reflection | The transformation that reflects about the specified plane.
 | Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Public property | Scale | The real number that represents the scale of the transformation.
 | Translation | The transformation that translates by the specified vector.

See Also

Transform
Autodesk.Revit.Geometry Namespace


Transform Constructor
CollapseAll image DropDown image

The copy constructor.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform(
    Transform source
)
Visual Basic (Declaration)
Public Sub New ( _
    source As Transform _
)
Visual C++
public:
Transform (
    Transform^ source
)

Parameters

source
Transform

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Transform Methods
CollapseAll image DropDown image

Syntax

C#
public class Transform
Visual Basic (Declaration)
Public Class Transform
Visual C++
public ref class Transform

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
 | Multiply | Multiplies the two specified transforms.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Transform
Autodesk.Revit.Geometry Namespace


AlmostEqual Method

Transform..::AlmostEqual Method
CollapseAll image DropDown image

Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AlmostEqual(
    Transform right
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    right As Transform _
) As Boolean
Visual C++
public:
bool AlmostEqual (
    Transform^ right
)

Parameters

right
Transform
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal; otherwise, false.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Multiply Method (Transform)

Transform..::Multiply Method (Transform)
See Also
CollapseAll image DropDown image

Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform Multiply(
    Transform right
)
Visual Basic (Declaration)
Public Function Multiply ( _
    right As Transform _
) As Transform
Visual C++
public:
Transform^ Multiply (
    Transform^ right
)

Parameters

right
Transform
The specified transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Multiply Operator

Transform..::Multiply Operator
CollapseAll image DropDown image

Multiplies the two specified transforms.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform operator *(
    Transform left,
    Transform right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As Transform, _
    right As Transform _
) As Transform
Visual C++
public:
static Transform^ operator * (
    Transform^ left,
    Transform^ right
)

Parameters

left
Transform
The first transformation.
right
Transform
The second transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the first or second transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


OfPoint Method

Transform..::OfPoint Method
CollapseAll image DropDown image

Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ OfPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function OfPoint ( _
    point As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfPoint (
    XYZ^ point
)

Parameters

point
XYZ
The point to transform.

Return Value

The transformed point.

Remarks

Transformation of a point is affected by the translational part of the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


OfVector Method

Transform..::OfVector Method
CollapseAll image DropDown image

Applies the transform to the vector

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic (Declaration)
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector (
    XYZ^ vec
)

Parameters

vec
XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

Transform..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


ScaleBasis Method

Transform..::ScaleBasis Method
CollapseAll image DropDown image

Scales the basis vectors of this transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ScaleBasis(
    double scale
)
Visual Basic (Declaration)
Public Function ScaleBasis ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasis (
    double scale
)

Parameters

scale
Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


ScaleBasisAndOrigin Method

Transform..::ScaleBasisAndOrigin Method
CollapseAll image DropDown image

Scales the basis vectors and the origin of this transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ScaleBasisAndOrigin(
    double scale
)
Visual Basic (Declaration)
Public Function ScaleBasisAndOrigin ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasisAndOrigin (
    double scale
)

Parameters

scale
Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Transform Properties
CollapseAll image DropDown image

Syntax

C#
public class Transform
Visual Basic (Declaration)
Public Class Transform
Visual C++
public ref class Transform

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
 | Reflection | The transformation that reflects about the specified plane.
 | Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Public property | Scale | The real number that represents the scale of the transformation.
 | Translation | The transformation that translates by the specified vector.

See Also

Transform
Autodesk.Revit.Geometry Namespace


Basis Property

Transform..::Basis Property
CollapseAll image DropDown image

Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Basis[
    int idx
]{ get; set;}
Visual Basic (Declaration)
Public Property Basis ( _
    idx As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
    void set (int idx, XYZ^ value);
}

Parameters

idx
Int32
The index of the basis vector: 0, 1 or 2.

Remarks

This corresponds to the first three column vectors of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter.
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


BasisX Property

Transform..::BasisX Property
CollapseAll image DropDown image

The basis of the X axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ BasisX{ get; set;}
Visual Basic (Declaration)
Public Property BasisX As XYZ
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The X axis of the old coordinate system in the new coordinate system, or the 1st column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


BasisY Property

Transform..::BasisY Property
CollapseAll image DropDown image

The basis of the Y axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ BasisY{ get; set;}
Visual Basic (Declaration)
Public Property BasisY As XYZ
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Y axis of the old coordinate system in the new coordinate system, or the 2nd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


BasisZ Property

Transform..::BasisZ Property
CollapseAll image DropDown image

The basis of the Z axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ BasisZ{ get; set;}
Visual Basic (Declaration)
Public Property BasisZ As XYZ
Visual C++
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Z axis of the old coordinate system in the new coordinate system, or the 3rd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Determinant Property

Transform..::Determinant Property
CollapseAll image DropDown image

The determinant of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Determinant{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Determinant As Double
Visual C++
public:
property double Determinant {
    double get ();
}

Remarks

The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


HasReflection Property

Transform..::HasReflection Property
CollapseAll image DropDown image

The boolean value that indicates whether this transformation produces reflection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HasReflection{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HasReflection As Boolean
Visual C++
public:
property bool HasReflection {
    bool get ();
}

Remarks

Reflection transformation changes the handedness of a coordinate system.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this transformation is not conformal and the reflection is undefined.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Identity Property

Transform..::Identity Property
CollapseAll image DropDown image

The identity transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform Identity{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Identity As Transform
Visual C++
public:
static property Transform^ Identity {
    Transform^ get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Inverse Property

Transform..::Inverse Property
CollapseAll image DropDown image

The inverse transformation of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform Inverse{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Inverse As Transform
Visual C++
public:
property Transform^ Inverse {
    Transform^ get ();
}

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this transformation is not conformal or invertible.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


IsConformal Property

Transform..::IsConformal Property
CollapseAll image DropDown image

The boolean value that indicates whether this transformation is conformal.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsConformal{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsConformal As Boolean
Visual C++
public:
property bool IsConformal {
    bool get ();
}

Remarks

This property is true if this transformation can be decomposed as the product of a rigid-body motion, uniform scale and reflection. Such transformation preserves angles between vectors.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


IsIdentity Property

Transform..::IsIdentity Property
CollapseAll image DropDown image

The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsIdentity{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsIdentity As Boolean
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


IsTranslation Property

Transform..::IsTranslation Property
CollapseAll image DropDown image

The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsTranslation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsTranslation As Boolean
Visual C++
public:
property bool IsTranslation {
    bool get ();
}

Remarks

This property is true if the only effect of transformation is translation. It checks that the basis of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Origin Property

Transform..::Origin Property
CollapseAll image DropDown image

Defines the origin of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Origin{ get; set;}
Visual Basic (Declaration)
Public Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This corresponds to the fourth column vector of the conventional 3x4 matrix representation. Also, this is the translation component of the transformation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Reflection Property

Transform..::Reflection Property
CollapseAll image DropDown image

The transformation that reflects about the specified plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform Reflection[
    Plane plane
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Reflection ( _
    plane As Plane _
) As Transform
Visual C++
public:
static property Transform^ Reflection[Plane^ plane] {
    Transform^ get (Plane^ plane);
}

Parameters

plane
Plane
The plane to reflect about.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the plane is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Rotation Property

Transform..::Rotation Property
CollapseAll image DropDown image

The transformation that rotates by the specified angle about the specified axis and point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform Rotation[
    XYZ origin,
    XYZ axis,
    double angle
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Rotation ( _
    origin As XYZ, _
    axis As XYZ, _
    angle As Double _
) As Transform
Visual C++
public:
static property Transform^ Rotation[XYZ^ origin, XYZ^ axis, double angle] {
    Transform^ get (XYZ^ origin, XYZ^ axis, double angle);
}

Parameters

origin
XYZ
The point to rotate about.
axis
XYZ
The axis vector to rotate about.
angle
Double
The rotation angle in radians.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::ArgumentException | Thrown when the specified values fail to define the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Scale Property

Transform..::Scale Property
CollapseAll image DropDown image

The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Scale{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
}

Remarks

When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this transformation is not conformal and the scale is undefined.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Translation Property

Transform..::Translation Property
CollapseAll image DropDown image

The transformation that translates by the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform Translation[
    XYZ vec
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Translation ( _
    vec As XYZ _
) As Transform
Visual C++
public:
static property Transform^ Translation[XYZ^ vec] {
    Transform^ get (XYZ^ vec);
}

Parameters

vec
XYZ
The translation vector.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


UV Class
See Also Members
CollapseAll image DropDown image

Object representing coordinates in 2-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("96BE4DA5-F05A-45d9-ADD6-F40EC21C2E4E")]
public class UV
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("96BE4DA5-F05A-45d9-ADD6-F40EC21C2E4E")> _
Public Class UV
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"96BE4DA5-F05A-45d9-ADD6-F40EC21C2E4E")]
public ref class UV

Remarks

Usually this means parameters on a surface. In actual use , it could be interpreted as either point or vector in the space.

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Geometry..::UV

See Also

UV Members
Autodesk.Revit.Geometry Namespace


UV Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class UV
Visual Basic (Declaration)
Public Class UV
Visual C++
public ref class UV

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | UVUVNew | Overloaded.

Public Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
 | Addition | Adds the two specified 2-D vectors and returns the result.
Public method | AlmostEqual | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | Angle | Returns the angle between this vector and the specified vector.
Public method | Cross | The cross product of this 2-D vector and the specified 2-D vector.
Public method | Distance | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
 | Division | Divides the specified 2-D vector by the specified value.
Public method | Dot | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
 | Multiply | Overloaded.
Public method | Negate | Negates this 2-D vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
 | Subtraction | Subtracts the two specified 2-D vectors and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnaryNegation | Negates this 2-D vector and returns the result.

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
 | Basis | Indexed access for Basis.
 | BasisU | The basic of the U axis.
 | BasisV | The basic of the V axis.
Public property | IsNormalized | The boolean value that indicates whether this 2-D vector is a normalized vector.
Public property | IsZero | The boolean value that indicates whether this 2-D vector is a zero vector.
Public property | Item | Indexed access to coordinates.
Public property | Length | The length of this 2-D vector.
Public property | Normalized | This 2-D vector, normalized.
Public property | U | The first coordinate.
Public property | V | The second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.

See Also

UV
Autodesk.Revit.Geometry Namespace


UV Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | UVUVNew()() | default constructor
Public method | UVUVNew(UV) | Creates object with supplied UV object.
Public method | UVUVNew(Double, Double) | Creates object with supplied values.

See Also

UV Class
UV Members
Autodesk.Revit.Geometry Namespace


UV Constructor
CollapseAll image DropDown image

default constructor

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UV ()

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UV Constructor (UV)
CollapseAll image DropDown image

Creates object with supplied UV object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV(
    UV uv
)
Visual Basic (Declaration)
Public Sub New ( _
    uv As UV _
)
Visual C++
public:
UV (
    UV^ uv
)

Parameters

uv
UV
The supplied UV object

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UV Constructor (Double, Double)
CollapseAll image DropDown image

Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV(
    double u,
    double v
)
Visual Basic (Declaration)
Public Sub New ( _
    u As Double, _
    v As Double _
)
Visual C++
public:
UV (
    double u,
    double v
)

Parameters

u
Double
The first coordinate.
v
Double
The second coordinate.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UV Methods
CollapseAll image DropDown image

Syntax

C#
public class UV
Visual Basic (Declaration)
Public Class UV
Visual C++
public ref class UV

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
 | Addition | Adds the two specified 2-D vectors and returns the result.
Public method | AlmostEqual | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | Angle | Returns the angle between this vector and the specified vector.
Public method | Cross | The cross product of this 2-D vector and the specified 2-D vector.
Public method | Distance | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
 | Division | Divides the specified 2-D vector by the specified value.
Public method | Dot | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
 | Multiply | Overloaded.
Public method | Negate | Negates this 2-D vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
 | Subtraction | Subtracts the two specified 2-D vectors and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnaryNegation | Negates this 2-D vector and returns the result.

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

UV
Autodesk.Revit.Geometry Namespace


Add Method

UV..::Add Method
CollapseAll image DropDown image

Adds the specified 2-D vector to this 2-D vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Add(
    UV source
)
Visual Basic (Declaration)
Public Function Add ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Add (
    UV^ source
)

Parameters

source
UV
The vector to add to this vector.

Return Value

The 2-D vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Addition Operator

UV..::Addition Operator
CollapseAll image DropDown image

Adds the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV operator +(
    UV left,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator + (
    UV^ left,
    UV^ right
)

Parameters

left
UV
The first vector.
right
UV
The second vector.

Return Value

The 2-D vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


AlmostEqual Method

UV..::AlmostEqual Method
CollapseAll image DropDown image

Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AlmostEqual(
    UV source
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    source As UV _
) As Boolean
Visual C++
public:
bool AlmostEqual (
    UV^ source
)

Parameters

source
UV
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Angle Method

UV..::Angle Method
CollapseAll image DropDown image

Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Angle(
    UV source
)
Visual Basic (Declaration)
Public Function Angle ( _
    source As UV _
) As Double
Visual C++
public:
double Angle (
    UV^ source
)

Parameters

source
UV
The specified vector.

Return Value

The real number between 0 and 2*PI equal to the angle between the two vectors.

Remarks

The angle is measured counterclockwise.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Cross Method

UV..::Cross Method
CollapseAll image DropDown image

The cross product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Cross(
    UV source
)
Visual Basic (Declaration)
Public Function Cross ( _
    source As UV _
) As Double
Visual C++
public:
double Cross (
    UV^ source
)

Parameters

source
UV
The vector to multiply with this vector.

Return Value

The real number equal to the cross product.

Remarks

The cross product of the two vectors in 2-D space is defined as the area of the parallelogram they span.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Distance Method

UV..::Distance Method
CollapseAll image DropDown image

Returns the distance from this 2-D point to the specified 2-D point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Distance(
    UV source
)
Visual Basic (Declaration)
Public Function Distance ( _
    source As UV _
) As Double
Visual C++
public:
double Distance (
    UV^ source
)

Parameters

source
UV
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Divide Method

UV..::Divide Method
CollapseAll image DropDown image

Divides this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Divide (
    double value
)

Parameters

value
Double
The value to divide this vector by.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::DivideByZeroException | Thrown when the specified value is zero.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Division Operator

UV..::Division Operator
CollapseAll image DropDown image

Divides the specified 2-D vector by the specified value.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV operator /(
    UV left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator / (
    UV^ left,
    double value
)

Parameters

left
UV
The value to divide the vector by.
value
Double
The vector to divide by the value.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::DivideByZeroException | Thrown when the specified value is zero.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Dot Method

UV..::Dot Method
CollapseAll image DropDown image

The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Dot(
    UV source
)
Visual Basic (Declaration)
Public Function Dot ( _
    source As UV _
) As Double
Visual C++
public:
double Dot (
    UV^ source
)

Parameters

source
UV
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Pu*Pu + Rv*Rv.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Multiply Method

UV..::Multiply Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Multiply(Double) | Multiplies this 2-D vector by the specified value and returns the result.
 | Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
 | Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.

See Also

UV Class
UV Members
Autodesk.Revit.Geometry Namespace


Multiply Method (Double)

UV..::Multiply Method (Double)
See Also
CollapseAll image DropDown image

Multiplies this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Multiply (
    double value
)

Parameters

value
Double
The value to multiply with this vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Multiply Operator

UV..::Multiply Operator
CollapseAll image DropDown image

The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV operator *(
    double value,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator * (
    double value,
    UV^ right
)

Parameters

value
Double
The value to multiply with the specified vector.
right
UV
The vector to multiply with the value.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Multiply Operator

UV..::Multiply Operator
CollapseAll image DropDown image

The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV operator *(
    UV left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator * (
    UV^ left,
    double value
)

Parameters

left
UV
The vector to multiply with the value.
value
Double
The value to multiply with the specified vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Negate Method

UV..::Negate Method
CollapseAll image DropDown image

Negates this 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Negate()
Visual Basic (Declaration)
Public Function Negate As UV
Visual C++
public:
UV^ Negate ()

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Subtract Method

UV..::Subtract Method
CollapseAll image DropDown image

Subtracts the specified 2-D vector from this 2-D vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Subtract(
    UV source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Subtract (
    UV^ source
)

Parameters

source
UV
The vector to subtract from this vector.

Return Value

The 2-D vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Subtraction Operator

UV..::Subtraction Operator
CollapseAll image DropDown image

Subtracts the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV operator -(
    UV left,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator - (
    UV^ left,
    UV^ right
)

Parameters

left
UV
The first vector.
right
UV
The second vector.

Return Value

The 2-D vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UnaryNegation Operator

UV..::UnaryNegation Operator
CollapseAll image DropDown image

Negates this 2-D vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV operator -(
    UV source
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    source As UV _
) As UV
Visual C++
public:
static UV^ operator - (
    UV^ source
)

Parameters

source
UV

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UV Properties
CollapseAll image DropDown image

Syntax

C#
public class UV
Visual Basic (Declaration)
Public Class UV
Visual C++
public ref class UV

The type exposes the following properties.

Public Properties

 | Name | Description
 | Basis | Indexed access for Basis.
 | BasisU | The basic of the U axis.
 | BasisV | The basic of the V axis.
Public property | IsNormalized | The boolean value that indicates whether this 2-D vector is a normalized vector.
Public property | IsZero | The boolean value that indicates whether this 2-D vector is a zero vector.
Public property | Item | Indexed access to coordinates.
Public property | Length | The length of this 2-D vector.
Public property | Normalized | This 2-D vector, normalized.
Public property | U | The first coordinate.
Public property | V | The second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.

See Also

UV
Autodesk.Revit.Geometry Namespace


Basis Property

UV..::Basis Property
CollapseAll image DropDown image

Indexed access for Basis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV Basis[
    int idx
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Basis ( _
    idx As Integer _
) As UV
Visual C++
public:
static property UV^ Basis[int idx] {
    UV^ get (int idx);
}

Parameters

idx
Int32
Use 0 for U, 1 for V.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access an element of the Basis array with an index that is outside the bounds of the array.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


BasisU Property

UV..::BasisU Property
CollapseAll image DropDown image

The basic of the U axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV BasisU{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisU As UV
Visual C++
public:
static property UV^ BasisU {
    UV^ get ();
}

Remarks

The basis of the U axis is the vector (1,0), the unit vector on the U axis.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


BasisV Property

UV..::BasisV Property
CollapseAll image DropDown image

The basic of the V axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV BasisV{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisV As UV
Visual C++
public:
static property UV^ BasisV {
    UV^ get ();
}

Remarks

The basis of the V axis is the vector (0,1), the unit vector on the V axis.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


IsNormalized Property

UV..::IsNormalized Property
CollapseAll image DropDown image

The boolean value that indicates whether this 2-D vector is a normalized vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsNormalized{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsNormalized As Boolean
Visual C++
public:
property bool IsNormalized {
    bool get ();
}

Remarks

Normalized vector's length equals one within the tolerance (1.0e-09), in other words, that this is a unit vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


IsZero Property

UV..::IsZero Property
CollapseAll image DropDown image

The boolean value that indicates whether this 2-D vector is a zero vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsZero{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsZero As Boolean
Visual C++
public:
property bool IsZero {
    bool get ();
}

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Item Property

UV..::Item Property
CollapseAll image DropDown image

Indexed access to coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double this[
    int idx
]{ get; set;}
Visual Basic (Declaration)
Public Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
    void set (int idx, double value);
}

Parameters

idx
Int32
Use 0 for U and 1 for V.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access coordinates with an index that is larger than 1.
System..::NotFiniteNumberException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Length Property

UV..::Length Property
CollapseAll image DropDown image

The length of this 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Length{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

In 2-D Euclidean space, the length of the vector is the square root of the sum of the two coordinates squared.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Normalized Property

UV..::Normalized Property
CollapseAll image DropDown image

This 2-D vector, normalized.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UV Normalized{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Normalized As UV
Visual C++
public:
property UV^ Normalized {
    UV^ get ();
}

Remarks

Normalized indicates that the length of this vector equals one, in other words, that this is a unit vector.

Exceptions

Exception | Condition
System..::DivideByZeroException | Thrown when the length of current vector is zero.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


U Property

UV..::U Property
CollapseAll image DropDown image

The first coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double U{ get; set;}
Visual Basic (Declaration)
Public Property U As Double
Visual C++
public:
property double U {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the U property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


V Property

UV..::V Property
CollapseAll image DropDown image

The second coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double V{ get; set;}
Visual Basic (Declaration)
Public Property V As Double
Visual C++
public:
property double V {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the V property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Zero Property

UV..::Zero Property
CollapseAll image DropDown image

The coordinate origin or zero 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static UV Zero{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Zero As UV
Visual C++
public:
static property UV^ Zero {
    UV^ get ();
}

Remarks

The zero vector is (0,0).

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UVArray Class
See Also Members
CollapseAll image DropDown image

An array that contains UV coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D54CD84A-559C-493e-8686-DD63FF253893")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class UVArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("D54CD84A-559C-493e-8686-DD63FF253893")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class UVArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"D54CD84A-559C-493e-8686-DD63FF253893")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class UVArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::UVArray

See Also

UVArray Members
Autodesk.Revit.Geometry Namespace


UVArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class UVArray
Visual Basic (Declaration)
Public Class UVArray
Visual C++
public ref class UVArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | UVArrayUVArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every UV coordinate from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a UV coordinate at a specified index within the array.
Public property | Size | Returns the number of UV coordinates that are in the array.

See Also

UVArray
Autodesk.Revit.Geometry Namespace


UVArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UVArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UVArray ()

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


UVArray Methods
CollapseAll image DropDown image

Syntax

C#
public class UVArray
Visual Basic (Declaration)
Public Class UVArray
Visual C++
public ref class UVArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every UV coordinate from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

UVArray
Autodesk.Revit.Geometry Namespace


Append Method

UVArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    UV item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As UV _
)
Visual C++
public:
virtual void Append (
    UV^ item
)

Parameters

item
UV

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

UVArray..::Clear Method
CollapseAll image DropDown image

Removes every UV coordinate from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

UVArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

UVArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual UVArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As UVArrayIterator
Visual C++
public:
virtual UVArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

UVArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

UVArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    UV item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As UV, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    UV^ item,
    int index
)

Parameters

item
UV
index
Int32

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

UVArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

UVArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual UVArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As UVArrayIterator
Visual C++
public:
virtual UVArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


UVArray Properties
CollapseAll image DropDown image

Syntax

C#
public class UVArray
Visual Basic (Declaration)
Public Class UVArray
Visual C++
public ref class UVArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a UV coordinate at a specified index within the array.
Public property | Size | Returns the number of UV coordinates that are in the array.

See Also

UVArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

UVArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Item Property

UVArray..::Item Property
CollapseAll image DropDown image

Gets or sets a UV coordinate at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual UV Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As UV
Visual C++
public:
virtual property UV^ Item[int index] {
    UV^ get (int index);
    void set (int index, UV^ value);
}

Parameters

index
Int32
The index of the UV coordinate to be set or retrieved.

Return Value

Returns the UV coordinate at the specified index.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Size Property

UVArray..::Size Property
CollapseAll image DropDown image

Returns the number of UV coordinates that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


UVArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of UV coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BDE4731F-551A-494a-9984-9AEB61A06BB4")]
public abstract class UVArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BDE4731F-551A-494a-9984-9AEB61A06BB4")> _
Public MustInherit Class UVArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BDE4731F-551A-494a-9984-9AEB61A06BB4")]
public ref class UVArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::UVArrayIterator

See Also

UVArrayIterator Members
Autodesk.Revit.Geometry Namespace


UVArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class UVArrayIterator
Visual Basic (Declaration)
Public MustInherit Class UVArrayIterator
Visual C++
public ref class UVArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | UVArrayIteratorUVArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

UVArrayIterator
Autodesk.Revit.Geometry Namespace


UVArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public UVArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UVArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


UVArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class UVArrayIterator
Visual Basic (Declaration)
Public MustInherit Class UVArrayIterator
Visual C++
public ref class UVArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

UVArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

UVArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

UVArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

UVArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

UVArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


UVArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class UVArrayIterator
Visual Basic (Declaration)
Public MustInherit Class UVArrayIterator
Visual C++
public ref class UVArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

UVArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

UVArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


XYZ Class
See Also Members
CollapseAll image DropDown image

Object representing coordinates in 3-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("57DCD1DC-D725-49b3-B04A-879FA927FA80")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class XYZ
Visual Basic (Declaration)
<GuidAttribute("57DCD1DC-D725-49b3-B04A-879FA927FA80")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class XYZ
Visual C++
[GuidAttribute(L"57DCD1DC-D725-49b3-B04A-879FA927FA80")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class XYZ

Remarks

Usually this means a point or a vector in space, depending on the actual use.

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Geometry..::XYZ

See Also

XYZ Members
Autodesk.Revit.Geometry Namespace


XYZ Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class XYZ
Visual Basic (Declaration)
Public Class XYZ
Visual C++
public ref class XYZ

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | XYZXYZNew | Overloaded.

Public Methods

 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
 | Addition | Adds the two specified vectors and returns the result.
Public method | AlmostEqual | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | Angle | Returns the angle between this vector and the specified vector.
Public method | AngleAround | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | Cross | The cross product of this vector and the specified vector.
Public method | Distance | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
 | Division | Divides the specified vector by the specified value.
Public method | Dot | The dot product of this vector and the specified vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
 | Multiply | Overloaded.
Public method | Negate | Negates this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
 | Subtraction | Subtracts the two specified vectors and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.
 | UnaryNegation | Negates the specified vector and returns the result.

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
 | Basis | Indexed access for Basis.
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
Public property | IsZero | The boolean value that indicates whether this vector is a zero vector.
Public property | Item | Indexed access to coordinates.
Public property | Length | The length of this vector.
Public property | Normalized | This vector, normalized.
Public property | X | The first coordinate.
Public property | Y | The second coordinate.
Public property | Z | The third coordinate.
 | Zero | The coordinate origin or zero vector.

See Also

XYZ
Autodesk.Revit.Geometry Namespace


XYZ Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | XYZXYZNew()() | default constructor
Public method | XYZXYZNew(XYZ) | Creates object with supplied XYZ object.
Public method | XYZXYZNew(Double, Double, Double) | Creates object with supplied values.

See Also

XYZ Class
XYZ Members
Autodesk.Revit.Geometry Namespace


XYZ Constructor
CollapseAll image DropDown image

default constructor

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XYZ ()

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZ Constructor (XYZ)
CollapseAll image DropDown image

Creates object with supplied XYZ object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ(
    XYZ xyz
)
Visual Basic (Declaration)
Public Sub New ( _
    xyz As XYZ _
)
Visual C++
public:
XYZ (
    XYZ^ xyz
)

Parameters

xyz
XYZ
The supplied object

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZ Constructor (Double, Double, Double)
CollapseAll image DropDown image

Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
Visual C++
public:
XYZ (
    double x,
    double y,
    double z
)

Parameters

x
Double
The first coordinate.
y
Double
The second coordinate.
z
Double
The third coordinate.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZ Methods
CollapseAll image DropDown image

Syntax

C#
public class XYZ
Visual Basic (Declaration)
Public Class XYZ
Visual C++
public ref class XYZ

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
 | Addition | Adds the two specified vectors and returns the result.
Public method | AlmostEqual | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | Angle | Returns the angle between this vector and the specified vector.
Public method | AngleAround | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | Cross | The cross product of this vector and the specified vector.
Public method | Distance | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
 | Division | Divides the specified vector by the specified value.
Public method | Dot | The dot product of this vector and the specified vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
 | Multiply | Overloaded.
Public method | Negate | Negates this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
 | Subtraction | Subtracts the two specified vectors and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.
 | UnaryNegation | Negates the specified vector and returns the result.

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

XYZ
Autodesk.Revit.Geometry Namespace


Add Method

XYZ..::Add Method
CollapseAll image DropDown image

Adds the specified vector to this vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Add(
    XYZ source
)
Visual Basic (Declaration)
Public Function Add ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Add (
    XYZ^ source
)

Parameters

source
XYZ
The vector to add to this vector.

Return Value

The vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Addition Operator

XYZ..::Addition Operator
CollapseAll image DropDown image

Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator + (
    XYZ^ left,
    XYZ^ right
)

Parameters

left
XYZ
The first vector.
right
XYZ
The second vector.

Return Value

The vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


AlmostEqual Method

XYZ..::AlmostEqual Method
CollapseAll image DropDown image

Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AlmostEqual(
    XYZ source
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    source As XYZ _
) As Boolean
Visual C++
public:
bool AlmostEqual (
    XYZ^ source
)

Parameters

source
XYZ
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Angle Method

XYZ..::Angle Method
CollapseAll image DropDown image

Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Angle(
    XYZ source
)
Visual Basic (Declaration)
Public Function Angle ( _
    source As XYZ _
) As Double
Visual C++
public:
double Angle (
    XYZ^ source
)

Parameters

source
XYZ
The specified vector.

Return Value

The real number between 0 and PI equal to the angle between the two vectors.

Remarks

The angle between the two vectors is measured in the plane spanned by them.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


AngleAround Method

XYZ..::AngleAround Method
CollapseAll image DropDown image

Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double AngleAround(
    XYZ right,
    XYZ norm
)
Visual Basic (Declaration)
Public Function AngleAround ( _
    right As XYZ, _
    norm As XYZ _
) As Double
Visual C++
public:
double AngleAround (
    XYZ^ right,
    XYZ^ norm
)

Parameters

right
XYZ
The specified vector.
norm
XYZ
The normal vector that defines the plane.

Return Value

The real number between 0 and 2*PI equal to the projected angle between the two vectors.

Remarks

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Cross Method

XYZ..::Cross Method
CollapseAll image DropDown image

The cross product of this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Cross(
    XYZ source
)
Visual Basic (Declaration)
Public Function Cross ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Cross (
    XYZ^ source
)

Parameters

source
XYZ
The vector to multiply with this vector.

Return Value

The vector equal to the cross product.

Remarks

The cross product is defined as the vector which is perpendicular to both vectors with a magnitude equal to the area of the parallelogram they span. Also known as vector product or outer product.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Distance Method

XYZ..::Distance Method
CollapseAll image DropDown image

Returns the distance from this point to the specified point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Distance(
    XYZ source
)
Visual Basic (Declaration)
Public Function Distance ( _
    source As XYZ _
) As Double
Visual C++
public:
double Distance (
    XYZ^ source
)

Parameters

source
XYZ
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Divide Method

XYZ..::Divide Method
CollapseAll image DropDown image

Divides this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Divide (
    double value
)

Parameters

value
Double
The value to divide this vector by.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::DivideByZeroException | Thrown when the specified value is zero.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Division Operator

XYZ..::Division Operator
CollapseAll image DropDown image

Divides the specified vector by the specified value.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator /(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator / (
    XYZ^ left,
    double value
)

Parameters

left
XYZ
The value to divide the vector by.
value
Double
The vector to divide by the value.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::DivideByZeroException | Thrown when the specified value is zero.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Dot Method

XYZ..::Dot Method
CollapseAll image DropDown image

The dot product of this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Dot(
    XYZ source
)
Visual Basic (Declaration)
Public Function Dot ( _
    source As XYZ _
) As Double
Visual C++
public:
double Dot (
    XYZ^ source
)

Parameters

source
XYZ
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Multiply Method

XYZ..::Multiply Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Multiply(Double) | Multiplies this vector by the specified value and returns the result.
 | Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.
 | Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.

See Also

XYZ Class
XYZ Members
Autodesk.Revit.Geometry Namespace


Multiply Method (Double)

XYZ..::Multiply Method (Double)
See Also
CollapseAll image DropDown image

Multiplies this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Multiply (
    double value
)

Parameters

value
Double
The value to multiply with this vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Multiply Operator

XYZ..::Multiply Operator
CollapseAll image DropDown image

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator *(
    double value,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator * (
    double value,
    XYZ^ right
)

Parameters

value
Double
The value to multiply with the specified vector.
right
XYZ
The vector to multiply with the value.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Multiply Operator

XYZ..::Multiply Operator
CollapseAll image DropDown image

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator *(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator * (
    XYZ^ left,
    double value
)

Parameters

left
XYZ
The vector to multiply with the value.
value
Double
The value to multiply with the specified vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Negate Method

XYZ..::Negate Method
CollapseAll image DropDown image

Negates this vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Negate()
Visual Basic (Declaration)
Public Function Negate As XYZ
Visual C++
public:
XYZ^ Negate ()

Return Value

The vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Subtract Method

XYZ..::Subtract Method
CollapseAll image DropDown image

Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Subtract(
    XYZ source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Subtract (
    XYZ^ source
)

Parameters

source
XYZ
The vector to subtract from this vector.

Return Value

The vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Subtraction Operator

XYZ..::Subtraction Operator
CollapseAll image DropDown image

Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator - (
    XYZ^ left,
    XYZ^ right
)

Parameters

left
XYZ
The first vector.
right
XYZ
The second vector.

Return Value

The vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


TripleProduct Method

XYZ..::TripleProduct Method
CollapseAll image DropDown image

The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TripleProduct(
    XYZ middle,
    XYZ right
)
Visual Basic (Declaration)
Public Function TripleProduct ( _
    middle As XYZ, _
    right As XYZ _
) As Double
Visual C++
public:
double TripleProduct (
    XYZ^ middle,
    XYZ^ right
)

Parameters

middle
XYZ
The second vector.
right
XYZ
The third vector.

Return Value

The real number equal to the triple product.

Remarks

The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


UnaryNegation Operator

XYZ..::UnaryNegation Operator
CollapseAll image DropDown image

Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator -(
    XYZ source
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    source As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator - (
    XYZ^ source
)

Parameters

source
XYZ

Return Value

The vector opposite to the specified vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZ Properties
CollapseAll image DropDown image

Syntax

C#
public class XYZ
Visual Basic (Declaration)
Public Class XYZ
Visual C++
public ref class XYZ

The type exposes the following properties.

Public Properties

 | Name | Description
 | Basis | Indexed access for Basis.
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
Public property | IsZero | The boolean value that indicates whether this vector is a zero vector.
Public property | Item | Indexed access to coordinates.
Public property | Length | The length of this vector.
Public property | Normalized | This vector, normalized.
Public property | X | The first coordinate.
Public property | Y | The second coordinate.
Public property | Z | The third coordinate.
 | Zero | The coordinate origin or zero vector.

See Also

XYZ
Autodesk.Revit.Geometry Namespace


Basis Property

XYZ..::Basis Property
CollapseAll image DropDown image

Indexed access for Basis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ Basis[
    int idx
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Basis ( _
    idx As Integer _
) As XYZ
Visual C++
public:
static property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access an element of the Basis array with an index that is outside the bounds of the array.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


BasisX Property

XYZ..::BasisX Property
CollapseAll image DropDown image

The basis of the X axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ BasisX{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisX As XYZ
Visual C++
public:
static property XYZ^ BasisX {
    XYZ^ get ();
}

Remarks

The basis of the X axis is the vector (1,0,0), the unit vector on the X axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


BasisY Property

XYZ..::BasisY Property
CollapseAll image DropDown image

The basis of the Y axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ BasisY{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisY As XYZ
Visual C++
public:
static property XYZ^ BasisY {
    XYZ^ get ();
}

Remarks

The basis of the Y axis is the vector (0,1,0), the unit vector on the Y axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


BasisZ Property

XYZ..::BasisZ Property
CollapseAll image DropDown image

The basis of the Z axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ BasisZ{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisZ As XYZ
Visual C++
public:
static property XYZ^ BasisZ {
    XYZ^ get ();
}

Remarks

The basis of the Z axis is the vector (0,0,1), the unit vector on the Z axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


IsNormalized Property

XYZ..::IsNormalized Property
CollapseAll image DropDown image

The boolean value that indicates whether this vector is a normalized vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsNormalized{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsNormalized As Boolean
Visual C++
public:
property bool IsNormalized {
    bool get ();
}

Remarks

Normalized vector's length equals one within the tolerance (1.0e-09), in other words, that this is a unit vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


IsZero Property

XYZ..::IsZero Property
CollapseAll image DropDown image

The boolean value that indicates whether this vector is a zero vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsZero{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsZero As Boolean
Visual C++
public:
property bool IsZero {
    bool get ();
}

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Item Property

XYZ..::Item Property
CollapseAll image DropDown image

Indexed access to coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double this[
    int idx
]{ get; set;}
Visual Basic (Declaration)
Public Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
    void set (int idx, double value);
}

Parameters

idx
Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access the coordinate with an index that is larger than 2.
System..::NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Length Property

XYZ..::Length Property
CollapseAll image DropDown image

The length of this vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Length{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

In 3-D Euclidean space, the length of the vector is the square root of the sum of the three coordinates squared.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Normalized Property

XYZ..::Normalized Property
CollapseAll image DropDown image

This vector, normalized.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Normalized{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Normalized As XYZ
Visual C++
public:
property XYZ^ Normalized {
    XYZ^ get ();
}

Remarks

Normalized indicates that the length of this vector equals one, in other words, that this is a unit vector.

Exceptions

Exception | Condition
System..::DivideByZeroException | Thrown when the length of this vector is zero.
System..::InvalidOperationException | Thrown when an error occurs in normalization.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


X Property

XYZ..::X Property
CollapseAll image DropDown image

The first coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double X{ get; set;}
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the X property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Y Property

XYZ..::Y Property
CollapseAll image DropDown image

The second coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Y{ get; set;}
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the Y property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Z Property

XYZ..::Z Property
CollapseAll image DropDown image

The third coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Z{ get; set;}
Visual Basic (Declaration)
Public Property Z As Double
Visual C++
public:
property double Z {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Zero Property

XYZ..::Zero Property
CollapseAll image DropDown image

The coordinate origin or zero vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ Zero{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Zero As XYZ
Visual C++
public:
static property XYZ^ Zero {
    XYZ^ get ();
}

Remarks

The zero vector is (0,0,0).

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZArray Class
See Also Members
CollapseAll image DropDown image

An array that contains XYZ coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C48C8840-2414-432c-AC25-C0D11C5367A0")]
public class XYZArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C48C8840-2414-432c-AC25-C0D11C5367A0")> _
Public Class XYZArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C48C8840-2414-432c-AC25-C0D11C5367A0")]
public ref class XYZArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::XYZArray

See Also

XYZArray Members
Autodesk.Revit.Geometry Namespace


XYZArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class XYZArray
Visual Basic (Declaration)
Public Class XYZArray
Visual C++
public ref class XYZArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | XYZArrayXYZArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every XYZ coordinate from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a XYZ coordinate at a specified index within the array.
Public property | Size | Returns the number of XYZ coordinates that are in the array.

See Also

XYZArray
Autodesk.Revit.Geometry Namespace


XYZArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XYZArray ()

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


XYZArray Methods
CollapseAll image DropDown image

Syntax

C#
public class XYZArray
Visual Basic (Declaration)
Public Class XYZArray
Visual C++
public ref class XYZArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every XYZ coordinate from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

XYZArray
Autodesk.Revit.Geometry Namespace


Append Method

XYZArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    XYZ item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As XYZ _
)
Visual C++
public:
virtual void Append (
    XYZ^ item
)

Parameters

item
XYZ

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

XYZArray..::Clear Method
CollapseAll image DropDown image

Removes every XYZ coordinate from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Dispose Method

XYZArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

XYZArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual XYZArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As XYZArrayIterator
Visual C++
public:
virtual XYZArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

XYZArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

XYZArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    XYZ item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As XYZ, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    XYZ^ item,
    int index
)

Parameters

item
XYZ
index
Int32

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

XYZArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

XYZArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual XYZArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As XYZArrayIterator
Visual C++
public:
virtual XYZArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


XYZArray Properties
CollapseAll image DropDown image

Syntax

C#
public class XYZArray
Visual Basic (Declaration)
Public Class XYZArray
Visual C++
public ref class XYZArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a XYZ coordinate at a specified index within the array.
Public property | Size | Returns the number of XYZ coordinates that are in the array.

See Also

XYZArray
Autodesk.Revit.Geometry Namespace


IsEmpty Property

XYZArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Item Property

XYZArray..::Item Property
CollapseAll image DropDown image

Gets or sets a XYZ coordinate at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual XYZ Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As XYZ
Visual C++
public:
virtual property XYZ^ Item[int index] {
    XYZ^ get (int index);
    void set (int index, XYZ^ value);
}

Parameters

index
Int32
The index of the XYZ coordinate to be set or retrieved.

Return Value

Returns the XYZ coordinate at the specified index.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Size Property

XYZArray..::Size Property
CollapseAll image DropDown image

Returns the number of XYZ coordinates that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of XYZ coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("36ABCEDA-577C-4920-8B22-1696C5404035")]
public abstract class XYZArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("36ABCEDA-577C-4920-8B22-1696C5404035")> _
Public MustInherit Class XYZArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"36ABCEDA-577C-4920-8B22-1696C5404035")]
public ref class XYZArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::XYZArrayIterator

See Also

XYZArrayIterator Members
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class XYZArrayIterator
Visual Basic (Declaration)
Public MustInherit Class XYZArrayIterator
Visual C++
public ref class XYZArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | XYZArrayIteratorXYZArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

XYZArrayIterator
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XYZArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class XYZArrayIterator
Visual Basic (Declaration)
Public MustInherit Class XYZArrayIterator
Visual C++
public ref class XYZArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

XYZArrayIterator
Autodesk.Revit.Geometry Namespace


Dispose Method

XYZArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

XYZArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReleaseUnmanagedResources Method

XYZArrayIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

XYZArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class XYZArrayIterator
Visual Basic (Declaration)
Public MustInherit Class XYZArrayIterator
Visual C++
public ref class XYZArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

XYZArrayIterator
Autodesk.Revit.Geometry Namespace


Current Property

XYZArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


Autodesk.Revit.MEP Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.MEP
Visual Basic (Declaration)
Namespace Autodesk.Revit.MEP
Visual C++
namespace Autodesk.Revit.MEP

Classes

 | Class | Description
Public class | Connector | Provides access to the Connector in Autodesk Revit MEP.
Public class | ConnectorManager | Provides access to the Connector Manager in Autodesk Revit MEP.
Public class | ConnectorSet | A set that can contain any type of object.
Public class | ConnectorSetIterator | An iterator to a set.
Public class | CorrectionFactor | Represents electrical correction factor information.
Public class | CorrectionFactorSet | A set that contains correction factors.
Public class | CorrectionFactorSetIterator | An iterator to a correction factor set.
Public class | DemandFactorData | Represents demand factor definition in a specified range.
Public class | DemandFactorDataSet | A set that can contain any type of object.
Public class | DemandFactorDataSetIterator | An iterator to a set.
Public class | ElectricalEquipment | Provides access to the Electrical Equipment in Autodesk Revit MEP.
Public class | ElectricalSetting | An object that represents electrical information within the Autodesk Revit project.
Public class | GroundConductorSize | Represents electrical ground conductor size definition information.
Public class | GroundConductorSizeSet | A set that contains GroundConductorSizes.
Public class | GroundConductorSizeSetIterator | An iterator to a GroundConductorSize set.
Public class | LightingDevice | Provides access to the Lighting Device in Autodesk Revit MEP.
Public class | LightingFixture | Provides access to the Lighting Fixture in Autodesk Revit MEP.
Public class | MechanicalEquipment | Provides access to the Mechanical Equipment in Autodesk Revit MEP.
Public class | MEPModel | Supports all Analytical Models that are persistent within the Autodesk Revit project
Public class | WireSize | Represents specific electrical wire size information.
Public class | WireSizeSet | A set that contains wire sizes.
Public class | WireSizeSetIterator | An iterator to a wire size set.


Connector Class
See Also Members
CollapseAll image DropDown image

Provides access to the Connector in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0256C2CE-6485-4014-8900-200794632753")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Connector : APIObject
Visual Basic (Declaration)
<GuidAttribute("0256C2CE-6485-4014-8900-200794632753")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Connector _
    Inherits APIObject
Visual C++
[GuidAttribute(L"0256C2CE-6485-4014-8900-200794632753")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Connector : public APIObject

Remarks

The Connector object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::Connector

See Also

Connector Members
Autodesk.Revit.MEP Namespace


Connector Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Connector
Visual Basic (Declaration)
Public Class Connector
Visual C++
public ref class Connector

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConnectorConnectorNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | AllRefs | Return the All the References of the Connector.
Public property | ConnectorType | Return the Connector Type of the Connector.
Public property | Domain | Return the Domain of the Connector.
Public property | Height | Return the Height of the Connector.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Owner | Return the owner of the Connector.
Public property | Radius | Return the Radius of the Connector.
Public property | Shape | Return the Shape of the Connector.
Public property | Width | Return the Width of the Connector.

See Also

Connector
Autodesk.Revit.MEP Namespace


Connector Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Connector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Connector ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Connector Properties
CollapseAll image DropDown image

Syntax

C#
public class Connector
Visual Basic (Declaration)
Public Class Connector
Visual C++
public ref class Connector

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AllRefs | Return the All the References of the Connector.
Public property | ConnectorType | Return the Connector Type of the Connector.
Public property | Domain | Return the Domain of the Connector.
Public property | Height | Return the Height of the Connector.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Owner | Return the owner of the Connector.
Public property | Radius | Return the Radius of the Connector.
Public property | Shape | Return the Shape of the Connector.
Public property | Width | Return the Width of the Connector.

See Also

Connector
Autodesk.Revit.MEP Namespace


AllRefs Property

Connector..::AllRefs Property
CollapseAll image DropDown image

Return the All the References of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorSet AllRefs{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AllRefs As ConnectorSet
Visual C++
public:
property ConnectorSet^ AllRefs {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the references of the Connector.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


ConnectorType Property

Connector..::ConnectorType Property
CollapseAll image DropDown image

Return the Connector Type of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorType ConnectorType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ConnectorType As ConnectorType
Visual C++
public:
property ConnectorType ConnectorType {
    ConnectorType get ();
}

Remarks

This property is used to retrieve the Type of the Connector.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Domain Property

Connector..::Domain Property
CollapseAll image DropDown image

Return the Domain of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Domain Domain{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Domain As Domain
Visual C++
public:
property Domain Domain {
    Domain get ();
}

Remarks

This property is used to retrieve the Domain of the Connector.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Height Property

Connector..::Height Property
CollapseAll image DropDown image

Return the Height of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Height{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Height As Double
Visual C++
public:
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the Height of the Connector.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown out when the Connecotr's Shape is not Rect.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Owner Property

Connector..::Owner Property
CollapseAll image DropDown image

Return the owner of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Owner{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Owner As Element
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

This property is used to retrieve the owner of the Connector.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Radius Property

Connector..::Radius Property
CollapseAll image DropDown image

Return the Radius of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Radius{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
}

Remarks

This property is used to retrieve the Radius of the Connector.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown out when the Connecotr's Shape is not Round.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Shape Property

Connector..::Shape Property
CollapseAll image DropDown image

Return the Shape of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorProfileType Shape{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Remarks

This property is used to retrieve the Shape of the Connector.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Width Property

Connector..::Width Property
CollapseAll image DropDown image

Return the Width of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Width{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the Width of the Connector.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown out when the Connecotr's Shape is not Rect.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


ConnectorManager Class
See Also Members
CollapseAll image DropDown image

Provides access to the Connector Manager in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("703D9390-CE79-4d72-8535-85F7A95F4E2E")]
public class ConnectorManager : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("703D9390-CE79-4d72-8535-85F7A95F4E2E")> _
Public Class ConnectorManager _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"703D9390-CE79-4d72-8535-85F7A95F4E2E")]
public ref class ConnectorManager : public APIObject

Remarks

The Connector Manager object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::ConnectorManager

See Also

ConnectorManager Members
Autodesk.Revit.MEP Namespace


ConnectorManager Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ConnectorManager
Visual Basic (Declaration)
Public Class ConnectorManager
Visual C++
public ref class ConnectorManager

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConnectorManagerConnectorManagerNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Owner | Return the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager
Autodesk.Revit.MEP Namespace


ConnectorManager Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorManager ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


ConnectorManager Properties
CollapseAll image DropDown image

Syntax

C#
public class ConnectorManager
Visual Basic (Declaration)
Public Class ConnectorManager
Visual C++
public ref class ConnectorManager

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Owner | Return the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager
Autodesk.Revit.MEP Namespace


Connectors Property

ConnectorManager..::Connectors Property
CollapseAll image DropDown image

Return all the Connectors of the Connector Manager.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorSet Connectors{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Connectors As ConnectorSet
Visual C++
public:
property ConnectorSet^ Connectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the Connectors from the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


Owner Property

ConnectorManager..::Owner Property
CollapseAll image DropDown image

Return the owner of the Connector Manager.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Owner{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Owner As Element
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

This property is used to retrieve the owner of the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


UnusedConnectors Property

ConnectorManager..::UnusedConnectors Property
CollapseAll image DropDown image

Return all the unused Connectors of the Connector Manager.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorSet UnusedConnectors{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UnusedConnectors As ConnectorSet
Visual C++
public:
property ConnectorSet^ UnusedConnectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the unused Connectors from the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


ConnectorSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9F0A99B4-9ED7-46dd-AFF4-5A27A9CE60F2")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ConnectorSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("9F0A99B4-9ED7-46dd-AFF4-5A27A9CE60F2")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ConnectorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"9F0A99B4-9ED7-46dd-AFF4-5A27A9CE60F2")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ConnectorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::ConnectorSet

See Also

ConnectorSet Members
Autodesk.Revit.MEP Namespace


ConnectorSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ConnectorSet
Visual Basic (Declaration)
Public Class ConnectorSet
Visual C++
public ref class ConnectorSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConnectorSetConnectorSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ConnectorSet
Autodesk.Revit.MEP Namespace


ConnectorSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorSet ()

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ConnectorSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ConnectorSet
Visual Basic (Declaration)
Public Class ConnectorSet
Visual C++
public ref class ConnectorSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ConnectorSet
Autodesk.Revit.MEP Namespace


Clear Method

ConnectorSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Contains Method

ConnectorSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Connector^ item
)

Parameters

item
Connector

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Dispose Method

ConnectorSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Erase Method

ConnectorSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Connector _
) As Integer
Visual C++
public:
virtual int Erase (
    Connector^ item
)

Parameters

item
Connector

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

ConnectorSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ConnectorSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

ConnectorSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Insert Method

ConnectorSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Connector^ item
)

Parameters

item
Connector

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

ConnectorSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

ConnectorSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ConnectorSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ConnectorSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ConnectorSet
Visual Basic (Declaration)
Public Class ConnectorSet
Visual C++
public ref class ConnectorSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ConnectorSet
Autodesk.Revit.MEP Namespace


IsEmpty Property

ConnectorSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Size Property

ConnectorSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1433049A-1D46-4344-B236-6B25E6B70699")]
public abstract class ConnectorSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1433049A-1D46-4344-B236-6B25E6B70699")> _
Public MustInherit Class ConnectorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1433049A-1D46-4344-B236-6B25E6B70699")]
public ref class ConnectorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::ConnectorSetIterator

See Also

ConnectorSetIterator Members
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ConnectorSetIterator
Visual Basic (Declaration)
Public MustInherit Class ConnectorSetIterator
Visual C++
public ref class ConnectorSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConnectorSetIteratorConnectorSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ConnectorSetIterator
Visual Basic (Declaration)
Public MustInherit Class ConnectorSetIterator
Visual C++
public ref class ConnectorSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ConnectorSetIterator
Autodesk.Revit.MEP Namespace


Dispose Method

ConnectorSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

ConnectorSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

ConnectorSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

ConnectorSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ConnectorSetIterator
Visual Basic (Declaration)
Public MustInherit Class ConnectorSetIterator
Visual C++
public ref class ConnectorSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator
Autodesk.Revit.MEP Namespace


Current Property

ConnectorSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


CorrectionFactor Class
See Also Members
CollapseAll image DropDown image

Represents electrical correction factor information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("586B020A-E1BD-4e4b-B8AD-35D540F8C853")]
public class CorrectionFactor : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("586B020A-E1BD-4e4b-B8AD-35D540F8C853")> _
Public Class CorrectionFactor _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"586B020A-E1BD-4e4b-B8AD-35D540F8C853")]
public ref class CorrectionFactor : public APIObject

Remarks

Correction facotr is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::CorrectionFactor

See Also

CorrectionFactor Members
Autodesk.Revit.MEP Namespace


CorrectionFactor Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CorrectionFactor
Visual Basic (Declaration)
Public Class CorrectionFactor
Visual C++
public ref class CorrectionFactor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CorrectionFactorCorrectionFactorNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Factor | Get factor value of wire correction factor.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor
Autodesk.Revit.MEP Namespace


CorrectionFactor Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CorrectionFactor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactor ()

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


CorrectionFactor Properties
CollapseAll image DropDown image

Syntax

C#
public class CorrectionFactor
Visual Basic (Declaration)
Public Class CorrectionFactor
Visual C++
public ref class CorrectionFactor

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Factor | Get factor value of wire correction factor.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor
Autodesk.Revit.MEP Namespace


Factor Property

CorrectionFactor..::Factor Property
CollapseAll image DropDown image

Get factor value of wire correction factor.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Factor{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Factor As Double
Visual C++
public:
property double Factor {
    double get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


Temperature Property

CorrectionFactor..::Temperature Property
CollapseAll image DropDown image

Get temperature which is used for specifying correction factor.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public long Temperature{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Temperature As Long
Visual C++
public:
property long long Temperature {
    long long get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Class
See Also Members
CollapseAll image DropDown image

A set that contains correction factors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2CDFDE83-DBE2-4ec8-858A-799408BB3C9C")]
public class CorrectionFactorSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2CDFDE83-DBE2-4ec8-858A-799408BB3C9C")> _
Public Class CorrectionFactorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2CDFDE83-DBE2-4ec8-858A-799408BB3C9C")]
public ref class CorrectionFactorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::CorrectionFactorSet

See Also

CorrectionFactorSet Members
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CorrectionFactorSet
Visual Basic (Declaration)
Public Class CorrectionFactorSet
Visual C++
public ref class CorrectionFactorSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CorrectionFactorSetCorrectionFactorSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every correction factor from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CorrectionFactorSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactorSet ()

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Methods
CollapseAll image DropDown image

Syntax

C#
public class CorrectionFactorSet
Visual Basic (Declaration)
Public Class CorrectionFactorSet
Visual C++
public ref class CorrectionFactorSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every correction factor from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CorrectionFactorSet
Autodesk.Revit.MEP Namespace


Clear Method

CorrectionFactorSet..::Clear Method
CollapseAll image DropDown image

Removes every correction factor from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Contains Method

CorrectionFactorSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Contains (
    CorrectionFactor^ item
)

Parameters

item
CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Dispose Method

CorrectionFactorSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Erase Method

CorrectionFactorSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CorrectionFactor _
) As Integer
Visual C++
public:
virtual int Erase (
    CorrectionFactor^ item
)

Parameters

item
CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

CorrectionFactorSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CorrectionFactorSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

CorrectionFactorSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Insert Method

CorrectionFactorSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Insert (
    CorrectionFactor^ item
)

Parameters

item
CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

CorrectionFactorSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

CorrectionFactorSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CorrectionFactorSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Properties
CollapseAll image DropDown image

Syntax

C#
public class CorrectionFactorSet
Visual Basic (Declaration)
Public Class CorrectionFactorSet
Visual C++
public ref class CorrectionFactorSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet
Autodesk.Revit.MEP Namespace


IsEmpty Property

CorrectionFactorSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Size Property

CorrectionFactorSet..::Size Property
CollapseAll image DropDown image

Returns the number of correction factors that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a correction factor set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("807AF9E7-2AC7-4100-8F68-AC6B7CA4A376")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class CorrectionFactorSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("807AF9E7-2AC7-4100-8F68-AC6B7CA4A376")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class CorrectionFactorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"807AF9E7-2AC7-4100-8F68-AC6B7CA4A376")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CorrectionFactorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::CorrectionFactorSetIterator

See Also

CorrectionFactorSetIterator Members
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CorrectionFactorSetIterator
Visual Basic (Declaration)
Public MustInherit Class CorrectionFactorSetIterator
Visual C++
public ref class CorrectionFactorSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CorrectionFactorSetIteratorCorrectionFactorSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CorrectionFactorSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactorSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CorrectionFactorSetIterator
Visual Basic (Declaration)
Public MustInherit Class CorrectionFactorSetIterator
Visual C++
public ref class CorrectionFactorSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CorrectionFactorSetIterator
Autodesk.Revit.MEP Namespace


Dispose Method

CorrectionFactorSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

CorrectionFactorSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

CorrectionFactorSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

CorrectionFactorSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CorrectionFactorSetIterator
Visual Basic (Declaration)
Public MustInherit Class CorrectionFactorSetIterator
Visual C++
public ref class CorrectionFactorSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator
Autodesk.Revit.MEP Namespace


Current Property

CorrectionFactorSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


DemandFactorData Class
See Also Members
CollapseAll image DropDown image

Represents demand factor definition in a specified range.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("69E1A68B-DB0D-4614-8F20-DB797BD92BDB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DemandFactorData : APIObject
Visual Basic (Declaration)
<GuidAttribute("69E1A68B-DB0D-4614-8F20-DB797BD92BDB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DemandFactorData _
    Inherits APIObject
Visual C++
[GuidAttribute(L"69E1A68B-DB0D-4614-8F20-DB797BD92BDB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DemandFactorData : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::DemandFactorData

See Also

DemandFactorData Members
Autodesk.Revit.MEP Namespace


DemandFactorData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DemandFactorData
Visual Basic (Declaration)
Public Class DemandFactorData
Visual C++
public ref class DemandFactorData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DemandFactorDataDemandFactorDataNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValid | Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.
Public property | MaxFactor | Get upper limit value of the range, the unit is volt-ampere.
Public property | MinFactor | Get lower limit value of the range, the unit is volt-ampere.
Public property | Percentage | Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

See Also

DemandFactorData
Autodesk.Revit.MEP Namespace


DemandFactorData Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DemandFactorData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactorData ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


DemandFactorData Properties
CollapseAll image DropDown image

Syntax

C#
public class DemandFactorData
Visual Basic (Declaration)
Public Class DemandFactorData
Visual C++
public ref class DemandFactorData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValid | Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.
Public property | MaxFactor | Get upper limit value of the range, the unit is volt-ampere.
Public property | MinFactor | Get lower limit value of the range, the unit is volt-ampere.
Public property | Percentage | Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

See Also

DemandFactorData
Autodesk.Revit.MEP Namespace


IsValid Property

DemandFactorData..::IsValid Property
CollapseAll image DropDown image

Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsValid{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
Visual C++
public:
property bool IsValid {
    bool get ();
}

Return Value

true if the data can still be used, otherwise false.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


MaxFactor Property

DemandFactorData..::MaxFactor Property
CollapseAll image DropDown image

Get upper limit value of the range, the unit is volt-ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public long MaxFactor{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MaxFactor As Long
Visual C++
public:
property long long MaxFactor {
    long long get ();
}

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


MinFactor Property

DemandFactorData..::MinFactor Property
CollapseAll image DropDown image

Get lower limit value of the range, the unit is volt-ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public long MinFactor{ get; set;}
Visual Basic (Declaration)
Public Property MinFactor As Long
Visual C++
public:
property long long MinFactor {
    long long get ();
    void set (long long value);
}

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Valid min factor should bigger than the min value of previous range and less than the max factor of current range.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


Percentage Property

DemandFactorData..::Percentage Property
CollapseAll image DropDown image

Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Percentage{ get; set;}
Visual Basic (Declaration)
Public Property Percentage As Double
Visual C++
public:
property double Percentage {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Throw exception when assign a negative value to percentage.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BF6091E9-6C7D-4359-A38E-35A049BAD77F")]
public class DemandFactorDataSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BF6091E9-6C7D-4359-A38E-35A049BAD77F")> _
Public Class DemandFactorDataSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BF6091E9-6C7D-4359-A38E-35A049BAD77F")]
public ref class DemandFactorDataSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::DemandFactorDataSet

See Also

DemandFactorDataSet Members
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DemandFactorDataSet
Visual Basic (Declaration)
Public Class DemandFactorDataSet
Visual C++
public ref class DemandFactorDataSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DemandFactorDataSetDemandFactorDataSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

DemandFactorDataSet
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DemandFactorDataSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactorDataSet ()

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Methods
CollapseAll image DropDown image

Syntax

C#
public class DemandFactorDataSet
Visual Basic (Declaration)
Public Class DemandFactorDataSet
Visual C++
public ref class DemandFactorDataSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DemandFactorDataSet
Autodesk.Revit.MEP Namespace


Clear Method

DemandFactorDataSet..::Clear Method
CollapseAll image DropDown image

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Contains Method

DemandFactorDataSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    DemandFactorData item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DemandFactorData _
) As Boolean
Visual C++
public:
virtual bool Contains (
    DemandFactorData^ item
)

Parameters

item
DemandFactorData

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Dispose Method

DemandFactorDataSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Erase Method

DemandFactorDataSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    DemandFactorData item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DemandFactorData _
) As Integer
Visual C++
public:
virtual int Erase (
    DemandFactorData^ item
)

Parameters

item
DemandFactorData

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

DemandFactorDataSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DemandFactorDataSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DemandFactorDataSetIterator
Visual C++
public:
virtual DemandFactorDataSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

DemandFactorDataSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Insert Method

DemandFactorDataSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    DemandFactorData item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DemandFactorData _
) As Boolean
Visual C++
public:
virtual bool Insert (
    DemandFactorData^ item
)

Parameters

item
DemandFactorData

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

DemandFactorDataSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

DemandFactorDataSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DemandFactorDataSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DemandFactorDataSetIterator
Visual C++
public:
virtual DemandFactorDataSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Properties
CollapseAll image DropDown image

Syntax

C#
public class DemandFactorDataSet
Visual Basic (Declaration)
Public Class DemandFactorDataSet
Visual C++
public ref class DemandFactorDataSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

DemandFactorDataSet
Autodesk.Revit.MEP Namespace


IsEmpty Property

DemandFactorDataSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Size Property

DemandFactorDataSet..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FD0BBD5A-CA99-4849-A71C-1D08D8D1AE2F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class DemandFactorDataSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("FD0BBD5A-CA99-4849-A71C-1D08D8D1AE2F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class DemandFactorDataSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"FD0BBD5A-CA99-4849-A71C-1D08D8D1AE2F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DemandFactorDataSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::DemandFactorDataSetIterator

See Also

DemandFactorDataSetIterator Members
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DemandFactorDataSetIterator
Visual Basic (Declaration)
Public MustInherit Class DemandFactorDataSetIterator
Visual C++
public ref class DemandFactorDataSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DemandFactorDataSetIteratorDemandFactorDataSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DemandFactorDataSetIterator
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DemandFactorDataSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactorDataSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DemandFactorDataSetIterator
Visual Basic (Declaration)
Public MustInherit Class DemandFactorDataSetIterator
Visual C++
public ref class DemandFactorDataSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DemandFactorDataSetIterator
Autodesk.Revit.MEP Namespace


Dispose Method

DemandFactorDataSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

DemandFactorDataSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

DemandFactorDataSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

DemandFactorDataSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DemandFactorDataSetIterator
Visual Basic (Declaration)
Public MustInherit Class DemandFactorDataSetIterator
Visual C++
public ref class DemandFactorDataSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DemandFactorDataSetIterator
Autodesk.Revit.MEP Namespace


Current Property

DemandFactorDataSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


ElectricalEquipment Class
See Also Members
CollapseAll image DropDown image

Provides access to the Electrical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F454E07F-A071-4911-8D2B-B8E6403292AC")]
public class ElectricalEquipment : MEPModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F454E07F-A071-4911-8D2B-B8E6403292AC")> _
Public Class ElectricalEquipment _
    Inherits MEPModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F454E07F-A071-4911-8D2B-B8E6403292AC")]
public ref class ElectricalEquipment : public MEPModel

Remarks

The Electrical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::ElectricalEquipment

See Also

ElectricalEquipment Members
Autodesk.Revit.MEP Namespace


ElectricalEquipment Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElectricalEquipment
Visual Basic (Declaration)
Public Class ElectricalEquipment
Visual C++
public ref class ElectricalEquipment

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElectricalEquipmentElectricalEquipmentNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | DistributionSystem | get or set the Distribution System for the Electrical Equipment.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment
Autodesk.Revit.MEP Namespace


ElectricalEquipment Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalEquipment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalEquipment ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

ElectricalEquipment Class
Autodesk.Revit.MEP Namespace


ElectricalEquipment Properties
CollapseAll image DropDown image

Syntax

C#
public class ElectricalEquipment
Visual Basic (Declaration)
Public Class ElectricalEquipment
Visual C++
public ref class ElectricalEquipment

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | DistributionSystem | get or set the Distribution System for the Electrical Equipment.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment
Autodesk.Revit.MEP Namespace


DistributionSystem Property

ElectricalEquipment..::DistributionSystem Property
CollapseAll image DropDown image

get or set the Distribution System for the Electrical Equipment.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DistributionSysType DistributionSystem{ get; set;}
Visual Basic (Declaration)
Public Property DistributionSystem As DistributionSysType
Visual C++
public:
property DistributionSysType^ DistributionSystem {
    DistributionSysType^ get ();
    void set (DistributionSysType^ value);
}

Remarks

This property returns a Distribution System which is assigned to the Electrical Equipment. If there are no Distribution System assigned to this Electrical Equipment, this property will be nullptr.

See Also

ElectricalEquipment Class
Autodesk.Revit.MEP Namespace


ElectricalSetting Class
See Also Members
CollapseAll image DropDown image

An object that represents electrical information within the Autodesk Revit project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("79505A6F-08FD-4f15-9EC4-C70D48C29CD6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElectricalSetting : APIObject
Visual Basic (Declaration)
<GuidAttribute("79505A6F-08FD-4f15-9EC4-C70D48C29CD6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElectricalSetting _
    Inherits APIObject
Visual C++
[GuidAttribute(L"79505A6F-08FD-4f15-9EC4-C70D48C29CD6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElectricalSetting : public APIObject

Remarks

ElectricalSetting includes voltage type, distribution system type, wire type, and demand factor setting. All basic operations of these electrical elements are supported.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::ElectricalSetting

See Also

ElectricalSetting Members
Autodesk.Revit.MEP Namespace


ElectricalSetting Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSetting
Visual Basic (Declaration)
Public Class ElectricalSetting
Visual C++
public ref class ElectricalSetting

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElectricalSettingElectricalSettingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddDistributionSysType | Add a new distribution system type to project.
Public method | AddVoltageType | Add a new type definition of voltage into project.
Public method | AddWireMaterialType | Add a new type of wire material.
Public method | AddWireType | Add a new wire type to project.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDemandFactor | Get demand factor information according to specified load classification.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveDistributionSysType | Remove an existing distribution system type from the project.
Public method | RemoveVoltageType | Remove the voltage type from project.
Public method | RemoveWireMaterialType | Remove the wire material type from project.
Public method | RemoveWireType | Remove wire type definition from project.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ConduitTypes | Get electrical conduit types information of the project.
Public property | DistributionSysTypes | Get all distribution system types of the project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | VoltageTypes | Get all voltage type definitions information of the project.
Public property | WireMaterialTypes | Get electrical wire material types information of the project.
Public property | WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting
Autodesk.Revit.MEP Namespace


ElectricalSetting Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSetting ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


ElectricalSetting Methods
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSetting
Visual Basic (Declaration)
Public Class ElectricalSetting
Visual C++
public ref class ElectricalSetting

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddDistributionSysType | Add a new distribution system type to project.
Public method | AddVoltageType | Add a new type definition of voltage into project.
Public method | AddWireMaterialType | Add a new type of wire material.
Public method | AddWireType | Add a new wire type to project.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDemandFactor | Get demand factor information according to specified load classification.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveDistributionSysType | Remove an existing distribution system type from the project.
Public method | RemoveVoltageType | Remove the voltage type from project.
Public method | RemoveWireMaterialType | Remove the wire material type from project.
Public method | RemoveWireType | Remove wire type definition from project.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

ElectricalSetting
Autodesk.Revit.MEP Namespace


AddDistributionSysType Method

ElectricalSetting..::AddDistributionSysType Method
CollapseAll image DropDown image

Add a new distribution system type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DistributionSysType AddDistributionSysType(
    string name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType volLineToLine,
    VoltageType volLineToGround
)
Visual Basic (Declaration)
Public Function AddDistributionSysType ( _
    name As String, _
    phase As ElectricalPhase, _
    phaseConfig As ElectricalPhaseConfiguration, _
    numWire As Integer, _
    volLineToLine As VoltageType, _
    volLineToGround As VoltageType _
) As DistributionSysType
Visual C++
public:
DistributionSysType^ AddDistributionSysType (
    String^ name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType^ volLineToLine,
    VoltageType^ volLineToGround
)

Parameters

name
String
The name of new added distribution system type
phase
ElectricalPhase
Single or three phase this type is
phaseConfig
ElectricalPhaseConfiguration
Configuration property of given phase
numWire
Int32
Wire number of this distribution system
volLineToLine
VoltageType
Type of line to line voltage in this system
volLineToGround
VoltageType
Type of line to ground voltage in this system

Return Value

New added distribution system type object.

Exceptions

Exception | Condition
System..::ArgumentException | The name can't be null, empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


AddVoltageType Method

ElectricalSetting..::AddVoltageType Method
CollapseAll image DropDown image

Add a new type definition of voltage into project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VoltageType AddVoltageType(
    string name,
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Function AddVoltageType ( _
    name As String, _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
) As VoltageType
Visual C++
public:
VoltageType^ AddVoltageType (
    String^ name,
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

name
String
Specify voltage type name
actualValue
Double
Specify actual value of voltage type.
minValue
Double
Specify acceptable minimum value of the voltage type.
maxValue
Double
Specify acceptable maximum value of the voltage type.

Return Value

New added voltage type object.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


AddWireMaterialType Method

ElectricalSetting..::AddWireMaterialType Method
CollapseAll image DropDown image

Add a new type of wire material.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialType AddWireMaterialType(
    string name,
    WireMaterialType baseMaterial
)
Visual Basic (Declaration)
Public Function AddWireMaterialType ( _
    name As String, _
    baseMaterial As WireMaterialType _
) As WireMaterialType
Visual C++
public:
WireMaterialType^ AddWireMaterialType (
    String^ name,
    WireMaterialType^ baseMaterial
)

Parameters

name
String
Name of new material type.
baseMaterial
WireMaterialType
Specify an existing material type which New material will be constructed based on.

Return Value

New added wire material type object.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


AddWireType Method

ElectricalSetting..::AddWireType Method
CollapseAll image DropDown image

Add a new wire type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireType AddWireType(
    string name,
    WireMaterialType materialType,
    TemperatureRatingType temperatureRating,
    InsulationType insulation,
    WireSize maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType.WireType..::NeutralMode neutralMode,
    ConduitType conduit
)
Visual Basic (Declaration)
Public Function AddWireType ( _
    name As String, _
    materialType As WireMaterialType, _
    temperatureRating As TemperatureRatingType, _
    insulation As InsulationType, _
    maxSize As WireSize, _
    neutralMultiplier As Double, _
    neutralRequired As Boolean, _
    neutralMode As WireType..::NeutralMode, _
    conduit As ConduitType _
) As WireType
Visual C++
public:
WireType^ AddWireType (
    String^ name,
    WireMaterialType^ materialType,
    TemperatureRatingType^ temperatureRating,
    InsulationType^ insulation,
    WireSize^ maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType..::NeutralMode neutralMode,
    ConduitType^ conduit
)

Parameters

name
String
Name of the new wire type.
materialType
WireMaterialType
Wire material of new wire type.
temperatureRating
TemperatureRatingType
Temperature rating type information of new wire type.
insulation
InsulationType
Insulation of new wire type.
maxSize
WireSize
Max wire size of new wire type.
neutralMultiplier
Double
Neutral multiplier of new wire type.
neutralRequired
Boolean
Specify whether neutral point is required.
neutralMode
WireType..::NeutralMode
Specify neutral mode.
conduit
ConduitType
Conduit type of new wire type.

Return Value

New added wire type object.

Remarks

Param of temperatureRating should be retrieved from param of materialType, and params such as insulation, maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to be failed.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


GetDemandFactor Method

ElectricalSetting..::GetDemandFactor Method
CollapseAll image DropDown image

Get demand factor information according to specified load classification.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DemandFactor GetDemandFactor(
    LoadClassification loadClassification
)
Visual Basic (Declaration)
Public Function GetDemandFactor ( _
    loadClassification As LoadClassification _
) As DemandFactor
Visual C++
public:
DemandFactor^ GetDemandFactor (
    LoadClassification loadClassification
)

Parameters

loadClassification
LoadClassification
Specify which category of demand factor will be retrieved.

Return Value

Demand factor object to define demand factor of specific load classification in a project.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveDistributionSysType Method

ElectricalSetting..::RemoveDistributionSysType Method
CollapseAll image DropDown image

Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveDistributionSysType(
    DistributionSysType distributionSysType
)
Visual Basic (Declaration)
Public Sub RemoveDistributionSysType ( _
    distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType (
    DistributionSysType^ distributionSysType
)

Parameters

distributionSysType
DistributionSysType

Exceptions

Exception | Condition
System..::InvalidOperationException | Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveVoltageType Method

ElectricalSetting..::RemoveVoltageType Method
CollapseAll image DropDown image

Remove the voltage type from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveVoltageType(
    VoltageType voltageType
)
Visual Basic (Declaration)
Public Sub RemoveVoltageType ( _
    voltageType As VoltageType _
)
Visual C++
public:
void RemoveVoltageType (
    VoltageType^ voltageType
)

Parameters

voltageType
VoltageType
Specify the voltage type to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | Voltage type can be removed only if it isn't in service with any distribution systems.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveWireMaterialType Method

ElectricalSetting..::RemoveWireMaterialType Method
CollapseAll image DropDown image

Remove the wire material type from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveWireMaterialType(
    WireMaterialType materialType
)
Visual Basic (Declaration)
Public Sub RemoveWireMaterialType ( _
    materialType As WireMaterialType _
)
Visual C++
public:
void RemoveWireMaterialType (
    WireMaterialType^ materialType
)

Parameters

materialType
WireMaterialType
The wire material type to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | Wire material type can be removed only if it is not currently assigned to any wire type, and the last one wire material type can't be removed, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveWireType Method

ElectricalSetting..::RemoveWireType Method
CollapseAll image DropDown image

Remove wire type definition from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveWireType(
    WireType wireType
)
Visual Basic (Declaration)
Public Sub RemoveWireType ( _
    wireType As WireType _
)
Visual C++
public:
void RemoveWireType (
    WireType^ wireType
)

Parameters

wireType
WireType

Exceptions

Exception | Condition
System..::InvalidOperationException | Wire type can be removed only if it is not used, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


ElectricalSetting Properties
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSetting
Visual Basic (Declaration)
Public Class ElectricalSetting
Visual C++
public ref class ElectricalSetting

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ConduitTypes | Get electrical conduit types information of the project.
Public property | DistributionSysTypes | Get all distribution system types of the project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | VoltageTypes | Get all voltage type definitions information of the project.
Public property | WireMaterialTypes | Get electrical wire material types information of the project.
Public property | WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting
Autodesk.Revit.MEP Namespace


ConduitTypes Property

ElectricalSetting..::ConduitTypes Property
CollapseAll image DropDown image

Get electrical conduit types information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConduitTypeSet ConduitTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ConduitTypes As ConduitTypeSet
Visual C++
public:
property ConduitTypeSet^ ConduitTypes {
    ConduitTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


DistributionSysTypes Property

ElectricalSetting..::DistributionSysTypes Property
CollapseAll image DropDown image

Get all distribution system types of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DistributionSysTypeSet DistributionSysTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DistributionSysTypes As DistributionSysTypeSet
Visual C++
public:
property DistributionSysTypeSet^ DistributionSysTypes {
    DistributionSysTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


VoltageTypes Property

ElectricalSetting..::VoltageTypes Property
CollapseAll image DropDown image

Get all voltage type definitions information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VoltageTypeSet VoltageTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VoltageTypes As VoltageTypeSet
Visual C++
public:
property VoltageTypeSet^ VoltageTypes {
    VoltageTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


WireMaterialTypes Property

ElectricalSetting..::WireMaterialTypes Property
CollapseAll image DropDown image

Get electrical wire material types information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialTypeSet WireMaterialTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property WireMaterialTypes As WireMaterialTypeSet
Visual C++
public:
property WireMaterialTypeSet^ WireMaterialTypes {
    WireMaterialTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


WireTypes Property

ElectricalSetting..::WireTypes Property
CollapseAll image DropDown image

Get all wire type definition information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireTypeSet WireTypes{ get;}
Visual Basic (Declaration)
Public ReadOnly Property WireTypes As WireTypeSet
Visual C++
public:
property WireTypeSet^ WireTypes {
    WireTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


GroundConductorSize Class
See Also Members
CollapseAll image DropDown image

Represents electrical ground conductor size definition information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1B71F025-7594-426a-AF3C-EA6FFDF72515")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GroundConductorSize : APIObject
Visual Basic (Declaration)
<GuidAttribute("1B71F025-7594-426a-AF3C-EA6FFDF72515")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GroundConductorSize _
    Inherits APIObject
Visual C++
[GuidAttribute(L"1B71F025-7594-426a-AF3C-EA6FFDF72515")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GroundConductorSize : public APIObject

Remarks

Ground conductor size is defined based on corresponding wire material type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::GroundConductorSize

See Also

GroundConductorSize Members
Autodesk.Revit.MEP Namespace


GroundConductorSize Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GroundConductorSize
Visual Basic (Declaration)
Public Class GroundConductorSize
Visual C++
public ref class GroundConductorSize

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GroundConductorSizeGroundConductorSizeNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
Public property | ConductorSize | Get conductor size corresponding to specific ampacity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize
Autodesk.Revit.MEP Namespace


GroundConductorSize Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroundConductorSize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSize ()

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


GroundConductorSize Properties
CollapseAll image DropDown image

Syntax

C#
public class GroundConductorSize
Visual Basic (Declaration)
Public Class GroundConductorSize
Visual C++
public ref class GroundConductorSize

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
Public property | ConductorSize | Get conductor size corresponding to specific ampacity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize
Autodesk.Revit.MEP Namespace


Ampacity Property

GroundConductorSize..::Ampacity Property
CollapseAll image DropDown image

Get ampacity which is used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public long Ampacity{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Ampacity As Long
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


ConductorSize Property

GroundConductorSize..::ConductorSize Property
CollapseAll image DropDown image

Get conductor size corresponding to specific ampacity.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string ConductorSize{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ConductorSize As String
Visual C++
public:
property String^ ConductorSize {
    String^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


MaterialBelongTo Property

GroundConductorSize..::MaterialBelongTo Property
CollapseAll image DropDown image

Get the material type which include this ground conductor size information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialType MaterialBelongTo{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MaterialBelongTo As WireMaterialType
Visual C++
public:
property WireMaterialType^ MaterialBelongTo {
    WireMaterialType^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains GroundConductorSizes.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8DE7B9BE-0A02-4f67-852A-27789B6D3D08")]
public class GroundConductorSizeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8DE7B9BE-0A02-4f67-852A-27789B6D3D08")> _
Public Class GroundConductorSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8DE7B9BE-0A02-4f67-852A-27789B6D3D08")]
public ref class GroundConductorSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::GroundConductorSizeSet

See Also

GroundConductorSizeSet Members
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GroundConductorSizeSet
Visual Basic (Declaration)
Public Class GroundConductorSizeSet
Visual C++
public ref class GroundConductorSizeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GroundConductorSizeSetGroundConductorSizeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every GroundConductorSize from the set, rendering it empty.
Public method | Contains | Tests for the existence of a GroundConductorSize within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GroundConductorSize from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified GroundConductorSize into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroundConductorSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSizeSet ()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class GroundConductorSizeSet
Visual Basic (Declaration)
Public Class GroundConductorSizeSet
Visual C++
public ref class GroundConductorSizeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every GroundConductorSize from the set, rendering it empty.
Public method | Contains | Tests for the existence of a GroundConductorSize within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GroundConductorSize from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified GroundConductorSize into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GroundConductorSizeSet
Autodesk.Revit.MEP Namespace


Clear Method

GroundConductorSizeSet..::Clear Method
CollapseAll image DropDown image

Removes every GroundConductorSize from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

GroundConductorSizeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a GroundConductorSize within the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Contains (
    GroundConductorSize^ item
)

Parameters

item
GroundConductorSize
The GroundConductorSize to be searched for.

Return Value

The Contains method returns True if the GroundConductorSize is within the set, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Dispose Method

GroundConductorSizeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

GroundConductorSizeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified GroundConductorSize from the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GroundConductorSize _
) As Integer
Visual C++
public:
virtual int Erase (
    GroundConductorSize^ item
)

Parameters

item
GroundConductorSize
The GroundConductorSize to be erased.

Return Value

The number of GroundConductorSizes that were erased from the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

GroundConductorSizeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GroundConductorSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

GroundConductorSizeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

GroundConductorSizeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified GroundConductorSize into the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Insert (
    GroundConductorSize^ item
)

Parameters

item
GroundConductorSize
The GroundConductorSize to be inserted into the set.

Return Value

Returns whether the GroundConductorSize was inserted into the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

GroundConductorSizeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

GroundConductorSizeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GroundConductorSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class GroundConductorSizeSet
Visual Basic (Declaration)
Public Class GroundConductorSizeSet
Visual C++
public ref class GroundConductorSizeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet
Autodesk.Revit.MEP Namespace


IsEmpty Property

GroundConductorSizeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Size Property

GroundConductorSizeSet..::Size Property
CollapseAll image DropDown image

Returns the number of GroundConductorSizes that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a GroundConductorSize set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B597FA50-708A-413e-85AD-D56428509919")]
public abstract class GroundConductorSizeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B597FA50-708A-413e-85AD-D56428509919")> _
Public MustInherit Class GroundConductorSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B597FA50-708A-413e-85AD-D56428509919")]
public ref class GroundConductorSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::GroundConductorSizeSetIterator

See Also

GroundConductorSizeSetIterator Members
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class GroundConductorSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GroundConductorSizeSetIterator
Visual C++
public ref class GroundConductorSizeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GroundConductorSizeSetIteratorGroundConductorSizeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroundConductorSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSizeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class GroundConductorSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GroundConductorSizeSetIterator
Visual C++
public ref class GroundConductorSizeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GroundConductorSizeSetIterator
Autodesk.Revit.MEP Namespace


Dispose Method

GroundConductorSizeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

GroundConductorSizeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

GroundConductorSizeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

GroundConductorSizeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class GroundConductorSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GroundConductorSizeSetIterator
Visual C++
public ref class GroundConductorSizeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator
Autodesk.Revit.MEP Namespace


Current Property

GroundConductorSizeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


LightingDevice Class
See Also Members
CollapseAll image DropDown image

Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("60C8455F-950B-4694-9848-258D28B5D88F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LightingDevice : MEPModel
Visual Basic (Declaration)
<GuidAttribute("60C8455F-950B-4694-9848-258D28B5D88F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LightingDevice _
    Inherits MEPModel
Visual C++
[GuidAttribute(L"60C8455F-950B-4694-9848-258D28B5D88F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::LightingDevice

See Also

LightingDevice Members
Autodesk.Revit.MEP Namespace


LightingDevice Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LightingDevice
Visual Basic (Declaration)
Public Class LightingDevice
Visual C++
public ref class LightingDevice

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LightingDeviceLightingDeviceNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice
Autodesk.Revit.MEP Namespace


LightingDevice Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LightingDevice()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LightingDevice ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

LightingDevice Class
Autodesk.Revit.MEP Namespace


LightingFixture Class
See Also Members
CollapseAll image DropDown image

Provides access to the Lighting Fixture in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("70CDB95F-C739-459c-929A-A25C22C2C760")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LightingFixture : MEPModel
Visual Basic (Declaration)
<GuidAttribute("70CDB95F-C739-459c-929A-A25C22C2C760")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LightingFixture _
    Inherits MEPModel
Visual C++
[GuidAttribute(L"70CDB95F-C739-459c-929A-A25C22C2C760")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LightingFixture : public MEPModel

Remarks

The Lighting Fixture object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::LightingFixture

See Also

LightingFixture Members
Autodesk.Revit.MEP Namespace


LightingFixture Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LightingFixture
Visual Basic (Declaration)
Public Class LightingFixture
Visual C++
public ref class LightingFixture

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LightingFixtureLightingFixtureNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingFixture
Autodesk.Revit.MEP Namespace


LightingFixture Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LightingFixture()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LightingFixture ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

LightingFixture Class
Autodesk.Revit.MEP Namespace


MechanicalEquipment Class
See Also Members
CollapseAll image DropDown image

Provides access to the Mechanical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("705F6574-3FB2-44de-AA99-5E8C594D7458")]
public class MechanicalEquipment : MEPModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("705F6574-3FB2-44de-AA99-5E8C594D7458")> _
Public Class MechanicalEquipment _
    Inherits MEPModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"705F6574-3FB2-44de-AA99-5E8C594D7458")]
public ref class MechanicalEquipment : public MEPModel

Remarks

The Mechanical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::MechanicalEquipment

See Also

MechanicalEquipment Members
Autodesk.Revit.MEP Namespace


MechanicalEquipment Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MechanicalEquipment
Visual Basic (Declaration)
Public Class MechanicalEquipment
Visual C++
public ref class MechanicalEquipment

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MechanicalEquipmentMechanicalEquipmentNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MechanicalEquipment
Autodesk.Revit.MEP Namespace


MechanicalEquipment Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MechanicalEquipment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MechanicalEquipment ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

MechanicalEquipment Class
Autodesk.Revit.MEP Namespace


MEPModel Class
See Also Members
CollapseAll image DropDown image

Supports all Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("24DFB032-FCEB-40b9-BD36-A9E11DEA80E2")]
public class MEPModel : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("24DFB032-FCEB-40b9-BD36-A9E11DEA80E2")> _
Public Class MEPModel _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"24DFB032-FCEB-40b9-BD36-A9E11DEA80E2")]
public ref class MEPModel : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::ElectricalEquipment
Autodesk.Revit.MEP..::LightingDevice
Autodesk.Revit.MEP..::LightingFixture
Autodesk.Revit.MEP..::MechanicalEquipment

See Also

MEPModel Members
Autodesk.Revit.MEP Namespace


MEPModel Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MEPModel
Visual Basic (Declaration)
Public Class MEPModel
Visual C++
public ref class MEPModel

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MEPModelMEPModelNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel
Autodesk.Revit.MEP Namespace


MEPModel Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPModel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPModel ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


MEPModel Properties
CollapseAll image DropDown image

Syntax

C#
public class MEPModel
Visual Basic (Declaration)
Public Class MEPModel
Visual C++
public ref class MEPModel

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel
Autodesk.Revit.MEP Namespace


ConnectorManager Property

MEPModel..::ConnectorManager Property
CollapseAll image DropDown image

Retrieves the Connector Manager from this MEPModel.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConnectorManager ConnectorManager{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

This property returns Connector Manager from this MEPModel.

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


ElectricalSystems Property

MEPModel..::ElectricalSystems Property
CollapseAll image DropDown image

Retrieves the electrical systems that are currently created using this MEPModel.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystemSet ElectricalSystems{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSystems As ElectricalSystemSet
Visual C++
public:
property ElectricalSystemSet^ ElectricalSystems {
    ElectricalSystemSet^ get ();
}

Remarks

This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set.

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


WireSize Class
See Also Members
CollapseAll image DropDown image

Represents specific electrical wire size information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9C0C9DA1-7EA6-463d-AE7E-D3F050683029")]
public class WireSize : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9C0C9DA1-7EA6-463d-AE7E-D3F050683029")> _
Public Class WireSize _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9C0C9DA1-7EA6-463d-AE7E-D3F050683029")]
public ref class WireSize : public APIObject

Remarks

Wire size is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::WireSize

See Also

WireSize Members
Autodesk.Revit.MEP Namespace


WireSize Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireSize
Visual Basic (Declaration)
Public Class WireSize
Visual C++
public ref class WireSize

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireSizeWireSizeNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Public property | Diameter | Get diameter of wire.
Public property | InUse | Get or set whether the size can be used in sizing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Get size symbol of wire.

See Also

WireSize
Autodesk.Revit.MEP Namespace


WireSize Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSize ()

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


WireSize Properties
CollapseAll image DropDown image

Syntax

C#
public class WireSize
Visual Basic (Declaration)
Public Class WireSize
Visual C++
public ref class WireSize

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Public property | Diameter | Get diameter of wire.
Public property | InUse | Get or set whether the size can be used in sizing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Get size symbol of wire.

See Also

WireSize
Autodesk.Revit.MEP Namespace


Ampacity Property

WireSize..::Ampacity Property
CollapseAll image DropDown image

Get ampacity which be used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public long Ampacity{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Ampacity As Long
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


Diameter Property

WireSize..::Diameter Property
CollapseAll image DropDown image

Get diameter of wire.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Diameter{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Double
Visual C++
public:
property double Diameter {
    double get ();
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


InUse Property

WireSize..::InUse Property
CollapseAll image DropDown image

Get or set whether the size can be used in sizing.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool InUse{ get; set;}
Visual Basic (Declaration)
Public Property InUse As Boolean
Visual C++
public:
property bool InUse {
    bool get ();
    void set (bool value);
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


Size Property

WireSize..::Size Property
CollapseAll image DropDown image

Get size symbol of wire.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Size{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Size As String
Visual C++
public:
property String^ Size {
    String^ get ();
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


WireSizeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains wire sizes.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D85BC35E-D247-49a2-87DB-1587BF4217F6")]
public class WireSizeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D85BC35E-D247-49a2-87DB-1587BF4217F6")> _
Public Class WireSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D85BC35E-D247-49a2-87DB-1587BF4217F6")]
public ref class WireSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::WireSizeSet

See Also

WireSizeSet Members
Autodesk.Revit.MEP Namespace


WireSizeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireSizeSet
Visual Basic (Declaration)
Public Class WireSizeSet
Visual C++
public ref class WireSizeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireSizeSetWireSizeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every wire size from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire size within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire size from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire size into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet
Autodesk.Revit.MEP Namespace


WireSizeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSizeSet ()

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


WireSizeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class WireSizeSet
Visual Basic (Declaration)
Public Class WireSizeSet
Visual C++
public ref class WireSizeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every wire size from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire size within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire size from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire size into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireSizeSet
Autodesk.Revit.MEP Namespace


Clear Method

WireSizeSet..::Clear Method
CollapseAll image DropDown image

Removes every wire size from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

WireSizeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a wire size within the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Contains (
    WireSize^ item
)

Parameters

item
WireSize
The wire size to be searched for.

Return Value

The Contains method returns True if the wire size is within the set, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Dispose Method

WireSizeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

WireSizeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified wire size from the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireSize _
) As Integer
Visual C++
public:
virtual int Erase (
    WireSize^ item
)

Parameters

item
WireSize
The wire size to be erased.

Return Value

The number of wire sizes that were erased from the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

WireSizeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

WireSizeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

WireSizeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified wire size into the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Insert (
    WireSize^ item
)

Parameters

item
WireSize
The wire size to be inserted into the set.

Return Value

Returns whether the wire size was inserted into the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

WireSizeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

WireSizeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


WireSizeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class WireSizeSet
Visual Basic (Declaration)
Public Class WireSizeSet
Visual C++
public ref class WireSizeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet
Autodesk.Revit.MEP Namespace


IsEmpty Property

WireSizeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Size Property

WireSizeSet..::Size Property
CollapseAll image DropDown image

Returns the number of wire sizes that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a wire size set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EF1C21D2-E326-4334-BB1B-C14DCC30AAF6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class WireSizeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("EF1C21D2-E326-4334-BB1B-C14DCC30AAF6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class WireSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"EF1C21D2-E326-4334-BB1B-C14DCC30AAF6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WireSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::WireSizeSetIterator

See Also

WireSizeSetIterator Members
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class WireSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireSizeSetIterator
Visual C++
public ref class WireSizeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireSizeSetIteratorWireSizeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSizeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class WireSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireSizeSetIterator
Visual C++
public ref class WireSizeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireSizeSetIterator
Autodesk.Revit.MEP Namespace


Dispose Method

WireSizeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

WireSizeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


ReleaseUnmanagedResources Method

WireSizeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

WireSizeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class WireSizeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireSizeSetIterator
Visual C++
public ref class WireSizeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator
Autodesk.Revit.MEP Namespace


Current Property

WireSizeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


Autodesk.Revit.MEP.Enums Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.MEP.Enums
Visual Basic (Declaration)
Namespace Autodesk.Revit.MEP.Enums
Visual C++
namespace Autodesk.Revit.MEP.Enums

Enumerations

 | Enumeration | Description
Public enumeration | BaseLoadOn | An enumerate type listing all the possible Power Load Unit for a Space object.
Public enumeration | ConditionType | An enumerate type listing all the possible Return Airflow Type for a Space object.
Public enumeration | ConnectorProfileType | An enumerate type listing all the Connector type for the Connection.
Public enumeration | ConnectorType | An enumerate type listing all the Connector type for the Connection.
Public enumeration | Domain | An enumerate type listing all the Domain type for the Connector.
Public enumeration | DuctSystemType | An enumerate type listing all the possible Duct System Types for a Duct Connector object.
Public enumeration | ElectricalPhase | An enumerate type to specify weather the electrical system is single phase or three phases.
Public enumeration | ElectricalPhaseConfiguration | An enumerate type to specify electrical phase configuration.
Public enumeration | ElectricalSystemType | An enumerate type listing all the possible Pipe System Types for a Duct Connector object.
Public enumeration | LoadClassification | An enumerate type to list all demond factor classification.
Public enumeration | LoadClassificationType | An enumerate type listing all the possible Load Classification Type for a Connector object.
Public enumeration | OccupancyUnit | An enumerate type listing all the possible Occupancy Unit for a Space object.
Public enumeration | PipeSystemType | An enumerate type listing all the possible Pipe System Types for a Duct Connector object.
Public enumeration | PowerFactorStateType | An enumerate type listing all the possible Power Factor State Type for a Connector object.
Public enumeration | ReturnAirflowType | An enumerate type listing all the possible Return Airflow Type for a Space object.
Public enumeration | SpaceType | An enumerate type listing all the possible Space Type for a Space object.
Public enumeration | WiringType | An enumerate type to list all wiring type.


BaseLoadOn Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Power Load Unit for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9463CF2C-9D70-46cb-8A97-712F6BDBD5D8")]
public enum BaseLoadOn
Visual Basic (Declaration)
<GuidAttribute("9463CF2C-9D70-46cb-8A97-712F6BDBD5D8")> _
Public Enumeration BaseLoadOn
Visual C++
[GuidAttribute(L"9463CF2C-9D70-46cb-8A97-712F6BDBD5D8")]
public enum class BaseLoadOn

Members

Member name | Description
kNoOfBaseLoadOnMethods | Return BaseLoadOn is NoOfBaseLoadOnMethods.
kUseActualLoad | Return BaseLoadOn is UseActualLoad.
kUseCalculatedLoad | Return BaseLoadOn is UseCalculatedLoad.
kUseEnteredLoad | Return BaseLoadOn is UseEnteredLoad.
kUseDefaultLoad | Return BaseLoadOn is UseDefaultLoad.

See Also

Autodesk.Revit.MEP.Enums Namespace


ConditionType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Return Airflow Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9951AB18-54C2-4028-A2B3-AA5E3F44AFE3")]
public enum ConditionType
Visual Basic (Declaration)
<GuidAttribute("9951AB18-54C2-4028-A2B3-AA5E3F44AFE3")> _
Public Enumeration ConditionType
Visual C++
[GuidAttribute(L"9951AB18-54C2-4028-A2B3-AA5E3F44AFE3")]
public enum class ConditionType

Members

Member name | Description
NoOfConditionTypes | Return Condition Type is NoOfConditionTypes.
NaturallyVentedOnly | Return Condition Type is NaturallyVentedOnly.
Vented | Return Condition Type is Vented.
Unconditioned | Return Condition Type is Unconditioned.
HeatedAndCooled | Return Condition Type is HeatedAndCooled.
Cooled | Return Condition Type is Cooled.
Heated | Return Condition Type is Heated.
NoConditionType | Return Condition Type is NoConditionType.

See Also

Autodesk.Revit.MEP.Enums Namespace


ConnectorProfileType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Connector type for the Connection.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9E3C967E-8ED0-4dab-8860-02EE39E086E5")]
public enum ConnectorProfileType
Visual Basic (Declaration)
<GuidAttribute("9E3C967E-8ED0-4dab-8860-02EE39E086E5")> _
Public Enumeration ConnectorProfileType
Visual C++
[GuidAttribute(L"9E3C967E-8ED0-4dab-8860-02EE39E086E5")]
public enum class ConnectorProfileType

Members

Member name | Description
OvalProfile | Connection Profile Type is Oval.
RectProfile | Connection Profile Type is Rect.
RoundProfile | Connection Profile Type is Round.
InvalidProfile | Connection Profile Type is Invalid.

See Also

Autodesk.Revit.MEP.Enums Namespace


ConnectorType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Connector type for the Connection.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4A24A235-D0BF-49fe-BE54-CDD37D791E34")]
public enum ConnectorType
Visual Basic (Declaration)
<GuidAttribute("4A24A235-D0BF-49fe-BE54-CDD37D791E34")> _
Public Enumeration ConnectorType
Visual C++
[GuidAttribute(L"4A24A235-D0BF-49fe-BE54-CDD37D791E34")]
public enum class ConnectorType

Members

Member name | Description
AllConnectorModes | Connection Type is All Connector Modes.
NonEndConn | Connection Type is Non End Connection.
PhysicalConn | Connection Type is Physical Connection.
LogicalConn | Connection Type is Logical Connection.
CurveConn | Connection Type is Curve Connection.
EndConn | Connection Type is End Connection.
InvalidConnectorType | Connection Type is Invalid.

See Also

Autodesk.Revit.MEP.Enums Namespace


Domain Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Domain type for the Connector.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6EE54BD3-C804-4abf-A9FB-0173837E4E4E")]
public enum Domain
Visual Basic (Declaration)
<GuidAttribute("6EE54BD3-C804-4abf-A9FB-0173837E4E4E")> _
Public Enumeration Domain
Visual C++
[GuidAttribute(L"6EE54BD3-C804-4abf-A9FB-0173837E4E4E")]
public enum class Domain

Members

Member name | Description
DomainPiping | Domain is Piping.
DomainElectrical | Domain is Electrical.
DomainHvac | Domain is Hvac.
DomainUndefined | Domain is Undefined.

See Also

Autodesk.Revit.MEP.Enums Namespace


DuctSystemType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Duct System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F6C03427-CC6A-4265-984F-557F10C8515B")]
public enum DuctSystemType
Visual Basic (Declaration)
<GuidAttribute("F6C03427-CC6A-4265-984F-557F10C8515B")> _
Public Enumeration DuctSystemType
Visual C++
[GuidAttribute(L"F6C03427-CC6A-4265-984F-557F10C8515B")]
public enum class DuctSystemType

Members

Member name | Description
Global | Duct System Type is Global.
Fitting | Duct System Type is Fitting.
OtherAir | Duct System Type is OtherAir.
ExhaustAir | Duct System Type is ExhaustAir.
ReturnAir | Duct System Type is ReturnAir.
SupplyAir | Duct System Type is SupplyAir.

See Also

Autodesk.Revit.MEP.Enums Namespace


ElectricalPhase Enumeration
CollapseAll image DropDown image

An enumerate type to specify weather the electrical system is single phase or three phases.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C1FC623F-3439-427d-8A6E-C358058699BE")]
public enum ElectricalPhase
Visual Basic (Declaration)
<GuidAttribute("C1FC623F-3439-427d-8A6E-C358058699BE")> _
Public Enumeration ElectricalPhase
Visual C++
[GuidAttribute(L"C1FC623F-3439-427d-8A6E-C358058699BE")]
public enum class ElectricalPhase

Members

Member name | Description
ThreePhase | Electrical phase is ThreePhase.
SinglePhase | Electrical phase is SinglePhase.

See Also

Autodesk.Revit.MEP.Enums Namespace


ElectricalPhaseConfiguration Enumeration
CollapseAll image DropDown image

An enumerate type to specify electrical phase configuration.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2E77E716-4237-4f14-AEED-3B04B3CA2245")]
public enum ElectricalPhaseConfiguration
Visual Basic (Declaration)
<GuidAttribute("2E77E716-4237-4f14-AEED-3B04B3CA2245")> _
Public Enumeration ElectricalPhaseConfiguration
Visual C++
[GuidAttribute(L"2E77E716-4237-4f14-AEED-3B04B3CA2245")]
public enum class ElectricalPhaseConfiguration

Members

Member name | Description
Delta | Electrical phase configuration is delta.
Wye | Electrical phase configuration is Y.
Undefined | Electrical phase configuration is undefined.

See Also

Autodesk.Revit.MEP.Enums Namespace


ElectricalSystemType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Pipe System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FC906532-BAA2-40a1-AACD-1B11ED8A01B5")]
public enum ElectricalSystemType
Visual Basic (Declaration)
<GuidAttribute("FC906532-BAA2-40a1-AACD-1B11ED8A01B5")> _
Public Enumeration ElectricalSystemType
Visual C++
[GuidAttribute(L"FC906532-BAA2-40a1-AACD-1B11ED8A01B5")]
public enum class ElectricalSystemType

Members

Member name | Description
Communication | Electrical System Type is Communication.
Controls | Electrical System Type is Controls.
NurseCall | Electrical System Type is NurseCall.
FireAlarm | Electrical System Type is FireAlarm.
Telephone | Electrical System Type is Telephone.
PowerCircuit | Electrical System Type is PowerCircuit.
Data | Electrical System Type is Data.
Security | Electrical System Type is Security.

See Also

Autodesk.Revit.MEP.Enums Namespace


LoadClassification Enumeration
CollapseAll image DropDown image

An enumerate type to list all demond factor classification.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E1C52466-3BE6-4f07-8108-E704596394D7")]
public enum LoadClassification
Visual Basic (Declaration)
<GuidAttribute("E1C52466-3BE6-4f07-8108-E704596394D7")> _
Public Enumeration LoadClassification
Visual C++
[GuidAttribute(L"E1C52466-3BE6-4f07-8108-E704596394D7")]
public enum class LoadClassification

Members

Member name | Description
Hvac | Load classification is HVAC.
Lighting | Load classification is lighting.
Power | Load classification is power.
Undefined | Load classification is undefined.

See Also

Autodesk.Revit.MEP.Enums Namespace


LoadClassificationType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Load Classification Type for a Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("38608224-626B-4540-8BDC-0922448755C6")]
public enum LoadClassificationType
Visual Basic (Declaration)
<GuidAttribute("38608224-626B-4540-8BDC-0922448755C6")> _
Public Enumeration LoadClassificationType
Visual C++
[GuidAttribute(L"38608224-626B-4540-8BDC-0922448755C6")]
public enum class LoadClassificationType

Members

Member name | Description
HVAC | Load Classification Type is HVAC.
Lighting | Load Classification Type is Lighting.
Power | Load Classification Type is Power.
Other | Load Classification Type is Other.

See Also

Autodesk.Revit.MEP.Enums Namespace


OccupancyUnit Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Occupancy Unit for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("ADA4FF50-C5CA-43e2-AD49-AF4FCD87B56E")]
public enum OccupancyUnit
Visual Basic (Declaration)
<GuidAttribute("ADA4FF50-C5CA-43e2-AD49-AF4FCD87B56E")> _
Public Enumeration OccupancyUnit
Visual C++
[GuidAttribute(L"ADA4FF50-C5CA-43e2-AD49-AF4FCD87B56E")]
public enum class OccupancyUnit

Members

Member name | Description
AreaPerPerson | Return OccupancyUnit is AreaPerPerson.
NumberOfPeople | Return OccupancyUnit is NumberOfPeople.
UseDefaultValues | Return OccupancyUnit is UseDefaultValues.

See Also

Autodesk.Revit.MEP.Enums Namespace


PipeSystemType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Pipe System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("31450C28-12DA-400f-A74E-61C24CB0C309")]
public enum PipeSystemType
Visual Basic (Declaration)
<GuidAttribute("31450C28-12DA-400f-A74E-61C24CB0C309")> _
Public Enumeration PipeSystemType
Visual C++
[GuidAttribute(L"31450C28-12DA-400f-A74E-61C24CB0C309")]
public enum class PipeSystemType

Members

Member name | Description
Global | Pipe System Type is Global.
Fitting | Pipe System Type is Fitting.
FireProtectOther | Pipe System Type is FireProtectOther.
FireProtectPreaction | Pipe System Type is FireProtectPreaction.
FireProtectDry | Pipe System Type is FireProtectDry.
FireProtectWet | Pipe System Type is FireProtectWet.
OtherPipe | Pipe System Type is OtherPipe.
DomesticColdWater | Pipe System Type is DomesticColdWater.
DomesticHotWater | Pipe System Type is DomesticHotWater.
Sanitary | Pipe System Type is Sanitary.
ReturnHydronic | Pipe System Type is ReturnHydronic.
SupplyHydronic | Pipe System Type is SupplyHydronic.

See Also

Autodesk.Revit.MEP.Enums Namespace


PowerFactorStateType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Power Factor State Type for a Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C4E8AEDE-E694-4827-AA3A-A071E81EA60F")]
public enum PowerFactorStateType
Visual Basic (Declaration)
<GuidAttribute("C4E8AEDE-E694-4827-AA3A-A071E81EA60F")> _
Public Enumeration PowerFactorStateType
Visual C++
[GuidAttribute(L"C4E8AEDE-E694-4827-AA3A-A071E81EA60F")]
public enum class PowerFactorStateType

Members

Member name | Description
Lagging | Power FactorState Type is Lagging.
Leading | Power FactorState Type is Leading.

See Also

Autodesk.Revit.MEP.Enums Namespace


ReturnAirflowType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Return Airflow Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("14EFFFFF-CACC-4faa-99D2-B2D5C9450460")]
public enum ReturnAirflowType
Visual Basic (Declaration)
<GuidAttribute("14EFFFFF-CACC-4faa-99D2-B2D5C9450460")> _
Public Enumeration ReturnAirflowType
Visual C++
[GuidAttribute(L"14EFFFFF-CACC-4faa-99D2-B2D5C9450460")]
public enum class ReturnAirflowType

Members

Member name | Description
ActualSupplyAirflow | Return Airflow Type is ActualSupplyAirflow.
CalculatedSupplyAirflow | Return Airflow Type is CalculatedSupplyAirflow.
SpecifiedSupplyAirflow | Return Airflow Type is SpecifiedSupplyAirflow.
Specified | Return Airflow Type is Specified.

See Also

Autodesk.Revit.MEP.Enums Namespace


SpaceType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Space Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EC4C15CA-D174-4c7a-B46D-0302CCD142F3")]
public enum SpaceType
Visual Basic (Declaration)
<GuidAttribute("EC4C15CA-D174-4c7a-B46D-0302CCD142F3")> _
Public Enumeration SpaceType
Visual C++
[GuidAttribute(L"EC4C15CA-D174-4c7a-B46D-0302CCD142F3")]
public enum class SpaceType

Members

Member name | Description
kNoOfSpaceTypes | Return Space Type is NoOfSpaceTypes.
kWorshipPulpitChoirReligious | Return Space Type is WorshipPulpitChoirReligious.
kWorkshopWorkshop | Return Space Type is WorkshopWorkshop.
kTerminalTicketCounterTransportation | Return Space Type is TerminalTicketCounterTransportation.
kSupermarketSalesAreaRetail | Return Space Type is SupermarketSalesAreaRetail.
kStairway | Return Space Type is Stairway.
kStairsInactive | Return Space Type is StairsInactive.
kStacksLibrary | Return Space Type is StacksLibrary.
kSpecialtyStoreSalesAreaRetail | Return Space Type is SpecialtyStoreSalesAreaRetail.
kSortingAreaPostOffice | Return Space Type is SortingAreaPostOffice.
kSleepingQuartersPoliceOrFireStation | Return Space Type is SleepingQuartersPoliceOrFireStation.
kRingSportsAreaSportsArena | Return Space Type is RingSportsAreaSportsArena.
kRestrooms | Return Space Type is Restrooms.
kRestorationMuseum | Return Space Type is RestorationMuseum.
kRecoveryHospitalOrHealthcare | Return Space Type is RecoveryHospitalOrHealthcare.
kReceptionOrWaitingHotel | Return Space Type is ReceptionOrWaitingHotel.
kReceptionOrWaitingMotel | Return Space Type is ReceptionOrWaitingMotel.
kReceptionOrWaitingTransportation | Return Space Type is ReceptionOrWaitingTransportation.
kReadingAreaLibrary | Return Space Type is ReadingAreaLibrary.
kPublicAndStaffLoungeHospitalOrHealthcare | Return Space Type is PublicAndStaffLoungeHospitalOrHealthcare.
kPoliceStationLaboratoryPoliceOrFireStations | Return Space Type is PoliceStationLaboratoryPoliceOrFireStations.
kPlayingAreaGymnasium | Return Space Type is PlayingAreaGymnasium.
kPhysicalTherapyHospitalOrHealthcare | Return Space Type is PhysicalTherapyHospitalOrHealthcare.
kPharmacyHospitalOrHealthcare | Return Space Type is PharmacyHospitalOrHealthcare.
kPersonalServicesSalesAreaRetail | Return Space Type is PersonalServicesSalesAreaRetail.
kPatientRoomHospitalOrHealthcare | Return Space Type is PatientRoomHospitalOrHealthcare.
kParkingAreaPedestrianParkingGarage | Return Space Type is ParkingAreaPedestrianParkingGarage.
kParkingAreaAttendantOnlyParkingGarage | Return Space Type is ParkingAreaAttendantOnlyParkingGarage.
kOtherTelevisedPlayingAreaSportsArena | Return Space Type is OtherTelevisedPlayingAreaSportsArena.
kOperatingRoomHospitalOrHealthcare | Return Space Type is OperatingRoomHospitalOrHealthcare.
kOfficeCommonActivityAreasInactiveStorage | Return Space Type is OfficeCommonActivityAreasInactiveStorage.
kOfficeOpenPlan | Return Space Type is OfficeOpenPlan.
kOfficeEnclosed | Return Space Type is OfficeEnclosed.
kNurseStationHospitalOrHealthcare | Return Space Type is NurseStationHospitalOrHealthcare.
kMuseumAndGalleryStorage | Return Space Type is MuseumAndGalleryStorage.
kMerchandisingSalesAreaRetail | Return Space Type is MerchandisingSalesAreaRetail.
kMediumOrBulkyMaterialWarehouse | Return Space Type is MediumOrBulkyMaterialWarehouse.
kMassMerchandisingSalesAreaRetail | Return Space Type is MassMerchandisingSalesAreaRetail.
kMallConcourseSalesAreaRetail | Return Space Type is MallConcourseSalesAreaRetail.
kLoungeOrRecreation | Return Space Type is LoungeOrRecreation.
kLobbyHotel | Return Space Type is LobbyHotel.
kLobbyPostOffice | Return Space Type is LobbyPostOffice.
kLobbyPerformingArtsTheatre | Return Space Type is LobbyPerformingArtsTheatre.
kLobbyAuditorium | Return Space Type is LobbyAuditorium.
kLobbyMotionPictureTheatre | Return Space Type is LobbyMotionPictureTheatre.
kLobbyReligiousBuildings | Return Space Type is LobbyReligiousBuildings.
kLobby | Return Space Type is Lobby.
kLivingQuartersHotel | Return Space Type is LivingQuartersHotel.
kLivingQuartersMotel | Return Space Type is LivingQuartersMotel.
kLivingQuartersDormitory | Return Space Type is LivingQuartersDormitory.
kLibraryAudioVisualLibraryAudioVisual | Return Space Type is LibraryAudioVisualLibraryAudioVisual.
kLaundryWashingHospitalOrHealthcare | Return Space Type is LaundryWashingHospitalOrHealthcare.
kLaundryIroningAndSorting | Return Space Type is LaundryIroningAndSorting.
kLaboratoryOffice | Return Space Type is LaboratoryOffice.
kJudgesChambersCourtHouse | Return Space Type is JudgesChambersCourtHouse.
kInactiveStorage | Return Space Type is InactiveStorage.
kHotelOrConferenceCenterConferenceOrMeeting | Return Space Type is HotelOrConferenceCenterConferenceOrMeeting.
kHospitalOrRadiologyHospitalOrHealthcare | Return Space Type is HospitalOrRadiologyHospitalOrHealthcare.
kHospitalOrMedicalSuppliesHospitalOrHealthcare | Return Space Type is HospitalOrMedicalSuppliesHospitalOrHealthcare.
kHospitalNurseryHospitalOrHealthcare | Return Space Type is HospitalNurseryHospitalOrHealthcare.
kGeneralExhibitionMuseum | Return Space Type is GeneralExhibitionMuseum.
kGeneralLowBayManufacturingFacility | Return Space Type is GeneralLowBayManufacturingFacility.
kGeneralHighBayManufacturingFacility | Return Space Type is GeneralHighBayManufacturingFacility.
kGarageServiceOrRepairAutomotiveFacility | Return Space Type is GarageServiceOrRepairAutomotiveFacility.
kFoodPreparation | Return Space Type is FoodPreparation.
kFireStationEngineRoomPoliceOrFireStation | Return Space Type is FireStationEngineRoomPoliceOrFireStation.
kFineMerchandiseSalesAreaRetail | Return Space Type is FineMerchandiseSalesAreaRetail.
kFineMaterialWarehouse | Return Space Type is FineMaterialWarehouse.
kFellowshipHallReligiousBuildings | Return Space Type is FellowshipHallReligiousBuildings.
kExhibitSpaceConventionCenter | Return Space Type is ExhibitSpaceConventionCenter.
kExerciseAreaGymnasium | Return Space Type is ExerciseAreaGymnasium.
kExerciseAreaExerciseCenter | Return Space Type is ExerciseAreaExerciseCenter.
kExamOrTreatmentHospitalOrHealthcare | Return Space Type is ExamOrTreatmentHospitalOrHealthcare.
kEquipmentRoomManufacturingFacility | Return Space Type is EquipmentRoomManufacturingFacility.
kEmergencyHospitalOrHealthcare | Return Space Type is EmergencyHospitalOrHealthcare.
kElevatorLobbies | Return Space Type is ElevatorLobbies.
kElectricalOrMechanical | Return Space Type is ElectricalOrMechanical.
kDressingOrLockerOrFittingRoomExerciseCenter | Return Space Type is DressingOrLockerOrFittingRoomExerciseCenter.
kDressingOrLockerOrFittingRoomAuditorium | Return Space Type is DressingOrLockerOrFittingRoomAuditorium.
kDressingOrLockerOrFittingRoomPerformingArtsTheatre | Return Space Type is DressingOrLockerOrFittingRoomPerformingArtsTheatre.
kDressingOrLockerOrFittingRoomCourtHouse | Return Space Type is DressingOrLockerOrFittingRoomCourtHouse.
kDressingOrLockerOrFittingRoomGymnasium | Return Space Type is DressingOrLockerOrFittingRoomGymnasium.
kDormitoryStudyHall | Return Space Type is DormitoryStudyHall.
kDormitoryBedroom | Return Space Type is DormitoryBedroom.
kDiningAreaCivilServices | Return Space Type is DiningAreaCivilServices.
kDiningAreaPenitentiary | Return Space Type is DiningAreaPenitentiary.
kDiningAreaTransportation | Return Space Type is DiningAreaTransportation.
kDiningAreaMotel | Return Space Type is DiningAreaMotel.
kDiningAreaLoungeOrLeisureDining | Return Space Type is DiningAreaLoungeOrLeisureDining.
kDiningAreaFamilyDining | Return Space Type is DiningAreaFamilyDining.
kDiningAreaHotel | Return Space Type is DiningAreaHotel.
kDiningArea | Return Space Type is DiningArea.
kDetailedManufacturingFacility | Return Space Type is DetailedManufacturingFacility.
kDepartmentStoreSalesAreaRetail | Return Space Type is DepartmentStoreSalesAreaRetail.
kCourtroomCourtHouse | Return Space Type is CourtroomCourtHouse.
kCourtSportsAreaSportsArena | Return Space Type is CourtSportsAreaSportsArena.
kCorridorsWithPatientWaitingExamHospitalOrHealthcare | Return Space Type is CorridorsWithPatientWaitingExamHospitalOrHealthcare.
kCorridorOrTransitionManufacturingFacility | Return Space Type is CorridorOrTransitionManufacturingFacility.
kCorridorOrTransition | Return Space Type is CorridorOrTransition.
kConferenceMeetingOrMultipurpose | Return Space Type is ConferenceMeetingOrMultipurpose.
kComfinementCellsCourtHouse | Return Space Type is ComfinementCellsCourtHouse.
kComfinementCellsPenitentiary | Return Space Type is ComfinementCellsPenitentiary.
kClassroomOrLectureOrTraining | Return Space Type is ClassroomOrLectureOrTraining.
kClassroomOrLectureOrTrainingPenitentiary | Return Space Type is ClassroomOrLectureOrTrainingPenitentiary.
kCardFileAndCataloguingLibrary | Return Space Type is CardFileAndCataloguingLibrary.
kBarberAndBeautyParlor | Return Space Type is BarberAndBeautyParlor.
kBankingActivityAreaOffice | Return Space Type is BankingActivityAreaOffice.
kBankCustomerArea | Return Space Type is BankCustomerArea.
kAudienceOrSeatingAreaAuditorium | Return Space Type is AudienceOrSeatingAreaAuditorium.
kAudienceOrSeatingAreaCourtHouse | Return Space Type is AudienceOrSeatingAreaCourtHouse.
kAudienceOrSeatingAreaPoliceOrFireStations | Return Space Type is AudienceOrSeatingAreaPoliceOrFireStations.
kAudienceOrSeatingAreaReligious | Return Space Type is AudienceOrSeatingAreaReligious.
kAudienceOrSeatingAreaPerformingArtsTheatre | Return Space Type is AudienceOrSeatingAreaPerformingArtsTheatre.
kAudienceOrSeatingAreaMotionPictureTheatre | Return Space Type is AudienceOrSeatingAreaMotionPictureTheatre.
kAudienceOrSeatingAreaConventionCenter | Return Space Type is AudienceOrSeatingAreaConventionCenter.
kAudienceOrSeatingAreaSportsArena | Return Space Type is AudienceOrSeatingAreaSportsArena.
kAudienceOrSeatingAreaGymnasium | Return Space Type is AudienceOrSeatingAreaGymnasium.
kAudienceOrSeatingAreaExerciseCenter | Return Space Type is AudienceOrSeatingAreaExerciseCenter.
kAudienceOrSeatingAreaPenitentiary | Return Space Type is AudienceOrSeatingAreaPenitentiary.
kAtriumFirstThreeFloors | Return Space Type is AtriumFirstThreeFloors.
kAtriumEachAdditionalFloor | Return Space Type is AtriumEachAdditionalFloor.
kAirportConcourse | Return Space Type is AirportConcourse.
kAirOrTrainOrBusBaggageArea | Return Space Type is AirOrTrainOrBusBaggageArea.
kActiveStorageHospitalOrHealthcare | Return Space Type is ActiveStorageHospitalOrHealthcare.
kActiveStorage | Return Space Type is ActiveStorage.
kNoSpaceType | Return Space Type is NoSpaceType.

See Also

Autodesk.Revit.MEP.Enums Namespace


WiringType Enumeration
CollapseAll image DropDown image

An enumerate type to list all wiring type.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("75868222-9B4C-4ebe-889F-2CCE658EF1B2")]
public enum WiringType
Visual Basic (Declaration)
<GuidAttribute("75868222-9B4C-4ebe-889F-2CCE658EF1B2")> _
Public Enumeration WiringType
Visual C++
[GuidAttribute(L"75868222-9B4C-4ebe-889F-2CCE658EF1B2")]
public enum class WiringType

Members

Member name | Description
Chamfer | Chamfered wiring can be used to indicate wiring that is exposed.
Arc | Arc wiring is used to indicate wiring that is concealed within walls, ceilings, or floors.

See Also

Autodesk.Revit.MEP.Enums Namespace


Autodesk.Revit.Options Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Options
Visual Basic (Declaration)
Namespace Autodesk.Revit.Options
Visual C++
namespace Autodesk.Revit.Options

Classes

 | Class | Description
Public class | Application | The Application Options object provides access to application wide settings.


Application Class
See Also Members
CollapseAll image DropDown image

The Application Options object provides access to application wide settings.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("09B3A3D8-BBA0-4ec8-B8F1-A2EC53C69C51")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Application : APIObject
Visual Basic (Declaration)
<GuidAttribute("09B3A3D8-BBA0-4ec8-B8F1-A2EC53C69C51")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Application _
    Inherits APIObject
Visual C++
[GuidAttribute(L"09B3A3D8-BBA0-4ec8-B8F1-A2EC53C69C51")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Application : public APIObject

Remarks

This object provides access to variables that are located in the Settings dialog within Autodesk Revit.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Options..::Application

See Also

Application Members
Autodesk.Revit.Options Namespace


Application Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ApplicationApplicationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LibraryPaths | Retrieves path information for where content is stored on disk.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.

See Also

Application
Autodesk.Revit.Options Namespace


Application Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Application ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Application Class
Autodesk.Revit.Options Namespace


Application Properties
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LibraryPaths | Retrieves path information for where content is stored on disk.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.

See Also

Application
Autodesk.Revit.Options Namespace


LibraryPaths Property

Application..::LibraryPaths Property
CollapseAll image DropDown image

Retrieves path information for where content is stored on disk.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringStringMap LibraryPaths{ get; set;}
Visual Basic (Declaration)
Public Property LibraryPaths As StringStringMap
Visual C++
public:
property StringStringMap^ LibraryPaths {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

This property is used to control where Autodesk Revit searches for content. The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

See Also

Application Class
Autodesk.Revit.Options Namespace


SharedParametersFilename Property

Application..::SharedParametersFilename Property
CollapseAll image DropDown image

Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string SharedParametersFilename{ get; set;}
Visual Basic (Declaration)
Public Property SharedParametersFilename As String
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

Application Class
Autodesk.Revit.Options Namespace


Autodesk.Revit.Parameters Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Parameters
Visual Basic (Declaration)
Namespace Autodesk.Revit.Parameters
Visual C++
namespace Autodesk.Revit.Parameters

Classes

 | Class | Description
Public class | Binding | Binding objects are used to take a parameter definition and bind it to one or more categories.
Public class | BindingMap | The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Public class | Definition | The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Public class | DefinitionFile | The DefinitionFile object represents a shared parameters file on disk.
Public class | DefinitionGroup | The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Public class | DefinitionGroups | A specialised set of definition groups that allows creation of new groups.
Public class | DefinitionGroupsBase | A set that contains definition groups.
Public class | DefinitionGroupsBaseIterator | An iterator to a definition group set.
Public class | Definitions | A base class that supports the addition of new parameter definitions.
Public class | DefinitionsBase | A set that contains definitions.
Public class | DefinitionsBaseIterator | An iterator to a definition set.
Public class | ElementBinding | A base class for all types of binding that attach to an element.
Public class | ExternalDefinition | The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Public class | ExternalDefinitions | Supports the creation of new shared parameters definitions.
Public class | InstanceBinding | The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Public class | InternalDefinition | This object represent a parameter definition built into Autodesk Revit.
Public class | InternalDefinitions | This object blocks attempts to create new internal definitions as they are not permitted.
Public class | ParameterListItem | Object representing list item of external list parameter.
Public class | ParameterListItemArray | An array that can contain any type of object.
Public class | ParameterListItemArrayIterator | An iterator to a array.
Public class | TypeBinding | TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Enumerations

 | Enumeration | Description
Public enumeration | BuildingType | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | BuiltInParameter | An enumerate type listing all of the built-in parameter ids supported by Autodesk Revit.
Public enumeration | BuiltInParameterGroup | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | ConstructionType | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | ParameterType | An enumerate type listing all of the data type interpretation that Autodesk Revit supports.
Public enumeration | ServiceType | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | StorageType | An enumerate type listing all of the internal parameter data storage types that Autodesk Revit supports.


Binding Class
See Also Members
CollapseAll image DropDown image

Binding objects are used to take a parameter definition and bind it to one or more categories.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6EE2D12A-CF9F-46b4-8124-028D858A2242")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class Binding : APIObject
Visual Basic (Declaration)
<GuidAttribute("6EE2D12A-CF9F-46b4-8124-028D858A2242")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class Binding _
    Inherits APIObject
Visual C++
[GuidAttribute(L"6EE2D12A-CF9F-46b4-8124-028D858A2242")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Binding abstract : public APIObject

Remarks

This class is a base class for all types of parameter binding within Autodesk Revit. Once the binging objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not effect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding

See Also

Binding Members
Autodesk.Revit.Parameters Namespace


Binding Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class Binding
Visual Basic (Declaration)
Public MustInherit Class Binding
Visual C++
public ref class Binding abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BindingBindingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding
Autodesk.Revit.Parameters Namespace


Binding Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Binding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Binding ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Binding Class
Autodesk.Revit.Parameters Namespace


BindingMap Class
See Also Members
CollapseAll image DropDown image

The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("893800BA-2A48-4cce-86E5-A5C795B3628E")]
public class BindingMap : DefinitionBindingMap
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("893800BA-2A48-4cce-86E5-A5C795B3628E")> _
Public Class BindingMap _
    Inherits DefinitionBindingMap
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"893800BA-2A48-4cce-86E5-A5C795B3628E")]
public ref class BindingMap : public DefinitionBindingMap

Remarks

The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::DefinitionBindingMap
Autodesk.Revit.Parameters..::BindingMap

See Also

BindingMap Members
Autodesk.Revit.Parameters Namespace


BindingMap Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BindingMap
Visual Basic (Declaration)
Public Class BindingMap
Visual C++
public ref class BindingMap

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BindingMapBindingMapNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap ..:: Clear()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap ..:: Contains(Definition).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap ..:: Erase(Definition).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Overloaded.
Public method | ReInsert | Overloaded.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionBindingMap ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionBindingMap.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap ..:: Item[([Definition])].)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap
Autodesk.Revit.Parameters Namespace


BindingMap Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BindingMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BindingMap ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


BindingMap Methods
CollapseAll image DropDown image

Syntax

C#
public class BindingMap
Visual Basic (Declaration)
Public Class BindingMap
Visual C++
public ref class BindingMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap ..:: Clear()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap ..:: Contains(Definition).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap ..:: Erase(Definition).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Overloaded.
Public method | ReInsert | Overloaded.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionBindingMap ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionBindingMap.)

See Also

BindingMap
Autodesk.Revit.Parameters Namespace


Clear Method

BindingMap..::Clear Method
CollapseAll image DropDown image

This method is used to remove all the items in the map.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear () override

Remarks

The method Clear inherited from base class is not permitted for this class. A NotSupportedException will be thrown.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Contains Method

BindingMap..::Contains Method
CollapseAll image DropDown image

The Contains method is used to check if the parameter binding exists for one definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override bool Contains(
    Definition key
)
Visual Basic (Declaration)
Public Overrides Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Definition^ key
) override

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Dispose Method

BindingMap..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Erase Method

BindingMap..::Erase Method
CollapseAll image DropDown image

This method is used to erase one item in the map.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override int Erase(
    Definition key
)
Visual Basic (Declaration)
Public Overrides Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase (
    Definition^ key
) override

Parameters

key
Definition

Remarks

The method Erase inherited from base class is not permitted for this class. A NotSupportedException will be thrown. Use Remove() instead to remove the binding from the Revit session and from the map.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Insert Method

BindingMap..::Insert Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Insert(Definition, Binding) | The Insert method is used to create a new parameter binding. (Overrides DefinitionBindingMap ..:: Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | The Insert method is used to create a new parameter binding.

See Also

BindingMap Class
BindingMap Members
Autodesk.Revit.Parameters Namespace


Insert Method (Definition, Binding)

BindingMap..::Insert Method (Definition, Binding)
See Also
CollapseAll image DropDown image

The Insert method is used to create a new parameter binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overrides Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Definition^ key,
    Binding^ item
) override

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, post an error and return false.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Insert Method (Definition, Binding, BuiltInParameterGroup)

BindingMap..::Insert Method (Definition, Binding, BuiltInParameterGroup)
See Also
CollapseAll image DropDown image

The Insert method is used to create a new parameter binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the Parameter binding already exists, post an error and return false

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


ReInsert Method

BindingMap..::ReInsert Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ReInsert(Definition, Binding) | The Insert method is used to create a new parameter binding.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | The Insert method is used to create a new parameter binding.

See Also

BindingMap Class
BindingMap Members
Autodesk.Revit.Parameters Namespace


ReInsert Method (Definition, Binding)

BindingMap..::ReInsert Method (Definition, Binding)
See Also
CollapseAll image DropDown image

The Insert method is used to create a new parameter binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool ReInsert (
    Definition^ key,
    Binding^ item
)

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


ReInsert Method (Definition, Binding, BuiltInParameterGroup)

BindingMap..::ReInsert Method (Definition, Binding, BuiltInParameterGroup)
See Also
CollapseAll image DropDown image

The Insert method is used to create a new parameter binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic (Declaration)
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool ReInsert (
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Remove Method

BindingMap..::Remove Method
CollapseAll image DropDown image

The Remove method is used to remove a parameter binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Remove(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Remove ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Remove (
    Definition^ key
)

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


BindingMap Properties
CollapseAll image DropDown image

Syntax

C#
public class BindingMap
Visual Basic (Declaration)
Public Class BindingMap
Visual C++
public ref class BindingMap

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap ..:: Item[([Definition])].)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap
Autodesk.Revit.Parameters Namespace


Item Property

BindingMap..::Item Property
CollapseAll image DropDown image

The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Binding Item[
    Definition key
]{ get; set;}
Visual Basic (Declaration)
Public Overrides Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Field Value

The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

set_Item is not permitted for this class. A NotSupportedException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


BuildingType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("917B2B7A-2A38-48ab-AE5E-037C01CA5891")]
public enum BuildingType
Visual Basic (Declaration)
<GuidAttribute("917B2B7A-2A38-48ab-AE5E-037C01CA5891")> _
Public Enumeration BuildingType
Visual C++
[GuidAttribute(L"917B2B7A-2A38-48ab-AE5E-037C01CA5891")]
public enum class BuildingType

Members

Member name | Description
kWorkshop | Building Type is Workshop.
kWarehouse | Building Type is Warehouse.
kTransportation | Building Type is Transportation.
kTownHall | Building Type is TownHall.
kSportsArena | Building Type is SportsArena.
kSchoolOrUniversity | Building Type is SchoolOrUniversity.
kRetail | Building Type is Retail.
kReligiousBuilding | Building Type is ReligiousBuilding.
kPostOffice | Building Type is PostOffice.
kPoliceStation | Building Type is PoliceStation.
kPerformingArtsTheater | Building Type is PerformingArtsTheater.
kPenitentiary | Building Type is Penitentiary.
kParkingGarage | Building Type is ParkingGarage.
kOffice | Building Type is Office.
kMuseum | Building Type is Museum.
kMultiFamily | Building Type is MultiFamily.
kMotionPictureTheatre | Building Type is MotionPictureTheatre.
kMotel | Building Type is Motel.
kManufacturing | Building Type is Manufacturing.
kLibrary | Building Type is Library.
kHotel | Building Type is Hotel.
kHospitalOrHealthcare | Building Type is HospitalOrHealthcare.
kGymnasium | Building Type is Gymnasium.
kFireStation | Building Type is FireStation.
kExerciseCenter | Building Type is ExerciseCenter.
kDormitory | Building Type is Dormitory.
kDiningFamily | Building Type is DiningFamily.
kDiningCafeteriaFastFood | Building Type is DiningCafeteriaFastFood.
kDiningBarLoungeOrLeisure | Building Type is DiningBarLoungeOrLeisure.
kCourthouse | Building Type is Courthouse.
kConventionCenter | Building Type is ConventionCenter.
kAutomotiveFacility | Building Type is AutomotiveFacility.
kNoOfBuildingTypes | Building Type is NoOfBuildingTypes.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also

Autodesk.Revit.Parameters Namespace


BuiltInParameter Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the built-in parameter ids supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("955DE662-CE14-4781-8E33-835B7F533AE2")]
public enum BuiltInParameter
Visual Basic (Declaration)
<GuidAttribute("955DE662-CE14-4781-8E33-835B7F533AE2")> _
Public Enumeration BuiltInParameter
Visual C++
[GuidAttribute(L"955DE662-CE14-4781-8E33-835B7F533AE2")]
public enum class BuiltInParameter

Members

Member name | Description
RBS_ELEC_CIRCUIT_WIRE_NUM_HOTS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_NEUTRALS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_GROUNDS_PARAM |
RBS_ELEC_WIRE_TYPE |
RBS_ELEC_WIRE_ELEVATION |
RBS_ELEC_WIRE_SHOW_TICKMARKS |
RBS_ELEC_WIRE_HOT_ADJUSTMENT |
RBS_ELEC_WIRE_NEUTRAL_ADJUSTMENT |
RBS_ELEC_WIRE_GROUND_ADJUSTMENT |
RBS_ELEC_WIRE_SHARE_NEUTRAL |
RBS_ELEC_WIRE_SHARE_GROUND |
RBS_ELEC_CIRCUIT_NAME |
RBS_FAMILY_CONTENT_SECONDARY_DISTRIBSYS |
RBS_ELEC_CIRCUIT_NAMING |
RBS_ELEC_CIRCUIT_PREFIX_SEPARATOR |
RBS_ELEC_CIRCUIT_PREFIX |
RBS_ELEC_MODIFICATIONS |
RBS_ELEC_ENCLOSURE |
RBS_ELEC_MAINS |
RBS_ELEC_MOUNTING |
RBS_ELEC_SHORT_CIRCUIT_RATING |
RBS_ELEC_MAX_POLE_BREAKERS |
RBS_ELEC_PANEL_NAME |
RBS_ELEC_PANEL_TOTALESTLOAD_HVAC_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_HVAC_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_LIGHT_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_LIGHT_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_POWER_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_POWER_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_OTHER_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_OTHER_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_PARAM |
RBS_ELEC_DEMANDFACTOR_LOADCLASSIFICATION_PARAM |
RBS_ELEC_DEMANDFACTOR_LOAD_PARAM |
RBS_ELEC_DEMANDFACTOR_DEMANDLOAD_PARAM |
RBS_FAMILY_CONTENT_DISTRIBUTION_SYSTEM |
RBS_DISTRIBUTIONSYS_VLL_PARAM |
RBS_DISTRIBUTIONSYS_VLG_PARAM |
RBS_DISTRIBUTIONSYS_PHASE_PARAM |
RBS_DISTRIBUTIONSYS_CONFIG_PARAM |
RBS_DISTRIBUTIONSYS_NUMWIRES_PARAM |
RBS_VOLTAGETYPE_VOLTAGE_PARAM |
RBS_VOLTAGETYPE_MINVOLTAGE_PARAM |
RBS_VOLTAGETYPE_MAXVOLTAGE_PARAM |
RBS_ELEC_APPARENT_LOAD_PHASEC |
RBS_ELEC_APPARENT_LOAD_PHASEB |
RBS_ELEC_APPARENT_LOAD_PHASEA |
RBS_ELEC_TRUE_LOAD_PHASEC |
RBS_ELEC_TRUE_LOAD_PHASEB |
RBS_ELEC_TRUE_LOAD_PHASEA |
RBS_ELEC_TRUE_CURRENT_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEA_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEB_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEC_PARAM |
RBS_ELEC_APPARENT_CURRENT_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM |
RBS_ELEC_VOLTAGE_DROP_PARAM |
RBS_ELEC_CALC_COEFFICIENT_UTILIZATION |
RBS_ELEC_CIRCUIT_LENGTH_PARAM |
RBS_ELEC_CIRCUIT_RATING_PARAM |
RBS_ELEC_CIRCUIT_WIRE_SIZE_PARAM |
RBS_ELEC_CIRCUIT_WIRE_TYPE_PARAM |
RBS_ELEC_ROOM_CAVITY_RATIO |
RBS_ELEC_ROOM_AVERAGE_ILLUMINATION |
RBS_ELEC_ROOM_REFLECTIVITY_FLOOR |
RBS_ELEC_ROOM_REFLECTIVITY_WALLS |
RBS_ELEC_ROOM_REFLECTIVITY_CEILING |
RBS_ELEC_ROOM_LIGHTING_CALC_WORKPLANE |
RBS_WIRE_MATERIAL_PARAM |
RBS_WIRE_TEMPERATURE_RATING_PARAM |
RBS_WIRE_INSULATION_PARAM |
RBS_WIRE_MAX_CONDUCTOR_SIZE_PARAM |
RBS_WIRE_NEUTRAL_MULTIPLIER_PARAM |
RBS_WIRE_NEUTRAL_INCLUDED_IN_BALANCED_LOAD_PARAM |
RBS_WIRE_NEUTRAL_MODE_PARAM |
RBS_WIRE_CONDUIT_TYPE_PARAM |
RBS_ELEC_AMBIENT_TEMPERATURE |
RBS_EDIT_CIRCUITS_PARAM |
RBS_ELEC_CIRCUIT_TYPE |
RBS_ELEC_SERVICE |
RBS_ELEC_PANEL |
RBS_ELEC_CIRCUIT |
RBS_ELEC_LOAD_CLASSIFICATION |
RBS_ELEC_TRUE_LOAD_PHASE3 |
RBS_ELEC_TRUE_LOAD_PHASE2 |
RBS_ELEC_TRUE_LOAD_PHASE1 |
RBS_ELEC_TRUE_LOAD |
RBS_ELEC_POWER_FACTOR_STATE |
RBS_ELEC_POWER_FACTOR |
RBS_ELEC_APPARENT_LOAD_PHASE3 |
RBS_ELEC_APPARENT_LOAD_PHASE2 |
RBS_ELEC_APPARENT_LOAD_PHASE1 |
RBS_ELEC_APPARENT_LOAD |
RBS_ELEC_BALANCED_LOAD |
RBS_ELEC_VOLTAGE |
RBS_ELEC_NUMBER_OF_POLES |
RBS_CONNECTOR_DESCRIPTION |
MARKUPS_PRIVATE |
MARKUPS_NOTES |
MARKUPS_HISTORY |
MARKUPS_STATUS |
MARKUPS_LABEL |
MARKUPS_CREATOR |
MARKUPS_CREATED |
MARKUPS_MODIFIED |
LEGEND_COMPONENT_DETAIL_LEVEL |
LEGEND_COMPONENT_LENGTH |
LEGEND_COMPONENT_VIEW |
LEGEND_COMPONENT |
OPTION_SET_ID |
OPTION_NAME |
PRIMARY_OPTION_ID |
OPTION_SET_NAME |
GROUP_ATTACHED_PARENT_NAME |
GROUP_ALLOWED_VIEW_TYPES |
GROUP_OFFSET_FROM_LEVEL |
GROUP_LEVEL |
RBS_CONNECTOR_ISPRIMARY |
CONNECTOR_REFERENCE_INDEX |
RBS_PIPE_SYSTEM_TYPE |
CONNECTOR_ANGLE |
RBS_DUCT_SYSTEM_TYPE |
CONNECTOR_IS_EDGELOOP_CENTERED_OBSOLETE |
CONNECTOR_INDEX |
CONNECTOR_VISIBLE_SIZE |
CONNECTOR_HEIGHT |
CONNECTOR_WIDTH |
CONNECTOR_SIZE |
CONNECTOR_RADIUS |
CONNECTOR_PROFILE_TYPE |
ZONE_CALCULATED_AREA_PER_COOLING_LOAD_PARAM |
ZONE_CALCULATED_AREA_PER_HEATING_LOAD_PARAM |
ZONE_USE_AIR_CHANGES_PER_HOUR_PARAM |
ZONE_USE_OUTSIDE_AIR_PER_AREA_PARAM |
ZONE_USE_OUTSIDE_AIR_PER_PERSON_PARAM |
ZONE_USE_DEHUMIDIFICATION_SETPOINT_PARAM |
ZONE_USE_HUMIDIFICATION_SETPOINT_PARAM |
ZONE_OUTDOOR_AIR_INFORMATION_PARAM |
ZONE_COOLING_INFORMATION_PARAM |
ZONE_HEATING_INFORMATION_PARAM |
RBS_ENERGY_ANALYSIS_SLIVER_SPACE_TOLERANCE |
ZONE_AREA_GROSS |
ZONE_VOLUME_GROSS |
SPACE_IS_PLENUM |
SPACE_IS_OCCUPIABLE |
SPACE_ASSOC_ROOM_NUMBER |
SPACE_ASSOC_ROOM_NAME |
ZONE_PHASE |
ZONE_PHASE_ID |
RBS_ENERGY_ANALYSIS_PROJECT_PHASE_PARAM |
ROOM_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM |
ROOM_CALCULATED_COOLING_LOAD_PER_AREA_PARAM |
ROOM_CALCULATED_HEATING_LOAD_PER_AREA_PARAM |
ZONE_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM |
ZONE_CALCULATED_COOLING_LOAD_PER_AREA_PARAM |
ZONE_CALCULATED_HEATING_LOAD_PER_AREA_PARAM |
ZONE_LEVEL_ID |
ZONE_OA_RATE_PER_ACH_PARAM |
ZONE_OUTSIDE_AIR_PER_AREA_PARAM |
ZONE_OUTSIDE_AIR_PER_PERSON_PARAM |
ZONE_DEHUMIDIFICATION_SET_POINT_PARAM |
LOAD_COMBINATION_TYPE |
LOAD_COMBINATION_FACTOR |
LOAD_COMBINATION_NAME |
LOAD_NATURE_NAME |
LOAD_CASE_CATEGORY |
LOAD_CASE_NATURE |
LOAD_CASE_NUMBER |
LOAD_CASE_NAME |
LOAD_ATTR_AREA_FORCE_SCALE_FACTOR |
LOAD_ATTR_LINEAR_FORCE_SCALE_FACTOR |
LOAD_ARROW_SEPARATION |
LOAD_ATTR_MOMENT_SCALE_FACTOR |
LOAD_ATTR_MOMENT_ARROW_LINE |
LOAD_ATTR_MOMENT_ARROW_ARC |
LOAD_ATTR_FORCE_SCALE_FACTOR |
LOAD_ATTR_FORCE_ARROW_TYPE |
LOAD_DESCRIPTION |
LOAD_COMMENTS |
LOAD_CASE_NATURE_TEXT |
LOAD_COMMENT_TEXT |
LOAD_ALL_NON_0_LOADS |
LOAD_AREA_AREA |
LOAD_AREA_FORCE_FZ3 |
LOAD_AREA_FORCE_FY3 |
LOAD_AREA_FORCE_FX3 |
LOAD_AREA_FORCE_FZ2 |
LOAD_AREA_FORCE_FY2 |
LOAD_AREA_FORCE_FX2 |
LOAD_AREA_FORCE_FZ1 |
LOAD_AREA_FORCE_FY1 |
LOAD_AREA_FORCE_FX1 |
LOAD_LINEAR_LENGTH |
LOAD_IS_PROJECTED |
LOAD_MOMENT_MZ2 |
LOAD_MOMENT_MY2 |
LOAD_MOMENT_MX2 |
LOAD_MOMENT_MZ1 |
LOAD_MOMENT_MY1 |
LOAD_MOMENT_MX1 |
LOAD_LINEAR_FORCE_FZ2 |
LOAD_LINEAR_FORCE_FY2 |
LOAD_LINEAR_FORCE_FX2 |
LOAD_LINEAR_FORCE_FZ1 |
LOAD_LINEAR_FORCE_FY1 |
LOAD_LINEAR_FORCE_FX1 |
LOAD_MOMENT_MZ |
LOAD_MOMENT_MY |
LOAD_MOMENT_MX |
LOAD_FORCE_FZ |
LOAD_FORCE_FY |
LOAD_FORCE_FX |
LOAD_IS_REACTION |
LOAD_IS_CREATED_BY_API |
LOAD_IS_UNIFORM |
LOAD_USE_LOCAL_COORDINATE_SYSTEM_HOSTED |
LOAD_USE_LOCAL_COORDINATE_SYSTEM |
LOAD_CASE_ID |
SPAN_DIR_SYM_PARAM_RIGHT |
SPAN_DIR_SYM_PARAM_LEFT |
SPAN_DIR_SYM_PARAM_BOTTOM |
SPAN_DIR_SYM_PARAM_TOP |
SPAN_DIR_INST_PARAM_ANGLE |
CLEAR_COVER |
CLEAR_COVER_BOTTOM |
CLEAR_COVER_TOP |
CLEAR_COVER_OTHER |
CLEAR_COVER_INTERIOR |
CLEAR_COVER_EXTERIOR |
COVER_TYPE_LENGTH |
COVER_TYPE_NAME |
JOIST_SYSTEM_CLEAR_SPACING_PARAM |
JOIST_SYSTEM_FIXED_SPACING_PARAM |
JOIST_SYSTEM_MAXIMUM_SPACING_PARAM |
CURVE_EDGE_OFFSET |
TRUSS_TYPE_EDIT |
BEAM_SYSTEM_3D_PARAM |
TRUSS_BEAM_TYPE_FOR_TRAN_PAR |
TRUSS_BEAM_TYPE_FOR_DIAG_PAR |
TRUSS_BEAM_TYPE_FOR_VERT_PAR |
TRUSS_BEAM_TYPE_FOR_BOT_CHORD_PAR |
TRUSS_BEAM_TYPE_FOR_TOP_CHORD_PAR |
TRUSS_BEAM_TYPE_FOR_CHORDS_PAR |
TRUSS_HEIGHT_PARAM |
JOIST_SYSTEM_NEW_BEAM_TYPE_NO_FAM_NAME_PARAM |
BEAM_SYSTEM_TAG_INST_PARAM_ANGLE |
BEAM_SYSTEM_TAG_PARAM_RIGHT |
BEAM_SYSTEM_TAG_PARAM_LEFT |
JOIST_SYSTEM_NUM_BEAMS_SAME_TYPE |
BEAM_H_JUSTIFICATION |
BEAM_V_JUSTIFICATION |
CURVE_SUPPORT_OFFSET |
JOIST_SYSTEM_NEW_BEAM_TYPE_PARAM |
JOIST_SYSTEM_LAYOUT_RULE_PARAM |
JOIST_SYSTEM_JUSTIFICATION_PARAM |
JOIST_SYSTEM_SPACING_PARAM |
JOIST_SYSTEM_NUMBER_OF_LINES_PARAM |
RBS_DUCT_FLOW_PARAM |
CURTAIN_VERSION_PARAM |
PADDING_LENGTH |
ELEM_ARRAY_ROLL |
ELEM_ARRAY_PITCH |
ELEM_ARRAY_ROTATION |
ELEM_ARRAY_Z_OFFSET |
ELEM_ARRAY_Y_OFFSET |
ELEM_ARRAY_X_OFFSET |
ELEM_ARRAY_ROLL_PROG |
ELEM_ARRAY_PITCH_PROG |
ELEM_ARRAY_ROTATION_PROG |
ELEM_ARRAY_ALWAYS_VERTICAL |
ELEM_ARRAY_ANCHORS_VISIBLE |
CURTAINGRID_USE_CURVE_DIST |
SPACING_JUSTIFICATION |
SPACING_NUM_DIVISIONS |
SPACING_LENGTH |
SPACING_LAYOUT |
CURTAINGRID_USE_CURVE_DIST_2 |
CURTAINGRID_USE_CURVE_DIST_1 |
CURTAINGRID_ADJUST_BORDER_2 |
CURTAINGRID_ADJUST_BORDER_1 |
CURTAINGRID_BELT_2 |
CURTAINGRID_BELT_1 |
CURTAINGRID_ORIGIN_2 |
CURTAINGRID_ORIGIN_1 |
CURTAINGRID_ANGLE_2 |
CURTAINGRID_ANGLE_1 |
SPACING_NUM_DIVISIONS_2 |
SPACING_NUM_DIVISIONS_1 |
SPACING_JUSTIFICATION_2 |
SPACING_JUSTIFICATION_1 |
SPACING_LENGTH_2 |
SPACING_LENGTH_1 |
SPACING_LAYOUT_2 |
SPACING_LAYOUT_1 |
CURTAINGRID_USE_CURVE_DIST_HORIZ |
CURTAINGRID_USE_CURVE_DIST_VERT |
CURTAINGRID_ADJUST_BORDER_HORIZ |
CURTAINGRID_ADJUST_BORDER_VERT |
CURTAINGRID_BELT_HORIZ |
CURTAINGRID_BELT_VERT |
CURTAINGRID_ORIGIN_HORIZ |
CURTAINGRID_ORIGIN_VERT |
CURTAINGRID_ANGLE_HORIZ |
CURTAINGRID_ANGLE_VERT |
GRIDLINE_SPEC_STATUS |
SPACING_NUM_DIVISIONS_HORIZ |
SPACING_NUM_DIVISIONS_VERT |
SPACING_JUSTIFICATION_HORIZ |
SPACING_JUSTIFICATION_VERT |
SPACING_LENGTH_HORIZ |
SPACING_LENGTH_VERT |
SPACING_LAYOUT_HORIZ |
SPACING_LAYOUT_VERT |
SCHEDULE_VISIBLE_DESIGN_OPTION_PARAM |
DESIGN_OPTION_ID |
DESIGN_OPTION_PARAM |
PLAN_REGION_VIEW_RANGE |
PLAN_REGION_TOP_CLIP_PLANE_OFFSET |
PLAN_REGION_BOTTOM_CLIP_PLANE_OFFSET |
PLAN_REGION_CUT_PLANE_OFFSET |
SKETCH_GRID_SPACING_PARAM |
HOSTFIN_PARAM_VOLUME_COMPUTED |
HOSTFIN_PARAM_AREA_COMPUTED |
HOSTFIN_PARAM_MATERIAL |
HOSTFIN_PARAM_THICKNESS |
HOSTFIN_PARAM_OFFSET |
JOIN_STRENGTH_ORDER |
FAMILY_USE_PRECUT_SHAPE |
WALL_SWEEP_DEFAULT_SETBACK_PARAM |
WALL_SWEEP_CUTS_WALL_PARAM |
WALL_SWEEP_CUT_BY_INSERTS_PARAM |
SLAB_EDGE_PROFILE_PARAM |
GUTTER_PROFILE_PARAM |
REVEAL_PROFILE_PARAM |
FAMILY_SHARED |
FAMILY_WORK_PLANE_BASED |
FAMILY_AUTOJOIN |
FAMILY_IS_PARAMETRIC |
FAMILY_KEEP_TEXT_READABLE |
WALL_BOTTOM_EXTENSION_DIST_PARAM |
WALL_TOP_EXTENSION_DIST_PARAM |
SWEEP_BASE_VERT_OFFSET |
SWEEP_BASE_ROTATION_ANGLE |
SWEEP_BASE_OFFSET |
SLAB_EDGE_MATERIAL_PARAM |
GUTTER_MATERIAL_PARAM |
FASCIA_MATERIAL_PARAM |
SWEEP_BASE_FLOOR_SUBCATEGORY_ID |
SWEEP_BASE_ROOF_SUBCATEGORY_ID |
FASCIA_PROFILE_PARAM |
DECAL_SUBCATEGORY_ID |
DECAL_HEIGHT_PIXELS |
DECAL_WIDTH_PIXELS |
DECAL_HEIGHT |
DECAL_WIDTH |
DECAL_LOCK_PROPORTIONS |
DECAL_ATTRIBUTES |
FAMILY_KEY_EXT_PARAM |
WALL_SWEEP_WALL_SUBCATEGORY_ID |
FAMILY_ALWAYS_VERTICAL |
FAMILY_ROTATE_WITH_COMPONENT |
HOST_VOLUME_COMPUTED |
HOST_AREA_COMPUTED |
WALL_SWEEP_WALL_OFFSET_PARAM |
CORNICE_MATERIAL_PARAM |
WALL_SWEEP_OFFSET_PARAM |
WALL_SWEEP_LEVEL_PARAM |
WALL_SWEEP_PROFILE_PARAM |
AREA_SCHEME_NAME |
AREA_SCHEME_ID |
AREA_TYPE_TEXT |
AREA_TYPE_NAME |
AREA_TYPE |
VIEW_AREA_SCHEME |
CONTOUR_LABELS_RELATIVE_BASE |
CONTOUR_LABELS_ELEV_BASE_TYPE |
PROPERTY_SEGMENT_SUBCATEGORY_ID |
PROPERTY_SEGMENT_L_R |
PROPERTY_SEGMENT_RADIUS |
PROPERTY_SEGMENT_E_W |
PROPERTY_SEGMENT_BEARING |
PROPERTY_SEGMENT_N_S |
PROPERTY_SEGMENT_DISTANCE |
PROPERTY_LENGTH_UNITS |
PROPERTY_AREA_UNITS |
VOLUME_NET |
PROJECTED_SURFACE_AREA |
CONTOUR_LABELS_LINEAR_UNITS |
CONTOUR_LABELS_PRIMARY_ONLY |
PROPERTY_SUBCATEGORY_ID |
PROPERTY_AREA_OPEN |
POCHE_DEPTH |
VOLUME_FILL |
VOLUME_CUT |
SURFACE_PERIMETER |
SURFACE_AREA |
PROPERTY_AREA |
BUILDINGPAD_HEIGHTABOVELEVEL_PARAM |
BUILDINGPAD_THICKNESS |
BOUNDARY_RADIUS |
BOUNDARY_INC_ANGLE |
CONTOUR_SUBCATEGORY_ID |
BOUNDARY_BEARING |
BOUNDARY_DISTANCE |
CONTOUR_ELEVATION_STEP |
CONTOUR_ELEVATION |
POINT_ELEVATION |
VOLUME_OF_INTEREST_NAME |
VIEWER_VOLUME_OF_INTEREST_3D |
VOLUME_OF_INTEREST_VIEWS_VISIBLE |
VIEWER_VOLUME_OF_INTEREST_CROP |
DATUM_VOLUME_OF_INTEREST |
ORIENT_BY_VIEW |
ROOM_PHASE |
ROOM_PHASE_ID |
PHASE_SEQUENCE_NUMBER |
PHASE_NAME |
VIEW_FAMILY |
ROOM_PHASE_NAME |
PRINT_SET |
VIEW_TYPE |
PHASE_DEMOLISHED_NAME |
PHASE_CREATED_NAME |
VIEW_PHASE_FILTER |
VIEW_PHASE |
PHASE_DEMOLISHED |
PHASE_CREATED |
LEVEL_DATA_MASS_TYPE_DESCRIPTION |
LEVEL_DATA_MASS_INSTANCE_COMMENTS |
LEVEL_DATA_MASS_TYPE_COMMENTS |
LEVEL_DATA_MASS_FAMILY_AND_TYPE_PARAM |
LEVEL_DATA_MASS_FAMILY_PARAM |
LEVEL_DATA_SPACE_USAGE |
LEVEL_DATA_OWNING_LEVEL |
LEVEL_DATA_MASS_TYPE_PARAM |
LEVEL_DATA_VOLUME |
LEVEL_DATA_SURFACE_AREA |
LEVEL_DATA_FLOOR_AREA |
LEVEL_DATA_FLOOR_PERIMETER |
MASS_FUNCTION |
MASS_GROSS_VOLUME |
MASS_GROSS_SURFACE_AREA |
MASS_FLOOR_AREA_LEVELS |
MASS_GROSS_AREA |
MASSING_DEFAULT_ROOF_TYPE |
MASSING_DEFAULT_WALL_TYPE |
MASSING_DEFAULT_FLOOR_TYPE |
MASSING_INTEGRATION_LEVEL |
PROJECT_REVISION_REVISION_ISSUED_BY |
PROJECT_REVISION_REVISION_ISSUED_TO |
PROJECT_REVISION_REVISION_DATE |
PROJECT_REVISION_REVISION_DESCRIPTION |
PROJECT_REVISION_REVISION_NUM |
PROJECT_REVISION_SEQUENCE_NUM |
REVISION_CLOUD_REVISION_ISSUED_BY |
REVISIONS_ARE_BY_SHEET |
REVISION_CLOUD_REVISION_ISSUED_TO |
REVISION_CLOUD_REVISION_DATE |
REVISION_CLOUD_REVISION_DESCRIPTION |
REVISION_CLOUD_REVISION_NUM |
REVISION_CLOUD_REVISION |
HELIX_PITCH |
HELIX_LENGTH |
CURVE_PATTERN_CLOUD |
REPEATING_DETAIL_ROTATION |
CURVE_PATTERN_REPEATING_DETAIL |
REPEATING_DETAIL_INSIDE |
REPEATING_DETAIL_ELEMENT |
REPEATING_DETAIL_LAYOUT |
REPEATING_DETAIL_SPACING |
REPEATING_DETAIL_NUMBER |
CURVE_PATTERN_INSULATION |
INSULATION_SCALE |
INSULATION_WIDTH |
VIEW_DETAIL_LEVEL |
DETAIL_LEVEL_PULLDOWN_IMPERIAL |
DETAIL_LEVEL_PULLDOWN_METRIC |
TAG_SELECT_END |
TAG_SELECT_START |
FURNITURE_THICKNESS |
FURNITURE_WIDTH |
FURNITURE_HEIGHT |
PLUMBING_FIXTURES_VENT_CONNECTION |
PLUMBING_FIXTURES_WASTE_CONNECTION |
PLUMBING_FIXTURES_CW_CONNECTION |
PLUMBING_FIXTURES_HW_CONNECTION |
PLUMBING_FIXTURES_TRAP |
PLUMBING_FIXTURES_DRAIN |
PLUMBING_FIXTURES_SUPPLY_PIPE |
PLUMBING_FIXTURES_SUPPLY_FITTING |
LIGHTING_FIXTURE_LIGHT_EMITTER |
LIGHTING_FIXTURE_DIMMER |
LIGHTING_FIXTURE_ON |
LIGHTING_FIXTURE_LAMP |
LIGHTING_FIXTURE_WATTAGE |
ELECTICAL_EQUIP_VOLTAGE |
ELECTICAL_EQUIP_WATTAGE |
CURTAIN_WALL_PANEL_HOST_ID |
CURTAIN_WALL_SYSPANEL_OFFSET |
CURTAIN_WALL_SYSPANEL_THICKNESS |
CURTAIN_WALL_PANELS_CONSTRUCTION_TYPE |
CURTAIN_WALL_PANELS_FINISH |
CURTAIN_WALL_PANELS_WIDTH |
CURTAIN_WALL_PANELS_HEIGHT |
CASEWORK_HEIGHT |
CASEWORK_DEPTH |
CASEWORK_WIDTH |
CASEWORK_FINISH |
CASEWORK_CONSTRUCTION_TYPE |
ALL_MODEL_SYSTEM |
ALL_MODEL_FAMILY_NAME |
ALL_MODEL_MODEL |
ALL_MODEL_MANUFACTURER |
ALL_MODEL_COST |
ALL_MODEL_INSTANCE_COMMENTS |
ALL_MODEL_TYPE_COMMENTS |
ALL_MODEL_URL |
ALL_MODEL_DESCRIPTION |
ALL_MODEL_TYPE_NAME |
ALL_MODEL_TYPE_MARK |
ALL_MODEL_MARK |
GENERIC_THICKNESS |
GENERIC_HEIGHT |
GENERIC_DEPTH |
GENERIC_WIDTH |
GENERIC_FINISH |
GENERIC_CONSTRUCTION_TYPE |
ELEMENT_LOCKED_PARAM |
STAIRS_RAILING_BALUSTER_IS_POST |
STAIRS_RAILING_CONNECTION |
STAIRS_RAILING_ANGLED_CONNECTION |
STAIRS_RAILING_TANGENT_CONNECTION |
STAIRS_RAILING_HEIGHT_SHIFT_VAL |
STAIRS_RAILING_HEIGHT_SHIFT_TYPE |
STAIRS_RAILING_RAIL_NAME |
STAIRS_RAILING_BALUSTER_PLACEMENT |
STAIRS_RAILING_BALUSTER_SLOPE_ANGLE |
STAIRS_RAILING_BALUSTER_BOTTOM_ANGLE |
STAIRS_RAILING_BALUSTER_TOP_ANGLE |
STAIRS_RAILING_BALUSTER_HEIGHT |
STAIRS_RAILING_HEIGHT_OFFSET |
STAIRS_RAILING_BASE_LEVEL_PARAM |
STAIRS_RAILING_BALUSTER_OFFSET |
STAIRS_RAILING_BALUSTER_FAMILY |
STAIRS_RAILING_RAIL_OFFSET |
STAIRS_RAILING_RAIL_HEIGHT |
STAIRS_RAILING_RAIL_STRUCTURE |
STAIRS_RAILING_SHAPE |
STAIRS_RAILING_BALUSTER_TREAD_OFFSET |
STAIRS_RAILING_BALUSTER_LENGTH |
STAIRS_RAILING_BALUSTER_WIDTH |
STAIRS_RAILING_BALUSTERS_PER_TREAD |
STAIRS_RAILING_BALUSTER_SPACING |
STAIRS_RAILING_BALUSTER_SPACING_TYPE |
STAIRS_RAILING_BOTTOM_EXT |
STAIRS_RAILING_TOP_EXT |
STAIRS_RAILING_BALUSTER_SHAPE |
STAIRS_RAILING_THICKNESS |
STAIRS_RAILING_WIDTH |
STAIRS_RAILING_HEIGHT |
STAIRS_RAILING_BALUSTER_ATTACH_PT |
STAIRS_RAILING_NUM_BALUSTERS |
PARAMS_TITLE_LAST |
SWEPTBLEND_PARAMS_TITLE |
ELEM_ARRAY_PARAMS_TITLE |
AREA_LOAD_PARAMS_TITLE |
REBAR_PARAMS_TITLE |
HOSTFIN_PARAMS_TITLE |
BUILDINGPAD_PARAMS_TITLE |
STAIRS_RAILING_PARAMS_TITLE |
RAMP_PARAMS_TITLE |
RAILING_PARAMS_TITLE |
OPENING_PARAMS_TITLE |
REVOLUTION_PARAMS_TITLE |
BLEND_PARAMS_TITLE |
SWEEP_PARAMS_TITLE |
EXTRUSION_PARAMS_TITLE |
REGION_PARAMS_TITLE |
WALL_PARAMS_TITLE |
CEILING_PARAMS_TITLE |
FLOOR_PARAMS_TITLE |
ROOF_PARAMS_TITLE |
FBX_LIGHT_PHOTOMETRIC_FILE_CACHE |
FBX_LIGHT_PHOTOMETRICS_FAM |
FAMILY_CURVE_ATTACHMENT_PROPORTION |
FBX_LIGHT_SOURCE_LENGTH |
FBX_LIGHT_SOURCE_DIAMETER |
FBX_LIGHT_EMIT_CIRCLE_DIAMETER |
FBX_LIGHT_EMIT_RECTANGLE_LENGTH |
FBX_LIGHT_EMIT_RECTANGLE_WIDTH |
FBX_LIGHT_EMIT_LINE_LENGTH |
FBX_LIGHT_Z_ROTATION_OFFSET_OOPS |
FBX_LIGHT_Y_ROTATION_OFFSET_OOPS |
FBX_LIGHT_X_ROTATION_OFFSET_OOPS |
FBX_LIGHT_PHOTOMETRIC_FILE_OOPS |
FBX_LIGHT_PHOTOMETRIC_FILE |
FBX_LIGHT_SPOT_TILT_ANGLE_OOPS |
FBX_LIGHT_SPOT_FIELD_ANGLE_OOPS |
FBX_LIGHT_SPOT_BEAM_ANGLE_OOPS |
FBX_LIGHT_SPOT_TILT_ANGLE |
FBX_LIGHT_SPOT_FIELD_ANGLE |
FBX_LIGHT_SPOT_BEAM_ANGLE |
FBX_LIGHT_EMIT_SHAPE_VISIBLE |
FBX_LIGHT_DIMMING_LIGHT_COLOR |
FBX_LIGHT_TOTAL_LIGHT_LOSS_OOPS |
FBX_LIGHT_TOTAL_LIGHT_LOSS |
FBX_LIGHT_LUMENAIRE_DIRT |
FBX_LIGHT_LAMP_LUMEN_DEPR |
FBX_LIGHT_SURFACE_LOSS |
FBX_LIGHT_LAMP_TILT_LOSS |
FBX_LIGHT_BALLAST_LOSS_OOPS |
FBX_LIGHT_BALLAST_LOSS |
FBX_LIGHT_VOLTAGE_LOSS |
FBX_LIGHT_TEMPERATURE_LOSS |
FBX_LIGHT_LOSS_FACTOR_METOD |
FBX_LIGHT_LOSS_FACTOR_CTRL |
FBX_LIGHT_COLOR_FILTER |
FBX_LIGHT_INITIAL_COLOR_NAME |
FBX_LIGHT_INITIAL_COLOR_TEMPERATURE |
FBX_LIGHT_INITIAL_COLOR_CTRL |
FBX_LIGHT_AT_A_DISTANCE |
FBX_LIGHT_ILLUMINANCE |
FBX_LIGHT_LIMUNOUS_FLUX |
FBX_LIGHT_LIMUNOUS_INTENSITY |
FBX_LIGHT_EFFICACY |
FBX_LIGHT_WATTAGE |
FBX_LIGHT_INITIAL_INTENSITY_INPUT_METOD |
FBX_LIGHT_INITIAL_INTENSITY |
FBX_LIGHT_PHOTOMETRICS |
FBX_ASSET_TYPE |
MESH_ELEM_ALL_GRID_ROTATION |
MESH_ELEM_TILE_BORDER |
CURTAIN_MESH_SYSTEM_PANEL_FLIP |
CURTAIN_MESH_SYSTEM_PANEL_FAILURE |
CURTAIN_MESH_SYSTEM_PANEL_INCOMPLETE |
CURTAIN_MESH_SYSTEM_PANEL_PRIMARY |
MESH_ELEM_ALL_POINTS |
MESH_ELEM_PARQUET |
MESH_ELEM_PARQUET_FLIP |
MESH_ELEM_PARQUET_ROTATION_ANGLE |
MESH_ELEM_PARQUET_INDENT_2 |
MESH_ELEM_PARQUET_INDENT_1 |
MESH_ELEM_SPLIT_REF_PRECUT |
MESH_ELEM_OFFSET_FROM_SURFACE |
MESH_ELEM_TOTAL_EDGE_LENGTH |
MESH_ELEM_EDGE_NUMBER |
MESH_ELEM_POINT_NUMBER |
MESH_ELEM_FACET_NUMBER |
MESH_ELEM_SURFACE_AREA |
GB_RECYCLED_HOST_ASSEMBLY |
GB_RENEWABLE_ENERGY_SOURCE |
GB_RECYCLED_COMPONENT |
GB_FCS_CERTIFIED_WOOD |
GB_GREEN_SEAL_PAINT_STD |
GB_GREEN_LABEL_PLUS_STD |
GB_OUTGAS_FORMALDEHYDE |
GB_RAPIDLY_RENEWABLE_PLANT_MATERIAL |
GB_LINK_TO_COMPONENT_DOCUMENTATION |
GB_LINK_TO_MATERIAL_DOCUMENTATION |
GB_FIXTURE_FLOW_RATE |
GB_EQUIPMENT_REFRIGERANT_LIFESPAN |
GB_REFRIGERANT_LB_PER_COOLING_TON |
GB_MINIMUM_EFFICIENCY_REPORTING_VALUE |
GB_SOLAR_REFLECTIVE_INDEX |
GB_GLOBAL_WARMING_POTENTIAL |
GB_ATMOSPHERIC_LIFETIME |
GB_OZONE_DEPLETION_POTENTIAL |
GB_VISIBLE_LIGHT_TRANSMITTANCE |
GB_NEW_MATERIAL_COST |
GB_RECYCLED_MATERIAL_COST |
GB_R_VALUE |
GB_RECYCLED_MATERIAL_PERCENT |
GB_U_VALUE |
GB_SOURCE_DISTANCE |
GB_REFRIGERANT_USED |
GB_OPERATIONAL_RECYCLED_MATERIAL |
GB_WASTE_WATER_TYPE_GENERATED |
GB_BUILDING_OCCUPANCY |
GB_ANNUAL_RENEWABLE_ENERGY_PRODUCED |
GB_ANNUAL_RAINFALL |
GB_ANNUAL_ELECTICAL_CONSUMPTION |
LABEL_MULTI_PARAMETER |
JOIST_SYSTEM_ELEM_TAG_NEW_MEMBERS_VIEW |
REFERENCE_VIEWER_ATTR_TAG |
REFERENCE_VIEWER_TARGET_VIEW |
MATCHLINE_BOTTOM_PLANE |
MATCHLINE_TOP_PLANE |
MATCHLINE_BOTTOM_OFFSET |
MATCHLINE_TOP_OFFSET |
TRUSS_FAMILY_BOTTOM_CHORD_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_ANGLE_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_VERTICAL_PROJECTION_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_START_RELEASE_TYPE |
TRUSS_FAMILY_BOTTOM_CHORD_END_RELEASE_TYPE |
TRUSS_FAMILY_TOP_CHORD_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_TOP_CHORD_ANGLE_PARAM |
TRUSS_FAMILY_TOP_CHORD_VERTICAL_PROJECTION_PARAM |
TRUSS_FAMILY_TOP_CHORD_START_RELEASE_TYPE |
TRUSS_FAMILY_TOP_CHORD_END_RELEASE_TYPE |
TRUSS_FAMILY_DIAG_WEB_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_DIAG_WEB_ANGLE_PARAM |
TRUSS_FAMILY_DIAG_WEB_START_RELEASE_TYPE |
TRUSS_FAMILY_DIAG_WEB_END_RELEASE_TYPE |
TRUSS_FAMILY_VERT_WEB_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_VERT_WEB_ANGLE_PARAM |
TRUSS_FAMILY_VERT_WEB_START_RELEASE_TYPE |
TRUSS_FAMILY_VERT_WEB_END_RELEASE_TYPE |
TRUSS_ELEMENT_TAG_NEW_MEMBERS_VIEW |
TRUSS_NON_BEARING_OFFSET_PARAM |
TRUSS_BEARING_CHORD_TOP_BOTTOM_PARAM |
TRUSS_ELEMENT_SPAN_PARAM |
TRUSS_ELEMENT_STICK_JUST_PARAM |
TRUSS_FAMILY_WEBS_HAVE_SYMBOLIC_CUTBACK_PARAM |
TRUSS_HEIGHT |
TRUSS_FAMILY_TRANSFORMATION_PARAM |
TRUSS_ELEMENT_REFERENCE_LEVEL_PARAM |
TRUSS_ELEMENT_END1_ELEVATION |
TRUSS_ELEMENT_END0_ELEVATION |
TRUSS_ELEMENT_BEARING_JUST_PARAM |
TRUSS_ELEMENT_CREATE_BOTTOM_PARAM |
TRUSS_ELEMENT_CREATE_TOP_PARAM |
TRUSS_ELEMENT_ANGLE_PARAM |
TRUSS_ELEMENT_CLASS_PARAM |
TRUSS_FAMILY_SYMBOL_ID |
TRUSS_LENGTH |
BOUNDARY_PARAM_PRESET_AREA |
BOUNDARY_PARAM_PRESET_LINEAR |
BOUNDARY_PARAM_PRESET |
BOUNDARY_Z_TRANSLATION_SPRING |
BOUNDARY_Z_TRANSLATION_FIXED |
BOUNDARY_Z_ROTATION_SPRING |
BOUNDARY_Z_ROTATION_FIXED |
BOUNDARY_Y_TRANSLATION_SPRING |
BOUNDARY_Y_TRANSLATION_FIXED |
BOUNDARY_Y_ROTATION_SPRING |
BOUNDARY_Y_ROTATION_FIXED |
BOUNDARY_X_TRANSLATION_SPRING |
BOUNDARY_X_TRANSLATION_FIXED |
BOUNDARY_X_ROTATION_SPRING |
BOUNDARY_X_ROTATION_FIXED |
BOUNDARY_AREA_RESTRAINT_Z |
BOUNDARY_AREA_RESTRAINT_Y |
BOUNDARY_AREA_RESTRAINT_X |
BOUNDARY_LINEAR_RESTRAINT_ROT_X |
BOUNDARY_LINEAR_RESTRAINT_Z |
BOUNDARY_LINEAR_RESTRAINT_Y |
BOUNDARY_LINEAR_RESTRAINT_X |
BOUNDARY_RESTRAINT_ROT_Z |
BOUNDARY_RESTRAINT_ROT_Y |
BOUNDARY_RESTRAINT_ROT_X |
BOUNDARY_RESTRAINT_Z |
BOUNDARY_RESTRAINT_Y |
BOUNDARY_RESTRAINT_X |
BOUNDARY_DIRECTION_ROT_Z |
BOUNDARY_DIRECTION_ROT_Y |
BOUNDARY_DIRECTION_ROT_X |
BOUNDARY_DIRECTION_Z |
BOUNDARY_DIRECTION_Y |
BOUNDARY_DIRECTION_X |
BOUNDARY_CONDITIONS_IS_EXT |
BOUNDARY_CONDITIONS_TYPE |
KEYNOTE_SYSTEM |
KEY_SOURCE_PARAM |
KEYNOTE_PARAM |
KEYNOTE_NUMBER |
SHEET_KEY_NUMBER |
KEYNOTE_TEXT |
KEY_VALUE |
PHY_MATERIAL_PARAM_GRADE |
PHY_MATERIAL_PARAM_SPECIES |
PHY_MATERIAL_PARAM_EXP_COEFF |
PHY_MATERIAL_PARAM_BENDING |
PHY_MATERIAL_PARAM_SHEAR_MOD |
PHY_MATERIAL_PARAM_POISSON_MOD |
PHY_MATERIAL_PARAM_SHEAR_PERPENDICULAR |
PHY_MATERIAL_PARAM_SHEAR_PARALLEL |
PHY_MATERIAL_PARAM_COMPRESSION_PERPENDICULAR |
PHY_MATERIAL_PARAM_COMPRESSION_PARALLEL |
PHY_MATERIAL_PARAM_YOUNG_MOD |
PHY_MATERIAL_PARAM_TYPE |
ELEM_CATEGORY_PARAM_MT |
ELEM_CATEGORY_PARAM |
MATERIAL_VOLUME |
MATERIAL_AREA |
MATERIAL_NAME |
RBS_SYSTEM_FLOW_CONVERSION_METHOD_PARAM |
RBS_SYSTEM_NUM_ELEMENTS_PARAM |
RBS_SYSTEM_BASE_ELEMENT_PARAM |
RBS_SYSTEM_TYPE_PARAM |
RBS_SYSTEM_NAME_PARAM |
PHY_MATERIAL_PARAM_LIGHT_WEIGHT |
PHY_MATERIAL_PARAM_BEHAVIOR |
PHY_MATERIAL_PARAM_RESISTANCE_CALC_STRENGTH |
PHY_MATERIAL_PARAM_REDUCTION_FACTOR |
PHY_MATERIAL_PARAM_MINIMUM_TENSILE_STRENGTH |
PHY_MATERIAL_PARAM_MINIMUM_YIELD_STRESS |
PHY_MATERIAL_PARAM_SHEAR_STRENGTH_REDUCTION |
PHY_MATERIAL_PARAM_SHEAR_REINFORCEMENT |
PHY_MATERIAL_PARAM_BENDING_REINFORCEMENT |
PHY_MATERIAL_PARAM_CONCRETE_COMPRESSION |
PHY_MATERIAL_PARAM_DAMPING_RATIO |
PHY_MATERIAL_PARAM_EXP_COEFF3 |
PHY_MATERIAL_PARAM_EXP_COEFF2 |
PHY_MATERIAL_PARAM_EXP_COEFF1 |
PHY_MATERIAL_PARAM_UNIT_WEIGHT |
PHY_MATERIAL_PARAM_SHEAR_MOD3 |
PHY_MATERIAL_PARAM_SHEAR_MOD2 |
PHY_MATERIAL_PARAM_SHEAR_MOD1 |
PHY_MATERIAL_PARAM_POISSON_MOD3 |
PHY_MATERIAL_PARAM_POISSON_MOD2 |
PHY_MATERIAL_PARAM_POISSON_MOD1 |
PHY_MATERIAL_PARAM_YOUNG_MOD3 |
PHY_MATERIAL_PARAM_YOUNG_MOD2 |
PHY_MATERIAL_PARAM_YOUNG_MOD1 |
RBS_FP_SPRINKLER_ORIFICE_SIZE_PARAM |
RBS_FP_SPRINKLER_TEMPERATURE_RATING_PARAM |
RBS_FP_SPRINKLER_K_FACTOR_PARAM |
RBS_FP_SPRINKLER_PRESSURE_CLASS_PARAM |
RBS_FP_SPRINKLER_ORIFICE_PARAM |
RBS_FP_SPRINKLER_COVERAGE_PARAM |
RBS_FP_SPRINKLER_RESPONSE_PARAM |
RBS_SHOW_PROFILE_TYPE |
RBS_PIPE_SYSTEM_FIXTURE_UNIT_PARAM |
RBS_PIPE_SLOPE |
RBS_DUCT_SLOPE |
RBS_CURVE_UTSLOPE |
RBS_PIPE_VOLUME_PARAM |
RBS_PIPE_WFU_PARAM |
RBS_PIPE_HWFU_PARAM |
RBS_PIPE_CWFU_PARAM |
RBS_PIPE_FLOW_CONFIGURATION_PARAM |
RBS_PIPE_FLOW_DIRECTION_PARAM |
RBS_PIPE_TOTAL_FIXTURE_UNITS_PARAM_OBSOLETE |
RBS_PIPE_FIXTURE_UNITS_PARAM |
RBS_CURVE_SLOPE_RISE_RUN_METRIC |
RBS_CURVE_SLOPE_RISE_RUN_IMPERIAL |
RBS_CURVE_SLOPE_ANGLE |
RBS_PIPE_STATIC_PRESSURE |
RBS_PIPE_INSULATION_THICKNESS |
RBS_DUCT_BOTTOM_ELEVATION |
RBS_DUCT_TOP_ELEVATION |
RBS_PIPE_OUTER_DIAMETER |
RBS_PIPE_INVERT_ELEVATION |
RBS_PIPE_TYPE_FITTING_LOSS_METHOD_PARAM |
RBS_PIPE_TYPE_FITTING_LOSS_TABLE_PARAM |
RBS_PIPE_TYPE_FITTING_LOSS_KFACTOR_PARAM |
RBS_PIPE_TYPE_VALVE_LOSS_CVFACTOR_PARAM |
RBS_PIPE_FITTING_LOSS_METHOD_PARAM |
RBS_PIPE_FITTING_LOSS_TABLE_PARAM |
RBS_PIPE_FITTING_LOSS_KFACTOR_PARAM |
RBS_PIPE_VALVE_LOSS_CVFACTOR_PARAM |
RBS_PIPE_ADDITIONAL_FLOW_PARAM |
RBS_PIPE_DIAMETER_PARAM |
RBS_CURVE_SLOPE |
RBS_ADJUSTABLE_CONNECTOR |
RBS_FLOW_FACTOR_PARAM |
RBS_DUCT_FLOW_CONFIGURATION_PARAM |
RBS_DUCT_FLOW_DIRECTION_PARAM |
RBS_PIPE_FLUID_TYPE_PARAM |
RBS_PIPE_FLUID_TEMPERATURE_PARAM |
RBS_PIPE_FLUID_VISCOSITY_PARAM |
RBS_PIPE_FLUID_DENSITY_PARAM |
RBS_PIPE_FLOW_PARAM |
RBS_PIPE_INNER_DIAM_PARAM |
RBS_PIPE_REYNOLDS_NUMBER_PARAM |
RBS_PIPE_RELATIVE_ROUGHNESS_PARAM |
RBS_PIPE_FLOW_STATE_PARAM |
RBS_PIPE_FRICTION_FACTOR_PARAM |
RBS_PIPE_VELOCITY_PARAM |
RBS_PIPE_FRICTION_PARAM |
RBS_PIPE_PRESSUREDROP_PARAM |
RBS_PIPE_ROUGHNESS_PARAM |
RBS_SYSTEM_PARAM |
RBS_PIPE_MATERIAL_PARAM |
RBS_PIPE_CONNECTIONTYPE_PARAM |
RBS_PIPE_CLASS_PARAM |
RBS_ELEC_SWITCH_ID_PARAM |
RBS_WIRE_CIRCUIT_DESCRIPTION |
RBS_WIRE_CIRCUIT_LOAD_NAME |
RBS_WIRE_NUM_CONDUCTORS_PARAM |
RBS_ELEC_WIRE_TICKMARK_STATE |
RBS_CIRCUIT_DIRECTION |
RBS_ELEC_CIRCUIT_PANEL_PARAM |
RBS_ELEC_CIRCUIT_NUMBER |
RBS_ELEC_WIRE_CIRCUITS |
RBS_ELEC_CIRCUIT_WIRE_NUM_RUNS_PARAM |
STAIRS_ATTR_LAST_RISER |
STAIRS_ATTR_FIRST_RISER |
STAIRS_ATTR_STAIRS_BOTTOM |
STAIRS_ATTR_MONOLITHIC_STAIRS |
STAIRS_ATTR_CALC_ENABLED |
STAIRS_ATTR_CALC_MAX |
STAIRS_ATTR_CALC_MIN |
STAIRS_ATTR_EQ_RESULT |
STAIRS_ACTUAL_TREAD_DEPTH |
STAIRS_ATTR_TREAD_MULT |
STAIRS_ATTR_RISER_MULT |
STAIRS_ATTR_STAIR_CALCULATOR |
STAIRS_ACTUAL_NUM_RISERS |
STAIRS_ATTR_BREAK_SYM_IN_CUTLINE |
STAIRS_ATTR_RISER_MATERIAL |
STAIRS_ATTR_RISER_TYPE |
STAIRS_ATTR_TREAD_MATERIAL |
STAIRS_ATTR_NOSING_LENGTH |
STAIRS_ATTR_TREAD_FRONT_PROFILE |
STAIRS_ATTR_STRINGER_MATERIAL |
STAIRS_ATTR_STRINGER_OFFSET |
STAIRS_ATTR_STRINGER_CARRIAGE |
STAIRS_ATTR_SIDE_STRINGER_TYPE_PARAM |
STAIRS_MULTISTORY_TOP_LEVEL_PARAM |
STAIRS_STRINGERS_PRESENT |
STAIRS_BALUSTER_TREAD_OFFSET |
STAIRS_RIGHT_RAIL_BOTTOM_EXT |
STAIRS_RIGHT_RAIL_TOP_EXT |
STAIRS_ATTR_BALUSTER_LENGTH |
STAIRS_ATTR_BALUSTER_WIDTH |
STAIRS_ATTR_BALUSTERS_PER_TREAD |
STAIRS_ATTR_BALUSTER_SPACING |
STAIRS_ATTR_BALUSTER_SPACING_TYPE |
STAIRS_LEFT_RAIL_BOTTOM_EXT |
STAIRS_LEFT_RAIL_TOP_EXT |
STAIRS_ATTR_BALUSTER_SHAPE |
STAIRS_RIGHT_BALUSTER_ATTACH_PT |
STAIRS_ATTR_RIGHT_RAILING_PRESENT |
STAIRS_ATTR_LEFT_RAILING_PRESENT |
STAIRS_TOP_OFFSET |
STAIRS_BASE_OFFSET |
STAIRS_ATTR_RAILING_THICKNESS |
STAIRS_ATTR_RAILING_WIDTH |
STAIRS_ATTR_RAILING_HEIGHT |
STAIRS_ATTR_LEFT_BALUSTER_ATTACH_PT |
STAIRS_ATTR_BALUSTER_ATTACH_PT |
STAIRS_ATTR_NUM_BALUSTERS |
STAIRS_ATTR_RISER_ANGLE |
STAIRS_ATTR_TREAD_THICKNESS |
STAIRS_ATTR_STRINGER_THICKNESS |
STAIRS_ATTR_STRINGER_HEIGHT |
STAIRS_ATTR_RISERS_PRESENT |
STAIRS_TREAD_LENGTH |
STAIRS_ACTUAL_RISER_HEIGHT |
STAIRS_DESIRED_NUM_RISERS |
STAIRS_ATTR_TREAD_WIDTH |
STAIRS_ATTR_TREAD_LENGTH |
STAIRS_ATTR_MAX_RISER_HEIGHT |
STAIRS_TOP_LEVEL_PARAM |
STAIRS_BASE_LEVEL_PARAM |
LEVEL_RELATIVE_BASE_TYPE |
LEVEL_HORIZONTAL_TEXT_OFFSET |
LEVEL_VERTICAL_ELEV_OFFSET |
LEVEL_VERTICAL_TEXT_OFFSET |
LEVEL_IS_DATUM |
LEVEL_MAKE_PLAN_VIEW |
LEVEL_HEAD_RADIUS |
LEVEL_ELEV |
LEVEL_NAME |
LEVEL_HEAD_TAG |
TAG_NO_BREAK_PARAM_STRINGS |
ROOM_TAG_ORIENTATION_PARAM |
TAG_ORIENTATION_PARAM |
TAG_FORMAT_OPTIONS |
TAG_SAMPLE_TEXT |
TAG_TAG |
VIS_GRAPHICS_DESIGNOPTIONS |
VIS_GRAPHICS_RVT_LINKS |
VIS_GRAPHICS_FILTERS |
VIS_GRAPHICS_IMPORT |
VIS_GRAPHICS_ANNOTATION |
VIS_GRAPHICS_MODEL |
ROOM_USER_PARAM_LAST |
ROOM_USER_PARAM_FIRST |
LEVEL_ATTR_ROOM_COMPUTATION_AUTOMATIC |
LEVEL_ATTR_ROOM_COMPUTATION_HEIGHT |
ALWAYS_ZERO_LENGTH |
ROOM_COMPUTATION_METHOD |
ROOM_LOWER_OFFSET |
ROOM_UPPER_OFFSET |
ROOM_UPPER_LEVEL |
ROOM_VOLUME |
ROOM_HEIGHT |
TO_ROOM_NAME |
FROM_ROOM_NAME |
ROOM_PERIMETER |
ROOM_LEVEL_ID |
TO_WHICH_ROOM |
FROM_WHICH_ROOM |
TO_ROOM_ID |
FROM_ROOM_ID |
TO_ROOM_NUMBER |
FROM_ROOM_NUMBER |
ROOM_OCCUPANCY |
ROOM_OCCUPANT |
ROOM_DEPARTMENT |
ROOM_FINISH_BASE |
ROOM_FINISH_CEILING |
ROOM_FINISH_WALL |
ROOM_FINISH_FLOOR |
ROOM_AREA |
ROOM_NUMBER |
ROOM_NAME |
FILLED_REGION_BACKGROUND |
GRID_END_SEGMENTS_LENGTH |
GRID_END_SEGMENT_PATTERN |
GRID_END_SEGMENT_COLOR |
GRID_END_SEGMENT_WEIGHT |
GRID_CENTER_SEGMENT_PATTERN |
GRID_CENTER_SEGMENT_COLOR |
GRID_CENTER_SEGMENT_WEIGHT |
GRID_CENTER_SEGMENT_STYLE |
GRID_BUBBLE_LINE_PEN |
GRID_BUBBLE_RADIUS |
GRID_LABEL |
GRID_HEAD_TAG |
SECTION_BROKEN_DISPLAY_STYLE |
SECTION_COARSER_SCALE_PULLDOWN_IMPERIAL |
SECTION_COARSER_SCALE_PULLDOWN_METRIC |
SECTION_PARENT_VIEW_NAME |
SECTION_SHOW_IN_ONE_VIEW_ONLY |
SECTION_ATTR_TAIL_TAG |
SECTION_HIDE_LINE_PARAM |
SECTION_END2_MARK_PARAM |
SECTION_END1_MARK_PARAM |
SECTION_ATTR_TAIL_WIDTH |
SECTION_ATTR_TAIL_LENGTH |
SECTION_ATTR_HEAD_TAG |
KEEP_READABLE |
LEADER_LINE |
LEADER_OFFSET_SHEET |
SPOT_SLOPE_OFFSET_FROM_REFERENCE |
SPOT_SLOPE_SLOPE_REPRESENTATION |
SPOT_SLOPE_SLOPE_DIRECTION |
SPOT_ELEV_LOWER_VALUE |
SPOT_ELEV_SINGLE_OR_UPPER_VALUE |
SPOT_ELEV_IND_TYPE_ELEVATION |
SPOT_COORDINATE_INCLUDE_ELEVATION |
SPOT_COORDINATE_ELEVATION_SUFFIX |
SPOT_COORDINATE_ELEVATION_PREFIX |
SPOT_COORDINATE_BOTTOM_SUFFIX |
SPOT_COORDINATE_BOTTOM_PREFIX |
SPOT_COORDINATE_TOP_SUFFIX |
SPOT_COORDINATE_TOP_PREFIX |
SPOT_ELEV_LOWER_SUFFIX |
SPOT_ELEV_LOWER_PREFIX |
SPOT_ELEV_SINGLE_OR_UPPER_SUFFIX |
SPOT_ELEV_SINGLE_OR_UPPER_PREFIX |
BASELINE_DIM_OFFSET |
SPOT_ELEV_BEND_LEADER |
SPOT_ELEV_IND_TYPE_BOTTOM |
SPOT_ELEV_IND_TYPE_TOP |
SPOT_ELEV_IND_BOTTOM |
SPOT_ELEV_IND_TOP |
SPOT_ELEV_TEXT_LOCATION |
SPOT_ELEV_ROTATE_WITH_COMPONENT |
SPOT_ELEV_DISPLAY_ELEVATIONS |
ORDINATE_DIM_SETTING |
LINEAR_DIM_TYPE |
SPOT_DIM_LEADER |
DIM_STYLE_FLIPPED_DIM_LINE_EXTENSION |
DIM_STYLE_INTERIOR_TICK_MARK |
SPOT_COORDINATE_TEXT_ORIENTATION |
SPOT_TEXT_FROM_LEADER |
SPOT_COORDINATE_BASE |
SPOT_ELEV_READ_CONVENTION |
SPOT_ELEV_IND_TYPE |
SPOT_ELEV_BOT_VALUE |
SPOT_ELEV_TOP_VALUE |
SPOT_ELEV_TEXT_ORIENTATION |
SPOT_ELEV_IND_ELEVATION |
SPOT_ELEV_IND_EW |
SPOT_ELEV_IND_NS |
DIM_STYLE_READ_CONVENTION |
HEAVY_END_PEN |
DIM_STYLE_DIM_LINE_SNAP_DIST |
DIM_STYLE_CENTERLINE_TICK_MARK |
SPOT_ELEV_LINE_PEN |
SPOT_ELEV_TICK_MARK_PEN |
SPOT_ELEV_LEADER_ARROWHEAD |
SPOT_ELEV_RELATIVE_BASE |
SPOT_ELEV_FLIP_TEXT_VERT |
SPOT_ELEV_TEXT_HORIZ_OFFSET |
SPOT_ELEV_LEADER |
SPOT_ELEV_BASE |
SPOT_ELEV_SYMBOL |
DIM_STYLE_SHOW_OPENING_HT |
DIM_STYLE_CENTERLINE_PATTERN |
DIM_WITNS_LINE_EXTENSION_BELOW |
DIM_WITNS_LINE_CNTRL |
DIM_LINE_EXTENSION |
DIM_STYLE_CENTERLINE_SYMBOL |
DIM_TEXT_BACKGROUND |
DIM_STYLE_ANGULAR_UNITS |
DIM_STYLE_LINEAR_UNITS |
LEADER_ARROW_WIDTH |
ARROW_FILLED |
RADIAL_FILLED_TICK |
LINEAR_FILLED_TICK |
RADIAL_ARROW_WIDTH |
LINEAR_ARROW_WIDTH |
HEAVY_TICK_MARK_PEN |
DIM_VISIBLE |
RADIAL_TICK_SIZE |
LINEAR_TICK_SIZE |
RADIAL_TICK_TYPE |
LINEAR_TICK_TYPE |
ARROW_SIZE |
ARROW_TYPE |
TICK_MARK_PEN |
TEXT_POSITION |
SUPPRESS_0_IN |
SUPPRESS_0_FT |
RADIUS_PREFIX |
CENTER_MARK_SIZE |
ARC_CENTER_MARK |
WITNS_LINE_GAP_TO_ELT |
WITNS_LINE_EXTENSION |
TICK_SIZE |
TICK_TYPE |
TEXT_DIST_TO_LINE |
TEXT_ALIGNMENT |
MODEL_TEXT_SIZE |
TEXT_STYLE_SIZE |
TEXT_STYLE_FONT |
SHOW_TITLE |
TITLE_STYLE_UNDERLINE |
TITLE_STYLE_ITALIC |
TITLE_STYLE_BOLD |
TITLE_SIZE |
TITLE_FONT |
TEXT_WIDTH_SCALE |
TEXT_TAB_SIZE |
ARC_LEADER_PARAM |
TEXT_MODEL_TEXT |
DIM_LEADER_ARROWHEAD |
SHEET_ISSUE_DATE |
PROJECT_ISSUE_DATE |
PROJECT_STATUS |
CLIENT_NAME |
PROJECT_ADDRESS |
PROJECT_NAME |
PROJECT_NUMBER |
LEADER_ARROWHEAD |
TEXT_BACKGROUND |
TEXT_STYLE_UNDERLINE |
TEXT_STYLE_ITALIC |
TEXT_STYLE_BOLD |
CURVE_IS_FILLED |
TEXT_ALIGN_VERT |
TEXT_ALIGN_HORZ |
TEXT_TEXT |
HEAD_STYLE |
LINE_PATTERN |
LINE_COLOR |
LINE_PEN |
TEXT_COLOR |
TEXT_SIZE |
TEXT_FONT |
FACE_TYPE_NON_CAPPED_END |
FACE_TYPE_CAPPED_END |
FACE_TYPE_INTERIOR |
FACE_TYPE_EXTERIOR |
FACE_TYPE |
CLINE_SUBCATEGORY |
EDGE_LINEWORK |
BUILDING_CURVE_GSTYLE_PLUS_INVISIBLE |
BUILDING_CURVE_GSTYLE |
HEAD_ON_PLACEMENT_METHOD |
IS_VISIBLE_PARAM |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM_MINUS_ANALYTICAL |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_MINUS_ANALYTICAL |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE |
FAMILY_ELEM_SUBCATEGORY |
STAIRS_CURVE_TAG |
STAIRS_CURVE_FACE_TAG |
STAIRS_CURVE_RISER_SEGMENT_NUM |
STAIRS_CURVE_ORIENTATION |
STAIRS_CURVE_BOUNDARY_SIDE |
STAIRS_CURVE_RISER_NUM |
STAIRS_CURVE_RUN_ID2 |
STAIRS_CURVE_RUN_ID1 |
STAIRS_CURVE_TYPE |
ROOF_SLOPE |
CURVE_PARAM_STEEL_CANTILEVER |
CURVE_PARAM_CONCRETE_CANTILEVER |
CURVE_NUMBER_OF_SEGMENTS |
SPECIFY_SLOPE_OR_OFFSET |
SLOPE_ARROW_LEVEL_END |
SLOPE_ARROW_LEVEL_START |
CURVE_LEVEL |
CURVE_HEIGHT_OFFSET |
CURVE_IS_SLOPE_DEFINING |
DEFINES_CONSTANT_HEIGHT |
ROOF_CURVE_HEIGHT_AT_WALL |
ROOF_RISE_RUN_IMPERIAL |
ROOF_RISE_RUN_METRIC |
ROOF_SLOPE_ANGLE |
ROOF_CURVE_HEIGHT_OFFSET |
ROOF_CURVE_IS_SLOPE_DEFINING |
VIEW_DESIGN_OPTIONS_CONFIG |
VIEW_GRAPH_SCHED_LEVEL_RELATIVE_BASE_TYPE |
VIEW_GRAPH_SCHED_HIDDEN_LEVELS |
VIEW_GRAPH_SCHED_TOTAL_ROWS |
VIEW_GRAPH_SCHED_ROWS_COUNT |
VIEW_GRAPH_SCHED_GRID_APPEARANCE |
VIEW_GRAPH_SCHED_TEXT_APPEARANCE |
VIEW_GRAPH_SCHED_TITLE |
VIEW_GRAPH_SCHED_HEIGHT_BETWEEN |
VIEW_GRAPH_SCHED_HEIGHT_BELOW |
VIEW_GRAPH_SCHED_HEIGHT_ABOVE |
VIEW_GRAPH_SCHED_SIDE_WIDTH |
VIEW_GRAPH_SCHED_ROWS_FROM |
VIEW_GRAPH_SCHED_GROUP_SIMILAR |
VIEW_GRAPH_SCHED_MATERIAL_TYPES |
VIEW_GRAPH_SCHED_LOCATIONS_HIGH |
VIEW_GRAPH_SCHED_LOCATIONS_LOW |
VIEW_GRAPH_SCHED_BOTTOM_LEVEL |
VIEW_GRAPH_SCHED_TOP_LEVEL |
LIGHT_POS_Z |
LIGHT_POS_Y |
LIGHT_POS_X |
LIGHT_ON |
VIEWPORT_ATTR_ORIENTATION_ON_SHEET |
VIEWPORT_ATTR_SHOW_BOX |
VIEWPORT_ATTR_SHOW_EXTENSION_LINE |
VIEWPORT_ATTR_SHOW_LABEL |
VIEWPORT_ATTR_LABEL_TAG |
VIEW_SCALE_HAVENAME |
VIEW_SCALE_CUSTOMNAME |
VIEW_GRAPH_SCHED_OFF_GRID |
VIEW_GRAPH_SCHED_UNITS_FORMAT |
VIEWPORT_SHEET_NAME |
VIEWPORT_SHEET_NUMBER |
VIEWPORT_STRETCH_FACTOR |
VIEWPORT_SCALE |
VIEWPORT_VIEW_NAME |
VIEWPORT_DETAIL_NUMBER |
VIEWPORT_CLIPPING |
RENDER_RPC_PROPERTIES |
FAMILY_SYMBOLIC_REP |
FAMILY_RENDERING_TYPE |
RENDER_RPC_FILENAME |
RENDER_PLANT_TRIM_HEIGHT |
RENDER_PLANT_HEIGHT |
RENDER_PLANT_NAME |
RENDER_ENVIRONMENT |
RENDER_TIMEDATEPLACE |
RENDER_SETTING_UPGRADE_USER_SET |
RENDER_SETTING_UPGRADE_DPI |
RENDER_SETTING_UPGRADE_SIZEY |
RENDER_SETTING_UPGRADE_SIZEX |
RENDER_SETTING_UPGRADE_BTYPE |
COLOR_SCHEME_LOCATION |
VIEW_DEPENDENCY |
VIEW_BACK_CLIPPING |
VIEW_DOCUMENTATION_CATEGORY |
VIEW_MODEL_DISPLAY_MODE_SHOPDRAWING |
VIEW_GRAPH_SCHED_TOTAL_COLUMNS |
VIEW_UNDERLAY_ORIENTATION |
VIEW_DEFAULT_TEMPLATE |
VIEW_GRAPH_SCHED_NUMBER_COLUMNS |
VIEW_GRAPH_SCHED_GRID_WIDTH |
ADVANCED_MODEL_GRAPHICS |
MODEL_GRAPHICS_STYLE_ANON_DRAFT |
VIEW_REFERENCING_DETAIL |
VIEW_REFERENCING_SHEET |
VIEW_CAMERA_POSITION |
PLAN_VIEW_NORTH |
WALKTHROUGH_FRAMES_COUNT |
PLAN_VIEW_LEVEL |
MODEL_GRAPHICS_STYLE |
VIEW_VISIBLE_CATEGORIES |
VIEW_DISCIPLINE |
PLAN_VIEW_RANGE |
VIEW_MODEL_DISPLAY_MODE |
VIEW_SHOW_MASSING |
PLAN_VIEW_TOP_CLIP_HEIGHT |
VIEW_CLEAN_JOINS |
VIEW_SHEET_VIEWPORT_INFO |
PLAN_VIEW_SHOW_ELEMS_ABOVE |
PLAN_VIEW_CUT_PLANE_HEIGHT |
VIEW_DEPTH |
VIEW_UNDERLAY_ID |
VIEW_SCALE_PULLDOWN_IMPERIAL |
VIEW_SCALE_PULLDOWN_METRIC |
VIEW_SCALE |
VIEW_SCHEMA_SETTING_FOR_SYSTEM |
VIEW_SCHEMA_SETTING_FOR_BUILDING |
VIEW_FIXED_SKETCH_PLANE |
VIEW_NAME_DISABLED |
VIEW_DESCRIPTION |
VIEW_NAME |
VIEWER3D_RENDER_SETTINGS |
VIEWER3D_IMAGE_SETTINGS |
VIEWER3D_RAY_QUALITY_UPGRADE |
VIEWER3D_ARE_ELEMENT_UPGRADE |
VIEWER3D_TDP_ELEMENT_UPGRADE |
VIEWER_REFERENCE_LABEL_TEXT |
VIEWER_IS_REFERENCE |
VIEWER_REFERENCE_LABEL |
VIEWER_MODEL_CLIP_BOX_ACTIVE |
VIEWER_DETAIL_NUMBER |
VIEWER_SHEET_NUMBER |
VIEWER_BOUND_ACTIVE_NEAR |
VIEWER_BOUND_FAR_CLIPPING |
VIEWER_BOUND_ACTIVE_FAR |
VIEWER_BOUND_ACTIVE_BOTTOM |
VIEWER_BOUND_ACTIVE_TOP |
VIEWER_BOUND_ACTIVE_LEFT |
VIEWER_BOUND_ACTIVE_RIGHT |
VIEWER_BOUND_OFFSET_NEAR |
VIEWER_BOUND_OFFSET_FAR |
VIEWER_BOUND_OFFSET_BOTTOM |
VIEWER_BOUND_OFFSET_TOP |
VIEWER_BOUND_OFFSET_LEFT |
VIEWER_BOUND_OFFSET_RIGHT |
VIEWER_ANNOTATION_CROP_ACTIVE |
VIEWER_SHOW_UNCROPPED |
VIEWER_CROP_REGION_VISIBLE |
VIEWER_CROP_REGION_DISABLED |
VIEWER_CROP_REGION |
VIEWER_PERSPECTIVE_DISABLED |
VIEWER_PERSPECTIVE |
VIEWER_TARGET_ELEVATION |
VIEWER_OPTION_VISIBILITY |
VIEWER_EYE_ELEVATION |
DIM_DISPLAY_EQ |
DIM_NOT_MODIFIABLE |
DIM_SUFFIX |
DIM_PREFIX |
DIM_LABEL |
DIM_VALUE_ANGLE |
DIM_VALUE_LENGTH |
ELEM_REFERENCE_NAME_2D_XZ |
CURVE_ELEM_DEFINES_SLOPE |
RADIAL_ARRAY_ARC_RADIUS |
CURVE_DETERMINES_ORIENTATION |
DATUM_PLANE_DEFINES_WALL_CLOSURE |
CURVE_IS_DETAIL |
CURVE_ELEM_ARC_RADIUS |
CURVE_ELEM_ARC_RANGE |
CURVE_ELEM_ARC_END_ANGLE |
CURVE_ELEM_ARC_START_ANGLE |
CURVE_ELEM_LINE_ANGLE |
CURVE_ELEM_LENGTH |
ELEM_DELETABLE_IN_FAMILY |
ELEM_REFERENCE_NAME |
DATUM_PLANE_DEFINES_ORIGIN |
ELEM_IS_REFERENCE |
CURVE_ELEM_VISIBLE_TYPE |
FAMILY_PARAM_END |
FAMILY_PARAM_START |
COLUMN_LOCATION_MARK |
COLUMN_TOP_ATTACH_CUT_PARAM |
COLUMN_BASE_ATTACH_CUT_PARAM |
COLUMN_BASE_ATTACHED_PARAM |
COLUMN_TOP_ATTACHED_PARAM |
COLUMN_BASE_ATTACHMENT_OFFSET_PARAM |
COLUMN_TOP_ATTACHMENT_OFFSET_PARAM |
COLUMN_BASE_ATTACH_JUSTIFICATION_PARAM |
COLUMN_TOP_ATTACH_JUSTIFICATION_PARAM |
MATERIAL_PARAM_SHININESS |
MATERIAL_PARAM_SMOOTHNESS |
MATERIAL_PARAM_GLOW |
MATERIAL_PARAM_TRANSPARENCY |
MATERIAL_PARAM_COLOR |
UNIFORMAT_DESCRIPTION |
ZONE_HUMIDIFICATION_SET_POINT_PARAM |
ZONE_COOLING_AIR_TEMPERATURE_PARAM |
ZONE_HEATING_AIR_TEMPERATURE_PARAM |
ZONE_COOLING_SET_POINT_PARAM |
ZONE_HEATING_SET_POINT_PARAM |
ZONE_CALCULATED_SUPPLY_AIRFLOW_PARAM |
ZONE_CALCULATED_COOLING_LOAD_PARAM |
ZONE_CALCULATED_HEATING_LOAD_PARAM |
ZONE_SERVICE_TYPE_PARAM |
ZONE_VOLUME |
ZONE_PERIMETER |
ZONE_AREA |
ZONE_NAME |
RBS_ENERGY_ANALYSIS_SHADING_SURFACES_PARAM |
RBS_ENERGY_ANALYSIS_GROUND_PLANE_PARAM |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Z |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Y |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_X |
RBS_ENERGY_ANALYSIS_SURFACE_AZIMUTH |
RBS_ENERGY_ANALYSIS_SURFACE_TILT |
RBS_ENERGY_ANALYSIS_SURFACE_CADOBJECTID |
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID2 |
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID1 |
ROOM_EDIT_ELECTRICAL_LOADS_PARAM |
ROOM_EDIT_PEOPLE_LOADS_PARAM |
RBS_PROJECT_LOCATION_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_ROOFLIGHT_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_INTERNAL_WINDOW_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_EXTERNAL_WINDOW_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_PARTITION_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_DOOR_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_CEILING_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_ROOF_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_SOLID_GROUND_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_EXTERNAL_WALL_PARAM |
RBS_CONSTRUCTION_TYPE_ROOFLIGHT_PARAM |
RBS_CONSTRUCTION_TYPE_INTERNAL_WINDOW_PARAM |
RBS_CONSTRUCTION_TYPE_EXTERNAL_WINDOW_PARAM |
RBS_CONSTRUCTION_TYPE_PARTITION_PARAM |
RBS_CONSTRUCTION_TYPE_DOOR_PARAM |
RBS_CONSTRUCTION_TYPE_CEILING_PARAM |
RBS_CONSTRUCTION_TYPE_ROOF_PARAM |
RBS_CONSTRUCTION_TYPE_SOLID_GROUND_PARAM |
RBS_CONSTRUCTION_TYPE_EXTERNAL_WALL_PARAM |
ROOM_ACTUAL_LIGHTING_LOAD_PER_AREA_PARAM |
ROOM_ACTUAL_POWER_LOAD_PER_AREA_PARAM |
ROOM_BASE_HEAT_LOAD_ON_PARAM |
ROOM_LIGHTING_LOAD_UNITS_PARAM |
ROOM_POWER_LOAD_UNITS_PARAM |
ROOM_DESIGN_COOLING_LOAD_PARAM |
ROOM_CALCULATED_COOLING_LOAD_PARAM |
ROOM_DESIGN_HEATING_LOAD_PARAM |
ROOM_CALCULATED_HEATING_LOAD_PARAM |
ROOM_BASE_RETURN_AIRFLOW_ON_PARAM |
ROOM_CONSTRUCTION_SET_PARAM |
ROOM_SERVICE_TYPE_PARAM_OBSOLETE |
RBS_CONSTRUCTION_SET_PARAM |
RBS_SERVICE_TYPE_PARAM |
RBS_GBXML_SURFACE_AREA |
RBS_GBXML_SURFACE_TYPE |
RBS_GBXML_SURFACE_NAME |
FAMILY_ELECTRICAL_MAINTAIN_ANNOTATION_ORIENTATION |
RBS_FAMILY_CONTENT_ANNOTATION_DISPLAY |
RBS_ELECTRICAL_DATA |
RBS_CALCULATED_SIZE |
ROOM_PEOPLE_SENSIBLE_HEAT_GAIN_PER_PERSON_PARAM |
RBS_IS_CUSTOM_FITTING |
RBS_CONNECTOR_OFFSET_OBSOLETE |
RBS_LOOKUP_TABLE_NAME |
GBXML_PREDEF_CONSTRUCTION_SLABS_ON_GRADE_PARAM |
GBXML_PREDEF_CONSTRUCTION_UNDERGROUND_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_SHADE_WALLS_PARAM |
RBS_COLOR_FILL_CONTOUR_AT_SIZE_PARAM |
RBS_COLOR_FILL_WIDTH_PARAM |
ROOM_DESIGN_LIGHTING_LOAD_PARAM |
ROOM_DESIGN_POWER_LOAD_PARAM |
ROOM_ACTUAL_OTHER_LOAD_PARAM |
ROOM_ACTUAL_MECHANICAL_LOAD_PARAM |
ROOM_ACTUAL_LIGHTING_LOAD_PARAM |
ROOM_ACTUAL_POWER_LOAD_PARAM |
ROOM_BASE_LIGHTING_LOAD_ON_PARAM |
ROOM_BASE_POWER_LOAD_ON_PARAM |
ROOM_DESIGN_OTHER_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_MECHANICAL_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_LIGHTING_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_POWER_LOAD_PER_AREA_PARAM |
RBS_ROOM_COEFFICIENT_UTILIZATION |
RBS_FAMILY_CONTENT_TAKEOFF_FIXED_LENGTH |
RBS_FAMILY_CONTENT_TAKEOFF_PROJLENGTH |
RBS_FAMILY_CONTENT_TAKEOFF_LENGTH |
RBS_FAMILY_CONTENT_OFFSET_HEIGHT |
RBS_FAMILY_CONTENT_OFFSET_WIDTH |
FAMILY_TABLE_OBSOLETE |
FAMILY_INLINE_FITTING_CALCULATION_MODE_OBSOLETE |
FAMILY_CONTENT_PART_TYPE |
GBXML_PREDEF_CONSTRUCTION_OPERABLE_WINDOWS_PARAM |
GBXML_PREDEF_CONSTRUCTION_NON_SLIDING_DOOR_PARAM |
GBXML_PREDEF_CONSTRUCTION_UNDERGROUND_SLABS_PARAM |
GBXML_PREDEF_CONSTRUCTION_INTERIOR_FLOORS_PARAM |
GBXML_PREDEF_CONSTRUCTION_INTERIOR_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_EXTERIOR_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_CEILINGS_PARAM |
GBXML_PREDEF_CONSTRUCTION_ROOFS_PARAM |
GBXML_EDIT_DATA_PARAM |
ROOM_ACTUAL_EXHAUST_AIRFLOW_PARAM |
ROOM_ACTUAL_RETURN_AIRFLOW_PARAM |
ROOM_ACTUAL_SUPPLY_AIRFLOW_PARAM |
ROOM_RETURN_EQUAL_SUPPLY_AIRFLOW_PARAM_OBSOLETE |
ROOM_TEMPERATURE_PARAM_OBSOLETE |
ROOM_DESIGN_COOLING_TEMP_PARAM_OBSOLETE |
ROOM_DESIGN_HEATING_TEMP_PARAM_OBSOLETE |
ROOM_PEOPLE_LATENT_HEAT_GAIN_PER_PERSON_PARAM |
ROOM_PEOPLE_TOTAL_HEAT_GAIN_PER_PERSON_PARAM |
ROOM_LIGHTING_POWER_PER_AREA_PARAM_OBSOLETE |
ROOM_EQUIPMENT_POWER_PER_AREA_PARAM_OBSOLETE |
ROOM_USE_DATA_IN_ENERGY_ANALYSIS_PARAM_OBSOLETE |
ROOM_OUTSIDE_AIR_PER_PERSON_PARAM_OBSOLETE |
ROOM_OUTSIDE_AIR_PER_AREA_PARAM_OBSOLETE |
ROOM_AIR_CHANGES_PARAM_OBSOLETE |
ROOM_CALCULATED_EXHAUST_AIRFLOW_PARAM |
ROOM_CALCULATED_SUPPLY_AIRFLOW_PARAM |
ROOM_BASE_SUPPLY_AIRFLOW_ON_PARAM_OBSOLETE |
ROOM_DESIGN_EXHAUST_AIRFLOW_PARAM |
ROOM_DESIGN_RETURN_AIRFLOW_PARAM |
ROOM_DESIGN_SUPPLY_AIRFLOW_PARAM |
ROOM_AREA_PER_PERSON_PARAM |
ROOM_NUMBER_OF_PEOPLE_PARAM |
ROOM_OCCUPANCY_UNIT_PARAM |
ROOM_SPACE_TYPE_PARAM |
ROOM_CONDITION_TYPE_PARAM |
PROJECT_POSTAL_CODE |
PROJECT_BUILDING_TYPE |
RBS_SIZE_LOCK |
RBS_ADDITIONAL_FLOW |
RBS_CURVETYPE_MAX_WIDTH_PARAM |
ROOM_ZONE_PARAM_OBSOLETE |
RBS_PIPE_SIZE_FORMATTED_PARAM |
RBS_DUCT_SIZE_FORMATTED_PARAM |
RBS_DUCT_STATIC_PRESSURE |
RBS_FLEX_PIPE_TYPE_PARAM |
RBS_PIPE_TYPE_PARAM |
RBS_FLEX_DUCT_TYPE_PARAM |
RBS_DUCT_TYPE_PARAM |
RBS_DUCT_FITTING_LOSS_TABLE_PARAM |
RBS_DUCT_FITTING_LOSS_METHOD_PARAM |
RBS_FLEXDUCT_ROUNDTYPE_PARAM |
RBS_CURVETYPE_PREFERRED_BRANCH_PARAM |
RBS_CURVETYPE_DEFAULT_TAKEOFF_PARAM |
RBS_OFFSET_PARAM |
RBS_CURVETYPE_DEFAULT_UNION_PARAM |
RBS_REQUIRED_FLOW |
RBS_HYDRAULIC_DIAMETER_PARAM |
RBS_REYNOLDSNUMBER_PARAM |
RBS_EQ_DIAMETER_PARAM |
RBS_CURVETYPE_MULTISHAPE_TRANSITION_PARAM |
RBS_SECTION |
RBS_LOSS_COEFFICIENT |
RBS_MAX_FLOW |
RBS_MIN_FLOW |
RBS_VELOCITY_PRESSURE |
RBS_CURVE_SURFACE_AREA |
RBS_CURVETYPE_MAX_HEIGHT_PARAM |
RBS_LINING_THICKNESS |
RBS_INSULATION_THICKNESS |
RBS_FRICTION |
RBS_CURVETYPE_RISEDROP_TYPE_PARAM |
RBS_CURVETYPE_ROUGHNESS_PARAM |
RBS_CURVETYPE_DEFAULT_TRANSITION_PARAM |
RBS_CURVETYPE_DEFAULT_CROSS_PARAM |
RBS_CURVETYPE_DEFAULT_TEE_PARAM |
RBS_CURVETYPE_DEFAULT_ELBOW_PARAM |
RBS_FLOW_DIRECTION_OBSOLETE |
RBS_PRESSURE_DROP |
RBS_VELOCITY |
RBS_CURVE_VERT_OFFSET_PARAM |
RBS_CURVE_HOR_OFFSET_PARAM |
RBS_FLOW_OBSOLETE |
RBS_CURVE_DIAMETER_PARAM |
RBS_CURVE_HEIGHT_PARAM |
RBS_CURVE_WIDTH_PARAM |
RBS_CURVETYPE_PROFILE_PARAM |
RBS_FLEX_PATTERN_PARAM |
RBS_SYSTEM_CATEGORY_PARAM |
RBS_END_OFFSET_PARAM |
RBS_START_OFFSET_PARAM |
RBS_END_LEVEL_PARAM |
RBS_START_LEVEL_PARAM |
IFC_TYPE_GUID |
IFC_GUID |
REIN_EST_BAR_VOLUME |
REIN_EST_BAR_LENGTH |
REIN_EST_NUMBER_OF_BARS |
PATH_REIN_SPANLENGTH_ALT_OFFSET |
PATH_REIN_SPANLENGTH_BARLENGTH_ALT |
PATH_REIN_SPANLENGTH_BARLENGTH_PRIM |
PATH_REIN_SPANLENGTH_TOP_ALT |
PATH_REIN_END_SPANHOOK_ALT |
PATH_REIN_END_SPANHOOK_PRIM |
PATH_REIN_SUMMARY |
PATH_REIN_SPANLENGTH_BOTTOM_ALT |
PATH_REIN_SPANLENGTH_BOTTOM_PRIM |
PATH_REIN_SPANHOOK_ALT |
PATH_REIN_SPANHOOK_PRIM |
PATH_REIN_ADDL_OFFSET |
PATH_REIN_ALT_OFFSET |
PATH_REIN_END_HOOK_ORIENT_2_WALL |
PATH_REIN_END_HOOK_ORIENT_1_WALL |
PATH_REIN_END_HOOK_ORIENT_2_SLAB |
PATH_REIN_END_HOOK_ORIENT_1_SLAB |
PATH_REIN_END_HOOK_TYPE_2 |
PATH_REIN_END_HOOK_TYPE_1 |
PATH_REIN_HOOK_ORIENT_2_WALL |
PATH_REIN_HOOK_ORIENT_1_WALL |
PATH_REIN_HOOK_ORIENT_2_SLAB |
PATH_REIN_HOOK_ORIENT_1_SLAB |
PATH_REIN_HOOK_TYPE_2 |
PATH_REIN_HOOK_TYPE_1 |
PATH_REIN_LENGTH_2 |
PATH_REIN_LENGTH_1 |
PATH_REIN_TYPE_2 |
PATH_REIN_TYPE_1 |
PATH_REIN_ALTERNATING |
PATH_REIN_NUMBER_OF_BARS |
PATH_REIN_SPACING |
PATH_REIN_FACE_WALL |
PATH_REIN_FACE_SLAB |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_ACTIVE_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_ACTIVE_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_SPACING_BACK_DIR_2 |
REBAR_SYSTEM_SPACING_BACK_DIR_1 |
REBAR_SYSTEM_SPACING_FRONT_DIR_2 |
REBAR_SYSTEM_SPACING_FRONT_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_1 |
REBAR_SYSTEM_ACTIVE_BACK_DIR_2 |
REBAR_SYSTEM_ACTIVE_BACK_DIR_1 |
REBAR_SYSTEM_ACTIVE_FRONT_DIR_2 |
REBAR_SYSTEM_ACTIVE_FRONT_DIR_1 |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_2 |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_1 |
REBAR_SYSTEM_SPACING_TOP_DIR_2 |
REBAR_SYSTEM_SPACING_TOP_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1 |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2 |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1 |
REBAR_SYSTEM_ACTIVE_TOP_DIR_2 |
REBAR_SYSTEM_ACTIVE_TOP_DIR_1 |
REBAR_SYSTEM_SPANHOOK_TOP_DIR_2 |
REBAR_SYSTEM_SPANHOOK_BOTTOM_DIR_2 |
REBAR_SYSTEM_SPANHOOK_RIGHT_DIR_1 |
REBAR_SYSTEM_SPANHOOK_LEFT_DIR_1 |
REBAR_SYSTEM_SPANACTIVE_DIR_2 |
REBAR_SYSTEM_SPANACTIVE_DIR_1 |
REBAR_SYSTEM_ADDL_BOTTOM_OFFSET |
REBAR_SYSTEM_ADDL_TOP_OFFSET |
REBAR_SYSTEM_TOP_MINOR_MATCHES_BOTTOM_MINOR |
REBAR_SYSTEM_TOP_MAJOR_MATCHES_BOTTOM_MAJOR |
REBAR_SYSTEM_BOTTOM_MAJOR_MATCHES_BOTTOM_MINOR |
REBAR_SYSTEM_TOP_MAJOR_MATCHES_TOP_MINOR |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_WITH_SPACING |
REBAR_SYSTEM_COVER_BOTTOM |
REBAR_SYSTEM_COVER_TOP |
REBAR_SYSTEM_OVERRIDE |
REBAR_SYSTEM_LAYER_SUMMARY_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_WITH_SPACING |
REBAR_SYSTEM_LAYOUT_RULE |
REBAR_SYSTEM_COVER_SIDE |
REBAR_INSTANCE_BEND_DIAMETER |
REBAR_INSTANCE_BAR_DIAMETER |
REBAR_SHAPE_END_HOOK_OFFSET |
REBAR_SHAPE_END_HOOK_LENGTH |
REBAR_SHAPE_START_HOOK_OFFSET |
REBAR_SHAPE_START_HOOK_LENGTH |
REBAR_ELEM_SCHEDULE_MARK |
REBAR_ELEM_HOOK_STYLE |
REBAR_ELEM_SHAPE |
REBAR_SHAPE_HOOK_END_TYPE |
REBAR_SHAPE_HOOK_START_TYPE |
REBAR_SHAPE_HOOK_STYLE |
REBAR_BAR_ALLOWED_BAR_TYPES |
REBAR_BAR_MAXIMUM_BEND_RADIUS |
REBAR_BAR_STIRRUP_BEND_DIAMETER |
REBAR_BAR_HOOK_LENGTHS |
REBAR_HOOK_STYLE |
REBAR_ELEM_LENGTH |
REBAR_SHAPE |
REBAR_ELEMENT_VISIBILITY |
REBAR_ELEM_BAR_SPACING |
REBAR_ELEM_QUANTITY_OF_BARS |
REBAR_ELEM_LAYOUT_RULE |
REBAR_STANDARD_BEND_DIAMETER |
REBAR_ELEM_HOOK_END_ORIENT |
REBAR_ELEM_HOOK_END_TYPE |
REBAR_ELEM_HOOK_START_ORIENT |
REBAR_ELEM_HOOK_START_TYPE |
REBAR_ELEM_TOTAL_LENGTH |
REBAR_HOOK_LINE_LEN_FACTOR |
REBAR_HOOK_ANGLE |
REBAR_BAR_STYLE |
REBAR_BAR_BEND_RADIUS |
REBAR_BAR_DIAMETER |
CWP_COPY_ROOF_INSERTS |
CWP_COPY_FLOOR_INSERTS |
CWP_COPY_WALL_INSERTS |
CWP_LINKED_ROOM_PARAMS |
CWP_LINKED_ROOM_PHASES |
CWP_ORIG_Z |
CWP_ORIG_Y |
CWP_ORIG_X |
CWP_REUSE_GRIDS_SAME_NAME |
CWP_REUSE_LEVELS_SAME_NAME |
CWP_SPLIT_COLUMNS_AT_LEVELS |
CWP_REUSE_EXISTING_GRIDS |
CWP_REUSE_EXISTING_LEVELS |
CWP_LEVEL_OFFSET |
CWP_ADD_LEVEL_SUFFIX |
CWP_ADD_LEVEL_PREFIX |
CWP_ADD_GRID_SUFFIX |
CWP_ADD_GRID_PREFIX |
CWP_DONT_COPY_TYPE |
CWP_COPY_ORIGINAL_TYPE |
LOAD_USAGE_NAME |
LOAD_COMBINATION_STATE |
STAIRS_PARAMS_TITLE |
CURVE_PARAMS_TITLE |
DEFAULT_PARAMS_TITLE |
PARAMS_TITLE_FIRST |
RAMP_ATTR_TEXT_SIZE |
RAMP_ATTR_TEXT_FONT |
RAMP_ATTR_MATERIAL |
RAMP_ATTR_RIGHT_BALUSTER_ATTACH_PT |
RAMP_ATTR_LEFT_BALUSTER_ATTACH_PT |
RAMP_ATTR_SHAPE |
RAMP_ATTR_THICKNESS |
RAMP_MAX_RUN_LENGTH |
RAMP_SLOPE |
RAMP_ATTR_MIN_INV_SLOPE |
RAMP_ATTR_WIDTH |
PLAN_VIEW_VIEW_DIR |
POCHE_MAT_ID |
ELEVATN_TAG |
CALLOUT_TAG |
SECTION_TAG |
CALLOUT_SYNCRONIZE_VIEW_DEPTH |
CALLOUT_SYNCRONIZE_BOUND_OFFSET_FAR |
LEADER_LINE_PEN |
CALLOUT_CORNER_SHEET_RADIUS |
CALLOUT_ATTR_HEAD_TAG |
SYMBOL_USER_PARAM_LAST |
SYMBOL_USER_PARAM_FIRST |
ELEMENT_USER_PARAM_LAST |
ELEMENT_USER_PARAM_FIRST |
GRID_BUBBLE_END_2 |
GRID_BUBBLE_END_1 |
DATUM_BUBBLE_LOCATION_IN_ELEV |
DATUM_BUBBLE_END_1 |
DATUM_BUBBLE_END_2 |
DATUM_TEXT |
ELLIPSE_FOCUS_MRK_VISIBLE |
UNBOUND_CURVE_SPLIT_PARAM |
ARC_CURVE_CNTR_MRK_SZ_PARAM |
ARC_CURVE_CNTR_MRK_VISIBLE |
ARC_CURVE_CNTR_MRK_VISIBLE_OBSOLETE |
ARC_WALL_CNTR_MRK_SZ_PARAM |
ARC_WALL_CNTR_MRK_VISIBLE |
REF_TABLE_PARAM_NAME |
REF_TABLE_ELEM_NAME |
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_INST_PARAM |
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_PARAM |
SCHEDULE_EMBEDDED_PARAM |
SCHEDULE_SHEET_APPEARANCE_PARAM |
SCHEDULE_FORMAT_PARAM |
SCHEDULE_GROUP_PARAM |
SCHEDULE_SORT_PARAM |
SCHEDULE_FILTER_PARAM |
SCHEDULE_FIELDS_PARAM |
RASTER_HORIZONTAL_SCALE |
RASTER_VERTICAL_SCALE |
RASTER_SYMBOL_HEIGHT |
RASTER_SYMBOL_WIDTH |
RASTER_SYMBOL_RESOLUTION |
RASTER_SYMBOL_FILENAME |
RASTER_SYMBOL_VIEWNAME |
RASTER_SYMBOL_PIXELHEIGHT |
RASTER_SYMBOL_PIXELWIDTH |
RASTER_MAINTAIN_ASPECT_RATIO |
RASTER_SHEETHEIGHT |
RASTER_SHEETWIDTH |
IMPORT_ADT_ENTITY_ROLL |
IMPORT_ADT_ENTITY_THICKNESS |
IMPORT_ADT_ENTITY_LENGTH |
IMPORT_ADT_ENTITY_WIDTH |
IMPORT_ADT_ENTITY_HEIGHT |
IMPORT_ADT_COMPONENTS_DESC |
IMPORT_ADT_ENTITY_STYLE |
IMPORT_ADT_ENTITY_STRUCT_TYPE |
IMPORT_ADT_ENTITY_TYPE |
RVT_LINK_PHASE_MAP |
RVT_LINK_REFERENCE_TYPE |
RVT_LINK_FILE_NAME_WITHOUT_EXT |
RVT_LEVEL_OFFSET |
RVT_HOST_LEVEL |
RVT_SOURCE_LEVEL |
RVT_LEVEL_MAP |
RVT_LINK_INSTANCE_NAME |
GEO_LOCATION |
IMPORT_INSTANCE_SCALE |
IMPORT_BACKGROUND |
IMPORT_DISPLAY_UNITS |
IMPORT_BASE_LEVEL_OFFSET |
IMPORT_BASE_LEVEL |
IMPORT_SCALE |
IMPORT_SYMBOL_NAME |
ELEV_REFERENCE_LABEL_POS |
ELEV_ASSOC_DATUM |
ELEV_VIEW_NAME_POS |
ELEV_SHOW_VIEW_NAME |
ELEV_TEXT_POS |
ELEV_ARROW_FILLED |
ELEV_ARROW_ANGLE |
ELEV_SHAPE |
ELEV_WIDTH |
COLOR_FILL_SWATCH_HEIGHT_PARAM |
COLOR_FILL_SWATCH_WIDTH_PARAM |
COLOR_FILL_FILTERED_PARAM |
COLOR_FILL_SYMBOL_SIZE_PARAM |
COLOR_FILL_SCHEMA_PARAM |
DETAIL_ARRAY_GROUP_ELEMENT_INST |
DETAIL_ARRAY_GROUP_ELEMENT |
SPACING_ORIENTATION_STEP_ALL |
SPACING_INITIAL_ROTATION |
SPACING_ORIENTATION_STEP2 |
SPACING_ORIENTATION_STEP1_INST |
SHEET_CURRENT_REVISION_DESCRIPTION |
SHEET_REVISIONS_ON_SHEET |
SHEET_CURRENT_REVISION |
SHEET_HEIGHT |
SHEET_WIDTH |
SHEET_FILE_PATH |
SHEET_APPROVED_BY |
SHEET_DESIGNED_BY |
SHEET_SCHEDULED |
SHEET_CHECKED_BY |
SHEET_DRAWN_BY |
SHEET_DATE |
SHEET_SCALE |
SHEET_NUMBER |
SHEET_NAME |
MODEL_ARRAY_GROUP_ELEMENT_INST |
SPACING_APPEND |
SPACING_ORIENTATION_STEP1 |
MODEL_ARRAY_GROUP_ELEMENT |
AUTO_JOIN_CONDITION_WALL |
AUTO_MULLION_BORDER2_HORIZ |
AUTO_MULLION_BORDER1_HORIZ |
AUTO_MULLION_BORDER2_VERT |
AUTO_MULLION_BORDER1_VERT |
AUTO_MULLION_INTERIOR_HORIZ |
AUTO_MULLION_INTERIOR_VERT |
AUTO_PANEL_WALL |
AUTO_JOIN_CONDITION |
AUTO_PANEL |
AUTO_MULLION_BORDER2_GRID2 |
AUTO_MULLION_BORDER1_GRID2 |
AUTO_MULLION_BORDER2_GRID1 |
AUTO_MULLION_BORDER1_GRID1 |
AUTO_MULLION_INTERIOR_GRID2 |
AUTO_MULLION_INTERIOR_GRID1 |
CURTAIN_GRID_BASE_ORIENTATION |
MULLION_ANGLE |
MULLION_POSITION |
MULLION_PROFILE |
MAXIMUM_MULLION_LENGTH |
TRAP_MULL_WIDTH |
MULLION_DEPTH2 |
MULLION_DEPTH1 |
MULLION_DEPTH |
LV_MULLION_LEG2 |
LV_MULLION_LEG1 |
MULLION_CORNER_TYPE |
MULLION_FAM_TYPE |
MULLION_OFFSET |
CIRC_MULLION_RADIUS |
CUST_MULLION_THICK |
CUST_MULLION_WIDTH2 |
CUST_MULLION_WIDTH1 |
RECT_MULLION_THICK |
RECT_MULLION_BACK |
RECT_MULLION_FRONT |
RECT_MULLION_WIDTH2 |
RECT_MULLION_WIDTH1 |
STAIRS_RAILINGS_TYPE_NONE |
STAIRS_RAILINGS_TYPE_SYSTEM_DEFAULT |
STAIRS_INST_ALWAYS_UP |
STAIRS_ATTR_TRIM_TOP |
STAIRS_INST_DOWN_ARROW_ON |
STAIRS_INST_DOWN_LABEL_TEXT |
STAIRS_INST_DOWN_LABEL_ON |
STAIRS_INST_UP_ARROW_ON |
STAIRS_INST_UP_LABEL_TEXT |
STAIRS_INST_UP_LABEL_ON |
STAIRS_ATTR_TEXT_SIZE |
STAIRS_ATTR_TEXT_FONT |
STAIRS_ATTR_BODY_MATERIAL |
STAIRS_ATTR_LANDING_CARRIAGE |
STAIRS_ATTR_LANDINGS_OVERLAPPING |
STAIRS_ATTR_RIGHT_SIDE_STRINGER |
STAIRS_ATTR_LEFT_SIDE_STRINGER |
STAIRS_ATTR_NOSING_PLACEMENT |
STAIRS_ATTR_RISER_TREAD_CONNECT |
STAIRS_ATTR_RISER_THICKNESS |
STAIRS_ATTR_NUM_MID_STRINGERS |
STAIRS_ATTR_STAIRS_CUT_OFFSET |
UNIFORMAT_CODE |
CONTOUR_HEIGHT |
SLOPE_END_HEIGHT |
SLOPE_START_HEIGHT |
CEILING_HAS_THICKNESS_PARAM |
CEILING_THICKNESS_PARAM |
CEILING_HEIGHTABOVELEVEL_PARAM |
CEILING_THICKNESS |
CEILING_ATTR_COST_PARAM |
CEILING_ATTR_SYSTEMNAME_PARAM |
CEILING_ATTR_SPACING2_PARAM |
CEILING_ATTR_SPACING1_PARAM |
CEILING_ATTR_PATTERN_PARAM |
CEILING_ATTR_DEFAULT_HEIGHT_PARAM |
ANY_PATTERN_ID_PARAM_NO_NO |
FILL_PATTERN_ID_PARAM_NO_NO |
OBJECT_STYLE_MATERIAL_ID_PARAM |
WRAPPING_AT_INSERTS_PARAM |
WRAPPING_AT_ENDS_PARAM |
COARSE_SCALE_FILL_PATTERN_COLOR |
MODEL_CATEGORY_ID_PARAM |
HOST_ID_PARAM |
MATERIAL_ID_PARAM |
COARSE_SCALE_FILL_PATTERN_ID_PARAM |
ANY_PATTERN_ID_PARAM |
FILL_PATTERN_TYPE_PARAM |
WALL_STRUCTURE_ID_PARAM |
SURFACE_PATTERN_ID_PARAM |
FILL_PATTERN_ID_PARAM |
ID_PARAM |
ELEM_FAMILY_AND_TYPE_NAMES_PARAM |
ELEM_FAMILY_NAME_PARAM |
ELEM_TYPE_NAME_PARAM |
SCHEDULE_ROOM_PHASE_PARAM |
EDITED_BY |
SCHEDULE_TOP_LEVEL_OFFSET_PARAM |
SCHEDULE_BASE_LEVEL_OFFSET_PARAM |
SCHEDULE_TOP_LEVEL_PARAM |
SCHEDULE_BASE_LEVEL_PARAM |
SCHEDULE_LEVEL_PARAM |
ELEM_ROOM_ID |
ELEM_ROOM_NAME |
ELEM_ROOM_NUMBER |
ROOM_PARTITION_PARAM_DISABLED |
ROOM_PARTITION_PARAM |
ROOM_TAG_PARTITION_PARAM_DISABLED |
ROOM_TAG_PARTITION_PARAM |
ELEM_PARTITION_PARAM_DISABLED |
ELEM_PARTITION_PARAM |
ELEM_FAMILY_AND_TYPE_PARAM |
ELEM_FAMILY_PARAM |
ELEM_TYPE_PARAM |
ELEM_TYPE_LABEL |
BR_ORG_FILTER |
BR_ORG_FOLDERS |
ELEM_NAME_READONLY_PARAM |
ELEM_NAME_PARAM |
SYMBOL_FAMILY_AND_TYPE_NAMES_PARAM |
SYMBOL_FAMILY_NAME_PARAM |
SYMBOL_NAME_PARAM |
SYMBOL_ID_PARAM |
FLOOR_PARAM_SPAN_DIRECTION |
FLOOR_PARAM_IS_STRUCTURAL |
HOST_PERIMETER_COMPUTED |
LEVEL_PARAM |
FLOOR_HEIGHTABOVELEVEL_PARAM |
FLOOR_THICKNESS_PARAM |
FLOOR_ATTR_SCALLOP_EDGES_PARAM |
FLOOR_ATTR_DEFAULT_HEIGHT_PARAM |
FLOOR_ATTR_DEFAULT_THICKNESS_PARAM |
FLOOR_ATTR_HEIGHTABOVELEVEL_PARAM |
FLOOR_ATTR_THICKNESS_PARAM |
PROFILE_PARAM_ALONG_PATH |
PROFILE_FAM_TYPE_PLUS_NONE |
PROFILE2_ANGLE |
PROFILE2_FAM_TYPE |
PROFILE2_FLIPPED_HOR |
PROFILE2_OFFSET_Y |
PROFILE2_OFFSET_X |
PROFILE1_ANGLE |
PROFILE1_FAM_TYPE |
PROFILE1_FLIPPED_HOR |
PROFILE1_OFFSET_Y |
PROFILE1_OFFSET_X |
FAM_PROFILE_USAGE |
SWEEP_TRAJ_SEGMENTED |
SWEEP_MAX_SEG_ANGLE |
MODEL_OR_SYMBOLIC |
PROFILE_ANGLE |
PROFILE_FAM_TYPE |
PROFILE_FLIPPED_HOR |
PROFILE_OFFSET_Y |
PROFILE_OFFSET_X |
EXTRUSION_LENGTH |
MATERIAL_OR_PARAM_ID |
ELEMENT_IS_CUTTING_DISABLED |
CURVE_VISIBILITY_PARAM |
GEOM_VISIBILITY_PARAM |
ELEMENT_IS_CUTTING |
EXTRUSION_AUTO_PARAMS |
BLEND_END_PARAM |
BLEND_START_PARAM |
REVOLUTION_END_ANGLE |
REVOLUTION_START_ANGLE |
EXTRUSION_END_PARAM |
EXTRUSION_START_PARAM |
FACEROOF_OFFSET_PARAM |
FACEROOF_LEVEL_PARAM |
ROOF_FACES_LOCATION |
RELATED_TO_MASS |
ROOF_RAFTER_OR_TRUSS_TEXT_PARAM |
FASCIA_DEPTH_PARAM |
ROOF_EAVE_CUT_PARAM |
ROOF_RAFTER_OR_TRUSS_PARAM |
ROOF_BASE_LEVEL_PARAM |
CURVE_WALL_OFFSET_ROOFS |
CURVE_WALL_OFFSET |
ACTUAL_MAX_RIDGE_HEIGHT_PARAM |
ALLOW_MAX_RIDGE_HEIGHT_PARAM |
ROOF_UPTO_LEVEL_OFFSET_PARAM |
ROOF_UPTO_LEVEL_PARAM |
ROOF_LEVEL_OFFSET_PARAM |
ROOF_WIDTH_PARAM |
ROOF_CONSTRAINT_OFFSET_PARAM |
ROOF_CONSTRAINT_LEVEL_PARAM |
HOST_SSE_CURVED_EDGE_CONDITION_PARAM |
ROOF_ATTR_SCALLOP_EDGES_PARAM |
ROOF_ATTR_THICKNESS_PARAM |
ROOF_ATTR_DEFAULT_THICKNESS_PARAM |
CONTINUOUS_FOOTING_BREAK_AT_INSERTS_DISABLE |
CONTINUOUS_FOOTING_DEFAULT_END_EXTENSION_LENGTH |
STRUCTURAL_ANALYTICAL_TESSELLATE |
STRUCTURAL_ANALYTICAL_TESS_DEVIATION |
STRUCTURAL_ANALYTICAL_HARD_POINTS |
STRUCTURAL_BEND_DIR_ANGLE |
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_COLUMN |
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_FRAMING |
STRUCTURAL_ANALYTICAL_SKETCH_XY_AUTODETECT |
STRUCTURAL_ANALYTICAL_AUTODETECT |
STRUCTURAL_CONT_FOOTING_ANALYZES_AS |
STRUCTURAL_FOOTING_ANALYZES_AS |
STRUCTURAL_BRACE_ANALYZES_AS |
STRUCTURAL_BEAM_ANALYZES_AS |
STRUCTURAL_FLOOR_ANALYZES_AS |
STRUCTURAL_ANALYZES_AS |
STRUCTURAL_BEAM_CUTBACK_FOR_COLUMN |
BEAM_V_JUSTIFICATION_OTHER_VALUE |
STRUCTURAL_BEAM_ORIENTATION |
STRUCTURAL_BEAM_END1_ELEVATION |
STRUCTURAL_BEAM_END0_ELEVATION |
FAMILY_EXPORT_AS_GEOMETRY |
STRUCTURAL_FOUNDATION_LENGTH |
STRUCTURAL_FOUNDATION_WIDTH |
CONTINUOUS_FOOTING_LENGTH |
STRUCTURAL_PLATE_CONNECTION |
STRUCTURAL_WELD_CONNECTION |
CONTINUOUS_FOOTING_ECCENTRICITY |
CONTINUOUS_FOOTING_STRUCTURAL_USAGE |
CONTINUOUS_FOOTING_BEARING_WIDTH |
STRUCTURAL_FOOTING_BOTTOM_ELEVATION |
FAMILY_STRUCT_FOOTING_USE_CAP_TOP |
STRUCTURAL_COPING_DISTANCE |
CONTINUOUS_FOOTING_WIDTH |
CONTINUOUS_FOOTING_THICKNESS |
CONTINUOUS_FOOTING_BOTTOM_HEEL |
CONTINUOUS_FOOTING_TOP_HEEL |
CONTINUOUS_FOOTING_BOTTOM_TOE |
CONTINUOUS_FOOTING_TOP_TOE |
STRUCTURAL_ANALYTICAL_MODEL |
STRUCTURAL_ANALYTICAL_RIGID_LINK |
FAMILY_STRUCT_MATERIAL_TYPE |
STRUCTURAL_BOTTOM_RELEASE_MZ |
STRUCTURAL_BOTTOM_RELEASE_MY |
STRUCTURAL_BOTTOM_RELEASE_MX |
STRUCTURAL_BOTTOM_RELEASE_FZ |
STRUCTURAL_BOTTOM_RELEASE_FY |
STRUCTURAL_BOTTOM_RELEASE_FX |
STRUCTURAL_TOP_RELEASE_MZ |
STRUCTURAL_TOP_RELEASE_MY |
STRUCTURAL_TOP_RELEASE_MX |
STRUCTURAL_TOP_RELEASE_FZ |
STRUCTURAL_TOP_RELEASE_FY |
STRUCTURAL_TOP_RELEASE_FX |
STRUCTURAL_BOTTOM_RELEASE_TYPE |
STRUCTURAL_TOP_RELEASE_TYPE |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_TOP |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_WALL_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_WALL_TOP |
STRUCTURAL_MATERIAL_TYPE |
STRUCTURAL_CAMBER |
STRUCTURAL_NUMBER_OF_STUDS |
STRUCTURAL_END_RELEASE_MZ |
STRUCTURAL_END_RELEASE_MY |
STRUCTURAL_END_RELEASE_MX |
STRUCTURAL_END_RELEASE_FZ |
STRUCTURAL_END_RELEASE_FY |
STRUCTURAL_END_RELEASE_FX |
STRUCTURAL_START_RELEASE_MZ |
STRUCTURAL_START_RELEASE_MY |
STRUCTURAL_START_RELEASE_MX |
STRUCTURAL_START_RELEASE_FZ |
STRUCTURAL_START_RELEASE_FY |
STRUCTURAL_START_RELEASE_FX |
STRUCTURAL_END_RELEASE_TYPE |
STRUCTURAL_START_RELEASE_TYPE |
STRUCTURAL_WALL_BOTTOM_PROJECTION_PLANE |
STRUCTURAL_WALL_TOP_PROJECTION_PLANE |
STRUCTURAL_WALL_PROJECTION_SURFACE |
STRUCTURAL_COLUMN_ANALYTICAL_OFFSET |
STRUCTURAL_ANALYTICAL_PROJECT_FLOOR_PLANE |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE |
STRUCTURAL_BRACE_REPRESENTATION |
STRUCTURAL_CONNECTION_TYPE |
STRUCTURAL_MOMENT_CONN_END |
STRUCTURAL_MOMENT_CONN_START |
STRUCTURAL_STICK_SYMBOL_LOCATION |
STRUCTURAL_BEAM_END_SUPPORT |
STRUCTURAL_BEAM_START_SUPPORT |
WINDOW_INSET_PARAM |
WINDOW_TYPE_USER_PARAM_LAST |
WINDOW_TYPE_USER_PARAM_FIRST |
WINDOW_OPERATION_TYPE |
WINDOW_CONSTRUCTION_TYPE |
WINDOW_INSET |
WINDOW_THICKNESS |
WINDOW_WIDTH |
WINDOW_HEIGHT |
WINDOW_TYPE_ID |
WINDOW_DEFAULT_SILL_HEIGHT_PARAM |
WINDOW_OPENING_HEIGHT_PARAM |
WINDOW_JAMB_DEPTH_PARAM |
WINDOW_JAMB_WIDTH_PARAM |
WINDOW_OPENING_WIDTH_PARAM |
STRUCTURAL_ATTACHMENT_END_VALUE_ELEVATION |
STRUCTURAL_ATTACHMENT_START_VALUE_ELEVATION |
STRUCTURAL_ATTACHMENT_END_LEVEL_REFERENCE |
STRUCTURAL_ATTACHMENT_START_LEVEL_REFERENCE |
STRUCTURAL_ATTACHMENT_END_VALUE_RATIO |
STRUCTURAL_ATTACHMENT_START_VALUE_RATIO |
STRUCTURAL_ATTACHMENT_END_REFELEMENT_END |
TYPE_WALL_CLOSURE |
STRUCTURAL_ATTACHMENT_START_REFELEMENT_END |
STRUCTURAL_ATTACHMENT_END_VALUE_DISTANCE |
STRUCTURAL_ATTACHMENT_START_VALUE_DISTANCE |
STRUCTURAL_ATTACHMENT_END_TYPE |
STRUCTURAL_ATTACHMENT_START_TYPE |
STRUCTURAL_FRAME_CUT_LENGTH |
INSTANCE_REFERENCE_LEVEL_PARAM |
INSTANCE_STRUCT_USAGE_TEXT_PARAM |
INSTANCE_STRUCT_USAGE_PARAM |
SKETCH_PLANE_PARAM |
INSTANCE_STRUCT_INSERTION_PARAM |
INSTANCE_STRUCT_SETBACK1_PARAM |
INSTANCE_STRUCT_SETBACK0_PARAM |
INSTANCE_LENGTH_PARAM |
INSTANCE_MOVES_WITH_GRID_PARAM |
INSTANCE_OFFSET_POS_PARAM |
INSTANCE_SCHEDULE_ONLY_LEVEL_PARAM |
INSTANCE_FREE_HOST_OFFSET_PARAM |
INSTANCE_FREE_HOST_PARAM |
INSTANCE_HEAD_HEIGHT_PARAM |
INSTANCE_SILL_HEIGHT_PARAM |
INSTANCE_ELEVATION_PARAM |
FAMILY_TOP_LEVEL_OFFSET_PARAM_DISABLED |
FAMILY_TOP_LEVEL_OFFSET_PARAM |
FAMILY_BASE_LEVEL_OFFSET_PARAM |
TEMP_SCHEDULE_CATEGORY_PARAM |
FAMILY_LEVEL_PARAM_DISABLED |
FAMILY_TOP_LEVEL_PARAM_DISABLED |
FAMILY_BASE_LEVEL_PARAM_DISABLED |
FAMILY_LEVEL_PARAM |
FAMILY_TOP_LEVEL_PARAM |
FAMILY_BASE_LEVEL_PARAM |
FAMILY_RFA_PATH_PSEUDO_PARAM |
FAMILY_CATEGORY_PSEUDO_PARAM |
FAMILY_NAME_PSEUDO_PARAM |
FAMILY_USAGE_PSEUDO_PARAM |
FAMILY_KEYWORD2 |
FAMILY_KEYWORD1 |
FAMILY_CLASS_CODE |
FAMILY_DESCRIPTION |
FAMILY_MANUFACTURER |
FAMILY_WPB_DEFAULT_ELEVATION |
FAMILY_LINE_LENGTH_PARAM |
FAMILY_ROUGH_WIDTH_PARAM |
FAMILY_ROUGH_HEIGHT_PARAM |
FAMILY_WINDOW_INSET_PARAM |
FAMILY_THICKNESS_PARAM |
FAMILY_WIDTH_PARAM |
FAMILY_HEIGHT_PARAM |
DOOR_THICKNESS |
DOOR_WIDTH |
DOOR_HEIGHT |
DOOR_USER_PARAM_LAST |
DOOR_USER_PARAM_FIRST |
DOOR_OPERATION_TYPE |
DOOR_FRAME_MATERIAL |
DOOR_FRAME_TYPE |
DOOR_FINISH |
DOOR_CONSTRUCTION_TYPE |
DOOR_FIRE_RATING |
DOOR_COST |
DOOR_SYMBOL_ID |
DOOR_NUMBER |
DOOR_HEIGHT_PARAM_OBSOLETE |
DOOR_THICKNESS_PARAM_OBSOLETE |
DOOR_WIDTH_PARAM_OBSOLETE |
HOST_PANEL_SCHEDULE_AS_PANEL_PARAM |
WALL_LOCATION_LINE_OFFSET_PARAM |
WALL_KEY_REF_PARAM |
WALL_STRUCTURAL_USAGE_TEXT_PARAM |
MEASURE_FROM_STRUCTURE |
WALL_STRUCTURAL_USAGE_PARAM |
WALL_BOTTOM_IS_ATTACHED |
WALL_TOP_IS_ATTACHED |
CWALL_FAKE_END_PARAM_1 |
CWALL_FAKE_END_PARAM_0 |
WALL_ADDITIONAL_HEIGHT_CONSTRAINT_UPGRADE |
WALL_HEIGHT_CONSTRAINT_UPGRADE |
WALL_BASE_CONSTRAINT_UPGRADE |
WALL_BASE_OFFSET_COMPUTED |
WALL_ADDITIONAL_TOP_REF |
WALL_TOP_OFFSET |
WALL_BASE_OFFSET |
WALL_BASE_CONSTRAINT |
WALL_TYPE_ID |
WALL_USER_HEIGHT_PARAM |
WALL_UP_TO_LEVEL_ID |
WALL_HEIGHT_TYPE |
WALL_BASE_HEIGHT_PARAM |
WALL_HEIGHT_PARAM |
WALL_WIDTH_PARAM |
ALLOW_AUTO_EMBED |
WALL_FLOOR_ATTACHMENT_TYPE |
WALL_ATTR_ROOM_BOUNDING |
WALL_ATTR_EXTERIOR |
WALL_DEF_CNSTR_HEIGHT_TYPE_ALT |
WALL_DEF_CNSTR_HEIGHT_TYPE |
WALL_ATTR_HEIGHT_TYPE |
WALL_ATTR_DEFHEIGHT_PARAM |
WALL_ATTR_HEIGHT_PARAM |
WALL_ATTR_WIDTH_PARAM |
RENDER_STYLE_PARAM |
INVALID |

Remarks

Revit has a large number of built-in parameters. Given the large number of built in parameters please contact Autodesk ADN support for details on a particular parameter. The ID of the parameter can be used to retrieve the specific parameter from an Element, if it exists, by using the Element.Parameter property.

See Also

Autodesk.Revit.Parameters Namespace


BuiltInParameterGroup Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8A924832-4C80-4033-AECA-8F2F448B18AA")]
public enum BuiltInParameterGroup
Visual Basic (Declaration)
<GuidAttribute("8A924832-4C80-4033-AECA-8F2F448B18AA")> _
Public Enumeration BuiltInParameterGroup
Visual C++
[GuidAttribute(L"8A924832-4C80-4033-AECA-8F2F448B18AA")]
public enum class BuiltInParameterGroup

Members

Member name | Description
PG_ANALYSIS_RESULTS |
PG_SLAB_SHAPE_EDIT |
PG_LIGHT_PHOTOMETRICS |
PG_PARQUET |
PG_GREEN_BUILDING |
PG_PROFILE_2 |
PG_PROFILE_1 |
PG_PROFILE |
PG_TRUSS_FAMILY_BOTTOM_CHORD |
PG_TRUSS_FAMILY_TOP_CHORD |
PG_TRUSS_FAMILY_DIAG_WEB |
PG_TRUSS_FAMILY_VERT_WEB |
PG_TITLE |
PG_FIRE_PROTECTION |
PG_ROTATION_ABOUT |
PG_TRANSLATION_IN |
PG_ANALYTICAL_MODEL |
PG_REBAR_ARRAY |
PG_REBAR_SYSTEM_LAYERS |
PG_ORIENTATION |
PG_PATTERN_GRID |
PG_PATTERN_MULLION_2 |
PG_PATTERN_MULLION_HORIZ |
PG_PATTERN_MULLION_1 |
PG_PATTERN_MULLION_VERT |
PG_PATTERN_GRID_2 |
PG_PATTERN_GRID_HORIZ |
PG_PATTERN_GRID_1 |
PG_PATTERN_GRID_VERT |
PG_IFC |
PG_AELECTRICAL |
PG_ENERGY_ANALYSIS |
PG_STRUCTURAL_ANALYSIS |
PG_MECHANICAL_AIRFLOW |
PG_MECHANICAL_LOADS |
PG_ELECTRICAL_LOADS |
PG_ELECTRICAL_LIGHTING |
PG_TEXT |
PG_VIEW_CAMERA |
PG_VIEW_EXTENTS |
PG_PATTERN |
PG_CONSTRAINTS |
PG_PHASING |
PG_MECHANICAL |
PG_STRUCTURAL |
PG_PLUMBING |
PG_ELECTRICAL |
PG_STAIR_STRINGERS |
PG_STAIR_RISERS |
PG_STAIR_TREADS |
PG_MATERIALS |
PG_GRAPHICS |
PG_CONSTRUCTION |
PG_GEOMETRY |
PG_IDENTITY_DATA |
INVALID |

Remarks

Parameter groups are used to sort parameters within the Element Properties dialog.

See Also

Autodesk.Revit.Parameters Namespace


ConstructionType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("BFF6DBF1-36E6-4564-BA35-663D5172AE11")]
public enum ConstructionType
Visual Basic (Declaration)
<GuidAttribute("BFF6DBF1-36E6-4564-BA35-663D5172AE11")> _
Public Enumeration ConstructionType
Visual C++
[GuidAttribute(L"BFF6DBF1-36E6-4564-BA35-663D5172AE11")]
public enum class ConstructionType

Members

Member name | Description
Skylights | Construction Type is Skylights.
InteriorWindows | Construction Type is InteriorWindows.
ExteriorWindows | Construction Type is ExteriorWindows.
Doors | Construction Type is Doors.
Floors | Construction Type is Floors.
Roofs | Construction Type is Roofs.
Slabs | Construction Type is Slabs.
InteriorWalls | Construction Type is InteriorWalls.
ExteriorWalls | Construction Type is ExteriorWalls.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also

Autodesk.Revit.Parameters Namespace


Definition Class
See Also Members
CollapseAll image DropDown image

The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A84A6494-7EC3-4f98-A71A-66833D911B97")]
public abstract class Definition : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A84A6494-7EC3-4f98-A71A-66833D911B97")> _
Public MustInherit Class Definition _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A84A6494-7EC3-4f98-A71A-66833D911B97")]
public ref class Definition abstract : public APIObject

Remarks

This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilise this Definition base class as then the code will be applicable to both internal and external parameter definitions.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::ExternalDefinition
Autodesk.Revit.Parameters..::InternalDefinition

See Also

Definition Members
Autodesk.Revit.Parameters Namespace


Definition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class Definition
Visual Basic (Declaration)
Public MustInherit Class Definition
Visual C++
public ref class Definition abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter.
Public property | ParameterGroup | Returns the group ID of the parameter definition.
Public property | ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition
Autodesk.Revit.Parameters Namespace


Definition Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Definition ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


Definition Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class Definition
Visual Basic (Declaration)
Public MustInherit Class Definition
Visual C++
public ref class Definition abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter.
Public property | ParameterGroup | Returns the group ID of the parameter definition.
Public property | ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition
Autodesk.Revit.Parameters Namespace


Name Property

Definition..::Name Property
CollapseAll image DropDown image

The user visible name for the parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract string Name{ get;}
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () abstract;
}

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


ParameterGroup Property

Definition..::ParameterGroup Property
CollapseAll image DropDown image

Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract BuiltInParameterGroup ParameterGroup{ get;}
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () abstract;
}

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


ParameterType Property

Definition..::ParameterType Property
CollapseAll image DropDown image

Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract ParameterType ParameterType{ get;}
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () abstract;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


DefinitionFile Class
See Also Members
CollapseAll image DropDown image

The DefinitionFile object represents a shared parameters file on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3636DD8B-2285-494f-BEB8-ED88C76AAA15")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DefinitionFile : APIObject
Visual Basic (Declaration)
<GuidAttribute("3636DD8B-2285-494f-BEB8-ED88C76AAA15")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DefinitionFile _
    Inherits APIObject
Visual C++
[GuidAttribute(L"3636DD8B-2285-494f-BEB8-ED88C76AAA15")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DefinitionFile : public APIObject

Remarks

Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Document.OpenSharedParameterFile method.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionFile

See Also

DefinitionFile Members
Autodesk.Revit.Parameters Namespace


DefinitionFile Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionFile
Visual Basic (Declaration)
Public Class DefinitionFile
Visual C++
public ref class DefinitionFile

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionFileDefinitionFileNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile
Autodesk.Revit.Parameters Namespace


DefinitionFile Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionFile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionFile ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


DefinitionFile Methods
CollapseAll image DropDown image

Syntax

C#
public class DefinitionFile
Visual Basic (Declaration)
Public Class DefinitionFile
Visual C++
public ref class DefinitionFile

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionFile
Autodesk.Revit.Parameters Namespace


ReleaseUnmanagedResources Method

DefinitionFile..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


DefinitionFile Properties
CollapseAll image DropDown image

Syntax

C#
public class DefinitionFile
Visual Basic (Declaration)
Public Class DefinitionFile
Visual C++
public ref class DefinitionFile

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile
Autodesk.Revit.Parameters Namespace


Filename Property

DefinitionFile..::Filename Property
CollapseAll image DropDown image

This property returns the physical filename of the shared parameters file on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Filename{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Filename As String
Visual C++
public:
property String^ Filename {
    String^ get ();
}

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


Groups Property

DefinitionFile..::Groups Property
CollapseAll image DropDown image

Return a map of shared parameter definition groups contained within the file.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroups Groups{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Groups As DefinitionGroups
Visual C++
public:
property DefinitionGroups^ Groups {
    DefinitionGroups^ get ();
}

Remarks

A particular group can be found by Name, using the Item property on the DefinitionGroups object. A new group can be created by using the Create method on the DefinitionGroups Object. The Create method takes the name of the new group, as a string, as its input parameter, returning a reference to a new definition group object as its result.

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


DefinitionGroup Class
See Also Members
CollapseAll image DropDown image

The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("37059293-783E-41df-A9DF-5A4B3F87251C")]
public class DefinitionGroup : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("37059293-783E-41df-A9DF-5A4B3F87251C")> _
Public Class DefinitionGroup _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"37059293-783E-41df-A9DF-5A4B3F87251C")]
public ref class DefinitionGroup : public APIObject

Remarks

Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionGroup

See Also

DefinitionGroup Members
Autodesk.Revit.Parameters Namespace


DefinitionGroup Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroup
Visual Basic (Declaration)
Public Class DefinitionGroup
Visual C++
public ref class DefinitionGroup

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionGroupDefinitionGroupNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Returns the name of the parameter group.

See Also

DefinitionGroup
Autodesk.Revit.Parameters Namespace


DefinitionGroup Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroup ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


DefinitionGroup Properties
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroup
Visual Basic (Declaration)
Public Class DefinitionGroup
Visual C++
public ref class DefinitionGroup

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Returns the name of the parameter group.

See Also

DefinitionGroup
Autodesk.Revit.Parameters Namespace


Definitions Property

DefinitionGroup..::Definitions Property
CollapseAll image DropDown image

The Definitions property returns an object that contains all the shared parameter definitions within the group.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definitions Definitions{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Definitions As Definitions
Visual C++
public:
property Definitions^ Definitions {
    Definitions^ get ();
}

Remarks

A known definition can be retrieved, by name, using the Item property on the Definitions object. A new definition can be created by using the Create method. The Create method takes two parameters, a string for name and a type. If the creation of the definition was successful then an object representing the definition is returned by the Create method.

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


Name Property

DefinitionGroup..::Name Property
CollapseAll image DropDown image

Returns the name of the parameter group.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


DefinitionGroups Class
See Also Members
CollapseAll image DropDown image

A specialised set of definition groups that allows creation of new groups.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4C9E7357-F306-43a0-8FAA-3244EFB6C6A8")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DefinitionGroups : DefinitionGroupsBase
Visual Basic (Declaration)
<GuidAttribute("4C9E7357-F306-43a0-8FAA-3244EFB6C6A8")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DefinitionGroups _
    Inherits DefinitionGroupsBase
Visual C++
[GuidAttribute(L"4C9E7357-F306-43a0-8FAA-3244EFB6C6A8")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DefinitionGroups : public DefinitionGroupsBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionGroupsBase
Autodesk.Revit.Parameters..::DefinitionGroups

See Also

DefinitionGroups Members
Autodesk.Revit.Parameters Namespace


DefinitionGroups Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroups
Visual Basic (Declaration)
Public Class DefinitionGroups
Visual C++
public ref class DefinitionGroups

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionGroupsDefinitionGroupsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Public method | Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionGroupsBase ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionGroupsBase.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from DefinitionGroupsBase.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Retrieve a definition group by name.
Public property | Size | Returns the number of definition groups that are in the set. (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups
Autodesk.Revit.Parameters Namespace


DefinitionGroups Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroups()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroups ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


DefinitionGroups Methods
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroups
Visual Basic (Declaration)
Public Class DefinitionGroups
Visual C++
public ref class DefinitionGroups

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Public method | Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionGroupsBase ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups
Autodesk.Revit.Parameters Namespace


Create Method

DefinitionGroups..::Create Method
CollapseAll image DropDown image

Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroup Create(
    string name
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String _
) As DefinitionGroup
Visual C++
public:
DefinitionGroup^ Create (
    String^ name
)

Parameters

name
String
The name of the group to be created.

Return Value

If successful a reference to the new parameter group is returned, otherwise Nothing.

Remarks

If a group with the same name already exists then an exception will be thrown.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


Dispose Method

DefinitionGroups..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


DefinitionGroups Properties
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroups
Visual Basic (Declaration)
Public Class DefinitionGroups
Visual C++
public ref class DefinitionGroups

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from DefinitionGroupsBase.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Retrieve a definition group by name.
Public property | Size | Returns the number of definition groups that are in the set. (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups
Autodesk.Revit.Parameters Namespace


Item Property

DefinitionGroups..::Item Property
CollapseAll image DropDown image

Retrieve a definition group by name.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroup Item[
    string groupName
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    groupName As String _
) As DefinitionGroup
Visual C++
public:
property DefinitionGroup^ Item[String^ groupName] {
    DefinitionGroup^ get (String^ groupName);
}

Parameters

groupName
String
The name of the group for which to search.

Remarks

If the group is not found then Nothing will be returned.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Class
See Also Members
CollapseAll image DropDown image

A set that contains definition groups.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0183E075-FE77-488f-BDC5-36E72E446D3E")]
public class DefinitionGroupsBase : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0183E075-FE77-488f-BDC5-36E72E446D3E")> _
Public Class DefinitionGroupsBase _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0183E075-FE77-488f-BDC5-36E72E446D3E")]
public ref class DefinitionGroupsBase : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionGroupsBase
Autodesk.Revit.Parameters..::DefinitionGroups

See Also

DefinitionGroupsBase Members
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroupsBase
Visual Basic (Declaration)
Public Class DefinitionGroupsBase
Visual C++
public ref class DefinitionGroupsBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionGroupsBaseDefinitionGroupsBaseNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every definition group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a definition group within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroupsBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroupsBase ()

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Methods
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroupsBase
Visual Basic (Declaration)
Public Class DefinitionGroupsBase
Visual C++
public ref class DefinitionGroupsBase

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a definition group within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionGroupsBase
Autodesk.Revit.Parameters Namespace


Clear Method

DefinitionGroupsBase..::Clear Method
CollapseAll image DropDown image

Removes every definition group from the set, rendering it empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


Contains Method

DefinitionGroupsBase..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a definition group within the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    DefinitionGroup item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DefinitionGroup _
) As Boolean
Visual C++
public:
virtual bool Contains (
    DefinitionGroup^ item
)

Parameters

item
DefinitionGroup
The definition group to be searched for.

Return Value

The Contains method returns True if the definition group is within the set, otherwise False.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


Dispose Method

DefinitionGroupsBase..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


ForwardIterator Method

DefinitionGroupsBase..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DefinitionGroupsBaseIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionGroupsBaseIterator
Visual C++
public:
virtual DefinitionGroupsBaseIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


GetEnumerator Method

DefinitionGroupsBase..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


ReleaseUnmanagedResources Method

DefinitionGroupsBase..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


ReverseIterator Method

DefinitionGroupsBase..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DefinitionGroupsBaseIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionGroupsBaseIterator
Visual C++
public:
virtual DefinitionGroupsBaseIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Properties
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroupsBase
Visual Basic (Declaration)
Public Class DefinitionGroupsBase
Visual C++
public ref class DefinitionGroupsBase

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase
Autodesk.Revit.Parameters Namespace


IsEmpty Property

DefinitionGroupsBase..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


Size Property

DefinitionGroupsBase..::Size Property
CollapseAll image DropDown image

Returns the number of definition groups that are in the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a definition group set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A8807478-E1D0-4715-9C58-9BD08BA8210E")]
public abstract class DefinitionGroupsBaseIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A8807478-E1D0-4715-9C58-9BD08BA8210E")> _
Public MustInherit Class DefinitionGroupsBaseIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A8807478-E1D0-4715-9C58-9BD08BA8210E")]
public ref class DefinitionGroupsBaseIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionGroupsBaseIterator

See Also

DefinitionGroupsBaseIterator Members
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionGroupsBaseIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionGroupsBaseIterator
Visual C++
public ref class DefinitionGroupsBaseIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionGroupsBaseIteratorDefinitionGroupsBaseIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionGroupsBaseIterator
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroupsBaseIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroupsBaseIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionGroupsBaseIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionGroupsBaseIterator
Visual C++
public ref class DefinitionGroupsBaseIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionGroupsBaseIterator
Autodesk.Revit.Parameters Namespace


Dispose Method

DefinitionGroupsBaseIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


MoveNext Method

DefinitionGroupsBaseIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


ReleaseUnmanagedResources Method

DefinitionGroupsBaseIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Reset Method

DefinitionGroupsBaseIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionGroupsBaseIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionGroupsBaseIterator
Visual C++
public ref class DefinitionGroupsBaseIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionGroupsBaseIterator
Autodesk.Revit.Parameters Namespace


Current Property

DefinitionGroupsBaseIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Definitions Class
See Also Members
CollapseAll image DropDown image

A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E43291AE-0C84-4d04-A701-77F5B7DEB5FA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Definitions : DefinitionsBase
Visual Basic (Declaration)
<GuidAttribute("E43291AE-0C84-4d04-A701-77F5B7DEB5FA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Definitions _
    Inherits DefinitionsBase
Visual C++
[GuidAttribute(L"E43291AE-0C84-4d04-A701-77F5B7DEB5FA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Definitions : public DefinitionsBase

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions
Autodesk.Revit.Parameters..::ExternalDefinitions
Autodesk.Revit.Parameters..::InternalDefinitions

See Also

Definitions Members
Autodesk.Revit.Parameters Namespace


Definitions Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Definitions
Visual Basic (Declaration)
Public Class Definitions
Visual C++
public ref class Definitions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionsDefinitionsNew | Construct an empty set of parameter definitions.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Public method | Create | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionsBase ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionsBase.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Retrieve a definition by a given name.
Public property | Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

Definitions
Autodesk.Revit.Parameters Namespace


Definitions Constructor
CollapseAll image DropDown image

Construct an empty set of parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Definitions ()

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Definitions Methods
CollapseAll image DropDown image

Syntax

C#
public class Definitions
Visual Basic (Declaration)
Public Class Definitions
Visual C++
public ref class Definitions

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Public method | Create | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionsBase ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionsBase.)

See Also

Definitions
Autodesk.Revit.Parameters Namespace


Create Method

Definitions..::Create Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Create(String, ParameterType) | Create a new parameter definition using name, type and visibility. Can not be used to create list parameters
Public method | Create(String, ParameterType, Boolean) | Create a new user visible parameter definition using name and type. Can not be used to create list parameters

See Also

Definitions Class
Definitions Members
Autodesk.Revit.Parameters Namespace


Create Method (String, ParameterType)

Definitions..::Create Method (String, ParameterType)
See Also
CollapseAll image DropDown image

Create a new parameter definition using name, type and visibility. Can not be used to create list parameters

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definition Create(
    string name,
    ParameterType type
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType _
) As Definition
Visual C++
public:
Definition^ Create (
    String^ name,
    ParameterType type
)

Parameters

name
String
The name of the parameter definition to be created.
type
ParameterType
The name of the parameter type for the new definition.

Return Value

If successful a reference to the new parameter definition is returned, otherwise Nothing.

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Create Method (String, ParameterType, Boolean)

Definitions..::Create Method (String, ParameterType, Boolean)
See Also
CollapseAll image DropDown image

Create a new user visible parameter definition using name and type. Can not be used to create list parameters

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definition Create(
    string name,
    ParameterType type,
    bool visible
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType, _
    visible As Boolean _
) As Definition
Visual C++
public:
Definition^ Create (
    String^ name,
    ParameterType type,
    bool visible
)

Parameters

name
String
The name of the parameter definition to be created.
type
ParameterType
The name of the parameter type for the new definition.
visible
Boolean

Return Value

If successful a reference to the new parameter definition is returned, otherwise Nothing.

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Dispose Method

Definitions..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Definitions Properties
CollapseAll image DropDown image

Syntax

C#
public class Definitions
Visual Basic (Declaration)
Public Class Definitions
Visual C++
public ref class Definitions

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Retrieve a definition by a given name.
Public property | Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

Definitions
Autodesk.Revit.Parameters Namespace


Item Property

Definitions..::Item Property
CollapseAll image DropDown image

Retrieve a definition by a given name.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definition Item[
    string name
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    name As String _
) As Definition
Visual C++
public:
property Definition^ Item[String^ name] {
    Definition^ get (String^ name);
}

Parameters

name
String
The name of the parameter definition for which to search.

Remarks

If the definition is not found then Nothing will be returned.

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


DefinitionsBase Class
See Also Members
CollapseAll image DropDown image

A set that contains definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4415E971-CC60-4ae4-B1D2-77ADFABA279C")]
public class DefinitionsBase : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4415E971-CC60-4ae4-B1D2-77ADFABA279C")> _
Public Class DefinitionsBase _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4415E971-CC60-4ae4-B1D2-77ADFABA279C")]
public ref class DefinitionsBase : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions

See Also

DefinitionsBase Members
Autodesk.Revit.Parameters Namespace


DefinitionsBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionsBase
Visual Basic (Declaration)
Public Class DefinitionsBase
Visual C++
public ref class DefinitionsBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionsBaseDefinitionsBaseNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty.
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase
Autodesk.Revit.Parameters Namespace


DefinitionsBase Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionsBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionsBase ()

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionsBase Methods
CollapseAll image DropDown image

Syntax

C#
public class DefinitionsBase
Visual Basic (Declaration)
Public Class DefinitionsBase
Visual C++
public ref class DefinitionsBase

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty.
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionsBase
Autodesk.Revit.Parameters Namespace


Clear Method

DefinitionsBase..::Clear Method
CollapseAll image DropDown image

Removes every definition from the set, rendering it empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Contains Method

DefinitionsBase..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a definition within the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Definition^ item
)

Parameters

item
Definition
The definition to be searched for.

Return Value

The Contains method returns True if the definition is within the set, otherwise False.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Dispose Method

DefinitionsBase..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Erase Method

DefinitionsBase..::Erase Method
CollapseAll image DropDown image

Removes a specified definition from the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Definition _
) As Integer
Visual C++
public:
virtual int Erase (
    Definition^ item
)

Parameters

item
Definition
The definition to be erased.

Return Value

The number of definitions that were erased from the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


ForwardIterator Method

DefinitionsBase..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DefinitionsBaseIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionsBaseIterator
Visual C++
public:
virtual DefinitionsBaseIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


GetEnumerator Method

DefinitionsBase..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Insert Method

DefinitionsBase..::Insert Method
CollapseAll image DropDown image

Insert the specified definition into the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Definition _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Definition^ item
)

Parameters

item
Definition
The definition to be inserted into the set.

Return Value

Returns whether the definition was inserted into the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


ReleaseUnmanagedResources Method

DefinitionsBase..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


ReverseIterator Method

DefinitionsBase..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DefinitionsBaseIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionsBaseIterator
Visual C++
public:
virtual DefinitionsBaseIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionsBase Properties
CollapseAll image DropDown image

Syntax

C#
public class DefinitionsBase
Visual Basic (Declaration)
Public Class DefinitionsBase
Visual C++
public ref class DefinitionsBase

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase
Autodesk.Revit.Parameters Namespace


IsEmpty Property

DefinitionsBase..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Size Property

DefinitionsBase..::Size Property
CollapseAll image DropDown image

Returns the number of definitions that are in the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a definition set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("14B695FD-B958-4378-8D93-C5E09826DADB")]
public abstract class DefinitionsBaseIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("14B695FD-B958-4378-8D93-C5E09826DADB")> _
Public MustInherit Class DefinitionsBaseIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"14B695FD-B958-4378-8D93-C5E09826DADB")]
public ref class DefinitionsBaseIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBaseIterator

See Also

DefinitionsBaseIterator Members
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionsBaseIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionsBaseIterator
Visual C++
public ref class DefinitionsBaseIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionsBaseIteratorDefinitionsBaseIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionsBaseIterator
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionsBaseIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionsBaseIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionsBaseIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionsBaseIterator
Visual C++
public ref class DefinitionsBaseIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionsBaseIterator
Autodesk.Revit.Parameters Namespace


Dispose Method

DefinitionsBaseIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


MoveNext Method

DefinitionsBaseIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


ReleaseUnmanagedResources Method

DefinitionsBaseIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Reset Method

DefinitionsBaseIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionsBaseIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionsBaseIterator
Visual C++
public ref class DefinitionsBaseIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionsBaseIterator
Autodesk.Revit.Parameters Namespace


Current Property

DefinitionsBaseIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


ElementBinding Class
See Also Members
CollapseAll image DropDown image

A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AD24CAA2-FBE7-42b5-8C4B-E75AADF9C88D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ElementBinding : Binding
Visual Basic (Declaration)
<GuidAttribute("AD24CAA2-FBE7-42b5-8C4B-E75AADF9C88D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
[GuidAttribute(L"AD24CAA2-FBE7-42b5-8C4B-E75AADF9C88D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding
Autodesk.Revit.Parameters..::InstanceBinding
Autodesk.Revit.Parameters..::TypeBinding

See Also

ElementBinding Members
Autodesk.Revit.Parameters Namespace


ElementBinding Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementBinding
Visual Basic (Declaration)
Public MustInherit Class ElementBinding
Visual C++
public ref class ElementBinding abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementBindingElementBindingNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding
Autodesk.Revit.Parameters Namespace


ElementBinding Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementBinding ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementBinding Class
Autodesk.Revit.Parameters Namespace


ElementBinding Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ElementBinding
Visual Basic (Declaration)
Public MustInherit Class ElementBinding
Visual C++
public ref class ElementBinding abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding
Autodesk.Revit.Parameters Namespace


Categories Property

ElementBinding..::Categories Property
CollapseAll image DropDown image

Retrieve or set the categories to which a parameter definition will be bound.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategorySet Categories{ get; set;}
Visual Basic (Declaration)
Public Property Categories As CategorySet
Visual C++
public:
property CategorySet^ Categories {
    CategorySet^ get ();
    void set (CategorySet^ value);
}

Remarks

The Categories property is used to set the categories to which the definition will be bound when it is added to the document bindings. This property can also be read from existing bindings to interrogate to which categories a parameter has been bound.

See Also

ElementBinding Class
Autodesk.Revit.Parameters Namespace


ExternalDefinition Class
See Also Members
CollapseAll image DropDown image

The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("27835C94-19F1-4cf6-B627-E2C3B5A13A3F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ExternalDefinition : Definition
Visual Basic (Declaration)
<GuidAttribute("27835C94-19F1-4cf6-B627-E2C3B5A13A3F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ExternalDefinition _
    Inherits Definition
Visual C++
[GuidAttribute(L"27835C94-19F1-4cf6-B627-E2C3B5A13A3F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ExternalDefinition : public Definition

Remarks

The ExternalDefinition object is derived from the Definition object and therefore supports all the properties and methods of that object. The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Document.OpenSharedParameterFile method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::ExternalDefinition

See Also

ExternalDefinition Members
Autodesk.Revit.Parameters Namespace


ExternalDefinition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ExternalDefinition
Visual Basic (Declaration)
Public Class ExternalDefinition
Visual C++
public ref class ExternalDefinition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExternalDefinitionExternalDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter. (Overrides Definition ..:: Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition ..:: ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition ..:: ParameterType.)
Public property | Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

See Also

ExternalDefinition
Autodesk.Revit.Parameters Namespace


ExternalDefinition Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExternalDefinition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalDefinition ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ExternalDefinition Methods
CollapseAll image DropDown image

Syntax

C#
public class ExternalDefinition
Visual Basic (Declaration)
Public Class ExternalDefinition
Visual C++
public ref class ExternalDefinition

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

ExternalDefinition
Autodesk.Revit.Parameters Namespace


Dispose Method

ExternalDefinition..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ExternalDefinition Properties
CollapseAll image DropDown image

Syntax

C#
public class ExternalDefinition
Visual Basic (Declaration)
Public Class ExternalDefinition
Visual C++
public ref class ExternalDefinition

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter. (Overrides Definition ..:: Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition ..:: ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition ..:: ParameterType.)
Public property | Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

See Also

ExternalDefinition
Autodesk.Revit.Parameters Namespace


GUID Property

ExternalDefinition..::GUID Property
CollapseAll image DropDown image

Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Guid GUID{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property GUID As Guid
Visual C++
public:
virtual property Guid GUID {
    Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


Name Property

ExternalDefinition..::Name Property
CollapseAll image DropDown image

The user visible name for the parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


OwnerGroup Property

ExternalDefinition..::OwnerGroup Property
CollapseAll image DropDown image

Returns or change the group ID of the external parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DefinitionGroup OwnerGroup{ get; set;}
Visual Basic (Declaration)
Public Overridable Property OwnerGroup As DefinitionGroup
Visual C++
public:
virtual property DefinitionGroup^ OwnerGroup {
    DefinitionGroup^ get ();
    void set (DefinitionGroup^ value);
}

Remarks

If failed When set the group, a InvalidOperationException will be throwed.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterGroup Property

ExternalDefinition..::ParameterGroup Property
CollapseAll image DropDown image

Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override BuiltInParameterGroup ParameterGroup{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterType Property

ExternalDefinition..::ParameterType Property
CollapseAll image DropDown image

Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override ParameterType ParameterType{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


Visible Property

ExternalDefinition..::Visible Property
CollapseAll image DropDown image

Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Visible{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get ();
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Class
See Also Members
CollapseAll image DropDown image

Supports the creation of new shared parameters definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9D79DF27-F49E-497e-A3EF-D27CFAFB85BB")]
public class ExternalDefinitions : Definitions
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9D79DF27-F49E-497e-A3EF-D27CFAFB85BB")> _
Public Class ExternalDefinitions _
    Inherits Definitions
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9D79DF27-F49E-497e-A3EF-D27CFAFB85BB")]
public ref class ExternalDefinitions : public Definitions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions
Autodesk.Revit.Parameters..::ExternalDefinitions

See Also

ExternalDefinitions Members
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ExternalDefinitions
Visual Basic (Declaration)
Public Class ExternalDefinitions
Visual C++
public ref class ExternalDefinitions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExternalDefinitionsExternalDefinitionsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Public method | Create | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Definitions ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionsBase.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Public property | Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

ExternalDefinitions
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExternalDefinitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalDefinitions ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalDefinitions Class
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Methods
CollapseAll image DropDown image

Syntax

C#
public class ExternalDefinitions
Visual Basic (Declaration)
Public Class ExternalDefinitions
Visual C++
public ref class ExternalDefinitions

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Public method | Create | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Definitions ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionsBase.)

See Also

ExternalDefinitions
Autodesk.Revit.Parameters Namespace


Create Method

ExternalDefinitions..::Create Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Create(String, ParameterType) | Create a new parameter definition using name, type and visibility. Can not be used to create list parameters (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Create a new user visible parameter definition using name and type. Can not be used to create list parameters (Inherited from Definitions.)

See Also

ExternalDefinitions Class
ExternalDefinitions Members
Autodesk.Revit.Parameters Namespace


Dispose Method

ExternalDefinitions..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ExternalDefinitions Class
Autodesk.Revit.Parameters Namespace


InstanceBinding Class
See Also Members
CollapseAll image DropDown image

The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BE524CB5-D553-4948-A0FC-3402347230D8")]
public class InstanceBinding : ElementBinding
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BE524CB5-D553-4948-A0FC-3402347230D8")> _
Public Class InstanceBinding _
    Inherits ElementBinding
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BE524CB5-D553-4948-A0FC-3402347230D8")]
public ref class InstanceBinding : public ElementBinding

Remarks

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding
Autodesk.Revit.Parameters..::InstanceBinding

See Also

InstanceBinding Members
Autodesk.Revit.Parameters Namespace


InstanceBinding Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InstanceBinding
Visual Basic (Declaration)
Public Class InstanceBinding
Visual C++
public ref class InstanceBinding

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceBindingInstanceBindingNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding
Autodesk.Revit.Parameters Namespace


InstanceBinding Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | InstanceBindingInstanceBindingNew()() | Constructs an empty instance binding.
Public method | InstanceBindingInstanceBindingNew(CategorySet) | Constructs an instance binding with the set of categories passed.

See Also

InstanceBinding Class
InstanceBinding Members
Autodesk.Revit.Parameters Namespace


InstanceBinding Constructor
CollapseAll image DropDown image

Constructs an empty instance binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceBinding ()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

InstanceBinding Class
Autodesk.Revit.Parameters Namespace


InstanceBinding Constructor (CategorySet)
CollapseAll image DropDown image

Constructs an instance binding with the set of categories passed.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceBinding(
    CategorySet categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
InstanceBinding (
    CategorySet^ categories
)

Parameters

categories
CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

InstanceBinding Class
Autodesk.Revit.Parameters Namespace


InternalDefinition Class
See Also Members
CollapseAll image DropDown image

This object represent a parameter definition built into Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B9AE8360-F20B-4b21-B6FE-F8B31FE2A6B7")]
public class InternalDefinition : Definition
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B9AE8360-F20B-4b21-B6FE-F8B31FE2A6B7")> _
Public Class InternalDefinition _
    Inherits Definition
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B9AE8360-F20B-4b21-B6FE-F8B31FE2A6B7")]
public ref class InternalDefinition : public Definition

Remarks

The InternalDefinition object is derived from the Definition object and hence includes all properties and methods of the Definition object. This object adds no other properties and methods and is used purely for type identification.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::InternalDefinition

See Also

InternalDefinition Members
Autodesk.Revit.Parameters Namespace


InternalDefinition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InternalDefinition
Visual Basic (Declaration)
Public Class InternalDefinition
Visual C++
public ref class InternalDefinition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InternalDefinitionInternalDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter. (Overrides Definition ..:: Name.)
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition ..:: ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition ..:: ParameterType.)

See Also

InternalDefinition
Autodesk.Revit.Parameters Namespace


InternalDefinition Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InternalDefinition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InternalDefinition ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


InternalDefinition Methods
CollapseAll image DropDown image

Syntax

C#
public class InternalDefinition
Visual Basic (Declaration)
Public Class InternalDefinition
Visual C++
public ref class InternalDefinition

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

InternalDefinition
Autodesk.Revit.Parameters Namespace


Dispose Method

InternalDefinition..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


InternalDefinition Properties
CollapseAll image DropDown image

Syntax

C#
public class InternalDefinition
Visual Basic (Declaration)
Public Class InternalDefinition
Visual C++
public ref class InternalDefinition

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter. (Overrides Definition ..:: Name.)
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition ..:: ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition ..:: ParameterType.)

See Also

InternalDefinition
Autodesk.Revit.Parameters Namespace


Name Property

InternalDefinition..::Name Property
CollapseAll image DropDown image

The user visible name for the parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterGroup Property

InternalDefinition..::ParameterGroup Property
CollapseAll image DropDown image

Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override BuiltInParameterGroup ParameterGroup{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterType Property

InternalDefinition..::ParameterType Property
CollapseAll image DropDown image

Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override ParameterType ParameterType{ get;}
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


InternalDefinitions Class
See Also Members
CollapseAll image DropDown image

This object blocks attempts to create new internal definitions as they are not permitted.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("95A83518-5250-4a9b-B879-95DC2E0F0E37")]
public class InternalDefinitions : Definitions
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("95A83518-5250-4a9b-B879-95DC2E0F0E37")> _
Public Class InternalDefinitions _
    Inherits Definitions
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"95A83518-5250-4a9b-B879-95DC2E0F0E37")]
public ref class InternalDefinitions : public Definitions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions
Autodesk.Revit.Parameters..::InternalDefinitions

See Also

InternalDefinitions Members
Autodesk.Revit.Parameters Namespace


InternalDefinitions Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InternalDefinitions
Visual Basic (Declaration)
Public Class InternalDefinitions
Visual C++
public ref class InternalDefinitions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InternalDefinitionsInternalDefinitionsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Public method | Create | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Definitions ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionsBase.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Public property | Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

InternalDefinitions
Autodesk.Revit.Parameters Namespace


InternalDefinitions Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InternalDefinitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InternalDefinitions ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InternalDefinitions Class
Autodesk.Revit.Parameters Namespace


InternalDefinitions Methods
CollapseAll image DropDown image

Syntax

C#
public class InternalDefinitions
Visual Basic (Declaration)
Public Class InternalDefinitions
Visual C++
public ref class InternalDefinitions

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Public method | Create | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Definitions ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionsBase.)

See Also

InternalDefinitions
Autodesk.Revit.Parameters Namespace


Create Method

InternalDefinitions..::Create Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Create(String, ParameterType) | Create a new parameter definition using name, type and visibility. Can not be used to create list parameters (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Create a new user visible parameter definition using name and type. Can not be used to create list parameters (Inherited from Definitions.)

See Also

InternalDefinitions Class
InternalDefinitions Members
Autodesk.Revit.Parameters Namespace


Dispose Method

InternalDefinitions..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

InternalDefinitions Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Class
See Also Members
CollapseAll image DropDown image

Object representing list item of external list parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BD4B7BFE-E9F3-45e6-8659-1B0C08A50DF3")]
public class ParameterListItem : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BD4B7BFE-E9F3-45e6-8659-1B0C08A50DF3")> _
Public Class ParameterListItem _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BD4B7BFE-E9F3-45e6-8659-1B0C08A50DF3")]
public ref class ParameterListItem : public APIObject

Remarks

Usually this includes two properties: item string and item value.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::ParameterListItem

See Also

ParameterListItem Members
Autodesk.Revit.Parameters Namespace


ParameterListItem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ParameterListItem
Visual Basic (Declaration)
Public Class ParameterListItem
Visual C++
public ref class ParameterListItem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterListItemParameterListItemNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | String | Item string.
Public property | Value | Item value.

See Also

ParameterListItem
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ParameterListItemParameterListItemNew()() | For Internal Use Only.
Public method | ParameterListItemParameterListItemNew(String, ElementId) | Creates object with supplied item string and elementid value.
Public method | ParameterListItemParameterListItemNew(String, Double) | Creates object with supplied item string and double value.
Public method | ParameterListItemParameterListItemNew(String, Int32) | Creates object with supplied item string and integer value.
Public method | ParameterListItemParameterListItemNew(String, String) | Creates object with supplied item string and string value.

See Also

ParameterListItem Class
ParameterListItem Members
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterListItem ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, ElementId)
CollapseAll image DropDown image

Creates object with supplied item string and elementid value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItem(
    string itemStr,
    ElementId itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As ElementId _
)
Visual C++
public:
ParameterListItem (
    String^ itemStr,
    ElementId itemValue
)

Parameters

itemStr
String
The item string.
itemValue
ElementId
The item value.

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, Double)
CollapseAll image DropDown image

Creates object with supplied item string and double value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItem(
    string itemStr,
    double itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As Double _
)
Visual C++
public:
ParameterListItem (
    String^ itemStr,
    double itemValue
)

Parameters

itemStr
String
The item string.
itemValue
Double
The item value.

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, Int32)
CollapseAll image DropDown image

Creates object with supplied item string and integer value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItem(
    string itemStr,
    int itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As Integer _
)
Visual C++
public:
ParameterListItem (
    String^ itemStr,
    int itemValue
)

Parameters

itemStr
String
The item string.
itemValue
Int32
The item value.

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, String)
CollapseAll image DropDown image

Creates object with supplied item string and string value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItem(
    string itemStr,
    string itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As String _
)
Visual C++
public:
ParameterListItem (
    String^ itemStr,
    String^ itemValue
)

Parameters

itemStr
String
The item string.
itemValue
String
The item value.

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Properties
CollapseAll image DropDown image

Syntax

C#
public class ParameterListItem
Visual Basic (Declaration)
Public Class ParameterListItem
Visual C++
public ref class ParameterListItem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | String | Item string.
Public property | Value | Item value.

See Also

ParameterListItem
Autodesk.Revit.Parameters Namespace


String Property

ParameterListItem..::String Property
CollapseAll image DropDown image

Item string.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string String{ get; set;}
Visual Basic (Declaration)
Public Property String As String
Visual C++
public:
property String^ String {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


Value Property

ParameterListItem..::Value Property
CollapseAll image DropDown image

Item value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Value{ get; set;}
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B13BEC90-F1AF-4324-98C9-EEDB16208AE2")]
public class ParameterListItemArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B13BEC90-F1AF-4324-98C9-EEDB16208AE2")> _
Public Class ParameterListItemArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B13BEC90-F1AF-4324-98C9-EEDB16208AE2")]
public ref class ParameterListItemArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::ParameterListItemArray

See Also

ParameterListItemArray Members
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ParameterListItemArray
Visual Basic (Declaration)
Public Class ParameterListItemArray
Visual C++
public ref class ParameterListItemArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterListItemArrayParameterListItemArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ParameterListItemArray
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItemArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterListItemArray ()

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Methods
CollapseAll image DropDown image

Syntax

C#
public class ParameterListItemArray
Visual Basic (Declaration)
Public Class ParameterListItemArray
Visual C++
public ref class ParameterListItemArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterListItemArray
Autodesk.Revit.Parameters Namespace


Append Method

ParameterListItemArray..::Append Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    ParameterListItem item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ParameterListItem _
)
Visual C++
public:
virtual void Append (
    ParameterListItem^ item
)

Parameters

item
ParameterListItem

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Clear Method

ParameterListItemArray..::Clear Method
CollapseAll image DropDown image

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Dispose Method

ParameterListItemArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ForwardIterator Method

ParameterListItemArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ParameterListItemArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterListItemArrayIterator
Visual C++
public:
virtual ParameterListItemArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


GetEnumerator Method

ParameterListItemArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Insert Method

ParameterListItemArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    ParameterListItem item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ParameterListItem, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    ParameterListItem^ item,
    int index
)

Parameters

item
ParameterListItem
index
Int32

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ReleaseUnmanagedResources Method

ParameterListItemArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ReverseIterator Method

ParameterListItemArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ParameterListItemArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterListItemArrayIterator
Visual C++
public:
virtual ParameterListItemArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Properties
CollapseAll image DropDown image

Syntax

C#
public class ParameterListItemArray
Visual Basic (Declaration)
Public Class ParameterListItemArray
Visual C++
public ref class ParameterListItemArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ParameterListItemArray
Autodesk.Revit.Parameters Namespace


IsEmpty Property

ParameterListItemArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Item Property

ParameterListItemArray..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ParameterListItem Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ParameterListItem
Visual C++
public:
virtual property ParameterListItem^ Item[int index] {
    ParameterListItem^ get (int index);
    void set (int index, ParameterListItem^ value);
}

Parameters

index
Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Size Property

ParameterListItemArray..::Size Property
CollapseAll image DropDown image

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0ACCAEDF-B814-4e71-97FB-C1C5C14E4DB8")]
public abstract class ParameterListItemArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0ACCAEDF-B814-4e71-97FB-C1C5C14E4DB8")> _
Public MustInherit Class ParameterListItemArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0ACCAEDF-B814-4e71-97FB-C1C5C14E4DB8")]
public ref class ParameterListItemArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::ParameterListItemArrayIterator

See Also

ParameterListItemArrayIterator Members
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterListItemArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterListItemArrayIterator
Visual C++
public ref class ParameterListItemArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterListItemArrayIteratorParameterListItemArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterListItemArrayIterator
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterListItemArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterListItemArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterListItemArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterListItemArrayIterator
Visual C++
public ref class ParameterListItemArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterListItemArrayIterator
Autodesk.Revit.Parameters Namespace


Dispose Method

ParameterListItemArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


MoveNext Method

ParameterListItemArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ReleaseUnmanagedResources Method

ParameterListItemArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


Reset Method

ParameterListItemArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ParameterListItemArrayIterator
Visual Basic (Declaration)
Public MustInherit Class ParameterListItemArrayIterator
Visual C++
public ref class ParameterListItemArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterListItemArrayIterator
Autodesk.Revit.Parameters Namespace


Current Property

ParameterListItemArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ParameterType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the data type interpretation that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4A0E9B72-1CFD-4455-B7C4-4536A6883A22")]
public enum ParameterType
Visual Basic (Declaration)
<GuidAttribute("4A0E9B72-1CFD-4455-B7C4-4536A6883A22")> _
Public Enumeration ParameterType
Visual C++
[GuidAttribute(L"4A0E9B72-1CFD-4455-B7C4-4536A6883A22")]
public enum class ParameterType

Members

Member name | Description
Moment | The data value will be represented as a moment.
AreaForce | The data value will be represented as a area force.
LinearForce | The data value will be represented as a linear force.
Force | The data value will be represented as a force.
YesNo | A boolean value that will be represented as Yes or No.
Material | The value of this property is considered to be a material.
Angle | The parameter data represents an angle. The internal representation will be in radians. The user visible representation will be in the units that the user has chosen.
Volume | The parameter data represents a volume. The internal representation will be in decimal cubic feet. The user visible representation will be in the units that the user has chosen.
Area | The parameter data represents an area. The internal representation will be in decimal square feet. The user visible representation will be in the units that the user has chosen.
Integer | The parameter data should be interpreted as a whole number, positive or negative.
URL | A text string that represents a web address.
Length | The parameter data represents a length. The internal representation will be in decimal feet. The user visible representation will be in the units system that the user has chosen.
Text | The parameter data should be interpreted as a string of text.
Number | The parameter data should be interpreted as a real number, possibly including decimal points.
Invalid | The parameter type is invalid. This value should not be used.

See Also

Autodesk.Revit.Parameters Namespace


ServiceType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("864D707E-C57A-4943-A1C8-1B5CE812A2FD")]
public enum ServiceType
Visual Basic (Declaration)
<GuidAttribute("864D707E-C57A-4943-A1C8-1B5CE812A2FD")> _
Public Enumeration ServiceType
Visual C++
[GuidAttribute(L"864D707E-C57A-4943-A1C8-1B5CE812A2FD")]
public enum class ServiceType

Members

Member name | Description
kSplitSystemsWithMechanicalVentilationWithCooling | Service Type is SplitSystemsWithMechanicalVentilationWithCooling.
kSplitSystemsWithMechanicalVentilation | Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithNaturalVentilation | Service Type is SplitSystemsWithNaturalVentilation.
kVariableRefrigerantFlow | Service Type is VariableRefrigerantFlow.
kWaterLoopHeatPump | Service Type is WaterLoopHeatPump.
kActiveChilledBeams | Service Type is ActiveChilledBeams.
kRadiantCooledCeilings | Service Type is RadiantCooledCeilings.
kConstantVolumeDualDuct | Service Type is ConstantVolumeDualDuct.
kMultizoneHotDeckColdDeck | Service Type is MultizoneHotDeckColdDeck.
kConstantVolumeTerminalReheat | Service Type is ConstantVolumeTerminalReheat.
kConstantVolumeVariableOA | Service Type is ConstantVolumeVariableOA.
kConstantVolumeFixedOA | Service Type is ConstantVolumeFixedOA.
kInductionSystem | Service Type is InductionSystem.
kFanCoilSystem | Service Type is FanCoilSystem.
kVAVIndoorPackagedCabinet | Service Type is VAVIndoorPackagedCabinet.
kVAVDualDuct | Service Type is VAVDualDuct.
kVAVSingleDuct | Service Type is VAVSingleDuct.
kForcedConvectionHeaterNoFlue | Service Type is ForcedConvectionHeaterNoFlue.
kForcedConvectionHeaterFlue | Service Type is ForcedConvectionHeaterFlue.
kRadiantHeaterMultiburner | Service Type is RadiantHeaterMultiburner.
kRadiantHeaterNoFlue | Service Type is RadiantHeaterNoFlue.
kRadiantHeaterFlue | Service Type is RadiantHeaterFlue.
kOtherRoomHeater | Service Type is OtherRoomHeater.
kCentralHeatingHotAir | Service Type is CentralHeatingHotAir.
kCentralHeatingRadiantFloor | Service Type is CentralHeatingRadiantFloor.
kCentralHeatingConvectors | Service Type is CentralHeatingConvectors.
kCentralHeatingRadiators | Service Type is CentralHeatingRadiators.
kNoServiceType | Service Type is NoServiceType.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also

Autodesk.Revit.Parameters Namespace


StorageType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1EC4938F-D42B-4deb-A247-305564CA2087")]
public enum StorageType
Visual Basic (Declaration)
<GuidAttribute("1EC4938F-D42B-4deb-A247-305564CA2087")> _
Public Enumeration StorageType
Visual C++
[GuidAttribute(L"1EC4938F-D42B-4deb-A247-305564CA2087")]
public enum class StorageType

Members

Member name | Description
ElementId | The data type represents an element and is stored as the id of the element.
Integer | The internal data is stored in the form of a signed 32 bit integer.
String | The internal data will be stored in the form of a string of characters.
Double | The data will be stored internaly in the form of an 8 byte floating point number.
None | None represents an invalid storage type. This value should not be used.

See Also

Autodesk.Revit.Parameters Namespace


TypeBinding Class
See Also Members
CollapseAll image DropDown image

TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C45CA703-AEE8-4eea-831A-5FAF9AFEBAE0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class TypeBinding : ElementBinding
Visual Basic (Declaration)
<GuidAttribute("C45CA703-AEE8-4eea-831A-5FAF9AFEBAE0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class TypeBinding _
    Inherits ElementBinding
Visual C++
[GuidAttribute(L"C45CA703-AEE8-4eea-831A-5FAF9AFEBAE0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TypeBinding : public ElementBinding

Remarks

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding
Autodesk.Revit.Parameters..::TypeBinding

See Also

TypeBinding Members
Autodesk.Revit.Parameters Namespace


TypeBinding Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TypeBinding
Visual Basic (Declaration)
Public Class TypeBinding
Visual C++
public ref class TypeBinding

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TypeBindingTypeBindingNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding
Autodesk.Revit.Parameters Namespace


TypeBinding Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | TypeBindingTypeBindingNew()() | Constructs an empty type binding.
Public method | TypeBindingTypeBindingNew(CategorySet) | Constructs a type binding with the set of categories passed.

See Also

TypeBinding Class
TypeBinding Members
Autodesk.Revit.Parameters Namespace


TypeBinding Constructor
CollapseAll image DropDown image

Constructs an empty type binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TypeBinding ()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

TypeBinding Class
Autodesk.Revit.Parameters Namespace


TypeBinding Constructor (CategorySet)
CollapseAll image DropDown image

Constructs a type binding with the set of categories passed.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeBinding(
    CategorySet categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
TypeBinding (
    CategorySet^ categories
)

Parameters

categories
CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

TypeBinding Class
Autodesk.Revit.Parameters Namespace


Autodesk.Revit.Rooms Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Rooms
Visual Basic (Declaration)
Namespace Autodesk.Revit.Rooms
Visual C++
namespace Autodesk.Revit.Rooms

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of a room boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.

Enumerations

 | Enumeration | Description
Public enumeration | BoundaryLocationType | An enumerated type listing the options for volume computation in Autodesk Revit.


BoundaryLocationType Enumeration
CollapseAll image DropDown image

An enumerated type listing the options for volume computation in Autodesk Revit.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D8EDEDB9-A979-48ac-98BE-113C2347818E")]
public enum BoundaryLocationType
Visual Basic (Declaration)
<GuidAttribute("D8EDEDB9-A979-48ac-98BE-113C2347818E")> _
Public Enumeration BoundaryLocationType
Visual C++
[GuidAttribute(L"D8EDEDB9-A979-48ac-98BE-113C2347818E")]
public enum class BoundaryLocationType

Members

Member name | Description
WallCoreCenter | Room area is computed at wall core center.
WallCoreLayer | Room area is computed at wall core layer.
WallCenter | Room area is computed at wall center.
WallFinish | Room area is computed at wall finish.

See Also

Autodesk.Revit.Rooms Namespace


BoundarySegment Class
See Also Members
CollapseAll image DropDown image

An object that represents a segment of a room boundary.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9D84DB94-3EF0-47c9-BD65-5A91BD8FDDB4")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegment : APIObject
Visual Basic (Declaration)
<GuidAttribute("9D84DB94-3EF0-47c9-BD65-5A91BD8FDDB4")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
[GuidAttribute(L"9D84DB94-3EF0-47c9-BD65-5A91BD8FDDB4")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a room. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Rooms Namespace


BoundarySegment Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentBoundarySegmentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this room.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment
Autodesk.Revit.Rooms Namespace


BoundarySegment Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegment ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


BoundarySegment Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegment
Autodesk.Revit.Rooms Namespace


ReleaseUnmanagedResources Method

BoundarySegment..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


BoundarySegment Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this room.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment
Autodesk.Revit.Rooms Namespace


Curve Property

BoundarySegment..::Curve Property
CollapseAll image DropDown image

Get the curve that is formed by the element that defines the edge of this room.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


Document Property

BoundarySegment..::Document Property
CollapseAll image DropDown image

Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document Document{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


Element Property

BoundarySegment..::Element Property
CollapseAll image DropDown image

Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific room.

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segments.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("17C03E49-8B1B-4134-B737-90D37AD03F6C")]
public class BoundarySegmentArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("17C03E49-8B1B-4134-B737-90D37AD03F6C")> _
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"17C03E49-8B1B-4134-B737-90D37AD03F6C")]
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayBoundarySegmentArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray ()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArray
Autodesk.Revit.Rooms Namespace


Append Method

BoundarySegmentArray..::Append Method
CollapseAll image DropDown image

Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append (
    BoundarySegment^ item
)

Parameters

item
BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Clear Method

BoundarySegmentArray..::Clear Method
CollapseAll image DropDown image

Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Dispose Method

BoundarySegmentArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


ForwardIterator Method

BoundarySegmentArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


GetEnumerator Method

BoundarySegmentArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Insert Method

BoundarySegmentArray..::Insert Method
CollapseAll image DropDown image

Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    BoundarySegment^ item,
    int index
)

Parameters

item
BoundarySegment
The boundary segment to be inserted into the array.
index
Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


ReverseIterator Method

BoundarySegmentArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray
Autodesk.Revit.Rooms Namespace


IsEmpty Property

BoundarySegmentArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Item Property

BoundarySegmentArray..::Item Property
CollapseAll image DropDown image

Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegment Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Size Property

BoundarySegmentArray..::Size Property
CollapseAll image DropDown image

Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4AEA5FED-08CE-4e9d-AD23-141B1EDB4B8B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegmentArrayArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("4AEA5FED-08CE-4e9d-AD23-141B1EDB4B8B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"4AEA5FED-08CE-4e9d-AD23-141B1EDB4B8B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayBoundarySegmentArrayArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray ()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Rooms Namespace


Append Method

BoundarySegmentArrayArray..::Append Method
CollapseAll image DropDown image

Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append (
    BoundarySegmentArray^ item
)

Parameters

item
BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Clear Method

BoundarySegmentArrayArray..::Clear Method
CollapseAll image DropDown image

Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Dispose Method

BoundarySegmentArrayArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


ForwardIterator Method

BoundarySegmentArrayArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


GetEnumerator Method

BoundarySegmentArrayArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Insert Method

BoundarySegmentArrayArray..::Insert Method
CollapseAll image DropDown image

Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayArray..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


ReverseIterator Method

BoundarySegmentArrayArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Rooms Namespace


IsEmpty Property

BoundarySegmentArrayArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Item Property

BoundarySegmentArrayArray..::Item Property
CollapseAll image DropDown image

Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Size Property

BoundarySegmentArrayArray..::Size Property
CollapseAll image DropDown image

Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B186FE2D-0865-4bc9-A1E9-853D1346D550")]
public abstract class BoundarySegmentArrayArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B186FE2D-0865-4bc9-A1E9-853D1346D550")> _
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B186FE2D-0865-4bc9-A1E9-853D1346D550")]
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayIteratorBoundarySegmentArrayArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Rooms Namespace


Dispose Method

BoundarySegmentArrayArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


MoveNext Method

BoundarySegmentArrayArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


Reset Method

BoundarySegmentArrayArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Rooms Namespace


Current Property

BoundarySegmentArrayArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F7E829EB-2266-4f0a-9BC5-67554B01C307")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BoundarySegmentArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("F7E829EB-2266-4f0a-9BC5-67554B01C307")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"F7E829EB-2266-4f0a-9BC5-67554B01C307")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayIteratorBoundarySegmentArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Rooms Namespace


Dispose Method

BoundarySegmentArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


MoveNext Method

BoundarySegmentArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


Reset Method

BoundarySegmentArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Rooms Namespace


Current Property

BoundarySegmentArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


Autodesk.Revit.Site Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Site
Visual Basic (Declaration)
Namespace Autodesk.Revit.Site
Visual C++
namespace Autodesk.Revit.Site

Classes

 | Class | Description
Public class | City | An object that contains geographical locational informaiton for a known city.
Public class | CitySet | An set that contains cities.
Public class | CitySetIterator | An iterator to a city set.
Public class | ProjectLocation | An object that contains the offset location from the site location of the project
Public class | ProjectLocationSet | An set that contains project locations.
Public class | ProjectLocationSetIterator | An iterator to a project location set.
Public class | ProjectPosition | An object that is used to represent a geographical offset and rotation
Public class | SiteLocation | Contains the geographical location information for the project's site.


City Class
See Also Members
CollapseAll image DropDown image

An object that contains geographical locational informaiton for a known city.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DCC3B2AB-50B7-4722-B08B-A777F484B76E")]
public class City : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DCC3B2AB-50B7-4722-B08B-A777F484B76E")> _
Public Class City _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DCC3B2AB-50B7-4722-B08B-A777F484B76E")]
public ref class City : public APIObject

Remarks

This object contains longitude, latitude, timezone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::City

See Also

City Members
Autodesk.Revit.Site Namespace


City Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class City
Visual Basic (Declaration)
Public Class City
Visual C++
public ref class City

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CityCityNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | Latitde of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Timezone in which the city resides

See Also

City
Autodesk.Revit.Site Namespace


City Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public City()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
City ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

City Class
Autodesk.Revit.Site Namespace


City Properties
CollapseAll image DropDown image

Syntax

C#
public class City
Visual Basic (Declaration)
Public Class City
Visual C++
public ref class City

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | Latitde of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Timezone in which the city resides

See Also

City
Autodesk.Revit.Site Namespace


Latitude Property

City..::Latitude Property
CollapseAll image DropDown image

Latitde of the city

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Latitude{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
}

Remarks

A read only property that contains the latitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class
Autodesk.Revit.Site Namespace


Longitude Property

City..::Longitude Property
CollapseAll image DropDown image

Longitude of the city

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Longitude{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
}

Remarks

A read only property that contains the longitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class
Autodesk.Revit.Site Namespace


Name Property

City..::Name Property
CollapseAll image DropDown image

The name of the city

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

A read only string property that contains the name of the city, such as Boston.

See Also

City Class
Autodesk.Revit.Site Namespace


TimeZone Property

City..::TimeZone Property
CollapseAll image DropDown image

Timezone in which the city resides

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TimeZone{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

A read only property that returns the time zone in which the city resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

City Class
Autodesk.Revit.Site Namespace


CitySet Class
See Also Members
CollapseAll image DropDown image

An set that contains cities.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7D807CC6-6EA4-465e-9143-3F07D8AE2F6D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CitySet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("7D807CC6-6EA4-465e-9143-3F07D8AE2F6D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CitySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"7D807CC6-6EA4-465e-9143-3F07D8AE2F6D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CitySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::CitySet

See Also

CitySet Members
Autodesk.Revit.Site Namespace


CitySet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CitySet
Visual Basic (Declaration)
Public Class CitySet
Visual C++
public ref class CitySet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CitySetCitySetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of cities that are in the set.

See Also

CitySet
Autodesk.Revit.Site Namespace


CitySet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CitySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CitySet ()

See Also

CitySet Class
Autodesk.Revit.Site Namespace


CitySet Methods
CollapseAll image DropDown image

Syntax

C#
public class CitySet
Visual Basic (Declaration)
Public Class CitySet
Visual C++
public ref class CitySet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CitySet
Autodesk.Revit.Site Namespace


Clear Method

CitySet..::Clear Method
CollapseAll image DropDown image

Removes every city from the set, rendering it empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Contains Method

CitySet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a city within the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Contains (
    City^ item
)

Parameters

item
City
The city to be searched for.

Return Value

The Contains method returns True if the city is within the set, otherwise False.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Dispose Method

CitySet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Erase Method

CitySet..::Erase Method
CollapseAll image DropDown image

Removes a specified city from the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As City _
) As Integer
Visual C++
public:
virtual int Erase (
    City^ item
)

Parameters

item
City
The city to be erased.

Return Value

The number of cities that were erased from the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


ForwardIterator Method

CitySet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CitySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


GetEnumerator Method

CitySet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Insert Method

CitySet..::Insert Method
CollapseAll image DropDown image

Insert the specified city into the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Insert (
    City^ item
)

Parameters

item
City
The city to be inserted into the set.

Return Value

Returns whether the city was inserted into the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


ReleaseUnmanagedResources Method

CitySet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CitySet Class
Autodesk.Revit.Site Namespace


ReverseIterator Method

CitySet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CitySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


CitySet Properties
CollapseAll image DropDown image

Syntax

C#
public class CitySet
Visual Basic (Declaration)
Public Class CitySet
Visual C++
public ref class CitySet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of cities that are in the set.

See Also

CitySet
Autodesk.Revit.Site Namespace


IsEmpty Property

CitySet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Size Property

CitySet..::Size Property
CollapseAll image DropDown image

Returns the number of cities that are in the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CitySet Class
Autodesk.Revit.Site Namespace


CitySetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a city set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7E89D2A3-4953-43c0-B7E3-FD5CC10B282B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class CitySetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("7E89D2A3-4953-43c0-B7E3-FD5CC10B282B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class CitySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"7E89D2A3-4953-43c0-B7E3-FD5CC10B282B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CitySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::CitySetIterator

See Also

CitySetIterator Members
Autodesk.Revit.Site Namespace


CitySetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CitySetIterator
Visual Basic (Declaration)
Public MustInherit Class CitySetIterator
Visual C++
public ref class CitySetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CitySetIteratorCitySetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator
Autodesk.Revit.Site Namespace


CitySetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CitySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CitySetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


CitySetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CitySetIterator
Visual Basic (Declaration)
Public MustInherit Class CitySetIterator
Visual C++
public ref class CitySetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CitySetIterator
Autodesk.Revit.Site Namespace


Dispose Method

CitySetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


MoveNext Method

CitySetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


ReleaseUnmanagedResources Method

CitySetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


Reset Method

CitySetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


CitySetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CitySetIterator
Visual Basic (Declaration)
Public MustInherit Class CitySetIterator
Visual C++
public ref class CitySetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator
Autodesk.Revit.Site Namespace


Current Property

CitySetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


ProjectLocation Class
See Also Members
CollapseAll image DropDown image

An object that contains the offset location from the site location of the project

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CCDC982E-584B-4f9e-89CE-AE27CC5E7455")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ProjectLocation : Instance
Visual Basic (Declaration)
<GuidAttribute("CCDC982E-584B-4f9e-89CE-AE27CC5E7455")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ProjectLocation _
    Inherits Instance
Visual C++
[GuidAttribute(L"CCDC982E-584B-4f9e-89CE-AE27CC5E7455")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ProjectLocation : public Instance

Remarks

An project may have only one site, but the project may be placed at several locations on that site. This is done by have one site location object and several project location objects. The project location object contains an East to West offset, a North to South offset and an angle of rotation from the original site location. Existing project location objects can be found by using the ProjectLocations property on the Document object. New project locations can be created by duplicating and existing project location using the Duplicate method.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Site..::ProjectLocation

See Also

ProjectLocation Members
Autodesk.Revit.Site Namespace


ProjectLocation Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocation
Visual Basic (Declaration)
Public Class ProjectLocation
Visual C++
public ref class ProjectLocation

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectLocationProjectLocationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Project location. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjectPosition | Get or set the project position in relation to the site position
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SiteLocation | Get the site location to which this project location refers.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectLocation
Autodesk.Revit.Site Namespace


ProjectLocation Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocation ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


ProjectLocation Methods
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocation
Visual Basic (Declaration)
Public Class ProjectLocation
Visual C++
public ref class ProjectLocation

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ProjectLocation
Autodesk.Revit.Site Namespace


Duplicate Method

ProjectLocation..::Duplicate Method
CollapseAll image DropDown image

Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocation Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As ProjectLocation
Visual C++
public:
ProjectLocation^ Duplicate (
    String^ name
)

Parameters

name
String
The name to be assigned to the duplicated project location.

Return Value

If successful a duplicate of this project location object with the specified name.

Remarks

The name must not be the same as any existing site location objects.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


ProjectLocation Properties
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocation
Visual Basic (Declaration)
Public Class ProjectLocation
Visual C++
public ref class ProjectLocation

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Project location. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjectPosition | Get or set the project position in relation to the site position
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SiteLocation | Get the site location to which this project location refers.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectLocation
Autodesk.Revit.Site Namespace


Name Property

ProjectLocation..::Name Property
CollapseAll image DropDown image

Get or Set the Name of the Project location.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ get; set;}
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the Project location. It should be unique, otherwise it will throw exception.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


Parameter Property

ProjectLocation..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ProjectLocation Class
ProjectLocation Members
Autodesk.Revit.Site Namespace


ProjectPosition Property

ProjectLocation..::ProjectPosition Property
CollapseAll image DropDown image

Get or set the project position in relation to the site position

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectPosition ProjectPosition[
    XYZ point
]{ get; set;}
Visual Basic (Declaration)
Public Property ProjectPosition ( _
    point As XYZ _
) As ProjectPosition
Visual C++
public:
property ProjectPosition^ ProjectPosition[XYZ^ point] {
    ProjectPosition^ get (XYZ^ point);
    void set (XYZ^ point, ProjectPosition^ value);
}

Parameters

point
XYZ

Remarks

When getting a position the point passed is converted to an East to West, North to South and angle of rotation. When set the passed point becomes the specified East to West, North to South and angle location.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


SiteLocation Property

ProjectLocation..::SiteLocation Property
CollapseAll image DropDown image

Get the site location to which this project location refers.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SiteLocation SiteLocation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SiteLocation As SiteLocation
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The site location object contains the longitude, latitude and timezone of the entire project site.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


ProjectLocationSet Class
See Also Members
CollapseAll image DropDown image

An set that contains project locations.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("364921AE-071B-4d54-B84A-9F98A1163BCB")]
public class ProjectLocationSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("364921AE-071B-4d54-B84A-9F98A1163BCB")> _
Public Class ProjectLocationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"364921AE-071B-4d54-B84A-9F98A1163BCB")]
public ref class ProjectLocationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::ProjectLocationSet

See Also

ProjectLocationSet Members
Autodesk.Revit.Site Namespace


ProjectLocationSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocationSet
Visual Basic (Declaration)
Public Class ProjectLocationSet
Visual C++
public ref class ProjectLocationSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectLocationSetProjectLocationSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet
Autodesk.Revit.Site Namespace


ProjectLocationSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocationSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocationSet ()

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ProjectLocationSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocationSet
Visual Basic (Declaration)
Public Class ProjectLocationSet
Visual C++
public ref class ProjectLocationSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ProjectLocationSet
Autodesk.Revit.Site Namespace


Clear Method

ProjectLocationSet..::Clear Method
CollapseAll image DropDown image

Removes every project location from the set, rendering it empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Contains Method

ProjectLocationSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a project location within the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Contains (
    ProjectLocation^ item
)

Parameters

item
ProjectLocation
The project location to be searched for.

Return Value

The Contains method returns True if the project location is within the set, otherwise False.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Dispose Method

ProjectLocationSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Erase Method

ProjectLocationSet..::Erase Method
CollapseAll image DropDown image

Removes a specified project location from the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ProjectLocation _
) As Integer
Visual C++
public:
virtual int Erase (
    ProjectLocation^ item
)

Parameters

item
ProjectLocation
The project location to be erased.

Return Value

The number of project locations that were erased from the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ForwardIterator Method

ProjectLocationSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ProjectLocationSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


GetEnumerator Method

ProjectLocationSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Insert Method

ProjectLocationSet..::Insert Method
CollapseAll image DropDown image

Insert the specified project location into the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Insert (
    ProjectLocation^ item
)

Parameters

item
ProjectLocation
The project location to be inserted into the set.

Return Value

Returns whether the project location was inserted into the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ReleaseUnmanagedResources Method

ProjectLocationSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ReverseIterator Method

ProjectLocationSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ProjectLocationSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ProjectLocationSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocationSet
Visual Basic (Declaration)
Public Class ProjectLocationSet
Visual C++
public ref class ProjectLocationSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet
Autodesk.Revit.Site Namespace


IsEmpty Property

ProjectLocationSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Size Property

ProjectLocationSet..::Size Property
CollapseAll image DropDown image

Returns the number of project locations that are in the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a project location set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A726DBE6-868F-4491-B528-F7ACF53B8A57")]
public abstract class ProjectLocationSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A726DBE6-868F-4491-B528-F7ACF53B8A57")> _
Public MustInherit Class ProjectLocationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A726DBE6-868F-4491-B528-F7ACF53B8A57")]
public ref class ProjectLocationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::ProjectLocationSetIterator

See Also

ProjectLocationSetIterator Members
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ProjectLocationSetIterator
Visual Basic (Declaration)
Public MustInherit Class ProjectLocationSetIterator
Visual C++
public ref class ProjectLocationSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectLocationSetIteratorProjectLocationSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocationSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocationSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ProjectLocationSetIterator
Visual Basic (Declaration)
Public MustInherit Class ProjectLocationSetIterator
Visual C++
public ref class ProjectLocationSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ProjectLocationSetIterator
Autodesk.Revit.Site Namespace


Dispose Method

ProjectLocationSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


MoveNext Method

ProjectLocationSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ReleaseUnmanagedResources Method

ProjectLocationSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


Reset Method

ProjectLocationSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ProjectLocationSetIterator
Visual Basic (Declaration)
Public MustInherit Class ProjectLocationSetIterator
Visual C++
public ref class ProjectLocationSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator
Autodesk.Revit.Site Namespace


Current Property

ProjectLocationSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ProjectPosition Class
See Also Members
CollapseAll image DropDown image

An object that is used to represent a geographical offset and rotation

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("78F056F4-81A9-4b5b-9CE3-D1439715F4DD")]
public class ProjectPosition : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("78F056F4-81A9-4b5b-9CE3-D1439715F4DD")> _
Public Class ProjectPosition _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"78F056F4-81A9-4b5b-9CE3-D1439715F4DD")]
public ref class ProjectPosition : public APIObject

Remarks

This object is used by the project location object as a convenient way of getting and setting

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::ProjectPosition

See Also

ProjectPosition Members
Autodesk.Revit.Site Namespace


ProjectPosition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectPosition
Visual Basic (Declaration)
Public Class ProjectPosition
Visual C++
public ref class ProjectPosition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectPositionProjectPositionNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Angle | Angle from True North
Public property | EastWest | East to West offset
Public property | Elevation | Elevation above ground level.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NorthSouth | North to South offset

See Also

ProjectPosition
Autodesk.Revit.Site Namespace


ProjectPosition Constructor
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | ProjectPositionProjectPositionNew()() | For Internal Use Only.
Public method | ProjectPositionProjectPositionNew(Double, Double, Double, Double) | Construct a new ProjectPosition object with the specified East to West, North to South, Elevation and Angle of rotation

See Also

ProjectPosition Class
ProjectPosition Members
Autodesk.Revit.Site Namespace


ProjectPosition Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectPosition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectPosition ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


ProjectPosition Constructor (Double, Double, Double, Double)
CollapseAll image DropDown image

Construct a new ProjectPosition object with the specified East to West, North to South, Elevation and Angle of rotation

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
)
Visual C++
public:
ProjectPosition (
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Double
East to West offset
ns
Double
North to South offset
elevation
Double
Elevation offset
angle
Double
Rotation from true north

Remarks

The angle can be in the range of +PI to -PI

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


ProjectPosition Properties
CollapseAll image DropDown image

Syntax

C#
public class ProjectPosition
Visual Basic (Declaration)
Public Class ProjectPosition
Visual C++
public ref class ProjectPosition

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Angle | Angle from True North
Public property | EastWest | East to West offset
Public property | Elevation | Elevation above ground level.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NorthSouth | North to South offset

See Also

ProjectPosition
Autodesk.Revit.Site Namespace


Angle Property

ProjectPosition..::Angle Property
CollapseAll image DropDown image

Angle from True North

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Angle{ get; set;}
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

This is the angle difference between project north and true north measured in radians. It can have a value from -PI to +PI.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


EastWest Property

ProjectPosition..::EastWest Property
CollapseAll image DropDown image

East to West offset

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double EastWest{ get; set;}
Visual Basic (Declaration)
Public Property EastWest As Double
Visual C++
public:
property double EastWest {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the east to west direction. Measured in decimal feet.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


Elevation Property

ProjectPosition..::Elevation Property
CollapseAll image DropDown image

Elevation above ground level.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Elevation{ get; set;}
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

Measured in decimal feet.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


NorthSouth Property

ProjectPosition..::NorthSouth Property
CollapseAll image DropDown image

North to South offset

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double NorthSouth{ get; set;}
Visual Basic (Declaration)
Public Property NorthSouth As Double
Visual C++
public:
property double NorthSouth {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the north to south direction. Measured in decimal feet.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


SiteLocation Class
See Also Members
CollapseAll image DropDown image

Contains the geographical location information for the project's site.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("36653144-D399-46c3-ABEE-AED7013FFF8C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SiteLocation : Symbol
Visual Basic (Declaration)
<GuidAttribute("36653144-D399-46c3-ABEE-AED7013FFF8C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SiteLocation _
    Inherits Symbol
Visual C++
[GuidAttribute(L"36653144-D399-46c3-ABEE-AED7013FFF8C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SiteLocation : public Symbol

Remarks

Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Site..::SiteLocation

See Also

SiteLocation Members
Autodesk.Revit.Site Namespace


SiteLocation Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SiteLocation
Visual Basic (Declaration)
Public Class SiteLocation
Visual C++
public ref class SiteLocation

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SiteLocationSiteLocationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | The latitude of the site location
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Longitude | The longitude of the site location
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TimeZone | Timezone that contains the site
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SiteLocation
Autodesk.Revit.Site Namespace


SiteLocation Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SiteLocation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SiteLocation ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


SiteLocation Properties
CollapseAll image DropDown image

Syntax

C#
public class SiteLocation
Visual Basic (Declaration)
Public Class SiteLocation
Visual C++
public ref class SiteLocation

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | The latitude of the site location
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Longitude | The longitude of the site location
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TimeZone | Timezone that contains the site
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SiteLocation
Autodesk.Revit.Site Namespace


Latitude Property

SiteLocation..::Latitude Property
CollapseAll image DropDown image

The latitude of the site location

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Latitude{ get; set;}
Visual Basic (Declaration)
Public Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the latitude of the site location for the entire project. Note that the project may have several locations within that site which are set by using the SiteLocation objects. The value of this property is in radians between +PI and -PI.If this property is read only an exception will be thrown if an attempt is made to set the property.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


Longitude Property

SiteLocation..::Longitude Property
CollapseAll image DropDown image

The longitude of the site location

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Longitude{ get; set;}
Visual Basic (Declaration)
Public Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the longitude of the site location for the entire project. Note that the project may have several locations within that site which are set by using the SiteLocation objects. The value of this property is in radians between +PI and -PI.If this property is read only an exception will be thrown if an attempt is made to set the property.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


Parameter Property

SiteLocation..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SiteLocation Class
SiteLocation Members
Autodesk.Revit.Site Namespace


TimeZone Property

SiteLocation..::TimeZone Property
CollapseAll image DropDown image

Timezone that contains the site

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double TimeZone{ get; set;}
Visual Basic (Declaration)
Public Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
    void set (double value);
}

Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT. If this property is read only an exception will be thrown if an attempt is made to set the property.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


Autodesk.Revit.Spaces Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Spaces
Visual Basic (Declaration)
Namespace Autodesk.Revit.Spaces
Visual C++
namespace Autodesk.Revit.Spaces

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of a aream boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.


BoundarySegment Class
See Also Members
CollapseAll image DropDown image

An object that represents a segment of a aream boundary.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E9425E24-11E1-44b3-A1B2-379B64CE813B")]
public class BoundarySegment : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E9425E24-11E1-44b3-A1B2-379B64CE813B")> _
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E9425E24-11E1-44b3-A1B2-379B64CE813B")]
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a aream. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Spaces Namespace


BoundarySegment Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentBoundarySegmentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this aream.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment
Autodesk.Revit.Spaces Namespace


BoundarySegment Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegment ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


BoundarySegment Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegment
Autodesk.Revit.Spaces Namespace


ReleaseUnmanagedResources Method

BoundarySegment..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


BoundarySegment Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this aream.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment
Autodesk.Revit.Spaces Namespace


Curve Property

BoundarySegment..::Curve Property
CollapseAll image DropDown image

Get the curve that is formed by the element that defines the edge of this aream.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


Document Property

BoundarySegment..::Document Property
CollapseAll image DropDown image

Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document Document{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


Element Property

BoundarySegment..::Element Property
CollapseAll image DropDown image

Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific aream.

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segments.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FEC80154-DE86-405c-9F25-0EAA2A6E5898")]
public class BoundarySegmentArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FEC80154-DE86-405c-9F25-0EAA2A6E5898")> _
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FEC80154-DE86-405c-9F25-0EAA2A6E5898")]
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayBoundarySegmentArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray ()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArray
Autodesk.Revit.Spaces Namespace


Append Method

BoundarySegmentArray..::Append Method
CollapseAll image DropDown image

Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append (
    BoundarySegment^ item
)

Parameters

item
BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Clear Method

BoundarySegmentArray..::Clear Method
CollapseAll image DropDown image

Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Dispose Method

BoundarySegmentArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


ForwardIterator Method

BoundarySegmentArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


GetEnumerator Method

BoundarySegmentArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Insert Method

BoundarySegmentArray..::Insert Method
CollapseAll image DropDown image

Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    BoundarySegment^ item,
    int index
)

Parameters

item
BoundarySegment
The boundary segment to be inserted into the array.
index
Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArray..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


ReverseIterator Method

BoundarySegmentArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArray
Visual Basic (Declaration)
Public Class BoundarySegmentArray
Visual C++
public ref class BoundarySegmentArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray
Autodesk.Revit.Spaces Namespace


IsEmpty Property

BoundarySegmentArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Item Property

BoundarySegmentArray..::Item Property
CollapseAll image DropDown image

Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegment Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Size Property

BoundarySegmentArray..::Size Property
CollapseAll image DropDown image

Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4D70F568-44FD-42bd-8DF7-B0FC393FC005")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegmentArrayArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("4D70F568-44FD-42bd-8DF7-B0FC393FC005")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"4D70F568-44FD-42bd-8DF7-B0FC393FC005")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayBoundarySegmentArrayArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray ()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Methods
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Spaces Namespace


Append Method

BoundarySegmentArrayArray..::Append Method
CollapseAll image DropDown image

Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append (
    BoundarySegmentArray^ item
)

Parameters

item
BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Clear Method

BoundarySegmentArrayArray..::Clear Method
CollapseAll image DropDown image

Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Dispose Method

BoundarySegmentArrayArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


ForwardIterator Method

BoundarySegmentArrayArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


GetEnumerator Method

BoundarySegmentArrayArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Insert Method

BoundarySegmentArrayArray..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
BoundarySegmentArray
index
Int32

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayArray..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


ReverseIterator Method

BoundarySegmentArrayArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegmentArrayArray
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray
Visual C++
public ref class BoundarySegmentArrayArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray
Autodesk.Revit.Spaces Namespace


IsEmpty Property

BoundarySegmentArrayArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Item Property

BoundarySegmentArrayArray..::Item Property
CollapseAll image DropDown image

Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Size Property

BoundarySegmentArrayArray..::Size Property
CollapseAll image DropDown image

Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1F1AD2A2-9521-4bbe-9147-D4ABE13E4799")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BoundarySegmentArrayArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("1F1AD2A2-9521-4bbe-9147-D4ABE13E4799")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"1F1AD2A2-9521-4bbe-9147-D4ABE13E4799")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayIteratorBoundarySegmentArrayArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Spaces Namespace


Dispose Method

BoundarySegmentArrayArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


MoveNext Method

BoundarySegmentArrayArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


Reset Method

BoundarySegmentArrayArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator
Autodesk.Revit.Spaces Namespace


Current Property

BoundarySegmentArrayArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B3832EA7-B0A4-409f-9590-2C0D552E55AB")]
public abstract class BoundarySegmentArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B3832EA7-B0A4-409f-9590-2C0D552E55AB")> _
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B3832EA7-B0A4-409f-9590-2C0D552E55AB")]
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentArrayIteratorBoundarySegmentArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Spaces Namespace


Dispose Method

BoundarySegmentArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


MoveNext Method

BoundarySegmentArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


ReleaseUnmanagedResources Method

BoundarySegmentArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


Reset Method

BoundarySegmentArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BoundarySegmentArrayIterator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator
Visual C++
public ref class BoundarySegmentArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator
Autodesk.Revit.Spaces Namespace


Current Property

BoundarySegmentArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


Autodesk.Revit.Structural Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Structural
Visual Basic (Declaration)
Namespace Autodesk.Revit.Structural
Visual C++
namespace Autodesk.Revit.Structural

Classes

 | Class | Description
Public class | AnalyticalModel | Supports all Analytical Models that are persistent within the Autodesk Revit project
Public class | AnalyticalModel3D | Supports all Analytical Models that have more than two dimensions within the Autodesk Revit project
Public class | AnalyticalModelFloor | Supports all Floor Analytical Models that are persistent within the Autodesk Revit project
Public class | AnalyticalModelFrame | Supports Framing Analytical Models (e.g., Beam) that are persistent within the Autodesk Revit project
Public class | AnalyticalModelLocation | Supports Location Analytical Models (e.g., Structural Footings) that are persistent within the Autodesk Revit project
Public class | AnalyticalModelProfile | Represents an extruded profile.
Public class | AnalyticalModelWall | Supports all Wall Analytical Models that are persistent within the Autodesk Revit project
Public class | AnalyticalSupportData | Information for one support of another Structural Element.
Public class | AnalyticalSupportInfo | Information for one support of another Structural Element.
Public class | AnalyticalSupportInfoArray | An array that contains support information objects.
Public class | AnalyticalSupportInfoArrayIterator | An iterator to a support information array.
Public class | BarDescription | An object that represents an Area Reinforcement within the Autodesk Revit project.
Public class | CompoundStructure | An object that describes the multi layered construction of walls or floors.
Public class | CompoundStructureLayer | An object that describes the a single layer of multi layered object.
Public class | CompoundStructureLayerArray | An array that contains layer objects.
Public class | CompoundStructureLayerArrayIterator | An iterator to a layer array.


AnalyticalModel Class
See Also Members
CollapseAll image DropDown image

Supports all Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("22D54312-EA40-4877-AB98-ED8FE0193BF0")]
public class AnalyticalModel : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("22D54312-EA40-4877-AB98-ED8FE0193BF0")> _
Public Class AnalyticalModel _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"22D54312-EA40-4877-AB98-ED8FE0193BF0")]
public ref class AnalyticalModel : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelFrame
Autodesk.Revit.Structural..::AnalyticalModelWall
Autodesk.Revit.Structural..::AnalyticalModelFloor
Autodesk.Revit.Structural..::AnalyticalModelLocation
Autodesk.Revit.Structural..::AnalyticalModel3D
Autodesk.Revit.Structural..::AnalyticalModelProfile

See Also

AnalyticalModel Members
Autodesk.Revit.Structural Namespace


AnalyticalModel Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModel
Visual C++
public ref class AnalyticalModel

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelAnalyticalModelNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnalyticalModel
Autodesk.Revit.Structural Namespace


AnalyticalModel Constructor
CollapseAll image DropDown image

For Internal Use Only

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModel ()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

AnalyticalModel Class
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Class
See Also Members
CollapseAll image DropDown image

Supports all Analytical Models that have more than two dimensions within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F377028A-2A42-4faf-A349-0E3730FE22FC")]
public class AnalyticalModel3D : AnalyticalModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F377028A-2A42-4faf-A349-0E3730FE22FC")> _
Public Class AnalyticalModel3D _
    Inherits AnalyticalModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F377028A-2A42-4faf-A349-0E3730FE22FC")]
public ref class AnalyticalModel3D : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModel3D

See Also

AnalyticalModel3D Members
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModel3D
Visual Basic (Declaration)
Public Class AnalyticalModel3D
Visual C++
public ref class AnalyticalModel3D

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModel3DAnalyticalModel3DNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModel3D
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModel3D()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModel3D ()

Remarks

This constructor is exposed to enable support for COM interop only. This object must not be created by the developer.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModel3D
Visual Basic (Declaration)
Public Class AnalyticalModel3D
Visual C++
public ref class AnalyticalModel3D

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModel3D
Autodesk.Revit.Structural Namespace


Curves Property

AnalyticalModel3D..::Curves Property
CollapseAll image DropDown image

Returns curves that define the Analytical Model of the associated Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Returns a CurveArray containing the Analytical Model.

Remarks

There are no significant restrictions on the curves; they may not be coplanar, and they may not be even connected.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


SupportData Property

AnalyticalModel3D..::SupportData Property
CollapseAll image DropDown image

Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportData SupportData{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Class
See Also Members
CollapseAll image DropDown image

Supports all Floor Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CC6E9785-ED85-4dd3-A640-4D1450E69CC1")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalModelFloor : AnalyticalModel
Visual Basic (Declaration)
<GuidAttribute("CC6E9785-ED85-4dd3-A640-4D1450E69CC1")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalModelFloor _
    Inherits AnalyticalModel
Visual C++
[GuidAttribute(L"CC6E9785-ED85-4dd3-A640-4D1450E69CC1")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalModelFloor : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelFloor

See Also

AnalyticalModelFloor Members
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelFloor
Visual Basic (Declaration)
Public Class AnalyticalModelFloor
Visual C++
public ref class AnalyticalModelFloor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelFloorAnalyticalModelFloorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Curves | Provides access to the Floor Analytical Model.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFloor
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModelFloor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelFloor ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelFloor
Visual Basic (Declaration)
Public Class AnalyticalModelFloor
Visual C++
public ref class AnalyticalModelFloor

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curves | Provides access to the Floor Analytical Model.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFloor
Autodesk.Revit.Structural Namespace


Curves Property

AnalyticalModelFloor..::Curves Property
CollapseAll image DropDown image

Provides access to the Floor Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Curves that define the Floor's Analytical Model.

Remarks

The curves are all coplanar.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


SupportData Property

AnalyticalModelFloor..::SupportData Property
CollapseAll image DropDown image

Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportData SupportData{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Class
See Also Members
CollapseAll image DropDown image

Supports Framing Analytical Models (e.g., Beam) that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1FD5C4DD-078B-434d-BFCE-D275E586A295")]
public class AnalyticalModelFrame : AnalyticalModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1FD5C4DD-078B-434d-BFCE-D275E586A295")> _
Public Class AnalyticalModelFrame _
    Inherits AnalyticalModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1FD5C4DD-078B-434d-BFCE-D275E586A295")]
public ref class AnalyticalModelFrame : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelFrame

See Also

AnalyticalModelFrame Members
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelFrame
Visual Basic (Declaration)
Public Class AnalyticalModelFrame
Visual C++
public ref class AnalyticalModelFrame

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelFrameAnalyticalModelFrameNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Curve | Provides access to Structural Framing Analytical Model.
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.
Public property | RigidLink | Provides access to Rigid Links component of Structural Framing Element.
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFrame
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModelFrame()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelFrame ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelFrame
Visual Basic (Declaration)
Public Class AnalyticalModelFrame
Visual C++
public ref class AnalyticalModelFrame

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Provides access to Structural Framing Analytical Model.
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.
Public property | RigidLink | Provides access to Rigid Links component of Structural Framing Element.
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFrame
Autodesk.Revit.Structural Namespace


Curve Property

AnalyticalModelFrame..::Curve Property
CollapseAll image DropDown image

Provides access to Structural Framing Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Return Value

Returns a Curve containing the Analytical Model of the Structural Framing Element.

Remarks

The curve returned will not contain any Rigid Links. Use associated Rigid Links property to get Rigid Links.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


Curves Property

AnalyticalModelFrame..::Curves Property
CollapseAll image DropDown image

Returns curves that define the Analytical Model of the associated Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Returns a CurveArray containing the Analytical Model.

Remarks

There are no significant restrictions on the curves; they may not be coplanar, and they may not be even connected.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


Profile Property

AnalyticalModelFrame..::Profile Property
CollapseAll image DropDown image

This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModelProfile Profile{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Profile As AnalyticalModelProfile
Visual C++
public:
property AnalyticalModelProfile^ Profile {
    AnalyticalModelProfile^ get ();
}

Return Value

Returns a profile analytical model object if possible.

Remarks

Some elements may not be able to return a profile. In that case Nothing will be returned.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


RigidLink Property

AnalyticalModelFrame..::RigidLink Property
CollapseAll image DropDown image

Provides access to Rigid Links component of Structural Framing Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve RigidLink[
    int nEnd
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property RigidLink ( _
    nEnd As Integer _
) As Curve
Visual C++
public:
property Curve^ RigidLink[int nEnd] {
    Curve^ get (int nEnd);
}

Parameters

nEnd
Int32
An integer that represents the end of beam or column, 0 for the start and 1 for the end.

Return Value

Returns a Curve that is the Rigid Links component of the Structural Framing Element. End is determined by the input parameter.

Remarks

This is only meaningful for Beams.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


SupportData Property

AnalyticalModelFrame..::SupportData Property
CollapseAll image DropDown image

Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportData SupportData{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Class
See Also Members
CollapseAll image DropDown image

Supports Location Analytical Models (e.g., Structural Footings) that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AC3B0A73-4835-4d5c-9AEB-2F45B1526604")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalModelLocation : AnalyticalModel
Visual Basic (Declaration)
<GuidAttribute("AC3B0A73-4835-4d5c-9AEB-2F45B1526604")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalModelLocation _
    Inherits AnalyticalModel
Visual C++
[GuidAttribute(L"AC3B0A73-4835-4d5c-9AEB-2F45B1526604")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalModelLocation : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelLocation

See Also

AnalyticalModelLocation Members
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelLocation
Visual Basic (Declaration)
Public Class AnalyticalModelLocation
Visual C++
public ref class AnalyticalModelLocation

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelLocationAnalyticalModelLocationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Provides access to the location of the Analytical Model, in the case of Structural Foundations.
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelLocation
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModelLocation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelLocation ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelLocation
Visual Basic (Declaration)
Public Class AnalyticalModelLocation
Visual C++
public ref class AnalyticalModelLocation

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Provides access to the location of the Analytical Model, in the case of Structural Foundations.
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelLocation
Autodesk.Revit.Structural Namespace


Curves Property

AnalyticalModelLocation..::Curves Property
CollapseAll image DropDown image

Returns curves that define the Analytical Model of the associated Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Returns a CurveArray containing the Analytical Model.

Remarks

There are no significant restrictions on the curves; they may not be coplanar, and they may not be even connected.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


Point Property

AnalyticalModelLocation..::Point Property
CollapseAll image DropDown image

Provides access to the location of the Analytical Model, in the case of Structural Foundations.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Point{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Return Value

Returns a point object containing the location of this Analytical Model.

Remarks

The Location point is on the "top" of the Structural Foundation.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


SupportData Property

AnalyticalModelLocation..::SupportData Property
CollapseAll image DropDown image

Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportData SupportData{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Class
See Also Members
CollapseAll image DropDown image

Represents an extruded profile.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("766EE16B-F9D1-4557-A9ED-7223C1DEA5FA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalModelProfile : AnalyticalModel
Visual Basic (Declaration)
<GuidAttribute("766EE16B-F9D1-4557-A9ED-7223C1DEA5FA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalModelProfile _
    Inherits AnalyticalModel
Visual C++
[GuidAttribute(L"766EE16B-F9D1-4557-A9ED-7223C1DEA5FA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalModelProfile : public AnalyticalModel

Remarks

Elements, such as beams, may be formed from a profile that has been swept along a curve. This analytical model represents such a form and is used to access the cross section and the underlying curve that make up the element.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelProfile

See Also

AnalyticalModelProfile Members
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelProfile
Visual Basic (Declaration)
Public Class AnalyticalModelProfile
Visual C++
public ref class AnalyticalModelProfile

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelProfileAnalyticalModelProfileNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public property | EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
Public property | SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModelProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelProfile ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelProfile
Visual Basic (Declaration)
Public Class AnalyticalModelProfile
Visual C++
public ref class AnalyticalModelProfile

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public property | EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
Public property | SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile
Autodesk.Revit.Structural Namespace


DrivingCurve Property

AnalyticalModelProfile..::DrivingCurve Property
CollapseAll image DropDown image

Provides access to the curve that dictates the path of the swept profile.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve DrivingCurve{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DrivingCurve As Curve
Visual C++
public:
property Curve^ DrivingCurve {
    Curve^ get ();
}

Return Value

A curve that defines the path of the swept profile.

Remarks

The profile may not be swept the entire length of this curve. One should check the set back properties on this object to locate how far the the actual sweep is from the ends of the curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


EndSetBack Property

AnalyticalModelProfile..::EndSetBack Property
CollapseAll image DropDown image

Returns the distance from the end of the driving curve that the sweep actually finishes.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double EndSetBack{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndSetBack As Double
Visual C++
public:
property double EndSetBack {
    double get ();
}

Return Value

A distance from the end point of the driving curve.

Remarks

The distance is measured in decimal feet.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


StartSetBack Property

AnalyticalModelProfile..::StartSetBack Property
CollapseAll image DropDown image

Returns the distance from the start of the driving curve that the sweep actually begins.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double StartSetBack{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StartSetBack As Double
Visual C++
public:
property double StartSetBack {
    double get ();
}

Return Value

A distance from the start point of the driving curve.

Remarks

The distance is measured in decimal feet.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


SweptProfile Property

AnalyticalModelProfile..::SweptProfile Property
CollapseAll image DropDown image

Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Profile SweptProfile{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SweptProfile As Profile
Visual C++
public:
property Profile^ SweptProfile {
    Profile^ get ();
}

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Class
See Also Members
CollapseAll image DropDown image

Supports all Wall Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C4FD32F5-C283-4ffd-9334-CC9A57CD22F5")]
public class AnalyticalModelWall : AnalyticalModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C4FD32F5-C283-4ffd-9334-CC9A57CD22F5")> _
Public Class AnalyticalModelWall _
    Inherits AnalyticalModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C4FD32F5-C283-4ffd-9334-CC9A57CD22F5")]
public ref class AnalyticalModelWall : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelWall

See Also

AnalyticalModelWall Members
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelWall
Visual Basic (Declaration)
Public Class AnalyticalModelWall
Visual C++
public ref class AnalyticalModelWall

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelWallAnalyticalModelWallNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Curves | Provides access to the Wall Analytical Model.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelWall
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModelWall()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelWall ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelWall
Visual Basic (Declaration)
Public Class AnalyticalModelWall
Visual C++
public ref class AnalyticalModelWall

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curves | Provides access to the Wall Analytical Model.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelWall
Autodesk.Revit.Structural Namespace


Curves Property

AnalyticalModelWall..::Curves Property
CollapseAll image DropDown image

Provides access to the Wall Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Curves that define the Wall's Analytical Model.

Remarks

The curves are all coplanar.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


SupportData Property

AnalyticalModelWall..::SupportData Property
CollapseAll image DropDown image

Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportData SupportData{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Class
See Also Members
CollapseAll image DropDown image

Information for one support of another Structural Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("952A7D6E-D70D-4d3d-BEC1-1C0540D63081")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalSupportData : APIObject
Visual Basic (Declaration)
<GuidAttribute("952A7D6E-D70D-4d3d-BEC1-1C0540D63081")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalSupportData _
    Inherits APIObject
Visual C++
[GuidAttribute(L"952A7D6E-D70D-4d3d-BEC1-1C0540D63081")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalSupportData : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalSupportData

See Also

AnalyticalSupportData Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportData
Visual Basic (Declaration)
Public Class AnalyticalSupportData
Visual C++
public ref class AnalyticalSupportData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalSupportDataAnalyticalSupportDataNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | InfoArray | Gets support information array for Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Supported | Test to see if the Element is supported.

See Also

AnalyticalSupportData
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportData ()

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Methods
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportData
Visual Basic (Declaration)
Public Class AnalyticalSupportData
Visual C++
public ref class AnalyticalSupportData

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AnalyticalSupportData
Autodesk.Revit.Structural Namespace


ReleaseUnmanagedResources Method

AnalyticalSupportData..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportData
Visual Basic (Declaration)
Public Class AnalyticalSupportData
Visual C++
public ref class AnalyticalSupportData

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | InfoArray | Gets support information array for Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Supported | Test to see if the Element is supported.

See Also

AnalyticalSupportData
Autodesk.Revit.Structural Namespace


InfoArray Property

AnalyticalSupportData..::InfoArray Property
CollapseAll image DropDown image

Gets support information array for Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportInfoArray InfoArray{ get;}
Visual Basic (Declaration)
Public ReadOnly Property InfoArray As AnalyticalSupportInfoArray
Visual C++
public:
property AnalyticalSupportInfoArray^ InfoArray {
    AnalyticalSupportInfoArray^ get ();
}

Remarks

If the Element is a Foundation, this may be empty even though the Supported Flag is True.

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


Supported Property

AnalyticalSupportData..::Supported Property
CollapseAll image DropDown image

Test to see if the Element is supported.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Supported{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Supported As Boolean
Visual C++
public:
property bool Supported {
    bool get ();
}

Remarks

If the Element is supported, then True will be returned, otherwise False.

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Class
See Also Members
CollapseAll image DropDown image

Information for one support of another Structural Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5CBA80E7-4D0D-453b-9242-F339BB7E1EE8")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalSupportInfo : APIObject
Visual Basic (Declaration)
<GuidAttribute("5CBA80E7-4D0D-453b-9242-F339BB7E1EE8")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalSupportInfo _
    Inherits APIObject
Visual C++
[GuidAttribute(L"5CBA80E7-4D0D-453b-9242-F339BB7E1EE8")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalSupportInfo : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalSupportInfo

See Also

AnalyticalSupportInfo Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportInfo
Visual Basic (Declaration)
Public Class AnalyticalSupportInfo
Visual C++
public ref class AnalyticalSupportInfo

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalSupportInfoAnalyticalSupportInfoNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Element | Gets the Structural Element providing support.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportType | Returns the type of support provided by the other Element.

See Also

AnalyticalSupportInfo
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportInfo ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Methods
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportInfo
Visual Basic (Declaration)
Public Class AnalyticalSupportInfo
Visual C++
public ref class AnalyticalSupportInfo

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AnalyticalSupportInfo
Autodesk.Revit.Structural Namespace


ReleaseUnmanagedResources Method

AnalyticalSupportInfo..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportInfo
Visual Basic (Declaration)
Public Class AnalyticalSupportInfo
Visual C++
public ref class AnalyticalSupportInfo

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Element | Gets the Structural Element providing support.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SupportType | Returns the type of support provided by the other Element.

See Also

AnalyticalSupportInfo
Autodesk.Revit.Structural Namespace


Element Property

AnalyticalSupportInfo..::Element Property
CollapseAll image DropDown image

Gets the Structural Element providing support.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


SupportType Property

AnalyticalSupportInfo..::SupportType Property
CollapseAll image DropDown image

Returns the type of support provided by the other Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportType SupportType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SupportType As AnalyticalSupportType
Visual C++
public:
property AnalyticalSupportType SupportType {
    AnalyticalSupportType get ();
}

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Class
See Also Members
CollapseAll image DropDown image

An array that contains support information objects.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("556E392E-1D04-4291-BE39-7905555CFE52")]
public class AnalyticalSupportInfoArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("556E392E-1D04-4291-BE39-7905555CFE52")> _
Public Class AnalyticalSupportInfoArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"556E392E-1D04-4291-BE39-7905555CFE52")]
public ref class AnalyticalSupportInfoArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalSupportInfoArray

See Also

AnalyticalSupportInfoArray Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportInfoArray
Visual Basic (Declaration)
Public Class AnalyticalSupportInfoArray
Visual C++
public ref class AnalyticalSupportInfoArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalSupportInfoArrayAnalyticalSupportInfoArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the support to the end of the array.
Public method | Clear | Removes every support from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified support into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets support information at a specified index within the array.
Public property | Size | Returns the number of supports that are in the array.

See Also

AnalyticalSupportInfoArray
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportInfoArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportInfoArray ()

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Methods
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportInfoArray
Visual Basic (Declaration)
Public Class AnalyticalSupportInfoArray
Visual C++
public ref class AnalyticalSupportInfoArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the support to the end of the array.
Public method | Clear | Removes every support from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified support into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AnalyticalSupportInfoArray
Autodesk.Revit.Structural Namespace


Append Method

AnalyticalSupportInfoArray..::Append Method
CollapseAll image DropDown image

Add the support to the end of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    AnalyticalSupportInfo item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As AnalyticalSupportInfo _
)
Visual C++
public:
virtual void Append (
    AnalyticalSupportInfo^ item
)

Parameters

item
AnalyticalSupportInfo
The support to be added.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Clear Method

AnalyticalSupportInfoArray..::Clear Method
CollapseAll image DropDown image

Removes every support from the array, rendering it empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Dispose Method

AnalyticalSupportInfoArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


ForwardIterator Method

AnalyticalSupportInfoArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AnalyticalSupportInfoArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AnalyticalSupportInfoArrayIterator
Visual C++
public:
virtual AnalyticalSupportInfoArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


GetEnumerator Method

AnalyticalSupportInfoArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Insert Method

AnalyticalSupportInfoArray..::Insert Method
CollapseAll image DropDown image

Insert the specified support into the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    AnalyticalSupportInfo item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As AnalyticalSupportInfo, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    AnalyticalSupportInfo^ item,
    int index
)

Parameters

item
AnalyticalSupportInfo
The support to be inserted into the array.
index
Int32
The support will be inserted before this index.

Return Value

Returns whether the support was inserted into the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


ReleaseUnmanagedResources Method

AnalyticalSupportInfoArray..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


ReverseIterator Method

AnalyticalSupportInfoArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AnalyticalSupportInfoArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AnalyticalSupportInfoArrayIterator
Visual C++
public:
virtual AnalyticalSupportInfoArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalSupportInfoArray
Visual Basic (Declaration)
Public Class AnalyticalSupportInfoArray
Visual C++
public ref class AnalyticalSupportInfoArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets support information at a specified index within the array.
Public property | Size | Returns the number of supports that are in the array.

See Also

AnalyticalSupportInfoArray
Autodesk.Revit.Structural Namespace


IsEmpty Property

AnalyticalSupportInfoArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Item Property

AnalyticalSupportInfoArray..::Item Property
CollapseAll image DropDown image

Gets or sets support information at a specified index within the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AnalyticalSupportInfo Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As AnalyticalSupportInfo
Visual C++
public:
virtual property AnalyticalSupportInfo^ Item[int index] {
    AnalyticalSupportInfo^ get (int index);
    void set (int index, AnalyticalSupportInfo^ value);
}

Parameters

index
Int32
The index of the support information to be set or retrieved.

Return Value

Returns the support information at the specified index.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Size Property

AnalyticalSupportInfoArray..::Size Property
CollapseAll image DropDown image

Returns the number of supports that are in the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a support information array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("90E57B73-F3DB-4c5b-87B2-86D21C0BB55B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class AnalyticalSupportInfoArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("90E57B73-F3DB-4c5b-87B2-86D21C0BB55B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class AnalyticalSupportInfoArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"90E57B73-F3DB-4c5b-87B2-86D21C0BB55B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalSupportInfoArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalSupportInfoArrayIterator

See Also

AnalyticalSupportInfoArrayIterator Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class AnalyticalSupportInfoArrayIterator
Visual Basic (Declaration)
Public MustInherit Class AnalyticalSupportInfoArrayIterator
Visual C++
public ref class AnalyticalSupportInfoArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalSupportInfoArrayIteratorAnalyticalSupportInfoArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnalyticalSupportInfoArrayIterator
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalSupportInfoArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportInfoArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class AnalyticalSupportInfoArrayIterator
Visual Basic (Declaration)
Public MustInherit Class AnalyticalSupportInfoArrayIterator
Visual C++
public ref class AnalyticalSupportInfoArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AnalyticalSupportInfoArrayIterator
Autodesk.Revit.Structural Namespace


Dispose Method

AnalyticalSupportInfoArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


MoveNext Method

AnalyticalSupportInfoArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


ReleaseUnmanagedResources Method

AnalyticalSupportInfoArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


Reset Method

AnalyticalSupportInfoArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class AnalyticalSupportInfoArrayIterator
Visual Basic (Declaration)
Public MustInherit Class AnalyticalSupportInfoArrayIterator
Visual C++
public ref class AnalyticalSupportInfoArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnalyticalSupportInfoArrayIterator
Autodesk.Revit.Structural Namespace


Current Property

AnalyticalSupportInfoArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


BarDescription Class
See Also Members
CollapseAll image DropDown image

An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E8974D2F-2D8E-48a2-80D9-4C663801C653")]
public class BarDescription : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E8974D2F-2D8E-48a2-80D9-4C663801C653")> _
Public Class BarDescription _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E8974D2F-2D8E-48a2-80D9-4C663801C653")]
public ref class BarDescription : public APIObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::BarDescription

See Also

BarDescription Members
Autodesk.Revit.Structural Namespace


BarDescription Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BarDescription
Visual Basic (Declaration)
Public Class BarDescription
Visual C++
public ref class BarDescription

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BarDescriptionBarDescriptionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Public property | Count | Retrieves the number of bars of this shape.
Public property | HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
Public property | HookType | Retrieves the Rebar Hook Type property of a Bar Description.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Public property | Length | Retrieves the length of a Bar Description.

See Also

BarDescription
Autodesk.Revit.Structural Namespace


BarDescription Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BarDescription()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarDescription ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


BarDescription Methods
CollapseAll image DropDown image

Syntax

C#
public class BarDescription
Visual Basic (Declaration)
Public Class BarDescription
Visual C++
public ref class BarDescription

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

BarDescription
Autodesk.Revit.Structural Namespace


Dispose Method

BarDescription..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


BarDescription Properties
CollapseAll image DropDown image

Syntax

C#
public class BarDescription
Visual Basic (Declaration)
Public Class BarDescription
Visual C++
public ref class BarDescription

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Public property | Count | Retrieves the number of bars of this shape.
Public property | HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
Public property | HookType | Retrieves the Rebar Hook Type property of a Bar Description.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Public property | Length | Retrieves the length of a Bar Description.

See Also

BarDescription
Autodesk.Revit.Structural Namespace


BarType Property

BarDescription..::BarType Property
CollapseAll image DropDown image

Retrieves the Rebar Bar Type property of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarBarType BarType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BarType As RebarBarType
Visual C++
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


Count Property

BarDescription..::Count Property
CollapseAll image DropDown image

Retrieves the number of bars of this shape.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Count{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


HooksInSameDirection Property

BarDescription..::HooksInSameDirection Property
CollapseAll image DropDown image

Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HooksInSameDirection{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HooksInSameDirection As Boolean
Visual C++
public:
property bool HooksInSameDirection {
    bool get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


HookType Property

BarDescription..::HookType Property
CollapseAll image DropDown image

Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookType HookType[
    int end
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


Layer Property

BarDescription..::Layer Property
CollapseAll image DropDown image

Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Layer{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Layer As Integer
Visual C++
public:
property int Layer {
    int get ();
}

Remarks

For floors, layer 0 is Top Major; layer 1 is Top Minor; layer 2 is Bottom Major; layer 3 is Bottom Minor. For walls, layer 0 is Front Major; layer 1 is Front Minor; layer 2 is Back Major; layer 3 is Back Minor.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


Length Property

BarDescription..::Length Property
CollapseAll image DropDown image

Retrieves the length of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Length{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


CompoundStructure Class
See Also Members
CollapseAll image DropDown image

An object that describes the multi layered construction of walls or floors.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6854F546-9ECB-4bd4-8F29-50966C4EE037")]
public class CompoundStructure : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6854F546-9ECB-4bd4-8F29-50966C4EE037")> _
Public Class CompoundStructure _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6854F546-9ECB-4bd4-8F29-50966C4EE037")]
public ref class CompoundStructure : public APIObject

Remarks

The CompoundStructure object exposes the layers of elements, such as walls. These layers can be of varying thickness and material, each of which has a dedicated function.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::CompoundStructure

See Also

CompoundStructure Members
Autodesk.Revit.Structural Namespace


CompoundStructure Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructure
Visual Basic (Declaration)
Public Class CompoundStructure
Visual C++
public ref class CompoundStructure

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CompoundStructureCompoundStructureNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Layers | Returns the layers that make up the compound structure of the object.

See Also

CompoundStructure
Autodesk.Revit.Structural Namespace


CompoundStructure Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructure()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructure ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


CompoundStructure Methods
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructure
Visual Basic (Declaration)
Public Class CompoundStructure
Visual C++
public ref class CompoundStructure

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CompoundStructure
Autodesk.Revit.Structural Namespace


ReleaseUnmanagedResources Method

CompoundStructure..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


CompoundStructure Properties
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructure
Visual Basic (Declaration)
Public Class CompoundStructure
Visual C++
public ref class CompoundStructure

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Layers | Returns the layers that make up the compound structure of the object.

See Also

CompoundStructure
Autodesk.Revit.Structural Namespace


Layers Property

CompoundStructure..::Layers Property
CollapseAll image DropDown image

Returns the layers that make up the compound structure of the object.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructureLayerArray Layers{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Layers As CompoundStructureLayerArray
Visual C++
public:
property CompoundStructureLayerArray^ Layers {
    CompoundStructureLayerArray^ get ();
}

Remarks

The layers will be order from exterior to interior in the case of walls and from top to bottom in the case of floors.

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Class
See Also Members
CollapseAll image DropDown image

An object that describes the a single layer of multi layered object.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E658C477-82BE-4c4e-AD06-A52AEC473E82")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CompoundStructureLayer : APIObject
Visual Basic (Declaration)
<GuidAttribute("E658C477-82BE-4c4e-AD06-A52AEC473E82")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CompoundStructureLayer _
    Inherits APIObject
Visual C++
[GuidAttribute(L"E658C477-82BE-4c4e-AD06-A52AEC473E82")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CompoundStructureLayer : public APIObject

Remarks

A wall of floor may have several layers. Each layer contains information about its thickness, intended purpose (function) and material from which it is made.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::CompoundStructureLayer

See Also

CompoundStructureLayer Members
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructureLayer
Visual Basic (Declaration)
Public Class CompoundStructureLayer
Visual C++
public ref class CompoundStructureLayer

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CompoundStructureLayerCompoundStructureLayerNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | DeckProfile | Returns or set the family symbol of the deck profile of the layer within the structure.
Public property | DeckUsage | Returns usage of the deck layer within the structure.
Public property | Function | Returns the purpose/function of the layer within the structure.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Material | Get or set the material from which the layer is made.
Public property | Thickness | Retrieve or modify the thickness of the layer.
Public property | Variable | Returns or set whether the layer thickness is vrariable.

See Also

CompoundStructureLayer
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructureLayer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayer ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Properties
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructureLayer
Visual Basic (Declaration)
Public Class CompoundStructureLayer
Visual C++
public ref class CompoundStructureLayer

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | DeckProfile | Returns or set the family symbol of the deck profile of the layer within the structure.
Public property | DeckUsage | Returns usage of the deck layer within the structure.
Public property | Function | Returns the purpose/function of the layer within the structure.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Material | Get or set the material from which the layer is made.
Public property | Thickness | Retrieve or modify the thickness of the layer.
Public property | Variable | Returns or set whether the layer thickness is vrariable.

See Also

CompoundStructureLayer
Autodesk.Revit.Structural Namespace


DeckProfile Property

CompoundStructureLayer..::DeckProfile Property
CollapseAll image DropDown image

Returns or set the family symbol of the deck profile of the layer within the structure.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbol DeckProfile{ get; set;}
Visual Basic (Declaration)
Public Property DeckProfile As FamilySymbol
Visual C++
public:
property FamilySymbol^ DeckProfile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


DeckUsage Property

CompoundStructureLayer..::DeckUsage Property
CollapseAll image DropDown image

Returns usage of the deck layer within the structure.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructureDeckUsage DeckUsage{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DeckUsage As CompoundStructureDeckUsage
Visual C++
public:
property CompoundStructureDeckUsage DeckUsage {
    CompoundStructureDeckUsage get ();
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Function Property

CompoundStructureLayer..::Function Property
CollapseAll image DropDown image

Returns the purpose/function of the layer within the structure.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructureLayerFunction Function{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Function As CompoundStructureLayerFunction
Visual C++
public:
property CompoundStructureLayerFunction Function {
    CompoundStructureLayerFunction get ();
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Material Property

CompoundStructureLayer..::Material Property
CollapseAll image DropDown image

Get or set the material from which the layer is made.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Material Material{ get; set;}
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Thickness Property

CompoundStructureLayer..::Thickness Property
CollapseAll image DropDown image

Retrieve or modify the thickness of the layer.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Thickness{ get; set;}
Visual Basic (Declaration)
Public Property Thickness As Double
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Variable Property

CompoundStructureLayer..::Variable Property
CollapseAll image DropDown image

Returns or set whether the layer thickness is vrariable.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Variable{ get; set;}
Visual Basic (Declaration)
Public Property Variable As Boolean
Visual C++
public:
property bool Variable {
    bool get ();
    void set (bool value);
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Class
See Also Members
CollapseAll image DropDown image

An array that contains layer objects.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3F61AF97-F0EB-4435-9350-6738E59DC1DD")]
public class CompoundStructureLayerArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3F61AF97-F0EB-4435-9350-6738E59DC1DD")> _
Public Class CompoundStructureLayerArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3F61AF97-F0EB-4435-9350-6738E59DC1DD")]
public ref class CompoundStructureLayerArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::CompoundStructureLayerArray

See Also

CompoundStructureLayerArray Members
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructureLayerArray
Visual Basic (Declaration)
Public Class CompoundStructureLayerArray
Visual C++
public ref class CompoundStructureLayerArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CompoundStructureLayerArrayCompoundStructureLayerArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the layer to the end of the array.
Public method | Clear | Removes every layer from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified layer into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a layer at a specified index within the array.
Public property | Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructureLayerArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayerArray ()

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Methods
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructureLayerArray
Visual Basic (Declaration)
Public Class CompoundStructureLayerArray
Visual C++
public ref class CompoundStructureLayerArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the layer to the end of the array.
Public method | Clear | Removes every layer from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified layer into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CompoundStructureLayerArray
Autodesk.Revit.Structural Namespace


Append Method

CompoundStructureLayerArray..::Append Method
CollapseAll image DropDown image

Add the layer to the end of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Append(
    CompoundStructureLayer item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CompoundStructureLayer _
)
Visual C++
public:
virtual void Append (
    CompoundStructureLayer^ item
)

Parameters

item
CompoundStructureLayer
The phase to be added.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Clear Method

CompoundStructureLayerArray..::Clear Method
CollapseAll image DropDown image

Removes every layer from the array, rendering it empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Dispose Method

CompoundStructureLayerArray..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


ForwardIterator Method

CompoundStructureLayerArray..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CompoundStructureLayerArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CompoundStructureLayerArrayIterator
Visual C++
public:
virtual CompoundStructureLayerArrayIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


GetEnumerator Method

CompoundStructureLayerArray..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Insert Method

CompoundStructureLayerArray..::Insert Method
CollapseAll image DropDown image

Insert the specified layer into the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    CompoundStructureLayer item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CompoundStructureLayer, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    CompoundStructureLayer^ item,
    int index
)

Parameters

item
CompoundStructureLayer
The layer to be inserted into the array.
index
Int32
The layer will be inserted before this index.

Return Value

Returns whether the layer was inserted into the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


ReleaseUnmanagedResources Method

CompoundStructureLayerArray..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


ReverseIterator Method

CompoundStructureLayerArray..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CompoundStructureLayerArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CompoundStructureLayerArrayIterator
Visual C++
public:
virtual CompoundStructureLayerArrayIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Properties
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructureLayerArray
Visual Basic (Declaration)
Public Class CompoundStructureLayerArray
Visual C++
public ref class CompoundStructureLayerArray

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a layer at a specified index within the array.
Public property | Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray
Autodesk.Revit.Structural Namespace


IsEmpty Property

CompoundStructureLayerArray..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the array is empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Item Property

CompoundStructureLayerArray..::Item Property
CollapseAll image DropDown image

Gets or sets a layer at a specified index within the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CompoundStructureLayer Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CompoundStructureLayer
Visual C++
public:
virtual property CompoundStructureLayer^ Item[int index] {
    CompoundStructureLayer^ get (int index);
    void set (int index, CompoundStructureLayer^ value);
}

Parameters

index
Int32
The index of the layer to be set or retrieved.

Return Value

Returns the layer at the specified index.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Size Property

CompoundStructureLayerArray..::Size Property
CollapseAll image DropDown image

Returns the number of layers that are in the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a layer array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3AE05AEC-67E6-4576-ABF8-B36418B653CD")]
public abstract class CompoundStructureLayerArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3AE05AEC-67E6-4576-ABF8-B36418B653CD")> _
Public MustInherit Class CompoundStructureLayerArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3AE05AEC-67E6-4576-ABF8-B36418B653CD")]
public ref class CompoundStructureLayerArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::CompoundStructureLayerArrayIterator

See Also

CompoundStructureLayerArrayIterator Members
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CompoundStructureLayerArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CompoundStructureLayerArrayIterator
Visual C++
public ref class CompoundStructureLayerArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CompoundStructureLayerArrayIteratorCompoundStructureLayerArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CompoundStructureLayerArrayIterator
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructureLayerArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayerArrayIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CompoundStructureLayerArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CompoundStructureLayerArrayIterator
Visual C++
public ref class CompoundStructureLayerArrayIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CompoundStructureLayerArrayIterator
Autodesk.Revit.Structural Namespace


Dispose Method

CompoundStructureLayerArrayIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


MoveNext Method

CompoundStructureLayerArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


ReleaseUnmanagedResources Method

CompoundStructureLayerArrayIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


Reset Method

CompoundStructureLayerArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CompoundStructureLayerArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CompoundStructureLayerArrayIterator
Visual C++
public ref class CompoundStructureLayerArrayIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CompoundStructureLayerArrayIterator
Autodesk.Revit.Structural Namespace


Current Property

CompoundStructureLayerArrayIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


Autodesk.Revit.Structural.Enums Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Structural.Enums
Visual Basic (Declaration)
Namespace Autodesk.Revit.Structural.Enums
Visual C++
namespace Autodesk.Revit.Structural.Enums

Enumerations

 | Enumeration | Description
Public enumeration | AnalyticalSupportType | Describes the type of support given by another structural element.
Public enumeration | CompoundStructureDeckUsage | Describes how the deck relates to the surrounding layers.
Public enumeration | CompoundStructureLayerFunction | Describes the purpose of the layer within a compound structure, such as a wall or floor.
Public enumeration | InstanceUsage | An enumerate type listing all the possible structural usage cases for a FamilyInstance object.
Public enumeration | Material | Basic solid structural object material types.
Public enumeration | RebarHookOrientation | Orientation of a rebar hook relative to the path of the Rebar Shape.
Public enumeration | RebarShapeArcReferenceType | A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.
Public enumeration | RebarShapeBendAngle | A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
Public enumeration | RebarShapeDefinitionByArcType | A RebarShapeDefinitionByArc takes one of three forms.
Public enumeration | RebarStyle | Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
Public enumeration | SlabFoundationType | SlabFoundation type.
Public enumeration | StructuralType | Fundamental structural component category.
Public enumeration | TranslationRotationValue | Values for BoundaryConditions Translation and Rotation parameters.
Public enumeration | WallUsage | An enumerate type listing all the possible structural usage cases for a Wall object.


AnalyticalSupportType Enumeration
CollapseAll image DropDown image

Describes the type of support given by another structural element.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("44379A93-5C90-4b9f-9AB8-5646064781CD")]
public enum AnalyticalSupportType
Visual Basic (Declaration)
<GuidAttribute("44379A93-5C90-4b9f-9AB8-5646064781CD")> _
Public Enumeration AnalyticalSupportType
Visual C++
[GuidAttribute(L"44379A93-5C90-4b9f-9AB8-5646064781CD")]
public enum class AnalyticalSupportType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Surface_Support | A Surface support type.
Line_Support | A Line support type.
Point_Support | A Point support type.
Unknown_Support | An unknown support type.

See Also

Autodesk.Revit.Structural.Enums Namespace


CompoundStructureDeckUsage Enumeration
CollapseAll image DropDown image

Describes how the deck relates to the surrounding layers.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("14C97E4A-B580-4234-A58F-32626F446377")]
public enum CompoundStructureDeckUsage
Visual Basic (Declaration)
<GuidAttribute("14C97E4A-B580-4234-A58F-32626F446377")> _
Public Enumeration CompoundStructureDeckUsage
Visual C++
[GuidAttribute(L"14C97E4A-B580-4234-A58F-32626F446377")]
public enum class CompoundStructureDeckUsage

Members

Member name | Description
MergeWithLayerBelow | Deck is merged with the layer below.
Standalone | Deck is independent of other layers.
MergeWithLayerAbove | Deck is merged with the layer above.
Invalid | Invalid.

See Also

Autodesk.Revit.Structural.Enums Namespace


CompoundStructureLayerFunction Enumeration
CollapseAll image DropDown image

Describes the purpose of the layer within a compound structure, such as a wall or floor.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A7423B7D-229D-4928-8FA2-8E9C8377F0E5")]
public enum CompoundStructureLayerFunction
Visual Basic (Declaration)
<GuidAttribute("A7423B7D-229D-4928-8FA2-8E9C8377F0E5")> _
Public Enumeration CompoundStructureLayerFunction
Visual C++
[GuidAttribute(L"A7423B7D-229D-4928-8FA2-8E9C8377F0E5")]
public enum class CompoundStructureLayerFunction

Members

Member name | Description
StructuralDeck | A special layer considered to be structural decking.
MembraneLayer | A membrane layer.
Finish2 | A finish layer.
Finish1 | A finish layer.
ThermalOrAir | A thermal or air insulating layer.
Substrate | A substrate layer.
Structure | A structural layer.

See Also

Autodesk.Revit.Structural.Enums Namespace


InstanceUsage Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible structural usage cases for a FamilyInstance object.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("805FF4E8-D84B-4940-A575-AC818EDB3BF3")]
public enum InstanceUsage
Visual Basic (Declaration)
<GuidAttribute("805FF4E8-D84B-4940-A575-AC818EDB3BF3")> _
Public Enumeration InstanceUsage
Visual C++
[GuidAttribute(L"805FF4E8-D84B-4940-A575-AC818EDB3BF3")]
public enum class InstanceUsage

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
TrussWeb | The instance should be considered to be truss web for the purpose of structural analysis.
TrussChord | The instance should be considered to be truss chord for the purpose of structural analysis.
Automatic | The instance should be considered to be automatic for the purpose of structural analysis.
KickerBracing | The instance should be considered to be kicker bracing for the purpose of structural analysis.
HorizontalBracing | The instance should be considered to be horizontal bracing for the purpose of structural analysis.
Brace | The instance should be considered to be a brace for the purpose of structural analysis.
Other | The instance should be considered for the structural analysis but its purpose is not clearly defined.
Purlin | The instance should be considered to be a purlin for the purpose of structural analysis.
Joist | The instance should be considered to be a joist for the purpose of structural analysis.
Girder | The instance should be considered to be a girder for the purpose of structural analysis.
Column | The instance should be considered to be a column for the purpose of structural analysis.
Wall | The instance should be considered to be a wall for the purpose of structural analysis.
Undefined | The instance has no predefined usage.

See Also

Autodesk.Revit.Structural.Enums Namespace


Material Enumeration
CollapseAll image DropDown image

Basic solid structural object material types.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("514AE874-4CD8-4a82-B382-F3639007B731")]
public enum Material
Visual Basic (Declaration)
<GuidAttribute("514AE874-4CD8-4a82-B382-F3639007B731")> _
Public Enumeration Material
Visual C++
[GuidAttribute(L"514AE874-4CD8-4a82-B382-F3639007B731")]
public enum class Material

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
PrecastConcrete | The object is considered to be made of precast concrete.
Other | The material is defined, but it is not steel, concrete , wood or precast concrete.
Wood | The object is considered to be made of wood.
Concrete | The object is considered to be made of concrete.
Steel | The object is considered to be made of steel.
Undefined | The material for this object has not been defined.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarHookOrientation Enumeration
CollapseAll image DropDown image

Orientation of a rebar hook relative to the path of the Rebar Shape.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5F638191-248D-4e11-9011-478BAEF4DD5D")]
public enum RebarHookOrientation
Visual Basic (Declaration)
<GuidAttribute("5F638191-248D-4e11-9011-478BAEF4DD5D")> _
Public Enumeration RebarHookOrientation
Visual C++
[GuidAttribute(L"5F638191-248D-4e11-9011-478BAEF4DD5D")]
public enum class RebarHookOrientation

Members

Member name | Description
Right | Hook towards the right of a segment-based shape (RebarShapeDefinitionBySegments), or to the exterior of an arc-based shape (RebarShapeDefinitionByArc).
Left | Hook towards the left of a segment-based shape (RebarShapeDefinitionBySegments), or to the interior of an arc-based shape (RebarShapeDefinitionByArc).

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarShapeArcReferenceType Enumeration
CollapseAll image DropDown image

A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D7D65FC8-899D-4fe0-A0B0-C054251EE5DD")]
public enum RebarShapeArcReferenceType
Visual Basic (Declaration)
<GuidAttribute("D7D65FC8-899D-4fe0-A0B0-C054251EE5DD")> _
Public Enumeration RebarShapeArcReferenceType
Visual C++
[GuidAttribute(L"D7D65FC8-899D-4fe0-A0B0-C054251EE5DD")]
public enum class RebarShapeArcReferenceType

Members

Member name | Description
External | Measure to the exterior of the bend.
Centerline | Measure to the centerline of the bar.
Internal | Measure to the interior of the bend.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarShapeBendAngle Enumeration
CollapseAll image DropDown image

A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7CEB4F38-64CD-498f-B361-3DFA89B4FDCF")]
public enum RebarShapeBendAngle
Visual Basic (Declaration)
<GuidAttribute("7CEB4F38-64CD-498f-B361-3DFA89B4FDCF")> _
Public Enumeration RebarShapeBendAngle
Visual C++
[GuidAttribute(L"7CEB4F38-64CD-498f-B361-3DFA89B4FDCF")]
public enum class RebarShapeBendAngle

Members

Member name | Description
Right | The angle is 90 degrees.
Reversal | The angle is 180 degrees; the bar bends back on itself.
Obtuse | The angle is between 90 and 180 degrees.
Acute | The angle is less than 90 degrees.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarShapeDefinitionByArcType Enumeration
CollapseAll image DropDown image

A RebarShapeDefinitionByArc takes one of three forms.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("95A663A7-A95F-4080-AAAD-48CE6F315D12")]
public enum RebarShapeDefinitionByArcType
Visual Basic (Declaration)
<GuidAttribute("95A663A7-A95F-4080-AAAD-48CE6F315D12")> _
Public Enumeration RebarShapeDefinitionByArcType
Visual C++
[GuidAttribute(L"95A663A7-A95F-4080-AAAD-48CE6F315D12")]
public enum class RebarShapeDefinitionByArcType

Members

Member name | Description
LappedCircle | A full circle, subtending an angle more than 360 degrees and less than 720 degrees. The behavior in Revit is the same as Arc, but an extra complete circle is included in the rebar.
Arc | An arc, subtending an angle less than 360 degrees.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarStyle Enumeration
CollapseAll image DropDown image

Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6e20bbaf-da67-4b18-935f-0887928dc84a")]
public enum RebarStyle
Visual Basic (Declaration)
<GuidAttribute("6e20bbaf-da67-4b18-935f-0887928dc84a")> _
Public Enumeration RebarStyle
Visual C++
[GuidAttribute(L"6e20bbaf-da67-4b18-935f-0887928dc84a")]
public enum class RebarStyle

Members

Member name | Description
StirrupTie | A stirrup or tie bar.
Standard | A standard or longitudinal bar.

See Also

Autodesk.Revit.Structural.Enums Namespace


SlabFoundationType Enumeration
CollapseAll image DropDown image

SlabFoundation type.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FE020C82-04D1-4ce6-9E14-AAAB8D6C4CEE")]
public enum SlabFoundationType
Visual Basic (Declaration)
<GuidAttribute("FE020C82-04D1-4ce6-9E14-AAAB8D6C4CEE")> _
Public Enumeration SlabFoundationType
Visual C++
[GuidAttribute(L"FE020C82-04D1-4ce6-9E14-AAAB8D6C4CEE")]
public enum class SlabFoundationType

Members

Member name | Description
SlabOnGrade | SlabFoundationType is SlabOnGrade.
SlabFoundation | SlabFoundationType is SlabFoundation.
Slab | SlabFoundationType is Slab.

See Also

Autodesk.Revit.Structural.Enums Namespace


StructuralType Enumeration
CollapseAll image DropDown image

Fundamental structural component category.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("73FA611B-2972-4d34-AFD3-C7663644DB14")]
public enum StructuralType
Visual Basic (Declaration)
<GuidAttribute("73FA611B-2972-4d34-AFD3-C7663644DB14")> _
Public Enumeration StructuralType
Visual C++
[GuidAttribute(L"73FA611B-2972-4d34-AFD3-C7663644DB14")]
public enum class StructuralType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
UnknownFraming | The structural type of the object is unknow.
Footing | The object is considered to be a footing.
Column | The object is considered too be a column.
Brace | The object is considered to be a brace.
Beam | The object is considered to be a beam.
NonStructural | The object is considered to be non structural in nature.

See Also

Autodesk.Revit.Structural.Enums Namespace


TranslationRotationValue Enumeration
CollapseAll image DropDown image

Values for BoundaryConditions Translation and Rotation parameters.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("03D9CCEF-8582-4fb1-AF20-B41F159B5039")]
public enum TranslationRotationValue
Visual Basic (Declaration)
<GuidAttribute("03D9CCEF-8582-4fb1-AF20-B41F159B5039")> _
Public Enumeration TranslationRotationValue
Visual C++
[GuidAttribute(L"03D9CCEF-8582-4fb1-AF20-B41F159B5039")]
public enum class TranslationRotationValue

Members

Member name | Description
Spring | TranslationRotationValue is Spring.
Fixed | TranslationRotationValue is Fixed.
Release | TranslationRotationValue is Release.

See Also

Autodesk.Revit.Structural.Enums Namespace


WallUsage Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible structural usage cases for a Wall object.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A8311F50-E519-4df0-93D3-13229E723261")]
public enum WallUsage
Visual Basic (Declaration)
<GuidAttribute("A8311F50-E519-4df0-93D3-13229E723261")> _
Public Enumeration WallUsage
Visual C++
[GuidAttribute(L"A8311F50-E519-4df0-93D3-13229E723261")]
public enum class WallUsage

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Combined | The wall is subject to combined loads.
Shear | The wall is subject to shear loads.
Bearing | The wall is to be consisdered as load bearing for structural analysis.
NonBearing | The wall is considered non load bearing for structural analysis.

See Also

Autodesk.Revit.Structural.Enums Namespace


Autodesk.Revit.Symbols Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Symbols
Visual Basic (Declaration)
Namespace Autodesk.Revit.Symbols
Visual C++
namespace Autodesk.Revit.Symbols

Classes

 | Class | Description
Public class | AnnotationSymbolType | An object that represents a dimension style.
Public class | AnnotationSymbolTypeSet | A set that contains AnnotationSymbol types.
Public class | AnnotationSymbolTypeSetIterator | An iterator to a AnnotationSymbol type set.
Public class | AreaLoadType | An object that represents a dimension style.
Public class | AreaLoadTypeSet | A set that contains areaload types.
Public class | AreaLoadTypeSetIterator | An iterator to a areaload type set.
Public class | AreaReinforcementType | An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
Public class | AreaTagType | An object that represents a dimension style.
Public class | AreaTagTypeSet | A set that contains areatag types.
Public class | AreaTagTypeSetIterator | An iterator to a areatag type set.
Public class | BeamSystemType | An object that specifies the type of a beam system in Autodesk Revit.
Public class | BeamSystemTypeSet | A set that contains BeamSystem types.
Public class | BeamSystemTypeSetIterator | An iterator to a BeamSystem type set.
Public class | ContFootingType | An object that specifies the type of a continuous footing in Autodesk Revit.
Public class | ContFootingTypeSet | A set that contains ContFooting types.
Public class | ContFootingTypeSetIterator | An iterator to a ContFooting type set.
Public class | CurtainSystemType | An object that represents CurtainSystem type.
Public class | CurtainSystemTypeSet | A set that contains CurtainSystem types.
Public class | CurtainSystemTypeSetIterator | An iterator to a CurtainSystem type set.
Public class | DemandFactor | Represents a demand factor, which let you adjust the rating of the main service for a building based on the expectation that, at any given time, not all of the electrical equipment will not be drawing at its full rated load. You can specify one or more Demand Factors, applying different Demand Factors to Lighting, Power, HVAC, or Other systems in your project based on their load.
Public class | DimensionType | An object that represents a dimension style.
Public class | DimensionTypeSet | A set that contains dimension types.
Public class | DimensionTypeSetIterator | An iterator to a dimension type set.
Public class | DistributionSysType | Represents a specific type of distribution system.
Public class | DistributionSysTypeSet | A set that contains DistributionSys types.
Public class | DistributionSysTypeSetIterator | An iterator to a DistributionSys type set.
Public class | FamilySymbol | Represents a single Type within a Family.
Public class | FamilySymbolSet | A set that can contain family symbols.
Public class | FamilySymbolSetIterator | An iterator to a family symbol set.
Public class | FasciaType | An object that represents the fascia type in Autodesk Revit.
Public class | FasciaTypeSet | A set that contains fascia types.
Public class | FasciaTypeSetIterator | An iterator to a fascia type set.
Public class | FloorType | An object that specifies the type of a floor in Autodesk Revit.
Public class | FloorTypeSet | A set that contains floor types.
Public class | FloorTypeSetIterator | An iterator to a floor type set.
Public class | GridType | An object that represents a dimension style.
Public class | GridTypeSet | A set that contains grid types.
Public class | GridTypeSetIterator | An iterator to a grid type set.
Public class | GroupType | Represents a type of a user defined group.
Public class | GutterType | An object that represents the gutter type in Autodesk Revit.
Public class | GutterTypeSet | A set that contains gutter types.
Public class | GutterTypeSetIterator | An iterator to a gutter type set.
Public class | HostedSweepType | An object that represents the attributes for sweep host objects in Autodesk Revit.
Public class | HostObjAttributes | An object that represents characteristics of several kinds of type.
Public class | InsertableObject | A base class you all types that are insertable.
Public class | LevelType | An object that represents a dimension style.
Public class | LevelTypeSet | A set that contains level types.
Public class | LevelTypeSetIterator | An iterator to a level type set.
Public class | LineAndTextAttrSymbol | An object that represents a dimension style.
Public class | LineLoadType | An object that represents a dimension style.
Public class | LineLoadTypeSet | A set that contains lineload types.
Public class | LineLoadTypeSetIterator | An iterator to a lineload type set.
Public class | LoadTypeBase | An object that represents a dimension style.
Public class | LoadTypeBaseSet | A set that contains load type bases.
Public class | LoadTypeBaseSetIterator | An iterator to a load type base set.
Public class | MEPBuildingConstruction | Construction definition for Project Information.
Public class | MEPBuildingConstructionSet | A set that contains MEPBuildingConstructions.
Public class | MEPBuildingConstructionSetIterator | An iterator to a MEPBuildingConstruction set.
Public class | MullionType | An object that represents a dimension style.
Public class | MullionTypeSet | A set that contains mullion types.
Public class | MullionTypeSetIterator | An iterator to a mullion type set.
Public class | PanelType | An object that represents a dimension style.
Public class | PanelTypeSet | A set that contains panel types.
Public class | PanelTypeSetIterator | An iterator to a panel type set.
Public class | PathReinforcementType | An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
Public class | PointLoadType | An object that represents a dimension style.
Public class | PointLoadTypeSet | A set that contains pointload types.
Public class | PointLoadTypeSetIterator | An iterator to a pointload type set.
Public class | RebarBarType | A Rebar type object that is used in the generation of Rebar.
Public class | RebarBarTypeSet | A set that contains RebarBar types.
Public class | RebarBarTypeSetIterator | An iterator to a RebarBar type set.
Public class | RebarCoverType | A Rebar Cover setting. This element functions as a name-value pair for Rebar Cover Settings.
Public class | RebarCoverTypeSet | A set that contains RebarCover types.
Public class | RebarCoverTypeSetIterator | An iterator to a RebarCover type set.
Public class | RebarHookType | A Rebar Hook type object that is used in the generation of Rebar.
Public class | RebarHookTypeSet | A set that contains RebarHook types.
Public class | RebarHookTypeSetIterator | An iterator to a RebarHook type set.
Public class | RebarShape | RebarShape specifies the shape type for a Rebar instance.
Public class | RebarShapeDefinition | A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.
Public class | RebarShapeDefinitionByArc | Definition of a shape whose size and position can determined by a single arc.
Public class | RebarShapeDefinitionBySegments | Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
Public class | RebarShapeSet | An set that contains rebar shapes.
Public class | RebarShapeSetIterator | An iterator to a rebar shape set.
Public class | RoofType | Represents a specific type of roof.
Public class | RoofTypeSet | A set that contains roof types.
Public class | RoofTypeSetIterator | An iterator to a roof type set.
Public class | RoomTagType | An object that represents a dimension style.
Public class | RoomTagTypeSet | A set that contains room tag types.
Public class | RoomTagTypeSetIterator | An iterator to a room tag type set.
Public class | SlabEdgeType | An object that represents the slab edge type in Autodesk Revit.
Public class | SlabEdgeTypeSet | A set that contains slab edge types.
Public class | SlabEdgeTypeSetIterator | An iterator to a slab edge type set.
Public class | SpaceTagType | An object that represents a dimension style.
Public class | SpaceTagTypeSet | A set that contains space tag types.
Public class | SpaceTagTypeSetIterator | An iterator to a space tag type set.
Public class | SpotDimensionType | An object that specifies the type of a spot dimension in Autodesk Revit.
Public class | SpotDimensionTypeSet | A set that contains spotdimension types.
Public class | SpotDimensionTypeSetIterator | An iterator to a spotdimension type set.
Public class | TextElementType | An object that represents a dimension style.
Public class | TextNoteType | An object that represents a dimension style.
Public class | TextNoteTypeSet | A set that contains textnote types.
Public class | TextNoteTypeSetIterator | An iterator to a textnote type set.
Public class | TrussType | Represents a specific type of truss.
Public class | TrussTypeSet | A set that contains Truss types.
Public class | TrussTypeSetIterator | An iterator to a Truss type set.
Public class | VoltageType | Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.
Public class | VoltageTypeSet | A set that contains voltage types.
Public class | VoltageTypeSetIterator | An iterator to a voltage type set.
Public class | WallType | Represents a specific type of wall, such as 'Generic -8" '.
Public class | WallTypeSet | A set that contains wall types.
Public class | WallTypeSetIterator | An iterator to a wall type set.
Public class | WireType | Represents a specific wire type.
Public class | WireTypeSet | A set that contains wire types.
Public class | WireTypeSetIterator | An iterator to a wire type set.

Enumerations

 | Enumeration | Description
Public enumeration | WallType..::WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
Public enumeration | WireType..::NeutralMode | An enumerate type to list the neutral mode for wire type.


AnnotationSymbolType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A6EDA38F-8CD4-47cd-A016-022FF68A3567")]
public class AnnotationSymbolType : FamilySymbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A6EDA38F-8CD4-47cd-A016-022FF68A3567")> _
Public Class AnnotationSymbolType _
    Inherits FamilySymbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A6EDA38F-8CD4-47cd-A016-022FF68A3567")]
public ref class AnnotationSymbolType : public FamilySymbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol
Autodesk.Revit.Symbols..::AnnotationSymbolType

See Also

AnnotationSymbolType Members
Autodesk.Revit.Symbols Namespace


AnnotationSymbolType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbolType
Visual Basic (Declaration)
Public Class AnnotationSymbolType
Visual C++
public ref class AnnotationSymbolType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnnotationSymbolTypeAnnotationSymbolTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AnnotationSymbolType
Autodesk.Revit.Symbols Namespace


AnnotationSymbolType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbolType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbolType Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains AnnotationSymbol types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D209D344-26BB-4d06-8F69-EE0864E056DB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnnotationSymbolTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("D209D344-26BB-4d06-8F69-EE0864E056DB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnnotationSymbolTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"D209D344-26BB-4d06-8F69-EE0864E056DB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnnotationSymbolTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::AnnotationSymbolTypeSet

See Also

AnnotationSymbolTypeSet Members
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbolTypeSet
Visual Basic (Declaration)
Public Class AnnotationSymbolTypeSet
Visual C++
public ref class AnnotationSymbolTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnnotationSymbolTypeSetAnnotationSymbolTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a AnnotationSymbol type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified AnnotationSymbol type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified AnnotationSymbol type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbolTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSet ()

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbolTypeSet
Visual Basic (Declaration)
Public Class AnnotationSymbolTypeSet
Visual C++
public ref class AnnotationSymbolTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a AnnotationSymbol type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified AnnotationSymbol type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified AnnotationSymbol type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AnnotationSymbolTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

AnnotationSymbolTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every AnnotationSymbol type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

AnnotationSymbolTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a AnnotationSymbol type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    AnnotationSymbolType^ item
)

Parameters

item
AnnotationSymbolType
The AnnotationSymbol type to be searched for.

Return Value

The Contains method returns True if the AnnotationSymbol type is within the set, otherwise False.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

AnnotationSymbolTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

AnnotationSymbolTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified AnnotationSymbol type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AnnotationSymbolType _
) As Integer
Visual C++
public:
virtual int Erase (
    AnnotationSymbolType^ item
)

Parameters

item
AnnotationSymbolType
The AnnotationSymbol type to be erased.

Return Value

The number of AnnotationSymbol types that were erased from the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

AnnotationSymbolTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

AnnotationSymbolTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

AnnotationSymbolTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified AnnotationSymbol type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    AnnotationSymbolType^ item
)

Parameters

item
AnnotationSymbolType
The AnnotationSymbol type to be inserted into the set.

Return Value

Returns whether the AnnotationSymbol type was inserted into the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

AnnotationSymbolTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

AnnotationSymbolTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbolTypeSet
Visual Basic (Declaration)
Public Class AnnotationSymbolTypeSet
Visual C++
public ref class AnnotationSymbolTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

AnnotationSymbolTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

AnnotationSymbolTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of AnnotationSymbol types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a AnnotationSymbol type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9385D613-E70E-4ff1-83D3-BDCD0381976F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class AnnotationSymbolTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("9385D613-E70E-4ff1-83D3-BDCD0381976F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class AnnotationSymbolTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"9385D613-E70E-4ff1-83D3-BDCD0381976F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnnotationSymbolTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::AnnotationSymbolTypeSetIterator

See Also

AnnotationSymbolTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class AnnotationSymbolTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AnnotationSymbolTypeSetIterator
Visual C++
public ref class AnnotationSymbolTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnnotationSymbolTypeSetIteratorAnnotationSymbolTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbolTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class AnnotationSymbolTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AnnotationSymbolTypeSetIterator
Visual C++
public ref class AnnotationSymbolTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AnnotationSymbolTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

AnnotationSymbolTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

AnnotationSymbolTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

AnnotationSymbolTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

AnnotationSymbolTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class AnnotationSymbolTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AnnotationSymbolTypeSetIterator
Visual C++
public ref class AnnotationSymbolTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

AnnotationSymbolTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaLoadType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("93199EDC-E5D7-4c3f-A762-AB4F745929EF")]
public class AreaLoadType : LoadTypeBase
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("93199EDC-E5D7-4c3f-A762-AB4F745929EF")> _
Public Class AreaLoadType _
    Inherits LoadTypeBase
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"93199EDC-E5D7-4c3f-A762-AB4F745929EF")]
public ref class AreaLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LoadTypeBase
Autodesk.Revit.Symbols..::AreaLoadType

See Also

AreaLoadType Members
Autodesk.Revit.Symbols Namespace


AreaLoadType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaLoadType
Visual Basic (Declaration)
Public Class AreaLoadType
Visual C++
public ref class AreaLoadType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaLoadTypeAreaLoadTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoadType
Autodesk.Revit.Symbols Namespace


AreaLoadType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoadType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoadType Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains areaload types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E457C057-A65D-4f02-897F-0F80E5D39967")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AreaLoadTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("E457C057-A65D-4f02-897F-0F80E5D39967")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AreaLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"E457C057-A65D-4f02-897F-0F80E5D39967")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::AreaLoadTypeSet

See Also

AreaLoadTypeSet Members
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaLoadTypeSet
Visual Basic (Declaration)
Public Class AreaLoadTypeSet
Visual C++
public ref class AreaLoadTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaLoadTypeSetAreaLoadTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every areaload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areaload type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areaload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areaload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadTypeSet ()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class AreaLoadTypeSet
Visual Basic (Declaration)
Public Class AreaLoadTypeSet
Visual C++
public ref class AreaLoadTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every areaload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areaload type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areaload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areaload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AreaLoadTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

AreaLoadTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every areaload type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

AreaLoadTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a areaload type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    AreaLoadType^ item
)

Parameters

item
AreaLoadType
The areaload type to be searched for.

Return Value

The Contains method returns True if the areaload type is within the set, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

AreaLoadTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

AreaLoadTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified areaload type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AreaLoadType _
) As Integer
Visual C++
public:
virtual int Erase (
    AreaLoadType^ item
)

Parameters

item
AreaLoadType
The areaload type to be erased.

Return Value

The number of areaload types that were erased from the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

AreaLoadTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AreaLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

AreaLoadTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

AreaLoadTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified areaload type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    AreaLoadType^ item
)

Parameters

item
AreaLoadType
The areaload type to be inserted into the set.

Return Value

Returns whether the areaload type was inserted into the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

AreaLoadTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

AreaLoadTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AreaLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaLoadTypeSet
Visual Basic (Declaration)
Public Class AreaLoadTypeSet
Visual C++
public ref class AreaLoadTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

AreaLoadTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

AreaLoadTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of areaload types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a areaload type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CE53DA69-D038-4130-BA20-18A2F75BA9E6")]
public abstract class AreaLoadTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CE53DA69-D038-4130-BA20-18A2F75BA9E6")> _
Public MustInherit Class AreaLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CE53DA69-D038-4130-BA20-18A2F75BA9E6")]
public ref class AreaLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::AreaLoadTypeSetIterator

See Also

AreaLoadTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class AreaLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AreaLoadTypeSetIterator
Visual C++
public ref class AreaLoadTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaLoadTypeSetIteratorAreaLoadTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class AreaLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AreaLoadTypeSetIterator
Visual C++
public ref class AreaLoadTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AreaLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

AreaLoadTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

AreaLoadTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

AreaLoadTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

AreaLoadTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class AreaLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AreaLoadTypeSetIterator
Visual C++
public ref class AreaLoadTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

AreaLoadTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("69D1DB51-B014-4d84-99BB-04CB3A5E051E")]
public class AreaReinforcementType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("69D1DB51-B014-4d84-99BB-04CB3A5E051E")> _
Public Class AreaReinforcementType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"69D1DB51-B014-4d84-99BB-04CB3A5E051E")]
public ref class AreaReinforcementType : public Symbol

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::AreaReinforcementType

See Also

AreaReinforcementType Members
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcementType
Visual Basic (Declaration)
Public Class AreaReinforcementType
Visual C++
public ref class AreaReinforcementType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaReinforcementTypeAreaReinforcementTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcementType
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaReinforcementType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaReinforcementType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaReinforcementType Class
Autodesk.Revit.Symbols Namespace


AreaTagType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3CA818A9-8EF8-4D67-B079-1FBD19C5A553")]
public class AreaTagType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3CA818A9-8EF8-4D67-B079-1FBD19C5A553")> _
Public Class AreaTagType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3CA818A9-8EF8-4D67-B079-1FBD19C5A553")]
public ref class AreaTagType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::AreaTagType

See Also

AreaTagType Members
Autodesk.Revit.Symbols Namespace


AreaTagType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaTagType
Visual Basic (Declaration)
Public Class AreaTagType
Visual C++
public ref class AreaTagType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaTagTypeAreaTagTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaTagType
Autodesk.Revit.Symbols Namespace


AreaTagType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaTagType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTagType Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains areatag types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CC927E18-4D2A-4029-A443-AB4A7F5B3389")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AreaTagTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("CC927E18-4D2A-4029-A443-AB4A7F5B3389")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AreaTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"CC927E18-4D2A-4029-A443-AB4A7F5B3389")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::AreaTagTypeSet

See Also

AreaTagTypeSet Members
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaTagTypeSet
Visual Basic (Declaration)
Public Class AreaTagTypeSet
Visual C++
public ref class AreaTagTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaTagTypeSetAreaTagTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every areatag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areatag type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areatag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areatag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagTypeSet ()

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class AreaTagTypeSet
Visual Basic (Declaration)
Public Class AreaTagTypeSet
Visual C++
public ref class AreaTagTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every areatag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areatag type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areatag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areatag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AreaTagTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

AreaTagTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every areatag type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

AreaTagTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a areatag type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    AreaTagType^ item
)

Parameters

item
AreaTagType
The areatag type to be searched for.

Return Value

The Contains method returns True if the areatag type is within the set, otherwise False.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

AreaTagTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

AreaTagTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified areatag type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AreaTagType _
) As Integer
Visual C++
public:
virtual int Erase (
    AreaTagType^ item
)

Parameters

item
AreaTagType
The areatag type to be erased.

Return Value

The number of areatag types that were erased from the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

AreaTagTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AreaTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

AreaTagTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

AreaTagTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified areatag type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    AreaTagType^ item
)

Parameters

item
AreaTagType
The areatag type to be inserted into the set.

Return Value

Returns whether the areatag type was inserted into the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

AreaTagTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

AreaTagTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AreaTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaTagTypeSet
Visual Basic (Declaration)
Public Class AreaTagTypeSet
Visual C++
public ref class AreaTagTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

AreaTagTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

AreaTagTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of areatag types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a areatag type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1911A18F-35B6-4D42-B9B5-BFA6E303FEBE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class AreaTagTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("1911A18F-35B6-4D42-B9B5-BFA6E303FEBE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class AreaTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"1911A18F-35B6-4D42-B9B5-BFA6E303FEBE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::AreaTagTypeSetIterator

See Also

AreaTagTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class AreaTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AreaTagTypeSetIterator
Visual C++
public ref class AreaTagTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaTagTypeSetIteratorAreaTagTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class AreaTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AreaTagTypeSetIterator
Visual C++
public ref class AreaTagTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AreaTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

AreaTagTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

AreaTagTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

AreaTagTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

AreaTagTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class AreaTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class AreaTagTypeSetIterator
Visual C++
public ref class AreaTagTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

AreaTagTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


BeamSystemType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a beam system in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9F133549-7A7E-4f00-B64E-975A06DEE81A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BeamSystemType : Symbol
Visual Basic (Declaration)
<GuidAttribute("9F133549-7A7E-4f00-B64E-975A06DEE81A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BeamSystemType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"9F133549-7A7E-4f00-B64E-975A06DEE81A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BeamSystemType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::BeamSystemType

See Also

BeamSystemType Members
Autodesk.Revit.Symbols Namespace


BeamSystemType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BeamSystemType
Visual Basic (Declaration)
Public Class BeamSystemType
Visual C++
public ref class BeamSystemType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BeamSystemTypeBeamSystemTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BeamSystemType
Autodesk.Revit.Symbols Namespace


BeamSystemType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystemType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BeamSystemType Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains BeamSystem types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6FB6A3F0-325A-4a31-AC2B-B618F875FACB")]
public class BeamSystemTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6FB6A3F0-325A-4a31-AC2B-B618F875FACB")> _
Public Class BeamSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6FB6A3F0-325A-4a31-AC2B-B618F875FACB")]
public ref class BeamSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::BeamSystemTypeSet

See Also

BeamSystemTypeSet Members
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BeamSystemTypeSet
Visual Basic (Declaration)
Public Class BeamSystemTypeSet
Visual C++
public ref class BeamSystemTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BeamSystemTypeSetBeamSystemTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every BeamSystem type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a BeamSystem type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified BeamSystem type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified BeamSystem type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of BeamSystem types that are in the set.

See Also

BeamSystemTypeSet
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystemTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemTypeSet ()

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class BeamSystemTypeSet
Visual Basic (Declaration)
Public Class BeamSystemTypeSet
Visual C++
public ref class BeamSystemTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every BeamSystem type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a BeamSystem type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified BeamSystem type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified BeamSystem type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BeamSystemTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

BeamSystemTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every BeamSystem type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

BeamSystemTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a BeamSystem type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    BeamSystemType^ item
)

Parameters

item
BeamSystemType
The BeamSystem type to be searched for.

Return Value

The Contains method returns True if the BeamSystem type is within the set, otherwise False.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

BeamSystemTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

BeamSystemTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified BeamSystem type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As BeamSystemType _
) As Integer
Visual C++
public:
virtual int Erase (
    BeamSystemType^ item
)

Parameters

item
BeamSystemType
The BeamSystem type to be erased.

Return Value

The number of BeamSystem types that were erased from the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

BeamSystemTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BeamSystemTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

BeamSystemTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

BeamSystemTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified BeamSystem type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    BeamSystemType^ item
)

Parameters

item
BeamSystemType
The BeamSystem type to be inserted into the set.

Return Value

Returns whether the BeamSystem type was inserted into the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

BeamSystemTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

BeamSystemTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BeamSystemTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class BeamSystemTypeSet
Visual Basic (Declaration)
Public Class BeamSystemTypeSet
Visual C++
public ref class BeamSystemTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of BeamSystem types that are in the set.

See Also

BeamSystemTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

BeamSystemTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

BeamSystemTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of BeamSystem types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a BeamSystem type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("143217D6-F201-4d4a-A359-29CB7074527D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BeamSystemTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("143217D6-F201-4d4a-A359-29CB7074527D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BeamSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"143217D6-F201-4d4a-A359-29CB7074527D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BeamSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::BeamSystemTypeSetIterator

See Also

BeamSystemTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class BeamSystemTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class BeamSystemTypeSetIterator
Visual C++
public ref class BeamSystemTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BeamSystemTypeSetIteratorBeamSystemTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystemTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class BeamSystemTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class BeamSystemTypeSetIterator
Visual C++
public ref class BeamSystemTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

BeamSystemTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

BeamSystemTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

BeamSystemTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

BeamSystemTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

BeamSystemTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class BeamSystemTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class BeamSystemTypeSetIterator
Visual C++
public ref class BeamSystemTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

BeamSystemTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ContFootingType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a continuous footing in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AC21A9E3-31E6-4f45-9436-5CF05377C60D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ContFootingType : HostObjAttributes
Visual Basic (Declaration)
<GuidAttribute("AC21A9E3-31E6-4f45-9436-5CF05377C60D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ContFootingType _
    Inherits HostObjAttributes
Visual C++
[GuidAttribute(L"AC21A9E3-31E6-4f45-9436-5CF05377C60D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ContFootingType : public HostObjAttributes

Remarks

The structural layers of the continuous footing can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::ContFootingType

See Also

ContFootingType Members
Autodesk.Revit.Symbols Namespace


ContFootingType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ContFootingType
Visual Basic (Declaration)
Public Class ContFootingType
Visual C++
public ref class ContFootingType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ContFootingTypeContFootingTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ContFootingType
Autodesk.Revit.Symbols Namespace


ContFootingType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ContFootingType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFootingType Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains ContFooting types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A06A0804-B219-48bd-A0F3-F776805C1470")]
public class ContFootingTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A06A0804-B219-48bd-A0F3-F776805C1470")> _
Public Class ContFootingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A06A0804-B219-48bd-A0F3-F776805C1470")]
public ref class ContFootingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::ContFootingTypeSet

See Also

ContFootingTypeSet Members
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ContFootingTypeSet
Visual Basic (Declaration)
Public Class ContFootingTypeSet
Visual C++
public ref class ContFootingTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ContFootingTypeSetContFootingTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every ContFooting type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a ContFooting type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified ContFooting type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified ContFooting type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ContFootingTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingTypeSet ()

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ContFootingTypeSet
Visual Basic (Declaration)
Public Class ContFootingTypeSet
Visual C++
public ref class ContFootingTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every ContFooting type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a ContFooting type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified ContFooting type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified ContFooting type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ContFootingTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

ContFootingTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every ContFooting type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

ContFootingTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a ContFooting type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    ContFootingType^ item
)

Parameters

item
ContFootingType
The ContFooting type to be searched for.

Return Value

The Contains method returns True if the ContFooting type is within the set, otherwise False.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

ContFootingTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

ContFootingTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified ContFooting type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ContFootingType _
) As Integer
Visual C++
public:
virtual int Erase (
    ContFootingType^ item
)

Parameters

item
ContFootingType
The ContFooting type to be erased.

Return Value

The number of ContFooting types that were erased from the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

ContFootingTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ContFootingTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

ContFootingTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

ContFootingTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified ContFooting type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    ContFootingType^ item
)

Parameters

item
ContFootingType
The ContFooting type to be inserted into the set.

Return Value

Returns whether the ContFooting type was inserted into the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

ContFootingTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

ContFootingTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ContFootingTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class ContFootingTypeSet
Visual Basic (Declaration)
Public Class ContFootingTypeSet
Visual C++
public ref class ContFootingTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

ContFootingTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

ContFootingTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of ContFooting types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a ContFooting type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4BF3B989-A863-4340-A4F8-3CE38550FF11")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ContFootingTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("4BF3B989-A863-4340-A4F8-3CE38550FF11")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ContFootingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"4BF3B989-A863-4340-A4F8-3CE38550FF11")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ContFootingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::ContFootingTypeSetIterator

See Also

ContFootingTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class ContFootingTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class ContFootingTypeSetIterator
Visual C++
public ref class ContFootingTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ContFootingTypeSetIteratorContFootingTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ContFootingTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class ContFootingTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class ContFootingTypeSetIterator
Visual C++
public ref class ContFootingTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ContFootingTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

ContFootingTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

ContFootingTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

ContFootingTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

ContFootingTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class ContFootingTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class ContFootingTypeSetIterator
Visual C++
public ref class ContFootingTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

ContFootingTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


CurtainSystemType Class
See Also Members
CollapseAll image DropDown image

An object that represents CurtainSystem type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("62C719D0-0675-43ca-9B9A-10BF87F569DE")]
public class CurtainSystemType : HostObjAttributes
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("62C719D0-0675-43ca-9B9A-10BF87F569DE")> _
Public Class CurtainSystemType _
    Inherits HostObjAttributes
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"62C719D0-0675-43ca-9B9A-10BF87F569DE")]
public ref class CurtainSystemType : public HostObjAttributes

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::CurtainSystemType

See Also

CurtainSystemType Members
Autodesk.Revit.Symbols Namespace


CurtainSystemType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystemType
Visual Basic (Declaration)
Public Class CurtainSystemType
Visual C++
public ref class CurtainSystemType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainSystemTypeCurtainSystemTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystemType
Autodesk.Revit.Symbols Namespace


CurtainSystemType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystemType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemType Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains CurtainSystem types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("32D88D78-78D3-4ff8-BC33-C54D6F5031A3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurtainSystemTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("32D88D78-78D3-4ff8-BC33-C54D6F5031A3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurtainSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"32D88D78-78D3-4ff8-BC33-C54D6F5031A3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::CurtainSystemTypeSet

See Also

CurtainSystemTypeSet Members
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystemTypeSet
Visual Basic (Declaration)
Public Class CurtainSystemTypeSet
Visual C++
public ref class CurtainSystemTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainSystemTypeSetCurtainSystemTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every CurtainSystem type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a CurtainSystem type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified CurtainSystem type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified CurtainSystem type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystemTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemTypeSet ()

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystemTypeSet
Visual Basic (Declaration)
Public Class CurtainSystemTypeSet
Visual C++
public ref class CurtainSystemTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every CurtainSystem type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a CurtainSystem type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified CurtainSystem type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified CurtainSystem type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainSystemTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

CurtainSystemTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every CurtainSystem type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

CurtainSystemTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a CurtainSystem type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    CurtainSystemType^ item
)

Parameters

item
CurtainSystemType
The CurtainSystem type to be searched for.

Return Value

The Contains method returns True if the CurtainSystem type is within the set, otherwise False.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

CurtainSystemTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

CurtainSystemTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified CurtainSystem type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainSystemType _
) As Integer
Visual C++
public:
virtual int Erase (
    CurtainSystemType^ item
)

Parameters

item
CurtainSystemType
The CurtainSystem type to be erased.

Return Value

The number of CurtainSystem types that were erased from the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

CurtainSystemTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurtainSystemTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

CurtainSystemTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

CurtainSystemTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified CurtainSystem type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    CurtainSystemType^ item
)

Parameters

item
CurtainSystemType
The CurtainSystem type to be inserted into the set.

Return Value

Returns whether the CurtainSystem type was inserted into the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

CurtainSystemTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

CurtainSystemTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual CurtainSystemTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystemTypeSet
Visual Basic (Declaration)
Public Class CurtainSystemTypeSet
Visual C++
public ref class CurtainSystemTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

CurtainSystemTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

CurtainSystemTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of CurtainSystem types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a CurtainSystem type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2A20B8FD-5539-4f29-ADB4-CC772C208E8F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class CurtainSystemTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("2A20B8FD-5539-4f29-ADB4-CC772C208E8F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class CurtainSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"2A20B8FD-5539-4f29-ADB4-CC772C208E8F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::CurtainSystemTypeSetIterator

See Also

CurtainSystemTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainSystemTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainSystemTypeSetIterator
Visual C++
public ref class CurtainSystemTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainSystemTypeSetIteratorCurtainSystemTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystemTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainSystemTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainSystemTypeSetIterator
Visual C++
public ref class CurtainSystemTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainSystemTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

CurtainSystemTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

CurtainSystemTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

CurtainSystemTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

CurtainSystemTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class CurtainSystemTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class CurtainSystemTypeSetIterator
Visual C++
public ref class CurtainSystemTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

CurtainSystemTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DemandFactor Class
See Also Members
CollapseAll image DropDown image

Represents a demand factor, which let you adjust the rating of the main service for a building based on the expectation that, at any given time, not all of the electrical equipment will not be drawing at its full rated load. You can specify one or more Demand Factors, applying different Demand Factors to Lighting, Power, HVAC, or Other systems in your project based on their load.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5A8D81EE-BE77-4a53-9A17-845F6417FC59")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DemandFactor : Symbol
Visual Basic (Declaration)
<GuidAttribute("5A8D81EE-BE77-4a53-9A17-845F6417FC59")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DemandFactor _
    Inherits Symbol
Visual C++
[GuidAttribute(L"5A8D81EE-BE77-4a53-9A17-845F6417FC59")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DemandFactor : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::DemandFactor

See Also

DemandFactor Members
Autodesk.Revit.Symbols Namespace


DemandFactor Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DemandFactor
Visual Basic (Declaration)
Public Class DemandFactor
Visual C++
public ref class DemandFactor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DemandFactorDemandFactorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPercentage | Set percentage value for the specified range.
Public method | SetPercentageToInfinity | This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DataItems | Get all data items in this demand factor, which represents demand factor percentage in a specific range.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadClassification | Get category of demand factor.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DemandFactor
Autodesk.Revit.Symbols Namespace


DemandFactor Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DemandFactor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactor ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DemandFactor Class
Autodesk.Revit.Symbols Namespace


DemandFactor Methods
CollapseAll image DropDown image

Syntax

C#
public class DemandFactor
Visual Basic (Declaration)
Public Class DemandFactor
Visual C++
public ref class DemandFactor

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPercentage | Set percentage value for the specified range.
Public method | SetPercentageToInfinity | This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

DemandFactor
Autodesk.Revit.Symbols Namespace


SetPercentage Method

DemandFactor..::SetPercentage Method
CollapseAll image DropDown image

Set percentage value for the specified range.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetPercentage(
    long minFactor,
    long maxFactor,
    double percentage
)
Visual Basic (Declaration)
Public Sub SetPercentage ( _
    minFactor As Long, _
    maxFactor As Long, _
    percentage As Double _
)
Visual C++
public:
void SetPercentage (
    long long minFactor,
    long long maxFactor,
    double percentage
)

Parameters

minFactor
Int64
Lower boundary of the range.
maxFactor
Int64
Upper boundary of the range.
percentage
Double
Percentage value of this range.

Remarks

Demand factor data items have been obsolete after this operation, so they should be retrieved again before using. Use "SetFactorDataToInfinity" if the maxFactor value is positive infinity.

Exceptions

Exception | Condition
System..::ArgumentException | All three parameter can't be negative, maxFactor must be greater than minFactor, and minFactor and percentage can't be positive infinity, otherwise the exception will be thrown.

See Also

DemandFactor Class
Autodesk.Revit.Symbols Namespace


SetPercentageToInfinity Method

DemandFactor..::SetPercentageToInfinity Method
CollapseAll image DropDown image

This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetPercentageToInfinity(
    long minFactor,
    double percentage
)
Visual Basic (Declaration)
Public Sub SetPercentageToInfinity ( _
    minFactor As Long, _
    percentage As Double _
)
Visual C++
public:
void SetPercentageToInfinity (
    long long minFactor,
    double percentage
)

Parameters

minFactor
Int64
Lower boundary of the range.
percentage
Double
Percentage value of this range.

Remarks

Demand factor data items have been obsolete after this operation, so they should be retrieved again before using.

Exceptions

Exception | Condition
System..::ArgumentException | Both parameters can't be negative or positive infinity, otherwise the exception will be thrown.

See Also

DemandFactor Class
Autodesk.Revit.Symbols Namespace


DemandFactor Properties
CollapseAll image DropDown image

Syntax

C#
public class DemandFactor
Visual Basic (Declaration)
Public Class DemandFactor
Visual C++
public ref class DemandFactor

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DataItems | Get all data items in this demand factor, which represents demand factor percentage in a specific range.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadClassification | Get category of demand factor.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DemandFactor
Autodesk.Revit.Symbols Namespace


DataItems Property

DemandFactor..::DataItems Property
CollapseAll image DropDown image

Get all data items in this demand factor, which represents demand factor percentage in a specific range.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DemandFactorDataSet DataItems{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DataItems As DemandFactorDataSet
Visual C++
public:
property DemandFactorDataSet^ DataItems {
    DemandFactorDataSet^ get ();
}

See Also

DemandFactor Class
Autodesk.Revit.Symbols Namespace


LoadClassification Property

DemandFactor..::LoadClassification Property
CollapseAll image DropDown image

Get category of demand factor.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadClassification LoadClassification{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LoadClassification As LoadClassification
Visual C++
public:
property LoadClassification LoadClassification {
    LoadClassification get ();
}

See Also

DemandFactor Class
Autodesk.Revit.Symbols Namespace


Parameter Property

DemandFactor..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DemandFactor Class
DemandFactor Members
Autodesk.Revit.Symbols Namespace


DimensionType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4DB3A29F-C044-4959-AE64-9408013B8F82")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DimensionType : Symbol
Visual Basic (Declaration)
<GuidAttribute("4DB3A29F-C044-4959-AE64-9408013B8F82")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DimensionType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"4DB3A29F-C044-4959-AE64-9408013B8F82")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DimensionType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::DimensionType
Autodesk.Revit.Symbols..::SpotDimensionType

See Also

DimensionType Members
Autodesk.Revit.Symbols Namespace


DimensionType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DimensionType
Visual Basic (Declaration)
Public Class DimensionType
Visual C++
public ref class DimensionType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DimensionTypeDimensionTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DimensionType
Autodesk.Revit.Symbols Namespace


DimensionType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DimensionType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionType Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains dimension types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("92F8FF69-5F11-4614-81B8-2E3D5161DBEF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DimensionTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("92F8FF69-5F11-4614-81B8-2E3D5161DBEF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"92F8FF69-5F11-4614-81B8-2E3D5161DBEF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::DimensionTypeSet

See Also

DimensionTypeSet Members
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DimensionTypeSet
Visual Basic (Declaration)
Public Class DimensionTypeSet
Visual C++
public ref class DimensionTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DimensionTypeSetDimensionTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every dimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a dimension type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified dimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified dimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DimensionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionTypeSet ()

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class DimensionTypeSet
Visual Basic (Declaration)
Public Class DimensionTypeSet
Visual C++
public ref class DimensionTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every dimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a dimension type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified dimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified dimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DimensionTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

DimensionTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every dimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

DimensionTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a dimension type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    DimensionType^ item
)

Parameters

item
DimensionType
The dimension type to be searched for.

Return Value

The Contains method returns True if the dimension type is within the set, otherwise False.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

DimensionTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

DimensionTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified dimension type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DimensionType _
) As Integer
Visual C++
public:
virtual int Erase (
    DimensionType^ item
)

Parameters

item
DimensionType
The dimension type to be erased.

Return Value

The number of dimension types that were erased from the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

DimensionTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DimensionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

DimensionTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

DimensionTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified dimension type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    DimensionType^ item
)

Parameters

item
DimensionType
The dimension type to be inserted into the set.

Return Value

Returns whether the dimension type was inserted into the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

DimensionTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

DimensionTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DimensionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class DimensionTypeSet
Visual Basic (Declaration)
Public Class DimensionTypeSet
Visual C++
public ref class DimensionTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

DimensionTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

DimensionTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of dimension types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a dimension type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("92A36E5D-C542-426a-A9F3-3C7EAB39574D")]
public abstract class DimensionTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("92A36E5D-C542-426a-A9F3-3C7EAB39574D")> _
Public MustInherit Class DimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"92A36E5D-C542-426a-A9F3-3C7EAB39574D")]
public ref class DimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::DimensionTypeSetIterator

See Also

DimensionTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DimensionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class DimensionTypeSetIterator
Visual C++
public ref class DimensionTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DimensionTypeSetIteratorDimensionTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DimensionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DimensionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class DimensionTypeSetIterator
Visual C++
public ref class DimensionTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DimensionTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

DimensionTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

DimensionTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

DimensionTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

DimensionTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DimensionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class DimensionTypeSetIterator
Visual C++
public ref class DimensionTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

DimensionTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DistributionSysType Class
See Also Members
CollapseAll image DropDown image

Represents a specific type of distribution system.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FE87C57E-11CC-4bbb-B90F-FCCDB911D6EA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DistributionSysType : Symbol
Visual Basic (Declaration)
<GuidAttribute("FE87C57E-11CC-4bbb-B90F-FCCDB911D6EA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DistributionSysType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"FE87C57E-11CC-4bbb-B90F-FCCDB911D6EA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DistributionSysType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::DistributionSysType

See Also

DistributionSysType Members
Autodesk.Revit.Symbols Namespace


DistributionSysType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DistributionSysType
Visual Basic (Declaration)
Public Class DistributionSysType
Visual C++
public ref class DistributionSysType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DistributionSysTypeDistributionSysTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
Public property | ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Get the value which indicates whether this distribution system is in service now.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | NumWires | Get or set number of wires of distribution system.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VoltageLineToGround | Get or set line to ground voltage of distribution system type.
Public property | VoltageLineToLine | Get or set line to line voltage type of distribution system type.

See Also

DistributionSysType
Autodesk.Revit.Symbols Namespace


DistributionSysType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DistributionSysType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DistributionSysType Class
Autodesk.Revit.Symbols Namespace


DistributionSysType Properties
CollapseAll image DropDown image

Syntax

C#
public class DistributionSysType
Visual Basic (Declaration)
Public Class DistributionSysType
Visual C++
public ref class DistributionSysType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
Public property | ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Get the value which indicates whether this distribution system is in service now.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | NumWires | Get or set number of wires of distribution system.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VoltageLineToGround | Get or set line to ground voltage of distribution system type.
Public property | VoltageLineToLine | Get or set line to line voltage type of distribution system type.

See Also

DistributionSysType
Autodesk.Revit.Symbols Namespace


ElectricalPhase Property

DistributionSysType..::ElectricalPhase Property
CollapseAll image DropDown image

Get or set electrical phase (single, triple or undefined) of distribution system.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalPhase ElectricalPhase{ get; set;}
Visual Basic (Declaration)
Public Property ElectricalPhase As ElectricalPhase
Visual C++
public:
property ElectricalPhase ElectricalPhase {
    ElectricalPhase get ();
    void set (ElectricalPhase value);
}

See Also

DistributionSysType Class
Autodesk.Revit.Symbols Namespace


ElectricalPhaseConfiguration Property

DistributionSysType..::ElectricalPhaseConfiguration Property
CollapseAll image DropDown image

Get or set electrical phase configuration (Y, delta or undefined) of distribution system.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalPhaseConfiguration ElectricalPhaseConfiguration{ get; set;}
Visual Basic (Declaration)
Public Property ElectricalPhaseConfiguration As ElectricalPhaseConfiguration
Visual C++
public:
property ElectricalPhaseConfiguration ElectricalPhaseConfiguration {
    ElectricalPhaseConfiguration get ();
    void set (ElectricalPhaseConfiguration value);
}

See Also

DistributionSysType Class
Autodesk.Revit.Symbols Namespace


IsInUse Property

DistributionSysType..::IsInUse Property
CollapseAll image DropDown image

Get the value which indicates whether this distribution system is in service now.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInUse{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

DistributionSysType Class
Autodesk.Revit.Symbols Namespace


NumWires Property

DistributionSysType..::NumWires Property
CollapseAll image DropDown image

Get or set number of wires of distribution system.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumWires{ get; set;}
Visual Basic (Declaration)
Public Property NumWires As Integer
Visual C++
public:
property int NumWires {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | While assign a negative value to NumWires.

See Also

DistributionSysType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

DistributionSysType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DistributionSysType Class
DistributionSysType Members
Autodesk.Revit.Symbols Namespace


VoltageLineToGround Property

DistributionSysType..::VoltageLineToGround Property
CollapseAll image DropDown image

Get or set line to ground voltage of distribution system type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VoltageType VoltageLineToGround{ get; set;}
Visual Basic (Declaration)
Public Property VoltageLineToGround As VoltageType
Visual C++
public:
property VoltageType^ VoltageLineToGround {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.Symbols Namespace


VoltageLineToLine Property

DistributionSysType..::VoltageLineToLine Property
CollapseAll image DropDown image

Get or set line to line voltage type of distribution system type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VoltageType VoltageLineToLine{ get; set;}
Visual Basic (Declaration)
Public Property VoltageLineToLine As VoltageType
Visual C++
public:
property VoltageType^ VoltageLineToLine {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
System..::InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains DistributionSys types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DF2C2FC5-C096-4926-BB70-0B45B9F8FE6A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DistributionSysTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("DF2C2FC5-C096-4926-BB70-0B45B9F8FE6A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DistributionSysTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"DF2C2FC5-C096-4926-BB70-0B45B9F8FE6A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DistributionSysTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::DistributionSysTypeSet

See Also

DistributionSysTypeSet Members
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DistributionSysTypeSet
Visual Basic (Declaration)
Public Class DistributionSysTypeSet
Visual C++
public ref class DistributionSysTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DistributionSysTypeSetDistributionSysTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every DistributionSys type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a DistributionSys type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified DistributionSys type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified DistributionSys type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of DistributionSys types that are in the set.

See Also

DistributionSysTypeSet
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DistributionSysTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysTypeSet ()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class DistributionSysTypeSet
Visual Basic (Declaration)
Public Class DistributionSysTypeSet
Visual C++
public ref class DistributionSysTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every DistributionSys type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a DistributionSys type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified DistributionSys type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified DistributionSys type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DistributionSysTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

DistributionSysTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every DistributionSys type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

DistributionSysTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a DistributionSys type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    DistributionSysType^ item
)

Parameters

item
DistributionSysType
The DistributionSys type to be searched for.

Return Value

The Contains method returns True if the DistributionSys type is within the set, otherwise False.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

DistributionSysTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

DistributionSysTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified DistributionSys type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DistributionSysType _
) As Integer
Visual C++
public:
virtual int Erase (
    DistributionSysType^ item
)

Parameters

item
DistributionSysType
The DistributionSys type to be erased.

Return Value

The number of DistributionSys types that were erased from the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

DistributionSysTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DistributionSysTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

DistributionSysTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

DistributionSysTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified DistributionSys type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    DistributionSysType^ item
)

Parameters

item
DistributionSysType
The DistributionSys type to be inserted into the set.

Return Value

Returns whether the DistributionSys type was inserted into the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

DistributionSysTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

DistributionSysTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual DistributionSysTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class DistributionSysTypeSet
Visual Basic (Declaration)
Public Class DistributionSysTypeSet
Visual C++
public ref class DistributionSysTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of DistributionSys types that are in the set.

See Also

DistributionSysTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

DistributionSysTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

DistributionSysTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of DistributionSys types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DistributionSysTypeSet Class
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a DistributionSys type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E877B9CE-E594-4dee-90D6-157CE13E167C")]
public abstract class DistributionSysTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E877B9CE-E594-4dee-90D6-157CE13E167C")> _
Public MustInherit Class DistributionSysTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E877B9CE-E594-4dee-90D6-157CE13E167C")]
public ref class DistributionSysTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::DistributionSysTypeSetIterator

See Also

DistributionSysTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DistributionSysTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class DistributionSysTypeSetIterator
Visual C++
public ref class DistributionSysTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DistributionSysTypeSetIteratorDistributionSysTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DistributionSysTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class DistributionSysTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class DistributionSysTypeSetIterator
Visual C++
public ref class DistributionSysTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DistributionSysTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

DistributionSysTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

DistributionSysTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

DistributionSysTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

DistributionSysTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DistributionSysTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class DistributionSysTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class DistributionSysTypeSetIterator
Visual C++
public ref class DistributionSysTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

DistributionSysTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FamilySymbol Class
See Also Members
CollapseAll image DropDown image

Represents a single Type within a Family.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D1272CC0-F45E-4afc-B9FD-EFC54E6FAD7E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FamilySymbol : InsertableObject
Visual Basic (Declaration)
<GuidAttribute("D1272CC0-F45E-4afc-B9FD-EFC54E6FAD7E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
[GuidAttribute(L"D1272CC0-F45E-4afc-B9FD-EFC54E6FAD7E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FamilySymbol : public InsertableObject

Remarks

The FamilySymbol object represents a Type within a Family. Each family can contain one or more family symbols. The FamilySymbol object is derived from the Symbol object and also the Element object and as such inherits all the properties and methods of those objects.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol
Autodesk.Revit.Symbols..::AnnotationSymbolType
Autodesk.Revit.Symbols..::MullionType
Autodesk.Revit.Symbols..::PanelType

See Also

FamilySymbol Members
Autodesk.Revit.Symbols Namespace


FamilySymbol Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FamilySymbol
Visual Basic (Declaration)
Public Class FamilySymbol
Visual C++
public ref class FamilySymbol

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilySymbolFamilySymbolNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Material | This property returns the physical material from which the type is made.
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilySymbol
Autodesk.Revit.Symbols Namespace


FamilySymbol Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbol ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


FamilySymbol Properties
CollapseAll image DropDown image

Syntax

C#
public class FamilySymbol
Visual Basic (Declaration)
Public Class FamilySymbol
Visual C++
public ref class FamilySymbol

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Material | This property returns the physical material from which the type is made.
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilySymbol
Autodesk.Revit.Symbols Namespace


Family Property

FamilySymbol..::Family Property
CollapseAll image DropDown image

Returns the Family object to which the symbol belongs.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Family Family{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Family As Family
Visual C++
public:
property Family^ Family {
    Family^ get ();
}

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


Material Property

FamilySymbol..::Material Property
CollapseAll image DropDown image

This property returns the physical material from which the type is made.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Material Material{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Material As Material
Visual C++
public:
property Material Material {
    Material get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material.

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


Parameter Property

FamilySymbol..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

FamilySymbol Class
FamilySymbol Members
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Class
See Also Members
CollapseAll image DropDown image

A set that can contain family symbols.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("82F34527-38BE-435f-8774-742F3DE11942")]
public class FamilySymbolSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("82F34527-38BE-435f-8774-742F3DE11942")> _
Public Class FamilySymbolSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"82F34527-38BE-435f-8774-742F3DE11942")]
public ref class FamilySymbolSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::FamilySymbolSet

See Also

FamilySymbolSet Members
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FamilySymbolSet
Visual Basic (Declaration)
Public Class FamilySymbolSet
Visual C++
public ref class FamilySymbolSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilySymbolSetFamilySymbolSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every symbol from the set, rendering it empty.
Public method | Contains | Tests for the existence of a family symbol within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified family symbol from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified family symbol into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbolSet ()

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Methods
CollapseAll image DropDown image

Syntax

C#
public class FamilySymbolSet
Visual Basic (Declaration)
Public Class FamilySymbolSet
Visual C++
public ref class FamilySymbolSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every symbol from the set, rendering it empty.
Public method | Contains | Tests for the existence of a family symbol within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified family symbol from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified family symbol into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FamilySymbolSet
Autodesk.Revit.Symbols Namespace


Clear Method

FamilySymbolSet..::Clear Method
CollapseAll image DropDown image

Removes every symbol from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

FamilySymbolSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a family symbol within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Contains (
    FamilySymbol^ item
)

Parameters

item
FamilySymbol
The symbol to be searched for.

Return Value

The Contains method returns True if the symbol is within the set, otherwise False.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

FamilySymbolSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

FamilySymbolSet..::Erase Method
CollapseAll image DropDown image

Removes a specified family symbol from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FamilySymbol _
) As Integer
Visual C++
public:
virtual int Erase (
    FamilySymbol^ item
)

Parameters

item
FamilySymbol
The symbol to be erased.

Return Value

The number of symbols that were erased from the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

FamilySymbolSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FamilySymbolSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

FamilySymbolSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

FamilySymbolSet..::Insert Method
CollapseAll image DropDown image

Insert the specified family symbol into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Insert (
    FamilySymbol^ item
)

Parameters

item
FamilySymbol
The symbol to be inserted into the set.

Return Value

Returns whether the symbol was inserted into the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

FamilySymbolSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

FamilySymbolSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FamilySymbolSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Properties
CollapseAll image DropDown image

Syntax

C#
public class FamilySymbolSet
Visual Basic (Declaration)
Public Class FamilySymbolSet
Visual C++
public ref class FamilySymbolSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

FamilySymbolSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Size Property

FamilySymbolSet..::Size Property
CollapseAll image DropDown image

Returns the number of family symbols that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a family symbol set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0DD2030C-A846-4811-BF5D-964EA85A3E38")]
public abstract class FamilySymbolSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0DD2030C-A846-4811-BF5D-964EA85A3E38")> _
Public MustInherit Class FamilySymbolSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0DD2030C-A846-4811-BF5D-964EA85A3E38")]
public ref class FamilySymbolSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::FamilySymbolSetIterator

See Also

FamilySymbolSetIterator Members
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class FamilySymbolSetIterator
Visual Basic (Declaration)
Public MustInherit Class FamilySymbolSetIterator
Visual C++
public ref class FamilySymbolSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilySymbolSetIteratorFamilySymbolSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbolSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbolSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class FamilySymbolSetIterator
Visual Basic (Declaration)
Public MustInherit Class FamilySymbolSetIterator
Visual C++
public ref class FamilySymbolSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FamilySymbolSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

FamilySymbolSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

FamilySymbolSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

FamilySymbolSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

FamilySymbolSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class FamilySymbolSetIterator
Visual Basic (Declaration)
Public MustInherit Class FamilySymbolSetIterator
Visual C++
public ref class FamilySymbolSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

FamilySymbolSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


FasciaType Class
See Also Members
CollapseAll image DropDown image

An object that represents the fascia type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F57677B3-E404-47db-A65C-ED1B41BAFAE5")]
public class FasciaType : HostedSweepType
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F57677B3-E404-47db-A65C-ED1B41BAFAE5")> _
Public Class FasciaType _
    Inherits HostedSweepType
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F57677B3-E404-47db-A65C-ED1B41BAFAE5")]
public ref class FasciaType : public HostedSweepType

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::HostedSweepType
Autodesk.Revit.Symbols..::FasciaType

See Also

FasciaType Members
Autodesk.Revit.Symbols Namespace


FasciaType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FasciaType
Visual Basic (Declaration)
Public Class FasciaType
Visual C++
public ref class FasciaType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FasciaTypeFasciaTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FasciaType
Autodesk.Revit.Symbols Namespace


FasciaType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FasciaType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FasciaType Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains fascia types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("53A2E6F4-8402-4c1c-8B0D-2D85CE839A88")]
public class FasciaTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("53A2E6F4-8402-4c1c-8B0D-2D85CE839A88")> _
Public Class FasciaTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"53A2E6F4-8402-4c1c-8B0D-2D85CE839A88")]
public ref class FasciaTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::FasciaTypeSet

See Also

FasciaTypeSet Members
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FasciaTypeSet
Visual Basic (Declaration)
Public Class FasciaTypeSet
Visual C++
public ref class FasciaTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FasciaTypeSetFasciaTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every fascia type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fascia type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified fascia type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified fascia type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FasciaTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaTypeSet ()

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class FasciaTypeSet
Visual Basic (Declaration)
Public Class FasciaTypeSet
Visual C++
public ref class FasciaTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every fascia type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fascia type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified fascia type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified fascia type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FasciaTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

FasciaTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every fascia type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

FasciaTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a fascia type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    FasciaType^ item
)

Parameters

item
FasciaType
The fascia type to be searched for.

Return Value

The Contains method returns True if the fascia type is within the set, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

FasciaTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

FasciaTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified fascia type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FasciaType _
) As Integer
Visual C++
public:
virtual int Erase (
    FasciaType^ item
)

Parameters

item
FasciaType
The fascia type to be erased.

Return Value

The number of fascia types that were erased from the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

FasciaTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FasciaTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

FasciaTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

FasciaTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified fascia type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    FasciaType^ item
)

Parameters

item
FasciaType
The fascia type to be inserted into the set.

Return Value

Returns whether the fascia type was inserted into the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

FasciaTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

FasciaTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FasciaTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class FasciaTypeSet
Visual Basic (Declaration)
Public Class FasciaTypeSet
Visual C++
public ref class FasciaTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

FasciaTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

FasciaTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of fascia types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a fascia type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9B7A6B1D-9A11-47d5-8124-B5A3E6ABCB25")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class FasciaTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("9B7A6B1D-9A11-47d5-8124-B5A3E6ABCB25")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class FasciaTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"9B7A6B1D-9A11-47d5-8124-B5A3E6ABCB25")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FasciaTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::FasciaTypeSetIterator

See Also

FasciaTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class FasciaTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class FasciaTypeSetIterator
Visual C++
public ref class FasciaTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FasciaTypeSetIteratorFasciaTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FasciaTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class FasciaTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class FasciaTypeSetIterator
Visual C++
public ref class FasciaTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FasciaTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

FasciaTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

FasciaTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

FasciaTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

FasciaTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class FasciaTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class FasciaTypeSetIterator
Visual C++
public ref class FasciaTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

FasciaTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FloorType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("89A3A1E8-A760-4fc8-8EF7-AC01EBDC6303")]
public class FloorType : HostObjAttributes
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("89A3A1E8-A760-4fc8-8EF7-AC01EBDC6303")> _
Public Class FloorType _
    Inherits HostObjAttributes
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"89A3A1E8-A760-4fc8-8EF7-AC01EBDC6303")]
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::FloorType

See Also

FloorType Members
Autodesk.Revit.Symbols Namespace


FloorType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FloorType
Visual Basic (Declaration)
Public Class FloorType
Visual C++
public ref class FloorType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FloorTypeFloorTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FloorType
Autodesk.Revit.Symbols Namespace


FloorType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FloorType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FloorType Class
Autodesk.Revit.Symbols Namespace


FloorType Properties
CollapseAll image DropDown image

Syntax

C#
public class FloorType
Visual Basic (Declaration)
Public Class FloorType
Visual C++
public ref class FloorType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FloorType
Autodesk.Revit.Symbols Namespace


IsFoundationSlab Property

FloorType..::IsFoundationSlab Property
CollapseAll image DropDown image

Returns whether the element FloorAttributes type is FoundationSlab.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsFoundationSlab{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsFoundationSlab As Boolean
Visual C++
public:
property bool IsFoundationSlab {
    bool get ();
}

See Also

FloorType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

FloorType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

FloorType Class
FloorType Members
Autodesk.Revit.Symbols Namespace


FloorTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains floor types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("92820CA4-FA03-49fa-B6E3-FA5BF080889B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FloorTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("92820CA4-FA03-49fa-B6E3-FA5BF080889B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FloorTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"92820CA4-FA03-49fa-B6E3-FA5BF080889B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FloorTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::FloorTypeSet

See Also

FloorTypeSet Members
Autodesk.Revit.Symbols Namespace


FloorTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FloorTypeSet
Visual Basic (Declaration)
Public Class FloorTypeSet
Visual C++
public ref class FloorTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FloorTypeSetFloorTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every floor type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a floor type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified floor type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified floor type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet
Autodesk.Revit.Symbols Namespace


FloorTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FloorTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorTypeSet ()

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


FloorTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class FloorTypeSet
Visual Basic (Declaration)
Public Class FloorTypeSet
Visual C++
public ref class FloorTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every floor type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a floor type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified floor type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified floor type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FloorTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

FloorTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every floor type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

FloorTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a floor type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    FloorType^ item
)

Parameters

item
FloorType
The floor type to be searched for.

Return Value

The Contains method returns True if the floor type is within the set, otherwise False.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

FloorTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

FloorTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified floor type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FloorType _
) As Integer
Visual C++
public:
virtual int Erase (
    FloorType^ item
)

Parameters

item
FloorType
The floor type to be erased.

Return Value

The number of floor types that were erased from the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

FloorTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FloorTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

FloorTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

FloorTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified floor type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    FloorType^ item
)

Parameters

item
FloorType
The floor type to be inserted into the set.

Return Value

Returns whether the floor type was inserted into the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

FloorTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

FloorTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual FloorTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


FloorTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class FloorTypeSet
Visual Basic (Declaration)
Public Class FloorTypeSet
Visual C++
public ref class FloorTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

FloorTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

FloorTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of floor types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a floor type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C020D138-0DE8-46ff-A1D0-F9F923A3E75F")]
public abstract class FloorTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C020D138-0DE8-46ff-A1D0-F9F923A3E75F")> _
Public MustInherit Class FloorTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C020D138-0DE8-46ff-A1D0-F9F923A3E75F")]
public ref class FloorTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::FloorTypeSetIterator

See Also

FloorTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class FloorTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class FloorTypeSetIterator
Visual C++
public ref class FloorTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FloorTypeSetIteratorFloorTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FloorTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class FloorTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class FloorTypeSetIterator
Visual C++
public ref class FloorTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FloorTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

FloorTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

FloorTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

FloorTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

FloorTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class FloorTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class FloorTypeSetIterator
Visual C++
public ref class FloorTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

FloorTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GridType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F74464C8-7E16-4a30-9CE0-33CAEEBF0803")]
public class GridType : LineAndTextAttrSymbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F74464C8-7E16-4a30-9CE0-33CAEEBF0803")> _
Public Class GridType _
    Inherits LineAndTextAttrSymbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F74464C8-7E16-4a30-9CE0-33CAEEBF0803")]
public ref class GridType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::GridType

See Also

GridType Members
Autodesk.Revit.Symbols Namespace


GridType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GridType
Visual Basic (Declaration)
Public Class GridType
Visual C++
public ref class GridType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GridTypeGridTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GridType
Autodesk.Revit.Symbols Namespace


GridType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GridType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GridType Class
Autodesk.Revit.Symbols Namespace


GridTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains grid types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0C411B00-FB42-49c5-8EFC-894B54ABF3A8")]
public class GridTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0C411B00-FB42-49c5-8EFC-894B54ABF3A8")> _
Public Class GridTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0C411B00-FB42-49c5-8EFC-894B54ABF3A8")]
public ref class GridTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::GridTypeSet

See Also

GridTypeSet Members
Autodesk.Revit.Symbols Namespace


GridTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GridTypeSet
Visual Basic (Declaration)
Public Class GridTypeSet
Visual C++
public ref class GridTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GridTypeSetGridTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every grid type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a grid type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified grid type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified grid type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet
Autodesk.Revit.Symbols Namespace


GridTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GridTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTypeSet ()

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GridTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class GridTypeSet
Visual Basic (Declaration)
Public Class GridTypeSet
Visual C++
public ref class GridTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every grid type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a grid type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified grid type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified grid type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GridTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

GridTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every grid type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

GridTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a grid type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    GridType^ item
)

Parameters

item
GridType
The grid type to be searched for.

Return Value

The Contains method returns True if the grid type is within the set, otherwise False.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

GridTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

GridTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified grid type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GridType _
) As Integer
Visual C++
public:
virtual int Erase (
    GridType^ item
)

Parameters

item
GridType
The grid type to be erased.

Return Value

The number of grid types that were erased from the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

GridTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GridTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

GridTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

GridTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified grid type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    GridType^ item
)

Parameters

item
GridType
The grid type to be inserted into the set.

Return Value

Returns whether the grid type was inserted into the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

GridTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

GridTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GridTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GridTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class GridTypeSet
Visual Basic (Declaration)
Public Class GridTypeSet
Visual C++
public ref class GridTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

GridTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

GridTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of grid types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a grid type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("65367313-3E79-49e0-8747-6C879609090F")]
public abstract class GridTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("65367313-3E79-49e0-8747-6C879609090F")> _
Public MustInherit Class GridTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"65367313-3E79-49e0-8747-6C879609090F")]
public ref class GridTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::GridTypeSetIterator

See Also

GridTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class GridTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GridTypeSetIterator
Visual C++
public ref class GridTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GridTypeSetIteratorGridTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GridTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class GridTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GridTypeSetIterator
Visual C++
public ref class GridTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GridTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

GridTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

GridTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

GridTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

GridTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class GridTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GridTypeSetIterator
Visual C++
public ref class GridTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

GridTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GroupType Class
See Also Members
CollapseAll image DropDown image

Represents a type of a user defined group.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D4894974-BA34-4d79-9B0E-B9D06EE1247A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GroupType : Symbol
Visual Basic (Declaration)
<GuidAttribute("D4894974-BA34-4d79-9B0E-B9D06EE1247A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GroupType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"D4894974-BA34-4d79-9B0E-B9D06EE1247A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GroupType : public Symbol

Remarks

The GroupType object can be used to swap the type of an existing group or to place an new instance of a group.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::GroupType

See Also

GroupType Members
Autodesk.Revit.Symbols Namespace


GroupType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GroupType
Visual Basic (Declaration)
Public Class GroupType
Visual C++
public ref class GroupType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GroupTypeGroupTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Groups | Retrieve a set of all the groups that have this type.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GroupType
Autodesk.Revit.Symbols Namespace


GroupType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroupType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroupType Class
Autodesk.Revit.Symbols Namespace


GroupType Properties
CollapseAll image DropDown image

Syntax

C#
public class GroupType
Visual Basic (Declaration)
Public Class GroupType
Visual C++
public ref class GroupType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Groups | Retrieve a set of all the groups that have this type.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GroupType
Autodesk.Revit.Symbols Namespace


Groups Property

GroupType..::Groups Property
CollapseAll image DropDown image

Retrieve a set of all the groups that have this type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GroupSet Groups{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Groups As GroupSet
Visual C++
public:
property GroupSet^ Groups {
    GroupSet^ get ();
}

Return Value

A set of group objects that all share this group type.

Remarks

All groups returned by this property belong to this group type. A groups type can be changed by using the GroupType property on the group object, in which case it will no longer belong to this type but it will belong to the new type instead.

See Also

GroupType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

GroupType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

GroupType Class
GroupType Members
Autodesk.Revit.Symbols Namespace


GutterType Class
See Also Members
CollapseAll image DropDown image

An object that represents the gutter type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DC5650E9-9275-4702-B80A-72BD7AB1A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GutterType : HostedSweepType
Visual Basic (Declaration)
<GuidAttribute("DC5650E9-9275-4702-B80A-72BD7AB1A7B7")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GutterType _
    Inherits HostedSweepType
Visual C++
[GuidAttribute(L"DC5650E9-9275-4702-B80A-72BD7AB1A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GutterType : public HostedSweepType

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::HostedSweepType
Autodesk.Revit.Symbols..::GutterType

See Also

GutterType Members
Autodesk.Revit.Symbols Namespace


GutterType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GutterType
Visual Basic (Declaration)
Public Class GutterType
Visual C++
public ref class GutterType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GutterTypeGutterTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GutterType
Autodesk.Revit.Symbols Namespace


GutterType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GutterType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GutterType Class
Autodesk.Revit.Symbols Namespace


GutterTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains gutter types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A997D6A7-6D7B-4aea-BAA3-BD3F2B83224C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GutterTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("A997D6A7-6D7B-4aea-BAA3-BD3F2B83224C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GutterTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"A997D6A7-6D7B-4aea-BAA3-BD3F2B83224C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GutterTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::GutterTypeSet

See Also

GutterTypeSet Members
Autodesk.Revit.Symbols Namespace


GutterTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GutterTypeSet
Visual Basic (Declaration)
Public Class GutterTypeSet
Visual C++
public ref class GutterTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GutterTypeSetGutterTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every gutter type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a gutter type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified gutter type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified gutter type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet
Autodesk.Revit.Symbols Namespace


GutterTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GutterTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterTypeSet ()

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GutterTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class GutterTypeSet
Visual Basic (Declaration)
Public Class GutterTypeSet
Visual C++
public ref class GutterTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every gutter type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a gutter type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified gutter type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified gutter type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GutterTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

GutterTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every gutter type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

GutterTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a gutter type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    GutterType^ item
)

Parameters

item
GutterType
The gutter type to be searched for.

Return Value

The Contains method returns True if the gutter type is within the set, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

GutterTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

GutterTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified gutter type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GutterType _
) As Integer
Visual C++
public:
virtual int Erase (
    GutterType^ item
)

Parameters

item
GutterType
The gutter type to be erased.

Return Value

The number of gutter types that were erased from the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

GutterTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GutterTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

GutterTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

GutterTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified gutter type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    GutterType^ item
)

Parameters

item
GutterType
The gutter type to be inserted into the set.

Return Value

Returns whether the gutter type was inserted into the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

GutterTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

GutterTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GutterTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GutterTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class GutterTypeSet
Visual Basic (Declaration)
Public Class GutterTypeSet
Visual C++
public ref class GutterTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

GutterTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

GutterTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of gutter types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a gutter type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E16D7776-F3B4-4a27-B826-6CFE7A612241")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class GutterTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("E16D7776-F3B4-4a27-B826-6CFE7A612241")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class GutterTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"E16D7776-F3B4-4a27-B826-6CFE7A612241")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GutterTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::GutterTypeSetIterator

See Also

GutterTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class GutterTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GutterTypeSetIterator
Visual C++
public ref class GutterTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GutterTypeSetIteratorGutterTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public GutterTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class GutterTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GutterTypeSetIterator
Visual C++
public ref class GutterTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

GutterTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

GutterTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

GutterTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

GutterTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

GutterTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class GutterTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class GutterTypeSetIterator
Visual C++
public ref class GutterTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

GutterTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


HostedSweepType Class
See Also Members
CollapseAll image DropDown image

An object that represents the attributes for sweep host objects in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("190C820A-2736-402e-9608-BE6CC577BB0E")]
public class HostedSweepType : HostObjAttributes
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("190C820A-2736-402e-9608-BE6CC577BB0E")> _
Public Class HostedSweepType _
    Inherits HostObjAttributes
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"190C820A-2736-402e-9608-BE6CC577BB0E")]
public ref class HostedSweepType : public HostObjAttributes

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::HostedSweepType
Autodesk.Revit.Symbols..::SlabEdgeType
Autodesk.Revit.Symbols..::GutterType
Autodesk.Revit.Symbols..::FasciaType

See Also

HostedSweepType Members
Autodesk.Revit.Symbols Namespace


HostedSweepType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class HostedSweepType
Visual Basic (Declaration)
Public Class HostedSweepType
Visual C++
public ref class HostedSweepType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | HostedSweepTypeHostedSweepTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostedSweepType
Autodesk.Revit.Symbols Namespace


HostedSweepType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public HostedSweepType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostedSweepType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostedSweepType Class
Autodesk.Revit.Symbols Namespace


HostObjAttributes Class
See Also Members
CollapseAll image DropDown image

An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("57BED09B-03D1-4381-B8CB-1AB3287CDA55")]
public class HostObjAttributes : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("57BED09B-03D1-4381-B8CB-1AB3287CDA55")> _
Public Class HostObjAttributes _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"57BED09B-03D1-4381-B8CB-1AB3287CDA55")]
public ref class HostObjAttributes : public Symbol

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::WallType
Autodesk.Revit.Symbols..::FloorType
Autodesk.Revit.Symbols..::ContFootingType
Autodesk.Revit.Symbols..::RoofType
Autodesk.Revit.Symbols..::CurtainSystemType
Autodesk.Revit.Symbols..::HostedSweepType

See Also

HostObjAttributes Members
Autodesk.Revit.Symbols Namespace


HostObjAttributes Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class HostObjAttributes
Visual Basic (Declaration)
Public Class HostObjAttributes
Visual C++
public ref class HostObjAttributes

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | HostObjAttributesHostObjAttributesNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostObjAttributes
Autodesk.Revit.Symbols Namespace


HostObjAttributes Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public HostObjAttributes()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostObjAttributes ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace


HostObjAttributes Properties
CollapseAll image DropDown image

Syntax

C#
public class HostObjAttributes
Visual Basic (Declaration)
Public Class HostObjAttributes
Visual C++
public ref class HostObjAttributes

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostObjAttributes
Autodesk.Revit.Symbols Namespace


CompoundStructure Property

HostObjAttributes..::CompoundStructure Property
CollapseAll image DropDown image

Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructure CompoundStructure{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CompoundStructure As CompoundStructure
Visual C++
public:
property CompoundStructure^ CompoundStructure {
    CompoundStructure^ get ();
}

Remarks

From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return Nothing.

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace


Parameter Property

HostObjAttributes..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

HostObjAttributes Class
HostObjAttributes Members
Autodesk.Revit.Symbols Namespace


InsertableObject Class
See Also Members
CollapseAll image DropDown image

A base class you all types that are insertable.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("51B12AD1-208A-467c-80CA-D5435ABF2726")]
public class InsertableObject : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("51B12AD1-208A-467c-80CA-D5435ABF2726")> _
Public Class InsertableObject _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"51B12AD1-208A-467c-80CA-D5435ABF2726")]
public ref class InsertableObject : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol

See Also

InsertableObject Members
Autodesk.Revit.Symbols Namespace


InsertableObject Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InsertableObject
Visual Basic (Declaration)
Public Class InsertableObject
Visual C++
public ref class InsertableObject

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InsertableObjectInsertableObjectNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsertableObject
Autodesk.Revit.Symbols Namespace


InsertableObject Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsertableObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsertableObject ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InsertableObject Class
Autodesk.Revit.Symbols Namespace


LevelType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("126647C3-F518-4c5e-A6E4-D353DD9BBBEC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LevelType : Symbol
Visual Basic (Declaration)
<GuidAttribute("126647C3-F518-4c5e-A6E4-D353DD9BBBEC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LevelType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"126647C3-F518-4c5e-A6E4-D353DD9BBBEC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LevelType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LevelType

See Also

LevelType Members
Autodesk.Revit.Symbols Namespace


LevelType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LevelType
Visual Basic (Declaration)
Public Class LevelType
Visual C++
public ref class LevelType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LevelTypeLevelTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LevelType
Autodesk.Revit.Symbols Namespace


LevelType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LevelType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LevelType Class
Autodesk.Revit.Symbols Namespace


LevelTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains level types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9662B2F0-1F91-4e85-A830-2A2E82AE9097")]
public class LevelTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9662B2F0-1F91-4e85-A830-2A2E82AE9097")> _
Public Class LevelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9662B2F0-1F91-4e85-A830-2A2E82AE9097")]
public ref class LevelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::LevelTypeSet

See Also

LevelTypeSet Members
Autodesk.Revit.Symbols Namespace


LevelTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LevelTypeSet
Visual Basic (Declaration)
Public Class LevelTypeSet
Visual C++
public ref class LevelTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LevelTypeSetLevelTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every level type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a level type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified level type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified level type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet
Autodesk.Revit.Symbols Namespace


LevelTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LevelTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelTypeSet ()

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


LevelTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class LevelTypeSet
Visual Basic (Declaration)
Public Class LevelTypeSet
Visual C++
public ref class LevelTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every level type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a level type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified level type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified level type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LevelTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

LevelTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every level type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

LevelTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a level type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    LevelType^ item
)

Parameters

item
LevelType
The level type to be searched for.

Return Value

The Contains method returns True if the level type is within the set, otherwise False.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

LevelTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

LevelTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified level type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LevelType _
) As Integer
Visual C++
public:
virtual int Erase (
    LevelType^ item
)

Parameters

item
LevelType
The level type to be erased.

Return Value

The number of level types that were erased from the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

LevelTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LevelTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

LevelTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

LevelTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified level type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    LevelType^ item
)

Parameters

item
LevelType
The level type to be inserted into the set.

Return Value

Returns whether the level type was inserted into the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

LevelTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

LevelTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LevelTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


LevelTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class LevelTypeSet
Visual Basic (Declaration)
Public Class LevelTypeSet
Visual C++
public ref class LevelTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

LevelTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

LevelTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of level types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a level type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E724B123-93FD-4714-B04A-9A3A8F5E67E5")]
public abstract class LevelTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E724B123-93FD-4714-B04A-9A3A8F5E67E5")> _
Public MustInherit Class LevelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E724B123-93FD-4714-B04A-9A3A8F5E67E5")]
public ref class LevelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::LevelTypeSetIterator

See Also

LevelTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LevelTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class LevelTypeSetIterator
Visual C++
public ref class LevelTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LevelTypeSetIteratorLevelTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LevelTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LevelTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class LevelTypeSetIterator
Visual C++
public ref class LevelTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LevelTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

LevelTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

LevelTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

LevelTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

LevelTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LevelTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class LevelTypeSetIterator
Visual C++
public ref class LevelTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

LevelTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("02D4DBE2-27D6-49e4-BB5B-4F928ECF96D1")]
public class LineAndTextAttrSymbol : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("02D4DBE2-27D6-49e4-BB5B-4F928ECF96D1")> _
Public Class LineAndTextAttrSymbol _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"02D4DBE2-27D6-49e4-BB5B-4F928ECF96D1")]
public ref class LineAndTextAttrSymbol : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::TextElementType
Autodesk.Revit.Symbols..::GridType

See Also

LineAndTextAttrSymbol Members
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LineAndTextAttrSymbol
Visual Basic (Declaration)
Public Class LineAndTextAttrSymbol
Visual C++
public ref class LineAndTextAttrSymbol

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineAndTextAttrSymbolLineAndTextAttrSymbolNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineAndTextAttrSymbol
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineAndTextAttrSymbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineAndTextAttrSymbol ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineAndTextAttrSymbol Class
Autodesk.Revit.Symbols Namespace


LineLoadType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3EEDA648-5F60-4697-BA40-742FACB29077")]
public class LineLoadType : LoadTypeBase
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3EEDA648-5F60-4697-BA40-742FACB29077")> _
Public Class LineLoadType _
    Inherits LoadTypeBase
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3EEDA648-5F60-4697-BA40-742FACB29077")]
public ref class LineLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LoadTypeBase
Autodesk.Revit.Symbols..::LineLoadType

See Also

LineLoadType Members
Autodesk.Revit.Symbols Namespace


LineLoadType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LineLoadType
Visual Basic (Declaration)
Public Class LineLoadType
Visual C++
public ref class LineLoadType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineLoadTypeLineLoadTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoadType
Autodesk.Revit.Symbols Namespace


LineLoadType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoadType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoadType Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains lineload types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A0EBAB84-7C37-4495-A858-242EBDBB8B4F")]
public class LineLoadTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A0EBAB84-7C37-4495-A858-242EBDBB8B4F")> _
Public Class LineLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A0EBAB84-7C37-4495-A858-242EBDBB8B4F")]
public ref class LineLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::LineLoadTypeSet

See Also

LineLoadTypeSet Members
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LineLoadTypeSet
Visual Basic (Declaration)
Public Class LineLoadTypeSet
Visual C++
public ref class LineLoadTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineLoadTypeSetLineLoadTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every lineload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a lineload type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified lineload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified lineload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadTypeSet ()

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class LineLoadTypeSet
Visual Basic (Declaration)
Public Class LineLoadTypeSet
Visual C++
public ref class LineLoadTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every lineload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a lineload type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified lineload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified lineload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LineLoadTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

LineLoadTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every lineload type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

LineLoadTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a lineload type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    LineLoadType^ item
)

Parameters

item
LineLoadType
The lineload type to be searched for.

Return Value

The Contains method returns True if the lineload type is within the set, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

LineLoadTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

LineLoadTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified lineload type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LineLoadType _
) As Integer
Visual C++
public:
virtual int Erase (
    LineLoadType^ item
)

Parameters

item
LineLoadType
The lineload type to be erased.

Return Value

The number of lineload types that were erased from the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

LineLoadTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LineLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

LineLoadTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

LineLoadTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified lineload type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    LineLoadType^ item
)

Parameters

item
LineLoadType
The lineload type to be inserted into the set.

Return Value

Returns whether the lineload type was inserted into the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

LineLoadTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

LineLoadTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LineLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class LineLoadTypeSet
Visual Basic (Declaration)
Public Class LineLoadTypeSet
Visual C++
public ref class LineLoadTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

LineLoadTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

LineLoadTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of lineload types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a lineload type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1FB42148-5ECE-4ec7-9C02-BF7D485DE90E")]
public abstract class LineLoadTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1FB42148-5ECE-4ec7-9C02-BF7D485DE90E")> _
Public MustInherit Class LineLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1FB42148-5ECE-4ec7-9C02-BF7D485DE90E")]
public ref class LineLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::LineLoadTypeSetIterator

See Also

LineLoadTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LineLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class LineLoadTypeSetIterator
Visual C++
public ref class LineLoadTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineLoadTypeSetIteratorLineLoadTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LineLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class LineLoadTypeSetIterator
Visual C++
public ref class LineLoadTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LineLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

LineLoadTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

LineLoadTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

LineLoadTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

LineLoadTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LineLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class LineLoadTypeSetIterator
Visual C++
public ref class LineLoadTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

LineLoadTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LoadTypeBase Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FC46E5CC-E8EE-4adb-9A89-8DEFC39A679C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LoadTypeBase : Symbol
Visual Basic (Declaration)
<GuidAttribute("FC46E5CC-E8EE-4adb-9A89-8DEFC39A679C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LoadTypeBase _
    Inherits Symbol
Visual C++
[GuidAttribute(L"FC46E5CC-E8EE-4adb-9A89-8DEFC39A679C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadTypeBase : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LoadTypeBase
Autodesk.Revit.Symbols..::PointLoadType
Autodesk.Revit.Symbols..::LineLoadType
Autodesk.Revit.Symbols..::AreaLoadType

See Also

LoadTypeBase Members
Autodesk.Revit.Symbols Namespace


LoadTypeBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadTypeBase
Visual Basic (Declaration)
Public Class LoadTypeBase
Visual C++
public ref class LoadTypeBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadTypeBaseLoadTypeBaseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadTypeBase
Autodesk.Revit.Symbols Namespace


LoadTypeBase Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadTypeBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBase ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadTypeBase Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Class
See Also Members
CollapseAll image DropDown image

A set that contains load type bases.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3A2C7B02-E17F-46dc-B8AC-DCE08E722031")]
public class LoadTypeBaseSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3A2C7B02-E17F-46dc-B8AC-DCE08E722031")> _
Public Class LoadTypeBaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3A2C7B02-E17F-46dc-B8AC-DCE08E722031")]
public ref class LoadTypeBaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::LoadTypeBaseSet

See Also

LoadTypeBaseSet Members
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadTypeBaseSet
Visual Basic (Declaration)
Public Class LoadTypeBaseSet
Visual C++
public ref class LoadTypeBaseSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadTypeBaseSetLoadTypeBaseSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every load type base from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load type base within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load type base from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load type base into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadTypeBaseSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBaseSet ()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadTypeBaseSet
Visual Basic (Declaration)
Public Class LoadTypeBaseSet
Visual C++
public ref class LoadTypeBaseSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every load type base from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load type base within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load type base from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load type base into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadTypeBaseSet
Autodesk.Revit.Symbols Namespace


Clear Method

LoadTypeBaseSet..::Clear Method
CollapseAll image DropDown image

Removes every load type base from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

LoadTypeBaseSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a load type base within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Contains (
    LoadTypeBase^ item
)

Parameters

item
LoadTypeBase
The load type base to be searched for.

Return Value

The Contains method returns True if the load type base is within the set, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

LoadTypeBaseSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

LoadTypeBaseSet..::Erase Method
CollapseAll image DropDown image

Removes a specified load type base from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LoadTypeBase _
) As Integer
Visual C++
public:
virtual int Erase (
    LoadTypeBase^ item
)

Parameters

item
LoadTypeBase
The load type base to be erased.

Return Value

The number of load type bases that were erased from the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

LoadTypeBaseSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadTypeBaseSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

LoadTypeBaseSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

LoadTypeBaseSet..::Insert Method
CollapseAll image DropDown image

Insert the specified load type base into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Insert (
    LoadTypeBase^ item
)

Parameters

item
LoadTypeBase
The load type base to be inserted into the set.

Return Value

Returns whether the load type base was inserted into the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

LoadTypeBaseSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

LoadTypeBaseSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual LoadTypeBaseSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Properties
CollapseAll image DropDown image

Syntax

C#
public class LoadTypeBaseSet
Visual Basic (Declaration)
Public Class LoadTypeBaseSet
Visual C++
public ref class LoadTypeBaseSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

LoadTypeBaseSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Size Property

LoadTypeBaseSet..::Size Property
CollapseAll image DropDown image

Returns the number of load type bases that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a load type base set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("649DE3E2-B385-4a20-AB83-F6655A0A0CCD")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class LoadTypeBaseSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("649DE3E2-B385-4a20-AB83-F6655A0A0CCD")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class LoadTypeBaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"649DE3E2-B385-4a20-AB83-F6655A0A0CCD")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LoadTypeBaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::LoadTypeBaseSetIterator

See Also

LoadTypeBaseSetIterator Members
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadTypeBaseSetIterator
Visual Basic (Declaration)
Public MustInherit Class LoadTypeBaseSetIterator
Visual C++
public ref class LoadTypeBaseSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadTypeBaseSetIteratorLoadTypeBaseSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadTypeBaseSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBaseSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadTypeBaseSetIterator
Visual Basic (Declaration)
Public MustInherit Class LoadTypeBaseSetIterator
Visual C++
public ref class LoadTypeBaseSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadTypeBaseSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

LoadTypeBaseSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

LoadTypeBaseSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

LoadTypeBaseSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

LoadTypeBaseSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class LoadTypeBaseSetIterator
Visual Basic (Declaration)
Public MustInherit Class LoadTypeBaseSetIterator
Visual C++
public ref class LoadTypeBaseSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

LoadTypeBaseSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Class
See Also Members
CollapseAll image DropDown image

Construction definition for Project Information.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B50D9A83-5E09-4dc5-900A-4F36CAAEDD9E")]
public class MEPBuildingConstruction : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B50D9A83-5E09-4dc5-900A-4F36CAAEDD9E")> _
Public Class MEPBuildingConstruction _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B50D9A83-5E09-4dc5-900A-4F36CAAEDD9E")]
public ref class MEPBuildingConstruction : public Symbol

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::MEPBuildingConstruction

See Also

MEPBuildingConstruction Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MEPBuildingConstruction
Visual Basic (Declaration)
Public Class MEPBuildingConstruction
Visual C++
public ref class MEPBuildingConstruction

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MEPBuildingConstructionMEPBuildingConstructionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BuildingConstruction | Get or Set the Building Construction of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Constructions | Get all the Building Constructions according to the specific Construction type.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPBuildingConstruction
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstruction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstruction ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Properties
CollapseAll image DropDown image

Syntax

C#
public class MEPBuildingConstruction
Visual Basic (Declaration)
Public Class MEPBuildingConstruction
Visual C++
public ref class MEPBuildingConstruction

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BuildingConstruction | Get or Set the Building Construction of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Constructions | Get all the Building Constructions according to the specific Construction type.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPBuildingConstruction
Autodesk.Revit.Symbols Namespace


BuildingConstruction Property

MEPBuildingConstruction..::BuildingConstruction Property
CollapseAll image DropDown image

Get or Set the Building Construction of the Project Information.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Construction BuildingConstruction[
    ConstructionType constructionType
]{ get; set;}
Visual Basic (Declaration)
Public Property BuildingConstruction ( _
    constructionType As ConstructionType _
) As Construction
Visual C++
public:
property Construction^ BuildingConstruction[ConstructionType constructionType] {
    Construction^ get (ConstructionType constructionType);
    void set (ConstructionType constructionType, Construction^ value);
}

Parameters

constructionType
ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


Constructions Property

MEPBuildingConstruction..::Constructions Property
CollapseAll image DropDown image

Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Set Constructions[
    ConstructionType constructionType
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Constructions ( _
    constructionType As ConstructionType _
) As Set
Visual C++
public:
property Set^ Constructions[ConstructionType constructionType] {
    Set^ get (ConstructionType constructionType);
}

Parameters

constructionType
ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


Parameter Property

MEPBuildingConstruction..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
MEPBuildingConstruction Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Class
See Also Members
CollapseAll image DropDown image

A set that contains MEPBuildingConstructions.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("06758845-3902-45b3-AADA-5BDB97D46295")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MEPBuildingConstructionSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("06758845-3902-45b3-AADA-5BDB97D46295")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MEPBuildingConstructionSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"06758845-3902-45b3-AADA-5BDB97D46295")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MEPBuildingConstructionSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::MEPBuildingConstructionSet

See Also

MEPBuildingConstructionSet Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MEPBuildingConstructionSet
Visual Basic (Declaration)
Public Class MEPBuildingConstructionSet
Visual C++
public ref class MEPBuildingConstructionSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MEPBuildingConstructionSetMEPBuildingConstructionSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Public method | Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified MEPBuildingConstruction from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified MEPBuildingConstruction into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstructionSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstructionSet ()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Methods
CollapseAll image DropDown image

Syntax

C#
public class MEPBuildingConstructionSet
Visual Basic (Declaration)
Public Class MEPBuildingConstructionSet
Visual C++
public ref class MEPBuildingConstructionSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Public method | Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified MEPBuildingConstruction from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified MEPBuildingConstruction into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MEPBuildingConstructionSet
Autodesk.Revit.Symbols Namespace


Clear Method

MEPBuildingConstructionSet..::Clear Method
CollapseAll image DropDown image

Removes every MEPBuildingConstruction from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

MEPBuildingConstructionSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a MEPBuildingConstruction within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Contains (
    MEPBuildingConstruction^ item
)

Parameters

item
MEPBuildingConstruction
The MEPBuildingConstruction to be searched for.

Return Value

The Contains method returns True if the MEPBuildingConstruction is within the set, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

MEPBuildingConstructionSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

MEPBuildingConstructionSet..::Erase Method
CollapseAll image DropDown image

Removes a specified MEPBuildingConstruction from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As MEPBuildingConstruction _
) As Integer
Visual C++
public:
virtual int Erase (
    MEPBuildingConstruction^ item
)

Parameters

item
MEPBuildingConstruction
The MEPBuildingConstruction to be erased.

Return Value

The number of MEPBuildingConstructions that were erased from the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

MEPBuildingConstructionSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

MEPBuildingConstructionSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

MEPBuildingConstructionSet..::Insert Method
CollapseAll image DropDown image

Insert the specified MEPBuildingConstruction into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Insert (
    MEPBuildingConstruction^ item
)

Parameters

item
MEPBuildingConstruction
The MEPBuildingConstruction to be inserted into the set.

Return Value

Returns whether the MEPBuildingConstruction was inserted into the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

MEPBuildingConstructionSet..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

MEPBuildingConstructionSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Properties
CollapseAll image DropDown image

Syntax

C#
public class MEPBuildingConstructionSet
Visual Basic (Declaration)
Public Class MEPBuildingConstructionSet
Visual C++
public ref class MEPBuildingConstructionSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

MEPBuildingConstructionSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Size Property

MEPBuildingConstructionSet..::Size Property
CollapseAll image DropDown image

Returns the number of MEPBuildingConstructions that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a MEPBuildingConstruction set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2CB0E10E-7386-419a-A0AF-CE9575357A3B")]
public abstract class MEPBuildingConstructionSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2CB0E10E-7386-419a-A0AF-CE9575357A3B")> _
Public MustInherit Class MEPBuildingConstructionSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2CB0E10E-7386-419a-A0AF-CE9575357A3B")]
public ref class MEPBuildingConstructionSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::MEPBuildingConstructionSetIterator

See Also

MEPBuildingConstructionSetIterator Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class MEPBuildingConstructionSetIterator
Visual Basic (Declaration)
Public MustInherit Class MEPBuildingConstructionSetIterator
Visual C++
public ref class MEPBuildingConstructionSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MEPBuildingConstructionSetIteratorMEPBuildingConstructionSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstructionSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstructionSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class MEPBuildingConstructionSetIterator
Visual Basic (Declaration)
Public MustInherit Class MEPBuildingConstructionSetIterator
Visual C++
public ref class MEPBuildingConstructionSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MEPBuildingConstructionSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

MEPBuildingConstructionSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

MEPBuildingConstructionSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

MEPBuildingConstructionSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

MEPBuildingConstructionSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class MEPBuildingConstructionSetIterator
Visual Basic (Declaration)
Public MustInherit Class MEPBuildingConstructionSetIterator
Visual C++
public ref class MEPBuildingConstructionSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

MEPBuildingConstructionSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MullionType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DF22B216-4E35-4783-B1DE-F8F8E36F5300")]
public class MullionType : FamilySymbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DF22B216-4E35-4783-B1DE-F8F8E36F5300")> _
Public Class MullionType _
    Inherits FamilySymbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DF22B216-4E35-4783-B1DE-F8F8E36F5300")]
public ref class MullionType : public FamilySymbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol
Autodesk.Revit.Symbols..::MullionType

See Also

MullionType Members
Autodesk.Revit.Symbols Namespace


MullionType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MullionType
Visual Basic (Declaration)
Public Class MullionType
Visual C++
public ref class MullionType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MullionTypeMullionTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MullionType
Autodesk.Revit.Symbols Namespace


MullionType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MullionType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MullionType Class
Autodesk.Revit.Symbols Namespace


MullionTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains mullion types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("40C37658-5FB2-4a41-A7C2-FFBDBE120B2A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MullionTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("40C37658-5FB2-4a41-A7C2-FFBDBE120B2A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MullionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"40C37658-5FB2-4a41-A7C2-FFBDBE120B2A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MullionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::MullionTypeSet

See Also

MullionTypeSet Members
Autodesk.Revit.Symbols Namespace


MullionTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MullionTypeSet
Visual Basic (Declaration)
Public Class MullionTypeSet
Visual C++
public ref class MullionTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MullionTypeSetMullionTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet
Autodesk.Revit.Symbols Namespace


MullionTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MullionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionTypeSet ()

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


MullionTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class MullionTypeSet
Visual Basic (Declaration)
Public Class MullionTypeSet
Visual C++
public ref class MullionTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MullionTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

MullionTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every mullion type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

MullionTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a mullion type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    MullionType^ item
)

Parameters

item
MullionType
The mullion type to be searched for.

Return Value

The Contains method returns True if the mullion type is within the set, otherwise False.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

MullionTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

MullionTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified mullion type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As MullionType _
) As Integer
Visual C++
public:
virtual int Erase (
    MullionType^ item
)

Parameters

item
MullionType
The mullion type to be erased.

Return Value

The number of mullion types that were erased from the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

MullionTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MullionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

MullionTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

MullionTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified mullion type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    MullionType^ item
)

Parameters

item
MullionType
The mullion type to be inserted into the set.

Return Value

Returns whether the mullion type was inserted into the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

MullionTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

MullionTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MullionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


MullionTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class MullionTypeSet
Visual Basic (Declaration)
Public Class MullionTypeSet
Visual C++
public ref class MullionTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

MullionTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

MullionTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of mullion types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a mullion type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7FC6EDEA-FE99-47e2-AE27-4EDA5B763344")]
public abstract class MullionTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7FC6EDEA-FE99-47e2-AE27-4EDA5B763344")> _
Public MustInherit Class MullionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7FC6EDEA-FE99-47e2-AE27-4EDA5B763344")]
public ref class MullionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::MullionTypeSetIterator

See Also

MullionTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class MullionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class MullionTypeSetIterator
Visual C++
public ref class MullionTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MullionTypeSetIteratorMullionTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MullionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class MullionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class MullionTypeSetIterator
Visual C++
public ref class MullionTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

MullionTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

MullionTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

MullionTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

MullionTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

MullionTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class MullionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class MullionTypeSetIterator
Visual C++
public ref class MullionTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

MullionTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PanelType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C06F1A9B-7411-4b1e-AF9D-16453E80E35A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PanelType : FamilySymbol
Visual Basic (Declaration)
<GuidAttribute("C06F1A9B-7411-4b1e-AF9D-16453E80E35A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PanelType _
    Inherits FamilySymbol
Visual C++
[GuidAttribute(L"C06F1A9B-7411-4b1e-AF9D-16453E80E35A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PanelType : public FamilySymbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol
Autodesk.Revit.Symbols..::PanelType

See Also

PanelType Members
Autodesk.Revit.Symbols Namespace


PanelType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PanelType
Visual Basic (Declaration)
Public Class PanelType
Visual C++
public ref class PanelType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PanelTypePanelTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PanelType
Autodesk.Revit.Symbols Namespace


PanelType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PanelType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PanelType Class
Autodesk.Revit.Symbols Namespace


PanelTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains panel types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A2D7CE4B-24AE-4970-B4BE-8FCC2298A7B8")]
public class PanelTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A2D7CE4B-24AE-4970-B4BE-8FCC2298A7B8")> _
Public Class PanelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A2D7CE4B-24AE-4970-B4BE-8FCC2298A7B8")]
public ref class PanelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::PanelTypeSet

See Also

PanelTypeSet Members
Autodesk.Revit.Symbols Namespace


PanelTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PanelTypeSet
Visual Basic (Declaration)
Public Class PanelTypeSet
Visual C++
public ref class PanelTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PanelTypeSetPanelTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet
Autodesk.Revit.Symbols Namespace


PanelTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PanelTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelTypeSet ()

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


PanelTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class PanelTypeSet
Visual Basic (Declaration)
Public Class PanelTypeSet
Visual C++
public ref class PanelTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PanelTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

PanelTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every panel type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

PanelTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a panel type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    PanelType^ item
)

Parameters

item
PanelType
The panel type to be searched for.

Return Value

The Contains method returns True if the panel type is within the set, otherwise False.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

PanelTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

PanelTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified panel type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PanelType _
) As Integer
Visual C++
public:
virtual int Erase (
    PanelType^ item
)

Parameters

item
PanelType
The panel type to be erased.

Return Value

The number of panel types that were erased from the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

PanelTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PanelTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

PanelTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

PanelTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified panel type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    PanelType^ item
)

Parameters

item
PanelType
The panel type to be inserted into the set.

Return Value

Returns whether the panel type was inserted into the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

PanelTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

PanelTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PanelTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


PanelTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class PanelTypeSet
Visual Basic (Declaration)
Public Class PanelTypeSet
Visual C++
public ref class PanelTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

PanelTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

PanelTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of panel types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a panel type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FE6154E1-0DD3-46bd-BA13-A825329BB8FB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class PanelTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("FE6154E1-0DD3-46bd-BA13-A825329BB8FB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class PanelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"FE6154E1-0DD3-46bd-BA13-A825329BB8FB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PanelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::PanelTypeSetIterator

See Also

PanelTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PanelTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PanelTypeSetIterator
Visual C++
public ref class PanelTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PanelTypeSetIteratorPanelTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PanelTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PanelTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PanelTypeSetIterator
Visual C++
public ref class PanelTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PanelTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

PanelTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

PanelTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

PanelTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

PanelTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PanelTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PanelTypeSetIterator
Visual C++
public ref class PanelTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

PanelTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PathReinforcementType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C3D00F02-5FAE-4a42-ACD4-8459FDF79AA4")]
public class PathReinforcementType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C3D00F02-5FAE-4a42-ACD4-8459FDF79AA4")> _
Public Class PathReinforcementType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C3D00F02-5FAE-4a42-ACD4-8459FDF79AA4")]
public ref class PathReinforcementType : public Symbol

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::PathReinforcementType

See Also

PathReinforcementType Members
Autodesk.Revit.Symbols Namespace


PathReinforcementType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PathReinforcementType
Visual Basic (Declaration)
Public Class PathReinforcementType
Visual C++
public ref class PathReinforcementType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PathReinforcementTypePathReinforcementTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PathReinforcementType
Autodesk.Revit.Symbols Namespace


PathReinforcementType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PathReinforcementType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PathReinforcementType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PathReinforcementType Class
Autodesk.Revit.Symbols Namespace


PointLoadType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C8AB7056-0102-4500-81B8-B3C397183452")]
public class PointLoadType : LoadTypeBase
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C8AB7056-0102-4500-81B8-B3C397183452")> _
Public Class PointLoadType _
    Inherits LoadTypeBase
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C8AB7056-0102-4500-81B8-B3C397183452")]
public ref class PointLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LoadTypeBase
Autodesk.Revit.Symbols..::PointLoadType

See Also

PointLoadType Members
Autodesk.Revit.Symbols Namespace


PointLoadType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PointLoadType
Visual Basic (Declaration)
Public Class PointLoadType
Visual C++
public ref class PointLoadType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PointLoadTypePointLoadTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PointLoadType
Autodesk.Revit.Symbols Namespace


PointLoadType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PointLoadType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoadType Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains pointload types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6A964B37-D285-4c73-9CF1-CF4F64E74E3C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PointLoadTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("6A964B37-D285-4c73-9CF1-CF4F64E74E3C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PointLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"6A964B37-D285-4c73-9CF1-CF4F64E74E3C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PointLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::PointLoadTypeSet

See Also

PointLoadTypeSet Members
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PointLoadTypeSet
Visual Basic (Declaration)
Public Class PointLoadTypeSet
Visual C++
public ref class PointLoadTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PointLoadTypeSetPointLoadTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every pointload type from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PointLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadTypeSet ()

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class PointLoadTypeSet
Visual Basic (Declaration)
Public Class PointLoadTypeSet
Visual C++
public ref class PointLoadTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every pointload type from the set, rendering it empty.
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PointLoadTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

PointLoadTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every pointload type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

PointLoadTypeSet..::Contains Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    PointLoadType^ item
)

Parameters

item
PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

PointLoadTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

PointLoadTypeSet..::Erase Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PointLoadType _
) As Integer
Visual C++
public:
virtual int Erase (
    PointLoadType^ item
)

Parameters

item
PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

PointLoadTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PointLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

PointLoadTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

PointLoadTypeSet..::Insert Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    PointLoadType^ item
)

Parameters

item
PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

PointLoadTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

PointLoadTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual PointLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class PointLoadTypeSet
Visual Basic (Declaration)
Public Class PointLoadTypeSet
Visual C++
public ref class PointLoadTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

PointLoadTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

PointLoadTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of pointload types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a pointload type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("30F67B07-7AF6-484f-8BAB-3EE61053D741")]
public abstract class PointLoadTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("30F67B07-7AF6-484f-8BAB-3EE61053D741")> _
Public MustInherit Class PointLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"30F67B07-7AF6-484f-8BAB-3EE61053D741")]
public ref class PointLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::PointLoadTypeSetIterator

See Also

PointLoadTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PointLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PointLoadTypeSetIterator
Visual C++
public ref class PointLoadTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PointLoadTypeSetIteratorPointLoadTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PointLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class PointLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PointLoadTypeSetIterator
Visual C++
public ref class PointLoadTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

PointLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

PointLoadTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

PointLoadTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

PointLoadTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

PointLoadTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class PointLoadTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class PointLoadTypeSetIterator
Visual C++
public ref class PointLoadTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

PointLoadTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarBarType Class
See Also Members
CollapseAll image DropDown image

A Rebar type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("552DD05F-1B14-430b-B15F-430E4397931B")]
public class RebarBarType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("552DD05F-1B14-430b-B15F-430E4397931B")> _
Public Class RebarBarType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"552DD05F-1B14-430b-B15F-430E4397931B")]
public ref class RebarBarType : public Symbol

Remarks

The RebarBarType object contains information about Rebar. Access to these details is made available through built in parameters. The following are parameters that can be used: REBAR_BAR_DIAMETER - diameter of bar, REBAR_BAR_BEND_RADIUS - minimal bend radius of the rebar, MATERIAL_ID_PARAM - identifies the material of which the rebar is made, REBAR_BAR_STYLE - category that is used to represent the Rebar in drawings.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RebarBarType

See Also

RebarBarType Members
Autodesk.Revit.Symbols Namespace


RebarBarType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarBarType
Visual Basic (Declaration)
Public Class RebarBarType
Visual C++
public ref class RebarBarType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarBarTypeRebarBarTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAutoCalcHookLengths |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAutoCalcHookLengths | Specify whether hook lengths are automatically calculated.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HookLength | Access to length data in the hook lengths map.
Public property | HookOffsetLength | Access to offset length data in the hook lengths map.
Public property | HookPermission | Access to permission data in the hook lengths map.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarBarType
Autodesk.Revit.Symbols Namespace


RebarBarType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarBarType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


RebarBarType Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarBarType
Visual Basic (Declaration)
Public Class RebarBarType
Visual C++
public ref class RebarBarType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAutoCalcHookLengths |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAutoCalcHookLengths | Specify whether hook lengths are automatically calculated.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

RebarBarType
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarBarType..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


GetAutoCalcHookLengths Method

RebarBarType..::GetAutoCalcHookLengths Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool GetAutoCalcHookLengths(
    RebarHookType
)
Visual Basic (Declaration)
Public Function GetAutoCalcHookLengths ( _
     As RebarHookType _
) As Boolean
Visual C++
public:
bool GetAutoCalcHookLengths (
    RebarHookType^
)

Parameters

RebarHookType

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


SetAutoCalcHookLengths Method

RebarBarType..::SetAutoCalcHookLengths Method
CollapseAll image DropDown image

Specify whether hook lengths are automatically calculated.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetAutoCalcHookLengths(
    RebarHookType __unnamed000,
    bool autoCalc
)
Visual Basic (Declaration)
Public Sub SetAutoCalcHookLengths ( _
    __unnamed000 As RebarHookType, _
    autoCalc As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths (
    RebarHookType^ __unnamed000,
    bool autoCalc
)

Parameters

__unnamed000
RebarHookType
autoCalc
Boolean
Setting this value to true discards the current value set by set_HookLength().

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


RebarBarType Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarBarType
Visual Basic (Declaration)
Public Class RebarBarType
Visual C++
public ref class RebarBarType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HookLength | Access to length data in the hook lengths map.
Public property | HookOffsetLength | Access to offset length data in the hook lengths map.
Public property | HookPermission | Access to permission data in the hook lengths map.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarBarType
Autodesk.Revit.Symbols Namespace


HookLength Property

RebarBarType..::HookLength Property
CollapseAll image DropDown image

Access to length data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HookLength[
    RebarHookType hookType
]{ get; set;}
Visual Basic (Declaration)
Public Property HookLength ( _
    hookType As RebarHookType _
) As Double
Visual C++
public:
property double HookLength[RebarHookType^ hookType] {
    double get (RebarHookType^ hookType);
    void set (RebarHookType^ hookType, double value);
}

Parameters

hookType
RebarHookType

Remarks

Setting this property implicitly turns off the AutoCalcHookLengths property for this hook.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


HookOffsetLength Property

RebarBarType..::HookOffsetLength Property
CollapseAll image DropDown image

Access to offset length data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HookOffsetLength[
    RebarHookType hookId
]{ get; set;}
Visual Basic (Declaration)
Public Property HookOffsetLength ( _
    hookId As RebarHookType _
) As Double
Visual C++
public:
property double HookOffsetLength[RebarHookType^ hookId] {
    double get (RebarHookType^ hookId);
    void set (RebarHookType^ hookId, double value);
}

Parameters

hookId
RebarHookType

Remarks

Setting this property implicitly turns off the AutoCalcHookLengths property for this hook. It is only possible to set the offset length for hooks greater than 90 degrees.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


HookPermission Property

RebarBarType..::HookPermission Property
CollapseAll image DropDown image

Access to permission data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HookPermission[
    RebarHookType hookId
]{ get; set;}
Visual Basic (Declaration)
Public Property HookPermission ( _
    hookId As RebarHookType _
) As Boolean
Visual C++
public:
property bool HookPermission[RebarHookType^ hookId] {
    bool get (RebarHookType^ hookId);
    void set (RebarHookType^ hookId, bool value);
}

Parameters

hookId
RebarHookType

Remarks

This determines whether the hooks may be used with this bar type.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

RebarBarType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RebarBarType Class
RebarBarType Members
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains RebarBar types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B0050842-2DA7-4683-B7C9-0C75D1159458")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RebarBarTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("B0050842-2DA7-4683-B7C9-0C75D1159458")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RebarBarTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"B0050842-2DA7-4683-B7C9-0C75D1159458")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarBarTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarBarTypeSet

See Also

RebarBarTypeSet Members
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarBarTypeSet
Visual Basic (Declaration)
Public Class RebarBarTypeSet
Visual C++
public ref class RebarBarTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarBarTypeSetRebarBarTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every RebarBar type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarBar type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarBar type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarBar type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarBarTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarTypeSet ()

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarBarTypeSet
Visual Basic (Declaration)
Public Class RebarBarTypeSet
Visual C++
public ref class RebarBarTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every RebarBar type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarBar type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarBar type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarBar type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarBarTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

RebarBarTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every RebarBar type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

RebarBarTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a RebarBar type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    RebarBarType^ item
)

Parameters

item
RebarBarType
The RebarBar type to be searched for.

Return Value

The Contains method returns True if the RebarBar type is within the set, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarBarTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

RebarBarTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified RebarBar type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarBarType _
) As Integer
Visual C++
public:
virtual int Erase (
    RebarBarType^ item
)

Parameters

item
RebarBarType
The RebarBar type to be erased.

Return Value

The number of RebarBar types that were erased from the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

RebarBarTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarBarTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

RebarBarTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

RebarBarTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified RebarBar type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    RebarBarType^ item
)

Parameters

item
RebarBarType
The RebarBar type to be inserted into the set.

Return Value

Returns whether the RebarBar type was inserted into the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarBarTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

RebarBarTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarBarTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarBarTypeSet
Visual Basic (Declaration)
Public Class RebarBarTypeSet
Visual C++
public ref class RebarBarTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

RebarBarTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

RebarBarTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of RebarBar types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a RebarBar type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1FE335D8-1316-4cb0-8214-F2A60B6E3D13")]
public abstract class RebarBarTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1FE335D8-1316-4cb0-8214-F2A60B6E3D13")> _
Public MustInherit Class RebarBarTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1FE335D8-1316-4cb0-8214-F2A60B6E3D13")]
public ref class RebarBarTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarBarTypeSetIterator

See Also

RebarBarTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarBarTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarBarTypeSetIterator
Visual C++
public ref class RebarBarTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarBarTypeSetIteratorRebarBarTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarBarTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarBarTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarBarTypeSetIterator
Visual C++
public ref class RebarBarTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarBarTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarBarTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

RebarBarTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarBarTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

RebarBarTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarBarTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarBarTypeSetIterator
Visual C++
public ref class RebarBarTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

RebarBarTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarCoverType Class
See Also Members
CollapseAll image DropDown image

A Rebar Cover setting. This element functions as a name-value pair for Rebar Cover Settings.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A2DBAA2B-6165-4a7e-85E2-6EBBF01EB4EA")]
public class RebarCoverType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A2DBAA2B-6165-4a7e-85E2-6EBBF01EB4EA")> _
Public Class RebarCoverType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A2DBAA2B-6165-4a7e-85E2-6EBBF01EB4EA")]
public ref class RebarCoverType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RebarCoverType

See Also

RebarCoverType Members
Autodesk.Revit.Symbols Namespace


RebarCoverType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarCoverType
Visual Basic (Declaration)
Public Class RebarCoverType
Visual C++
public ref class RebarCoverType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarCoverTypeRebarCoverTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoverDistance | A distance that can be used as a concrete cover value in a document.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarCoverType
Autodesk.Revit.Symbols Namespace


RebarCoverType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarCoverType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


RebarCoverType Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarCoverType
Visual Basic (Declaration)
Public Class RebarCoverType
Visual C++
public ref class RebarCoverType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

RebarCoverType
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarCoverType..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


RebarCoverType Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarCoverType
Visual Basic (Declaration)
Public Class RebarCoverType
Visual C++
public ref class RebarCoverType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoverDistance | A distance that can be used as a concrete cover value in a document.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarCoverType
Autodesk.Revit.Symbols Namespace


CoverDistance Property

RebarCoverType..::CoverDistance Property
CollapseAll image DropDown image

A distance that can be used as a concrete cover value in a document.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double CoverDistance{ get; set;}
Visual Basic (Declaration)
Public Property CoverDistance As Double
Visual C++
public:
property double CoverDistance {
    double get ();
    void set (double value);
}

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

RebarCoverType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RebarCoverType Class
RebarCoverType Members
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains RebarCover types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C90FF30A-EAC7-4407-A9F3-1E0ECED773A0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RebarCoverTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("C90FF30A-EAC7-4407-A9F3-1E0ECED773A0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RebarCoverTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"C90FF30A-EAC7-4407-A9F3-1E0ECED773A0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarCoverTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarCoverTypeSet

See Also

RebarCoverTypeSet Members
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarCoverTypeSet
Visual Basic (Declaration)
Public Class RebarCoverTypeSet
Visual C++
public ref class RebarCoverTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarCoverTypeSetRebarCoverTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every RebarCover type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarCover type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarCover type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarCover type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarCoverTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverTypeSet ()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarCoverTypeSet
Visual Basic (Declaration)
Public Class RebarCoverTypeSet
Visual C++
public ref class RebarCoverTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every RebarCover type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarCover type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarCover type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarCover type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarCoverTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

RebarCoverTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every RebarCover type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

RebarCoverTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a RebarCover type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    RebarCoverType^ item
)

Parameters

item
RebarCoverType
The RebarCover type to be searched for.

Return Value

The Contains method returns True if the RebarCover type is within the set, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarCoverTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

RebarCoverTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified RebarCover type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarCoverType _
) As Integer
Visual C++
public:
virtual int Erase (
    RebarCoverType^ item
)

Parameters

item
RebarCoverType
The RebarCover type to be erased.

Return Value

The number of RebarCover types that were erased from the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

RebarCoverTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarCoverTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

RebarCoverTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

RebarCoverTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified RebarCover type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    RebarCoverType^ item
)

Parameters

item
RebarCoverType
The RebarCover type to be inserted into the set.

Return Value

Returns whether the RebarCover type was inserted into the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarCoverTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

RebarCoverTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarCoverTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarCoverTypeSet
Visual Basic (Declaration)
Public Class RebarCoverTypeSet
Visual C++
public ref class RebarCoverTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

RebarCoverTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

RebarCoverTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of RebarCover types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a RebarCover type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C1096142-89E2-49e6-8106-68D69C13B6AA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class RebarCoverTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("C1096142-89E2-49e6-8106-68D69C13B6AA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class RebarCoverTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"C1096142-89E2-49e6-8106-68D69C13B6AA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarCoverTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarCoverTypeSetIterator

See Also

RebarCoverTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarCoverTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarCoverTypeSetIterator
Visual C++
public ref class RebarCoverTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarCoverTypeSetIteratorRebarCoverTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarCoverTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarCoverTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarCoverTypeSetIterator
Visual C++
public ref class RebarCoverTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarCoverTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarCoverTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

RebarCoverTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarCoverTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

RebarCoverTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarCoverTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarCoverTypeSetIterator
Visual C++
public ref class RebarCoverTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

RebarCoverTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarHookType Class
See Also Members
CollapseAll image DropDown image

A Rebar Hook type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("ACEF6715-EBE3-412d-A16D-222FFA38C622")]
public class RebarHookType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("ACEF6715-EBE3-412d-A16D-222FFA38C622")> _
Public Class RebarHookType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"ACEF6715-EBE3-412d-A16D-222FFA38C622")]
public ref class RebarHookType : public Symbol

Remarks

This object contains the definition of the hooks that may be created at the ends of the rebar. The specifics of these hooks are contained within parameters that are accessible from this object. REBAR_HOOK_ANGLE - angle (range 0-PI) between first/last segment of rebar and the straight segment of the hook, REBAR_HOOK_LINE_LEN_FACTOR - a multiplier used to compute the length of the straight segment of the hook. The Length is computed as the bar diameter * the multiplier.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RebarHookType

See Also

RebarHookType Members
Autodesk.Revit.Symbols Namespace


RebarHookType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarHookType
Visual Basic (Declaration)
Public Class RebarHookType
Visual C++
public ref class RebarHookType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarHookTypeRebarHookTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarHookType
Autodesk.Revit.Symbols Namespace


RebarHookType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHookType Class
Autodesk.Revit.Symbols Namespace


RebarHookType Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarHookType
Visual Basic (Declaration)
Public Class RebarHookType
Visual C++
public ref class RebarHookType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

RebarHookType
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarHookType..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarHookType Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains RebarHook types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("02B3C1DD-821B-4179-AAFD-7427868C0002")]
public class RebarHookTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("02B3C1DD-821B-4179-AAFD-7427868C0002")> _
Public Class RebarHookTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"02B3C1DD-821B-4179-AAFD-7427868C0002")]
public ref class RebarHookTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarHookTypeSet

See Also

RebarHookTypeSet Members
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarHookTypeSet
Visual Basic (Declaration)
Public Class RebarHookTypeSet
Visual C++
public ref class RebarHookTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarHookTypeSetRebarHookTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every RebarHook type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarHook type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarHook type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarHook type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookTypeSet ()

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarHookTypeSet
Visual Basic (Declaration)
Public Class RebarHookTypeSet
Visual C++
public ref class RebarHookTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every RebarHook type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarHook type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarHook type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarHook type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarHookTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

RebarHookTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every RebarHook type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

RebarHookTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a RebarHook type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    RebarHookType^ item
)

Parameters

item
RebarHookType
The RebarHook type to be searched for.

Return Value

The Contains method returns True if the RebarHook type is within the set, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarHookTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

RebarHookTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified RebarHook type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarHookType _
) As Integer
Visual C++
public:
virtual int Erase (
    RebarHookType^ item
)

Parameters

item
RebarHookType
The RebarHook type to be erased.

Return Value

The number of RebarHook types that were erased from the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

RebarHookTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarHookTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

RebarHookTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

RebarHookTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified RebarHook type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    RebarHookType^ item
)

Parameters

item
RebarHookType
The RebarHook type to be inserted into the set.

Return Value

Returns whether the RebarHook type was inserted into the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarHookTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

RebarHookTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarHookTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarHookTypeSet
Visual Basic (Declaration)
Public Class RebarHookTypeSet
Visual C++
public ref class RebarHookTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

RebarHookTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

RebarHookTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of RebarHook types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a RebarHook type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("747FC16B-7253-4842-B15C-535C2AF2D180")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class RebarHookTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("747FC16B-7253-4842-B15C-535C2AF2D180")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class RebarHookTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"747FC16B-7253-4842-B15C-535C2AF2D180")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarHookTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarHookTypeSetIterator

See Also

RebarHookTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarHookTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarHookTypeSetIterator
Visual C++
public ref class RebarHookTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarHookTypeSetIteratorRebarHookTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarHookTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarHookTypeSetIterator
Visual C++
public ref class RebarHookTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarHookTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarHookTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

RebarHookTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarHookTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

RebarHookTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarHookTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarHookTypeSetIterator
Visual C++
public ref class RebarHookTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

RebarHookTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarShape Class
See Also Members
CollapseAll image DropDown image

RebarShape specifies the shape type for a Rebar instance.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("65EEC113-00BA-4b1c-8C37-81EFF20F632F")]
public class RebarShape : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("65EEC113-00BA-4b1c-8C37-81EFF20F632F")> _
Public Class RebarShape _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"65EEC113-00BA-4b1c-8C37-81EFF20F632F")]
public ref class RebarShape : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RebarShape

See Also

RebarShape Members
Autodesk.Revit.Symbols Namespace


RebarShape Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarShape
Visual Basic (Declaration)
Public Class RebarShape
Visual C++
public ref class RebarShape

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeRebarShapeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllowed |
 | GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
Public method | GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
Public method | NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
Public method | SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Definition | Get the shape definition object associated with this shape.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HookAngle | Get and set the hook angle.
Public property | HookOrientation | Get and set the hook orientation.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RebarStyle | Access the rebar style.
Public property | SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SimpleArc |
Public property | SimpleLine |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarShape
Autodesk.Revit.Symbols Namespace


RebarShape Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShape()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShape ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


RebarShape Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShape
Visual Basic (Declaration)
Public Class RebarShape
Visual C++
public ref class RebarShape

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllowed |
 | GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
Public method | GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
Public method | NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
Public method | SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

RebarShape
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarShape..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


GetAllowed Method

RebarShape..::GetAllowed Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool GetAllowed(
    RebarBarType
)
Visual Basic (Declaration)
Public Function GetAllowed ( _
     As RebarBarType _
) As Boolean
Visual C++
public:
bool GetAllowed (
    RebarBarType^
)

Parameters

RebarBarType

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


GetAllRebarShapeParameters Method

RebarShape..::GetAllRebarShapeParameters Method
CollapseAll image DropDown image

List all shape parameters used by all the existing RebarShapes in the document.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static DefinitionsBase GetAllRebarShapeParameters(
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetAllRebarShapeParameters ( _
    doc As Document _
) As DefinitionsBase
Visual C++
public:
static DefinitionsBase^ GetAllRebarShapeParameters (
    Document^ doc
)

Parameters

doc
Document

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


GetCurvesForBrowser Method

RebarShape..::GetCurvesForBrowser Method
CollapseAll image DropDown image

Generate curves for the shape, as used in the shape browser.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray GetCurvesForBrowser()
Visual Basic (Declaration)
Public Function GetCurvesForBrowser As CurveArray
Visual C++
public:
CurveArray^ GetCurvesForBrowser ()

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


NewDefinitionByArc Method

RebarShape..::NewDefinitionByArc Method
CollapseAll image DropDown image

Create a shape definition by arc, and associate it with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinitionByArc NewDefinitionByArc()
Visual Basic (Declaration)
Public Function NewDefinitionByArc As RebarShapeDefinitionByArc
Visual C++
public:
RebarShapeDefinitionByArc^ NewDefinitionByArc ()

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


NewDefinitionBySegments Method

RebarShape..::NewDefinitionBySegments Method
CollapseAll image DropDown image

Create a shape definition by segments, and associate it with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinitionBySegments NewDefinitionBySegments(
    int numSegments
)
Visual Basic (Declaration)
Public Function NewDefinitionBySegments ( _
    numSegments As Integer _
) As RebarShapeDefinitionBySegments
Visual C++
public:
RebarShapeDefinitionBySegments^ NewDefinitionBySegments (
    int numSegments
)

Parameters

numSegments
Int32

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SetAllowed Method

RebarShape..::SetAllowed Method
CollapseAll image DropDown image

Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetAllowed(
    RebarBarType barType,
    bool allowed
)
Visual Basic (Declaration)
Public Sub SetAllowed ( _
    barType As RebarBarType, _
    allowed As Boolean _
)
Visual C++
public:
void SetAllowed (
    RebarBarType^ barType,
    bool allowed
)

Parameters

barType
RebarBarType
allowed
Boolean

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


RebarShape Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarShape
Visual Basic (Declaration)
Public Class RebarShape
Visual C++
public ref class RebarShape

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Definition | Get the shape definition object associated with this shape.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HookAngle | Get and set the hook angle.
Public property | HookOrientation | Get and set the hook orientation.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RebarStyle | Access the rebar style.
Public property | SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SimpleArc |
Public property | SimpleLine |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarShape
Autodesk.Revit.Symbols Namespace


Definition Property

RebarShape..::Definition Property
CollapseAll image DropDown image

Get the shape definition object associated with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinition Definition{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Definition As RebarShapeDefinition
Visual C++
public:
property RebarShapeDefinition^ Definition {
    RebarShapeDefinition^ get ();
}

Remarks

Returns null until one of the factory methods (e.g. NewDefinitionBySegments()) is called.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


HookAngle Property

RebarShape..::HookAngle Property
CollapseAll image DropDown image

Get and set the hook angle.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int HookAngle[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Property HookAngle ( _
    index As Integer _
) As Integer
Visual C++
public:
property int HookAngle[int index] {
    int get (int index);
    void set (int index, int value);
}

Parameters

index
Int32

Remarks

The hook angle is expressed as an integral number of degrees (common values are 0, 90, 135, and 180). Use a 0 index for the starting hook, and 1 for the ending hook.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


HookOrientation Property

RebarShape..::HookOrientation Property
CollapseAll image DropDown image

Get and set the hook orientation.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookOrientation HookOrientation[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Property HookOrientation ( _
    index As Integer _
) As RebarHookOrientation
Visual C++
public:
property RebarHookOrientation HookOrientation[int index] {
    RebarHookOrientation get (int index);
    void set (int index, RebarHookOrientation value);
}

Parameters

index
Int32

Remarks

Use a 0 index for the starting hook, and 1 for the ending hook. Orientation is 1 for the left side of the shape or -1 for the right side. For arc-driven shapes, 1 is for the inside of the arc, -1 for the outside.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


Parameter Property

RebarShape..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RebarShape Class
RebarShape Members
Autodesk.Revit.Symbols Namespace


RebarStyle Property

RebarShape..::RebarStyle Property
CollapseAll image DropDown image

Access the rebar style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarStyle RebarStyle{ get; set;}
Visual Basic (Declaration)
Public Property RebarStyle As RebarStyle
Visual C++
public:
property RebarStyle RebarStyle {
    RebarStyle get ();
    void set (RebarStyle value);
}

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SameShapeIgnoringHooks Property

RebarShape..::SameShapeIgnoringHooks Property
CollapseAll image DropDown image

Test whether two shapes have equivalent definitions.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SameShapeIgnoringHooks[
    RebarShape otherShape
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SameShapeIgnoringHooks ( _
    otherShape As RebarShape _
) As Boolean
Visual C++
public:
property bool SameShapeIgnoringHooks[RebarShape^ otherShape] {
    bool get (RebarShape^ otherShape);
}

Parameters

otherShape
RebarShape

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SimpleArc Property

RebarShape..::SimpleArc Property
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SimpleArc{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SimpleArc As Boolean
Visual C++
public:
property bool SimpleArc {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SimpleLine Property

RebarShape..::SimpleLine Property
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SimpleLine{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SimpleLine As Boolean
Visual C++
public:
property bool SimpleLine {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Class
See Also Members
CollapseAll image DropDown image

A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3083737D-A4F8-49f6-BE3B-C0FE4486966F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RebarShapeDefinition : APIObject
Visual Basic (Declaration)
<GuidAttribute("3083737D-A4F8-49f6-BE3B-C0FE4486966F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RebarShapeDefinition _
    Inherits APIObject
Visual C++
[GuidAttribute(L"3083737D-A4F8-49f6-BE3B-C0FE4486966F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarShapeDefinition : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarShapeDefinition
Autodesk.Revit.Symbols..::RebarShapeDefinitionBySegments
Autodesk.Revit.Symbols..::RebarShapeDefinitionByArc

See Also

RebarShapeDefinition Members
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeDefinitionRebarShapeDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition.
Public method | AddParameter | Add a parameter to the shape definition.
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Public method | Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeDefinition
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeDefinition ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinition

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition.
Public method | AddParameter | Add a parameter to the shape definition.
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Public method | Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

RebarShapeDefinition
Autodesk.Revit.Symbols Namespace


AddFormulaParameter Method

RebarShapeDefinition..::AddFormulaParameter Method
CollapseAll image DropDown image

Add a formula-driven parameter to the shape definition.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter AddFormulaParameter(
    ExternalDefinition param,
    string formula
)
Visual Basic (Declaration)
Public Function AddFormulaParameter ( _
    param As ExternalDefinition, _
    formula As String _
) As Parameter
Visual C++
public:
Parameter^ AddFormulaParameter (
    ExternalDefinition^ param,
    String^ formula
)

Parameters

param
ExternalDefinition
formula
String

Remarks

Like AddParameter(), this function introduces a parameter into the shape definition, but the parameter's value is driven by a formula. Formula parameters cannot be used in constraints to drive the shape. The formula is in the same format as in Revit families. The formula is allowed to refer to other parameters that are already in the definition, plus the builtin parameters REBAR_INSTANCE_BAR_DIAMETER, REBAR_INSTANCE_BEND_DIAMETER, REBAR_SHAPE_START_HOOK_LENGTH, REBAR_SHAPE_START_HOOK_OFFSET, REBAR_SHAPE_END_HOOK_LENGTH, REBAR_SHAPE_END_HOOK_OFFSET, REBAR_ELEM_LENGTH, REBAR_ELEM_TOTAL_LENGTH, and REBAR_ELEM_QUANTITY_OF_BARS.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


AddParameter Method

RebarShapeDefinition..::AddParameter Method
CollapseAll image DropDown image

Add a parameter to the shape definition.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter AddParameter(
    ExternalDefinition param,
    double defaultValue
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    param As ExternalDefinition, _
    defaultValue As Double _
) As Parameter
Visual C++
public:
Parameter^ AddParameter (
    ExternalDefinition^ param,
    double defaultValue
)

Parameters

param
ExternalDefinition
The parameter. To obtain this object, the following calls are required: Application.OpenSharedParameterFile(); Parameters.DefinitionFile.Groups.get_Item() or .create(); and Parameters.DefinitionGroup.Definitions.get_Item() or .create().
defaultValue
Double
A default value for this parameter in shapes. The default values should be chosen carefully, because they are required to be consistent as a set of constraints.

Remarks

Shape parameters must be shared parameters and have value type double. A parameter must be added with AddParameter() before it can be used to drive the shape with the various AddConstraint() functions. A parameter that does not drive a constraint is legal and will simply become an editable parameter on any Rebar that is an instance of this RebarShape.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


CheckDefaultParameterValues Method

RebarShapeDefinition..::CheckDefaultParameterValues Method
CollapseAll image DropDown image

Check that the shape can be solved with the default parameter values.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiam
)
Visual Basic (Declaration)
Public Function CheckDefaultParameterValues ( _
    bendRadius As Double, _
    barDiam As Double _
) As Boolean
Visual C++
public:
bool CheckDefaultParameterValues (
    double bendRadius,
    double barDiam
)

Parameters

bendRadius
Double
barDiam
Double

Remarks

This function runs the rebar solver with the default parameter values. If it fails (returns false), rebar instances of this shape will not work. This may be from the default parameters being inconsistent, or from some error in the shape definition. The solver requires a specific bend radius and bar diameter, and the result depends on these values, but in practice they usually do not affect the result of this function as long as they are small. It is legal to pass 0.0 for both arguments. The definition must be Complete in order for this function to succeed. This function can be called before or after Commit().

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


Commit Method

RebarShapeDefinition..::Commit Method
CollapseAll image DropDown image

Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Commit()
Visual Basic (Declaration)
Public Sub Commit
Visual C++
public:
void Commit ()

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarShapeDefinition..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinition

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeDefinition
Autodesk.Revit.Symbols Namespace


Complete Property

RebarShapeDefinition..::Complete Property
CollapseAll image DropDown image

Report whether the shape definition is fully constrained.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Complete{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Complete As Boolean
Visual C++
public:
property bool Complete {
    bool get ();
}

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Class
See Also Members
CollapseAll image DropDown image

Definition of a shape whose size and position can determined by a single arc.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("03D16B2E-6E41-4809-9DD5-7F57766DFF46")]
public class RebarShapeDefinitionByArc : RebarShapeDefinition
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("03D16B2E-6E41-4809-9DD5-7F57766DFF46")> _
Public Class RebarShapeDefinitionByArc _
    Inherits RebarShapeDefinition
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"03D16B2E-6E41-4809-9DD5-7F57766DFF46")]
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition

Remarks

In this shape definition, all dimensions are allowed to be driving dimensions.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarShapeDefinition
Autodesk.Revit.Symbols..::RebarShapeDefinitionByArc

See Also

RebarShapeDefinitionByArc Members
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionByArc
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc
Visual C++
public ref class RebarShapeDefinitionByArc

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeDefinitionByArcRebarShapeDefinitionByArcNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
Public method | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
Public method | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
Public method | AddConstraintRadius | Specify a parameter to drive the radius of the shape.
Public method | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides RebarShapeDefinition ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinitionByArc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeDefinitionByArc ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionByArc
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc
Visual C++
public ref class RebarShapeDefinitionByArc

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
Public method | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
Public method | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
Public method | AddConstraintRadius | Specify a parameter to drive the radius of the shape.
Public method | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides RebarShapeDefinition ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

RebarShapeDefinitionByArc
Autodesk.Revit.Symbols Namespace


AddConstraintArcLength Method

RebarShapeDefinitionByArc..::AddConstraintArcLength Method
CollapseAll image DropDown image

Specify a parameter to drive the arc length of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintArcLength(
    Parameter
)
Visual Basic (Declaration)
Public Sub AddConstraintArcLength ( _
     As Parameter _
)
Visual C++
public:
void AddConstraintArcLength (
    Parameter^
)

Parameters

Parameter

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintChordLength Method

RebarShapeDefinitionByArc..::AddConstraintChordLength Method
CollapseAll image DropDown image

Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintChordLength(
    Parameter
)
Visual Basic (Declaration)
Public Sub AddConstraintChordLength ( _
     As Parameter _
)
Visual C++
public:
void AddConstraintChordLength (
    Parameter^
)

Parameters

Parameter

Remarks

The chord length is measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintCircumference Method

RebarShapeDefinitionByArc..::AddConstraintCircumference Method
See Also
CollapseAll image DropDown image

Specify a parameter to drive the circumference of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintCircumference(
    Parameter __unnamed000,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintCircumference ( _
    __unnamed000 As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintCircumference (
    Parameter^ __unnamed000,
    RebarShapeArcReferenceType arcRefType
)

Parameters

__unnamed000
Parameter
arcRefType
RebarShapeArcReferenceType
Specify along which circle the circumference is measured--to the interior of the bar, the centerline, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintDiameter Method

RebarShapeDefinitionByArc..::AddConstraintDiameter Method
CollapseAll image DropDown image

Specify a parameter to drive the diameter of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintDiameter(
    Parameter __unnamed000,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintDiameter ( _
    __unnamed000 As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintDiameter (
    Parameter^ __unnamed000,
    RebarShapeArcReferenceType arcRefType
)

Parameters

__unnamed000
Parameter
arcRefType
RebarShapeArcReferenceType
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintRadius Method

RebarShapeDefinitionByArc..::AddConstraintRadius Method
CollapseAll image DropDown image

Specify a parameter to drive the radius of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintRadius(
    Parameter __unnamed000,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintRadius ( _
    __unnamed000 As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintRadius (
    Parameter^ __unnamed000,
    RebarShapeArcReferenceType arcRefType
)

Parameters

__unnamed000
Parameter
arcRefType
RebarShapeArcReferenceType
Specify how the radius should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintSagittaLength Method

RebarShapeDefinitionByArc..::AddConstraintSagittaLength Method
See Also
CollapseAll image DropDown image

Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintSagittaLength(
    Parameter
)
Visual Basic (Declaration)
Public Sub AddConstraintSagittaLength ( _
     As Parameter _
)
Visual C++
public:
void AddConstraintSagittaLength (
    Parameter^
)

Parameters

Parameter

Remarks

The sagitta will be measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarShapeDefinitionByArc..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionByArc
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc
Visual C++
public ref class RebarShapeDefinitionByArc

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc
Autodesk.Revit.Symbols Namespace


Type Property

RebarShapeDefinitionByArc..::Type Property
CollapseAll image DropDown image

Among those rebar shapes defined by an arc, specify which kind.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinitionByArcType Type{ get; set;}
Visual Basic (Declaration)
Public Property Type As RebarShapeDefinitionByArcType
Visual C++
public:
property RebarShapeDefinitionByArcType Type {
    RebarShapeDefinitionByArcType get ();
    void set (RebarShapeDefinitionByArcType value);
}

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Class
See Also Members
CollapseAll image DropDown image

Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0A780F06-0685-4c1d-8F4D-F29D2B1DE012")]
public class RebarShapeDefinitionBySegments : RebarShapeDefinition
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0A780F06-0685-4c1d-8F4D-F29D2B1DE012")> _
Public Class RebarShapeDefinitionBySegments _
    Inherits RebarShapeDefinition
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0A780F06-0685-4c1d-8F4D-F29D2B1DE012")]
public ref class RebarShapeDefinitionBySegments : public RebarShapeDefinition

Remarks

The segments are numbered starting with 0, and they have a direction; so the beginning of the shape is end 0 of segment 0, and the end of the shape is end 1 of segment (n-1). Each segment must have enough constraints to determine its position. Overconstraining is allowed. The most common combinations are: (1) A fixed direction together with a parallel length constraint; (2) A parallel length constraint plus another length constraint parallel to the x-axis or y-axis; (3) A parallel length constraint plus length constraints parallel to both the x-axis and y-axis. Multiple constraints may be driven by the same parameter, even on the same segment. Length constraints may be measured in two ways. For "measured to the outside of the bend," the reference is a tangent to the exterior face of the bar; the thickness of the bar is included. For "measured to the inside," the reference is the center of the arc of the bend; this is the point where the bend begins, if the constraint is parallel to the segment. Constraints are directed, and their direction vectors always have a positive dot-product with the segment direction, so in arguments like "measureToOutsideOfBend0", the "0" refers to the initial end of both the segment and the constraint. A bend may have the default radius of the bar type referenced by the Rebar element, or it may have a radius defined by a parameter. A 180-degree bend is described by introducing an extra segment in between the two straight segments, tangent to the midpoint of the bend.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarShapeDefinition
Autodesk.Revit.Symbols..::RebarShapeDefinitionBySegments

See Also

RebarShapeDefinitionBySegments Members
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionBySegments
Visual Basic (Declaration)
Public Class RebarShapeDefinitionBySegments
Visual C++
public ref class RebarShapeDefinitionBySegments

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeDefinitionBySegmentsRebarShapeDefinitionBySegmentsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddBendDefaultRadius | Specify a default-radius bend.
Public method | AddBendVariableRadius | Specify a variable-radius bend.
Public method | AddConstraintParallelToSegment |
Public method | AddConstraintToSegment | Add a constraint that determines the length of a segment.
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveParameterFromSegment | Remove constraints from a segment.
Public method | SetSegmentAs180DegreeBend | Overloaded.
Public method | SetSegmentFixedDirection | Fix the direction of a segment.
Public method | SetSegmentVariableDirection | Remove the fixed direction from a segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides RebarShapeDefinition ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfSegments |

See Also

RebarShapeDefinitionBySegments
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinitionBySegments()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeDefinitionBySegments ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionBySegments
Visual Basic (Declaration)
Public Class RebarShapeDefinitionBySegments
Visual C++
public ref class RebarShapeDefinitionBySegments

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddBendDefaultRadius | Specify a default-radius bend.
Public method | AddBendVariableRadius | Specify a variable-radius bend.
Public method | AddConstraintParallelToSegment |
Public method | AddConstraintToSegment | Add a constraint that determines the length of a segment.
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveParameterFromSegment | Remove constraints from a segment.
Public method | SetSegmentAs180DegreeBend | Overloaded.
Public method | SetSegmentFixedDirection | Fix the direction of a segment.
Public method | SetSegmentVariableDirection | Remove the fixed direction from a segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides RebarShapeDefinition ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

RebarShapeDefinitionBySegments
Autodesk.Revit.Symbols Namespace


AddBendDefaultRadius Method

RebarShapeDefinitionBySegments..::AddBendDefaultRadius Method
See Also
CollapseAll image DropDown image

Specify a default-radius bend.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)
Visual Basic (Declaration)
Public Sub AddBendDefaultRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle _
)
Visual C++
public:
void AddBendDefaultRadius (
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)

Parameters

iSegmentFollowingBend
Int32
turn
Int32
Specify 1 for a left turn, -1 for a right turn.
angle
RebarShapeBendAngle

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddBendVariableRadius Method

RebarShapeDefinitionBySegments..::AddBendVariableRadius Method
See Also
CollapseAll image DropDown image

Specify a variable-radius bend.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter radiusParam,
    bool measureIncludingBarThickness
)
Visual Basic (Declaration)
Public Sub AddBendVariableRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle, _
    radiusParam As Parameter, _
    measureIncludingBarThickness As Boolean _
)
Visual C++
public:
void AddBendVariableRadius (
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter^ radiusParam,
    bool measureIncludingBarThickness
)

Parameters

iSegmentFollowingBend
Int32
turn
Int32
Specify 1 for a left turn, -1 for a right turn.
angle
RebarShapeBendAngle
radiusParam
Parameter
measureIncludingBarThickness
Boolean

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddConstraintParallelToSegment Method

RebarShapeDefinitionBySegments..::AddConstraintParallelToSegment Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintParallelToSegment(
    int iSegment,
    Parameter param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintParallelToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintParallelToSegment (
    int iSegment,
    Parameter^ param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Int32
param
Parameter
measureToOutsideOfBend0
Boolean
measureToOutsideOfBend1
Boolean

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddConstraintToSegment Method

RebarShapeDefinitionBySegments..::AddConstraintToSegment Method
See Also
CollapseAll image DropDown image

Add a constraint that determines the length of a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintToSegment(
    int iSegment,
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    signOfZCoordOfCrossProductOfConstraintDirBySegmentDir As Integer, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintToSegment (
    int iSegment,
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Int32
param
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
signOfZCoordOfCrossProductOfConstraintDirBySegmentDir
Int32
measureToOutsideOfBend0
Boolean
measureToOutsideOfBend1
Boolean

Remarks

The vector defined by (constraintDirCoordX, constraintDirCoordY) must have a positive dot product with the desired direction of the segment. This restriction, combined with the value of signOfZCoordOfCrossProductOfConstraintDirBySegmentDir, defines a quadrant of the plane that limits the variable-angle segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddListeningDimensionBendToBend Method

RebarShapeDefinitionBySegments..::AddListeningDimensionBendToBend Method
See Also
CollapseAll image DropDown image

Specify a dimension between two bends, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddListeningDimensionBendToBend(
    Parameter __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionBendToBend ( _
    __unnamed000 As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iEnd0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionBendToBend (
    Parameter^ __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)

Parameters

__unnamed000
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
iSegment0
Int32
Index of the first segment.
iEnd0
Int32
End (0 or 1) of the first segment.
iSegment1
Int32
Index of the second segment.
iEnd1
Int32
End (0 or 1) of the second segment.

Remarks

Each reference is at the outside of the bend, perpendicular to the specified segment. So the overall length of a shape with 5 segments might be defined by calling this function with iSegment0=0, iEnd0=0, iSegment1=4, iEnd1=1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddListeningDimensionSegmentToBend Method

RebarShapeDefinitionBySegments..::AddListeningDimensionSegmentToBend Method
See Also
CollapseAll image DropDown image

Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddListeningDimensionSegmentToBend(
    Parameter __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToBend ( _
    __unnamed000 As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToBend (
    Parameter^ __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)

Parameters

__unnamed000
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
iSegment0
Int32
Index of the first segment, which must be perpendicular to the constraint direction.
iSegment1
Int32
Index of the second segment.
iEnd1
Int32
End (0 or 1) of the second segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddListeningDimensionSegmentToSegment Method

RebarShapeDefinitionBySegments..::AddListeningDimensionSegmentToSegment Method
See Also
CollapseAll image DropDown image

Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddListeningDimensionSegmentToSegment(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToSegment ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToSegment (
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)

Parameters

param
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
iSegment0
Int32
iSegment1
Int32

Remarks

RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarShapeDefinitionBySegments..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RemoveParameterFromSegment Method

RebarShapeDefinitionBySegments..::RemoveParameterFromSegment Method
See Also
CollapseAll image DropDown image

Remove constraints from a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveParameterFromSegment(
    int iSegment,
    Parameter param
)
Visual Basic (Declaration)
Public Sub RemoveParameterFromSegment ( _
    iSegment As Integer, _
    param As Parameter _
)
Visual C++
public:
void RemoveParameterFromSegment (
    int iSegment,
    Parameter^ param
)

Parameters

iSegment
Int32
param
Parameter

Remarks

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


SetSegmentAs180DegreeBend Method

RebarShapeDefinitionBySegments..::SetSegmentAs180DegreeBend Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | SetSegmentAs180DegreeBend(Int32) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
Public method | SetSegmentAs180DegreeBend(Int32, Parameter, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

See Also

RebarShapeDefinitionBySegments Class
RebarShapeDefinitionBySegments Members
Autodesk.Revit.Symbols Namespace


SetSegmentAs180DegreeBend Method (Int32)

RebarShapeDefinitionBySegments..::SetSegmentAs180DegreeBend Method (Int32)
See Also
CollapseAll image DropDown image

Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentAs180DegreeBend (
    int iSegment
)

Parameters

iSegment
Int32

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)

RebarShapeDefinitionBySegments..::SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)
See Also
CollapseAll image DropDown image

Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter radiusParam,
    bool measureToOutsideOfBend
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer, _
    radiusParam As Parameter, _
    measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend (
    int iSegment,
    Parameter^ radiusParam,
    bool measureToOutsideOfBend
)

Parameters

iSegment
Int32
radiusParam
Parameter
measureToOutsideOfBend
Boolean

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


SetSegmentFixedDirection Method

RebarShapeDefinitionBySegments..::SetSegmentFixedDirection Method
See Also
CollapseAll image DropDown image

Fix the direction of a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)
Visual Basic (Declaration)
Public Sub SetSegmentFixedDirection ( _
    iSegment As Integer, _
    vecCoordX As Double, _
    vecCoordY As Double _
)
Visual C++
public:
void SetSegmentFixedDirection (
    int iSegment,
    double vecCoordX,
    double vecCoordY
)

Parameters

iSegment
Int32
vecCoordX
Double
vecCoordY
Double

Remarks

The centerline of the segment will be constrained to be parallel to the vector. The line must have at least one constraint.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


SetSegmentVariableDirection Method

RebarShapeDefinitionBySegments..::SetSegmentVariableDirection Method
See Also
CollapseAll image DropDown image

Remove the fixed direction from a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetSegmentVariableDirection(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentVariableDirection ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentVariableDirection (
    int iSegment
)

Parameters

iSegment
Int32

Remarks

The segment's angle will be allowed to vary, with a range of 90 degrees. The line must have at least two constraints.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionBySegments
Visual Basic (Declaration)
Public Class RebarShapeDefinitionBySegments
Visual C++
public ref class RebarShapeDefinitionBySegments

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfSegments |

See Also

RebarShapeDefinitionBySegments
Autodesk.Revit.Symbols Namespace


NumberOfSegments Property

RebarShapeDefinitionBySegments..::NumberOfSegments Property
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumberOfSegments{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSegments As Integer
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RebarShapeSet Class
See Also Members
CollapseAll image DropDown image

An set that contains rebar shapes.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8833A7FD-F8C0-4699-950F-82897102D4A3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RebarShapeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("8833A7FD-F8C0-4699-950F-82897102D4A3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RebarShapeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"8833A7FD-F8C0-4699-950F-82897102D4A3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarShapeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarShapeSet

See Also

RebarShapeSet Members
Autodesk.Revit.Symbols Namespace


RebarShapeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeSet
Visual Basic (Declaration)
Public Class RebarShapeSet
Visual C++
public ref class RebarShapeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeSetRebarShapeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every rebar shape from the set, rendering it empty.
Public method | Contains | Tests for the existence of a rebar shape within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified rebar shape from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified rebar shape into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet
Autodesk.Revit.Symbols Namespace


RebarShapeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeSet ()

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


RebarShapeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeSet
Visual Basic (Declaration)
Public Class RebarShapeSet
Visual C++
public ref class RebarShapeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every rebar shape from the set, rendering it empty.
Public method | Contains | Tests for the existence of a rebar shape within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified rebar shape from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified rebar shape into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarShapeSet
Autodesk.Revit.Symbols Namespace


Clear Method

RebarShapeSet..::Clear Method
CollapseAll image DropDown image

Removes every rebar shape from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

RebarShapeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a rebar shape within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Contains (
    RebarShape^ item
)

Parameters

item
RebarShape
The rebar shape to be searched for.

Return Value

The Contains method returns True if the rebar shape is within the set, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarShapeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

RebarShapeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified rebar shape from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarShape _
) As Integer
Visual C++
public:
virtual int Erase (
    RebarShape^ item
)

Parameters

item
RebarShape
The rebar shape to be erased.

Return Value

The number of rebar shapes that were erased from the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

RebarShapeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarShapeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

RebarShapeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

RebarShapeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified rebar shape into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Insert (
    RebarShape^ item
)

Parameters

item
RebarShape
The rebar shape to be inserted into the set.

Return Value

Returns whether the rebar shape was inserted into the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarShapeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

RebarShapeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RebarShapeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


RebarShapeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeSet
Visual Basic (Declaration)
Public Class RebarShapeSet
Visual C++
public ref class RebarShapeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

RebarShapeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

RebarShapeSet..::Size Property
CollapseAll image DropDown image

Returns the number of rebar shapes that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a rebar shape set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("521A9A61-C638-46a7-8BE8-A87C826E2293")]
public abstract class RebarShapeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("521A9A61-C638-46a7-8BE8-A87C826E2293")> _
Public MustInherit Class RebarShapeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"521A9A61-C638-46a7-8BE8-A87C826E2293")]
public ref class RebarShapeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarShapeSetIterator

See Also

RebarShapeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarShapeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarShapeSetIterator
Visual C++
public ref class RebarShapeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeSetIteratorRebarShapeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarShapeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarShapeSetIterator
Visual C++
public ref class RebarShapeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarShapeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

RebarShapeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

RebarShapeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RebarShapeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

RebarShapeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class RebarShapeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RebarShapeSetIterator
Visual C++
public ref class RebarShapeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

RebarShapeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoofType Class
See Also Members
CollapseAll image DropDown image

Represents a specific type of roof.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FD40F869-65FA-4462-BA37-F902FEA5DCFB")]
public class RoofType : HostObjAttributes
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FD40F869-65FA-4462-BA37-F902FEA5DCFB")> _
Public Class RoofType _
    Inherits HostObjAttributes
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FD40F869-65FA-4462-BA37-F902FEA5DCFB")]
public ref class RoofType : public HostObjAttributes

Remarks

All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::RoofType

See Also

RoofType Members
Autodesk.Revit.Symbols Namespace


RoofType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RoofType
Visual Basic (Declaration)
Public Class RoofType
Visual C++
public ref class RoofType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoofTypeRoofTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoofType
Autodesk.Revit.Symbols Namespace


RoofType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoofType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoofType Class
Autodesk.Revit.Symbols Namespace


RoofTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains roof types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6CCBAD8F-EE00-4ddf-BB8F-B8EF805EBE14")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RoofTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("6CCBAD8F-EE00-4ddf-BB8F-B8EF805EBE14")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RoofTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"6CCBAD8F-EE00-4ddf-BB8F-B8EF805EBE14")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RoofTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RoofTypeSet

See Also

RoofTypeSet Members
Autodesk.Revit.Symbols Namespace


RoofTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RoofTypeSet
Visual Basic (Declaration)
Public Class RoofTypeSet
Visual C++
public ref class RoofTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoofTypeSetRoofTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every roof type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a roof type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified roof type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified roof type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet
Autodesk.Revit.Symbols Namespace


RoofTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoofTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofTypeSet ()

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


RoofTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RoofTypeSet
Visual Basic (Declaration)
Public Class RoofTypeSet
Visual C++
public ref class RoofTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every roof type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a roof type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified roof type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified roof type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RoofTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

RoofTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every roof type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

RoofTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a roof type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    RoofType^ item
)

Parameters

item
RoofType
The roof type to be searched for.

Return Value

The Contains method returns True if the roof type is within the set, otherwise False.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RoofTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

RoofTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified roof type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoofType _
) As Integer
Visual C++
public:
virtual int Erase (
    RoofType^ item
)

Parameters

item
RoofType
The roof type to be erased.

Return Value

The number of roof types that were erased from the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

RoofTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RoofTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

RoofTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

RoofTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified roof type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    RoofType^ item
)

Parameters

item
RoofType
The roof type to be inserted into the set.

Return Value

Returns whether the roof type was inserted into the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RoofTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

RoofTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RoofTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


RoofTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class RoofTypeSet
Visual Basic (Declaration)
Public Class RoofTypeSet
Visual C++
public ref class RoofTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

RoofTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

RoofTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of roof types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a roof type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("45AD0B09-B726-4ef9-B37D-B84C9F9E6213")]
public abstract class RoofTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("45AD0B09-B726-4ef9-B37D-B84C9F9E6213")> _
Public MustInherit Class RoofTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"45AD0B09-B726-4ef9-B37D-B84C9F9E6213")]
public ref class RoofTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RoofTypeSetIterator

See Also

RoofTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class RoofTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RoofTypeSetIterator
Visual C++
public ref class RoofTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoofTypeSetIteratorRoofTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoofTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class RoofTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RoofTypeSetIterator
Visual C++
public ref class RoofTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RoofTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

RoofTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

RoofTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RoofTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

RoofTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class RoofTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RoofTypeSetIterator
Visual C++
public ref class RoofTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

RoofTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoomTagType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FEF207A3-0247-4ce2-8A3F-C9BBD553545F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RoomTagType : Symbol
Visual Basic (Declaration)
<GuidAttribute("FEF207A3-0247-4ce2-8A3F-C9BBD553545F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RoomTagType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"FEF207A3-0247-4ce2-8A3F-C9BBD553545F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RoomTagType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RoomTagType

See Also

RoomTagType Members
Autodesk.Revit.Symbols Namespace


RoomTagType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RoomTagType
Visual Basic (Declaration)
Public Class RoomTagType
Visual C++
public ref class RoomTagType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoomTagTypeRoomTagTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoomTagType
Autodesk.Revit.Symbols Namespace


RoomTagType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTagType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTagType Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains room tag types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("85653B88-3136-4134-B89D-365B76EE84DE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RoomTagTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("85653B88-3136-4134-B89D-365B76EE84DE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RoomTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"85653B88-3136-4134-B89D-365B76EE84DE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RoomTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RoomTagTypeSet

See Also

RoomTagTypeSet Members
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RoomTagTypeSet
Visual Basic (Declaration)
Public Class RoomTagTypeSet
Visual C++
public ref class RoomTagTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoomTagTypeSetRoomTagTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every room tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a room tag type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified room tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified room tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagTypeSet ()

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RoomTagTypeSet
Visual Basic (Declaration)
Public Class RoomTagTypeSet
Visual C++
public ref class RoomTagTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every room tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a room tag type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified room tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified room tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RoomTagTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

RoomTagTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every room tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

RoomTagTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a room tag type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    RoomTagType^ item
)

Parameters

item
RoomTagType
The room tag type to be searched for.

Return Value

The Contains method returns True if the room tag type is within the set, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

RoomTagTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

RoomTagTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified room tag type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoomTagType _
) As Integer
Visual C++
public:
virtual int Erase (
    RoomTagType^ item
)

Parameters

item
RoomTagType
The room tag type to be erased.

Return Value

The number of room tag types that were erased from the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

RoomTagTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RoomTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

RoomTagTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

RoomTagTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified room tag type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    RoomTagType^ item
)

Parameters

item
RoomTagType
The room tag type to be inserted into the set.

Return Value

Returns whether the room tag type was inserted into the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RoomTagTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

RoomTagTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual RoomTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class RoomTagTypeSet
Visual Basic (Declaration)
Public Class RoomTagTypeSet
Visual C++
public ref class RoomTagTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

RoomTagTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

RoomTagTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of room tag types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a room tag type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("38859A84-1F13-4a03-AA61-1EA497288272")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class RoomTagTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("38859A84-1F13-4a03-AA61-1EA497288272")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class RoomTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"38859A84-1F13-4a03-AA61-1EA497288272")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RoomTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RoomTagTypeSetIterator

See Also

RoomTagTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class RoomTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RoomTagTypeSetIterator
Visual C++
public ref class RoomTagTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoomTagTypeSetIteratorRoomTagTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class RoomTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RoomTagTypeSetIterator
Visual C++
public ref class RoomTagTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RoomTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

RoomTagTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

RoomTagTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

RoomTagTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

RoomTagTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class RoomTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class RoomTagTypeSetIterator
Visual C++
public ref class RoomTagTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

RoomTagTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SlabEdgeType Class
See Also Members
CollapseAll image DropDown image

An object that represents the slab edge type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3470A8B8-0E11-4517-BC98-849B09CED8DF")]
public class SlabEdgeType : HostedSweepType
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3470A8B8-0E11-4517-BC98-849B09CED8DF")> _
Public Class SlabEdgeType _
    Inherits HostedSweepType
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3470A8B8-0E11-4517-BC98-849B09CED8DF")]
public ref class SlabEdgeType : public HostedSweepType

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::HostedSweepType
Autodesk.Revit.Symbols..::SlabEdgeType

See Also

SlabEdgeType Members
Autodesk.Revit.Symbols Namespace


SlabEdgeType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SlabEdgeType
Visual Basic (Declaration)
Public Class SlabEdgeType
Visual C++
public ref class SlabEdgeType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabEdgeTypeSlabEdgeTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SlabEdgeType
Autodesk.Revit.Symbols Namespace


SlabEdgeType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdgeType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdgeType Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains slab edge types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FA2E905D-5348-4105-9F65-697067E4A401")]
public class SlabEdgeTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FA2E905D-5348-4105-9F65-697067E4A401")> _
Public Class SlabEdgeTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FA2E905D-5348-4105-9F65-697067E4A401")]
public ref class SlabEdgeTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::SlabEdgeTypeSet

See Also

SlabEdgeTypeSet Members
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SlabEdgeTypeSet
Visual Basic (Declaration)
Public Class SlabEdgeTypeSet
Visual C++
public ref class SlabEdgeTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabEdgeTypeSetSlabEdgeTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every slab edge type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a slab edge type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified slab edge type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified slab edge type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdgeTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeTypeSet ()

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class SlabEdgeTypeSet
Visual Basic (Declaration)
Public Class SlabEdgeTypeSet
Visual C++
public ref class SlabEdgeTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every slab edge type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a slab edge type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified slab edge type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified slab edge type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SlabEdgeTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

SlabEdgeTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every slab edge type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

SlabEdgeTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a slab edge type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    SlabEdgeType^ item
)

Parameters

item
SlabEdgeType
The slab edge type to be searched for.

Return Value

The Contains method returns True if the slab edge type is within the set, otherwise False.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

SlabEdgeTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

SlabEdgeTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified slab edge type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SlabEdgeType _
) As Integer
Visual C++
public:
virtual int Erase (
    SlabEdgeType^ item
)

Parameters

item
SlabEdgeType
The slab edge type to be erased.

Return Value

The number of slab edge types that were erased from the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

SlabEdgeTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabEdgeTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

SlabEdgeTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

SlabEdgeTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified slab edge type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    SlabEdgeType^ item
)

Parameters

item
SlabEdgeType
The slab edge type to be inserted into the set.

Return Value

Returns whether the slab edge type was inserted into the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

SlabEdgeTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

SlabEdgeTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SlabEdgeTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class SlabEdgeTypeSet
Visual Basic (Declaration)
Public Class SlabEdgeTypeSet
Visual C++
public ref class SlabEdgeTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

SlabEdgeTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

SlabEdgeTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of slab edge types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a slab edge type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3628A0C2-32B3-405a-B249-5FA3937719B3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class SlabEdgeTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("3628A0C2-32B3-405a-B249-5FA3937719B3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class SlabEdgeTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"3628A0C2-32B3-405a-B249-5FA3937719B3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SlabEdgeTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::SlabEdgeTypeSetIterator

See Also

SlabEdgeTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabEdgeTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SlabEdgeTypeSetIterator
Visual C++
public ref class SlabEdgeTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SlabEdgeTypeSetIteratorSlabEdgeTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdgeTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabEdgeTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SlabEdgeTypeSetIterator
Visual C++
public ref class SlabEdgeTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SlabEdgeTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

SlabEdgeTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

SlabEdgeTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

SlabEdgeTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

SlabEdgeTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SlabEdgeTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SlabEdgeTypeSetIterator
Visual C++
public ref class SlabEdgeTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

SlabEdgeTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpaceTagType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("284DBC8E-5038-4f49-9954-7B8A8FF3B7F3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SpaceTagType : Symbol
Visual Basic (Declaration)
<GuidAttribute("284DBC8E-5038-4f49-9954-7B8A8FF3B7F3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SpaceTagType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"284DBC8E-5038-4f49-9954-7B8A8FF3B7F3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SpaceTagType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::SpaceTagType

See Also

SpaceTagType Members
Autodesk.Revit.Symbols Namespace


SpaceTagType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpaceTagType
Visual Basic (Declaration)
Public Class SpaceTagType
Visual C++
public ref class SpaceTagType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpaceTagTypeSpaceTagTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SpaceTagType
Autodesk.Revit.Symbols Namespace


SpaceTagType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceTagType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTagType Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains space tag types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B4102D94-8E75-40dd-A3BC-BC02AC521503")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SpaceTagTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("B4102D94-8E75-40dd-A3BC-BC02AC521503")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SpaceTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"B4102D94-8E75-40dd-A3BC-BC02AC521503")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SpaceTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::SpaceTagTypeSet

See Also

SpaceTagTypeSet Members
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpaceTagTypeSet
Visual Basic (Declaration)
Public Class SpaceTagTypeSet
Visual C++
public ref class SpaceTagTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpaceTagTypeSetSpaceTagTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every space tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a space tag type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified space tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified space tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagTypeSet ()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class SpaceTagTypeSet
Visual Basic (Declaration)
Public Class SpaceTagTypeSet
Visual C++
public ref class SpaceTagTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every space tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a space tag type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified space tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified space tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SpaceTagTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

SpaceTagTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every space tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

SpaceTagTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a space tag type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    SpaceTagType^ item
)

Parameters

item
SpaceTagType
The space tag type to be searched for.

Return Value

The Contains method returns True if the space tag type is within the set, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

SpaceTagTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

SpaceTagTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified space tag type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SpaceTagType _
) As Integer
Visual C++
public:
virtual int Erase (
    SpaceTagType^ item
)

Parameters

item
SpaceTagType
The space tag type to be erased.

Return Value

The number of space tag types that were erased from the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

SpaceTagTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SpaceTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

SpaceTagTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

SpaceTagTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified space tag type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    SpaceTagType^ item
)

Parameters

item
SpaceTagType
The space tag type to be inserted into the set.

Return Value

Returns whether the space tag type was inserted into the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

SpaceTagTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

SpaceTagTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SpaceTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class SpaceTagTypeSet
Visual Basic (Declaration)
Public Class SpaceTagTypeSet
Visual C++
public ref class SpaceTagTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

SpaceTagTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

SpaceTagTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of space tag types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a space tag type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7FC4DB0A-DF6E-446d-A822-4CF43BF8C74D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class SpaceTagTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("7FC4DB0A-DF6E-446d-A822-4CF43BF8C74D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class SpaceTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"7FC4DB0A-DF6E-446d-A822-4CF43BF8C74D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SpaceTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::SpaceTagTypeSetIterator

See Also

SpaceTagTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SpaceTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpaceTagTypeSetIterator
Visual C++
public ref class SpaceTagTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpaceTagTypeSetIteratorSpaceTagTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpaceTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SpaceTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpaceTagTypeSetIterator
Visual C++
public ref class SpaceTagTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SpaceTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

SpaceTagTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

SpaceTagTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

SpaceTagTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

SpaceTagTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SpaceTagTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpaceTagTypeSetIterator
Visual C++
public ref class SpaceTagTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

SpaceTagTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpotDimensionType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a spot dimension in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("33E06682-FB9E-42ab-8493-6DDCFE5485D0")]
public class SpotDimensionType : DimensionType
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("33E06682-FB9E-42ab-8493-6DDCFE5485D0")> _
Public Class SpotDimensionType _
    Inherits DimensionType
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"33E06682-FB9E-42ab-8493-6DDCFE5485D0")]
public ref class SpotDimensionType : public DimensionType

Remarks

The types of a spot dimension can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::DimensionType
Autodesk.Revit.Symbols..::SpotDimensionType

See Also

SpotDimensionType Members
Autodesk.Revit.Symbols Namespace


SpotDimensionType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpotDimensionType
Visual Basic (Declaration)
Public Class SpotDimensionType
Visual C++
public ref class SpotDimensionType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpotDimensionTypeSpotDimensionTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SpotDimensionType
Autodesk.Revit.Symbols Namespace


SpotDimensionType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimensionType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpotDimensionType Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains spotdimension types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2FD73765-98C9-4dd7-B160-ED6F28975992")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SpotDimensionTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("2FD73765-98C9-4dd7-B160-ED6F28975992")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SpotDimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"2FD73765-98C9-4dd7-B160-ED6F28975992")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SpotDimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::SpotDimensionTypeSet

See Also

SpotDimensionTypeSet Members
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpotDimensionTypeSet
Visual Basic (Declaration)
Public Class SpotDimensionTypeSet
Visual C++
public ref class SpotDimensionTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpotDimensionTypeSetSpotDimensionTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every spotdimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a spotdimension type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified spotdimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified spotdimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimensionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionTypeSet ()

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class SpotDimensionTypeSet
Visual Basic (Declaration)
Public Class SpotDimensionTypeSet
Visual C++
public ref class SpotDimensionTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every spotdimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a spotdimension type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified spotdimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified spotdimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SpotDimensionTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

SpotDimensionTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every spotdimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

SpotDimensionTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a spotdimension type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    SpotDimensionType^ item
)

Parameters

item
SpotDimensionType
The spotdimension type to be searched for.

Return Value

The Contains method returns True if the spotdimension type is within the set, otherwise False.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

SpotDimensionTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

SpotDimensionTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified spotdimension type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SpotDimensionType _
) As Integer
Visual C++
public:
virtual int Erase (
    SpotDimensionType^ item
)

Parameters

item
SpotDimensionType
The spotdimension type to be erased.

Return Value

The number of spotdimension types that were erased from the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

SpotDimensionTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SpotDimensionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

SpotDimensionTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

SpotDimensionTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified spotdimension type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    SpotDimensionType^ item
)

Parameters

item
SpotDimensionType
The spotdimension type to be inserted into the set.

Return Value

Returns whether the spotdimension type was inserted into the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

SpotDimensionTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

SpotDimensionTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual SpotDimensionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class SpotDimensionTypeSet
Visual Basic (Declaration)
Public Class SpotDimensionTypeSet
Visual C++
public ref class SpotDimensionTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

SpotDimensionTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

SpotDimensionTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of spotdimension types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a spotdimension type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A397D957-0455-4599-8913-1C9BF3F771A5")]
public abstract class SpotDimensionTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A397D957-0455-4599-8913-1C9BF3F771A5")> _
Public MustInherit Class SpotDimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A397D957-0455-4599-8913-1C9BF3F771A5")]
public ref class SpotDimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::SpotDimensionTypeSetIterator

See Also

SpotDimensionTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class SpotDimensionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpotDimensionTypeSetIterator
Visual C++
public ref class SpotDimensionTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpotDimensionTypeSetIteratorSpotDimensionTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimensionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class SpotDimensionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpotDimensionTypeSetIterator
Visual C++
public ref class SpotDimensionTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

SpotDimensionTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

SpotDimensionTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

SpotDimensionTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

SpotDimensionTypeSetIterator..::ReleaseUnmanagedResources Method
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

SpotDimensionTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class SpotDimensionTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class SpotDimensionTypeSetIterator
Visual C++
public ref class SpotDimensionTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

SpotDimensionTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TextElementType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("ABBD8EEF-F133-4e1f-8D14-C32BD1988739")]
public class TextElementType : LineAndTextAttrSymbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("ABBD8EEF-F133-4e1f-8D14-C32BD1988739")> _
Public Class TextElementType _
    Inherits LineAndTextAttrSymbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"ABBD8EEF-F133-4e1f-8D14-C32BD1988739")]
public ref class TextElementType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::TextElementType
Autodesk.Revit.Symbols..::TextNoteType

See Also

TextElementType Members
Autodesk.Revit.Symbols Namespace


TextElementType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TextElementType
Visual Basic (Declaration)
Public Class TextElementType
Visual C++
public ref class TextElementType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TextElementTypeTextElementTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextElementType
Autodesk.Revit.Symbols Namespace


TextElementType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextElementType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextElementType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextElementType Class
Autodesk.Revit.Symbols Namespace


TextNoteType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5027ABB2-0254-495d-9FAB-2FF1AF76CB99")]
public class TextNoteType : TextElementType
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5027ABB2-0254-495d-9FAB-2FF1AF76CB99")> _
Public Class TextNoteType _
    Inherits TextElementType
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5027ABB2-0254-495d-9FAB-2FF1AF76CB99")]
public ref class TextNoteType : public TextElementType

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::TextElementType
Autodesk.Revit.Symbols..::TextNoteType

See Also

TextNoteType Members
Autodesk.Revit.Symbols Namespace


TextNoteType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TextNoteType
Visual Basic (Declaration)
Public Class TextNoteType
Visual C++
public ref class TextNoteType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TextNoteTypeTextNoteTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextNoteType
Autodesk.Revit.Symbols Namespace


TextNoteType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNoteType Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains textnote types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("17F923F9-EF32-4e21-B05F-C41CBE46D907")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class TextNoteTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("17F923F9-EF32-4e21-B05F-C41CBE46D907")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class TextNoteTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"17F923F9-EF32-4e21-B05F-C41CBE46D907")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TextNoteTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::TextNoteTypeSet

See Also

TextNoteTypeSet Members
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TextNoteTypeSet
Visual Basic (Declaration)
Public Class TextNoteTypeSet
Visual C++
public ref class TextNoteTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TextNoteTypeSetTextNoteTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every textnote type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a textnote type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified textnote type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified textnote type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteTypeSet ()

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class TextNoteTypeSet
Visual Basic (Declaration)
Public Class TextNoteTypeSet
Visual C++
public ref class TextNoteTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every textnote type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a textnote type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified textnote type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified textnote type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

TextNoteTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

TextNoteTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every textnote type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

TextNoteTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a textnote type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    TextNoteType^ item
)

Parameters

item
TextNoteType
The textnote type to be searched for.

Return Value

The Contains method returns True if the textnote type is within the set, otherwise False.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

TextNoteTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

TextNoteTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified textnote type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TextNoteType _
) As Integer
Visual C++
public:
virtual int Erase (
    TextNoteType^ item
)

Parameters

item
TextNoteType
The textnote type to be erased.

Return Value

The number of textnote types that were erased from the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

TextNoteTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual TextNoteTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

TextNoteTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

TextNoteTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified textnote type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    TextNoteType^ item
)

Parameters

item
TextNoteType
The textnote type to be inserted into the set.

Return Value

Returns whether the textnote type was inserted into the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

TextNoteTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

TextNoteTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual TextNoteTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class TextNoteTypeSet
Visual Basic (Declaration)
Public Class TextNoteTypeSet
Visual C++
public ref class TextNoteTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

TextNoteTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

TextNoteTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of textnote types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a textnote type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("91359D45-EC71-4196-A161-57A5892840EC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class TextNoteTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("91359D45-EC71-4196-A161-57A5892840EC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class TextNoteTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"91359D45-EC71-4196-A161-57A5892840EC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TextNoteTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::TextNoteTypeSetIterator

See Also

TextNoteTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class TextNoteTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TextNoteTypeSetIterator
Visual C++
public ref class TextNoteTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TextNoteTypeSetIteratorTextNoteTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class TextNoteTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TextNoteTypeSetIterator
Visual C++
public ref class TextNoteTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

TextNoteTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

TextNoteTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

TextNoteTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

TextNoteTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

TextNoteTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class TextNoteTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TextNoteTypeSetIterator
Visual C++
public ref class TextNoteTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

TextNoteTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TrussType Class
See Also Members
CollapseAll image DropDown image

Represents a specific type of truss.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E7BA9C7B-D08C-4229-9043-A8266EA97E59")]
public class TrussType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E7BA9C7B-D08C-4229-9043-A8266EA97E59")> _
Public Class TrussType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E7BA9C7B-D08C-4229-9043-A8266EA97E59")]
public ref class TrussType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::TrussType

See Also

TrussType Members
Autodesk.Revit.Symbols Namespace


TrussType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TrussType
Visual Basic (Declaration)
Public Class TrussType
Visual C++
public ref class TrussType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TrussTypeTrussTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TrussType
Autodesk.Revit.Symbols Namespace


TrussType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussType Class
Autodesk.Revit.Symbols Namespace


TrussTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains Truss types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FD1D2689-A70F-4052-90DF-919F96E69881")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class TrussTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("FD1D2689-A70F-4052-90DF-919F96E69881")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class TrussTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"FD1D2689-A70F-4052-90DF-919F96E69881")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TrussTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::TrussTypeSet

See Also

TrussTypeSet Members
Autodesk.Revit.Symbols Namespace


TrussTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TrussTypeSet
Visual Basic (Declaration)
Public Class TrussTypeSet
Visual C++
public ref class TrussTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TrussTypeSetTrussTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every Truss type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a Truss type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified Truss type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified Truss type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet
Autodesk.Revit.Symbols Namespace


TrussTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussTypeSet ()

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


TrussTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class TrussTypeSet
Visual Basic (Declaration)
Public Class TrussTypeSet
Visual C++
public ref class TrussTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every Truss type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a Truss type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified Truss type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified Truss type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

TrussTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

TrussTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every Truss type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

TrussTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a Truss type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    TrussType^ item
)

Parameters

item
TrussType
The Truss type to be searched for.

Return Value

The Contains method returns True if the Truss type is within the set, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

TrussTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

TrussTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified Truss type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TrussType _
) As Integer
Visual C++
public:
virtual int Erase (
    TrussType^ item
)

Parameters

item
TrussType
The Truss type to be erased.

Return Value

The number of Truss types that were erased from the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

TrussTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual TrussTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

TrussTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

TrussTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified Truss type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    TrussType^ item
)

Parameters

item
TrussType
The Truss type to be inserted into the set.

Return Value

Returns whether the Truss type was inserted into the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

TrussTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

TrussTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual TrussTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


TrussTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class TrussTypeSet
Visual Basic (Declaration)
Public Class TrussTypeSet
Visual C++
public ref class TrussTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

TrussTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

TrussTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of Truss types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a Truss type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1F2AEAE4-3CF0-4468-AACF-56201F8CFD3E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class TrussTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("1F2AEAE4-3CF0-4468-AACF-56201F8CFD3E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class TrussTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"1F2AEAE4-3CF0-4468-AACF-56201F8CFD3E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TrussTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::TrussTypeSetIterator

See Also

TrussTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class TrussTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TrussTypeSetIterator
Visual C++
public ref class TrussTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TrussTypeSetIteratorTrussTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TrussTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class TrussTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TrussTypeSetIterator
Visual C++
public ref class TrussTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

TrussTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

TrussTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

TrussTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

TrussTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

TrussTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class TrussTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class TrussTypeSetIterator
Visual C++
public ref class TrussTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

TrussTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


VoltageType Class
See Also Members
CollapseAll image DropDown image

Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2E85B874-1C11-4d8c-9776-6CF7FCC455EB")]
public class VoltageType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2E85B874-1C11-4d8c-9776-6CF7FCC455EB")> _
Public Class VoltageType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2E85B874-1C11-4d8c-9776-6CF7FCC455EB")]
public ref class VoltageType : public Symbol

Remarks

Actual, minimum and maximum value of voltage type can retrieved through properties, but only can be modified through SetVoltageValue method. All the unit of voltage properties in this class is volt.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::VoltageType

See Also

VoltageType Members
Autodesk.Revit.Symbols Namespace


VoltageType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class VoltageType
Visual Basic (Declaration)
Public Class VoltageType
Visual C++
public ref class VoltageType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | VoltageTypeVoltageTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
Public property | MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

VoltageType
Autodesk.Revit.Symbols Namespace


VoltageType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VoltageType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VoltageType Class
Autodesk.Revit.Symbols Namespace


VoltageType Methods
CollapseAll image DropDown image

Syntax

C#
public class VoltageType
Visual Basic (Declaration)
Public Class VoltageType
Visual C++
public ref class VoltageType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

VoltageType
Autodesk.Revit.Symbols Namespace


SetVoltageValue Method

VoltageType..::SetVoltageValue Method
CollapseAll image DropDown image

Assign new values to modify voltage type, all of the unit are volt.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Sub SetVoltageValue ( _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
)
Visual C++
public:
void SetVoltageValue (
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

actualValue
Double
minValue
Double
maxValue
Double

Exceptions

Exception | Condition
System..::ArgumentException | Actual value can't be more than minValue or less than maxValue, and all of them can't be negative, otherwise the exception will be thrown.

See Also

VoltageType Class
Autodesk.Revit.Symbols Namespace


VoltageType Properties
CollapseAll image DropDown image

Syntax

C#
public class VoltageType
Visual Basic (Declaration)
Public Class VoltageType
Visual C++
public ref class VoltageType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
Public property | MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

VoltageType
Autodesk.Revit.Symbols Namespace


ActualValue Property

VoltageType..::ActualValue Property
CollapseAll image DropDown image

Get actual voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ActualValue{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ActualValue As Double
Visual C++
public:
property double ActualValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.Symbols Namespace


IsInUse Property

VoltageType..::IsInUse Property
CollapseAll image DropDown image

Indicates whether this voltage type is in service now, such as by other distribution system.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInUse{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

VoltageType Class
Autodesk.Revit.Symbols Namespace


MaxValue Property

VoltageType..::MaxValue Property
CollapseAll image DropDown image

Get upper boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double MaxValue{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MaxValue As Double
Visual C++
public:
property double MaxValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.Symbols Namespace


MinValue Property

VoltageType..::MinValue Property
CollapseAll image DropDown image

Get lower boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double MinValue{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MinValue As Double
Visual C++
public:
property double MinValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

VoltageType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

VoltageType Class
VoltageType Members
Autodesk.Revit.Symbols Namespace


VoltageTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains voltage types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7E22350D-CD8E-4f0e-A361-272D7A8DB0EB")]
public class VoltageTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7E22350D-CD8E-4f0e-A361-272D7A8DB0EB")> _
Public Class VoltageTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7E22350D-CD8E-4f0e-A361-272D7A8DB0EB")]
public ref class VoltageTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::VoltageTypeSet

See Also

VoltageTypeSet Members
Autodesk.Revit.Symbols Namespace


VoltageTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class VoltageTypeSet
Visual Basic (Declaration)
Public Class VoltageTypeSet
Visual C++
public ref class VoltageTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | VoltageTypeSetVoltageTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every voltage type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a voltage type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified voltage type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified voltage type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of voltage types that are in the set.

See Also

VoltageTypeSet
Autodesk.Revit.Symbols Namespace


VoltageTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VoltageTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageTypeSet ()

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


VoltageTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class VoltageTypeSet
Visual Basic (Declaration)
Public Class VoltageTypeSet
Visual C++
public ref class VoltageTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every voltage type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a voltage type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified voltage type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified voltage type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

VoltageTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

VoltageTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every voltage type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

VoltageTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a voltage type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    VoltageType^ item
)

Parameters

item
VoltageType
The voltage type to be searched for.

Return Value

The Contains method returns True if the voltage type is within the set, otherwise False.

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

VoltageTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

VoltageTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified voltage type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As VoltageType _
) As Integer
Visual C++
public:
virtual int Erase (
    VoltageType^ item
)

Parameters

item
VoltageType
The voltage type to be erased.

Return Value

The number of voltage types that were erased from the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

VoltageTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual VoltageTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

VoltageTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

VoltageTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified voltage type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    VoltageType^ item
)

Parameters

item
VoltageType
The voltage type to be inserted into the set.

Return Value

Returns whether the voltage type was inserted into the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

VoltageTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

VoltageTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual VoltageTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


VoltageTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class VoltageTypeSet
Visual Basic (Declaration)
Public Class VoltageTypeSet
Visual C++
public ref class VoltageTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of voltage types that are in the set.

See Also

VoltageTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

VoltageTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

VoltageTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of voltage types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VoltageTypeSet Class
Autodesk.Revit.Symbols Namespace


VoltageTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a voltage type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2222C6E8-4FF5-45fa-93FD-275E8DB6136E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class VoltageTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("2222C6E8-4FF5-45fa-93FD-275E8DB6136E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class VoltageTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"2222C6E8-4FF5-45fa-93FD-275E8DB6136E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class VoltageTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::VoltageTypeSetIterator

See Also

VoltageTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


VoltageTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class VoltageTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class VoltageTypeSetIterator
Visual C++
public ref class VoltageTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | VoltageTypeSetIteratorVoltageTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator
Autodesk.Revit.Symbols Namespace


VoltageTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public VoltageTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


VoltageTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class VoltageTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class VoltageTypeSetIterator
Visual C++
public ref class VoltageTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

VoltageTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

VoltageTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

VoltageTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

VoltageTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

VoltageTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


VoltageTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class VoltageTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class VoltageTypeSetIterator
Visual C++
public ref class VoltageTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

VoltageTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WallType Class
See Also Members
CollapseAll image DropDown image

Represents a specific type of wall, such as 'Generic -8" '.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D9B7204E-6EB9-4f93-880F-71908ADCB797")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WallType : HostObjAttributes
Visual Basic (Declaration)
<GuidAttribute("D9B7204E-6EB9-4f93-880F-71908ADCB797")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WallType _
    Inherits HostObjAttributes
Visual C++
[GuidAttribute(L"D9B7204E-6EB9-4f93-880F-71908ADCB797")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WallType : public HostObjAttributes

Remarks

All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::WallType

See Also

WallType Members
Autodesk.Revit.Symbols Namespace


WallType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WallType
Visual Basic (Declaration)
Public Class WallType
Visual C++
public ref class WallType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WallTypeWallTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Kind | Reports the nature of the wall
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Width | Returns the overall thickness of this type of wall.

See Also

WallType
Autodesk.Revit.Symbols Namespace


WallType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


WallType Properties
CollapseAll image DropDown image

Syntax

C#
public class WallType
Visual Basic (Declaration)
Public Class WallType
Visual C++
public ref class WallType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Kind | Reports the nature of the wall
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Width | Returns the overall thickness of this type of wall.

See Also

WallType
Autodesk.Revit.Symbols Namespace


Kind Property

WallType..::Kind Property
CollapseAll image DropDown image

Reports the nature of the wall

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallType.WallType..::WallKind Kind{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Kind As WallType..::WallKind
Visual C++
public:
property WallType..::WallKind Kind {
    WallType..::WallKind get ();
}

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

WallType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

WallType Class
WallType Members
Autodesk.Revit.Symbols Namespace


Width Property

WallType..::Width Property
CollapseAll image DropDown image

Returns the overall thickness of this type of wall.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Width{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


WallType..::WallKind Enumeration
CollapseAll image DropDown image

Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E9A68360-146E-48df-A6BE-5C0DB6ED688E")]
public enum WallKind
Visual Basic (Declaration)
<GuidAttribute("E9A68360-146E-48df-A6BE-5C0DB6ED688E")> _
Public Enumeration WallKind
Visual C++
[GuidAttribute(L"E9A68360-146E-48df-A6BE-5C0DB6ED688E")]
public enum class WallKind

Members

Member name | Description
Stacked | A stacked wall of several wall types.
Curtain | A curtain wall.
Basic | A standard wall.
Unknown | The basic type is not known.

See Also

Autodesk.Revit.Symbols Namespace


WallTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains wall types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3F57AAAC-E4E8-465d-B7E8-EC4CD8A18A8E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WallTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("3F57AAAC-E4E8-465d-B7E8-EC4CD8A18A8E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WallTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"3F57AAAC-E4E8-465d-B7E8-EC4CD8A18A8E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WallTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::WallTypeSet

See Also

WallTypeSet Members
Autodesk.Revit.Symbols Namespace


WallTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WallTypeSet
Visual Basic (Declaration)
Public Class WallTypeSet
Visual C++
public ref class WallTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WallTypeSetWallTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every wall type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wall type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wall type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wall type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet
Autodesk.Revit.Symbols Namespace


WallTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallTypeSet ()

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


WallTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class WallTypeSet
Visual Basic (Declaration)
Public Class WallTypeSet
Visual C++
public ref class WallTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every wall type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wall type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wall type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wall type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WallTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

WallTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every wall type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

WallTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a wall type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    WallType^ item
)

Parameters

item
WallType
The wall type to be searched for.

Return Value

The Contains method returns True if the wall type is within the set, otherwise False.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

WallTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

WallTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified wall type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WallType _
) As Integer
Visual C++
public:
virtual int Erase (
    WallType^ item
)

Parameters

item
WallType
The wall type to be erased.

Return Value

The number of wall types that were erased from the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

WallTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WallTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

WallTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

WallTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified wall type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    WallType^ item
)

Parameters

item
WallType
The wall type to be inserted into the set.

Return Value

Returns whether the wall type was inserted into the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

WallTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

WallTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WallTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


WallTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class WallTypeSet
Visual Basic (Declaration)
Public Class WallTypeSet
Visual C++
public ref class WallTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

WallTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

WallTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of wall types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a wall type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C1834E19-AA9A-48cb-82FC-0B1FC8D5B614")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class WallTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("C1834E19-AA9A-48cb-82FC-0B1FC8D5B614")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class WallTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"C1834E19-AA9A-48cb-82FC-0B1FC8D5B614")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WallTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::WallTypeSetIterator

See Also

WallTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class WallTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WallTypeSetIterator
Visual C++
public ref class WallTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WallTypeSetIteratorWallTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class WallTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WallTypeSetIterator
Visual C++
public ref class WallTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WallTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

WallTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

WallTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

WallTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

WallTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class WallTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WallTypeSetIterator
Visual C++
public ref class WallTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

WallTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WireType Class
See Also Members
CollapseAll image DropDown image

Represents a specific wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3313674E-6902-4b49-9E7C-8BD1549D9FE5")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WireType : Symbol
Visual Basic (Declaration)
<GuidAttribute("3313674E-6902-4b49-9E7C-8BD1549D9FE5")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WireType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"3313674E-6902-4b49-9E7C-8BD1549D9FE5")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WireType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::WireType

See Also

WireType Members
Autodesk.Revit.Symbols Namespace


WireType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireType
Visual Basic (Declaration)
Public Class WireType
Visual C++
public ref class WireType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireTypeWireTypeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Conduit | Get of set conduit type of wire type.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Insulation | Get of set insulation type.
Public property | IsInUse | Indicate whether the wire type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaxSize | Get of set max size of wire type.
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | NeutralMultiplier | Get of set neutral multiplier type of wire type.
Public property | NeutralRequired | Get of set whether the neutral point is required.
Public property | NeutralSize | Get of set maximum neutral size of wire type.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TemperatureRating | Get of set temperature rating type of wire type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WireMaterial | Get of set material type of wire type.

See Also

WireType
Autodesk.Revit.Symbols Namespace


WireType Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireType ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


WireType Properties
CollapseAll image DropDown image

Syntax

C#
public class WireType
Visual Basic (Declaration)
Public Class WireType
Visual C++
public ref class WireType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Conduit | Get of set conduit type of wire type.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Insulation | Get of set insulation type.
Public property | IsInUse | Indicate whether the wire type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaxSize | Get of set max size of wire type.
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | NeutralMultiplier | Get of set neutral multiplier type of wire type.
Public property | NeutralRequired | Get of set whether the neutral point is required.
Public property | NeutralSize | Get of set maximum neutral size of wire type.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TemperatureRating | Get of set temperature rating type of wire type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WireMaterial | Get of set material type of wire type.

See Also

WireType
Autodesk.Revit.Symbols Namespace


Conduit Property

WireType..::Conduit Property
CollapseAll image DropDown image

Get of set conduit type of wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ConduitType Conduit{ get; set;}
Visual Basic (Declaration)
Public Property Conduit As ConduitType
Visual C++
public:
property ConduitType^ Conduit {
    ConduitType^ get ();
    void set (ConduitType^ value);
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


Insulation Property

WireType..::Insulation Property
CollapseAll image DropDown image

Get of set insulation type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InsulationType Insulation{ get; set;}
Visual Basic (Declaration)
Public Property Insulation As InsulationType
Visual C++
public:
property InsulationType^ Insulation {
    InsulationType^ get ();
    void set (InsulationType^ value);
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


IsInUse Property

WireType..::IsInUse Property
CollapseAll image DropDown image

Indicate whether the wire type is in use.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInUse{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


MaxSize Property

WireType..::MaxSize Property
CollapseAll image DropDown image

Get of set max size of wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSize MaxSize{ get; set;}
Visual Basic (Declaration)
Public Property MaxSize As WireSize
Visual C++
public:
property WireSize^ MaxSize {
    WireSize^ get ();
    void set (WireSize^ value);
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


NeutralMultiplier Property

WireType..::NeutralMultiplier Property
CollapseAll image DropDown image

Get of set neutral multiplier type of wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double NeutralMultiplier{ get; set;}
Visual Basic (Declaration)
Public Property NeutralMultiplier As Double
Visual C++
public:
property double NeutralMultiplier {
    double get ();
    void set (double value);
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


NeutralRequired Property

WireType..::NeutralRequired Property
CollapseAll image DropDown image

Get of set whether the neutral point is required.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool NeutralRequired{ get; set;}
Visual Basic (Declaration)
Public Property NeutralRequired As Boolean
Visual C++
public:
property bool NeutralRequired {
    bool get ();
    void set (bool value);
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


NeutralSize Property

WireType..::NeutralSize Property
CollapseAll image DropDown image

Get of set maximum neutral size of wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireType.WireType..::NeutralMode NeutralSize{ get; set;}
Visual Basic (Declaration)
Public Property NeutralSize As WireType..::NeutralMode
Visual C++
public:
property WireType..::NeutralMode NeutralSize {
    WireType..::NeutralMode get ();
    void set (WireType..::NeutralMode value);
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

WireType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

WireType Class
WireType Members
Autodesk.Revit.Symbols Namespace


TemperatureRating Property

WireType..::TemperatureRating Property
CollapseAll image DropDown image

Get of set temperature rating type of wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TemperatureRatingType TemperatureRating{ get; set;}
Visual Basic (Declaration)
Public Property TemperatureRating As TemperatureRatingType
Visual C++
public:
property TemperatureRatingType^ TemperatureRating {
    TemperatureRatingType^ get ();
    void set (TemperatureRatingType^ value);
}

Remarks

Should retrieved from rellevant WireMaterial object.

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


WireMaterial Property

WireType..::WireMaterial Property
CollapseAll image DropDown image

Get of set material type of wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireMaterialType WireMaterial{ get; set;}
Visual Basic (Declaration)
Public Property WireMaterial As WireMaterialType
Visual C++
public:
property WireMaterialType^ WireMaterial {
    WireMaterialType^ get ();
    void set (WireMaterialType^ value);
}

See Also

WireType Class
Autodesk.Revit.Symbols Namespace


WireType..::NeutralMode Enumeration
CollapseAll image DropDown image

An enumerate type to list the neutral mode for wire type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C22E887D-52E8-46f2-A301-1DB16C28A762")]
public enum NeutralMode
Visual Basic (Declaration)
<GuidAttribute("C22E887D-52E8-46f2-A301-1DB16C28A762")> _
Public Enumeration NeutralMode
Visual C++
[GuidAttribute(L"C22E887D-52E8-46f2-A301-1DB16C28A762")]
public enum class NeutralMode

Members

Member name | Description
UnbalancedCurrent | Neutral Mode is UnbalancedCurrent.
HotConductorSize | Neutral Mode is HotConductorSize.

See Also

Autodesk.Revit.Symbols Namespace


WireTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains wire types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DFED0793-F048-4aeb-B075-9944E181FEA5")]
public class WireTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DFED0793-F048-4aeb-B075-9944E181FEA5")> _
Public Class WireTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DFED0793-F048-4aeb-B075-9944E181FEA5")]
public ref class WireTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::WireTypeSet

See Also

WireTypeSet Members
Autodesk.Revit.Symbols Namespace


WireTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireTypeSet
Visual Basic (Declaration)
Public Class WireTypeSet
Visual C++
public ref class WireTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireTypeSetWireTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every wire type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire types that are in the set.

See Also

WireTypeSet
Autodesk.Revit.Symbols Namespace


WireTypeSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireTypeSet ()

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


WireTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class WireTypeSet
Visual Basic (Declaration)
Public Class WireTypeSet
Visual C++
public ref class WireTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every wire type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire type within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireTypeSet
Autodesk.Revit.Symbols Namespace


Clear Method

WireTypeSet..::Clear Method
CollapseAll image DropDown image

Removes every wire type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

WireTypeSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a wire type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Contains (
    WireType^ item
)

Parameters

item
WireType
The wire type to be searched for.

Return Value

The Contains method returns True if the wire type is within the set, otherwise False.

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


Dispose Method

WireTypeSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

WireTypeSet..::Erase Method
CollapseAll image DropDown image

Removes a specified wire type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireType _
) As Integer
Visual C++
public:
virtual int Erase (
    WireType^ item
)

Parameters

item
WireType
The wire type to be erased.

Return Value

The number of wire types that were erased from the set.

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

WireTypeSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

WireTypeSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

WireTypeSet..::Insert Method
CollapseAll image DropDown image

Insert the specified wire type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Insert (
    WireType^ item
)

Parameters

item
WireType
The wire type to be inserted into the set.

Return Value

Returns whether the wire type was inserted into the set.

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

WireTypeSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

WireTypeSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual WireTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


WireTypeSet Properties
CollapseAll image DropDown image

Syntax

C#
public class WireTypeSet
Visual Basic (Declaration)
Public Class WireTypeSet
Visual C++
public ref class WireTypeSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire types that are in the set.

See Also

WireTypeSet
Autodesk.Revit.Symbols Namespace


IsEmpty Property

WireTypeSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

WireTypeSet..::Size Property
CollapseAll image DropDown image

Returns the number of wire types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireTypeSet Class
Autodesk.Revit.Symbols Namespace


WireTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a wire type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5212C1A9-0F67-47ca-8D5E-48D8A4604C31")]
public abstract class WireTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5212C1A9-0F67-47ca-8D5E-48D8A4604C31")> _
Public MustInherit Class WireTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5212C1A9-0F67-47ca-8D5E-48D8A4604C31")]
public ref class WireTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::WireTypeSetIterator

See Also

WireTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


WireTypeSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class WireTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireTypeSetIterator
Visual C++
public ref class WireTypeSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireTypeSetIteratorWireTypeSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator
Autodesk.Revit.Symbols Namespace


WireTypeSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireTypeSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WireTypeSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class WireTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireTypeSetIterator
Visual C++
public ref class WireTypeSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

WireTypeSetIterator
Autodesk.Revit.Symbols Namespace


Dispose Method

WireTypeSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

WireTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

WireTypeSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ReleaseUnmanagedResources Method

WireTypeSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

WireTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

WireTypeSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WireTypeSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class WireTypeSetIterator
Visual Basic (Declaration)
Public MustInherit Class WireTypeSetIterator
Visual C++
public ref class WireTypeSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator
Autodesk.Revit.Symbols Namespace


Current Property

WireTypeSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Autodesk.Revit.Utility Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Utility
Visual Basic (Declaration)
Namespace Autodesk.Revit.Utility
Visual C++
namespace Autodesk.Revit.Utility

Classes

 | Class | Description
Public class | Asset |
Public class | AssetProperties |
Public class | AssetProperty |
Public class | AssetPropertyBoolean |
Public class | AssetPropertyDistance |
Public class | AssetPropertyDouble |
Public class | AssetPropertyDoubleArray2d |
Public class | AssetPropertyDoubleArray3d |
Public class | AssetPropertyDoubleArray4d |
Public class | AssetPropertyDoubleMatrix44 |
Public class | AssetPropertyEnum |
Public class | AssetPropertyFloat |
Public class | AssetPropertyInteger |
Public class | AssetPropertyReference |
Public class | AssetPropertyString |
Public class | AssetPropertyTime |
Public class | AssetSet | A set that contains assets.
Public class | AssetSetIterator | An iterator to a asset set.


Asset Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("889EC11D-15AD-4497-84B8-63099095A1A9")]
public class Asset : AssetProperties
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("889EC11D-15AD-4497-84B8-63099095A1A9")> _
Public Class Asset _
    Inherits AssetProperties
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"889EC11D-15AD-4497-84B8-63099095A1A9")]
public ref class Asset : public AssetProperties

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetProperties
Autodesk.Revit.Utility..::Asset

See Also

Asset Members
Autodesk.Revit.Utility Namespace


Asset Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Asset
Visual Basic (Declaration)
Public Class Asset
Visual C++
public ref class Asset

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetAssetNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | AssetType | Get the object's AssetPropertyType
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | LibraryName | Get the library name
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Size | Get the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Public property | Title | Get the asset's title
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset
Autodesk.Revit.Utility Namespace


Asset Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Asset()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Asset ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Properties
CollapseAll image DropDown image

Syntax

C#
public class Asset
Visual Basic (Declaration)
Public Class Asset
Visual C++
public ref class Asset

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AssetType | Get the object's AssetPropertyType
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | LibraryName | Get the library name
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Size | Get the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Public property | Title | Get the asset's title
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset
Autodesk.Revit.Utility Namespace


AssetType Property

Asset..::AssetType Property
CollapseAll image DropDown image

Get the object's AssetPropertyType

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetType AssetType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property AssetType As AssetType
Visual C++
public:
property AssetType AssetType {
    AssetType get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Item Property

Asset..::Item Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Item[([Int32])] | (Inherited from AssetProperties.)
Public property | Item[([String])] | Get the one property that the current object contains with the given name (Inherited from AssetProperties.)

See Also

Asset Class
Asset Members
Autodesk.Revit.Utility Namespace


LibraryName Property

Asset..::LibraryName Property
CollapseAll image DropDown image

Get the library name

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string LibraryName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property LibraryName As String
Visual C++
public:
property String^ LibraryName {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Title Property

Asset..::Title Property
CollapseAll image DropDown image

Get the asset's title

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Title{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


AssetProperties Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("931BDAEB-E7DA-4429-9362-0AFE679DC9B4")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetProperties : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("931BDAEB-E7DA-4429-9362-0AFE679DC9B4")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetProperties _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"931BDAEB-E7DA-4429-9362-0AFE679DC9B4")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetProperties : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetProperties
Autodesk.Revit.Utility..::Asset

See Also

AssetProperties Members
Autodesk.Revit.Utility Namespace


AssetProperties Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetProperties
Visual Basic (Declaration)
Public Class AssetProperties
Visual C++
public ref class AssetProperties

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertiesAssetPropertiesNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Size | Get the number of the AssetProperty(s) in the object.
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetProperties
Autodesk.Revit.Utility Namespace


AssetProperties Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetProperties()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetProperties ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetProperties
Visual Basic (Declaration)
Public Class AssetProperties
Visual C++
public ref class AssetProperties

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Size | Get the number of the AssetProperty(s) in the object.
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetProperties
Autodesk.Revit.Utility Namespace


Item Property

AssetProperties..::Item Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Item[([Int32])] |
Public property | Item[([String])] | Get the one property that the current object contains with the given name

See Also

AssetProperties Class
AssetProperties Members
Autodesk.Revit.Utility Namespace


Item Property (Int32)

AssetProperties..::Item Property (Int32)
See Also
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetProperty this[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As AssetProperty
Visual C++
public:
property AssetProperty^ default[int index] {
    AssetProperty^ get (int index);
}

Parameters

index
Int32

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


Item Property (String)

AssetProperties..::Item Property (String)
See Also
CollapseAll image DropDown image

Get the one property that the current object contains with the given name

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetProperty this[
    string name
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As AssetProperty
Visual C++
public:
property AssetProperty^ default[String^ name] {
    AssetProperty^ get (String^ name);
}

Parameters

name
String

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


Size Property

AssetProperties..::Size Property
CollapseAll image DropDown image

Get the number of the AssetProperty(s) in the object.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Size{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
Visual C++
public:
property int Size {
    int get ();
}

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperty Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D72C74E8-D2C8-4e42-876A-707DED2A5067")]
public class AssetProperty : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D72C74E8-D2C8-4e42-876A-707DED2A5067")> _
Public Class AssetProperty _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D72C74E8-D2C8-4e42-876A-707DED2A5067")]
public ref class AssetProperty : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetProperties
Autodesk.Revit.Utility..::AssetPropertyBoolean
Autodesk.Revit.Utility..::AssetPropertyDistance
Autodesk.Revit.Utility..::AssetPropertyDouble
Autodesk.Revit.Utility..::AssetPropertyDoubleArray2d
Autodesk.Revit.Utility..::AssetPropertyDoubleArray3d
Autodesk.Revit.Utility..::AssetPropertyDoubleArray4d
Autodesk.Revit.Utility..::AssetPropertyDoubleMatrix44
Autodesk.Revit.Utility..::AssetPropertyEnum
Autodesk.Revit.Utility..::AssetPropertyFloat
Autodesk.Revit.Utility..::AssetPropertyInteger
Autodesk.Revit.Utility..::AssetPropertyReference
Autodesk.Revit.Utility..::AssetPropertyString
Autodesk.Revit.Utility..::AssetPropertyTime

See Also

AssetProperty Members
Autodesk.Revit.Utility Namespace


AssetProperty Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetProperty
Visual Basic (Declaration)
Public Class AssetProperty
Visual C++
public ref class AssetProperty

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyAssetPropertyNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeName | Get the name of the AssetProperty
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty
Public property | Type | Returns the Type of the AssetProperty

See Also

AssetProperty
Autodesk.Revit.Utility Namespace


AssetProperty Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetProperty()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetProperty ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Methods
CollapseAll image DropDown image

Syntax

C#
public class AssetProperty
Visual Basic (Declaration)
Public Class AssetProperty
Visual C++
public ref class AssetProperty

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeName | Get the name of the AssetProperty
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AssetProperty
Autodesk.Revit.Utility Namespace


GetTypeName Method

AssetProperty..::GetTypeName Method
CollapseAll image DropDown image

Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static string GetTypeName(
    AssetPropertyType type
)
Visual Basic (Declaration)
Public Shared Function GetTypeName ( _
    type As AssetPropertyType _
) As String
Visual C++
public:
static String^ GetTypeName (
    AssetPropertyType type
)

Parameters

type
AssetPropertyType

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


ReleaseUnmanagedResources Method

AssetProperty..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetProperty
Visual Basic (Declaration)
Public Class AssetProperty
Visual C++
public ref class AssetProperty

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty
Public property | Type | Returns the Type of the AssetProperty

See Also

AssetProperty
Autodesk.Revit.Utility Namespace


Name Property

AssetProperty..::Name Property
CollapseAll image DropDown image

Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Name{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


Type Property

AssetProperty..::Type Property
CollapseAll image DropDown image

Returns the Type of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AssetPropertyType Type{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Type As AssetPropertyType
Visual C++
public:
virtual property AssetPropertyType Type {
    AssetPropertyType get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("463B92FE-61CD-4827-BB0A-B4402C0E651C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyBoolean : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("463B92FE-61CD-4827-BB0A-B4402C0E651C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyBoolean _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"463B92FE-61CD-4827-BB0A-B4402C0E651C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyBoolean : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyBoolean

See Also

AssetPropertyBoolean Members
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyBoolean
Visual Basic (Declaration)
Public Class AssetPropertyBoolean
Visual C++
public ref class AssetPropertyBoolean

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyBooleanAssetPropertyBooleanNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyBoolean
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyBoolean()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyBoolean ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyBoolean
Visual Basic (Declaration)
Public Class AssetPropertyBoolean
Visual C++
public ref class AssetPropertyBoolean

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyBoolean
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyBoolean..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As Boolean
Visual C++
public:
property bool Value {
    bool get ();
}

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("12A49091-C0A9-4594-8E84-4BC9B2012261")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyDistance : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("12A49091-C0A9-4594-8E84-4BC9B2012261")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyDistance _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"12A49091-C0A9-4594-8E84-4BC9B2012261")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyDistance : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyDistance

See Also

AssetPropertyDistance Members
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDistance
Visual Basic (Declaration)
Public Class AssetPropertyDistance
Visual C++
public ref class AssetPropertyDistance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyDistanceAssetPropertyDistanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | DisplayUnitType |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDistance
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyDistance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDistance ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDistance
Visual Basic (Declaration)
Public Class AssetPropertyDistance
Visual C++
public ref class AssetPropertyDistance

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | DisplayUnitType |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDistance
Autodesk.Revit.Utility Namespace


DisplayUnitType Property

AssetPropertyDistance..::DisplayUnitType Property
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DisplayUnitType DisplayUnitType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyDistance..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5A0E76EC-7611-47cc-94DF-D8725FA88362")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyDouble : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("5A0E76EC-7611-47cc-94DF-D8725FA88362")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyDouble _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"5A0E76EC-7611-47cc-94DF-D8725FA88362")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyDouble : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyDouble

See Also

AssetPropertyDouble Members
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDouble
Visual Basic (Declaration)
Public Class AssetPropertyDouble
Visual C++
public ref class AssetPropertyDouble

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyDoubleAssetPropertyDoubleNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDouble
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyDouble()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDouble ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDouble
Visual Basic (Declaration)
Public Class AssetPropertyDouble
Visual C++
public ref class AssetPropertyDouble

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDouble
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyDouble..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1C535257-7114-40a8-9160-251FCDCF0A9B")]
public class AssetPropertyDoubleArray2d : AssetProperty
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1C535257-7114-40a8-9160-251FCDCF0A9B")> _
Public Class AssetPropertyDoubleArray2d _
    Inherits AssetProperty
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1C535257-7114-40a8-9160-251FCDCF0A9B")]
public ref class AssetPropertyDoubleArray2d : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyDoubleArray2d

See Also

AssetPropertyDoubleArray2d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleArray2d
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray2d
Visual C++
public ref class AssetPropertyDoubleArray2d

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyDoubleArray2dAssetPropertyDoubleArray2dNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyDoubleArray2d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleArray2d ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleArray2d
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray2d
Visual C++
public ref class AssetPropertyDoubleArray2d

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyDoubleArray2d..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E6FC0A99-1FAA-4419-9392-D942144BCF9C")]
public class AssetPropertyDoubleArray3d : AssetProperty
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E6FC0A99-1FAA-4419-9392-D942144BCF9C")> _
Public Class AssetPropertyDoubleArray3d _
    Inherits AssetProperty
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E6FC0A99-1FAA-4419-9392-D942144BCF9C")]
public ref class AssetPropertyDoubleArray3d : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyDoubleArray3d

See Also

AssetPropertyDoubleArray3d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleArray3d
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray3d
Visual C++
public ref class AssetPropertyDoubleArray3d

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyDoubleArray3dAssetPropertyDoubleArray3dNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyDoubleArray3d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleArray3d ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleArray3d
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray3d
Visual C++
public ref class AssetPropertyDoubleArray3d

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyDoubleArray3d..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("53E02843-DB5A-465f-B6A7-1E2E808D3539")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyDoubleArray4d : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("53E02843-DB5A-465f-B6A7-1E2E808D3539")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyDoubleArray4d _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"53E02843-DB5A-465f-B6A7-1E2E808D3539")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyDoubleArray4d : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyDoubleArray4d

See Also

AssetPropertyDoubleArray4d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleArray4d
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray4d
Visual C++
public ref class AssetPropertyDoubleArray4d

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyDoubleArray4dAssetPropertyDoubleArray4dNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyDoubleArray4d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleArray4d ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleArray4d
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray4d
Visual C++
public ref class AssetPropertyDoubleArray4d

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyDoubleArray4d..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("87316DF1-18C1-4ab3-A2DA-66ED055FEFF0")]
public class AssetPropertyDoubleMatrix44 : AssetProperty
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("87316DF1-18C1-4ab3-A2DA-66ED055FEFF0")> _
Public Class AssetPropertyDoubleMatrix44 _
    Inherits AssetProperty
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"87316DF1-18C1-4ab3-A2DA-66ED055FEFF0")]
public ref class AssetPropertyDoubleMatrix44 : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyDoubleMatrix44

See Also

AssetPropertyDoubleMatrix44 Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleMatrix44
Visual Basic (Declaration)
Public Class AssetPropertyDoubleMatrix44
Visual C++
public ref class AssetPropertyDoubleMatrix44

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyDoubleMatrix44AssetPropertyDoubleMatrix44New | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyDoubleMatrix44()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleMatrix44 ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyDoubleMatrix44
Visual Basic (Declaration)
Public Class AssetPropertyDoubleMatrix44
Visual C++
public ref class AssetPropertyDoubleMatrix44

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyDoubleMatrix44..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DoubleArray Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6516F7A0-3B10-426b-8803-A378E6C1480B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyEnum : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("6516F7A0-3B10-426b-8803-A378E6C1480B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyEnum _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"6516F7A0-3B10-426b-8803-A378E6C1480B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyEnum : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyEnum

See Also

AssetPropertyEnum Members
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyEnum
Visual Basic (Declaration)
Public Class AssetPropertyEnum
Visual C++
public ref class AssetPropertyEnum

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyEnumAssetPropertyEnumNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyEnum
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyEnum()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyEnum ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyEnum
Visual Basic (Declaration)
Public Class AssetPropertyEnum
Visual C++
public ref class AssetPropertyEnum

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyEnum
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyEnum..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4841DF0A-393A-4b79-B095-1FB1097C2D2B")]
public class AssetPropertyFloat : AssetProperty
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4841DF0A-393A-4b79-B095-1FB1097C2D2B")> _
Public Class AssetPropertyFloat _
    Inherits AssetProperty
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4841DF0A-393A-4b79-B095-1FB1097C2D2B")]
public ref class AssetPropertyFloat : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyFloat

See Also

AssetPropertyFloat Members
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyFloat
Visual Basic (Declaration)
Public Class AssetPropertyFloat
Visual C++
public ref class AssetPropertyFloat

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyFloatAssetPropertyFloatNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyFloat
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyFloat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyFloat ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyFloat
Visual Basic (Declaration)
Public Class AssetPropertyFloat
Visual C++
public ref class AssetPropertyFloat

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyFloat
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyFloat..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public float Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As Single
Visual C++
public:
property float Value {
    float get ();
}

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2E87D3B0-14F3-4bd7-9BBC-FB2E4C5210C1")]
public class AssetPropertyInteger : AssetProperty
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2E87D3B0-14F3-4bd7-9BBC-FB2E4C5210C1")> _
Public Class AssetPropertyInteger _
    Inherits AssetProperty
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2E87D3B0-14F3-4bd7-9BBC-FB2E4C5210C1")]
public ref class AssetPropertyInteger : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyInteger

See Also

AssetPropertyInteger Members
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyInteger
Visual Basic (Declaration)
Public Class AssetPropertyInteger
Visual C++
public ref class AssetPropertyInteger

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyIntegerAssetPropertyIntegerNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyInteger
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyInteger()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyInteger ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyInteger
Visual Basic (Declaration)
Public Class AssetPropertyInteger
Visual C++
public ref class AssetPropertyInteger

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyInteger
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyInteger..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3B558AF6-CE67-4e12-8515-E464477DE6DD")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyReference : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("3B558AF6-CE67-4e12-8515-E464477DE6DD")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyReference _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"3B558AF6-CE67-4e12-8515-E464477DE6DD")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyReference : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyReference

See Also

AssetPropertyReference Members
Autodesk.Revit.Utility Namespace


AssetPropertyReference Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyReference
Visual Basic (Declaration)
Public Class AssetPropertyReference
Visual C++
public ref class AssetPropertyReference

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyReferenceAssetPropertyReferenceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetPropertyReference
Autodesk.Revit.Utility Namespace


AssetPropertyReference Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyReference()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyReference ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("66921EEC-ADB4-4d8d-AAE5-BEFB5D9B84F4")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyString : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("66921EEC-ADB4-4d8d-AAE5-BEFB5D9B84F4")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyString _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"66921EEC-ADB4-4d8d-AAE5-BEFB5D9B84F4")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyString : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyString

See Also

AssetPropertyString Members
Autodesk.Revit.Utility Namespace


AssetPropertyString Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyString
Visual Basic (Declaration)
Public Class AssetPropertyString
Visual C++
public ref class AssetPropertyString

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyStringAssetPropertyStringNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyString
Autodesk.Revit.Utility Namespace


AssetPropertyString Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyString()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyString ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyString
Visual Basic (Declaration)
Public Class AssetPropertyString
Visual C++
public ref class AssetPropertyString

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyString
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyString..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DA98334A-F785-45f4-8A91-81071405A993")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AssetPropertyTime : AssetProperty
Visual Basic (Declaration)
<GuidAttribute("DA98334A-F785-45f4-8A91-81071405A993")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AssetPropertyTime _
    Inherits AssetProperty
Visual C++
[GuidAttribute(L"DA98334A-F785-45f4-8A91-81071405A993")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetPropertyTime : public AssetProperty

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetPropertyTime

See Also

AssetPropertyTime Members
Autodesk.Revit.Utility Namespace


AssetPropertyTime Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyTime
Visual Basic (Declaration)
Public Class AssetPropertyTime
Visual C++
public ref class AssetPropertyTime

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetPropertyTimeAssetPropertyTimeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from AssetProperty.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyTime
Autodesk.Revit.Utility Namespace


AssetPropertyTime Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetPropertyTime()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyTime ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetPropertyTime
Visual Basic (Declaration)
Public Class AssetPropertyTime
Visual C++
public ref class AssetPropertyTime

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyTime
Autodesk.Revit.Utility Namespace


Value Property

AssetPropertyTime..::Value Property
CollapseAll image DropDown image

Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DateTime Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As DateTime
Visual C++
public:
property DateTime Value {
    DateTime get ();
}

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetSet Class
See Also Members
CollapseAll image DropDown image

A set that contains assets.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DBDB4098-5E3E-4aa1-A8B2-D96AF1F24A5F")]
public class AssetSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DBDB4098-5E3E-4aa1-A8B2-D96AF1F24A5F")> _
Public Class AssetSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DBDB4098-5E3E-4aa1-A8B2-D96AF1F24A5F")]
public ref class AssetSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetSet

See Also

AssetSet Members
Autodesk.Revit.Utility Namespace


AssetSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AssetSet
Visual Basic (Declaration)
Public Class AssetSet
Visual C++
public ref class AssetSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetSetAssetSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every asset from the set, rendering it empty.
Public method | Contains | Tests for the existence of a asset within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified asset from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified asset into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of assets that are in the set.

See Also

AssetSet
Autodesk.Revit.Utility Namespace


AssetSet Constructor
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetSet ()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Methods
CollapseAll image DropDown image

Syntax

C#
public class AssetSet
Visual Basic (Declaration)
Public Class AssetSet
Visual C++
public ref class AssetSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every asset from the set, rendering it empty.
Public method | Contains | Tests for the existence of a asset within the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified asset from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified asset into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AssetSet
Autodesk.Revit.Utility Namespace


Clear Method

AssetSet..::Clear Method
CollapseAll image DropDown image

Removes every asset from the set, rendering it empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear ()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Contains Method

AssetSet..::Contains Method
CollapseAll image DropDown image

Tests for the existence of a asset within the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Contains(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Contains (
    Asset^ item
)

Parameters

item
Asset
The asset to be searched for.

Return Value

The Contains method returns True if the asset is within the set, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Dispose Method

AssetSet..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Erase Method

AssetSet..::Erase Method
CollapseAll image DropDown image

Removes a specified asset from the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Asset _
) As Integer
Visual C++
public:
virtual int Erase (
    Asset^ item
)

Parameters

item
Asset
The asset to be erased.

Return Value

The number of assets that were erased from the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ForwardIterator Method

AssetSet..::ForwardIterator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AssetSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ForwardIterator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


GetEnumerator Method

AssetSet..::GetEnumerator Method
CollapseAll image DropDown image

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator ()

Return Value

Returns a forward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Insert Method

AssetSet..::Insert Method
CollapseAll image DropDown image

Insert the specified asset into the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Asset^ item
)

Parameters

item
Asset
The asset to be inserted into the set.

Return Value

Returns whether the asset was inserted into the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ReleaseUnmanagedResources Method

AssetSet..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ReverseIterator Method

AssetSet..::ReverseIterator Method
CollapseAll image DropDown image

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual AssetSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ReverseIterator ()

Return Value

Returns a backward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Properties
CollapseAll image DropDown image

Syntax

C#
public class AssetSet
Visual Basic (Declaration)
Public Class AssetSet
Visual C++
public ref class AssetSet

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of assets that are in the set.

See Also

AssetSet
Autodesk.Revit.Utility Namespace


IsEmpty Property

AssetSet..::IsEmpty Property
CollapseAll image DropDown image

Test to see if the set is empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsEmpty{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Size Property

AssetSet..::Size Property
CollapseAll image DropDown image

Returns the number of assets that are in the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Size{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a asset set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A491F06D-8DC9-4579-AB14-0AA23334F317")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class AssetSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("A491F06D-8DC9-4579-AB14-0AA23334F317")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class AssetSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"A491F06D-8DC9-4579-AB14-0AA23334F317")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AssetSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetSetIterator

See Also

AssetSetIterator Members
Autodesk.Revit.Utility Namespace


AssetSetIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class AssetSetIterator
Visual Basic (Declaration)
Public MustInherit Class AssetSetIterator
Visual C++
public ref class AssetSetIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AssetSetIteratorAssetSetIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator
Autodesk.Revit.Utility Namespace


AssetSetIterator Constructor
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AssetSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetSetIterator ()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Methods
CollapseAll image DropDown image

Syntax

C#
public abstract class AssetSetIterator
Visual Basic (Declaration)
Public MustInherit Class AssetSetIterator
Visual C++
public ref class AssetSetIterator abstract

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

AssetSetIterator
Autodesk.Revit.Utility Namespace


Dispose Method

AssetSetIterator..::Dispose Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose (
    bool
) override

Parameters

Boolean

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


MoveNext Method

AssetSetIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


ReleaseUnmanagedResources Method

AssetSetIterator..::ReleaseUnmanagedResources Method
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
protected override void ReleaseUnmanagedResources()
Visual Basic (Declaration)
Protected Overrides Sub ReleaseUnmanagedResources
Visual C++
protected:
virtual void ReleaseUnmanagedResources () override

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Reset Method

AssetSetIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Properties
CollapseAll image DropDown image

Syntax

C#
public abstract class AssetSetIterator
Visual Basic (Declaration)
Public MustInherit Class AssetSetIterator
Visual C++
public ref class AssetSetIterator abstract

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator
Autodesk.Revit.Utility Namespace


Current Property

AssetSetIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Parameter Property

CeilingAndFloor..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

CeilingAndFloor Class
CeilingAndFloor Members
Autodesk.Revit.Elements Namespace


Parameter Property

CurtainSystemBase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

CurtainSystemBase Class
CurtainSystemBase Members
Autodesk.Revit.Elements Namespace


Parameter Property

DesignOption..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DesignOption Class
DesignOption Members
Autodesk.Revit.Elements Namespace


Parameter Property

DetailArc..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DetailArc Class
DetailArc Members
Autodesk.Revit.Elements Namespace


Parameter Property

DetailEllipse..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DetailEllipse Class
DetailEllipse Members
Autodesk.Revit.Elements Namespace


Parameter Property

DetailLine..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DetailLine Class
DetailLine Members
Autodesk.Revit.Elements Namespace


Parameter Property

DetailNurbSpline..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DetailNurbSpline Class
DetailNurbSpline Members
Autodesk.Revit.Elements Namespace


Parameter Property

FillPattern..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

FillPattern Class
FillPattern Members
Autodesk.Revit.Elements Namespace


Parameter Property

HostObject..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

HostObject Class
HostObject Members
Autodesk.Revit.Elements Namespace


Parameter Property

InsertableInstance..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

InsertableInstance Class
InsertableInstance Members
Autodesk.Revit.Elements Namespace


Parameter Property

Instance..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Instance Class
Instance Members
Autodesk.Revit.Elements Namespace


Parameter Property

LinePattern..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LinePattern Class
LinePattern Members
Autodesk.Revit.Elements Namespace


Parameter Property

LoadCase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LoadCase Class
LoadCase Members
Autodesk.Revit.Elements Namespace


Parameter Property

LoadNature..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LoadNature Class
LoadNature Members
Autodesk.Revit.Elements Namespace


Parameter Property

LoadUsage..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LoadUsage Class
LoadUsage Members
Autodesk.Revit.Elements Namespace


Parameter Property

MaterialOther..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

MaterialOther Class
MaterialOther Members
Autodesk.Revit.Elements Namespace


Parameter Property

ModelArc..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ModelArc Class
ModelArc Members
Autodesk.Revit.Elements Namespace


Parameter Property

ModelEllipse..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ModelEllipse Class
ModelEllipse Members
Autodesk.Revit.Elements Namespace


Parameter Property

ModelHermiteSpline..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ModelHermiteSpline Class
ModelHermiteSpline Members
Autodesk.Revit.Elements Namespace


Parameter Property

ModelLine..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ModelLine Class
ModelLine Members
Autodesk.Revit.Elements Namespace


Parameter Property

ModelNurbSpline..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ModelNurbSpline Class
ModelNurbSpline Members
Autodesk.Revit.Elements Namespace


Parameter Property

Phase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

Phase Class
Phase Members
Autodesk.Revit.Elements Namespace


Parameter Property

SketchBase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SketchBase Class
SketchBase Members
Autodesk.Revit.Elements Namespace


Print Method

View3D..::Print Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Print(Boolean) | Print this view with default print setting and default view template. (Inherited from View.)
Public method | Print(View) | Print this view with default print setting and specialized view template. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with default print setting and specialized view template. (Inherited from View.)

See Also

View3D Class
View3D Members
Autodesk.Revit.Elements Namespace


Parameter Property

ViewDrafting..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ViewDrafting Class
ViewDrafting Members
Autodesk.Revit.Elements Namespace


Print Method

ViewDrafting..::Print Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Print(Boolean) | Print this view with default print setting and default view template. (Inherited from View.)
Public method | Print(View) | Print this view with default print setting and specialized view template. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with default print setting and specialized view template. (Inherited from View.)

See Also

ViewDrafting Class
ViewDrafting Members
Autodesk.Revit.Elements Namespace


Parameter Property

ViewPlan..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ViewPlan Class
ViewPlan Members
Autodesk.Revit.Elements Namespace


Print Method

ViewPlan..::Print Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Print(Boolean) | Print this view with default print setting and default view template. (Inherited from View.)
Public method | Print(View) | Print this view with default print setting and specialized view template. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with default print setting and specialized view template. (Inherited from View.)

See Also

ViewPlan Class
ViewPlan Members
Autodesk.Revit.Elements Namespace


Parameter Property

ViewSection..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ViewSection Class
ViewSection Members
Autodesk.Revit.Elements Namespace


Print Method

ViewSection..::Print Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Print(Boolean) | Print this view with default print setting and default view template. (Inherited from View.)
Public method | Print(View) | Print this view with default print setting and specialized view template. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with default print setting and specialized view template. (Inherited from View.)

See Also

ViewSection Class
ViewSection Members
Autodesk.Revit.Elements Namespace


Intersect Method

Arc..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Arc Class
Arc Members
Autodesk.Revit.Geometry Namespace


IsInside Method

Arc..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and returns end index. (Inherited from Curve.)

See Also

Arc Class
Arc Members
Autodesk.Revit.Geometry Namespace


Intersect Method

ConicalFace..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

ConicalFace..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and returns additional results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members
Autodesk.Revit.Geometry Namespace


Intersect Method

CylindricalFace..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

CylindricalFace..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and returns additional results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members
Autodesk.Revit.Geometry Namespace


Intersect Method

Ellipse..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members
Autodesk.Revit.Geometry Namespace


IsInside Method

Ellipse..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and returns end index. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members
Autodesk.Revit.Geometry Namespace


Intersect Method

HermiteFace..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

HermiteFace..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and returns additional results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members
Autodesk.Revit.Geometry Namespace


Intersect Method

Line..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Line Class
Line Members
Autodesk.Revit.Geometry Namespace


IsInside Method

Line..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and returns end index. (Inherited from Curve.)

See Also

Line Class
Line Members
Autodesk.Revit.Geometry Namespace


Intersect Method

PlanarFace..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

PlanarFace..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and returns additional results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members
Autodesk.Revit.Geometry Namespace


Intersect Method

RevolvedFace..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

RevolvedFace..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and returns additional results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members
Autodesk.Revit.Geometry Namespace


Intersect Method

RuledFace..::Intersect Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

RuledFace..::IsInside Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and returns additional results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members
Autodesk.Revit.Geometry Namespace


Multiply Method

Transform..::Multiply Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | Multiply(Transform) | Multiplies this transformation by the specified transformation and returns the result.
 | Multiply(Transform, Transform) | Multiplies the two specified transforms.

See Also

Transform Class
Transform Members
Autodesk.Revit.Geometry Namespace


Parameter Property

AnnotationSymbolType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AnnotationSymbolType Class
AnnotationSymbolType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

AreaLoadType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AreaLoadType Class
AreaLoadType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

AreaReinforcementType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AreaReinforcementType Class
AreaReinforcementType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

AreaTagType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

AreaTagType Class
AreaTagType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

BeamSystemType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

BeamSystemType Class
BeamSystemType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

ContFootingType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

ContFootingType Class
ContFootingType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

CurtainSystemType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

CurtainSystemType Class
CurtainSystemType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

DimensionType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

DimensionType Class
DimensionType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

FasciaType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

FasciaType Class
FasciaType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

GridType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

GridType Class
GridType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

GutterType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

GutterType Class
GutterType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

HostedSweepType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

HostedSweepType Class
HostedSweepType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

InsertableObject..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

InsertableObject Class
InsertableObject Members
Autodesk.Revit.Symbols Namespace


Parameter Property

LevelType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LevelType Class
LevelType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

LineAndTextAttrSymbol..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class
LineAndTextAttrSymbol Members
Autodesk.Revit.Symbols Namespace


Parameter Property

LineLoadType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LineLoadType Class
LineLoadType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

LoadTypeBase..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

LoadTypeBase Class
LoadTypeBase Members
Autodesk.Revit.Symbols Namespace


Parameter Property

MullionType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

MullionType Class
MullionType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

PanelType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

PanelType Class
PanelType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

PathReinforcementType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

PathReinforcementType Class
PathReinforcementType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

PointLoadType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

PointLoadType Class
PointLoadType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

RebarHookType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RebarHookType Class
RebarHookType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

RoofType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RoofType Class
RoofType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

RoomTagType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

RoomTagType Class
RoomTagType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

SlabEdgeType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SlabEdgeType Class
SlabEdgeType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

SpaceTagType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SpaceTagType Class
SpaceTagType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

SpotDimensionType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

SpotDimensionType Class
SpotDimensionType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

TextElementType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

TextElementType Class
TextElementType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

TextNoteType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

TextNoteType Class
TextNoteType Members
Autodesk.Revit.Symbols Namespace


Parameter Property

TrussType..::Parameter Property
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public property | Parameter[([Guid])] | Retrieves a parameter from an element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([String])] | Retrieve parameter object from parameter name. (Inherited from Element.)
Public property | Parameter[([BuiltInParameter])] | Retrieves a parameter from an element given a parameter id. (Inherited from Element.)
Public property | Parameter[([Definition])] | Retrieve a parameter from an element based on its definition. (Inherited from Element.)

See Also

TrussType Class
TrussType Members
Autodesk.Revit.Symbols Namespace