ParameterStorage Methods
CollapseAll image DropDown image

Syntax

C#
public class ParameterStorage
Visual Basic (Declaration)
Public Class ParameterStorage
Visual C++
public ref class ParameterStorage

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | Set | Overloaded.

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterStorage
Autodesk.Revit Namespace