AddConstraintDiameter Method

RebarShapeDefinitionByArc..::AddConstraintDiameter Method
CollapseAll image DropDown image

Specify a parameter to drive the diameter of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintDiameter(
    Parameter __unnamed000,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintDiameter ( _
    __unnamed000 As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintDiameter (
    Parameter^ __unnamed000,
    RebarShapeArcReferenceType arcRefType
)

Parameters

__unnamed000
Parameter
arcRefType
RebarShapeArcReferenceType
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace