LogicOrFilter Class
See Also Members
CollapseAll image DropDown image

The LogicOrFilter is used to implement Logic-OR operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B5EB6F89-3B92-4e51-95BF-43CCE41DA8AD")]
public class LogicOrFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B5EB6F89-3B92-4e51-95BF-43CCE41DA8AD")> _
Public Class LogicOrFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B5EB6F89-3B92-4e51-95BF-43CCE41DA8AD")]
public ref class LogicOrFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-OR relationship, use it to filter elements which satisfy one of two sub-filters.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::LogicOrFilter

See Also

LogicOrFilter Members
Autodesk.Revit Namespace