BoundarySegmentArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segments.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("17C03E49-8B1B-4134-B737-90D37AD03F6C")]
public class BoundarySegmentArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("17C03E49-8B1B-4134-B737-90D37AD03F6C")> _
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"17C03E49-8B1B-4134-B737-90D37AD03F6C")]
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Rooms Namespace