Autodesk.Revit.Creation Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Creation
Visual Basic (Declaration)
Namespace Autodesk.Revit.Creation
Visual C++
namespace Autodesk.Revit.Creation

Classes

 | Class | Description
Public class | Application | The Application Creation object is used to create new instances of utility objects.
Public class | AreaCreationData | A class which wraps the arguments of Area for batch creation
Public class | Document | The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Public class | FamilyInstanceCreationData | A class which wraps the arguments of FamilyInstance for batch creation.
Public class | Filter | The Filter creation object is used to create new instances of element filter utility objects.
Public class | ProfiledWallCreationData | A class which wraps the arguments of Wall for batch creation
Public class | RectangularWallCreationData | A class which wraps the arguments of Wall for batch creation
Public class | RoomCreationData | A class which wraps the arguments of Room for batch creation.
Public class | TextNoteCreationData | A class which wraps the arguments of TextNote for batch creation

Enumerations

 | Enumeration | Description
Public enumeration | Document..::eRefFace | Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Application Class
See Also Members
CollapseAll image DropDown image

The Application Creation object is used to create new instances of utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("711849C2-4FD7-4617-BB97-B212DA042C8E")]
public class Application : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("711849C2-4FD7-4617-BB97-B212DA042C8E")> _
Public Class Application _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"711849C2-4FD7-4617-BB97-B212DA042C8E")]
public ref class Application : public APIObject

Remarks

General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Creation..::Application

See Also

Application Members
Autodesk.Revit.Creation Namespace