AnalyticalModelProfile Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelProfile
Visual Basic (Declaration)
Public Class AnalyticalModelProfile
Visual C++
public ref class AnalyticalModelProfile

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public property | EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
Public property | StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
Public property | SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile
Autodesk.Revit.Structural Namespace