Autodesk.Revit.Areas Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Areas
Visual Basic (Declaration)
Namespace Autodesk.Revit.Areas
Visual C++
namespace Autodesk.Revit.Areas

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of a area boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.

BoundarySegment Class
See Also Members
CollapseAll image DropDown image

An object that represents a segment of a area boundary.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("30D74E65-6F1F-4C18-BFB3-3F1832FFD64A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegment : APIObject
Visual Basic (Declaration)
<GuidAttribute("30D74E65-6F1F-4C18-BFB3-3F1832FFD64A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
[GuidAttribute(L"30D74E65-6F1F-4C18-BFB3-3F1832FFD64A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Areas Namespace