LocationPoint Class
See Also Members
CollapseAll image DropDown image

Provides location functionality for all elements that have a single insertion point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("AD815920-6B6A-4122-A8CE-021F1560399B")]
public class LocationPoint : Location
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("AD815920-6B6A-4122-A8CE-021F1560399B")> _
Public Class LocationPoint _
    Inherits Location
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"AD815920-6B6A-4122-A8CE-021F1560399B")]
public ref class LocationPoint : public Location

Remarks

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Location
Autodesk.Revit..::LocationPoint

See Also

LocationPoint Members
Autodesk.Revit Namespace