MaterialGeneric Class
See Also Members
CollapseAll image DropDown image

Represents a generic material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7E29A64E-223D-4182-A2E1-5A1E17DBFBBF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialGeneric : Material
Visual Basic (Declaration)
<GuidAttribute("7E29A64E-223D-4182-A2E1-5A1E17DBFBBF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialGeneric _
    Inherits Material
Visual C++
[GuidAttribute(L"7E29A64E-223D-4182-A2E1-5A1E17DBFBBF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialGeneric : public Material

Remarks

MaterialGeneric is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialGeneric

See Also

MaterialGeneric Members
Autodesk.Revit.Elements Namespace