MenuItem Properties
CollapseAll image DropDown image

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AssemblyName | Get or set name of the assembly which external command lives in.
Public property | Checked | Set check or uncheck the menu through API.
Public property | ClassName | Get or set name of the class which implements external command.
Public property | Enabled | Disable and Enable the Custom menu through API.
Public property | MenuItemType | Get type of the menu through API.
Public property | Name | Get name of the menu through API.
Public property | StatusbarTip | Get or set tips.

See Also

MenuItem
Autodesk.Revit Namespace