Item Property

ParameterMap..::Item Property
CollapseAll image DropDown image

Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Parameter Item[
    string key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Parameter
Visual C++
public:
virtual property Parameter^ Item[String^ key] {
    Parameter^ get (String^ key);
    void set (String^ key, Parameter^ value);
}

Parameters

key
String
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

ParameterMap Class
Autodesk.Revit Namespace