Solid Properties
CollapseAll image DropDown image

Syntax

C#
public class Solid
Visual Basic (Declaration)
Public Class Solid
Visual C++
public ref class Solid

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid
Autodesk.Revit.Geometry Namespace