MoveNext Method

ParameterListItemArrayIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one item forward.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace