Mullion Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Mullion
Visual Basic (Declaration)
Public Class Mullion
Visual C++
public ref class Mullion

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MullionMullionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | LocationCurve | The curve profile of the mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Parameter | Overloaded.

See Also

Mullion
Autodesk.Revit.Elements Namespace