TextNote Class
See Also Members
CollapseAll image DropDown image

Provides access to the TextNote object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9C1F90C9-4654-42e9-AEB3-575FF9A97F6B")]
public class TextNote : TextElement
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9C1F90C9-4654-42e9-AEB3-575FF9A97F6B")> _
Public Class TextNote _
    Inherits TextElement
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9C1F90C9-4654-42e9-AEB3-575FF9A97F6B")]
public ref class TextNote : public TextElement

Remarks

The user can create TextNote object and change the internal property as Leaders and so on.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::TextElement
Autodesk.Revit.Elements..::TextNote

See Also

TextNote Members
Autodesk.Revit.Elements Namespace