Gutter Class
See Also Members
CollapseAll image DropDown image

An object that represents a gutter within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5EE23152-06FA-493a-8C35-89E979950D12")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Gutter : HostedSweep
Visual Basic (Declaration)
<GuidAttribute("5EE23152-06FA-493a-8C35-89E979950D12")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Gutter _
    Inherits HostedSweep
Visual C++
[GuidAttribute(L"5EE23152-06FA-493a-8C35-89E979950D12")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Gutter : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::Gutter

See Also

Gutter Members
Autodesk.Revit.Elements Namespace