NewAreaReinforcement Method

Document..::NewAreaReinforcement Method
CollapseAll image DropDown image

Creates a new instance of an Area Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaReinforcement NewAreaReinforcement(
    Element host,
    CurveArray curves,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewAreaReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    direction As XYZ _
) As AreaReinforcement
Visual C++
public:
AreaReinforcement^ NewAreaReinforcement (
    Element^ host,
    CurveArray^ curves,
    XYZ^ direction
)

Parameters

host
Element
The element to which the Area Reinforcement belongs. The element must be a structural floor or wall.
curves
CurveArray
An array of curves that define the boundary of the area. They must belong to the top face of the floor or the exterior face of the wall.
direction
XYZ

Return Value

If successful, NewAreaReinforcement returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace