AddDistributionSysType Method

ElectricalSetting..::AddDistributionSysType Method
CollapseAll image DropDown image

Add a new distribution system type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DistributionSysType AddDistributionSysType(
    string name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType volLineToLine,
    VoltageType volLineToGround
)
Visual Basic (Declaration)
Public Function AddDistributionSysType ( _
    name As String, _
    phase As ElectricalPhase, _
    phaseConfig As ElectricalPhaseConfiguration, _
    numWire As Integer, _
    volLineToLine As VoltageType, _
    volLineToGround As VoltageType _
) As DistributionSysType
Visual C++
public:
DistributionSysType^ AddDistributionSysType (
    String^ name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType^ volLineToLine,
    VoltageType^ volLineToGround
)

Parameters

name
String
The name of new added distribution system type
phase
ElectricalPhase
Single or three phase this type is
phaseConfig
ElectricalPhaseConfiguration
Configuration property of given phase
numWire
Int32
Wire number of this distribution system
volLineToLine
VoltageType
Type of line to line voltage in this system
volLineToGround
VoltageType
Type of line to ground voltage in this system

Return Value

New added distribution system type object.

Exceptions

Exception | Condition
System..::ArgumentException | The name can't be null, empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace