Extrusion Class
See Also Members
CollapseAll image DropDown image

Provides access to the Extrusion model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A9DDCB39-4F1A-4ec3-AF2C-2CCB3521C415")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Extrusion : GenericForm
Visual Basic (Declaration)
<GuidAttribute("A9DDCB39-4F1A-4ec3-AF2C-2CCB3521C415")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Extrusion _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"A9DDCB39-4F1A-4ec3-AF2C-2CCB3521C415")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Extrusion : public GenericForm

Remarks

The Extrusion object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Extrusion

See Also

Extrusion Members
Autodesk.Revit.Elements Namespace