BoundarySegmentArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segments.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5930C8C8-69A1-4729-A621-6F41851657FB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegmentArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("5930C8C8-69A1-4729-A621-6F41851657FB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"5930C8C8-69A1-4729-A621-6F41851657FB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Areas Namespace