NewModelCurveArray Method

Document..::NewModelCurveArray Method
CollapseAll image DropDown image

Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurveArray ( _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewModelCurveArray (
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurveArray
CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane
SketchPlane

Return Value

If successful an array of new model line elements. Otherwise null pointer.

Remarks

See Also

Document Class
Autodesk.Revit.Creation Namespace