AnalyticalModelProfile Class
See Also Members
CollapseAll image DropDown image

Represents an extruded profile.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("766EE16B-F9D1-4557-A9ED-7223C1DEA5FA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalModelProfile : AnalyticalModel
Visual Basic (Declaration)
<GuidAttribute("766EE16B-F9D1-4557-A9ED-7223C1DEA5FA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalModelProfile _
    Inherits AnalyticalModel
Visual C++
[GuidAttribute(L"766EE16B-F9D1-4557-A9ED-7223C1DEA5FA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalModelProfile : public AnalyticalModel

Remarks

Elements, such as beams, may be formed from a profile that has been swept along a curve. This analytical model represents such a form and is used to access the cross section and the underlying curve that make up the element.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelProfile

See Also

AnalyticalModelProfile Members
Autodesk.Revit.Structural Namespace