Truss Methods
CollapseAll image DropDown image

Syntax

C#
public class Truss
Visual Basic (Declaration)
Public Class Truss
Visual C++
public ref class Truss

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
Public method | DetachTopChord | Detach the truss's top from a specified element.
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.

Protected Methods

 | Name | Description

See Also

Truss
Autodesk.Revit.Elements Namespace