DuplicateConstruction Method

MEPSpaceConstruction..::DuplicateConstruction Method
CollapseAll image DropDown image

Create a new construction for Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPBuildingConstruction DuplicateConstruction(
    MEPBuildingConstruction pCurrentConstruction,
    string pName
)
Visual Basic (Declaration)
Public Function DuplicateConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction, _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ DuplicateConstruction (
    MEPBuildingConstruction^ pCurrentConstruction,
    String^ pName
)

Parameters

pCurrentConstruction
MEPBuildingConstruction
The existent Construction want to be cloned.
pName
String
The name of the new Construction.

Remarks

If the name is same with the existen one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace