TypeFilter Class
See Also Members
CollapseAll image DropDown image

Represents a filter to filter elements with the given type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CD9E823B-F629-432a-AA50-C60266B732CE")]
public class TypeFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CD9E823B-F629-432a-AA50-C60266B732CE")> _
Public Class TypeFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CD9E823B-F629-432a-AA50-C60266B732CE")]
public ref class TypeFilter : public Filter

Remarks

The TypeFilter object is to filter all the elements with the given type in the active document. You can specify whether its derived classes will be filtered out or not. By default, this filter will not retrieve derived classes objects.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::TypeFilter

See Also

TypeFilter Members
Autodesk.Revit Namespace