Area Properties
CollapseAll image DropDown image

Syntax

C#
public class Area
Visual Basic (Declaration)
Public Class Area
Visual C++
public ref class Area

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Boundary | Returns the boundary of the area.
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the area. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Name of the Number.
Public property | Parameter | Overloaded.

See Also

Area
Autodesk.Revit.Elements Namespace