DefinitionsBase Class
See Also Members
CollapseAll image DropDown image

A set that contains definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4415E971-CC60-4ae4-B1D2-77ADFABA279C")]
public class DefinitionsBase : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4415E971-CC60-4ae4-B1D2-77ADFABA279C")> _
Public Class DefinitionsBase _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4415E971-CC60-4ae4-B1D2-77ADFABA279C")]
public ref class DefinitionsBase : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions

See Also

DefinitionsBase Members
Autodesk.Revit.Parameters Namespace