CurtainSystem Class
See Also Members
CollapseAll image DropDown image

Provides access to the CurtainSystem object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("14018A71-D0DB-46e9-BB31-6C732896BCEF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurtainSystem : CurtainSystemBase
Visual Basic (Declaration)
<GuidAttribute("14018A71-D0DB-46e9-BB31-6C732896BCEF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurtainSystem _
    Inherits CurtainSystemBase
Visual C++
[GuidAttribute(L"14018A71-D0DB-46e9-BB31-6C732896BCEF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainSystem : public CurtainSystemBase

Remarks

The user can create CurtainSystem object and change the internal properties.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CurtainSystemBase
Autodesk.Revit.Elements..::CurtainSystem

See Also

CurtainSystem Members
Autodesk.Revit.Elements Namespace