Room Property

FamilyInstance..::Room Property
CollapseAll image DropDown image

Returns the Room in which an instance is located at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room Room{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

This property can be used for facilities management type applications. The Room object can also provide its boundary for containment testing.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace