Symbol Property

FamilyInstance..::Symbol Property
CollapseAll image DropDown image

Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilySymbol Symbol{ get; set;}
Visual Basic (Declaration)
Public Property Symbol As FamilySymbol
Visual C++
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace