ExternalDefinition Class
See Also Members
CollapseAll image DropDown image

The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("27835C94-19F1-4cf6-B627-E2C3B5A13A3F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ExternalDefinition : Definition
Visual Basic (Declaration)
<GuidAttribute("27835C94-19F1-4cf6-B627-E2C3B5A13A3F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ExternalDefinition _
    Inherits Definition
Visual C++
[GuidAttribute(L"27835C94-19F1-4cf6-B627-E2C3B5A13A3F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ExternalDefinition : public Definition

Remarks

The ExternalDefinition object is derived from the Definition object and therefore supports all the properties and methods of that object. The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Document.OpenSharedParameterFile method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::ExternalDefinition

See Also

ExternalDefinition Members
Autodesk.Revit.Parameters Namespace