ExternalDefinition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ExternalDefinition
Visual Basic (Declaration)
Public Class ExternalDefinition
Visual C++
public ref class ExternalDefinition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExternalDefinitionExternalDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | Name | The user visible name for the parameter. (Overrides Definition ..:: Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition ..:: ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition ..:: ParameterType.)
Public property | Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

See Also

ExternalDefinition
Autodesk.Revit.Parameters Namespace