BoxPlacement Enumeration
CollapseAll image DropDown image

An enumerate type listing possible placement of a box (an object of rectangular shape.)

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7B58277A-FD3F-47bf-A48F-47FADA20B9F8")]
public enum BoxPlacement
Visual Basic (Declaration)
<GuidAttribute("7B58277A-FD3F-47bf-A48F-47FADA20B9F8")> _
Public Enumeration BoxPlacement
Visual C++
[GuidAttribute(L"7B58277A-FD3F-47bf-A48F-47FADA20B9F8")]
public enum class BoxPlacement

Members

Member name | Description
BottomRight | Placement of a box by its bottom right corner.
TopLeft | Placement of a box by its top left corner.
Center | Placement of a box by its center point.
BottomLeft | Placement of a box by its bottom left corner.
TopRight | Placement of a box by its top right corner.

See Also

Autodesk.Revit.Enums Namespace