NewModelCurve Method

Document..::NewModelCurve Method
CollapseAll image DropDown image

Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewModelCurve (
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Curve
The internal geometry curve for model line.
sketchPlane
SketchPlane
The sketch plane this new model line resides in.

Return Value

If successful a new model line element. Otherwise null pointer.

Remarks

Different type of model curve element will be returned according to the type of geometry curve.

See Also

Document Class
Autodesk.Revit.Creation Namespace