ConduitTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ConduitTypeSet
Visual Basic (Declaration)
Public Class ConduitTypeSet
Visual C++
public ref class ConduitTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConduitTypeSetConduitTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every conduit type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a conduit type within the set.
Public method | Erase | Removes a specified conduit type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified conduit type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of conduit types that are in the set.

See Also

ConduitTypeSet
Autodesk.Revit.Elements Namespace