PrintManager Class
See Also Members
CollapseAll image DropDown image

Represents the Print information in Print Dialog(File->Print) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("55A9D557-4BF5-4331-B8AF-58AFA16EE196")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PrintManager : APIObject
Visual Basic (Declaration)
<GuidAttribute("55A9D557-4BF5-4331-B8AF-58AFA16EE196")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PrintManager _
    Inherits APIObject
Visual C++
[GuidAttribute(L"55A9D557-4BF5-4331-B8AF-58AFA16EE196")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PrintManager : public APIObject

Remarks

This class is a new interface class in Revit API for print function.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PrintManager

See Also

PrintManager Members
Autodesk.Revit Namespace