Transformed Property

Curve..::Transformed Property
CollapseAll image DropDown image

Applies the specified transformation to this curve and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Transformed[
    Transform transform
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Curve
Visual C++
public:
property Curve^ Transformed[Transform^ transform] {
    Curve^ get (Transform^ transform);
}

Parameters

transform
Transform
The transformation to be applied.

Return Value

The transformed curve.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified transformation is null.
System..::InvalidOperationException | Thrown when the transformation is not valid or the transformation application fails.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace