ExtrusionRoof Class
See Also Members
CollapseAll image DropDown image

Represents some kinds of Extrusion Roofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6D770476-FC0D-4f57-84E7-B091DB25DD5E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ExtrusionRoof : RoofBase
Visual Basic (Declaration)
<GuidAttribute("6D770476-FC0D-4f57-84E7-B091DB25DD5E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ExtrusionRoof _
    Inherits RoofBase
Visual C++
[GuidAttribute(L"6D770476-FC0D-4f57-84E7-B091DB25DD5E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ExtrusionRoof : public RoofBase

Remarks

The ExtrusionRoof object represents some kinds of extrusion roof in Revit. The extrusion roof object is derived from the RoofBase object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::RoofBase
Autodesk.Revit.Elements..::ExtrusionRoof

See Also

ExtrusionRoof Members
Autodesk.Revit.Elements Namespace