ParameterStorage Class
See Also Members
CollapseAll image DropDown image

An object that contains details for the value of a parameter. This class is mainly used with the class FilterCriterion to retrieve Elements according to certain criteria.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("ECCB2394-583D-4b40-8D90-953AFB6AF9FF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ParameterStorage : APIObject
Visual Basic (Declaration)
<GuidAttribute("ECCB2394-583D-4b40-8D90-953AFB6AF9FF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ParameterStorage _
    Inherits APIObject
Visual C++
[GuidAttribute(L"ECCB2394-583D-4b40-8D90-953AFB6AF9FF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ParameterStorage : public APIObject

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterStorage

See Also

ParameterStorage Members
Autodesk.Revit Namespace