BarDescription Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class BarDescription
Visual Basic (Declaration)
Public Class BarDescription
Visual C++
public ref class BarDescription

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BarDescriptionBarDescriptionNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Public property | Count | Retrieves the number of bars of this shape.
Public property | HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
Public property | HookType | Retrieves the Rebar Hook Type property of a Bar Description.
Public property | Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Public property | Length | Retrieves the length of a Bar Description.

See Also

BarDescription
Autodesk.Revit.Structural Namespace