Category Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Category
Visual Basic (Declaration)
Public Class Category
Visual C++
public ref class Category

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoryCategoryNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | GetHashCode | (Overrides Object ..:: GetHashCode()().)

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Id | Returns the category id associated with the category object.
Public property | Material | Retrieve or change the material of the category.
Public property | Name | Returns the user visible name of the category.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the sub categories of this category.
Public property | Visible | Retrieve or change the visible of the category in the active view.

See Also

Category
Autodesk.Revit Namespace