CategoryNameMap Methods
CollapseAll image DropDown image

Syntax

C#
public class CategoryNameMap
Visual Basic (Declaration)
Public Class CategoryNameMap
Visual C++
public ref class CategoryNameMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CategoryNameMap
Autodesk.Revit Namespace