Rebar Methods
CollapseAll image DropDown image

Syntax

C#
public class Rebar
Visual Basic (Declaration)
Public Class Rebar
Visual C++
public ref class Rebar

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | ScaleToBox | Move and resize the bar to fit within a specified box.
Public method | SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.

Protected Methods

 | Name | Description

See Also

Rebar
Autodesk.Revit.Elements Namespace