Rotation Property

Transform..::Rotation Property
CollapseAll image DropDown image

The transformation that rotates by the specified angle about the specified axis and point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform Rotation[
    XYZ origin,
    XYZ axis,
    double angle
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Rotation ( _
    origin As XYZ, _
    axis As XYZ, _
    angle As Double _
) As Transform
Visual C++
public:
static property Transform^ Rotation[XYZ^ origin, XYZ^ axis, double angle] {
    Transform^ get (XYZ^ origin, XYZ^ axis, double angle);
}

Parameters

origin
XYZ
The point to rotate about.
axis
XYZ
The axis vector to rotate about.
angle
Double
The rotation angle in radians.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::ArgumentException | Thrown when the specified values fail to define the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace