LayoutRuleFixedDistance Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Fixed-Distance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("17DB8BE0-D34F-4f16-BD65-E4E0059C740C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LayoutRuleFixedDistance : LayoutRule
Visual Basic (Declaration)
<GuidAttribute("17DB8BE0-D34F-4f16-BD65-E4E0059C740C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LayoutRuleFixedDistance _
    Inherits LayoutRule
Visual C++
[GuidAttribute(L"17DB8BE0-D34F-4f16-BD65-E4E0059C740C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LayoutRuleFixedDistance : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleFixedDistance

See Also

LayoutRuleFixedDistance Members
Autodesk.Revit.Elements Namespace