Insert Method

CategoryNameMap..::Insert Method
CollapseAll image DropDown image

Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    string key,
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert (
    String^ key,
    Category^ item
)

Parameters

key
String
The name to be used for inserting the category into the map.
item
Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace