LinePattern Class
See Also Members
CollapseAll image DropDown image

Represents a line pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D11DCFD0-B773-43c4-963E-957D30B9DFB1")]
public class LinePattern : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D11DCFD0-B773-43c4-963E-957D30B9DFB1")> _
Public Class LinePattern _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D11DCFD0-B773-43c4-963E-957D30B9DFB1")]
public ref class LinePattern : public Element

Remarks

Currently the details of the line patterns are not exposed but all the line patterns can be found on the Document object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LinePattern

See Also

LinePattern Members
Autodesk.Revit.Elements Namespace