Item Property

CurveArray..::Item Property
CollapseAll image DropDown image

Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Curve Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Curve
Visual C++
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}

Parameters

index
Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace