SetControlPointsAndWeights Method

NurbSpline..::SetControlPointsAndWeights Method
CollapseAll image DropDown image

Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetControlPointsAndWeights(
    XYZArray ctrlPoints,
    DoubleArray weights
)
Visual Basic (Declaration)
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As XYZArray, _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights (
    XYZArray^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
XYZArray
weights
DoubleArray

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace