XYZArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an array of XYZ coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("36ABCEDA-577C-4920-8B22-1696C5404035")]
public abstract class XYZArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("36ABCEDA-577C-4920-8B22-1696C5404035")> _
Public MustInherit Class XYZArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"36ABCEDA-577C-4920-8B22-1696C5404035")]
public ref class XYZArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::XYZArrayIterator

See Also

XYZArrayIterator Members
Autodesk.Revit.Geometry Namespace