Wire Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Wire
Visual Basic (Declaration)
Public Class Wire
Visual C++
public ref class Wire

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireWireNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | ConnectorManager | Get connector manager of the wire.
Public property | GroundConductorNum | Get of set ground conductor number. Its default value is zero after created.
Public property | HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Public property | NeutralConductorNum | Get of set neutral conductor number. Its default value is zero after created.
Public property | Parameter | Overloaded.
Public property | WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire
Autodesk.Revit.Elements Namespace