ElementBinding Class
See Also Members
CollapseAll image DropDown image

A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AD24CAA2-FBE7-42b5-8C4B-E75AADF9C88D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ElementBinding : Binding
Visual Basic (Declaration)
<GuidAttribute("AD24CAA2-FBE7-42b5-8C4B-E75AADF9C88D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
[GuidAttribute(L"AD24CAA2-FBE7-42b5-8C4B-E75AADF9C88D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding
Autodesk.Revit.Parameters..::InstanceBinding
Autodesk.Revit.Parameters..::TypeBinding

See Also

ElementBinding Members
Autodesk.Revit.Parameters Namespace