ModelLine Class
See Also Members
CollapseAll image DropDown image

Represents a ModelLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("04A14242-C701-4425-A529-D89408CEFFC2")]
public class ModelLine : ModelCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("04A14242-C701-4425-A529-D89408CEFFC2")> _
Public Class ModelLine _
    Inherits ModelCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"04A14242-C701-4425-A529-D89408CEFFC2")]
public ref class ModelLine : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelLine

See Also

ModelLine Members
Autodesk.Revit.Elements Namespace