BindingMap Methods
CollapseAll image DropDown image

Syntax

C#
public class BindingMap
Visual Basic (Declaration)
Public Class BindingMap
Visual C++
public ref class BindingMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap ..:: Clear()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap ..:: Contains(Definition).)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap ..:: Erase(Definition).)
Public method | Insert | Overloaded.
Public method | ReInsert | Overloaded.
Public method | Remove | The Remove method is used to remove a parameter binding.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionBindingMap ..:: Dispose(Boolean).)

See Also

BindingMap
Autodesk.Revit.Parameters Namespace