Instance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Instance
Visual Basic (Declaration)
Public Class Instance
Visual C++
public ref class Instance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Transformed | Transforms this instance and returns the result.

See Also

Instance
Autodesk.Revit.Geometry Namespace