SetComparisonResult Enumeration
CollapseAll image DropDown image

An enumerate type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6D1E3706-5BF7-4178-B2BF-065D62E0563B")]
public enum SetComparisonResult
Visual Basic (Declaration)
<GuidAttribute("6D1E3706-5BF7-4178-B2BF-065D62E0563B")> _
Public Enumeration SetComparisonResult
Visual C++
[GuidAttribute(L"6D1E3706-5BF7-4178-B2BF-065D62E0563B")]
public enum class SetComparisonResult

Members

Member name | Description
BothEmpty | Both sets are empty.
RightEmpty | The right set is empty and the left set is not.
LeftEmpty | The left set is empty and the right set is not.
Equal | Two nonempty sets are equal.
Superset | Both sets are not empty and the left set is strict superset of the right.
Subset | Both sets are not empty and the left set is strict subset of the right.
Overlap | The overlap of two sets is not empty and strict subset of both.
Disjoint | Both sets are not empty and don't overlap.

See Also

Autodesk.Revit.Enums Namespace