ElementSet Class
See Also Members
CollapseAll image DropDown image

A set that contains element objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7C79A689-EDA2-45b8-A0BA-9A4054641481")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElementSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("7C79A689-EDA2-45b8-A0BA-9A4054641481")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"7C79A689-EDA2-45b8-A0BA-9A4054641481")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementSet
Autodesk.Revit..::SelElementSet

See Also

ElementSet Members
Autodesk.Revit Namespace