FamilySymbol Class
See Also Members
CollapseAll image DropDown image

Represents a single Type within a Family.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D1272CC0-F45E-4afc-B9FD-EFC54E6FAD7E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FamilySymbol : InsertableObject
Visual Basic (Declaration)
<GuidAttribute("D1272CC0-F45E-4afc-B9FD-EFC54E6FAD7E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
[GuidAttribute(L"D1272CC0-F45E-4afc-B9FD-EFC54E6FAD7E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FamilySymbol : public InsertableObject

Remarks

The FamilySymbol object represents a Type within a Family. Each family can contain one or more family symbols. The FamilySymbol object is derived from the Symbol object and also the Element object and as such inherits all the properties and methods of those objects.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol
Autodesk.Revit.Symbols..::AnnotationSymbolType
Autodesk.Revit.Symbols..::MullionType
Autodesk.Revit.Symbols..::PanelType

See Also

FamilySymbol Members
Autodesk.Revit.Symbols Namespace