AnalyticalModelFrame Properties
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelFrame
Visual Basic (Declaration)
Public Class AnalyticalModelFrame
Visual C++
public ref class AnalyticalModelFrame

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Provides access to Structural Framing Analytical Model.
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | Profile | This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.
Public property | RigidLink | Provides access to Rigid Links component of Structural Framing Element.
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFrame
Autodesk.Revit.Structural Namespace