CompoundStructureDeckUsage Enumeration
CollapseAll image DropDown image

Describes how the deck relates to the surrounding layers.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("14C97E4A-B580-4234-A58F-32626F446377")]
public enum CompoundStructureDeckUsage
Visual Basic (Declaration)
<GuidAttribute("14C97E4A-B580-4234-A58F-32626F446377")> _
Public Enumeration CompoundStructureDeckUsage
Visual C++
[GuidAttribute(L"14C97E4A-B580-4234-A58F-32626F446377")]
public enum class CompoundStructureDeckUsage

Members

Member name | Description
MergeWithLayerBelow | Deck is merged with the layer below.
Standalone | Deck is independent of other layers.
MergeWithLayerAbove | Deck is merged with the layer above.
Invalid | Invalid.

See Also

Autodesk.Revit.Structural.Enums Namespace