OnDocumentNewed Event

ControlledApplication..::OnDocumentNewed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometime a new document will be created during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as create some elements for this document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace