Document Class
See Also Members
CollapseAll image DropDown image

The Document Creation object is used to create new instances of elements within the Autodesk Revit project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DB1636EA-F122-4354-B984-9BDBB4D0218A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Document : APIObject
Visual Basic (Declaration)
<GuidAttribute("DB1636EA-F122-4354-B984-9BDBB4D0218A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Document _
    Inherits APIObject
Visual C++
[GuidAttribute(L"DB1636EA-F122-4354-B984-9BDBB4D0218A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Document : public APIObject

Remarks

The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly. The object can create a limited number of types, which is expected to increase as the API matures.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Creation..::Document

See Also

Document Members
Autodesk.Revit.Creation Namespace