DesignOption Property

Element..::DesignOption Property
CollapseAll image DropDown image

Returns the design option to which the element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DesignOption DesignOption{ get;}
Visual Basic (Declaration)
Public ReadOnly Property DesignOption As DesignOption
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return Nothing.

See Also

Element Class
Autodesk.Revit Namespace