DialogBoxEventHandler Delegate
CollapseAll image DropDown image

A handler for the event that is fired when a Revit dialog box is displayed during an external API command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public delegate void DialogBoxEventHandler(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Public Delegate Sub DialogBoxEventHandler ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
public delegate void DialogBoxEventHandler (
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
DialogBoxData
An object that describes the dialog box

See Also

Autodesk.Revit.Events Namespace