MEPModel Class
See Also Members
CollapseAll image DropDown image

Supports all Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("24DFB032-FCEB-40b9-BD36-A9E11DEA80E2")]
public class MEPModel : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("24DFB032-FCEB-40b9-BD36-A9E11DEA80E2")> _
Public Class MEPModel _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"24DFB032-FCEB-40b9-BD36-A9E11DEA80E2")]
public ref class MEPModel : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::ElectricalEquipment
Autodesk.Revit.MEP..::LightingDevice
Autodesk.Revit.MEP..::LightingFixture
Autodesk.Revit.MEP..::MechanicalEquipment

See Also

MEPModel Members
Autodesk.Revit.MEP Namespace