DuctSystemType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Duct System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F6C03427-CC6A-4265-984F-557F10C8515B")]
public enum DuctSystemType
Visual Basic (Declaration)
<GuidAttribute("F6C03427-CC6A-4265-984F-557F10C8515B")> _
Public Enumeration DuctSystemType
Visual C++
[GuidAttribute(L"F6C03427-CC6A-4265-984F-557F10C8515B")]
public enum class DuctSystemType

Members

Member name | Description
Global | Duct System Type is Global.
Fitting | Duct System Type is Fitting.
OtherAir | Duct System Type is OtherAir.
ExhaustAir | Duct System Type is ExhaustAir.
ReturnAir | Duct System Type is ReturnAir.
SupplyAir | Duct System Type is SupplyAir.

See Also

Autodesk.Revit.MEP.Enums Namespace