Reset Method

ParameterListItemArrayIterator..::Reset Method
CollapseAll image DropDown image

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace