Wall Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Wall
Visual Basic (Declaration)
Public Class Wall
Visual C++
public ref class Wall

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WallWallNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | flip | The wall orientation will be flipped.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for this Wall.
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Orientation | Provides access to the wall's external face's orientation.
Public property | Parameter | Overloaded.
Public property | StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
Public property | WallType | Retrieve or change the type of the wall.
Public property | Width | Returns the overall thickness of the wall.

See Also

Wall
Autodesk.Revit.Elements Namespace