Translation Property

Transform..::Translation Property
CollapseAll image DropDown image

The transformation that translates by the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform Translation[
    XYZ vec
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Translation ( _
    vec As XYZ _
) As Transform
Visual C++
public:
static property Transform^ Translation[XYZ^ vec] {
    Transform^ get (XYZ^ vec);
}

Parameters

vec
XYZ
The translation vector.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace