Sketch Class
See Also Members
CollapseAll image DropDown image

Provides access to the Sketch in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("84278CA0-4E34-4205-9646-648F79126EA2")]
public class Sketch : SketchBase
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("84278CA0-4E34-4205-9646-648F79126EA2")> _
Public Class Sketch _
    Inherits SketchBase
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"84278CA0-4E34-4205-9646-648F79126EA2")]
public ref class Sketch : public SketchBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::Sketch

See Also

Sketch Members
Autodesk.Revit.Elements Namespace