AnalyticalModelWall Class
See Also Members
CollapseAll image DropDown image

Supports all Wall Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C4FD32F5-C283-4ffd-9334-CC9A57CD22F5")]
public class AnalyticalModelWall : AnalyticalModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C4FD32F5-C283-4ffd-9334-CC9A57CD22F5")> _
Public Class AnalyticalModelWall _
    Inherits AnalyticalModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C4FD32F5-C283-4ffd-9334-CC9A57CD22F5")]
public ref class AnalyticalModelWall : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelWall

See Also

AnalyticalModelWall Members
Autodesk.Revit.Structural Namespace