ScaleToBox Method

Rebar..::ScaleToBox Method
CollapseAll image DropDown image

Move and resize the bar to fit within a specified box.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ScaleToBox(
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Sub ScaleToBox ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
)
Visual C++
public:
void ScaleToBox (
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

origin
XYZ
xVec
XYZ
yVec
XYZ

Remarks

The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace