RebarBarTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarBarTypeSet
Visual Basic (Declaration)
Public Class RebarBarTypeSet
Visual C++
public ref class RebarBarTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every RebarBar type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarBar type within the set.
Public method | Erase | Removes a specified RebarBar type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified RebarBar type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarBarTypeSet
Autodesk.Revit.Symbols Namespace