SlabEdge Class
See Also Members
CollapseAll image DropDown image

An object that represents a slab edge within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("AD002C65-8673-4bdb-B954-793E70266B66")]
public class SlabEdge : HostedSweep
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("AD002C65-8673-4bdb-B954-793E70266B66")> _
Public Class SlabEdge _
    Inherits HostedSweep
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"AD002C65-8673-4bdb-B954-793E70266B66")]
public ref class SlabEdge : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::SlabEdge

See Also

SlabEdge Members
Autodesk.Revit.Elements Namespace