CitySet Methods
CollapseAll image DropDown image

Syntax

C#
public class CitySet
Visual Basic (Declaration)
Public Class CitySet
Visual C++
public ref class CitySet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CitySet
Autodesk.Revit.Site Namespace