MaterialWood Properties
CollapseAll image DropDown image

Syntax

C#
public class MaterialWood
Visual Basic (Declaration)
Public Class MaterialWood
Visual C++
public ref class MaterialWood

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Bending | Get or set the bending of the wood material.
Public property | CompressionParallel | Get or set the compression parallel to grain of the wood material.
Public property | CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
Public property | Grade | Get or set the grade of the wood material.
Public property | Parameter | Overloaded.
Public property | PoissonModulus | Get or set the Poisson modulus of the wood material.
Public property | ShearModulus | Get or set the shear modulus of the wood material.
Public property | ShearParallel | Get or set the shear parallel to grain of the wood material.
Public property | ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Public property | Species | Get or set the species of the wood material.
Public property | ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Public property | UnitWeight | Get or set the unit weight of the wood material.
Public property | YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood
Autodesk.Revit.Elements Namespace