RebarHostData Class
See Also Members
CollapseAll image DropDown image

Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("740FFDF7-8F1F-4bb1-BFEE-B39AE35257C9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RebarHostData : APIObject
Visual Basic (Declaration)
<GuidAttribute("740FFDF7-8F1F-4bb1-BFEE-B39AE35257C9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RebarHostData _
    Inherits APIObject
Visual C++
[GuidAttribute(L"740FFDF7-8F1F-4bb1-BFEE-B39AE35257C9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarHostData : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::RebarHostData

See Also

RebarHostData Members
Autodesk.Revit.Elements Namespace