ProjectPosition Constructor (Double, Double, Double, Double)
CollapseAll image DropDown image

Construct a new ProjectPosition object with the specified East to West, North to South, Elevation and Angle of rotation

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
)
Visual C++
public:
ProjectPosition (
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Double
East to West offset
ns
Double
North to South offset
elevation
Double
Elevation offset
angle
Double
Rotation from true north

Remarks

The angle can be in the range of +PI to -PI

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace