SketchPlane Class
See Also Members
CollapseAll image DropDown image

Represents a SketchPlane within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("53C5D986-BF53-4189-8C6F-CF7162EE5707")]
public class SketchPlane : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("53C5D986-BF53-4189-8C6F-CF7162EE5707")> _
Public Class SketchPlane _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"53C5D986-BF53-4189-8C6F-CF7162EE5707")]
public ref class SketchPlane : public Element

Remarks

The SketchPlane object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the user visible name of the level that appears in the level bubble. To retrieve all the levels within a project use the Document.Elements iterator and look for objects of type Autodesk.Revit.Elements.SketchPlane.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchPlane

See Also

SketchPlane Members
Autodesk.Revit.Elements Namespace