TextNoteLeaderTypes Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Leader types.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3E78C10B-64A5-4443-8613-B8873BF74A21")]
public enum TextNoteLeaderTypes
Visual Basic (Declaration)
<GuidAttribute("3E78C10B-64A5-4443-8613-B8873BF74A21")> _
Public Enumeration TextNoteLeaderTypes
Visual C++
[GuidAttribute(L"3E78C10B-64A5-4443-8613-B8873BF74A21")]
public enum class TextNoteLeaderTypes

Members

Member name | Description
TNLT_ARC_R | The leader is put at the right of the Text object and in the arc style.
TNLT_ARC_L | The leader is put at the left of the Text object and in the arc style.
TNLT_STRAIGHT_R | The leader is put at the right of the Text object and in the straight style.
TNLT_STRAIGHT_L | The leader is put at the left of the Text object and in the straight style.

See Also

Autodesk.Revit.Enums Namespace