PathReinforcementType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C3D00F02-5FAE-4a42-ACD4-8459FDF79AA4")]
public class PathReinforcementType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C3D00F02-5FAE-4a42-ACD4-8459FDF79AA4")> _
Public Class PathReinforcementType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C3D00F02-5FAE-4a42-ACD4-8459FDF79AA4")]
public ref class PathReinforcementType : public Symbol

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::PathReinforcementType

See Also

PathReinforcementType Members
Autodesk.Revit.Symbols Namespace