PipeSystemType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Pipe System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("31450C28-12DA-400f-A74E-61C24CB0C309")]
public enum PipeSystemType
Visual Basic (Declaration)
<GuidAttribute("31450C28-12DA-400f-A74E-61C24CB0C309")> _
Public Enumeration PipeSystemType
Visual C++
[GuidAttribute(L"31450C28-12DA-400f-A74E-61C24CB0C309")]
public enum class PipeSystemType

Members

Member name | Description
Global | Pipe System Type is Global.
Fitting | Pipe System Type is Fitting.
FireProtectOther | Pipe System Type is FireProtectOther.
FireProtectPreaction | Pipe System Type is FireProtectPreaction.
FireProtectDry | Pipe System Type is FireProtectDry.
FireProtectWet | Pipe System Type is FireProtectWet.
OtherPipe | Pipe System Type is OtherPipe.
DomesticColdWater | Pipe System Type is DomesticColdWater.
DomesticHotWater | Pipe System Type is DomesticHotWater.
Sanitary | Pipe System Type is Sanitary.
ReturnHydronic | Pipe System Type is ReturnHydronic.
SupplyHydronic | Pipe System Type is SupplyHydronic.

See Also

Autodesk.Revit.MEP.Enums Namespace