Floor Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Floor
Visual Basic (Declaration)
Public Class Floor
Visual C++
public ref class Floor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FloorFloorNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the floor object.
Public property | FloorType | Retrieves/set an object that represents the type of the floor.
Public property | Parameter | Overloaded.
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor
Public property | SpanDirectionSymbols | An array of span direction symbols associated with this floor.
Public property | StructuralUsage | The floors designated structural usage, such as bearing or non bearing.

See Also

Floor
Autodesk.Revit.Elements Namespace