CurtainGridLine Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridLine
Visual Basic (Declaration)
Public Class CurtainGridLine
Visual C++
public ref class CurtainGridLine

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainGridLineCurtainGridLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
Public method | RemoveSegment | Remove the segment specified by the input curve.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Lock | Retrieve or change the lock state of the curtain grid line.
Public property | Parameter | Overloaded.
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.

See Also

CurtainGridLine
Autodesk.Revit.Elements Namespace