BaseArray Class
See Also Members
CollapseAll image DropDown image

An abstract base class that represents an array within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0335452A-782C-4f86-BD9C-C950FDC1A72D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BaseArray : Element
Visual Basic (Declaration)
<GuidAttribute("0335452A-782C-4f86-BD9C-C950FDC1A72D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BaseArray _
    Inherits Element
Visual C++
[GuidAttribute(L"0335452A-782C-4f86-BD9C-C950FDC1A72D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BaseArray abstract : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BaseArray
Autodesk.Revit.Elements..::LinearArray
Autodesk.Revit.Elements..::RadialArray

See Also

BaseArray Members
Autodesk.Revit.Elements Namespace