LibraryPaths Property

Application..::LibraryPaths Property
CollapseAll image DropDown image

Retrieves path information for where content is stored on disk.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringStringMap LibraryPaths{ get; set;}
Visual Basic (Declaration)
Public Property LibraryPaths As StringStringMap
Visual C++
public:
property StringStringMap^ LibraryPaths {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

This property is used to control where Autodesk Revit searches for content. The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

See Also

Application Class
Autodesk.Revit.Options Namespace