Application Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ApplicationApplicationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | NewArc | Overloaded.
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewArray | Creates a new instance of a generic Array.
Public method | NewBoundingBoxUV | Overloaded.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
Public method | NewColor | Returns a new color object.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWF2DExportOptions | Creates DWF2D Export options.
Public method | NewDWF3DExportOptions | Creates DWF3D Export options.
Public method | NewDWFX2DExportOptions | Creates DWFX2D Export options.
Public method | NewDWFX3DExportOptions | Creates DWFX3D Export options.
Public method | NewDWGExportOptions | Creates DWG Export options.
Public method | NewElementArray | Returns an array that can hold element objects.
Public method | NewElementId | Creates a new ElementId object.
Public method | NewElementIdSet | Creates a new instance of a set specifically for holding element ids.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewEllipse | Creates a new geometric ellipse object.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData | Overloaded.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewFillPatternSet | Returns a set that can hold fill pattern objects.
Public method | NewGBXMLExportOptions | Creates Gren-Building XML Export options.
Public method | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewInstanceBinding | Overloaded.
Public method | NewIntersectionResultArray | Creates a new instance of a IntersectionResult array.
Public method | NewLine | Creates a new bound or unbounded geometric line object.
Public method | NewLineBound | Creates a new bounded geometric line object.
Public method | NewLinePatternSet | Returns a set that can hold line pattern objects.
Public method | NewLineUnbound | Creates a new unbounded geometric line object.
Public method | NewLoadCaseArray | Creates a new instance of a LoadCase array.
Public method | NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
Public method | NewLoadUsageArray | Creates a new instance of a LoadUsage array.
Public method | NewMap | Creates a new instance of a generic Map.
Public method | NewMaterialSet | Create a new instance of MaterialSet.
Public method | NewNurbSpline | Creates a new geometric nurbSpline object.
Public method | NewParameterListItemArray | Returns an array that can hold list items of external list parameter.
Public method | NewPlane | Overloaded.
Public method | NewPostedErrorArray | Creates a array to store instances of PostedError.
Public method | NewProfiledWallCreationData | Overloaded.
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewRectangularWallCreationData | Overloaded.
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewRoomCreationData | Creates an object which wraps the arguments of Room for batch creation.
Public method | NewSelElementSet | Creates a new instance of a set specifically for holding selected elements.
Public method | NewSet | Creates a new instance of a generic Set.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewStringStringMap | Creates a new map that maps one string to another string.
Public method | NewTextNoteCreationData | Overloaded.
Public method | NewTypeBinding | Overloaded.
Public method | NewUV | Overloaded.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewXYZ | Overloaded.
Public method | NewXYZArray | Generate an empty array that can hold XYZ point objects.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Filter | Gives access to an object for creating different types of filters.

See Also

Application
Autodesk.Revit.Creation Namespace