AreaReinforcement Class
See Also Members
CollapseAll image DropDown image

An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67B97E86-7979-48c0-A81C-A189CE899019")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AreaReinforcement : Element
Visual Basic (Declaration)
<GuidAttribute("67B97E86-7979-48c0-A81C-A189CE899019")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AreaReinforcement _
    Inherits Element
Visual C++
[GuidAttribute(L"67B97E86-7979-48c0-A81C-A189CE899019")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AreaReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::AreaReinforcement

See Also

AreaReinforcement Members
Autodesk.Revit.Elements Namespace