gbXMLParamElem Class
See Also Members
CollapseAll image DropDown image

An object that represents the gbXML Parameters within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("422DADB3-7AD6-443f-8F0F-7AFFB13FEA9E")]
public class gbXMLParamElem : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("422DADB3-7AD6-443f-8F0F-7AFFB13FEA9E")> _
Public Class gbXMLParamElem _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"422DADB3-7AD6-443f-8F0F-7AFFB13FEA9E")]
public ref class gbXMLParamElem : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::gbXMLParamElem

See Also

gbXMLParamElem Members
Autodesk.Revit.Elements Namespace