Insert Method

CurveArray..::Insert Method
CollapseAll image DropDown image

Insert the specified curve into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Curve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Curve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Curve^ item,
    int index
)

Parameters

item
Curve
The curve to be inserted into the array.
index
Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace