LogicNotFilter Class
See Also Members
CollapseAll image DropDown image

The LogicNotFilter is used to implement Logic-NOT operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("BB6BF006-D08F-4d22-9480-51836EB30E00")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LogicNotFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("BB6BF006-D08F-4d22-9480-51836EB30E00")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LogicNotFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"BB6BF006-D08F-4d22-9480-51836EB30E00")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LogicNotFilter : public Filter

Remarks

This filter represents a combined filter consists of one sub-filter by Logic-NOT relationship, use it to filter elements which don't satisfy the sub-filter.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::LogicNotFilter

See Also

LogicNotFilter Members
Autodesk.Revit Namespace