TrussType Class
See Also Members
CollapseAll image DropDown image

Represents a specific type of truss.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E7BA9C7B-D08C-4229-9043-A8266EA97E59")]
public class TrussType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E7BA9C7B-D08C-4229-9043-A8266EA97E59")> _
Public Class TrussType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E7BA9C7B-D08C-4229-9043-A8266EA97E59")]
public ref class TrussType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::TrussType

See Also

TrussType Members
Autodesk.Revit.Symbols Namespace