NewProjectDocument Method

Application..::NewProjectDocument Method
CollapseAll image DropDown image

New project document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument (
    String^ templateFileName
)

Parameters

templateFileName
String
The template file name.

Remarks

It is correspond to the File->New->Project....

Exceptions

Exception | Condition
System..::ArgumentException | if 'templateFileName' is a null object or a empty string.
System..::InvalidOperationException | if can not new a project document.

See Also

Application Class
Autodesk.Revit Namespace