CreateInstance Method

ObjectFactory..::CreateInstance Method
CollapseAll image DropDown image

For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public APIObject CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function CreateInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As APIObject
Visual C++
public:
APIObject^ CreateInstance (
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
IntPtr
pData
IntPtr
tag
IntPtr

Return Value

See Also

ObjectFactory Class
Autodesk.Revit Namespace