InsulationType Class
See Also Members
CollapseAll image DropDown image

Represents electrical insulation type definition information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DD811A5A-38D2-4aa7-A20A-1C2656027C69")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class InsulationType : Element
Visual Basic (Declaration)
<GuidAttribute("DD811A5A-38D2-4aa7-A20A-1C2656027C69")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class InsulationType _
    Inherits Element
Visual C++
[GuidAttribute(L"DD811A5A-38D2-4aa7-A20A-1C2656027C69")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class InsulationType : public Element

Remarks

Insulation type is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::InsulationType

See Also

InsulationType Members
Autodesk.Revit.Elements Namespace