RoofBase Properties
CollapseAll image DropDown image

Syntax

C#
public class RoofBase
Visual Basic (Declaration)
Public Class RoofBase
Visual C++
public ref class RoofBase

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Parameter | Overloaded.
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.

See Also

RoofBase
Autodesk.Revit.Elements Namespace