InstanceUsageFilter Class
See Also Members
CollapseAll image DropDown image

Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("86A213E1-C5E0-49d7-AB5D-81322340AC2A")]
public class InstanceUsageFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("86A213E1-C5E0-49d7-AB5D-81322340AC2A")> _
Public Class InstanceUsageFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"86A213E1-C5E0-49d7-AB5D-81322340AC2A")]
public ref class InstanceUsageFilter : public Filter

Remarks

The InstanceUsageFilter object is to filter all the elements with the given InstanceUsage/StructuralUsage in the active document. FamilyInstance (only brace and beam) has the property StructuralUsage.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::InstanceUsageFilter

See Also

InstanceUsageFilter Members
Autodesk.Revit Namespace