GutterTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GutterTypeSet
Visual Basic (Declaration)
Public Class GutterTypeSet
Visual C++
public ref class GutterTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GutterTypeSetGutterTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every gutter type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a gutter type within the set.
Public method | Erase | Removes a specified gutter type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified gutter type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet
Autodesk.Revit.Symbols Namespace