SymbolGeometry Property

Instance..::SymbolGeometry Property
CollapseAll image DropDown image

The geometric representation of the symbol.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element SymbolGeometry{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SymbolGeometry As Element
Visual C++
public:
property Element^ SymbolGeometry {
    Element^ get ();
}

Remarks

This method is here because Autodesk.Revit.Element.Geometry will not return anything if the element is a symbol. Note that the symbol geometry will not be transformed by this call. It will still be defined in the local coordinate system of the symbol. However, the context of the Instance object (such as effective material) will be applied to the symbol. Ordinarily, this should not matter because the symbol is supposed to define its own context. Also, note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Symbol geometry will be parsed with the same options as those used when this object was retrieved.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace