FamilyFilter Class
See Also Members
CollapseAll image DropDown image

A filter object that used to filter family elements which satisfy specified criterion, filter elements via specifying family name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6BBD9055-0D7F-4148-93E4-A935B6408F86")]
public class FamilyFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6BBD9055-0D7F-4148-93E4-A935B6408F86")> _
Public Class FamilyFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6BBD9055-0D7F-4148-93E4-A935B6408F86")]
public ref class FamilyFilter : public Filter

Remarks

The filtered elements include: Family type elements, Symbol type elements, FamilyInstance type elements and other types instances(such as Door, Wall, etc) whose family is specified family. These elements should belong to main model, active design option or primary design option.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::FamilyFilter

See Also

FamilyFilter Members
Autodesk.Revit Namespace