NewDetailCurve Method

Document..::NewDetailCurve Method
CollapseAll image DropDown image

Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewDetailCurve ( _
    view As View, _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As DetailCurve
Visual C++
public:
DetailCurve^ NewDetailCurve (
    View^ view,
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

view
View
The view in which the detail curve is to be visible.
geometryCurve
Curve
The internal geometry curve for detail curve. It should be a bound curve.
sketchPlane
SketchPlane
The sketch plane this new detail curve resides in.

Return Value

If successful a new detail curve element. Otherwise null pointer.

Remarks

Different type of detail curve element will be returned according to the type of geometry curve.

See Also

Document Class
Autodesk.Revit.Creation Namespace