StorageType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1EC4938F-D42B-4deb-A247-305564CA2087")]
public enum StorageType
Visual Basic (Declaration)
<GuidAttribute("1EC4938F-D42B-4deb-A247-305564CA2087")> _
Public Enumeration StorageType
Visual C++
[GuidAttribute(L"1EC4938F-D42B-4deb-A247-305564CA2087")]
public enum class StorageType

Members

Member name | Description
ElementId | The data type represents an element and is stored as the id of the element.
Integer | The internal data is stored in the form of a signed 32 bit integer.
String | The internal data will be stored in the form of a string of characters.
Double | The data will be stored internaly in the form of an 8 byte floating point number.
None | None represents an invalid storage type. This value should not be used.

See Also

Autodesk.Revit.Parameters Namespace