BoundingBoxXYZ Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundingBoxXYZ
Visual Basic (Declaration)
Public Class BoundingBoxXYZ
Visual C++
public ref class BoundingBoxXYZ

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether bounding box is turned on.
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
Public property | Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ
Autodesk.Revit.Geometry Namespace