SetPlaneAndCurve Method

ModelCurve..::SetPlaneAndCurve Method
CollapseAll image DropDown image

Set sketch plane and geometry curve properties simultaneously.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetPlaneAndCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Sub SetPlaneAndCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
)
Visual C++
public:
void SetPlaneAndCurve (
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Curve
The new geometry curve property.
sketchPlane
SketchPlane
The new sketch plane property.

Remarks

Set the sketch plane and geometry curve properties for the curve.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace