WallType Class
See Also Members
CollapseAll image DropDown image

Represents a specific type of wall, such as 'Generic -8" '.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D9B7204E-6EB9-4f93-880F-71908ADCB797")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WallType : HostObjAttributes
Visual Basic (Declaration)
<GuidAttribute("D9B7204E-6EB9-4f93-880F-71908ADCB797")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WallType _
    Inherits HostObjAttributes
Visual C++
[GuidAttribute(L"D9B7204E-6EB9-4f93-880F-71908ADCB797")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WallType : public HostObjAttributes

Remarks

All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::WallType

See Also

WallType Members
Autodesk.Revit.Symbols Namespace