PlanarFace Class
See Also Members
CollapseAll image DropDown image

A planar face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("EF7AB8DF-4CBB-4933-BEC6-4747EB33EED8")]
public class PlanarFace : Face
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("EF7AB8DF-4CBB-4933-BEC6-4747EB33EED8")> _
Public Class PlanarFace _
    Inherits Face
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"EF7AB8DF-4CBB-4933-BEC6-4747EB33EED8")]
public ref class PlanarFace : public Face

Remarks

Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parametrization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::PlanarFace

See Also

PlanarFace Members
Autodesk.Revit.Geometry Namespace