CeilingAndFloor Class
See Also Members
CollapseAll image DropDown image

A base class that provides support for all ceiling and floor objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E3567FD7-0E1B-4de8-B999-FBED7D6161D6")]
public class CeilingAndFloor : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E3567FD7-0E1B-4de8-B999-FBED7D6161D6")> _
Public Class CeilingAndFloor _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E3567FD7-0E1B-4de8-B999-FBED7D6161D6")]
public ref class CeilingAndFloor : public HostObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CeilingAndFloor

See Also

CeilingAndFloor Members
Autodesk.Revit.Elements Namespace