VoltageType Class
See Also Members
CollapseAll image DropDown image

Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2E85B874-1C11-4d8c-9776-6CF7FCC455EB")]
public class VoltageType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2E85B874-1C11-4d8c-9776-6CF7FCC455EB")> _
Public Class VoltageType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2E85B874-1C11-4d8c-9776-6CF7FCC455EB")]
public ref class VoltageType : public Symbol

Remarks

Actual, minimum and maximum value of voltage type can retrieved through properties, but only can be modified through SetVoltageValue method. All the unit of voltage properties in this class is volt.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::VoltageType

See Also

VoltageType Members
Autodesk.Revit.Symbols Namespace