FillPattern Class
See Also Members
CollapseAll image DropDown image

Represents a fill pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C927D76A-60DD-4543-984B-543976DB4367")]
public class FillPattern : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C927D76A-60DD-4543-984B-543976DB4367")> _
Public Class FillPattern _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C927D76A-60DD-4543-984B-543976DB4367")]
public ref class FillPattern : public Element

Remarks

Currently the details of the fill patterns are not exposed but all the fill patterns can be found on the Document object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::FillPattern

See Also

FillPattern Members
Autodesk.Revit.Elements Namespace