Insert Method

InstanceArray..::Insert Method
CollapseAll image DropDown image

Insert the specified instance into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Instance item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Instance, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Instance^ item,
    int index
)

Parameters

item
Instance
The instance to be inserted into the array.
index
Int32
The instance will be inserted before this index.

Return Value

Returns whether the instance was inserted into the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace