ComputeDerivatives Method

Edge..::ComputeDerivatives Method
CollapseAll image DropDown image

Returns the moving frame around the edge at the parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ComputeDerivatives(
    double parameter
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives (
    double parameter
)

Parameters

parameter
Double
The parameter is the natural (or "raw") edge parameter.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation memebers: Origin is the point on the edge (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the binormal vector (tangent x normal). Normal and binormal are zero if the edge is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when parameter is an infinite number.
System..::InvalidOperationException | Thrown when failed to compute derivatives.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace