RebarShape Property

Rebar..::RebarShape Property
CollapseAll image DropDown image

Get/Set the RebarShape associated with the Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShape RebarShape{ get; set;}
Visual Basic (Declaration)
Public Property RebarShape As RebarShape
Visual C++
public:
property RebarShape^ RebarShape {
    RebarShape^ get ();
    void set (RebarShape^ value);
}

Remarks

When set, the instance will choose values for its shape parameters to try to preserve its previous shape.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace