NewPathReinforcement Method

Document..::NewPathReinforcement Method
CollapseAll image DropDown image

Creates a new instance of a Path Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PathReinforcement NewPathReinforcement(
    Element host,
    CurveArray curves,
    bool flip
)
Visual Basic (Declaration)
Public Function NewPathReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    flip As Boolean _
) As PathReinforcement
Visual C++
public:
PathReinforcement^ NewPathReinforcement (
    Element^ host,
    CurveArray^ curves,
    bool flip
)

Parameters

host
Element
The element to which the Path Reinforcement belongs. The element must be a structural floor or wall.
curves
CurveArray
An array of curves forming a chain. Bars will be placed orthogonal to the chain with their hook ends near the chain, offset by the side cover setting. The curves must belong to the top face of the floor or the exterior face of the wall.
flip
Boolean
A flag controlling the bars relative to the curves. If the curves are given in order and with consistent orientation, the bars will lie to the right of the chain if flip=false, to the left if flip=true, when viewed from above the floor or outside the wall.

Return Value

If successful, NewPathReinforcement returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace