BubbleEnd Property

ReferencePlane..::BubbleEnd Property
CollapseAll image DropDown image

The bubble end of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ BubbleEnd{ get; set;}
Visual Basic (Declaration)
Public Property BubbleEnd As XYZ
Visual C++
public:
property XYZ^ BubbleEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the bubble end is set to almost the same point as free end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace