WireSize Class
See Also Members
CollapseAll image DropDown image

Represents specific electrical wire size information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9C0C9DA1-7EA6-463d-AE7E-D3F050683029")]
public class WireSize : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9C0C9DA1-7EA6-463d-AE7E-D3F050683029")> _
Public Class WireSize _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9C0C9DA1-7EA6-463d-AE7E-D3F050683029")]
public ref class WireSize : public APIObject

Remarks

Wire size is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::WireSize

See Also

WireSize Members
Autodesk.Revit.MEP Namespace