Geometry Property

Element..::Geometry Property
CollapseAll image DropDown image

Retrieves the geometric representation of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Geometry[
    Options options
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Geometry ( _
    options As Options _
) As Element
Visual C++
public:
property Element^ Geometry[Options^ options] {
    Element^ get (Options^ options);
}

Parameters

options
Options
User preferences for parsing of geometry.

Remarks

This call will retrieve 3d representation of the element. Nothing will be returned for symbols, annotations or details. This involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical.

See Also

Element Class
Autodesk.Revit Namespace