NewProjectTemplateDocument Method

Application..::NewProjectTemplateDocument Method
CollapseAll image DropDown image

New project template document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic (Declaration)
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument (
    String^ templateFilename
)

Parameters

templateFilename
String
The template file name.

Remarks

It is correspond to the File->New->Project....

Exceptions

Exception | Condition
System..::ArgumentException | if 'templateFileName' is a null object or a empty string.
System..::InvalidOperationException | if can not new a project template document.

See Also

Application Class
Autodesk.Revit Namespace