Subtraction Operator

XYZ..::Subtraction Operator
CollapseAll image DropDown image

Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator - (
    XYZ^ left,
    XYZ^ right
)

Parameters

left
XYZ
The first vector.
right
XYZ
The second vector.

Return Value

The vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace