GenericForm Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GenericForm
Visual Basic (Declaration)
Public Class GenericForm
Visual C++
public ref class GenericForm

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GenericFormGenericFormNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | Parameter | Overloaded.
Public property | Visible | The visibility of the GenericForm.

See Also

GenericForm
Autodesk.Revit.Elements Namespace