DemandFactorData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DemandFactorData
Visual Basic (Declaration)
Public Class DemandFactorData
Visual C++
public ref class DemandFactorData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DemandFactorDataDemandFactorDataNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | IsValid | Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.
Public property | MaxFactor | Get upper limit value of the range, the unit is volt-ampere.
Public property | MinFactor | Get lower limit value of the range, the unit is volt-ampere.
Public property | Percentage | Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

See Also

DemandFactorData
Autodesk.Revit.MEP Namespace