UnitWeight Property

MaterialGeneric..::UnitWeight Property
CollapseAll image DropDown image

Get or set the unit weight of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double UnitWeight{ get; set;}
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace