FamilyBase Class
See Also Members
CollapseAll image DropDown image

A base class for all Family objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("80C91481-6FCF-4d5e-A324-F750699035C7")]
public class FamilyBase : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("80C91481-6FCF-4d5e-A324-F750699035C7")> _
Public Class FamilyBase _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"80C91481-6FCF-4d5e-A324-F750699035C7")]
public ref class FamilyBase : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::FamilyBase
Autodesk.Revit.Elements..::Family

See Also

FamilyBase Members
Autodesk.Revit.Elements Namespace