RebarShape Class
See Also Members
CollapseAll image DropDown image

RebarShape specifies the shape type for a Rebar instance.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("65EEC113-00BA-4b1c-8C37-81EFF20F632F")]
public class RebarShape : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("65EEC113-00BA-4b1c-8C37-81EFF20F632F")> _
Public Class RebarShape _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"65EEC113-00BA-4b1c-8C37-81EFF20F632F")]
public ref class RebarShape : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RebarShape

See Also

RebarShape Members
Autodesk.Revit.Symbols Namespace