Opening Class
See Also Members
CollapseAll image DropDown image

An object that represents a Opening within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9AAA7DD6-FA3A-4cb9-ADCA-DC8B063B09AB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Opening : Element
Visual Basic (Declaration)
<GuidAttribute("9AAA7DD6-FA3A-4cb9-ADCA-DC8B063B09AB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Opening _
    Inherits Element
Visual C++
[GuidAttribute(L"9AAA7DD6-FA3A-4cb9-ADCA-DC8B063B09AB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Opening : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Opening

See Also

Opening Members
Autodesk.Revit.Elements Namespace