GenericForm Class
See Also Members
CollapseAll image DropDown image

Provides access to the Generic Form model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4F46029D-6FE1-4aaa-B836-EDEA9395A41D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GenericForm : Element
Visual Basic (Declaration)
<GuidAttribute("4F46029D-6FE1-4aaa-B836-EDEA9395A41D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GenericForm _
    Inherits Element
Visual C++
[GuidAttribute(L"4F46029D-6FE1-4aaa-B836-EDEA9395A41D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GenericForm : public Element

Remarks

The Generic Form object can be queried for a generic form for use in family modeling and massing.it is the base class of Sweep, Blend, Extrusion, Revolution.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Extrusion
Autodesk.Revit.Elements..::Sweep
Autodesk.Revit.Elements..::Blend
Autodesk.Revit.Elements..::Revolution

See Also

GenericForm Members
Autodesk.Revit.Elements Namespace