InsertableObject Class
See Also Members
CollapseAll image DropDown image

A base class you all types that are insertable.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("51B12AD1-208A-467c-80CA-D5435ABF2726")]
public class InsertableObject : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("51B12AD1-208A-467c-80CA-D5435ABF2726")> _
Public Class InsertableObject _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"51B12AD1-208A-467c-80CA-D5435ABF2726")]
public ref class InsertableObject : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol

See Also

InsertableObject Members
Autodesk.Revit.Symbols Namespace