InternalDefinition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class InternalDefinition
Visual Basic (Declaration)
Public Class InternalDefinition
Visual C++
public ref class InternalDefinition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InternalDefinitionInternalDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | Name | The user visible name for the parameter. (Overrides Definition ..:: Name.)
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition ..:: ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition ..:: ParameterType.)

See Also

InternalDefinition
Autodesk.Revit.Parameters Namespace