NewGroup Method

Document..::NewGroup Method
CollapseAll image DropDown image

Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Group NewGroup(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function NewGroup ( _
    elements As ElementSet _
) As Group
Visual C++
public:
Group^ NewGroup (
    ElementSet^ elements
)

Parameters

elements
ElementSet
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.

See Also

Document Class
Autodesk.Revit.Creation Namespace