Edge Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Edge
Visual Basic (Declaration)
Public Class Edge
Visual C++
public ref class Edge

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EdgeEdgeNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | Reference | Returns a stable reference to the edge.

See Also

Edge
Autodesk.Revit.Geometry Namespace