InsertableInstance Class
See Also Members
CollapseAll image DropDown image

A base class that provides support insertable instances.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A3C274C2-A754-4ccb-9202-18FF73696730")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class InsertableInstance : Instance
Visual Basic (Declaration)
<GuidAttribute("A3C274C2-A754-4ccb-9202-18FF73696730")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class InsertableInstance _
    Inherits Instance
Visual C++
[GuidAttribute(L"A3C274C2-A754-4ccb-9202-18FF73696730")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class InsertableInstance : public Instance

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::InsertableInstance
Autodesk.Revit.Elements..::FamilyInstance

See Also

InsertableInstance Members
Autodesk.Revit.Elements Namespace