Plane Class
See Also Members
CollapseAll image DropDown image

Provides access to the geometry plane object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B94F4B81-C12B-47fa-863B-024C54CE4C42")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Plane : APIObject
Visual Basic (Declaration)
<GuidAttribute("B94F4B81-C12B-47fa-863B-024C54CE4C42")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Plane _
    Inherits APIObject
Visual C++
[GuidAttribute(L"B94F4B81-C12B-47fa-863B-024C54CE4C42")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Plane : public APIObject

Remarks

The user can construct a plane object, get or set the vectors and origin through this class.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Plane

See Also

Plane Members
Autodesk.Revit.Geometry Namespace