MaterialConcrete Class
See Also Members
CollapseAll image DropDown image

Represents a concrete material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D571124B-EB8F-4bc8-B27C-FC2773A3188B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialConcrete : Material
Visual Basic (Declaration)
<GuidAttribute("D571124B-EB8F-4bc8-B27C-FC2773A3188B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialConcrete _
    Inherits Material
Visual C++
[GuidAttribute(L"D571124B-EB8F-4bc8-B27C-FC2773A3188B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialConcrete : public Material

Remarks

MaterialConcrete is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialConcrete

See Also

MaterialConcrete Members
Autodesk.Revit.Elements Namespace