CurtainSystem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystem
Visual Basic (Declaration)
Public Class CurtainSystem
Visual C++
public ref class CurtainSystem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainSystemCurtainSystemNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Public property | Parameter | Overloaded.

See Also

CurtainSystem
Autodesk.Revit.Elements Namespace