Line Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Line
Visual Basic (Declaration)
Public Class Line
Visual C++
public ref class Line

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
 | Bound | Returns the bounded line between the specified points.
 | Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.

See Also

Line
Autodesk.Revit.Geometry Namespace