FamilyInstance Properties
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstance
Visual Basic (Declaration)
Public Class FamilyInstance
Visual C++
public ref class FamilyInstance

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the family instance.
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | Overloaded.
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element.
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Material | This property returns the physical material from which the instance is made.
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Parameter | Overloaded.
Public property | Room | Overloaded.
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Property to get the sub componets of current family instance.
Public property | SuperComponent | Property to get the super componet of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | Overloaded.

See Also

FamilyInstance
Autodesk.Revit.Elements Namespace