RebarShapeDefinitionByArc Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionByArc
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc
Visual C++
public ref class RebarShapeDefinitionByArc

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeDefinitionByArcRebarShapeDefinitionByArcNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
Public method | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
Public method | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
Public method | AddConstraintRadius | Specify a parameter to drive the radius of the shape.
Public method | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides RebarShapeDefinition ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc
Autodesk.Revit.Symbols Namespace