DetailArc Class
See Also Members
CollapseAll image DropDown image

Represents a DetailArc within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8138EF2C-5288-4250-8A61-5E20F0AFB8B1")]
public class DetailArc : DetailCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8138EF2C-5288-4250-8A61-5E20F0AFB8B1")> _
Public Class DetailArc _
    Inherits DetailCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8138EF2C-5288-4250-8A61-5E20F0AFB8B1")]
public ref class DetailArc : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailArc

See Also

DetailArc Members
Autodesk.Revit.Elements Namespace