HostedSweep Class
See Also Members
CollapseAll image DropDown image

An object that represents a roof within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("864776A8-6312-4049-95AF-F24F33E9D58F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class HostedSweep : HostObject
Visual Basic (Declaration)
<GuidAttribute("864776A8-6312-4049-95AF-F24F33E9D58F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class HostedSweep _
    Inherits HostObject
Visual C++
[GuidAttribute(L"864776A8-6312-4049-95AF-F24F33E9D58F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class HostedSweep : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::SlabEdge
Autodesk.Revit.Elements..::Gutter
Autodesk.Revit.Elements..::Fascia

See Also

HostedSweep Members
Autodesk.Revit.Elements Namespace