StringStringMap Methods
CollapseAll image DropDown image

Syntax

C#
public class StringStringMap
Visual Basic (Declaration)
Public Class StringStringMap
Visual C++
public ref class StringStringMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every string from the map, rendering it empty.
Public method | Contains | Tests for the existence of a string key within the map.
Public method | Erase | Removes an item with the specified string key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

StringStringMap
Autodesk.Revit.Collections Namespace