LayoutRuleFixedDistance Constructor (Double, BeamSystemJustifyType)
CollapseAll image DropDown image

Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleFixedDistance (
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Double
The value of spacing must be in (0, 30000).
justifyType
BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace