AnnotationSymbolTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbolTypeSet
Visual Basic (Declaration)
Public Class AnnotationSymbolTypeSet
Visual C++
public ref class AnnotationSymbolTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnnotationSymbolTypeSetAnnotationSymbolTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a AnnotationSymbol type within the set.
Public method | Erase | Removes a specified AnnotationSymbol type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified AnnotationSymbol type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet
Autodesk.Revit.Symbols Namespace