SubComponents Property

FamilyInstance..::SubComponents Property
CollapseAll image DropDown image

Property to get the sub componets of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet SubComponents{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SubComponents As ElementSet
Visual C++
public:
property ElementSet^ SubComponents {
    ElementSet^ get ();
}

Remarks

When current familyinstance has no sub component, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace