RebarShapeDefinitionByArc Class
See Also Members
CollapseAll image DropDown image

Definition of a shape whose size and position can determined by a single arc.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("03D16B2E-6E41-4809-9DD5-7F57766DFF46")]
public class RebarShapeDefinitionByArc : RebarShapeDefinition
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("03D16B2E-6E41-4809-9DD5-7F57766DFF46")> _
Public Class RebarShapeDefinitionByArc _
    Inherits RebarShapeDefinition
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"03D16B2E-6E41-4809-9DD5-7F57766DFF46")]
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition

Remarks

In this shape definition, all dimensions are allowed to be driving dimensions.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarShapeDefinition
Autodesk.Revit.Symbols..::RebarShapeDefinitionByArc

See Also

RebarShapeDefinitionByArc Members
Autodesk.Revit.Symbols Namespace