Instance Class
See Also Members
CollapseAll image DropDown image

An instance of another element (symbol), specially positioned by this element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7EEA590E-DD5F-430b-BF42-18D457CBE5C0")]
public class Instance : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7EEA590E-DD5F-430b-BF42-18D457CBE5C0")> _
Public Class Instance _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7EEA590E-DD5F-430b-BF42-18D457CBE5C0")]
public ref class Instance : public GeometryObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Instance

See Also

Instance Members
Autodesk.Revit.Geometry Namespace