Item Property

CategoryNameMap..::Item Property
CollapseAll image DropDown image

Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Category Item[
    string key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}

Parameters

key
String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace