ArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0C5E799B-240D-4b6a-9BCA-39AC0D878DE1")]
public abstract class ArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0C5E799B-240D-4b6a-9BCA-39AC0D878DE1")> _
Public MustInherit Class ArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0C5E799B-240D-4b6a-9BCA-39AC0D878DE1")]
public ref class ArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::ArrayIterator

See Also

ArrayIterator Members
Autodesk.Revit.Collections Namespace