MaterialSteel Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialSteel
Visual Basic (Declaration)
Public Class MaterialSteel
Visual C++
public ref class MaterialSteel

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialSteelMaterialSteelNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this steel material element. (Overrides Material ..:: Duplicate(String).)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the steel material.
Public property | DampingRatio | Get or set the damping ratio of the steel material.
Public property | MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
Public property | MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Public property | Parameter | Overloaded.
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
Public property | ReductionFactor | Get or set the reduction factor for shear of the steel material.
Public property | ShearModulusX | Get or set the x component of the shear modulus of the steel material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the steel material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Public property | UnitWeight | Get or set the unit weight of the steel material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the steel material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the steel material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel
Autodesk.Revit.Elements Namespace