Parameter Properties
CollapseAll image DropDown image

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Get the display unit type of the parameter object.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject ..:: IsReadOnly.)
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter
Autodesk.Revit Namespace