WallType..::WallKind Enumeration
CollapseAll image DropDown image

Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E9A68360-146E-48df-A6BE-5C0DB6ED688E")]
public enum WallKind
Visual Basic (Declaration)
<GuidAttribute("E9A68360-146E-48df-A6BE-5C0DB6ED688E")> _
Public Enumeration WallKind
Visual C++
[GuidAttribute(L"E9A68360-146E-48df-A6BE-5C0DB6ED688E")]
public enum class WallKind

Members

Member name | Description
Stacked | A stacked wall of several wall types.
Curtain | A curtain wall.
Basic | A standard wall.
Unknown | The basic type is not known.

See Also

Autodesk.Revit.Symbols Namespace