Item Property

BindingMap..::Item Property
CollapseAll image DropDown image

The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override Binding Item[
    Definition key
]{ get; set;}
Visual Basic (Declaration)
Public Overrides Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Field Value

The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

set_Item is not permitted for this class. A NotSupportedException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace