TranslationRotationValue Enumeration
CollapseAll image DropDown image

Values for BoundaryConditions Translation and Rotation parameters.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("03D9CCEF-8582-4fb1-AF20-B41F159B5039")]
public enum TranslationRotationValue
Visual Basic (Declaration)
<GuidAttribute("03D9CCEF-8582-4fb1-AF20-B41F159B5039")> _
Public Enumeration TranslationRotationValue
Visual C++
[GuidAttribute(L"03D9CCEF-8582-4fb1-AF20-B41F159B5039")]
public enum class TranslationRotationValue

Members

Member name | Description
Spring | TranslationRotationValue is Spring.
Fixed | TranslationRotationValue is Fixed.
Release | TranslationRotationValue is Release.

See Also

Autodesk.Revit.Structural.Enums Namespace