NewDefinitionBySegments Method

RebarShape..::NewDefinitionBySegments Method
CollapseAll image DropDown image

Create a shape definition by segments, and associate it with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinitionBySegments NewDefinitionBySegments(
    int numSegments
)
Visual Basic (Declaration)
Public Function NewDefinitionBySegments ( _
    numSegments As Integer _
) As RebarShapeDefinitionBySegments
Visual C++
public:
RebarShapeDefinitionBySegments^ NewDefinitionBySegments (
    int numSegments
)

Parameters

numSegments
Int32

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace