NewDetailCurveArray Method

Document..::NewDetailCurveArray Method
CollapseAll image DropDown image

Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DetailCurveArray NewDetailCurveArray(
    View view,
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewDetailCurveArray ( _
    view As View, _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ NewDetailCurveArray (
    View^ view,
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

view
View
The view in which the detail curves are to be visible.
geometryCurveArray
CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.
sketchPlane
SketchPlane
The sketch plane this new detail curves resides in.

Return Value

If successful an array of new detail curve elements. Otherwise null pointer.

See Also

Document Class
Autodesk.Revit.Creation Namespace