ElementSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ElementSet
Visual Basic (Declaration)
Public Class ElementSet
Visual C++
public ref class ElementSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ElementSet
Autodesk.Revit Namespace