Curves Property

Rebar..::Curves Property
CollapseAll image DropDown image

The centerline of the Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray Curves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Remarks

These curves represent the centerline of the rebar, including the hooks and bends. They are the curves shown in Revit views at the coarse detail level.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace