OnClose Event

Document..::OnClose Event
CollapseAll image DropDown image

Subscribe to the OnClose event to be notified before the current document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentCloseEventHandler OnClose
Visual Basic (Declaration)
Public Event OnClose As DocumentCloseEventHandler
Visual C++
public:
 event DocumentCloseEventHandler^ OnClose {
    void add (DocumentCloseEventHandler^ value);
    void remove (DocumentCloseEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be closed. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace