Parameter Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ParameterParameterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Set | Overloaded.
Public method | SetValueString | Set the parameter value according to the input string.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Get the display unit type of the parameter object.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject ..:: IsReadOnly.)
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter
Autodesk.Revit Namespace