NewWires Method

ElectricalSystem..::NewWires Method
CollapseAll image DropDown image

Create a bunch of wires for the electrical system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireSet NewWires(
    View view,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWires ( _
    view As View, _
    wiringType As WiringType _
) As WireSet
Visual C++
public:
WireSet^ NewWires (
    View^ view,
    WiringType wiringType
)

Parameters

view
View
The view in which the wire is to be visible.
wiringType
WiringType
Specify the wiring type(Arc or Chamfer) that is to be applied to all new created wires.

Return Value

New created wires

Exceptions

Exception | Condition
System..::ArgumentException | This method can just only be used to created a bunch of wires according to specific pairs of elements, so if there exists null element in any pair of familyInstancePairs, the exception will be thrown.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace