SelectPanel Method

ElectricalSystem..::SelectPanel Method
CollapseAll image DropDown image

Set the panel for the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SelectPanel(
    FamilyInstance panel
)
Visual Basic (Declaration)
Public Sub SelectPanel ( _
    panel As FamilyInstance _
)
Visual C++
public:
void SelectPanel (
    FamilyInstance^ panel
)

Parameters

panel
FamilyInstance
The panel of the electrical system.

Remarks

If successful, the panel will be set for the system. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the panel parameter Value is null.
System..::InvalidOperationException | Thrown when the panel cannot be set for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace