FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
XYZ
A vector that dictates the direction of certain family instances.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace