ViewSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ViewSet
Visual Basic (Declaration)
Public Class ViewSet
Visual C++
public ref class ViewSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSetViewSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet
Autodesk.Revit.Elements Namespace