HookOffsetLength Property

RebarBarType..::HookOffsetLength Property
CollapseAll image DropDown image

Access to offset length data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double HookOffsetLength[
    RebarHookType hookId
]{ get; set;}
Visual Basic (Declaration)
Public Property HookOffsetLength ( _
    hookId As RebarHookType _
) As Double
Visual C++
public:
property double HookOffsetLength[RebarHookType^ hookId] {
    double get (RebarHookType^ hookId);
    void set (RebarHookType^ hookId, double value);
}

Parameters

hookId
RebarHookType

Remarks

Setting this property implicitly turns off the AutoCalcHookLengths property for this hook. It is only possible to set the offset length for hooks greater than 90 degrees.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace