FloorType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("89A3A1E8-A760-4fc8-8EF7-AC01EBDC6303")]
public class FloorType : HostObjAttributes
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("89A3A1E8-A760-4fc8-8EF7-AC01EBDC6303")> _
Public Class FloorType _
    Inherits HostObjAttributes
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"89A3A1E8-A760-4fc8-8EF7-AC01EBDC6303")]
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::FloorType

See Also

FloorType Members
Autodesk.Revit.Symbols Namespace