UniqueId Property

Element..::UniqueId Property
CollapseAll image DropDown image

A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string UniqueId{ get;}
Visual Basic (Declaration)
Public ReadOnly Property UniqueId As String
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

Remarks

The UniqueId can be used to store an identifier in and external database and then be used to retrieve the exact same element in the future if it still exists. This id can be passed the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as save to central whereas the ElementId property may change.

See Also

Element Class
Autodesk.Revit Namespace