TemperatureRatingType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingType
Visual Basic (Declaration)
Public Class TemperatureRatingType
Visual C++
public ref class TemperatureRatingType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TemperatureRatingTypeTemperatureRatingTypeNew |

Public Methods

 | Name | Description
Public method | AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
Public method | AddInsulationType | Add a new kind of insulation type into this temperature rating type.
Public method | AddWireSize | Add a new kind of wire size type into this temperature rating type.
Public method | RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
Public method | RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
Public method | RemoveWireSize | Remove an existing wire size type from this temperature rating type.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
Public property | InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
Public property | IsInUse | Indicate whether the temperature rating type is in use.
Public property | MaterialType | Get the material type information which this temperature rating type belongs to.
Public property | Name | Get name of temperature rating type. (Overrides Element ..:: Name.)
Public property | Parameter | Overloaded.
Public property | WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType
Autodesk.Revit.Elements Namespace