Edge Class
See Also Members
CollapseAll image DropDown image

An edge of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("247AEC56-4ACB-475f-8980-99F689765B43")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Edge : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("247AEC56-4ACB-475f-8980-99F689765B43")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Edge _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"247AEC56-4ACB-475f-8980-99F689765B43")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parametrization that is normalized to [0,1].

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Edge

See Also

Edge Members
Autodesk.Revit.Geometry Namespace