ShearModulus Property

MaterialWood..::ShearModulus Property
CollapseAll image DropDown image

Get or set the shear modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulus{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulus As Double
Visual C++
public:
property double ShearModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace