ElectricalSystem Class
See Also Members
CollapseAll image DropDown image

Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5F9BCF72-B234-40e4-ACDA-84A82CEAE77D")]
public class ElectricalSystem : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5F9BCF72-B234-40e4-ACDA-84A82CEAE77D")> _
Public Class ElectricalSystem _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5F9BCF72-B234-40e4-ACDA-84A82CEAE77D")]
public ref class ElectricalSystem : public Element

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ElectricalSystem

See Also

ElectricalSystem Members
Autodesk.Revit.Elements Namespace