DetailCurveArray Methods
CollapseAll image DropDown image

Syntax

C#
public class DetailCurveArray
Visual Basic (Declaration)
Public Class DetailCurveArray
Visual C++
public ref class DetailCurveArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DetailCurveArray
Autodesk.Revit.Elements Namespace