PhaseArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a phase array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("676AB018-D158-46ed-8AD3-2A1D786F126E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class PhaseArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("676AB018-D158-46ed-8AD3-2A1D786F126E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class PhaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"676AB018-D158-46ed-8AD3-2A1D786F126E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PhaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::PhaseArrayIterator

See Also

PhaseArrayIterator Members
Autodesk.Revit.Elements Namespace