MessageBoxData Class
See Also Members
CollapseAll image DropDown image

An object that represents a simple message box that has been displayed prompting the user for some action.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3423CED5-9F90-417d-B3FE-0CD05F03E47A")]
public class MessageBoxData : DialogBoxData
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3423CED5-9F90-417d-B3FE-0CD05F03E47A")> _
Public Class MessageBoxData _
    Inherits DialogBoxData
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3423CED5-9F90-417d-B3FE-0CD05F03E47A")]
public ref class MessageBoxData : public DialogBoxData

Remarks

When the application receives this object, a simple message box has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Events..::DialogBoxData
Autodesk.Revit.Events..::MessageBoxData

See Also

MessageBoxData Members
Autodesk.Revit.Events Namespace