NewRebar Method

Document..::NewRebar Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewRebar(RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, Int32, Int32, Boolean, Boolean) | Creates a new instance of a Rebar element within the project
Public method | NewRebar(RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ) | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace