OnDocumentClosed Event

Application..::OnDocumentClosed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentClosed event to be notified after a document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been closed during an API command. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace