Level Class
See Also Members
CollapseAll image DropDown image

Represents a Level line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("98333DD3-C7C2-4e26-B54B-2876D00D98D5")]
public class Level : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("98333DD3-C7C2-4e26-B54B-2876D00D98D5")> _
Public Class Level _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"98333DD3-C7C2-4e26-B54B-2876D00D98D5")]
public ref class Level : public Element

Remarks

The Level object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the user visible name of the level that appears in the level bubble. To retrieve all the levels within a project use the Document.Elements iterator and look for objects of type Autodesk.Revit.Elements.Level.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Level

See Also

Level Members
Autodesk.Revit.Elements Namespace