FamilyInstance Class
See Also Members
CollapseAll image DropDown image

This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C691F591-61A6-460e-AF90-90118509366C")]
public class FamilyInstance : InsertableInstance
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C691F591-61A6-460e-AF90-90118509366C")> _
Public Class FamilyInstance _
    Inherits InsertableInstance
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C691F591-61A6-460e-AF90-90118509366C")]
public ref class FamilyInstance : public InsertableInstance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::InsertableInstance
Autodesk.Revit.Elements..::FamilyInstance

See Also

FamilyInstance Members
Autodesk.Revit.Elements Namespace