Parameter Methods
CollapseAll image DropDown image

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Set | Overloaded.
Public method | SetValueString | Set the parameter value according to the input string.

Protected Methods

 | Name | Description

See Also

Parameter
Autodesk.Revit Namespace