DefinitionBindingMap Class
See Also Members
CollapseAll image DropDown image

A map that contains mappings of parameter definitions to parameter bindings.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("42407C5E-5D3C-4540-8C96-E659AFF836D7")]
public class DefinitionBindingMap : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("42407C5E-5D3C-4540-8C96-E659AFF836D7")> _
Public Class DefinitionBindingMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"42407C5E-5D3C-4540-8C96-E659AFF836D7")]
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::DefinitionBindingMap
Autodesk.Revit.Parameters..::BindingMap

See Also

DefinitionBindingMap Members
Autodesk.Revit.Collections Namespace