NewLoadCombination Method

Document..::NewLoadCombination Method
CollapseAll image DropDown image

Creates a new instance of a LoadCombination element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCombination NewLoadCombination(
    string name,
    int typeInd,
    int stateInd,
    double[] factors,
    LoadCaseArray cases,
    LoadCombinationArray combinations,
    LoadUsageArray usages
)
Visual Basic (Declaration)
Public Function NewLoadCombination ( _
    name As String, _
    typeInd As Integer, _
    stateInd As Integer, _
    factors As Double(), _
    cases As LoadCaseArray, _
    combinations As LoadCombinationArray, _
    usages As LoadUsageArray _
) As LoadCombination
Visual C++
public:
LoadCombination^ NewLoadCombination (
    String^ name,
    int typeInd,
    int stateInd,
    array<double>^ factors,
    LoadCaseArray^ cases,
    LoadCombinationArray^ combinations,
    LoadUsageArray^ usages
)

Parameters

name
String
The not empty name for the Load Combination Element to create.
typeInd
Int32
LoadCombination Type Index: 0-Combination, 1-Envelope.
stateInd
Int32
LoadCombination State Index: 0-Servicebility, 1-Ultimate.
factors
array< Double >[]()
Factors array for Load Combination formula.
cases
LoadCaseArray
Load Cases array for Load Combination formula.
combinations
LoadCombinationArray
Load Combinations array for Load Combination formula.
usages
LoadUsageArray
Load Usages array.

Return Value

If successful, NewLoadCombination and there isn’t the Load Combination Element with the same name returns an object for the newly created LoadCombination. If such element exist and match desired one (has the same formula and the same usages set), returns existing element. Otherwise nothing is returned.

Remarks

Factors and Load Combinations arrays have the same dimension (n). The Load Combination formula is equal to: factors[0]*cases[0]*factors[1]*cases[1]*. . . factors[n]*cases[n]. This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace