StructuralTypeFilter Class
See Also Members
CollapseAll image DropDown image

A Filter object that represents StructuralType, used to retrieve family instances whose structural type is specified structural type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0AC36005-04E8-4560-9659-49A26B5BE24F")]
public class StructuralTypeFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0AC36005-04E8-4560-9659-49A26B5BE24F")> _
Public Class StructuralTypeFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0AC36005-04E8-4560-9659-49A26B5BE24F")]
public ref class StructuralTypeFilter : public Filter

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::StructuralTypeFilter

See Also

StructuralTypeFilter Members
Autodesk.Revit Namespace