MapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class MapIterator
Visual Basic (Declaration)
Public MustInherit Class MapIterator
Visual C++
public ref class MapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MapIteratorMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

MapIterator
Autodesk.Revit.Collections Namespace