Path3d Class
See Also Members
CollapseAll image DropDown image

Provides access to the Generic 3D path object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E1238821-CD4B-4500-82F5-DDA027A3A0E6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Path3d : SketchBase
Visual Basic (Declaration)
<GuidAttribute("E1238821-CD4B-4500-82F5-DDA027A3A0E6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Path3d _
    Inherits SketchBase
Visual C++
[GuidAttribute(L"E1238821-CD4B-4500-82F5-DDA027A3A0E6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Path3d : public SketchBase

Remarks

This object represents a 3D path sketch of Sweep.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::Path3d

See Also

Path3d Members
Autodesk.Revit.Elements Namespace