NewFamilyInstance Method

Document..::NewFamilyInstance Method
See Also Members
CollapseAll image

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Insert a new instance of a Family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Add a new instance of a Family into the Autodesk Revit project, using a location and a type/symbol.
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Add a new instance of a Family into the Autodesk Revit project, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Insert a new instance of a Family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Add a new instance of a level based Family into the Autodesk Revit project, using a location, type/symbol and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Insert an new instance of a Family into an existing element in the Autodesk Revit project, using a location, type/symbol, the host element and a reference direction.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace