IExternalCommand Interface
See Also Members
CollapseAll image DropDown image

An interface that when support provides additional commands within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1D2E879E-22AA-420f-9607-AFC45D9733F6")]
public interface IExternalCommand
Visual Basic (Declaration)
<GuidAttribute("1D2E879E-22AA-420f-9607-AFC45D9733F6")> _
Public Interface IExternalCommand
Visual C++
[GuidAttribute(L"1D2E879E-22AA-420f-9607-AFC45D9733F6")]
public interface class IExternalCommand

Remarks

To add an external command to Autodesk Revit the developer should implement an object that supports the IExternalCommand interface.

See Also

IExternalCommand Members
Autodesk.Revit Namespace