Room Class
See Also Members
CollapseAll image DropDown image

Provides access to the room topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("54548F23-4FB5-43fd-968D-47EBD37A6D79")]
public class Room : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("54548F23-4FB5-43fd-968D-47EBD37A6D79")> _
Public Class Room _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"54548F23-4FB5-43fd-968D-47EBD37A6D79")]
public ref class Room : public Element

Remarks

The room object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Room

See Also

Room Members
Autodesk.Revit.Elements Namespace