IExternalApplication..::Result Enumeration
CollapseAll image DropDown image

Informs Autodesk Revit of the status of your application after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CC16E821-AE76-4437-9F41-DEC39752DA34")]
public enum Result
Visual Basic (Declaration)
<GuidAttribute("CC16E821-AE76-4437-9F41-DEC39752DA34")> _
Public Enumeration Result
Visual C++
[GuidAttribute(L"CC16E821-AE76-4437-9F41-DEC39752DA34")]
public enum class Result

Members

Member name | Description
Cancelled | Signifies that the external application is cancelled.
Succeeded | The external application completed successfully. Autodesk Revit will keep this object during the entire Revit session.
Failed | The external application was unable to complete its task.

See Also

Autodesk.Revit Namespace