Pinned Property

Element..::Pinned Property
CollapseAll image DropDown image

Informs the developer if an element has been pinned by a user.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Pinned{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Pinned As Boolean
Visual C++
public:
property bool Pinned {
    bool get ();
}

Remarks

If a user pins an element then they are signifying that the element should not be changed.

See Also

Element Class
Autodesk.Revit Namespace