Filter Class
See Also Members
CollapseAll image DropDown image

Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("24E91405-DEB5-448b-B07F-325F66AA654A")]
public abstract class Filter : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("24E91405-DEB5-448b-B07F-325F66AA654A")> _
Public MustInherit Class Filter _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"24E91405-DEB5-448b-B07F-325F66AA654A")]
public ref class Filter abstract : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::CategoryFilter
Autodesk.Revit..::FamilyFilter
Autodesk.Revit..::InstanceUsageFilter
Autodesk.Revit..::MaterialFilter
Autodesk.Revit..::ParameterFilter
Autodesk.Revit..::StructuralTypeFilter
Autodesk.Revit..::SymbolFilter
Autodesk.Revit..::TypeFilter
Autodesk.Revit..::WallUsageFilter
Autodesk.Revit..::LogicAndFilter
Autodesk.Revit..::LogicOrFilter
Autodesk.Revit..::LogicNotFilter

See Also

Filter Members
Autodesk.Revit Namespace