InternalDefinitions Class
See Also Members
CollapseAll image DropDown image

This object blocks attempts to create new internal definitions as they are not permitted.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("95A83518-5250-4a9b-B879-95DC2E0F0E37")]
public class InternalDefinitions : Definitions
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("95A83518-5250-4a9b-B879-95DC2E0F0E37")> _
Public Class InternalDefinitions _
    Inherits Definitions
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"95A83518-5250-4a9b-B879-95DC2E0F0E37")]
public ref class InternalDefinitions : public Definitions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions
Autodesk.Revit.Parameters..::InternalDefinitions

See Also

InternalDefinitions Members
Autodesk.Revit.Parameters Namespace