ViewType Enumeration
CollapseAll image DropDown image

An enumerate type listing available view types.)

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A87F6F42-6C6C-48d3-AB82-9EBFE6BB72E2")]
public enum ViewType
Visual Basic (Declaration)
<GuidAttribute("A87F6F42-6C6C-48d3-AB82-9EBFE6BB72E2")> _
Public Enumeration ViewType
Visual C++
[GuidAttribute(L"A87F6F42-6C6C-48d3-AB82-9EBFE6BB72E2")]
public enum class ViewType

Members

Member name | Description
Section | Cross section type of view.
Internal | Revit's internal type of view
Rendering | Rendering type of view.
Walkthrough | Walk-Through type of 3D view.
ColumnSchedule | Column Schedule type of view.
PanelSchedule | Panel Schedule Report view.
PresureLossReport | Presure Loss Report view.
LoadsReport | Loads Report view.
CostReport | Cost Report view.
Report | Report type of view.
Legend | Legend type of view.
DrawingSheet | Drawing sheet type of view.
DraftingView | Drafting type of view.
Schedule | Schedule type of view.
ThreeD | 3-D type of view.
Detail | Detail type of view.
Elevation | Elevation type of view.
CeilingPlan | Reflected ceiling plan type of view.
AreaPlan | Area plan type of view.
EngineeringPlan | Engineering Floor Plan type of view.
FloorPlan | Floor plan type of view.
Undefined | Undefined/unspecified type of view.

See Also

Autodesk.Revit.Enums Namespace