CreateTopMenu Method

Application..::CreateTopMenu Method
CollapseAll image DropDown image

Creates a top level menu which will be added to revit main menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual MenuItem CreateTopMenu(
    string menuName
)
Visual Basic (Declaration)
Public Overridable Function CreateTopMenu ( _
    menuName As String _
) As MenuItem
Visual C++
public:
virtual MenuItem^ CreateTopMenu (
    String^ menuName
)

Parameters

menuName
String
The caption of the menu to be created.

Remarks

The user can use this function to add a new item to the main menu of Revit. The return value will be the created MenuItem.

See Also

Application Class
Autodesk.Revit Namespace