PrintSetup Class
See Also Members
CollapseAll image DropDown image

Represents the Print Setup (File->Print Setup...) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0A0F0C54-4225-409d-98DB-4EB1853B43E3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PrintSetup : APIObject
Visual Basic (Declaration)
<GuidAttribute("0A0F0C54-4225-409d-98DB-4EB1853B43E3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PrintSetup _
    Inherits APIObject
Visual C++
[GuidAttribute(L"0A0F0C54-4225-409d-98DB-4EB1853B43E3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PrintSetup : public APIObject

Remarks

The Print Setup object can only get from PrintManager object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PrintSetup

See Also

PrintSetup Members
Autodesk.Revit Namespace