NurbSpline Properties
CollapseAll image DropDown image

Syntax

C#
public class NurbSpline
Visual Basic (Declaration)
Public Class NurbSpline
Visual C++
public ref class NurbSpline

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | isClosed | Return/set the nurb spline's isClosed property.
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline
Autodesk.Revit.Geometry Namespace