CurtainGrid Class
See Also Members
CollapseAll image DropDown image

Represents a CurtainGrid within Autodesk Revit. It is not an independent element.It represents a CurtainGrid from a curtain wall,curtain system or curtain roof. Curtain wall has only one CurtainGrid,curtain system or curtain roof may have several CurtainGrids.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("0C4F6489-CAAE-4920-94CF-3E83C1DD8130")]
public class CurtainGrid : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("0C4F6489-CAAE-4920-94CF-3E83C1DD8130")> _
Public Class CurtainGrid _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"0C4F6489-CAAE-4920-94CF-3E83C1DD8130")]
public ref class CurtainGrid : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::CurtainGrid

See Also

CurtainGrid Members
Autodesk.Revit.Elements Namespace