OnStartup Method

IExternalApplication..::OnStartup Method
CollapseAll image DropDown image

Provide an interface for the user to do some extra work when Revit starts.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
IExternalApplication.IExternalApplication..::Result OnStartup(
    ControlledApplication application
)
Visual Basic (Declaration)
Function OnStartup ( _
    application As ControlledApplication _
) As IExternalApplication..::Result
Visual C++
IExternalApplication..::Result OnStartup (
    ControlledApplication^ application
)

Parameters

application
ControlledApplication
The application is being started.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an exteranl application, the task within OnStartup will be executed when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace