ElementIterator Methods
CollapseAll image DropDown image

Syntax

C#
public class ElementIterator
Visual Basic (Declaration)
Public Class ElementIterator
Visual C++
public ref class ElementIterator

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | MoveNext | Move the iterator one element forward.
Public method | Reset | Bring the iterator back to the start of the database.

Protected Methods

 | Name | Description
Protected method | canSkipElement |
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | getADoc | Get document to which current iterator belongs.
Protected method | getElemIter | Get current element iterator.

See Also

ElementIterator
Autodesk.Revit Namespace