ContFootingType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a continuous footing in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AC21A9E3-31E6-4f45-9436-5CF05377C60D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ContFootingType : HostObjAttributes
Visual Basic (Declaration)
<GuidAttribute("AC21A9E3-31E6-4f45-9436-5CF05377C60D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ContFootingType _
    Inherits HostObjAttributes
Visual C++
[GuidAttribute(L"AC21A9E3-31E6-4f45-9436-5CF05377C60D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ContFootingType : public HostObjAttributes

Remarks

The structural layers of the continuous footing can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::ContFootingType

See Also

ContFootingType Members
Autodesk.Revit.Symbols Namespace