APIObject Class
See Also Members
CollapseAll image DropDown image

Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("959E7C83-A739-42b1-BDAD-42EDC4619C62")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class APIObject : IDisposable
Visual Basic (Declaration)
<GuidAttribute("959E7C83-A739-42b1-BDAD-42EDC4619C62")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class APIObject _
    Implements IDisposable
Visual C++
[GuidAttribute(L"959E7C83-A739-42b1-BDAD-42EDC4619C62")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementSet
Autodesk.Revit..::ElementSetIterator
Autodesk.Revit..::Document
Autodesk.Revit..::Element
Autodesk.Revit..::ElementIdSet
Autodesk.Revit..::ElementIdSetIterator
Autodesk.Revit..::Color
Autodesk.Revit..::ToolbarArray
Autodesk.Revit..::ToolbarArrayIterator
Autodesk.Revit..::Application
Autodesk.Revit..::ExternalCommandData
Autodesk.Revit..::PostedError
Autodesk.Revit..::PostedErrorArray
Autodesk.Revit..::PostedErrorArrayIterator
Autodesk.Revit..::Selection
Autodesk.Revit..::Settings
Autodesk.Revit..::CategoryNameMap
Autodesk.Revit..::CategoryNameMapIterator
Autodesk.Revit..::Category
Autodesk.Revit..::PlanTopology
Autodesk.Revit..::PlanCircuit
Autodesk.Revit..::PrintParameters
Autodesk.Revit..::PrintSetup
Autodesk.Revit..::PrintManager
Autodesk.Revit..::DocumentSet
Autodesk.Revit..::DocumentSetIterator
Autodesk.Revit..::MenuItem
Autodesk.Revit..::ToolbarItem
Autodesk.Revit..::Toolbar
Autodesk.Revit..::ExternalApplicationArray
Autodesk.Revit..::ExternalApplicationArrayIterator
Autodesk.Revit..::CategorySet
Autodesk.Revit..::CategorySetIterator
Autodesk.Revit..::ElementArray
Autodesk.Revit..::ElementArrayIterator
Autodesk.Revit..::FillPatternSet
Autodesk.Revit..::FillPatternSetIterator
Autodesk.Revit..::MaterialSet
Autodesk.Revit..::MaterialSetIterator
Autodesk.Revit..::LinePatternSet
Autodesk.Revit..::LinePatternSetIterator
Autodesk.Revit..::Filter
Autodesk.Revit..::ElementIterator
Autodesk.Revit..::PlanTopologySet
Autodesk.Revit..::PlanTopologySetIterator
Autodesk.Revit..::FilterCriterion
Autodesk.Revit..::Location
Autodesk.Revit..::PlanCircuitSet
Autodesk.Revit..::PlanCircuitSetIterator
Autodesk.Revit..::SuspendUpdating
Autodesk.Revit..::FormatOptions
Autodesk.Revit..::Leader
Autodesk.Revit..::LeaderArray
Autodesk.Revit..::LeaderArrayIterator
Autodesk.Revit..::PaperSize
Autodesk.Revit..::PaperSizeSet
Autodesk.Revit..::PaperSizeSetIterator
Autodesk.Revit..::PaperSource
Autodesk.Revit..::PaperSourceSet
Autodesk.Revit..::PaperSourceSetIterator
Autodesk.Revit..::ViewSheetSetting
Autodesk.Revit..::ToolbarItemArray
Autodesk.Revit..::ToolbarItemArrayIterator
Autodesk.Revit..::Parameter
Autodesk.Revit..::ParameterMap
Autodesk.Revit..::ParameterMapIterator
Autodesk.Revit..::ParameterSet
Autodesk.Revit..::ParameterSetIterator
Autodesk.Revit..::ParameterStorage
Autodesk.Revit.Events..::DialogBoxData
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Reference
Autodesk.Revit.Geometry..::Plane
Autodesk.Revit.Geometry..::CurveArray
Autodesk.Revit.Geometry..::CurveArrayIterator
Autodesk.Revit.Geometry..::Options
Autodesk.Revit.Geometry..::XYZArray
Autodesk.Revit.Geometry..::XYZArrayIterator
Autodesk.Revit.Geometry..::DoubleArray
Autodesk.Revit.Geometry..::DoubleArrayIterator
Autodesk.Revit.Geometry..::BoundingBoxXYZ
Autodesk.Revit.Geometry..::ReferenceArray
Autodesk.Revit.Geometry..::ReferenceArrayIterator
Autodesk.Revit.Geometry..::FaceArray
Autodesk.Revit.Geometry..::FaceArrayIterator
Autodesk.Revit.Geometry..::IntersectionResultArray
Autodesk.Revit.Geometry..::IntersectionResultArrayIterator
Autodesk.Revit.Geometry..::Transform
Autodesk.Revit.Geometry..::IntersectionResult
Autodesk.Revit.Geometry..::CurveArrArray
Autodesk.Revit.Geometry..::CurveArrArrayIterator
Autodesk.Revit.Geometry..::UVArray
Autodesk.Revit.Geometry..::UVArrayIterator
Autodesk.Revit.Geometry..::EdgeArray
Autodesk.Revit.Geometry..::EdgeArrayIterator
Autodesk.Revit.Geometry..::EdgeArrayArray
Autodesk.Revit.Geometry..::EdgeArrayArrayIterator
Autodesk.Revit.Geometry..::GeometryObjectArray
Autodesk.Revit.Geometry..::GeometryObjectArrayIterator
Autodesk.Revit.Geometry..::MeshTriangle
Autodesk.Revit.Geometry..::InstanceArray
Autodesk.Revit.Geometry..::InstanceArrayIterator
Autodesk.Revit.Geometry..::MeshArray
Autodesk.Revit.Geometry..::MeshArrayIterator
Autodesk.Revit.Geometry..::SolidArray
Autodesk.Revit.Geometry..::SolidArrayIterator
Autodesk.Revit.Elements..::ViewSet
Autodesk.Revit.Elements..::ViewSetIterator
Autodesk.Revit.Elements..::RebarHostData
Autodesk.Revit.Elements..::LoadCaseSet
Autodesk.Revit.Elements..::LoadCaseSetIterator
Autodesk.Revit.Elements..::LoadCaseArray
Autodesk.Revit.Elements..::LoadCaseArrayIterator
Autodesk.Revit.Elements..::LoadUsageArray
Autodesk.Revit.Elements..::LoadUsageArrayIterator
Autodesk.Revit.Elements..::LoadCombinationArray
Autodesk.Revit.Elements..::LoadCombinationArrayIterator
Autodesk.Revit.Elements..::SpaceSet
Autodesk.Revit.Elements..::SpaceSetIterator
Autodesk.Revit.Elements..::PhaseArray
Autodesk.Revit.Elements..::PhaseArrayIterator
Autodesk.Revit.Elements..::ViewSheetSets
Autodesk.Revit.Elements..::ViewSheetSetsIterator
Autodesk.Revit.Elements..::ModelCurveArray
Autodesk.Revit.Elements..::ModelCurveArrayIterator
Autodesk.Revit.Elements..::DetailCurveArray
Autodesk.Revit.Elements..::DetailCurveArrayIterator
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::CurtainCell
Autodesk.Revit.Elements..::CurtainCellSet
Autodesk.Revit.Elements..::CurtainCellSetIterator
Autodesk.Revit.Elements..::CurtainGrid
Autodesk.Revit.Elements..::CurtainGridSet
Autodesk.Revit.Elements..::CurtainGridSetIterator
Autodesk.Revit.Elements..::GenericFormSet
Autodesk.Revit.Elements..::GenericFormSetIterator
Autodesk.Revit.Elements..::ModelCurveArrArray
Autodesk.Revit.Elements..::ModelCurveArrArrayIterator
Autodesk.Revit.Elements..::GroupSet
Autodesk.Revit.Elements..::GroupSetIterator
Autodesk.Revit.Elements..::SketchSet
Autodesk.Revit.Elements..::SketchSetIterator
Autodesk.Revit.Elements..::ElectricalSystemSet
Autodesk.Revit.Elements..::ElectricalSystemSetIterator
Autodesk.Revit.Elements..::ConduitTypeSet
Autodesk.Revit.Elements..::ConduitTypeSetIterator
Autodesk.Revit.Elements..::WireMaterialTypeSet
Autodesk.Revit.Elements..::WireMaterialTypeSetIterator
Autodesk.Revit.Elements..::TemperatureRatingTypeSet
Autodesk.Revit.Elements..::TemperatureRatingTypeSetIterator
Autodesk.Revit.Elements..::InsulationTypeSet
Autodesk.Revit.Elements..::InsulationTypeSetIterator
Autodesk.Revit.Elements..::WireSet
Autodesk.Revit.Elements..::WireSetIterator
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::DefinitionFile
Autodesk.Revit.Parameters..::DefinitionGroup
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::DefinitionsBaseIterator
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ParameterListItemArray
Autodesk.Revit.Parameters..::ParameterListItemArrayIterator
Autodesk.Revit.Parameters..::ParameterListItem
Autodesk.Revit.Parameters..::DefinitionGroupsBase
Autodesk.Revit.Parameters..::DefinitionGroupsBaseIterator
Autodesk.Revit.Collections..::StringStringMap
Autodesk.Revit.Collections..::StringStringMapIterator
Autodesk.Revit.Collections..::DefinitionBindingMap
Autodesk.Revit.Collections..::DefinitionBindingMapIterator
Autodesk.Revit.Collections..::Array
Autodesk.Revit.Collections..::ArrayIterator
Autodesk.Revit.Collections..::Map
Autodesk.Revit.Collections..::MapIterator
Autodesk.Revit.Collections..::Set
Autodesk.Revit.Collections..::SetIterator
Autodesk.Revit.Editor..::SlabShapeCreaseArray
Autodesk.Revit.Editor..::SlabShapeCreaseArrayIterator
Autodesk.Revit.Editor..::SlabShapeVertexArray
Autodesk.Revit.Editor..::SlabShapeVertexArrayIterator
Autodesk.Revit.Creation..::Filter
Autodesk.Revit.Creation..::Application
Autodesk.Revit.Creation..::Document
Autodesk.Revit.Options..::Application
Autodesk.Revit.Symbols..::RebarShapeDefinition
Autodesk.Revit.Symbols..::FamilySymbolSet
Autodesk.Revit.Symbols..::FamilySymbolSetIterator
Autodesk.Revit.Symbols..::WallTypeSet
Autodesk.Revit.Symbols..::WallTypeSetIterator
Autodesk.Revit.Symbols..::FloorTypeSet
Autodesk.Revit.Symbols..::FloorTypeSetIterator
Autodesk.Revit.Symbols..::ContFootingTypeSet
Autodesk.Revit.Symbols..::ContFootingTypeSetIterator
Autodesk.Revit.Symbols..::BeamSystemTypeSet
Autodesk.Revit.Symbols..::BeamSystemTypeSetIterator
Autodesk.Revit.Symbols..::DimensionTypeSet
Autodesk.Revit.Symbols..::DimensionTypeSetIterator
Autodesk.Revit.Symbols..::AnnotationSymbolTypeSet
Autodesk.Revit.Symbols..::AnnotationSymbolTypeSetIterator
Autodesk.Revit.Symbols..::SpotDimensionTypeSet
Autodesk.Revit.Symbols..::SpotDimensionTypeSetIterator
Autodesk.Revit.Symbols..::RebarBarTypeSet
Autodesk.Revit.Symbols..::RebarBarTypeSetIterator
Autodesk.Revit.Symbols..::RebarHookTypeSet
Autodesk.Revit.Symbols..::RebarHookTypeSetIterator
Autodesk.Revit.Symbols..::RebarCoverTypeSet
Autodesk.Revit.Symbols..::RebarCoverTypeSetIterator
Autodesk.Revit.Symbols..::RebarShapeSet
Autodesk.Revit.Symbols..::RebarShapeSetIterator
Autodesk.Revit.Symbols..::LevelTypeSet
Autodesk.Revit.Symbols..::LevelTypeSetIterator
Autodesk.Revit.Symbols..::TextNoteTypeSet
Autodesk.Revit.Symbols..::TextNoteTypeSetIterator
Autodesk.Revit.Symbols..::GridTypeSet
Autodesk.Revit.Symbols..::GridTypeSetIterator
Autodesk.Revit.Symbols..::RoomTagTypeSet
Autodesk.Revit.Symbols..::RoomTagTypeSetIterator
Autodesk.Revit.Symbols..::TrussTypeSet
Autodesk.Revit.Symbols..::TrussTypeSetIterator
Autodesk.Revit.Symbols..::RoofTypeSet
Autodesk.Revit.Symbols..::RoofTypeSetIterator
Autodesk.Revit.Symbols..::SpaceTagTypeSet
Autodesk.Revit.Symbols..::SpaceTagTypeSetIterator
Autodesk.Revit.Symbols..::MullionTypeSet
Autodesk.Revit.Symbols..::MullionTypeSetIterator
Autodesk.Revit.Symbols..::PanelTypeSet
Autodesk.Revit.Symbols..::PanelTypeSetIterator
Autodesk.Revit.Symbols..::CurtainSystemTypeSet
Autodesk.Revit.Symbols..::CurtainSystemTypeSetIterator
Autodesk.Revit.Symbols..::SlabEdgeTypeSet
Autodesk.Revit.Symbols..::SlabEdgeTypeSetIterator
Autodesk.Revit.Symbols..::GutterTypeSet
Autodesk.Revit.Symbols..::GutterTypeSetIterator
Autodesk.Revit.Symbols..::FasciaTypeSet
Autodesk.Revit.Symbols..::FasciaTypeSetIterator
Autodesk.Revit.Symbols..::AreaTagTypeSet
Autodesk.Revit.Symbols..::AreaTagTypeSetIterator
Autodesk.Revit.Symbols..::LoadTypeBaseSet
Autodesk.Revit.Symbols..::LoadTypeBaseSetIterator
Autodesk.Revit.Symbols..::PointLoadTypeSet
Autodesk.Revit.Symbols..::PointLoadTypeSetIterator
Autodesk.Revit.Symbols..::LineLoadTypeSet
Autodesk.Revit.Symbols..::LineLoadTypeSetIterator
Autodesk.Revit.Symbols..::AreaLoadTypeSet
Autodesk.Revit.Symbols..::AreaLoadTypeSetIterator
Autodesk.Revit.Symbols..::DistributionSysTypeSet
Autodesk.Revit.Symbols..::DistributionSysTypeSetIterator
Autodesk.Revit.Symbols..::VoltageTypeSet
Autodesk.Revit.Symbols..::VoltageTypeSetIterator
Autodesk.Revit.Symbols..::WireTypeSet
Autodesk.Revit.Symbols..::WireTypeSetIterator
Autodesk.Revit.Symbols..::MEPBuildingConstructionSet
Autodesk.Revit.Symbols..::MEPBuildingConstructionSetIterator
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::BarDescription
Autodesk.Revit.Structural..::CompoundStructure
Autodesk.Revit.Structural..::AnalyticalSupportData
Autodesk.Revit.Structural..::AnalyticalSupportInfo
Autodesk.Revit.Structural..::AnalyticalSupportInfoArray
Autodesk.Revit.Structural..::AnalyticalSupportInfoArrayIterator
Autodesk.Revit.Structural..::CompoundStructureLayer
Autodesk.Revit.Structural..::CompoundStructureLayerArray
Autodesk.Revit.Structural..::CompoundStructureLayerArrayIterator
Autodesk.Revit.Site..::City
Autodesk.Revit.Site..::CitySet
Autodesk.Revit.Site..::CitySetIterator
Autodesk.Revit.Site..::ProjectPosition
Autodesk.Revit.Site..::ProjectLocationSet
Autodesk.Revit.Site..::ProjectLocationSetIterator
Autodesk.Revit.MEP..::WireSize
Autodesk.Revit.MEP..::CorrectionFactor
Autodesk.Revit.MEP..::GroundConductorSize
Autodesk.Revit.MEP..::DemandFactorData
Autodesk.Revit.MEP..::Connector
Autodesk.Revit.MEP..::ElectricalSetting
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::ConnectorSet
Autodesk.Revit.MEP..::ConnectorSetIterator
Autodesk.Revit.MEP..::ConnectorManager
Autodesk.Revit.MEP..::DemandFactorDataSet
Autodesk.Revit.MEP..::DemandFactorDataSetIterator
Autodesk.Revit.MEP..::WireSizeSet
Autodesk.Revit.MEP..::WireSizeSetIterator
Autodesk.Revit.MEP..::GroundConductorSizeSet
Autodesk.Revit.MEP..::GroundConductorSizeSetIterator
Autodesk.Revit.MEP..::CorrectionFactorSet
Autodesk.Revit.MEP..::CorrectionFactorSetIterator
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetSet
Autodesk.Revit.Utility..::AssetSetIterator
Autodesk.Revit.Rooms..::BoundarySegment
Autodesk.Revit.Rooms..::BoundarySegmentArray
Autodesk.Revit.Rooms..::BoundarySegmentArrayIterator
Autodesk.Revit.Rooms..::BoundarySegmentArrayArray
Autodesk.Revit.Rooms..::BoundarySegmentArrayArrayIterator
Autodesk.Revit.Areas..::BoundarySegment
Autodesk.Revit.Areas..::BoundarySegmentArray
Autodesk.Revit.Areas..::BoundarySegmentArrayIterator
Autodesk.Revit.Areas..::BoundarySegmentArrayArray
Autodesk.Revit.Areas..::BoundarySegmentArrayArrayIterator
Autodesk.Revit.Spaces..::BoundarySegment
Autodesk.Revit.Spaces..::BoundarySegmentArray
Autodesk.Revit.Spaces..::BoundarySegmentArrayIterator
Autodesk.Revit.Spaces..::BoundarySegmentArrayArray
Autodesk.Revit.Spaces..::BoundarySegmentArrayArrayIterator

See Also

APIObject Members
Autodesk.Revit Namespace