DetailCurve Class
See Also Members
CollapseAll image DropDown image

Represents a DetailCurve within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BC135687-9262-4725-990A-467D3610CBB5")]
public class DetailCurve : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BC135687-9262-4725-990A-467D3610CBB5")> _
Public Class DetailCurve _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BC135687-9262-4725-990A-467D3610CBB5")]
public ref class DetailCurve : public Element

Remarks

This is the parent class for detail lines. Currently, the supported detail lines are line, arc, Ellipse, NurbSpline.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailArc
Autodesk.Revit.Elements..::DetailEllipse
Autodesk.Revit.Elements..::DetailLine
Autodesk.Revit.Elements..::DetailNurbSpline

See Also

DetailCurve Members
Autodesk.Revit.Elements Namespace