RebarHookOrientation Enumeration
CollapseAll image DropDown image

Orientation of a rebar hook relative to the path of the Rebar Shape.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5F638191-248D-4e11-9011-478BAEF4DD5D")]
public enum RebarHookOrientation
Visual Basic (Declaration)
<GuidAttribute("5F638191-248D-4e11-9011-478BAEF4DD5D")> _
Public Enumeration RebarHookOrientation
Visual C++
[GuidAttribute(L"5F638191-248D-4e11-9011-478BAEF4DD5D")]
public enum class RebarHookOrientation

Members

Member name | Description
Right | Hook towards the right of a segment-based shape (RebarShapeDefinitionBySegments), or to the exterior of an arc-based shape (RebarShapeDefinitionByArc).
Left | Hook towards the left of a segment-based shape (RebarShapeDefinitionBySegments), or to the interior of an arc-based shape (RebarShapeDefinitionByArc).

See Also

Autodesk.Revit.Structural.Enums Namespace