SaveAs Method

ViewSheetSetting..::SaveAs Method
CollapseAll image DropDown image

Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ newName
)

Parameters

newName
String
view sheet set name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current viewsheetset list, an InvalidOperationException will be thrown.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace