RebarBarType Class
See Also Members
CollapseAll image DropDown image

A Rebar type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("552DD05F-1B14-430b-B15F-430E4397931B")]
public class RebarBarType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("552DD05F-1B14-430b-B15F-430E4397931B")> _
Public Class RebarBarType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"552DD05F-1B14-430b-B15F-430E4397931B")]
public ref class RebarBarType : public Symbol

Remarks

The RebarBarType object contains information about Rebar. Access to these details is made available through built in parameters. The following are parameters that can be used: REBAR_BAR_DIAMETER - diameter of bar, REBAR_BAR_BEND_RADIUS - minimal bend radius of the rebar, MATERIAL_ID_PARAM - identifies the material of which the rebar is made, REBAR_BAR_STYLE - category that is used to represent the Rebar in drawings.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RebarBarType

See Also

RebarBarType Members
Autodesk.Revit.Symbols Namespace