OnDocumentSaved Event

Application..::OnDocumentSaved Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSaved event to be notified after a document is saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved. By subscribing to this event the application will be notified after such an event and can perform an action in reponse.

See Also

Application Class
Autodesk.Revit Namespace