ElectricalSystemType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Pipe System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("FC906532-BAA2-40a1-AACD-1B11ED8A01B5")]
public enum ElectricalSystemType
Visual Basic (Declaration)
<GuidAttribute("FC906532-BAA2-40a1-AACD-1B11ED8A01B5")> _
Public Enumeration ElectricalSystemType
Visual C++
[GuidAttribute(L"FC906532-BAA2-40a1-AACD-1B11ED8A01B5")]
public enum class ElectricalSystemType

Members

Member name | Description
Communication | Electrical System Type is Communication.
Controls | Electrical System Type is Controls.
NurseCall | Electrical System Type is NurseCall.
FireAlarm | Electrical System Type is FireAlarm.
Telephone | Electrical System Type is Telephone.
PowerCircuit | Electrical System Type is PowerCircuit.
Data | Electrical System Type is Data.
Security | Electrical System Type is Security.

See Also

Autodesk.Revit.MEP.Enums Namespace