Options..::DetailLevels Enumeration
CollapseAll image DropDown image

Chooses the detail level of an element's representation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D86E60F7-978E-4be7-B2BD-9A314D4A4796")]
public enum DetailLevels
Visual Basic (Declaration)
<GuidAttribute("D86E60F7-978E-4be7-B2BD-9A314D4A4796")> _
Public Enumeration DetailLevels
Visual C++
[GuidAttribute(L"D86E60F7-978E-4be7-B2BD-9A314D4A4796")]
public enum class DetailLevels

Members

Member name | Description
Fine | Corresponds to the fine view detail setting.
Medium | Corresponds to the medium view detail setting.
Coarse | Corresponds to the coarse view detail setting.
MAX | The value is used to check whether the enum is the same size as the internal one.
Undefined | May produce all or none of the available representations.

Remarks

This corresponds to detail levels in Revit's views and families.

See Also

Autodesk.Revit.Geometry Namespace