Plane Constructor (XYZ, XYZ)
CollapseAll image DropDown image

Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    norm As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane (
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
XYZ
The normal vector of the plane.
origin
XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace