SetPercentageToInfinity Method

DemandFactor..::SetPercentageToInfinity Method
CollapseAll image DropDown image

This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetPercentageToInfinity(
    long minFactor,
    double percentage
)
Visual Basic (Declaration)
Public Sub SetPercentageToInfinity ( _
    minFactor As Long, _
    percentage As Double _
)
Visual C++
public:
void SetPercentageToInfinity (
    long long minFactor,
    double percentage
)

Parameters

minFactor
Int64
Lower boundary of the range.
percentage
Double
Percentage value of this range.

Remarks

Demand factor data items have been obsolete after this operation, so they should be retrieved again before using.

Exceptions

Exception | Condition
System..::ArgumentException | Both parameters can't be negative or positive infinity, otherwise the exception will be thrown.

See Also

DemandFactor Class
Autodesk.Revit.Symbols Namespace