CompoundStructure Class
See Also Members
CollapseAll image DropDown image

An object that describes the multi layered construction of walls or floors.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6854F546-9ECB-4bd4-8F29-50966C4EE037")]
public class CompoundStructure : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6854F546-9ECB-4bd4-8F29-50966C4EE037")> _
Public Class CompoundStructure _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6854F546-9ECB-4bd4-8F29-50966C4EE037")]
public ref class CompoundStructure : public APIObject

Remarks

The CompoundStructure object exposes the layers of elements, such as walls. These layers can be of varying thickness and material, each of which has a dedicated function.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::CompoundStructure

See Also

CompoundStructure Members
Autodesk.Revit.Structural Namespace