VersionNumber Property

ControlledApplication..::VersionNumber Property
CollapseAll image DropDown image

Return the primary version of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string VersionNumber{ get;}
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correct against that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace