LocationCurve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LocationCurve
Visual Basic (Declaration)
Public Class LocationCurve
Visual C++
public ref class LocationCurve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LocationCurveLocationCurveNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve
Autodesk.Revit Namespace