ExternalDefinitions Class
See Also Members
CollapseAll image DropDown image

Supports the creation of new shared parameters definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9D79DF27-F49E-497e-A3EF-D27CFAFB85BB")]
public class ExternalDefinitions : Definitions
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9D79DF27-F49E-497e-A3EF-D27CFAFB85BB")> _
Public Class ExternalDefinitions _
    Inherits Definitions
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9D79DF27-F49E-497e-A3EF-D27CFAFB85BB")]
public ref class ExternalDefinitions : public Definitions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions
Autodesk.Revit.Parameters..::ExternalDefinitions

See Also

ExternalDefinitions Members
Autodesk.Revit.Parameters Namespace