Curve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Curve
Visual Basic (Declaration)
Public Class Curve
Visual C++
public ref class Curve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurveCurveNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | EndParameter | The parameter of the start or the end point of the curve.
Public property | EndPoint | The start or the end point of this curve.
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Transformed | Applies the specified transformation to this curve and returns the result.

See Also

Curve
Autodesk.Revit.Geometry Namespace