Application Methods
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile | Overloaded.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.

Protected Methods

 | Name | Description

See Also

Application
Autodesk.Revit Namespace