SpotDimensionType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a spot dimension in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("33E06682-FB9E-42ab-8493-6DDCFE5485D0")]
public class SpotDimensionType : DimensionType
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("33E06682-FB9E-42ab-8493-6DDCFE5485D0")> _
Public Class SpotDimensionType _
    Inherits DimensionType
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"33E06682-FB9E-42ab-8493-6DDCFE5485D0")]
public ref class SpotDimensionType : public DimensionType

Remarks

The types of a spot dimension can be accessed via this object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::DimensionType
Autodesk.Revit.Symbols..::SpotDimensionType

See Also

SpotDimensionType Members
Autodesk.Revit.Symbols Namespace