AddGeneric Method

Materials..::AddGeneric Method
CollapseAll image DropDown image

Add a generic material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialGeneric AddGeneric(
    string name
)
Visual Basic (Declaration)
Public Function AddGeneric ( _
    name As String _
) As MaterialGeneric
Visual C++
public:
MaterialGeneric^ AddGeneric (
    String^ name
)

Parameters

name
String
The name of the generic material to be added.

Return Value

The pointer to the added generic material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace