DefinitionsBaseIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a definition set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("14B695FD-B958-4378-8D93-C5E09826DADB")]
public abstract class DefinitionsBaseIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("14B695FD-B958-4378-8D93-C5E09826DADB")> _
Public MustInherit Class DefinitionsBaseIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"14B695FD-B958-4378-8D93-C5E09826DADB")]
public ref class DefinitionsBaseIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBaseIterator

See Also

DefinitionsBaseIterator Members
Autodesk.Revit.Parameters Namespace