PrintSetting Class
See Also Members
CollapseAll image DropDown image

Represents the Print Setup (File->Print Setup...) within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5D6B1B6B-73E6-4592-93D2-E98FBAFC6FD4")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PrintSetting : Element
Visual Basic (Declaration)
<GuidAttribute("5D6B1B6B-73E6-4592-93D2-E98FBAFC6FD4")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PrintSetting _
    Inherits Element
Visual C++
[GuidAttribute(L"5D6B1B6B-73E6-4592-93D2-E98FBAFC6FD4")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PrintSetting : public Element

Remarks

The Print Setup object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::PrintSetting

See Also

PrintSetting Members
Autodesk.Revit.Elements Namespace