ProjectLocation Class
See Also Members
CollapseAll image DropDown image

An object that contains the offset location from the site location of the project

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CCDC982E-584B-4f9e-89CE-AE27CC5E7455")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ProjectLocation : Instance
Visual Basic (Declaration)
<GuidAttribute("CCDC982E-584B-4f9e-89CE-AE27CC5E7455")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ProjectLocation _
    Inherits Instance
Visual C++
[GuidAttribute(L"CCDC982E-584B-4f9e-89CE-AE27CC5E7455")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ProjectLocation : public Instance

Remarks

An project may have only one site, but the project may be placed at several locations on that site. This is done by have one site location object and several project location objects. The project location object contains an East to West offset, a North to South offset and an angle of rotation from the original site location. Existing project location objects can be found by using the ProjectLocations property on the Document object. New project locations can be created by duplicating and existing project location using the Duplicate method.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Site..::ProjectLocation

See Also

ProjectLocation Members
Autodesk.Revit.Site Namespace