ConstructionType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("BFF6DBF1-36E6-4564-BA35-663D5172AE11")]
public enum ConstructionType
Visual Basic (Declaration)
<GuidAttribute("BFF6DBF1-36E6-4564-BA35-663D5172AE11")> _
Public Enumeration ConstructionType
Visual C++
[GuidAttribute(L"BFF6DBF1-36E6-4564-BA35-663D5172AE11")]
public enum class ConstructionType

Members

Member name | Description
Skylights | Construction Type is Skylights.
InteriorWindows | Construction Type is InteriorWindows.
ExteriorWindows | Construction Type is ExteriorWindows.
Doors | Construction Type is Doors.
Floors | Construction Type is Floors.
Roofs | Construction Type is Roofs.
Slabs | Construction Type is Slabs.
InteriorWalls | Construction Type is InteriorWalls.
ExteriorWalls | Construction Type is ExteriorWalls.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also

Autodesk.Revit.Parameters Namespace