RebarShapeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeSet
Visual Basic (Declaration)
Public Class RebarShapeSet
Visual C++
public ref class RebarShapeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every rebar shape from the set, rendering it empty.
Public method | Contains | Tests for the existence of a rebar shape within the set.
Public method | Erase | Removes a specified rebar shape from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified rebar shape into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

RebarShapeSet
Autodesk.Revit.Symbols Namespace