RemoveInsulationType Method

TemperatureRatingType..::RemoveInsulationType Method
CollapseAll image DropDown image

Remove an existing insulation type from this temperature rating type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveInsulationType(
    InsulationType insulationType
)
Visual Basic (Declaration)
Public Sub RemoveInsulationType ( _
    insulationType As InsulationType _
)
Visual C++
public:
void RemoveInsulationType (
    InsulationType^ insulationType
)

Parameters

insulationType
InsulationType
Insulation type to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | The last one insulation type of project and any one which is in use by a wire type can't be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.Elements Namespace