Current Property

DefinitionsBaseIterator..::Current Property
CollapseAll image DropDown image

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual Object Current{ get;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable ReadOnly Property Current As Object
Visual C++
[ComVisibleAttribute(false)]
public:
virtual property Object^ Current {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace