ProjectPosition Class
See Also Members
CollapseAll image DropDown image

An object that is used to represent a geographical offset and rotation

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("78F056F4-81A9-4b5b-9CE3-D1439715F4DD")]
public class ProjectPosition : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("78F056F4-81A9-4b5b-9CE3-D1439715F4DD")> _
Public Class ProjectPosition _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"78F056F4-81A9-4b5b-9CE3-D1439715F4DD")]
public ref class ProjectPosition : public APIObject

Remarks

This object is used by the project location object as a convenient way of getting and setting

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::ProjectPosition

See Also

ProjectPosition Members
Autodesk.Revit.Site Namespace