XYZ Constructor (Double, Double, Double)
CollapseAll image DropDown image

Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
Visual C++
public:
XYZ (
    double x,
    double y,
    double z
)

Parameters

x
Double
The first coordinate.
y
Double
The second coordinate.
z
Double
The third coordinate.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace