SolidArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a solids array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("612A8839-5045-4d1b-BF44-8C24F4281CFB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class SolidArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("612A8839-5045-4d1b-BF44-8C24F4281CFB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class SolidArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"612A8839-5045-4d1b-BF44-8C24F4281CFB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SolidArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::SolidArrayIterator

See Also

SolidArrayIterator Members
Autodesk.Revit.Geometry Namespace