GridTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class GridTypeSet
Visual Basic (Declaration)
Public Class GridTypeSet
Visual C++
public ref class GridTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GridTypeSetGridTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every grid type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a grid type within the set.
Public method | Erase | Removes a specified grid type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified grid type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet
Autodesk.Revit.Symbols Namespace