BoundarySegmentArray Class
See Also Members
CollapseAll image DropDown image

An array that contains boundary segments.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FEC80154-DE86-405c-9F25-0EAA2A6E5898")]
public class BoundarySegmentArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FEC80154-DE86-405c-9F25-0EAA2A6E5898")> _
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FEC80154-DE86-405c-9F25-0EAA2A6E5898")]
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Spaces Namespace