Erase Method

Map..::Erase Method
CollapseAll image DropDown image

Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual int Erase(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Object _
) As Integer
Visual C++
public:
virtual int Erase (
    Object^ key
)

Parameters

key
Object
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace