Item Property

EdgeArray..::Item Property
CollapseAll image DropDown image

Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Edge Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Edge
Visual C++
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}

Parameters

index
Int32
The index of the edge to be set or retrieved.

Return Value

Returns the edge at the specified index.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace