Mesh Class
See Also Members
CollapseAll image DropDown image

A triangular mesh.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8B7FFA0D-AA82-4eeb-AFF6-70D2D7FF3845")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Mesh : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("8B7FFA0D-AA82-4eeb-AFF6-70D2D7FF3845")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Mesh _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"8B7FFA0D-AA82-4eeb-AFF6-70D2D7FF3845")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Mesh : public GeometryObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Mesh

See Also

Mesh Members
Autodesk.Revit.Geometry Namespace