Element Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Element
Visual Basic (Declaration)
Public Class Element
Visual C++
public ref class Element

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ElementElementNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Public property | Level | If the element is level based then level to which the element is assigned it returned.
Public property | Location | This property is used to find the physical location of an element within project.
Public property | Name | Returns a human readable name for the Element.
Public property | ObjectType | Returns the instance type of this object.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | PhaseCreated | An object representing the phase when the element is created.
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished.
Public property | Pinned | Informs the developer if an element has been pinned by a user.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance.
Public property | UniqueId | A stable unique identifier for an element within the document.

See Also

Element
Autodesk.Revit Namespace