IExternalApplication Methods
CollapseAll image DropDown image

Syntax

C#
public interface IExternalApplication
Visual Basic (Declaration)
Public Interface IExternalApplication
Visual C++
public interface class IExternalApplication

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | OnShutdown | Provide an interface for the user to do some extra work when Revit closes.
Public method | OnStartup | Provide an interface for the user to do some extra work when Revit starts.

See Also

IExternalApplication
Autodesk.Revit Namespace