PhaseArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class PhaseArrayIterator
Visual Basic (Declaration)
Public MustInherit Class PhaseArrayIterator
Visual C++
public ref class PhaseArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PhaseArrayIteratorPhaseArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.

See Also

PhaseArrayIterator
Autodesk.Revit.Elements Namespace