ModelCurveArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a model curve array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C740DB23-F551-4dea-897B-AA1BE47E770E")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ModelCurveArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("C740DB23-F551-4dea-897B-AA1BE47E770E")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ModelCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"C740DB23-F551-4dea-897B-AA1BE47E770E")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::ModelCurveArrayIterator

See Also

ModelCurveArrayIterator Members
Autodesk.Revit.Elements Namespace