Insert Method

ParameterMap..::Insert Method
CollapseAll image DropDown image

Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    string key,
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert (
    String^ key,
    Parameter^ item
)

Parameters

key
String
The key to be used for inserting the item into the map.
item
Parameter
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace