Faces Property

Solid..::Faces Property
CollapseAll image DropDown image

The faces that belong to the solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FaceArray Faces{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Faces As FaceArray
Visual C++
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}

Remarks

A face may be degenerate. This can be determined with the Face property IsTwoSided.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace