Materials Class
See Also Members
CollapseAll image DropDown image

A set of materials that provides access to the materials in an Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("359D23D8-D459-4d7d-B6B7-25E9396425F1")]
public class Materials : MaterialSet
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("359D23D8-D459-4d7d-B6B7-25E9396425F1")> _
Public Class Materials _
    Inherits MaterialSet
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"359D23D8-D459-4d7d-B6B7-25E9396425F1")]
public ref class Materials : public MaterialSet

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::MaterialSet
Autodesk.Revit..::Materials

See Also

Materials Members
Autodesk.Revit Namespace