RoofTypeSet Class
See Also Members
CollapseAll image DropDown image

A set that contains roof types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6CCBAD8F-EE00-4ddf-BB8F-B8EF805EBE14")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RoofTypeSet : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("6CCBAD8F-EE00-4ddf-BB8F-B8EF805EBE14")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RoofTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"6CCBAD8F-EE00-4ddf-BB8F-B8EF805EBE14")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RoofTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RoofTypeSet

See Also

RoofTypeSet Members
Autodesk.Revit.Symbols Namespace