ProjectUnit Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectUnit
Visual Basic (Declaration)
Public Class ProjectUnit
Visual C++
public ref class ProjectUnit

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectUnitProjectUnitNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | setDigitGroupingType | Set the Digit Grouping Amount, using the three types

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
Public property | DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
Public property | DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Public property | FormatOptions | Get the Format Options of the Project Unit Settings.
Public property | Name | Get and Set the Name property (Overrides Element ..:: Name.)
Public property | Parameter | Overloaded.

See Also

ProjectUnit
Autodesk.Revit.Elements Namespace