MaterialSteel Class
See Also Members
CollapseAll image DropDown image

Represents a steel material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2C4F4CEA-05B4-46b6-800C-2A39344F8F66")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialSteel : Material
Visual Basic (Declaration)
<GuidAttribute("2C4F4CEA-05B4-46b6-800C-2A39344F8F66")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialSteel _
    Inherits Material
Visual C++
[GuidAttribute(L"2C4F4CEA-05B4-46b6-800C-2A39344F8F66")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialSteel : public Material

Remarks

MaterialSteel is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialSteel

See Also

MaterialSteel Members
Autodesk.Revit.Elements Namespace