RemoveFromCircuit Method

ElectricalSystem..::RemoveFromCircuit Method
CollapseAll image DropDown image

remove a set of exist components from the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveFromCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Sub RemoveFromCircuit ( _
    components As ElementSet _
)
Visual C++
public:
void RemoveFromCircuit (
    ElementSet^ components
)

Parameters

components
ElementSet
The components removed from the electrical system.

Remarks

If successful, all the components will remove from the system. Otherwise nothing is removed. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the components parameter Value is null.
System..::InvalidOperationException | Thrown when the components cannot be removed from the system.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace