Filter Class
See Also Members
CollapseAll image DropDown image

The Filter creation object is used to create new instances of element filter utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1D9FA602-01D7-483e-A243-1564DF05E469")]
public class Filter : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1D9FA602-01D7-483e-A243-1564DF05E469")> _
Public Class Filter _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1D9FA602-01D7-483e-A243-1564DF05E469")]
public ref class Filter : public APIObject

Remarks

Elements filter related objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Creation..::Filter

See Also

Filter Members
Autodesk.Revit.Creation Namespace