Autodesk.Revit.Rooms Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Rooms
Visual Basic (Declaration)
Namespace Autodesk.Revit.Rooms
Visual C++
namespace Autodesk.Revit.Rooms

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of a room boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.

Enumerations

 | Enumeration | Description
Public enumeration | BoundaryLocationType | An enumerated type listing the options for volume computation in Autodesk Revit.

BoundaryLocationType Enumeration
CollapseAll image DropDown image

An enumerated type listing the options for volume computation in Autodesk Revit.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D8EDEDB9-A979-48ac-98BE-113C2347818E")]
public enum BoundaryLocationType
Visual Basic (Declaration)
<GuidAttribute("D8EDEDB9-A979-48ac-98BE-113C2347818E")> _
Public Enumeration BoundaryLocationType
Visual C++
[GuidAttribute(L"D8EDEDB9-A979-48ac-98BE-113C2347818E")]
public enum class BoundaryLocationType

Members

Member name | Description
WallCoreCenter | Room area is computed at wall core center.
WallCoreLayer | Room area is computed at wall core layer.
WallCenter | Room area is computed at wall center.
WallFinish | Room area is computed at wall finish.

See Also

Autodesk.Revit.Rooms Namespace