DefinitionFile Class
See Also Members
CollapseAll image DropDown image

The DefinitionFile object represents a shared parameters file on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3636DD8B-2285-494f-BEB8-ED88C76AAA15")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DefinitionFile : APIObject
Visual Basic (Declaration)
<GuidAttribute("3636DD8B-2285-494f-BEB8-ED88C76AAA15")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DefinitionFile _
    Inherits APIObject
Visual C++
[GuidAttribute(L"3636DD8B-2285-494f-BEB8-ED88C76AAA15")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DefinitionFile : public APIObject

Remarks

Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Document.OpenSharedParameterFile method.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionFile

See Also

DefinitionFile Members
Autodesk.Revit.Parameters Namespace