Reflection Property

Transform..::Reflection Property
CollapseAll image DropDown image

The transformation that reflects about the specified plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Transform Reflection[
    Plane plane
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Reflection ( _
    plane As Plane _
) As Transform
Visual C++
public:
static property Transform^ Reflection[Plane^ plane] {
    Transform^ get (Plane^ plane);
}

Parameters

plane
Plane
The plane to reflect about.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the plane is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace