Enabled Property

ToolbarItem..::Enabled Property
CollapseAll image DropDown image

Gets or sets a value indicating whether the button is enabled.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Enabled{ get; set;}
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

When the Enabled property is set to false, the toolbar item cannot be clicked, and the item's appearance changes. The Image and Text assigned to the button appear grayed out.

See Also

ToolbarItem Class
Autodesk.Revit Namespace