ParameterListItem Class
See Also Members
CollapseAll image DropDown image

Object representing list item of external list parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BD4B7BFE-E9F3-45e6-8659-1B0C08A50DF3")]
public class ParameterListItem : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BD4B7BFE-E9F3-45e6-8659-1B0C08A50DF3")> _
Public Class ParameterListItem _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BD4B7BFE-E9F3-45e6-8659-1B0C08A50DF3")]
public ref class ParameterListItem : public APIObject

Remarks

Usually this includes two properties: item string and item value.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::ParameterListItem

See Also

ParameterListItem Members
Autodesk.Revit.Parameters Namespace