MoveNext Method

ElementIterator..::MoveNext Method
CollapseAll image DropDown image

Move the iterator one element forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual bool MoveNext()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Function MoveNext As Boolean
Visual C++
[ComVisibleAttribute(false)]
public:
virtual bool MoveNext ()

Return Value

Returns True if the iterator was successfully moved forward one element and the Current property will return a valid Element. False will be returned it the iterator has reached the end of the project database.

See Also

ElementIterator Class
Autodesk.Revit Namespace