RuledFace Class
See Also Members
CollapseAll image DropDown image

A ruled face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("35418C2A-5FD9-4CB7-B5C6-B3C2E564653B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RuledFace : Face
Visual Basic (Declaration)
<GuidAttribute("35418C2A-5FD9-4CB7-B5C6-B3C2E564653B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RuledFace _
    Inherits Face
Visual C++
[GuidAttribute(L"35418C2A-5FD9-4CB7-B5C6-B3C2E564653B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RuledFace : public Face

Remarks

Ruled faces are defined by ruled surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::RuledFace

See Also

RuledFace Members
Autodesk.Revit.Geometry Namespace