OnDocumentOpened Event

Application..::OnDocumentOpened Event
CollapseAll image DropDown image

Subscribe to the OnDocumentOpened event to be notified after a document has been opened.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been opened. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace