Instance Properties
CollapseAll image DropDown image

Syntax

C#
public class Instance
Visual Basic (Declaration)
Public Class Instance
Visual C++
public ref class Instance

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Transformed | Transforms this instance and returns the result.

See Also

Instance
Autodesk.Revit.Geometry Namespace