Set Class
See Also Members
CollapseAll image DropDown image

A set that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6CA7525A-7C8A-4d18-AD0A-981663E9A0CC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Set : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("6CA7525A-7C8A-4d18-AD0A-981663E9A0CC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Set _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"6CA7525A-7C8A-4d18-AD0A-981663E9A0CC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Set : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::Set

See Also

Set Members
Autodesk.Revit.Collections Namespace