LoadTypeBaseSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadTypeBaseSet
Visual Basic (Declaration)
Public Class LoadTypeBaseSet
Visual C++
public ref class LoadTypeBaseSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadTypeBaseSetLoadTypeBaseSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every load type base from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load type base within the set.
Public method | Erase | Removes a specified load type base from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified load type base into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet
Autodesk.Revit.Symbols Namespace