ElementId Structure
See Also Members
CollapseAll image DropDown image

The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EEF7A1DF-FC31-4bcb-95FB-06B718D37307")]
public struct ElementId
Visual Basic (Declaration)
<GuidAttribute("EEF7A1DF-FC31-4bcb-95FB-06B718D37307")> _
Public Structure ElementId
Visual C++
[GuidAttribute(L"EEF7A1DF-FC31-4bcb-95FB-06B718D37307")]
public value class ElementId

Remarks

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.

See Also

ElementId Members
Autodesk.Revit Namespace