Blend Class
See Also Members
CollapseAll image DropDown image

Provides access to the Blend model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7F9E59E7-1B48-41bc-930A-1A6971064B3B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Blend : GenericForm
Visual Basic (Declaration)
<GuidAttribute("7F9E59E7-1B48-41bc-930A-1A6971064B3B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Blend _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"7F9E59E7-1B48-41bc-930A-1A6971064B3B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Blend : public GenericForm

Remarks

The Blend object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Blend

See Also

Blend Members
Autodesk.Revit.Elements Namespace