NewTruss Method

Document..::NewTruss Method
CollapseAll image DropDown image

Creates a New Truss.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Truss NewTruss(
    TrussType trussType,
    SketchPlane sketchPlane,
    Curve baseCurve,
    View dbView
)
Visual Basic (Declaration)
Public Function NewTruss ( _
    trussType As TrussType, _
    sketchPlane As SketchPlane, _
    baseCurve As Curve, _
    dbView As View _
) As Truss
Visual C++
public:
Truss^ NewTruss (
    TrussType^ trussType,
    SketchPlane^ sketchPlane,
    Curve^ baseCurve,
    View^ dbView
)

Parameters

trussType
TrussType
The type for truss.
sketchPlane
SketchPlane
The sketch plane the truss is going to be reside in.It could be nullptr.
baseCurve
Curve
The curve that represents truss's base curve. It must be a line, must not be a vertical line, must be within the sketch plane if sketchPlane is valid.
dbView
View
The DBView where truss's tag going to be placed. A valid dbViewId must be a Plan view or RPlan view, or an elevation view paralleling to the truss base curve.

See Also

Document Class
Autodesk.Revit.Creation Namespace