RoofTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a roof type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("45AD0B09-B726-4ef9-B37D-B84C9F9E6213")]
public abstract class RoofTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("45AD0B09-B726-4ef9-B37D-B84C9F9E6213")> _
Public MustInherit Class RoofTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"45AD0B09-B726-4ef9-B37D-B84C9F9E6213")]
public ref class RoofTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RoofTypeSetIterator

See Also

RoofTypeSetIterator Members
Autodesk.Revit.Symbols Namespace