NewAnnotationSymbol Method

Document..::NewAnnotationSymbol Method
CollapseAll image DropDown image

Add a new instance of a Annotation Symbol into the Autodesk Revit project, using a location and a symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnnotationSymbol NewAnnotationSymbol(
    XYZ location,
    AnnotationSymbolType annotationSymbolType,
    View specView
)
Visual Basic (Declaration)
Public Function NewAnnotationSymbol ( _
    location As XYZ, _
    annotationSymbolType As AnnotationSymbolType, _
    specView As View _
) As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ NewAnnotationSymbol (
    XYZ^ location,
    AnnotationSymbolType^ annotationSymbolType,
    View^ specView
)

Parameters

location
XYZ
The physical location where the annotation symbol is to be placed.
annotationSymbolType
AnnotationSymbolType
A annotation symbol type object that represents the type of the instance that is to be inserted.
specView
View
a 2D view which display the annotation symbol.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

See Also

Document Class
Autodesk.Revit.Creation Namespace