PlanCircuit Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PlanCircuit
Visual Basic (Declaration)
Public Class PlanCircuit
Visual C++
public ref class PlanCircuit

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PlanCircuitPlanCircuitNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Area | The enclosed area of the circuit.
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.

See Also

PlanCircuit
Autodesk.Revit Namespace