FamilyInstance Methods
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstance
Visual Basic (Declaration)
Public Class FamilyInstance
Visual C++
public ref class FamilyInstance

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Change the room to which the door or window is opened.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopings | Lists the elements currently used as coping cutters for this element.
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
Public method | SetCopings | Specify the set of coping cutters on this element.

Protected Methods

 | Name | Description

See Also

FamilyInstance
Autodesk.Revit.Elements Namespace