DetailEllipse Class
See Also Members
CollapseAll image DropDown image

Represents a DetailEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("89B5AF3A-2E2F-4094-9686-25970F4528C2")]
public class DetailEllipse : DetailCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("89B5AF3A-2E2F-4094-9686-25970F4528C2")> _
Public Class DetailEllipse _
    Inherits DetailCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"89B5AF3A-2E2F-4094-9686-25970F4528C2")]
public ref class DetailEllipse : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailEllipse

See Also

DetailEllipse Members
Autodesk.Revit.Elements Namespace