Multiply Operator

XYZ..::Multiply Operator
CollapseAll image DropDown image

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator *(
    double value,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator * (
    double value,
    XYZ^ right
)

Parameters

value
Double
The value to multiply with the specified vector.
right
XYZ
The vector to multiply with the value.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace