VolumeCalculationOptions Members
See Also Methods Constructors Fields Properties
CollapseAll image DropDown image

Syntax

C#
public class VolumeCalculationOptions
Visual Basic (Declaration)
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | VolumeCalculationOptionsVolumeCalculationOptionsNew | Creates a new instance of the volume calculation options.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Fields

 | Name | Description
Public field | RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
Public field | VolumeComputationEnbale | Deprecated; this field will be removed in future release of the Revit API. Use VolumeComputationEnable instead.

Public Properties

 | Name | Description
Public property | VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions
Autodesk.Revit Namespace