Category Class
See Also Members
CollapseAll image DropDown image

Represents the category or sub category to which an element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5D5097B8-00A6-4afc-A125-9DB1A484C869")]
public class Category : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5D5097B8-00A6-4afc-A125-9DB1A484C869")> _
Public Class Category _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5D5097B8-00A6-4afc-A125-9DB1A484C869")]
public ref class Category : public APIObject

Remarks

Categories are an import tool within Revit for identifying the inferred type of an element, such as anything in the Walls category should be considered as a wall. The API exposes access to the built in categories within Revit via the Document.Settings.Categories property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Category

See Also

Category Members
Autodesk.Revit Namespace