GUID Property

ExternalDefinition..::GUID Property
CollapseAll image DropDown image

Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Guid GUID{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property GUID As Guid
Visual C++
public:
virtual property Guid GUID {
    Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace