ElementIterator Class
See Also Members
CollapseAll image DropDown image

An iterator object that enable access to every element within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8329CDF1-D3B5-4829-AB8A-6071F7D7A2B8")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElementIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("8329CDF1-D3B5-4829-AB8A-6071F7D7A2B8")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElementIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"8329CDF1-D3B5-4829-AB8A-6071F7D7A2B8")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementIterator : public APIObject,
    IEnumerator

Remarks

The Autodesk Revit may contain a very large number of elements so iteration can be very time consuming. The elements that are accessible by this iterator are not only the visible elements within the project, but also those that cannot be seen, such as family types, wall types, group types etc. This is a forward seeking iterator.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementIterator

See Also

ElementIterator Members
Autodesk.Revit Namespace