MEPSpaceConstruction Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class MEPSpaceConstruction
Visual Basic (Declaration)
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MEPSpaceConstructionMEPSpaceConstructionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | DeleteConstruction | Remove a existent construction from Space constructions.
Public method | DuplicateConstruction | Create a new construction for Space constructions.
Public method | NewConstruction | Create a new construction for Space constructions.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
Public property | SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction
Autodesk.Revit Namespace