Insert Method

ReferenceArray..::Insert Method
CollapseAll image DropDown image

Insert the specified reference into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void Insert(
    Reference item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Reference, _
    index As Integer _
)
Visual C++
public:
virtual void Insert (
    Reference^ item,
    int index
)

Parameters

item
Reference
The reference to be inserted into the array.
index
Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace