Sweep Class
See Also Members
CollapseAll image DropDown image

Provides access to the Sweep model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("48510B8A-21BA-4675-A297-CEB88F1EC7FC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Sweep : GenericForm
Visual Basic (Declaration)
<GuidAttribute("48510B8A-21BA-4675-A297-CEB88F1EC7FC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Sweep _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"48510B8A-21BA-4675-A297-CEB88F1EC7FC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Sweep : public GenericForm

Remarks

The Sweep object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Sweep

See Also

Sweep Members
Autodesk.Revit.Elements Namespace