CheckDefaultParameterValues Method

RebarShapeDefinition..::CheckDefaultParameterValues Method
CollapseAll image DropDown image

Check that the shape can be solved with the default parameter values.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiam
)
Visual Basic (Declaration)
Public Function CheckDefaultParameterValues ( _
    bendRadius As Double, _
    barDiam As Double _
) As Boolean
Visual C++
public:
bool CheckDefaultParameterValues (
    double bendRadius,
    double barDiam
)

Parameters

bendRadius
Double
barDiam
Double

Remarks

This function runs the rebar solver with the default parameter values. If it fails (returns false), rebar instances of this shape will not work. This may be from the default parameters being inconsistent, or from some error in the shape definition. The solver requires a specific bend radius and bar diameter, and the result depends on these values, but in practice they usually do not affect the result of this function as long as they are small. It is legal to pass 0.0 for both arguments. The definition must be Complete in order for this function to succeed. This function can be called before or after Commit().

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace