TrussMemberType Enumeration
CollapseAll image DropDown image

Indicates the "kind" of a truss member.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67567F4C-44A3-40ec-A515-070A34BAE392")]
public enum TrussMemberType
Visual Basic (Declaration)
<GuidAttribute("67567F4C-44A3-40ec-A515-070A34BAE392")> _
Public Enumeration TrussMemberType
Visual C++
[GuidAttribute(L"67567F4C-44A3-40ec-A515-070A34BAE392")]
public enum class TrussMemberType

Members

Member name | Description
ETK_TrussDiagWeb | Truss DiagWeb.
ETK_TrussVertWeb | Truss VertWeb.
ETK_TrussBottomChord | Truss bottom chord.
ETK_TrussTopChord | Truss top chord.
ETK_Unknown | Unknown element type.

See Also

Autodesk.Revit.Enums Namespace