NewTypeBinding Method

Application..::NewTypeBinding Method
CollapseAll image DropDown image

Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeBinding NewTypeBinding()
Visual Basic (Declaration)
Public Function NewTypeBinding As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding ()

Return Value

Returns a new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
Autodesk.Revit.Creation Namespace