PropOverrideMode Enumeration
CollapseAll image DropDown image

An enumerate type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D1B98627-ADE8-4600-9837-CD7AF47AD6DC")]
public enum PropOverrideMode
Visual Basic (Declaration)
<GuidAttribute("D1B98627-ADE8-4600-9837-CD7AF47AD6DC")> _
Public Enumeration PropOverrideMode
Visual C++
[GuidAttribute(L"D1B98627-ADE8-4600-9837-CD7AF47AD6DC")]
public enum class PropOverrideMode

Members

Member name | Description
NewLayer | All properties BYLAYER, New Layers for overrides.
ByLayer | All properties BYLAYER, no overrides.
ByEntity | Category properties BYLAYER, overrides BYENTITY.

See Also

Autodesk.Revit.Enums Namespace