AddGridLine Method

CurtainGrid..::AddGridLine Method
CollapseAll image DropDown image

Add a GridLine to the CurtainGrid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddGridLine ( _
    isUGridLine As Boolean, _
    position As XYZ, _
    oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine (
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)

Parameters

isUGridLine
Boolean
Specify the direction of the grid line. If it is true, a U-direction grid line will be added. Otherwise, V-direction grid line will be added.
position
XYZ
specify the position of the grid line. If the param to locate the Gridline (which is calculated by the input position)-is out of range, throw invalid argument exception.
oneSegmentOnly
Boolean
If it is true, only one segment is added. Otherwise, all segments will be added

Return Value

The created CurtainGridLine is returned if the operation is successful. Otherwise, nullptr is returned.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace