Autodesk.Revit.Parameters Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Parameters
Visual Basic (Declaration)
Namespace Autodesk.Revit.Parameters
Visual C++
namespace Autodesk.Revit.Parameters

Classes

 | Class | Description
Public class | Binding | Binding objects are used to take a parameter definition and bind it to one or more categories.
Public class | BindingMap | The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Public class | Definition | The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Public class | DefinitionFile | The DefinitionFile object represents a shared parameters file on disk.
Public class | DefinitionGroup | The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Public class | DefinitionGroups | A specialised set of definition groups that allows creation of new groups.
Public class | DefinitionGroupsBase | A set that contains definition groups.
Public class | DefinitionGroupsBaseIterator | An iterator to a definition group set.
Public class | Definitions | A base class that supports the addition of new parameter definitions.
Public class | DefinitionsBase | A set that contains definitions.
Public class | DefinitionsBaseIterator | An iterator to a definition set.
Public class | ElementBinding | A base class for all types of binding that attach to an element.
Public class | ExternalDefinition | The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Public class | ExternalDefinitions | Supports the creation of new shared parameters definitions.
Public class | InstanceBinding | The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Public class | InternalDefinition | This object represent a parameter definition built into Autodesk Revit.
Public class | InternalDefinitions | This object blocks attempts to create new internal definitions as they are not permitted.
Public class | ParameterListItem | Object representing list item of external list parameter.
Public class | ParameterListItemArray | An array that can contain any type of object.
Public class | ParameterListItemArrayIterator | An iterator to a array.
Public class | TypeBinding | TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Enumerations

 | Enumeration | Description
Public enumeration | BuildingType | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | BuiltInParameter | An enumerate type listing all of the built-in parameter ids supported by Autodesk Revit.
Public enumeration | BuiltInParameterGroup | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | ConstructionType | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | ParameterType | An enumerate type listing all of the data type interpretation that Autodesk Revit supports.
Public enumeration | ServiceType | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | StorageType | An enumerate type listing all of the internal parameter data storage types that Autodesk Revit supports.

Binding Class
See Also Members
CollapseAll image DropDown image

Binding objects are used to take a parameter definition and bind it to one or more categories.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6EE2D12A-CF9F-46b4-8124-028D858A2242")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class Binding : APIObject
Visual Basic (Declaration)
<GuidAttribute("6EE2D12A-CF9F-46b4-8124-028D858A2242")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class Binding _
    Inherits APIObject
Visual C++
[GuidAttribute(L"6EE2D12A-CF9F-46b4-8124-028D858A2242")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Binding abstract : public APIObject

Remarks

This class is a base class for all types of parameter binding within Autodesk Revit. Once the binging objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not effect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding

See Also

Binding Members
Autodesk.Revit.Parameters Namespace