Ellipse Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Ellipse
Visual Basic (Declaration)
Public Class Ellipse
Visual C++
public ref class Ellipse

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | EllipseEllipseNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Center | Returns the center of the ellipse.
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.

See Also

Ellipse
Autodesk.Revit.Geometry Namespace