PlaceGroup Method

Document..::PlaceGroup Method
CollapseAll image DropDown image

Place an instance of a Model Group into the Autodesk Revit project, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Visual Basic (Declaration)
Public Function PlaceGroup ( _
    location As XYZ, _
    groupType As GroupType _
) As Group
Visual C++
public:
Group^ PlaceGroup (
    XYZ^ location,
    GroupType^ groupType
)

Parameters

location
XYZ
The physical location where the group is to be placed.
groupType
GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

If creation was successful then an instance to the new group is returned, otherwise Nothing.

Remarks

This method is used to place a new instance of an existing group type within the project. The group's origin will placed at the point specified by the location. All group types within the project can be found by iterating over the document and looking for elements of type Autodesk.Revit.Symbols.GroupType.

See Also

Document Class
Autodesk.Revit.Creation Namespace