APIObject Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

Syntax

C#
public class APIObject
Visual Basic (Declaration)
Public Class APIObject
Visual C++
public ref class APIObject

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | APIObjectAPIObjectNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Dispose | Overloaded.

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.
Protected method | Finalize | (Overrides Object ..:: Finalize()().)
Protected method | ReleaseManagedResources |
Protected method | ReleaseUnmanagedResources |

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject
Autodesk.Revit Namespace