ExportUnit Enumeration
CollapseAll image DropDown image

An enumerate type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B282C4EE-5552-4bb4-89CB-B8EFC68668C8")]
public enum ExportUnit
Visual Basic (Declaration)
<GuidAttribute("B282C4EE-5552-4bb4-89CB-B8EFC68668C8")> _
Public Enumeration ExportUnit
Visual C++
[GuidAttribute(L"B282C4EE-5552-4bb4-89CB-B8EFC68668C8")]
public enum class ExportUnit

Members

Member name | Description
Default | Default export unit. Depends on Revit's current units.
Meter | Meters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.

See Also

Autodesk.Revit.Enums Namespace