Family Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Family
Visual Basic (Declaration)
Public Class Family
Visual C++
public ref class Family

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyFamilyNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Components | A set of all components that belong to a Family.
Public property | LoadedSymbols | A set of all family symbols loaded in a Family.
Public property | Others | A set of all other components that belong to a Family.
Public property | Parameter | Overloaded.
Public property | SolidForms | A set of all solid forms that belong to a Family.
Public property | Symbols | A set of all symbols (types) that belong to a Family.
Public property | VoidForms | A set of all void forms that belong to a Family.

See Also

Family
Autodesk.Revit.Elements Namespace