ViewSheetSetting Class
See Also Members
CollapseAll image DropDown image

Represents the View/Sheet Set (File->Print) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2845E150-DC15-4a01-8069-50F0DA9BBD6B")]
public class ViewSheetSetting : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2845E150-DC15-4a01-8069-50F0DA9BBD6B")> _
Public Class ViewSheetSetting _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2845E150-DC15-4a01-8069-50F0DA9BBD6B")]
public ref class ViewSheetSetting : public APIObject

Remarks

The View/Sheet Setting object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ViewSheetSetting

See Also

ViewSheetSetting Members
Autodesk.Revit Namespace