AddConcrete Method

Materials..::AddConcrete Method
CollapseAll image DropDown image

Add a concrete material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialConcrete AddConcrete(
    string name
)
Visual Basic (Declaration)
Public Function AddConcrete ( _
    name As String _
) As MaterialConcrete
Visual C++
public:
MaterialConcrete^ AddConcrete (
    String^ name
)

Parameters

name
String
The name of the concrete material to be added.

Return Value

The pointer to the added concrete material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace