ConnectorType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Connector type for the Connection.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4A24A235-D0BF-49fe-BE54-CDD37D791E34")]
public enum ConnectorType
Visual Basic (Declaration)
<GuidAttribute("4A24A235-D0BF-49fe-BE54-CDD37D791E34")> _
Public Enumeration ConnectorType
Visual C++
[GuidAttribute(L"4A24A235-D0BF-49fe-BE54-CDD37D791E34")]
public enum class ConnectorType

Members

Member name | Description
AllConnectorModes | Connection Type is All Connector Modes.
NonEndConn | Connection Type is Non End Connection.
PhysicalConn | Connection Type is Physical Connection.
LogicalConn | Connection Type is Logical Connection.
CurveConn | Connection Type is Curve Connection.
EndConn | Connection Type is End Connection.
InvalidConnectorType | Connection Type is Invalid.

See Also

Autodesk.Revit.MEP.Enums Namespace