Line Class
See Also Members
CollapseAll image DropDown image

A line in space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("35969067-89A2-4576-8017-E17D0B1B4370")]
public class Line : Curve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("35969067-89A2-4576-8017-E17D0B1B4370")> _
Public Class Line _
    Inherits Curve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"35969067-89A2-4576-8017-E17D0B1B4370")]
public ref class Line : public Curve

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Line

See Also

Line Members
Autodesk.Revit.Geometry Namespace