Profile Class
See Also Members
CollapseAll image DropDown image

A geometric profile consisting of a loop of curves.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D09109A0-1049-43d1-9273-6514A0A245B2")]
public class Profile : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D09109A0-1049-43d1-9273-6514A0A245B2")> _
Public Class Profile _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D09109A0-1049-43d1-9273-6514A0A245B2")]
public ref class Profile : public GeometryObject

Remarks

The profile may be filled.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Profile

See Also

Profile Members
Autodesk.Revit.Geometry Namespace