ModelHermiteSpline Class
See Also Members
CollapseAll image DropDown image

Represents a ModelHermiteSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EFA7BF12-F113-491d-AA62-6E83098D336B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ModelHermiteSpline : ModelCurve
Visual Basic (Declaration)
<GuidAttribute("EFA7BF12-F113-491d-AA62-6E83098D336B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ModelHermiteSpline _
    Inherits ModelCurve
Visual C++
[GuidAttribute(L"EFA7BF12-F113-491d-AA62-6E83098D336B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelHermiteSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelHermiteSpline

See Also

ModelHermiteSpline Members
Autodesk.Revit.Elements Namespace