BoundingBox Property

Element..::BoundingBox Property
CollapseAll image DropDown image

Retrieves a box that circumscribes all geometry of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxXYZ BoundingBox[
    View
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property BoundingBox ( _
     As View _
) As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ BoundingBox[View^ ] {
    BoundingBoxXYZ^ get (View^ );
}

Parameters

View

Remarks

Pass in a view to query view-specific (e.g., cut) geometry or null for model geometry. If view box is not known, will return model box; if model box is not known, will return null.

See Also

Element Class
Autodesk.Revit Namespace