ChangePanelType Method

CurtainGrid..::ChangePanelType Method
CollapseAll image DropDown image

Change type of a curtain panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element ChangePanelType(
    Element panel,
    Symbol newSymbol
)
Visual Basic (Declaration)
Public Function ChangePanelType ( _
    panel As Element, _
    newSymbol As Symbol _
) As Element
Visual C++
public:
Element^ ChangePanelType (
    Element^ panel,
    Symbol^ newSymbol
)

Parameters

panel
Element
The panel to be changed, it can be a type of Panel or a Wall.
newSymbol
Symbol
The new symbol, it may be PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the resulted element of Autodesk.Revit.Elements.Panel or Autodesk.Revit.Elements.Wall is returned.

Exceptions

Exception | Condition
System..::ArgumentException | If the input newSymbol is a WallType but the panel is hosted in a CurtainSystem, ArgumentException will be thrown.
System..::InvalidOperationException | Internal fails to change the type or regeneration fails.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace