SolidGeometry Enumeration
CollapseAll image DropDown image

An enumerate type listing possible ways of exporting solids in 3D views.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5BA62B01-1E40-4813-A03F-D708FBFC8AB8")]
public enum SolidGeometry
Visual Basic (Declaration)
<GuidAttribute("5BA62B01-1E40-4813-A03F-D708FBFC8AB8")> _
Public Enumeration SolidGeometry
Visual C++
[GuidAttribute(L"5BA62B01-1E40-4813-A03F-D708FBFC8AB8")]
public enum class SolidGeometry

Members

Member name | Description
ACIS | All visible Revit Building geometry is exported as ACIS 3D solids (except for any elements that are already a polymesh.)
Polymesh | All visible solids are exported as polymesh.

See Also

Autodesk.Revit.Enums Namespace