RectangularWallCreationData Constructor (Curve, Level, Boolean)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData (
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace