MaterialWood Class
See Also Members
CollapseAll image DropDown image

Represents a wood material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3967F6E1-8FFB-4377-9FDE-FCF0A291D593")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialWood : Material
Visual Basic (Declaration)
<GuidAttribute("3967F6E1-8FFB-4377-9FDE-FCF0A291D593")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialWood _
    Inherits Material
Visual C++
[GuidAttribute(L"3967F6E1-8FFB-4377-9FDE-FCF0A291D593")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialWood : public Material

Remarks

MaterialWood is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialWood

See Also

MaterialWood Members
Autodesk.Revit.Elements Namespace