Document Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DocumentDocumentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | NewAnnotationSymbol | Add a new instance of a Annotation Symbol into the Autodesk Revit project, using a location and a symbol.
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions | Overloaded.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreaLoad | Overloaded.
Public method | NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
Public method | NewAreas |
Public method | NewAreaTag | Creates a new area tag.
Public method | NewAreaViewPlan | Creates a new view for the new area.
Public method | NewBeamSystem | Overloaded.
Public method | NewCurtainSystem | Overloaded.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension | Overloaded.
Public method | NewElectricalSystem | Overloaded.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance | Overloaded.
Public method | NewFamilyInstances |
Public method | NewFascia | Overloaded.
Public method | NewFloor | Overloaded.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFoundationWall | Creates a new continuous footing object.
Public method | NewGrid | Overloaded.
Public method | NewGrids | Creates new grid lines.
Public method | NewGroup | Creates a new type of group.
Public method | NewGutter | Overloaded.
Public method | NewLevel | Creates a new level.
Public method | NewLineBoundaryConditions | Overloaded.
Public method | NewLineLoad | Overloaded.
Public method | NewLoadCase | Creates a new instance of a LoadCase element within the project.
Public method | NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
Public method | NewLoadNature | Creates a new instance of a LoadNature element within the project.
Public method | NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewOpening | Overloaded.
Public method | NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewPointLoad | Overloaded.
Public method | NewRebar | Overloaded.
Public method | NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | NewRoom | Overloaded.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms | Overloaded.
Public method | NewRoomTag | Creates a new RoomTag.
Public method | NewSketchPlane | Creates a new sketch plane.
Public method | NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
Public method | NewSlabEdge | Overloaded.
Public method | NewSpace | Overloaded.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces | Overloaded.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTag | Creates a new IndependentTag Element.
Public method | NewTextNote | Overloaded.
Public method | NewTextNotes |
Public method | NewTruss | Creates a New Truss.
Public method | NewView3D | Creates a new 3D view.
Public method | NewViewDrafting | Creates a new drafting view.
Public method | NewViewPlan | Creates a plan view based on the specified level.
Public method | NewViewSection | Creates a new section view.
Public method | NewViewSheet | Creates a new sheet view.
Public method | NewWall | Overloaded.
Public method | NewWalls | Overloaded.
Public method | NewWire | Creates a new wire element.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit project, using a location and a group type.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description

See Also

Document
Autodesk.Revit.Creation Namespace