ConicalFace Class
See Also Members
CollapseAll image DropDown image

A cone face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D1870B7F-BD63-4046-8E09-3DE05846FCBA")]
public class ConicalFace : Face
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D1870B7F-BD63-4046-8E09-3DE05846FCBA")> _
Public Class ConicalFace _
    Inherits Face
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D1870B7F-BD63-4046-8E09-3DE05846FCBA")]
public ref class ConicalFace : public Face

Remarks

Cone faces are defined by cone surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + v*[sin(HalfAngle)*(cos(u)*Radius[0] + sin(u)*Radius[1]) + cos(HalfAngle)*Axis]

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::ConicalFace

See Also

ConicalFace Members
Autodesk.Revit.Geometry Namespace