Autodesk.Revit.Spaces Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Spaces
Visual Basic (Declaration)
Namespace Autodesk.Revit.Spaces
Visual C++
namespace Autodesk.Revit.Spaces

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of a aream boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.

BoundarySegment Class
See Also Members
CollapseAll image DropDown image

An object that represents a segment of a aream boundary.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E9425E24-11E1-44b3-A1B2-379B64CE813B")]
public class BoundarySegment : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E9425E24-11E1-44b3-A1B2-379B64CE813B")> _
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E9425E24-11E1-44b3-A1B2-379B64CE813B")]
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a aream. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Spaces Namespace