MenuItem..::MenuType Enumeration
CollapseAll image DropDown image

Type of menu to be created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("ED952F57-3F78-4399-B4CD-30E8A380CD6B")]
public enum MenuType
Visual Basic (Declaration)
<GuidAttribute("ED952F57-3F78-4399-B4CD-30E8A380CD6B")> _
Public Enumeration MenuType
Visual C++
[GuidAttribute(L"ED952F57-3F78-4399-B4CD-30E8A380CD6B")]
public enum class MenuType

Members

Member name | Description
SeparatorMenu | Menu used to separate other menus
PopupMenu | Pop up menu which can have sub menus.
BasicMenu | Standard menu associated with a command.

Remarks

There are three types of menu which can be created when Revit is at startup.

See Also

Autodesk.Revit Namespace