AssetPropertyType Enumeration
CollapseAll image DropDown image

An enumerate to list AssetProperty Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("83D31B2F-81AA-4572-A4CB-705D5573184D")]
public enum AssetPropertyType
Visual Basic (Declaration)
<GuidAttribute("83D31B2F-81AA-4572-A4CB-705D5573184D")> _
Public Enumeration AssetPropertyType
Visual C++
[GuidAttribute(L"83D31B2F-81AA-4572-A4CB-705D5573184D")]
public enum class AssetPropertyType

Members

Member name | Description
APT_Last |
APT_Reference |
APT_Asset |
APT_Distance |
APT_Time |
APT_String |
APT_Double44 | AssetPropertyDoubleMatrix44.
APT_DoubleArray4d | AssetPropertyDoubleArray4d.
APT_DoubleArray3d | AssetPropertyDoubleArray3d.
APT_DoubleArray2d | AssetPropertyDoubleArray2d.
APT_Double | AssetPropertyDouble.
APT_Float |
APT_Integer |
APT_Enum |
APT_Boolean |
APT_Properties |
APT_Unknown |

See Also

Autodesk.Revit.Enums Namespace