GetAllTopMenus Method

Application..::GetAllTopMenus Method
CollapseAll image DropDown image

Returns all of the top level menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual void GetAllTopMenus(
    ref Array topMenus
)
Visual Basic (Declaration)
Public Overridable Sub GetAllTopMenus ( _
    ByRef topMenus As Array _
)
Visual C++
public:
virtual void GetAllTopMenus (
    Array^% topMenus
)

Parameters

topMenus
Array %
This is an output argument, which will include all the main menu items of Revit.

Remarks

All the items included in the main menu of Revit will be returned in the output arguments topMenus.

See Also

Application Class
Autodesk.Revit Namespace