ProjectLocation Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocation
Visual Basic (Declaration)
Public Class ProjectLocation
Visual C++
public ref class ProjectLocation

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectLocationProjectLocationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Generate a copy of this project location with the specified name.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Name | Get or Set the Name of the Project location. (Overrides Element ..:: Name.)
Public property | Parameter | Overloaded.
Public property | ProjectPosition | Get or set the project position in relation to the site position
Public property | SiteLocation | Get the site location to which this project location refers.

See Also

ProjectLocation
Autodesk.Revit.Site Namespace