RebarShapeDefinitionBySegments Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinitionBySegments
Visual Basic (Declaration)
Public Class RebarShapeDefinitionBySegments
Visual C++
public ref class RebarShapeDefinitionBySegments

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddBendDefaultRadius | Specify a default-radius bend.
Public method | AddBendVariableRadius | Specify a variable-radius bend.
Public method | AddConstraintParallelToSegment |
Public method | AddConstraintToSegment | Add a constraint that determines the length of a segment.
Public method | AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Public method | RemoveParameterFromSegment | Remove constraints from a segment.
Public method | SetSegmentAs180DegreeBend | Overloaded.
Public method | SetSegmentFixedDirection | Fix the direction of a segment.
Public method | SetSegmentVariableDirection | Remove the fixed direction from a segment.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides RebarShapeDefinition ..:: Dispose(Boolean).)

See Also

RebarShapeDefinitionBySegments
Autodesk.Revit.Symbols Namespace