ProjectInfo Class
See Also Members
CollapseAll image DropDown image

An object that represents a Project Information within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CC6BAA47-01CD-40a2-8660-CCE3262C24D6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ProjectInfo : Element
Visual Basic (Declaration)
<GuidAttribute("CC6BAA47-01CD-40a2-8660-CCE3262C24D6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ProjectInfo _
    Inherits Element
Visual C++
[GuidAttribute(L"CC6BAA47-01CD-40a2-8660-CCE3262C24D6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ProjectInfo : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ProjectInfo

See Also

ProjectInfo Members
Autodesk.Revit.Elements Namespace