GutterType Class
See Also Members
CollapseAll image DropDown image

An object that represents the gutter type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DC5650E9-9275-4702-B80A-72BD7AB1A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GutterType : HostedSweepType
Visual Basic (Declaration)
<GuidAttribute("DC5650E9-9275-4702-B80A-72BD7AB1A7B7")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GutterType _
    Inherits HostedSweepType
Visual C++
[GuidAttribute(L"DC5650E9-9275-4702-B80A-72BD7AB1A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GutterType : public HostedSweepType

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::HostedSweepType
Autodesk.Revit.Symbols..::GutterType

See Also

GutterType Members
Autodesk.Revit.Symbols Namespace