Autodesk.Revit.Symbols Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Symbols
Visual Basic (Declaration)
Namespace Autodesk.Revit.Symbols
Visual C++
namespace Autodesk.Revit.Symbols

Classes

 | Class | Description
Public class | AnnotationSymbolType | An object that represents a dimension style.
Public class | AnnotationSymbolTypeSet | A set that contains AnnotationSymbol types.
Public class | AnnotationSymbolTypeSetIterator | An iterator to a AnnotationSymbol type set.
Public class | AreaLoadType | An object that represents a dimension style.
Public class | AreaLoadTypeSet | A set that contains areaload types.
Public class | AreaLoadTypeSetIterator | An iterator to a areaload type set.
Public class | AreaReinforcementType | An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
Public class | AreaTagType | An object that represents a dimension style.
Public class | AreaTagTypeSet | A set that contains areatag types.
Public class | AreaTagTypeSetIterator | An iterator to a areatag type set.
Public class | BeamSystemType | An object that specifies the type of a beam system in Autodesk Revit.
Public class | BeamSystemTypeSet | A set that contains BeamSystem types.
Public class | BeamSystemTypeSetIterator | An iterator to a BeamSystem type set.
Public class | ContFootingType | An object that specifies the type of a continuous footing in Autodesk Revit.
Public class | ContFootingTypeSet | A set that contains ContFooting types.
Public class | ContFootingTypeSetIterator | An iterator to a ContFooting type set.
Public class | CurtainSystemType | An object that represents CurtainSystem type.
Public class | CurtainSystemTypeSet | A set that contains CurtainSystem types.
Public class | CurtainSystemTypeSetIterator | An iterator to a CurtainSystem type set.
Public class | DemandFactor | Represents a demand factor, which let you adjust the rating of the main service for a building based on the expectation that, at any given time, not all of the electrical equipment will not be drawing at its full rated load. You can specify one or more Demand Factors, applying different Demand Factors to Lighting, Power, HVAC, or Other systems in your project based on their load.
Public class | DimensionType | An object that represents a dimension style.
Public class | DimensionTypeSet | A set that contains dimension types.
Public class | DimensionTypeSetIterator | An iterator to a dimension type set.
Public class | DistributionSysType | Represents a specific type of distribution system.
Public class | DistributionSysTypeSet | A set that contains DistributionSys types.
Public class | DistributionSysTypeSetIterator | An iterator to a DistributionSys type set.
Public class | FamilySymbol | Represents a single Type within a Family.
Public class | FamilySymbolSet | A set that can contain family symbols.
Public class | FamilySymbolSetIterator | An iterator to a family symbol set.
Public class | FasciaType | An object that represents the fascia type in Autodesk Revit.
Public class | FasciaTypeSet | A set that contains fascia types.
Public class | FasciaTypeSetIterator | An iterator to a fascia type set.
Public class | FloorType | An object that specifies the type of a floor in Autodesk Revit.
Public class | FloorTypeSet | A set that contains floor types.
Public class | FloorTypeSetIterator | An iterator to a floor type set.
Public class | GridType | An object that represents a dimension style.
Public class | GridTypeSet | A set that contains grid types.
Public class | GridTypeSetIterator | An iterator to a grid type set.
Public class | GroupType | Represents a type of a user defined group.
Public class | GutterType | An object that represents the gutter type in Autodesk Revit.
Public class | GutterTypeSet | A set that contains gutter types.
Public class | GutterTypeSetIterator | An iterator to a gutter type set.
Public class | HostedSweepType | An object that represents the attributes for sweep host objects in Autodesk Revit.
Public class | HostObjAttributes | An object that represents characteristics of several kinds of type.
Public class | InsertableObject | A base class you all types that are insertable.
Public class | LevelType | An object that represents a dimension style.
Public class | LevelTypeSet | A set that contains level types.
Public class | LevelTypeSetIterator | An iterator to a level type set.
Public class | LineAndTextAttrSymbol | An object that represents a dimension style.
Public class | LineLoadType | An object that represents a dimension style.
Public class | LineLoadTypeSet | A set that contains lineload types.
Public class | LineLoadTypeSetIterator | An iterator to a lineload type set.
Public class | LoadTypeBase | An object that represents a dimension style.
Public class | LoadTypeBaseSet | A set that contains load type bases.
Public class | LoadTypeBaseSetIterator | An iterator to a load type base set.
Public class | MEPBuildingConstruction | Construction definition for Project Information.
Public class | MEPBuildingConstructionSet | A set that contains MEPBuildingConstructions.
Public class | MEPBuildingConstructionSetIterator | An iterator to a MEPBuildingConstruction set.
Public class | MullionType | An object that represents a dimension style.
Public class | MullionTypeSet | A set that contains mullion types.
Public class | MullionTypeSetIterator | An iterator to a mullion type set.
Public class | PanelType | An object that represents a dimension style.
Public class | PanelTypeSet | A set that contains panel types.
Public class | PanelTypeSetIterator | An iterator to a panel type set.
Public class | PathReinforcementType | An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
Public class | PointLoadType | An object that represents a dimension style.
Public class | PointLoadTypeSet | A set that contains pointload types.
Public class | PointLoadTypeSetIterator | An iterator to a pointload type set.
Public class | RebarBarType | A Rebar type object that is used in the generation of Rebar.
Public class | RebarBarTypeSet | A set that contains RebarBar types.
Public class | RebarBarTypeSetIterator | An iterator to a RebarBar type set.
Public class | RebarCoverType | A Rebar Cover setting. This element functions as a name-value pair for Rebar Cover Settings.
Public class | RebarCoverTypeSet | A set that contains RebarCover types.
Public class | RebarCoverTypeSetIterator | An iterator to a RebarCover type set.
Public class | RebarHookType | A Rebar Hook type object that is used in the generation of Rebar.
Public class | RebarHookTypeSet | A set that contains RebarHook types.
Public class | RebarHookTypeSetIterator | An iterator to a RebarHook type set.
Public class | RebarShape | RebarShape specifies the shape type for a Rebar instance.
Public class | RebarShapeDefinition | A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.
Public class | RebarShapeDefinitionByArc | Definition of a shape whose size and position can determined by a single arc.
Public class | RebarShapeDefinitionBySegments | Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
Public class | RebarShapeSet | An set that contains rebar shapes.
Public class | RebarShapeSetIterator | An iterator to a rebar shape set.
Public class | RoofType | Represents a specific type of roof.
Public class | RoofTypeSet | A set that contains roof types.
Public class | RoofTypeSetIterator | An iterator to a roof type set.
Public class | RoomTagType | An object that represents a dimension style.
Public class | RoomTagTypeSet | A set that contains room tag types.
Public class | RoomTagTypeSetIterator | An iterator to a room tag type set.
Public class | SlabEdgeType | An object that represents the slab edge type in Autodesk Revit.
Public class | SlabEdgeTypeSet | A set that contains slab edge types.
Public class | SlabEdgeTypeSetIterator | An iterator to a slab edge type set.
Public class | SpaceTagType | An object that represents a dimension style.
Public class | SpaceTagTypeSet | A set that contains space tag types.
Public class | SpaceTagTypeSetIterator | An iterator to a space tag type set.
Public class | SpotDimensionType | An object that specifies the type of a spot dimension in Autodesk Revit.
Public class | SpotDimensionTypeSet | A set that contains spotdimension types.
Public class | SpotDimensionTypeSetIterator | An iterator to a spotdimension type set.
Public class | TextElementType | An object that represents a dimension style.
Public class | TextNoteType | An object that represents a dimension style.
Public class | TextNoteTypeSet | A set that contains textnote types.
Public class | TextNoteTypeSetIterator | An iterator to a textnote type set.
Public class | TrussType | Represents a specific type of truss.
Public class | TrussTypeSet | A set that contains Truss types.
Public class | TrussTypeSetIterator | An iterator to a Truss type set.
Public class | VoltageType | Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.
Public class | VoltageTypeSet | A set that contains voltage types.
Public class | VoltageTypeSetIterator | An iterator to a voltage type set.
Public class | WallType | Represents a specific type of wall, such as 'Generic -8" '.
Public class | WallTypeSet | A set that contains wall types.
Public class | WallTypeSetIterator | An iterator to a wall type set.
Public class | WireType | Represents a specific wire type.
Public class | WireTypeSet | A set that contains wire types.
Public class | WireTypeSetIterator | An iterator to a wire type set.

Enumerations

 | Enumeration | Description
Public enumeration | WallType..::WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
Public enumeration | WireType..::NeutralMode | An enumerate type to list the neutral mode for wire type.

AnnotationSymbolType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A6EDA38F-8CD4-47cd-A016-022FF68A3567")]
public class AnnotationSymbolType : FamilySymbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A6EDA38F-8CD4-47cd-A016-022FF68A3567")> _
Public Class AnnotationSymbolType _
    Inherits FamilySymbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A6EDA38F-8CD4-47cd-A016-022FF68A3567")]
public ref class AnnotationSymbolType : public FamilySymbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol
Autodesk.Revit.Symbols..::AnnotationSymbolType

See Also

AnnotationSymbolType Members
Autodesk.Revit.Symbols Namespace