NewSpotElevation Method

Document..::NewSpotElevation Method
CollapseAll image DropDown image

Generate a new spot elevation object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SpotDimension NewSpotElevation(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotElevation ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotElevation (
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
View
The view in which the spot elevation is to be visible.
reference
Reference
The reference to which the spot elevation is to be bound.
origin
XYZ
The point which the spot elevation evaluate.
bend
XYZ
The bend point for the spot elevation.
end
XYZ
The end point for the spot elevation.
refPt
XYZ
The actual point on the reference which the spot elevation evaluate.
hasLeader
Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise Nothing.

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace