Dispose Method

APIObject..::Dispose Method
CollapseAll image DropDown image

Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose () sealed

Remarks

This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.

See Also

APIObject Class
Autodesk.Revit Namespace