NewLineBound Method

Application..::NewLineBound Method
CollapseAll image DropDown image

Creates a new bounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line NewLineBound(
    XYZ start,
    XYZ end
)
Visual Basic (Declaration)
Public Function NewLineBound ( _
    start As XYZ, _
    end As XYZ _
) As Line
Visual C++
public:
Line^ NewLineBound (
    XYZ^ start,
    XYZ^ end
)

Parameters

start
XYZ
A start point for the line.
end
XYZ
An end point for the line.

Return Value

Returns a new bounded line object.

Remarks

The new line is bounded and has the start parameter as the start point and the end parameter as the end point.

See Also

Application Class
Autodesk.Revit.Creation Namespace