Curve Methods
CollapseAll image DropDown image

Syntax

C#
public class Curve
Visual Basic (Declaration)
Public Class Curve
Visual C++
public ref class Curve

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.

Protected Methods

 | Name | Description

See Also

Curve
Autodesk.Revit.Geometry Namespace