SetAutoCalcHookLengths Method

RebarBarType..::SetAutoCalcHookLengths Method
CollapseAll image DropDown image

Specify whether hook lengths are automatically calculated.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetAutoCalcHookLengths(
    RebarHookType __unnamed000,
    bool autoCalc
)
Visual Basic (Declaration)
Public Sub SetAutoCalcHookLengths ( _
    __unnamed000 As RebarHookType, _
    autoCalc As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths (
    RebarHookType^ __unnamed000,
    bool autoCalc
)

Parameters

__unnamed000
RebarHookType
autoCalc
Boolean
Setting this value to true discards the current value set by set_HookLength().

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace