Settings Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Settings
Visual Basic (Declaration)
Public Class Settings
Visual C++
public ref class Settings

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SettingsSettingsNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
Public property | LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Public property | Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
Public property | VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings
Autodesk.Revit Namespace