ModelCurve Class
See Also Members
CollapseAll image DropDown image

Represents a ModelCurve within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("117FA724-284E-4d9f-8B5C-CBC27C4E78D3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ModelCurve : Element
Visual Basic (Declaration)
<GuidAttribute("117FA724-284E-4d9f-8B5C-CBC27C4E78D3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ModelCurve _
    Inherits Element
Visual C++
[GuidAttribute(L"117FA724-284E-4d9f-8B5C-CBC27C4E78D3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelCurve : public Element

Remarks

This is the parent class for model lines. Currently, the supported model lines are line, arc, Ellipse, NurbSpline and HermiteSpline.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelArc
Autodesk.Revit.Elements..::ModelEllipse
Autodesk.Revit.Elements..::ModelLine
Autodesk.Revit.Elements..::ModelHermiteSpline
Autodesk.Revit.Elements..::ModelNurbSpline

See Also

ModelCurve Members
Autodesk.Revit.Elements Namespace