GeometryCurve Property

DetailCurve..::GeometryCurve Property
CollapseAll image DropDown image

Get or set the geometry curve of the detail line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve GeometryCurve{ get; set;}
Visual Basic (Declaration)
Public Property GeometryCurve As Curve
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

Because there are no corresponding geometry curve type for HermiteSpline, for this type only general Geometry::Curve object will be returned.

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace