Application Events
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following events.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Autodesk Revit dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified after a document is closed.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified after a new document has been created.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified after a document has been opened.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified after a document is saved.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

See Also

Application
Autodesk.Revit Namespace