TemperatureRatingType Properties
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingType
Visual Basic (Declaration)
Public Class TemperatureRatingType
Visual C++
public ref class TemperatureRatingType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
Public property | InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
Public property | IsInUse | Indicate whether the temperature rating type is in use.
Public property | MaterialType | Get the material type information which this temperature rating type belongs to.
Public property | Name | Get name of temperature rating type. (Overrides Element ..:: Name.)
Public property | Parameter | Overloaded.
Public property | WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType
Autodesk.Revit.Elements Namespace