CriteriaFilterType Enumeration
CollapseAll image DropDown image

An enumerate type listing all relationships between element's parameter value and the specified value. It is used in defining a criterion in element retrieval by criteria filter.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("BAD4BC1C-0B8D-4456-9B51-5E27418EA5ED")]
public enum CriteriaFilterType
Visual Basic (Declaration)
<GuidAttribute("BAD4BC1C-0B8D-4456-9B51-5E27418EA5ED")> _
Public Enumeration CriteriaFilterType
Visual C++
[GuidAttribute(L"BAD4BC1C-0B8D-4456-9B51-5E27418EA5ED")]
public enum class CriteriaFilterType

Members

Member name | Description
Contains | The element's parameter value contains the specified value.
DoesNotEndWith | The element's parameter value doesn't end with specified value.
EndsWith | The element's parameter value ends with the specified value.
DoesNotBeginWith | The element's parameter value doesn't begin with specified value.
BeginsWith | The element's parameter value begins with the specified value.
DoesNotContain | The element's parameter value doesn't contain the specified value.
LessThanOrEqual | The element's parameter value is less than or equal to the specified value.
LessThan | The element's parameter value is less than the specified value.
GreaterThanOrEqual | The element's parameter value is greater than or equal to the specified value.
GreaterThan | The element's parameter value is greater than the specified value.
NotEqual | The element's parameter value is not equal to the specified value.
Equal | The element's parameter value is equal to the specified value.
HasParam | The element has parameter.
Invalid | Invalid filter type.

See Also

Autodesk.Revit.Enums Namespace