CutLineWeightOverrideByElement Property

View..::CutLineWeightOverrideByElement Property
CollapseAll image DropDown image

Override the cut lines' weight by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int CutLineWeightOverrideByElement[
    ElementIdSet ids
]{ get; set;}
Visual Basic (Declaration)
Public Property CutLineWeightOverrideByElement ( _
    ids As ElementIdSet _
) As Integer
Visual C++
public:
property int CutLineWeightOverrideByElement[ElementIdSet^ ids] {
    int get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, int value);
}

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be override.

Remarks

This property set the line weight of the element to override the graphics in the view. The line weigh number should be less or equal 16 and greater or equal 1 or equal -1.

See Also

View Class
Autodesk.Revit.Elements Namespace