LightingDevice Class
See Also Members
CollapseAll image DropDown image

Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("60C8455F-950B-4694-9848-258D28B5D88F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LightingDevice : MEPModel
Visual Basic (Declaration)
<GuidAttribute("60C8455F-950B-4694-9848-258D28B5D88F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LightingDevice _
    Inherits MEPModel
Visual C++
[GuidAttribute(L"60C8455F-950B-4694-9848-258D28B5D88F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::LightingDevice

See Also

LightingDevice Members
Autodesk.Revit.MEP Namespace