IsReadOnly Property

APIObject..::IsReadOnly Property
CollapseAll image DropDown image

Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool IsReadOnly{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

See Also

APIObject Class
Autodesk.Revit Namespace