Insert Method

Map..::Insert Method
CollapseAll image DropDown image

Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Object key,
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Object, _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Object^ key,
    Object^ item
)

Parameters

key
Object
The key to be used for inserting the item into the map.
item
Object
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace