MeshArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MeshArray
Visual Basic (Declaration)
Public Class MeshArray
Visual C++
public ref class MeshArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MeshArrayMeshArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the mesh to the end of the array.
Public method | Clear | Removes every mesh from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified mesh into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a mesh at a specified index within the array.
Public property | Size | Returns the number of meshes that are in the array.

See Also

MeshArray
Autodesk.Revit.Geometry Namespace