ViewSheet Class
See Also Members
CollapseAll image DropDown image

A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7F87AAA0-C777-4c55-894B-C19184F0C914")]
public class ViewSheet : View
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7F87AAA0-C777-4c55-894B-C19184F0C914")> _
Public Class ViewSheet _
    Inherits View
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7F87AAA0-C777-4c55-894B-C19184F0C914")]
public ref class ViewSheet : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::ViewSheet

See Also

ViewSheet Members
Autodesk.Revit.Elements Namespace