DrawPoint Method

SlabShapeEditor..::DrawPoint Method
CollapseAll image DropDown image

Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic (Declaration)
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint (
    XYZ^ location
)

Parameters

location
XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return null. Drawing a point on boundary crease may increase the number of creases.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace