Floor Properties
CollapseAll image DropDown image

Syntax

C#
public class Floor
Visual Basic (Declaration)
Public Class Floor
Visual C++
public ref class Floor

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the floor object.
Public property | FloorType | Retrieves/set an object that represents the type of the floor.
Public property | Parameter | Overloaded.
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor
Public property | SpanDirectionSymbols | An array of span direction symbols associated with this floor.
Public property | StructuralUsage | The floors designated structural usage, such as bearing or non bearing.

See Also

Floor
Autodesk.Revit.Elements Namespace