MenuItem Methods
CollapseAll image DropDown image

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddToExternalTools | Add top level menu to "external tools" menu.
Public method | Append | Overloaded.
Public method | GetMenuItemCount | Get number of sub menus, if current menu is not popup menu, zero will be returned.
Public method | GetSubMenu | Get a sub menu, if current menu is not popup menu, null will be returned.
Public method | Insert | Overloaded.

Protected Methods

 | Name | Description

See Also

MenuItem
Autodesk.Revit Namespace