AnnotationSymbol Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnnotationSymbol
Visual Basic (Declaration)
Public Class AnnotationSymbol
Visual C++
public ref class AnnotationSymbol

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnnotationSymbolAnnotationSymbolNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | addLeader | add a leader to this annotation symbol.
Public method | duplicate | Duplicate this annotation symbol.
Public method | removeLeader | remove a leader of this annotation symbol.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | Leaders | Get all the leaders of this annotation symbol.
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Parameter | Overloaded.

See Also

AnnotationSymbol
Autodesk.Revit.Elements Namespace