Face Class
See Also Members
CollapseAll image DropDown image

A face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D0ADC7CF-97FB-4903-BEC1-5D0CA2FA047D")]
public class Face : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D0ADC7CF-97FB-4903-BEC1-5D0CA2FA047D")> _
Public Class Face _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D0ADC7CF-97FB-4903-BEC1-5D0CA2FA047D")]
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::ConicalFace
Autodesk.Revit.Geometry..::CylindricalFace
Autodesk.Revit.Geometry..::HermiteFace
Autodesk.Revit.Geometry..::PlanarFace
Autodesk.Revit.Geometry..::RevolvedFace
Autodesk.Revit.Geometry..::RuledFace

See Also

Face Members
Autodesk.Revit.Geometry Namespace