DialogBoxData Class
See Also Members
CollapseAll image DropDown image

An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EDE91043-9BB6-4659-8163-753619C30DB8")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DialogBoxData : APIObject
Visual Basic (Declaration)
<GuidAttribute("EDE91043-9BB6-4659-8163-753619C30DB8")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DialogBoxData _
    Inherits APIObject
Visual C++
[GuidAttribute(L"EDE91043-9BB6-4659-8163-753619C30DB8")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Events..::DialogBoxData
Autodesk.Revit.Events..::MessageBoxData

See Also

DialogBoxData Members
Autodesk.Revit.Events Namespace