CoverType Property

RebarHostData..::CoverType Property
CollapseAll image DropDown image

Gets the RebarCoverType associated with a face of the element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarCoverType CoverType[
    Reference
]{ get; set;}
Visual Basic (Declaration)
Public Property CoverType ( _
     As Reference _
) As RebarCoverType
Visual C++
public:
property RebarCoverType^ CoverType[Reference^ ] {
    RebarCoverType^ get (Reference^ );
    void set (Reference^ , RebarCoverType^ value);
}

Parameters

Reference

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace