BeamSystem Class
See Also Members
CollapseAll image DropDown image

An object that represents a BeamSystem within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("72166770-C7A0-478e-B5A3-6EE6AC560673")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BeamSystem : Element
Visual Basic (Declaration)
<GuidAttribute("72166770-C7A0-478e-B5A3-6EE6AC560673")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BeamSystem _
    Inherits Element
Visual C++
[GuidAttribute(L"72166770-C7A0-478e-B5A3-6EE6AC560673")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BeamSystem : public Element

Remarks

This object derived from the Element base object. It can be used access the properties of a BeamSystem, such as elevation, level etc. All the beams belongs to a BeamSystem can be got and there is a static method to find out the BeamSystem to which the beam belongs.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BeamSystem

See Also

BeamSystem Members
Autodesk.Revit.Elements Namespace