ParameterMap Class
See Also Members
CollapseAll image DropDown image

A map that can contain a mapping of a parameter name (a String) to a parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C5EA27F0-3D6D-4767-8407-38C0D428679F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ParameterMap : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("C5EA27F0-3D6D-4767-8407-38C0D428679F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ParameterMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"C5EA27F0-3D6D-4767-8407-38C0D428679F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ParameterMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterMap

See Also

ParameterMap Members
Autodesk.Revit Namespace