TrussTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class TrussTypeSet
Visual Basic (Declaration)
Public Class TrussTypeSet
Visual C++
public ref class TrussTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TrussTypeSetTrussTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every Truss type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a Truss type within the set.
Public method | Erase | Removes a specified Truss type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified Truss type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet
Autodesk.Revit.Symbols Namespace