Smoothness Property

Material..::Smoothness Property
CollapseAll image DropDown image

The smoothness of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Smoothness{ get; set;}
Visual Basic (Declaration)
Public Property Smoothness As Integer
Visual C++
public:
property int Smoothness {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace