CompoundStructureLayerArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a layer array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("3AE05AEC-67E6-4576-ABF8-B36418B653CD")]
public abstract class CompoundStructureLayerArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("3AE05AEC-67E6-4576-ABF8-B36418B653CD")> _
Public MustInherit Class CompoundStructureLayerArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"3AE05AEC-67E6-4576-ABF8-B36418B653CD")]
public ref class CompoundStructureLayerArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::CompoundStructureLayerArrayIterator

See Also

CompoundStructureLayerArrayIterator Members
Autodesk.Revit.Structural Namespace