Location Class
See Also Members
CollapseAll image DropDown image

Provides location functionality for all elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("62945E43-FB00-42e5-8A21-EA6F4DD9960C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Location : APIObject
Visual Basic (Declaration)
<GuidAttribute("62945E43-FB00-42e5-8A21-EA6F4DD9960C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Location _
    Inherits APIObject
Visual C++
[GuidAttribute(L"62945E43-FB00-42e5-8A21-EA6F4DD9960C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Location : public APIObject

Remarks

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Location
Autodesk.Revit..::LocationPoint
Autodesk.Revit..::LocationCurve

See Also

Location Members
Autodesk.Revit Namespace