ExternalCommandData Class
See Also Members
CollapseAll image DropDown image

A class contains reference to Application and View which are needed by external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("68060C9A-ED4E-4b55-9849-AB6C1FF7EF94")]
public class ExternalCommandData : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("68060C9A-ED4E-4b55-9849-AB6C1FF7EF94")> _
Public Class ExternalCommandData _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"68060C9A-ED4E-4b55-9849-AB6C1FF7EF94")]
public ref class ExternalCommandData : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ExternalCommandData

See Also

ExternalCommandData Members
Autodesk.Revit Namespace