ModelCurve Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ModelCurve
Visual Basic (Declaration)
Public Class ModelCurve
Visual C++
public ref class ModelCurve

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ModelCurveModelCurveNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | getLineStyle | Get the line style of the curve.
Public method | setLineStyle | Set the line style for the curve.
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | GeometryCurve | Get or set the geometry curve of the model line.
Public property | LineStyles | Returns all line style of the curve.
Public property | Parameter | Overloaded.
Public property | SketchPlane | Get or set the sketch the model line resides in.

See Also

ModelCurve
Autodesk.Revit.Elements Namespace