RebarShape Methods
CollapseAll image DropDown image

Syntax

C#
public class RebarShape
Visual Basic (Declaration)
Public Class RebarShape
Visual C++
public ref class RebarShape

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | GetAllowed |
 | GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
Public method | GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
Public method | NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
Public method | NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
Public method | SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

See Also

RebarShape
Autodesk.Revit.Symbols Namespace