XYZ Properties
CollapseAll image DropDown image

Syntax

C#
public class XYZ
Visual Basic (Declaration)
Public Class XYZ
Visual C++
public ref class XYZ

The type exposes the following properties.

Public Properties

 | Name | Description
 | Basis | Indexed access for Basis.
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
Public property | IsZero | The boolean value that indicates whether this vector is a zero vector.
Public property | Item | Indexed access to coordinates.
Public property | Length | The length of this vector.
Public property | Normalized | This vector, normalized.
Public property | X | The first coordinate.
Public property | Y | The second coordinate.
Public property | Z | The third coordinate.
 | Zero | The coordinate origin or zero vector.

See Also

XYZ
Autodesk.Revit.Geometry Namespace