ViewPlan Class
See Also Members
CollapseAll image DropDown image

A plan represents for floor plan or ceiling plan.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A488E5D2-DB09-4e4e-B5DD-6BAD060781EA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ViewPlan : View
Visual Basic (Declaration)
<GuidAttribute("A488E5D2-DB09-4e4e-B5DD-6BAD060781EA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ViewPlan _
    Inherits View
Visual C++
[GuidAttribute(L"A488E5D2-DB09-4e4e-B5DD-6BAD060781EA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ViewPlan : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::ViewPlan

See Also

ViewPlan Members
Autodesk.Revit.Elements Namespace