NewAreaBoundaryLine Method

Document..::NewAreaBoundaryLine Method
CollapseAll image DropDown image

Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
    SketchPlane plan,
    Curve geometryCurve,
    ViewPlan areaView
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryLine ( _
    plan As SketchPlane, _
    geometryCurve As Curve, _
    areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine (
    SketchPlane^ plan,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)

Parameters

plan
SketchPlane
The sketch plan
geometryCurve
Curve
The geometry curve on which the boundary line are
areaView
ViewPlan
The View for the new Area

See Also

Document Class
Autodesk.Revit.Creation Namespace