NewSpaceBoundaryLines Method

Document..::NewSpaceBoundaryLines Method
CollapseAll image DropDown image

Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ModelCurveArray NewSpaceBoundaryLines(
    SketchPlane plan,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceBoundaryLines ( _
    plan As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewSpaceBoundaryLines (
    SketchPlane^ plan,
    CurveArray^ curves,
    View^ view
)

Parameters

plan
SketchPlane
The sketch plan
curves
CurveArray
The geometry curves on which the boundary lines are
view
View
The View for the new Space

See Also

Document Class
Autodesk.Revit.Creation Namespace