ModelEllipse Class
See Also Members
CollapseAll image DropDown image

Represents a ModelEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8CCD9846-23DF-4382-8048-02D143A02D86")]
public class ModelEllipse : ModelCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8CCD9846-23DF-4382-8048-02D143A02D86")> _
Public Class ModelEllipse _
    Inherits ModelCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8CCD9846-23DF-4382-8048-02D143A02D86")]
public ref class ModelEllipse : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelEllipse

See Also

ModelEllipse Members
Autodesk.Revit.Elements Namespace