ProfiledWallCreationData Constructor (CurveArray, Boolean)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace