LayoutRuleClearSpacing Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Clear-Spacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7D15F3B9-F54E-49fe-9594-0313C64D72AF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LayoutRuleClearSpacing : LayoutRule
Visual Basic (Declaration)
<GuidAttribute("7D15F3B9-F54E-49fe-9594-0313C64D72AF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LayoutRuleClearSpacing _
    Inherits LayoutRule
Visual C++
[GuidAttribute(L"7D15F3B9-F54E-49fe-9594-0313C64D72AF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LayoutRuleClearSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleClearSpacing

See Also

LayoutRuleClearSpacing Members
Autodesk.Revit.Elements Namespace