Profile Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Profile
Visual Basic (Declaration)
Public Class Profile
Visual C++
public ref class Profile

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProfileProfileNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this profile.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | Transformed | Transforms this profile and returns the result.

See Also

Profile
Autodesk.Revit.Geometry Namespace