NewMaterialFilter Method

Filter..::NewMaterialFilter Method
CollapseAll image DropDown image

Creates a MaterialFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialFilter NewMaterialFilter(
    Material material
)
Visual Basic (Declaration)
Public Function NewMaterialFilter ( _
    material As Material _
) As MaterialFilter
Visual C++
public:
MaterialFilter^ NewMaterialFilter (
    Material material
)

Parameters

material
Material
Filter elements by the material.

Return Value

Returns a new material filter object with given material.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace