HostedSweepType Class
See Also Members
CollapseAll image DropDown image

An object that represents the attributes for sweep host objects in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("190C820A-2736-402e-9608-BE6CC577BB0E")]
public class HostedSweepType : HostObjAttributes
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("190C820A-2736-402e-9608-BE6CC577BB0E")> _
Public Class HostedSweepType _
    Inherits HostObjAttributes
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"190C820A-2736-402e-9608-BE6CC577BB0E")]
public ref class HostedSweepType : public HostObjAttributes

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::HostedSweepType
Autodesk.Revit.Symbols..::SlabEdgeType
Autodesk.Revit.Symbols..::GutterType
Autodesk.Revit.Symbols..::FasciaType

See Also

HostedSweepType Members
Autodesk.Revit.Symbols Namespace