CompoundStructureLayer Class
See Also Members
CollapseAll image DropDown image

An object that describes the a single layer of multi layered object.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E658C477-82BE-4c4e-AD06-A52AEC473E82")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CompoundStructureLayer : APIObject
Visual Basic (Declaration)
<GuidAttribute("E658C477-82BE-4c4e-AD06-A52AEC473E82")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CompoundStructureLayer _
    Inherits APIObject
Visual C++
[GuidAttribute(L"E658C477-82BE-4c4e-AD06-A52AEC473E82")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CompoundStructureLayer : public APIObject

Remarks

A wall of floor may have several layers. Each layer contains information about its thickness, intended purpose (function) and material from which it is made.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::CompoundStructureLayer

See Also

CompoundStructureLayer Members
Autodesk.Revit.Structural Namespace