IsMiterLocked Property

IExtension..::IsMiterLocked Property
CollapseAll image DropDown image

Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
bool IsMiterLocked[
    int index
]{ get; set;}
Visual Basic (Declaration)
Property IsMiterLocked ( _
    index As Integer _
) As Boolean
Visual C++
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid

See Also

IExtension Interface
Autodesk.Revit Namespace