NewSlab Method

Document..::NewSlab Method
CollapseAll image DropDown image

Creates a slab within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewSlab(
    CurveArray profile,
    Level level,
    Line slopedArrow,
    double slope,
    bool isStructural
)
Visual Basic (Declaration)
Public Function NewSlab ( _
    profile As CurveArray, _
    level As Level, _
    slopedArrow As Line, _
    slope As Double, _
    isStructural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewSlab (
    CurveArray^ profile,
    Level^ level,
    Line^ slopedArrow,
    double slope,
    bool isStructural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the slab.
level
Level
The level on which the slab is to be placed.
slopedArrow
Line
A line use to control the sloped angle of the slab. It should be in the same face with profile.
slope
Double
The slope.
isStructural
Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace