Zone Class
See Also Members
CollapseAll image DropDown image

Provides access to the Zone Element in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("25CA3569-508C-46b7-ABF5-44F61209A3F3")]
public class Zone : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("25CA3569-508C-46b7-ABF5-44F61209A3F3")> _
Public Class Zone _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"25CA3569-508C-46b7-ABF5-44F61209A3F3")]
public ref class Zone : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object is only available in Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Zone

See Also

Zone Members
Autodesk.Revit.Elements Namespace