Edge Methods
CollapseAll image DropDown image

Syntax

C#
public class Edge
Visual Basic (Declaration)
Public Class Edge
Visual C++
public ref class Edge

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.

Protected Methods

 | Name | Description

See Also

Edge
Autodesk.Revit.Geometry Namespace