Materials Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Materials
Visual Basic (Declaration)
Public Class Materials
Visual C++
public ref class Materials

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialsMaterialsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddConcrete | Add a concrete material with the given name .
Public method | AddGeneric | Add a generic material with the given name .
Public method | AddOther | Add an other material with the given name .
Public method | AddSteel | Add a steel material with the given name .
Public method | AddWood | Add a wood material with the given name .
Public method | Contains | Overloaded.
Public method | Remove | Remove the material with the speicified name .

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides MaterialSet ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | Item | Overloaded.

See Also

Materials
Autodesk.Revit Namespace