Document Methods
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AbortTransaction | Abort a transaction for specified document.
Public method | Array | Overloaded.
Public method | ArrayWithoutAssociate | Overloaded.
Public method | BeginTransaction | Overloaded.
Public method | Close | Overloaded.
Public method | Delete | Overloaded.
Public method | EndTransaction | Overloaded.
Public method | Export | Overloaded.
Public method | Import | Overloaded.
Public method | LoadFamily | Overloaded.
Public method | LoadFamilySymbol | Overloaded.
Public method | Mirror | Overloaded.
Public method | Move | Overloaded.
Public method | Print | Overloaded.
Public method | Rotate | Overloaded.
Public method | Save | Overloaded.
Public method | SaveAs | Overloaded.
Public method | ShowElements | Overloaded.

Protected Methods

 | Name | Description

See Also

Document
Autodesk.Revit Namespace