Autodesk.Revit.Editor Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Editor
Visual Basic (Declaration)
Namespace Autodesk.Revit.Editor
Visual C++
namespace Autodesk.Revit.Editor

Classes

 | Class | Description
Public class | SlabShapeCrease | A crease used in Slab Shape Editing.
Public class | SlabShapeCreaseArray | An array that can contain any number of creases used in Slab Shape Editing.
Public class | SlabShapeCreaseArrayIterator | An iterator to an array of creases used for Slab Shape Editing.
Public class | SlabShapeEditor | An object used for Slab Shape Editing.
Public class | SlabShapeVertex | A vertex used in Slab Shape Editing.
Public class | SlabShapeVertexArray | An array that can contain any number of vertices used in Slab Shape Editing.
Public class | SlabShapeVertexArrayIterator | An iterator to an array of vertices used for Slab Shape Editing.

SlabShapeCrease Class
See Also Members
CollapseAll image DropDown image

A crease used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A7DBD5D2-AF15-4c6f-BC5B-F3D3B7381AD6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SlabShapeCrease
Visual Basic (Declaration)
<GuidAttribute("A7DBD5D2-AF15-4c6f-BC5B-F3D3B7381AD6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SlabShapeCrease
Visual C++
[GuidAttribute(L"A7DBD5D2-AF15-4c6f-BC5B-F3D3B7381AD6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SlabShapeCrease

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Editor..::SlabShapeCrease

See Also

SlabShapeCrease Members
Autodesk.Revit.Editor Namespace