BoundarySegmentArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EEFD665B-3238-4925-84E3-ED8EB723B20F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BoundarySegmentArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("EEFD665B-3238-4925-84E3-ED8EB723B20F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"EEFD665B-3238-4925-84E3-ED8EB723B20F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Areas..::BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Areas Namespace