ModelNurbSpline Class
See Also Members
CollapseAll image DropDown image

Represents a ModelNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C0A8C877-514A-473b-8C43-D927C8BC6B99")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ModelNurbSpline : ModelCurve
Visual Basic (Declaration)
<GuidAttribute("C0A8C877-514A-473b-8C43-D927C8BC6B99")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ModelNurbSpline _
    Inherits ModelCurve
Visual C++
[GuidAttribute(L"C0A8C877-514A-473b-8C43-D927C8BC6B99")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ModelNurbSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelNurbSpline

See Also

ModelNurbSpline Members
Autodesk.Revit.Elements Namespace