RebarShape Properties
CollapseAll image DropDown image

Syntax

C#
public class RebarShape
Visual Basic (Declaration)
Public Class RebarShape
Visual C++
public ref class RebarShape

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Definition | Get the shape definition object associated with this shape.
Public property | HookAngle | Get and set the hook angle.
Public property | HookOrientation | Get and set the hook orientation.
Public property | Parameter | Overloaded.
Public property | RebarStyle | Access the rebar style.
Public property | SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
Public property | SimpleArc |
Public property | SimpleLine |

See Also

RebarShape
Autodesk.Revit.Symbols Namespace