Autodesk.Revit.Utility Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Utility
Visual Basic (Declaration)
Namespace Autodesk.Revit.Utility
Visual C++
namespace Autodesk.Revit.Utility

Classes

 | Class | Description
Public class | Asset |
Public class | AssetProperties |
Public class | AssetProperty |
Public class | AssetPropertyBoolean |
Public class | AssetPropertyDistance |
Public class | AssetPropertyDouble |
Public class | AssetPropertyDoubleArray2d |
Public class | AssetPropertyDoubleArray3d |
Public class | AssetPropertyDoubleArray4d |
Public class | AssetPropertyDoubleMatrix44 |
Public class | AssetPropertyEnum |
Public class | AssetPropertyFloat |
Public class | AssetPropertyInteger |
Public class | AssetPropertyReference |
Public class | AssetPropertyString |
Public class | AssetPropertyTime |
Public class | AssetSet | A set that contains assets.
Public class | AssetSetIterator | An iterator to a asset set.

Asset Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("889EC11D-15AD-4497-84B8-63099095A1A9")]
public class Asset : AssetProperties
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("889EC11D-15AD-4497-84B8-63099095A1A9")> _
Public Class Asset _
    Inherits AssetProperties
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"889EC11D-15AD-4497-84B8-63099095A1A9")]
public ref class Asset : public AssetProperties

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetProperties
Autodesk.Revit.Utility..::Asset

See Also

Asset Members
Autodesk.Revit.Utility Namespace