FromRoom Property

FamilyInstance..::FromRoom Property
CollapseAll image DropDown image

Property to get the room from which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room FromRoom{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FromRoom As Room
Visual C++
public:
property Room^ FromRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return null.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace