RevolvedFace Class
See Also Members
CollapseAll image DropDown image

A revolved face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1C4B1626-85A2-4258-9D7F-AFA441A7EA13")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RevolvedFace : Face
Visual Basic (Declaration)
<GuidAttribute("1C4B1626-85A2-4258-9D7F-AFA441A7EA13")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RevolvedFace _
    Inherits Face
Visual C++
[GuidAttribute(L"1C4B1626-85A2-4258-9D7F-AFA441A7EA13")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RevolvedFace : public Face

Remarks

Revoved faces are defined by revolved surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + Curve0(v)*cos(u)*Radius[0] + Curve0(v)*sin(u)*Radius[1] + Curve1(v)*Axis, where the profile curve has the parametric equation (Curve0(t), Curve1(t)).

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::RevolvedFace

See Also

RevolvedFace Members
Autodesk.Revit.Geometry Namespace