Edge Properties
CollapseAll image DropDown image

Syntax

C#
public class Edge
Visual Basic (Declaration)
Public Class Edge
Visual C++
public ref class Edge

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | Reference | Returns a stable reference to the edge.

See Also

Edge
Autodesk.Revit.Geometry Namespace