NumCurves Property

BoundaryConditions..::NumCurves Property
CollapseAll image DropDown image

Returns the number of curves represent the Boundary Conditions Element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int NumCurves{ get;}
Visual Basic (Declaration)
Public ReadOnly Property NumCurves As Integer
Visual C++
public:
property int NumCurves {
    int get ();
}

Remarks

For Point Boundary Conditions returns 0, for Line Boundary Conditions returns 1, for Area Boundary Conditions returns value > 0.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace