Plane Constructor (XYZ, XYZ, XYZ)
CollapseAll image DropDown image

Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane (
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
XYZ
The vector for x-axis.
yVec
XYZ
The vector for y-axis.
origin
XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace