ModelArc Class
See Also Members
CollapseAll image DropDown image

Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("26E3630F-1061-4306-9259-9CB243B3BD3D")]
public class ModelArc : ModelCurve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("26E3630F-1061-4306-9259-9CB243B3BD3D")> _
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"26E3630F-1061-4306-9259-9CB243B3BD3D")]
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::ModelArc

See Also

ModelArc Members
Autodesk.Revit.Elements Namespace