SpaceType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Space Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EC4C15CA-D174-4c7a-B46D-0302CCD142F3")]
public enum SpaceType
Visual Basic (Declaration)
<GuidAttribute("EC4C15CA-D174-4c7a-B46D-0302CCD142F3")> _
Public Enumeration SpaceType
Visual C++
[GuidAttribute(L"EC4C15CA-D174-4c7a-B46D-0302CCD142F3")]
public enum class SpaceType

Members

Member name | Description
kNoOfSpaceTypes | Return Space Type is NoOfSpaceTypes.
kWorshipPulpitChoirReligious | Return Space Type is WorshipPulpitChoirReligious.
kWorkshopWorkshop | Return Space Type is WorkshopWorkshop.
kTerminalTicketCounterTransportation | Return Space Type is TerminalTicketCounterTransportation.
kSupermarketSalesAreaRetail | Return Space Type is SupermarketSalesAreaRetail.
kStairway | Return Space Type is Stairway.
kStairsInactive | Return Space Type is StairsInactive.
kStacksLibrary | Return Space Type is StacksLibrary.
kSpecialtyStoreSalesAreaRetail | Return Space Type is SpecialtyStoreSalesAreaRetail.
kSortingAreaPostOffice | Return Space Type is SortingAreaPostOffice.
kSleepingQuartersPoliceOrFireStation | Return Space Type is SleepingQuartersPoliceOrFireStation.
kRingSportsAreaSportsArena | Return Space Type is RingSportsAreaSportsArena.
kRestrooms | Return Space Type is Restrooms.
kRestorationMuseum | Return Space Type is RestorationMuseum.
kRecoveryHospitalOrHealthcare | Return Space Type is RecoveryHospitalOrHealthcare.
kReceptionOrWaitingHotel | Return Space Type is ReceptionOrWaitingHotel.
kReceptionOrWaitingMotel | Return Space Type is ReceptionOrWaitingMotel.
kReceptionOrWaitingTransportation | Return Space Type is ReceptionOrWaitingTransportation.
kReadingAreaLibrary | Return Space Type is ReadingAreaLibrary.
kPublicAndStaffLoungeHospitalOrHealthcare | Return Space Type is PublicAndStaffLoungeHospitalOrHealthcare.
kPoliceStationLaboratoryPoliceOrFireStations | Return Space Type is PoliceStationLaboratoryPoliceOrFireStations.
kPlayingAreaGymnasium | Return Space Type is PlayingAreaGymnasium.
kPhysicalTherapyHospitalOrHealthcare | Return Space Type is PhysicalTherapyHospitalOrHealthcare.
kPharmacyHospitalOrHealthcare | Return Space Type is PharmacyHospitalOrHealthcare.
kPersonalServicesSalesAreaRetail | Return Space Type is PersonalServicesSalesAreaRetail.
kPatientRoomHospitalOrHealthcare | Return Space Type is PatientRoomHospitalOrHealthcare.
kParkingAreaPedestrianParkingGarage | Return Space Type is ParkingAreaPedestrianParkingGarage.
kParkingAreaAttendantOnlyParkingGarage | Return Space Type is ParkingAreaAttendantOnlyParkingGarage.
kOtherTelevisedPlayingAreaSportsArena | Return Space Type is OtherTelevisedPlayingAreaSportsArena.
kOperatingRoomHospitalOrHealthcare | Return Space Type is OperatingRoomHospitalOrHealthcare.
kOfficeCommonActivityAreasInactiveStorage | Return Space Type is OfficeCommonActivityAreasInactiveStorage.
kOfficeOpenPlan | Return Space Type is OfficeOpenPlan.
kOfficeEnclosed | Return Space Type is OfficeEnclosed.
kNurseStationHospitalOrHealthcare | Return Space Type is NurseStationHospitalOrHealthcare.
kMuseumAndGalleryStorage | Return Space Type is MuseumAndGalleryStorage.
kMerchandisingSalesAreaRetail | Return Space Type is MerchandisingSalesAreaRetail.
kMediumOrBulkyMaterialWarehouse | Return Space Type is MediumOrBulkyMaterialWarehouse.
kMassMerchandisingSalesAreaRetail | Return Space Type is MassMerchandisingSalesAreaRetail.
kMallConcourseSalesAreaRetail | Return Space Type is MallConcourseSalesAreaRetail.
kLoungeOrRecreation | Return Space Type is LoungeOrRecreation.
kLobbyHotel | Return Space Type is LobbyHotel.
kLobbyPostOffice | Return Space Type is LobbyPostOffice.
kLobbyPerformingArtsTheatre | Return Space Type is LobbyPerformingArtsTheatre.
kLobbyAuditorium | Return Space Type is LobbyAuditorium.
kLobbyMotionPictureTheatre | Return Space Type is LobbyMotionPictureTheatre.
kLobbyReligiousBuildings | Return Space Type is LobbyReligiousBuildings.
kLobby | Return Space Type is Lobby.
kLivingQuartersHotel | Return Space Type is LivingQuartersHotel.
kLivingQuartersMotel | Return Space Type is LivingQuartersMotel.
kLivingQuartersDormitory | Return Space Type is LivingQuartersDormitory.
kLibraryAudioVisualLibraryAudioVisual | Return Space Type is LibraryAudioVisualLibraryAudioVisual.
kLaundryWashingHospitalOrHealthcare | Return Space Type is LaundryWashingHospitalOrHealthcare.
kLaundryIroningAndSorting | Return Space Type is LaundryIroningAndSorting.
kLaboratoryOffice | Return Space Type is LaboratoryOffice.
kJudgesChambersCourtHouse | Return Space Type is JudgesChambersCourtHouse.
kInactiveStorage | Return Space Type is InactiveStorage.
kHotelOrConferenceCenterConferenceOrMeeting | Return Space Type is HotelOrConferenceCenterConferenceOrMeeting.
kHospitalOrRadiologyHospitalOrHealthcare | Return Space Type is HospitalOrRadiologyHospitalOrHealthcare.
kHospitalOrMedicalSuppliesHospitalOrHealthcare | Return Space Type is HospitalOrMedicalSuppliesHospitalOrHealthcare.
kHospitalNurseryHospitalOrHealthcare | Return Space Type is HospitalNurseryHospitalOrHealthcare.
kGeneralExhibitionMuseum | Return Space Type is GeneralExhibitionMuseum.
kGeneralLowBayManufacturingFacility | Return Space Type is GeneralLowBayManufacturingFacility.
kGeneralHighBayManufacturingFacility | Return Space Type is GeneralHighBayManufacturingFacility.
kGarageServiceOrRepairAutomotiveFacility | Return Space Type is GarageServiceOrRepairAutomotiveFacility.
kFoodPreparation | Return Space Type is FoodPreparation.
kFireStationEngineRoomPoliceOrFireStation | Return Space Type is FireStationEngineRoomPoliceOrFireStation.
kFineMerchandiseSalesAreaRetail | Return Space Type is FineMerchandiseSalesAreaRetail.
kFineMaterialWarehouse | Return Space Type is FineMaterialWarehouse.
kFellowshipHallReligiousBuildings | Return Space Type is FellowshipHallReligiousBuildings.
kExhibitSpaceConventionCenter | Return Space Type is ExhibitSpaceConventionCenter.
kExerciseAreaGymnasium | Return Space Type is ExerciseAreaGymnasium.
kExerciseAreaExerciseCenter | Return Space Type is ExerciseAreaExerciseCenter.
kExamOrTreatmentHospitalOrHealthcare | Return Space Type is ExamOrTreatmentHospitalOrHealthcare.
kEquipmentRoomManufacturingFacility | Return Space Type is EquipmentRoomManufacturingFacility.
kEmergencyHospitalOrHealthcare | Return Space Type is EmergencyHospitalOrHealthcare.
kElevatorLobbies | Return Space Type is ElevatorLobbies.
kElectricalOrMechanical | Return Space Type is ElectricalOrMechanical.
kDressingOrLockerOrFittingRoomExerciseCenter | Return Space Type is DressingOrLockerOrFittingRoomExerciseCenter.
kDressingOrLockerOrFittingRoomAuditorium | Return Space Type is DressingOrLockerOrFittingRoomAuditorium.
kDressingOrLockerOrFittingRoomPerformingArtsTheatre | Return Space Type is DressingOrLockerOrFittingRoomPerformingArtsTheatre.
kDressingOrLockerOrFittingRoomCourtHouse | Return Space Type is DressingOrLockerOrFittingRoomCourtHouse.
kDressingOrLockerOrFittingRoomGymnasium | Return Space Type is DressingOrLockerOrFittingRoomGymnasium.
kDormitoryStudyHall | Return Space Type is DormitoryStudyHall.
kDormitoryBedroom | Return Space Type is DormitoryBedroom.
kDiningAreaCivilServices | Return Space Type is DiningAreaCivilServices.
kDiningAreaPenitentiary | Return Space Type is DiningAreaPenitentiary.
kDiningAreaTransportation | Return Space Type is DiningAreaTransportation.
kDiningAreaMotel | Return Space Type is DiningAreaMotel.
kDiningAreaLoungeOrLeisureDining | Return Space Type is DiningAreaLoungeOrLeisureDining.
kDiningAreaFamilyDining | Return Space Type is DiningAreaFamilyDining.
kDiningAreaHotel | Return Space Type is DiningAreaHotel.
kDiningArea | Return Space Type is DiningArea.
kDetailedManufacturingFacility | Return Space Type is DetailedManufacturingFacility.
kDepartmentStoreSalesAreaRetail | Return Space Type is DepartmentStoreSalesAreaRetail.
kCourtroomCourtHouse | Return Space Type is CourtroomCourtHouse.
kCourtSportsAreaSportsArena | Return Space Type is CourtSportsAreaSportsArena.
kCorridorsWithPatientWaitingExamHospitalOrHealthcare | Return Space Type is CorridorsWithPatientWaitingExamHospitalOrHealthcare.
kCorridorOrTransitionManufacturingFacility | Return Space Type is CorridorOrTransitionManufacturingFacility.
kCorridorOrTransition | Return Space Type is CorridorOrTransition.
kConferenceMeetingOrMultipurpose | Return Space Type is ConferenceMeetingOrMultipurpose.
kComfinementCellsCourtHouse | Return Space Type is ComfinementCellsCourtHouse.
kComfinementCellsPenitentiary | Return Space Type is ComfinementCellsPenitentiary.
kClassroomOrLectureOrTraining | Return Space Type is ClassroomOrLectureOrTraining.
kClassroomOrLectureOrTrainingPenitentiary | Return Space Type is ClassroomOrLectureOrTrainingPenitentiary.
kCardFileAndCataloguingLibrary | Return Space Type is CardFileAndCataloguingLibrary.
kBarberAndBeautyParlor | Return Space Type is BarberAndBeautyParlor.
kBankingActivityAreaOffice | Return Space Type is BankingActivityAreaOffice.
kBankCustomerArea | Return Space Type is BankCustomerArea.
kAudienceOrSeatingAreaAuditorium | Return Space Type is AudienceOrSeatingAreaAuditorium.
kAudienceOrSeatingAreaCourtHouse | Return Space Type is AudienceOrSeatingAreaCourtHouse.
kAudienceOrSeatingAreaPoliceOrFireStations | Return Space Type is AudienceOrSeatingAreaPoliceOrFireStations.
kAudienceOrSeatingAreaReligious | Return Space Type is AudienceOrSeatingAreaReligious.
kAudienceOrSeatingAreaPerformingArtsTheatre | Return Space Type is AudienceOrSeatingAreaPerformingArtsTheatre.
kAudienceOrSeatingAreaMotionPictureTheatre | Return Space Type is AudienceOrSeatingAreaMotionPictureTheatre.
kAudienceOrSeatingAreaConventionCenter | Return Space Type is AudienceOrSeatingAreaConventionCenter.
kAudienceOrSeatingAreaSportsArena | Return Space Type is AudienceOrSeatingAreaSportsArena.
kAudienceOrSeatingAreaGymnasium | Return Space Type is AudienceOrSeatingAreaGymnasium.
kAudienceOrSeatingAreaExerciseCenter | Return Space Type is AudienceOrSeatingAreaExerciseCenter.
kAudienceOrSeatingAreaPenitentiary | Return Space Type is AudienceOrSeatingAreaPenitentiary.
kAtriumFirstThreeFloors | Return Space Type is AtriumFirstThreeFloors.
kAtriumEachAdditionalFloor | Return Space Type is AtriumEachAdditionalFloor.
kAirportConcourse | Return Space Type is AirportConcourse.
kAirOrTrainOrBusBaggageArea | Return Space Type is AirOrTrainOrBusBaggageArea.
kActiveStorageHospitalOrHealthcare | Return Space Type is ActiveStorageHospitalOrHealthcare.
kActiveStorage | Return Space Type is ActiveStorage.
kNoSpaceType | Return Space Type is NoSpaceType.

See Also

Autodesk.Revit.MEP.Enums Namespace