SelElementSet Class
See Also Members
CollapseAll image DropDown image

This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F38EF9B4-1324-4700-9BBE-B570933596D9")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SelElementSet : ElementSet
Visual Basic (Declaration)
<GuidAttribute("F38EF9B4-1324-4700-9BBE-B570933596D9")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SelElementSet _
    Inherits ElementSet
Visual C++
[GuidAttribute(L"F38EF9B4-1324-4700-9BBE-B570933596D9")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SelElementSet : public ElementSet

Remarks

Because the ModScope is transfered into the constructor, the SelElementSet can be used to Add or Remove element from the selected element set directly.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementSet
Autodesk.Revit..::SelElementSet

See Also

SelElementSet Members
Autodesk.Revit Namespace