LevelTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LevelTypeSet
Visual Basic (Declaration)
Public Class LevelTypeSet
Visual C++
public ref class LevelTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LevelTypeSetLevelTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every level type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a level type within the set.
Public method | Erase | Removes a specified level type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified level type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet
Autodesk.Revit.Symbols Namespace