SpanDirectionAngle Property

Floor..::SpanDirectionAngle Property
CollapseAll image DropDown image

Retrieve the span direction angle of the floor

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double SpanDirectionAngle{ get; set;}
Visual Basic (Declaration)
Public Property SpanDirectionAngle As Double
Visual C++
public:
property double SpanDirectionAngle {
    double get ();
    void set (double value);
}

Remarks

The angle returned is in radians. An exception will be thrown if the floor is non structural.

See Also

Floor Class
Autodesk.Revit.Elements Namespace