Curve Property

LocationCurve..::Curve Property
CollapseAll image DropDown image

Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve{ get; set;}
Visual Basic (Declaration)
Public Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

See Also

LocationCurve Class
Autodesk.Revit Namespace