ControlledApplication Methods
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.

Protected Methods

 | Name | Description

See Also

ControlledApplication
Autodesk.Revit Namespace