Phase Class
See Also Members
CollapseAll image DropDown image

Represents a phase in the life of a building.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("55A3998B-8A8D-472b-B0AE-83BD93ADE3BB")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Phase : Element
Visual Basic (Declaration)
<GuidAttribute("55A3998B-8A8D-472b-B0AE-83BD93ADE3BB")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Phase _
    Inherits Element
Visual C++
[GuidAttribute(L"55A3998B-8A8D-472b-B0AE-83BD93ADE3BB")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Phase

See Also

Phase Members
Autodesk.Revit.Elements Namespace