BeamSystemTypeSetIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a BeamSystem type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("143217D6-F201-4d4a-A359-29CB7074527D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BeamSystemTypeSetIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("143217D6-F201-4d4a-A359-29CB7074527D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BeamSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"143217D6-F201-4d4a-A359-29CB7074527D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BeamSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::BeamSystemTypeSetIterator

See Also

BeamSystemTypeSetIterator Members
Autodesk.Revit.Symbols Namespace