AddSegment Method

Gutter..::AddSegment Method
CollapseAll image DropDown image

Add segments to the gutter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void AddSegment (
    Reference^ targetRef
)

Parameters

targetRef
Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::ArgumentNullException | This exception will be thrown in following cases: - Input targetRef is null.
System..::InvalidOperationException | This exception will be thrown in following cases: 1.Internal code fails to create the segment object. 2.Regeneration fails.
System..::ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges

See Also

Gutter Class
Autodesk.Revit.Elements Namespace