SiteLocation Class
See Also Members
CollapseAll image DropDown image

Contains the geographical location information for the project's site.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("36653144-D399-46c3-ABEE-AED7013FFF8C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SiteLocation : Symbol
Visual Basic (Declaration)
<GuidAttribute("36653144-D399-46c3-ABEE-AED7013FFF8C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SiteLocation _
    Inherits Symbol
Visual C++
[GuidAttribute(L"36653144-D399-46c3-ABEE-AED7013FFF8C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SiteLocation : public Symbol

Remarks

Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Site..::SiteLocation

See Also

SiteLocation Members
Autodesk.Revit.Site Namespace