NewFamilyDocument Method

Application..::NewFamilyDocument Method
CollapseAll image DropDown image

New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document NewFamilyDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewFamilyDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewFamilyDocument (
    String^ templateFileName
)

Parameters

templateFileName
String
The template file name.

Remarks

It is correspond to the File->New->Family.../TitleBlock.../Annotation Symbol....

Exceptions

Exception | Condition
System..::ArgumentException | if 'templateFileName' is a null object or a empty string.
System..::InvalidOperationException | if can not new a family document.

See Also

Application Class
Autodesk.Revit Namespace