Zoom Property

PrintParameters..::Zoom Property
CollapseAll image DropDown image

Retrieve the Zoom value of current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Zoom{ get; set;}
Visual Basic (Declaration)
Public Property Zoom As Integer
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Remarks

This property will control the Paper placement method. It means if user choose Fit to page and then Paper placement property will change to Center.

Exceptions

Exception | Condition
System..::InvalidOperationException | if Current Zoom Type is NOT Zoom.
System..::ArgumentOutOfRangeException | if Zoom value can not less than 1.

See Also

PrintParameters Class
Autodesk.Revit Namespace