BeamSystemType Class
See Also Members
CollapseAll image DropDown image

An object that specifies the type of a beam system in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9F133549-7A7E-4f00-B64E-975A06DEE81A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BeamSystemType : Symbol
Visual Basic (Declaration)
<GuidAttribute("9F133549-7A7E-4f00-B64E-975A06DEE81A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BeamSystemType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"9F133549-7A7E-4f00-B64E-975A06DEE81A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BeamSystemType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::BeamSystemType

See Also

BeamSystemType Members
Autodesk.Revit.Symbols Namespace