PathName Property

Document..::PathName Property
CollapseAll image DropDown image

Call this function to get the fully qualified path of the document's disk file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public string PathName{ get;}
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

The project's fully qualified path. This string is empty if the project has not been saved or does not have a disk file associated with it.

See Also

Document Class
Autodesk.Revit Namespace