AnalyticalModelFrame Class
See Also Members
CollapseAll image DropDown image

Supports Framing Analytical Models (e.g., Beam) that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1FD5C4DD-078B-434d-BFCE-D275E586A295")]
public class AnalyticalModelFrame : AnalyticalModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1FD5C4DD-078B-434d-BFCE-D275E586A295")> _
Public Class AnalyticalModelFrame _
    Inherits AnalyticalModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1FD5C4DD-078B-434d-BFCE-D275E586A295")]
public ref class AnalyticalModelFrame : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelFrame

See Also

AnalyticalModelFrame Members
Autodesk.Revit.Structural Namespace