StructuralType Property

FamilyInstance..::StructuralType Property
CollapseAll image DropDown image

Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StructuralType StructuralType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StructuralType As StructuralType
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace