NewExtrusionRoof Method

Document..::NewExtrusionRoof Method
CollapseAll image DropDown image

Creates a new Extrusion Roof.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ExtrusionRoof NewExtrusionRoof(
    CurveArray profile,
    ReferencePlane refPlane,
    Level level,
    RoofType roofType,
    double extrusionStart,
    double extrusionEnd
)
Visual Basic (Declaration)
Public Function NewExtrusionRoof ( _
    profile As CurveArray, _
    refPlane As ReferencePlane, _
    level As Level, _
    roofType As RoofType, _
    extrusionStart As Double, _
    extrusionEnd As Double _
) As ExtrusionRoof
Visual C++
public:
ExtrusionRoof^ NewExtrusionRoof (
    CurveArray^ profile,
    ReferencePlane^ refPlane,
    Level^ level,
    RoofType^ roofType,
    double extrusionStart,
    double extrusionEnd
)

Parameters

profile
CurveArray
The profile of the extrusion roof.
refPlane
ReferencePlane
The work plane for the extrusion roof.
level
Level
The level of the extrusion roof.
roofType
RoofType
Type of the extrusion roof.
extrusionStart
Double
Start the extrusion.
extrusionEnd
Double
End the extrusion.

See Also

Document Class
Autodesk.Revit.Creation Namespace