Elements Property

Document..::Elements Property
CollapseAll image DropDown image

Provides access to all elements within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIterator Elements{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementIterator
Visual C++
public:
property ElementIterator^ Elements {
    ElementIterator^ get ();
}

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

See Also

Document Class
Autodesk.Revit Namespace