WireTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireTypeSet
Visual Basic (Declaration)
Public Class WireTypeSet
Visual C++
public ref class WireTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireTypeSetWireTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every wire type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire type within the set.
Public method | Erase | Removes a specified wire type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified wire type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of wire types that are in the set.

See Also

WireTypeSet
Autodesk.Revit.Symbols Namespace