MaterialGeneric Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MaterialGeneric
Visual Basic (Declaration)
Public Class MaterialGeneric
Visual C++
public ref class MaterialGeneric

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialGenericMaterialGenericNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this generic material element. (Overrides Material ..:: Duplicate(String).)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Material ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the generic material.
Public property | DampingRatio | Get or set the damping ratio of the generic material.
Public property | MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Public property | Parameter | Overloaded.
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
Public property | ReductionFactor | Get or set the reduction factor for shear of the generic material.
Public property | ShearModulusX | Get or set the x component of the shear modulus of the generic material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the generic material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Public property | UnitWeight | Get or set the unit weight of the generic material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the generic material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the generic material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric
Autodesk.Revit.Elements Namespace