PaperSizeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PaperSizeSet
Visual Basic (Declaration)
Public Class PaperSizeSet
Visual C++
public ref class PaperSizeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PaperSizeSetPaperSizeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet
Autodesk.Revit Namespace