CurtainGrid Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainGrid
Visual Basic (Declaration)
Public Class CurtainGrid
Visual C++
public ref class CurtainGrid

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainGridCurtainGridNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddGridLine | Add a GridLine to the CurtainGrid.
Public method | ChangePanelType | Change type of a curtain panel.
Public method | GetCell | Get the specified cell located by the intersection of the grid lin
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Cells | Get all the cells owned by this curtain grid.
Public property | Grid1Angle | Get/Set the angle for grid1 pattern of the curtain grid.
Public property | Grid1Justification | Get/Set the Justification for grid1 pattern of the curtain grid.
Public property | Grid1Offset | Get/Set the offset for grid1 pattern of the curtain grid.
Public property | Grid2Angle | Get/Set the angle for grid2 pattern of the curtain grid.
Public property | Grid2Justification | Get/Set the Justification for grid2 pattern of the curtain grid.
Public property | Grid2Offset | Get/Set the offset for grid2 pattern of the curtain grid.
Public property | Mullions | Get all the mullions of the curtain grid. The element in this set is an instance of Autodesk::Revit::Elements::Mullion.
Public property | NumPanels | Retrieve the number of panels.
Public property | NumULines | Get the U direction grid line number.
Public property | NumVLines | Get the V direction grid line number.
Public property | Panels | Get all the panels of the curtain grid.
Public property | UGridLines | Return all grid lines of U direction.
Public property | UnlockedMullions | Get all the unlocked mullions of of the curtain grid.
Public property | UnlockedPanels | Get all the unlocked panels of the curtain grid.
Public property | VGridLines | Return all grid lines of V direction.

See Also

CurtainGrid
Autodesk.Revit.Elements Namespace