CurveArray Class
See Also Members
CollapseAll image DropDown image

An array that can contain curves.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("390919CF-F65D-481d-91DD-DB539B87C904")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurveArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("390919CF-F65D-481d-91DD-DB539B87C904")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"390919CF-F65D-481d-91DD-DB539B87C904")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::CurveArray

See Also

CurveArray Members
Autodesk.Revit.Geometry Namespace