MEPModel Property

FamilyInstance..::MEPModel Property
CollapseAll image DropDown image

Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MEPModel MEPModel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property MEPModel As MEPModel
Visual C++
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}

Remarks

If the family instance has a MEP model it is returned by this method, otherwise Nothing is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace