AddFormulaParameter Method

RebarShapeDefinition..::AddFormulaParameter Method
CollapseAll image DropDown image

Add a formula-driven parameter to the shape definition.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter AddFormulaParameter(
    ExternalDefinition param,
    string formula
)
Visual Basic (Declaration)
Public Function AddFormulaParameter ( _
    param As ExternalDefinition, _
    formula As String _
) As Parameter
Visual C++
public:
Parameter^ AddFormulaParameter (
    ExternalDefinition^ param,
    String^ formula
)

Parameters

param
ExternalDefinition
formula
String

Remarks

Like AddParameter(), this function introduces a parameter into the shape definition, but the parameter's value is driven by a formula. Formula parameters cannot be used in constraints to drive the shape. The formula is in the same format as in Revit families. The formula is allowed to refer to other parameters that are already in the definition, plus the builtin parameters REBAR_INSTANCE_BAR_DIAMETER, REBAR_INSTANCE_BEND_DIAMETER, REBAR_SHAPE_START_HOOK_LENGTH, REBAR_SHAPE_START_HOOK_OFFSET, REBAR_SHAPE_END_HOOK_LENGTH, REBAR_SHAPE_END_HOOK_OFFSET, REBAR_ELEM_LENGTH, REBAR_ELEM_TOTAL_LENGTH, and REBAR_ELEM_QUANTITY_OF_BARS.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace