Fascia Class
See Also Members
CollapseAll image DropDown image

An object that represents a fascia within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A4CD9A82-8303-4d63-A00C-2B02C5248200")]
public class Fascia : HostedSweep
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A4CD9A82-8303-4d63-A00C-2B02C5248200")> _
Public Class Fascia _
    Inherits HostedSweep
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A4CD9A82-8303-4d63-A00C-2B02C5248200")]
public ref class Fascia : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::HostedSweep
Autodesk.Revit.Elements..::Fascia

See Also

Fascia Members
Autodesk.Revit.Elements Namespace