ControlledApplication Events
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following events.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

See Also

ControlledApplication
Autodesk.Revit Namespace