WireMaterialType Class
See Also Members
CollapseAll image DropDown image

Represents electrical wire material type definition information of wire type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B21F609A-5889-4184-A288-1204706FE8C0")]
public class WireMaterialType : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B21F609A-5889-4184-A288-1204706FE8C0")> _
Public Class WireMaterialType _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B21F609A-5889-4184-A288-1204706FE8C0")]
public ref class WireMaterialType : public Element

Remarks

All the other properties of wire type are based on wire material type. Only the wire material types which are retrieved from ElectricalSetting can work well, so don't retrieve it from Revit project directly.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::WireMaterialType

See Also

WireMaterialType Members
Autodesk.Revit.Elements Namespace