Application Class
See Also Members
CollapseAll image DropDown image

Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("66D283CE-9E65-4153-91DB-FC0AF80644B3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Application : APIObject
Visual Basic (Declaration)
<GuidAttribute("66D283CE-9E65-4153-91DB-FC0AF80644B3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Application _
    Inherits APIObject
Visual C++
[GuidAttribute(L"66D283CE-9E65-4153-91DB-FC0AF80644B3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Application : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Application

See Also

Application Members
Autodesk.Revit Namespace