DetailLine Class
See Also Members
CollapseAll image DropDown image

Represents a DetailLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("70013D2F-3846-4e0b-87BC-D7271C71244C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DetailLine : DetailCurve
Visual Basic (Declaration)
<GuidAttribute("70013D2F-3846-4e0b-87BC-D7271C71244C")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DetailLine _
    Inherits DetailCurve
Visual C++
[GuidAttribute(L"70013D2F-3846-4e0b-87BC-D7271C71244C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DetailLine : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailLine

See Also

DetailLine Members
Autodesk.Revit.Elements Namespace