Parameters Property

Element..::Parameters Property
CollapseAll image DropDown image

Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterSet Parameters{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterSet
Visual C++
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}

Remarks

The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.

See Also

Element Class
Autodesk.Revit Namespace