BeginTransaction Method

Document..::BeginTransaction Method
CollapseAll image DropDown image

Begins a transaction for the following operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool BeginTransaction()
Visual Basic (Declaration)
Public Function BeginTransaction As Boolean
Visual C++
public:
bool BeginTransaction ()

Return Value

true is returned if the transaction is started successfully, otherwise false will be returned.

Remarks

To begin a new transaction before a series of operation can ensure all the following operations will be done in same transaction, which can avoid inconsistency.

See Also

Document Class
Autodesk.Revit Namespace