Solid Class
See Also Members
CollapseAll image DropDown image

A 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A3A05FE6-7546-4020-B610-A5219CE08687")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Solid : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("A3A05FE6-7546-4020-B610-A5219CE08687")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Solid _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"A3A05FE6-7546-4020-B610-A5219CE08687")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Solid

See Also

Solid Members
Autodesk.Revit.Geometry Namespace