SuspendUpdating Class
See Also Members
CollapseAll image DropDown image

Temporarily delay Revit's automatic updating and consistency operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public class SuspendUpdating : APIObject
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Class SuspendUpdating _
    Inherits APIObject
Visual C++
[ComVisibleAttribute(false)]
public ref class SuspendUpdating : public APIObject

Remarks

Creating an intance of this object will cause Autodesk Revit to suspend certain updating and consistency operation thereby enabling increased performance of large scale changes via the API. When the object is disposed updating will take place if required. The object should be disposed explicitly using the Dispose method to ensure known points of consistency within your application. Note that while this object is active the Revit model data may be inconsistent hence values retrieve from object cannot necessarily be trusted. The object may be nested and the Nested property will return if such an object is already nested. During nesting the final updating will only happen when all SuspendUpdating objects are disposed. Currently suspend updating functionality works primarily with object transformation operations such as move and rotate. Note: This functionality is not available through the Revit COM API. Following methods(properties) support SuspendUpdating: Autodesk.Revit.Document.Move, Autodesk.Revit.Document.Rotate, Autodesk.Revit.Document.Mirror, Autodesk.Revit.Location.Move, Autodesk.Revit.Location.Rotate, Autodesk.Revit.Creation.Document.NewAnnotationSymbol, Autodesk.Revit.Elements.FamilyInstance.flipHand, Autodesk.Revit.Elements.FamilyInstance.flipFacing, Autodesk.Revit.Elements.FamilyInstance.rotate, Autodesk.Revit.Elements.FamilyInstance.FlipFromToRoom, Autodesk.Revit.Elements.CurtainGridLine.Move, property Autodesk.Revit.LocationPoint.Point.set, property Autodesk.Revit.Elements.FamilyInstance.Symbol.set, property Autodesk.Revit.Elements.FamilyInstance.StructuralUsage.set, property Autodesk.Revit.Elements.Wall.WallType.set, property Autodesk.Revit.Elements.TextNote.Coord.set, property Autodesk.Revit.Elements.TextNote.Width.set, property Autodesk.Revit.Elements.IndependentTag.TagHeadPosition.set, property Autodesk.Revit.Elements.IndependentTag.LeaderElbow.set, property Autodesk.Revit.Elements.IndependentTag.LeaderEnd.set, property Autodesk.Revit.Leader.End.set, property Autodesk.Revit.Leader.Elbow.set

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::SuspendUpdating

See Also

SuspendUpdating Members
Autodesk.Revit Namespace