Map Class
See Also Members
CollapseAll image DropDown image

A map that can contain a mapping of any type of object to any other type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A2D913DD-93B3-4db1-AB40-D5B6F792AD29")]
public class Map : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A2D913DD-93B3-4db1-AB40-D5B6F792AD29")> _
Public Class Map _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A2D913DD-93B3-4db1-AB40-D5B6F792AD29")]
public ref class Map : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::Map

See Also

Map Members
Autodesk.Revit.Collections Namespace