DocumentEvents Methods
CollapseAll image DropDown image

Syntax

C#
public interface DocumentEvents
Visual Basic (Declaration)
Public Interface DocumentEvents
Visual C++
public interface class DocumentEvents

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | OnClose | This event is fired before the current document is closed.
Public method | OnSave | This event is fired before the current document is saved.
Public method | OnSaveAs | This event is fired before the current document is saved as another file.

See Also

DocumentEvents
Autodesk.Revit.Events Namespace