Grid Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Grid
Visual Basic (Declaration)
Public Class Grid
Visual C++
public ref class Grid

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | GridGridNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides Element ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | GridType | Get and Set the type of the grid object.
Public property | IsCurved | Test to see if the grid line is curved or straight.
Public property | Parameter | Overloaded.

See Also

Grid
Autodesk.Revit.Elements Namespace