TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData (
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
View
The View for TextNote.
origin
XYZ
Origin of the TextNote.
baseVec
XYZ
BaseVec parameter of the TextNote.
upVec
XYZ
UpVec parameter of the TextNote.
lineWidth
Double
Line width of the out rectangle.
textAlign
TextAlignFlags
Align style.
leaderType
TextNoteLeaderTypes
Leader type as straight or arc.
leaderStyle
TextNoteLeaderStyles
Leader style.
leaderEnd
XYZ
End point of the leader.
leaderElbow
XYZ
Elbow point of the leader.
strText
String
Text.

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace