ElementArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an element array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EA263E94-36C6-4a99-B6F5-7D62A3CEEDB2")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class ElementArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("EA263E94-36C6-4a99-B6F5-7D62A3CEEDB2")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class ElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"EA263E94-36C6-4a99-B6F5-7D62A3CEEDB2")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementArrayIterator

See Also

ElementArrayIterator Members
Autodesk.Revit Namespace