Autodesk.Revit Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit
Visual Basic (Declaration)
Namespace Autodesk.Revit
Visual C++
namespace Autodesk.Revit

Classes

 | Class | Description
Public class | ACADExportOptions | Export options specific to AutoCAD file formats.
Public class | ACADImportOptions | Import options specific to AutoCAD file formats.
Public class | APIObject | Supports all objects in the Autodesk Revit API hierarchy.
Public class | Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class | CADExportOptions | Generic CAD Export options.
Public class | CADImportOptions | Generic CAD Import options.
Public class | Categories | The Categories object is a map that contains all the Category objects within the Document.
Public class | Category | Represents the category or sub category to which an element belongs.
Public class | CategoryFilter | Represents a filter to filter elements with specific category.
Public class | CategoryNameMap | A map that contains a mapping of category name to its category object.
Public class | CategoryNameMapIterator | An iterator to a category name map.
Public class | CategorySet | A set that can contains Category objects.
Public class | CategorySetIterator | An iterator to a category set.
Public class | Color | Represents a color in Autodesk Revit.
Public class | Construction | Construction definition for Project Information.
Public class | ControlledApplication | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class | Document | An object that represents an open Autodesk Revit project.
Public class | DocumentSet | A set that can contain any documents.
Public class | DocumentSetIterator | An iterator to a set of documents.
Public class | DWF2DExportOptions | DWF2D Export options.
Public class | DWF3DExportOptions | DWF3D Export options.
Public class | DWFX2DExportOptions | DWFX2D Export options.
Public class | DWFX3DExportOptions | DWFX3D Export options.
Public class | DWGExportOptions | DWG Export options.
Public class | DWGImportOptions | Import options specific to AutoCAD's DWG file formats.
Public class | Element | Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.
Public class | ElementArray | An array that contains element objects.
Public class | ElementArrayIterator | An iterator to an element array.
Public class | ElementIdSet | A set that can contain Element Ids.
Public class | ElementIdSetIterator | An iterator to a element id set.
Public class | ElementIterator | An iterator object that enable access to every element within the Autodesk Revit project.
Public class | ElementSet | A set that contains element objects.
Public class | ElementSetIterator | An iterator to an element set.
Public class | ExternalApplicationArray | An array that can contain any number of IExternalApplication objects.
Public class | ExternalApplicationArrayIterator | An iterator to an array of IExternalApplication objects..
Public class | ExternalCommandData | A class contains reference to Application and View which are needed by external command.
Public class | FamilyFilter | A filter object that used to filter family elements which satisfy specified criterion, filter elements via specifying family name.
Public class | FBXExportOptions | 3D-Studio Max (FBX) Export options.
Public class | FillPatternSet | A set that contains FillPatterns.
Public class | FillPatternSetIterator | An iterator to a FillPattern set.
Public class | Filter | Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.
Public class | FilterCriterion | An object that defines the criteria as the filter for retrieving certain needed elements.
Public class | FormatOptions | Contains the Unit information of current user selection of Unit within the project.
Public class | GBXMLExportOptions | Gren-Building XML Export options.
Public class | GenericImportOptions | Generic Import options.
Public class | ImageImportOptions | Import options specific image (bitmap) formats.
Public class | InstanceUsageFilter | Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.
Public class | Leader | An object that represents a Leader within the Autodesk Revit project.
Public class | LeaderArray | An array that can contain any number of leaders.
Public class | LeaderArrayIterator | An iterator to an array of leaders.
Public class | LinePatternSet | A set that can contain any number of line patterns.
Public class | LinePatternSetIterator | An iterator to a set.
Public class | Location | Provides location functionality for all elements.
Public class | LocationCurve | Provides location functionality for all elements that are based upon a curve.
Public class | LocationPoint | Provides location functionality for all elements that have a single insertion point.
Public class | LogicAndFilter | The LogicAndFilter is used to implement Logic-AND operation of Filters.
Public class | LogicNotFilter | The LogicNotFilter is used to implement Logic-NOT operation of Filters.
Public class | LogicOrFilter | The LogicOrFilter is used to implement Logic-OR operation of Filters.
Public class | MaterialFilter | Represents a filter to filter elements with the given material.
Public class | Materials | A set of materials that provides access to the materials in an Autodesk Revit project.
Public class | MaterialSet | An set that contains materials.
Public class | MaterialSetIterator | An iterator to a material set.
Public class | MenuItem | Basic unit to build custermized menus.
Public class | MEPSpaceConstruction | Construction definition for Space.
Public class | ObjectFactory | For Internal Use Only.
Public class | PaperSize | An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
Public class | PaperSizeSet | A set that can contain any number of paper size objects.
Public class | PaperSizeSetIterator | An iterator to a set of paper size objects.
Public class | PaperSource | An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
Public class | PaperSourceSet | A set that can contain any number of paper source objects.
Public class | PaperSourceSetIterator | An iterator to a set of paper source objects.
Public class | Parameter | The parameter object contains the value data assigned to that parameter.
Public class | ParameterFilter | To filter elements with specific parameter criterion.
Public class | ParameterMap | A map that can contain a mapping of a parameter name (a String) to a parameter.
Public class | ParameterMapIterator | An iterator to a map relating a parameter name (the key, a String) to a parameter.
Public class | ParameterSet | A set that contains parameters.
Public class | ParameterSetIterator | An iterator to a parameter set.
Public class | ParameterStorage | An object that contains details for the value of a parameter. This class is mainly used with the class FilterCriterion to retrieve Elements according to certain criteria.
Public class | PlanCircuit | An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Public class | PlanCircuitSet | A set that can contain any number of plan circuit objects.
Public class | PlanCircuitSetIterator | An iterator to a set of plan circuit objects.
Public class | PlanTopology | An object that represents a Plan Topology within the Autodesk Revit project.
Public class | PlanTopologySet | A set that can contain any number of plan topology objects.
Public class | PlanTopologySetIterator | An iterator to a set of plan topology objects.
Public class | PostedError | A class that holds information about a posted error.
Public class | PostedErrorArray | An array that can contain any number of posted errors.
Public class | PostedErrorArrayIterator | A class that holds an array of posted errors.
Public class | PrintManager | Represents the Print information in Print Dialog(File->Print) within Autodesk Revit.
Public class | PrintParameters | An object that contains settings used for printing the document.
Public class | PrintSetup | Represents the Print Setup (File->Print Setup...) within Autodesk Revit.
Public class | Selection | Contains the current user selection of elements within the project.
Public class | SelElementSet | This class contains the current user selection of elements within the project.
Public class | Settings | The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Public class | StructuralTypeFilter | A Filter object that represents StructuralType, used to retrieve family instances whose structural type is specified structural type.
Public class | SuspendUpdating | Temporarily delay Revit's automatic updating and consistency operations.
Public class | Symbol | Base class for all Symbols and Types within Autodesk Revit.
Public class | SymbolFilter | A filter object that used to filter symbol elements which satisfy specified criterion, filter elements by specifying symbol name.
Public class | Toolbar | The Toolbar object represents a tool bar, which should contains an array of ToolbarItems.
Public class | ToolbarArray | An array that can contain any number of toolbars.
Public class | ToolbarArrayIterator | An iterator to an array of toolbars.
Public class | ToolbarItem | The ToolbarItem object represents a tool bar item, which should contain the information for creating one tool bar item.
Public class | ToolbarItemArray | An array that can contain any number of toolbar items.
Public class | ToolbarItemArrayIterator | An iterator to an array of toolbar items.
Public class | TrussMemberInfo | Provides access to the information of a truss member in Autodesk Revit.
Public class | TypeFilter | Represents a filter to filter elements with the given type.
Public class | ViewSheetSetting | Represents the View/Sheet Set (File->Print) within Autodesk Revit.
Public class | VolumeCalculationOptions | This class provides access to options related to room volume and area computations.
Public class | VolumeCalculationSetting | This class provides access to settings related to room volume and area computations.
Public class | WallUsageFilter | A Filter object that represents Structural WallUsage, used to retrieve Wall elements whose structural WallUsage is specified WallUsage type.

Structures

 | Structure | Description
Public structure | ElementId | The ElementId object is used as a unique identification for an element within a single project.

Interfaces

 | Interface | Description
Public interface | IExtension | An interface that supports the additonal operation for Extension Status
Public interface | IExternalApplication | An interface that when support provides additional applications within Autodesk Revit implemented by external applications.
Public interface | IExternalCommand | An interface that when support provides additional commands within Autodesk Revit implemented by external applications.

Enumerations

 | Enumeration | Description
Public enumeration | BuiltInCategory | A list of all the built in categories within Revit.
Public enumeration | IExternalApplication..::Result | Informs Autodesk Revit of the status of your application after execution.
Public enumeration | IExternalCommand..::Result | Informs Autodesk Revit of the status of your command after execution.
Public enumeration | JoinType | The type of join at the end of an element. The join type affects only geometric treatment, i.e. cleaning of the end, and not join behavior.
Public enumeration | MenuItem..::MenuType | Type of menu to be created.
Public enumeration | ToolbarItem..::ToolbarItemType | An enumerate type listing all the toolbar item styles.

Send comments about this topic to Autodesk.

ACADExportOptions Class
See Also Members
CollapseAll image DropDown image

Export options specific to AutoCAD file formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7AE51DE2-276A-4a45-A751-D58A923B684D")]
public abstract class ACADExportOptions : CADExportOptions
Visual Basic (Declaration)
<GuidAttribute("7AE51DE2-276A-4a45-A751-D58A923B684D")> _
Public MustInherit Class ACADExportOptions _
    Inherits CADExportOptions
Visual C++
[GuidAttribute(L"7AE51DE2-276A-4a45-A751-D58A923B684D")]
public ref class ACADExportOptions abstract : public CADExportOptions

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::CADExportOptions
Autodesk.Revit..::ACADExportOptions
Autodesk.Revit..::DWGExportOptions

See Also

ACADExportOptions Members
Autodesk.Revit Namespace