ElectricalSetting Methods
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSetting
Visual Basic (Declaration)
Public Class ElectricalSetting
Visual C++
public ref class ElectricalSetting

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddDistributionSysType | Add a new distribution system type to project.
Public method | AddVoltageType | Add a new type definition of voltage into project.
Public method | AddWireMaterialType | Add a new type of wire material.
Public method | AddWireType | Add a new wire type to project.
Public method | GetDemandFactor | Get demand factor information according to specified load classification.
Public method | RemoveDistributionSysType | Remove an existing distribution system type from the project.
Public method | RemoveVoltageType | Remove the voltage type from project.
Public method | RemoveWireMaterialType | Remove the wire material type from project.
Public method | RemoveWireType | Remove wire type definition from project.

Protected Methods

 | Name | Description

See Also

ElectricalSetting
Autodesk.Revit.MEP Namespace