LoadUsageArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadUsageArray
Visual Basic (Declaration)
Public Class LoadUsageArray
Visual C++
public ref class LoadUsageArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadUsageArrayLoadUsageArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the load usage to the end of the array.
Public method | Clear | Removes every load usage from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified load usage into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an load usage at a specified index within the array.
Public property | Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray
Autodesk.Revit.Elements Namespace