PanelType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C06F1A9B-7411-4b1e-AF9D-16453E80E35A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PanelType : FamilySymbol
Visual Basic (Declaration)
<GuidAttribute("C06F1A9B-7411-4b1e-AF9D-16453E80E35A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PanelType _
    Inherits FamilySymbol
Visual C++
[GuidAttribute(L"C06F1A9B-7411-4b1e-AF9D-16453E80E35A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PanelType : public FamilySymbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::FamilySymbol
Autodesk.Revit.Symbols..::PanelType

See Also

PanelType Members
Autodesk.Revit.Symbols Namespace