FillPatternSet Methods
CollapseAll image DropDown image

Syntax

C#
public class FillPatternSet
Visual Basic (Declaration)
Public Class FillPatternSet
Visual C++
public ref class FillPatternSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every fill pattern from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fill pattern within the set.
Public method | Erase | Removes a specified fill pattern from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified fill pattern into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FillPatternSet
Autodesk.Revit Namespace