DemandFactor Class
See Also Members
CollapseAll image DropDown image

Represents a demand factor, which let you adjust the rating of the main service for a building based on the expectation that, at any given time, not all of the electrical equipment will not be drawing at its full rated load. You can specify one or more Demand Factors, applying different Demand Factors to Lighting, Power, HVAC, or Other systems in your project based on their load.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5A8D81EE-BE77-4a53-9A17-845F6417FC59")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DemandFactor : Symbol
Visual Basic (Declaration)
<GuidAttribute("5A8D81EE-BE77-4a53-9A17-845F6417FC59")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DemandFactor _
    Inherits Symbol
Visual C++
[GuidAttribute(L"5A8D81EE-BE77-4a53-9A17-845F6417FC59")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DemandFactor : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::DemandFactor

See Also

DemandFactor Members
Autodesk.Revit.Symbols Namespace