Item Property

GeometryObjectArray..::Item Property
CollapseAll image DropDown image

Gets or sets a geometry object at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual GeometryObject Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As GeometryObject
Visual C++
public:
virtual property GeometryObject^ Item[int index] {
    GeometryObject^ get (int index);
    void set (int index, GeometryObject^ value);
}

Parameters

index
Int32
The index of the geometry object to be set or retrieved.

Return Value

Returns the geometry object at the specified index.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace