AssetProperty Class
See Also Members
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("D72C74E8-D2C8-4e42-876A-707DED2A5067")]
public class AssetProperty : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("D72C74E8-D2C8-4e42-876A-707DED2A5067")> _
Public Class AssetProperty _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"D72C74E8-D2C8-4e42-876A-707DED2A5067")]
public ref class AssetProperty : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Utility..::AssetProperty
Autodesk.Revit.Utility..::AssetProperties
Autodesk.Revit.Utility..::AssetPropertyBoolean
Autodesk.Revit.Utility..::AssetPropertyDistance
Autodesk.Revit.Utility..::AssetPropertyDouble
Autodesk.Revit.Utility..::AssetPropertyDoubleArray2d
Autodesk.Revit.Utility..::AssetPropertyDoubleArray3d
Autodesk.Revit.Utility..::AssetPropertyDoubleArray4d
Autodesk.Revit.Utility..::AssetPropertyDoubleMatrix44
Autodesk.Revit.Utility..::AssetPropertyEnum
Autodesk.Revit.Utility..::AssetPropertyFloat
Autodesk.Revit.Utility..::AssetPropertyInteger
Autodesk.Revit.Utility..::AssetPropertyReference
Autodesk.Revit.Utility..::AssetPropertyString
Autodesk.Revit.Utility..::AssetPropertyTime

See Also

AssetProperty Members
Autodesk.Revit.Utility Namespace