LoadBase Class
See Also Members
CollapseAll image DropDown image

The LoadBase object is the base class for all load objects within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("8AF35A53-05B0-4c95-91EA-FE873C94A3D1")]
public class LoadBase : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("8AF35A53-05B0-4c95-91EA-FE873C94A3D1")> _
Public Class LoadBase _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"8AF35A53-05B0-4c95-91EA-FE873C94A3D1")]
public ref class LoadBase : public Element

Remarks

Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::PointLoad
Autodesk.Revit.Elements..::LineLoad
Autodesk.Revit.Elements..::AreaLoad

See Also

LoadBase Members
Autodesk.Revit.Elements Namespace