WireMaterialType Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class WireMaterialType
Visual Basic (Declaration)
Public Class WireMaterialType
Visual C++
public ref class WireMaterialType

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | WireMaterialTypeWireMaterialTypeNew |

Public Methods

 | Name | Description
Public method | AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
Public method | AddTemperatureRatingType | Add a new temperature rating type into material type.
Public method | RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
Public method | RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Public property | IsInUse | Indicate whether the wire material type is in use.
Public property | Name | Get name of wire material type. (Overrides Element ..:: Name.)
Public property | Parameter | Overloaded.
Public property | TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.

See Also

WireMaterialType
Autodesk.Revit.Elements Namespace