LineScaling Enumeration
CollapseAll image DropDown image

An enumerate type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B8CEDC92-BD91-47a2-9A22-491CA04DC1C4")]
public enum LineScaling
Visual Basic (Declaration)
<GuidAttribute("B8CEDC92-BD91-47a2-9A22-491CA04DC1C4")> _
Public Enumeration LineScaling
Visual C++
[GuidAttribute(L"B8CEDC92-BD91-47a2-9A22-491CA04DC1C4")]
public enum class LineScaling

Members

Member name | Description
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.

Remarks

Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash.

Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.

See Also

Autodesk.Revit.Enums Namespace