BeamBelongsTo Method

BeamSystem..::BeamBelongsTo Method
CollapseAll image DropDown image

Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Visual Basic (Declaration)
Public Shared Function BeamBelongsTo ( _
    beam As FamilyInstance _
) As BeamSystem
Visual C++
public:
static BeamSystem^ BeamBelongsTo (
    FamilyInstance^ beam
)

Parameters

beam
FamilyInstance
The beam want to ask.

Return Value

The BeamSystem.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace