YoungModulus Property

MaterialWood..::YoungModulus Property
CollapseAll image DropDown image

Get or set the Young modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulus{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulus As Double
Visual C++
public:
property double YoungModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the Young modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace