Document Property

Element..::Document Property
CollapseAll image DropDown image

Returns the Document in which the Element resides.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Document Document{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.

See Also

Element Class
Autodesk.Revit Namespace