Duplicate Method

ProjectLocation..::Duplicate Method
CollapseAll image DropDown image

Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectLocation Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As ProjectLocation
Visual C++
public:
ProjectLocation^ Duplicate (
    String^ name
)

Parameters

name
String
The name to be assigned to the duplicated project location.

Return Value

If successful a duplicate of this project location object with the specified name.

Remarks

The name must not be the same as any existing site location objects.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace