RoofBase Class
See Also Members
CollapseAll image DropDown image

Represents all kinds of Roofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("32BA40EA-20B6-4961-AF29-96FAF8EFBE47")]
public class RoofBase : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("32BA40EA-20B6-4961-AF29-96FAF8EFBE47")> _
Public Class RoofBase _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"32BA40EA-20B6-4961-AF29-96FAF8EFBE47")]
public ref class RoofBase : public HostObject

Remarks

The RoofBase object represents all kinds of roof in Revit.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::RoofBase
Autodesk.Revit.Elements..::FootPrintRoof
Autodesk.Revit.Elements..::ExtrusionRoof

See Also

RoofBase Members
Autodesk.Revit.Elements Namespace