ApplicationEvents Members
See Also Methods
CollapseAll image DropDown image

Syntax

C#
public interface ApplicationEvents
Visual Basic (Declaration)
Public Interface ApplicationEvents
Visual C++
public interface class ApplicationEvents

The type exposes the following members.

Public Methods

 | Name | Description
Public method | OnDialogBox | This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.
Public method | OnDocumentClosed | This event is fired after a document is closed.
Public method | OnDocumentNewed | This event is fired after a new document is created.
Public method | OnDocumentOpened | This event is fired after a document is opened.
Public method | OnDocumentSaved | This event is fired after a document is saved.
Public method | OnDocumentSavedAs | This event is fired after a document is saved as another file name.

See Also

ApplicationEvents
Autodesk.Revit.Events Namespace