OnSaveAs Event

Document..::OnSaveAs Event
CollapseAll image DropDown image

Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSaveAsEventHandler OnSaveAs
Visual Basic (Declaration)
Public Event OnSaveAs As DocumentSaveAsEventHandler
Visual C++
public:
 event DocumentSaveAsEventHandler^ OnSaveAs {
    void add (DocumentSaveAsEventHandler^ value);
    void remove (DocumentSaveAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be saved as a file with another name. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace