CompoundStructureLayerArray Methods
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructureLayerArray
Visual Basic (Declaration)
Public Class CompoundStructureLayerArray
Visual C++
public ref class CompoundStructureLayerArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the layer to the end of the array.
Public method | Clear | Removes every layer from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified layer into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CompoundStructureLayerArray
Autodesk.Revit.Structural Namespace