Floor Class
See Also Members
CollapseAll image DropDown image

An object that represents a Floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("7CDB996A-A00C-4b7f-AF5F-CEEFA02CE136")]
public class Floor : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("7CDB996A-A00C-4b7f-AF5F-CEEFA02CE136")> _
Public Class Floor _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"7CDB996A-A00C-4b7f-AF5F-CEEFA02CE136")]
public ref class Floor : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::Floor

See Also

Floor Members
Autodesk.Revit.Elements Namespace