FilterCriterion Class
See Also Members
CollapseAll image DropDown image

An object that defines the criteria as the filter for retrieving certain needed elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3E651097-7CC6-4ce6-BF8F-5BF97009F270")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class FilterCriterion : APIObject
Visual Basic (Declaration)
<GuidAttribute("3E651097-7CC6-4ce6-BF8F-5BF97009F270")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class FilterCriterion _
    Inherits APIObject
Visual C++
[GuidAttribute(L"3E651097-7CC6-4ce6-BF8F-5BF97009F270")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class FilterCriterion : public APIObject

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::FilterCriterion

See Also

FilterCriterion Members
Autodesk.Revit Namespace