Panel Class
See Also Members
CollapseAll image DropDown image

This object represents a curtain panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DCDCF539-A640-4c9f-B12C-C6092F2BC621")]
public class Panel : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DCDCF539-A640-4c9f-B12C-C6092F2BC621")> _
Public Class Panel _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DCDCF539-A640-4c9f-B12C-C6092F2BC621")]
public ref class Panel : public Element

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Panel

See Also

Panel Members
Autodesk.Revit.Elements Namespace