NewViewSection Method

Document..::NewViewSection Method
CollapseAll image DropDown image

Creates a new section view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSection NewViewSection(
    BoundingBoxXYZ box
)
Visual Basic (Declaration)
Public Function NewViewSection ( _
    box As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
ViewSection^ NewViewSection (
    BoundingBoxXYZ^ box
)

Parameters

box
BoundingBoxXYZ
The orientation and bounds of the view. The X direction of the box is right on screen; Y, up; Z, towards the user.

Return Value

The newly created section view.

See Also

Document Class
Autodesk.Revit.Creation Namespace