SetProfile Method

Truss..::SetProfile Method
CollapseAll image DropDown image

Add or modify the profile of a truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetProfile(
    CurveArray topChords,
    CurveArray bottomChords
)
Visual Basic (Declaration)
Public Sub SetProfile ( _
    topChords As CurveArray, _
    bottomChords As CurveArray _
)
Visual C++
public:
void SetProfile (
    CurveArray^ topChords,
    CurveArray^ bottomChords
)

Parameters

topChords
CurveArray
The curves serving as top chords of the truss.
bottomChords
CurveArray
The curves serving as bottom chords of the truss.

See Also

Truss Class
Autodesk.Revit.Elements Namespace