RebarStyle Enumeration
CollapseAll image DropDown image

Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6e20bbaf-da67-4b18-935f-0887928dc84a")]
public enum RebarStyle
Visual Basic (Declaration)
<GuidAttribute("6e20bbaf-da67-4b18-935f-0887928dc84a")> _
Public Enumeration RebarStyle
Visual C++
[GuidAttribute(L"6e20bbaf-da67-4b18-935f-0887928dc84a")]
public enum class RebarStyle

Members

Member name | Description
StirrupTie | A stirrup or tie bar.
Standard | A standard or longitudinal bar.

See Also

Autodesk.Revit.Structural.Enums Namespace