BeamSystem Properties
CollapseAll image DropDown image

Syntax

C#
public class BeamSystem
Visual Basic (Declaration)
Public Class BeamSystem
Visual C++
public ref class BeamSystem

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BeamSystemType | Retrieve or change the type of the BeamSystem.
Public property | BeamType | Retrieve or change the Beam Type of the BeamSystem.
Public property | Direction | Retrieve or change the Direction of the BeamSystem.
Public property | Elevation | Retrieve or change the Elevation of the BeamSystem.
Public property | LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Parameter | Overloaded.
Public property | Profile | Retrieve or set the profile of the BeamSystem.

See Also

BeamSystem
Autodesk.Revit.Elements Namespace