Grid Class
See Also Members
CollapseAll image DropDown image

Represents a single grid line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("584AEACB-B042-48ef-9FC4-5A654083370A")]
public class Grid : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("584AEACB-B042-48ef-9FC4-5A654083370A")> _
Public Class Grid _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"584AEACB-B042-48ef-9FC4-5A654083370A")]
public ref class Grid : public Element

Remarks

Grid lines can either be curved or straight. The Grid object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the contents of the grid lines bubble.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Grid

See Also

Grid Members
Autodesk.Revit.Elements Namespace