ProjectLocationSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocationSet
Visual Basic (Declaration)
Public Class ProjectLocationSet
Visual C++
public ref class ProjectLocationSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectLocationSetProjectLocationSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet
Autodesk.Revit.Site Namespace