Rename Method

PrintSetup..::Rename Method
CollapseAll image DropDown image

Rename the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename (
    String^ newName
)

Parameters

newName
String
print setting name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current print setting list, a InvalidOperationException will be thrown.

See Also

PrintSetup Class
Autodesk.Revit Namespace