Addition Operator

XYZ..::Addition Operator
CollapseAll image DropDown image

Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator + (
    XYZ^ left,
    XYZ^ right
)

Parameters

left
XYZ
The first vector.
right
XYZ
The second vector.

Return Value

The vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace