Autodesk.Revit.Site Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Site
Visual Basic (Declaration)
Namespace Autodesk.Revit.Site
Visual C++
namespace Autodesk.Revit.Site

Classes

 | Class | Description
Public class | City | An object that contains geographical locational informaiton for a known city.
Public class | CitySet | An set that contains cities.
Public class | CitySetIterator | An iterator to a city set.
Public class | ProjectLocation | An object that contains the offset location from the site location of the project
Public class | ProjectLocationSet | An set that contains project locations.
Public class | ProjectLocationSetIterator | An iterator to a project location set.
Public class | ProjectPosition | An object that is used to represent a geographical offset and rotation
Public class | SiteLocation | Contains the geographical location information for the project's site.

City Class
See Also Members
CollapseAll image DropDown image

An object that contains geographical locational informaiton for a known city.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DCC3B2AB-50B7-4722-B08B-A777F484B76E")]
public class City : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DCC3B2AB-50B7-4722-B08B-A777F484B76E")> _
Public Class City _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DCC3B2AB-50B7-4722-B08B-A777F484B76E")]
public ref class City : public APIObject

Remarks

This object contains longitude, latitude, timezone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Site..::City

See Also

City Members
Autodesk.Revit.Site Namespace