PoissonModulusZ Property

MaterialSteel..::PoissonModulusZ Property
CollapseAll image DropDown image

Get or set the z component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusZ{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace