LineLoadTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class LineLoadTypeSet
Visual Basic (Declaration)
Public Class LineLoadTypeSet
Visual C++
public ref class LineLoadTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every lineload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a lineload type within the set.
Public method | Erase | Removes a specified lineload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified lineload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LineLoadTypeSet
Autodesk.Revit.Symbols Namespace