DefinitionsBase Methods
CollapseAll image DropDown image

Syntax

C#
public class DefinitionsBase
Visual Basic (Declaration)
Public Class DefinitionsBase
Visual C++
public ref class DefinitionsBase

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty.
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Erase | Removes a specified definition from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified definition into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

DefinitionsBase
Autodesk.Revit.Parameters Namespace