AreaLoad Properties
CollapseAll image DropDown image

Syntax

C#
public class AreaLoad
Visual Basic (Declaration)
Public Class AreaLoad
Visual C++
public ref class AreaLoad

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Public property | Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Public property | Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Public property | NumCurves | Returns the number of curves within a geometric loop that defines the area.
Public property | NumLoops | Returns the number of geometric curve loops that define the area.
Public property | NumRefPoints | Returns the total number of reference points for the area load.
Public property | Parameter | Overloaded.
Public property | RefPoint | Retrieve the physical location of the reference point.

See Also

AreaLoad
Autodesk.Revit.Elements Namespace