Settings Class
See Also Members
CollapseAll image DropDown image

The settings object provides access to general components of the Autodesk Revit application, such as Categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("20F6047C-6690-49ff-B27F-D5371EDC180A")]
public class Settings : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("20F6047C-6690-49ff-B27F-D5371EDC180A")> _
Public Class Settings _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"20F6047C-6690-49ff-B27F-D5371EDC180A")]
public ref class Settings : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Settings

See Also

Settings Members
Autodesk.Revit Namespace