WallUsage Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible structural usage cases for a Wall object.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A8311F50-E519-4df0-93D3-13229E723261")]
public enum WallUsage
Visual Basic (Declaration)
<GuidAttribute("A8311F50-E519-4df0-93D3-13229E723261")> _
Public Enumeration WallUsage
Visual C++
[GuidAttribute(L"A8311F50-E519-4df0-93D3-13229E723261")]
public enum class WallUsage

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Combined | The wall is subject to combined loads.
Shear | The wall is subject to shear loads.
Bearing | The wall is to be consisdered as load bearing for structural analysis.
NonBearing | The wall is considered non load bearing for structural analysis.

See Also

Autodesk.Revit.Structural.Enums Namespace