Autodesk.Revit.Structural.Enums Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Structural.Enums
Visual Basic (Declaration)
Namespace Autodesk.Revit.Structural.Enums
Visual C++
namespace Autodesk.Revit.Structural.Enums

Enumerations

 | Enumeration | Description
Public enumeration | AnalyticalSupportType | Describes the type of support given by another structural element.
Public enumeration | CompoundStructureDeckUsage | Describes how the deck relates to the surrounding layers.
Public enumeration | CompoundStructureLayerFunction | Describes the purpose of the layer within a compound structure, such as a wall or floor.
Public enumeration | InstanceUsage | An enumerate type listing all the possible structural usage cases for a FamilyInstance object.
Public enumeration | Material | Basic solid structural object material types.
Public enumeration | RebarHookOrientation | Orientation of a rebar hook relative to the path of the Rebar Shape.
Public enumeration | RebarShapeArcReferenceType | A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.
Public enumeration | RebarShapeBendAngle | A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
Public enumeration | RebarShapeDefinitionByArcType | A RebarShapeDefinitionByArc takes one of three forms.
Public enumeration | RebarStyle | Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
Public enumeration | SlabFoundationType | SlabFoundation type.
Public enumeration | StructuralType | Fundamental structural component category.
Public enumeration | TranslationRotationValue | Values for BoundaryConditions Translation and Rotation parameters.
Public enumeration | WallUsage | An enumerate type listing all the possible structural usage cases for a Wall object.

AnalyticalSupportType Enumeration
CollapseAll image DropDown image

Describes the type of support given by another structural element.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("44379A93-5C90-4b9f-9AB8-5646064781CD")]
public enum AnalyticalSupportType
Visual Basic (Declaration)
<GuidAttribute("44379A93-5C90-4b9f-9AB8-5646064781CD")> _
Public Enumeration AnalyticalSupportType
Visual C++
[GuidAttribute(L"44379A93-5C90-4b9f-9AB8-5646064781CD")]
public enum class AnalyticalSupportType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Surface_Support | A Surface support type.
Line_Support | A Line support type.
Point_Support | A Point support type.
Unknown_Support | An unknown support type.

See Also

Autodesk.Revit.Structural.Enums Namespace