CurveArrArrayIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CurveArrArrayIterator
Visual Basic (Declaration)
Public MustInherit Class CurveArrArrayIterator
Visual C++
public ref class CurveArrArrayIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurveArrArrayIteratorCurveArrArrayIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.

See Also

CurveArrArrayIterator
Autodesk.Revit.Geometry Namespace