NewViewPlan Method

Document..::NewViewPlan Method
CollapseAll image DropDown image

Creates a plan view based on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewPlan NewViewPlan(
    string pViewName,
    Level pLevel,
    ViewType viewType
)
Visual Basic (Declaration)
Public Function NewViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    viewType As ViewType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewViewPlan (
    String^ pViewName,
    Level^ pLevel,
    ViewType viewType
)

Parameters

pViewName
String
The name for the new plan view, must be unique or null pointer.
pLevel
Level
The level on which the plan view is to be associated.
viewType
ViewType
The type of plan view to be created, must be Floor Plan or Ceiling Plan (Structural Plan in Structure).

Return Value

if successful, a new plan view object within the project, otherwise Nothing.

Remarks

if pViewName is null, the pLevel's name will be use as new plan view's name. if the name is not unique, an Exception will be thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace