LoadCaseSet Methods
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseSet
Visual Basic (Declaration)
Public Class LoadCaseSet
Visual C++
public ref class LoadCaseSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every load case from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load case within the set.
Public method | Erase | Removes a specified load case from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified load case into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadCaseSet
Autodesk.Revit.Elements Namespace