NewPointBoundaryConditions Method

Document..::NewPointBoundaryConditions Method
CollapseAll image DropDown image

Creates a new Point BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions NewPointBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewPointBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double, _
    Y_Rotation As TranslationRotationValue, _
    Y_RotationSpringModulus As Double, _
    Z_Rotation As TranslationRotationValue, _
    Z_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewPointBoundaryConditions (
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)

Parameters

reference
Reference
The Geometry reference to Beam's, Brace's or Column's analytical line end.
X_Translation
TranslationRotationValue
Translation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_TranslationSpringModulus
Double
Translation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Translation
TranslationRotationValue
Translation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_TranslationSpringModulus
Double
Translation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Translation
TranslationRotationValue
Translation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_TranslationSpringModulus
Double
Translation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"
X_Rotation
TranslationRotationValue
Rotation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_RotationSpringModulus
Double
Rotation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Rotation
TranslationRotationValue
Rotation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_RotationSpringModulus
Double
Rotation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Rotation
TranslationRotationValue
Rotation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_RotationSpringModulus
Double
Rotation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"

Return Value

If successful, NewPointBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 0 - "Point". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace