PathReinforcement Class
See Also Members
CollapseAll image DropDown image

An object that represents an Path Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C10B5ECE-E37F-4d78-B28C-E8A50F0862CF")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PathReinforcement : Element
Visual Basic (Declaration)
<GuidAttribute("C10B5ECE-E37F-4d78-B28C-E8A50F0862CF")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PathReinforcement _
    Inherits Element
Visual C++
[GuidAttribute(L"C10B5ECE-E37F-4d78-B28C-E8A50F0862CF")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PathReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Path Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::PathReinforcement

See Also

PathReinforcement Members
Autodesk.Revit.Elements Namespace