Item Property

BoundarySegmentArray..::Item Property
CollapseAll image DropDown image

Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual BoundarySegment Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace