CurveArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a curve array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("2AA28DDC-B988-40d6-93AD-69E770EAF920")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class CurveArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("2AA28DDC-B988-40d6-93AD-69E770EAF920")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class CurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"2AA28DDC-B988-40d6-93AD-69E770EAF920")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::CurveArrayIterator

See Also

CurveArrayIterator Members
Autodesk.Revit.Geometry Namespace