Autodesk.Revit.Collections Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Collections
Visual Basic (Declaration)
Namespace Autodesk.Revit.Collections
Visual C++
namespace Autodesk.Revit.Collections

Classes

 | Class | Description
Public class | Array | An array that can contain any type of object.
Public class | ArrayIterator | An iterator to a array.
Public class | DefinitionBindingMap | A map that contains mappings of parameter definitions to parameter bindings.
Public class | DefinitionBindingMapIterator | An iterator to a parameter definition to parameter bindings map.
Public class | Map | A map that can contain a mapping of any type of object to any other type of object.
Public class | MapIterator | An iterator to a map.
Public class | Set | A set that can contain any type of object.
Public class | SetIterator | An iterator to a set.
Public class | StringStringMap | A map that can contain a mapping of a string to another string.
Public class | StringStringMapIterator | An iterator to a string to string map.

Array Class
See Also Members
CollapseAll image DropDown image

An array that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A807ABA2-D7E9-4a97-974A-8A17F360DCC8")]
public class Array : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A807ABA2-D7E9-4a97-974A-8A17F360DCC8")> _
Public Class Array _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A807ABA2-D7E9-4a97-974A-8A17F360DCC8")]
public ref class Array : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::Array

See Also

Array Members
Autodesk.Revit.Collections Namespace