Autodesk.Revit.MEP.Enums Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.MEP.Enums
Visual Basic (Declaration)
Namespace Autodesk.Revit.MEP.Enums
Visual C++
namespace Autodesk.Revit.MEP.Enums

Enumerations

 | Enumeration | Description
Public enumeration | BaseLoadOn | An enumerate type listing all the possible Power Load Unit for a Space object.
Public enumeration | ConditionType | An enumerate type listing all the possible Return Airflow Type for a Space object.
Public enumeration | ConnectorProfileType | An enumerate type listing all the Connector type for the Connection.
Public enumeration | ConnectorType | An enumerate type listing all the Connector type for the Connection.
Public enumeration | Domain | An enumerate type listing all the Domain type for the Connector.
Public enumeration | DuctSystemType | An enumerate type listing all the possible Duct System Types for a Duct Connector object.
Public enumeration | ElectricalPhase | An enumerate type to specify weather the electrical system is single phase or three phases.
Public enumeration | ElectricalPhaseConfiguration | An enumerate type to specify electrical phase configuration.
Public enumeration | ElectricalSystemType | An enumerate type listing all the possible Pipe System Types for a Duct Connector object.
Public enumeration | LoadClassification | An enumerate type to list all demond factor classification.
Public enumeration | LoadClassificationType | An enumerate type listing all the possible Load Classification Type for a Connector object.
Public enumeration | OccupancyUnit | An enumerate type listing all the possible Occupancy Unit for a Space object.
Public enumeration | PipeSystemType | An enumerate type listing all the possible Pipe System Types for a Duct Connector object.
Public enumeration | PowerFactorStateType | An enumerate type listing all the possible Power Factor State Type for a Connector object.
Public enumeration | ReturnAirflowType | An enumerate type listing all the possible Return Airflow Type for a Space object.
Public enumeration | SpaceType | An enumerate type listing all the possible Space Type for a Space object.
Public enumeration | WiringType | An enumerate type to list all wiring type.

BaseLoadOn Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Power Load Unit for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9463CF2C-9D70-46cb-8A97-712F6BDBD5D8")]
public enum BaseLoadOn
Visual Basic (Declaration)
<GuidAttribute("9463CF2C-9D70-46cb-8A97-712F6BDBD5D8")> _
Public Enumeration BaseLoadOn
Visual C++
[GuidAttribute(L"9463CF2C-9D70-46cb-8A97-712F6BDBD5D8")]
public enum class BaseLoadOn

Members

Member name | Description
kNoOfBaseLoadOnMethods | Return BaseLoadOn is NoOfBaseLoadOnMethods.
kUseActualLoad | Return BaseLoadOn is UseActualLoad.
kUseCalculatedLoad | Return BaseLoadOn is UseCalculatedLoad.
kUseEnteredLoad | Return BaseLoadOn is UseEnteredLoad.
kUseDefaultLoad | Return BaseLoadOn is UseDefaultLoad.

See Also

Autodesk.Revit.MEP.Enums Namespace