AreaReinforcement Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AreaReinforcement
Visual Basic (Declaration)
Public Class AreaReinforcement
Visual C++
public ref class AreaReinforcement

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaReinforcementAreaReinforcementNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | AreaReinforcementType | Retrieves the type of the Area Reinforcement.
Public property | BarDescription | Retrieves the Bar Table property of an Area Reinforcement element.
Public property | Curves | Retrieves the array of curves forming the boundary of the Area Reinforcement.
Public property | Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes.
Public property | Parameter | Overloaded.

See Also

AreaReinforcement
Autodesk.Revit.Elements Namespace