CompoundStructureLayerFunction Enumeration
CollapseAll image DropDown image

Describes the purpose of the layer within a compound structure, such as a wall or floor.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A7423B7D-229D-4928-8FA2-8E9C8377F0E5")]
public enum CompoundStructureLayerFunction
Visual Basic (Declaration)
<GuidAttribute("A7423B7D-229D-4928-8FA2-8E9C8377F0E5")> _
Public Enumeration CompoundStructureLayerFunction
Visual C++
[GuidAttribute(L"A7423B7D-229D-4928-8FA2-8E9C8377F0E5")]
public enum class CompoundStructureLayerFunction

Members

Member name | Description
StructuralDeck | A special layer considered to be structural decking.
MembraneLayer | A membrane layer.
Finish2 | A finish layer.
Finish1 | A finish layer.
ThermalOrAir | A thermal or air insulating layer.
Substrate | A substrate layer.
Structure | A structural layer.

See Also

Autodesk.Revit.Structural.Enums Namespace