Key Property

ParameterMapIterator..::Key Property
CollapseAll image DropDown image

Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual string Key{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace