DefinitionGroupsBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionGroupsBase
Visual Basic (Declaration)
Public Class DefinitionGroupsBase
Visual C++
public ref class DefinitionGroupsBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionGroupsBaseDefinitionGroupsBaseNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every definition group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a definition group within the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase
Autodesk.Revit.Parameters Namespace