ProjectLocationSet Methods
CollapseAll image DropDown image

Syntax

C#
public class ProjectLocationSet
Visual Basic (Declaration)
Public Class ProjectLocationSet
Visual C++
public ref class ProjectLocationSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ProjectLocationSet
Autodesk.Revit.Site Namespace