TemperatureRatingType Class
See Also Members
CollapseAll image DropDown image

Represents temperature rating type definition information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1FC97013-70F5-4f2e-98AA-48444E82249A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class TemperatureRatingType : Element
Visual Basic (Declaration)
<GuidAttribute("1FC97013-70F5-4f2e-98AA-48444E82249A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class TemperatureRatingType _
    Inherits Element
Visual C++
[GuidAttribute(L"1FC97013-70F5-4f2e-98AA-48444E82249A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TemperatureRatingType : public Element

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type informations such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::TemperatureRatingType

See Also

TemperatureRatingType Members
Autodesk.Revit.Elements Namespace