ConnectorProfileType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the Connector type for the Connection.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9E3C967E-8ED0-4dab-8860-02EE39E086E5")]
public enum ConnectorProfileType
Visual Basic (Declaration)
<GuidAttribute("9E3C967E-8ED0-4dab-8860-02EE39E086E5")> _
Public Enumeration ConnectorProfileType
Visual C++
[GuidAttribute(L"9E3C967E-8ED0-4dab-8860-02EE39E086E5")]
public enum class ConnectorProfileType

Members

Member name | Description
OvalProfile | Connection Profile Type is Oval.
RectProfile | Connection Profile Type is Rect.
RoundProfile | Connection Profile Type is Round.
InvalidProfile | Connection Profile Type is Invalid.

See Also

Autodesk.Revit.MEP.Enums Namespace