RebarHostData Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarHostData
Visual Basic (Declaration)
Public Class RebarHostData
Visual C++
public ref class RebarHostData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarHostDataRebarHostDataNew | For Internal Use Only.

Public Methods

 | Name | Description
 | getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | HasCoverTypeForReference | Checks whether the reference has an associated cover.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | CoverType | Gets the RebarCoverType associated with a face of the element.
Public property | Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData
Autodesk.Revit.Elements Namespace