ReferencePlane Class
See Also Members
CollapseAll image DropDown image

Represents a reference plane of Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("11F1777D-1062-42de-B6A5-1DAA64AF620C")]
public class ReferencePlane : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("11F1777D-1062-42de-B6A5-1DAA64AF620C")> _
Public Class ReferencePlane _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"11F1777D-1062-42de-B6A5-1DAA64AF620C")]
public ref class ReferencePlane : public Element

Remarks

This object is derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also has many methods to set the specific properties of the reference plane

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ReferencePlane

See Also

ReferencePlane Members
Autodesk.Revit.Elements Namespace