AnalyticalSupportData Class
See Also Members
CollapseAll image DropDown image

Information for one support of another Structural Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("952A7D6E-D70D-4d3d-BEC1-1C0540D63081")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalSupportData : APIObject
Visual Basic (Declaration)
<GuidAttribute("952A7D6E-D70D-4d3d-BEC1-1C0540D63081")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalSupportData _
    Inherits APIObject
Visual C++
[GuidAttribute(L"952A7D6E-D70D-4d3d-BEC1-1C0540D63081")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalSupportData : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalSupportData

See Also

AnalyticalSupportData Members
Autodesk.Revit.Structural Namespace