Valid Property

RebarHostData..::Valid Property
CollapseAll image DropDown image

Returns whether the element is a valid rebar host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Valid{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Valid As Boolean
Visual C++
public:
property bool Valid {
    bool get ();
}

Remarks

If getRebarHostData() returns an invalid RebarHostData, this means that the element can be made a valid rebar host, generally by setting a property like FLOOR_PARAM_IS_STRUCTURAL or by changing the element's physical material to concrete. On the other hand, if getRebarHostData() returns null, the element cannot be made into a rebar host.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace