FilterCriterion Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FilterCriterion
Visual Basic (Declaration)
Public Class FilterCriterion
Visual C++
public ref class FilterCriterion

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterCriterionFilterCriterionNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | FilterType | Gets or sets the filter type of this criterion.
Public property | Parameter | Gets or sets the parameter of this criterion by builtin parameter.
Public property | ParameterID | Gets or sets the parameter of this criterion by parameter id.
Public property | ParameterValue | Gets or sets the parameter value of this criterion.

See Also

FilterCriterion
Autodesk.Revit Namespace