Area Class
See Also Members
CollapseAll image DropDown image

Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("576F8B9E-55DE-4E08-B520-C0B922FBEA0E")]
public class Area : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("576F8B9E-55DE-4E08-B520-C0B922FBEA0E")> _
Public Class Area _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"576F8B9E-55DE-4E08-B520-C0B922FBEA0E")]
public ref class Area : public Element

Remarks

The area object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Area

See Also

Area Members
Autodesk.Revit.Elements Namespace