DefinitionGroup Class
See Also Members
CollapseAll image DropDown image

The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("37059293-783E-41df-A9DF-5A4B3F87251C")]
public class DefinitionGroup : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("37059293-783E-41df-A9DF-5A4B3F87251C")> _
Public Class DefinitionGroup _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"37059293-783E-41df-A9DF-5A4B3F87251C")]
public ref class DefinitionGroup : public APIObject

Remarks

Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionGroup

See Also

DefinitionGroup Members
Autodesk.Revit.Parameters Namespace