MapIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("79C1ABA9-849D-4a53-8B31-268C85D05056")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class MapIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("79C1ABA9-849D-4a53-8B31-268C85D05056")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class MapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"79C1ABA9-849D-4a53-8B31-268C85D05056")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Collections..::MapIterator

See Also

MapIterator Members
Autodesk.Revit.Collections Namespace