OnDocumentOpened Event

ControlledApplication..::OnDocumentOpened Event
CollapseAll image DropDown image

Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometime a document will be opened during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as get some elements from the opened document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace