LightingFixture Class
See Also Members
CollapseAll image DropDown image

Provides access to the Lighting Fixture in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("70CDB95F-C739-459c-929A-A25C22C2C760")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LightingFixture : MEPModel
Visual Basic (Declaration)
<GuidAttribute("70CDB95F-C739-459c-929A-A25C22C2C760")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LightingFixture _
    Inherits MEPModel
Visual C++
[GuidAttribute(L"70CDB95F-C739-459c-929A-A25C22C2C760")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LightingFixture : public MEPModel

Remarks

The Lighting Fixture object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::LightingFixture

See Also

LightingFixture Members
Autodesk.Revit.MEP Namespace