FasciaType Class
See Also Members
CollapseAll image DropDown image

An object that represents the fascia type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F57677B3-E404-47db-A65C-ED1B41BAFAE5")]
public class FasciaType : HostedSweepType
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F57677B3-E404-47db-A65C-ED1B41BAFAE5")> _
Public Class FasciaType _
    Inherits HostedSweepType
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F57677B3-E404-47db-A65C-ED1B41BAFAE5")]
public ref class FasciaType : public HostedSweepType

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::HostedSweepType
Autodesk.Revit.Symbols..::FasciaType

See Also

FasciaType Members
Autodesk.Revit.Symbols Namespace