MaterialSet Class
See Also Members
CollapseAll image DropDown image

An set that contains materials.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BEA2B6C7-76C1-46d7-8B40-A31E82132BCA")]
public class MaterialSet : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BEA2B6C7-76C1-46d7-8B40-A31E82132BCA")> _
Public Class MaterialSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BEA2B6C7-76C1-46d7-8B40-A31E82132BCA")]
public ref class MaterialSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::MaterialSet
Autodesk.Revit..::Materials

See Also

MaterialSet Members
Autodesk.Revit Namespace