InstanceBinding Class
See Also Members
CollapseAll image DropDown image

The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("BE524CB5-D553-4948-A0FC-3402347230D8")]
public class InstanceBinding : ElementBinding
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("BE524CB5-D553-4948-A0FC-3402347230D8")> _
Public Class InstanceBinding _
    Inherits ElementBinding
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"BE524CB5-D553-4948-A0FC-3402347230D8")]
public ref class InstanceBinding : public ElementBinding

Remarks

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding
Autodesk.Revit.Parameters..::InstanceBinding

See Also

InstanceBinding Members
Autodesk.Revit.Parameters Namespace