Duplicate Method

Material..::Duplicate Method
CollapseAll image DropDown image

Duplicates the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public MustOverride Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate (
    String^ name
) abstract

Parameters

name
String
Name of the new material.

Return Value

The new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, a null pointer will be returned.

See Also

Material Class
Autodesk.Revit.Elements Namespace