NurbSpline Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class NurbSpline
Visual Basic (Declaration)
Public Class NurbSpline
Visual C++
public ref class NurbSpline

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | NurbSplineNurbSplineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | isClosed | Return/set the nurb spline's isClosed property.
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline
Autodesk.Revit.Geometry Namespace