GeometryObject Class
See Also Members
CollapseAll image DropDown image

The common base class for all geometric primitives.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1E32AE6C-FD44-4e70-8A8F-B10899AF59CE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GeometryObject : APIObject
Visual Basic (Declaration)
<GuidAttribute("1E32AE6C-FD44-4e70-8A8F-B10899AF59CE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GeometryObject _
    Inherits APIObject
Visual C++
[GuidAttribute(L"1E32AE6C-FD44-4e70-8A8F-B10899AF59CE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GeometryObject : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Profile
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::Edge
Autodesk.Revit.Geometry..::Element
Autodesk.Revit.Geometry..::Mesh
Autodesk.Revit.Geometry..::Instance
Autodesk.Revit.Geometry..::Solid

See Also

GeometryObject Members
Autodesk.Revit.Geometry Namespace