ViewDirection Property

View..::ViewDirection Property
CollapseAll image DropDown image

The direction towards the viewer.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ ViewDirection{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ViewDirection As XYZ
Visual C++
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}

Remarks

In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.

See Also

View Class
Autodesk.Revit.Elements Namespace