Dimension Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Dimension
Visual Basic (Declaration)
Public Class Dimension
Visual C++
public ref class Dimension

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DimensionDimensionNew |

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Curve | A curve that represents the dimension line.
Public property | DimensionType | The dimension style of this dimension.
Public property | Name | Retrieve or Change the name associated with the Dimension.
Public property | Parameter | Overloaded.
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension
Autodesk.Revit.Elements Namespace