Room Properties
CollapseAll image DropDown image

Syntax

C#
public class Room
Visual Basic (Declaration)
Public Class Room
Visual C++
public ref class Room

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | Get the Area of the Room.
Public property | BaseOffset | Get or Set the Base Offset of the Room.
Public property | Boundary | Returns the boundary of the room.
Public property | ClosedShell | Return the closedShell of the Room.
Public property | LimitOffset | Get or Set the Limit Offset of the Room.
Public property | Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element ..:: Location.)
Public property | Name | Get or Set the Name of the room. (Overrides Element ..:: Name.)
Public property | Number | Get or Set the Number of the Room.
Public property | Parameter | Overloaded.
Public property | Perimeter | Get the Perimeter of the Room.
Public property | UnboundedHeight | Get the Unbounded Height of the Room.
Public property | UpperLimit | Get or Set the Upper Limit of the Room.
Public property | Volume | Get the Volume of the Room.

See Also

Room
Autodesk.Revit.Elements Namespace