Ellipse Class
See Also Members
CollapseAll image DropDown image

A whole or partial ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("99427A0B-C429-44ac-8510-3F798396D14F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Ellipse : Curve
Visual Basic (Declaration)
<GuidAttribute("99427A0B-C429-44ac-8510-3F798396D14F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Ellipse _
    Inherits Curve
Visual C++
[GuidAttribute(L"99427A0B-C429-44ac-8510-3F798396D14F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Ellipse : public Curve

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Ellipse

See Also

Ellipse Members
Autodesk.Revit.Geometry Namespace