NewLine Method

Application..::NewLine Method
CollapseAll image DropDown image

Creates a new bound or unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line NewLine(
    XYZ point,
    XYZ endOrDirection,
    bool bound
)
Visual Basic (Declaration)
Public Function NewLine ( _
    point As XYZ, _
    endOrDirection As XYZ, _
    bound As Boolean _
) As Line
Visual C++
public:
Line^ NewLine (
    XYZ^ point,
    XYZ^ endOrDirection,
    bool bound
)

Parameters

point
XYZ
A start point or a point through which the line will pass.
endOrDirection
XYZ
An end point of a vector for the direction of the line.
bound
Boolean
Set to True if you wish the line to be bound or False is the line is to be infinite.

Return Value

Returns a new bounded or unbounded line object.

Remarks

If the bound parameter is False then the point parameter is considered to be a point on the line and the endOrDirection parameter is considered to be a directional vector. If the bound parameter is True then the point parameter is considered to be the start of the line and the endOrDirection parameter is considered to be the end of the line.

See Also

Application Class
Autodesk.Revit.Creation Namespace