View Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class View
Visual Basic (Declaration)
Public Class View
Visual C++
public ref class View

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewViewNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view.
Public method | getVisibility | get category visible of this view.
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | CanBePrinted | Test whether the view can be printed.
Public property | CropBox | The crop box sets display bounds of the view.
Public property | CropBoxActive | Active of the Crop Box/Region.
Public property | CropBoxVisible | Visibility of the Crop Box/Region.
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view.
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
Public property | Elements | Set of all elements that will be drawn in the view.
Public property | GenLevel | The level which generate this View.
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in inches).
Public property | Parameter | Overloaded.
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewName | The name of the view.
Public property | ViewType | The type of the view.

See Also

View
Autodesk.Revit.Elements Namespace