LineLoad Class
See Also Members
CollapseAll image DropDown image

An object that represents a force/moment applied in a linear manner.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B60742B1-4D95-4e65-A404-C24EC450DAA4")]
public class LineLoad : LoadBase
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B60742B1-4D95-4e65-A404-C24EC450DAA4")> _
Public Class LineLoad _
    Inherits LoadBase
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B60742B1-4D95-4e65-A404-C24EC450DAA4")]
public ref class LineLoad : public LoadBase

Remarks

The load/moment may be uniform or it may vary between the two ends of the line.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::LineLoad

See Also

LineLoad Members
Autodesk.Revit.Elements Namespace