FamilySymbolSet Methods
CollapseAll image DropDown image

Syntax

C#
public class FamilySymbolSet
Visual Basic (Declaration)
Public Class FamilySymbolSet
Visual C++
public ref class FamilySymbolSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every symbol from the set, rendering it empty.
Public method | Contains | Tests for the existence of a family symbol within the set.
Public method | Erase | Removes a specified family symbol from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified family symbol into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FamilySymbolSet
Autodesk.Revit.Symbols Namespace