Selection Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Selection
Visual Basic (Declaration)
Public Class Selection
Visual C++
public ref class Selection

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SelectionSelectionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | PickOne | Allows the user to select one element.
Public method | WindowSelect | Allows the user to select elements by a rectangle.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Elements | The elements that are currently selected.
Public property | StatusbarTip | The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection
Autodesk.Revit Namespace