FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
StructuralType
Specify if the family instance is structural.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace