SaveAs Method

PrintSetup..::SaveAs Method
CollapseAll image DropDown image

Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ newName
)

Parameters

newName
String
print setting name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current print setting list, a InvalidOperationException will be thrown.

See Also

PrintSetup Class
Autodesk.Revit Namespace