ModelCurve Properties
CollapseAll image DropDown image

Syntax

C#
public class ModelCurve
Visual Basic (Declaration)
Public Class ModelCurve
Visual C++
public ref class ModelCurve

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | GeometryCurve | Get or set the geometry curve of the model line.
Public property | LineStyles | Returns all line style of the curve.
Public property | Parameter | Overloaded.
Public property | SketchPlane | Get or set the sketch the model line resides in.

See Also

ModelCurve
Autodesk.Revit.Elements Namespace