PlanCircuit Class
See Also Members
CollapseAll image DropDown image

An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("6B098CEE-319E-429c-B7CB-99637A65FA60")]
public class PlanCircuit : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("6B098CEE-319E-429c-B7CB-99637A65FA60")> _
Public Class PlanCircuit _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"6B098CEE-319E-429c-B7CB-99637A65FA60")]
public ref class PlanCircuit : public APIObject

Remarks

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of romms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanCircuit

See Also

PlanCircuit Members
Autodesk.Revit Namespace