RebarShapeDefinition Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarShapeDefinitionRebarShapeDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition.
Public method | AddParameter | Add a parameter to the shape definition.
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Public method | Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained.

See Also

RebarShapeDefinition
Autodesk.Revit.Symbols Namespace