Material Enumeration
CollapseAll image DropDown image

Basic solid structural object material types.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("514AE874-4CD8-4a82-B382-F3639007B731")]
public enum Material
Visual Basic (Declaration)
<GuidAttribute("514AE874-4CD8-4a82-B382-F3639007B731")> _
Public Enumeration Material
Visual C++
[GuidAttribute(L"514AE874-4CD8-4a82-B382-F3639007B731")]
public enum class Material

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
PrecastConcrete | The object is considered to be made of precast concrete.
Other | The material is defined, but it is not steel, concrete , wood or precast concrete.
Wood | The object is considered to be made of wood.
Concrete | The object is considered to be made of concrete.
Steel | The object is considered to be made of steel.
Undefined | The material for this object has not been defined.

See Also

Autodesk.Revit.Structural.Enums Namespace