ElectricalEquipment Class
See Also Members
CollapseAll image DropDown image

Provides access to the Electrical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F454E07F-A071-4911-8D2B-B8E6403292AC")]
public class ElectricalEquipment : MEPModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F454E07F-A071-4911-8D2B-B8E6403292AC")> _
Public Class ElectricalEquipment _
    Inherits MEPModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F454E07F-A071-4911-8D2B-B8E6403292AC")]
public ref class ElectricalEquipment : public MEPModel

Remarks

The Electrical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::ElectricalEquipment

See Also

ElectricalEquipment Members
Autodesk.Revit.MEP Namespace