Dimension Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("904E6686-E3C8-4664-A27D-BA17F223329D")]
public class Dimension : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("904E6686-E3C8-4664-A27D-BA17F223329D")> _
Public Class Dimension _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"904E6686-E3C8-4664-A27D-BA17F223329D")]
public ref class Dimension : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Dimension
Autodesk.Revit.Elements..::SpotDimension

See Also

Dimension Members
Autodesk.Revit.Elements Namespace