LayoutRuleMaximumSpacing Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Max-Spacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("DA1A1817-CCC4-4a5b-9ABF-BA37778F0264")]
public class LayoutRuleMaximumSpacing : LayoutRule
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("DA1A1817-CCC4-4a5b-9ABF-BA37778F0264")> _
Public Class LayoutRuleMaximumSpacing _
    Inherits LayoutRule
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"DA1A1817-CCC4-4a5b-9ABF-BA37778F0264")]
public ref class LayoutRuleMaximumSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleMaximumSpacing

See Also

LayoutRuleMaximumSpacing Members
Autodesk.Revit.Elements Namespace