BoundarySegmentArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F7E829EB-2266-4f0a-9BC5-67554B01C307")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class BoundarySegmentArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("F7E829EB-2266-4f0a-9BC5-67554B01C307")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"F7E829EB-2266-4f0a-9BC5-67554B01C307")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Rooms Namespace