IExternalApplication Interface
See Also Members
CollapseAll image DropDown image

An interface that when support provides additional applications within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B2C17B9E-54E6-4147-A320-77450D57265A")]
public interface IExternalApplication
Visual Basic (Declaration)
<GuidAttribute("B2C17B9E-54E6-4147-A320-77450D57265A")> _
Public Interface IExternalApplication
Visual C++
[GuidAttribute(L"B2C17B9E-54E6-4147-A320-77450D57265A")]
public interface class IExternalApplication

Remarks

To add an external application to Autodesk Revit the developer should implement an object that supports the IExternalApplication interface.

See Also

IExternalApplication Members
Autodesk.Revit Namespace