Document Members
See Also Methods Properties Constructors Events
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DocumentDocumentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AbortTransaction | Abort a transaction for specified document.
Public method | Array | Overloaded.
Public method | ArrayWithoutAssociate | Overloaded.
Public method | BeginTransaction | Overloaded.
Public method | Close | Overloaded.
Public method | Delete | Overloaded.
Public method | EndTransaction | Overloaded.
Public method | Export | Overloaded.
Public method | Import | Overloaded.
Public method | LoadFamily | Overloaded.
Public method | LoadFamilySymbol | Overloaded.
Public method | Mirror | Overloaded.
Public method | Move | Overloaded.
Public method | Print | Overloaded.
Public method | Rotate | Overloaded.
Public method | Save | Overloaded.
Public method | SaveAs | Overloaded.
Public method | ShowElements | Overloaded.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Public property | BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
Public property | ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
Public property | DeckProfiles | Returns an object that contains all of the avaible deck profiles currently loaded to this project.
Public property | DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | ElectricalEquipmentTypes | Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.
Public property | Element | Overloaded.
Public property | Elements | Overloaded.
Public property | FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
Public property | FilterTypeSupported | Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.
Public property | FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
Public property | GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
Public property | GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
Public property | IsModified | Reports if the document has been modified since it was last saved.
Public property | IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
Public property | IsWorkshared | Identifies if worksets have been enabled in the document.
Public property | LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
Public property | LightingDeviceTypes | Returns an object that contains all of the avaible lighting device types currently loaded to this project.
Public property | LightingFixtureTypes | Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.
Public property | MechanicalEquipmentTypes | Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | Call this function to get the fully qualified path of the document's disk file.
Public property | Phases | Retrieves all the object that represent phases within the project.
Public property | PlanTopologies | Overloaded.
Public property | PlanTopology | Overloaded.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | PrintSettings | Retrieve all Print Settings of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ProjectUnit | Provides access to Project Unit Setting with in the document.
Public property | ReactionsAreUpToDate | Reports whether the reactionary loads have changed.
Public property | RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
Public property | RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
Public property | RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
Public property | RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
Public property | RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
Public property | RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | Selection | Retrieve the currently selected Elements in Autodesk Revit.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
Public property | SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
Public property | TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Public property | Title | Call this function to get the project's title, which is usually derived from the project's filename.
Public property | TitleBlocks | Titleblocks currently loaded into the document.
Public property | TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
Public property | TypeOfStorage | Get the storage type of the specified builtin parameter.
Public property | ViewSheetSets | The view sheet sets stored in the document.
Public property | WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
Public property | WorksharingCentralFilename | The name and path of the central file name for a workshared document.

Public Events

 | Name | Description
Public event | OnClose | Subscribe to the OnClose event to be notified before the current document is closed.
Public event | OnSave | Subscribe to the OnSave event to be notified before a document has been saved.
Public event | OnSaveAs | Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

See Also

Document
Autodesk.Revit Namespace