IExternalCommand..::Result Enumeration
CollapseAll image DropDown image

Informs Autodesk Revit of the status of your command after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("93E200E9-2024-4e04-9E3A-C4EDCCD67B8B")]
public enum Result
Visual Basic (Declaration)
<GuidAttribute("93E200E9-2024-4e04-9E3A-C4EDCCD67B8B")> _
Public Enumeration Result
Visual C++
[GuidAttribute(L"93E200E9-2024-4e04-9E3A-C4EDCCD67B8B")]
public enum class Result

Members

Member name | Description
Cancelled | Signifies that the user cancelled the external command. Autodesk Revit should undo any changes made by the external command but not signal a failure.
Succeeded | The external command completed successfully. Autodesk Revit will keep any changes made by the external command.
Failed | The external command was unable to complete its task. Autodesk Revit should undo any operations that the external command performed and signal a failure.

See Also

Autodesk.Revit Namespace