HookOrientation Property

RebarShape..::HookOrientation Property
CollapseAll image DropDown image

Get and set the hook orientation.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookOrientation HookOrientation[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Property HookOrientation ( _
    index As Integer _
) As RebarHookOrientation
Visual C++
public:
property RebarHookOrientation HookOrientation[int index] {
    RebarHookOrientation get (int index);
    void set (int index, RebarHookOrientation value);
}

Parameters

index
Int32

Remarks

Use a 0 index for the starting hook, and 1 for the ending hook. Orientation is 1 for the left side of the shape or -1 for the right side. For arc-driven shapes, 1 is for the inside of the arc, -1 for the outside.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace