SketchPlane Property

ModelCurve..::SketchPlane Property
CollapseAll image DropDown image

Get or set the sketch the model line resides in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchPlane SketchPlane{ get; set;}
Visual Basic (Declaration)
Public Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Remarks

A SketchPlane is a plane where you want to draw lines.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace