DefinitionGroups Class
See Also Members
CollapseAll image DropDown image

A specialised set of definition groups that allows creation of new groups.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4C9E7357-F306-43a0-8FAA-3244EFB6C6A8")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DefinitionGroups : DefinitionGroupsBase
Visual Basic (Declaration)
<GuidAttribute("4C9E7357-F306-43a0-8FAA-3244EFB6C6A8")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DefinitionGroups _
    Inherits DefinitionGroupsBase
Visual C++
[GuidAttribute(L"4C9E7357-F306-43a0-8FAA-3244EFB6C6A8")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DefinitionGroups : public DefinitionGroupsBase

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionGroupsBase
Autodesk.Revit.Parameters..::DefinitionGroups

See Also

DefinitionGroups Members
Autodesk.Revit.Parameters Namespace