ConditionType Enumeration
CollapseAll image DropDown image

An enumerate type listing all the possible Return Airflow Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9951AB18-54C2-4028-A2B3-AA5E3F44AFE3")]
public enum ConditionType
Visual Basic (Declaration)
<GuidAttribute("9951AB18-54C2-4028-A2B3-AA5E3F44AFE3")> _
Public Enumeration ConditionType
Visual C++
[GuidAttribute(L"9951AB18-54C2-4028-A2B3-AA5E3F44AFE3")]
public enum class ConditionType

Members

Member name | Description
NoOfConditionTypes | Return Condition Type is NoOfConditionTypes.
NaturallyVentedOnly | Return Condition Type is NaturallyVentedOnly.
Vented | Return Condition Type is Vented.
Unconditioned | Return Condition Type is Unconditioned.
HeatedAndCooled | Return Condition Type is HeatedAndCooled.
Cooled | Return Condition Type is Cooled.
Heated | Return Condition Type is Heated.
NoConditionType | Return Condition Type is NoConditionType.

See Also

Autodesk.Revit.MEP.Enums Namespace