RebarHookType Class
See Also Members
CollapseAll image DropDown image

A Rebar Hook type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("ACEF6715-EBE3-412d-A16D-222FFA38C622")]
public class RebarHookType : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("ACEF6715-EBE3-412d-A16D-222FFA38C622")> _
Public Class RebarHookType _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"ACEF6715-EBE3-412d-A16D-222FFA38C622")]
public ref class RebarHookType : public Symbol

Remarks

This object contains the definition of the hooks that may be created at the ends of the rebar. The specifics of these hooks are contained within parameters that are accessible from this object. REBAR_HOOK_ANGLE - angle (range 0-PI) between first/last segment of rebar and the straight segment of the hook, REBAR_HOOK_LINE_LEN_FACTOR - a multiplier used to compute the length of the straight segment of the hook. The Length is computed as the bar diameter * the multiplier.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::RebarHookType

See Also

RebarHookType Members
Autodesk.Revit.Symbols Namespace