View Class
See Also Members
CollapseAll image DropDown image

Base class for Revit Views.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("1C66A293-1D20-452a-A366-D4DEE6824345")]
public class View : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("1C66A293-1D20-452a-A366-D4DEE6824345")> _
Public Class View _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"1C66A293-1D20-452a-A366-D4DEE6824345")]
public ref class View : public Element

Remarks

A View is an image produced from a Revit model. Views can be graphical (plans etc.) or textual (schedules etc.) Views keep track of Elements that can be seen in them.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::View3D
Autodesk.Revit.Elements..::ViewDrafting
Autodesk.Revit.Elements..::ViewSheet
Autodesk.Revit.Elements..::ViewSection
Autodesk.Revit.Elements..::ViewPlan

See Also

View Members
Autodesk.Revit.Elements Namespace