NewLineUnbound Method

Application..::NewLineUnbound Method
CollapseAll image DropDown image

Creates a new unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Line NewLineUnbound(
    XYZ point,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewLineUnbound ( _
    point As XYZ, _
    direction As XYZ _
) As Line
Visual C++
public:
Line^ NewLineUnbound (
    XYZ^ point,
    XYZ^ direction
)

Parameters

point
XYZ
A point through which the line will pass.
direction
XYZ
A vector for the direction of the line.

Return Value

Returns a new unbounded line object.

Remarks

The line returned will be infinite in length and pass through the point provided in the specified direction. This method is useful for generating an axis around which an element can be rotated.

See Also

Application Class
Autodesk.Revit.Creation Namespace