NewLoadCase Method

Document..::NewLoadCase Method
CollapseAll image DropDown image

Creates a new instance of a LoadCase element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadCase NewLoadCase(
    string name,
    LoadNature nature,
    Category category
)
Visual Basic (Declaration)
Public Function NewLoadCase ( _
    name As String, _
    nature As LoadNature, _
    category As Category _
) As LoadCase
Visual C++
public:
LoadCase^ NewLoadCase (
    String^ name,
    LoadNature^ nature,
    Category^ category
)

Parameters

name
String
The not empty name for the Load Case Element to create.
nature
LoadNature
The Load Case nature.
category
Category
The Load Case category.

Return Value

If successful, NewLoadCase and there isn’t the Load Case Element with the same name returns an object for the newly created LoadCase. If such element exist and match desired one (has the same nature and number), returns existing element. Otherwise nothing is returned.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace