Document Events
CollapseAll image DropDown image

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following events.

Public Events

 | Name | Description
Public event | OnClose | Subscribe to the OnClose event to be notified before the current document is closed.
Public event | OnSave | Subscribe to the OnSave event to be notified before a document has been saved.
Public event | OnSaveAs | Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

See Also

Document
Autodesk.Revit Namespace