MEPBuildingConstruction Class
See Also Members
CollapseAll image DropDown image

Construction definition for Project Information.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B50D9A83-5E09-4dc5-900A-4F36CAAEDD9E")]
public class MEPBuildingConstruction : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B50D9A83-5E09-4dc5-900A-4F36CAAEDD9E")> _
Public Class MEPBuildingConstruction _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B50D9A83-5E09-4dc5-900A-4F36CAAEDD9E")]
public ref class MEPBuildingConstruction : public Symbol

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::MEPBuildingConstruction

See Also

MEPBuildingConstruction Members
Autodesk.Revit.Symbols Namespace