CurtainCell Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class CurtainCell
Visual Basic (Declaration)
Public Class CurtainCell
Visual C++
public ref class CurtainCell

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainCellCurtainCellNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell
Autodesk.Revit.Elements Namespace