Curve Class
See Also Members
CollapseAll image DropDown image

A parametric curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C1F2AF7E-4873-42b3-A517-1817DC59D6D1")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Curve : GeometryObject
Visual Basic (Declaration)
<GuidAttribute("C1F2AF7E-4873-42b3-A517-1817DC59D6D1")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Curve _
    Inherits GeometryObject
Visual C++
[GuidAttribute(L"C1F2AF7E-4873-42b3-A517-1817DC59D6D1")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parametrization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Line
Autodesk.Revit.Geometry..::Arc
Autodesk.Revit.Geometry..::Ellipse
Autodesk.Revit.Geometry..::NurbSpline

See Also

Curve Members
Autodesk.Revit.Geometry Namespace