ControlledApplication Members
See Also Methods Constructors Properties Events
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ControlledApplicationControlledApplicationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | VersionBuild | Returns the internal build number of the Revit applciation.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

See Also

ControlledApplication
Autodesk.Revit Namespace