ReferenceArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a reference array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FDD8860C-3764-4ef7-81D5-599E154BA70B")]
public abstract class ReferenceArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FDD8860C-3764-4ef7-81D5-599E154BA70B")> _
Public MustInherit Class ReferenceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FDD8860C-3764-4ef7-81D5-599E154BA70B")]
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::ReferenceArrayIterator

See Also

ReferenceArrayIterator Members
Autodesk.Revit.Geometry Namespace