NewProjectPosition Method

Application..::NewProjectPosition Method
CollapseAll image DropDown image

Creates a new project position object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectPosition NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Function NewProjectPosition ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
) As ProjectPosition
Visual C++
public:
ProjectPosition^ NewProjectPosition (
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Double
East to West offset in feet.
ns
Double
North to South offset in feet.
elevation
Double
Elevation above sea level in feet.
angle
Double
Rotation angle away from true north in the range of -PI to +PI.

Remarks

This object contains offset information and is used by the project location object for setting the project location relative to the site location. Measurements are in feet and radians.

See Also

Application Class
Autodesk.Revit.Creation Namespace