TemperatureRatingType Methods
CollapseAll image DropDown image

Syntax

C#
public class TemperatureRatingType
Visual Basic (Declaration)
Public Class TemperatureRatingType
Visual C++
public ref class TemperatureRatingType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
Public method | AddInsulationType | Add a new kind of insulation type into this temperature rating type.
Public method | AddWireSize | Add a new kind of wire size type into this temperature rating type.
Public method | RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
Public method | RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
Public method | RemoveWireSize | Remove an existing wire size type from this temperature rating type.

Protected Methods

 | Name | Description

See Also

TemperatureRatingType
Autodesk.Revit.Elements Namespace