FamilyInstance Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class FamilyInstance
Visual Basic (Declaration)
Public Class FamilyInstance
Visual C++
public ref class FamilyInstance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyInstanceFamilyInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Change the room to which the door or window is opened.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopings | Lists the elements currently used as coping cutters for this element.
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
Public method | SetCopings | Specify the set of coping cutters on this element.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the family instance.
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | Overloaded.
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element.
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Material | This property returns the physical material from which the instance is made.
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Parameter | Overloaded.
Public property | Room | Overloaded.
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Property to get the sub componets of current family instance.
Public property | SuperComponent | Property to get the super componet of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | Overloaded.

See Also

FamilyInstance
Autodesk.Revit.Elements Namespace