MenuItem Class
See Also Members
CollapseAll image DropDown image

Basic unit to build custermized menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("17767ABF-BF32-4488-900D-C905439E65DA")]
public class MenuItem : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("17767ABF-BF32-4488-900D-C905439E65DA")> _
Public Class MenuItem _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"17767ABF-BF32-4488-900D-C905439E65DA")]
public ref class MenuItem : public APIObject

Remarks

The MenuItem object is a basic unit to build custermized menus when revit is at statup .

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::MenuItem

See Also

MenuItem Members
Autodesk.Revit Namespace