HookAngle Property

RebarShape..::HookAngle Property
CollapseAll image DropDown image

Get and set the hook angle.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int HookAngle[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Property HookAngle ( _
    index As Integer _
) As Integer
Visual C++
public:
property int HookAngle[int index] {
    int get (int index);
    void set (int index, int value);
}

Parameters

index
Int32

Remarks

The hook angle is expressed as an integral number of degrees (common values are 0, 90, 135, and 180). Use a 0 index for the starting hook, and 1 for the ending hook.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace