ParameterType Property

Definition..::ParameterType Property
CollapseAll image DropDown image

Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public abstract ParameterType ParameterType{ get;}
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () abstract;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

Definition Class
Autodesk.Revit.Parameters Namespace