Shininess Property

Material..::Shininess Property
CollapseAll image DropDown image

The shininess of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public int Shininess{ get; set;}
Visual Basic (Declaration)
Public Property Shininess As Integer
Visual C++
public:
property int Shininess {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 128. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace