Autodesk.Revit.Structural Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Structural
Visual Basic (Declaration)
Namespace Autodesk.Revit.Structural
Visual C++
namespace Autodesk.Revit.Structural

Classes

 | Class | Description
Public class | AnalyticalModel | Supports all Analytical Models that are persistent within the Autodesk Revit project
Public class | AnalyticalModel3D | Supports all Analytical Models that have more than two dimensions within the Autodesk Revit project
Public class | AnalyticalModelFloor | Supports all Floor Analytical Models that are persistent within the Autodesk Revit project
Public class | AnalyticalModelFrame | Supports Framing Analytical Models (e.g., Beam) that are persistent within the Autodesk Revit project
Public class | AnalyticalModelLocation | Supports Location Analytical Models (e.g., Structural Footings) that are persistent within the Autodesk Revit project
Public class | AnalyticalModelProfile | Represents an extruded profile.
Public class | AnalyticalModelWall | Supports all Wall Analytical Models that are persistent within the Autodesk Revit project
Public class | AnalyticalSupportData | Information for one support of another Structural Element.
Public class | AnalyticalSupportInfo | Information for one support of another Structural Element.
Public class | AnalyticalSupportInfoArray | An array that contains support information objects.
Public class | AnalyticalSupportInfoArrayIterator | An iterator to a support information array.
Public class | BarDescription | An object that represents an Area Reinforcement within the Autodesk Revit project.
Public class | CompoundStructure | An object that describes the multi layered construction of walls or floors.
Public class | CompoundStructureLayer | An object that describes the a single layer of multi layered object.
Public class | CompoundStructureLayerArray | An array that contains layer objects.
Public class | CompoundStructureLayerArrayIterator | An iterator to a layer array.

AnalyticalModel Class
See Also Members
CollapseAll image DropDown image

Supports all Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("22D54312-EA40-4877-AB98-ED8FE0193BF0")]
public class AnalyticalModel : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("22D54312-EA40-4877-AB98-ED8FE0193BF0")> _
Public Class AnalyticalModel _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"22D54312-EA40-4877-AB98-ED8FE0193BF0")]
public ref class AnalyticalModel : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelFrame
Autodesk.Revit.Structural..::AnalyticalModelWall
Autodesk.Revit.Structural..::AnalyticalModelFloor
Autodesk.Revit.Structural..::AnalyticalModelLocation
Autodesk.Revit.Structural..::AnalyticalModel3D
Autodesk.Revit.Structural..::AnalyticalModelProfile

See Also

AnalyticalModel Members
Autodesk.Revit.Structural Namespace