HostObject Class
See Also Members
CollapseAll image DropDown image

A base class that provides support for all objects that can host other objects, such as a wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B9A60FA9-F07B-4ebe-A7E9-59E4704DE5D6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class HostObject : Element
Visual Basic (Declaration)
<GuidAttribute("B9A60FA9-F07B-4ebe-A7E9-59E4704DE5D6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class HostObject _
    Inherits Element
Visual C++
[GuidAttribute(L"B9A60FA9-F07B-4ebe-A7E9-59E4704DE5D6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class HostObject : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CeilingAndFloor
Autodesk.Revit.Elements..::Wall
Autodesk.Revit.Elements..::Floor
Autodesk.Revit.Elements..::ContFooting
Autodesk.Revit.Elements..::RoofBase
Autodesk.Revit.Elements..::Wire
Autodesk.Revit.Elements..::CurtainGridLine
Autodesk.Revit.Elements..::CurtainSystemBase
Autodesk.Revit.Elements..::HostedSweep

See Also

HostObject Members
Autodesk.Revit.Elements Namespace