RemoveSegment Method

HostedSweep..::RemoveSegment Method
CollapseAll image DropDown image

Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment (
    Reference^ targetRef
)

Parameters

targetRef
Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace