FaceArray Methods
CollapseAll image DropDown image

Syntax

C#
public class FaceArray
Visual Basic (Declaration)
Public Class FaceArray
Visual C++
public ref class FaceArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

FaceArray
Autodesk.Revit.Geometry Namespace