GetAllRebarShapeParameters Method

RebarShape..::GetAllRebarShapeParameters Method
CollapseAll image DropDown image

List all shape parameters used by all the existing RebarShapes in the document.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static DefinitionsBase GetAllRebarShapeParameters(
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetAllRebarShapeParameters ( _
    doc As Document _
) As DefinitionsBase
Visual C++
public:
static DefinitionsBase^ GetAllRebarShapeParameters (
    Document^ doc
)

Parameters

doc
Document

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace