UnaryNegation Operator

XYZ..::UnaryNegation Operator
CollapseAll image DropDown image

Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator -(
    XYZ source
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    source As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator - (
    XYZ^ source
)

Parameters

source
XYZ

Return Value

The vector opposite to the specified vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace