LayoutRuleFixedNumber Class
See Also Members
CollapseAll image DropDown image

This class indicate the layout rule of a Beam System is Fixed-Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D518A610-7616-4c53-AE97-681A7453EA69")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LayoutRuleFixedNumber : LayoutRule
Visual Basic (Declaration)
<GuidAttribute("D518A610-7616-4c53-AE97-681A7453EA69")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LayoutRuleFixedNumber _
    Inherits LayoutRule
Visual C++
[GuidAttribute(L"D518A610-7616-4c53-AE97-681A7453EA69")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LayoutRuleFixedNumber : public LayoutRule

Remarks

To use this type of LayoutRule, only the number of the beams must be set.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleFixedNumber

See Also

LayoutRuleFixedNumber Members
Autodesk.Revit.Elements Namespace