Face Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Face
Visual Basic (Declaration)
Public Class Face
Visual C++
public ref class Face

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FaceFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
Public method | Evaluate | Evaluates parameters on the face.
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face.
Public method | Triangulate | Returns a triangular mesh approximation to the face.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElement | Element describing the material from which this face is composed. (Overrides GeometryObject ..::MaterialElement()().)
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.

See Also

Face
Autodesk.Revit.Geometry Namespace