CurtainSystemBase Class
See Also Members
CollapseAll image DropDown image

Provides access to the CurtainSystemBase object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3D5D69E1-878F-4006-8BFC-340F0159C3DC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CurtainSystemBase : HostObject
Visual Basic (Declaration)
<GuidAttribute("3D5D69E1-878F-4006-8BFC-340F0159C3DC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CurtainSystemBase _
    Inherits HostObject
Visual C++
[GuidAttribute(L"3D5D69E1-878F-4006-8BFC-340F0159C3DC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CurtainSystemBase : public HostObject

Remarks

This is the base class of CurtainSystem.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::CurtainSystemBase
Autodesk.Revit.Elements..::CurtainSystem

See Also

CurtainSystemBase Members
Autodesk.Revit.Elements Namespace