CompoundStructureLayer Properties
CollapseAll image DropDown image

Syntax

C#
public class CompoundStructureLayer
Visual Basic (Declaration)
Public Class CompoundStructureLayer
Visual C++
public ref class CompoundStructureLayer

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | DeckProfile | Returns or set the family symbol of the deck profile of the layer within the structure.
Public property | DeckUsage | Returns usage of the deck layer within the structure.
Public property | Function | Returns the purpose/function of the layer within the structure.
Public property | Material | Get or set the material from which the layer is made.
Public property | Thickness | Retrieve or modify the thickness of the layer.
Public property | Variable | Returns or set whether the layer thickness is vrariable.

See Also

CompoundStructureLayer
Autodesk.Revit.Structural Namespace