Transformed Property

Instance..::Transformed Property
CollapseAll image DropDown image

Transforms this instance and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Instance Transformed[
    Transform transform
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Instance
Visual C++
public:
property Instance^ Transformed[Transform^ transform] {
    Instance^ get (Transform^ transform);
}

Parameters

transform
Transform
The transformation used to transform the instance.

Return Value

The transformed instance.

Remarks

Concatenates the specified transformation so that it is applied after the transformation of this instance.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace