IntersectionResult Class
See Also Members
CollapseAll image DropDown image

This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8C8658C4-68AD-4b18-B304-1E22A91C063B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class IntersectionResult : APIObject
Visual Basic (Declaration)
<GuidAttribute("8C8658C4-68AD-4b18-B304-1E22A91C063B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class IntersectionResult _
    Inherits APIObject
Visual C++
[GuidAttribute(L"8C8658C4-68AD-4b18-B304-1E22A91C063B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class IntersectionResult : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::IntersectionResult

See Also

IntersectionResult Members
Autodesk.Revit.Geometry Namespace