RebarShapeArcReferenceType Enumeration
CollapseAll image DropDown image

A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D7D65FC8-899D-4fe0-A0B0-C054251EE5DD")]
public enum RebarShapeArcReferenceType
Visual Basic (Declaration)
<GuidAttribute("D7D65FC8-899D-4fe0-A0B0-C054251EE5DD")> _
Public Enumeration RebarShapeArcReferenceType
Visual C++
[GuidAttribute(L"D7D65FC8-899D-4fe0-A0B0-C054251EE5DD")]
public enum class RebarShapeArcReferenceType

Members

Member name | Description
External | Measure to the exterior of the bend.
Centerline | Measure to the centerline of the bar.
Internal | Measure to the interior of the bend.

See Also

Autodesk.Revit.Structural.Enums Namespace