Definitions Class
See Also Members
CollapseAll image DropDown image

A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E43291AE-0C84-4d04-A701-77F5B7DEB5FA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Definitions : DefinitionsBase
Visual Basic (Declaration)
<GuidAttribute("E43291AE-0C84-4d04-A701-77F5B7DEB5FA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Definitions _
    Inherits DefinitionsBase
Visual C++
[GuidAttribute(L"E43291AE-0C84-4d04-A701-77F5B7DEB5FA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Definitions : public DefinitionsBase

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::DefinitionsBase
Autodesk.Revit.Parameters..::Definitions
Autodesk.Revit.Parameters..::ExternalDefinitions
Autodesk.Revit.Parameters..::InternalDefinitions

See Also

Definitions Members
Autodesk.Revit.Parameters Namespace