Autodesk.Revit.Geometry Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Geometry
Visual Basic (Declaration)
Namespace Autodesk.Revit.Geometry
Visual C++
namespace Autodesk.Revit.Geometry

Classes

 | Class | Description
Public class | Arc | A circular arc.
Public class | BoundingBoxUV | A two-dimensional rectangle, parallel to the coordinate axes.
Public class | BoundingBoxXYZ | A three-dimensional rectangular box.
Public class | ConicalFace | A cone face of a 3d solid.
Public class | Curve | A parametric curve.
Public class | CurveArrArray | An array that can contain any type of object.
Public class | CurveArrArrayIterator | An iterator to a array.
Public class | CurveArray | An array that can contain curves.
Public class | CurveArrayIterator | An iterator to a curve array.
Public class | CylindricalFace | A cylinder face of a 3d solid.
Public class | DoubleArray | An array that contains doubles.
Public class | DoubleArrayIterator | An iterator to an array of doubles.
Public class | Edge | An edge of a 3d solid.
Public class | EdgeArray | An array that contains edges.
Public class | EdgeArrayArray | An array of edge arrays.
Public class | EdgeArrayArrayIterator | An iterator to an array or edge arrays.
Public class | EdgeArrayIterator | An iterator to an edge array.
Public class | Element | Geometric representation of an element.
Public class | Ellipse | A whole or partial ellipse.
Public class | Face | A face of a 3d solid.
Public class | FaceArray | An array that contains faces.
Public class | FaceArrayIterator | An iterator to a face array.
Public class | GeometryObject | The common base class for all geometric primitives.
Public class | GeometryObjectArray | An array that contains geometry objects.
Public class | GeometryObjectArrayIterator | An iterator to a geometry object array.
Public class | HermiteFace | A cubic hermite spline face of a 3d solid.
Public class | Instance | An instance of another element (symbol), specially positioned by this element.
Public class | InstanceArray | An array that contains instances.
Public class | InstanceArrayIterator | An iterator to an instance array.
Public class | IntersectionResult | This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Public class | IntersectionResultArray | An array that can contain any type of object.
Public class | IntersectionResultArrayIterator | An iterator to a array.
Public class | Line | A line in space.
Public class | Mesh | A triangular mesh.
Public class | MeshArray | An array that contains meshes.
Public class | MeshArrayIterator | An iterator to a mesh array.
Public class | MeshTriangle | One triangle of a mesh.
Public class | NurbSpline | A nurb spline.
Public class | Options | User preferences for parsing of geometry.
Public class | PlanarFace | A planar face of a 3d solid.
Public class | Plane | Provides access to the geometry plane object.
Public class | Profile | A geometric profile consisting of a loop of curves.
Public class | Reference | A stable reference to a geometric object in a Revit model.
Public class | ReferenceArray |
Public class | ReferenceArrayIterator | An iterator to a reference array.
Public class | RevolvedFace | A revolved face of a 3d solid.
Public class | RuledFace | A ruled face of a 3d solid.
Public class | Solid | A 3d solid.
Public class | SolidArray | An array that contains solids.
Public class | SolidArrayIterator | An iterator to a solids array.
Public class | Transform | A transformation of the affine 3-space.
Public class | UV | Object representing coordinates in 2-space.
Public class | UVArray | An array that contains UV coordinates.
Public class | UVArrayIterator | An iterator to an array of UV coordinates.
Public class | XYZ | Object representing coordinates in 3-space.
Public class | XYZArray | An array that contains XYZ coordinates.
Public class | XYZArrayIterator | An iterator to an array of XYZ coordinates.

Enumerations

 | Enumeration | Description
Public enumeration | Options..::DetailLevels | Chooses the detail level of an element's representation.

Arc Class
See Also Members
CollapseAll image DropDown image

A circular arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6456ED41-1F0B-4418-94D2-1E09642A3FB0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Arc : Curve
Visual Basic (Declaration)
<GuidAttribute("6456ED41-1F0B-4418-94D2-1E09642A3FB0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Arc _
    Inherits Curve
Visual C++
[GuidAttribute(L"6456ED41-1F0B-4418-94D2-1E09642A3FB0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Arc : public Curve

Remarks

The arc lies in the plane defined by center and normal.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::Arc

See Also

Arc Members
Autodesk.Revit.Geometry Namespace