Family Class
See Also Members
CollapseAll image DropDown image

The Family object is a Symbol that defines an entire family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("CB06E669-3606-4f97-A59F-120FFE430153")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Family : FamilyBase
Visual Basic (Declaration)
<GuidAttribute("CB06E669-3606-4f97-A59F-120FFE430153")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Family _
    Inherits FamilyBase
Visual C++
[GuidAttribute(L"CB06E669-3606-4f97-A59F-120FFE430153")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Family : public FamilyBase

Remarks

This object is used mostly to get all the family symbols that belong to the family so that instances can be swapped from one symbol to another. The Family object is derived from the Symbol object and the Element object and as such inherits all the properties and methods of that object. Families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of Families. The Family object represents the entire family such as an 'I Beam'. You can think of that object as representing the entire family file on disk. The Family object contains a number of FamilySymbols. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that Type (FamilySymbol) within the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project. Therefore: Each FamilyInstance has one FamilySymbol, e.g. an instance of a W14x32. Each FamilySymbol belongs to one Family, e.g. the W14x32 symbol belongs to an 'I Beam' family. Each Family will contain one or more FamilySymbols, e.g. the 'I Beam' family contains a W14x32 symbol, a W12x32 symbol etc.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::FamilyBase
Autodesk.Revit.Elements..::Family

See Also

Family Members
Autodesk.Revit.Elements Namespace