Options Class
See Also Members
CollapseAll image DropDown image

User preferences for parsing of geometry.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("2E680113-3D6E-4f42-9158-4DDA76ED7F25")]
public class Options : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("2E680113-3D6E-4f42-9158-4DDA76ED7F25")> _
Public Class Options _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"2E680113-3D6E-4f42-9158-4DDA76ED7F25")]
public ref class Options : public APIObject

Remarks

Get an instance of this class from Application.Create, set your preferences and pass it to Element.Geometry or Instance.Geometry.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Options

See Also

Options Members
Autodesk.Revit.Geometry Namespace