PrintSetup Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PrintSetup
Visual Basic (Declaration)
Public Class PrintSetup
Visual C++
public ref class PrintSetup

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintSetupPrintSetupNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Delete | Delete the current print setting.
Public method | Rename | Rename the current print setting to another print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | CurrentPrintSetting | Get or Set the current Print Setting of Print Setup.
Public property | PaperSizes | Get all Print sizes of current Print.
Public property | PaperSources | Get all Print sources of current Print.

See Also

PrintSetup
Autodesk.Revit Namespace