ItemType Property

ToolbarItem..::ItemType Property
CollapseAll image DropDown image

Gets or sets the item type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItem.ToolbarItem..::ToolbarItemType ItemType{ get; set;}
Visual Basic (Declaration)
Public Property ItemType As ToolbarItem..::ToolbarItemType
Visual C++
public:
property ToolbarItem..::ToolbarItemType ItemType {
    ToolbarItem..::ToolbarItemType get ();
    void set (ToolbarItem..::ToolbarItemType value);
}

Remarks

If the item is set to BtnRText, the ItemText will be displayed on the right side of the button. If it's set to BtnSeparator, it'll appear as a button separate. If it's set to BtnStd, it acts as a standard button.

See Also

ToolbarItem Class
Autodesk.Revit Namespace