NewLoadNature Method

Document..::NewLoadNature Method
CollapseAll image DropDown image

Creates a new instance of a LoadNature element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadNature NewLoadNature(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadNature ( _
    name As String _
) As LoadNature
Visual C++
public:
LoadNature^ NewLoadNature (
    String^ name
)

Parameters

name
String
The name for the Load Nature Element to create.

Return Value

If successful and there isn’t the Load Nature Element with the same name NewLoadNature returns an object for the newly created LoadNature. If such element exist it returns existing element. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace