ControlledApplication Properties
CollapseAll image DropDown image

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | VersionBuild | Returns the internal build number of the Revit applciation.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication
Autodesk.Revit Namespace