LayoutRule Class
See Also Members
CollapseAll image DropDown image

The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CBF44E93-2DA5-4df0-AC5F-577F327E1A47")]
public abstract class LayoutRule : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CBF44E93-2DA5-4df0-AC5F-577F327E1A47")> _
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CBF44E93-2DA5-4df0-AC5F-577F327E1A47")]
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Elements..::LayoutRule
Autodesk.Revit.Elements..::LayoutRuleFixedDistance
Autodesk.Revit.Elements..::LayoutRuleFixedNumber
Autodesk.Revit.Elements..::LayoutRuleMaximumSpacing
Autodesk.Revit.Elements..::LayoutRuleClearSpacing

See Also

LayoutRule Members
Autodesk.Revit.Elements Namespace