NewAreaViewPlan Method

Document..::NewAreaViewPlan Method
CollapseAll image DropDown image

Creates a new view for the new area.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewPlan NewAreaViewPlan(
    string pViewName,
    Level pLevel,
    AreaElemType areaElemType
)
Visual Basic (Declaration)
Public Function NewAreaViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    areaElemType As AreaElemType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewAreaViewPlan (
    String^ pViewName,
    Level^ pLevel,
    AreaElemType areaElemType
)

Parameters

pViewName
String
The name of new created view
pLevel
Level
areaElemType
AreaElemType
The type of area element

See Also

Document Class
Autodesk.Revit.Creation Namespace