Direction Property

ReferencePlane..::Direction Property
CollapseAll image DropDown image

The direction of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Direction{ get; set;}
Visual Basic (Declaration)
Public Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is almost zero or if it is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace