Map Methods
CollapseAll image DropDown image

Syntax

C#
public class Map
Visual Basic (Declaration)
Public Class Map
Visual C++
public ref class Map

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Map
Autodesk.Revit.Collections Namespace