Rename Method

ViewSheetSetting..::Rename Method
CollapseAll image DropDown image

Rename the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename (
    String^ newName
)

Parameters

newName
String
view sheet set name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Remarks

If the input newName is existed in current viewsheetset list, an InvalidOperationException will be thrown.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace