FamilyCategory Property

FamilyBase..::FamilyCategory Property
CollapseAll image DropDown image

Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Category FamilyCategory{ get;}
Visual Basic (Declaration)
Public ReadOnly Property FamilyCategory As Category
Visual C++
public:
property Category^ FamilyCategory {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace