Leader Class
See Also Members
CollapseAll image DropDown image

An object that represents a Leader within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F8C25806-26EB-450f-AE4F-B6F2E8C7489D")]
public class Leader : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F8C25806-26EB-450f-AE4F-B6F2E8C7489D")> _
Public Class Leader _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F8C25806-26EB-450f-AE4F-B6F2E8C7489D")]
public ref class Leader : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Leader.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Leader

See Also

Leader Members
Autodesk.Revit Namespace