ElementArray Class
See Also Members
CollapseAll image DropDown image

An array that contains element objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("B3AE5AA1-CF1E-4624-BB1A-EB3E600E23EA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElementArray : APIObject, IEnumerable
Visual Basic (Declaration)
<GuidAttribute("B3AE5AA1-CF1E-4624-BB1A-EB3E600E23EA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[GuidAttribute(L"B3AE5AA1-CF1E-4624-BB1A-EB3E600E23EA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ElementArray

See Also

ElementArray Members
Autodesk.Revit Namespace