GetSubMenu Method

MenuItem..::GetSubMenu Method
CollapseAll image DropDown image

Get a sub menu, if current menu is not popup menu, null will be returned.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem GetSubMenu(
    int pos
)
Visual Basic (Declaration)
Public Function GetSubMenu ( _
    pos As Integer _
) As MenuItem
Visual C++
public:
MenuItem^ GetSubMenu (
    int pos
)

Parameters

pos
Int32
Index of the sub menu to be returned, starting from 0.

Return Value

Sub menu item will be returned if successful.

Remarks

Before get sub menu, it's better to call GetMenuItemCount.

See Also

MenuItem Class
Autodesk.Revit Namespace