TextNoteTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class TextNoteTypeSet
Visual Basic (Declaration)
Public Class TextNoteTypeSet
Visual C++
public ref class TextNoteTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every textnote type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a textnote type within the set.
Public method | Erase | Removes a specified textnote type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified textnote type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

TextNoteTypeSet
Autodesk.Revit.Symbols Namespace