EndTransaction Method

Document..::EndTransaction Method
CollapseAll image DropDown image

Ends a transaction for specified document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool EndTransaction()
Visual Basic (Declaration)
Public Function EndTransaction As Boolean
Visual C++
public:
bool EndTransaction ()

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

See Also

Document Class
Autodesk.Revit Namespace