MaterialOther Class
See Also Members
CollapseAll image DropDown image

Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F86E76AD-B1A6-4b9a-83EE-B55A9909B771")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class MaterialOther : Material
Visual Basic (Declaration)
<GuidAttribute("F86E76AD-B1A6-4b9a-83EE-B55A9909B771")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class MaterialOther _
    Inherits Material
Visual C++
[GuidAttribute(L"F86E76AD-B1A6-4b9a-83EE-B55A9909B771")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class MaterialOther : public Material

Remarks

MaterialOther is a child class of Material.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialOther

See Also

MaterialOther Members
Autodesk.Revit.Elements Namespace