View3D Class
See Also Members
CollapseAll image DropDown image

A freely-oriented orthographic or perspective view of the model.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("333F83F4-8765-4967-BC29-865F9FA9E25F")]
public class View3D : View
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("333F83F4-8765-4967-BC29-865F9FA9E25F")> _
Public Class View3D _
    Inherits View
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"333F83F4-8765-4967-BC29-865F9FA9E25F")]
public ref class View3D : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::View3D

See Also

View3D Members
Autodesk.Revit.Elements Namespace