Multiply Operator

XYZ..::Multiply Operator
CollapseAll image DropDown image

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ operator *(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator * (
    XYZ^ left,
    double value
)

Parameters

left
XYZ
The vector to multiply with the value.
value
Double
The value to multiply with the specified vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace