BoundarySegmentArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B3832EA7-B0A4-409f-9590-2C0D552E55AB")]
public abstract class BoundarySegmentArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B3832EA7-B0A4-409f-9590-2C0D552E55AB")> _
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B3832EA7-B0A4-409f-9590-2C0D552E55AB")]
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Spaces..::BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Spaces Namespace