GenLevel Property

View..::GenLevel Property
CollapseAll image DropDown image

The level which generate this View.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Level GenLevel{ get;}
Visual Basic (Declaration)
Public ReadOnly Property GenLevel As Level
Visual C++
public:
property Level^ GenLevel {
    Level^ get ();
}

Remarks

This property retrieve the level which generate this View, such as Plan Views is generated by Level1 or Level2, etc. if this View is not generated by a level, here will return a null.

See Also

View Class
Autodesk.Revit.Elements Namespace