AttachTopChord Method

Truss..::AttachTopChord Method
CollapseAll image DropDown image

Attach truss's top to a specified element,the element should be a roof or floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AttachTopChord(
    Element attachToElement,
    bool forceRemoveSketch
)
Visual Basic (Declaration)
Public Sub AttachTopChord ( _
    attachToElement As Element, _
    forceRemoveSketch As Boolean _
)
Visual C++
public:
void AttachTopChord (
    Element^ attachToElement,
    bool forceRemoveSketch
)

Parameters

attachToElement
Element
The element that the truss's top is going to attach.
forceRemoveSketch
Boolean
Whether detach the original sketch if there is one.

See Also

Truss Class
Autodesk.Revit.Elements Namespace