CurtainSystemTypeSet Methods
CollapseAll image DropDown image

Syntax

C#
public class CurtainSystemTypeSet
Visual Basic (Declaration)
Public Class CurtainSystemTypeSet
Visual C++
public ref class CurtainSystemTypeSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every CurtainSystem type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a CurtainSystem type within the set.
Public method | Erase | Removes a specified CurtainSystem type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified CurtainSystem type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CurtainSystemTypeSet
Autodesk.Revit.Symbols Namespace