Sweep Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Sweep
Visual Basic (Declaration)
Public Class Sweep
Visual C++
public ref class Sweep

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SweepSweepNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | EnableTrajSegmentation | Returns the Trajectory Segmentation state of the Sweep.
Public property | MaxSegmentAngle | Returns the Maximum Segment Angle of the Sweep.
Public property | Parameter | Overloaded.
Public property | Path3d | Returns the 3D Path Sketch of the Sweep.
Public property | PathSketch | Returns the Plan Path Sketch of the Sweep.
Public property | ProfileSketch | Returns the profile Sketch of the Sweep.

See Also

Sweep
Autodesk.Revit.Elements Namespace