NewReferencePlane2 Method

Document..::NewReferencePlane2 Method
CollapseAll image DropDown image

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane2 ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    thirdPnt As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane2 (
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)

Parameters

bubbleEnd
XYZ
The bubble end applied to reference plane.
freeEnd
XYZ
The free end applied to reference plane.
thirdPnt
XYZ
A third point needed to define the reference plane.
pView
View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace