NewFootPrintRoof Method

Document..::NewFootPrintRoof Method
CollapseAll image DropDown image

Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    ElementIdSet footPrintToModelCurvesMapping
)
Visual Basic (Declaration)
Public Function NewFootPrintRoof ( _
    footPrint As CurveArray, _
    level As Level, _
    roofType As RoofType, _
    footPrintToModelCurvesMapping As ElementIdSet _
) As FootPrintRoof
Visual C++
public:
FootPrintRoof^ NewFootPrintRoof (
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    ElementIdSet^ footPrintToModelCurvesMapping
)

Parameters

footPrint
CurveArray
The footprint of the FootPrintRoof.
level
Level
The level of the FootPrintRoof.
roofType
RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping
ElementIdSet
Map footprint to Model Curves.

See Also

Document Class
Autodesk.Revit.Creation Namespace