SuspendUpdating Constructor
CollapseAll image DropDown image

Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SuspendUpdating (
    Document^ document
)

Parameters

document
Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating object has been disposed Revit will make the document consistent again.

See Also

SuspendUpdating Class
Autodesk.Revit Namespace