CurtainGridLine Properties
CollapseAll image DropDown image

Syntax

C#
public class CurtainGridLine
Visual Basic (Declaration)
Public Class CurtainGridLine
Visual C++
public ref class CurtainGridLine

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Lock | Retrieve or change the lock state of the curtain grid line.
Public property | Parameter | Overloaded.
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.

See Also

CurtainGridLine
Autodesk.Revit.Elements Namespace