HostedSweep Properties
CollapseAll image DropDown image

Syntax

C#
public class HostedSweep
Visual Basic (Declaration)
Public Class HostedSweep
Visual C++
public ref class HostedSweep

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | Parameter | Overloaded.
Public property | ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep
Autodesk.Revit.Elements Namespace