NewLoadUsage Method

Document..::NewLoadUsage Method
CollapseAll image DropDown image

Creates a new instance of a LoadUsage element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LoadUsage NewLoadUsage(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadUsage ( _
    name As String _
) As LoadUsage
Visual C++
public:
LoadUsage^ NewLoadUsage (
    String^ name
)

Parameters

name
String
The not empty name for the Load Usage Element to create.

Return Value

If successful and there isn’t the Load Usage Element with the same name NewLoadUsage returns an object for the newly created LoadUsage. If such element exist it returns existing element. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace