Item Property

SolidArray..::Item Property
CollapseAll image DropDown image

Gets or sets a solid at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Solid Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Solid
Visual C++
public:
virtual property Solid^ Item[int index] {
    Solid^ get (int index);
    void set (int index, Solid^ value);
}

Parameters

index
Int32
The index of the solid to be set or retrieved.

Return Value

Returns the solid at the specified index.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace