Toolbar Class
See Also Members
CollapseAll image DropDown image

The Toolbar object represents a tool bar, which should contains an array of ToolbarItems.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("045FCF04-CBB7-4192-AAF0-D0BE3ACEFC12")]
public class Toolbar : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("045FCF04-CBB7-4192-AAF0-D0BE3ACEFC12")> _
Public Class Toolbar _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"045FCF04-CBB7-4192-AAF0-D0BE3ACEFC12")]
public ref class Toolbar : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Toolbar

See Also

Toolbar Members
Autodesk.Revit Namespace