Evaluate Method

Curve..::Evaluate Method
CollapseAll image DropDown image

Evaluates a parameter on the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Evaluate(
    double param,
    bool normalized
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double, _
    normalized As Boolean _
) As XYZ
Visual C++
public:
XYZ^ Evaluate (
    double param,
    bool normalized
)

Parameters

param
Double
The parameter to be evaluated.
normalized
Boolean
If false, param is interpreted as natural parametrization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace