FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Curve
The curve where the instance is based.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace