Truss Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Truss
Visual Basic (Declaration)
Public Class Truss
Visual C++
public ref class Truss

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | TrussTrussNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
Public method | DetachTopChord | Detach the truss's top from a specified element.
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Curves | Get all the truss curves.
Public property | Members | Get all the members of truss.
Public property | Parameter | Overloaded.
Public property | TrussType | Retrieve/set an object that represents the type of the truss.

See Also

Truss
Autodesk.Revit.Elements Namespace