RoofType Class
See Also Members
CollapseAll image DropDown image

Represents a specific type of roof.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FD40F869-65FA-4462-BA37-F902FEA5DCFB")]
public class RoofType : HostObjAttributes
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FD40F869-65FA-4462-BA37-F902FEA5DCFB")> _
Public Class RoofType _
    Inherits HostObjAttributes
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FD40F869-65FA-4462-BA37-F902FEA5DCFB")]
public ref class RoofType : public HostObjAttributes

Remarks

All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::RoofType

See Also

RoofType Members
Autodesk.Revit.Symbols Namespace