NewTag Method

Document..::NewTag Method
CollapseAll image DropDown image

Creates a new IndependentTag Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public IndependentTag NewTag(
    View dbview,
    Element objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ pnt
)
Visual Basic (Declaration)
Public Function NewTag ( _
    dbview As View, _
    objelem As Element, _
    leader As Boolean, _
    tagmode As TagMode, _
    tagorn As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
IndependentTag^ NewTag (
    View^ dbview,
    Element^ objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ^ pnt
)

Parameters

dbview
View
The view in which the dimension is to be visible.
objelem
Element
The host object of tag
leader
Boolean
whether have leader
tagmode
TagMode
the mode of tag. Add by Category, add by Multi-Category and add by material
tagorn
TagOrientation
The Orientation of the Tag
pnt
XYZ
The position of the Tag

Return Value

If successful, an IndependentTag object is returned.

Remarks

This method forms an Tag tie to the host object.

See Also

Document Class
Autodesk.Revit.Creation Namespace