Material Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class Material
Visual Basic (Declaration)
Public MustInherit Class Material
Visual C++
public ref class Material abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialMaterialNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicates the material.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | Color | The color of the material.
Public property | CutPattern | The cut pattern of the material.
Public property | CutPatternColor | The cut pattern color of the material.
Public property | Glow | Whether the material can glow.
Public property | Parameter | Overloaded.
Public property | RenderAppearance | The rendering appearance property of the material.
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | SurfacePattern | The surface pattern of the material.
Public property | SurfacePatternColor | The surface pattern color of the material.
Public property | Transparency | The transparency of the material.

See Also

Material
Autodesk.Revit.Elements Namespace