InternalDefinition Class
See Also Members
CollapseAll image DropDown image

This object represent a parameter definition built into Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("B9AE8360-F20B-4b21-B6FE-F8B31FE2A6B7")]
public class InternalDefinition : Definition
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("B9AE8360-F20B-4b21-B6FE-F8B31FE2A6B7")> _
Public Class InternalDefinition _
    Inherits Definition
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"B9AE8360-F20B-4b21-B6FE-F8B31FE2A6B7")]
public ref class InternalDefinition : public Definition

Remarks

The InternalDefinition object is derived from the Definition object and hence includes all properties and methods of the Definition object. This object adds no other properties and methods and is used purely for type identification.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::InternalDefinition

See Also

InternalDefinition Members
Autodesk.Revit.Parameters Namespace