AddTemperatureRatingType Method

WireMaterialType..::AddTemperatureRatingType Method
CollapseAll image DropDown image

Add a new temperature rating type into material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TemperatureRatingType AddTemperatureRatingType(
    string name,
    TemperatureRatingType baseOn
)
Visual Basic (Declaration)
Public Function AddTemperatureRatingType ( _
    name As String, _
    baseOn As TemperatureRatingType _
) As TemperatureRatingType
Visual C++
public:
TemperatureRatingType^ AddTemperatureRatingType (
    String^ name,
    TemperatureRatingType^ baseOn
)

Parameters

name
String
Name of temperature type to be added.
baseOn
TemperatureRatingType
The new temperature rating will be created base on this existing temperature rating type.

Return Value

New constructed temperature rating type.

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace