HostObjAttributes Class
See Also Members
CollapseAll image DropDown image

An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("57BED09B-03D1-4381-B8CB-1AB3287CDA55")]
public class HostObjAttributes : Symbol
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("57BED09B-03D1-4381-B8CB-1AB3287CDA55")> _
Public Class HostObjAttributes _
    Inherits Symbol
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"57BED09B-03D1-4381-B8CB-1AB3287CDA55")]
public ref class HostObjAttributes : public Symbol

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::WallType
Autodesk.Revit.Symbols..::FloorType
Autodesk.Revit.Symbols..::ContFootingType
Autodesk.Revit.Symbols..::RoofType
Autodesk.Revit.Symbols..::CurtainSystemType
Autodesk.Revit.Symbols..::HostedSweepType

See Also

HostObjAttributes Members
Autodesk.Revit.Symbols Namespace