Selection Class
See Also Members
CollapseAll image DropDown image

Contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("50E07DF9-F172-4bd6-9983-C0711EB36A31")]
public class Selection : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("50E07DF9-F172-4bd6-9983-C0711EB36A31")> _
Public Class Selection _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"50E07DF9-F172-4bd6-9983-C0711EB36A31")]
public ref class Selection : public APIObject

Remarks

The Selection object is used to retrieve the current user selected elements when an external API command is executed.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Selection

See Also

Selection Members
Autodesk.Revit Namespace