SetAllowed Method

RebarShape..::SetAllowed Method
CollapseAll image DropDown image

Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetAllowed(
    RebarBarType barType,
    bool allowed
)
Visual Basic (Declaration)
Public Sub SetAllowed ( _
    barType As RebarBarType, _
    allowed As Boolean _
)
Visual C++
public:
void SetAllowed (
    RebarBarType^ barType,
    bool allowed
)

Parameters

barType
RebarBarType
allowed
Boolean

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace