HasCoverTypeForReference Method

RebarHostData..::HasCoverTypeForReference Method
CollapseAll image DropDown image

Checks whether the reference has an associated cover.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HasCoverTypeForReference(
    Reference
)
Visual Basic (Declaration)
Public Function HasCoverTypeForReference ( _
     As Reference _
) As Boolean
Visual C++
public:
bool HasCoverTypeForReference (
    Reference^
)

Parameters

Reference

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace