CategoryNameMapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class CategoryNameMapIterator
Visual Basic (Declaration)
Public MustInherit Class CategoryNameMapIterator
Visual C++
public ref class CategoryNameMapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoryNameMapIteratorCategoryNameMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator
Autodesk.Revit Namespace