Autodesk.Revit.Enums Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Enums
Visual Basic (Declaration)
Namespace Autodesk.Revit.Enums
Visual C++
namespace Autodesk.Revit.Enums

Enumerations

 | Enumeration | Description
Public enumeration | ACADVersion | An enumerate type listing available AutoCAD versions, into which a file may be exported.
Public enumeration | AreaElemType | An enumerate type to store type of AreaElement.
Public enumeration | AssetPropertyType | An enumerate to list AssetProperty Types in Revit.
Public enumeration | AssetType | An enumerate to list Asset Types in Revit.
Public enumeration | BeamSystemJustifyType | Describes the justify method of beamsystem.
Public enumeration | BoxPlacement | An enumerate type listing possible placement of a box (an object of rectangular shape.)
Public enumeration | ColorDepthType | An enumerate type listing all Color Depth types of Print Setting.
Public enumeration | CriteriaFilterType | An enumerate type listing all relationships between element's parameter value and the specified value. It is used in defining a criterion in element retrieval by criteria filter.
Public enumeration | CurtainGridAlignType | An enumerate to list CurtainGrid patterns.
Public enumeration | DecimalSymbolType | An enumerate type listing two types of the Decimal Symbol types that Autodesk Revit supports.
Public enumeration | DigitGroupingAmount | An enumerate type listing the types of the Digit Grouping Amount that Autodesk Revit supports.
Public enumeration | DigitGroupingSymbolType | An enumerate type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.
Public enumeration | DisplayUnit | Describes the type of Revit display unit, metric or imperial.
Public enumeration | DisplayUnitType | An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.
Public enumeration | EaveCutterType | An enumerate type to store type of EaveCutter.
Public enumeration | ExportUnit | An enumerate type listing possible target units for CAD Export.
Public enumeration | HiddenLineViewsType | An enumerate type listing all Hidden Line Views types of Print Setting.
Public enumeration | ImportColorMode | An enumerate type listing how colors are handled in an import process.
Public enumeration | ImportPlacement | An enumerate type listing possible placement modes for imported drawings.
Public enumeration | ImportUnit | An enumerate type listing possible target units for CAD Export.
Public enumeration | LeaderEndCondition | An enumerate type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.
Public enumeration | LineScaling | An enumerate type listing possible LineType scaling modes.
Public enumeration | MarginType | An enumerate type listing all Margin types of Print Setting.
Public enumeration | MaterialBehaviourType | An enumerate type listing all the material behavior type.
Public enumeration | PageOrientationType | An enumerate type listing all Page Orientation types of Print Setting.
Public enumeration | PaperPlacementType | An enumerate type listing all Paper Placement types of Print Setting.
Public enumeration | PostedErrorType | Describes the type of a posted error.
Public enumeration | PrintRange | An enumerate type listing all Print Range types of Print.
Public enumeration | PropOverrideMode | An enumerate type listing ways how overridden object styles get exported.
Public enumeration | RasterQualityType | An enumerate type listing all Raster Quality types of Print Setting.
Public enumeration | SetComparisonResult | An enumerate type listing all the relationship types between two sets of arbitrary nature.
Public enumeration | SlabShapeCreaseType | An enumerate type listing all Crease types of Slab Shape Edit.
Public enumeration | SlabShapeVertexType | An enumerate type listing all Vertex types of Slab Shape Edit.
Public enumeration | SolidGeometry | An enumerate type listing possible ways of exporting solids in 3D views.
Public enumeration | TagMode | An enumerate type listing Tag Mode when user adding tag that Autodesk Revit supports.
Public enumeration | TagOrientation | An enumerate type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.
Public enumeration | TextAlignFlags | An enumerate type listing all the Text align flags.
Public enumeration | TextAlignMask | An enumerate type listing all the Text align mask.
Public enumeration | TextElementBackground | An enumerate type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
Public enumeration | TextNoteLeaderStyles | An enumerate type listing all the Leader styles.
Public enumeration | TextNoteLeaderTypes | An enumerate type listing all the Leader types.
Public enumeration | TrussMemberType | Indicates the "kind" of a truss member.
Public enumeration | UnitGroup | An enumerate type listing Discipline of the Unit types that Autodesk Revit supports.
Public enumeration | UnitSymbolType | An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.
Public enumeration | UnitType | An enumerate type listing all the Unit types that Autodesk Revit supports.
Public enumeration | ViewType | An enumerate type listing available view types.)
Public enumeration | VirtualPrinterType | An enumerate to list Virtual Printer Types in Revit.
Public enumeration | ZoomType | An enumerate type listing all Zoom types of Print Setting.

ACADVersion Enumeration
CollapseAll image DropDown image

An enumerate type listing available AutoCAD versions, into which a file may be exported.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("EA7663B8-3A5B-495d-97C8-4E82C71BB739")]
public enum ACADVersion
Visual Basic (Declaration)
<GuidAttribute("EA7663B8-3A5B-495d-97C8-4E82C71BB739")> _
Public Enumeration ACADVersion
Visual C++
[GuidAttribute(L"EA7663B8-3A5B-495d-97C8-4E82C71BB739")]
public enum class ACADVersion

Members

Member name | Description
Default | Revit Building application's default export format.
R2007 | AutoCAD 2007 file format.
R2004 | AutoCAD 2004 file format.
R2000 | AutoCAD 2000 file format.

See Also

Autodesk.Revit.Enums Namespace