LocationCurve Class
See Also Members
CollapseAll image DropDown image

Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("67C26FFA-E670-4b32-9B86-21CA5A6B1C00")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LocationCurve : Location
Visual Basic (Declaration)
<GuidAttribute("67C26FFA-E670-4b32-9B86-21CA5A6B1C00")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LocationCurve _
    Inherits Location
Visual C++
[GuidAttribute(L"67C26FFA-E670-4b32-9B86-21CA5A6B1C00")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Location
Autodesk.Revit..::LocationCurve

See Also

LocationCurve Members
Autodesk.Revit Namespace