gbXMLParamElem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class gbXMLParamElem
Visual Basic (Declaration)
Public Class gbXMLParamElem
Visual C++
public ref class gbXMLParamElem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | gbXMLParamElemgbXMLParamElemNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | BuildingConstruction | Get the Building Construction of the Project Information.
Public property | BuildingService | Get or Set the Building Service of the Project Information.
Public property | BuildingType | Get or Set the Building Type of the Project Information.
Public property | GroundPlane | Get the Ground Plane of the Project Information.
Public property | Parameter | Overloaded.
Public property | PostalCode | Get or Set the Postal Code of the Project Information.
Public property | ProjectLocation | Get the Location of the Project Information.
Public property | ProjectPhase | Get the Project Phase of the Project Information.
Public property | ShadingSurfaces | Get the Shading Surfaces of the Project Information.

See Also

gbXMLParamElem
Autodesk.Revit.Elements Namespace