ObjectType Property

Element..::ObjectType Property
CollapseAll image DropDown image

Returns the instance type of this object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Symbol ObjectType{ get; set;}
Visual Basic (Declaration)
Public Property ObjectType As Symbol
Visual C++
public:
property Symbol^ ObjectType {
    Symbol^ get ();
    void set (Symbol^ value);
}

Remarks

The type of the object returned by this method depends upon the type of this instance, for example - if this object is a wall then a wall type object will be returned. Not all objects have an instance type in which case Nothing is returned.

See Also

Element Class
Autodesk.Revit Namespace