OnDialogBox Method

ApplicationEvents..::OnDialogBox Method
CollapseAll image DropDown image

This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
void OnDialogBox(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Sub OnDialogBox ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
void OnDialogBox (
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
DialogBoxData
An object that describes the dialog box.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace