CylindricalFace Class
See Also Members
CollapseAll image DropDown image

A cylinder face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AD4F8A59-1D25-41B1-A755-8CC9AB1216A0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CylindricalFace : Face
Visual Basic (Declaration)
<GuidAttribute("AD4F8A59-1D25-41B1-A755-8CC9AB1216A0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CylindricalFace _
    Inherits Face
Visual C++
[GuidAttribute(L"AD4F8A59-1D25-41B1-A755-8CC9AB1216A0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CylindricalFace : public Face

Remarks

Cylinder faces are defined by cylinder surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + cos(u)*Radius[0] + sin(u)*Radius[1] + v*Axis

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::CylindricalFace

See Also

CylindricalFace Members
Autodesk.Revit.Geometry Namespace