SlabShapeEditor Methods
CollapseAll image DropDown image

Syntax

C#
public class SlabShapeEditor
Visual Basic (Declaration)
Public Class SlabShapeEditor
Visual C++
public ref class SlabShapeEditor

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | ModifySubElement | Overloaded.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.

Protected Methods

 | Name | Description

See Also

SlabShapeEditor
Autodesk.Revit.Editor Namespace