TypeBinding Class
See Also Members
CollapseAll image DropDown image

TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("C45CA703-AEE8-4eea-831A-5FAF9AFEBAE0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class TypeBinding : ElementBinding
Visual Basic (Declaration)
<GuidAttribute("C45CA703-AEE8-4eea-831A-5FAF9AFEBAE0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class TypeBinding _
    Inherits ElementBinding
Visual C++
[GuidAttribute(L"C45CA703-AEE8-4eea-831A-5FAF9AFEBAE0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class TypeBinding : public ElementBinding

Remarks

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Binding
Autodesk.Revit.Parameters..::ElementBinding
Autodesk.Revit.Parameters..::TypeBinding

See Also

TypeBinding Members
Autodesk.Revit.Parameters Namespace