Reference Class
See Also Members
CollapseAll image DropDown image

A stable reference to a geometric object in a Revit model.
An array that contains reference objects.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DD414170-A856-44d8-829B-BCC137E6FF41")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Reference : APIObject
Visual Basic (Declaration)
<GuidAttribute("DD414170-A856-44d8-829B-BCC137E6FF41")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Reference _
    Inherits APIObject
Visual C++
[GuidAttribute(L"DD414170-A856-44d8-829B-BCC137E6FF41")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Reference : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Reference

See Also

Reference Members
Autodesk.Revit.Geometry Namespace