Rebar Properties
CollapseAll image DropDown image

Syntax

C#
public class Rebar
Visual Basic (Declaration)
Public Class Rebar
Visual C++
public ref class Rebar

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ArrayLength | For Rebar with an array layout, return the length of the distribution path.
Public property | BarType | Return the type of the rebar.
Public property | Curves | The centerline of the Rebar.
Public property | DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Public property | Host | The element that contains the rebar.
Public property | IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Public property | Parameter | Overloaded.
Public property | RebarShape | Get/Set the RebarShape associated with the Rebar.

See Also

Rebar
Autodesk.Revit.Elements Namespace