AddSteel Method

Materials..::AddSteel Method
CollapseAll image DropDown image

Add a steel material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialSteel AddSteel(
    string name
)
Visual Basic (Declaration)
Public Function AddSteel ( _
    name As String _
) As MaterialSteel
Visual C++
public:
MaterialSteel^ AddSteel (
    String^ name
)

Parameters

name
String
The name of the steel material to be added.

Return Value

The pointer to the added steel material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace