NurbSpline Class
See Also Members
CollapseAll image DropDown image

A nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("70E084BC-81A8-4a32-8E86-ADDB8B8D8DDB")]
public class NurbSpline : Curve
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("70E084BC-81A8-4a32-8E86-ADDB8B8D8DDB")> _
Public Class NurbSpline _
    Inherits Curve
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"70E084BC-81A8-4a32-8E86-ADDB8B8D8DDB")]
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Curve
Autodesk.Revit.Geometry..::NurbSpline

See Also

NurbSpline Members
Autodesk.Revit.Geometry Namespace