AnalyticalModelProfile Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class AnalyticalModelProfile
Visual Basic (Declaration)
Public Class AnalyticalModelProfile
Visual C++
public ref class AnalyticalModelProfile

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelProfileAnalyticalModelProfileNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public property | EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
Public property | StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
Public property | SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile
Autodesk.Revit.Structural Namespace