Space Class
See Also Members
CollapseAll image DropDown image

Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9B4B226D-1077-4a92-8DA1-354C90AE121B")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Space : Element
Visual Basic (Declaration)
<GuidAttribute("9B4B226D-1077-4a92-8DA1-354C90AE121B")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Space _
    Inherits Element
Visual C++
[GuidAttribute(L"9B4B226D-1077-4a92-8DA1-354C90AE121B")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Space : public Element

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Space

See Also

Space Members
Autodesk.Revit.Elements Namespace