OnDocumentSavedAs Event

ControlledApplication..::OnDocumentSavedAs Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometime a document will be saved to a file with another name during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace