Transform Class
See Also Members
CollapseAll image DropDown image

A transformation of the affine 3-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4CE66A0D-2A39-4307-89B2-40ACE3EE4792")]
public class Transform : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4CE66A0D-2A39-4307-89B2-40ACE3EE4792")> _
Public Class Transform _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4CE66A0D-2A39-4307-89B2-40ACE3EE4792")]
public ref class Transform : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::Transform

See Also

Transform Members
Autodesk.Revit.Geometry Namespace