ObjectFactory Methods
CollapseAll image DropDown image

Syntax

C#
public class ObjectFactory
Visual Basic (Declaration)
Public Class ObjectFactory
Visual C++
public ref class ObjectFactory

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | CreateInstance | For Internal Use Only.
Public method | Dispose | Overloaded.
Public method | GetInstance | For Internal Use Only.
Public method | RemoveInstance | For Internal Use Only.

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.

See Also

ObjectFactory
Autodesk.Revit Namespace