OnDocumentSavedAs Event

Application..::OnDocumentSavedAs Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved to a file with another name. By subscribing to this event the application will be notified after such an event and can perform an action in reponse.

See Also

Application Class
Autodesk.Revit Namespace