Volume Property

Solid..::Volume Property
CollapseAll image DropDown image

Returns the signed volume of this solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Volume{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Return Value

The real number equal to the signed volume of this solid.

Remarks

Calculates the solid volume by integrating tessellated representations of faces and edges. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace