OnDocumentSaved Event

ControlledApplication..::OnDocumentSaved Event
CollapseAll image DropDown image

Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometime a document will be saved during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace