OnSave Event

Document..::OnSave Event
CollapseAll image DropDown image

Subscribe to the OnSave event to be notified before a document has been saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentSaveEventHandler OnSave
Visual Basic (Declaration)
Public Event OnSave As DocumentSaveEventHandler
Visual C++
public:
 event DocumentSaveEventHandler^ OnSave {
    void add (DocumentSaveEventHandler^ value);
    void remove (DocumentSaveEventHandler^ value);
}

Remarks

Sometimes an application needs to know when the document will be saved. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace