Material Class
See Also Members
CollapseAll image DropDown image

Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("80C8B148-52E1-43bd-95E5-B04612D36000")]
public abstract class Material : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("80C8B148-52E1-43bd-95E5-B04612D36000")> _
Public MustInherit Class Material _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"80C8B148-52E1-43bd-95E5-B04612D36000")]
public ref class Material abstract : public Element

Remarks

This is the abstract parent class for concrete material subclasses. Currently, the supported materials are wood, steel, generic, concrete and other.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::MaterialConcrete
Autodesk.Revit.Elements..::MaterialGeneric
Autodesk.Revit.Elements..::MaterialOther
Autodesk.Revit.Elements..::MaterialSteel
Autodesk.Revit.Elements..::MaterialWood

See Also

Material Members
Autodesk.Revit.Elements Namespace