Categories Class
See Also Members
CollapseAll image DropDown image

The Categories object is a map that contains all the Category objects within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("5DA0C323-C8E7-40ff-A176-C9DBB6E479EC")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Categories : CategoryNameMap
Visual Basic (Declaration)
<GuidAttribute("5DA0C323-C8E7-40ff-A176-C9DBB6E479EC")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Categories _
    Inherits CategoryNameMap
Visual C++
[GuidAttribute(L"5DA0C323-C8E7-40ff-A176-C9DBB6E479EC")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Categories : public CategoryNameMap

Remarks

A specific category object can be retrieved from the Categories map using the Item method, passing the name, as a string, to the method.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::CategoryNameMap
Autodesk.Revit..::Categories

See Also

Categories Members
Autodesk.Revit Namespace