ReferencePlane Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ReferencePlane
Visual Basic (Declaration)
Public Class ReferencePlane
Visual C++
public ref class ReferencePlane

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ReferencePlaneReferencePlaneNew |

Public Methods

 | Name | Description
Public method | Flip | Flips the orientation of the reference plane.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Direction | The direction of the reference plane.
Public property | FreeEnd | The free end of the reference plane.
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | Parameter | Overloaded.
Public property | Plane | The geometry plane to which the reference plane is assigned.

See Also

ReferencePlane
Autodesk.Revit.Elements Namespace