Autodesk.Revit.Elements Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Elements
Visual Basic (Declaration)
Namespace Autodesk.Revit.Elements
Visual C++
namespace Autodesk.Revit.Elements

Classes

 | Class | Description
Public class | AnnotationSymbol | This object represents a symbol of the Generic Annotation.
Public class | Area | Provides access to the area topology in Autodesk Revit.
Public class | AreaLoad | An object that represents a force applied across an area.
Public class | AreaReinforcement | An object that represents an Area Reinforcement within the Autodesk Revit project.
Public class | AreaReinforcementCurve | An object that specifies the type of a floor in Autodesk Revit.
Public class | AreaTag | Provides access to the area topology in Autodesk Revit.
Public class | BaseArray | An abstract base class that represents an array within the Revit project.
Public class | BeamSystem | An object that represents a BeamSystem within the Autodesk Revit project.
Public class | Blend | Provides access to the Blend model in Autodesk Revit.
Public class | BoundaryConditions | An object that represents a force applied across an area.
Public class | CeilingAndFloor | A base class that provides support for all ceiling and floor objects.
Public class | ConduitType | Represents a specific conduit type of wire type.
Public class | ConduitTypeSet | A set that contains conduit types.
Public class | ConduitTypeSetIterator | An iterator to a conduit type set.
Public class | ContFooting | An object that represents a Continuous Footing within Autodesk Revit.
Public class | CurtainCell | Represents a CurtainCell within Autodesk Revit.
Public class | CurtainCellSet | A set that can contain any type of object.
Public class | CurtainCellSetIterator | An iterator to a set.
Public class | CurtainGrid | Represents a CurtainGrid within Autodesk Revit. It is not an independent element.It represents a CurtainGrid from a curtain wall,curtain system or curtain roof. Curtain wall has only one CurtainGrid,curtain system or curtain roof may have several CurtainGrids.
Public class | CurtainGridLine | Represents a CurtainGridLine within Autodesk Revit.
Public class | CurtainGridSet | A set that can contain any type of object.
Public class | CurtainGridSetIterator | An iterator to a set.
Public class | CurtainSystem | Provides access to the CurtainSystem object in Autodesk Revit.
Public class | CurtainSystemBase | Provides access to the CurtainSystemBase object in Autodesk Revit.
Public class | DesignOption | An element that represents a design alternative.
Public class | DetailArc | Represents a DetailArc within Autodesk Revit.
Public class | DetailCurve | Represents a DetailCurve within Autodesk Revit.
Public class | DetailCurveArray | An array that can contain any type of object.
Public class | DetailCurveArrayIterator | An iterator to a array.
Public class | DetailEllipse | Represents a DetailEllipse within Autodesk Revit.
Public class | DetailLine | Represents a DetailLine within Autodesk Revit.
Public class | DetailNurbSpline | Represents a DetailNurbSpline within Autodesk Revit.
Public class | Dimension | An object that represents a dimension within the Revit project.
Public class | ElectricalSystem | Provides access to the Electrical System in Autodesk Revit MEP.
Public class | ElectricalSystemSet | A set that can contain any type of object.
Public class | ElectricalSystemSetIterator | An iterator to a set.
Public class | Extrusion | Provides access to the Extrusion model in Autodesk Revit.
Public class | ExtrusionRoof | Represents some kinds of Extrusion Roofs.
Public class | Family | The Family object is a Symbol that defines an entire family.
Public class | FamilyBase | A base class for all Family objects.
Public class | FamilyInstance | This object represents a single instance of a family type, such as a single I beam.
Public class | Fascia | An object that represents a fascia within the Autodesk Revit project.
Public class | FillPattern | Represents a fill pattern element within an Autodesk Revit project.
Public class | Floor | An object that represents a Floor within the Autodesk Revit project.
Public class | FootPrintRoof | Represents kinds of FootPrintRoofs.
Public class | gbXMLParamElem | An object that represents the gbXML Parameters within the Autodesk Revit project.
Public class | GenericForm | Provides access to the Generic Form model in Autodesk Revit.
Public class | GenericFormSet | A set that can contain any type of object.
Public class | GenericFormSetIterator | An iterator to a set.
Public class | Grid | Represents a single grid line within Autodesk Revit.
Public class | Group | This object represents a group of elements within the project.
Public class | GroupSet | An set that contains groups.
Public class | GroupSetIterator | An iterator to a group set.
Public class | Gutter | An object that represents a gutter within the Autodesk Revit project.
Public class | HostedSweep | An object that represents a roof within the Autodesk Revit project.
Public class | HostObject | A base class that provides support for all objects that can host other objects, such as a wall.
Public class | IndependentTag | Represents a IndependentTag within Autodesk Revit.
Public class | InsertableInstance | A base class that provides support insertable instances.
Public class | Instance | A base class for all instance objects.
Public class | InsulationType | Represents electrical insulation type definition information.
Public class | InsulationTypeSet | A set that contains insulation types.
Public class | InsulationTypeSetIterator | An iterator to a insulation type set.
Public class | LayoutRule | The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Public class | LayoutRuleClearSpacing | This class indicate the layout rule of a Beam System is Clear-Spacing.
Public class | LayoutRuleFixedDistance | This class indicate the layout rule of a Beam System is Fixed-Distance.
Public class | LayoutRuleFixedNumber | This class indicate the layout rule of a Beam System is Fixed-Number.
Public class | LayoutRuleMaximumSpacing | This class indicate the layout rule of a Beam System is Max-Spacing.
Public class | Level | Represents a Level line within Autodesk Revit.
Public class | LinearArray | An object that represents an Array created linearly within the Revit project.
Public class | LineLoad | An object that represents a force/moment applied in a linear manner.
Public class | LinePattern | Represents a line pattern element within an Autodesk Revit project.
Public class | LoadBase | The LoadBase object is the base class for all load objects within the Autodesk Revit API.
Public class | LoadCase | This object represents a load case within the project.
Public class | LoadCaseArray | An array that contains load case objects.
Public class | LoadCaseArrayIterator | An iterator to an load case array.
Public class | LoadCaseSet | A set that contains load cases.
Public class | LoadCaseSetIterator | An iterator to a load case set.
Public class | LoadCombination | An object that represents a load combination.
Public class | LoadCombinationArray | An array that can contain any type of object.
Public class | LoadCombinationArrayIterator | An iterator to a array.
Public class | LoadNature | A structural Load nature object.
Public class | LoadUsage | This object represents a load case within the project.
Public class | LoadUsageArray | An array that contains load usage objects.
Public class | LoadUsageArrayIterator | An iterator to an load usage array.
Public class | Material | Represents a material element within an Autodesk Revit project.
Public class | MaterialConcrete | Represents a concrete material element in an Autodesk Revit project.
Public class | MaterialGeneric | Represents a generic material element in an Autodesk Revit project.
Public class | MaterialOther | Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.
Public class | MaterialSteel | Represents a steel material element in an Autodesk Revit project.
Public class | MaterialWood | Represents a wood material element in an Autodesk Revit project.
Public class | ModelArc | Represents a ModelArc within Autodesk Revit.
Public class | ModelCurve | Represents a ModelCurve within Autodesk Revit.
Public class | ModelCurveArrArray | An array that can contain any type of object.
Public class | ModelCurveArrArrayIterator | An iterator to a array.
Public class | ModelCurveArray | An array that contains model curves.
Public class | ModelCurveArrayIterator | An iterator to a model curve array.
Public class | ModelEllipse | Represents a ModelEllipse within Autodesk Revit.
Public class | ModelHermiteSpline | Represents a ModelHermiteSpline within Autodesk Revit.
Public class | ModelLine | Represents a ModelLine within Autodesk Revit.
Public class | ModelNurbSpline | Represents a ModelNurbSpline within Autodesk Revit.
Public class | Mullion | Represents a CurtainGrid within Autodesk Revit.
Public class | Opening | An object that represents a Opening within the Autodesk Revit project.
Public class | Panel | This object represents a curtain panel.
Public class | Path3d | Provides access to the Generic 3D path object in Autodesk Revit.
Public class | PathReinforcement | An object that represents an Path Reinforcement within the Autodesk Revit project.
Public class | Phase | Represents a phase in the life of a building.
Public class | PhaseArray | An array that contains phase objects.
Public class | PhaseArrayIterator | An iterator to a phase array.
Public class | PointLoad | An object that represents a force/moment applied to a single point.
Public class | PrintSetting | Represents the Print Setup (File->Print Setup...) within Autodesk Revit.
Public class | ProjectInfo | An object that represents a Project Information within the Autodesk Revit project.
Public class | ProjectUnit | Provides access to the Project Unit... in Autodesk Revit.
Public class | RadialArray | An object that represents an Array created radially within the Revit project.
Public class | Rebar | An object that represents Rebar.
Public class | RebarHostData | Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.
Public class | ReferencePlane | Represents a reference plane of Autodesk Revit.
Public class | Revolution | Provides access to the Revolution Form model in Autodesk Revit.
Public class | RoofBase | Represents all kinds of Roofs.
Public class | Room | Provides access to the room topology in Autodesk Revit.
Public class | RoomTag | Provides access to the room tag in Autodesk Revit.
Public class | Sketch | Provides access to the Sketch in Autodesk Revit.
Public class | SketchBase | Provides access to the SketchBase in Autodesk Revit.
Public class | SketchPlane | Represents a SketchPlane within Autodesk Revit.
Public class | SketchSet | A set that can contain any type of object.
Public class | SketchSetIterator | An iterator to a set.
Public class | SlabEdge | An object that represents a slab edge within the Autodesk Revit project.
Public class | Space | Provides access to the space topology in Autodesk Revit.
Public class | SpaceSet | A set that can contain any type of object.
Public class | SpaceSetIterator | An iterator to a set.
Public class | SpaceTag | Provides access to the space tag in Autodesk Revit.
Public class | SpotDimension | An object that represents a spot dimension within the Revit project.
Public class | Sweep | Provides access to the Sweep model in Autodesk Revit.
Public class | TemperatureRatingType | Represents temperature rating type definition information.
Public class | TemperatureRatingTypeSet | A set that contains TemperatureRating types.
Public class | TemperatureRatingTypeSetIterator | An iterator to a TemperatureRating type set.
Public class | TextElement | Represents the TextElment.
Public class | TextNote | Provides access to the TextNote object in Autodesk Revit.
Public class | Truss | Represents all kinds of Trusses.
Public class | View | Base class for Revit Views.
Public class | View3D | A freely-oriented orthographic or perspective view of the model.
Public class | ViewDrafting | A drafting view allows the user to draw graphics without including them in the model.
Public class | ViewPlan | A plan represents for floor plan or ceiling plan.
Public class | ViewSection | A section view cuts through the model to expose its interior structure.
Public class | ViewSet | A set that contains views.
Public class | ViewSetIterator | An iterator to a view set.
Public class | ViewSheet | A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.
Public class | ViewSheetSet | Represents all kinds of ViewSheetSets.
Public class | ViewSheetSets | A set that can contain any type of object.
Public class | ViewSheetSetsIterator | An iterator to a set.
Public class | Wall | Represents all of the different kinds of walls Autodesk Revit.
Public class | Wire | An object to represent electrical wire in Revit MEP product.
Public class | WireMaterialType | Represents electrical wire material type definition information of wire type.
Public class | WireMaterialTypeSet | A set that contains wire material types.
Public class | WireMaterialTypeSetIterator | An iterator to a wire material type set.
Public class | WireSet | A set that can contain any type of object.
Public class | WireSetIterator | An iterator to a set.
Public class | Zone | Provides access to the Zone Element in Autodesk Revit.

AnnotationSymbol Class
See Also Members
CollapseAll image DropDown image

This object represents a symbol of the Generic Annotation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F09BD497-A1D9-493d-82CF-95978B03059A")]
public class AnnotationSymbol : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F09BD497-A1D9-493d-82CF-95978B03059A")> _
Public Class AnnotationSymbol _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F09BD497-A1D9-493d-82CF-95978B03059A")]
public ref class AnnotationSymbol : public Element

Remarks

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::AnnotationSymbol

See Also

AnnotationSymbol Members
Autodesk.Revit.Elements Namespace