ResetSlabShape Method

SlabShapeEditor..::ResetSlabShape Method
CollapseAll image DropDown image

Removes the modifications made during editing and resets the element geometry back to the un-modified state.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void ResetSlabShape()
Visual Basic (Declaration)
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape ()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace