DimensionType Class
See Also Members
CollapseAll image DropDown image

An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4DB3A29F-C044-4959-AE64-9408013B8F82")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DimensionType : Symbol
Visual Basic (Declaration)
<GuidAttribute("4DB3A29F-C044-4959-AE64-9408013B8F82")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DimensionType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"4DB3A29F-C044-4959-AE64-9408013B8F82")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DimensionType : public Symbol

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::DimensionType
Autodesk.Revit.Symbols..::SpotDimensionType

See Also

DimensionType Members
Autodesk.Revit.Symbols Namespace