Execute Method

IExternalCommand..::Execute Method
CollapseAll image DropDown image

Overload this method to implement and external command within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
IExternalCommand.IExternalCommand..::Result Execute(
    ExternalCommandData commandData,
    out string message,
    ElementSet elements
)
Visual Basic (Declaration)
Function Execute ( _
    commandData As ExternalCommandData, _
    <OutAttribute> ByRef message As String, _
    <OutAttribute> elements As ElementSet _
) As IExternalCommand..::Result
Visual C++
IExternalCommand..::Result Execute (
    ExternalCommandData^ commandData,
    [InAttribute] [OutAttribute] String^% message,
    [InAttribute] [OutAttribute] ElementSet^ elements
)

Parameters

commandData
ExternalCommandData
A ExternalCommandData object which contains reference to Application and View needed by external command.
message
String %
Error message can be returned by external command.
elements
ElementSet
Element set could be used for transferring elements between external command and Autodesk Revit.

Return Value

Result tells whether the excution fail,succeed or was canceled by user. If not succeed, Autodesk Revit should undo any changes made by the external command.

See Also

IExternalCommand Interface
Autodesk.Revit Namespace