NewViewSheet Method

Document..::NewViewSheet Method
CollapseAll image DropDown image

Creates a new sheet view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ViewSheet NewViewSheet(
    FamilySymbol titleBlock
)
Visual Basic (Declaration)
Public Function NewViewSheet ( _
    titleBlock As FamilySymbol _
) As ViewSheet
Visual C++
public:
ViewSheet^ NewViewSheet (
    FamilySymbol^ titleBlock
)

Parameters

titleBlock
FamilySymbol
The titleblock family symbol to apply to this sheet.

Return Value

The newly created sheet view.

Remarks

Use the TitleBlocks property of Document to choose a titleblock.

See Also

Document Class
Autodesk.Revit.Creation Namespace