Transform Methods
CollapseAll image DropDown image

Syntax

C#
public class Transform
Visual Basic (Declaration)
Public Class Transform
Visual C++
public ref class Transform

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
 | Multiply | Multiplies the two specified transforms.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

Transform
Autodesk.Revit.Geometry Namespace