Data Property

ExternalCommandData..::Data Property
CollapseAll image DropDown image

A data map that can be used to read and write data to the Autodesk Revit journal file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StringStringMap Data{ get; set;}
Visual Basic (Declaration)
Public Property Data As StringStringMap
Visual C++
public:
property StringStringMap^ Data {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

The data map is a string to string map that can be used to store data in the Revit journal file at the end of execution of the external command. If the command is then executed from the journal file during playback this data is then passed to the external command in this Data property so the external command can execute with this passed data in a UI-less mode, hence providing non interactive journal playback for automated testing purposes. For more information on Revit's journaling features contact the Autodesk Developer Network.

See Also

ExternalCommandData Class
Autodesk.Revit Namespace