ElectricalSystem Methods
CollapseAll image DropDown image

Syntax

C#
public class ElectricalSystem
Visual Basic (Declaration)
Public Class ElectricalSystem
Visual C++
public ref class ElectricalSystem

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddToCircuit | Add a set of exist components to the Electrical System.
Public method | DisconnectPanel | Disconnect the panel for the Electrical System.
Public method | NewWires | Create a bunch of wires for the electrical system.
Public method | RemoveFromCircuit | remove a set of exist components from the Electrical System.
Public method | SelectPanel | Set the panel for the Electrical System.

Protected Methods

 | Name | Description

See Also

ElectricalSystem
Autodesk.Revit.Elements Namespace