Solid Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Solid
Visual Basic (Declaration)
Public Class Solid
Visual C++
public ref class Solid

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SolidSolidNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid
Autodesk.Revit.Geometry Namespace