DefinitionBindingMapIterator Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class DefinitionBindingMapIterator
Visual Basic (Declaration)
Public MustInherit Class DefinitionBindingMapIterator
Visual C++
public ref class DefinitionBindingMapIterator abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionBindingMapIteratorDefinitionBindingMapIteratorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
Public property | Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator
Autodesk.Revit.Collections Namespace