Filter Methods
CollapseAll image DropDown image

Syntax

C#
public class Filter
Visual Basic (Declaration)
Public Class Filter
Visual C++
public ref class Filter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | NewCategoryFilter | Overloaded.
Public method | NewFamilyFilter | Creates a FamilyFilter object.
Public method | NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
Public method | NewLogicAndFilter | Creates a new LogicAndFilter object.
Public method | NewLogicNotFilter | Creates a new LogicNotFilter object.
Public method | NewLogicOrFilter | Creates a new LogicOrFilter object.
Public method | NewMaterialFilter | Creates a MaterialFilter object.
Public method | NewParameterFilter | Overloaded.
Public method | NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
Public method | NewSymbolFilter | Creates a SymbolFilter object.
Public method | NewTypeFilter | Overloaded.
Public method | NewWallUsageFilter | Creates a new WallUsageFilter object.

Protected Methods

 | Name | Description

See Also

Filter
Autodesk.Revit.Creation Namespace