NewLogicAndFilter Method

Filter..::NewLogicAndFilter Method
CollapseAll image DropDown image

Creates a new LogicAndFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicAndFilter NewLogicAndFilter(
    Filter leftFilter,
    Filter rightFilter
)
Visual Basic (Declaration)
Public Function NewLogicAndFilter ( _
    leftFilter As Filter, _
    rightFilter As Filter _
) As LogicAndFilter
Visual C++
public:
LogicAndFilter^ NewLogicAndFilter (
    Filter^ leftFilter,
    Filter^ rightFilter
)

Parameters

leftFilter
Filter
leftFilter is left operand of logic-and operator
rightFilter
Filter
rightFilter is right operand of logic-and operator

Return Value

Returns a new LogicAndFilter object.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace