RoofBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class RoofBase
Visual Basic (Declaration)
Public Class RoofBase
Visual C++
public ref class RoofBase

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RoofBaseRoofBaseNew |

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Parameter | Overloaded.
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.

See Also

RoofBase
Autodesk.Revit.Elements Namespace