ToolbarItems Property

Toolbar..::ToolbarItems Property
CollapseAll image DropDown image

Gets the collection of ToolBarItem controls assigned to the toolbar control.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItemArray ToolbarItems{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ToolbarItems As ToolbarItemArray
Visual C++
public:
property ToolbarItemArray^ ToolbarItems {
    ToolbarItemArray^ get ();
}

Remarks

The ToolbarItems property is a zero-based indexed collection used to hold all the ToolBarItem controls assigned to the toolbar. Because the property is read-only, it can not be assigned a collection of toolbar items directly. Toolbar items can be added by using the methods AddItem. Use the Add method to add individual button.

See Also

Toolbar Class
Autodesk.Revit Namespace