ProjectUnit Class
See Also Members
CollapseAll image DropDown image

Provides access to the Project Unit... in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("19F91877-F209-4481-9C5F-4916FA86B1AA")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ProjectUnit : Element
Visual Basic (Declaration)
<GuidAttribute("19F91877-F209-4481-9C5F-4916FA86B1AA")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ProjectUnit _
    Inherits Element
Visual C++
[GuidAttribute(L"19F91877-F209-4481-9C5F-4916FA86B1AA")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ProjectUnit : public Element

Remarks

The ProjectUnit object can be queried for its D in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::ProjectUnit

See Also

ProjectUnit Members
Autodesk.Revit.Elements Namespace