HookType Property

BarDescription..::HookType Property
CollapseAll image DropDown image

Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarHookType HookType[
    int end
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace