DoubleArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DoubleArray
Visual Basic (Declaration)
Public Class DoubleArray
Visual C++
public ref class DoubleArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DoubleArrayDoubleArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray
Autodesk.Revit.Geometry Namespace