ProjectPosition Property

ProjectLocation..::ProjectPosition Property
CollapseAll image DropDown image

Get or set the project position in relation to the site position

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProjectPosition ProjectPosition[
    XYZ point
]{ get; set;}
Visual Basic (Declaration)
Public Property ProjectPosition ( _
    point As XYZ _
) As ProjectPosition
Visual C++
public:
property ProjectPosition^ ProjectPosition[XYZ^ point] {
    ProjectPosition^ get (XYZ^ point);
    void set (XYZ^ point, ProjectPosition^ value);
}

Parameters

point
XYZ

Remarks

When getting a position the point passed is converted to an East to West, North to South and angle of rotation. When set the passed point becomes the specified East to West, North to South and angle location.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace