OnDialogBox Event

ControlledApplication..::OnDialogBox Event
CollapseAll image DropDown image

Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometime a Revit dialog box may be displayed during an API command. By subscribing to this event you application will be notified of such an event and perform an action, such as causing the dialog to be ok'd or cancelled etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace