AddWood Method

Materials..::AddWood Method
CollapseAll image DropDown image

Add a wood material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialWood AddWood(
    string name
)
Visual Basic (Declaration)
Public Function AddWood ( _
    name As String _
) As MaterialWood
Visual C++
public:
MaterialWood^ AddWood (
    String^ name
)

Parameters

name
String
The name of the wood material to be added.

Return Value

The pointer to the added wood material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

See Also

Materials Class
Autodesk.Revit Namespace