RebarShapeDefinition Class
See Also Members
CollapseAll image DropDown image

A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("3083737D-A4F8-49f6-BE3B-C0FE4486966F")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class RebarShapeDefinition : APIObject
Visual Basic (Declaration)
<GuidAttribute("3083737D-A4F8-49f6-BE3B-C0FE4486966F")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class RebarShapeDefinition _
    Inherits APIObject
Visual C++
[GuidAttribute(L"3083737D-A4F8-49f6-BE3B-C0FE4486966F")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class RebarShapeDefinition : public APIObject

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Symbols..::RebarShapeDefinition
Autodesk.Revit.Symbols..::RebarShapeDefinitionBySegments
Autodesk.Revit.Symbols..::RebarShapeDefinitionByArc

See Also

RebarShapeDefinition Members
Autodesk.Revit.Symbols Namespace