HookPermission Property

RebarBarType..::HookPermission Property
CollapseAll image DropDown image

Access to permission data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool HookPermission[
    RebarHookType hookId
]{ get; set;}
Visual Basic (Declaration)
Public Property HookPermission ( _
    hookId As RebarHookType _
) As Boolean
Visual C++
public:
property bool HookPermission[RebarHookType^ hookId] {
    bool get (RebarHookType^ hookId);
    void set (RebarHookType^ hookId, bool value);
}

Parameters

hookId
RebarHookType

Remarks

This determines whether the hooks may be used with this bar type.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace