Autodesk.Revit.MEP Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.MEP
Visual Basic (Declaration)
Namespace Autodesk.Revit.MEP
Visual C++
namespace Autodesk.Revit.MEP

Classes

 | Class | Description
Public class | Connector | Provides access to the Connector in Autodesk Revit MEP.
Public class | ConnectorManager | Provides access to the Connector Manager in Autodesk Revit MEP.
Public class | ConnectorSet | A set that can contain any type of object.
Public class | ConnectorSetIterator | An iterator to a set.
Public class | CorrectionFactor | Represents electrical correction factor information.
Public class | CorrectionFactorSet | A set that contains correction factors.
Public class | CorrectionFactorSetIterator | An iterator to a correction factor set.
Public class | DemandFactorData | Represents demand factor definition in a specified range.
Public class | DemandFactorDataSet | A set that can contain any type of object.
Public class | DemandFactorDataSetIterator | An iterator to a set.
Public class | ElectricalEquipment | Provides access to the Electrical Equipment in Autodesk Revit MEP.
Public class | ElectricalSetting | An object that represents electrical information within the Autodesk Revit project.
Public class | GroundConductorSize | Represents electrical ground conductor size definition information.
Public class | GroundConductorSizeSet | A set that contains GroundConductorSizes.
Public class | GroundConductorSizeSetIterator | An iterator to a GroundConductorSize set.
Public class | LightingDevice | Provides access to the Lighting Device in Autodesk Revit MEP.
Public class | LightingFixture | Provides access to the Lighting Fixture in Autodesk Revit MEP.
Public class | MechanicalEquipment | Provides access to the Mechanical Equipment in Autodesk Revit MEP.
Public class | MEPModel | Supports all Analytical Models that are persistent within the Autodesk Revit project
Public class | WireSize | Represents specific electrical wire size information.
Public class | WireSizeSet | A set that contains wire sizes.
Public class | WireSizeSetIterator | An iterator to a wire size set.

Connector Class
See Also Members
CollapseAll image DropDown image

Provides access to the Connector in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0256C2CE-6485-4014-8900-200794632753")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Connector : APIObject
Visual Basic (Declaration)
<GuidAttribute("0256C2CE-6485-4014-8900-200794632753")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Connector _
    Inherits APIObject
Visual C++
[GuidAttribute(L"0256C2CE-6485-4014-8900-200794632753")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Connector : public APIObject

Remarks

The Connector object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::Connector

See Also

Connector Members
Autodesk.Revit.MEP Namespace