OnDocumentClosed Event

ControlledApplication..::OnDocumentClosed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometime a document will be closed during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace