InstanceArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to an instance array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("9DA1D933-A299-4039-A213-CFB8FB1D0A75")]
public abstract class InstanceArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("9DA1D933-A299-4039-A213-CFB8FB1D0A75")> _
Public MustInherit Class InstanceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"9DA1D933-A299-4039-A213-CFB8FB1D0A75")]
public ref class InstanceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::InstanceArrayIterator

See Also

InstanceArrayIterator Members
Autodesk.Revit.Geometry Namespace