MechanicalEquipment Class
See Also Members
CollapseAll image DropDown image

Provides access to the Mechanical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("705F6574-3FB2-44de-AA99-5E8C594D7458")]
public class MechanicalEquipment : MEPModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("705F6574-3FB2-44de-AA99-5E8C594D7458")> _
Public Class MechanicalEquipment _
    Inherits MEPModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"705F6574-3FB2-44de-AA99-5E8C594D7458")]
public ref class MechanicalEquipment : public MEPModel

Remarks

The Mechanical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::MEPModel
Autodesk.Revit.MEP..::MechanicalEquipment

See Also

MechanicalEquipment Members
Autodesk.Revit.MEP Namespace