PlanTopology Class
See Also Members
CollapseAll image DropDown image

An object that represents a Plan Topology within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("511384BD-1B3B-45ac-966E-A228F8AA94D3")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class PlanTopology : APIObject
Visual Basic (Declaration)
<GuidAttribute("511384BD-1B3B-45ac-966E-A228F8AA94D3")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class PlanTopology _
    Inherits APIObject
Visual C++
[GuidAttribute(L"511384BD-1B3B-45ac-966E-A228F8AA94D3")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class PlanTopology : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::PlanTopology

See Also

PlanTopology Members
Autodesk.Revit Namespace