AnalyticalModel3D Class
See Also Members
CollapseAll image DropDown image

Supports all Analytical Models that have more than two dimensions within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F377028A-2A42-4faf-A349-0E3730FE22FC")]
public class AnalyticalModel3D : AnalyticalModel
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F377028A-2A42-4faf-A349-0E3730FE22FC")> _
Public Class AnalyticalModel3D _
    Inherits AnalyticalModel
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F377028A-2A42-4faf-A349-0E3730FE22FC")]
public ref class AnalyticalModel3D : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModel3D

See Also

AnalyticalModel3D Members
Autodesk.Revit.Structural Namespace