XYZArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class XYZArray
Visual Basic (Declaration)
Public Class XYZArray
Visual C++
public ref class XYZArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | XYZArrayXYZArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every XYZ coordinate from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a XYZ coordinate at a specified index within the array.
Public property | Size | Returns the number of XYZ coordinates that are in the array.

See Also

XYZArray
Autodesk.Revit.Geometry Namespace