Application Properties
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ActiveDocument | Provides access to an object that represents the currently active project.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | Documents | Returns a set of documents within Revit.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

Application
Autodesk.Revit Namespace