IntersectionResult Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class IntersectionResult
Visual Basic (Declaration)
Public Class IntersectionResult
Visual C++
public ref class IntersectionResult

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | IntersectionResultIntersectionResultNew |

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult
Autodesk.Revit.Geometry Namespace