LogicAndFilter Class
See Also Members
CollapseAll image DropDown image

The LogicAndFilter is used to implement Logic-AND operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("96D40172-8F32-418f-8A74-E0D5458F11E0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LogicAndFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("96D40172-8F32-418f-8A74-E0D5458F11E0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LogicAndFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"96D40172-8F32-418f-8A74-E0D5458F11E0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LogicAndFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-AND relationship, use it to filter elements which satisfy both sub-filters.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::LogicAndFilter

See Also

LogicAndFilter Members
Autodesk.Revit Namespace