SetLayoutRuleWithoutExaminingHost Method

Rebar..::SetLayoutRuleWithoutExaminingHost Method
CollapseAll image DropDown image

Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetLayoutRuleWithoutExaminingHost(
    int layoutRule
)
Visual Basic (Declaration)
Public Sub SetLayoutRuleWithoutExaminingHost ( _
    layoutRule As Integer _
)
Visual C++
public:
void SetLayoutRuleWithoutExaminingHost (
    int layoutRule
)

Parameters

layoutRule
Int32
0 for "None" or "Single", 1 for "Fixed Number", 2 for "Maximum Spacing", 3 for "Number with Spacing", 4 for "Minimum Clear Spacing".

Remarks

Changing the parameter REBAR_ELEM_LAYOUT_RULE attempts to extend the rebar set towards the center of the host, but depending on geometrical conditions, it can make the wrong decision. This function changes the layout rule while suppressing the geometric test for the direction of the set. The difference in behavior only occurs when changing the layout rule from None (0) to one of the other settings.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace