DetailNurbSpline Class
See Also Members
CollapseAll image DropDown image

Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("619BBA93-34CE-4a2c-A4DC-840B877E2847")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DetailNurbSpline : DetailCurve
Visual Basic (Declaration)
<GuidAttribute("619BBA93-34CE-4a2c-A4DC-840B877E2847")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
[GuidAttribute(L"619BBA93-34CE-4a2c-A4DC-840B877E2847")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::DetailNurbSpline

See Also

DetailNurbSpline Members
Autodesk.Revit.Elements Namespace