BuiltInParameterGroup Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8A924832-4C80-4033-AECA-8F2F448B18AA")]
public enum BuiltInParameterGroup
Visual Basic (Declaration)
<GuidAttribute("8A924832-4C80-4033-AECA-8F2F448B18AA")> _
Public Enumeration BuiltInParameterGroup
Visual C++
[GuidAttribute(L"8A924832-4C80-4033-AECA-8F2F448B18AA")]
public enum class BuiltInParameterGroup

Members

Member name | Description
PG_ANALYSIS_RESULTS |
PG_SLAB_SHAPE_EDIT |
PG_LIGHT_PHOTOMETRICS |
PG_PARQUET |
PG_GREEN_BUILDING |
PG_PROFILE_2 |
PG_PROFILE_1 |
PG_PROFILE |
PG_TRUSS_FAMILY_BOTTOM_CHORD |
PG_TRUSS_FAMILY_TOP_CHORD |
PG_TRUSS_FAMILY_DIAG_WEB |
PG_TRUSS_FAMILY_VERT_WEB |
PG_TITLE |
PG_FIRE_PROTECTION |
PG_ROTATION_ABOUT |
PG_TRANSLATION_IN |
PG_ANALYTICAL_MODEL |
PG_REBAR_ARRAY |
PG_REBAR_SYSTEM_LAYERS |
PG_ORIENTATION |
PG_PATTERN_GRID |
PG_PATTERN_MULLION_2 |
PG_PATTERN_MULLION_HORIZ |
PG_PATTERN_MULLION_1 |
PG_PATTERN_MULLION_VERT |
PG_PATTERN_GRID_2 |
PG_PATTERN_GRID_HORIZ |
PG_PATTERN_GRID_1 |
PG_PATTERN_GRID_VERT |
PG_IFC |
PG_AELECTRICAL |
PG_ENERGY_ANALYSIS |
PG_STRUCTURAL_ANALYSIS |
PG_MECHANICAL_AIRFLOW |
PG_MECHANICAL_LOADS |
PG_ELECTRICAL_LOADS |
PG_ELECTRICAL_LIGHTING |
PG_TEXT |
PG_VIEW_CAMERA |
PG_VIEW_EXTENTS |
PG_PATTERN |
PG_CONSTRAINTS |
PG_PHASING |
PG_MECHANICAL |
PG_STRUCTURAL |
PG_PLUMBING |
PG_ELECTRICAL |
PG_STAIR_STRINGERS |
PG_STAIR_RISERS |
PG_STAIR_TREADS |
PG_MATERIALS |
PG_GRAPHICS |
PG_CONSTRUCTION |
PG_GEOMETRY |
PG_IDENTITY_DATA |
INVALID |

Remarks

Parameter groups are used to sort parameters within the Element Properties dialog.

See Also

Autodesk.Revit.Parameters Namespace