Element Class
See Also Members
CollapseAll image DropDown image

Geometric representation of an element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("92F7301A-D945-450c-9C17-764909E6486D")]
public class Element : GeometryObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("92F7301A-D945-450c-9C17-764909E6486D")> _
Public Class Element _
    Inherits GeometryObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"92F7301A-D945-450c-9C17-764909E6486D")]
public ref class Element : public GeometryObject

Remarks

This class contains geometric primitives that are generated from the parametric description of the element.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Element

See Also

Element Members
Autodesk.Revit.Geometry Namespace