RemoveTemperatureRatingType Method

WireMaterialType..::RemoveTemperatureRatingType Method
CollapseAll image DropDown image

Remove an existing temperature rating type from this material type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveTemperatureRatingType(
    TemperatureRatingType temperatureRating
)
Visual Basic (Declaration)
Public Sub RemoveTemperatureRatingType ( _
    temperatureRating As TemperatureRatingType _
)
Visual C++
public:
void RemoveTemperatureRatingType (
    TemperatureRatingType^ temperatureRating
)

Parameters

temperatureRating
TemperatureRatingType
The temperature rating type to be removed.

Exceptions

Exception | Condition
System..::InvalidOperationException | The last temperature rating type of project and any one used by a wire type can't be removed.

See Also

WireMaterialType Class
Autodesk.Revit.Elements Namespace