OnDialogBox Event

Application..::OnDialogBox Event
CollapseAll image DropDown image

Subscribe to the OnDialogBox event to be notified when a Autodesk Revit dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometime a Autodesk Revit dialog box may be displayed during an API command. By subscribing to this event the application will be notified of such an event and can perform an action, such as dismissing the dialog automatically.

See Also

Application Class
Autodesk.Revit Namespace