ParameterMapIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a map relating a parameter name (the key, a String) to a parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("EFBB82F9-0E36-4b8f-B50D-05E3B2CD9A28")]
public abstract class ParameterMapIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("EFBB82F9-0E36-4b8f-B50D-05E3B2CD9A28")> _
Public MustInherit Class ParameterMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"EFBB82F9-0E36-4b8f-B50D-05E3B2CD9A28")]
public ref class ParameterMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::ParameterMapIterator

See Also

ParameterMapIterator Members
Autodesk.Revit Namespace