ParameterFilter Class
See Also Members
CollapseAll image DropDown image

To filter elements with specific parameter criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("AD469815-0BA9-4bca-9BCD-2C8A9556731F")]
public class ParameterFilter : Filter
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("AD469815-0BA9-4bca-9BCD-2C8A9556731F")> _
Public Class ParameterFilter _
    Inherits Filter
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"AD469815-0BA9-4bca-9BCD-2C8A9556731F")]
public ref class ParameterFilter : public Filter

Remarks

The parameter filter object is used to filter all the elements in the document which meet the given parameter criterion.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::ParameterFilter

See Also

ParameterFilter Members
Autodesk.Revit Namespace