NewNurbSpline Method

Application..::NewNurbSpline Method
CollapseAll image DropDown image

Creates a new geometric nurbSpline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public NurbSpline NewNurbSpline(
    XYZArray ctrlPoints,
    DoubleArray weights,
    DoubleArray knots,
    int nDegree,
    bool bClosed,
    bool bRational
)
Visual Basic (Declaration)
Public Function NewNurbSpline ( _
    ctrlPoints As XYZArray, _
    weights As DoubleArray, _
    knots As DoubleArray, _
    nDegree As Integer, _
    bClosed As Boolean, _
    bRational As Boolean _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline (
    XYZArray^ ctrlPoints,
    DoubleArray^ weights,
    DoubleArray^ knots,
    int nDegree,
    bool bClosed,
    bool bRational
)

Parameters

ctrlPoints
XYZArray
The control points of the nurbSpline.
weights
DoubleArray
The weights of the nurbSpline.
knots
DoubleArray
The knots of the nurbSpline.
nDegree
Int32
The degree of the nurbSpline.
bClosed
Boolean
The nurbSpline is closed or not.
bRational
Boolean
The nurbSpline is rational or no rational.

Remarks

If bRational is true,the size of ctrlPoints must equal to weights's,otherwise throw ArgumentException. There is a rule like that the size of knots equals to the sum of nDegree, ctrlPoints.size and 1, and the first nDegree+1 elements in the knots always are zero.

See Also

Application Class
Autodesk.Revit.Creation Namespace