Wall Class
See Also Members
CollapseAll image DropDown image

Represents all of the different kinds of walls Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("52FF70F5-4985-43ed-B21D-584FC5584F6D")]
public class Wall : HostObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("52FF70F5-4985-43ed-B21D-584FC5584F6D")> _
Public Class Wall _
    Inherits HostObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"52FF70F5-4985-43ed-B21D-584FC5584F6D")]
public ref class Wall : public HostObject

Remarks

The wall object represents all the different kinds of wall in Revit. The WallType property is used to distinguish the type of the wall. The wall object is derived from the Element object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::Wall

See Also

Wall Members
Autodesk.Revit.Elements Namespace