Rebar Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Rebar
Visual Basic (Declaration)
Public Class Rebar
Visual C++
public ref class Rebar

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarRebarNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ScaleToBox | Move and resize the bar to fit within a specified box.
Public method | SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | ArrayLength | For Rebar with an array layout, return the length of the distribution path.
Public property | BarType | Return the type of the rebar.
Public property | Curves | The centerline of the Rebar.
Public property | DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Public property | Host | The element that contains the rebar.
Public property | IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Public property | Parameter | Overloaded.
Public property | RebarShape | Get/Set the RebarShape associated with the Rebar.

See Also

Rebar
Autodesk.Revit.Elements Namespace