ImportUnit Enumeration
CollapseAll image DropDown image

An enumerate type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("7BC6080E-27B7-43db-B04C-9F7C76D4AE47")]
public enum ImportUnit
Visual Basic (Declaration)
<GuidAttribute("7BC6080E-27B7-43db-B04C-9F7C76D4AE47")> _
Public Enumeration ImportUnit
Visual C++
[GuidAttribute(L"7BC6080E-27B7-43db-B04C-9F7C76D4AE47")]
public enum class ImportUnit

Members

Member name | Description
Default | Unit (if available) from the document that is getting imported.
Meter | Meters as decimal values.
Decimeter | Centimeters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.

See Also

Autodesk.Revit.Enums Namespace