ParameterType Enumeration
CollapseAll image DropDown image

An enumerate type listing all of the data type interpretation that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("4A0E9B72-1CFD-4455-B7C4-4536A6883A22")]
public enum ParameterType
Visual Basic (Declaration)
<GuidAttribute("4A0E9B72-1CFD-4455-B7C4-4536A6883A22")> _
Public Enumeration ParameterType
Visual C++
[GuidAttribute(L"4A0E9B72-1CFD-4455-B7C4-4536A6883A22")]
public enum class ParameterType

Members

Member name | Description
Moment | The data value will be represented as a moment.
AreaForce | The data value will be represented as a area force.
LinearForce | The data value will be represented as a linear force.
Force | The data value will be represented as a force.
YesNo | A boolean value that will be represented as Yes or No.
Material | The value of this property is considered to be a material.
Angle | The parameter data represents an angle. The internal representation will be in radians. The user visible representation will be in the units that the user has chosen.
Volume | The parameter data represents a volume. The internal representation will be in decimal cubic feet. The user visible representation will be in the units that the user has chosen.
Area | The parameter data represents an area. The internal representation will be in decimal square feet. The user visible representation will be in the units that the user has chosen.
Integer | The parameter data should be interpreted as a whole number, positive or negative.
URL | A text string that represents a web address.
Length | The parameter data represents a length. The internal representation will be in decimal feet. The user visible representation will be in the units system that the user has chosen.
Text | The parameter data should be interpreted as a string of text.
Number | The parameter data should be interpreted as a real number, possibly including decimal points.
Invalid | The parameter type is invalid. This value should not be used.

See Also

Autodesk.Revit.Parameters Namespace