Face Properties
CollapseAll image DropDown image

Syntax

C#
public class Face
Visual Basic (Declaration)
Public Class Face
Visual C++
public ref class Face

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElement | Element describing the material from which this face is composed. (Overrides GeometryObject ..::MaterialElement()().)
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.

See Also

Face
Autodesk.Revit.Geometry Namespace