FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace