Opening Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Opening
Visual Basic (Declaration)
Public Class Opening
Visual C++
public ref class Opening

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | OpeningOpeningNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | BoundaryCurves | Retrieves the geometry information if the opening boundary is not a rect.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | Host | Retrieves the host element of this opening.
Public property | IsRectBoundary | Retrieves the information whether the opening has a rect boundary.
Public property | Parameter | Overloaded.

See Also

Opening
Autodesk.Revit.Elements Namespace