DesignOption Class
See Also Members
CollapseAll image DropDown image

An element that represents a design alternative.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0A5ED1CF-9543-4573-B5DE-280922549327")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class DesignOption : Element
Visual Basic (Declaration)
<GuidAttribute("0A5ED1CF-9543-4573-B5DE-280922549327")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class DesignOption _
    Inherits Element
Visual C++
[GuidAttribute(L"0A5ED1CF-9543-4573-B5DE-280922549327")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class DesignOption : public Element

Remarks

Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::DesignOption

See Also

DesignOption Members
Autodesk.Revit.Elements Namespace