AreaElemType Enumeration
CollapseAll image DropDown image

An enumerate type to store type of AreaElement.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("DCECC415-7605-4C4A-9B1F-CB7AC320618E")]
public enum AreaElemType
Visual Basic (Declaration)
<GuidAttribute("DCECC415-7605-4C4A-9B1F-CB7AC320618E")> _
Public Enumeration AreaElemType
Visual C++
[GuidAttribute(L"DCECC415-7605-4C4A-9B1F-CB7AC320618E")]
public enum class AreaElemType

Members

Member name | Description
BOMAArea | Office Area Scheme - uses BOMA rules for space classification.
GrossArea | Gross Area Scheme - only 2 types of spaces (internal and external).

See Also

Autodesk.Revit.Enums Namespace