Arc Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Arc
Visual Basic (Declaration)
Public Class Arc
Visual C++
public ref class Arc

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ArcArcNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | Center | Returns the center of the arc.
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Radius | Returns the radius of the arc.

See Also

Arc
Autodesk.Revit.Geometry Namespace