Mesh Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class Mesh
Visual Basic (Declaration)
Public Class Mesh
Visual C++
public ref class Mesh

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MeshMeshNew | For Internal Use Only.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.

See Also

Mesh
Autodesk.Revit.Geometry Namespace