Symbol Class
See Also Members
CollapseAll image DropDown image

Base class for all Symbols and Types within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FEE5FE57-9B1E-4fa7-B616-D610DEE18434")]
public class Symbol : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("FEE5FE57-9B1E-4fa7-B616-D610DEE18434")> _
Public Class Symbol _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FEE5FE57-9B1E-4fa7-B616-D610DEE18434")]
public ref class Symbol : public Element

Remarks

Symbols are usually non user visible elements that define instances. For example a wall type is a symbol that is not visible until an instance of the wall is created.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::InsertableObject
Autodesk.Revit.Symbols..::HostObjAttributes
Autodesk.Revit.Symbols..::LoadTypeBase
Autodesk.Revit.Symbols..::GroupType
Autodesk.Revit.Symbols..::RebarBarType
Autodesk.Revit.Symbols..::RebarHookType
Autodesk.Revit.Symbols..::RebarShape
Autodesk.Revit.Symbols..::RebarCoverType
Autodesk.Revit.Symbols..::AreaReinforcementType
Autodesk.Revit.Symbols..::DimensionType
Autodesk.Revit.Symbols..::LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::PathReinforcementType
Autodesk.Revit.Symbols..::BeamSystemType
Autodesk.Revit.Symbols..::LevelType
Autodesk.Revit.Symbols..::RoomTagType
Autodesk.Revit.Symbols..::AreaTagType
Autodesk.Revit.Symbols..::VoltageType
Autodesk.Revit.Symbols..::DistributionSysType
Autodesk.Revit.Symbols..::WireType
Autodesk.Revit.Symbols..::DemandFactor
Autodesk.Revit.Symbols..::TrussType
Autodesk.Revit.Symbols..::SpaceTagType
Autodesk.Revit.Symbols..::MEPBuildingConstruction
Autodesk.Revit.Site..::SiteLocation

See Also

Symbol Members
Autodesk.Revit Namespace