Insert Method

DefinitionBindingMap..::Insert Method
CollapseAll image DropDown image

Insert the specified binding with the specified definition into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Definition^ key,
    Binding^ item
)

Parameters

key
Definition
The definition to be used for inserting the binding into the map.
item
Binding
The binding to be inserted into the map.

Return Value

Returns whether the binding was inserted into the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace