TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
CollapseAll image DropDown image

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData (
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
View
The View for TextNote.
origin
XYZ
Origin of the TextNote.
baseVec
XYZ
BaseVec parameter of the TextNote.
upVec
XYZ
UpVec parameter of the TextNote.
lineWidth
Double
Line width of the out rectangle.
textAlign
TextAlignFlags
Align style.
strText
String
Text.

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace