Application Members
See Also Methods Properties Constructors Events
CollapseAll image DropDown image

Syntax

C#
public class Application
Visual Basic (Declaration)
Public Class Application
Visual C++
public ref class Application

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ApplicationApplicationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | CreateToolbar | Create a new ToolBar
Public method | CreateTopMenu | Creates a top level menu which will be added to revit main menus.
Public method | GetAllTopMenus | Returns all of the top level menus.
Public method | GetToolbars | Get all the ToolBars created by API.
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile | Overloaded.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | ActiveDocument | Provides access to an object that represents the currently active project.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | Documents | Returns a set of documents within Revit.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

Public Events

 | Name | Description
Public event | OnDialogBox | Subscribe to the OnDialogBox event to be notified when a Autodesk Revit dialog box is displayed during an API external command.
Public event | OnDocumentClosed | Subscribe to the OnDocumentClosed event to be notified after a document is closed.
Public event | OnDocumentNewed | Subscribe to the OnDocumentNewed event to be notified after a new document has been created.
Public event | OnDocumentOpened | Subscribe to the OnDocumentOpened event to be notified after a document has been opened.
Public event | OnDocumentSaved | Subscribe to the OnDocumentSaved event to be notified after a document is saved.
Public event | OnDocumentSavedAs | Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

See Also

Application
Autodesk.Revit Namespace