OfVector Method

Transform..::OfVector Method
CollapseAll image DropDown image

Applies the transform to the vector

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic (Declaration)
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector (
    XYZ^ vec
)

Parameters

vec
XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace