Autodesk.Revit.Events Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Events
Visual Basic (Declaration)
Namespace Autodesk.Revit.Events
Visual C++
namespace Autodesk.Revit.Events

Classes

 | Class | Description
Public class | DialogBoxData | An object that is passed to your application when a dialog is displayed in Revit.
Public class | MessageBoxData | An object that represents a simple message box that has been displayed prompting the user for some action.

Interfaces

 | Interface | Description
Public interface | ApplicationEvents | An interface that supports the events from the Revit Application object.
Public interface | DocumentEvents | An interface that supports the events from the Autodesk Revit Document object.

Delegates

 | Delegate | Description
Public delegate | DialogBoxEventHandler | A handler for the event that is fired when a Revit dialog box is displayed during an external API command.
Public delegate | DocumentClosedEventHandler | A handler for the event that is fired after a document is closed.
Public delegate | DocumentCloseEventHandler | A handler for the event that is fired before the current document is closed.
Public delegate | DocumentNewedEventHandler | A handler for the event that is fired after a new document is created.
Public delegate | DocumentOpenedEventHandler | A handler for the event that is fired after a document is opened.
Public delegate | DocumentSaveAsEventHandler | A handler for the event that is fired before the current document is saved as a file with different file name.
Public delegate | DocumentSavedAsEventHandler | A handler for the event that is fired after a document is saved as a file with different file name.
Public delegate | DocumentSavedEventHandler | A handler for the event that is fired after a document is saved.
Public delegate | DocumentSaveEventHandler | A handler for the event that is fired before the current document is saved.

ApplicationEvents Interface
See Also Members
CollapseAll image DropDown image

An interface that supports the events from the Revit Application object.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)]
[GuidAttribute("4DD847AE-D94C-4f5a-B4FC-CDCEF896DC4A")]
public interface ApplicationEvents
Visual Basic (Declaration)
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)> _
<GuidAttribute("4DD847AE-D94C-4f5a-B4FC-CDCEF896DC4A")> _
Public Interface ApplicationEvents
Visual C++
[InterfaceTypeAttribute(ComInterfaceType::InterfaceIsIDispatch)]
[GuidAttribute(L"4DD847AE-D94C-4f5a-B4FC-CDCEF896DC4A")]
public interface class ApplicationEvents

See Also

ApplicationEvents Members
Autodesk.Revit.Events Namespace