LoadCaseSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class LoadCaseSet
Visual Basic (Declaration)
Public Class LoadCaseSet
Visual C++
public ref class LoadCaseSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LoadCaseSetLoadCaseSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every load case from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load case within the set.
Public method | Erase | Removes a specified load case from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified load case into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet
Autodesk.Revit.Elements Namespace