InternalDefinition Properties
CollapseAll image DropDown image

Syntax

C#
public class InternalDefinition
Visual Basic (Declaration)
Public Class InternalDefinition
Visual C++
public ref class InternalDefinition

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Name | The user visible name for the parameter. (Overrides Definition ..:: Name.)
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition ..:: ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition ..:: ParameterType.)

See Also

InternalDefinition
Autodesk.Revit.Parameters Namespace