ControlledApplication Class
See Also Members
CollapseAll image DropDown image

Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("4C99D41F-ACA5-4d11-8E3A-58D526818220")]
public class ControlledApplication
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("4C99D41F-ACA5-4d11-8E3A-58D526818220")> _
Public Class ControlledApplication
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"4C99D41F-ACA5-4d11-8E3A-58D526818220")]
public ref class ControlledApplication

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::ControlledApplication

See Also

ControlledApplication Members
Autodesk.Revit Namespace