Definition Class
See Also Members
CollapseAll image DropDown image

The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A84A6494-7EC3-4f98-A71A-66833D911B97")]
public abstract class Definition : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A84A6494-7EC3-4f98-A71A-66833D911B97")> _
Public MustInherit Class Definition _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A84A6494-7EC3-4f98-A71A-66833D911B97")]
public ref class Definition abstract : public APIObject

Remarks

This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilise this Definition base class as then the code will be applicable to both internal and external parameter definitions.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Parameters..::Definition
Autodesk.Revit.Parameters..::ExternalDefinition
Autodesk.Revit.Parameters..::InternalDefinition

See Also

Definition Members
Autodesk.Revit.Parameters Namespace