UVArray Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class UVArray
Visual Basic (Declaration)
Public Class UVArray
Visual C++
public ref class UVArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | UVArrayUVArrayNew |

Public Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every UV coordinate from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a UV coordinate at a specified index within the array.
Public property | Size | Returns the number of UV coordinates that are in the array.

See Also

UVArray
Autodesk.Revit.Geometry Namespace