GetAllTopMenus Method

ControlledApplication..::GetAllTopMenus Method
CollapseAll image DropDown image

Returns all of the top level menus.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void GetAllTopMenus(
    ref Array topMenus
)
Visual Basic (Declaration)
Public Sub GetAllTopMenus ( _
    ByRef topMenus As Array _
)
Visual C++
public:
void GetAllTopMenus (
    Array^% topMenus
)

Parameters

topMenus
Array %
This is an output argument, which will include all the main menu items of Revit.

Remarks

All the items included in the main menu of Revit will be returned in the output arguments topMenus.

See Also

ControlledApplication Class
Autodesk.Revit Namespace