BoundarySegment Properties
CollapseAll image DropDown image

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this room.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.

See Also

BoundarySegment
Autodesk.Revit.Rooms Namespace