MaterialConcrete Properties
CollapseAll image DropDown image

Syntax

C#
public class MaterialConcrete
Visual Basic (Declaration)
Public Class MaterialConcrete
Visual C++
public ref class MaterialConcrete

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the concrete material.
Public property | ConcreteCompression | Get or set the concrete compression of the concrete material.
Public property | DampingRatio | Get or set the damping ratio of the concrete material.
Public property | LightWeight | Get or set whether the concrete material is lightweight.
Public property | Parameter | Overloaded.
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
Public property | ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
Public property | ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Public property | UnitWeight | Get or set the unit weight of the concrete material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete
Autodesk.Revit.Elements Namespace