AnalyticalModelLocation Class
See Also Members
CollapseAll image DropDown image

Supports Location Analytical Models (e.g., Structural Footings) that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("AC3B0A73-4835-4d5c-9AEB-2F45B1526604")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class AnalyticalModelLocation : AnalyticalModel
Visual Basic (Declaration)
<GuidAttribute("AC3B0A73-4835-4d5c-9AEB-2F45B1526604")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class AnalyticalModelLocation _
    Inherits AnalyticalModel
Visual C++
[GuidAttribute(L"AC3B0A73-4835-4d5c-9AEB-2F45B1526604")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class AnalyticalModelLocation : public AnalyticalModel

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Structural..::AnalyticalModel
Autodesk.Revit.Structural..::AnalyticalModelLocation

See Also

AnalyticalModelLocation Members
Autodesk.Revit.Structural Namespace