ElectricalSetting Class
See Also Members
CollapseAll image DropDown image

An object that represents electrical information within the Autodesk Revit project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("79505A6F-08FD-4f15-9EC4-C70D48C29CD6")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ElectricalSetting : APIObject
Visual Basic (Declaration)
<GuidAttribute("79505A6F-08FD-4f15-9EC4-C70D48C29CD6")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ElectricalSetting _
    Inherits APIObject
Visual C++
[GuidAttribute(L"79505A6F-08FD-4f15-9EC4-C70D48C29CD6")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ElectricalSetting : public APIObject

Remarks

ElectricalSetting includes voltage type, distribution system type, wire type, and demand factor setting. All basic operations of these electrical elements are supported.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.MEP..::ElectricalSetting

See Also

ElectricalSetting Members
Autodesk.Revit.MEP Namespace