CategoryNameMap Class
See Also Members
CollapseAll image DropDown image

A map that contains a mapping of category name to its category object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("293DE12E-7815-402b-A673-548CF922895E")]
public class CategoryNameMap : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("293DE12E-7815-402b-A673-548CF922895E")> _
Public Class CategoryNameMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"293DE12E-7815-402b-A673-548CF922895E")]
public ref class CategoryNameMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::CategoryNameMap
Autodesk.Revit..::Categories

See Also

CategoryNameMap Members
Autodesk.Revit Namespace