NewSketchPlane Method

Document..::NewSketchPlane Method
CollapseAll image DropDown image

Creates a new sketch plane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SketchPlane NewSketchPlane(
    Plane geometryPlane
)
Visual Basic (Declaration)
Public Function NewSketchPlane ( _
    geometryPlane As Plane _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane (
    Plane^ geometryPlane
)

Parameters

geometryPlane
Plane
The geometry plane to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise null pointer.

Remarks

See Also

Document Class
Autodesk.Revit.Creation Namespace