DefinitionBindingMap Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DefinitionBindingMap
Visual Basic (Declaration)
Public Class DefinitionBindingMap
Visual C++
public ref class DefinitionBindingMap

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionBindingMapDefinitionBindingMapNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains | Tests for the existence of a definition within the map.
Public method | Erase | Removes a binding with the specified definition from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert | Insert the specified binding with the specified definition into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | Item | Gets or sets a parameter binding for a specified parameter definition within the map.
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap
Autodesk.Revit.Collections Namespace