OnDocumentNewed Event

Application..::OnDocumentNewed Event
CollapseAll image DropDown image

Subscribe to the OnDocumentNewed event to be notified after a new document has been created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a new document has been created. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace