SuspendUpdating Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SuspendUpdating
Visual Basic (Declaration)
Public Class SuspendUpdating
Visual C++
public ref class SuspendUpdating

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SuspendUpdatingSuspendUpdatingNew | Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description
Protected method | ReleaseManagedResources | (Overrides APIObject ..:: ReleaseManagedResources()().)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Nested | A property that reports if updating has already been suspended before

See Also

SuspendUpdating
Autodesk.Revit Namespace