DemandFactor Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class DemandFactor
Visual Basic (Declaration)
Public Class DemandFactor
Visual C++
public ref class DemandFactor

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DemandFactorDemandFactorNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | SetPercentage | Set percentage value for the specified range.
Public method | SetPercentageToInfinity | This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | DataItems | Get all data items in this demand factor, which represents demand factor percentage in a specific range.
Public property | LoadClassification | Get category of demand factor.
Public property | Parameter | Overloaded.

See Also

DemandFactor
Autodesk.Revit.Symbols Namespace