Id Property

Element..::Id Property
CollapseAll image DropDown image

Provides a way of uniquely identifying an Element within an Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementId Id{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId Id {
    ElementId get ();
}

Remarks

Returns an ElementId object containing the project wide unique identifier for this Element. The identifier with the ElementId is only unique for the project, it is not unique across separate Autodesk Revit projects.

See Also

Element Class
Autodesk.Revit Namespace