CategoryFilter Class
See Also Members
CollapseAll image DropDown image

Represents a filter to filter elements with specific category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0A6EFA03-01F3-4e17-934F-41DE44D2A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class CategoryFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("0A6EFA03-01F3-4e17-934F-41DE44D2A7B7")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class CategoryFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"0A6EFA03-01F3-4e17-934F-41DE44D2A7B7")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class CategoryFilter : public Filter

Remarks

The category filter object is used to filter all the elements in the document of which the category is the appointed one.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::CategoryFilter

See Also

CategoryFilter Members
Autodesk.Revit Namespace