Filter Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public abstract class Filter
Visual Basic (Declaration)
Public MustInherit Class Filter
Visual C++
public ref class Filter abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
 | LogicalAnd | Overload operator && for new Logic-AND filter.
 | LogicalNot | Overload operator ! for new Logic-Not filter.
 | LogicalOr | Overload operator || for new Logic-OR filter.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)

Public Properties

 | Name | Description

See Also

Filter
Autodesk.Revit Namespace