TextElement Class
See Also Members
CollapseAll image DropDown image

Represents the TextElment.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("5AB5EA87-1218-429c-AF65-D6B88E275A41")]
public class TextElement : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("5AB5EA87-1218-429c-AF65-D6B88E275A41")> _
Public Class TextElement _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"5AB5EA87-1218-429c-AF65-D6B88E275A41")]
public ref class TextElement : public Element

Remarks

This class can be parent class of TextNote and other Text related classes.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::TextElement
Autodesk.Revit.Elements..::TextNote

See Also

TextElement Members
Autodesk.Revit.Elements Namespace