AddWireType Method

ElectricalSetting..::AddWireType Method
CollapseAll image DropDown image

Add a new wire type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WireType AddWireType(
    string name,
    WireMaterialType materialType,
    TemperatureRatingType temperatureRating,
    InsulationType insulation,
    WireSize maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType.WireType..::NeutralMode neutralMode,
    ConduitType conduit
)
Visual Basic (Declaration)
Public Function AddWireType ( _
    name As String, _
    materialType As WireMaterialType, _
    temperatureRating As TemperatureRatingType, _
    insulation As InsulationType, _
    maxSize As WireSize, _
    neutralMultiplier As Double, _
    neutralRequired As Boolean, _
    neutralMode As WireType..::NeutralMode, _
    conduit As ConduitType _
) As WireType
Visual C++
public:
WireType^ AddWireType (
    String^ name,
    WireMaterialType^ materialType,
    TemperatureRatingType^ temperatureRating,
    InsulationType^ insulation,
    WireSize^ maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType..::NeutralMode neutralMode,
    ConduitType^ conduit
)

Parameters

name
String
Name of the new wire type.
materialType
WireMaterialType
Wire material of new wire type.
temperatureRating
TemperatureRatingType
Temperature rating type information of new wire type.
insulation
InsulationType
Insulation of new wire type.
maxSize
WireSize
Max wire size of new wire type.
neutralMultiplier
Double
Neutral multiplier of new wire type.
neutralRequired
Boolean
Specify whether neutral point is required.
neutralMode
WireType..::NeutralMode
Specify neutral mode.
conduit
ConduitType
Conduit type of new wire type.

Return Value

New added wire type object.

Remarks

Param of temperatureRating should be retrieved from param of materialType, and params such as insulation, maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to be failed.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace