SketchBase Class
See Also Members
CollapseAll image DropDown image

Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A8CFE7ED-FEFB-48c4-B13D-99AEAE577F82")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class SketchBase : Element
Visual Basic (Declaration)
<GuidAttribute("A8CFE7ED-FEFB-48c4-B13D-99AEAE577F82")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class SketchBase _
    Inherits Element
Visual C++
[GuidAttribute(L"A8CFE7ED-FEFB-48c4-B13D-99AEAE577F82")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::Sketch
Autodesk.Revit.Elements..::Path3d

See Also

SketchBase Members
Autodesk.Revit.Elements Namespace