Item Property

ReferenceArray..::Item Property
CollapseAll image DropDown image

Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Reference Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Reference
Visual C++
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}

Parameters

index
Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace