PrintManager Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PrintManager
Visual Basic (Declaration)
Public Class PrintManager
Visual C++
public ref class PrintManager

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintManagerPrintManagerNew | Overloaded.

Protected Constructors

 | Name | Description
Protected method | PrintManagerPrintManagerNew | Overloaded.

Public Methods

 | Name | Description
Public method | Close | Close the Print, just like close the Print Dialog in Revit.
Public method | SelectNewPrintDriver | User can select new Printer with new printer name and its port name.
Public method | SubmitPrint | Overloaded.

Protected Methods

 | Name | Description
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Collate | Retrieve the information about whether to Collate or not of the current print.
Public property | CombinedFile | Retrieve the file name if user choose print to file.
Public property | CopyNumber | Retrieve the Number of copies of current print.
Public property | IsVirtual | Retrieve the information about whether the current printer is virtual or not in Revit.
Public property | PrinterName | Retrieve the printer name of current project.
Public property | PrintOrderReverse | Retrieve the information about whether to Reverse the print order or not of the current print.
Public property | PrintRange | Retrieve the Print Range of current print.
Public property | PrintSetup | Retrieve the Print Setup information of current project, and you can change the default Print Setting for Current Project.
Public property | PrintToFile | Retrieve the information about whether to Print to File or not of current project.
Public property | PrintToFileName | Retrieve the file name if user choose print to file.
Public property | ViewSheetSetting | Retrieve the View/Sheet Set information of current project, and you can change the default View/Sheet Set for Current Project.

See Also

PrintManager
Autodesk.Revit Namespace