MenuItem Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MenuItemMenuItemNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddToExternalTools | Add top level menu to "external tools" menu.
Public method | Append | Overloaded.
Public method | GetMenuItemCount | Get number of sub menus, if current menu is not popup menu, zero will be returned.
Public method | GetSubMenu | Get a sub menu, if current menu is not popup menu, null will be returned.
Public method | Insert | Overloaded.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AssemblyName | Get or set name of the assembly which external command lives in.
Public property | Checked | Set check or uncheck the menu through API.
Public property | ClassName | Get or set name of the class which implements external command.
Public property | Enabled | Disable and Enable the Custom menu through API.
Public property | MenuItemType | Get type of the menu through API.
Public property | Name | Get name of the menu through API.
Public property | StatusbarTip | Get or set tips.

See Also

MenuItem
Autodesk.Revit Namespace