GeometryObjectArrayIterator Class
See Also Members
CollapseAll image DropDown image

An iterator to a geometry object array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("F8BAD43C-CE1B-4bd0-8B29-AD0F396E19E0")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public abstract class GeometryObjectArrayIterator : APIObject, IEnumerator
Visual Basic (Declaration)
<GuidAttribute("F8BAD43C-CE1B-4bd0-8B29-AD0F396E19E0")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public MustInherit Class GeometryObjectArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[GuidAttribute(L"F8BAD43C-CE1B-4bd0-8B29-AD0F396E19E0")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GeometryObjectArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObjectArrayIterator

See Also

GeometryObjectArrayIterator Members
Autodesk.Revit.Geometry Namespace