Unit Field

CADImportOptions..::Unit Field
CollapseAll image DropDown image

The unit of measure for imported geometry.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ImportUnit Unit
Visual Basic (Declaration)
Public Unit As ImportUnit
Visual C++
public:
ImportUnit Unit

Remarks

Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored.

Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, Revit will default to inches.

See Also

CADImportOptions Class
Autodesk.Revit Namespace