XYZArray Class
See Also Members
CollapseAll image DropDown image

An array that contains XYZ coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("C48C8840-2414-432c-AC25-C0D11C5367A0")]
public class XYZArray : APIObject, IEnumerable
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("C48C8840-2414-432c-AC25-C0D11C5367A0")> _
Public Class XYZArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"C48C8840-2414-432c-AC25-C0D11C5367A0")]
public ref class XYZArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::XYZArray

See Also

XYZArray Members
Autodesk.Revit.Geometry Namespace