GroupType Class
See Also Members
CollapseAll image DropDown image

Represents a type of a user defined group.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("D4894974-BA34-4d79-9B0E-B9D06EE1247A")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class GroupType : Symbol
Visual Basic (Declaration)
<GuidAttribute("D4894974-BA34-4d79-9B0E-B9D06EE1247A")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class GroupType _
    Inherits Symbol
Visual C++
[GuidAttribute(L"D4894974-BA34-4d79-9B0E-B9D06EE1247A")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class GroupType : public Symbol

Remarks

The GroupType object can be used to swap the type of an existing group or to place an new instance of a group.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Symbols..::GroupType

See Also

GroupType Members
Autodesk.Revit.Symbols Namespace