XYZ Class
See Also Members
CollapseAll image DropDown image

Object representing coordinates in 3-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("57DCD1DC-D725-49b3-B04A-879FA927FA80")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class XYZ
Visual Basic (Declaration)
<GuidAttribute("57DCD1DC-D725-49b3-B04A-879FA927FA80")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class XYZ
Visual C++
[GuidAttribute(L"57DCD1DC-D725-49b3-B04A-879FA927FA80")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class XYZ

Remarks

Usually this means a point or a vector in space, depending on the actual use.

Inheritance Hierarchy

System..::Object
Autodesk.Revit.Geometry..::XYZ

See Also

XYZ Members
Autodesk.Revit.Geometry Namespace