StructuralType Enumeration
CollapseAll image DropDown image

Fundamental structural component category.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("73FA611B-2972-4d34-AFD3-C7663644DB14")]
public enum StructuralType
Visual Basic (Declaration)
<GuidAttribute("73FA611B-2972-4d34-AFD3-C7663644DB14")> _
Public Enumeration StructuralType
Visual C++
[GuidAttribute(L"73FA611B-2972-4d34-AFD3-C7663644DB14")]
public enum class StructuralType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
UnknownFraming | The structural type of the object is unknow.
Footing | The object is considered to be a footing.
Column | The object is considered too be a column.
Brace | The object is considered to be a brace.
Beam | The object is considered to be a beam.
NonStructural | The object is considered to be non structural in nature.

See Also

Autodesk.Revit.Structural.Enums Namespace