AddView Method

ViewSheet..::AddView Method
CollapseAll image DropDown image

Places view on the sheet at the given location.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddView(
    View newView,
    UV location
)
Visual Basic (Declaration)
Public Sub AddView ( _
    newView As View, _
    location As UV _
)
Visual C++
public:
void AddView (
    View^ newView,
    UV^ location
)

Parameters

newView
View
The view to be placed.
location
UV
Sheet coordinates (in inches) of the center of the view.

Remarks

Argument exception occurs if the view is of unappropriate type (e.g. ViewSheet) or the view is already placed on another sheet. The lower left corner of the sheet has coordinates [0,0]. Empty views are not placed on the sheet but no exception occurs.

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace