Revolution Class
See Also Members
CollapseAll image DropDown image

Provides access to the Revolution Form model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("0FD3C0B1-2A8F-4431-8318-8CBF59B5A83D")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Revolution : GenericForm
Visual Basic (Declaration)
<GuidAttribute("0FD3C0B1-2A8F-4431-8318-8CBF59B5A83D")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Revolution _
    Inherits GenericForm
Visual C++
[GuidAttribute(L"0FD3C0B1-2A8F-4431-8318-8CBF59B5A83D")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Revolution : public GenericForm

Remarks

The Revolution Form object can be queried for a generic form for use in family modeling and massing.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::Revolution

See Also

Revolution Members
Autodesk.Revit.Elements Namespace