AddToExternalTools Method

MenuItem..::AddToExternalTools Method
CollapseAll image DropDown image

Add top level menu to "external tools" menu.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AddToExternalTools()
Visual Basic (Declaration)
Public Function AddToExternalTools As Boolean
Visual C++
public:
bool AddToExternalTools ()

Return Value

When trying to add a non-top level menu into "external tools" menu, it gets false.

Remarks

All of the sub-menus will be added into external tools menu.

See Also

MenuItem Class
Autodesk.Revit Namespace