NewReferencePlane Method

Document..::NewReferencePlane Method
CollapseAll image DropDown image

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    cutVec As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane (
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)

Parameters

bubbleEnd
XYZ
The bubble end applied to reference plane.
freeEnd
XYZ
The free end applied to reference plane.
cutVec
XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView
View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace