ViewSection Class
See Also Members
CollapseAll image DropDown image

A section view cuts through the model to expose its interior structure.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("A32F0033-46FB-43b2-B23C-0DDA606E8F60")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class ViewSection : View
Visual Basic (Declaration)
<GuidAttribute("A32F0033-46FB-43b2-B23C-0DDA606E8F60")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class ViewSection _
    Inherits View
Visual C++
[GuidAttribute(L"A32F0033-46FB-43b2-B23C-0DDA606E8F60")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class ViewSection : public View

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::ViewSection

See Also

ViewSection Members
Autodesk.Revit.Elements Namespace