Location Property

Element..::Location Property
CollapseAll image DropDown image

This property is used to find the physical location of an element within project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Location Location{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get ();
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.

See Also

Element Class
Autodesk.Revit Namespace