PointLoadTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class PointLoadTypeSet
Visual Basic (Declaration)
Public Class PointLoadTypeSet
Visual C++
public ref class PointLoadTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PointLoadTypeSetPointLoadTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every pointload type from the set, rendering it empty.
Public method | Contains |
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet
Autodesk.Revit.Symbols Namespace