SetEndPointParameter Method

HostedSweep..::SetEndPointParameter Method
CollapseAll image DropDown image

Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Visual Basic (Declaration)
Public Function SetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer, _
    param As Double _
) As Boolean
Visual C++
public:
bool SetEndPointParameter (
    Reference^ targetRef,
    int endIdx,
    double param
)

Parameters

targetRef
Reference
Segment's reference whose parameter want to be set.
endIdx
Int32
Start point (=0) or end point (=1).
param
Double
Value of parameter.

Return Value

true if operation success.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace