Create Property

ControlledApplication..::Create Property
CollapseAll image DropDown image

Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Application Create{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

ControlledApplication Class
Autodesk.Revit Namespace