ToolbarItem Members
See Also Methods Properties
CollapseAll image DropDown image

Syntax

C#
public class ToolbarItem
Visual Basic (Declaration)
Public Class ToolbarItem
Visual C++
public ref class ToolbarItem

The type exposes the following members.

Public Methods

 | Name | Description

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | AssemblyName | Gets or sets the assembly path.
Public property | Checked | Gets or sets a value indicating whether a toggle-style toolbar button is currently in the checked state.
Public property | ClassName | Gets or sets the class name.
Public property | Enabled | Gets or sets a value indicating whether the button is enabled.
Public property | ImageIndex | Gets or sets the index value of the image assigned to the button.
Public property | ItemText | Gets or sets the text displayed on the toolbar button.
Public property | ItemType | Gets or sets the item type.
Public property | StatusbarTip | Gets or sets the text that appears on the Status bar for the button.
Public property | ToolTip | Gets or sets the text that appears as a ToolTip for the button.

See Also

ToolbarItem
Autodesk.Revit Namespace