WallUsageFilter Class
See Also Members
CollapseAll image DropDown image

A Filter object that represents Structural WallUsage, used to retrieve Wall elements whose structural WallUsage is specified WallUsage type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("1DB666E5-A207-449d-AD08-D5FF1B346418")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class WallUsageFilter : Filter
Visual Basic (Declaration)
<GuidAttribute("1DB666E5-A207-449d-AD08-D5FF1B346418")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class WallUsageFilter _
    Inherits Filter
Visual C++
[GuidAttribute(L"1DB666E5-A207-449d-AD08-D5FF1B346418")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class WallUsageFilter : public Filter

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Filter
Autodesk.Revit..::WallUsageFilter

See Also

WallUsageFilter Members
Autodesk.Revit Namespace