SpotDimensionTypeSet Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class SpotDimensionTypeSet
Visual Basic (Declaration)
Public Class SpotDimensionTypeSet
Visual C++
public ref class SpotDimensionTypeSet

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SpotDimensionTypeSetSpotDimensionTypeSetNew |

Public Methods

 | Name | Description
Public method | Clear | Removes every spotdimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a spotdimension type within the set.
Public method | Erase | Removes a specified spotdimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified spotdimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet
Autodesk.Revit.Symbols Namespace