DrawSplitLine Method

SlabShapeEditor..::DrawSplitLine Method
CollapseAll image DropDown image

Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeCreaseArray DrawSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
Visual Basic (Declaration)
Public Function DrawSplitLine ( _
    startVertex As SlabShapeVertex, _
    endVertex As SlabShapeVertex _
) As SlabShapeCreaseArray
Visual C++
public:
SlabShapeCreaseArray^ DrawSplitLine (
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)

Parameters

startVertex
SlabShapeVertex
The vertex to start the split line.
endVertex
SlabShapeVertex
The vertex to end the split line.

Return Value

The newly created creases.

Remarks

Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace