Autodesk.Revit.Options Namespace
CollapseAll image

Syntax

C#
namespace Autodesk.Revit.Options
Visual Basic (Declaration)
Namespace Autodesk.Revit.Options
Visual C++
namespace Autodesk.Revit.Options

Classes

 | Class | Description
Public class | Application | The Application Options object provides access to application wide settings.

Application Class
See Also Members
CollapseAll image DropDown image

The Application Options object provides access to application wide settings.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("09B3A3D8-BBA0-4ec8-B8F1-A2EC53C69C51")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Application : APIObject
Visual Basic (Declaration)
<GuidAttribute("09B3A3D8-BBA0-4ec8-B8F1-A2EC53C69C51")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Application _
    Inherits APIObject
Visual C++
[GuidAttribute(L"09B3A3D8-BBA0-4ec8-B8F1-A2EC53C69C51")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Application : public APIObject

Remarks

This object provides access to variables that are located in the Settings dialog within Autodesk Revit.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Options..::Application

See Also

Application Members
Autodesk.Revit.Options Namespace