LinearArray Class
See Also Members
CollapseAll image DropDown image

An object that represents an Array created linearly within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("55655614-3DED-44a2-AC44-B2614AA75259")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class LinearArray : BaseArray
Visual Basic (Declaration)
<GuidAttribute("55655614-3DED-44a2-AC44-B2614AA75259")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class LinearArray _
    Inherits BaseArray
Visual C++
[GuidAttribute(L"55655614-3DED-44a2-AC44-B2614AA75259")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class LinearArray : public BaseArray

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::BaseArray
Autodesk.Revit.Elements..::LinearArray

See Also

LinearArray Members
Autodesk.Revit.Elements Namespace