Panel Properties
CollapseAll image DropDown image

Syntax

C#
public class Panel
Visual Basic (Declaration)
Public Class Panel
Visual C++
public ref class Panel

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AsFamilyInstance | This property is used to get family instance within project.
Public property | Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | PanelType | The Panel style of this Panel.
Public property | Parameter | Overloaded.
Public property | Transform | This property is used to find the transform of a curtain panel within project.

See Also

Panel
Autodesk.Revit.Elements Namespace