FormatOptions Class
See Also Members
CollapseAll image DropDown image

Contains the Unit information of current user selection of Unit within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("A07FEB06-BCDF-416d-8B46-23AF07A1E1D5")]
public class FormatOptions : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("A07FEB06-BCDF-416d-8B46-23AF07A1E1D5")> _
Public Class FormatOptions _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"A07FEB06-BCDF-416d-8B46-23AF07A1E1D5")]
public ref class FormatOptions : public APIObject

Remarks

The FormatOptions contains 5 item. Rounding and UnitSymbol properties depend on the Units propery.All these three properties provided set function, but it is more rigid on input.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::FormatOptions

See Also

FormatOptions Members
Autodesk.Revit Namespace