ExtrusionRoof Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Syntax

C#
public class ExtrusionRoof
Visual Basic (Declaration)
Public Class ExtrusionRoof
Visual C++
public ref class ExtrusionRoof

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExtrusionRoofExtrusionRoofNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.

Protected Methods

 | Name | Description

Public Properties

 | Name | Description
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Public property | Parameter | Overloaded.

See Also

ExtrusionRoof
Autodesk.Revit.Elements Namespace