BoundarySegment Class
See Also Members
CollapseAll image DropDown image

An object that represents a segment of a room boundary.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("9D84DB94-3EF0-47c9-BD65-5A91BD8FDDB4")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundarySegment : APIObject
Visual Basic (Declaration)
<GuidAttribute("9D84DB94-3EF0-47c9-BD65-5A91BD8FDDB4")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
[GuidAttribute(L"9D84DB94-3EF0-47c9-BD65-5A91BD8FDDB4")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a room. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Rooms..::BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Rooms Namespace