BoundingBoxXYZ Class
See Also Members
CollapseAll image DropDown image

A three-dimensional rectangular box.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("8813BA5C-9BBD-4fb1-B0DF-C03C2DA0CAAE")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class BoundingBoxXYZ : APIObject
Visual Basic (Declaration)
<GuidAttribute("8813BA5C-9BBD-4fb1-B0DF-C03C2DA0CAAE")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class BoundingBoxXYZ _
    Inherits APIObject
Visual C++
[GuidAttribute(L"8813BA5C-9BBD-4fb1-B0DF-C03C2DA0CAAE")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class BoundingBoxXYZ : public APIObject

Remarks

The box is defined as follows. A Transform specifies the coordinate system in which the box is defined. The minimum and maximum values for each coordinate in that system are specified. An alternative way to construct the box is: for each basis vector of the transform, there are two planes that are orthogonal to the vector and have their origins given by Transform.Origin + BasisVector * Bound. The entire box and each face may be turned on or off.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::BoundingBoxXYZ

See Also

BoundingBoxXYZ Members
Autodesk.Revit.Geometry Namespace