ElementsAtJoin Property

LocationCurve..::ElementsAtJoin Property
CollapseAll image DropDown image

Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public List<Element> ElementsAtJoin[
    int end
]{ get; set;}
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Property ElementsAtJoin ( _
    end As Integer _
) As List(Of Element)
Visual C++
[ComVisibleAttribute(false)]
public:
property List<Element^>^ ElementsAtJoin[int end] {
    List<Element^>^ get (int end);
    void set (int end, List<Element^>^ value);
}

Parameters

end
Int32
The end at which the join is to be obtained or we want to change the order of join participants.

Remarks

The list of elements is expected to be a permutation of the elements already in the join at the end. It is expected that no new elements will be introduced, and existing ones will not be removed.

See Also

LocationCurve Class
Autodesk.Revit Namespace