Instance Class
See Also Members
CollapseAll image DropDown image

A base class for all instance objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("E1AB420F-77F1-452c-B53F-E97A60AB16DA")]
public class Instance : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("E1AB420F-77F1-452c-B53F-E97A60AB16DA")> _
Public Class Instance _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"E1AB420F-77F1-452c-B53F-E97A60AB16DA")]
public ref class Instance : public Element

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::InsertableInstance
Autodesk.Revit.Site..::ProjectLocation

See Also

Instance Members
Autodesk.Revit.Elements Namespace