Wire Class
See Also Members
CollapseAll image DropDown image

An object to represent electrical wire in Revit MEP product.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("6BF91B15-A25D-4a24-9ED8-EBED11DE8DA5")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class Wire : HostObject
Visual Basic (Declaration)
<GuidAttribute("6BF91B15-A25D-4a24-9ED8-EBED11DE8DA5")> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
Public Class Wire _
    Inherits HostObject
Visual C++
[GuidAttribute(L"6BF91B15-A25D-4a24-9ED8-EBED11DE8DA5")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
public ref class Wire : public HostObject

Remarks

Adding wiring to a project is optional. you can create circuits and maintain the information associated with them without adding wiring to the project.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::Wire

See Also

Wire Members
Autodesk.Revit.Elements Namespace