HermiteFace Class
See Also Members
CollapseAll image DropDown image

A cubic hermite spline face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("CC0AF75F-6778-4C89-995E-96906F6B6929")]
public class HermiteFace : Face
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("CC0AF75F-6778-4C89-995E-96906F6B6929")> _
Public Class HermiteFace _
    Inherits Face
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"CC0AF75F-6778-4C89-995E-96906F6B6929")]
public ref class HermiteFace : public Face

Remarks

Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit.Geometry..::GeometryObject
Autodesk.Revit.Geometry..::Face
Autodesk.Revit.Geometry..::HermiteFace

See Also

HermiteFace Members
Autodesk.Revit.Geometry Namespace