Element Class
See Also Members
CollapseAll image DropDown image

Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("11CA8950-8E66-4295-9A90-702202BD7704")]
public class Element : APIObject
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("11CA8950-8E66-4295-9A90-702202BD7704")> _
Public Class Element _
    Inherits APIObject
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"11CA8950-8E66-4295-9A90-702202BD7704")]
public ref class Element : public APIObject

Remarks

The Element object is base class for all elements that can persist inside the Autodesk Revit project database. Element objects can be retrieved from the Document.Element or Document.Elements properties.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit..::Symbol
Autodesk.Revit.Elements..::BaseArray
Autodesk.Revit.Elements..::BoundaryConditions
Autodesk.Revit.Elements..::View
Autodesk.Revit.Elements..::Instance
Autodesk.Revit.Elements..::HostObject
Autodesk.Revit.Elements..::LoadNature
Autodesk.Revit.Elements..::FamilyBase
Autodesk.Revit.Elements..::Material
Autodesk.Revit.Elements..::Level
Autodesk.Revit.Elements..::Grid
Autodesk.Revit.Elements..::LoadBase
Autodesk.Revit.Elements..::LoadCombination
Autodesk.Revit.Elements..::LoadCase
Autodesk.Revit.Elements..::LoadUsage
Autodesk.Revit.Elements..::Room
Autodesk.Revit.Elements..::Group
Autodesk.Revit.Elements..::Rebar
Autodesk.Revit.Elements..::AreaReinforcementCurve
Autodesk.Revit.Elements..::AreaReinforcement
Autodesk.Revit.Elements..::DesignOption
Autodesk.Revit.Elements..::Phase
Autodesk.Revit.Elements..::Dimension
Autodesk.Revit.Elements..::RoomTag
Autodesk.Revit.Elements..::ProjectInfo
Autodesk.Revit.Elements..::gbXMLParamElem
Autodesk.Revit.Elements..::ProjectUnit
Autodesk.Revit.Elements..::FillPattern
Autodesk.Revit.Elements..::ModelCurve
Autodesk.Revit.Elements..::SketchPlane
Autodesk.Revit.Elements..::ReferencePlane
Autodesk.Revit.Elements..::Opening
Autodesk.Revit.Elements..::DetailCurve
Autodesk.Revit.Elements..::BeamSystem
Autodesk.Revit.Elements..::IndependentTag
Autodesk.Revit.Elements..::TextElement
Autodesk.Revit.Elements..::GenericForm
Autodesk.Revit.Elements..::SketchBase
Autodesk.Revit.Elements..::PathReinforcement
Autodesk.Revit.Elements..::AnnotationSymbol
Autodesk.Revit.Elements..::LinePattern
Autodesk.Revit.Elements..::ViewSheetSet
Autodesk.Revit.Elements..::PrintSetting
Autodesk.Revit.Elements..::Area
Autodesk.Revit.Elements..::AreaTag
Autodesk.Revit.Elements..::ElectricalSystem
Autodesk.Revit.Elements..::InsulationType
Autodesk.Revit.Elements..::TemperatureRatingType
Autodesk.Revit.Elements..::WireMaterialType
Autodesk.Revit.Elements..::ConduitType
Autodesk.Revit.Elements..::Truss
Autodesk.Revit.Elements..::Space
Autodesk.Revit.Elements..::SpaceTag
Autodesk.Revit.Elements..::Zone
Autodesk.Revit.Elements..::Mullion
Autodesk.Revit.Elements..::Panel

See Also

Element Members
Autodesk.Revit Namespace