AreaTag Class
See Also Members
CollapseAll image DropDown image

Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("F86DFBD1-746D-431F-91EB-9EA240357660")]
public class AreaTag : Element
Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual)> _
<GuidAttribute("F86DFBD1-746D-431F-91EB-9EA240357660")> _
Public Class AreaTag _
    Inherits Element
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"F86DFBD1-746D-431F-91EB-9EA240357660")]
public ref class AreaTag : public Element

Remarks

The areaTag object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::Object
Autodesk.Revit..::APIObject
Autodesk.Revit..::Element
Autodesk.Revit.Elements..::AreaTag

See Also

AreaTag Members
Autodesk.Revit.Elements Namespace