NewRoomTag Method

Document..::NewRoomTag Method
CollapseAll image DropDown image

Creates a new RoomTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RoomTag NewRoomTag(
    Room room,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomTag ( _
    room As Room, _
    point As UV, _
    view As View _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag (
    Room^ room,
    UV^ point,
    View^ view
)

Parameters

room
Room
The Room which the tag refers.
point
UV
A 2D point that dictates the location on the level of the room.
view
View
The view where the tag will lie.

Return Value

If successful a RoomTag object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

See Also

Document Class
Autodesk.Revit.Creation Namespace