Face Methods

Syntax

C#
public class Face
Visual Basic (Declaration)
Public Class Face
Visual C++
public ref class Face

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

See Also

Face
Autodesk.Revit.Geometry Namespace