Creates a new geometric plane object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane NewPlane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    norm As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane (
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
XYZ
X vector of the plane coordinate system.
origin
XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

Remarks

The new plane is created with a normal vectors and an origin.

See Also

Application Class
Autodesk.Revit.Creation Namespace