LogicNotFilter Members
See Also Methods Properties Constructors Fields

Syntax

C#
public class LogicNotFilter
Visual Basic (Declaration)
Public Class LogicNotFilter
Visual C++
public ref class LogicNotFilter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LogicNotFilterLogicNotFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from Filter.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Protected Fields

 | Name | Description
Protected field | m_subFilter | Filter which is operand of Logic-NOT operation

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SubFilter | Get Filter which is operand of Logic-NOT operation

See Also

LogicNotFilter
Autodesk.Revit Namespace