YoungModulusX Property

MaterialGeneric..::YoungModulusX Property

Get or set the x component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double YoungModulusX{ get; set;}
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace