Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddListeningDimensionSegmentToBend(
    Parameter __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToBend ( _
    __unnamed000 As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToBend (
    Parameter^ __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)

Parameters

__unnamed000
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
iSegment0
Int32
Index of the first segment, which must be perpendicular to the constraint direction.
iSegment1
Int32
Index of the second segment.
iEnd1
Int32
End (0 or 1) of the second segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace