Rotate an element within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rotate(
    Element element,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    element As Element, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate (
    Element^ element,
    Line^ axis,
    double angle
)

Parameters

element
Element
The element that is to be rotated.
axis
Line
An unbounded line that represents the axis of rotation.
angle
Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Autodesk.Revit Namespace