Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName
)

Parameters

fileName
String
File name to be saved as.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

None.

See Also

Document Class
Autodesk.Revit Namespace