BasisX Property

XYZ..::BasisX Property

The basis of the X axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static XYZ BasisX{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisX As XYZ
Visual C++
public:
static property XYZ^ BasisX {
    XYZ^ get ();
}

Remarks

The basis of the X axis is the vector (1,0,0), the unit vector on the X axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace