Creates a fascia along the reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia (
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
FasciaType
The type of the fascia to create
references
ReferenceArray
An array of planar lines and arcs that represent the place where you want to place fascia.

Return Value

If successful a new fascia object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace