Profile Properties

Syntax

C#
public class Profile
Visual Basic (Declaration)
Public Class Profile
Visual C++
public ref class Profile

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Transformed | Transforms this profile and returns the result.

See Also

Profile
Autodesk.Revit.Geometry Namespace