Curve Properties

Syntax

C#
public class Curve
Visual Basic (Declaration)
Public Class Curve
Visual C++
public ref class Curve

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | EndParameter | The parameter of the start or the end point of the curve.
Public property | EndPoint | The start or the end point of this curve.
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Transformed | Applies the specified transformation to this curve and returns the result.

See Also

Curve
Autodesk.Revit.Geometry Namespace