Unbound Property

Line..::Unbound Property

Returns the unbounded line that passes through the specified point in the direction of the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public static Line Unbound[
    XYZ origin,
    XYZ vector
]{ get;}
Visual Basic (Declaration)
Public Shared ReadOnly Property Unbound ( _
    origin As XYZ, _
    vector As XYZ _
) As Line
Visual C++
public:
static property Line^ Unbound[XYZ^ origin, XYZ^ vector] {
    Line^ get (XYZ^ origin, XYZ^ vector);
}

Parameters

origin
XYZ
The start point of the line.
vector
XYZ
The direction vector.

Exceptions

Exception | Condition
System..::ArgumentException | Thrown when the specified vector is almost zero and cannot be normalized.

See Also

Line Class
Autodesk.Revit.Geometry Namespace