Exports the current view or a selection of views in DWFX-3D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFX3DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFX3DExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFX3DExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
Selection of 3D views to be exported. If nullptr or empty, only the active 3D view will be exported.
options
DWFX3DExportOptions
Various options applicable to the DWFX format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be 3D views in order for the Export to succeed.

See Also

Document Class
Autodesk.Revit Namespace