Open document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String, _
    postedErrors As PostedErrorArray _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile (
    String^ fileName,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
String
The file to be opened.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Remarks

This method corresponds to the File->Open... menu command.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

Exceptions

Exception | Condition
System..::ArgumentException | if 'fileName' is a null object or a empty string.
System..::InvalidOperationException | if can not open a file.

See Also

Application Class
Autodesk.Revit Namespace