Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName,
    bool changeDocumentFilename
)

Parameters

fileName
String
File name to be saved as.
changeDocumentFilename
Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

None.

See Also

Document Class
Autodesk.Revit Namespace