FilterType Property

FilterCriterion..::FilterType Property

Gets or sets the filter type of this criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CriteriaFilterType FilterType{ get; set;}
Visual Basic (Declaration)
Public Property FilterType As CriteriaFilterType
Visual C++
public:
property CriteriaFilterType FilterType {
    CriteriaFilterType get ();
    void set (CriteriaFilterType value);
}

Remarks

The filter type defines the relationship between the parameter of certain element and the parameter value which is specified by the property of ParameterValue.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace