Creates a floor within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the floor.
structural
Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace