Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData (
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
height
Double
The height of the wall.
offset
Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
Autodesk.Revit.Creation Namespace