PrintSetup Members
See Also Methods Properties Constructors

Syntax

C#
public class PrintSetup
Visual Basic (Declaration)
Public Class PrintSetup
Visual C++
public ref class PrintSetup

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintSetupPrintSetupNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Delete | Delete the current print setting.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current print setting to another print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | CurrentPrintSetting | Get or Set the current Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PaperSizes | Get all Print sizes of current Print.
Public property | PaperSources | Get all Print sources of current Print.

See Also

PrintSetup
Autodesk.Revit Namespace