BoundarySegment Members
See Also Methods Properties Constructors

Syntax

C#
public class BoundarySegment
Visual Basic (Declaration)
Public Class BoundarySegment
Visual C++
public ref class BoundarySegment

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | BoundarySegmentBoundarySegmentNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this room.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment
Autodesk.Revit.Rooms Namespace