MaterialConcrete Properties

Syntax

C#
public class MaterialConcrete
Visual Basic (Declaration)
Public Class MaterialConcrete
Visual C++
public ref class MaterialConcrete

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Behavior | Get or set the material behavior type of the concrete material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | ConcreteCompression | Get or set the concrete compression of the concrete material.
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DampingRatio | Get or set the damping ratio of the concrete material.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LightWeight | Get or set whether the concrete material is lightweight.
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
Public property | PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
Public property | PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
Public property | ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
Public property | ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
Public property | ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
Public property | ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the concrete material.
Public property | YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
Public property | YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
Public property | YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete
Autodesk.Revit.Elements Namespace