DefinitionGroups Methods

Syntax

C#
public class DefinitionGroups
Visual Basic (Declaration)
Public Class DefinitionGroups
Visual C++
public ref class DefinitionGroups

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Public method | Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionGroupsBase ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups
Autodesk.Revit.Parameters Namespace