ViewSheetSetting Methods

Syntax

C#
public class ViewSheetSetting
Visual Basic (Declaration)
Public Class ViewSheetSetting
Visual C++
public ref class ViewSheetSetting

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current view sheet set to another view sheet set with the specified name.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

ViewSheetSetting
Autodesk.Revit Namespace