Remove the fixed direction from a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetSegmentVariableDirection(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentVariableDirection ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentVariableDirection (
    int iSegment
)

Parameters

iSegment
Int32

Remarks

The segment's angle will be allowed to vary, with a range of 90 degrees. The line must have at least two constraints.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace