Creates a number of new Rooms.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room NewRoom(
    Room room,
    PlanCircuit circuit
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    room As Room, _
    circuit As PlanCircuit _
) As Room
Visual C++
public:
Room^ NewRoom (
    Room^ room,
    PlanCircuit^ circuit
)

Parameters

room
Room
The room which you want to locate in the circuit.
circuit
PlanCircuit
The circuit which you want to locate a room.

Return Value

If successful room should be returned, otherwise Nothing.

Remarks

If the circuit is not closed or there is a room already exist in the circuit, will throw a exception.

See Also

Document Class
Autodesk.Revit.Creation Namespace