Element Properties

Syntax

C#
public class Element
Visual Basic (Declaration)
Public Class Element
Visual C++
public ref class Element

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed. (Overrides GeometryObject ..::MaterialElement()().)
Public property | Objects | All geometric primitives contained in the element.

See Also

Element
Autodesk.Revit.Geometry Namespace