Creates a new instance of a LineLoad element within the project using the host Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoad NewLineLoad(
    Reference reference,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    reference As Reference, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad (
    Reference^ reference,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Reference
The Geometry reference to Beam's, Brace's, Column's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical lines.
forces
XYZArray
The applied 3d linear forces in the end points.
moments
XYZArray
The applied 3d linear moments in the end points.
uniform
Boolean
Set to True if you wish to create the uniform load.
projected
Boolean
Set to True if you wish to create the projected load.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
LineLoadType
plane
SketchPlane

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace