MEPSpaceConstruction Members
See Also Methods Constructors Properties

Syntax

C#
public class MEPSpaceConstruction
Visual Basic (Declaration)
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MEPSpaceConstructionMEPSpaceConstructionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | DeleteConstruction | Remove a existent construction from Space constructions.
Public method | DuplicateConstruction | Create a new construction for Space constructions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewConstruction | Create a new construction for Space constructions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
Public property | SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction
Autodesk.Revit Namespace