SlabShapeEditor Property

RoofBase..::SlabShapeEditor Property

Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabShapeEditor SlabShapeEditor{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Roofs cannot be attached to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, the ShapeEditor will be nullptr.

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace