Creates a gutter along the reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    reference As Reference _
) As Gutter
Visual C++
public:
Gutter^ NewGutter (
    GutterType^ GutterType,
    Reference^ reference
)

Parameters

GutterType
GutterType
The type of the gutter to create
reference
Reference
A planar line or arc that represent the place where you want to place gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace