Truss Methods

Syntax

C#
public class Truss
Visual Basic (Declaration)
Public Class Truss
Visual C++
public ref class Truss

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
Public method | DetachTopChord | Detach the truss's top from a specified element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Truss
Autodesk.Revit.Elements Namespace