Creates a non rectangular profile wall within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace