JoinType Enumeration

The type of join at the end of an element. The join type affects only geometric treatment, i.e. cleaning of the end, and not join behavior.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("E36E9F08-7163-44cd-9E08-1535E169B491")]
public enum JoinType
Visual Basic (Declaration)
<GuidAttribute("E36E9F08-7163-44cd-9E08-1535E169B491")> _
Public Enumeration JoinType
Visual C++
[GuidAttribute(L"E36E9F08-7163-44cd-9E08-1535E169B491")]
public enum class JoinType

Members

Member name | Description
None | No join type
Extension | Extension Join
SquareOff | Square-off Join
Miter | Miter Join
Abut | Abut Join

See Also

Autodesk.Revit Namespace