Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve
)

Parameters

curve
Curve
The specified curve to intersect with this face.

Return Value

The type of the intersection.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the argument curve is null.
System..::InvalidOperationException | Thrown when the intersection calculation fails.

See Also

Face Class
Autodesk.Revit.Geometry Namespace