Name Property

GenericForm..::Name Property

Get and Set the Name property

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override string Name{ set;}
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace