Rebar Members
See Also Methods Properties Constructors

Syntax

C#
public class Rebar
Visual Basic (Declaration)
Public Class Rebar
Visual C++
public ref class Rebar

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarRebarNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ScaleToBox | Move and resize the bar to fit within a specified box.
Public method | SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | ArrayLength | For Rebar with an array layout, return the length of the distribution path.
Public property | BarType | Return the type of the rebar.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Curves | The centerline of the Rebar.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Host | The element that contains the rebar.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | RebarShape | Get/Set the RebarShape associated with the Rebar.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Rebar
Autodesk.Revit.Elements Namespace