Materials Members
See Also Methods Properties Constructors

Syntax

C#
public class Materials
Visual Basic (Declaration)
Public Class Materials
Visual C++
public ref class Materials

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MaterialsMaterialsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddConcrete | Add a concrete material with the given name .
Public method | AddGeneric | Add a generic material with the given name .
Public method | AddOther | Add an other material with the given name .
Public method | AddSteel | Add a steel material with the given name .
Public method | AddWood | Add a wood material with the given name .
Public method | Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Public method | Contains | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified material from the set. (Inherited from MaterialSet.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified material into the set. (Inherited from MaterialSet.)
Public method | Remove | Remove the material with the speicified name .
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides MaterialSet ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from MaterialSet.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials
Autodesk.Revit Namespace