Creates a new Room.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room NewRoom(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    level As Level, _
    point As UV _
) As Room
Visual C++
public:
Room^ NewRoom (
    Level^ level,
    UV^ point
)

Parameters

level
Level
The level on which the room is to exist.
point
UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Room object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace