StorageType Property

Parameter..::StorageType Property

Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StorageType StorageType{ get;}
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

Parameter Class
Autodesk.Revit Namespace