Creates a new TextNote object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote (
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

pView
View
Current DBView
origin
XYZ
origin of the TextNote
baseVec
XYZ
baseVec parameter of the TextNote.
upVec
XYZ
upVec parameter of the TextNote.
lineWidth
Double
line width of the out rectangle.
textAlign
TextAlignFlags
align style.
leaderType
TextNoteLeaderTypes
leader type as straight or arc.
leaderStyle
TextNoteLeaderStyles
leaderEnd
XYZ
end point of the leader.
leaderElbow
XYZ
elbow point of the leader.
strText
String
text.

Return Value

If successful, a TextNote object is returned.

Remarks

This method forms a TextNote object.

See Also

Document Class
Autodesk.Revit.Creation Namespace