Creates a new MEP Electrical System element from an unused Connector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    Connector connector,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    connector As Connector, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem (
    Connector^ connector,
    ElectricalSystemType elecSysType
)

Parameters

connector
Connector
The Connector to create this Electrical System.
elecSysType
ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
System..::InvalidOperationException | Thrown when the electrical system cannot be created by these input connector.

See Also

Document Class
Autodesk.Revit.Creation Namespace