Selection Members
See Also Methods Properties Constructors

Syntax

C#
public class Selection
Visual Basic (Declaration)
Public Class Selection
Visual C++
public ref class Selection

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SelectionSelectionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickOne | Allows the user to select one element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WindowSelect | Allows the user to select elements by a rectangle.

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Elements | The elements that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | StatusbarTip | The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection
Autodesk.Revit Namespace