Creates a set of new spaces and insert to a existent schedule with the phase you assigned.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewSpaces(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces (
    Phase^ phase,
    int count
)

Parameters

phase
Phase
The phase on which the space is to exist.
count
Int32

Return Value

If successful spaces with NO Location should be returned, otherwise Nothing. If your action is in the certain Design Option, the spaces will in the certain Option.

See Also

Document Class
Autodesk.Revit.Creation Namespace