Creates a floor within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor (
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
FloorType
A floor type to be used by the new floor instead of the default type.
level
Level
The level on which the floor is to be placed.
structural
Boolean
If set, specifies that the floor is structural in nature.

Return Value

if successful, a new floor object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise a exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace