Retrieves the specified element from the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element[
    string
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
     As String _
) As Element
Visual C++
public:
property Element^ Element[String^ ] {
    Element^ get (String^ );
}

Parameters

String

Remarks

Returns the element corresponding to the unique id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the uniqueId does not exist then an empty reference will be returned.

See Also

Document Class
Autodesk.Revit Namespace