DWF3DExportOptions Members
See Also Fields Methods Constructors

Syntax

C#
public class DWF3DExportOptions
Visual Basic (Declaration)
Public Class DWF3DExportOptions
Visual C++
public ref class DWF3DExportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWF3DExportOptionsDWF3DExportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWF3DExportOptions
Autodesk.Revit Namespace