Move several elements within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    ElementSet elements,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    elements As ElementSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    ElementSet^ elements,
    XYZ^ translationVec
)

Parameters

elements
ElementSet
A set of element which are to be moved.
translationVec
XYZ
The vector by which the elements are to be moved.

Return Value

If the elements are moved successfully then the method returns True, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved, for example: if the elements are floors, the openings within those floors will also be moved.

See Also

Document Class
Autodesk.Revit Namespace