IsPerspective Property

View3D..::IsPerspective Property

Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsPerspective{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsPerspective As Boolean
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

Remarks

If this is false, the view is orthographic - the view direction is constant. In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The view direction property becomes less meaningful - it only describes the general orientation of the camera.

See Also

View3D Class
Autodesk.Revit.Elements Namespace