Calculates the intersection of the specified curve with this face and returns the intersection results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    ref IntersectionResultArray results
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    ByRef results As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve,
    IntersectionResultArray^% results
)

Parameters

curve
Curve
The specified curve to intersect with this face.
results
IntersectionResultArray %
Provides more information about the intersection.

Return Value

The type of the intersection.

Remarks

The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members: XYZPoint is the evaluated intersection point; UVPoint is the intersection parameters on the face; Parameter is the raw intersection parameter on the curve; EdgeObject is the edge if the intersection happens to be near an edge of face; EdgeParameter is the parameter of the nearest point on the edge.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the curve is null.
System..::InvalidOperationException | Thrown when the intersection calculation fails.

See Also

Face Class
Autodesk.Revit.Geometry Namespace