Line Members
See Also Methods Properties Constructors

Syntax

C#
public class Line
Visual Basic (Declaration)
Public Class Line
Visual C++
public ref class Line

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LineLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
 | Bound | Returns the bounded line between the specified points.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
 | Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.

See Also

Line
Autodesk.Revit.Geometry Namespace