Append a new menu after the last sub menu of current menu, basic menu, popup menu and separator menu are allowed here.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Append(
    MenuItem.MenuItem..::MenuType menuType,
    string menuName,
    string assemblyName,
    string className
)
Visual Basic (Declaration)
Public Function Append ( _
    menuType As MenuItem..::MenuType, _
    menuName As String, _
    assemblyName As String, _
    className As String _
) As MenuItem
Visual C++
public:
MenuItem^ Append (
    MenuItem..::MenuType menuType,
    String^ menuName,
    String^ assemblyName,
    String^ className
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.
menuName
String
Text which will be displayed on the created menu.
assemblyName
String
Assembly in which the corresponding command lives.
className
String
Class which implements corresponding command.

Return Value

That new appended menu item will be returned if success, else null.

Remarks

Menu will be added as the last menu of current pop up menu. If menuName is null, a default name will be given. And if assembly name and class name are null and it is a basic menu, then they should be assigned later via corresponding properties.

See Also

MenuItem Class
Autodesk.Revit Namespace