LightingDevice Members
See Also Methods Properties Constructors

Syntax

C#
public class LightingDevice
Visual Basic (Declaration)
Public Class LightingDevice
Visual C++
public ref class LightingDevice

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LightingDeviceLightingDeviceNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice
Autodesk.Revit.MEP Namespace