Distance Method

XYZ..::Distance Method

Returns the distance from this point to the specified point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Distance(
    XYZ source
)
Visual Basic (Declaration)
Public Function Distance ( _
    source As XYZ _
) As Double
Visual C++
public:
double Distance (
    XYZ^ source
)

Parameters

source
XYZ
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace