Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
position
Line
A line on the face defining where the symbol is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
Autodesk.Revit.Creation Namespace