Categories Members
See Also Methods Properties Constructors

Syntax

C#
public class Categories
Visual Basic (Declaration)
Public Class Categories
Visual C++
public ref class Categories

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CategoriesCategoriesNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Public method | Contains | Tests for the existence of a category with that name within the map. (Inherited from CategoryNameMap.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map. (Inherited from CategoryNameMap.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from CategoryNameMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides CategoryNameMap ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from CategoryNameMap.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from CategoryNameMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Size | Returns the number of categories that are in the map. (Inherited from CategoryNameMap.)

See Also

Categories
Autodesk.Revit Namespace