Scale Property

Transform..::Scale Property

The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Scale{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
}

Remarks

When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when this transformation is not conformal and the scale is undefined.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace