Arc Properties

Syntax

C#
public class Arc
Visual Basic (Declaration)
Public Class Arc
Visual C++
public ref class Arc

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the arc.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)

See Also

Arc
Autodesk.Revit.Geometry Namespace