FormatOptions Members
See Also Methods Properties Constructors

Syntax

C#
public class FormatOptions
Visual Basic (Declaration)
Public Class FormatOptions
Visual C++
public ref class FormatOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FormatOptionsFormatOptionsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Group | Retrieves the Group of Units Type that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieves the Name of Units Type that are currently selected.
Public property | Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Public property | Units | Retrieves the Units Type that are currently selected.
Public property | Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions
Autodesk.Revit Namespace