CADImportOptions Fields

Syntax

C#
public abstract class CADImportOptions
Visual Basic (Declaration)
Public MustInherit Class CADImportOptions
Visual C++
public ref class CADImportOptions abstract

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import.
Public field | CustomScale | Scaling the import.
Public field | OrientToView | Place the import at the same orientation as the current view.
Public field | Placement | Where to place the import.
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Public field | Unit | The unit of measure for imported geometry.
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions
Autodesk.Revit Namespace