SelElementSet Methods

Syntax

C#
public class SelElementSet
Visual Basic (Declaration)
Public Class SelElementSet
Visual C++
public ref class SelElementSet

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Add | Add an element into the selected element set.
Public method | Clear | Clear the selected element set. (Overrides ElementSet ..:: Clear()().)
Public method | Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Remove an element from the selected element set. (Overrides ElementSet ..:: Erase(Element).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Public method | Remove | Remove an element from the selected element set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides ElementSet ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from ElementSet.)

See Also

SelElementSet
Autodesk.Revit Namespace