MessageBoxData Members
See Also Methods Properties Constructors

Syntax

C#
public class MessageBoxData
Visual Basic (Declaration)
Public Class MessageBoxData
Visual C++
public ref class MessageBoxData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MessageBoxDataMessageBoxDataNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | DialogType | An integer that describes the standard windows type of the dialog box.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData
Autodesk.Revit.Events Namespace