Settings Members
See Also Methods Properties Constructors

Syntax

C#
public class Settings
Visual Basic (Declaration)
Public Class Settings
Visual C++
public ref class Settings

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | SettingsSettingsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Public property | Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
Public property | VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings
Autodesk.Revit Namespace