Item Property

XYZArray..::Item Property

Gets or sets a XYZ coordinate at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual XYZ Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As XYZ
Visual C++
public:
virtual property XYZ^ Item[int index] {
    XYZ^ get (int index);
    void set (int index, XYZ^ value);
}

Parameters

index
Int32
The index of the XYZ coordinate to be set or retrieved.

Return Value

Returns the XYZ coordinate at the specified index.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace