Move an element within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Move(
    Element element,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    element As Element, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move (
    Element^ element,
    XYZ^ translationVec
)

Parameters

element
Element
The element that is to be moved.
translationVec
XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is level, all the elements on that level will also be moved.

See Also

Document Class
Autodesk.Revit Namespace