LoadUsageArray Methods

Syntax

C#
public class LoadUsageArray
Visual Basic (Declaration)
Public Class LoadUsageArray
Visual C++
public ref class LoadUsageArray

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Append | Add the load usage to the end of the array.
Public method | Clear | Removes every load usage from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load usage into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

LoadUsageArray
Autodesk.Revit.Elements Namespace