MaterialWood Properties

Syntax

C#
public class MaterialWood
Visual Basic (Declaration)
Public Class MaterialWood
Visual C++
public ref class MaterialWood

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Bending | Get or set the bending of the wood material.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material. (Inherited from Material.)
Public property | CompressionParallel | Get or set the compression parallel to grain of the wood material.
Public property | CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
Public property | CutPattern | The cut pattern of the material. (Inherited from Material.)
Public property | CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow. (Inherited from Material.)
Public property | Grade | Get or set the grade of the wood material.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | PoissonModulus | Get or set the Poisson modulus of the wood material.
Public property | RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Public property | ShearModulus | Get or set the shear modulus of the wood material.
Public property | ShearParallel | Get or set the shear parallel to grain of the wood material.
Public property | ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Public property | Shininess | The shininess of the material. (Inherited from Material.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Smoothness | The smoothness of the material. (Inherited from Material.)
Public property | Species | Get or set the species of the wood material.
Public property | SurfacePattern | The surface pattern of the material. (Inherited from Material.)
Public property | SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Public property | ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Public property | Transparency | The transparency of the material. (Inherited from Material.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UnitWeight | Get or set the unit weight of the wood material.
Public property | YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood
Autodesk.Revit.Elements Namespace