SweptProfile Property

AnalyticalModelProfile..::SweptProfile Property

Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Profile SweptProfile{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SweptProfile As Profile
Visual C++
public:
property Profile^ SweptProfile {
    Profile^ get ();
}

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace