DWGExportOptions Fields

Syntax

C#
public class DWGExportOptions
Visual Basic (Declaration)
Public Class DWGExportOptions
Visual C++
public ref class DWGExportOptions

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from CADExportOptions.)
Public field | ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
Public field | FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
Public field | ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from CADExportOptions.)
Public field | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
Public field | LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
Public field | MergedViews | Whether to merge all views in one file (via XRefs).
Public field | PropOverrides | How to export overriden object styles. (Inherited from ACADExportOptions.)
Public field | SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
Public field | TargetUnit | Type of units in the target CAD format. (Inherited from CADExportOptions.)

See Also

DWGExportOptions
Autodesk.Revit Namespace