Close the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Close(
    bool saveModified,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close (
    bool saveModified,
    PostedErrorArray^ postedErrors
)

Parameters

saveModified
Boolean
Indicates if the current document should be saved before close operation.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if bSaveBeforeClose is set to true, but Save returns false. Otherwise, returns true.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return false.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace