Array one or several elements within the project by a specified number of degree.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    Element^ element,
    int number,
    bool moveToLast,
    double angle
)

Parameters

element
Element
The element that is to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace