Add a new instance of a Family into the Autodesk Revit project, using a curve, type/symbol and reference level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance (
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Curve
The curve where the instance is based.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to insert one family instance into another element along the geometry of a curve. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the project before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail. All levels within the project can be found by iterating over the entire project and searching for objects of type Autodesk.Revit.Elements.Level.

See Also

Document Class
Autodesk.Revit.Creation Namespace