UV Members
See Also Methods Constructors Properties

Syntax

C#
public class UV
Visual Basic (Declaration)
Public Class UV
Visual C++
public ref class UV

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | UVUVNew | Overloaded.

Public Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
 | Addition | Adds the two specified 2-D vectors and returns the result.
Public method | AlmostEqual | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | Angle | Returns the angle between this vector and the specified vector.
Public method | Cross | The cross product of this 2-D vector and the specified 2-D vector.
Public method | Distance | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
 | Division | Divides the specified 2-D vector by the specified value.
Public method | Dot | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
 | Multiply | Overloaded.
Public method | Negate | Negates this 2-D vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
 | Subtraction | Subtracts the two specified 2-D vectors and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnaryNegation | Negates this 2-D vector and returns the result.

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
 | Basis | Indexed access for Basis.
 | BasisU | The basic of the U axis.
 | BasisV | The basic of the V axis.
Public property | IsNormalized | The boolean value that indicates whether this 2-D vector is a normalized vector.
Public property | IsZero | The boolean value that indicates whether this 2-D vector is a zero vector.
Public property | Item | Indexed access to coordinates.
Public property | Length | The length of this 2-D vector.
Public property | Normalized | This 2-D vector, normalized.
Public property | U | The first coordinate.
Public property | V | The second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.

See Also

UV
Autodesk.Revit.Geometry Namespace