Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Face
A face of a geometry object.
location
XYZ
Point on the face where the instance is to be placed.
referenceDirection
XYZ
A vector that defines the direction of the family instance.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
Autodesk.Revit.Creation Namespace