CurtainGridLine Methods

Syntax

C#
public class CurtainGridLine
Visual Basic (Declaration)
Public Class CurtainGridLine
Visual C++
public ref class CurtainGridLine

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

CurtainGridLine
Autodesk.Revit.Elements Namespace