RebarHostData Members
See Also Methods Properties Constructors

Syntax

C#
public class RebarHostData
Visual Basic (Declaration)
Public Class RebarHostData
Visual C++
public ref class RebarHostData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RebarHostDataRebarHostDataNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCoverTypeForReference | Checks whether the reference has an associated cover.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | CoverType | Gets the RebarCoverType associated with a face of the element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData
Autodesk.Revit.Elements Namespace