Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData (
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
wallType
WallType
A wall type to be used by the new wall instead of the default type.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.
normal
XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

Application Class
Autodesk.Revit.Creation Namespace