Delete an element from the project given the id of that element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    ref ElementId id
)
Visual Basic (Declaration)
Public Function Delete ( _
    ByRef id As ElementId _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    ElementId% id
)

Parameters

id
ElementId %
The ElementId for the element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace