Creates a new TextNote object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote (
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

pView
View
Current DBView
origin
XYZ
origin of the TextNote
baseVec
XYZ
baseVec parameter of the TextNote.
upVec
XYZ
upVec parameter of the TextNote.
lineWidth
Double
line width of the out rectangle.
textAlign
TextAlignFlags
align style.
strText
String
text.

Return Value

If successful, a TextNote object is returned.

Remarks

This method forms a TextNote object.

See Also

Document Class
Autodesk.Revit.Creation Namespace