Visible Property

ExternalDefinition..::Visible Property

Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Visible{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get ();
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace