NewWallUsageFilter Method

Filter..::NewWallUsageFilter Method

Creates a new WallUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallUsageFilter NewWallUsageFilter(
    WallUsage wallUsage
)
Visual Basic (Declaration)
Public Function NewWallUsageFilter ( _
    wallUsage As WallUsage _
) As WallUsageFilter
Visual C++
public:
WallUsageFilter^ NewWallUsageFilter (
    WallUsage wallUsage
)

Parameters

wallUsage
WallUsage
Filter elements by the wall usage.

Return Value

Returns a new wall usage filter object with given wall usage.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace