Creates a new Opening Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    bottomLevel As Level, _
    topLevel As Level, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)

Parameters

bottomLevel
Level
bottom level
topLevel
Level
top level
profile
CurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

See Also

Document Class
Autodesk.Revit.Creation Namespace