Asset Properties

Syntax

C#
public class Asset
Visual Basic (Declaration)
Public Class Asset
Visual C++
public ref class Asset

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | AssetType | Get the object's AssetPropertyType
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | LibraryName | Get the library name
Public property | Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Public property | Size | Get the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Public property | Title | Get the asset's title
Public property | Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset
Autodesk.Revit.Utility Namespace