Creates a new category filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryFilter NewCategoryFilter(
    BuiltInCategory builtInCat
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    builtInCat As BuiltInCategory _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter (
    BuiltInCategory builtInCat
)

Parameters

builtInCat
BuiltInCategory
Filter elements by the built-in category.

Return Value

Returns a new category filter object with given built-in category.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace