Specify a default-radius bend.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)
Visual Basic (Declaration)
Public Sub AddBendDefaultRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle _
)
Visual C++
public:
void AddBendDefaultRadius (
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)

Parameters

iSegmentFollowingBend
Int32
turn
Int32
Specify 1 for a left turn, -1 for a right turn.
angle
RebarShapeBendAngle

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace