Curve Property

AreaLoad..::Curve Property

Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve Curve[
    int loopIndex,
    int curveIndex
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    loopIndex As Integer, _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int loopIndex, int curveIndex] {
    Curve^ get (int loopIndex, int curveIndex);
}

Parameters

loopIndex
Int32
The index of the geometric loop.
curveIndex
Int32
The index curve within the loop.

Remarks

The loop index should be between 0 and less than NumLoops. The curve index should be between 0 and less than NumCurves(loopIndex).

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace