SectionBox Property

View3D..::SectionBox Property

The section box of the 3D view cuts the model by its bounds.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundingBoxXYZ SectionBox{ get; set;}
Visual Basic (Declaration)
Public Property SectionBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ SectionBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

To turn off section box, pass in null or a disabled box. Individual bound enabled flags are currently ignored.

See Also

View3D Class
Autodesk.Revit.Elements Namespace