Instance Members
See Also Methods Properties Constructors

Syntax

C#
public class Instance
Visual Basic (Declaration)
Public Class Instance
Visual C++
public ref class Instance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InstanceInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Transformed | Transforms this instance and returns the result.

See Also

Instance
Autodesk.Revit.Geometry Namespace