Print this view with default print setting and specialized view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print (
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

viewTemplate
View
The view template which apply to the view.
useCurrentPrintSettings
Boolean
If true, print the view with the current print setting ,otherwise with the print setting of the document.

Remarks

If the view can not be printed successfully then an exception will be thrown out.

See Also

View Class
Autodesk.Revit.Elements Namespace