ParameterStorage Methods

Syntax

C#
public class ParameterStorage
Visual Basic (Declaration)
Public Class ParameterStorage
Visual C++
public ref class ParameterStorage

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the ElementId stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

ParameterStorage
Autodesk.Revit Namespace