Reset Method

SetIterator..::Reset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[ComVisibleAttribute(false)]
public virtual void Reset()
Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub Reset
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void Reset ()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace