Blend Properties

Syntax

C#
public class Blend
Visual Basic (Declaration)
Public Class Blend
Visual C++
public ref class Blend

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FirstEnd | Returns the First End of the Blend.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SecondEnd | Returns the Second End of the Blend.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TopSketch | Returns the Top Sketch of the Blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Blend
Autodesk.Revit.Elements Namespace