Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem (
    CurveArray^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
CurveArray
The profile of the BeamSystem.
sketchPlane
SketchPlane
The work plane of the BeamSystem.
direction
XYZ
The direction is the direction of the BeamSystem.
is3d
Boolean
If the BeamSystem is 3D, the inputted sketchPlane must be a level, or an exception will be thrown out.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
Autodesk.Revit.Creation Namespace