ScaleBasis Method

Transform..::ScaleBasis Method

Scales the basis vectors of this transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ScaleBasis(
    double scale
)
Visual Basic (Declaration)
Public Function ScaleBasis ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasis (
    double scale
)

Parameters

scale
Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace