Period Property

Face..::Period Property

The period of this face in the specified parametric direction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Period[
    int paramIdx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Period ( _
    paramIdx As Integer _
) As Double
Visual C++
public:
property double Period[int paramIdx] {
    double get (int paramIdx);
}

Parameters

paramIdx
Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

The real number equal to the period of this face.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.
System..::InvalidOperationException | Thrown when this face is not cyclic in the specified direction.

See Also

Face Class
Autodesk.Revit.Geometry Namespace