Print a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View _
)
Visual C++
public:
void Print (
    ViewSet^ views,
    View^ viewTemplate
)

Parameters

views
ViewSet
The set of views which need to be printed.
viewTemplate
View
The view template which apply to the set of views.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown out.

See Also

Document Class
Autodesk.Revit Namespace