Key Property

MapIterator..::Key Property

Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Object Key{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As Object
Visual C++
public:
virtual property Object^ Key {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace