BuildingType Enumeration

An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("917B2B7A-2A38-48ab-AE5E-037C01CA5891")]
public enum BuildingType
Visual Basic (Declaration)
<GuidAttribute("917B2B7A-2A38-48ab-AE5E-037C01CA5891")> _
Public Enumeration BuildingType
Visual C++
[GuidAttribute(L"917B2B7A-2A38-48ab-AE5E-037C01CA5891")]
public enum class BuildingType

Members

Member name | Description
kWorkshop | Building Type is Workshop.
kWarehouse | Building Type is Warehouse.
kTransportation | Building Type is Transportation.
kTownHall | Building Type is TownHall.
kSportsArena | Building Type is SportsArena.
kSchoolOrUniversity | Building Type is SchoolOrUniversity.
kRetail | Building Type is Retail.
kReligiousBuilding | Building Type is ReligiousBuilding.
kPostOffice | Building Type is PostOffice.
kPoliceStation | Building Type is PoliceStation.
kPerformingArtsTheater | Building Type is PerformingArtsTheater.
kPenitentiary | Building Type is Penitentiary.
kParkingGarage | Building Type is ParkingGarage.
kOffice | Building Type is Office.
kMuseum | Building Type is Museum.
kMultiFamily | Building Type is MultiFamily.
kMotionPictureTheatre | Building Type is MotionPictureTheatre.
kMotel | Building Type is Motel.
kManufacturing | Building Type is Manufacturing.
kLibrary | Building Type is Library.
kHotel | Building Type is Hotel.
kHospitalOrHealthcare | Building Type is HospitalOrHealthcare.
kGymnasium | Building Type is Gymnasium.
kFireStation | Building Type is FireStation.
kExerciseCenter | Building Type is ExerciseCenter.
kDormitory | Building Type is Dormitory.
kDiningFamily | Building Type is DiningFamily.
kDiningCafeteriaFastFood | Building Type is DiningCafeteriaFastFood.
kDiningBarLoungeOrLeisure | Building Type is DiningBarLoungeOrLeisure.
kCourthouse | Building Type is Courthouse.
kConventionCenter | Building Type is ConventionCenter.
kAutomotiveFacility | Building Type is AutomotiveFacility.
kNoOfBuildingTypes | Building Type is NoOfBuildingTypes.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also

Autodesk.Revit.Parameters Namespace