SuperComponent Property

FamilyInstance..::SuperComponent Property

Property to get the super componet of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element SuperComponent{ get;}
Visual Basic (Declaration)
Public ReadOnly Property SuperComponent As Element
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When current familyinstance has no super component, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace