Moment Property

LineLoad..::Moment Property

Returns the three dimensional moment applied to one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Moment[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Moment ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Moment[int index] {
    XYZ^ get (int index);
}

Parameters

index
Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace