Provides access to all elements of specified type within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIterator Elements[
    Type
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
     As Type _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Type^ ] {
    ElementIterator^ get (Type^ );
}

Parameters

Type

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements of specified type. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

See Also

Document Class
Autodesk.Revit Namespace