SurfacePattern Property

Material..::SurfacePattern Property

The surface pattern of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FillPattern SurfacePattern{ get; set;}
Visual Basic (Declaration)
Public Property SurfacePattern As FillPattern
Visual C++
public:
property FillPattern^ SurfacePattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The surface pattern element, or null, if the material does not have an associated surface pattern.

See Also

Material Class
Autodesk.Revit.Elements Namespace