Zone Members
See Also Methods Properties Constructors

Syntax

C#
public class Zone
Visual Basic (Declaration)
Public Class Zone
Visual C++
public ref class Zone

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ZoneZoneNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddSpaces | Add a set of existing spaces to Zone element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveSpaces | Remove a set of existing spaces to the current Zone element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | Area | Get the Area of the Zone.
Public property | Boundary | Returns the boundary of the Zone.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
Public property | CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
Public property | CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
Public property | DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GrossArea | Get the Gross Area of the Zone.
Public property | GrossVolume | Get the Gross Volume of the Zone.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
Public property | HeatingSetPoint | Get or set the Heating Set Point of the Zone.
Public property | HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultZone | Reports whether this zone is default or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Zone. (Overrides Element ..:: Name.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
Public property | OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
Public property | OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Zone.
Public property | Phase | Get the Phase of the Zone.
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ServiceType | Get or set the Service Type of the Zone.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | Spaces | Get the Spaces of the Zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Volume | Get the Volume of the Zone.

See Also

Zone
Autodesk.Revit.Elements Namespace