Definition Members
See Also Methods Properties Constructors

Syntax

C#
public abstract class Definition
Visual Basic (Declaration)
Public MustInherit Class Definition
Visual C++
public ref class Definition abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DefinitionDefinitionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter.
Public property | ParameterGroup | Returns the group ID of the parameter definition.
Public property | ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition
Autodesk.Revit.Parameters Namespace