Materials Properties

Syntax

C#
public class Materials
Visual Basic (Declaration)
Public Class Materials
Visual C++
public ref class Materials

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Overloaded.
Public property | Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials
Autodesk.Revit Namespace