XYZ Members
See Also Methods Constructors Properties

Syntax

C#
public class XYZ
Visual Basic (Declaration)
Public Class XYZ
Visual C++
public ref class XYZ

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | XYZXYZNew | Overloaded.

Public Methods

 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
 | Addition | Adds the two specified vectors and returns the result.
Public method | AlmostEqual | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | Angle | Returns the angle between this vector and the specified vector.
Public method | AngleAround | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | Cross | The cross product of this vector and the specified vector.
Public method | Distance | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
 | Division | Divides the specified vector by the specified value.
Public method | Dot | The dot product of this vector and the specified vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
 | Multiply | Overloaded.
Public method | Negate | Negates this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
 | Subtraction | Subtracts the two specified vectors and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.
 | UnaryNegation | Negates the specified vector and returns the result.

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
 | Basis | Indexed access for Basis.
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
Public property | IsZero | The boolean value that indicates whether this vector is a zero vector.
Public property | Item | Indexed access to coordinates.
Public property | Length | The length of this vector.
Public property | Normalized | This vector, normalized.
Public property | X | The first coordinate.
Public property | Y | The second coordinate.
Public property | Z | The third coordinate.
 | Zero | The coordinate origin or zero vector.

See Also

XYZ
Autodesk.Revit.Geometry Namespace