PrintParameters Members
See Also Methods Properties Constructors

Syntax

C#
public class PrintParameters
Visual Basic (Declaration)
Public Class PrintParameters
Visual C++
public ref class PrintParameters

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PrintParametersPrintParametersNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | ColorDepth | Retrieve the Color Depth Type of current print setting.
Public property | HiddenLineViews | Retrieve the Hidden Line Views of current print setting.
Public property | HideCropBoundaries | Returns if the Options of current print parameter is Hide Crop Boundaries.
Public property | HideReforWorkPlanes | Returns if the Options of current print parameter is View Links in Blue.
Public property | HideScopeBoxes | Returns if the Options of current print parameter is Hide Scope Boxes.
Public property | HideUnreferencedViewTages | Returns if the Options of current print parameter is Hide Unreferenced View Tages.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MarginType | Retrieve the Print Margin Type of current print setting.
Public property | PageOrientation | Retrieves the Page Orientation of the Print Setting.
Public property | PaperPlacement | Retrieve the Paper Placement Type of current print setting.
Public property | PaperSize | Retrieves the Page size of the Print Setting.
Public property | PaperSource | Retrieves the Page source of the Print Setting.
Public property | RasterQuality | Retrieve the Raster Quality Type of current print setting.
Public property | UserDefinedMarginX | Retrieve the User defined x value of offset from corner of current print setting.
Public property | UserDefinedMarginY | Retrieve the User defined y value of offset from corner of current print setting.
Public property | ViewLinksinBlue | Returns if the current print parameter is View Links in Blue.
Public property | Zoom | Retrieve the Zoom value of current print setting.
Public property | ZoomType | Retrieve the Zoom Type of current print setting.

See Also

PrintParameters
Autodesk.Revit Namespace