Begins a transaction for the following operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool BeginTransaction(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function BeginTransaction ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool BeginTransaction (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

true is returned if the transaction is started successfully, otherwise false will be returned.

Remarks

To begin a new transaction before a series of operation can ensure all the following operations will be done in same transaction, which can avoid inconsistency.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace