ComputeNormalizedParameter Method

Curve..::ComputeNormalizedParameter Method

Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ComputeNormalizedParameter(
    double rawParameter
)
Visual Basic (Declaration)
Public Function ComputeNormalizedParameter ( _
    rawParameter As Double _
) As Double
Visual C++
public:
double ComputeNormalizedParameter (
    double rawParameter
)

Parameters

rawParameter
Double
The raw parameter.

Return Value

The real number equal to the normalized curve parameter.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when rawParameter is infinite.
System..::InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace