Print User-assigned view with the current Settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SubmitPrint(
    View view
)
Visual Basic (Declaration)
Public Function SubmitPrint ( _
    view As View _
) As Boolean
Visual C++
public:
bool SubmitPrint (
    View^ view
)

Parameters

view
View
The User-assigned view.

Remarks

PrintManager will print the user-assigned view with the current settings. When the print range is visible and the view is not the active view, the print result is whole view. It means the visible option will be meaningless in this context.

See Also

PrintManager Class
Autodesk.Revit Namespace