Distance Method

Curve..::Distance Method

Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Distance(
    XYZ point
)
Visual Basic (Declaration)
Public Function Distance ( _
    point As XYZ _
) As Double
Visual C++
public:
double Distance (
    XYZ^ point
)

Parameters

point
XYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace