CategoryNameMap Methods

Syntax

C#
public class CategoryNameMap
Visual Basic (Declaration)
Public Class CategoryNameMap
Visual C++
public ref class CategoryNameMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

See Also

CategoryNameMap
Autodesk.Revit Namespace