TemperatureRatingType Methods

Syntax

C#
public class TemperatureRatingType
Visual Basic (Declaration)
Public Class TemperatureRatingType
Visual C++
public ref class TemperatureRatingType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
Public method | AddInsulationType | Add a new kind of insulation type into this temperature rating type.
Public method | AddWireSize | Add a new kind of wire size type into this temperature rating type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
Public method | RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
Public method | RemoveWireSize | Remove an existing wire size type from this temperature rating type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

TemperatureRatingType
Autodesk.Revit.Elements Namespace