Creates new Spaces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewSpaces(
    Level level,
    Phase phase,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces (
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Level
The level on which the spaces is to exist.
phase
Phase
The phase on which the spaces is to exist.
view
View
The view on which the tags of spaces is to exist.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace