ExternalCommandData Members
See Also Methods Properties Constructors

Syntax

C#
public class ExternalCommandData
Visual Basic (Declaration)
Public Class ExternalCommandData
Visual C++
public ref class ExternalCommandData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ExternalCommandDataExternalCommandDataNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Application | Retrieves an object that represents the current Application for external command.
Public property | Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData
Autodesk.Revit Namespace