Save the changes for the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Save(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Save ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Save (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace