Item Property

ModelCurveArray..::Item Property

Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual ModelCurve Item[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurve
Visual C++
public:
virtual property ModelCurve^ Item[int index] {
    ModelCurve^ get (int index);
    void set (int index, ModelCurve^ value);
}

Parameters

index
Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace