Creates a new instance of a AreaLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    XYZArray forces,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    forces As XYZArray, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad (
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    XYZArray^ forces,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
CurveArray
An array of curves that define the shape of the area load curves.
refPntIdxs
array< Int32 >[]()
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
array< Int32 >[]()
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
forces
XYZArray
The 3d area forces applied to each of the reference points in the refPntIdxs array.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
AreaLoadType

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application. The size of the refPntIdxs, ends, and forces arrays must be the same, and a maximum of 3 values is permitted.

See Also

Document Class
Autodesk.Revit.Creation Namespace