LocationPoint Members
See Also Methods Properties Constructors

Syntax

C#
public class LocationPoint
Visual Basic (Declaration)
Public Class LocationPoint
Visual C++
public ref class LocationPoint

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | LocationPointLocationPointNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Get and set the physical location of the element.
Public property | Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint
Autodesk.Revit Namespace