ElectricalEquipment Properties

Syntax

C#
public class ElectricalEquipment
Visual Basic (Declaration)
Public Class ElectricalEquipment
Visual C++
public ref class ElectricalEquipment

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | DistributionSystem | get or set the Distribution System for the Electrical Equipment.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment
Autodesk.Revit.MEP Namespace