Creates a new instance of a AreaLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad NewAreaLoad(
    Element host,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    host As Element, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad (
    Element^ host,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

host
Element
The host element (Floor or Wall) of the AreaLoad application.
force
XYZ
The 3d area force applied to the first reference point.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
AreaLoadType

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace