Creates an object which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData (
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
XYZ
The physical location where the instance is to be placed.
symbol
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Level
A Level object that is used as the base level for the object.
structuralType
StructuralType
If structural then specify the type of the component.

See Also

Application Class
Autodesk.Revit.Creation Namespace