AnalyticalModelProfile Members
See Also Methods Properties Constructors

Syntax

C#
public class AnalyticalModelProfile
Visual Basic (Declaration)
Public Class AnalyticalModelProfile
Visual C++
public ref class AnalyticalModelProfile

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelProfileAnalyticalModelProfileNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public property | EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
Public property | SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile
Autodesk.Revit.Structural Namespace