BasisZ Property

Transform..::BasisZ Property

The basis of the Z axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ BasisZ{ get; set;}
Visual Basic (Declaration)
Public Property BasisZ As XYZ
Visual C++
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Z axis of the old coordinate system in the new coordinate system, or the 3rd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace