WallType Property

Wall..::WallType Property

Retrieve or change the type of the wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public WallType WallType{ get; set;}
Visual Basic (Declaration)
Public Property WallType As WallType
Visual C++
public:
property WallType^ WallType {
    WallType^ get ();
    void set (WallType^ value);
}

Remarks

The WallType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a wall by setting it to a different wall type. All the wall types in the project can be found using the Document.WallTypes property.

See Also

Wall Class
Autodesk.Revit.Elements Namespace