ElectricalSystem Methods

Syntax

C#
public class ElectricalSystem
Visual Basic (Declaration)
Public Class ElectricalSystem
Visual C++
public ref class ElectricalSystem

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddToCircuit | Add a set of exist components to the Electrical System.
Public method | DisconnectPanel | Disconnect the panel for the Electrical System.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewWires | Create a bunch of wires for the electrical system.
Public method | RemoveFromCircuit | remove a set of exist components from the Electrical System.
Public method | SelectPanel | Set the panel for the Electrical System.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

ElectricalSystem
Autodesk.Revit.Elements Namespace