CurtainGridLine Members
See Also Methods Properties Constructors

Syntax

C#
public class CurtainGridLine
Visual Basic (Declaration)
Public Class CurtainGridLine
Visual C++
public ref class CurtainGridLine

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CurtainGridLineCurtainGridLineNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Lock | Retrieve or change the lock state of the curtain grid line.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainGridLine
Autodesk.Revit.Elements Namespace