FamilyInstance Members
See Also Methods Properties Constructors

Syntax

C#
public class FamilyInstance
Visual Basic (Declaration)
Public Class FamilyInstance
Visual C++
public ref class FamilyInstance

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FamilyInstanceFamilyInstanceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Change the room to which the door or window is opened.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopings | Lists the elements currently used as coping cutters for this element.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
Public method | SetCopings | Specify the set of coping cutters on this element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from InsertableInstance.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | AnalyticalModel | Retrieves the structural analytical model for the family instance.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | Overloaded.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element ..:: Location.)
Public property | Material | This property returns the physical material from which the instance is made.
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Room | Overloaded.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Property to get the sub componets of current family instance.
Public property | SuperComponent | Property to get the super componet of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | Overloaded.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyInstance
Autodesk.Revit.Elements Namespace