Line Properties

Syntax

C#
public class Line
Visual Basic (Declaration)
Public Class Line
Visual C++
public ref class Line

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
 | Bound | Returns the bounded line between the specified points.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
 | Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.

See Also

Line
Autodesk.Revit.Geometry Namespace