LineLoad Properties

Syntax

C#
public class LineLoad
Visual Basic (Declaration)
Public Class LineLoad
Visual C++
public ref class LineLoad

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndPoint | Returns the three dimensional location of the end point for the line load.
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the start point of the line load.
Public property | Force2 | Returns the three dimensional force applied to the end point of the line load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment applied to one of the points for the line load.
Public property | Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Public property | Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | Point | Returns the three dimensional location of one of the points for the line load.
Public property | ProjectedLoad | Returns whether the load is projected or not.
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | StartPoint | Returns the three dimensional location of the start point for the line load.
Public property | UniformLoad | Report if the load is uniform.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoad
Autodesk.Revit.Elements Namespace