View Methods

Syntax

C#
public class View
Visual Basic (Declaration)
Public Class View
Visual C++
public ref class View

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view.
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

View
Autodesk.Revit.Elements Namespace