ObjectFactory Property

Application..::ObjectFactory Property

Provides an object that can be used to create other instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ObjectFactory ObjectFactory{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ObjectFactory As ObjectFactory
Visual C++
public:
property ObjectFactory^ ObjectFactory {
    ObjectFactory^ get ();
}

Remarks

Returns an object factory object that can create other objects. This property is available for advanced use cases only. For general purpose creation of Autodesk Revit API objects use the Application.Create object.

See Also

Application Class
Autodesk.Revit Namespace