CompoundStructureLayerArray Members
See Also Methods Properties Constructors

Syntax

C#
public class CompoundStructureLayerArray
Visual Basic (Declaration)
Public Class CompoundStructureLayerArray
Visual C++
public ref class CompoundStructureLayerArray

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CompoundStructureLayerArrayCompoundStructureLayerArrayNew |

Public Methods

 | Name | Description
Public method | Append | Add the layer to the end of the array.
Public method | Clear | Removes every layer from the array, rendering it empty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified layer into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a layer at a specified index within the array.
Public property | Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray
Autodesk.Revit.Structural Namespace