DetailCurve Methods

Syntax

C#
public class DetailCurve
Visual Basic (Declaration)
Public Class DetailCurve
Visual C++
public ref class DetailCurve

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | getLineStyle | Get the line style of the curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | setLineStyle | Set the line style for the curve.
Public method | SetPlaneAndCurve | Set sketch plane and geometry curve properties simultaneously.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

DetailCurve
Autodesk.Revit.Elements Namespace