PanelType Property

Panel..::PanelType Property

The Panel style of this Panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PanelType PanelType{ get; set;}
Visual Basic (Declaration)
Public Property PanelType As PanelType
Visual C++
public:
property PanelType^ PanelType {
    PanelType^ get ();
    void set (PanelType^ value);
}

Remarks

The Symbol property can be used to retrieve the kind of the panel. This property can also be used to change the type of a panel by setting it to a different type. All the panel types in the project can be found using the Document.CutainPanelTypes property.

See Also

Panel Class
Autodesk.Revit.Elements Namespace