WireMaterialType Methods

Syntax

C#
public class WireMaterialType
Visual Basic (Declaration)
Public Class WireMaterialType
Visual C++
public ref class WireMaterialType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
Public method | AddTemperatureRatingType | Add a new temperature rating type into material type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
Public method | RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

WireMaterialType
Autodesk.Revit.Elements Namespace