Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName,
    bool changeDocumentFilename,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
String
File name to be saved as.
changeDocumentFilename
Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace