Specify a dimension between two bends, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddListeningDimensionBendToBend(
    Parameter __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionBendToBend ( _
    __unnamed000 As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iEnd0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionBendToBend (
    Parameter^ __unnamed000,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)

Parameters

__unnamed000
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
iSegment0
Int32
Index of the first segment.
iEnd0
Int32
End (0 or 1) of the first segment.
iSegment1
Int32
Index of the second segment.
iEnd1
Int32
End (0 or 1) of the second segment.

Remarks

Each reference is at the outside of the bend, perpendicular to the specified segment. So the overall length of a shape with 5 segments might be defined by calling this function with iSegment0=0, iEnd0=0, iSegment1=4, iEnd1=1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace