TypeOfStorage Property

Document..::TypeOfStorage Property

Get the storage type of the specified builtin parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StorageType TypeOfStorage[
    BuiltInParameter
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property TypeOfStorage ( _
     As BuiltInParameter _
) As StorageType
Visual C++
public:
property StorageType TypeOfStorage[BuiltInParameter ] {
    StorageType get (BuiltInParameter );
}

Parameters

BuiltInParameter

Remarks

This property is useful in element retrieval. It can be used to create a ParameterStorage object with a correct storage type for the FilterCriterion object.

See Also

Document Class
Autodesk.Revit Namespace