Creates a new TypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType,
    bool includeDerivedTypes
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type, _
    includeDerivedTypes As Boolean _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter (
    Type^ givenType,
    bool includeDerivedTypes
)

Parameters

givenType
Type
Filter elements by the given type.
includeDerivedTypes
Boolean
Indicates if find out the elements which are given type's derived classes or not. If includeDerivedTypes is true, will filter derived class elements; false, don't filter derived class elements.

Return Value

Returns a new type filter object within given type.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace