Exports the current model in Green-Building XML format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    options As GBXMLExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
options
GBXMLExportOptions
Options applicable to the dbXML format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be null).

See Also

Document Class
Autodesk.Revit Namespace