Creates a opening in a swall or arcwall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    wall As Wall, _
    pntStart As XYZ, _
    pntEnd As XYZ _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)

Parameters

wall
Wall
host element of the opening.
pntStart
XYZ
first point of the rect.
pntEnd
XYZ
second point of the rect.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on the arc wall or swall.

See Also

Document Class
Autodesk.Revit.Creation Namespace