Creates a new Area BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions (
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

hostElement
Element
The Geometry reference to Wall, Slab or Slab Foundation.
X_Translation
TranslationRotationValue
Translation for axe X. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
X_TranslationSpringModulus
Double
Translation Spring Modulus for axe X. Ignored if X_Translation is not 2 - "Spring"
Y_Translation
TranslationRotationValue
Translation for axe Y. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Y_TranslationSpringModulus
Double
Translation Spring Modulus for axe Y. Ignored if Y_Translation is not 2 - "Spring"
Z_Translation
TranslationRotationValue
Translation for axe Z. 0 - "Fixed", 1 - "Pinned", 2 - "Spring".
Z_TranslationSpringModulus
Double
Translation Spring Modulus for axe Z. Ignored if Z_Translation is not 2 - "Spring"

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace