StructuralUsage Property

Floor..::StructuralUsage Property

The floors designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabFoundationType StructuralUsage{ get; set;}
Visual Basic (Declaration)
Public Property StructuralUsage As SlabFoundationType
Visual C++
public:
property SlabFoundationType StructuralUsage {
    SlabFoundationType get ();
    void set (SlabFoundationType value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Floor Class
Autodesk.Revit.Elements Namespace