NewElementArray Method

Application..::NewElementArray Method

Returns an array that can hold element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementArray NewElementArray()
Visual Basic (Declaration)
Public Function NewElementArray As ElementArray
Visual C++
public:
ElementArray^ NewElementArray ()

Return Value

An empty array that can contain any Autodesk Revit element derived objects.

Remarks

The array returned by this method can be used as a general purpose tool for holding ordered lists of any type of element.

See Also

Application Class
Autodesk.Revit.Creation Namespace