Creates a fascia along the reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    reference As Reference _
) As Fascia
Visual C++
public:
Fascia^ NewFascia (
    FasciaType^ FasciaType,
    Reference^ reference
)

Parameters

FasciaType
FasciaType
The type of the fascia to create
reference
Reference
A planar line or arc that represent the place where you want to place fascia.

Return Value

If successful a new fascia object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace