The Insert method is used to create a new parameter binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public override bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overrides Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert (
    Definition^ key,
    Binding^ item
) override

Parameters

key
Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, post an error and return false.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace