ProjectPosition Members
See Also Methods Properties Constructors

Syntax

C#
public class ProjectPosition
Visual Basic (Declaration)
Public Class ProjectPosition
Visual C++
public ref class ProjectPosition

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ProjectPositionProjectPositionNew | Overloaded.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Angle | Angle from True North
Public property | EastWest | East to West offset
Public property | Elevation | Elevation above ground level.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NorthSouth | North to South offset

See Also

ProjectPosition
Autodesk.Revit.Site Namespace