Item Property

XYZ..::Item Property

Indexed access to coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double this[
    int idx
]{ get; set;}
Visual Basic (Declaration)
Public Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
    void set (int idx, double value);
}

Parameters

idx
Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access the coordinate with an index that is larger than 2.
System..::NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace