Close the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Close(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if Save operations fails. Otherwise, returns true.

Remarks

Before the document is closed, the changes will be saved firstly.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace