Loads an entire family and all its types/symbols into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool LoadFamily(
    string filename
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String _
) As Boolean
Visual C++
public:
bool LoadFamily (
    String^ filename
)

Parameters

filename
String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

Returns True if the entire family was loaded successfully into the project, otherwise false.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

See Also

Document Class
Autodesk.Revit Namespace