Creates a new grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Grid NewGrid(
    Arc arc
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    arc As Arc _
) As Grid
Visual C++
public:
Grid^ NewGrid (
    Arc^ arc
)

Parameters

arc
Arc
A arc object that represents the location of the new grid line.

Return Value

The newly created grid line.

Remarks

The arc should be on a horizontal plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace