Creates a new Space element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Space NewSpace(
    Level level,
    Phase phase,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    phase As Phase, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace (
    Level^ level,
    Phase^ phase,
    UV^ point
)

Parameters

level
Level
The level on which the room is to exist.
phase
Phase
The phase on which the room is to exist.
point
UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Space element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::InvalidOperationException | Thrown when the space cannot be created with input level and phase.

See Also

Document Class
Autodesk.Revit.Creation Namespace