PostedError Members
See Also Methods Properties Constructors

Syntax

C#
public class PostedError
Visual Basic (Declaration)
Public Class PostedError
Visual C++
public ref class PostedError

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | PostedErrorPostedErrorNew | Copy constructor

Public Methods

 | Name | Description
 | Equality | Equality operator - static method
 | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides Object ..:: ToString()().)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Descriptor | Internal string identifier for the error.
Public property | ErrorType | Type of the error.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | Message associated with the error.
Public property | RawID | Internal identifier of the error.

See Also

PostedError
Autodesk.Revit Namespace