Specify a parameter to drive the circumference of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintCircumference(
    Parameter __unnamed000,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintCircumference ( _
    __unnamed000 As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintCircumference (
    Parameter^ __unnamed000,
    RebarShapeArcReferenceType arcRefType
)

Parameters

__unnamed000
Parameter
arcRefType
RebarShapeArcReferenceType
Specify along which circle the circumference is measured--to the interior of the bar, the centerline, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace