WireType Properties

Syntax

C#
public class WireType
Visual Basic (Declaration)
Public Class WireType
Visual C++
public ref class WireType

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Conduit | Get of set conduit type of wire type.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Insulation | Get of set insulation type.
Public property | IsInUse | Indicate whether the wire type is in use.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | MaxSize | Get of set max size of wire type.
Public property | Name | set name for a symbol (Inherited from Symbol.)
Public property | NeutralMultiplier | Get of set neutral multiplier type of wire type.
Public property | NeutralRequired | Get of set whether the neutral point is required.
Public property | NeutralSize | Get of set maximum neutral size of wire type.
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | TemperatureRating | Get of set temperature rating type of wire type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | WireMaterial | Get of set material type of wire type.

See Also

WireType
Autodesk.Revit.Symbols Namespace