Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter radiusParam,
    bool measureToOutsideOfBend
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer, _
    radiusParam As Parameter, _
    measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend (
    int iSegment,
    Parameter^ radiusParam,
    bool measureToOutsideOfBend
)

Parameters

iSegment
Int32
radiusParam
Parameter
measureToOutsideOfBend
Boolean

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace