ElementId Members
See Also Methods Fields

Syntax

C#
public struct ElementId
Visual Basic (Declaration)
Public Structure ElementId
Visual C++
public value class ElementId

The type exposes the following members.

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | Value | Provides the value of the element id as an integer.

See Also

ElementId
Autodesk.Revit Namespace