Category Properties

Syntax

C#
public class Category
Visual Basic (Declaration)
Public Class Category
Visual C++
public ref class Category

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Id | Returns the category id associated with the category object.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Material | Retrieve or change the material of the category.
Public property | Name | Returns the user visible name of the category.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the sub categories of this category.
Public property | Visible | Retrieve or change the visible of the category in the active view.

See Also

Category
Autodesk.Revit Namespace