Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewTypeBinding ( _
    categorySet As CategorySet _
) As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding (
    CategorySet^ categorySet
)

Parameters

categorySet
CategorySet
A set of categories that will be added to the binding.

Return Value

Returns a new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category.

See Also

Application Class
Autodesk.Revit.Creation Namespace