Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace