VoltageType Methods

Syntax

C#
public class VoltageType
Visual Basic (Declaration)
Public Class VoltageType
Visual C++
public ref class VoltageType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

VoltageType
Autodesk.Revit.Symbols Namespace