Creates a new CurtainSystem element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As FaceArray, _
    curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem (
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is null. The size of faces is zero.
System..::InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace