ComputeDerivatives Method

Face..::ComputeDerivatives Method

Returns the moving frame around the face at the specified parameters.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Transform ComputeDerivatives(
    UV point
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    point As UV _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives (
    UV^ point
)

Parameters

point
UV
The parameters to be evaluated, in natural parametrization of the face.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the face; (equivalent to Evaluate); BasisX is the tangent vector along the U coordinate; (partial derivative with respect to U); BasisY is the tangent vector along the V coordinate; (partial derivative with respect to V); BasisZ is the normal vector. None of the vectors are normalized.

See Also

Face Class
Autodesk.Revit.Geometry Namespace