Delete several elements from the project given their ids.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    ElementIdSet ids
)
Visual Basic (Declaration)
Public Function Delete ( _
    ids As ElementIdSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    ElementIdSet^ ids
)

Parameters

ids
ElementIdSet
A set of element ids for the elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace