EndParameter Property

Curve..::EndParameter Property

The parameter of the start or the end point of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double EndParameter[
    int index
]{ get; set;}
Visual Basic (Declaration)
Public Property EndParameter ( _
    index As Integer _
) As Double
Visual C++
public:
property double EndParameter[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when the specified index is not 0 or 1 both in the getter and setter.
System..::InvalidOperationException | Thrown when the specified parameter is not within curve bounds in the setter, or the object is internally marked as read-only in the setter, or the curve is unbound both in the getter and setter.
System..::NotFiniteNumberException | Thrown when the value of parameter is infinite in the setter.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace