Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve
)

Parameters

curve
Curve
The specified curve to intersect with this curve.

Return Value

The value of SetComparisonResult enumeration that contains the intersection results.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified curve is null.
System..::InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace