RebarBarType Methods

Syntax

C#
public class RebarBarType
Visual Basic (Declaration)
Public Class RebarBarType
Visual C++
public ref class RebarBarType

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAutoCalcHookLengths |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAutoCalcHookLengths | Specify whether hook lengths are automatically calculated.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

RebarBarType
Autodesk.Revit.Symbols Namespace