Creates a new rectangular profile wall within the project on the specified level using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall (
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Curve
An arc or line representing the base line of the wall.
level
Level
The level on which the wall is to be placed.
structural
Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace