BindingMap Methods

Syntax

C#
public class BindingMap
Visual Basic (Declaration)
Public Class BindingMap
Visual C++
public ref class BindingMap

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap ..:: Clear()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap ..:: Contains(Definition).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap ..:: Erase(Definition).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Overloaded.
Public method | ReInsert | Overloaded.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides DefinitionBindingMap ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionBindingMap.)

See Also

BindingMap
Autodesk.Revit.Parameters Namespace