BasisY Property

Transform..::BasisY Property

The basis of the Y axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ BasisY{ get; set;}
Visual Basic (Declaration)
Public Property BasisY As XYZ
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Y axis of the old coordinate system in the new coordinate system, or the 2nd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace