Fix the direction of a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)
Visual Basic (Declaration)
Public Sub SetSegmentFixedDirection ( _
    iSegment As Integer, _
    vecCoordX As Double, _
    vecCoordY As Double _
)
Visual C++
public:
void SetSegmentFixedDirection (
    int iSegment,
    double vecCoordX,
    double vecCoordY
)

Parameters

iSegment
Int32
vecCoordX
Double
vecCoordY
Double

Remarks

The centerline of the segment will be constrained to be parallel to the vector. The line must have at least one constraint.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace