PoissonModulusX Property

MaterialSteel..::PoissonModulusX Property

Get or set the x component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double PoissonModulusX{ get; set;}
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace