OnShutdown Method

IExternalApplication..::OnShutdown Method

Provide an interface for the user to do some extra work when Revit closes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
IExternalApplication.IExternalApplication..::Result OnShutdown(
    ControlledApplication application
)
Visual Basic (Declaration)
Function OnShutdown ( _
    application As ControlledApplication _
) As IExternalApplication..::Result
Visual C++
IExternalApplication..::Result OnShutdown (
    ControlledApplication^ application
)

Parameters

application
ControlledApplication
The application is being shut down.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an exteranl application, the task within OnShutdown will be executed when Revit closes.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace