Creates new Rooms.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewRooms(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level, _
    phase As Phase _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms (
    Level^ level,
    Phase^ phase
)

Parameters

level
Level
The level on which the room is to exist.
phase
Phase
The phase on which the room is to exist.

Return Value

If successful a Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::ArgumentNullException | If either of RoomCreationData's level or point is null object.
System..::ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace