Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    direction As XYZ _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem (
    CurveArray^ profile,
    XYZ^ direction
)

Parameters

profile
CurveArray
The profile is the profile of the BeamSystem.
direction
XYZ
The direction is the direction of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
Autodesk.Revit.Creation Namespace