Creates a non rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace