Creates a gutter along the reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter (
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
GutterType
The type of the gutter to create
references
ReferenceArray
An array of planar lines and arcs that represent the place where you want to place gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace