Add a new ToolbarItem to the Toolbar.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItem AddItem(
    MenuItem pMenuItem
)
Visual Basic (Declaration)
Public Function AddItem ( _
    pMenuItem As MenuItem _
) As ToolbarItem
Visual C++
public:
ToolbarItem^ AddItem (
    MenuItem^ pMenuItem
)

Parameters

pMenuItem
MenuItem
The corresponding MenuItem, can be null. If pMenuItem is not null, the new Item will have the same execution command with the menu. If pMenuItem is null, it will create a separator bar.

Remarks

This method will add a new API ToolBarItem to the Toolbar.

Exceptions

Exception | Condition
System..::ArgumentException | if 'pMenuItem' is a pop up menu.

See Also

Toolbar Class
Autodesk.Revit Namespace