Exports the current model in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As FBXExportOptions _
) As Boolean
Visual C++
public:
bool Export (
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)

Parameters

folder
String
Output folder, into which file(s) will be exported. The folder must exists.
name
String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
ViewSet
options
FBXExportOptions
Options applicable to the FBX format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be null).

See Also

Document Class
Autodesk.Revit Namespace