NewLogicNotFilter Method

Filter..::NewLogicNotFilter Method

Creates a new LogicNotFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LogicNotFilter NewLogicNotFilter(
    Filter subFilter
)
Visual Basic (Declaration)
Public Function NewLogicNotFilter ( _
    subFilter As Filter _
) As LogicNotFilter
Visual C++
public:
LogicNotFilter^ NewLogicNotFilter (
    Filter^ subFilter
)

Parameters

subFilter
Filter
subFilter is an operand of logic-not operator

Return Value

Returns a new LogicNotFilter object.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace