Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate (
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
ElementSet
A set of elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace