RuledFace Members
See Also Methods Properties Constructors

Syntax

C#
public class RuledFace
Visual Basic (Declaration)
Public Class RuledFace
Visual C++
public ref class RuledFace

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | RuledFaceRuledFaceNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect | Overloaded.
Public method | IsInside | Overloaded.
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from GeometryObject.)

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

RuledFace
Autodesk.Revit.Geometry Namespace