Profile Property

AnalyticalModelFrame..::Profile Property

This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AnalyticalModelProfile Profile{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Profile As AnalyticalModelProfile
Visual C++
public:
property AnalyticalModelProfile^ Profile {
    AnalyticalModelProfile^ get ();
}

Return Value

Returns a profile analytical model object if possible.

Remarks

Some elements may not be able to return a profile. In that case Nothing will be returned.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace