Definition Property

RebarShape..::Definition Property

Get the shape definition object associated with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public RebarShapeDefinition Definition{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Definition As RebarShapeDefinition
Visual C++
public:
property RebarShapeDefinition^ Definition {
    RebarShapeDefinition^ get ();
}

Remarks

Returns null until one of the factory methods (e.g. NewDefinitionBySegments()) is called.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace