NewFamilyFilter Method

Filter..::NewFamilyFilter Method

Creates a FamilyFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public FamilyFilter NewFamilyFilter(
    string familyName
)
Visual Basic (Declaration)
Public Function NewFamilyFilter ( _
    familyName As String _
) As FamilyFilter
Visual C++
public:
FamilyFilter^ NewFamilyFilter (
    String^ familyName
)

Parameters

familyName
String
Filter elements by the family name.

Return Value

Returns a new family filter object with given family.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the familyName is nullptr or empty.

See Also

Filter Class
Autodesk.Revit.Creation Namespace