ViewSection Members
See Also Methods Properties Constructors

Syntax

C#
public class ViewSection
Visual Basic (Declaration)
Public Class ViewSection
Visual C++
public ref class ViewSection

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ViewSectionViewSectionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | ApplyTemplate | Applies the template to this view. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVisibility | get category visible of this view. (Inherited from View.)
Public method | Print | Overloaded.
Public method | setVisibility | set category visible of this view. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

Public Properties

 | Name | Description
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CropBox | The crop box sets display bounds of the view. (Inherited from View.)
Public property | CropBoxActive | Active of the Crop Box/Region. (Inherited from View.)
Public property | CropBoxVisible | Visibility of the Crop Box/Region. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
Public property | GenLevel | The level which generate this View. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | If the element is level based then level to which the element is assigned it returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within project. (Inherited from Element.)
Public property | Name | Returns a human readable name for the Element. (Inherited from Element.)
Public property | ObjectType | Returns the instance type of this object. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | Parameter | Overloaded.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Informs the developer if an element has been pinned by a user. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)

See Also

ViewSection
Autodesk.Revit.Elements Namespace