Filter Members
See Also Methods Properties Constructors

Syntax

C#
public abstract class Filter
Visual Basic (Declaration)
Public MustInherit Class Filter
Visual C++
public ref class Filter abstract

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LogicalAnd | Overload operator && for new Logic-AND filter.
 | LogicalNot | Overload operator ! for new Logic-Not filter.
 | LogicalOr | Overload operator || for new Logic-OR filter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter
Autodesk.Revit Namespace