RebarShape Methods

Syntax

C#
public class RebarShape
Visual Basic (Declaration)
Public Class RebarShape
Visual C++
public ref class RebarShape

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Duplicate | Duplicate this object. (Inherited from Symbol.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllowed |
 | GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
Public method | GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
Public method | NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
Public method | SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides APIObject ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

RebarShape
Autodesk.Revit.Symbols Namespace