Creates a slab edge along the reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    references As ReferenceArray _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge (
    SlabEdgeType^ SlabEdgeType,
    ReferenceArray^ references
)

Parameters

SlabEdgeType
SlabEdgeType
The type of the slab edge to create
references
ReferenceArray
An array of planar lines and arcs that represent the place where you want to place slab edge.

Return Value

If successful a new slab edge object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace