Provides access to all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIterator Elements[
    Filter filter
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Filter^ filter] {
    ElementIterator^ get (Filter^ filter);
}

Parameters

filter
Filter
Filter specified by user.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter of Filter is null.

See Also

Document Class
Autodesk.Revit Namespace