NewStructuralTypeFilter Method

Filter..::NewStructuralTypeFilter Method

Creates a StructuralTypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public StructuralTypeFilter NewStructuralTypeFilter(
    StructuralType structType
)
Visual Basic (Declaration)
Public Function NewStructuralTypeFilter ( _
    structType As StructuralType _
) As StructuralTypeFilter
Visual C++
public:
StructuralTypeFilter^ NewStructuralTypeFilter (
    StructuralType structType
)

Parameters

structType
StructuralType
Filter elements by the structural type.

Return Value

Returns a new structural type filter object with given structural type.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace