AreaCreationData Members
See Also Methods Constructors Properties

Syntax

C#
public class AreaCreationData
Visual Basic (Declaration)
Public Class AreaCreationData
Visual C++
public ref class AreaCreationData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AreaCreationDataAreaCreationDataNew | The data needed to create a new area

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | TagPoint | Specify the location of the area tag.

See Also

AreaCreationData
Autodesk.Revit.Creation Namespace