MenuItem Members
See Also Methods Properties Constructors

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | MenuItemMenuItemNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | AddToExternalTools | Add top level menu to "external tools" menu.
Public method | Append | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMenuItemCount | Get number of sub menus, if current menu is not popup menu, zero will be returned.
Public method | GetSubMenu | Get a sub menu, if current menu is not popup menu, null will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | AssemblyName | Get or set name of the assembly which external command lives in.
Public property | Checked | Set check or uncheck the menu through API.
Public property | ClassName | Get or set name of the class which implements external command.
Public property | Enabled | Disable and Enable the Custom menu through API.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MenuItemType | Get type of the menu through API.
Public property | Name | Get name of the menu through API.
Public property | StatusbarTip | Get or set tips.

See Also

MenuItem
Autodesk.Revit Namespace