AddParameter Method

RebarShapeDefinition..::AddParameter Method

Add a parameter to the shape definition.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter AddParameter(
    ExternalDefinition param,
    double defaultValue
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    param As ExternalDefinition, _
    defaultValue As Double _
) As Parameter
Visual C++
public:
Parameter^ AddParameter (
    ExternalDefinition^ param,
    double defaultValue
)

Parameters

param
ExternalDefinition
The parameter. To obtain this object, the following calls are required: Application.OpenSharedParameterFile(); Parameters.DefinitionFile.Groups.get_Item() or .create(); and Parameters.DefinitionGroup.Definitions.get_Item() or .create().
defaultValue
Double
A default value for this parameter in shapes. The default values should be chosen carefully, because they are required to be consistent as a set of constraints.

Remarks

Shape parameters must be shared parameters and have value type double. A parameter must be added with AddParameter() before it can be used to drive the shape with the various AddConstraint() functions. A parameter that does not drive a constraint is legal and will simply become an editable parameter on any Rebar that is an instance of this RebarShape.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace