ImageImportOptions Members
See Also Fields Methods Constructors

Syntax

C#
public class ImageImportOptions
Visual Basic (Declaration)
Public Class ImageImportOptions
Visual C++
public ref class ImageImportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ImageImportOptionsImageImportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | Placement | Placement mode defines by which point is the image goind to be inserted.
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | Resolution | Resolution [ppi] of the image to be imported.
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

ImageImportOptions
Autodesk.Revit Namespace