Filter Members
See Also Methods Properties Constructors

Syntax

C#
public class Filter
Visual Basic (Declaration)
Public Class Filter
Visual C++
public ref class Filter

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterFilterNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewCategoryFilter | Overloaded.
Public method | NewFamilyFilter | Creates a FamilyFilter object.
Public method | NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
Public method | NewLogicAndFilter | Creates a new LogicAndFilter object.
Public method | NewLogicNotFilter | Creates a new LogicNotFilter object.
Public method | NewLogicOrFilter | Creates a new LogicOrFilter object.
Public method | NewMaterialFilter | Creates a MaterialFilter object.
Public method | NewParameterFilter | Overloaded.
Public method | NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
Public method | NewSymbolFilter | Creates a SymbolFilter object.
Public method | NewTypeFilter | Overloaded.
Public method | NewWallUsageFilter | Creates a new WallUsageFilter object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter
Autodesk.Revit.Creation Namespace