Creates a new Opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    Document.Document..::eRefFace iFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    famInstElement As Element, _
    profile As CurveArray, _
    iFace As Document..::eRefFace _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Element^ famInstElement,
    CurveArray^ profile,
    Document..::eRefFace iFace
)

Parameters

famInstElement
Element
host element of the opening, can be a beam, brace and column.
profile
CurveArray
profile of the opening.
iFace
Document..::eRefFace
face on which opening is based on.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on a beam, brace and column.

See Also

Document Class
Autodesk.Revit.Creation Namespace