Specify a variable-radius bend.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter radiusParam,
    bool measureIncludingBarThickness
)
Visual Basic (Declaration)
Public Sub AddBendVariableRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle, _
    radiusParam As Parameter, _
    measureIncludingBarThickness As Boolean _
)
Visual C++
public:
void AddBendVariableRadius (
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter^ radiusParam,
    bool measureIncludingBarThickness
)

Parameters

iSegmentFollowingBend
Int32
turn
Int32
Specify 1 for a left turn, -1 for a right turn.
angle
RebarShapeBendAngle
radiusParam
Parameter
measureIncludingBarThickness
Boolean

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace