HasMiter Property

IExtension..::HasMiter Property

Retrieves the miter status at the end

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
bool HasMiter[
    int index
]{ get;}
Visual Basic (Declaration)
ReadOnly Property HasMiter ( _
    index As Integer _
) As Boolean
Visual C++
property bool HasMiter[int index] {
    bool get (int index);
}

Parameters

index
Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, this can check whether the beam is mitered with other beams at the end

See Also

IExtension Interface
Autodesk.Revit Namespace