AngleAround Method

XYZ..::AngleAround Method

Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double AngleAround(
    XYZ right,
    XYZ norm
)
Visual Basic (Declaration)
Public Function AngleAround ( _
    right As XYZ, _
    norm As XYZ _
) As Double
Visual C++
public:
double AngleAround (
    XYZ^ right,
    XYZ^ norm
)

Parameters

right
XYZ
The specified vector.
norm
XYZ
The normal vector that defines the plane.

Return Value

The real number between 0 and 2*PI equal to the projected angle between the two vectors.

Remarks

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace