Creates new Rooms.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet NewRooms(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms (
    Phase^ phase,
    int count
)

Parameters

phase
Phase
The phase on which the room is to exist.
count
Int32
The number of the rooms to be created.

Return Value

If successful a Element set which contain the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace