Item Property

Map..::Item Property

Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Object Item[
    Object key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Object _
) As Object
Visual C++
public:
virtual property Object^ Item[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Object
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

Map Class
Autodesk.Revit.Collections Namespace