Imports a DWG file into Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Import(
    string file,
    DWGImportOptions options,
    ref Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As DWGImportOptions, _
    ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import (
    String^ file,
    DWGImportOptions^ options,
    Element^% element
)

Parameters

file
String
Full path of the file to import. File must exist.
options
DWGImportOptions
Various options applicable to the DWG format. If nullptr, all options will be set to their respective default values.
element
Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

See Also

Document Class
Autodesk.Revit Namespace