Save the document to another file with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool SaveAs(
    string fileName,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs (
    String^ fileName,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
String
File name to be saved as.
postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns false if save operation fails, otherwise, returns true.

Remarks

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace