Dot Method

UV..::Dot Method

The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Dot(
    UV source
)
Visual Basic (Declaration)
Public Function Dot ( _
    source As UV _
) As Double
Visual C++
public:
double Dot (
    UV^ source
)

Parameters

source
UV
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Pu*Pu + Rv*Rv.

See Also

UV Class
Autodesk.Revit.Geometry Namespace