Calculates the intersection of this curve with the specified curve and returns the intersection results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    ref IntersectionResultArray resultArray
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    ByRef resultArray As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect (
    Curve^ curve,
    IntersectionResultArray^% resultArray
)

Parameters

curve
Curve
The specified curve to intersect with this curve.
resultArray
IntersectionResultArray %
Provides more information about the intersection.

Return Value

The value of SetComparisonResult enumeration that contains the intersection results.

Remarks

The array of the intersection results contains one entry for each point where curves intersect. The following is the meaning of IntersectionResult members: XYZPoint is the evaluated intersection point; UVPoint.U is the raw parameter on this curve, UVPoint.V is the raw parameter on the specified curve.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified curve is null.
System..::InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace