ObjectFactory Methods

Syntax

C#
public class ObjectFactory
Visual Basic (Declaration)
Public Class ObjectFactory
Visual C++
public ref class ObjectFactory

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | CreateInstance | For Internal Use Only.
Public method | Dispose | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInstance | For Internal Use Only.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveInstance | For Internal Use Only.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

ObjectFactory
Autodesk.Revit Namespace