APIObject Methods

Syntax

C#
public class APIObject
Visual Basic (Declaration)
Public Class APIObject
Visual C++
public ref class APIObject

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Dispose | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | Overloaded.
Protected method | Finalize | (Overrides Object ..:: Finalize()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources |
Protected method | ReleaseUnmanagedResources |

See Also

APIObject
Autodesk.Revit Namespace