CADImportOptions Members
See Also Methods Constructors Fields

Syntax

C#
public abstract class CADImportOptions
Visual Basic (Declaration)
Public MustInherit Class CADImportOptions
Visual C++
public ref class CADImportOptions abstract

The type exposes the following members.

Protected Constructors

 | Name | Description
Protected method | CADImportOptionsCADImportOptionsNew |

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import.
Public field | CustomScale | Scaling the import.
Public field | OrientToView | Place the import at the same orientation as the current view.
Public field | Placement | Where to place the import.
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Public field | Unit | The unit of measure for imported geometry.
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions
Autodesk.Revit Namespace