EndPointReference Property

Curve..::EndPointReference Property

Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Reference EndPointReference[
    int index
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullptr if reference cannot be obtained.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.
System..::InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace