Creates a new geometric plane object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Plane NewPlane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane (
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
XYZ
X vector of the plane coordinate system.
yVec
XYZ
Y vector of the plane coordinate system.
origin
XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

Remarks

The new plane is created with two coordinate vectors and an origin.

See Also

Application Class
Autodesk.Revit.Creation Namespace