Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ NewXYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Function NewXYZ ( _
    x As Double, _
    y As Double, _
    z As Double _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ (
    double x,
    double y,
    double z
)

Parameters

x
Double
The first coordinate.
y
Double
The second coordinate.
z
Double
The third coordinate.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

Application Class
Autodesk.Revit.Creation Namespace