DefinitionFile Properties

Syntax

C#
public class DefinitionFile
Visual Basic (Declaration)
Public Class DefinitionFile
Visual C++
public ref class DefinitionFile

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile
Autodesk.Revit.Parameters Namespace