NewCurveArray Method

Application..::NewCurveArray Method

Creates an empty array that can store geometric curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurveArray NewCurveArray()
Visual Basic (Declaration)
Public Function NewCurveArray As CurveArray
Visual C++
public:
CurveArray^ NewCurveArray ()

Return Value

Returns an empty array that can hold geometric curves.

Remarks

This method can be used to create an array that can hold any curve type object. This array can be then passed to methods, such as NewAreaLoad, to represent the geometry for the boundary of the load.

See Also

Application Class
Autodesk.Revit.Creation Namespace