Insert a new menu before the specified menu.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MenuItem Insert(
    MenuItem.MenuItem..::MenuType menuType,
    string menuName,
    int pos
)
Visual Basic (Declaration)
Public Function Insert ( _
    menuType As MenuItem..::MenuType, _
    menuName As String, _
    pos As Integer _
) As MenuItem
Visual C++
public:
MenuItem^ Insert (
    MenuItem..::MenuType menuType,
    String^ menuName,
    int pos
)

Parameters

menuType
MenuItem..::MenuType
Type of the menu to be created.
menuName
String
Text which will be displayed on the created menu.
pos
Int32
Position before which new menu item will be inserted.

Return Value

That new inserted menu item will be returned if success, else null.

Remarks

If pos is -1, menu will be appended. And the other arguments are the same with method Append.

See Also

MenuItem Class
Autodesk.Revit Namespace