MaxEnabled Property

BoundingBoxXYZ..::MaxEnabled Property

Defines whether the maximum bound is active for given dimension.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool MaxEnabled[
    int dim
]{ get; set;}
Visual Basic (Declaration)
Public Property MaxEnabled ( _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool MaxEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace