Creates a new instance of a Rebar element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Rebar NewRebar(
    RebarStyle style,
    RebarBarType rebarType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    CurveArray curves,
    int startHookOrient,
    int endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    style As RebarStyle, _
    rebarType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As CurveArray, _
    startHookOrient As Integer, _
    endHookOrient As Integer, _
    useExistingShapeIfPossible As Boolean, _
    createNewShape As Boolean _
) As Rebar
Visual C++
public:
Rebar^ NewRebar (
    RebarStyle style,
    RebarBarType^ rebarType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    CurveArray^ curves,
    int startHookOrient,
    int endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)

Parameters

style
RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
rebarType
RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
startHook
RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted before the first curve of the rebar. If this parameter is null, it means to create a rebar with NONE hook type.
endHook
RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted after the last curve segment of the rebar. If this parameter is null, it means to create a rebar with NONE hook type.
host
Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
norm
XYZ
The normal to the plane that the rebar curves lie on.
curves
CurveArray
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Int32
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = 1: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = 3: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Int32
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = 1: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = 3: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
useExistingShapeIfPossible
Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns null or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true".
createNewShape
Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.

Return Value

If successful, NewRebar returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace