ACADImportOptions Fields

Syntax

C#
public abstract class ACADImportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADImportOptions
Visual C++
public ref class ACADImportOptions abstract

The type exposes the following fields.

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
Public field | CustomScale | Scaling the import. (Inherited from CADImportOptions.)
Public field | LayerSelection | The layers collection for import.
Public field | LineWeights | A Byte array of line weights for the DWG/DXF Color number.
Public field | OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Public field | Placement | Where to place the import. (Inherited from CADImportOptions.)
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Public field | Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
Public field | VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions
Autodesk.Revit Namespace