Item Property

DefinitionBindingMap..::Item Property

Gets or sets a parameter binding for a specified parameter definition within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Binding Item[
    Definition key
]{ get; set;}
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key);
    void set (Definition^ key, Binding^ value);
}

Parameters

key
Definition
The parameter definition of the binding to be set or retrieved.

Return Value

Returns the binding for the specified definition.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace