Set the parameter to a new real number value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual bool Set(
    double value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
virtual bool Set (
    double value
)

Parameters

value
Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown System::ArgumentNullException when the value is infinite.

See Also

ParameterStorage Class
Autodesk.Revit Namespace