Imports an image (a bitmap) into Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Import(
    string file,
    ImageImportOptions options,
    ref Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As ImageImportOptions, _
    ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import (
    String^ file,
    ImageImportOptions^ options,
    Element^% element
)

Parameters

file
String
Full path of the file to import. File must exist.
options
ImageImportOptions
Various options applicable to an image. If nullptr, all options will be set to their respective default values.
element
Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

See Also

Document Class
Autodesk.Revit Namespace