Document Methods

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AbortTransaction | Abort a transaction for specified document.
Public method | Array | Overloaded.
Public method | ArrayWithoutAssociate | Overloaded.
Public method | BeginTransaction | Overloaded.
Public method | Close | Overloaded.
Public method | Delete | Overloaded.
Public method | EndTransaction | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Overloaded.
Public method | LoadFamily | Overloaded.
Public method | LoadFamilySymbol | Overloaded.
Public method | Mirror | Overloaded.
Public method | Move | Overloaded.
Public method | Print | Overloaded.
Public method | Rotate | Overloaded.
Public method | Save | Overloaded.
Public method | SaveAs | Overloaded.
Public method | ShowElements | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

See Also

Document
Autodesk.Revit Namespace