Rotate several elements within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool Rotate(
    ElementSet elements,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    elements As ElementSet, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate (
    ElementSet^ elements,
    Line^ axis,
    double angle
)

Parameters

elements
ElementSet
A set of elements that are to be rotated.
axis
Line
An unbounded line that represents the axis of rotation.
angle
Double
The number of degrees, in radians, by which the elements are to be rotated around the specified axis.

Return Value

If the elements are rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Autodesk.Revit Namespace