RemoveDistributionSysType Method

ElectricalSetting..::RemoveDistributionSysType Method

Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void RemoveDistributionSysType(
    DistributionSysType distributionSysType
)
Visual Basic (Declaration)
Public Sub RemoveDistributionSysType ( _
    distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType (
    DistributionSysType^ distributionSysType
)

Parameters

distributionSysType
DistributionSysType

Exceptions

Exception | Condition
System..::InvalidOperationException | Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace