Subtract Method

XYZ..::Subtract Method

Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Subtract(
    XYZ source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Subtract (
    XYZ^ source
)

Parameters

source
XYZ
The vector to subtract from this vector.

Return Value

The vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace