AddSpaces Method

Zone..::AddSpaces Method

Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool AddSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function AddSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool AddSpaces (
    SpaceSet^ spaces
)

Parameters

spaces
SpaceSet
The spaces which want to add to zone element.

Return Value

If successful the current zone element will add a set of input spaces, otherwise Nothing.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter Value is null.
System..::InvalidOperationException | Thrown when the input spaces cannot be added to current zone element.

See Also

Zone Class
Autodesk.Revit.Elements Namespace