ActiveDocument Property

Application..::ActiveDocument Property

Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document ActiveDocument{ get; set;}
Visual Basic (Declaration)
Public Overridable Property ActiveDocument As Document
Visual C++
public:
virtual property Document^ ActiveDocument {
    Document^ get ();
    void set (Document^ value);
}

Remarks

External API commands can access this property in read-oly mode only! The ability to modify the property is reserved for future implementations.

Exceptions

Exception | Condition
System..::NotSupportedException | Thrown when attempting to modify the property.

See Also

Application Class
Autodesk.Revit Namespace