DisconnectPanel Method

ElectricalSystem..::DisconnectPanel Method

Disconnect the panel for the Electrical System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void DisconnectPanel()
Visual Basic (Declaration)
Public Sub DisconnectPanel
Visual C++
public:
void DisconnectPanel ()

Remarks

If successful, the system will disconnect this panel. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the panel parameter Value is null.
System..::InvalidOperationException | Thrown when the panel cannot be disconnected for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.Elements Namespace