Creates a new geometric arc object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Arc NewArc(
    XYZ end0,
    XYZ end1,
    XYZ pointOnCurve
)
Visual Basic (Declaration)
Public Function NewArc ( _
    end0 As XYZ, _
    end1 As XYZ, _
    pointOnCurve As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc (
    XYZ^ end0,
    XYZ^ end1,
    XYZ^ pointOnCurve
)

Parameters

end0
XYZ
The start point of the arc.
end1
XYZ
The end point of the arc.
pointOnCurve
XYZ
A point on the arc.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace