Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    ElementId parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As ElementId _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    ElementId parameterValue
)

Parameters

builtinParameter
BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
ElementId
The parameter value that is stored as ElementId.

Return Value

Returns a new parameter filter object with given element id.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace