Creates a new geometric arc object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Arc NewArc(
    Plane plane,
    double radius,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewArc ( _
    plane As Plane, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
) As Arc
Visual C++
public:
Arc^ NewArc (
    Plane^ plane,
    double radius,
    double startAngle,
    double endAngle
)

Parameters

plane
Plane
The plane which the arc resides in. The plane's origin is the center of the arc.
radius
Double
startAngle
Double
The start angle of the arc.
endAngle
Double
The end angle of the arc.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace