Indicates whether the specified parameter value is within this curve's bounds and returns end index.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInside(
    double parameter,
    ref int end
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double, _
    ByRef end As Integer _
) As Boolean
Visual C++
public:
bool IsInside (
    double parameter,
    int% end
)

Parameters

parameter
Double
The raw curve parameter to be evaluated.
end
Int32 %
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

True if the parameter is within the curve's bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace