Connector Members
See Also Methods Properties Constructors

Syntax

C#
public class Connector
Visual Basic (Declaration)
Public Class Connector
Visual C++
public ref class Connector

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | ConnectorConnectorNew | For Internal Use Only

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | AllRefs | Return the All the References of the Connector.
Public property | ConnectorType | Return the Connector Type of the Connector.
Public property | Domain | Return the Domain of the Connector.
Public property | Height | Return the Height of the Connector.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Owner | Return the owner of the Connector.
Public property | Radius | Return the Radius of the Connector.
Public property | Shape | Return the Shape of the Connector.
Public property | Width | Return the Width of the Connector.

See Also

Connector
Autodesk.Revit.MEP Namespace