Groups Property

DefinitionFile..::Groups Property

Return a map of shared parameter definition groups contained within the file.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroups Groups{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Groups As DefinitionGroups
Visual C++
public:
property DefinitionGroups^ Groups {
    DefinitionGroups^ get ();
}

Remarks

A particular group can be found by Name, using the Item property on the DefinitionGroups object. A new group can be created by using the Create method on the DefinitionGroups Object. The Create method takes the name of the new group, as a string, as its input parameter, returning a reference to a new definition group object as its result.

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace