Creates a new space and insert to a existent schedule with the phase you assigned.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Space NewSpace(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    phase As Phase _
) As Space
Visual C++
public:
Space^ NewSpace (
    Phase^ phase
)

Parameters

phase
Phase
The phase on which the space is to exist.

Return Value

If successful a space with NO Location should be returned, otherwise Nothing. If your action is in the certain Design Option, the space will in the certain Option.

See Also

Document Class
Autodesk.Revit.Creation Namespace