InternalDefinitions Members
See Also Methods Properties Constructors

Syntax

C#
public class InternalDefinitions
Visual Basic (Declaration)
Public Class InternalDefinitions
Visual C++
public ref class InternalDefinitions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | InternalDefinitionsInternalDefinitionsNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Public method | Create | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Overrides Definitions ..:: Dispose(Boolean).)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from DefinitionsBase.)

Public Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Public property | Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

InternalDefinitions
Autodesk.Revit.Parameters Namespace