Behavior Property

MaterialGeneric..::Behavior Property

Get or set the material behavior type of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public MaterialBehaviourType Behavior{ get; set;}
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace