FilterCriterion Members
See Also Methods Properties Constructors

Syntax

C#
public class FilterCriterion
Visual Basic (Declaration)
Public Class FilterCriterion
Visual C++
public ref class FilterCriterion

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | FilterCriterionFilterCriterionNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Overrides APIObject ..:: ReleaseUnmanagedResources()().)

Public Properties

 | Name | Description
Public property | FilterType | Gets or sets the filter type of this criterion.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | Gets or sets the parameter of this criterion by builtin parameter.
Public property | ParameterID | Gets or sets the parameter of this criterion by parameter id.
Public property | ParameterValue | Gets or sets the parameter value of this criterion.

See Also

FilterCriterion
Autodesk.Revit Namespace