RevolvedFace Properties

Syntax

C#
public class RevolvedFace
Visual Basic (Declaration)
Public Class RevolvedFace
Visual C++
public ref class RevolvedFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)

See Also

RevolvedFace
Autodesk.Revit.Geometry Namespace