Create Method

DefinitionGroups..::Create Method

Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public DefinitionGroup Create(
    string name
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String _
) As DefinitionGroup
Visual C++
public:
DefinitionGroup^ Create (
    String^ name
)

Parameters

name
String
The name of the group to be created.

Return Value

If successful a reference to the new parameter group is returned, otherwise Nothing.

Remarks

If a group with the same name already exists then an exception will be thrown.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace