Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    double parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As Double _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    double parameterValue
)

Parameters

builtinParameter
BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Double
The parameter value that is stored as Double.

Return Value

Returns a new parameter filter object with given Double value.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::NotFiniteNumberException | Thrown when the parameterValue is infinite values, such as double.NegativeInfinite.
System..::ArgumentException | Thrown when the parameterValue is not number, such as double.Nan.

See Also

Filter Class
Autodesk.Revit.Creation Namespace