Retrieve a category object using a built in category id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Category Item[
    BuiltInCategory categoryId
]{ get;}
Visual Basic (Declaration)
Public Overridable ReadOnly Property Item ( _
    categoryId As BuiltInCategory _
) As Category
Visual C++
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}

Parameters

categoryId
BuiltInCategory

See Also

Categories Class
Autodesk.Revit Namespace