CurtainSystemType Property

CurtainSystem..::CurtainSystemType Property

get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CurtainSystemType CurtainSystemType{ get; set;}
Visual Basic (Declaration)
Public Property CurtainSystemType As CurtainSystemType
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter curtainSystemType is null.
System..::InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace