Retrieves a parameter from an element given a parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Parameter Parameter[
    BuiltInParameter parameterId
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
    Parameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.

See Also

Element Class
Autodesk.Revit Namespace