Array one or several elements within the project by a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LinearArray Array(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array (
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementIds
ElementIdSet
A set of ids for elements that are to be arrayed.
number
Int32
The number of the array.
moveToLast
Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Autodesk.Revit Namespace