Creates an object which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData (
    CurveArray^ profile,
    bool structural
)

Parameters

profile
CurveArray
A array of planar lines and arcs that represent the vertical profile of the wall.
structural
Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
Autodesk.Revit.Creation Namespace