ReferenceCurve Property

HostedSweep..::ReferenceCurve Property

Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Curve ReferenceCurve[
    Reference targetRef
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property ReferenceCurve ( _
    targetRef As Reference _
) As Curve
Visual C++
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}

Parameters

targetRef
Reference
Segment's reference whose curve want to be retrieved.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace