Retrieves the specified element from the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Element Element[
    ref ElementId id
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
    ByRef id As ElementId _
) As Element
Visual C++
public:
property Element^ Element[ElementId% id] {
    Element^ get (ElementId% id);
}

Parameters

id
ElementId %
The ElementId of the element to be retrieved from the Document.

Remarks

Returns the element corresponding to the id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the ElementId does not exist then an empty reference will be returned.

See Also

Document Class
Autodesk.Revit Namespace