PlanarFace Properties

Syntax

C#
public class PlanarFace
Visual Basic (Declaration)
Public Class PlanarFace
Visual C++
public ref class PlanarFace

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
Public property | MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Public property | Normal | Normal of the surface.
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Vector | Defining vectors of the surface.

See Also

PlanarFace
Autodesk.Revit.Geometry Namespace