Creates a new Opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    hostElement As Element, _
    profile As CurveArray, _
    bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening (
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)

Parameters

hostElement
Element
host element of the opening, can be a roof,floor and ceiling.
profile
CurveArray
profile of the opening.
bPerpendicularFace
Boolean
whether it is to cut perpendicular to the face or cut vertically.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on the floor, ceiling and roof

See Also

Document Class
Autodesk.Revit.Creation Namespace