Delete several elements from the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function Delete ( _
    elements As ElementSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    ElementSet^ elements
)

Parameters

elements
ElementSet
A set of elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace