Toolbar Members
See Also Methods Properties

Syntax

C#
public class Toolbar
Visual Basic (Declaration)
Public Class Toolbar
Visual C++
public ref class Toolbar

The type exposes the following members.

Public Methods

 | Name | Description
Public method | AddItem | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the toolbar can respond to user interaction.
Public property | Image | Gets or sets the collection of images available to the toolbar button controls.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Gets or sets the name of the toolbar.
Public property | ToolbarItems | Gets the collection of ToolBarItem controls assigned to the toolbar control.
Public property | Visible | Gets or sets a value indicating whether the toolbar is displayed.

See Also

Toolbar
Autodesk.Revit Namespace