DemandFactorData Members
See Also Methods Properties Constructors

Syntax

C#
public class DemandFactorData
Visual Basic (Declaration)
Public Class DemandFactorData
Visual C++
public ref class DemandFactorData

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DemandFactorDataDemandFactorDataNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValid | Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.
Public property | MaxFactor | Get upper limit value of the range, the unit is volt-ampere.
Public property | MinFactor | Get lower limit value of the range, the unit is volt-ampere.
Public property | Percentage | Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

See Also

DemandFactorData
Autodesk.Revit.MEP Namespace