Basis Property

Transform..::Basis Property

Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public XYZ Basis[
    int idx
]{ get; set;}
Visual Basic (Declaration)
Public Property Basis ( _
    idx As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
    void set (int idx, XYZ^ value);
}

Parameters

idx
Int32
The index of the basis vector: 0, 1 or 2.

Remarks

This corresponds to the first three column vectors of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter.
System..::InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace