Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    string parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As String _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    String^ parameterValue
)

Parameters

builtinParameter
BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
String
The parameter value that is stored as String.

Return Value

Returns a new parameter filter object with given string.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::ArgumentNullException | Thrown when the parameterValue is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace