Creates a new instance of a LineLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public LineLoad NewLineLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    XYZ point1,
    XYZ force1,
    XYZ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    point1 As XYZ, _
    force1 As XYZ, _
    moment1 As XYZ, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad (
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    XYZ^ point1,
    XYZ^ force1,
    XYZ^ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
XYZ
The first point of the LineLoad application.
force
XYZ
The applied 3d linear force in the first point.
moment
XYZ
The applied 3d linear moment in the first point.
point1
XYZ
The second point of the LineLoad application.
force1
XYZ
The applied 3d linear force in the second point.
moment1
XYZ
The applied 3d linear moment in the second point.
uniform
Boolean
Set to True if you wish to create the uniform load.
projected
Boolean
Set to True if you wish to create the projected load.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
LineLoadType
plane
SketchPlane

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace