AnalyticalModelLocation Members
See Also Methods Properties Constructors

Syntax

C#
public class AnalyticalModelLocation
Visual Basic (Declaration)
Public Class AnalyticalModelLocation
Visual C++
public ref class AnalyticalModelLocation

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | AnalyticalModelLocationAnalyticalModelLocationNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | Curves | Returns curves that define the Analytical Model of the associated Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Provides access to the location of the Analytical Model, in the case of Structural Foundations.
Public property | SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelLocation
Autodesk.Revit.Structural Namespace