Z Property

XYZ..::Z Property

The third coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Z{ get; set;}
Visual Basic (Declaration)
Public Property Z As Double
Visual C++
public:
property double Z {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::NotFiniteNumberException | Thrown when setting an infinite number to the Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace