Add a new ToolbarItem to the Toolbar.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ToolbarItem AddItem(
    string pAssemblyName,
    string pClassName
)
Visual Basic (Declaration)
Public Function AddItem ( _
    pAssemblyName As String, _
    pClassName As String _
) As ToolbarItem
Visual C++
public:
ToolbarItem^ AddItem (
    String^ pAssemblyName,
    String^ pClassName
)

Parameters

pAssemblyName
String
The execution command corresponding Assembly name.
pClassName
String
The execution command corresponding Class name.

Remarks

This method will add a new API ToolBarItem to the Toolbar.

Exceptions

Exception | Condition
System..::ArgumentException | If 'pAssemblyName' or 'pClassName' is a null object or an empty string.

See Also

Toolbar Class
Autodesk.Revit Namespace