Creates a new room and insert to a exist schedule with the phase you assigned.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Room NewRoom(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom (
    Phase^ phase
)

Parameters

phase
Phase
The phase on which the room is to exist.

Return Value

If successful a room with NO Location should be returned, otherwise Nothing. If your action is in the certain Design Option, the room will in the certain Option.

See Also

Document Class
Autodesk.Revit.Creation Namespace