Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Rebar NewRebar(
    RebarShape rebarShape,
    RebarBarType rebarType,
    Element host,
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    rebarShape As RebarShape, _
    rebarType As RebarBarType, _
    host As Element, _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
) As Rebar
Visual C++
public:
Rebar^ NewRebar (
    RebarShape^ rebarShape,
    RebarBarType^ rebarType,
    Element^ host,
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

rebarShape
RebarShape
The shape type of the Rebar.
rebarType
RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
host
Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
origin
XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVec
XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVec
XYZ
The y-axis in the shape definition will be mapped to this direction in the project.

See Also

Document Class
Autodesk.Revit.Creation Namespace