Add a constraint that determines the length of a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddConstraintToSegment(
    int iSegment,
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    signOfZCoordOfCrossProductOfConstraintDirBySegmentDir As Integer, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintToSegment (
    int iSegment,
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Int32
param
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
signOfZCoordOfCrossProductOfConstraintDirBySegmentDir
Int32
measureToOutsideOfBend0
Boolean
measureToOutsideOfBend1
Boolean

Remarks

The vector defined by (constraintDirCoordX, constraintDirCoordY) must have a positive dot product with the desired direction of the segment. This restriction, combined with the value of signOfZCoordOfCrossProductOfConstraintDirBySegmentDir, defines a quadrant of the plane that limits the variable-angle segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace