Open document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile (
    String^ fileName
)

Parameters

fileName
String
The file to be opened.

Remarks

It is correspond to the File->Open....

Exceptions

Exception | Condition
System..::ArgumentException | if 'fileName' is a null object or a empty string.
System..::InvalidOperationException | if can not open a file.

See Also

Application Class
Autodesk.Revit Namespace