Print this view with default print setting and default view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void Print(
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print (
    bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings
Boolean
If true, print the view with the current print setting ,otherwise with the print setting of the document.

Remarks

If the view can not be printed successfully then an exception will be thrown out.

See Also

View Class
Autodesk.Revit.Elements Namespace