Gutter Methods

Syntax

C#
public class Gutter
Visual Basic (Declaration)
Public Class Gutter
Visual C++
public ref class Gutter

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | AddSegment | Add segments to the gutter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from HostObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from Element.)

See Also

Gutter
Autodesk.Revit.Elements Namespace