InstanceUsage Enumeration

An enumerate type listing all the possible structural usage cases for a FamilyInstance object.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
[GuidAttribute("805FF4E8-D84B-4940-A575-AC818EDB3BF3")]
public enum InstanceUsage
Visual Basic (Declaration)
<GuidAttribute("805FF4E8-D84B-4940-A575-AC818EDB3BF3")> _
Public Enumeration InstanceUsage
Visual C++
[GuidAttribute(L"805FF4E8-D84B-4940-A575-AC818EDB3BF3")]
public enum class InstanceUsage

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
TrussWeb | The instance should be considered to be truss web for the purpose of structural analysis.
TrussChord | The instance should be considered to be truss chord for the purpose of structural analysis.
Automatic | The instance should be considered to be automatic for the purpose of structural analysis.
KickerBracing | The instance should be considered to be kicker bracing for the purpose of structural analysis.
HorizontalBracing | The instance should be considered to be horizontal bracing for the purpose of structural analysis.
Brace | The instance should be considered to be a brace for the purpose of structural analysis.
Other | The instance should be considered for the structural analysis but its purpose is not clearly defined.
Purlin | The instance should be considered to be a purlin for the purpose of structural analysis.
Joist | The instance should be considered to be a joist for the purpose of structural analysis.
Girder | The instance should be considered to be a girder for the purpose of structural analysis.
Column | The instance should be considered to be a column for the purpose of structural analysis.
Wall | The instance should be considered to be a wall for the purpose of structural analysis.
Undefined | The instance has no predefined usage.

See Also

Autodesk.Revit.Structural.Enums Namespace