Generate a new linear dimension object within the project using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewDimension (
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
View
The view in which the dimension is to be visible.
line
Line
The line drawn for the dimension.
references
ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

If successful a new dimension object, otherwise Nothing.

Remarks

The currently user set default style is used for the created dimension.

See Also

Document Class
Autodesk.Revit.Creation Namespace