Creates a new geometric arc object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Arc NewArc(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Visual Basic (Declaration)
Public Function NewArc ( _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    xAxis As XYZ, _
    yAxis As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc (
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)

Parameters

center
XYZ
The center of the arc.
radius
Double
The radius of the arc.
startAngle
Double
The start angle of the arc.
endAngle
Double
The end angle of the arc.
xAxis
XYZ
The x axis to define the arc plane. Must be normalized.
yAxis
XYZ
The y axis to define the arc plane. Must be normalized.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace