Delete an element from the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementIdSet Delete(
    Element element
)
Visual Basic (Declaration)
Public Function Delete ( _
    element As Element _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete (
    Element^ element
)

Parameters

element
Element
The element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

See Also

Document Class
Autodesk.Revit Namespace