GetAllBeams Method

BeamSystem..::GetAllBeams Method

Get all the beams of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ElementSet GetAllBeams()
Visual Basic (Declaration)
Public Function GetAllBeams As ElementSet
Visual C++
public:
ElementSet^ GetAllBeams ()

Return Value

The beams.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace