ShearModulusX Property

MaterialSteel..::ShearModulusX Property

Get or set the x component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double ShearModulusX{ get; set;}
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace