Creates a new instance of a AreaLoad element with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public AreaLoad NewAreaLoad(
    XYZArray points,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    points As XYZArray, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad (
    XYZArray^ points,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

points
XYZArray
Vertexes of AreaLoad shape polygon.
force
XYZ
The applied 3d area force.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
AreaLoadType

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace