IsCyclic Property

Face..::IsCyclic Property

The boolean value that indicates whether this face is periodic in the specified parametric direction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsCyclic[
    int paramIdx
]{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic ( _
    paramIdx As Integer _
) As Boolean
Visual C++
public:
property bool IsCyclic[int paramIdx] {
    bool get (int paramIdx);
}

Parameters

paramIdx
Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

True if this face is cyclic; otherwise, false.

Exceptions

Exception | Condition
System..::IndexOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.

See Also

Face Class
Autodesk.Revit.Geometry Namespace