Creates a new instance of a PointLoad element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public PointLoad NewPointLoad(
    Reference reference,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    reference As Reference, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad (
    Reference^ reference,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Reference
The Geometry reference to Beam's, Brace's, Column's, analytical line's end.
force
XYZ
The 3d force.
moment
XYZ
The 3d moment.
isReaction
Boolean
Set to True if you wish to create the reaction.
symbol
PointLoadType
plane
SketchPlane

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
Autodesk.Revit.Creation Namespace