CompoundStructure Property

HostObjAttributes..::CompoundStructure Property

Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CompoundStructure CompoundStructure{ get;}
Visual Basic (Declaration)
Public ReadOnly Property CompoundStructure As CompoundStructure
Visual C++
public:
property CompoundStructure^ CompoundStructure {
    CompoundStructure^ get ();
}

Remarks

From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return Nothing.

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace