Creates a new TypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter (
    Type^ givenType
)

Parameters

givenType
Type
Filter elements by the given type.

Return Value

Returns a new type filter object within given type.

Remarks

It will not find out the elements which is given type's derived classes.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace