NewInstanceUsageFilter Method

Filter..::NewInstanceUsageFilter Method

Creates an InstanceUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public InstanceUsageFilter NewInstanceUsageFilter(
    InstanceUsage instanceUsage
)
Visual Basic (Declaration)
Public Function NewInstanceUsageFilter ( _
    instanceUsage As InstanceUsage _
) As InstanceUsageFilter
Visual C++
public:
InstanceUsageFilter^ NewInstanceUsageFilter (
    InstanceUsage instanceUsage
)

Parameters

instanceUsage
InstanceUsage
Filter elements by the instance usage.

Return Value

Returns a new instance usage filter object with given instance usage.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace