Ends a transaction for specified document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool EndTransaction(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function EndTransaction ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool EndTransaction (
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
PostedErrorArray
Would contain list of failures posted during the process.

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Autodesk.Revit Namespace