Indicates whether the specified point is within this face and returns additional results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsInside(
    UV point,
    ref IntersectionResult result
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV, _
    ByRef result As IntersectionResult _
) As Boolean
Visual C++
public:
bool IsInside (
    UV^ point,
    IntersectionResult^% result
)

Parameters

point
UV
The parameters to be evaluated, in natural parametrization of the face.
result
IntersectionResult %
Provides more information when the point is on the edge; otherwise, nullptr.

Return Value

Returns true is within this face, otherwise false.

Remarks

The following is the meaning of the IntersectionResult members when the point is on the edge: EdgeObject is the edge that the point lies on; EdgeParameter is the parameter of the point on the edge nearest to the UV point; UV is the specified point.

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
Autodesk.Revit.Geometry Namespace