Generate a new linear dimension object within the project using the specified dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewDimension (
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
View
The view in which the dimension is to be visible.
line
Line
The line drawn for the dimension.
references
ReferenceArray
An array of geometric references to which the dimension is to be bound.
dimensionType
DimensionType
The dimension style to be used for the dimension.

Return Value

If successful a new dimension object, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace