VolumeCalculationOptions Members
See Also Methods Constructors Fields Properties

Syntax

C#
public class VolumeCalculationOptions
Visual Basic (Declaration)
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | VolumeCalculationOptionsVolumeCalculationOptionsNew | Creates a new instance of the volume calculation options.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
Public field | VolumeComputationEnbale | Deprecated; this field will be removed in future release of the Revit API. Use VolumeComputationEnable instead.

Public Properties

 | Name | Description
Public property | VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions
Autodesk.Revit Namespace