Creates a new grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Grid NewGrid(
    Line line
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    line As Line _
) As Grid
Visual C++
public:
Grid^ NewGrid (
    Line^ line
)

Parameters

line
Line
A line object which represents the location of the grid line.

Return Value

The newly created grid line.

Remarks

The line should be on a horizontal plane.

See Also

Document Class
Autodesk.Revit.Creation Namespace