Create a new user visible parameter definition using name and type. Can not be used to create list parameters

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public Definition Create(
    string name,
    ParameterType type,
    bool visible
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType, _
    visible As Boolean _
) As Definition
Visual C++
public:
Definition^ Create (
    String^ name,
    ParameterType type,
    bool visible
)

Parameters

name
String
The name of the parameter definition to be created.
type
ParameterType
The name of the parameter type for the new definition.
visible
Boolean

Return Value

If successful a reference to the new parameter definition is returned, otherwise Nothing.

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace