Creates a slab edge along the reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    reference As Reference _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge (
    SlabEdgeType^ SlabEdgeType,
    Reference^ reference
)

Parameters

SlabEdgeType
SlabEdgeType
The type of the slab edge to create
reference
Reference
A planar line or arc that represent the place where you want to place slab edge.

Return Value

If successful a new slab edge object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace