Creates a parameter filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    int parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As Integer _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter (
    String^ paramDefName,
    CriteriaFilterType filterType,
    int parameterValue
)

Parameters

paramDefName
String
The user visible name of the parameter to be retrieved.
filterType
CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Int32
The parameter value that is stored as Integer.

Return Value

Returns a new parameter filter object with given Integer value.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::ArgumentNullException | Thrown when the paramDefName is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace