ToolbarItem Members
See Also Methods Properties

Syntax

C#
public class ToolbarItem
Visual Basic (Declaration)
Public Class ToolbarItem
Visual C++
public ref class ToolbarItem

The type exposes the following members.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | AssemblyName | Gets or sets the assembly path.
Public property | Checked | Gets or sets a value indicating whether a toggle-style toolbar button is currently in the checked state.
Public property | ClassName | Gets or sets the class name.
Public property | Enabled | Gets or sets a value indicating whether the button is enabled.
Public property | ImageIndex | Gets or sets the index value of the image assigned to the button.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | ItemText | Gets or sets the text displayed on the toolbar button.
Public property | ItemType | Gets or sets the item type.
Public property | StatusbarTip | Gets or sets the text that appears on the Status bar for the button.
Public property | ToolTip | Gets or sets the text that appears as a ToolTip for the button.

See Also

ToolbarItem
Autodesk.Revit Namespace