Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public void AddListeningDimensionSegmentToSegment(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToSegment ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToSegment (
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)

Parameters

param
Parameter
constraintDirCoordX
Double
constraintDirCoordY
Double
iSegment0
Int32
iSegment1
Int32

Remarks

RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace