Creates a new category filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public CategoryFilter NewCategoryFilter(
    Category category
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    category As Category _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter (
    Category^ category
)

Parameters

category
Category
Filter elements by the category.

Return Value

Returns a new category filter object with given category.

Exceptions

Exception | Condition
System..::ArgumentNullException | Thrown when the specified parameter is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace