CompoundStructureLayer Members
See Also Methods Properties Constructors

Syntax

C#
public class CompoundStructureLayer
Visual Basic (Declaration)
Public Class CompoundStructureLayer
Visual C++
public ref class CompoundStructureLayer

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | CompoundStructureLayerCompoundStructureLayerNew | For Internal Use Only.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Dispose | (Inherited from APIObject.)
Protected method | Finalize | (Inherited from APIObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | (Inherited from APIObject.)
Protected method | ReleaseUnmanagedResources | (Inherited from APIObject.)

Public Properties

 | Name | Description
Public property | DeckProfile | Returns or set the family symbol of the deck profile of the layer within the structure.
Public property | DeckUsage | Returns usage of the deck layer within the structure.
Public property | Function | Returns the purpose/function of the layer within the structure.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Material | Get or set the material from which the layer is made.
Public property | Thickness | Retrieve or modify the thickness of the layer.
Public property | Variable | Returns or set whether the layer thickness is vrariable.

See Also

CompoundStructureLayer
Autodesk.Revit.Structural Namespace