IsTranslation Property

Transform..::IsTranslation Property

The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public bool IsTranslation{ get;}
Visual Basic (Declaration)
Public ReadOnly Property IsTranslation As Boolean
Visual C++
public:
property bool IsTranslation {
    bool get ();
}

Remarks

This property is true if the only effect of transformation is translation. It checks that the basis of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).

See Also

Transform Class
Autodesk.Revit.Geometry Namespace