Period Property

Curve..::Period Property

The period of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll)

Syntax

C#
public double Period{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Period As Double
Visual C++
public:
property double Period {
    double get ();
}

Exceptions

Exception | Condition
System..::InvalidOperationException | Thrown when the curve is not cyclic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace