DWGImportOptions Members
See Also Fields Methods Constructors

Syntax

C#
public class DWGImportOptions
Visual Basic (Declaration)
Public Class DWGImportOptions
Visual C++
public ref class DWGImportOptions

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | DWGImportOptionsDWGImportOptionsNew | Default constructor. Sets all options to their default values.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Fields

 | Name | Description
Public field | ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
Public field | CustomScale | Scaling the import. (Inherited from CADImportOptions.)
Public field | LayerSelection | The layers collection for import. (Inherited from ACADImportOptions.)
Public field | LineWeights | A Byte array of line weights for the DWG/DXF Color number. (Inherited from ACADImportOptions.)
Public field | OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Public field | Placement | Where to place the import. (Inherited from CADImportOptions.)
Public field | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public field | ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Public field | Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
Public field | View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
Public field | VisibleLayersOnly | Only import the visible layers. (Inherited from ACADImportOptions.)

See Also

DWGImportOptions
Autodesk.Revit Namespace